DASHBOARD RELEASE NOTES

Welcome to the DashBoard v9.4.1. Release Notes. Please read this document to find important information on areas of DashBoard that may not be covered in the Getting Started Guide or the User Help system.

CONTENTS

<table>
<thead>
<tr>
<th>SECTION</th>
<th>PAGE</th>
</tr>
</thead>
<tbody>
<tr>
<td>DASHBOARD RELEASE NOTES</td>
<td>1</td>
</tr>
<tr>
<td>UPGRADE CONSIDERATIONS</td>
<td>2</td>
</tr>
<tr>
<td>VERSION HISTORY</td>
<td></td>
</tr>
<tr>
<td>VERSION 9.4.1 – MAY 2022</td>
<td>3</td>
</tr>
<tr>
<td>VERSION 9.4.0 – APRIL 2022</td>
<td>3</td>
</tr>
<tr>
<td>VERSION 9.2.2 – DECEMBER 2021</td>
<td>7</td>
</tr>
<tr>
<td>VERSION 9.2.1 – APRIL 2021</td>
<td>9</td>
</tr>
<tr>
<td>VERSION 9.2.0 – NOVEMBER 2020</td>
<td>10</td>
</tr>
<tr>
<td>VERSION 9.1.4 – OCTOBER 2020</td>
<td>13</td>
</tr>
<tr>
<td>VERSION 9.1.3 – SEPTEMBER 2020</td>
<td>13</td>
</tr>
<tr>
<td>VERSION 9.1.2 – AUGUST 2020</td>
<td>14</td>
</tr>
<tr>
<td>VERSION 9.1.1 – JULY 2020</td>
<td>15</td>
</tr>
<tr>
<td>VERSION 9.0.2 – MAY 2020</td>
<td>20</td>
</tr>
<tr>
<td>VERSION 9.0.0 – APRIL 2020</td>
<td>21</td>
</tr>
<tr>
<td>VERSION 8.8.0 – DECEMBER 2019</td>
<td>25</td>
</tr>
<tr>
<td>VERSION 8.7.1 – OCTOBER 2019</td>
<td>26</td>
</tr>
<tr>
<td>VERSION 8.6.0 – MAY 2018</td>
<td>32</td>
</tr>
<tr>
<td>KNOWN ISSUES</td>
<td>38</td>
</tr>
<tr>
<td>GETTING HELP</td>
<td>41</td>
</tr>
</tbody>
</table>
UPGRADE CONSIDERATIONS

The latest DashBoard upgrade considerations and important notices are listed below.

ROLE-BASED ACCESS CONTROL REQUIREMENTS

- If you are using an RPM Server that is secured with HTTPS, future DashBoard upgrades will require manually adding the RPM Server certificate to DashBoard after the installation process is complete. The upgrade procedure can be found in the DashBoard Role-Based Access Control Guide (85100DR-09A-xxx).

- Note:
  For other considerations see the DashBoard User Guide > System Requirements section.
VERSION HISTORY

VERSION 9.4.1 – MAY 2022

BUGS ADDRESSED

- Fixed an issue impacting DashBoard customers with multiple XPression devices, where the XPression plugin was removed from the device tree when DashBoard closed. (DASH-4188)

VERSION 9.4.0 – APRIL 2022

WHAT’S NEW

- ROLE-BASED ACCESS CONTROL (RBAC)

DashBoard now provides Role-Based Access Control (RBAC) via the Ross Platform Manager (RPM) Server. RPM can sync with existing LDAP directory infrastructures, or an administrator can configure users and roles from scratch using the DashBoard interface or RPM web-browser interface. With RPM it’s easy to enforce different levels of user permissions — read, write, and/or upgrade — for various DashBoard Connect/openGear devices or panels present in DashBoard.

1) ADD RPM SERVER
2) CONFIGURE USER RIGHTS
3) CONFIGURE DEVICE PERMISSIONS

Once added, the RPM Server appears in the DashBoard Tree View. Expand it and use the Access Control node to open the Configure User Rights dialog.

The Configure User Rights dialog can be used to configure user and role permissions.

Once a role is selected, you can control access to DashBoard devices from the Permissions tab.

REQUIREMENTS:
Requires the Ross Platform Manager (v1.6+) — which includes an RPM Server — and licenses for Role-Based Access Control and LDAP Authentication (if required). Please reach out to your Ross sales representative for more details.

LIMITATIONS FOR ULTRITOUCH DEVICES:
Currently, it is recommended that you assign both read and write access permissions to roles that perform administrative actions on the Utritouch Management panel. For more details, see the Known Issues for Role-Based Access Control (RBAC).
For more details, see the new DashBoard Role-Based Access Control Guide. It is available on the Ross Video website under the DashBoard product page’s Downloads. TIP: You can also access the latest DashBoard guides in DashBoard, from the top menu (under Help > Help Contents).

Notice: The deprecated User Rights Management (URM) Guide has been removed.

OGP SUBSCRIPTIONS SUPPORT (FOR OGP JSON DEVICES)
The new openGear (OGP) Subscriptions protocol is available for OGP JSON devices that have implemented Minimal Mode. This feature will help to optimize memory usage and communication, increase panel efficiency, and load device panels faster. Once implemented, device panels will only receive updates from the previously defined minimal set or the new subscriptions list of device parameter OIDs.

```
<context contexttype="opengear" objectid="MyDevice" subscriptions="true">
   <meta>
      <subscription oids="oid1, oid2, oid3**"/>
   </meta>
</context>
```

CUSTOMPANEL OGLML DOCUMENT SYNTAX

NEW SUBSCRIPTIONS "AUTO-SUBSCRIBE" CHECKBOXES
The DashBoard PanelBuilder editor provides convenient auto-subscribe checkboxes to simplify the process of adding device parameters to the panel’s subscriptions list.

Note: When the parameters are from a device that does not support subscriptions, the checkboxes will be grayed out.

Auto-Subscribe option in ogScript Editor

Auto-subscribe option in PanelBuilder
Available when a component is dragged-and-dropped from a DashBoard Connect/OGP device.

Subscribe|Unsubscribe option in Script Palette
General information on how to work with OGP devices that support subscriptions can be found in the DashBoard User Guide and CustomPanel Development Guide. It is available on the Ross Video website (under Downloads).

TIP: You can also access the latest DashBoard guides in DashBoard, from the top menu (under Help > Help Contents). Use the search to jump to the “Minimal Mode” or “Subscriptions” content.

OGP partners can find Minimal Mode & Subscriptions Application Notes and the DashBoard openGear Software Development Guide on the openGear Partner Portal.

NOTE: This guide contains the protocol information and is only available to openGear partners who have signed the Ross Video Non-Disclosure Agreement (NDA).

- **SUPPORT FOR NDI® 5**

  NDI users can take advantage of the latest NDI innovations.

  **IMPORTANT**: DashBoard 9.4 and later support NDI® 5, but not all video codecs are supported for NDI®|HX. Windows and Linux do not support the HEVC codec.

- **SUPPORT FOR HITATCHI CAMERA MODEL SK-UHD7000**

  This model has been added to the list of supported cameras.

- **PTZ CAMERA ENHANCEMENTS**

  **Furio Gateway for PTZ Camera Controllers**

  The Furio gateway that allows controllers using the Furio API, such as SmartShell, to control PTZ Cameras through DashBoard has a few new features:

  - The value of ZoomVar reported in SmartShell for the pan and tilt axes now reflects whether the variable zoom setting on the PTZ Camera is ON (zoomVar reported as 100) or OFF (zoomVar reported as 0). For cameras that don’t support Variable Zoom and for other axes, the value will be reported as 50. This value is read only and cannot be set from SmartShell or other Furio controllers.

  - The Furio Gateway now reports when the camera has moved away from a recalled preset through direct control of the pan, tilt, zoom or focus axes. This can be seen in SmartShell as a change in the border color of the last recalled preset from dark blue to light blue. This feature works only when the camera was moved by a control sent through the DashBoard PTZ Camera Controller, either directly or via a gateway.
BUGS ADDRESSED

- DASHBOARD
  - Fixed a Big Sur OSX compatibility issue where DashBoard did not always open. (DASH-3530)
  - Fixed an issue where the DashBoard Memory Manager indicator did not display the correct status after the DashBoard region and language settings were changed. (DASH-3891)
  - Fixed an Ultritouch issue with network DNS setting and retrieval. (DASH-1658)
  - Fixed an issue where the file size limitation of 16MB was not sufficient to upload larger files to openGear cards. The file size now supports file uploads up to 32MB. (DASH-3908)

- CAMERAS
  - Fixed an issue where when using Carbonite to control the iris on a PTZ-12G, PTZ-NDI, or Lumens camera through the VISCA gateway of the DashBoard PTZ Camera plugin, the iris close function appeared at the wrong end of the scale. Iris control from Carbonite now works normally. (CI-637)
WHAT'S NEW

- CONTROL OF ROSS PTZ-12G & PTZ-NDI CAMERAS

The PTZ Camera Controller in DashBoard now supports the new Ross PTZ-12G and PTZ-NDI cameras. To add a PTZ camera to DashBoard, navigate to File > New > Other > Cameras and select PTZ Cameras. Select the camera from the list of available models.

The PTZ-12G and PTZ-NDI Camera Controllers within DashBoard allow you to:

- **Store, recall and manage presets** — This feature provides access to the 256 stored presets available on the camera itself, as well as presets stored locally on the DashBoard computer.
- **Directly control pan, tilt, zoom, focus and iris** — Use the DashBoard UI or an external USB HID joystick connected to the DashBoard computer to control these settings. You can also set the digital zoom limit for the camera and store and recall it with presets stored locally in DashBoard.
- **Perform basic paint control** — Use the DashBoard UI or an external USB HID joystick connected to the DashBoard computer to perform basic paint control.
- **View and configure selected camera settings** — You can view these settings and access the camera’s on-screen configuration menu.
- **Use the VISCA gateway to control your PTZ camera from a VISCA over TCP controller (such as Carbonite)** — You can use the gateway to directly control pan, tilt, zoom and focus as well as to store and recall presets both locally on the DashBoard machine and from on-camera storage.
- **Use the Furio gateway to control your PTZ camera from a controller using the Furio API (such as SmartShell)** — You can use the gateway to directly control the pan, tilt, zoom and focus on the camera as well as to store, recall and manage presets and banks.
- **Use the DashBoard tally service to monitor and display the camera tally state** — In addition to tally services, you can also set the tally light on the camera itself.

For more details, see the User Manual for PTZ Camera Control Plugin (8351DR-015-9.2.2).
• **VISCA GATEWAY FOR PT HEAD CONTROL PLUGIN**

The Ross PT Head Controller in DashBoard now includes a VISCA gateway feature. To configure and enable the gateway, select the **Config** option within the DashBoard control panel for the PT Head and look for the new **Gateway** button.

The VISCA gateway provides basic control of a Ross PT Head from a VISCA over TCP controller (such as a Carbonite). The VISCA gateway allows you to:

- **Directly control pan, tilt, zoom, and focus** — Control these settings directly from the PT Head of the controller.
- **Store and recall presets using the external ID of the preset as the reference** — Configuration settings in the gateway allow you to determine whether recalling presets through the gateway should trigger a cut or a run and to set the categories on the PT Head to use when storing and recalling presets.

For more details, see the USER MANUAL FOR PT HEAD CONTROL PLUGIN (8351DR-019-9.2.2).

• **CONTROL OF LUMENS VC-A71P & VC-A71PN CAMERAS**

The PTZ Camera Controller in DashBoard now supports Lumens PTZ Cameras with model numbers VC-A71P and VC-A71PN. This controller offers many of the same features as the PTZ-12G & PTZ-NDI controllers, apart from a few camera settings which are not supported through VISCA by the Lumens camera. It does not include a digital zoom limit, and the variable zoom feature (to determine whether the pan & tilt velocity should vary as the zoom changes).

**LICENSING REQUIREMENTS**

A PTZ Camera license is required to use DashBoard to control these cameras.

**BUGS ADDRESSED**

• **PT HEAD CONTROLLER**

- Fixed an issue where using DashBoard camera control alongside another camera controller such as Vision[Ai]ry Ft to control a PT Head would occasionally cause DashBoard to fail to gain joystick control when the **Enable Joystick** button was pressed. (CI-492)
VERSION 9.2.1 – APRIL 2021

BUGS ADDRESSED

- DASHBOARD
  - Fixed an issue where devices with numeric OIDs occasionally caused AutoWire to break. (DASH-3735)
  - Fixed an issue where fetching widgets occasionally caused DashBoard to become unresponsive for a minute or longer. (DASH-3771)
  - Fixed an issue where the Data Sources table rows did not each point to the correct device context. (DASH-3721)
  - Fixed an issue with toggle buttons, with a mask attribute applied, where the mask included a partial white border outline. (DASH-3327)
  - Fixed an issue where modifying parameter values while building OGLML occasionally caused DashBoard to become unresponsive. (DASH-3784)
  - Fixed a performance issue where Graphite Audio Mixers in DashBoard were impacted by memory leaks. (DASH-3751)

- ACIDCAM AND HITACHI CAMERA CONTROLLER
  - Fixed a tally issue where the green tally light was not working as expected. (CI-371)
WHAT'S NEW

• CONTROL OF PANASONIC AW-UE150 CAMERAS

The PTZ Camera Controller in DashBoard has been extended to add support for Panasonic AW-UE150 cameras. To add an AW-UE150 to DashBoard, navigate to File > New > Other > Cameras, and select PTZ Cameras. You can then select the Panasonic AW-UE150 from the list of available models.

The Panasonic AW-UE150 Camera Controller within DashBoard allows you to:

• Store, recall and manage presets. Presets can be stored locally on the machine running DashBoard, or using the on-camera storage.
• Directly control pan, tilt, zoom, focus and iris using the DashBoard UI or an external USB HID joystick connected to the DashBoard computer.
• Perform basic paint control using the DashBoard UI or an external USB HID joystick connected to the DashBoard computer.
• View and configure selected camera settings and access the camera’s on-screen configuration menu.
• Use the VISCA gateway to control your AW-UE150 from a VISCA over TCP controller such as Carbonite. You can use the gateway to directly control the camera and to store and recall presets both locally in DashBoard and on the camera.
• Use the Furio gateway to control your AW-UE150 from SmartShell or another controller using the Furio API. You can use the gateway to directly control the camera and to store, recall and manage presets and categories.

NOTE

• To control the Panasonic AW-UE150 from DashBoard, you must purchase a license for the PTZ Camera Control feature. Please contact Ross Technical Support for assistance.
INTEGRATION OF DASHBOARD TALLY SERVICE WITH PTZ CAMERA CONTROL

The PTZ Camera controller can now be integrated with the DashBoard tally service to:

- Monitor and display camera tally state – both on-air and preview.
- Broadcast tally status to SmartShell using the Furio gateway so that SmartShell can correctly display on-air status for PTZ Cameras controlled through DashBoard.
- Optionally set the tally light on the camera itself.
- This functionality is available for all supported PTZ Camera types – PIVOTCam-SE, Sony BRC-X1000, Sony BRC-H900 and Panasonic AW-UE150.

NOTE

- The DashBoard tally service does not currently work with the TSL5.0 protocol. To use the new PTZ Camera Tally Integration feature, you must use TSL3.1. (DASH-3103)

SUPPORT FOR SONY BRC-X1000 TELE CONVERT AND CLEAR IMAGE ZOOM FEATURES

The PTZ page for the Sony BRC-X1000 camera control now provides buttons to enable and disable the Tele Convert and Clear Image Zoom features of the camera.

PTZ CAMERA CONTROL LICENSE

The Sony BRC Camera Control feature license has now been extended to include the new Panasonic AW-UE150 camera controller and rebranded as the PTZ Camera Control license. If you have already purchased this license, you will be able to access the new Panasonic AW-UE150 camera controller with no additional licensing required. Please contact Ross Technical Support for assistance.

For more information about using DashBoard to add and control PTZ cameras, please see the User Manual for PTZ Control Plugin (8351DR-015-9.2). To download a PDF copy, go to https://www.rossvideo.com/support/product-documentation/ross-robotics/.
UPGRADE CONSIDERATIONS

• LAUNCHING DASHBOARD ON MACOS BIG SUR
  o Upgrading to macOS Big Sur, version 11.0.1 or later, is not recommended if you are running DashBoard version 9.2 or earlier. Using macOS Big Sur may cause issues when launching the DashBoard application. You can use one of the workaround methods listed below:

To Launch DashBoard using Finder
  • Navigate to the DashBoard installation directory. Click the Finder icon in the Dock and under Applications click DashBoard.app and select Show Package Contents. Then you can navigate to the Contents > MacOS > and run PermissionDashBoard.

To Launch DashBoard using Terminal
  • Enter this CLI command in Terminal. Note: this directory path assumes that you have installed DashBoard in the default installation directory.

open /Applications/DashBoard/DashBoard.app/Contents/MacOS/PermissionDashBoard

BUGS ADDRESSED

• The camera controller for ACID and Hitachi cameras was not setting the green tally light on the camera when the DashBoard UI was displaying it as being on. This has now been resolved and green tally light should be correctly displayed on the camera. (CI-371)

• If the DashBoard PTZ Camera Controller was connecting to a camera that was mostly unresponsive, the UI would continue to show a progress bar displaying message “Reading camera settings” that would remain stuck at 99%. Behavior has now been changed so that the progress bar will now show “Waiting for camera to power on”. After 2 minutes, the progress bar will disappear and an error flag will be set so that the status of the camera is shown as “Bad – all messages to camera resulting in errors”, as shown below. If you see this error, please check the operation of your camera. For PIVOTCam-SE cameras, this can sometimes occur if the VISCA options in the On-Screen Display are incorrectly configured. (CI-278)

• When using SmartShell to control a PTZ Camera through the DashBoard Furio Gateway, the displayed focus position was not being updated when the camera focus was adjusted using either SmartShell or the DashBoard UI. This was caused by the PTZ Camera Controller failing
to request the new focus position after the focus axis had stopped moving and has now been resolved (CI-433).

- When using SmartShell to control a PTZ Camera through the DashBoard Furio Gateway, requesting a ZOOMVAR value of 0 for any axis would trigger a SmartShell error "BADDYNAMICRATIOARG". This has now been corrected so that a value of 0 will be accepted. Note that the SmartShell ZOOMVAR function is not supported by the Furio gateway and so will have no effect on axis sensitivity. To change pan and tilt axis sensitivity as the zoom value changes, use the “Variable Zoom” option in the DashBoard camera panel (CI-434).

VERSION 9.1.4 – OCTOBER 2020

BUGS ADDRESSED

- DASHBOARD
  - Fixed several Linux and Mac OS issues where dragging and dropping actions in DashBoard’s embedded web browsers and device interface pages occasionally caused DashBoard to become unresponsive.
    (DASH-3490 | DASH-3491 | DASH-3492 | DASH-3502)

VERSION 9.1.3 – SEPTEMBER 2020

BUGS ADDRESSED

- DASHBOARD
  - Fixed a Linux issue where device interface pages created from HTML outputs did not always display navigation correctly.

NOTE ON SUPPORTED LINUX OPERATING SYSTEMS

The following Linux operating systems are supported for DashBoard Version 9.1.3:

- CentOS Version 7 (64 bit)
- Ubuntu 16.04.6 LTS (64 bit)
- Fedora Version 23 (32 bit)
BUGS ADDRESSED

• DASHBOARD
  o Fixed an issue where integer parameters using the Date Picker widget display type view were not displaying the correct parameter value updates. (DASH-3366 | DASH-3367)
  o Fixed an issue where OGP-JSON devices and devices shared via the Proxy Server could not use OGLML in device menus in cases where OGLML was served via external objects. (DASH-3409)
  o Fixed a Mac OS issue with the Visual Logic Editor, where attempting to add Visual Logic blocks from a device was causing a null pointer exception that prevented blocks from appearing. (DASH-3415)
  o Fixed an issue with UDP messages, where DashBoard prevented certain UDP messages from being sent. (DASH-3416)
  o Fixed an issue that prevented custom slot names from appearing when OGP frames were shared via the proxy server. (DASH-3417)
  o Fixed an issue where the Add Task option would not appear consistently when panel builders right-clicked on parameters in PanelBuilder Edit Mode. (DASH-3384).
  o Fixed an issue where the custom color defined in the <color> tag did not appear in the DashBoard Component Editor’s color palette. (DASH-3407)

• CAMERA MOTION SYSTEMS
  o Fixed an issue where activating the paint integration feature on the PT Head plugin was preventing custom panels from opening successfully. (CI-339)
WHAT'S NEW

• **WINDOWS 64-BIT VERSION OF DASHBOARD AVAILABLE**
  In addition to our Linux 64-bit and Mac OS 64-bit versions, DashBoard is now available in a Windows 64-bit version that provides a faster, and more scalable experience for users. In addition to performance improvements, this version supports devices with requirements for 64-bit only software.

  If the Windows, Mac or Linux device you are running DashBoard on features a 64-bit processor and at least 4GB of RAM, you also have the option to increase memory allocation to DashBoard using the new feature described below.

• **ABILITY TO INCREASE MEMORY ALLOCATION FOR THE 64-BIT VERSION OF DASHBOARD**
  If you are running the 64-bit version of DashBoard, you can choose the amount of memory to allocate to DashBoard. The options range from the default value, which is a minimum of 1GB, to a maximum value of half of your system's available RAM.

  Navigate to Preferences > General to set the amount of memory. You can drag the slider to set the amount of memory available to DashBoard. The amount can only be allocated in increments of 1GB. You must restart DashBoard for the changes to take effect.

• **QUICK METHOD TO ADD TABS**
  You can now quickly add additional tabs without opening the Component Editor. In PanelBuilder Edit Mode, right-click on the blank space beside an existing tab to add another tab.

• **QUICK METHOD TO ADD TASKS TO BUTTONS, LABELS, PARAMS**
  You can now quickly add tasks to buttons, labels or parameters without opening the Component Editor. In PanelBuilder Edit Mode, right-click on a button to add a task to the selected button.
• **XPRESSION COUNTDOWN TIMER WIDGET**
  The XPression Countdown widget allows you to monitor a specific framebuffer and layer of XPression to determine what take item is currently on that layer, and the amount of time left for that take item. You can access this custom widget from the **Widget** button on PanelBuilder Edit Mode toolbar.

**REQUIREMENTS**

XPression Version 10.0 or later is required.

• **AURA THEME ENHANCEMENTS**
  The Aura theme includes usability enhancements for a consistent and smooth UI experience. Includes updates to scroll bars, touch wheel and slider views, label borders, border styles, masks, device/tree view icons, file pickers, background colors, and Ultritouch color constants.

**NOTE ON AURA FIXES**

- XPression license messages now display the correct value. (DASH-2177)
- PanelBuilder Edit Mode exception errors that appeared when you switch modes have been resolved. (DASH-3118)

**CONTROL OF ROSS PAN & TILT HEADS**

There are a number of updates to the Ross Pan & Tilt Head controller first introduced in v9.0:

**External ID Management**

The Ross PT Head controller allows you to assign a numerical ID to each preset, which can be useful for automation or when creating custom panels. Version 9.1 adds several enhancements to the basic external ID functionality:

- **External ID Uniqueness:**
  DashBoard will now ensure that all external IDs assigned to presets through DashBoard are unique, enforced either by category or by device, as chosen by the operator.

- **Auto-assign**
  DashBoard can now be configured to automatically assign an external ID when a preset is created, or upon request.

- **Display offset**
  DashBoard can now be configured to offset the displayed external IDs by 1. This can be helpful when working with other systems that also offset preset IDs, such as Carbonite.
• **Preset CUT and RUN commands using external ID**
  
  New commands have been added for custom panel creators to trigger preset recalls using the external ID assigned to the preset.

**Hard Panel Control of Preset Recall**

DashBoard can now be configured to allow a Hard Panel (such as a joystick controller with assignable buttons) to control preset recalls:

• CUT, RUN or ALT button activation
• HALT a preset recall
• Adjust the run duration of the preset
• A new time mode button that allows the operator to choose whether the hard panel controls run duration prior to preset recall, or time dilation during recall

Note that hard panel control of preset recall will not work when connecting to a PT Head connection that has been shared through the proxy server; a separate connection to the PT Heads should be established from every DashBoard client that requires access to them.

**Integration of Paint Control**

If the camera mounted on your PT Head is controlled by DashBoard, you can now configure DashBoard to integrate the paint control page into the Ross PT Head UI. This will allow you to view the paint UI as a tab within the PT Head UI and to control paint parameters with a joystick pointed at the PT Head.

This feature is supported for Ross ACIDcam, Hitachi Studio cameras, Panasonic AK-HC1500/HC1800/UB300 and Sony studio cameras that support CNA-1. For Sony and Panasonic cameras, you must have a Ross Video license for the paint control page in order to integrate paint controls into the PT Head UI.

**Enable/Disable Axes using PT Head UI**

DashBoard now offers an option to expose controls to enable and disable individual axes on the PT Head. Disabling is temporary; reconnecting DashBoard will re-enable the axes.
Preset Page - Safe Mode

Both shotbox and panel modes now offer an option to deselect all actions on the preset page, so that presets cannot be recalled or modified inadvertently. DashBoard will start up in this state.

For more information about using DashBoard to add and control robotic pan & tilt heads, and the new features added in 9.1, please see the User Manual for PT Head Control (8351DR-019). To download a PDF copy of the user manual, go to https://www.rossvideo.com/products-services/acquisition-production/robotic-camera-systems/studio-robotics/, follow the Downloads link, expand the Manuals node, and select the manual.

PTZ CAMERA ICONS

A new icon is now used for PTZ Cameras in the DashBoard tree

For more information about using DashBoard to add and control PTZ cameras, please see the User Manual for PTZ Control Plugin (8351DR-01). To download a PDF copy, go to https://www.rossvideo.com/support/product-documentation/ross-robotics/.

BUGS ADDRESSED

- DASHBOARD
  - Fixed an issue in DashBoard v9.1.0 where the DashBoard tree view did not display cached items when an HTTP request failed. (DASH-3404)
  - Fixed an issue with the installer for users running DashBoard v.9.1.0 on Mac OSX. (DASH-3406)
  - Fixed an issue with widget hint WIDGET_LINE_ONLY (6). (DASH-3401)
  - Fixed a notarization issue that required Mac OSX Catalina users to bypass Security and Privacy settings to install DashBoard. (DASH-2121)
  - Fixed an issue with the EQ Graph where replaced constraints continued to display the previous constraint's values. (DASH-2594)

- CAMERA MOTION SYSTEMS
  - Fixed a camera selection issue that occurred when you switch cameras using the joystick while UI follows selection was enabled. (DASH-2167)
  - Fixed an issue where removing a PTZ camera and then attempting to add the same device, or another device with the same IP address, back into DashBoard required a
restart of DashBoard. This has now been resolved and you can remove and re-add the same device without encountering problems. (CI-315)

- The Preset page of the DashBoard PT head plugin previously accepted run duration values that were too low to ever be operable. This has been resolved by introducing a number pad for specifying run duration values. If the value is too low, it automatically increases to the lowest potentially operable value when the number pad closes. Note that this change does not guarantee the duration will always be valid for recalling the preset. The minimum valid duration can be determined only when you are about to recall the preset, because it depends on the starting position of the head at that time. (CI-317)

- Previously, using the selector to switch joystick control to another camera while one or more joystick controls were active (for example the head was panning) would cause the first device to continue moving. This has now been corrected for both PT Head and PTZ Camera controllers. When the joystick switches to another device, all velocity controls will be reset to 0 and the first device will stop moving. (CI-328)

- Fixed an issue where SmartShell, when connecting to two or more PTZ Cameras using the DashBoard Furio Gateway, was occasionally showing a disconnection error due to a timeout on an Axis Status request. This was caused by a threading issue when formatting the motor position in the message response which has now been resolved. (CI-332)
VERSION 9.0.2 – MAY 2020

BUGS ADDRESSED

• Fixed an issue where listeners are created repeatedly for the same component. (DASH-3053)
• Fixed an issue where hovering over buttons caused a memory leak issue. (DASH-3055)
WHAT'S NEW

- NEW AURA UI THEME
  You can now design and build beautiful custom panels that leverage the new Aura theme, and update existing panels by launching them in DashBoard 9.0. Aura makes it easier to design stunning panels using simple two-dimensional elements and bright colors.

COMPATIBILITY NOTE
Blackstorm does not support the Aura theme.

- CHANGE THEME PREFERENCES
  Theme preferences now provides the ability to go back to the Classic theme if needed. Theme preferences are found in the Window menu under Preferences > General.

COMPATIBILITY NOTE
New features developed for future versions of DashBoard will not support the Classic theme.
• UPDATED THE COLOR PALETTE
The new color palette allows you to adopt a consistent color scheme for panels and saves you time by minimizing the need for style overrides. For more details on recommended usage, see the CustomPanel Development Guide.

• EQ GRAPH
You can now map parameters from a device to display a parametric equalization visualization, or EQ Graph. Many custom options, such as Q values and colors, are available using config options.

• SLIDER SUPPORTS COLOR FILL OPTION
The `w.fillcolor` config option option allows you to set the color fill for a slider with no label.

• SLIDER SUPPORTS ANCHOR FILL OPTIONS
The `w.fillanchor` config option option allows you to set an anchor point of min, max, mid, or none for the color fill for a slider with no label.

• DISABLE KEYBOARD AND NUMBER PAD
The `w.keyboard` config option option allows you to disable the keyboard or number pad that appears by default for Text Field (3) and Spinner (5) type widgets on Ultritouch panels.
• **EXTERNAL CONSTRAINTS**
  The EXTERNAL_CONSTRAINT can be used to indicate that the constraint for this parameter is provided in an external object, rather than embedded within the parameter descriptor.

```json
"constraint": {
    "type": "EXTERNAL",
    "eo": "0x05"
},
```

• **CAMERA CONTROL**
  Menu options for adding a new camera to DashBoard have been reconfigured to make them clearer and to distinguish between paint control of ENG/Box cameras and control of PTZ cameras.

• **CONTROL OF ROSS PAN & TILT HEADS**
  DashBoard now includes a built-in controller for Ross Pan & Tilt Heads (Note: while Furio heads can communicate with DashBoard directly, CamBot heads require the CamBot Protocol Translation software that is part of the Robotics Server to communicate with DashBoard. This software will be available for free for use with the PT head plugin).

  To add a PT head in DashBoard, navigate to **File > New > Other > Robots**, and select **Ross PT Head**. The head’s IP address is required.

Once connected to a PT Head, the operator can:

  o Store, recall, view and manage presets stored on the head. The operator can:
    ▪ View, add, delete, and rename categories.
    ▪ View, add, clone, edit, update, and delete presets.
    ▪ Perform timed recall of presets – using either the duration stored with the preset or an alternate duration set in the UI. Recall time can be dynamically altered while the preset is in progress.
    ▪ Assign external IDs to presets for use with other control systems such as switchers or APC software. Note that DashBoard does not ensure that the assigned IDs are unique.
o Directly control pan, tilt, zoom, focus, and iris axes – either through the DashBoard UI or by connecting a standard Microsoft HID-compliant USB joystick to the DashBoard computer. The operator can:
  ▪ Enable and disable joystick control.
  ▪ View axis status and position information
  ▪ Configure axes – speed, damping, and zoom-dependent sensitivity
  ▪ View axis limits. Set and clear soft limits for each axis.

o In addition to providing access to all of the core functionality of the pan & tilt heads, the Dashboard controller also includes some more advanced features that make it easier to use in a variety of workflows:
  ▪ Supports both panel mode (select a preset and then select the desired action) and shotbox mode (select an action and then select the desired preset)
  ▪ Includes settings to configure the preset grid size, view, and sort options. Also includes a setting to disable the confirmation pop-up upon preset creation, applying default values to accelerate the workflow.

For more information about using DashBoard to add and control robotic pan & tilt heads, please see the User Manual for PT Head Control (8351DR-019). To download a PDF copy of the user manual, go to https://www.rossvideo.com/products-services/acquisition-production/robotic-camera-systems/studio-robotics/, follow the Downloads link, expand the Manuals node, and select the manual.

**BUGS ADDRESSED**

- Fixed an Ultritouch issue where zip files that contained the same name as a folder caused an error message to appear despite the upload occurring successfully. (DASH-2194)
- Fixed an issue where the tooltip style attribute did not work for the color chooser and color chooser pop-up widget. (DASH-2393)
WHAT’S NEW

- **ABILITY TO DOWNLOAD CUSTOMPANELS ON ULTRITOUCH**
  You can now download CustomPanels from Ultritouch on to your computer. From DashBoard, click **Manage CustomPanel > Download from Device**.

- **SUPPORT FOR REBOOT FLAG ON COMMANDS ON ULTRITOUCH**
  If changes are made that require a reboot, a prompt will now appear that asks the user to reboot. If the user doesn't reboot at the recommended prompt, then the status in the device tree indicates the required reboot.

- **CAMERA MOTION SYSTEMS – SUPPORT FOR PIVOTCAM-SE**
  DashBoard PIVOTCam-SE control offers you the ability to:
  - Store, recall and manage presets. Presets can be stored and recalled locally from DashBoard storage, or directly from the camera head.
  - Control cameras directly using PTZ and Paint control pages.
  - Configure your camera to:
    - View camera data such as version numbers
    - View and modify a selection of camera settings
    - Configure SDI video output and configure and enable/disable IP streams
    - Configure gateways, which allow you to control the camera from Carbonite or SmartShell

**NOTE**

- For customers who previously used the PIVOTCam Control Panel, a new PTZ Legacy Preset Conversion Tool is available to help transfer presets to the new DashBoard controller. For more information, contact Technical Support and see the document, "Importing Presets from Legacy Camera Panels (8351DR-018-xx)".

- If you already have PIVOTCam-SE cameras, you will need to upgrade their firmware in order to use them with the DashBoard plugin. For the latest firmware upgrade package, including upgrade instructions, see [https://www.rossvideo.com/support/software-downloads/pivotcam](https://www.rossvideo.com/support/software-downloads/pivotcam).

For more information about configuring and controlling PIVOTCam-SE cameras from DashBoard, see the **User Manual for PTZ Camera Control Plugin (8351DR-015-8.8)**.

**BUGS ADDRESSED**

- Ultritouch
  - Fixed the issue with the CustomPanel list appearing empty in certain conditions.
- Fixed the Null Pointer issue when the Ultritouch was shut down without any UIs open.
- Fixed file upload issues.
- Fixed “remember connection” issues that occurred when adding a device to the DashBoard tree.
- Fixed usability issues that were causing an unintended click when trying to pan.
- Fixed the issue that permitted users to remove the DashBoard Service node.

- DashBoard
  - Fixed device descriptor request issues with the minimal mode code.
  - Fixed the issues saving CustomPanels that use drawers with hidden tabs.
  - Fixed the issue causing panels with large touch wheels to break.
  - Fixed the issue with the DashBoard application stealing focus.

**VERSION 8.7.1 – OCTOBER 2019**

**WHAT’S NEW**

- **Memory Manager Indicator**
  The Memory Manager (Figure 1.1) displays the current memory usage of the DashBoard instance that you are running and when memory is low it takes actions to free up memory by unloading inactive tabs, as shown in Figure 1.2. Unloaded tabs are indicated by a caret symbol in front of the name, for example “^ CustomPanel01.grid”. The Memory Manager will not unload active CustomPanels or active tabs. If you have a panel that runs tasks in the background (listeners, GPI triggers, timers, and etc.), you may not want DashBoard to unload your panel. You can use the keepalive flag in the top level of the CustomPanel source code to indicate that this panel should not be unloaded. Existing CustomPanels will not be unloaded because the keepalive is enabled by default.

Note: The memory usage shown is approximate and subject to Java’s garbage collection schedule, and it may take a few moments for changes in memory consumption to be reflected in the status.
Memory Manager with a healthy status (green)

Two frames that are shown in unloaded state

If your status indicator is green, then the memory usage is within the acceptable range. The status indicator turns yellow to indicate caution, and finally escalates to red to indicate when memory usage exceeds the recommended levels.

You can disable or enable the unload feature in the DashBoard General Preferences or set your preferences at the CustomPanel level.

- Memory Manager Tag
  If you would like to see a memory manager indicator directly in your panel, you can add the new memory manager widget. You can also customize its size and position when you add the memory manager tag.

  In PanelBuilder Edit Mode, you can double-click on the canvas to open the Component Editor. From there you can click Source tab, and add the memory manager widget to the top level of the source code (usually an <abs> container). You can include attributes to modify the size and position of the memory manager status bar, as shown in the example below:

  ```xml
  <abs contexttype="opengear" id="_top" keepalive="false" style="">
    <memory height="50" left="1500" top="50" width="200"/>
  </abs>
  ```

- Keep Alive tag
  If you have a CustomPanel that should never be unloaded, you can set a Keep Alive flag in the Abs Attributes that will tell DashBoard not to unload this panel (even if the memory is low).
Note: CustomPanels that were created in DashBoard 8.6 and earlier will not be unloaded when memory is low, because by default the Keep Alive option is enabled on CustomPanels that were built before the Memory Manager was available.

In PanelBuilder Edit Mode, double-click on an empty area on the CustomPanel to open the Component Editor. The uppermost abs should be selected in the tree. In the Abs Attributes tab under Remote Task Triggering, select Keep Alive. This button prevents DashBoard from unloading this CustomPanel, even when memory is low.

You can see the Keep Alive button below:

You can also set the keepalive attribute in the source code in the top-level abs. For example:

```xml
<abs contexttype="opengear" id="_top" keepalive="true" style="">
  ...main panel content here...
</abs>
```

- Ultritouch 4 Support
  You can now use the Ultritouch 4 Panel template when creating a CustomPanel for the new Ultritouch 4. The template provides a 1304 x 485 pixel canvas, which is designed to fit beside the built in DashBoard navigation in the Ultritouch User Interface (UI).

- Color Chooser now supports RGBA output format
  You can now use the w.format config option to modify the Color Chooser widget. This option allows the user to set the output format for color strings to RGBA (red-green-blue-alpha) or ARGB (alpha-red-green-blue). The value can be set to rgba or argb, where argb is the default output format.

  Tip: You can find a list of the available config options in the Param Attributes tab > Config Options area by clicking the Help button.

- Support for OGP Minimal Mode
  DashBoard 8.7.1 now supports any devices that implement OGP Minimal Mode to request a minimal amount of status updates to DashBoard until the devices’ user interfaces open.

  Additionally, the DashBoard Proxy server enables OGP Minimal Mode support by default for any devices it shares.

- New DashBoard Logo
  DashBoard's User Interface now features the new Dashboard logo and updated style.

- Other Enhancements
Improvements to the Color Chooser widget which now supports the use of transparency with the ogScript setStyle() function.

Improvements to Proxy Server support for Carbonite.

**Sony Camera Control Enhancements**

Sony camera control enhancements include the following:

- Support for Multi-Camera Mode for Sony Cameras Connected Through a CNA-1 Adapter
- Sony Master Control
- PTZ Camera Control (for Sony BRC cameras)
- Control of Sony BRC Cameras – VISCA Gateway

**Support for Multi-Camera Mode for Sony Cameras Connected Through a CNA-1 Adapter**

Ross Video’s Sony Paint plugin for DashBoard now supports Sony’s HZC-MSCN1 software upgrade for CNA-1 units. The software upgrade, available from Sony, enables you to control multiple cameras from a single CNA-1 unit.

**When you add a supported Sony ENG/Box Camera in DashBoard, you specify one of the following two operation modes:**

- **RCP Mode** — Each camera is associated with a dedicated CNA-1 Adapter. The camera control computer(s) address each camera directly through the camera's CNA-1 Adapter. RCP mode is sometimes referred to as Gateway mode.

- **MSU Mode** — The system includes one or more CNA-1 adapters, upgraded to run in MSU mode (Sony upgrade HZC-MSCN1). Each CNA-1 adapter controls a group of cameras. In facilities that have a large number of cameras, deploying multiple CNA-1 adapters may improve response time, as the system queues control requests and polls the cameras for status updates. An additional Sony MSU or upgraded CNA-1 adapter is required to act as the master device on the Sony network.

If you already have cameras that are configured for previous versions of the Sony Paint plugin that are connected directly (as opposed to via proxy server), they will continue working normally after you install DashBoard v8.7.1. Cameras connected via proxy server may need to be Unshared and then Shared to re-establish connectivity. See the Known Issues section of this document for more information (CI-190).
**Note:** The Sony Paint plugin is a licensed feature of DashBoard. It must be purchased from Ross Video. For assistance with licensing, please contact Ross Video Technical Support and ask for the Sony SSP Camera Control feature.

For detailed installation and configuration instructions, see the manual, “Installation Guide for Sony Paint Control (8351DR-012-8.7)“.

- **Sony Master Control**

  In this release, the Sony Paint plugin also includes a new configuration page that enables you to view and manage your connected cameras in both RCP and MSU mode. This Master Control page can be accessed from Slot 0 of the Sony ENG/Box Cameras node in the DashBoard tree:

- **PTZ Camera Control (for Sony BRC cameras)**

  DashBoard can now be used to configure and control select Sony BRC cameras models. DashBoard's PTZ Camera Control plugin communicates with Sony cameras using VISCA protocol over IP.

  DashBoard currently supports Sony models BRC-X1000 and BRC-H900.

  Using the PTZ Camera Control plugin, you can:
  
  - Store, recall, and manage presets
  - Control camera pan, tilt, zoom, focus, and iris. These can also be controlled using an external joystick connected to the DashBoard computer.
  - Perform basic paint and shading.
  - View and configure camera settings, and access the camera's on-screen configuration menu.
  - Export configuration and presets to be imported later, for use with the same model of camera.

  For detailed information about how to access and use the PTZ Camera Control plugin, see the Camera Control Manual (8351DR-015-8.7).

**Note:** The PTZ Camera Control plugin for configuration and control of select Sony BRC cameras is a licensed feature of DashBoard. It must be purchased from Ross Video. For
assistance with licensing, please contact Ross Video Technical Support and ask for the Sony BRC Camera Control feature.

- **Control of Sony BRC Cameras – VISCA Gateway**

The PTZ Camera Control plugin includes a gateway that enables controllers such as Carbonite to connect to supported Sony BRC cameras using VISCA Protocol over TCP.

Once you have added a Sony BRC camera to DashBoard, you can enable the VISCA gateway by navigating to Config > Gateway, specifying a port for your VISCA gateway, and tapping Enable to connect. The VISCA Gateway control page displays the status of the gateway and how many controllers are connected to it.

The VISCA Gateway provides access to:

- Directly control pan, tilt, zoom, focus, iris, and color on the connected camera.
- Store and recall presets. You can select whether to store presets:
  - Directly on the camera (set Presets option to Camera).
  - Locally on the DashBoard computer, where they can also be accessed through the Presets panel (set Presets option to Local).

**Note:**

To access the VISCA Gateway feature for a Sony BRC camera, you must purchase a license for the Sony BRC Camera Control feature. Please contact Ross Technical Support for assistance.

**BUGS ADDRESSED**

- You cannot use both the VDCP task server port and HTTP trigger server port at the same time for GPI triggers. (Navigate to Component Editor > Remote Task Triggering)
- The Color Chooser transparency slider does not show transparency.
- Issues with Proxy Server for Carbonite.
- Long OGP JSON messages block communications.
VERSION 8.6.0 – MAY 2018

WHAT’S NEW

• LDAP CONFIGURATION
  Removed the character limit on LDAP configuration fields to support larger queries.

• WIZARD FEATURE
  You can create wizards that contain a title, a page navigation pane, and a progress bar. The wizard allows you to automate complex tasks and break them into a series of steps that walk users through the process from start to finish. You can see an example wizard below:

![Example Wizard](image)

You can choose which features you would like to be visible, and how many pages appear in the wizard. Feature options include the tabs, progress bar, and dialog width and height. The wizard is now available in the PanelBuilder Edit Mode toolbar.
If you would like to modify the basic wizard, you can customize it using the script functions defined below. Each function is optional, so if you do not define a function, the wizard simply uses the default wizard settings for that function call. This allows a developer to override only a small portion of the wizard's operation, or to control as many aspects of the wizard's operation as needed. You can see a basic example below:

```html
<wizard dialog="false" height="465" left="104" name="My Wizard" style="bdr:shadow;" tabsvisible="true" top="122" width="694">
  <config help="" helptitle="" key="w.model" message=""/>
  var model = {
    getPageTitle: function(page) {
      return "SCRIPTABLE PAGE: " + (page + 1);
    },
    getMessage: function(page) {
      return "My message for page " + page;
    },
    getHelp: function(page) {
      return "My help for page " + page;
    }
  };
  model
</config>
<abs id="my-page1" name="Page One"/>
<abs id="my-page2" name="Page Two"/>
<abs id="my-page3" name="Page Three"/>
<abs id="my-page4" name="Page Four"/>
</wizard>
```
• **HELP CONTROL**

You can create a Help Control popup to display a custom title and help message using the Help tag, as shown in the example below.

![Help Control Example](image)

The Help Control pop-up is now available in Panelbuilder's *Edit Mode* menu.

![Edit Mode Menu](image)

To create a help pop up, use the **Help** button to create a basic canvas container, and in the **Tag Attributes** you can set the width, height, title and message. Messages can be plain text or html with many common html tags supported including hyperlinks. An OGLML example is shown below:

```html
<help height="40" html="true" left="53" name="?" popupheight="200" popupwidth="500" style="bg#ff0000;" title="Example Help" top="315" width="40"><![CDATA[<html><left><b><u>Html formated Heading</u></b><br><font color=#ffffdd>Take me home</font><br><a href="https://www.rossvideo.com/">Ross Video</a><br>The latest software release for Carbonite Black Solo unlocks a powerful USB Media Player functionality and is available to customers at no additional cost. This new media player provides the functionality of a single-channel clip player, for playout of compressed MPEG-4 AVC media
```
directly from a connected USB-media drive. There is no other production switcher in the world with this level of built-in media playback.

• **ULTRITOUCH DELETE FEATURE**

Ultritouch now provides a Delete feature that allows you to delete folders and CustomPanels from the Ultritouch User Interface. You can delete folders or CustomPanels from the Ultritouch device in DashBoard, or from the Ultritouch device interface.

In DashBoard open the Ultritouch device, and navigate to **Manage CustomPanels**. Then select the folder or file you would like to delete, and click **Remove**, as shown below.

You can also delete CustomPanels in Ultritouch from the device interface using the same method, as shown below.

• **BORDER LAYOUT CONTAINER**

You can use the border layout tool to create an area on a CustomPanel that you can anchor components to and later resize to maintain your intended layout. You can use a border layout to anchor components against any of the four borders of the container and in the center and set which of these areas will maintain their proportions when resized. It is useful for adding menus along the border edge of a CustomPanel, or to group components within a CustomPanel and later resize the components easily.

To add a border layout, in the PanelBuilder Edit Mode toolbar navigate to **Grids, Tables >**
Border Layout. Once you've drawn the border layout area on the canvas and set a growth quadrant (the only component that will expand when resized), you can add up to five components to the border layout. The components that are not part of the growth quadrant will maintain their height or width when resized.

Here's an example of a border layout with the growth quadrant set to the central content:

The source code for the border layout example is:

```xml
<abs contexttype="opengear" gridsize="20" id="_top" style="">
  <borderlayout height="460" left="20" top="40" width="780">
    <label anchor="north" height="56" name="Top Content" style="txt-align:center;bg#8C43AC;size:Big;font:bold;" width="182"/>
    <label anchor="east" height="370" name="Right Content" style="txt-align:center;bg#E67E22;size:Big;font:bold;" width="150"/>
    <label anchor="south" height="100" name="Bottom Content" style="txt-align:center;bg#287EB8;size:Big;font:bold;" width="467"/>
    <label anchor="west" height="338" name="Left Content" style="txt-align:center;bg#BF3A2B;size:Big;font:bold;" width="150"/>
    <label anchor="center" height="127" name="Center Content" style="txt-align:center;bg#27A5E5F;font:bold;size:Big;" width="152"/>
  </borderlayout>
</abs>
```
OTHER ENHANCEMENTS

- The option to set the visibility of components in the UI is now available for all component tags. The **Visible** checkbox, as shown below, is found by double-clicking a CustomPanel component in **Edit Component > Position/Stretch Attributes** tab.

![Visible](image)

- Visual Logic blocks now available for new Carbonite RossTalk Commands.
- The exit tag `<exit/>`, now allows you to open a new tab when closing the current tab.
- Drawers now have improved attribute functionality, which includes the following fields: name, ID, width, height.
- Global labels with a *.lbl extension can now be loaded using File > Open.
- Additional connection options were added to Ultritouch for IPS types, such as NK-NET, and RCP.

BUGS ADDRESSED

- Ultrix sometimes disconnects and return with “Max connections exceeded” message.
- Ultrix reloads information in DashBoard too frequently in certain network environments.
- When a drawer is set to Enabled, it doesn’t hide or show the Drawer tab.
- DashBoard may run out of memory when loading very large firmware files.
- Issues with platform upgrades in Ultritouch.
- Unable to use multiple OGP devices on same IP with DashBoard Command Line Interface.
- The File Browser does not point to the real location when the browser file is clicked.
- Dragging params from Carbonite to the CustomPanel breaks VL API blocks.
- The exit tag’s Exit Type Window opens more than one exit box.
- DashBoard cannot send firmware to NK products.
- For the XPression Plugin, you cannot see the Pattern Generator in DashBoard unless DashBoard is local to XPression.
- For the XPression Plugin, adding a device in config makes the XP widget not show the take items for all the XP devices.
KNOWN ISSUES

ROLE-BASED ACCESS CONTROL (RBAC)

- **FOR ULTRITOUCH** — When you assign a role permission for an Ultritouch device, currently the device permissions (to read, write or upgrade) may not perform as expected due to differences with the Ultritouch Management panel. It is recommended that you use both read and write access permissions to perform administrative actions on the Ultritouch Management panel.

- **RPM SERVER CERTIFICATES USING HTTPS** — If you are using an RPM Server that is secured with HTTP Secure, future DashBoard upgrades will require manually adding the RPM Server certificate to DashBoard after the installation process is complete. The upgrade procedure can be found in the DashBoard Role-Based Access Control Guide (85100DR-09A-xxx).

- If a role has any permissions for a card in an openGear frame, that role will also allow users assigned to that role to access any panels that use that card, or any cards in that frame, as a data source. (DBE-835)

NETWORK DEVICE INTERFACE (NDI)

- Limitations for NDI® 5 - DashBoard 9.4 and later support NDI® 5, but not all video codecs are supported for NDI®|HX:
  - Windows OS does not support the HEVC codec
  - Linux OS does not support the HEVC and H264 codec

AURA THEME

- Due to issues with SVG images, it is currently recommended that you avoid using SVG images within tables, trees, and combo boxes.

- If you are using the Spinner (Hex) widget in DashBoard 9.0+ with a Mac client, you may encounter issues with the text not displaying fully.

ROSSTALK EX

- If you use a panel that uses RossTalkEx to send commands to an XPression, and then try to access that XPression’s Sequencer View panel, it will fail to load the sequence items. If you open the Sequencer View panel first, and then use your panel you will not encounter any issues.

DASHBOARD TALLY SERVICE

- The DashBoard Tally does not work with the TSL5.0 protocol. TSL3.1 is recommended, and is required to use the PTZ Camera Tally Integration feature in DashBoard v9.2 and later. (DASH-3103)
PAINT CONTROL FOR SONY ENG/BOX CAMERAS

- Upgrading to a new version of DashBoard causes SmartShell to lose connectivity to Sony CNA-1 cameras via the DashBoard proxy server. To re-establish connectivity, open the DashBoard Proxy Server page, make note of the order of the cameras, Unshare all cameras, then Share each camera again in the same order that they were originally shared by right-clicking on each camera in the DashBoard tree and clicking Share Device. (CI-190)

PTZ CAMERA CONTROL

- The VISCA gateway for PTZ Cameras provides only a limited implementation of the VISCA protocol and does not include support for most status inquiries including the current value of pan, tilt, zoom and focus axes. Due to this limitation, focus control does not work from Carbonite (when configured to connect to a Sony device) or Acuity switchers when connecting to a PTZ Camera through the DashBoard VISCA gateway. Auto focus is unaffected by this issue and can be set from Carbonite or Acuity. For Carbonite, the recommended workaround is to use the “pivotcam” device configuration when connecting to the DashBoard VISCA gateway. For Acuity, focus must be controlled directly from DashBoard. Other VISCA controllers may encounter similar problems when connecting to the VISCA gateway. The recommended approach is to use a velocity-based control wherever possible (CI-307, CI-189)

- The full range of iris values is not available when controlling iris from Carbonite and Acuity when connecting to a Sony BRC camera through the DashBoard VISCA gateway. This does not affect the range of iris values when the camera is in automatic exposure mode. Workaround is to control iris directly from the DashBoard UI. (CI-188)

- When connecting to a Sony BRC-X1000 camera from DashBoard and switching from manual exposure to auto exposure with no change in exposure settings (iris, shutter, gain) there is a small but noticeable change in light levels in the video SDI output. This appears to be caused by the camera itself. (CI-169).

- Shutting down DashBoard and then immediately restarting it may occasionally result in failure to connect to any PTZ Cameras in the DashBoard tree. If this happens, the recommended resolution is to stop and restart DashBoard, ensuring that it has completely shut down before restarting it. Connectivity problems can also occur if two applications on a workstation are both attempting to connect to VISCA cameras using UDP connections. This could be another instance of DashBoard running the DashBoard PTZ Camera control or a Ross Sony camera custom control panel, or another non-Ross application that also connects to VISCA cameras. To resolve such connectivity problems, shut down all applications connecting to the VISCA cameras and then restart a single instance of DashBoard to connect to all your cameras. Note that it is not possible to run the DashBoard PTZ Camera control alongside a Ross Sony camera custom control panel even if they are hosted on the same instance of DashBoard and connecting to different cameras. (CI-238)

SYSTEM CONFIGURATION
• When installing your DashBoard client, if you experience communication issues and are running anti-virus software, consult your I.T. department.
GETTING HELP

- Help documentation is available directly in DashBoard, and can be found by navigating to the to menu, under Help > Help Contents. You can also download the guides in PDF format from the DashBoard product page on the Ross Video website under Downloads.

- Our 24-hour hotline service provides access to technical expertise around the clock. After-sales service and technical support is provided directly by Ross Video personnel.

- During business hours (Eastern Standard Time), technical support personnel are available by telephone.

- After hours and on weekends, emergency technical support is available. A telephone-answering device will provide the names and phone numbers of technical support and field service personnel who are on call. These people are available to react to any problem and to do whatever is necessary to ensure customer satisfaction. For serious issue which need urgent attention and tracking, please ensure you are given a ticket number and refer to this in future communications.
  
  - Technical Support: (+1) 613-652-4886
  - After Hours Emergency: (+1) 613-349-0006