Exporting Final Cut Pro X Clips for BlackStorm Server Playout

You must use the Apple Compressor application to render video clips from Final Cut Pro X to a BlackStorm Server supported video format before you export the video clips to your BlackStorm Server for transcoding. BlackStorm Servers support the following video formats for transcoding:

- **Avid DNxHD®** — use this format for HD playout.
- **DVCPRO HD** — use this format for HD playout.
- **DV** — use this format for SD playout.
- **Animation** — this format can be used for SD and HD key+fill playout.

### Avid DNxHD

Before you can use Compressor to render video clips from Final Cut Pro X to the Avid DNxHD format, you must create a custom setting in Compressor for the Avid DNxHD format. If you already have the required custom setting, you are ready to render.

**To render a video clip to the Avid DNxHD format:**

1. **Start Final Cut Pro X and create a video clip.**
2. Use the File menu to select **Send to Compressor** to open the Compressor application with your Final Cut Pro X project.
3. In the upper right corner of the Compressor application, click the Inspector icon to display the Inspector panel.
4. In the upper left corner of the Compressor application, click the Show icon to display the Settings list.
5. Drag your Avid DNxHD custom setting from the Settings list to your Final Cut Pro X project.
6. If required, use the Inspector panel to modify your rendering settings.
7. At the bottom of the Compressor application, click Start Batch.

**To create a custom setting for the Avid DNxHD format:**

1. **Open the Compressor application.**
2. In the upper right corner of the Compressor application, click the Inspector icon to display the Inspector panel.
3. In the upper left corner of the Compressor application, click the Show icon to display the Settings list.
4. In the lower left corner of the Compressor application, use the Add menu to select **New Setting**. A dialog box opens at the top of the Compressor application.
5. In the dialog box, use the Format list to select **QuickTime Movie**.
6. In the Name box enter a name for your new setting; for example, **BlackStorm DNxHD**.
7. In the Description box enter a description for your new setting.
8. Click OK to create a new setting and add it to the Settings list.
9. In the Settings list, select your new setting to view it in the Inspector panel on the right.
10. At the top of the Inspector panel, click General.
11. In the General Properties section, use the Format list to select Video and Audio.
12. At the top of the Inspector panel, click Video.
13. In the Video Properties section, use the Frame size list to select the dimensions of the output video clip as follows:

<table>
<thead>
<tr>
<th>Format</th>
<th>Dimensions</th>
</tr>
</thead>
<tbody>
<tr>
<td>720p 50 or 59.94</td>
<td>1280x720</td>
</tr>
<tr>
<td>1080i 50</td>
<td>1920x1080</td>
</tr>
<tr>
<td>1080i 59.94</td>
<td>1920x1080</td>
</tr>
<tr>
<td>1080p 59.94</td>
<td>1920x1080</td>
</tr>
</tbody>
</table>

14. Use the Pixel aspect ratio list to select an aspect ratio of 16:9 for the output clip.
15. Use the Frame rate list to set the frame rate of the output video clip as follows:

<table>
<thead>
<tr>
<th>Format</th>
<th>Frame Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>1080i</td>
<td>25 or 29.97</td>
</tr>
<tr>
<td>720p or 1080p</td>
<td>50 or 59.94</td>
</tr>
</tbody>
</table>

16. Use the Field Order list to set whether the output clip is interlaced or progressive as follows:

<table>
<thead>
<tr>
<th>Format</th>
<th>Field Order</th>
</tr>
</thead>
<tbody>
<tr>
<td>1080i</td>
<td>Upper First or Lower First</td>
</tr>
<tr>
<td>720p or 1080p</td>
<td>Progressive</td>
</tr>
</tbody>
</table>

17. For QuickTime settings click Change to open the Standard Video Compression Settings dialog box.
18. In the Standard Video Compression Settings dialog box, use the Compression Type list to select Avid DNxHD Codec.
19. In the **Compressor** section, use the **Resolutions** list to select one of the following valid resolutions:
   - 1080i/59.94 DNxHD 220 8-bit
   - 1080i/59.94 DNxHD 145 8-bit
   - 1080i/50 DNxHD 185 8-bit
   - 1080i/50 DNxHD 120 8-bit
   - 720p/59.94 DNxHD 220 8-bit
   - 720p/59.94 DNxHD 145 8-bit
   - 720p/50 DNxHD 185 8-bit
   - 720p/50 DNxHD 120 8-bit
   - 1080p/29.97 DNxHD 220 8-bit
   - 1080p/29.97 DNxHD 145 8-bit
20. Click **OK** to close the **Standard Video Compression Settings** dialog box.
21. At the top of the **Inspector** panel, click **Audio**.
22. In the **Audio Properties** section, use the **Channel layout** list to select a layout that meets your requirements.
23. Use the **Sample Rate** list to select 48.
24. Use the **Sample Size** list to select 16, 24, or 32.
25. For **QuickTime settings** click **Change** to open the **Sound Settings** dialog box.
26. In the **Sound Settings** dialog box, use the **Format Type** list to select **Linear PCM**.
27. Click **OK** to close the **Sound Settings** dialog box.

**DVCPRO HD**

Before you can use Compressor to render video clips from Final Cut Pro X to the DVCPRO HD format, you must create a custom setting in Compressor for the DVCPRO HD format. If you already have the required custom setting, you are ready to render.

**To render a video clip to the DVCPRO HD format:**
1. Start **Final Cut Pro X** and create a video clip.
2. Use the **File** menu to select **Send to Compressor** to open the **Compressor** application with your Final Cut Pro X project.
3. In the upper right corner of the **Compressor** application, click the **Inspector** icon to display the **Inspector** panel.
4. In the upper left corner of the **Compressor** application, click the **Show** icon to display the **Settings** list.
5. Drag your DVCPRO HD custom setting from the **Settings** list to your Final Cut Pro X project.
   - If you do not have a DVCPRO HD custom setting, follow the procedure **To create a custom setting for the DVCPRO HD format** that follows this procedure.
6. If required, use the **Inspector** panel to modify your rendering settings.
7. At the bottom of the **Compressor** application, click **Start Batch**.

**To create a custom setting for the DVCPRO HD format:**
1. Open the **Compressor** application.
2. In the upper right corner of the **Compressor** application, click the **Inspector** icon to display the **Inspector** panel.
3. In the upper left corner of the **Compressor** application, click the **Show** icon to display the **Settings** list.
4. In the lower left corner of the **Compressor** application, use the **Add** menu to select **New Setting**.
   - A dialog box opens at the top of the Compressor application.
5. In the dialog box, use the **Format** list to select **QuickTime Movie**.
6. In the **Name** box enter a name for your new setting; for example, **BlackStorm DVCPRO HD**.
7. In the **Description** box enter a description for your new setting.
8. Click **OK** to create a new setting and add it to the **Settings** list.
9. In the **Settings** list, select your new setting to view it in the **Inspector** panel on the right.
10. At the top of the **Inspector** panel, click **General**.
11. In the **General Properties** section, use the **Format** list to select **Video and Audio**.
12. At the top of the **Inspector** panel, click **Video**.
13. At the bottom of the **Video Properties** section, click **Change** to open the **Standard Video Compression Settings** dialog box.
14. In the **Standard Video Compression Settings** dialog box, use the **Compression Type** list to select one of the following codecs:
   - **DVCPRO HD 1080i50**
   - **DVCPRO HD 1080i60**
   - **DVCPRO HD 1080p30**
   - **DVCPRO HD 720p50**
   - **DVCPRO HD 720p60**
15. Click **OK** to close the **Standard Video Compression Settings** dialog box.
16. At the top of the **Inspector** panel, click **Audio**.
17. In the **Audio Properties** section, use the **Channel layout** list to select a layout that meets your requirements.
18. Use the **Sample Rate** list to select 48.
19. Use the **Sample Size** list to select 16, 24, or 32.
20. For **QuickTime settings** click **Change** to open the **Sound Settings** dialog box.
21. In the **Sound Settings** dialog box, use the **Format Type** list to select **Linear PCM**.
22. Click **OK** to close the **Sound Settings** dialog box.
DV

Before you can use Compressor to render video clips from Final Cut Pro X to the DV format, you must create a custom setting in Compressor for the DV format. If you already have the required custom setting, you are ready to render.

To render a video clip to the DV format:
1. Start Final Cut Pro X and create a video clip.
2. Use the File menu to select Send to Compressor to open the Compressor application with your Final Cut Pro X project.
3. In the upper right corner of the Compressor application, click the Inspector icon to display the Inspector panel.
4. In the upper left corner of the Compressor application, click the Show icon to display the Settings list.
5. Drag your DV custom setting from the Settings list to your Final Cut Pro X project. If you do not have a DV custom setting, follow the procedure To create a custom setting for the DV format that follows this procedure.
6. If required, use the Inspector panel to modify your rendering settings.
7. At the bottom of the Compressor application, click Start Batch.

To create a custom setting for the DV format:
1. Open the Compressor application.
2. In the upper right corner of the Compressor application, click the Inspector icon to display the Inspector panel.
3. In the upper left corner of the Compressor application, click the Show icon to display the Settings list.
4. In the lower left corner of the Compressor application, Use the Add menu to select New Setting.
   A dialog box opens at the top of the Compressor application.
5. In the dialog box, use the Format list to select QuickTime Movie.
6. In the Name box enter a name for your new setting; for example, BlackStorm DV.
7. In the Description box enter a description for your new setting.
8. Click OK to create a new setting and add it to the Settings list.
9. In the Settings list, select your new setting to view it in the Inspector panel on the right.
10. At the top of the Inspector panel, click General.
11. In the General Properties section, use the Format list to select Video and Audio.
12. At the top of the Inspector panel, click Video.
13. At the bottom of the Video Properties section, click Change to open the Standard Video Compression Settings dialog box.
14. In the Standard Video Compression Settings dialog box, use the Compression Type list to select one of the following codecs:
   - DV/DVCPRO - NTSC
   - DV - PAL
15. Click OK to close the Standard Video Compression Settings dialog box.
16. At the top of the Inspector panel, click Audio.
17. In the Audio Properties section, use the Channel layout list to select a layout that meets your requirements.
18. Use the Sample Rate list to select 48.
19. Use the Sample Size list to select 16, 24, or 32.
20. For QuickTime settings click Change to open the Sound Settings dialog box.
21. In the Sound Settings dialog box, use the Format Type list to select Linear PCM.
22. Click OK to close the Sound Settings dialog box.

Animation

Before you can use Compressor to render video clips from Final Cut Pro X to the Animation format, you must create a custom setting in Compressor for the Animation format. If you already have the required custom setting, you are ready to render.

To render a video clip to the Animation format:
1. Start Final Cut Pro X and create a video clip.
2. Use the File menu to select Send to Compressor to open the Compressor application with your Final Cut Pro X project.
3. In the upper right corner of the Compressor application, click the Inspector icon to display the Inspector panel.
4. In the upper left corner of the Compressor application, click the Show icon to display the Settings list.
5. Drag your Animation custom setting from the Settings list to your Final Cut Pro X project. If you do not have a Animation custom setting, follow the procedure To create a custom setting for the Animation format that follows this procedure.
6. If required, use the Inspector panel to modify your rendering settings.
7. At the bottom of the Compressor application, click Start Batch.

To create a custom setting for the Animation format:
1. Open the Compressor application.
2. In the upper right corner of the Compressor application, click the Inspector icon to display the Inspector panel.
3. In the upper left corner of the Compressor application, click the Show icon to display the Settings list.
4. In the lower left corner of the Compressor application, use the Add menu to select New Setting.
   A dialog box opens at the top of the Compressor application.
5. In the dialog box, use the Format list to select QuickTime Movie.
6. In the Name box enter a name for your new setting; for example, BlackStorm Animation.
7. In the Description box enter a description for your new setting.
8. Click OK to create a new setting and add it to the Settings list.
9. In the Settings list, select your new setting to view it in the Inspector panel on the right.
10. At the top of the Inspector panel, click General.
11. In the General Properties section, use the Format list to select Video and Audio.
12. At the top of the Inspector panel, click Video.
13. In the Video Properties section, use the Frame size list to select the dimensions of the output video clip as follows:

<table>
<thead>
<tr>
<th>Format</th>
<th>Dimensions</th>
</tr>
</thead>
<tbody>
<tr>
<td>720p 50 or 59.94</td>
<td>1280x720</td>
</tr>
<tr>
<td>1080i 50</td>
<td>1920x1080</td>
</tr>
<tr>
<td>1080i 59.94</td>
<td>1920x1080</td>
</tr>
<tr>
<td>1080p 59.94</td>
<td>1920x1080</td>
</tr>
</tbody>
</table>

14. Use the Pixel aspect ratio list to select an aspect ratio of 16:9 for the output clip.
15. Use the Frame rate list to set the frame rate of the output video clip as follows:

<table>
<thead>
<tr>
<th>Format</th>
<th>Frame Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>1080i</td>
<td>25 or 29.97</td>
</tr>
<tr>
<td>720p or 1080p</td>
<td>50 or 59.94</td>
</tr>
</tbody>
</table>

16. Use the Field Order list to set whether the output clip is interlaced or progressive as follows:

<table>
<thead>
<tr>
<th>Format</th>
<th>Field Order</th>
</tr>
</thead>
<tbody>
<tr>
<td>1080i</td>
<td>Upper First or Lower First</td>
</tr>
<tr>
<td>720p or 1080p</td>
<td>Progressive</td>
</tr>
</tbody>
</table>

17. For QuickTime settings click Change to open the Standard Video Compression Settings dialog box.
18. In the Standard Video Compression Settings dialog box, use the Compression Type list to select Animation.
19. Click OK to close the Standard Video Compression Settings dialog box.
20. At the top of the Inspector panel, click Audio.
21. In the Audio Properties section, use the Channel layout list to select a layout that meets your requirements.
22. Use the Sample Rate list to select 48.
23. Use the Sample Size list to select 16, 24, or 32.
24. For QuickTime settings click Change to open the Sound Settings dialog box.
25. In the Sound Settings dialog box, use the Format Type list to select Linear PCM.
26. Click OK to close the Sound Settings dialog box.

Contacting Technical Support

At Ross Video, we take pride in the quality of our products, but if problems occur, help is as close as the nearest telephone.

Our 24-hour Hot Line service ensures you have access to technical expertise around the clock. After-sales service and technical support is provided directly by Ross Video personnel. During business hours (eastern time), technical support personnel are available by telephone any time. After hours and on weekends, a direct emergency technical support phone line is available. If the technical support person who is on call does not answer this line immediately, a voice message can be left and the call will be returned shortly. This team of highly trained staff is available to react to any problem and to do whatever is necessary to ensure customer satisfaction.

- Technical Support: (+1) 613-652-4886
- After Hours Emergency: (+1) 613-349-0006
- E-mail: techsupport@rossvideo.com
- Website: http://www.rossvideo.com

Copyright

© 2014 Ross Video Limited. Ross®, and any related marks are trademarks or registered trademarks of Ross Video Limited. All other trademarks are the property of their respective companies. PATENTS ISSUED and PENDING. All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted in any form or by any means, mechanical, photocopying, recording or otherwise, without the prior written permission of Ross Video. While every precaution has been taken in the preparation of this document, Ross Video assumes no responsibility for errors or omissions. Neither is any liability assumed for damages resulting from the use of the information contained herein.