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Thank You for Choosing Ross
You've made a great choice. We expect you will be very happy with your purchase of Ross 
Technology. 
Our mission is to:
1. Provide a Superior Customer Experience

• offer the best product quality and support

2. Make Cool Practical Technology

• develop great products that customers love
Ross has become well known for the Ross Video Code of Ethics. It guides our interactions and 
empowers our employees. I hope you enjoy reading it below.
If anything at all with your Ross experience does not live up to your expectations be sure to reach 
out to us at solutions@rossvideo.com.

David Ross
CEO, Ross Video
dross@rossvideo.com

Ross Video Code of Ethics
Any company is the sum total of the people that make things happen. At Ross, our employees are a 
special group. Our employees truly care about doing a great job and delivering a high quality 
customer experience every day. This code of ethics hangs on the wall of all Ross Video locations to 
guide our behavior:
1. We will always act in our customers’ best interest.

2. We will do our best to understand our customers’ requirements.

3. We will not ship crap.

4. We will be great to work with.

5. We will do something extra for our customers, as an apology, when something big goes wrong 
and it's our fault.

6. We will keep our promises.

7. We will treat the competition with respect.

8. We will cooperate with and help other friendly companies.

9. We will go above and beyond in times of crisis. If there's no one to authorize the required action in 
times of company or customer crisis - do what you know in your heart is right. (You may rent 
helicopters if necessary.)
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Introduction
This guide covers the configuration of third-party devices to work within your Ross Tally System 
Console. The following chapters are included:

• “Introduction” summarizes the guide and provides important terms, and conventions.
• “Installation” outlines how to install the Tally System Console application on your computer.
• “Interface Overview” provides an overview of the Tally System Console interfaces including the 

menu tree, editors, and device configuration settings.
• “Getting Started” summarizes how to add connections to the devices in your tally system to the 

Tally System Console.
• “Camera Control Panels” provides an overview of how to design camera delegation control 

panels that are used in systems with multiple control rooms.
• “Production and M/C Switchers” provides additional information when assigning ports of a TSI 

which will be used to communicate with a production or master control switcher.
• “Routers” provides additional information to assign the serial port or network connection of a TSI 

which will be used to communicate with a router.
• “Displays” outlines how to assign the serial port or network connection of a TSI which will be 

used to communicate with one or more under-monitor displays.
• “UMDs” provides additional information when assigning a UMD port.
• “Parallel Interface Ports” provides additional information to assign the serial port or network 

connection of a TSI which will be used to communicate to receive and execute relay closure 
commands received via a serial line or a network connection.

• “GPIs and Parallel Interface Devices” outlines the steps for configuring one of three possible 
types of parallel interface devices: 4211 GPI units (serial connection), TXI-series GPI units 
(networked over Ethernet) and RCP-series generic control panels (serial connection).

• “GPI Inputs and Outputs” outlines how to define the individual GPI outputs configured for each 
parallel interface device, and how to define the individual GPI outputs configured for each control 
panel.

• “I/O and Signals” outlines the I/O and Signals tab settings.
• “Plant Layouts” discusses tally areas, Single Control Room and Multiple Control Room 

configurations.
• “Remote Control Panel Layouts” outlines how to define one or more Remote Control Panel 

(RCP) layouts. Each layout provides a graphical representation of one or more RCP panel and the 
assigned function for each button.

• “Tally Maps” outlines how to define one or more tally map layouts.
• “Tally Logic” summarizes the UMD, GPI, LED control expression editors.
• “Monitor Wall Layout Designer” outlines how to use the Monitor Wall Layout Designer to build a 

“monitor wall” from within the Tally System Console.
• “RCP Layout Designer” provides outlines how to use the RCP Layout Designer to configure one 

or more Remote Control Panel (RCP) units from within the Tally System Console.
• “Tally Map Layout Editor” outlines the Tally Map Layout Editor to assign inputs and outputs 

within the Tally System Console.
• “Reference” provides additional information that may be helpful when using the Tally System 

Console menu system.
• “Embedded Functions” explains how to use embedded functions.
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Related Publications
It is recommended to consult the following Ross documentation before installing and configuring 
your Tally System Console:

• TSI-4000 User Guide, Ross Part Number: 2400DR-004
• Ultricore BCS User Guide, Ross Part Number: 2201DR-106
• Ultricore-Tally Device Setup Guide, Ross Part Number: 2201DR-015
• Ultriscape User Guide, Ross Part Number: 2101DR-018
• ULTRIX-FR1, ULTRIX-FR2, and ULTRIX-FR5 Installation Guide, Ross Part Number: 2101DR-003
• ULTRIX-FR12 Installation Guide, Ross Part Number: 2101DR-603

Documentation Conventions
Special text formats are used in this guide to identify parts of the user interface, text that a user 
must enter, or a sequence of menus and sub-menus that must be followed to reach a particular 
command.

Interface Elements
Bold text is used to identify a user interface element such as a dialog box, menu item, or button. For 
example:

In the Network tab, click Apply.

User Entered Text
Courier text is used to identify text that a user must enter. For example:

In the Language box, enter English.

Referenced Guides
Text set in bold and italic represent the titles of referenced guides, manuals, or documents. For 
example:

For more information, refer to the TSI-4000 User Guide.

Menu Sequences
Menu arrows are used in procedures to identify a sequence of menu items that you must follow. 
For example, if a step reads “File > Save As,” you would click the File menu and then click Save As.

Important Instructions
Star icons are used to identify important instructions or features. For example:

 Contact your IT department before connecting to your facility network to ensure that there are 
no conflicts. They will provide you with an appropriate value for the IP Address, Subnet Mask, and 
Gateway for your device.
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Contacting Technical Support
At Ross Video, we take pride in the quality of our products, but if problems occur, help is as close as 
the nearest telephone.

Our 24-hour Hot Line service ensures you have access to technical expertise around the clock. 
After-sales service and technical support is provided directly by Ross Video personnel. During 
business hours (Eastern Time), technical support personnel are available by telephone. After hours 
and on weekends, a direct emergency technical support phone line is available. If the technical 
support person who is on call does not answer this line immediately, a voice message can be left 
and the call will be returned shortly. This team of highly trained staff is available to react to any 
problem and to do whatever is necessary to ensure customer satisfaction.

• Technical Support: (+1) 613-652-4886
• After Hours Emergency: (+1) 613-349-0006
• E-mail: techsupport@rossvideo.com 
• Website: http://www.rossvideo.com 

mailto:techsupport@rossvideo.com?Subject=Information%20Request&Body=Hi,%0D%0D
http://www.rossvideo.com
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Installation
The Tally System Console is an application that is designed to work in tandem with one or more TSI 
systems. The application provides the user with a spreadsheet-like interface to configure their tally 
systems. Changes can then be made to the tally logic and uploaded to each TSI system. In addition, 
the Tally System Console application can be configured to limit access to certain areas of the tally 
configuration. This allows for minor configuration changes without the hazard of disrupting any 
existing tallies (e.g. source name changes).

System Requirements
Ensure the following are available before installing and using the Tally System Console:

• The Tally System Console software from the Ross Video website (the file name should be Tally 
System Console 3.8-Redis-on.msi.)

• A computer to install the Tally System Console with a minimum of:
› 1.5GB hard disc space
› 1GB RAM
› 1GHz processor

• The computer for the Tally System Console is on the same network as your Ultricore BCS and 
other tally system devices.

Installing the Tally System Console
This section outlines how to install the Tally System Console application on your computer. 

To install the Tally System Console on your computer

1. Right-click the Tally System Console *.msi install file. 

2. Click Install.

3. Launch the Tally System Console.

4. Select Management > Configuration.

5. Select the General tab.

6. Select the Send configuration to TSI database box.

7. Click OK.

8. Select File > Merge Libraries.

9. Select the file Library10.lib.

10. Click OK.

Upgrading From Previous Versions
When upgrading from a previously installed version of the software, the installer will automatically 
uninstall the previous version. Note that previous registry settings may be erased in the uninstall 
process.
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Interface Overview
This chapter provides an overview of the Tally System Console interfaces including the menu tree, 
editors, and device configuration settings.

Overview
The Tally System Console application is broadly organized into two physical sections:

• The Menu toolbar on the left-half of the application allows for a tree list view of the entered 
devices, signals, sources, destination, and more. It can be used to invoke various types of editors 
in the Editor Pane and allows for dragging and dropping of items into the tables within the Table 
Editor Pane.

• The Table Editor toolbar on the right half of the application provides a table-like worksheet to 
enter in the tally system configuration information. Typical Excel-like keyboard/mouse navigation 
is supported in the Table Editor Pane. This includes CTRL+C (copy text), CTRL+V (paste text), and 
multiple cell selection by dragging the mouse with the left-button pressed or by holding the 
SHIFT-key on the keyboard while selecting individual cells.

Menu Toolbar
The Menu toolbar consists of a row of tabs near the top of the application. 

Figure 1  Example of the Menu Toolbar

Select a tab to display tally system configuration options:

• Hardware — Setup of TSI tally controllers and comm ports for Production and Master Control 
Switchers, Signal Routers, Displays and Parallel (GPI) Interfaces.

• UMDs (Under Monitor Displays) — Programming of Under Monitor Displays, including the UMD 
name, the signal of each UMD monitors, the ID number of each UMD, the comm port to which 
each UMD is connected, UMD monitoring styles, and other important information.

• GPIs (General Purpose Interface) — Parallel Input/Output setup, including the addresses of 
physical relay closure and relay sensing hardware, programming of relay closure outputs, and 
lists of available relay sensing inputs.

• I/O and Signals — Defines the signals that feed and signals that are provided by Production 
Switchers and Signal Routers.

• Plant Layout — Used to identify control rooms within the broadcast plant and monitor walls 
within each control room.

• Tally Logic — Defines the logic expressions used to control UMDs, GPI outputs, control panels, 
and router crosspoints.

Selecting a tab within the main interface of the menu tree pane displays the applicable the Editor 
Pane. (Figure 2)

Figure 2  Example of Selecting the I/O Signals Tab
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Clicking “+” or “-” on a menu bar displays a list of items that can be dragged and dropped into the 
Editor Pane, or displays additional menus.

Figure 3  Example of Displaying Additional Menus

Hardware Interfaces
This section outlines the hardware editors used to configure Tally System Interface controllers (such 
as the TSI-4000) using the options in the Tally System Console.

Tally System Interface Units Editor
This editor is used to define the TSI tally controllers that are configured by Tally System Console. 
Each line of the editor defines one TSI tally controller unit. 

Each column provides a setting:

• Active — Selecting this box marks the given TSI to receive configuration information from the 
Tally System Console. Clearing this box omits the given TSI unit from receiving configuration 
information. This allows multiple TSI units to be selectively configured.

• TSI Name — Assigns the name of a TSI tally controller. The TSI Name is also referenced in editors 
under the Hardware tab to assign comm ports signal routers, production switcher, GPI hardware 
and control panels to particular TSIs. This name should help the user to understand the purpose 
of the controller within the broadcast plant. For example, a TSI used to service the Control Room 
1 area of the plant might be named “CR1”.

• Interface # — Each TSI unit is given a unique ID number between 1 and 56. The interface number 
is programmed into the TSI hardware. This number, rather than the “TSI Name”, is attached to 
various items of the configuration that are sent to the TSIs. Each TSI uses this number to decide 
which items of the configuration are relevant to it, and will use the number to ignore items in the 
configuration that are meant for other TSIs. For TSIs that are redundantly paired through an Ross 
Video Auto-Change-Over (ACO) unit this number is the same.

• IP Address — an IP address to which the Tally System Console will send configuration 
information. This IP address must match the IP address of a TSI in your system.

Comm Port Setup Editor
The comm ports of TSI tally controllers are used to obtain crosspoint status information from signal 
routing and signal devices, as well as GPI input information from parallel interface devices and 
control panels, and to send control data to UMDs, control panels, GPI output devices and router 
destinations. The comm ports of TSI tally controllers can be either serial ports (RS-232, RS-422 or 
RS-485) or a network connection, depending on the type of device being interfaced. (Figure 4)
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Figure 4  Example of the Comm Port Setup Editor

Clicking + or - on the Comm Port Setup toolbar opens a drop-down list of various categories of 
hardware which will be connected to a TSI controller via the TSI comm ports:

Production & M/C (Master Control) Switchers — Signal switching devices used to place broadcast 
signals on-air. These devices are usually interfaced using a serial connection. One or more of the 
signal outputs of these devices are monitored by the tally system primarily for the generation of 
on-air or next-to-air (signal state) indicators in UMDs or via GPI outputs. These switchers can be 
complex but have only one crosspoint level. Some signal outputs of these devices are capable of 
selecting multiple signal inputs. The primary information received from these devices is crosspoint 
status, although some of these devices also provide input name information. Crosspoint control 
data is not sent to these devices, although some of these devices will accept input name 
information. Refer to “Production and M/C Switchers” for more information.

Routers — Signal switching devices used to route signals to video monitors, production and master 
control switchers, and to other routing and other signal processing devices. These devices are 
simply blocks of crosspoints and are monitored for the purposes of (a) knowing when a signal has 
arrived indirectly at (i.e. has been routed to) the on-air or next-to-air output of a production or M/C 
switcher and (b) knowing what signal is present in a signal monitor serviced by an under-monitor 
display. Signal routers can select only one input on each output but can have multiple levels of 
crosspoints. The primary information received from these devices is crosspoint status, although 
some routers also provide input name information for use in UMDs. Crosspoint control data can be 
sent to these devices. Transmission of name information to most of these devices is not supported 
by the TSI tally controller. Refer to “Routers” for more information.

Displays — Under-monitor text displays, usually also capable of color or graphic effects used to 
indicate the on-air or next-to-air state of a signal. Display communication is unidirectional (to the 
display only), except perhaps for communications handshaking. Depending on the type of display 
the type of information sent to a display can include text, color, font, and tally flags (for signal state 
indicators).

Parallel Interface Ports — Parallel interface devices, also called General Purpose Interface (GPI) 
devices, receive and execute relay closure commands received via a serial line or a network 
connection. These remotely-controlled relays are often referred to as General Purpose Interface 
Outputs, which is often shortened to the misnomer acronym GPOs. Parallel interface devices can 
also sense the state of relay closures or voltage sources and transfer this information to the tally 
controller over the same serial line or network connection. These parallel inputs are General 
Purpose Interface Inputs, again often misnamed as GPIs. In Ross tally systems, GPI inputs and GPI 
outputs are assigned numbered addresses in order to easily identify each input or output. Because 
control panels are treated as collections of GPI inputs (button presses) and GPI outputs (LED 
indicators), they are also configured as parallel interface devices.

Device Configuration Interface
The Device Configuration interface displays to the right of the Editor Pane when accessing the 
Production & M/C Switchers, Routers, and Displays subheadings under the Comm Port Setup menu 
bar. Depending on which subheading is selected and the type of device, the Device Configuration 
interface will review additional serial and networking information about that particular port.
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Two different views of the Device Configuration interface depending on whether the device is an 
MVP or not:

Figure 5 shows the Device Configuration interface when any port belonging to a Switcher, Router, 
or non-MVP Display is selected. Entry points to enter the device's address, IP addresses (primary 
and/or secondary), and COM ports (primary and/or secondary) will be provided. Depending on the 
type of device that the port belongs to, only some fields may be accessible. An option to override 
the default comm settings is provided as well.

Figure 6 shows the Device Configuration interface when any port belonging to a Display that is 
represented by an Evertz MVP type is selected. An area to enter in a list of IP addresses for each 
output card is provided.

Figure 5  Any Device Port Figure 6  A MVP Device
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Getting Started
This chapter outlines how to add connections to the devices in your tally system to the Tally System 
Console.

Adding Tally System Devices to the Tally System Console
This section provides a brief overview of how to add Ross tally devices to the Tally System Console.

To add the Ross tally system devices to the Tally System Console

1. Decide which TSI systems are to be configured. 

 All TSIs including redundant units should be listed.

2. Select Hardware > Tally System Interface Units to access the TSI system table. 

3. Enter the Name, Interface Number, and IP address for each TSI system. 

 For TSIs that are redundantly paired through an Ross Video Auto-Changeover Unit (ACO), the 
Interface Number will be the same for the paired units but the IP addresses will be different.

4. Select the Active state box for each TSI that will configured. 

Only those TSI that have the box selected will be uploaded with the configuration.

Configuring a Connection to a Device
All devices that the TSI will be communicating with will need to be configured. The Comm Port 
Configuration page allows for specifying the device, how it connects (serial or ethernet), and where 
it connects (COM7, IP address). This section provides a general overview of adding devices to the 
Tally System Console. For details on adding specific devices, refer to the Ultricore-Tally Device 
Setup Guide.

To display the Comm Port Setup menus

1. Click + beside Hardware > Comm Port Setup to expand the list.

The following tabs are available:

• Production & M/C Switchers (comm configuration for switchers)
• Routers (comm configuration for routers)
• Displays (comm configuration for RDUs/monitor walls)
• Parallel Interface Ports (comm configuration for external GPI devices: 4211, TXI, RCP)

To configure a connection to a switcher

1. Select Hardware > Comm Port Setup > Routers. 

A table for specifying each switcher that a TSI will communicate with is displayed on the right.

2. Use the Port Name field to specify a unique name for the switcher. 

Typically these are kept short. SWR is commonly used to represent a switcher.

3. Use the TSI Tally Controller Unit field to specify the TSI system that communicates with the 
switcher.

4. Use the Protocol field to specify the communication protocol the switcher uses.
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5. Change the communication settings for this port using the Device Configuration dialog.

• If connecting via ethernet, use the TCP/IP options to define the switcher connection.
• If connecting via serial, use the COM Port options to define the switcher connection.

To configure a connection to a router

1. Select Hardware > Comm Port Setup > Routers. 

A table for entering the routers that a TSI will communicate with is displayed on the right.

2. Use the Port Name field to specify a unique name for router port(s). 

Typically these are kept short. RTR is commonly used to represent a router.

3. Use the TSI Tally Controller Unit field to specify the TSI system that communicates with the 
router.

4. Use the Level field to specify the router level. 

 To specify more than one router level, separate the levels with a comma. E.g. 1,2 or SD,HD

5. Use the Protocol field to specify the communication protocol the router uses.

6. Change the communication settings for this port using the Device Configuration dialog.

• If connecting via ethernet, use the TCP/IP options to define the router connection.
• If connecting via serial, use the COM Port options to define the router connection.

To configure a connection to a Display Port

1. Select Hardware > Comm Port Setup > Displays. 

A table for entering the display devices that a TSI will communicate with is displayed on the 
right.

2. Use the Port Name field to specify a unique name for display port(s). 

Typically these are kept short. 

3. Use the TSI Tally Controller Unit field to specify the TSI system that communicates with the 
display device.

4. If required, use the Group Name field to assign a short identifier for the applicable ports.

5. Use the Protocol field to specify the communication protocol the display device uses.

6. Change the communication settings for this port using the Device Configuration dialog.

• If connecting via ethernet, use the TCP/IP options to define the port connection.
• If connecting via serial, use the COM Port options to define the port connection.

To configuring the Parallel Interface Ports

1. Select Hardware > Comm Port Setup > Parallel Interface Ports.

A table for entering the parallel devices that a TSI will communicate with is displayed on the 
right.

2. Specify the name of the parallel device port(s).

3. Select the TSI system that will communicate with the device.

4. Select the type of device - either a 4211 unit, TXI unit, or an RCP. 

 For a TXI unit running in Serial mode, this type should be set to 4211.

5. Assign the port that the device is connected to on the TSI. 

• For a TXI unit running in Serial mode, specify the corresponding COM port. 
• For a TXI unit running in Ethernet mode, specify TXI-Series.
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6. Assign a starting internal address at which the individual inputs/outputs of the port can be 
accessed. 

For example, in a 4211 unit with 40 GPI inputs, assigning a starting address of 400, then inputs # 
1-40 are addressed at address 400-439 respectively. 

 Selected addresses should be divisible by 8 and should not overlap the addresses for other ports.

Defining the Destinations
This section outlines how to define any production or master control switcher signal outputs or 
router outputs that will be tallied by the TSI system. For example, these could be production 
switcher program and preset (preview) buses, master control on-air buses, or router ISO-record 
destinations (EVS, VCR, etc...) for each control room

To define the destinations in the Tally System Console

1. Select I/O and Signals > Destination Definitions.

2. Locate the outputs that will be tallied by the TSI system. 

 It is possible that these outputs might have been automatically set up when the switcher/router 
ports were first configured.

3. Enter a name for each destination. 

 For the Output Device and Output Device IO, specify the output on the switcher/router that this 
destination represents.

Creating Tally Areas
A tally area is a representation of a single control room. In a broadcast facility, there may be one or 
more control rooms where each control room has its own production switcher. For example, 
control room CR1 could be using a Sony switcher, CR2 could be using a Grass Valley switcher, and 
CR3 could be using a Ross switcher. Each switcher has its own program/preset bus so the TSI 
system must know exactly which switcher outputs to look at for on-air and next-to-air sources 
within EACH control room. The Tally Area table lets you define what the outputs should be for each 
individual control room.

Individual tally areas are created indicating which destinations are to be tallied by the TSI. Each tally 
area will typically have the following 2 or more tally types: PGM (program bus outputs), PST (preset 
bus outputs), and/or EXT (external bus outputs).

 Although the tally types can be given other names (e.g. PROGRAM) this is not recommended 
because the default tally logic expressions provided in the Tally System Console are designed to 
use PGM/PST/EXT specifically. Not using the standard tally type names can cause the tally logic 
operations to fail. Tally types are case-sensitive so renaming to “pgm” is also not acceptable.

To create tally areas

1. Select Plant Layout > Tally Areas. 

2. Click + beside Tally Areas to expand the tree. 

The Single Control Room and Multiple Control Rooms nodes are displayed.

3. Select Multiple Control Rooms.

The Tally Areas - Multiple Control Room table displays.

 It is possible that default tally areas for your switchers may have already been created. If not, 
continue below.

4. Start by entering the names for each individual control room that you will tally. 



22 • Getting Started Tally System Console User Guide (v1-rev1)

As you enter in a control room name, it displays in the tree list on the left panel.

5. Select the newly created tally area in the tree list within the left window. 

This will display the tally types associated with this tally area.

6. Under the Tally Type column, create three entries: PGM, PST, and EXT. 

7. optional: Select the Destination field and assign the corresponding outputs for each of the 
entries in step 6.

The corresponding program/preview switcher outputs created in “Defining the Destinations” 
should be visible in the drop down.

 The Destination field can be kept blank if you do not want tallies for that particular tally type. 

8. To assign more than one destination to a tally type:

 This is useful in the case where you need to look at multiple outputs to determine if a source 
displays in any of them (e.g. ISO tally type where a source displays on more than one output).

a. Right-click the Destination column header. 

The column is highlighted in blue, and a dialog opens. 

b. Click Insert Column > Insert to the Right. 

A new column is inserted to the right of the selected Destination column.

Defining the Sources
This section outlines how to define signal sources that will feed the various router and switcher 
inputs, particularly those sources that feed multiple device inputs.

To define the sources in the Tally System Console

1. Select I/O and Signals > Source Definitions to edit the table of source definitions.

2. Enter a name for the source. This name is only used internally within the TSI.

For example, CAM01. 

 Although it is not required at this initial setup stage, the Short and Long Names can be assigned 
to the source. These names will be used by the dynamic UMD displays. Long Name will take 
precedence over the Short Name.

3. Specify the switcher and/or router inputs that the source will feed. 

 A source can also feed more than one input.

4. To specify an additional input:

a. Right-click the column heading for the source device.

The column is highlighted in blue and a dialog opens.

b. Click Insert Column > Insert to the Right. 

A new column is inserted to the right of the selected Source column.

 The field for the switcher/router inputs displays once the Comm Port Configuration for the 
devices is completed.

Defining the Display Devices
This section outlines how to configure your display devices and define how the source will be tallied 
and what will be displayed on the UMD (Monitoring Style). 
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For example, to tally a source that was entered in the Source Definitions table (“Defining the 
Sources”), select the Source monitoring style -- if a long name has been defined in the Source table, 
then it will be shown, otherwise the short name will be displayed. If Source table does not contain a 
long or short name, the crosspoint of the input will be shown. To force the use of the long name, 
the style Source Long could be used. To tally a source feeding a destination, choose the Destination 
monitoring style.

To define the display devices

1. Select UMDs > Display Devices.

2. Enter a name for the display unit.

3. Enter the port, serial #, and section # of the display (if possible).

4. To configure a display with more than one section, add another row into the table with the 
same name, port, serial # and select the desired section #.

 For RDU1500-series UMDs and VxV-4 series, the serial # will be the serial number of the display 
unit and the Section # will be 1-3 or 1-4 respectively for the two types.

 For other UMDs a serial number/ID (e.g. 1234) can be used (this number must match the UMD ID 
in the UMD system) and the Section # will be left at 1.

5. To define how the source will be tallied and what is displayed on the UMD:

a. Use the Monitoring Style menu to choose from the following:

 A Monitoring Style may require one or more parameters (see next step) to complete the tally logic 
for the UMD. 

• Source — Tally and show the source. Requires source/input parameter.
• Source Long — Tally and show the source long name. Requires source/input parameter.
• Source Short — Tally and show the source short name. Requires source/input parameter.
• Destination — Tally and show the source feeding a destination. Requires a 

destination/output parameter.
• Destination Long — Tally and show the source long name feeding a destination. Requires 

a destination/output parameter.
• Destination Short — Tally and show the source short name feeding a destination. Requires 

a destination/output parameter.
• Dest:Source — Tally and show the destination name and source feeding it. Displayed on 

UMD as destination:source. Requires a destination/output parameter.
• Show Name — No tally. Displays the internal UMD name for the TSI. No parameter 

required.
• Show ID — No tally. Displays the serial#/ID of the UMD. No parameter required.
• Show Text — No tally. Displays the text entered from the Text Override column. No 

parameter required.

b. Assign parameters to the Monitoring Description. 

 This may be required (depending on the Monitoring Style selected) to complete the monitoring 
logic.

 Parameters are assigned using drag-and-drops. Items visible in the left window tree-view are 
then dragged and dropped into the Monitoring Description area. 
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c. If the Monitoring Style requires a source or input parameter, any items under the following 
tables can be “dropped” into the Monitoring Description area:

• I/O and Signals > Source Definitions
• I/O and Signals > Input Definitions
• I/O and Signals > {Switcher Name SWR} - Input Names
• I/O and Signals > {Router Name RTR} - Input Names

d. If the Monitoring Style requires a destination or output parameter, any items under the 
following tables can be “dropped” into the description area:

• I/O and Signals > Destination Definitions
• I/O and Signals > {Switcher Name SWR} - Output Names
• I/O and Signals > {Router Name RTR} - Output Names

e. Decide which table you need to access that will have the required input or output item. 

f. Ensure the right-window table on Display Devices (UMDs) is selected.

g. Select the I/O and Signals tab in the left-window. 

h. Click + beside the table you need to access to expand the list of available items. 

The Display Devices (UMDs) table should still be visible in the right window.

i. Select an item from the left tree-view.

j. Drag-drop the item over to the corresponding Monitoring Description field.

k. After dragging the item into the Description area, the description updates accordingly.

6. Assign the Tally Area that the TSI will use to determine whether a source is on-air or next-to-air. 
The tally area(s) were created in “Creating Tally Areas”.

Configuring Parallel Interfaces
This section outlines how to define the GPI I/O devices in your Tally System Console.

To configure the parallel interfaces in the Tally System Console

1. Select GPIs > Parallel Interface Devices.

 A table of GPI I/O devices displays with 4211, TXI-Series, and RCP subheadings.

2. To set up a GPI I/O serial device or a 4211 device:

a. Select GPIs > Parallel Interface Devices > 4211. 

The Parallel Interface Device table displays in the right-window. 

b. Enter the name of the device. 

c. Assign the associated port (as defined in “Configuring Parallel Interfaces”). 

d. Set the size (# of inputs/outputs) of the device.

 The address position of the device will be automatically calculated.

3. To set up a GPI I/O ethernet device:

a. Select GPIs > Parallel Interface Devices > TXI Series.

The Parallel Interface Device table displays in the right-window. 

b. Enter the Name of the device.

c. Assign the associated port (as defined in “Configuring Parallel Interfaces”). 

d. Use the Type column to specify the type of device. 
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e. Enter the IP address of the device.

4. To set up a remote control panel (RCP):

a. Select GPIs > Parallel Interface Devices > RCP. 

The Remote Control Panels table displays in the right-window. 

b. Enter the Name of the RCP.

c. Assign the associated port (as defined in “Configuring Parallel Interfaces”). 

d. Enter the Serial # of the RCP. 

e. Set the RCP Size.

Defining GPI Outputs
This section outlines how to configure the GPI outputs of your parallel interface device(s). This 
requires you to provide a name, address, the number of outputs, and define how the GPI output(s) 
will be driven. For example, to drive camera tallies when a source goes on-air select the Source On 
Air monitoring style.

To define the GPI outputs

1. Select GPIs > GPI Outputs.

A list displays of the parallel interface devices that were defined in “Configuring Parallel 
Interfaces”. 

2. Select the parallel interface device subheading that you want to assign GPI outputs to. 

The GPI Outputs table for the selected device displays.

3. Enter a Name for the GPI output

4. Specify the Output Address (the output address is a zero-based number where address 0 
represents the first GPI output). 

5. Specify the number of outputs that this GPI output will drive (usually 1).

6. Use the Monitoring Style menu to define how the GPI output(s) will be driven. Choose from the 
following:

 A Monitoring Style may require one or more drag-and-drop parameters.

• Source On Air — Turn on GPI output if source is on-air. Requires source/input parameter.
• Destination On Air — Turn on GPI output if source on a destination is on-air. Requires 

destination/output parameter.
• Source Next to Air — Turn on GPI output if source is next-to-air. Requires source/input 

parameter.
• Destination Next to Air — Turn on GPI output if source on a destination is next-to-air. 

Requires a destination/output parameter.
• ON — Forces the GPI output to be on. No parameter required.
• OFF — Forces the GPI output to be off. No parameter required.
• Follow — The GPI output follow state of a GPI input. Requires GPI input parameter.

7. Assign parameters to the Monitoring Description. 

 This may be required (depending on the Monitoring Style selected) to complete the monitoring 
logic.

Parameters are assigned using drag-and-drops. Items visible in the left window tree-view are 
then dragged and dropped into the Monitoring Description area.
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8. If the Monitoring Style requires a source or input parameter, any items under the following 
tables can be “dropped” into the Monitoring Description area:

• I/O and Signals > Source Definitions
• I/O and Signals > Input Definitions
• I/O and Signals > {Switcher Name SWR} - Input Names
• I/O and Signal > {Router Name RTR} - Input Names

9. If the Monitoring Style requires a GPI input parameter, any items under the following tables 
can be “dropped” into the description area:

• GPIs >GPI Inputs >{Parallel Interface Device Name}

10. If the Monitoring Style requires a destination or output parameter, any items under the 
following tables can be “dropped” into the description area:

• I/O and Signals > Destination Definitions
• I/O and Signals > {Switcher Name SWR} - Output Names
• I/O and Signals > {Router Name RTR} - Output Names

11. To assign the drag-drop item to a Monitoring Description: 

a. Decide which table you need to access that will have the required input or output item. 

b. While keeping the right-window table on GPI Outputs, select the I/O and Signals tab (or GPIs 
tab if you are dragging GPI input items) in the left-window. 

c. Click + beside the table you need to access to expand the list of available items. 

The table for GPI Outputs should still be visible in the right-window. 

d. Select an item from the left tree-view.

e. Drag-drop it over to the corresponding Monitoring Description field.

12. After dragging the item, verify that the Monitoring Description field updates with the new 
information.

13. Assign the Tally Area that the TSI will use to determine whether a source is on-air or next-to-air. 

The tally area(s) were created in “Creating Tally Areas”. A tally area is not required for the ON, 
OFF, or GPI FOLLOW style.

Uploading to the TSI
Insertion of new entries in a table will usually require a full upload to the TSI(s).

To upload your settings to the actively selected TSIs

1. Select File > Update TSI Configuration to initiate the configuration upload to the actively 
selected TSIs. (You can also press CTRL+U.)

• The entire configuration will be validated for errors before being sent to the TSI. 
• A successful connection to the TSI will report Connection established to TSI System(s) at the 

bottom of the application.
• The Upload dialog opens.

2. Use the Upload dialog to monitor the upload.

3. Select File > Disconnect From TSI System(s) to disconnect from the TSIs once the upload has 
finished. (You can also press CTRL+D.)

After the TSI system(s) are updated, both the UMDs and GPI outputs begin to tally the assigned 
sources.
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To connect to the TSI without uploading any configuration data 

• Select File > Connect to TSI System(s). (You can also press CTRL+K.)
Staying connected (online) with a TSI will keep any defined virtual monitor walls updated. In 
addition, incremental modifications to the configuration such as name changes (e.g. short/long 
names in Source table) or raw control expression changes are applied immediately -- a full 
upload will not be required.
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Camera Control Panels
This chapter provides an overview of how to design camera delegation control panels that are used 
in systems with multiple control rooms where cameras need to be shared and managed between 
control rooms.

Overview
Each panel allows the user to assign each camera to a particular control room, such that only the 
assigned control room can generate a tally when it takes the camera to air. Control rooms not 
assigned to a given camera will not generate a camera tally when they take that camera to air.

Each panel can be set up with a number of camera buttons and a number of control room buttons. 
Pressing a control room button lights an LED on the control button and also lights up the buttons 
for the cameras assigned to the selected control room. Pressing camera buttons allows cameras to 
be assigned to or unassigned from the selected control room. Selecting a camera that is assigned to 
another control room automatically takes the camera away from its assigned control room and 
gives it to the newly assigned control room. Cameras may be assigned to one control room at a 
time.

Panels automatically track operations at other panels so that the current delegation state is visible 
at every panel in real time. This allows operators to be aware of camera assignments at all locations 
without having to coordinate with other personnel by phone or intercom.

A graphic RCP editor built into Tally System Console allows camera delegation RCPs to be easily 
created and laid out. Buttons styles (camera, control room, plus a Set button and a Clear button to 
respectively assign or un-assign all cameras for the selected control room) are placed by dragging 
the button style to the desired button position. Cameras and control rooms are then dragged to 
their respective positions to complete the panel. Included in the Tally System Console 2 release files 
is a demo configuration called RCP-CAM-DLG.TC2 which includes an example camera delegation 
application. It may be useful to open this configuration to view while following the procedures 
below.

Camera Delegation Panel Configuration
Depending on whether camera delegation panels are being added to an existing system, some of 
the steps outlined below may be skipped.

To include the Camera Delegation Setup Tools

1. Select Management > Configuration > Libraries.

2. Select RCP-CamDlg.Lib. 

This file contains the default logic for a typical camera delegation system. 

3. Click OK.

4. Select File > New.

This will clear the current configuration from TC2 and include the Camera Delegation setup 
tools from RCP-CamDlg.Lib.

5. If an existing configuration needs to be included:

a. Select File > Merge.

b. Open the existing configuration file. 

c. Click OK.
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6. If an existing configuration is not merged:

a. Select Hardware > Tally System Interface Units 

b. Add a TSI to the configuration. Refer to “To add the Ross tally system devices to the Tally 
System Console” for details.

c. Select File > Save.

To add Production Switchers and Camera Signals

1. Add production switchers. Refer to “To configure a connection to a switcher” if some are not 
already defined from an existing configuration.

2. Select I/O and Signals > Source Definitions.

3. Add the required camera sources.

4. In the Source Definitions, locate the column corresponding to each of the production 
switchers defined above. 

5. In these columns, add the physical number of each switcher input fed by a camera.

To add Tally Areas

1. Select Tally Areas > Multiple Control Rooms.

2. Locate the Tally Area Name fields.

3. Add a name for each control room. 

4. Select Plant Layout > Tally Areas.

5. Select the Multiple Control Rooms + icon. 

6. Select the menu bar for one of the new control room entries.

The Tally Area Editor opens.

7. Under Tally Type, add a new line called PGM and a new line called PST.

8. For the PGM tally type, select the switcher program bus for the given control room.

9. For the PST tally type, select the switcher preset bus for the given control room.

10. Repeat steps 6 to 9 for additional control rooms.

To create Remote Control Panels

1. To add an RCP serial interface port:

a. Select Hardware > Comm Port Setup > Parallel Interface Ports.

b. Refer to “Configuring Parallel Interfaces” for more information.

2. To add RCP-20 or RCP-40 control panels to the configuration:

a. Select GPIs > Parallel Interface Devices.

b. Refer to “To configure the parallel interfaces in the Tally System Console”for more 
information.

3. For each RCP:

a. Edit the serial number column to correspond to the serial number on the back panel of the 
RCP-20 or RCP-40s. 

b. Omit any leading zeros in the serial numbers.

4. For RCP-20 (20-button) panels, set the Size column to 20. 

5. For RCP-40 (40-button) panels, set the Size column to 40.
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To create a Remote Control Panels Editor

1. Select Plant Layout > Remote Control Panels.

2. Enter a title for the RCP layout under the Name column.

3. Click View.

4. Select GPIs > Parallel Interface Devices 

5. Click the + icon on the RCP menu bar. 

A list of RCPs displays.

6. Drag the RCP(s) from the RCP list to the Remote Control Panel editing area.

To lay Out the Remote Control Panels

1. Select Plant Layout > Remote Control Panels.

2. Enter a title for the RCP layout under the Name column.

3. Click View.

4. Select GPIs > Parallel Interface Devices.

5. Click the + icon of the RCP menu bar. 

A list of RCPs displays.

6. Drag the RCP(s) from the RCP list to the Remote Control Panel editing area.

7. Select the Tally Logic tab.

8. Click the + icon on the LED Control Expressions menu bar. 

This allows the creation of different types of buttons on the control panels (see table below).

9. Drag the different monitoring styles to various buttons in order to create the panel layout. 

Multiple buttons may be selected using the mouse, causing the selected buttons to be 
highlighted, after which a monitoring can be assigned to all of the highlighted buttons with a 
single drag-and-drop.

10. Select the I/O and Signals tab.

11. Click the + icon on the Source Definitions menu bar.

12. Drag the camera sources to the buttons with CAM_BUTTON monitoring styles. 

Multiple buttons may be selected using the mouse, causing the selected buttons to be 
highlighted, after which multiple camera sources can be assigned with a single drag-and-drop. 
In this case, a list of options for this operation is automatically displayed when the camera 
source is dropped.

13. Select Assign single item to each button in the selection.

14. Select Plant Layout > Tally Areas.

15. Click the + icon on the Multiple Control Rooms menu bar. 

A list of control rooms (Tally Areas) displays.

16. Drag control rooms to buttons with CR_BUTTON monitoring styles. 

Refer to “To add Tally Areas” for details on how tally areas are added to the configuration).
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Camera Delegation Button Types
Table 1 provides a summary of the button types and their function.

Add Delegated Camera Tally GPI Outputs
This section outlines how to drive camera tallies using a parallel interface.

Before proceeding, ensure that a parallel interface port and a TXI-series or 4211-series parallel 
interface unit were added to the configuration.If this has not already been done:

• Add a parallel interface port at Hardware > Comm Port Setup > Parallel Interface Ports. 
› For a serial interface, select 4211 from the Type column. 
› For an ethernet interface, select TXI-Series from the Type column. 

• Refer to “Configuring Parallel Interfaces” for more information.

Table 1  Camera Button Styles

Monitoring Style Description
DLG_CR_BUTTON This button type will be assigned to control rooms (called “tally 

areas” within Tally System Console2) and will allow the operator to 
select the “current control room”, i.e. the control room for which 
cameras will be assigned and un-assigned as camera buttons are 
pressed. 
Pressing a control room button will cause camera buttons assigned 
to this control room to light. 

DLG_ALL_BUTTON This button type allows the operator to assign cameras to “all 
control rooms”. Cameras assigned to all control rooms and 
selected on the program bus of any control room will tally. 
Pressing this button will cause camera buttons assigned to all 
control rooms to light.

DLG_CAM_BUTTON This button type will be assigned to cameras, and will allow the 
operator to select the cameras that will be assigned to the currently 
selected control room

DLG_SET_BUTTON This button type allows the operator to assign all cameras to the 
currently selected control room with one button press.

DLG_CLR_BUTTON This button type allows the operator to clear all camera 
assignments from the currently selected control room with one 
button press.

DLG_PGM_BUTTON This button type allows the operator to enter Programming Mode 
of an RCP Macro button. 
Once in programming mode, pressing the RCP Macro button 
selects the macro button for programming. Cameras can then be 
selected and assigned to the macro button while in programming 
mode.

DLG_MACRO_BUTTON This button type allows the operator to recall all cameras that were 
assigned to the macro button. If RCP panel is in “Programming 
Mode”, pressing the macro button selects the macro button for use 
with camera assignments. (currently not supported).

DLG_LOCK_BUTTON This button type allows the operator to disable/enable the panel.
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To add delegated camera tally GPI outputs

1. Add an entry in GPIs > Parallel Interface Devices > 4211 for each TXI-series or 4211-series 
parallel interface unit. Refer to “To configure the parallel interfaces in the Tally System 
Console” for more information.

2. Add GPI outputs in GPIs > GPI Outputs by selecting the name of the parallel interface created in 
the previous step. Refer to “To define the GPI outputs” for more information.

3. To assign the Monitoring Style for each GPI output, select Delegated Source from the drop 
down box in the Monitoring Style column of the GPI Outputs editor.

4. To assign a camera source to one of the GPI outputs:

a. Select I/O and Signals.

b. Click the + icon on the Source Definitions menu bar. 

c. Drag a camera source from the source list to the Monitoring Description column of the 
desired GPI output.
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Production and M/C Switchers
This chapter provides additional information when assigning ports of a TSI which will be used to 
communicate with a production or master control switcher.

General Setup
1. Select Hardware > Comm Port Setup > Production & M/C Switchers.

 Each line in this interface defines one switcher device.

2. Enter a Port Name for the switcher.

For production and master control switchers, the port name is also the device name. This 
unique name is referenced in other parts of the configuration in order to assign devices to a 
particular tally controller comm port. The name is arbitrarily assigned by the user. The name 
should be descriptive but short (e.g. SWR, RTR, CR1, etc.). Use of spaces in this name is 
discouraged.

3. Use the TSI Tally Controller Unit menu to select the TSI system to which the switcher will be 
wired or networked. 

This drop-down list is taken from the list of TSI controller names entered under Hardware > 
Tally System Interface Units. This choice assigns the TSI which will service the production or 
master control switcher.

4. Select the Protocol.

This specifies the communication protocol which will be used to communicate with the 
production or master control switcher. The protocol depends on the type of switcher or can 
depend on a protocol selected in the switcher engineering setup. 

 If Virtual Switcher is selected, no serial port or network port is assigned and crosspoint 
information for this virtual switcher device can programmed to simulate crosspoint data from 
GPI inputs or from crosspoint data from other router or switcher devices

5. In the Device Configuration dialog, select the TSI serial port to which the switcher will be wired, 
or enter the IP address of the switcher. 

• This dialog is used to set the communications particulars of a comm port. 
• Various fields of this dialog box are grayed or not depending on the protocol selected. 
• For serial ports, the Primary COM port is selected depending on the physical port of the 

controller wired to the switcher device. 
› These ports can be any of COM2 (RS-232), COM3 through COM6 (RS-422 using RJ-11 or 

RJ-12 connectors), or COM8 through COM12 (RS-422 or RS-485, using DB-9 connectors). 
› COM7 is generally reserved for parallel interface ports. 

• The Secondary COM port field is selected in a similar way but will be editable only for a few 
different protocols for which two serial ports might be useful. 

• The Override Comm Settings fields will display the commonly-used default serial parameter 
settings for the chosen protocol, but this value can be altered by checking Override Comm 
Settings and altering the Baud Rate, Data Bits, Parity and Stop Bits settings. 

• These values must be matched in the connected device. 
• The IP Address #1 and #2 fields are not usually used for Production or Master Control 

Switchers.
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 For serial ports the default comm settings (baud rate, data bits, parity bits and stop bits) can 
usually be accepted, but can be modified by selecting the Override Comm Settings box. It is rare 
for any comm setting other than the baud rate to be modified.

6. If you are using a Philips MPK-port-based device, use the Device Address (hex) field to match a 
number programmed into the engineering setup at the switcher end.
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Routers
This chapter provides additional information to assign the serial port or network connection of a TSI 
which will be used to communicate with a router. 

General Setup
1. Select Hardware > Comm Port Setup > Routers. 

 Each line in this editor defines one router device.

2. Enter a Port Name for the router. Note that for routers, the port name is also the device name.

The Port Name is unique and is referenced in other parts of the configuration in order to assign 
router devices to a particular tally controller comm port. The name is arbitrarily assigned by the 
user. The name should be descriptive but short (e.g. SWR, RTR, CR1, etc.). Use of spaces in this 
name is discouraged.

3. Use the TSI Tally Controller Unit menu to select the TSI system to which the router will be 
wired or networked.

The TSI Tally Controller Unit list is taken from the list of TSI controller names entered under 
Hardware > Tally System Interface Units. This choice assigns the TSI which will service the router

4. Select the router Protocol.

• The Protocol menu specifies the communication protocol which will be used to communicate 
with the router. 

• The protocol depends on the type of router or can depend on a protocol selected in the 
router engineering setup. 

• If Virtual Router is selected, no serial port or network port is assigned and crosspoint 
information for this virtual router device can programmed to simulate crosspoint data from 
GPI inputs or from crosspoint data from other router or router devices.

5. In the Level column, enter a level number, or multiple levels separated by commas. 

• Levels are usually numbered starting from 1.
• This designates the router level or levels to be monitored by the tally system. 
• Multiple level numbers are separated by commas. 
• In other editors of Tally System Console new columns are added for each level added to this 

field.

6. In the Device Configuration dialog, select the TSI serial port to which the router will be wired, 
or enter the IP address of the router. 

• For serial ports, the default comm settings (baud rate, data bits, parity bits and stop bits) can 
usually be accepted, but can be modified by checking the Override Comm Settings box. It is 
rare for any comm setting other than the baud rate to be modified.

• Various fields of this dialog box are editable or not depending on the protocol selected. 
• For serial ports, the Primary COM port is selected depending on the physical port of the 

controller wired to the router device. These ports can be any of COM2 (RS-232), COM3 
through COM6 (RS-422 using RJ-11 or RJ-12 connectors), or COM8 through COM12 (RS-422 or 
RS-485, using DB-9 connectors). COM7 is generally reserved for parallel interface ports. 

• The Secondary COM port field is selected in a similar way but will be editable only for a few 
different protocols for which two serial ports might be useful. 

• The Override Comm Settings fields display the commonly-used default serial parameter 
settings for the chosen protocol, but this value can be altered by checking Override Comm 
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Settings and altering the Baud Rate, Data Bits, Parity and Stop Bits settings. These values 
must be matched in the connected device. 

• The IP Address #1 and #2 fields are not usually used for routers. 
• The Device Address (hex) field is not used for any routers at this time.
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Displays
This chapter outlines how to assign the serial port or network connection of a TSI which will be used 
to communicate with one or more under-monitor displays.

General Setup
1. Select Hardware > Comm Port Setup > Displays.

 Each line in this interface defines one under-monitor display port.

2. Enter a Port Name.

• This unique name is referenced in other parts of the configuration in order to assign display 
devices to a particular tally controller comm port. 

• The name should be descriptive but short (e.g. UMD1, CR1-UMD, etc.). 
• Use of spaces in this name is discouraged.

3. Use the TSI Tally Controller Unit menu to select the TSI system to which the displays on the 
port will be wired or networked.

• The TSI Tally Controller Unit list is taken from the list of TSI controller names entered under 
Hardware > Tally System Interface Units. 

• This selection assigns the TSI which will service the displays. 

4. Select the display Protocol.

• The Protocol menu selects the communication protocol which will be used to communicate 
with the displays. 

• The protocol depends on the type of display or can depend on a protocol selected in the 
display engineering setup.

5. Use the Group Name (VIP) field when interfacing a TSI within a large system where more than 
2048 displays (2048 being the maximum number of VIP protocol IDs in one VIP group) need to 
be supported within a single TSI unit. 

• It allows groups of VIPs to be formed for the purpose of setting ranges of protocol IDs. 
• If no VIP group is specified, then a single group is automatically set up within the TSI.

6. In the Device Configuration dialog, select the TSI serial port to which the displays will be wired, 
or enter the IP address of the display hardware. 

• Some display hardware may have more than one IP address in the Port Configuration Panel. 
Fill in this information as required. 

• For serial ports, the default comm settings (baud rate, data bits, parity bits and stop bits) can 
usually be accepted, but can be modified by checking the Override Comm Settings box. It is 
rare for any comm setting other than the baud rate to be modified. 

• The Device Configuration dialog is used to set the communications particulars of a comm 
port. Various fields of this dialog box are editable or not depending on the protocol selected. 

• For serial ports, the Primary COM port is selected depending on the physical port of the 
controller wired to the display device. These ports can be any of COM2 (RS-232), COM3 
through COM6 (RS-422 using RJ11or RJ-12 connectors), or COM8 through COM12 (RS-422 or 
RS-485, using DB-9 connectors). COM7 is generally reserved for parallel interface ports. 

• The Override Comm Settings fields will display the commonly used default serial parameter 
settings for the chosen protocol, but this value can be altered by checking Override Comm 
Settings and altering the Baud Rate, Data Bits, Parity and Stop Bits settings. These values 
must be matched in the connected device. 
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UMDs
This chapter provides additional information when assigning a UMD port.

General Setup
For each UMD in your system:

1. Before any UMDs are programmed, assign a UMD port from the Menu Tree pane's Hardware > 
Comm Port Setup > Displays editor. 

2. Create signal sources and destinations in the Menu Tree pane's I/O and Signals > Sources and 
I/O and Signals > Destinations editors.

 Each line in this interface defines one UMD display.

3. Enter a UMD Device Name.

• This unique name is referenced in the Plant Layout > Monitor Walls editor in order to assign a 
UMD to a position within a monitor wall. 

• This name is also used within the TSI to find and identify UMDs so the name should be 
meaningful but terse.

4. Select the UMD Device Port.

• The Device Port is the name of a port defined in Comm Port Setup – Displays. 
• For serial displays, this defines the port to which this UMD should be connected. 
• For displays over an Ethernet connection, this port defines one or more IP addresses which 

will be used to update this display.

5. Assign an ID or Serial Number.

• The ID / Serial Number is a value used to identify a display, which usually must be matched in 
the display hardware setup. 

• For most Ross displays, this number is the serial number of the display. 
• For other systems, it is usually a number starting from 1 which identifies one of a set of 

UMDs.

6. Use the Section # field to identify parts of a display, typically dual, triple and quad split displays. 

• For Ross Video RDU1500 and RDU1100 displays, this number is valid in the 1-3 range (left, 
middle and right sections respectively). 

• For Ross Video VxV-4 series displays (which are quad splits) this number is valid in the 1-4 
range (top-left, top-right, bottom-left and bottom-right respectively). 

• For most other displays, this value is left at 1.

7. Select a Monitoring Style. 

• The items in this Monitoring Style list are defined in the Tally Logic > UMD Control 
Expressions editor. 

• Generally these items determine whether a display will monitor a signal input or signal 
output and the style of name that is shown for each type. 

• The text in UMDs given a source-based monitoring style will remain fixed unless the name of 
the source changes. 

• The text in UMDs given a destination-based (routed) monitoring style will automatically 
change as different sources are routed into the monitor. 

• Most of the monitoring styles also include an on-air indication of sorts, usually a text color 
change. 
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• The items in this list are fully customizable, however the predefined monitoring styles are 
suitable for most tally system applications.

 Some Monitoring Styles require additional information. The Monitoring Description field will 
show an incomplete description of the UMD operation (missing information is denoted within the 
description by an empty pair of '[]' square brackets). While other monitoring styles do not need 
any further information.

8. Verify that the Monitoring Description non-editable field reports a description for the 
currently selected Monitoring Style. 

• It is created along with the Monitoring Style in the Tally Logic > UMD Control Expressions 
editor. 

• This field also has a special role as the drag-and-drop target used to assign signal sources or 
destinations to the UMD. 

• Sources or destinations dragged from the menu tree pane into this field become part of the 
operation of the UMD, and the name of such sources or destinations are displayed as part of 
the Monitoring Description

9. For a Monitoring Description requiring additional information, this can be filled in by the 
following: 

a. Select the Menu Tree Pane's I/O and Signals.

b. Click the icon on either the Source Definitions or Destination Definitions menu bars to 
display a list of signal sources or destinations. 

 Do not click the menu bar itself, as this will switch the editor pane to a different editor.

10. Select an item from the Source Definitions or Destination Definitions heading. 

11. Drag one of these items to the Monitoring Description field of the UMD being programmed.

• The Monitoring Description field displays the operational description for the programmed 
UMD including the name of the assigned signal source or destination. 

• The UMD is now programmed for use.

 Double-clicking the Monitoring Description field shows a list of the item or items assigned to the 
UMD.

More than one UMD can be assigned with signal sources or destinations with one drag and drop 
by multi-selecting items from the menu tree (using Shift+left-click or CTRL+left-click) then 
selecting the “Assign a single parameter for each row” prompt.

 A thick vertical bar at the left side of the editor pane switches the editor between two sets of 
columns.

12. Use the Text Override field to determine if the current text contents of the display will be 
overridden.

• An non-blank entry in this field will override the current text contents of the display, allowing 
the operating to change the text contents of a UMD at will. 

• The text override entry affects only the text of one UMD and has no effect on source names. 
• The on-air tally capability of the display is not affected, nor are other text effects such as 

normal color, font, centering, etc. 
• Note that for routed monitors where the displayed source name normally changes as 

different sources are routed into the associated monitor, the text of an overridden UMD will 
remain fixed while the override is in place; in this case the text override needs to be removed 
manually to correct the display. Therefore text overrides are best used in source displays, in 
which the text is normally fixed. 

• Overrides of a destination display are most conveniently done where it is anticipated that the 
routing of the associated monitor will not change during a show. 
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• The text override can be removed by deleting the contents of this field.

13. Use the Tally Area menu to assign the UMD to a specific tally area. 

• A UMD assigned to a particular tally area will display the on-air indicator when the source that 
is displayed in the UMD is also present in the on-air output of the selected tally area control 
room.

• In the Plant Layout > Tally Areas > Multiple Control Rooms editor the various control rooms 
within a broadcast plant can be defined in terms of the signal destinations that are the on-air 
outputs of the control rooms. 

• A tally area is an area within the plant that services a control room and in which the UMDs are 
expected to reflect the on-air status of the signals that feed the control room. 

• The tally areas are normally named after their control rooms and the tally area names will 
display as options in this Tally Area drop-down list. 

14. Use the Location menu to specify the name of the monitor wall to which the UMD has been 
assigned in the Plant Layout > Monitor Wall editor.

15. Use the Raw Control field to determine if the operation of a UMD will be directly 
reprogrammed by typing Ross Video tally system embedded expressions, or text, or a mixture 
of both embedded expressions and text into this field. 

• Typed text without embedded expressions is displayed verbatim in the UMD. 
• Any text or embedded expressions typed into this field overrides the effects of all other fields 

on this editor row. 

 This is an advanced feature which should be used only with a full understanding of tally system 
programming.

16. Verify if the Raw Expression field displays the current programming of the UMD, which is a 
result of the Monitoring Style selection and any sources or destinations assigned to the UMD, or 
the result of any entry in the Raw Control field.



44 • UMDs Tally System Console User Guide (v1-rev1)



Tally System Console User Guide (v1-rev1) Parallel Interface Ports • 45

Parallel Interface Ports
This chapter provides additional information to assign the serial port or network connection of a TSI 
which will be used to communicate to receive and execute relay closure commands received via a 
serial line or a network connection.

General Setup
1. Select Hardware > Comm Port Setup > Parallel Interface Ports.

 Each line in this interface defines one parallel interface device port.

2. Enter a Port Name.

• This unique name is referenced in other parts of the configuration in order to assign GPI 
input / output devices to a particular tally controller comm port. 

• The name is arbitrarily assigned by the user. 
• The name should be descriptive but short (e.g. GPI1, CR1-GPIO, etc.). 
• Use of spaces in this name is discouraged.

3. Use the TSI Tally Controller Unit menu to select which the parallel interface devices on this 
port will be wired or networked.

• This drop-down list is taken from the list of TSI controller names entered under Hardware > 
Tally System Interface Units. 

• This choice assigns the TSI which will service the GPI input / output devices.

4. Use the Type menu to select the type of GPI input / output device that will reside on the port:

5. Select the Device Port. 

• This column is used to select the port on which the GPI devices will reside. 
• For 4211 and RCP devices these ports can be any of COM2 (RS-232), COM3 through COM6 

(RS-422 using RJ-11 or RJ-12 connectors), or COM7 through COM12 (RS-422 or RS-485, using 
DB-9 connectors). 

• This field is automatically set to “TXI-Series” if TXI-Series has been selected under the Type 
column (in this case a network rather than a serial connection is used). 

• There can be only one TXI-Series port.

6. Select the parallel interface device communications Protocol. 

7. Select the Comm Port that the parallel interface device is connected to on the TSI system. 

For TXI devices, the connection may be over Ethernet instead of over serial. In this case, a 
'TXI-Series' port is provided.

Table 2  List of Port Types

Port Type Description

4211 One or more Ross Video Model 4211 general-purpose interface units, 
or Ross Video TXI series GPI units operating in serial (4211) mode

TXI-Series One or more Ross Video TXI-series general-purpose interface units, 
operating in network mode. These devices communicate with the TSI 
over Ethernet.

RCP One or more Ross Video RCP-20 or RCP-40 remote control panels
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8. Enter in the Starting Address block for this device.

• For many systems, which have only one parallel interface port, this value can be set to 0. 
• This value must always be a multiple of 8. 
• For systems which have more than one parallel interface port (e.g. one 4211 port and one 

RCP port), one port address can be set to zero, and the other should be set to a value that 
allows room for the total number of GPI inputs or outputs that will be serviced by the 
lower-addressed port. For example if a parallel interface port addressed at zero supports 120 
GPI input or outputs, a second port could be addressed at a value of 120 or higher. Room 
should be left for future expansion. 

• The maximum value in this field is 4096. 
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GPIs and Parallel Interface 
Devices
This chapter outlines the steps for configuring one of three possible types of parallel interface 
devices: 4211 GPI units (serial connection), TXI-series GPI units (networked over Ethernet) and 
RCP-series generic control panels (serial connection).

4211 Editor
This editor is used to define Ross Video Model 4211 GPI units that can be used to provide relays 
closures and detect relay closures or control voltages from other equipment for tally processing 
purposes.

Each line in this editor defines one Model 4211 unit. 

Keep the following mind:

• Most 4211 units have an equal number of GPI inputs and GPI outputs, but if not, choose the 
larger of the two numbers to set the Size field. 

• Model 4211 units have DIP switches that need to be set. The DIP switch settings must be unique 
for a given Model 4211 port. To determine the DIP switch setting of each unit, take the field of this 
editor Address minus the port Address Block value from the Parallel Interface Ports editor, all 
divided by 8.

General Setup
1. Define a port of Type 4211 in the Hardware > Comm Port Setup > Parallel Interface Ports editor 

pane.

2. Select the Menu Tree pane's GPIs > Parallel Interface Devices > 4211 menu tab.

3. Enter the following to define the 4211 unit:

a. The Name of the unit. (e.g. STUDIO1 i used to tally cameras in Studio 1). This unique name is 
used in the GPIs > GPI Inputs and GPIs > GPI Outputs editors, where actual GPI inputs and 
outputs are defined.

b. The Port to which this unit will be connected.

c. The Size of the control panel (usually 40).

The unit is now defined.

4. Use the Device Port menu to assign the Model 4211 unit to the selected serial port.

• The Device Port list contains the names of Type-4211 ports created in the Hardware > Comm 
Port Setup > Parallel Interface Ports editing pane. 

• Each item in this list is associated with a serial port (COM2-COM12) in a particular TSI tally 
controller.

5. Use the Size field to determine the number of GPI inputs and outputs supported by this unit. 

 Sizes are in multiples of 8.

6. Verify that he Address field reports the GPI address for this unit. 

• The address is calculated from the Address Block value entered under the Hardware > Comm 
Port Setup > Parallel Interface Ports editing pane for the Device Port assigned to this unit, and 
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from the sizes of other Model 4211 assigned to the same port, in their order of appearance in 
this list. 

• This address is generally required by the operator only for advanced GPI programming.

Remote Control Panels (RCP)
This editor is used to define Ross Video RCP-series tally control panels that can programmed for 
various custom applications such as camera delegation.

Each line in this editor defines one RCP-series tally control panel.

General Setup
1. Define a port of Type RCP in the Hardware > Comm Port Setup > Parallel Interface Ports editor 

pane.

2. Select the Menu Tree pane's GPIs > Parallel Interface Devices > RCP menu bar.

3. Enter the Name of the unit. (e.g. STUDIO1 i used to tally cameras in Studio 1). 

This unique name is used in the GPIs > GPI Inputs and GPIs > GPI Outputs editing panes, where 
actual GPI inputs and outputs are defined.

4. Use the Device Port menu to assign the RCP-series control panel to the specified serial port.

• This drop-down list contains the names of Type-RCP ports created in the Hardware > Comm 
Port Setup > Parallel Interface Ports editing pane. 

• Each item in this list is associated with a serial port (COM2-COM12) in a particular TSI tally 
controller.

5. Use the Serial # field to enter the serial number of the control panel.

This is usually a five-digit number, and excluding any leading zeros. The number is visible on the 
back panel of the RCP unit.

6. Use the Size field to specify the number of buttons on the front of the unit, either 20 or 40.

7. Verify that the Address field reports a GPI address for this RCP. 

• The address is calculated from the Address Block value entered under the Hardware > Comm 
Port Setup > Parallel Interface Ports editing pane for the Device Port assigned to the RCP, and 
from the sizes of other control panels assigned to the same port, in their order of appearance 
in this list. 

• This address is generally required by the operator only for advanced GPI programming.

TXI-Series
This editor is used to define Ross Video TXI-Series GPI units that can be used to provide relays 
closures and detect relay closures from other equipment for tally processing purposes.

Each line in this editor defines one TXI-Series unit.

General Setup
1. Define a port of Type TXI-Series in the Hardware > Comm Port Setup > Parallel Interface Ports 

editor pane.

2. Select the Menu Tree pane's GPIs > Parallel Interface Devices > TXI-Series menu bar.

3. Enter the Name for this unit (e.g. STUDIO1 if used to tally cameras in Studio 1).
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This unique name is used in the GPIs >GPI Inputs and GPIs > GPI Outputs editing panes, where 
actual GPI inputs and outputs are defined.

4. Use the Device Port menu to select the network address for this unit.

• This drop-down list contains the names of Type-TXI-Series ports created in the Hardware > 
Comm Port Setup > Parallel Interface Ports editor. 

• Each item in this list is associated with a particular TSI. 

5. Use the Type menu to specify the model of TXI-Series unit, usually TXI-48 (48 GPI inputs and 
outputs) or TXI-80 (80 GPI inputs and outputs).

6. Verify that the Address field number reports a GPI address for this unit. 

• The address is calculated from the Address Block value entered under the Hardware > Comm 
Port Setup > Parallel Interface Ports editor for the Device Port assigned to this unit, and from 
the sizes of other TXI-Series assigned to the same port, in their order of appearance in this 
list. 

• This address is generally required by the operator only for advanced GPI programming.



50 • GPIs and Parallel Interface Devices Tally System Console User Guide (v1-rev1)



Tally System Console User Guide (v1-rev1) GPI Inputs and Outputs • 51

GPI Inputs and Outputs
This chapter outlines how to define the individual GPI outputs configured for each parallel interface 
device, and how to define the individual GPI outputs configured for each control panel.

Overview
Parallel interface devices, also called General Purpose Interface (GPI) devices, receive and execute 
relay closure commands received via a serial line or a network connection. These 
remotely-controlled relays are often referred to as General Purpose Interface Outputs, which is 
often shortened to the misnomer acronym GPOs. Parallel interface devices can also sense the state 
of relay closures or voltage sources and transfer this information to the tally controller over the 
same serial line or network connection. These parallel inputs are General Purpose Interface Inputs, 
again often misnamed as GPIs. In Ross tally systems, GPI inputs and GPI outputs are assigned 
numbered addresses in order to easily identify each input or output. Because control panels are 
treated as collections of GPI inputs (button presses) and GPI outputs (LED indicators), they are also 
configured as parallel interface devices.

GPI Inputs
Select GPIs > GPI Inputs to display a list of Parallel Interface Devices (as programmed in the GPIs > 
Parallel Interface Devices editors).

Figure 7  Example of the GPIs > Inputs

Selecting any of the menus under the GPI Inputs tab displays a list of the GPI inputs in the selected 
parallel interface device. One or more of these GPI inputs can be dragged into the Monitoring 
Description column of a UMD, GPI output, or Destination Definition editor in order to monitor GPI 
inputs.

GPI Outputs
Select GPIs > GPI Outputs to display a list of Parallel Interface Devices (as programmed in the GPIs > 
Parallel Interface Devices editors). Selecting any of the menus displays a list of the GPI outputs for 
the selected parallel interface device.
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Figure 8  Example of the GPIs > Outputs

TXI-Series/4211 Types GPI Outputs
This section outlines how to define the individual GPI outputs configured for each parallel interface 
device. The GPI outputs can be configured to trigger based on conditions set by the Monitoring 
Style.

General Setup
1. Use the GPI Output Name field to assign a unique name to identify the output in the TSI 

system. The name should be meaningful but terse.

2. Use the Output Address field to identify a GPI output with the parallel interface device. 

Numbering ranges from zero to one less than the number of outputs within the interface 
device. For example a TXI-80 parallel interface unit has 80 outputs; therefore the valid output 
addresses that can be entered into this field range from 0 to 79.

3. Specify the number of Outputs.

• A GPI output can consist of more than one physical GPI output. 
• Up to 64 outputs can be grouped in this way. 
• This number is usually set to 1.

4. Use the Monitoring Style field to determine whether a GPI will monitor a signal input, a signal 
output, a GPI input, or follow some other programming logic

• The items in this list are defined in the Tally Logic > GPI Control Expressions editor. 
• For signal inputs, the GPI output can be set when the signal input is determined to be on air 

or next-to-air. 
• For signal outputs, the GPI output can be set when the signal input selected by the signal 

destination is determined to be on air or next-to-air; thus the operation of the GPI output can 
be dynamic depending on signal routes. 

• The items in this list are fully customizable, however the predefined monitoring styles are 
suitable for most tally system applications.

5. Verify the Monitoring Description field reports the description for the currently selected 
Monitoring Style. 

• It is created along with the Monitoring Style in the Tally Logic > GPI Control Expressions 
editor. 
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• This field also has a special role as the drag-and-drop target used to assign signal sources or 
destinations to the GPI output. 

• Sources or destinations dragged from the menu tree pane into this field become part of the 
operation of the GPI output. 

• The name of such sources or destinations are displayed as part of the Monitoring 
Description.

6. Use the Tally Area field to assign the GPI output to a specific tally area. 

• A tally area is an area within the plant that services a control room and in which GPIs are 
expected to reflect the on-air status of the signals that feed the control room. 

• The tally areas are normally named after their control rooms and the tally area names display 
as options in this Tally Area drop-down list.

• The GPI will activate when the source that is displayed in the UMD is also present in the on-air 
output of the selected tally area control room.

• In the Plant Layout > Tally Areas > Multiple Control Rooms editor the various control rooms 
within a broadcast plant can be defined in terms of the signal destinations that are the on-air 
outputs of the control rooms. 

7. Use the Raw Control field to determine if the operation of a GPI output is directly 
re-programmed by typing tally system embedded expressions or numbers into this field. 

• Any text typed into this field overrides the effects of all other fields in this editor row. 
• This is an advanced feature which should be used only with a full understanding of tally 

system programming. 
• Typing “1” into the raw control field forces a GPI output of size 1 on. 
• Typing “0” into the raw control field forces the GPI output off.

8. Verify the Raw Expression field reports the current programming of the GPI output.

This is a result of the Monitoring Style selection and any sources or destinations assigned to the 
GPI output, or the result of any entry in the Raw Control field.

Control Panel LEDs
This section outlines how to define the individual GPI outputs configured for each control panel. 
The GPI outputs can be configured to trigger based on conditions set by the Monitoring Style.

General Setup
1. Use the LED Name field to enter a unique name that reflects the function of the panel key (e.g. 

CAM1, CR1, etc.).

2. Use the Panel LED # field to specify the number of LEDs within the panel, numbered from left 
to right and top to bottom on the control panel surface.

3. Use the # of LEDs field to select either 20 or 40 buttons.

4. Use the Monitoring Style field to determine whether an LED will monitor a GPI input or follow 
some other programming logic.

• This list is defined in the Tally Logic > LED Control Expressions editor. 
• The items in this list are fully customizable.

5. Verify that the Monitoring Description field reports a description for the currently selected 
Monitoring Style. 

• It is created along with the Monitoring Style in the Tally Logic > LED Control Expressions 
editor. 
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• This field also has a special role as the drag-and-drop target used to assign GP inputs to LED 
output. 

• GPI inputs dragged from the menu tree pane into this field become part of the operation of 
the GPI output. 

• The address of the assigned GPI inputs are displayed as part of the Monitoring Description.

6. Use the Tally Area field to assign the RCP LED to a specific tally area. 

• A tally area is an area within the plant that services a control room and in which GPIs are 
expected to reflect the on-air status of the signals that feed the control room. 

• The tally areas are normally named after their control rooms and the tally area names display 
as options in this list. 

• This LED will activate when the source is present in the on-air output of the selected tally area 
control room.

• In the Plant Layout > Tally Areas > Multiple Control Rooms editor the various control rooms 
within a broadcast plant can be defined in terms of the signal destinations that are the on-air 
outputs of the control rooms. 

7. Use the Raw Control field to determine if the operation of an LED will be directly 
reprogrammed by typing tally system embedded expressions or numbers into this field. 

• Any text typed into this field overrides the effects of all other fields in this editor row. 
• This is an advanced feature which should be used only with a full understanding of tally 

system programming. 
• Typing “1” into this field forces the LED on. 
• Typing “0” into this field forces the LED off.

8. Verify that the Raw Expression field reports the current programming of the LED which is a 
result of the Monitoring Style selection and any GPI inputs assigned to the LED or the result of 
any entry in the Raw Control field.
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I/O and Signals
This chapter outlines the I/O and Signals tab settings.

Signal Paths
The I/O and Signals tab defines the signals that feed and signals that are provided by Production 
Switchers and Signal Routers.

Signal paths describe signal connections (interconnects) between various routing and switching 
devices, as defined in the Comm Port Setup editors. The signal paths defined in the tally system 
configuration mimic the signal wiring of the broadcast plant. Each signal path (interconnect) has 
one origin and may feed one or more router or production switcher inputs. Each line in this editor 
defines one signal interconnect. The tally system collects crosspoint information from various signal 
routers, production switchers and master control switchers, tracing these crosspoints in order to 
know which signals have arrived at the on-air output or other monitoring points within the 
broadcast plant. However the tally system also needs to know where these signals might travel 
from one signal switching unit to another; providing this external signal path information is the role 
of the signal paths editor.

General Setup
Each column allows the user to specify one input to the router / switcher device. If a signal path 
connects to more than one input to the same router / switcher device, additional columns can be 
created manually by right-clicking the column and clicking on Insert Column. Column insertions 
should be kept to a minimum (i.e. the largest number of connections made to the same router / 
switcher device on the same signal path).

1. Select the I/O and Signals tab.

 Each line in this interface defines one signal path.

2. Use the Interconnect Name field to assign a unique name within the tally system controller to 
identify the interconnect. The name should be meaningful but terse.

3. Use the Signal Origin Device to assign the output of a specific device as the signal path origin.

This drop-down list allows the selection of one of the routers or switchers defined under 
Hardware >Comm Port Setup > Production & M/C Switchers or Hardware > Comm Port Setup > 
Routers. 

4. Use the Signal Origin field to type the name or number that denotes the output that feeds this 
signal path.

5. Use the [Router or Switcher] Inputs menu(s) to select the router or switcher device.

• There can be one or more of these columns in the editor, one for each router or switcher 
device defined under the Hardware > Comm Port Setup editors. 

• Each column header shows the name of one of these routers or production / master control 
switchers.

Source Definitions
A signal source, as the term is used in Tally System Console, is the originating and most upstream 
signal source, not fed by any other signal. Each source in this table is “virtual”, and is used to tie 
together a number of router and production switcher inputs that are fed by the same signal. In this 
way a signal source that arrives at some monitor or on-air output is treated as the same signal 
regardless of the signal route it takes to get there.
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When the source definition for a set of inputs is assigned to a UMD, the name of the source, or the 
Short Name or Long Name of the source is displayed, rather than the names of the router and 
production switcher inputs that make up the source definition. This is because the tally controller 
“traces through” the router and production switcher inputs of the source definition and stops at the 
apparent most upstream signal source, which is the virtual Source Definition. The router and 
production switcher inputs that are fed by a virtual source are called “signal ends”. It is possible and 
not uncommon to also to include single-end source definitions in the configuration for consistency.

General Setup
1. Select I/O and Signals > Source Definitions.

 Each line in this interface defines one source.

2. Use the Source Name field to assign a unique name to identify the source within the TSI. 

• The name should be meaningful but terse. 
• The use of spaces in this name is discouraged. 
• This name is displayed in UMDs if the Short Names and Long Names fields are left blank.

3. Use the Short Name field to enter a name that will be displayed in place of the Source Name. 
This depends on the programming of a UMD.

4. Use the Long Name field to enter a name that is displayed in place of the Source Name. This 
depends on the programming of a UMD.

5. Use the [Router or Switcher] Inputs fields to determine the router inputs, the master control 
switcher inputs or the production switcher inputs that are fed by this source. 

• These columns are “dynamic” in that the columns display in the editor as new router or 
switcher devices are entered in the Hardware > Comm Port Setup editors. 

• There is one column for each switcher device and for each router device level. 
• The form of name or number entered in this field depends on the protocol used to 

communicate with the device (the protocol is selected in Protocol column of the Hardware > 
Comm Port Setup > Routers editor or Hardware > Comm Port Setup > Production & M/C 
Switchers editor). 

• Generally for production or master control switchers, the primary inputs are numbered.
• In most production or master control switchers there are also a set of special inputs which 

are given names. Clicking on the empty field provides a popup list of these special named 
inputs. 

• For routers, in most protocols the inputs are simply numbered. A few router protocols use 
mnemonic names (e.g. CAM1, EVS-2, etc.) and these names must match the names specified 
in the router system configuration tables. The mnemonic names are usually the category / 
number combination entered at router control panels.

Destination Definitions
This editor is used to create a destination name alias for use within Tally System Console, and may 
also be used to program switch commands to control the inputs selected by the destination.

A “destination” or “output”, as the term in used in Tally System Console, is a signal exit from a signal 
router, a production switcher or a master control switcher. Such an output or destination can be 
assigned to a UMD or a GPI output in order generate on-air or next-to-air tally based on the state of 
the input selected by the destination. These destinations can optionally be given alias names which 
can be used within Tally System Console to make the assignments based on a name rather than the 
simple output number by which the outputs are often referenced.

Typically the destination definitions are created in this editor, then the named destinations can be 
dragged from the menu tree pane into some other editor such as the UMD editor, to be monitored 
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by the tally system. The Destination Name given the output is used only within Tally System Console 
and is not sent to the tally system and does not display in any UMDs. To change the names of 
outputs that display in UMDs use one of the I/O and Signals> [router or switcher] – Output Names 
editors.

General Setup
1. Select I/O and Signals > Destination Definitions.

 Each line in this interface defines one destination.

2. Use the Destination Name field to specify the name of router or switcher output used in other 
parts of Tally System Console. 

 This name is not sent to any TSI tally controller and does not display in any UMDs.

3. Use the Output Device field to select the router, production switcher or master control 
switcher for the destination being aliased.

4. Use the Output Device IO field to assign the specific destination which is being aliased by this 
entry. 

• The form of name or number entered in this field depends on the protocol used to 
communicate with the device (the protocol is selected in Protocol column the Hardware > 
Comm Port Setup > Routers editor or Hardware > Comm Port Setup > Production & M/C 
Switchers editor). 

• Generally for production or master control switchers, the destinations are named. If the 
switcher has a fixed set of destination names, clicking on this field will display a list of these 
names to select from.

• For routers, in most protocols the destinations are simply numbered. A few routers use 
mnemonic names (e.g. MON1, EVS-2, etc.) and these names must match the names specified 
in the router system configuration tables. The mnemonic names are usually the category / 
number combination entered at router control panels.

5. Use the Control Style field to determine whether the destination will switch based on a GPI 
input, the crosspoint status of another destination, or by manually dragging an input from the 
same router or switcher.

• This list is defined in the Tally Logic > Crosspoint Control Expressions editor. 
• The items in this list are fully customizable.

6. Verify that the Control Style Description field reports a valid description for the currently 
selected Control Style. 

• It is created along with the Control Style in the Tally Logic > Crosspoint Control Expressions 
editor. 

• This field also has a special role as the drag-and-drop target used to assign GPI inputs, some 
other router or switcher destination, or a router or switcher input to the destination; these 
items dragged from the menu tree pane into this field become part of the switching logic of 
the destination. 

• The name of the item dragged into this field is displayed as part of the Control Style 
Description.

7. Use the Raw Control field to determine if the operation of a router destination can be directly 
programmed by typing Ross Video tally system embedded expressions or names into this field. 

• Any text typed into this field overrides the effects of all other fields in this editor row. 
• This is an advanced feature which should be used only with a full understanding of tally 

system programming. 
• Text typed into this field is interpreted by the tally controller as the name of an input to which 

this destination will be switched.
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• Embedded expressions typed into this field are evaluated by the tally controller and the end 
result interpreted as the name of an router input (in the same router device and on the same 
level) to which this destination will be switched whenever the evaluated end result changes. 

 The name of the input must include the square-bracketed level suffix, and for numbered inputs 
the input number must contain three digits with leading zeros as necessary (e.g. 002[1]).

8. Verify that the Raw Expression field displays the current programming of the Destination, 
which is a result of the Control Style selection and any items dragged to the Control Style 
Description, unless it is the result of an entry in the Raw Control field.

Input Definitions
An “input” as the term in used in Tally System Console is a signal entry point into a signal router, a 
production switcher or a master control switcher. Such an input can be assigned to a UMD or a GPI 
output in order generate on-air or next-to-air tally based on the state of the input. These inputs can 
optionally be given alias names which can be used within Tally System Console to make the 
assignments based on a name rather than the simple input number by which the inputs are usually 
referenced. Typically the input definitions are created in this editor, then the named inputs can be 
dragged from the menu tree pane into some other editor such as the UMD editor in order to be 
monitored by the tally system. The same operation could also be performed by dragging the input 
from the menu tree pane's I/O and Signals >[router or switcher] – Input Names list, but (a) the 
names in this list are numeric and (b) the Monitoring Description for the UMD or GPI output would 
simply show a number rather than a user-friendly name. The Input Alias Name given the input is 
used only within Tally System Console and is not sent to the tally system and does not display in any 
UMDs. To change the names of the inputs that display in UMDs, use one of the I/O and Signals> 
[router or switcher] – Input Names editors.

General Setup
1. Select I/O and Signals > Input Definitions.

 Each line in this interface defines one input alias.

2. Use the Input Alias field to provide the name of router or switcher input used in other parts of 
Tally System Console. 

This name is not sent to any TSI tally controller and does not display in any UMDs.

3. Use the Input Device field to select the router, production switcher or master control switcher 
for the input being aliased.

4. Use the Input Device IO field to specify the input which is being aliased by this entry. 

• The form of name or number entered in this field depends on the protocol used to 
communicate with the device (the protocol is selected in Protocol column under the 
Hardware > Comm Port Setup > Routers editor or Hardware > Comm Port Setup > Production 
& M/C Switchers editor). 

• Generally for production or master control switchers, the primary inputs are numbered. In 
most production or master control switchers there are also a set of special inputs which are 
given names. If the switcher has a fixed set of input names, clicking on this field will provide a 
popup list of these names to select from.

• For routers, in most protocols the inputs are simply numbered. A few routers use mnemonic 
names (e.g. CAM1, EVS-2, etc.) and these names must match the names specified in the 
router system configuration tables. The mnemonic names are usually the category / number 
combination entered at router control panels. 
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Input Names for Routers/Switchers
The inputs of routers and production or master control switchers have protocol-mandated input 
names or numbers which are not necessarily useful or informative enough to be shown on a UMD, 
although these names will display in a UMD if no other alternative is available. These names tend to 
get replaced upon display because either (a) the input name is entered in the Input field of the I/O 
and Signals > Source Definitions editor, and the source definition for this input is used in UMDs 
instead of the input directly or (b) the input name is used directly in a UMD but the input has been 
given a “user-friendly” Long Name or Short name in this Input Names editor. Direct use of an input 
in UMDs is correct only if the input is fed by a signal source that feeds only the one router or 
production or master control switcher input; otherwise the source will be tallied differently 
depending on which of the various inputs fed by the source has arrived on air or at the monitoring 
point UMD. Except in very simple systems (for example one where all of the signal sources are 
wired into the productions switcher), using source definitions in UMDs, rather than inputs directly, 
is usually the better choice, in which case assigning Long Names and Short Names to inputs in this 
editor is unnecessary.

General Setup
1. Select I/O and Signals > Input Name.

 Each line in this interface defines one input name set.

A list displays that includes each router or switcher device that is created in:

• the Hardware > Comm Port Setup > Production & M/C Switchers or 
• the Hardware > Comm Port Setup > Routers editor. 

The name of the router or switcher is given as part of the title in the menu bar (e.g. “PCR1 – 
Input Names” or “PCR1 – Output Names”).

2. To override the name of the router or switcher input:

a. Enter the protocol-mandated Input Name or Input Number.

b. Enter a Long Name.

c. Enter a Short Name. 

The Long Name and Short Name are the names that will display in UMDs depending on how 
the UMDs are programmed and with the caveats described above.

3. Use the Priority field only if multi-source UMDs are needed and if important source names 
being in them are lost because many sources are displaying for the size of the UMDs.

4. Use the IO Name field to specify the name or number of the input which is being given 
UMD-displayable names. 

• The form of name or number entered in this field depends on the protocol used to 
communicate with the device (the protocol is selected in the Protocol column under 
Hardware > Comm Port Setup > Routers editor or Hardware > Comm Port Setup > Production 
& M/C Switchers editor). 

• Generally for production or master control switchers, the primary inputs are numbered. In 
most production or master control switchers there are also a set of special inputs which are 
named. 

• A few routers use mnemonic names (e.g. CAM1, EVS-2, etc.) and these names must match the 
names specified in the router system configuration tables. The mnemonic names are usually 
the category / number combination entered at router control panels.

5. Use the Short Name field to specify the name if the UMDs are programmed to show the Short 
Name. 
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This name will be used in place of the protocol mandated input name or number, whenever this 
input is displayed in the UMD.

6. Use the Long Name field to specify the name if the UMDs are programmed to show the Long 
Name in place of the protocol mandated input name or number, whenever this input is 
displayed in the UMD.

 Editing the Style A and Style B settings is optional (these can usually be left alone). 

7. Use the Style A menu to assign “Style A” to any one of the Primary Name (usually blank and not 
used), the Secondary Name (the protocol-mandated name or number), the Short Name, the 
Long Name or the style of Style B. 

• For the given input, UMDs programmed to use “Style A” will use the value of “Style A” to 
determine which name to display. 

• The Style A menu allows the name style to be changed for this input in all UMDs programmed 
to use Style A. 

• If no selection is made in this menu, the Long Name is assigned to Style A.

8. Use the Style B menu to assign “Style B” to any one of the Primary Name (usually blank and not 
used), the Secondary Name (the protocol-mandated name or number), the Short Name, the 
Long Name or the style of Style A. 

• For the given input, UMDs programmed to use “Style B” will use the value of “Style B” to 
determine which name to display. 

• The Style B menu allows the name style to be changed for this input in all UMDs programmed 
to use Style B. 

• If no selection is made in this menu, Style A is assigned to Style B.

9. Use the Input Type menu to specify whether the input is marked as a Reentry input. 

• Reentry — When the input as marked as re-entry, the input becomes the most upstream 
source and the TSI will stop tracing once it has reached this input. This is particularly useful if 
you want to specify exactly how many levels the TSI should trace before stopping. 

• Redirect — Redirects the tracing of the source name to come from a different source. The 
short name, long name, or both names can be redirected to lookup a different source by 
specifying which source to trace. Four drop-down options are available:
› None - No redirect performed 
› Short - Redirection only for Short Name
› Long - Redirection only for Long Name
› Both - Redirection for both Short and Long Name
When redirection is enabled, one or both of the Short/Long Name fields will gray-out. The 
grayed-out fields will be accepting a drag-and-dropped input. Select an input from the Input 
Definitions or resource device Input Names, and drag the names into the grayed-out fields.

10. Use the Priority field to specify an order-of-appearance priority inputs when they display in 
multi-source UMDs. 

• This allows “less important” inputs to be dropped from the display first if the display runs out 
of room to display all of the sources present at the monitoring point. 

• Without a priority setting, multi-source displays show the sources in alphabetical order. 
Multi-source displays are usually used to display the sources selected on program or preset 
buses. Note that such displays are usually programmed to use the Short Names rather than 
the Long Names to make more room for source names.
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Output Names for Routers/Switchers
The outputs of routers and production or master control switchers have protocol-mandated names 
or numbers which are not necessarily useful or informative enough to be shown on a UMD, 
although these names will display in a UMD if no other alternative is available. Output names are 
rarely displayed in UMDs, mainly to show the name of a monitoring destination in addition to the 
source selected by the destination. The Long Name and Short name assigned in this editor are 
useful for this kind of labeling.

General Setup
This editor displays under the I/O and Signals tab for each router or switcher device that is created 
in the Hardware > Comm Port Setup > Production & M/C Switchers or the Hardware > Comm Port 
Setup > Routers editor. The name of the router or switcher is given as part of the title in the menu 
bar (e.g. “PCR1 – Input Names” or “PCR1 – Output Names”).

To override the name of the router or switcher output, enter the protocol-mandated output name 
or number, and fill in a Long Name and Short Name. The Long Name and Short Name are the 
names that may display in UMDs, depending on how the UMDs are programmed. The Priority entry 
is not used for outputs.

1. Select I/O and Signals > Output Name.

 Each line in this interface defines one output name set.

2. Use the IO Name field to specify the name or number of the output which is being given 
UMD-displayable names. 

• The form of name or number entered in this field depends on the protocol used to 
communicate with the routing or switching device (the protocol is selected in Protocol 
column of the Hardware > Comm Port Setup > Routers editor or Hardware > Comm Port 
Setup > Production & M/C Switchers editor). Generally for production or master control 
switchers the outputs are named. 

• For routers, in most protocols, the outputs are simply numbered. A few routers use 
mnemonic names (e.g. CAM1, EVS-2, etc.) and these names must match the names specified 
in the router system configuration tables. The mnemonic names are usually the category / 
number combination entered at router control panels. At present the routers that use 
mnemonic names are Grass Valley SMS-7000 and Encore, Sony DVS-series routers (S-bus) 
Sony HKSP-R80 router interface (S-bus over IP), and Pesa TCP/IP-based router protocol 
(Perc2000 controller). All other routers use numbered outputs.

3. Use the Short Name field to enable UMDs programmed to show the Short Name to display the 
name entered in this field, in place of the protocol mandated output name or number, 
whenever this output is displayed in the UMD.

4. Use the Long Name field to enable UMDs programmed to show the Long Name will display the 
name entered in this field, in place of the protocol mandated output name or number, 
whenever this output is displayed in the UMD.

 Editing the Style A and Style B settings is optional (these can usually be left alone).

5. Use the Style A menu to allow “Style A” to be assigned as any one of the Primary Name (usually 
blank and not used), the Secondary Name (the protocol-mandated name or number), the Short 
Name, the Long Name or the style of Style B. 

• For the given output, UMDs programmed to use “Style A” will use the value of “Style A” to 
determine which name to display. 

• The Style A menu allows the name style to be changed for this output in all UMDs 
programmed to use Style A. 

• If no selection is made in this menu, the Long Name is assigned to Style A.
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6. Use the Style B to allow “Style B” to be assigned as any one of the Primary Name (usually blank 
and not used), the Secondary Name (the protocol-mandated name or number), the Short 
Name, the Long Name or the style of Style A. 

• For the given output, UMDs programmed to use “Style B” will use the value of “Style B” to 
determine which name to display. 

• The Style B menu allows the name style to be changed for this output in all UMDs 
programmed to use Style B. 

• If no selection is made in this drop-down Style A is assigned to Style B.

7. Use the Redirect menu to redirect the tracing of the source name to come from a different 
source. The short name, long name, or both names can be redirected to lookup a different 
source by specifying which source to trace. Four drop-down options are available:

• None — No redirect performed
• Short — Redirection only for Short Name
• Long — Redirection only for Long Name
• Both — Redirection for both Short and Long Name

8. When redirection is enabled, one or both of the Short/Long Name fields will gray-out. The 
grayed-out fields will be accepting a drag-and-dropped input. Select an input from the 
Destination Definitions or resource device Output Names, and drag the names into the 
grayed-out fields.

 The Priority menu is not used for outputs.
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Plant Layouts
This chapter discusses tally areas, Single Control Room and Multiple Control Room configurations.

Tally Areas
A tally area is an area within the plant that services a control room and in which GPIs and UMDs are 
expected to reflect various kinds of tally status (on air, next-to-air, iso-tally, etc.) for signals that feed 
the control room. The tally areas are normally named after their control rooms and the tally area 
names will display as options in the Tally Area drop-down list in the UMDs and GPI outputs editors. 
A GPI or UMD assigned to a particular tally area will indicate a tallied condition when the source that 
is associated with the GPI output or UMD displays in the appropriate output destinations.

Single Control Rooms
 Information on the use of Single Control Rooms is provided here to cover legacy systems. For 

newer systems, refer to “Multiple Control Rooms” which covers the case of both single and 
multiple control rooms.

Within a single tally area, a tally type is a collection of special router, production or master control 
switcher destinations (signal outputs), which require a tally to be generated for any source routed 
to any of the destinations in the collection. For example the program output of a production 
switcher could be listed in the destination list of a tally type called PGM. Any source displaying on 
the listed program bus would be considered “on program” (on air) and would trigger an on-air 
indicator in any UMD assigned to the tally area and display the source. Typically each tally type for a 
given tally area will have a distinct tally indicator in UMDs and GPI outputs. For example, amber and 
red colors might be used in UMDs to indicate on-air and next-to-air sources respectively, while red 
and green lamps might be used to tally cameras on-air or on ISO-record respectively.

 In single control rooms, only two predefined tally types, PGM and PST, are available for each Tally 
Area.

Requirements
If the tally system console was not already installed for use with Single Control Rooms, the Single 
Control Room Configuration Library should be activated as follows:

a. Select Management > Configuration > Libraries. 

b. Ensure that Single Control Room Configuration Library is selected.

c. Click OK. 

d. Click File > New to clear the configuration.

The signal switcher or routers that will place signals on air must then be created under the 
Hardware > Comm Port Setup > Production & M/C Switchers editor or the Hardware > Comm Port 
Setup > Routers editor. 

Destination definitions then need to be created in the I/O and Signals > Destination Definitions 
editor for the program output, preset output, or any other outputs that will tallied (e.g. router 
outputs used for iso-recording, or a program bus from another control room for a secondary tally).

General Setup
1. For a single control system, two tally types are automatically predefined. 

• By default, the tally type names are PGM (Program) and PST (Preset). 
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• User defined tally type names can be created such as ISO (Iso-tally). 
• The default tally type names PGM and PST are fixed names required by the tally logic 

expressions.

2. Select Plant Layout > Single Control Rooms. 

3. In the editor pane, enter a name under Tally Area Name. 

A new entry for the tally area displays under the Single Control Room menu tab.

4. Select the new entry to display the tally area table in the editor pane.

5. Select a destination under the Destinations column for the PGM and PST tally types.

Choose from a list of special destinations deemed to require a tally indication for any source 
routed to the destination

6. If more than one destination will be used to tally a single tally type:

a. Right-click the Destination column.

b. Select Insert Column to insert a new column to the right of the selected column.

c. Select another Destination in the new column.

Multiple Control Rooms
Within a single tally area, a tally type is a collection of special router, production or master control 
switcher destinations (signal outputs), which require a tally to be generated for any source routed 
to any of the destinations in the collection. For example the program output of a production 
switcher could be listed in the destination list of a tally type called PGM. Any source displaying on 
the listed program bus would be considered “on program” (on air) and would trigger an on-air 
indicator in any UMD assigned to the tally area and display the source. Typically each tally type for a 
given tally area will have a distinct tally indicator in UMDs and GPI outputs. For example, amber and 
red colors might be used in UMDs to indicate on-air and next-to-air sources respectively, while red 
and green lamps might be used to tally cameras on-air or on iso-record respectively.

In multiple control systems, up to eight tally types can be created for each Tally Area. The default 
tally types, PGM, PST, and EXT are required by the tally logic expressions.

Requirements
The Multiple Control Room Configuration Library is activated (if the tally system console was not 
already installed for use with Multiple Control Rooms) as follows:

a. Select Management > Configuration > Libraries. 

b. Ensure that Tally Logic Library for UMDs, GPOs, and Crosspoint Control is selected.

c. Click OK. 

d. Select File > New to clear the configuration.

The signal switcher or routers that will place signals on air were created in the Hardware > Comm 
Port Setup > Production & M/C Switchers editor or the Hardware > Comm Port Setup > Routers 
editor. 

Destination definitions were created in the I/O and Signals > Destination Definitions editor for the 
program output, preset output, or any other outputs that will tallied (e.g. router outputs used for 
iso-recording, or a program bus from another control room for a secondary tally).

General Setup
 For a multiple control system, there are no predefined tally types. 
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1. Select Plant Layout > Multiple Control Rooms. 

2. Enter a name in the Tally Area Name field.

A new entry for the tally area displays on the Multiple Control Room menu tab.

3. Select the new entry to show the tally area table in the editor pane.

4. Specify a Tally Type name (up to eight different types allowed). 

• Typical tally type names are PGM (Program), PST (Preset), and EXT (External). 
• User defined tally types such as ISO (Iso-tally) can be created. 
• The default tally logic will use PGM, PST, and EXT tally types.

5. Select a corresponding destination under the Destinations column for that tally type.

The Destinations column lists the special destinations deemed to require a tally indication for 
any source routed to the destination.

6. If more than one destination will be used to tally a single tally type: 

a. Right-click the Destination column.

b. Select Insert Column Choose to add a column to the right of the selected column.

c. Select another destination in the new column.

Monitor Walls
Defines one or more monitor wall layouts. Each layout provides a graphical representation of the 
displays for a broadcast plant as well as real-time display status. The interface includes the 
following:

• Name — reports the name of the virtual monitor wall.
• Status — opens the virtual monitor wall.
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Remote Control Panel Layouts
This chapter outlines how to define one or more Remote Control Panel (RCP) layouts. Each layout 
provides a graphical representation of one or more RCP panel and the assigned function for each 
button.

RCP Button Groups
This editor is used to define individual groups for an RCP pane layout. A group contains a collection 
of buttons. A default style can be assigned to the group. As buttons are added into the group, they 
will take on the default style.

Buttons will inherit the group style. A button's local style (if one was previously assigned) will be 
preserved. Priority will go to the group style when the button is used in the RCP panel layout.

General Setup
1. Enter a unique name for the button group.

2. Assign a Monitoring Style for the group entry.

• The style that will be set for all buttons that are assigned into this group. 
• This is useful when, for example, a number of buttons are to be assigned as sources in the 

RCP panel. Rather than setting each button to the specified style, the button only needs to be 
added to the group to inherit the group style.

3. Use the Comments field to provide additional information to the tally system programmer or 
user.

RCP Button Group Properties
This editor is used to define the macros associated with each individual group. Buttons that are 
assigned to the group will have access to the macro using the <#macro> operator (see “Drag / Drop 
Parameters”).

An advantage to assigning specific macros to a group is that each group (and therefore any buttons 
that fall in that group) can behave differently from one another because their macro values differ.

For example: Suppose each group is assigned a generic style:

“<#Source-1> is on-air, <#Source-2> is off-air”

Group1's RCP Button Group Properties (macro / value):

Source-1 / CAM1

Source-2 / CAM2

Group2's RCP Button Group Properties (macro / value):

Source-1 / VHS1

Source-2 / VHS2

Group3's RCP Button Group Properties (macro / value):

Source-1 / SSTOR

Source-2 / ME1PGM
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Then all buttons in Group1 will be assigned with “CAM1 is on-air, CAM2 is off-air”. All buttons in 
Group2 will be assigned “VHS1 is on-air, VHS2 is off-air”. All buttons in Group3 will be assigned 
“SSTOR is on-air, ME1PGM is off-air”.

A button can only access the macros belonging to the group that it belongs in. In other words, if a 
button is assigned to Group1, it is unable to access <#Source-1> and <#Source-2> for Group2 or 
Group3's macros.

General Setup
1. Enter a unique name for the macro.

2. Enter the Value of the macro.

This is the value that will be shown when accessed via the <#macro> operator. 

3. Use the Comments field to provide additional information to the tally system programmer or 
user.
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Tally Maps
This chapter outlines how to define one or more tally map layouts. Each layout provides a graphical 
representation of assignments between inputs and outputs within a pin-grid matrix interface. You 
can assign a name to the tally map layout.

Tally Map Inputs
This editor is used to define the tally map inputs that will be used within a tally map layout. Once 
the inputs are added into this table, they will automatically display within the tally map layout 
screen.

General Setup
1. Enter a name for the tally map input.

More than one tally map input can have the same name ONLY if the Assigned Output Device 
Type is different. In other words, one tally map input can have up to 4 different behaviors 
depending on the tally map style -- as long as they all have the same tally map input name and 
different Output Device Type to distinguish between one another.

2. Assign a Control Style to the tally map input (an output device type should be selected 
automatically based on the control style).

• The style defines the behavior of the tally map input. 
• The tally map input feeds the tally map output with the information that should be displayed, 

but it is the output device that determines how/what gets displayed.
• The tally map input style selected should define what type of information will be sent to the 

output device.

3. Drag-and-drop any required objects into the Description field to complete the style.

4. Use the Assigned Output Device Type menu to select the output device type associated with 
the tally map input. 

• Each tally map input can select any of the 4 output device types: UMD Device, GPI Outputs, 
RCP LED Outputs, Output Control. 

• When a tally map assignment is applied in the pin-grid matrix, the output device will only be 
assigned to the tally map input with the matching Assigned Output Device Type.

5. Use the Raw Control field to quickly override the tally map input control style with a 
user-defined expression.
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Tally Logic
This chapter summarizes the UMD, GPI, LED control expression editors.

UMD/GPI/LED Control Expressions
These control expressions editors are used for custom and an advanced programming of UMDs, 
GPI outputs, and control panel LEDs. The predefined control expressions are appropriate for most 
common tally system applications.

Each line in this editor defines one control expression.

Interface Overview
1. Use the Style Name field to select the name of the control expression by which it is listed in the 

Monitoring Style column of the UMD GPI Output, LED, and Destination Definition editor. 

If the style contains drag-drop parameters then the control expression as it is used in the target 
device must be completed by dragging some additional information into the Monitoring Style 
column of the editor.

2. Use the Style Type field to indicate whether the style is a Tally Map Output style. 

• When the style is marked as a Tally Map Output style, the style name will display in the Tally 
Map Profile Settings. 

• Keep blank if the style is not a Tally Map Output style.

3. For UMDs and GPI outputs which have no monitoring style selected, the Default For setting is 
applied automatically if this type of drag-drop parameter is dragged into the target device. 

This allows UMDs to be created and assigned with drag-drop parameters without assigning a 
monitoring style.

4. Add the required Control Expression(s).

• Control expressions are a combination of text, embedded expressions and drag-drop 
parameters. 

• Embedded functions are predefined keywords followed by a set of parentheses which 
contain comma separated parameters (e.g. ADD(2,2)). 

• Embedded functions allow the output of a text-programmed device to change based on 
factors other than the content of the text itself. 

• Drag-drop parameters are place-holders into which information dragged into the Editor Pane 
is inserted in order to complete a control expression. 

• Drag-drop parameters typically contain items such signal sources, router or switcher inputs 
or outputs or GPI inputs. 

• Drag-drop parameters are angle-bracketed text surrounding a parameter name (e.g. <P1>, 
<P2>, etc.). 

• Repeated parameters receive the same drag-drop information. 
• Text inserted into a control expression that is neither an embedded expression nor a 

drag-drop parameter is sent to the TSI and displayed or evaluated verbatim. 

For More Information on...
• drag-drop parameters, refer to “Drag / Drop Parameters”.
• embedded functions, refer to “Embedded Functions”.
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5. Use the Tally Mapper Optional Control Expression to determine what expression is used by 
the Tally Map Input table when the style is selected. 

• If no expression is found in the Tally Mapper Optional Control Expression field, the regular 
control expression will be used. 

• All other tables other than the Tally Map Input table will use the regular control expression.

6. Use the Description field to provide a description of the control expression purpose or logic for 
the user. 

• This text displays in the Monitoring Description column, and allows the author of the control 
expression.

• Drag-drop parameters in the control expression should also be appropriately included in the 
description – in this case the name of the dragged-in parameter will be included in the control 
description.

7. Use the Tally Mapper Input Label field to provide alternate text that can be shown for the 
Input side of a tally map layout. 

• This field can include the same angle-bracketed place-holders used in the Control Expression 
and Description fields described above. 

• The inputs belonging to the tally map layout must be set by the user to use the Tally Mapper 
Input Label expression rather than the standard “Input Name” (refer to “Changing Tally Map 
Axis Labels”).

8. Use the RCP Button Label field to specify the text that display in button images in the Remote 
Control Panel Layout editor. 

• A button assigned with style from the LED Control Expressions will show text from this field in 
button image the Layout Editor. 

• This field can include the same angle-bracketed place-holders used in the Control Expression 
and Description fields described above.

9. Use the Comment field to provide additional information to tally system programmer or user.

Crosspoint Control Expressions
This control expression editor is used for custom and advanced programming of switching logic for 
router destinations. The predefined control expressions are appropriate for most common tally 
system applications. Expressions created in this editor and assigned to a router destination in the 
editor pane's I/O and Signals > Destination Definitions editor, possibly along with some 
drag-and-drop parameters, allow router destination switching commands to sent to a router. For 
example, a router destination that monitors cameras can be switched between cameras by reading 
closures from the joystick-switches of an OCP station.

Each line in this editor defines one control expression.

Interface Overview
1. Use the Style Name field to specify the name of the control expression.

• This name is listed in the Monitoring Style column of the Destination Definition editor. 
• If the style contains drag-drop parameters then the control expression as it is used in the 

target device must be completed by dragging some additional information into the 
Monitoring Style column of the editor.

2. Use the Style Type field to Indicate whether the style is a Tally Map Output style. 

• When the style is marked as a Tally Map Output style, the style name displays in the Tally Map 
Profile Settings. 

• Keep blank if the style is not a Tally Map Output style.
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3. Use the Default For setting to indicate the condition required in order for this style to be 
selected by default. 

• This is used in tally maps where the outputs are of the type Output Control.
• When assigning crosspoints on the tally map, the default style will be set for the output when 

the input type (the condition) is met.

4. Add the required Control Expression(s). 

• Control expressions are a combination of text, embedded expressions and drag-drop 
parameters. 

• Embedded functions are pre-defined keywords followed by a set of parentheses which 
contain comma separated parameters (e.g. ADD(2,2)). 

• Embedded functions allow the output of a text-programmed device to change based on 
factors other than the content of the text itself. For more information on Embedded 
Functions refer to “Embedded Functions”.

• Drag-drop parameters are placeholders into which information dragged into the Edit Pane is 
inserted in order to complete a control expression. 

• Drag-drop parameters typically contain items such signal sources, router or switcher inputs 
or outputs or GPI inputs. 

• Drag-drop parameters are angle-bracketed text surrounding a parameter name (e.g. <P1>, 
<P2>, etc.). 

• Repeated parameters receive the same drag-drop information. 
• Text inserted into a control expression that is neither an embedded expression nor a 

drag-drop parameter is sent to the TSI and displayed or evaluated verbatim. 

For more information on drag-drop parameters, refer to “Drag / Drop Parameters”.

5. Use the Tally Mapper Optional Control Expression to assign the control expression that will 
be used by the Tally Map Input table when the style is selected. 

• If no expression is found in the Tally Mapper Optional Control Expression field, the regular 
control expression will be used. 

• All other tables other than the Tally Map Input table will use the regular control expression.

6. Use the Description field to specify the text that displays in the Control Description column.

• This enables you to provide a user-friendly description of the control expression purpose or 
logic for the user. 

• Drag-drop parameters in the control expression should also be appropriately included in the 
description – in this case the name of the dragged-in parameter will be included in the control 
description.

7. Use the Tally Mapper Input Label field to provide alternate text that can be displayed for the 
Input side of a tally map layout. 

• This field can include the same angle-bracketed place-holders used in the Control Expression 
and Description fields described above. 

• The inputs belonging to the tally map layout must be set by the user to use the Tally Mapper 
Input Label expression rather than the standard “Input Name” (refer to “Changing Tally Map 
Axis Labels”).

8. Use the Comment field to provide additional information to the tally system programmer or 
user.

Subroutines
These subroutines are stored as “global messages” (variables) within each TSI, and can be 
referenced from within a control expression to execute complex expressions, or expressions that 
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are referenced in many places. This can simplify the programming of complex functions, or simplify 
program maintenance by moving logic that is used in many places to one location for ease of future 
modifications. Unlike the Control Expressions the subroutines cannot be directly assigned using the 
Monitoring Style or Control Style columns in the UMD, GPI output, LED or Destination Definition 
editors; the subroutines have to be referenced from within the control expression using either the 
“V” of the “FN” embedded functions. The subroutines can also be reference by other subroutines in 
the same way.

General Setup
1. Use the Name field to specify a unique identifier to the subroutine. 

This is used as the parameter of an embedded “V” of the “FN” function.

2. Use the Control Expression to specify the expression that is read or executed by the TSI when 
its name is found as the parameter of an embedded “V” of the “FN” function.

3. Use the Comment field is to provide additional information to the tally system programmer or 
user.
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Monitor Wall Layout Designer
This chapter outlines how to use the Monitor Wall Layout Designer to build a “monitor wall” from 
within the Tally System Console.

Overview
A virtual monitor wall can be designed in such a way as to mimic the broadcast plant's physical 
monitor wall layout, or any other user-defined layout styles. This virtual monitor wall can allow one 
to monitor the outputs driving UMDs from one or more TSI systems from within the application.

Having the virtual monitor wall show the output from the TSI systems can be useful especially if the 
UMDs have not been physically wired to the TSI systems yet, and you want to check that the TSI is 
properly configured. Similarly, the virtual monitor wall allows you to monitor the outputs from the 
TSI systems without having to actually be in front of the UMDs.

The Layout Control Panel
The layout control panel allows one to control the navigation and viewing aspects of the monitor 
wall. The panel is shown as a horizontal bar with several buttons running across. 

Figure 9  Example of the Layout Control Panel

Each button performs a certain function. 

Layout Objects
A layout object on the monitor wall is represented by a display object. If the display object is 
associated with a UMD, the display object will show information about the UMD such as the name, 
section #, the type of monitoring style used, and more.

The tally display area on the display object will show the output driving that UMD from the TSI.

Table 3  Layout Control Panel — Buttons

Button Description
Turns on or off the panning mode. 
When panning mode is enabled, the cursor changes from the default 
arrow-shape to the hand. The current monitor wall layout can be panned 
around by “grabbing” a certain area of the layout and moving the layout 
around. The actual positions of the displays in the layout do not move (only the 
current viewing area). 
To pan the layout, click one area of the layout with the left-mouse button and 
hold down the button while moving the mouse around. Release the left-mouse 
button when done.

Turns on or off the full screen display of the layout.



76 • Monitor Wall Layout Designer Tally System Console User Guide (v1-rev1)

Figure 10  Example of Layout Object

The tally display area will display any tally text as received from the TSI and can have one or more 
displayable sections, depending on the display type. The style and formatting of the tally text (e.g. 
green, amber, left-justified, etc...) should be identical to what an actual Under Monitor Display 
would display when driven by the TSI. This area is updated only when the Tally System Console 
application is connected with the TSI systems.

Display Types
The layout currently supports several display types: 

Table 4  Layout Control Panel — Buttons

Type Description
Quad-display used for VxV-4 and VxV4-HD displays. 
A quad-display has 4 sections - each section is drawn in one of the 
four smaller displays.

Single 16x9 display. 
This display has only 1 displayable tally section.
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Working with the Layout Designer
The layout is an empty canvas that can have different objects “dropped” into the layout. Once in the 
layout, the objects can be rearranged and resized in any number of ways. Typically a layout is 
designed to mimic the physical monitor wall layout of a broadcast facility, however, it is not 
necessary to do so.

The layout designer control panel provides additional ways to navigate and manage your layout. 
Read the Layout Control Panel topic for additional information.

Selecting Objects
An object on the layout can be selected by clicking on it with the left-mouse button. The object will 
show up as being selected when it changes color.

One or more objects can be selected using the dragging method. Click and hold the left-mouse 
button to initiate the “dragging” mode. When you move the mouse in this mode, a translucent 
rectangular area will form indicating the selection area. Objects inside the selection area will be 
selected.

Single 4x3 display. 
This display has only 1 displayable tally section.

Dual 4x3 display. 
This display has 2 displayable sections.

Triple 4x3 display. 
This display has 3 displayable tally sections

No informational display. 
Only 1 displayable tally section.

Table 4  Layout Control Panel — Buttons

Type Description
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Figure 11  Example of a Selection Area

After you have made your selection, to select another object without losing the previous selection, 
you can hold down the CTRL-key and using the mouse, left-click on the new object. The new object 
will be added to your selection.

Resizing Objects
An object can be resized by holding the left-mouse button on one of its corners and then dragging 
the mouse. It is also possible to resize the sides of the object. When the mouse is moved over the 
sides or corners of the object, the icon will change to a directional arrow indicating that the object 
can be resized. The aspect ratio of the display area will be maintained even during resizing.

Figure 12  Example of Resizing an Object

Moving Objects
Once one or more objects are selected, they can be moved around the layout by dragging them 
around the layout. If the objects are moved on top of already pre-existing objects, the position of 
the selected objects will revert back to the original position they were in prior to being moved.
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Adding/Creating Objects
Display objects can be added or created on the layout either through dragging and dropping of 
UMDs onto the layout, or through the right-mouse-click menu. Refer to the Adding Displays to the 
Layout topic for additional information.

Adding Display Objects to the Layout
In order for the UMDs in the virtual monitor wall layout to output messages from the TSI, display 
objects must first be added to the monitor wall. Each object must be associated with the UMD that 
they will monitor before any status information will be displayed on the layout.

There are two methods to add a display object to the layout.

Method #1
1. With the layout currently open in the right window pane, select the UMDs tab in the left pane. 

2. Click + to expand the list of available UMDs. 

3. Select the UMD that is to be added to the layout. 

4. Using the mouse, hold the left-mouse-click to select the UMD.

5. Drag the mouse selection over to the layout. 

6. Release the left-mouse-click to “drop” the display object onto the layout. 

7. Upon dropping the UMD onto the layout, a display object is created and the UMD will be 
associated with the display object automatically. 

The information display area of the display object reports some properties of the UMD (e.g. 
name, section #, monitoring style, etc...).

 The type of display object will be selected automatically (e.g. quad display, single display, etc.) 
depending on the type of UMD. In the case of quad displays, even if only one UMD belonging to a 
quad-display is dropped into the layout, the Tally System Console will attempt to locate and 
assign all 4 UMDs that belong to that same quad-display. The UMDs will be matched based on 
their serial # and the assigned position in the quad-display will be determined by the section # 
for each of the UMDs.

Method #2
1. Right-click the layout to display the menu allowing you to manually add an object onto the 

layout. 

2. Select Add > Display Unit to access a list of possible display types.

3. Select Display Type to add. 

After this point, the display object has been added to the layout but it has not been associated 
with any UMD. Thus, it will not show any information display or status output.

4. Assign the display object to a UMD as follows:

a. With the layout currently open in the right pane, change to the UMDs tab in the left pane. 

b. Click + to expand the list of available UMDs. 

c. Select the UMD that is to be added to the layout. 

d. Using the mouse, hold the left-mouse-click on the UMD.

e. Drag the mouse over the empty display object. 

f. Release the left-mouse-click to “drop” the UMD onto the display object. 
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When this is complete, the display object reports the properties of the associated UMD (e.g. 
name, section #, monitoring style, etc...).

Assigning Monitoring Styles to Display Objects
Once a display object has been created on the layout and assigned a UMD, it is possible to also 
select a monitoring style for the UMD if one has not been defined already. The monitoring style can 
be set in either within the UMDs > Display Devices (UMDs) table by changing the Monitoring Style 
property for that UMD, or it can be assigned immediately via the layout page.

Assigning a Monitoring Style
1. With the layout currently open in the right pane, change to the Tally Logic tab in the left pane. 

2. Click + to expand the list of available styles for UMD Control Expressions. 

3. Select an expression that is to be assigned to a display object on the layout. 

4. Using the mouse, hold the left-mouse to select the expression.

5. Drag the mouse over and on top of the display object. 

6. Release the left-mouse-click to “drop” the expression into the display object.

• Upon dropping the expression into the display object, the monitoring style for the UMD will 
change - this will be reflected in the information display area of the display object. 

• The information display area reports “Style” followed by the expression that was just 
dropped. 

• The description of the expression is also reported.

Assigning Parameters to a Monitoring Style
Certain monitoring styles require additional information / parameters in order to properly function. 
Expressions that require additional parameters will show [] brackets within the description 
indicating that another object is required. Similarly to the monitoring style, the additional 
parameters can be added through the UMDs > Display Devices (UMDs) editing table, however, it is 
also possible to add the parameters from the layout page.

Figure 13  Example of Assigning Parameters

To add parameters through the layout, select the tab which contains the object that you wish to 
assign to the expression as a parameter.

In the example picture above, the description requires a Source object to be assigned: under the I/O 
and Signals tab, press the icon beside Source Definitions to expand the list of available sources. 
Left-mouse-click on one source and drag it on top of the display object. When the left-mouse button 
is released, the source object is released and should then be assigned to the description. As a 
result, the description should change to reflect the new parameter.
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Figure 14  Assigning a Source Object to the Description

Editing Display Object Properties
The properties of a display object on the layout can be modified by either right-clicking on the 
object or by double-clicking.

Modifying Layout Properties
Right-clicking on a display object will display the following menu:

Figure 15  Example of Modifying Layout Properties

The menu will indicate the name of the current UMD associated with the display object at the top. 
Additional menu items related to the selected display object are shown as well:

• Display Type — displays a sub-menu with a list of other display types. When a display type is 
selected from this sub-menu, the current display object type will change to the new type that was 
selected.
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• Tally Position — Allows placement of the tally text either above or below the information display 
area window of the display object. By default, the tally text area will be shown below the 
information display area.

• Unassign Display — Removes an associated UMD from the display object. Once unassociated, the 
display object will not show anything in the information display area or the tally text area.

• Delete — Removes the display object from the layout.

Modifying UMD Properties: Changing Override
The Override Text or Raw Expression (or both) of a UMD can be modified from within the layout 
designer by double-clicking on the display object. This will display a dialog with an area to enter in 
text for either the Override Text and/or Raw Expression field.

Figure 16  

Either the Text Override or Raw Control or both field entries will be visible in the dialog. This is 
determined by the double-click UMDs in Monitor Wall to Modify setting under Management > 
Configuration.

• Text Override — This field is only used if the monitoring style assigned to the UMD makes use of 
the __TEXT variable. Such a monitoring style can be written such that a default expression will be 
displayed if no text override is used, and a different expression will be displayed if the text 
override field contains a string.

• Raw Control — Causes the UMD to display its status output when evaluated using the entered 
raw expression.



Tally System Console User Guide (v1-rev1) RCP Layout Designer • 83

RCP Layout Designer
This chapter provides outlines how to use the RCP Layout Designer to configure one or more 
Remote Control Panel (RCP) units from within the Tally System Console.

Overview
The functionality of every individual button on an RCP can be configured on the layout designer by 
simply dragging and dropping in pre-programmed button styles onto the virtual RCP objects.

Since the functionality of the buttons are determined by control style expressions, RCPs can be 
configured to perform various tasks. Usually the RCPs can be configured to perform the following:

• Camera delegation (assign which sources can be tallied by which control room)
• Router control

RCP Layout Control Panel Overview
The layout control panel allows one to control the navigation and viewing aspects of the virtual 
space containing the RCP objects. The panel is shown as a horizontal bar with several buttons 
running across.

Figure 17  RCP Layout Control Panel

Each button will perform a certain function

Working with the RCP Layout Designer
The layout is an empty canvas that can have different objects “dropped” into the layout. Once in the 
layout, the objects can be rearranged and resized in any number of ways. Typically a layout is 
designed to mimic the physical monitor wall layout of a broadcast facility, however, it is not 
necessary to do so.

The Layout Designer Control Panel provides additional ways to navigate and manage your layout. 
Read the Layout Control Panel topic for additional information.

Table 5  RCP Layout Control Panel — Buttons

Button Description
Turns on or off the panning mode. 
When panning mode is enabled, the cursor changes from the default 
arrow-shape to the hand. The current monitor wall layout can be panned 
around by “grabbing” a certain area of the layout and moving the layout 
around. The actual positions of the displays in the layout do not move -- only 
the current viewing area. 
To pan the layout, click on one area of the layout with the left-mouse button 
and hold down the button while moving the mouse around. Release the 
left-mouse button when done.

Turns on or off the full screen display of the layout.
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Selecting Objects
An object on the layout can be selected by clicking on it with the left-mouse button. The object will 
show up as being selected when it changes color. One or more objects can be selected using the 
dragging method. Click and hold the left-mouse button to initiate the “dragging” mode. When you 
move the mouse in this mode, a translucent rectangular area will form indicating the selection area. 
Objects inside the selection area will be selected.

Figure 18  Example of Selecting Objects on a Layout

For RCP panel objects, buttons that fall within the selection area will be selected as well.

After you have made your selection, to select another object without losing the previous selection, 
you can hold down the CTRL-key and using the mouse, left-click on the new object.

The new object will be added to your selection.

Resizing Remote Control Panels
RCP panel objects have fixed sizes and cannot be resized. The fixed sizes are determined by the # of 
buttons set for that RCP device (a 20-button panel will only have a single row of buttons instead of 
two).

Moving Remote Control Panels
When one or more panel objects are selected, they can be moved around the layout by dragging 
them around the layout.

If the objects are moved on top of already pre-existing objects, the position of the selected objects 
will revert back to the original position they were in prior to being moved.

RCP panels can be moved to a different layout while preserving the assigned RCP buttons. This can 
be done by right-clicking on the RCP panel and choosing Move to RCP Layout (assuming there is 
another layout created).

Moving Buttons within Panels
One or more buttons in a panel can be moved around by drag+selecting and drag-dropping them 
onto another location on the panel. Buttons can be unassigned by right-clicking on them and 
choosing the Unassign Selected RCP Button(s) option.
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Adding/Creating Objects
RCP panel objects can be added or created on the layout either through dragging and dropping of 
RCP devices onto the layout. Refer to the Adding Displays to the Layout topic for additional 
information.

Displaying Button Assignment Information
Hovering the mouse button over an assigned button in the RCP panel will display information about 
which objects are currently assigned to the button, the button #, which group the button belongs 
to, which style is currently assigned, and which expression macros are assigned.

Adding Remote Control Panels to a Layout
To configure an RCP device, an object representing the device must first be created in the layout 
designer.

To add RCP to a layout

1. Define one or more RCP devices in the GPIs > Parallel Interface Devices > RCP table. 

Make sure that the RCP device has been assigned a size of 20 or 40 buttons.

2. Create a new RCP layout by selecting Plant Layout > Remote Control Panels and then 
entering a name for the RCP layout. 

3. Click View to modify the layout. The layout will be visible in the right window.

4. In the left-window, select the GPIs tab.

5. Click + beside Parallel Interface Devices to expand the list of available devices. 

6. Click + beside the RCP subheading to display your configured RCP devices in the tree-list.

7. Select one or more of the RCP devices in the left-window tree.

8. Drag-and-drop them onto the layout in the right-window.

This automatically creates the RCP panel objects within the layout.

Assigning RCP Buttons to Panels in the Layout
Once an RCP panel object has been created on the layout, the buttons in the panel can be assigned. 
Button functionality is assigned by dragging and dropping the RCP button styles onto the panel. 
Libraries have been provided to include preprogrammed button functionality. To be able to use the 
styles, the session should have been loaded with the appropriate libraries.

Pre-requisites
• RCP-CamDlg.lib library should be used when setting up a camera delegation panel.
• RCP-XptPanel.lib library should be used when setting up a crosspoint selection (router control) 

panel.
• To ensure that the session is loaded with the appropriate libraries, the default loaded libraries 

are configured in the Management > Configuration > Libraries section. Ensure the required 
library is selected. The library will be loaded the next time a new session is created. Alternatively, 
the library can be loaded on-the-fly and merged with the current configuration. This can be done 
by going to File > Merge Libraries and selecting the required library.

• Once the required libraries are loaded, the LED control expressions table (Tally Logic > LED 
Control Expressions) will be populated with available styles that can be assigned to the panel 
buttons. Typically the styles are named with _BUTTON as the suffix.



86 • RCP Layout Designer Tally System Console User Guide (v1-rev1)

Assigning a Button Style
With the Tally Logic > LED Control Expressions table expanded in the left pane, drag a button style 
and drop it onto a button of a panel in the layout. This will assign the style (the functionality) of the 
button.

It is possible to assign the style to more than one button. Select more than one button either by 
highlighting the buttons within a drag-selection area. Then drag the style onto the button selection. 
All selected buttons will inherit the button style.

Assigning Parameters to Buttons
Certain styles require additional information / parameters in order to properly function. 
Expressions that require additional parameters will show up as a red label on the button with a very 
brief description of what is needed. For example, “src?” means that a source is required, “ctrl rm?” 
means that a tally area (control room) is required. Once the expression is complete, the button label 
will either show nothing or will show a white label -- typically describing the object that the button is 
assigned with.

Assigning objects to complete the button style expression is a drag-and-drop procedure. If the 
button requires a source, a source object taken from I/O and Signals > Source Definitions (or any 
other source input will work) can be dropped onto the style. If a button requires a control room, a 
tally area from Plant Layout > Multiple Control Rooms can be dropped in.

In Figure 19, five buttons have been correctly assigned: 4 camera sources and 1 control room select 
button (the CLR button is a standalone button that does not require object assignments).

Figure 19  Example of Assigning Buttons

Assigning Parameters to Multiple Buttons
To assign objects to multiple buttons at a time (useful if you want to assign several buttons on a 
panel with several camera sources), drag-select the target buttons with your mouse. In the left-tree, 
highlight one or more objects and drag-drop them onto the highlighted buttons. If more than one 
object is being dragged in, you will have the option to:

• Assign all items to each button in the selection - if you selected 3 sources: CAM1, CAM2, CAM3, 
then each button would be assigned CAM1, CAM2, and CAM3 (all 3 sources for each button).

• Assign each item to an individual button in the selection - if you selected 3 sources: CAM1, CAM2, 
CAM3, then the first button would be assigned CAM1, the second button would be assigned 
CAM2, and the third button would be assigned CAM3 Assign all items only to this button - if you 
selected 3 sources: CAM1, CAM2, CAM3, then only the button underneath the mouse cursor 
would be assigned CAM1, CAM2, and CAM3 (all 3 sources only for the button under the mouse 
cursor).
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Intelligent Assignment of Buttons
It is possible to assign objects (e.g. cameras, sources, control rooms) to the RCP without needing to 
assign the style first. The Default For column within Tally Logic > LED Control Expressions associates 
the type of object (e.g. source, tally area) with the LED Control Expression style. By default, the 
built-in library associates input objects to use the “DLG_CAM_BUTTON” style and tally area objects 
to use the “DLG_CR_BUTTON” style. 

• When a camera/source object is dragged and dropped directly onto the RCP panel, the 
application will intelligently select the style where Default For is set to “Resource Input”. 

• When a tally area is dragged and dropped, the application will select the style where Default For 
is set to “Tally Area”. 

• When a destination object is dragged and dropped, the application will select the style where 
Default For is set to “Resource Output”.

Creating RCP Button Groups
Defining an RCP button group is an easy way of grouping one or more buttons together where all 
buttons share a common style (e.g. all of them being source buttons or all of them being macro 
buttons). When the buttons in the panel have been marked as part of a group, you can then assign 
objects to the buttons very quickly - - the style assigned to the group will be applied. Once buttons 
are assigned to a group, the group will be visible in the layout designer.

Groups can exist across panels in a multi-RCP layout.

Grouping buttons together also has an advantage where it is possible to assign macros to individual 
groups. This allows buttons in groups to take on different values depending on the assigned macro 
values for each group. Refer to “Assigning Expression Macros to RCP Button Groups” for more 
information.

To create RCP button groups

1. Select Plant Layout > RCP Button Groups to create a new group by entering a Group Name.

2. Select the Control Style that all buttons in this group will use. 

Typically this would be DLG_CAM_BUTTON for camera/source buttons and DLG_CR_BUTTON 
for tally area/control room buttons.

3. Select one or more buttons in the RCP panel. 

You can also add buttons from other layouts are part of the group by including them as part of 
the selection.

4. Click + beside RCP Button Groups to expand the list of available groups to select from. 

5. Drag and drop a group from the tree list to the button selection in the layout.

• All buttons in that group should now have the same style. 
• The group order when assigning objects to the buttons is determined when the buttons are 

first created in steps 3 and 4. 

6. To view or change the current order:

a. Right-click a button in a group.

b. Select Grouping > Change Button Order In Group. 

The numbers shown indicate the current order sequence. The smallest number being the 
first to be assigned. 

c. Select the buttons in the order that you require and the button sequence will be updated. 

d. Press Enter when done or Esc to cancel the button sequence change.
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7. Drag and drop the required objects (e.g. camera or sources) on top of the buttons in the group. 

Suppose you select 3 objects: CAM1, CAM2, and CAM3. If you drag the selection on top of the 
buttons assigned to the group, you will be given the option to: 1) assign all items to each button 
in group order - meaning CAM1, CAM2, and CAM3 are assigned to button 1, CAM1, CAM2, and 
CAM3 are assigned to button 2, etc... 2) assign each item to an individual button in group order 
- meaning CAM1 assigned to button1, CAM2 assigned to button2, etc... 3) assign all items to this 
button only - meaning CAM1, CAM2, and CAM3 assigned to the button that the mouse cursor is 
over.

Assigning Expression Macros to RCP Button Groups
Each group can take on different properties which are defined by a macro name and macro value 
pair, which can then be accessed by a button of that group. What this allows you to do is for 
instance, you can define a macro called NAME. By using the macro expression <#{macro name}> 
tag in an RCP LED Expression (RCP button style), the value of the macro NAME can be obtained from 
the group that the button is assigned.

For example:

Group #1: NAME="CR1-Cam-Group"

Group #2: NAME="CR2-Cam-Group"

Suppose Group #1 and Group #2 are both assigned with style “Group Name” which is defined as:

sv(!X,fn(<#NAME>))v(!X)

Then all buttons in Group #1 would take on the expression "sv(!X,fn(CR1-Cam-Group))v(!X)" and all 
buttons in Group #2 would take on the expression "sv(!X,fn(CR2-Cam-Group))v(!X)".

Thus, the expression and behavior of a button can change depending on the group that it belongs 
in.

Pre-requisites

The style (RCP LED expression) that is assigned to the group should include <#{macro name}> 
somewhere in the expression in order for expression macros to be used.

To assign expression macros to RCP button groups

1. Ensure the group is already be defined (refer to “Creating RCP Button Groups”). 

2. Select Plant Layout > RCP Button Group Properties.

3. Once the group exists, click + beside and the group should exist under that heading.

4. Select the group under the RCP Button Group Properties subheading. 

The RCP Macro Definitions table displays on the right.

5. Enter in a Macro Name.

6. Enter the Macro Value into the table.

7. To verify that a group has now been assigned the appropriate macro names:

a. Select Plant Layout > RCP Button Groups > {the group name}. 

b. Locate the Assigned Macros column.

c. Ensure the list of all macros created under the RCP Macro Definitions table are listed.
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Tally Map Layout Editor
This chapter outlines the Tally Map Layout Editor to assign inputs and outputs within the Tally 
System Console. 

Overview
The tally map layout editor shows a representation of the input and output assignments along two 
axis which surround the pin-grid.

Figure 20  Example of the Tally Map Layout Editor

Tally Map Layout Control Panel
The tally map layout control panel consists of a couple buttons to access important functions of a 
tally map layout.

Figure 21  Example of the Tally Map Layout Control Panel

Each button will perform a certain function.
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Tally Map Layout Axis
The two tally map axis represent the input and output items that can be assigned to one another. In 
most cases they do represent inputs and outputs (e.g. GPI inputs VS GPI outputs) but in some 
situations they can mean something else (e.g. Source VS GPI inputs).

By default the input axis is displayed vertically from top to bottom and the output axis goes across 
the layout horizontally. Both axis can be flipped if so desired. The input items are displayed in the 
order of appearance within the Tally Map Inputs table. Output items are displayed in the order of 
drag-and-drop preference. 

Assignment of Inputs
The tally map inputs will automatically populate as the Tally Map Inputs table is filled. Right-clicking 
on an input item will show the following options:

• Displayed Label — Select how the input names will be labeled. The names will either come from 
the Tally Map Inputs table or dynamically generated using the custom label expressions. The 
custom label expressions are found in the Tally Logic > UMD Control Expressions / GPI Control 
Expressions / LED Control Expressions / Crosspoint Control Expression tables.

• View Table Entry — Switches to the table containing the input item entry.
• View Assigned Parameters — Brings up the Parameter Manager form to view all assigned 

parameters to the tally map input item.
• Unassign Input Object(s) — Quickly removes all assigned parameters from the selected input.

Assignment of Outputs
Tally map output items can be assigned either by dragging one or more items into the “+ Drag Drop 
Outputs” section in the layout. Doing this will automatically add each output in order into the axis. 
Alternatively, one or more output items can be inserted anywhere along the axis by dragging it 
between other output items.

Table 6  Tally Map Layout Control Panel — Buttons

Button Description
Enable / disable layout panning

Display layout using the full screen

Swap tally map axis

Show tally map profile settings
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Output Items Options

Selecting one or more output items and then right-clicking will bring up the menu. The following 
options are available:

• View Table Entry — Switches to the table containing the output device entry. Not available when 
multiple output items are selected.

• View Assigned Parameters — Brings up the Parameter Manager form to view all assigned 
parameters to the output device. Not available when multiple output items are selected.

• Change Existing Tally Map Style — By default the tally map style assigned is the one specified in 
the Tally Map Profile settings form when a crosspoint assignment is made on the pin-grid. In the 
event that the style needs to be changed for certain output items without affecting global Tally 
Map Profile settings, this can be done from the right-click options menu.

• Lock Output(s) — Locks the selected output items so crosspoints associated with the output 
items cannot be changed on the tally map pin-grid.

• Remove Selected — Removes the selected output items from the tally map layout.

Tally Map Layout Grid
The tally map pin-grid is where the assignment of input items to output items is performed. By 
hovering the mouse over a cell in the pin-grid, the corresponding input and output items in the tally 
map axis will light up.

Figure 24  Example of Assigning and Input to an Output

Figure 22  Adding One or More Outputs Figure 23  Inserting One or More Outputs In-Between
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Prior to applying any tally map assignments, the pin-grid will show 1) whether any output item is 
being controlled/assigned to a tally map, 2) whether an output item is in use somewhere else (tally 
map not being applied).

When an output item is currently in use elsewhere and not in the tally map, the crosspoint will 
display as the unassigned state – a dark shaded circle. Moving the mouse over it will reveal the 
message “Output device is in use. No tally map assignment has been applied yet.” (Figure 25)

Figure 25  Example of an Output Status Message

Clicking the crosspoint (even when the output device is in use), will immediately apply the tally map 
assignment between the input and output items. The crosspoint will light up with the assigned-state 
blue-colored circle. Clicking on an assigned crosspoint will remove the assignment, and the circle 
will revert back to its original state (a dark circle if output device was in use before, or no circle if no 
previous assignment). (Figure 26)

Figure 26  Example of Selecting a Crosspoint

Output items that are locked will not allow their associated input item assignment(s) to change. The 
pin-grid will indicate locked crosspoints as being dark blue circles with a key-lock icon shown in the 
output axis. (Figure 27)
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Figure 27  Example of Two Locked Outputs

Pre-defined Crosspoint Assignments
A set of pre-defined crosspoint positions are accessible by right-clicking on the pin-grid. A menu 
selection displays. (Figure 28)

Figure 28  Example of Pre-defined Crosspoint Options

The following options are available:

• Switch Input and Output Axis — Flips the position of the vertical and horizontal axis.
• Select Diagonal Crosspoints — Select crosspoints in a diagonal fashion starting from the point at 

which the mouse was clicked on.
• Select Vertical Crosspoints — Select crosspoints in a vertical fashion starting from the point at 

which the mouse was clicked on.
• Select Horizontal Crosspoints — Select crosspoints in a horizontal fashion starting from the point 

at which the mouse was clicked on.
• Remove All Crosspoints — Removes all assigned crosspoints on the tally map grid.
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General Setup
A generic set of procedures can be applied when creating a tally map layout. Please check the 
Introduction to Using Tally Maps page for detailed examples of tally map configurations for use in 
different situations.

To create a tally map layout

1. Select Plant Layout > Tally Maps to create a new tally map layout.

2. Select Plant Layout > Tally Map Inputs to open the new tally map input table for the newly 
created tally map.

3. Define all the inputs for the tally map. 

• Input names do not have to be unique but the associated Output Device Type must be 
unique. 

• Each tally map input entry can be assigned different behaviors/styles for the input parameter 
and output device.

4. Assign an appropriate Output Device Type from the drop down. 

 Ensure there are no duplicate device types for the same input name.

5. Assign the Input Control Style that you wish to use.

6. If necessary (depending on the control style), you may need to drag-and-drop an item from the 
left-tree view to the Description field of the tally map input.

7. Once the tally map input table is complete, view the tally map by selecting Plant Layout > Tally 
Maps > View. 

All inputs that were created in the tally map input table should be visible.

8. Assign the corresponding output devices into the tally map by dragging-and-dropping from the 
left-tree view to the + Drag-drop Outputs area. 

The selected outputs display in the tally map.

9. Expand the Tally Map Profile slider by clicking the rectangle to the left of the tally map. 

10. Set the Tally Map Output Style that will be used in accordance to each of the output device 
types that are in the layout.

• Some output device entries may need to have the Tally Areas selected first for the tally map 
assignment to correctly work.

• The Tally Areas can be set in the UMD Display Devices, GPI Outputs, RCP LED Outputs, and 
Destination Definitions editor tables tally map. 

11. Minimize the Tally Map Profile slider when complete.

 Some output device entries may need to have the Tally Areas selected first for the tally map 
assignment to correctly work.

External GPI Inputs to Sources
Assigns a set of GPI inputs to individual sources (e.g. cameras). Typically used where external 
sources are fed into a facility/truck via GPI inputs.

Pre-requisites

• Routers/Switchers must area defined. 
• One or more sources in I/O and Signals > Source Definitions are defined.
• GPIO ports are defined under Hardware > Parallel Interface Ports.
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• Individual GPIO devices are defined under GPIs > Parallel Interface Devices.
• A tally area was defined under Plant Layout > Tally Areas > Multiple Control Rooms. 
• Within this tally area, the tally types PGM, PST, and EXT exist.

To create an external GPI inputs to sources tally map

1. Select Hardware > Comm Port Setup > Production & M/C Switchers.

2. Create a port name for an external switcher (e.g. EXT). 

3. Select External Virtual Switcher from the Protocol menu.

4. Select I/O and Signals > Destination Definitions.

5. Create a destination for each external GPI input. 

The name assigned can be associated with the GPI input (e.g. EXT-01). 

6. Set the Output Device to the external switcher.

7. Specify the Output Device IO.

• The Output Device IO should start from 1 for the first external GPI input and increment by 1 
for each GPI input thereafter. 

• GPI Inputs must be in consecutive order.

8. Verify that the Destination Definitions table includes the entries _EXT-PGM and _EXT-PST (or 
_[your switcher device name]-PGM/PST). If not, create them as follows:

9. To monitor sources for on-air tallies:

a. Set the Control Style for _EXT-PGM to Follow GPIs (Virtual). 

b. In the left-tree view, select GPIs.

c. Click + beside GPI Inputs to expand the list.

The available parallel I/O units display. 

d. Click + beside the parallel I/O unit which will be monitoring the external GPI inputs to expand 
the GPI inputs list. 

e. Select one or more GPI Inputs in the left-tree view. 

f. Drag-and-drop the selection into the Control Style Description area for _EXT-PGM. 

g. Select Assign as parameters to single row only when the sub-menu displays.

10. To monitor sources for next-to-air tallies:

a. Set the Control Style for _EXT-PST to Follow GPIs (Virtual). 

b. Repeat the steps as described for monitoring sources for on-air tallies except drag-and-drop 
the GPI Inputs selection into the Control Style Description area for _EXT-PST. 

c. Select Assign as parameters to single row only when the sub-menu displays.

 The Description field changes once the GPI inputs have been dragged-and-dropped.

11. Select Plant Layout > Tally Areas > Multiple Control Rooms.

12. Select the name of the control room that will tally from the external inputs. 

The tally types PGM and PST display in the right-window table edit. 

• For tally type PGM, set the Destination to “_EXT-PGM”.
• For tally type PST, set the Destination to “_EXT-PST”.

13. Create a new tally map layout:
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a. Select Plant Layout > Tally Maps.

b. Click + beside Plant Layout > Tally Map Inputs. 

The tally map that was just created displays. 

c. Select the tally map name to view the Tally Map Inputs table in the editor window.

14. In the Tally Map Inputs table:

a. Create an entry for each source. 

b. Set the Control Style to (Output Control) >> Tally Map Input (Source) for 
Ext-In-to-Source Tally Map.

15. In the left-tree view, select I/O and Signals.

16. Click + beside Source Definitions to reveal the list of available sources. 

17. Drag-and-drop a source from the list into the Description field within the Tally Map Inputs 
table. 

 The Description field updates to show the dropped in source name.

18. Ensure that Output Control is selected under Assigned Output Device Type.

19. View the tally map layout:

a. Select Plant Layouts > Tally Maps.

b. Select the tally map entry. 

All inputs that were created in the tally map input table are displayed.

20. In the left-tree view, select I/O and Signals.

21. Click the + beside Destination Definitions to display the list of available external GPI inputs. 

22. Select the external GPI inputs from the left-tree.

23. Drag-and-drop them onto the + Drag-drop Outputs area in the tally map layout. 

The selected outputs display in the tally map.

24. Click the rectangular button on the left of the layout to display the Tally Map Profile settings. 

 The required settings should be set according to the configuration specified under Tally Map 
Profile Settings.

Source/Destination to GPI Outputs
Assign sources or destinations to GPI outputs. GPI closures can be triggered when certain 
conditions for sources/destinations are met (force goes on-air, next-to-air, etc...).

Pre-requisites

• Routers/Switchers are defined. 
• One or more sources in I/O and Signals > Source Definitions are defined.
• GPIO ports are defined under Hardware > Parallel Interface Ports.
• Individual GPIO devices are defined under GPIs > Parallel Interface Devices.
• A tally area is defined under Plant Layout > Tally Areas > Multiple Control Rooms. 
• Within this tally area, the tally types PGM, PST, and EXT exist with the appropriate Destination(s) 

set.
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To create a source/destination to GPI outputs map

1. Select Plant Layout > Tally Maps to create a new tally map layout.

2. Click + beside Plant Layout > Tally Map Inputs. 

The tally map that was just created displays. 

3. Select the tally map name to view the Tally Map Inputs table in the editor window.

4. In the Tally Map Inputs table, create an entry for each source/destination. 

5. Set the Control Style to (GPI) >> Source On Air. 

Other possible control styles can be set according to requirements (e.g. (GPI) >> Destination On 
Air, (GPI) >> Source Next to Airtime…). 

6. Ensure that the Assigned Output Device Type is set for GPI Output.

7. Drag and drop the required source/destination into the Description field to complete the tally 
map input entry as follows:

a. Select I/O and Signals.

b. Click + beside Source Definitions (or Destination Definitions) in the left-tree view to expand 
the tree list. 

c. Select the sources/destinations in the left-tree 

d. Drag-and-drop them into the Description field in the editor view.

8. If you wish to view the tally map layout:

a. Select Plant Layouts > Tally Maps.

b. Click the tally map entry. 

All inputs that were created in the tally map input table should be visible.

9. In the left-tree view, select GPIs.

10. Click + beside GPI Outputs to expand the list of available GPI output devices.

11. Click + beside the GPI output device that contains the GPI outputs that will be associated with 
the source/destination. 

A list of GPI outputs displays in the left-tree view. 

12. Select one or more GPI outputs from the left-tree.

13. Drag-and-drop them onto the “+ Drag-drop Outputs” marker in the tally map layout. 

The selected outputs display in the tally map.

14. Click the rectangular button on the left of the layout to set the Tally Map Profile settings. 

15. Set the required Tally Map Profile Settings.

• GPI Outputs: (Tally Map) GPI Single — Use when checking a single source/destination to 
determine if GPI output should be triggered. (e.g. GPI output on when CAM-01 is on-air). 

• GPI Outputs: (Tally Map) GPI OR — Use when checking OR condition of sources/destinations 
to determine if GPI output should be triggered. Up to 10 sources/destinations can be 
assigned to a single GPI output. (e.g. GPI output on when CAM-01 OR CAM-02 OR CAM-03 are 
on-air). 

• GPI Outputs: (Tally Map) GPI AND — Use when checking AND condition of 
sources/destinations to determine if GPI output should be triggered. Up to 10 
sources/destinations can be assigned to a single GPI output. (e.g. GPI output on when 
CAM-01 AND CAM-02 AND CAM-03 are on-air)
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Additional Settings
The Tally Map Inputs styles used may require setting the correct Tally Area within the output 
devices' table. If selecting the crosspoint on the pin-grid causes an error to display like the following:

Figure 29  Example of an Error Message

Then right-click the output device and select View Table Entry.

Ensure that the tally area field is set for the output entry. This specifies which destination the TSI 
should monitor when tallying sources.

Source/Destination to UMD Display
Assign sources or destinations to UMD displays. A UMD display can tally a source/destination when 
certain conditions for sources/destinations are met (source goes on-air, next-to-air, etc…).

Pre-requisites

• Routers / Switches are defined. 
• One or more sources in I/O and Signals > Source Definitions or destinations in I/O and Signals > 

Destination Definitions are defined.
• UMD ports were defined under Hardware > Comm Port Setup > Displays.
• Individual UMD displays were defined under UMDs > Display Devices.

To create a source/destination to UMD display map

1. Select Plant Layout > Tally Maps to create a new tally map layout.

2. Click + beside Plant Layout > Tally Map Inputs. 

The tally map that was just created displays. 

3. Select the tally map name to view the Tally Map Inputs table in the editor window.
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4. In the Tally Map Inputs table, create an entry for each source/destination. 

5. Set the Control Style to (UMD) >> Source. 

Other possible control styles can be set according to requirements (e.g. (UMD) >> Destination, 
(UMD) >Dest:Source...). 

6. Ensure that the Assigned Output Device Type is set for UMD Device.

7. Drag and drop the required source/destination into the Description field to complete the tally 
map input entry. 

This can be done by clicking on I/O and Signals and then clicking on the ‘+’ beside Source 
Definitions (or Destination Definitions) in the left-tree view to expand the tree list. Select the 
sources/destinations in the left-tree and drag-and-drop them into the Description field in the 
editor view.

8. To view the tally map layout: 

a. Select Plant Layouts > Tally Maps.

b. Click the tally map entry. 

All inputs that were created in the tally map input table should be visible.

9. In the left-tree view, select UMDs.

10. Click + beside Display Devices (UMDs) to expand the list of available UMD output devices.

11. Select one or more UMD displays from the left-tree.

12. Drag-and-drop them onto the + Drag-drop Outputs area in the tally map layout. 

The selected outputs display in the tally map.

13. Click the rectangular button on the left of the layout to set the Tally Map Profile settings. 

 Required settings should be set according to the configuration specified under Tally Map Profile 
Settings.

14. Select one of the Tally Map Profile Settings:

• UMDs: (Tally Map) UMD Single — Tally a single source/destination on the UMD display.
• UMDs: (Tally Map) UMD Dual — Tally up to two sources/destinations on the UMD display.
• UMDs: (Tally Map) UMD Triple —Tally up to three sources/destinations on the UMD display.

Creating a GPI Input to GPI Output Tally Map
Maps GPI inputs to GPI outputs/RCP LED Outputs.

Pre-requisites

• GPIO ports were defined under Hardware > Parallel Interface Ports.
• Individual GPIO devices were defined under GPIs >Parallel Interface Devices.

To create a GPI input to GPI output tally map

1. Select Plant Layout > Tally Maps to create a new tally map layout.

2. Click + beside Plant Layout > Tally Map Inputs. 

The tally map that was just created displays. 

3. Select the tally map name to view the Tally Map Inputs table in the editor window.

4. In the Tally Map Inputs table, create an entry for each GPI input. 

• If the output is a GPI output, set the Control Style to (GPI) >> Follow and Assigned Output 
Device Type to GPI Output. 
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• If the output is an RCP LED output, set the Control Style to (RCP LED) >> Follow and 
Assigned Output Device Type to RCP LED Output.

5. Drag and drop the required GPI input into the Description field to complete the tally map input 
entry. 

a. Click + beside GPIs > GPI Inputs.

An expanded list of GPI inputs will be visible after clicking the ‘+’ beside the corresponding 
GPIO device shown in the left-tree view. 

b. Select the GPI inputs in the left-tree.

c. Drag-and-drop them into the Description field in the editor view.

6. To view the tally map layout:

a. Select Plant Layouts > Tally Maps.

b. Select the tally map entry. 

All inputs that were created in the tally map input table should be visible.

7. In the left-tree view, select GPIs. 

8. Click + beside GPI Outputs to expand list of available GPI output devices. 

9. Click + beside the corresponding GPIO device containing the GPI/RCP LED outputs.

10. Select one or more outputs from the left-tree.

11. Drag-and-drop them onto the + Drag-drop Outputs area in the tally map layout. 

The selected outputs display in the tally map.

12. Click the rectangular button on the left of the layout to set the Tally Map Profile settings. 

 Required settings should be set according to the configuration specified under Tally Map Profile 
Settings.

13. Choose the required setting for your GPI Output Devices:

• GPI Outputs: (Tally Map) GPI Single — GPI output will follow a single GPI input (e.g. GPI output 
on when GPI input is on)

• GPI Outputs: (Tally Map) GPI OR — Use when checking OR condition of GPI inputs to 
determine if GPI output should be triggered. Up to 10 GPI inputs can be assigned to a single 
GPI output. (e.g. GPI output on when GPI inputs 1, 2, or 5 are on)

• FPR GPI Outputs: (Tally Map) GPI AND — Use when checking AND condition of GPI inputs to 
determine if GPI output should be triggered. Up to 10 GPI inputs can be assigned to a single 
GPI output. (e.g. GPI output on when GPI inputs 1, 3, AND 4 are on) For RCP LED Output 
Devices

• RCP LED Outputs: (Tally Map) GPI Single — LED output will follow a single GPI input (e.g. LED 
output on when GPI input is on)

• RCP LED Outputs: (Tally Map) GPI OR — Use when checking OR condition of GPI inputs to 
determine if LED output should be triggered. Up to 10 GPI inputs can be assigned to a single 
LED output. (e.g. LED output on when GPI inputs 1, 2, or 5 are on)

• RCP LED Outputs: (Tally Map) GPI AND — Use when checking AND condition of GPI inputs to 
determine if LED output should be triggered. Up to 10 GPI inputs can be assigned to a single 
LED output. (e.g. LED output on when GPI inputs 1, 3, AND 4 are on).
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Creating a Camera Delegation Tally Map
You can create a tally map that is in conjunction with the RCP-CamDlg library so camera 
assignments can be done from either within the tally map or RCP layout editor. Local and remote 
TSIs can monitor virtual router DLG_CAM for the current camera assignments.

Pre-requisites

• RCP-CamDlg library is loaded into the configuration.
• Virtual router DLG_CAM is defined by the library.
• Routers / Switchers is defined. 
• One or more sources in I/O and Signals > Source Definitions are available.
• Control rooms are defined as tally areas under Tally Areas > Multiple Control Rooms. 
• A PGM, PST, and EXT tally type entry is available for each tally area.

To create a camera delegation tally map

1. Select I/O and Signals > Destination Definitions. 

Destination entries where the Output Device is DLG_CAM and the Output Device IO is the 
source name should be created if they do not already exist. If they do not exist:

a. Create a Destination Name with the same name as the source.

b. Set the Output Device to DLG_CAM. 

c. Set the Output Device IO to have the same as the source.

2. Select Plant Layout > Tally Maps to create a new tally map layout.

3. Click + beside Plant Layout > Tally Map Inputs. 

The tally map that was just created displays. 

4. Select the tally map name to view the Tally Map Inputs table in the editor window.

5. In the Tally Map Inputs table, create an entry for each control room. 

6. Set the Control Style to (Output Control) >> Control Room for Cam Delegation Tally Map. 

7. Ensure that the Assigned Output Device Type is set for Output Control.

8. Drag and drop the required control room into the Description field to complete the tally map 
input entry. 

a. Select Plant Layout > Tally Areas.

b. Click + beside Multiple Control Rooms in the left-tree view to expand the tree list. 

c. Select each control room in the left-tree.

d. Drag-and-drop them into the Description field in the editor view.

9. To view the tally map layout:

a. Select Plant Layouts > Tally Maps.

b. Click the tally map entry. 

All inputs that were created in the tally map input table are displayed.

10. In the left-tree view, select I/O and Signals. 

11. Click + beside Destination Definitions to expand list of available destinations.

12. Select one or more destinations from the left-tree.

13. Drag-and- drop them onto the + Drag-drop Outputs area in the tally map layout. 

The selected outputs display in the tally map.
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14. Click the rectangular button on the left of the layout to set the Tally Map Profile settings. 

 Required settings should be set according to the configuration specified under Tally Map Profile 
Settings.

15. Choose the Tally Map Profile Settings: Output Controls: (Tally Map) Cam Delegation.

Creating a Router Control Tally Map
This section outlines how to create a router control tally map, and assign router inputs to router 
outputs.

Pre-requisites

• A router is defined. 
• One or more router inputs are defined in I/O and Signals > (Router Name) – Input Names > 

Named Inputs.
• Short/Long names were assigned in the Named Inputs table which will later on be visible in the 

tally map layout.

To create a router control tally map

1. Select I/O and Signals > Destination Definitions. 

Destination entries where the Output Device is the router name (usually RTR) and the Output 
Device IO is the router output should be created if they do not already exist. If they do not exist, 
create a destination name for the router output.

a. Set the Output Device to the router name (usually RTR). 

b. Set the Output Device IO to be the router output.

2. Select Plant Layout > Tally Maps to create a new tally map layout.

3. Click + beside Plant Layout > Tally Map Inputs. 

The tally map that was just created displays. 

4. Select the tally map name to view the Tally Map Inputs table in the editor window.

5. In the Tally Map Inputs table, create an entry for each router input. 

6. Set the Control Style to (Output Control) >> TAKE.

7. Ensure that the Assigned Output Device Type is set for Output Control.

8. Click + for I/O and Signals > (Router Name) – Input Names > Named Inputs to expand the list of 
available router inputs. 

9. Select each router input in the left-tree.

10. Drag-and-drop them into the Description field in the editor view.

11. To view the tally map layout: 

a. Select Plant Layouts > Tally Maps.

b. Select the tally map entry. 

All inputs that were created in the tally map input table display.

12. In the left-tree view, select I/O and Signals. 

13. Click + beside Destination Definitions to expand list of available destinations.

14. Select one or more destinations from the left-tree.

15. Drag-and-drop them onto the + Drag-drop Outputs area in the tally map layout.
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The selected outputs display in the tally map.

16. Click the rectangular button on the left of the layout to set the Tally Map Profile settings. 

 Required settings should be set according to the configuration specified under Tally Map Profile 
Settings.

17. Select the from the following Tally Map Profile Settings:

• Output Controls: (Tally Map) TAKE Single In — Allow only one router input to be selected for a 
router output.

• Output Controls: (Tally Map) TAKE Multiple In — Allow one or more router inputs to be 
selected for a router output. Up to 10 router inputs can be assigned to a single router output.

Changing Tally Map Axis Labels
The output axis labeling reflects the name of each output device. To change the name shown in the 
output axis label, the output device name must also be modified.

Items on the input axis (the tally map inputs) can display 5 different possible labels:

• Input Name (default) — Use the name specified in the Tally Map Inputs table 
• User-Defined Label for UMDs — Use the labeling style defined for UMDs. The labeling style is 

defined in Tally Logic > UMD Control Expressions under the Tally Mapper Input Label column
• User-Defined Label for GPI Outputs — Use the labeling style defined for GPI outputs. The labeling 

style is defined in Tally Logic > GPI Control Expressions under the Tally Mapper Input Label 
column

• User-Defined Label for RCP LED Outputs — Use the labeling style defined for LED outputs. The 
labeling style is defined in Tally Logic > LED Control Expressions under the Tally Mapper Input 
Label column

• User-Defined Label for Output Controls — Use the labeling style defined for output controls (e.g. 
Destinations). The labeling style is defined in Tally Logic > Crosspoint Control Expressions under 
the Tally Mapper Input Label column 

By default, the Input Name type is used when the tally map is first created but a custom 
user-defined label can be selected. Each of the 4 main output types (UMDs, GPI Outputs, RCP LED 
Outputs, and Output Controls) can have their own unique labeling style.

Custom Labeling Styles
Under the UMD Control Expression, GPI Control Expressions, LED Control Expressions, and Output 
Control Expressions tables, a custom tally map input labeling style can be assigned. An input 
labeling style can make use of the internal drag-and-drop parameter tags to display dynamic 
information. Refer to “Drag / Drop Parameters” for further details on how the expressions are 
built. Examples of valid labels:

In Table 7, parameter P1 is used as a placeholder for the objects used in the tally map input table. A 
custom label can only use parameters that have been defined by a tally map input. In general 
parameter placeholders are prefixed with a leading ‘P’ followed by a number (incrementing by one 
for each new parameter).

Table 7  Examples of Custom Labels

Custom Label Displayed on Tally Map Axis

Source is <P1.ioname> Source is CAM01

Control Room <P1.name,,? > Control Room CR-1



104 • Tally Map Layout Editor Tally System Console User Guide (v1-rev1)

Changing the Displayed Label
You can choose to modify the input label for a single input or multiple. Both methods are described 
in this section.

To modify the Input Label for a single input 

1. In the Tally Map Layout view, right-click the input that you want to change. 

2. From the dialog, select Displayed Label.

3. Select the labeling style that you want.

To modify the Input Label for many inputs

A faster method to change the labels for many input items can be done through the Tally Map 
Properties window. 

1. In the left-tree view, expand the list of available tally maps by clicking + beside Plant Layout > 
Tally Maps. 

2. Right-click the tally map layout name in the left-tree view.

3. Select Properties to display the Tally Map Properties dialog. 

• In this window you can change the input and output axis font, flip the axis, and selectively 
assign the input labeling style for each input.

• Each individual input item can have its Displayed Label in Axis style modified by clicking on 
the drop-down and selecting a new style.

• The input labeling style for more than one input item can be applied altogether. This is done 
by first selecting one or more input items.

4. Right-click the selection.

5. Select Set Label for Selected Inputs. 

6. Select which labeling style to apply.
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Reference
This chapter provides additional information that may be helpful when using the Tally System 
Console menu system.

Table Editing Tips
• The various configuration editors can be invoked by clicking on the menu bars in the Menu Tree 

Pane.
• Existing configuration items that can be dragged from the Menu Tree Pane into the Editor Pane 

can be revealed by clicking on the icon of a menu bar in the Menu Tree.
• A red icon in the corner of a cell indicates an entry error of some sort. Hover the mouse pointer 

over the icon to obtain the reason for the error.

Keyboard Shortcuts
• To insert a new row before an existing row, select the existing row and press CTRL+Insert.
• To add a named item that increments the name from the previous line (CAM1, CAM2, etc... or 

CAMA, CAMB, etc...) press CTRL+Enter. 
• To copy a drop-down selection from the line above, press CTRL+Enter.
• To delete an entire row, select the first cell in the row (usually the Name) and press DELETE. 

Alternatively you can also press CTRL+Delete.
• To enter a series of numbers or incremented names (CAM1, CAM2 ... CAM96) press F1 to display 

the Command Window and enter in a ranged value (e.g. CAM1-12 or CAMA-Z).

Command Line Arguments
The Tally System Console application can load session files via parameters passed through the 
command line. This is especially useful if you wish to automate certain processes, such as loading 
or merging multiple sessions, when the application is first executed. Such a command line could 
then later be used in a call within a batch file.

Command Line Syntax
The common command line syntax is described below:

TallySystemConsole2.exe <INI file> <switch1> <TC2 file #1> <switchN> <TC2 file #N>

Table 8  Command Syntax

Command Description

<INI file> The custom interface file that will be applied until the application is 
closed. If a default startup custom interface file was defined to load on 
startup (Management > Configuration > Startup), the default interface 
file is ignored and the custom interface file specified on the command 
line is used.
NOTE: The *.ini extension for the file must be included in order for the 
application to recognize this as a custom interface file. Also, only one 
*.ini file should be specified on the command line. If multiple *.ini files 
are specified, the last *.ini file will be used and the rest ignored.
The *.ini file can be specified anywhere on the command line.
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Overview
Table 9 outlines the available command line switches.

switch1..switchN Any number of supported switches that will define a specific type of 
operation. The switches are not case-sensitive. Refer to Table 9 for 
details on available switches.
The switches can be specified anywhere on the command line. Its 
operation will only be applied to any preceding *.tc2 filename.

TC2 file(s) One or more session files that are to be loaded. Session files are loaded 
in the order specified on the command line.
NOTE: The *.tc2 extension for the file must be included in order for the 
application to recognize this as a Tally System Console session file.
The *.tc2 file can be specified anywhere on the command line.

Table 9  Available Command Line Switches

Command Description

/ml Merge Leave. If a newer duplicate entry in a table is found while 
loading multiple session files, the older entry will be kept and the 
newer entry will be ignored. Enabling this switch will not allow 
the newer entry to overwrite the older entry whenever a 
duplicate entry is found.
This switch can be prefixed in front of a *.tc2 file. Once enabled, 
the Merge Leave operation will apply to all other *.tc2 files on 
the command line until a different merge switch (/mo, /ma) is 
used.

/mo Merge Overwrite. If a newer duplicate entry in a table is found 
while loading multiple session files, the older entry will be 
replaced. Enabling this switch forces a merge overwrite to be 
performed whenever a duplicate entry is found.
This switch can be prefixed in front of a *.tc2 file. Once enabled, 
the Merge Overwrite operation will apply to all other *.tc2 files 
on the command line until a different merge switch (/ml, /ma) is 
used.

/ma Merge Ask User (default). If a newer duplicate entry in a table is 
found while loading multiple session files, a dialog opens asking 
the user what merge operation to perform.
This switch can be prefixed in front of a *.tc2 file. Once enabled, 
the Merge Ask User operation will apply to all other *.tc2 files on 
the command line until a different merge switch (/ml, /mo) is 
used.

/ro Read-Only mode. 
When enabled, all *.tc2 files specified after this switch will be 
loaded and marked as read-only within the application. All 
read-only rows will be colored differently than that of a normal 
read-write row.
NOTE: Saving to a session file will not include the read-only rows. 
Only read-write rows will be saved.

Table 8  Command Syntax

Command Description
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Examples of Usage
File1.tc2, File2.tc2, and File3.tc2 will be merged together and their rows set to Read Write. Duplicate 
entries encountered during the merges will cause the merge dialog to display. Custom interface file, 
Station1.ini, will be applied.

TallySystemConsole2.exe file1.tc2 file2.tc2 file3.tc2 station1.ini

File1.tc2 and File2.tc2 will be merged together and their rows set to Read Only. Base.tc2 will then be 
merged in with its rows in Read Write mode. Duplicate entries encountered during the merges will 
cause the merge dialog to display.

TallySystemConsole2.exe /ro file1.tc2 file2.tc2 /rw base.tc2

File1.tc2 and File2.tc2 will be merged together and their rows set to Read Only. Base.tc2, followed 
by Extra.tc2, will be merged in with their rows set to Read Write mode. Duplicate entries 
encountered during the merge of File2.tc2 and Base.tc2 will automatically merge using the Merge 
Overwrite mode. Duplicate entries encountered during the merge of Extra.tc2 will cause the merge 
dialog to display.

TallySystemConsole2.exe /ro file1.tc2 /mo file2.tc2 /rw base.tc2 /ma extra.tc2

/rw Read-Write mode (default). 
When enabled, all *.tc2 files specified after this switch will be 
loaded and marked as read-write within the application.
NOTE: Saving to a session file will not include the read-only rows. 
Only read-write rows will be saved. 

/set_tsi_ip:{TSI 
name},{TSI IP 
Address}

Replace a TSI given the {TSI name} with an IP address specified in 
{TSI IP Address}. 
The replacement is immediately performed after a session has 
been loaded and will continue to be replaced until the 
application is closed.
NOTE: {TSI name} is case-sensitive and must correctly match the 
TSI name in a session before the replacement is performed.
If the TSI name contains spaces, the name should be surrounded 
by a pair of quotation marks (" ") 

/set_tsi_active:{+/-}
{TSI name},...

Sets the Active state for one or more TSIs given their {TSI name}. 
The state will be set once all session files have completed loading 
or merged. When a '+' precedes the TSI name, its state will be set 
to Active (checked). If a '-' precedes the TSI name, its state will be 
set to Inactive (unchecked).
NOTE: {TSI name} is case-sensitive and must correctly match the 
TSI name in a session before its Active state can be changed. If 
the TSI name contains spaces, the name should be surrounded 
by a pair of quotation marks (" ") Multiple TSIs can be specified 
with their associated Active state by placing a comma (,) between 
each entry.

/ns No Save. 
When enabled, the Save option in the File menu will be disabled. 
This can be used to prevent the accidental overwrite of the 
opened session file. The Save As option can be used instead.

Table 9  Available Command Line Switches

Command Description
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File1.tc2 and File2.tc2 will be merged together and their rows set to Read Write. File3.tc2 will then 
be merged in as Read Only. Extra.tc2 will be merged in also as Read Only and if duplicate entries are 
encountered, no entry replacement will be performed. The Save menu will be disabled. When all 
session files have loaded, the TSI called TSI ONE will be located in the session. If found, its current IP 
address will be replaced by 10.0.0.1.

TallySystemConsole2.exe file1.tc2 file2.tc2 /ro file3.tc2 /ml extra.tc2 /set_tsi_ip: 
"TSI ONE",10.0.0.1 /ns

After the merging of File1.tc2, File2.tc2, and File3.tc2, TSI_A will be set to Active. TSI_B and TSI ONE 
will be set to Inactive. No changes to the Active state for TSI_C and TSI_D will be made because they 
are not specified on the command line.

TallySystemConsole2.exe file1.tc2 file2.tc2 file3.tc2 /set_tsi_active:+TSI_A, 
-TSI_B,-"TSI ONE"

Drag / Drop Parameters
When an item is dragged and dropped into a UMD or GPI output, for example when assigning a 
source or a destination to a UMD, the dragged-in information displays within the control expression 
for that UMD or GPI at a position determined by a clearly delineated sub-expression that is termed 
a drag / drop parameter.

The details of Drag / drop parameters needs to be know only if control expressions are to be 
modified or created. In the normal usage of Tally System Console2 various configuration items are 
dragged and dropped into UMDs, GPI outputs, RCP buttons and so on without any knowledge of 
the underlying drag and drop parameters themselves.

Where Drag/Drop Parameters Are Used
Drag / drop parameters are place-holders programmed into control expressions within the 
following editors:

• UMD Control Expressions
• GPI Output Control Expressions
• LED RCP Control Expressions
• Crosspoint Control Expressions

Drag / drop parameters may not be referenced in control expressions programmed in the 
Subroutines editor. In cases where the information embodied by a drag / drop parameter must be 
passed to a Subroutine expression then the drag / drop parameters may be assigned to a variable 
using the embedded SV function.

Drag / drop parameters not transmitted directly to any TSI as part of the configuration, but are first 
interpreted and substituted with other information, such as the name of a dragged-and-dropped 
source name, GPI input number, etc.

Tally System Console's final interpretation of the drag / drop parameters used within various 
control expressions can be examined in the Raw Expression columns of the Display Devices, GPI 
outputs and the Destinations Definitions editors.

Drag/Drop Parameter Syntax
The syntax of the drag / drop parameter is comprised of a set of angle brackets surrounding a 
parameter name, a parameter type specifier and a default text specifier. The parameter name, a 
parameter type specifier (PTS), default text specifier (DTS), required field specified (REQ), and field 
de-limiter (FLD) are separated by commas:

<{Parameter ID + Parameter #}[.property][,PTS][,DTS][,REQ][,FLD]>

• Parameter ID is a unique parameter identifier. Typically the ID is 'P' for convenience.



Tally System Console User Guide (v1-rev1) Reference • 109

• Parameter Number indicates the parameter #. Paired with the Parameter ID, this forms a unique 
parameter name which identifies a placeholder for dragging and dropping objects. E.g. P1, P2, P3, 
etc...

• Property - the property in which to access once the parameter contains an object filled within its 
placeholder. Refer to “Drag/Drop Parameter Properties” for a list of valid properties.

• PTS (Validation Type) - Indicates which type of objects are allowed to be assigned to the 
parameter. Refer to “Drag/Drop Parameter Properties” for a list of valid validation types.

• DTS (Default Text) - The displayed text if the parameter has not been assigned an object yet.
• REQ (Required flag) - Indicates whether this parameter is required to be filled with an object. If 

there is no object and the requirement flag is set, then an error displays during table validation. 
Accepted “Required” flags: Y, y, N, n, t, T, F, f, 0 (equivalent to no), 1 (equivalent to yes), REQ 
(required), and OPT (optional). Unrecognized flags will be treated as Required=true.

• FLD (Field Delimiter) - The text that will be prefixed before the displayed parameter object's 
property.

Examples:

<P>

Displays the default property (usually Name) of the drag-and-dropped object.

<P1,S>

Displays the default property (usually Name) of the drag-and-dropped object. Validation type “S” 
means that only Source objects can be dragged in.

<P2,S,Source Missing>

Displays the text “Source Missing” if no drag-and-dropped object has been assigned yet. Validation 
type “S” means that only Source objects can be dragged in.

<P3.Short,S,Source Missing>

Displays the text “Source Missing” if no drag-and-dropped object has been assigned yet. Validation 
type “S” means that only Source objects can be dragged in. If a Source object has been assigned, the 
Short property of the Source will be displayed.

<P1.Short,,Source Missing>

Displays the text "Source Missing” if no drag-and-dropped object has been assigned yet. No 
validation type specified so any dragged-in object is acceptable. The Short property of the object will 
be displayed.

<P1.Name,,,N,-->

Drag-and-drop of any object is optional for this parameter (REQ flag type 'N'). Any assigned object 
will be displayed with the Name property. A '--' will be prefixed in front of the name.

A typical drag / drop parameter usage might be:

SRC(<P1.IOSpec>) or SRC(<P1>)

This is the embedded SRC function which expects a resource device destination number or 
mnemonic, which could be dragged into this expression and that could result in, for example, the 
following expression being transmitted to the TSI as part of the configuration: SRC(RTR::MON1[1])

Drag/Drop Parameter Properties
Properties of a dragged and dropped expression parameter determine what information is 
extracted from the dragged and dropped configuration item. Consider for example a router input 
dragged into an expression. 

The <IOSpec> property of P1 shown in the previous section would be explicitly interpreted by Tally 
System Console as a router destination number or mnemonic. However if the property is not given, 
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the Tally System Console makes the assumption that the router destination number or mnemonic 
is wanted. However if, for example, the Long Name of the destination is required, then <P1.Long> 
can be specified.

Other properties that can be specified for extraction from a dragged and dropped configuration 
item are .Name (name of the item as programmed in Console 2), .IOName (like .IOSpec but without 
the level specifier when a router resource device input is used) and so on. A complete list of item 
properties is shown below.

If instead the name of the production switcher input, as programmed in the Input Names editor, 
was required then P1.Name would be used instead, which might then be interpreted, as for 
example: MyMonitor1

A brief set of properties for each dragged-in type of configuration item are listed in Table 10. A full 
set of properties are listed lower down the page:

In Table 10, a bolded property name indicates the default property for a give configuration item 
type. Keep the following in mind:

• The Bolded property name is the default property that will be used when no property names are 
specified. E.g. <P1> returns P1.IOName result.

• For a resource device IO specified as RTR::OUT1, the property Resource represents RTR, IOName 
is OUT1, and IOSpec is RTR::OUT1.

• Tally types can be user defined in Tally Type table column.
• GPI Input ListL (logical list) parameter returns comma separated logical number list/range of 

values (e.g. “1-10,13,15”). A description such as “Switched by GPI Inputs <P1.List>” may evaluate to 
“Switched by GPI Inputs 1-10,13,15”.

• GPI Input ListP (physical list) parameter returns comma separated list/range of values identified 
by hardware location (e.g. “TSI1,IO6,1-4” where the format is <TSI Name>,<IO Connector>,<IO 
1-8>).

• To specify one of the resource device outputs which could belong to a tally type, use the format 
<Parameter>.PGM[1] (e.g. P1.PGM[1] or P2.PGM[1].IOName), where [1] is a number subscript 
starting from 1 representing the current destination index to return.

Table 10  Configuration Items

Parameter Allowed Properties

Source Definition
Destination
Definition
Resource Device Input
Resource Device Output

Name, Resource, IOSpec (default), IOName, Long, Short, StyleA, 
StyleB

Tally Area Name, Number (default), {Area name}, {Area name}
[x] - x is tally area index #

Tally Type Name, Number (default), Resource, IOSpec,
IOName, {Tally Type}, {TallyType}[x] - x is a tally type
index, {TallyType}[x].Destination

GPI Input Name, Number (default), Start, Length

Port Name (default), TSIName, TSIID, Connr

Expression (Style) Name (default), Description, Content1, Content2

Tally Map Input Name (default)
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• For example <P1.IOSpec> is equivalent to <P1> 
• Specific examples of each property type:

Tally Map Expression Handling
Tally maps make use of expressions which perform functions based on the input that it receives. 
This section will give details on how these expression are built and handled by the application.

Building the Expressions
Each tally map input entry is associated with an input style. The generated input style expression 
will then be used as a parameter passed into the output device style when an input-output 
assignment is made in the tally map layout.

For example, creating these tally map inputs in Table 11

Means that you want to create an input called CAM-1 which will have 2 different characteristics 
when selected in the tally map pin-grid. If the input is assigned to a UMD output device, the (UMD) 
Source style will be used.

Likewise if the input is assigned to a GPI output device, the (GPI) Source On Air style will be used. 
The same applies for input CAM-2. Each input at some point will be evaluated with a result which 
might look like Table 12.

On a simplistic level, the inputs (refer to “Input Expression Passing” for the reason why they are 
not truly the evaluated results) fed into a tally map output expression. Which tally map output 
expression is used is determined by the configuration within the Tally Map Profile Settings. The tally 
map output expression is the final stage in determining what is sent out to the output device. All the 
logic to evaluate the inputs are done here and a final result, ready for output, is generated. 

Suppose the tally map profile is set up as follows:

Output Device: UMDs Style: (Tally Map) UMD Single

Style Expression: sv(!TA,<%TA>)sv(!TT1,<%TA.PGM>)sv(!TT2, <%TA.PST>)sv(!DT,<%DT>)<P1,,,n>

Table 11  Examples of Tally Map Inputs

Input 
Name

Style Output Device Raw Expression

CAM-1 UMD > Source UMD Device sv(!S,"*_DA::CAM01")sv(!FMT,FMTA)fn([ ]SRC)

CAM-1 GPI > Source On Air GPI Output tlya("*_DA::CAM01",[ ],[ ])

CAM-2 UMD > Destination UMD Device sv(!D, "RTR::001[1]")sv(!FMT,FMTA)fn([ ]DST)

CAM-2 GPI > Destination On Air GPI Output tlya("*_DA::CAM01",[ ],[ ])

Table 12  Using the GPI Source On Air Style

Input Name Output Device Result

CAM-1 UMD Device ac(1)CAM01

CAM-1 GPI Output 0

CAM-2 UMD Device ac(2)VTR01

CAM-2 GPI Output 1
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Output Device: GPI Outputs Style: (Tally Map) GPI OR Style

Style Expression: sv(!X,<P1,,,n><P2,,,n><P3,,,n><P4,,,n><P5,,,n><P6,,,n> 
<P7,,,n><P8,,,n><P9,,,n><P10,,,n>)if(len(v(!X)),if(pos(1,v(!X),1),1,0),0)

In this scenario, on an assignment of CAM-1 input with a UMD device, the evaluated input result is 
displayed as is. Since the output expression only has one parameter <P1>, it can only accept one 
input at a time. In essence, this is equivalent to only being allowed to do a single input select. 
CAM-1's evaluated result “ac(1)CAM01” will be in the <P1> slot when the final output expression is 
evaluated.

If CAM-2 input is then selected, CAM-2's evaluated result “ac(2)VTR01” would be placed into <P1> 
slot - replacing the previous result from CAM-1.

On the other hand, if CAM-1 input is paired with a GPI output device, its evaluated result of “0” 
would display in the first available (which is <P1>) slot in the output expression. Then if CAM-2 input 
is also paired with the same GPI output device, its evaluated result of “1” would display in the next 
available (<P2>) slot. The “(Tally Map) GPI OR Style” expression contains logic to evaluate all 
assigned inputs and performs a bitwise OR on them, returning a single result.

The “(Tally Map) GPI OR Style” expression demonstrates how more than one input can be 
selected/allowed, whereas the “(Tally Map) UMD Single” expression will only allow one input at a 
time.

Input Expression Passing
As mentioned earlier, the input is passed into the tally map output expression. However, 
completely evaluated results are not passed into the tally map output expression directly because 
of the possibility of non-evaluatable parameters. Rather, the raw input expression is passed directly 
into the tally map output expression. The evaluation will be performed at the tally map output side 
before being sent to the output device.

Non-Drag/Drop Parameter Handling
A non-tally map expression used by a UMD, GPI Output, RCP LED Output, or Output Control is 
equivalent to a single-level expression. All the required parameters and special non-drag-and-drop 
tags (e.g. <%TA>) are evaluated on the spot and sent to the output device. On the other hand, tally 
map expressions are two-level expressions. Tally Map Inputs are passed into the tally map output 
expression and a final combined evaluation is performed before being sent to the output device.

Normally, non-drag-drop tags such as <%BT> or <%TA> are parameter slots that are automatically 
filled by the table that the expression is in. However, Tally Map Input expressions generated in the 
tally map inputs table do not have any knowledge of what the non-drag-drop tags should be filled 
with. This is the main reason why the Raw Expression column may show incomplete parameters 
(most commonly represented by a pair of square brackets [ ]). However, once the input is passed 
into the output expression, the non-drag-drop tags will then be evaluated at the tally map output 
side. The final output expression should not have any incomplete parameters.
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Embedded Functions
This chapter explains how to use embedded functions.

Overview
Embedded functions can display in the control text of a remote display unit section, GPI output, 
resource output, or global message to perform various tasks. Embedded functions control display 
attributes, such as color and formatting, they provide “programming language” features such as 
variable assignment and referencing, math and logical functions, iteration, text manipulation, and 
system status information functions.

Most functions “return” a string of characters as a result of evaluating the function. The return 
string can be used as literal text or supplied to another higher-level function (the higher level 
function used another function as one of its arguments).

Some functions return an empty string (zero characters) because they have other side-effects such 
as variable assignment.

Some embedded functions return a string of characters identifying some element of system status. 
Examples would be a source name for a routing switcher crosspoint or the state of a GPI input 
signal.

Function names are not case sensitive. Function arguments are enclosed with left and right 
parenthesis characters and separated with a comma character. Enclose a comma or left or right 
parenthesis character in double or single quotes to specify the character literally.

 If copying and pasting example code, remove spaces that trail commas.

Table 13  Embedded Function Descriptions

Function Meaning Example or Prototype Description

Arithmetic Functions

ADD Function Add add(a, b) Add two values

DIV Function Divide div(a, b) Divide one value by another value

EQ Function Equate eq(a, b) Compare two values

GE Function Greater than or equal 
to

ge(a, b) Compare a >= b

GT Function Greater than gt(a, b) Compare a > b

LE Function Less than or equal to le(a, b) Compare a <= b

LT Function Less than lt(a, b) Compare a < b

MOD Function Modulus mod(a, b) Take arithmetic modulus a % b

MUL Function Multiple mul(a, b) a x b

SUB Function Subtract sub(a, b) a - b

Boolean Functions

AND Function And and(a, b) true if a and b are both non-zero

NOT Function Not not(a) true if a is zero

OR Function Or or(a, b) true if either a or b are non-zero

XOR Function Exclusive Or xor(a, b) true if only one of a and b is zero
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Bitwise Boolean Functions

BA Function Bitwise and ba(a, b) Bitwise and of values a and b

BN Function Bitwise not bn(a, b) Bitwise complement of given value

BO Function Bitwise or bo(a, b) Bitwise or of values a and b

BX Function Bitwise exclusive or bx(a, b) Bitwise excusive or of values a and b

Character Graphic Functions

GC Function Show uploaded graphic 
character

GC(1) Show uploaded graphic character

Conversion Functions 

B2N Function Binary to list b2b(n, offset) List the true bits in a decimal 
number (e.g. 7=0, 1, 2)

CHR Function ASCII code to character chr(32) Convert ASCII code to a character

D2H Function Decimal to Hex d2h(10) Convert decimal number to 
hexadecimal number

H2D Function Hex to Decimal h2d(1A) Convert hexadecimal number to 
decimal number

HEX Function Decimal to hex hex(10) Convert decimal number to 
hexadecimal number

N2B Function List to binary n2b("1, 2, 3", 0) Form a decimal number from a list of 
true bits (e.g. 0, 1, 2=7)

VAL Function Character to ASCII code val(A) Convert character to its ASCII code

Display Attribute Functions

AF Function Attribute - font af(0) Set UMD font size

AJ Function Attribute - justify aj(0) Justify UMD text

AC Function Attribute - color ac(85) Set UMD text color

ID Function ID of display id() Show numeric ID of UMD

NAME Function Name of display name() Show name of UMD

OPT Function Display programming 
option

opt(rent, on) Set programming options for UMD

Formatting Functions

S Function Show styled name s(SWR::1, A) Strips off resource device, level 
specifiers, and shows name of input 
as directed by the given style (long 
name, short name, etc.)

GPI Programming Functions

I2N Function GPI Input to list i2n(0, 4, 1) List the active GPIs input in a set of 
consecutive GPI inputs

IGS Function GPI input select IGS(channel, length, 
offset, transition, 
cascade, user bit, 
variable))

Show the last- activated GPI input of 
a consecutive set of GPI inputs - 
returns only one value

Table 13  Embedded Function Descriptions (Continued)

Function Meaning Example or Prototype Description
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IGM Function GPI input multi- select IGM(channel, length, 
offset, transition, 
cascade)

Show toggle state of any GPI input 
of consecutive set of GPI inputs - 
may return multiple values

IV Function GPI input value (state) iv(0) Show current state of a GPI input

IVC Function GPI input value 
changed

IVC(channel, length, 
transition, user bit)

Show bitmap of GPI inputs in a set 
of consecutive GPI inputs that have 
change state

IVT Function GPI input value toggle IVT(channel, transition, 
modulus)

Show toggle count of given GPI 
input, bounded by the given 
modulus, Typically used to toggle 
between 1or 0 on each change of 
state of the given GPI input

Path Tracing Functions

OD Function Origin destination 
feeding source

od(SWR::1) Show destination feeding the given 
input

PGD Function Program destination PGD(SWR::1, 0) Show program destination that has 
selected this input

PGM Function Source on program PGM(SWR::1) True if this source is selected by a 
program destination

PSD Function Preset destination PSD(SWR::1, 0) Show preset destination that has 
selected this input

PST Function Source on preset PST(SWR::1) True if this source is selected by a 
preset destination

SID Function Source in destination SID(*DA::CAM1, 
SWR1::GP1RED, 
SWR2::GP1RED)

Index of the given destination that 
has selected this input

SRC Function Show source on 
destination

SRC(RTR::MON1[1]) Show name of source on given 
destination

TLYA Function Tallied source tlya(*DA::CAM1, <%TA>, 
<%TA.PGM>)

True if given source is selected by 
the destination(s) defined in the 
given tally type in the given tally 
area

XPT Function Crosspoint on 
destination

XPT(RTR::MON1[1]) Show input immediately selected by 
the given destination

Programming Functions

DO Function Loop do(<condition>, 
<expression>)

Execute an expression while a 
condition is true

FN Function Call a custom 
subroutine

fn(MYTEST) Execute the expression stored in the 
given variable

IF Function Decision if(<condition>, <if 
true>, <if false>)

show expression a result if condition 
is true, otherwise show expression b 
result

ON Function Select on(<index>, <exp 0>, <exp 
1>, <exp 2>, …)

Pick expression from list of 
expression based on the value of a 
list index

SV Function Save variable sv(!X, 1) Save expression result into variable 
of the given name

Table 13  Embedded Function Descriptions (Continued)

Function Meaning Example or Prototype Description
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V Function Read variable v(!X) Show value stored in variable of the 
given name

System Control Functions

SETI Function Set interconnect SETI(<Name>, <Origin>, 
<Create>, <Trigger>, < 
Input1>, < Input2>, …)

Dynamically set interconnect

SETX Function Set crosspoint SETX(<Destination>, 
<Create>, <Clear>, 
<Trigger>, <Set>, 
<Process>, <Device Input 
1>, <Device Input 2>, …)

Dynamically set virtual crosspoint

Text processing Functions

LC Function Lower case lc(A) Lower case given text

LEN Function Length len("shows6") Length of given text

POS Function Find position of text 
(search)

pos("world", "hello 
world", 1)

Find first given text in second given 
text

SS Function Sub-string ss("hello world", 7, 5) Show substring of given text

TL Function Strip leading (left) 
spaces

tl(" hello) Show given text without leading 
spaces

TR Function Strip trailing (right) 
spaces

tr("hello ") Show given text without trailing 
spaces

UC Function Upper case uc(a) Upper case given text

Time Functions

AT Function Active timer to display 
single SP

AT("T1")SP(1)SP(2):SP(3)
SP(4)

Define timer to be displayed by 
following timer display Functions

CH Function Show timer digit CH(1)CH(2):CH(3)CH(4) Show timer digit

DATE Function Show date date() Show date

GPM Function Get system parameter 
mode (time)

GPM("T1") Get system parameter mode (time)

GPV Function Get system parameter 
value (time)

GPv("T1") Get system parameter value (time)

SP Function Show timer digit AT("T1")SP(1)SP(2):SP(3)
SP(4)

Show timer digit

SPM Function Set system parameter 
mode (time)

SPM(T1, 0215000010100--) Set system parameter mode (time)

TICK Function Show current system 
tick

tick() Show current system tick

TIME Function Show timer time() Show timer

UMD Programming Function

DUR Function Set display line 
duration

dur(20) Show display line for the given time

LIN Function Define display line lin(7) Following text is assigned to given 
lines specified by given bitmap

Table 13  Embedded Function Descriptions (Continued)

Function Meaning Example or Prototype Description
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Embedded Functions Reference
This section provides examples of embedded function usage.

ADD Function
Format: ADD(exp1,exp2)

The result is the sum of the numeric value exp1 and exp2.

Example: SV(!X,ADD(V(!X),1))

Increment the value of temporary variable X by 1.

AC Function
Format: AC(exp1)

The value exp1 is 4 pairs of 2-bit numbers to form 8-bit number from 0 to 255. Each bit pair is a 
green and red bit. The bit pair used is determined by local tally inputs T1 and T2. Set all 4 pairs the 
same for fixed color (the color not affected by tally state).

Calculate value exp1 by adding values from Table 14. 

SL Function Source list sl(SWR::GP1READ, A, 100) Show list of source selected on this 
destination

SLA Function Source list sl(SWR::GP1READ, A, 100, 
<%TA>), ac(NML), ac(PGM), 
ac(PST)

Show list of source selected on this 
destination using tally areas

TSD Function Show tallied 
destination name

tsd(RTR::MON1[1], A, 
ac(PGM), ac(PST), 
ac(NML))

Show styled name of given 
destination with tally

TSDA Function Show tallied 
destination name using 
tally areas

tsda(RTR::MON1[1], A, 
<%TA>, ac(NML), ac(PGM), 
ac(PST))

Show styled name of given 
destination with tally using tally 
areas

TSS Function Show tallied source 
name

tss(SWR::1, A, ac(PGM), 
ac(PST), ac(NML))

Show styled name of given source 
with tally

TSSA Function Show tallied source 
name using tally areas

tssa(SWR::1, A, <%TA>, 
ac(NML), ac(PGM), 
ac(PST))

Show styled name of given source 
with tally using tally areas

TSX Function Show source on 
destination

tsx(RTR::MON1[1], A, 
ac(PGM), ac(PST), 
ac(NML))

Show styled name of source on 
given

Table 14  AC Function Values

Color Active Local Tallies

None T1 T2 T1 & T2

Blank 0 0 0 0

Red 1 4 16 64

Green 2 8 32 128

Amber 3 12 48 192

Table 13  Embedded Function Descriptions (Continued)

Function Meaning Example or Prototype Description
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• Fixed red is 85 (1 + 4 + 16 + 64)
• Fixed green is 170 (2 + 8 + 32 + 128)
• Fixed amber is 255 (3 + 12 + 48 + 192)

Example: AC(85)RED AC(255)AMBER AC(170)GREEN

The result is RED AMBER GREEN in their respective colors.

Example: AF(19)123 AF(0)LARGE

The result is 123 in small reversed characters and LARGE in fixed spaced characters.

AF Function
Format: AF(exp1)

The value exp1 is a character set selector as follows:

 Some character sets may not be available on all remote display units.

Example: AF(19)123 AF(0)LARGE

The result is 123 in small reversed characters and LARGE in fixed spaced characters.

AJ Function
Format: AJ(exp1)

The value of exp1 is a justify mode selector as follows: 

Use more than one mode but always in order of left, center, and right. Full-width mode cannot be 
used with other modes. 

Example: AJ(1)CENTERAJ(2)RIGHT

The result is CENTER in the middle of display and RIGHT on the right side.

Table 15  AC Function Values

Value Description

0 fixed spacing (default)

1 large proportional spacing

2 medium proportional spacing

3 small

4 wide proportional spacing

5 block proportional spacing

8 vertical orientation

16 dot reverse

Table 16  AC Function Values

Value Description

0 left (default)

1 center

2 right

3 full-width
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AND Function
Format: AND(exp1,exp2)

If both exp1 and exp2 are not zero the result is 1, otherwise the result is zero.

Example: SV(!Z,AND(V(!X),V(!Y)))

If the temporary variable X is not zero and the temporary variable Y is not zero, set the value of 
temporary variable Z to 1, otherwise set the value of temporary variable Z to zero.

AT Function
Format: AT(exp1)

Enables the timer/counter named exp1 to display in the display Subsequent SP() functions refer to 
digits of the last selected timer/counter. Select up to 4 timers per display.

Example: AT(T1)SP(1)SP(2):SP(3)SP(4)

The result is hours and minutes for timer named T1 in HH:MM format.

B2N Function
Format: B2N(exp1,exp2)

Return a list of numbers, starting from the value given by exp2 that represents the bits set in the 
decimal number given in exp1. If exp2 is omitted, a value of zero of assumed. Non-numeric 
expressions or the number 0 in exp1 return an empty string. Numbers in the list are separated by 
commas.

Examples: 

B2N(7,0) returns “0,1,2”

B2N(7,1) returns “1,2,3”

This function is useful for converting a number to a list of inputs for output controls. See also “N2B 
Function”.

BA Function
Format: BA(exp1,exp2)

Each bit within the result value is 1 if the corresponding bits in the numeric values exp1 and exp2 
are both 1, otherwise that result bit is zero. The result bits are combined to produce the result 
value.

Example: SV(!X,BA(V(!Y),15))

The value of the temporary variable X is set to the least significant four bits of temporary variable Y.

BN Function
Format: BN(exp1)

Each bit within the result value is the inversion of the corresponding bit in the value exp1 (one’s 
complement).

Example: SV(!X,BN(V(!X))

Invert the value of the temporary variable X.

BO Function
Format: BO(exp1,exp2)



120 • Embedded Functions Tally System Console User Guide (v1-rev1)

Each bit within the result value is 1 if either of the corresponding bits in the numeric values exp1 
and exp2 are 1, otherwise that result bit is zero. The result bits are combined to produce the result 
value.

Example: SV(!X,BO(V(!X),1))

The value of the temporary variable X is set to nearest odd value.

BX Function
Format: BX(exp1,exp2)

Each bit within the result value is 1 if the corresponding bits in the numeric values exp1 and exp2 
are different, otherwise that result bit is zero. The result bits are combined to produce the result 
value.

Example: SV(!X,BX(V(!X),255))

The least significant eight bits of the value of the temporary variable X are inverted.

CH Function
Format: CH(exp1)

The result is a timer/counter digit for selector exp1, from 1 to 69. This function provides access to 
timer/counter digits regardless of the currently selected timer. Usually, this is not needed, and 
access to timer/counter digits is accomplished using AT and SP functions.

Example: CH(1)CH(2):CH(3)CH(4)

The result is hours and minutes digits of first timer/counter.

CHR Function
Format: CHR(exp1)

The result is a single character having the ASCII value exp1.

Example: SV(!X,CHR(61)CHR(62)CHR(63))

The temporary variable X is set to ABC.

DATE Function
Format: DATE(exp1)

The result is a sample of the day, month, year, and day of week adjusted for the timer named exp1, 
or the local date (unadjusted) if exp1 is omitted.

Example: SV(!D,SS(DATE(),1,4)))

The temporary variable D is set to the local year.

D2H Function
Format: D2H(exp1)

Return the hexadecimal equivalent of the decimal number in exp1. The returned number is an 
ASCII representation of a hexadecimal number.

Example: D2H(10) returns "A"

See also “H2D Function”.
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DIV Function
Format: DIV(exp1,exp2)

The result is the division of the numeric value exp1 and exp2. The remainder is discarded. If exp2 is 
zero, the result is also zero.

Example: SV(!X,DIV(V(!X),10))

The temporary variable X is divided by 10.

DO Function
Format: DO(exp1,exp2)

Repeatedly return the result of evaluating exp2 until exp1 is zero or a maximum of 100 iterations is 
reached. For effective use, evaluating exp2 must cause exp1 to eventually change to zero.

Example: SV(!X,0)DO(LT(V(!X),5),SV(!X,ADD(V(!X),1))V(!X)" ")

The result is the numbers from 1 to 5 separated by spaces.

DUR Function
Format: DUR(exp1)

Specifies the amount of time exp1, in hundredths of a second, to display the previously selected 
lines (use the LIN function to select lines). All displays have three separate lines that are displayed in 
sequence, each for their programmed duration. A line duration of zero prevents the line from 
displaying. If the duration of all lines are zero, the first line displays continuously.

Example: LIN(1)DUR(100)ON-AIRLIN(2)DUR(50)STUDIO 1

Flash ON-AIR for 1 second and STUDIO 1 for one half second.

EQ Function
Format: EQ(exp1,exp2,exp3,exp4,...)

The result is 1, 2, 3, ... if exp1 is equal to exp2, exp3, exp4, ..., respectively. The result is zero if exp1 
is not equal to any of exp2, exp3, exp4, ... .

Example: EQ(V(!X),JOHN,BOB,JIM,DAVE)

The result is 1, 2, 3, or 4, for values JOHN, BOB, JIM, or DAVE of temporary variable X

FN Function
Format: FN(exp1)

The value of the variable named exp1 is inserted and evaluated as if it displays in place of the FN 
function. Use this function to apply common portions of control text to many displays at once. 
Create a global message containing the common text fragment as its value and re-use the fragment 
where needed using the FN function with the name of the global message.

Example: SV(!Y,"SV(!X,ADD(V(!X),1))")SV(!X,0)FN(!Y)V(! X) FN(!Y)V(!X) FN(!Y)V(!X)

The result is 1 2 3.

GC Function
Format: GC(exp1)

The result is a graphic character for selector exp1, from 1 to 9. If the graphic character is not 
defined, the result is the empty string.
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Example: IF(IV(0),PLAYGC(1),STOPGC(2))

The result is PLAY and graphic character 1 if GPI input 0 is on, otherwise the result is STOP and 
graphic character 2.

GE Function
Format: GE(exp1,exp2)

If exp1 is greater than or equal to exp2 the result is 1, otherwise the result is zero. If either of exp1 
or exp2 are non-numeric, the strings are compared lexically in ASCII order ("ACC" is greater than 
"ABC").

Example: IF(GE(V(!X),10),"ALARM OVERFLOW",V(!X)" ALARMS")

If the temporary variable X has a value of 10 or more the IF function evaluates to the text "ALARM 
OVERFLOW", otherwise the IF function evaluates to the text "n ALARMS", where n is the value of 
temporary variable X.

GPM Function
Format: GPM(exp1)

Gets the system parameter mode of the timer/counter named exp1.

Example: ON(EQ(SS(GPM(T1),6,2),24,29),OTHER,PAL,NTSC)

The result is PAL, NTSC, or OTHER if the timer named T1 counts in 25, 30, or some other number of 
frames per second.

GPV Function
Format: GPV(exp1)

Gets the system parameter value of the timer/counter named exp1.

Example: SV(!X,SS(GPV(T1),1,2))

Set the temporary variable X to the current hour of the timer named T1.

GT Function
Format: GT(exp1,exp2)

If exp1 is greater than exp2 the result is 1, otherwise the result is zero. If either of exp1 or exp2 are 
non-numeric, the strings are compared lexically in ASCII order ("ACC" is greater than "ABC").

Example: IF(GT(V(!X),10),"ALARM OVERFLOW",V(!X)" ALARMS")

If the temporary variable X has a value more than 10 the IF function evaluates to the text "ALARM 
OVERFLOW", otherwise the IF function evaluates to the text "n ALARMS", where n is the value of 
temporary variable X.

H2D Function
Format: H2D(exp1)

Return the decimal equivalent of the hexadecimal number in exp1. Like most functions in the 
mathematical group, the returned number is an ASCII representation of a decimal number.

Example: H2D(A0) returns "160"

See also “D2H Function”.
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HEX Function
Format: HEX(exp1)

Same as H2D function. Return the decimal equivalent of the hexadecimal number in exp1. Like 
most functions in the mathematical group, the returned number is an ASCII representation of a 
decimal number.

Example: H2D(A0) returns "160"

See also “H2D Function”, and “D2H Function”.

I2N Function
Format: I2N(exp1,exp2,exp3)

Converts a set of active GPI inputs to a list of numbers. 

• Value exp1 is the first GPI input number.
• Value exp2 is the number of consecutive GPI inputs.
• Value exp3 is the first number of a sequence that corresponds with the first GPI input.

This function is commonly used to implement a multiple source output of a resource device. The 
I2N function is specified in the control text of one of the resource outputs of the device.

Example: I2N(40, 20, 1)

The result is the numbers from 1 to 20 separated by spaces that correspond to active GPI inputs 
from 40 to 59.

ID Function
Format: ID()

The result is the serial number of up to 6 characters followed by the section number 1, 2, or 3 of the 
display section that is accessing this function.

Example: ON(SS(ID(),LEN(ID()),1),,LEFT,CENTRE,RIGHT)

The result is LEFT, CENTRE, or RIGHT depending on the display section.

IF Function
Format: IF(exp1,exp2,exp3)

If exp1 is not zero, the result is exp2, otherwise the result is exp3.

Example: IF(IV(0),”ALARM 1”,”NO ALARMS”)

If GPI input number 0 has is active, the IF function evaluates to the text "ALARM 1". If GPI input 
number 0 is not active, the IF functions evaluates to the text "NO ALARMS".

IGM Function
Format: IGM(channel, length, offset, transition, cascade)

IGM (Input Group Mixer) multi-selects GPI inputs, returning a list of relative numbers representing 
the selected GPI inputs in a group of consecutive GPI inputs. In a typical application, hitting buttons 
on an RCP panel programmed with the IGM function allows more than one button to be selected at 
the same time. IGM returns a list of comma-separated numbers starting from "offset".Depending 
on the value of the Transition parameter IGM selects buttons on the button press, on the button 
release, or either.

• Channel: Starting address.
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• Length: Number of consecutive addresses monitored, including the starting address.  Default: 1
• Offset: The value returned when the first GPI input of the group is selected. Other returned 

values are consecutive. This allows control of the starting value of the returned list. Default: 0
• Transition:

› A value of "1" enables detection of a off-to-on transition.
› A value of "2" enables detection of an on-to-off transition.
› A value of "3" enables detection of both transition edges.
› A value of "0" causes the function to return an empty string. Default: "1" (off-to-on transition).

• Cascade: This allows another input list to be appended to the list returned by IGM. This is useful 
for cascading IGM functions for the handling of disjointed ranges of inputs. Default: no list.

Examples:

IGM(4,3,1) multi-selects GPI inputs 4,5,6 and returns some combination of the numbers "1","2","3".

IGM(1,3,1,1,IGM(11,3,4,1)) multi-selects GPI inputs 1,2,3 along with GPI inputs 11,12,13 and returns 
some combination of the numbers "1","2","3","4","5","6".

Note that the "cascaded" IGM function is for 4 in order provided a consecutive set of return values. 
See also “IGS Function”.

IGS Function
Format: IGS(channel, length, offset, transition, cascade, user bit, variable)

IGS (Input Group Select) single-selects GPI inputs, returning a single value, the relative number of 
the most-recently-changed GPI input. In a typical application, pressing a button on an RCP panel 
selects the last-pressed button in a group of buttons, allowing one button to be selected at a time, 
while automatically canceling previous selections.

• Channel: starting address.
• Length: number of consecutive addresses monitored, including the starting address. Default: 1
• Offset: The value returned when the first GPI input of the group is selected. Other returned 

values are consecutive. This allows control of the starting value of the returned list. Default: 0
• Transition:

› A value of "1" enables detection of a off-to-on transition.
› A value of "2" enables detection of an on-to-off transition.
› A value of "3" enables detection of both transition edges.
› A value of "0" causes the function to return an empty string. Default: "1" (off-to-on transition).

• Cascade: This allows another input list to be appended to the list returned by IGS. This is useful 
for cascading IGS functions for the handling of disjointed ranges of inputs. Default: no list.

• User bit: A value of 0 to 7 allows more than one IGS function to monitor the same GPI input. A 
unique user bit value would be used in each instance of IGS functions that monitor overlapping 
ranges of GPI inputs in a given tally system configuration. For example if IGS(0,2,1) and IGS(0,3,1) 
(overlapping GPI inputs 0 and 1), then IGS(0,2,1,,,0,*S) and IGS(0,3,1,,,1,*S) would be programmed, 
where the user bit numbers are "0" and "1" respectively. Default: 0

• Variable: This static variable is required for working memory for detecting and tracking GPI input 
changes. IGS functions used in the same display, GPI output or output control must have 
different static variable names. Default: none; a static variable name, starting with the asterisk 
character, must be supplied.

Example: IGS(0,3,1,,,,*S) would single-select one of GPI

inputs 0, 1 and 2, returning one of numbers "1", "2" or "3", depending on which GPI input was last 
toggled from the off to the on state.
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See also “IGM Function”.

IV Function
Format: IV(exp1)

The result is 1 if GPI input exp1 is active, otherwise the result is zero. Value exp1 must be numeric 
from 0 to 511.

Example: SV(!X,EQ(IV(0)IV(1)IV(2),100,110,111))

Sets temporary variable X to 1 if GPI input 0 is on and inputs 1 and 2 are off. Sets temporary variable 
X to 2 if GPI inputs 0 and 1 are on and input 2 is off. Sets temporary variable X to 3 if GPI inputs 0, 1, 
and 2 are on. For any other conditions of GPI inputs 0, 1, and 2, set temporary variable X to 0.

IVC Function
Format: IVC(channel, length, transition, user bit)

Returns a value of 1 when a change is detected on a given set of GPI inputs. The 1 is returned for 
only one evaluation of the expression; subsequent evaluations without another transition on the 
set of GPI inputs will return “0”. Therefore this function must usually be used in conjunction with a 
variable in order to trap GPI input transitions.

• Channel: starting address.
• Length: number of consecutive addresses monitored, including the starting address. Default: 1
• Transition:

› A value of "1" enables detection of a off-to-on transition
› A value of "2" enables detection of an on-to-off transition
› A value of "3" enables detection of both transition edges.
› A value of "0" causes the function to return an empty string. Default: “1” (off-to-on transition).

• User bit: A value of 0 to 7 allows more than one IVC function to monitor the same GPI input. A 
unique user bit value would be used in each instance of IGS functions that monitor overlapping 
ranges of GPI inputs in a given TSI configuration.

Example: sv(COUNT,if(ivc(0,4,1,0),add(v(COUNT)1,),v(COUNT))) 

will increment variable COUNT each time any of GPI inputs 0 to 3 toggle from the off to the on state.

See also “IVT Function”.

IVT Function
Format: IVT(channel, transition, modulus)

IVT returns a modulus of the count of the number of transitions detected on a given GPI input. In a 
typical application this can be used to toggle through a set of numbers by repeated presses of a key 
on an RCP panel.

• Channel: starting address.
• Transition:

› A value of "1" enables detection of a off-to-on transition
› A value of "2" enables detection of an on-to-off transition
› A value of "3" enables detection of both transition edges
› A value of "0" causes the function to return an empty string. Default: "1" (off-to-on transition).

• Modulus: Causes the returned transition count to be limited to the range zero to one less than 
the "modulus" parameter value. Default value: 2 (this causes the IVT function to return "0" or "1" 
on alternating transitions, making the returned value behave as an on-off toggle).
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Example:

IVT(0,1,4) returns one of values "0", "1", "2", "3", in that order, on each transition of GPI input "0" to 
from the off to the on state.

See also “IVC Function”.

LC Function
Format: LC(exp1)

Any upper case letters in exp1 are converted to lower case in the result.

Example:

UC(SS(V(!X),1,1))LC(SS(V(!X),2,50))

Modifies the temporary variable X to have the first character in upper case and the remaining 
characters in lower case.

LE Function
Format: LE(exp1,exp2)

If exp1 is less than or equal to exp2 the result is 1, otherwise the result is zero. If either of exp1 or 
exp2 are non-numeric, the strings are compared lexically in ASCII order ("ABC" is less than "ACC").

Example: IF(LE(V(!X),10),"IN RANGE","OUT OF RANGE")

If the temporary variable X has a value of more than 10 the IF function evaluates to the text "OUT 
OF RANGE", otherwise the IF function evaluates to the text "IN RANGE".

LEN Function
Format: LEN(exp1)

The result is the number of characters in exp1.

Example: SS(" ",1,DIV(SUB(20,LEN(V(!X))),2))V(!X)

The result is the contents of temporary variable X centered in a 20-character display area.

LIN Function
Format: LIN(exp1)

Selects the lines to be affected by subsequent text and functions. All displays have three separate 
lines that are displayed in sequence, each for the duration specified by the DUR function.

Calculate value exp1 by adding values from the following table: 

 To select all lines, use a value of 7 (1 + 2 + 4).

Example:

LIN(7)DUR(200)STATUS: LIN(1)OPENLIN(2)FROM 9 AMLIN(4)TO 5 PM

Table 17  LIN Function Values

Line Value

First 1

Second 2

Third 4
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The result is STATUS: followed by one of OPEN, FROM 9 AM, TO 5 PM, pausing on each for 2 
seconds.

LT Function
Format: LT(exp1,exp2)

If exp1 is less than exp2 the result is 1, otherwise the result is zero. If either of exp1 or exp2 are 
non-numeric, the strings are compared lexically in ASCII order ("ABC" is less than "ACC").

Example: IF(LT(V(!X),10),"BELOW TEN","TEN OR MORE")

If the temporary variable X has a value of 10 or more the IF function evaluates to the text "TEN OR 
MORE", otherwise the IF function evaluates to the text "BELOW TEN".

MOD Function
Format: MOD(exp1,exp2)

The result is the remainder of the division of the numeric value exp1 and exp2. The dividend is 
discarded. If exp2 is zero, the result is also zero.

Example: SV(!X,MOD(V(!X),10))

Sets the temporary variable X to a modulo-10 value.

MUL Function
Format: MUL(exp1,exp2)

The result is the product of the numeric value exp1 and exp2.

Example: SV(!X,MUL(V(!X),2))

Doubles the value of the temporary variable X.

N2B Function
Format: N2B(exp1,exp2)

Return a decimal number calculated from a list of set bit numbers, where the number 0 is bit 0, 
number 1 is bit 1 and so on. Where the list of numbers is specified as n1,n2,n3,… the returned value 
is calculated as 2^n1 + 2^n2 + 2^n2 …

This function is useful for converting the list of numbers returned from functions I2N, IGS, and IGM 
to a decimal value.

This is useful for easily programming control multiple consecutive GPI outputs and Ross Video 
RCP-20 and RCP-40 control panels. exp1 can be supplied by one of the aforementioned functions.

If a list of numbers is manually entered the list must be surrounded by double quotes. exp2 is 
subtracted from each number in the given list before the return value is calculated. exp2 is 
assumed to be zero if omitted.

Examples:

N2B("0,1,2") returns "7" 

N2B("1,2,3",1) also returns "7".

See also “B2N Function”.

NAME Function
Format: NAME()
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The result is the name of up to 26 characters of the display that is accessing this function.

Example:

SS(NAME(),SUB(LEN(NAME()),2),3))

The result is the last three characters from the name of the display.

NOT Function
Format: NOT(exp1)

If exp1 is zero the result is 1, otherwise the result is zero.

Example:

SV(!Y,NOT(EQ(V(!X),5)))

If the temporary variable X is 5, set the value of temporary variable Y to zero, otherwise set the 
value of temporary variable Y to 1.

OD Function
Format: OD(<Device::Input>)

Return name of the signal origin that is feeding this input. The signal original name is returned in 
Device::Output format.

In the formulation <Device::Input>, Device must be the name of a router or production switcher 
device, as defined in Hardware > Comm Port Setup > Production and M/C Switchers or ... Routers.. 
Input must be the name of an input of said Router or Production switcher device.

This function will return a value if the given input is included in the tally system configuration as one 
of the ends of a signal interconnection, as defined in either the Tally System Console "Source 
Definitions" editor or the "Signal Paths" editor. In the legacy Tally System Console such signal 
interconnections was defined under Resource > Interconnections.

Example:

OD(SWR::1) will return the destination feeding SWR input 1 (e.g. RTR::DEST1[1]), if SWR::1 is a Signal 
Path origin and RTR::DEST1[1] is a Signal Path end.

ON Function
Format: ON(exp1,exp2,exp3,exp4,...)

The result is exp2, exp3, exp4, ... if exp1 is 0, 1, 2, ..., respectively. If exp1 is too large, the result is the 
empty string.

Example:

ON(V(!X),ZERO,ONE,TWO,THREE,FOUR)

The result is ZERO, ONE, TWO, THREE, or FOUR for values 0, 1, 2, 3, 4 of temporary variable X, 
respectively.

ONUM Function
Format: ONUM(exp1)

Not available.

Example: ONUM(R1::VTR02)
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OPT Function
Format: OPT(<Option Name>,<Option Value>)

Set certain options to control the behavior of various embedded functions.

Option Name: "RENT"

Purpose: enable re-entry-limited signal trace for SRC, TSX, and SL functions. This allows 
destination-tracing UMDs to trace only to and not through re-entry inputs such as production 
switcher mix-effect buses, thus showing the name of the mix effect bus rather than the source 
feeding the mix-effect bus. OPT affects only functions that are programmed after the OPT function 
in the control expression.

Possible values: "on", "1" (both enable re-entry-limited signal trace) "off", "0" (both disable 
re-entry-limited signal trace). This option is off by default.

OPT must programmed, either directly or indirectly through a control expression or subroutine 
for each UMD that is desired to be affected by the OPT expression.

Example:

OPT(RENT,”on”)TSX(RTR::MON1[1],A) turns on the re-entry-limited signal trace for following the TSX 
function.

OR Function
Format: OR(exp1,exp2)

If either exp1 or exp2 are not zero the result is 1, otherwise the result is zero.

Example: SV(!Z,OR(V(!X),V(!Y)))

If the temporary variable X is not zero or the temporary variable Y is not zero, set the value of 
temporary variable Z to 1, otherwise set the value of temporary variable Z to zero.

PGD Function
Format: PGD(exp1,exp2)

The result is the name of one of the on-air destinations currently reached by the source named 
exp1. The numeric value exp2 is zero to get highest priority destination, 1 for next highest, and so 
on.

If the result is the empty string, there are no more on-air destinations reached by that source.

The format of exp1 is R::N[L], where R is the resource device name, N is the source name, and L is 
the optional level indicator. N and L are dependent on the type of resource device.

Example: S(PGD(R1::VTR002,0),A)

The result is the style A name of the first on-air destination connected to source VTR002 of resource 
R1.

PGM Function
Format: PGM(exp1)

The result is 1 if source exp1 is currently on-air, otherwise the result is zero. The source format is 
R::N[L], where R is the resource device name, N is the source name, and L is the optional level 
indicator. N and L are dependent on the type of resource device.

Example: IF(PGM(R1::CAM001),AC(85),AC(170))CAM 1

The result is CAM 1 in red if the source CAM001 of resource R1 is used on-air, otherwise the result is 
CAM 1 in green. 
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POS Function
Format: POS(exp1,exp2,exp3)

If the value exp3 is positive, the result is the position of string exp1 in string exp2 starting at position 
exp3 of string exp2. The first position is 1.

If the value exp3 is negative (it starts with a minus sign), the result is the position of anything but 
string exp1 in string exp2 starting at position exp3 (its absolute value).

Example: CAM 3 IF(POS(R2::CAM3,XPT(R2::ISO1)" "XPT(R2::ISO2)" "XPT(R2::ISO3,1)),ISO,IDLE)

The result is CAM 3 ISO if the source CAM3 is selected on destination ISO1, ISO2, or ISO3 of resource 
R2, otherwise the result is CAM 3 IDLE.

PSD Function
Format: PSD(exp1,exp2)

The result is the name of one of the next-to-air destinations currently reached by the source named 
exp1. The numeric value exp2 is zero to get highest priority destination, 1 for next highest, and so 
on.

If the result is the empty string, there are no more next-to-air destinations reached by that source.

The format of exp1 is R::N[L], where R is the resource device name, N is the source name, and L is 
the optional level indicator. N and L are dependent on the type of resource device.

Example: S(PSD(R1::CAM003,0),A)

The result is the style A name of the first next-to-air destination connected to source CAM003 of 
resource R1.

PST Function
Format: PST(exp1)

The result is 1 if source exp1 is currently next-to-air, otherwise the result is zero.

The source format is R::N[L], where R is the resource device name, N is the source name, and L is 
the optional level indicator. N and L are dependent on the type of resource device.

Example: IF(PST(R1::CAM002),AC(255),AC(170))CAM 2

The result is CAM 2 in amber if source CAM002 of resource R1 is next-to-air, otherwise the result is 
CAM 2 in green.

S Function
Format: S(exp1,exp2)

Gets the "styled" name of the source or destination named exp1 using the style selector exp2. The 
format of exp1 is R::N[L], where R is the resource device name, N is the source or destination name, 
and L is the optional level indicator. N and L are dependent on the type of resource device. Style 
exp2 is as follows: 

Table 18  S Function Values

Selector Style

0 primary name

1 secondary name

2 short name
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Styles A and B refer to one of the other styles independently for each source and destination. 
Primary and secondary names refer to the native name within the resource device, which could be 
a number. Long and short names are user-specified aliases.

Example: S(SRC(R1::AUX002,0),3)

The result is the long name of the originating source at destination AUX002 of resource R1.

SETI Function
Format: SETI(<Name>,<Origin>, <Create>,<Trigger>,< Input1>,< Input2>,…)

Allows dynamic control of signal interconnects. A signal interconnect describes a signal path from a 
signal origin to one or more inputs of a signal processing or routing device. Signal interconnects can 
be thought of as the description of the wiring of a given signal.

• Name: Name of the Signal Interconnection that is modified by this expression
• Origin: Device output (signal source) that will be interconnected to one or more device inputs. 

This parameter is specified in Device::Output format (e.g. RTR::OUT1[1] or SWR::M/E1)
• Create: If this parameter is evaluated to a non-zero value, the interconnect will be created within 

the TSI database if it does not already exist. If the parameter evaluates to a zero value, and the 
interconnection does not exist in the tally system database, this expression will have no effect. If 
the parameter evaluates to a zero value, and the interconnection already exists in the tally 
system database, this expression will operate as normal.

• Trigger: When the expression is evaluated and the trigger flag is found to be a non-zero value all 
inputs found connected to the given signal origin are disconnected, then all signal ends given in 
the list of inputs are connected to the given signal origin.

• Input List: One or more device inputs to which will be interconnected to the Origin output. 
Multiple inputs are separated by commas. Inputs are specified in Device::Input format. Empty 
entries or inputs specified incorrectly in the input list are ignored.

• Description: The interconnection of the given name is set with a signal path originating at the 
given Destination and ending in one or more device inputs. If the Create flag is evaluated to a 
non-zero value, the interconnect will be created within the TSI database if it does not already 
exist. The trigger parameter determines if the interconnect is actually written, for example on the 
basis of a GPI input switch. This allows interconnection to be switched dynamically and is 
particularly useful for creating certain types of tally maps. When the expression is evaluated and 
the trigger flag is found to be a non-zero value all inputs found connected to the given signal 
origin are disconnected, then all signal ends given in the list of inputs are connected to the given 
signal origin. Empty entries or inputs specified incorrectly in the input list are ignored.

Examples: 

SETI(PATH1,RTR::OUT1[1],1, ivc(0,1,3),if(iv(0),SWR::1),if(not(iv(0)),S WR::2)) 

SETI(PATH1,RTR::OUT1[1],1, ivc(0,1,3),if(iv(0),SWR::1,SWR::2))

The above expression switches an interconnection between two inputs when GPI input 0 changes 
state (see “IVC Function”).

3 long name

A style A

B style B

Table 18  S Function Values

Selector Style
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SETX Function
Format: SETX(<Signal Dest>,<Create>,<Clear>,<Trigger>, <Set>, <Process>,<Device Inp#1>,<Device 
Inp#2>,…)

Switches virtual crosspoints, mimicking a crosspoint change made by an external device, or a virtual 
crosspoint change made by an Output Control.

When the Trigger flag evaluates to a non-zero-value, and if the Clear flag has evaluated to a 
non-zero value, any inputs currently switched by the signal destination are turned off. Then, also if 
the Trigger flag has evaluated to a non-zero value and depending on the evaluated state of the Set 
flag, the listed inputs are either turned on (if Set is non-zero) or turned off (if Set is Zero). The tally 
system is informed of the crosspoint change only if the Process flag is set, at which point the various 
outputs of the tally system (UMDs, GPI outputs etc.) are updated to reflect the new state of the 
given signal destination. This allows multiple calls of the SETX function to be executed before the 
tally system reacts to the changes. The SETX function is ignored if the given signal destination does 
not exist and the create flag evaluates to zero. The given signal destination is created as necessary if 
the create flag is nonzero.

• Signal Destination: This is the virtual signal destination that is controlled and switched to different 
crosspoints. It is specified in the Device::Destination format (e.g. RTR::OUT1)

• Create: If the create flag evaluates to a non-zero value, and if the given signal destination does 
not exist in the tally system database (as defined in, for example, the Device Definition editor) the 
signal destination is automatically and internally created by the tally system. The automatically 
created signal destination does not display as an entry in the Tally System Console tables.

• Clear: If the clear flag evaluates to a non-zero value, any and all previously selected crosspoints 
are turned off (de-selected) before any new crosspoints are selected.

• Trigger: When the expression is evaluated and the trigger flag is found to be a non-zero value the 
specified device inputs are are selected or deselected. This allows the crosspoint selection 
process to occur only when some specific change has occurred, such as the switching of a GPI 
input.

• Set: When all other conditions for a crosspoint switch to occur are in place, the Set flag 
determines whether the device inputs specified in the device input list will be selected or 
deselected. In combination with the Clear flag (which can be set to clear, or not clear, previously 
selected inputs) this allows specified inputs to be individually turned on or off.

• Process: If the process flag evaluates to a zero value, the tally system is kept uninformed of any 
crosspoint changes made by the SETI function, until the next evaluation of the SETX function that 
finds the Process flag at a non-zero value. This allows multiple consecutive calls of the SETX 
function to be executed before the tally system reacts to the changes. For example this would 
allow one SETX function (with the process flag clear), to select a specific set of device inputs and a 
second SETX function (with the process flag set) to de-select another specific set of device inputs, 
before the tally system is called on to process all crosspoint changes made by the two 
consecutive SETX functions.In the more usual case where only one SETX function is used for a 
particular signal destination, the Process flag can be simply set to "1".

• Device Input List: The device inputs that will be selected or de-selected. Device inputs are 
specified by input name only, as the inputs are assumed to exist within the device specified by 
the Signal Destination parameter.

Examples: 

SETX(VRTR::OUT1,1,1,ivc(0,1,3),1,1,if(iv(0) ,"IN1"),if(not(iv(0)),"IN2"))

SETX(VRTR::OUT1,1,1,ivc(0,1,3),1,1,if(iv(0) ,"IN1","IN2"))

Both of the above expressions create signal destination VRTR::OUT1 and switches the destination 
between two inputs when GPI input 0 changes state (see “IVC Function”).

 SETX controls only the internal crosspoint status maintained by the TSI. SETX does not cause 
crosspoint changes to be transmitted to external hardware devices such as signal routing 
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systems. SETX is used with virtual (non-hardware) routers that are created and controlled entirely 
within the tally system control logic.

SID Function
Format: SID(exp1,exp2,exp3,exp4,...)

The result is 1, 2, 3, ... if the source named exp1 reaches the destination named exp2, exp3, exp4, ..., 
otherwise the result is zero. The format of exp1, exp2, exp3, exp4, ... is R::N[L], where R is the 
resource device name, N is the source or destination name, and L is the optional level indicator. N 
and L are dependent on the type of resource device.

Example: CAM 3 IF(SID(R2::CAM3,R2::ISO1,R2::ISO2,R2::ISO3),I SO,IDLE)

The result is CAM 3 ISO if the source CAM3 is selected on any of the destinations ISO1, ISO2, or ISO3 
of resource R2, otherwise the result is CAM3 IDLE.

SL Function
Format: SL(exp1,exp2,exp3,exp4,exp5,exp6)

The result is a list of zero or more styled names of sources currently reaching the destination 
named exp1 using the style selector exp2, with each source name preceded by one of string exp4, 
exp5, or exp6, depending on the on-air, next-to-air, or normal usage of the source, respectively. The 
function limits the total length of source names (including space separators) to the numeric value of 
exp3 in characters (partial source names are not listed). The format of exp1 and exp2 is described 
with S function.

Example: SL(S1::PGMOUTV,A,26,AC(85),AC(255),AC(170))

The result is a list, in 26 characters or less, of style A source names for sources reaching destination 
PGMOUTV of resource S1. Each on-air, next-to-air, and other sources display red, amber, and green, 
respectively.

SLA Function
Format: SLA(<Device::Destination>,<Style>,<UMD Length>,[,Tally Area][,Non-tallied Control 
Expression][, Tally type 0 Control Expression]…[, Tally type 7 Control Expression])

Similar to TSX function, but checks up to 8 tally types in the given tally area to determine if the 
source on the given destination should be tallied.

Example: SLA(RTR::MON1,A,20,<%TA>,ac(NML),ac(PGM),ac(EXT),ac(PST))

The above example displays the names of the sources selected by given the given router or 
switcher destination, in Style A, up the total number of characters determined by the UMD Length 
parameter. 

Text is shown with the AC(NML) color if the sources selected by the given destination is not 
contributing to any program (on air), preset (next to air) or external destination.

Text is shown with the Tally Type 0 (AC(PGM)) color if the source selected by the given destination is 
contributing to a program (on air) destination.

Text is shown with the Tally Type 1 (AC(EXT)) color if the source selected by the given destination is 
contributing to a preset (next to air) destination.

Text is shown with the Tally Type 2 AC(PST) color if the source selected by the given destination is 
contributing to a external destination (typically a program bus in another control room).

Depending on the the type of UMD the AC() commands NML, PGM, EXT, PST will typically generate 
white, red, amber, and green colours respectively.

The priority of Tally Types in the above example, have a descending order of priority:
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• Tally Type 0 (AC(PGM))
• Tally Type 1 (AC(EXT))
• Tally Type 2 (AC(PST))
• Non-tallied expression (AC(NML)).

Because of the above priority rules, if Tally Type 0 and Tally Type 1 are both active, then the Tally 
Type 0 colour code (AC(PGM)) is shown. RD1510 series UMDs can show differing source name 
colours, for cases where some sources are on air, on preset or neither of the above. Few 
multi-viewer systems have this capability, and typically this function is used to show program or 
preset bus status where all sources are either on program or preset. For this reason the colour 
parameters are often omitted from this function:

Example: SLA(RTR::MON1,A,20)

In Tally System Console <%TA> evaluates to a value of 0 through 7, depending on the UMDs > 
Display Devices > Tally Area column setting for the UMD programmed with this string.

SP Function
Format: SP(exp1)

The result is a timer/counter digit selected by exp1 for the timer/counter selected by most recent AT 
function. If none were selected, the result is the empty string. You can use any digit more than once 
in the same display. The numeric value exp1 selects digits as follows:

Table 19  SP Function Values

Selector Digit

1 tens of hours

2 units of hours

3 tens of minutes

4 units of minutes

5 tens of seconds

6 units of seconds

7 tens of frames

8 units of frames

9 tens of hours (zero-blanking)

10 units of hours (zero-blanking)

11 tens of minutes (zero-blanking)

12 units of minutes (zero-blanking)

13 tens of seconds (zero-blanking)

14 units of seconds (zero-blanking)

15 tens of frames (zero-blanking)

16 tens of hours (12-hour format)

17 units of hours (12-hour format)

18 upper-case A or P for AM/PM indicator

19 lower-case a or p for am/pm indicator
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Use this function to format your own timer/counter displays. Alternately, you can insert all the 
necessary functions at once from a dialog box. The dialog box list several common clock formats.

Example: AT(T2)SP(1)SP(2):SP(3)SP(4):SP(5)SP(6).SP(7)SP(8)

The result is the hours, minutes, seconds, and frames for the timer named T2 in HH:MM:SS.FF 
format.

SPM Function
Format: SPM(exp1,exp2)

Sets the system parameter mode and value of the timer/counter named exp1 to exp2.

Example: SPM(T1,0215000010100--)

Sets the timer named T1 to follow 2 hours and 15 minutes ahead of local time.

SRC Function
Format: SRC(exp1,exp2)

The result is the name of one of the originating sources currently reaching the destination named 
exp1. The numeric value exp2 is zero to get highest priority source, 1 for next highest, and so on. If 
the result is the empty string, there are no more sources reaching that destination.

The format of exp1 is R::N[L], where R is the resource device name, N is the destination name, and L 
is the optional level indicator. N and L are dependent on the type of resource device.

Example: S(SRC(R1::VTR001,0),A)

The result is the style A name of the originating source at the destination VTR001 of resource R1.

SS Function
Format: SS(exp1,exp2,exp3)

The result is the part of string exp1 starting from position exp2 and containing up to exp3 
characters. The first position is 1.

Example: SV(!X,SS(ADD(V(!X),1000),2,3))

The temporary variable X is padded with leading zeros to make it at least 3 characters long.

SUB Function
Format: SUB(exp1,exp2)

The result is the remainder of the subtraction of the numeric value exp2 from exp1.

Example: SV(!Y,EQ(LEN(SUB(V(!X),1)),LEN(V(!X))))

Set the temporary variable Y to zero if the temporary variable X is a power of 10, otherwise set the 
temporary variable Y to 1.

SV Function
Format: SV(exp1,exp2)

If the variable named exp1 already exists, the result of this function is to replace its value with exp2, 
otherwise the function creates a variable named exp1 and gives it the initial value of exp2. The 
result is always the empty string. The first character of exp1 determines the type of variable being 
set.

If exp1 starts with an exclamation point ! the variable is considered temporary. Its value lasts only 
until the end of the control text in which it displays.
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If exp1 start with an asterisk * the variable is considered private to the display section in which it 
displays. Its value is not available to other displays.

If exp1 starts with any other character, the variable is considered global to all displays. Do not 
create or modify global variables within the control text of any display section if its value is to be 
used by other display sections. Instead, use the Tally Logic > Subroutines table create or change the 
value of a global variable.

Example: SV(!X,"SV(!Y,MUL(V(!Y),10))V(!Y)")SV(!Y,1)FN(!X) FN(!X) FN(!X)

The result is 10 100 1000 by using the temporary variable X to repeat a set of operations on the 
temporary variable Y.

TIME Function
Format: TIME(exp1)

The result is a sample of the hour, minute, second, and frame adjusted for the timer named exp1, 
or the local time (unadjusted) if exp1 is omitted.

Example: SV(!T,SS(TIME(),1,2))

Sets the temporary variable T to the local hour.

TL Function
Format: TL(exp1)

The result is the string exp1 with any leading spaces removed.

Example: TL(IF(IV(1)," 1",)IF(IV(2)," 2",)IF(IV(3)," 3",))

The result is a list of only the active GPI inputs 1, 2 and 3, removing first space separator.

TLYA Function
Format: TLYA(<Device::Source>,<Tally Area>,<Tally Type>)

TLYA replaces the PGM and PST functions if Tally Areas are defined in the Tally System Console Tally 
Areas editor.

TLYA returns 1 if the given source signal source displays at any of the signal destinations defined by 
the given tally area and tally type. Tally areas and tally types are both specified as numbers in the 
range 0 through 7.

Examples:  

TLYA(SWR::1,0,0)

Returns 1 if input SWR::1 (input 1 of device SWR) is found to be contributing to a signal destination 
defined in Tally Type 0 of Tally Area 0.

TLYA(SWR::1,<%TA>,<%TA.PGM>)

Same effect as the first example.

Tally System Console replaces <%TA> with the number of the tally area selected for the GPI output 
or UMD for which the example expression is being programmed. This selection is made in the Tally 
Area column of the GPI output or UMD programming editor of Tally System Console. Tally System 
Console replaces <%TA.PGM> with the number of the tally type defined with name PGM in the Tally 
Area editor of Tally System Console. The various named Tally Types are numbered starting from 
zero according to their top-to-bottom order in the Tally Area editor. Typically these Tally Types are 
PGM (tally type 0), PST (tally type 1), EXT (tally type 2). 

See also “Tally Areas”.
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TR Function
Format: TR(exp1)

The result is the string exp1 with any trailing spaces removed.

Example: TR(IF(IV(1),"1 ",)IF(IV(2),"2 ",)IF(IV(3),"3",))

The result is a list of only the active GPI inputs 1, 2 and 3, removing last space separator.

TSD Function
Format: TSD(exp1,exp2,exp3,exp4,exp5)

The result is the styled name of the destination named exp1using the style selector exp2, preceded 
by one of string exp3, exp4, or exp5, depending on the on-air, next-to-air, or normal usage of that 
destination, respectively. The format of exp1 and exp2 is described with S function.

Example: TSD(R1::AUX001[1],3,AC(85),AC(255),AC(0))

The result is the long name for the destination AUX001, level 1 of resource R1. The name displays 
red, amber, or blank if the destination is on-air, next-to-air, or neither, respectively. 

See also “Tally Areas”.

TSDA Function
Format: TSDA(<Device::Destination>,<Style>[,Tally Area][,Nontallied Control Expression][,Tally type 
0 Control Expression]…[,Tally type 7 Control Expression ])

Similar to TSD function, but checks up to 8 tally types in the given tally area to determine if the 
source on the given destination should be tallied.

Example: TSDA(RTR::MON1,A,<%TA>,ac(NML),ac(PGM),ac(EXT),ac(PST))

The above example displays the name of the given destination in Style A. 

Text is shown with the AC(NML) color if the source selected by the given destination is not 
contributing to any program (on air), preset (next to air) or external destination.

Text is shown with the Tally Type 0 (AC(PGM)) color if the source selected by the given destination is 
contributing to a program (on air) destination.

Text is shown with the Tally Type 1 (AC(EXT)) color if the source selected by the given destination is 
contributing to a preset (next to air) destination.

Text is shown with the Tally Type 2 AC(PST) color if the source selected by the given destination is 
contributing to a external destination (typically a program bus in another control room).

Depending on the type of UMD the AC() commands NML, PGM, EXT, PST will typically generate 
white, red, amber, and green colors respectively.

The priority of Tally Types in the above example, have a descending order of priority:

• Tally Type 0 (AC(PGM))
• Tally Type 1 (AC(EXT))
• Tally Type 2 (AC(PST))
• Non-tallied expression (AC(NML))

Because of the above priority rules, if Tally Type 0 and Tally Type 1 are both active, then the Tally 
Type 0 color code (AC(PGM)) is shown.

In Tally System Console <%TA> evaluates to a value of 0 through 7, depending on the UMDs > 
Display Devices > Tally Area column setting for the UMD programmed with this string.

See also “Tally Areas”.
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TSS Function
Format: TSS(exp1,exp2,exp3,exp4,exp5)

The result is the styled name of the source named exp1 using the style selector exp2, preceded by 
one of string exp3, exp4, or exp5, depending on the on-air, next-to-air, or normal usage of that 
source, respectively. The format of exp1 and exp2 is described with S function.

Example: TSS(R1::CAM5,A,AC(85),AC(255),AC(170))

The result is the style A name for the source CAM5 of resource R1. The name displays red, amber 

See also “Tally Areas”.

TSSA Function
Format: TSSA(<Device::Source>,<Style>[,Tally Area][,Non-tallied Control Expression][, Tally type 0 
Control Expression]…[,Tally type 7 Control Expression])

Similar to TSS function, but checks up to 8 tally types in the given tally area to determine if the 
source on the given destination should be tallied.

Example: TSSA(RTR::MON1,A, <%TA>,ac(NML),ac(PGM),ac(EXT),ac(PST))

The above example displays the name of the given source, in Style A.

Text is shown with the AC(NML) color if the source selected by the given destination is not 
contributing to any program (on air), preset (next to air) or external destination.

Text is shown with the Tally Type 0 (AC(PGM)) color if the source selected by the given destination is

contributing to a program (on air) destination.

Text is shown with the Tally Type 1 (AC(EXT)) color if the source selected by the given destination is 
contributing to a preset (next to air) destination.

Text is shown with the Tally Type 2 AC(PST) color if the source selected by the given destination is 
contributing to a external destination (typically a program bus in another control room).

Depending on the the type of UMD the AC() commands NML, PGM, EXT, PST will typically generate 
white, red, amber, and green colours respectively.

The priority of Tally Types in the above example, have a descending order of priority:

• Tally Type 0 (AC(PGM))
• Tally Type 1 (AC(EXT))
• Tally Type 2 (AC(PST))
• Non-tallied expression (AC(NML)).

Because of the above priority rules, if Tally Type 0 and Tally Type 1 are both active, then the Tally 
Type 0 color code (AC(PGM)) is shown. In Tally System Console <%TA> evaluates to a value of 0 
through 7, depending on the UMDs > Display Devices > Tally Area column setting for the UMD 
programmed with this string.

See also “Tally Areas”.

TSX Function
Format: TSX(exp1,exp2,exp3,exp4,exp5)

The result is the styled name of the source currently reaching the destination named exp1 using the 
style selector exp2, preceded by one of string exp3, exp4, or exp5, depending on the on-air, 
next-to-air, or normal usage of that source, respectively. The format of exp1 and exp2 is described 
with S function.

Example: TSX(R2::004[2],A,AC(85),AC(255),AC(170))
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The result is the style A name for the source 004, level 2, of resource R2. The name displays red, 
amber, or green if the source is on-air, next-to-air, or neither, respectively.

See also “Tally Areas”.

TSXA Function
Format: TSXA(<Device::Destination>,<Style>[,Tally Area][,Nontallied Control Expression][, Tally type 
0 Control Expression]…[, Tally type 7 Control Expression])

Similar to TSX function, but checks up to 8 tally types in the given tally area to determine if the 
source on the given destination should be tallied.

Example: TSXA(RTR::MON1,A, <%TA>,ac(NML),ac(PGM),ac(EXT),ac(PST))

The above example displays the name of the source selected by given the given router or switcher 
destination, in Style A.

Text is shown with the AC(NML) color if the source selected by the given destination is not 
contributing to any program (on air), preset (next to air) or external destination.

Text is shown with the Tally Type 0 (AC(PGM)) color if the source selected by the given destination is 
contributing to a program (on air) destination. 

Text is shown with the Tally Type 1 (AC(EXT)) color if the source selected by the given destination is 
contributing to a preset (next to air) destination.

Text is shown with the Tally Type 2 AC(PST) color if the source selected by the given destination is 
contributing to a external destination (typically a program bus in another control room).

Depending on the the type of UMD the AC() commands NML, PGM, EXT, PST will typically generate 
white, red, amber, and green colors respectively.

The priority of Tally Types in the above example, have a descending order of priority:

• Tally Type 0 (AC(PGM))
• Tally Type 1 (AC(EXT))
• Tally Type 2 (AC(PST))
• Non-tallied expression (AC(NML)).

Because of the above priority rules, if Tally Type 0 and Tally Type 1 are both active, then the Tally 
Type 0 colour code (AC(PGM)) is shown. In Tally System Console <%TA> evaluates to a value of 0 
through 7, depending on the UMDs > Display Devices > Tally Area column setting for the UMD 
programmed with this string.

See also “Tally Areas”.

UC Function
Format: UC(exp1)

Any lower case letters in exp1 are converted to upper case in the result.

Example: UC(SS(V(!X),1,1))LC(SS(V(!X),2,50))

Modifies the temporary variable X to have the first character in upper case and the remaining 
characters in lower case.

US Function
Format: US()

The result is the number of dots there are in the width of the display section that is accessing this 
function.
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Example: SV(!X,DIV(US(),6))

Sets the temporary variable X to the number of fixed spacing characters that fit in the display 
section.

V Function
Format: V(exp1)

The result is the contents of the variable named exp1. The contents are not re-evaluated. Use the 
FN function to evaluate the contents of a variable. If the variable does not exist, the result is the 
empty string. The first character of exp1 determines the type of variable. Variable types are 
described with the SV function.

Example: SV(!X,:)AT(T1)SP(1)SP(2)V(!X)SP(3)SP(4)V(!X)S P(5)SP(6)

Using the temporary variable X to specify the separator as a colon, the result is the hours, minutes, 
seconds for the timer named T1 in HH:MM:SS format.

VAL Function
Format: VAL(exp1)

The result is the numeric ASCII value of the first character of the string exp1.

Example: IF(LT(VAL(UC(V(!X))),VAL(N)),A-M,N-Z)

The result is A-M if the first character of temporary variable X has a value less than that of the letter 
N, otherwise the result is N-Z.

XOR Function
Format: XOR(exp1,exp2)

If both exp1 and exp2 are not zero, or both exp1 and exp2 are zero, the result is zero, otherwise the 
result is 1.

Example: SV(!Z,XOR(V(!X),V(!Y)))

If the temporary variable X is not zero and the temporary variable Y is zero, or the temporary 
variable X is zero and the temporary variable Y is not zero, set the value of temporary variable Z to 
1, otherwise set the value of temporary variable Z to zero.

XPT Function
Format: XPT(exp1)

The result is the name of the source currently reaching the destination exp1. The format of exp1 is 
R::N[L], where R is the resource device name, N is the destination name, and L is the optional level 
indicator. N and L are dependent on the type of resource device.

Use this function instead of the SRC function when you are interested in the closest but not 
necessarily originating source for a destination.

Example: S(XPT(R1::VTR001),2)

The result is the short name for the source reaching the destination VTR001 of resource R1.

TICK Function
Format: TICK()

The result is a sample of the number of hundredths of seconds that have elapsed since the tally 
system was powered on. This number overflows to zero approximately every 24.8 days.
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Example: SV(X,IF(LEN(V(X)),V(X),TICK()))IF(LT(TICK(),A DD(V(X),500)),WAIT,DONE)

The result is WAIT if less than 5 seconds has past, otherwise the result is DONE.
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