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Thank You for Choosing Ross
You've made a great choice. We expect you will be very happy with your purchase of Ross 
Technology. 
Our mission is to:
1. Provide a Superior Customer Experience

• offer the best product quality and support

2. Make Cool Practical Technology

• develop great products that customers love
Ross has become well known for the Ross Video Code of Ethics. It guides our interactions and 
empowers our employees. I hope you enjoy reading it below.
If anything at all with your Ross experience does not live up to your expectations be sure to reach 
out to us at solutions@rossvideo.com.

David Ross
CEO, Ross Video
dross@rossvideo.com

Ross Video Code of Ethics
Any company is the sum total of the people that make things happen. At Ross, our employees are a 
special group. Our employees truly care about doing a great job and delivering a high quality 
customer experience every day. This code of ethics hangs on the wall of all Ross Video locations to 
guide our behavior:
1. We will always act in our customers’ best interest.

2. We will do our best to understand our customers’ requirements.

3. We will not ship crap.

4. We will be great to work with.

5. We will do something extra for our customers, as an apology, when something big goes wrong 
and it's our fault.

6. We will keep our promises.

7. We will treat the competition with respect.

8. We will cooperate with and help other friendly companies.

9. We will go above and beyond in times of crisis. If there's no one to authorize the required action in 
times of company or customer crisis - do what you know in your heart is right. (You may rent 
helicopters if necessary.)
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Statement of Compliance
This product has been determined to be compliant with the applicable standards, regulations, and 
directives for the countries where the product is marketed.

Compliance documentation, such as certification or Declaration of Compliance for the product is 
available upon request by contacting techsupport@rossvideo.com. Please include the product; 
model number identifiers and serial number and country that compliance information is needed in 
request.

EMC Notices
United States of America - FCC Part 15

This equipment has been tested and found to comply with the limits for a class A Digital device, 
pursuant to part 15 of the FCC Rules.

These limits are designed to provide reasonable protection against harmful interference when the 
equipment is operated in a Commercial environment. This equipment generates, uses, and can 
radiate radio frequency energy and, if not installed and used in accordance with the instruction 
manual, may cause harmful interference to radio communications. Operation of this equipment in 
a residential area is likely to cause harmful interference in which case the user will be required to 
correct the interference at his own expense.

Canada

This Class A device complies with Canadian ICES-003 and part 15 of the FCC Rules.

Cet appariel numerique de la classe “A” est conforme a la norme NMB-003 du Canada.

European Union

This equipment is in compliance with the essential requirements and other relevant provisions 
established under regulation (EC) No 765/2008 and Decision No 768/2008/EC referred to as the 
“New Legislative Framework”.

Australia/New Zealand

This equipment is in compliance with the provisions established under the Radiocommunications 
Act 1992 and Radiocommunications Labelling (Electromagnetic Compatibility) Notice 2008.

Korea

This equipment is in compliance with the provisions established under the Radio Waves Act.

Class A equipment (Broadcasting and communications service for business use).

This device is a business-use (Class A) EMC-compliant device. The seller and user are advised to be 
aware of this fact. This device is intended for use in areas outside home.

Notice — Changes or modifications to this equipment not expressly approved by Ross Video Ltd. could 
void the user’s authority to operate this equipment.

Warning — This equipment is compliant with Class A of CISPR 32. In a residential environment this 
equipment may cause radio interference.



International

This equipment has been tested under the requirements of CISPR 22:2008 or CISPR 32:2015 and 
found to comply with the limits for a Class A Digital device.

Environmental Information
The equipment may contain hazardous substances that could impact health and the environment.

To avoid the potential release of those substances into the environment and to diminish the need 
for the extraction of natural resources, Ross Video encourages you to use the appropriate take-back 
systems. These systems will reuse or recycle most of the materials from your end-of-life equipment 
in an environmentally friendly and health conscious manner.

The crossed-out wheeled bin symbol invites you to use these systems.

If you need more information on the collection, reuse, and recycling systems, please contact your 
local or regional waste administration. You can also contact Ross Video for more information on the 
environmental performances of our products.

This appliance may contain a Coin type battery which should not be treated as household waste.

To ensure that the battery will be treated properly use the appropriate take-back systems in your 
area. These systems will reuse or recycle most of the materials from your end-of-life equipment in 
an environmentally friendly and health conscious manner.

Security and Privacy 
If you would like more information on how Ross Video security and privacy practices have been 
applied to the Ultrix router, what you should know about maintaining security of this product, and 
how we can partner with you to ensure security throughout this product's life-cycle, contact 
techsupport@rossvideo.com.

Ross Video has implemented reasonable administrative, technical, and physical safeguards to help 
protect against security incidents and privacy breaches involving a Ross Video product provided 
those products are used in accordance with Ross Video instructions for use. However, as systems 
and threats evolve, no system can be protected against all vulnerabilities and we consider our 
customers the most important partner in maintaining security and privacy safeguards. If you have 
any concerns, we ask that you bring them to our attention, and we will investigate. Where 

Notice — This is a Class A product. In domestic environments, this product may cause radio 
interference, in which case the user may have to take adequate measures.
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appropriate, we will address the issue with product changes, technical bulletins and/or responsible 
disclosures to customers and regulators. Ross Video continuously strives to improve security and 
privacy throughout the product life-cycle using practices such as: 

• Privacy and Security by Design
• Product and Supplier Risk Assessment
• Vulnerability and Patch Management
• Secure Coding Practices and Analysis
• Vulnerability Scanning
• Access Controls appropriate to Customer Data
• Incident Response
• Clear paths for two-way communication between customers and Ross Video

If you would like to report a potential product related privacy or security issue (incident, breach, or 
vulnerability), contact techsupport@rossvideo.com.

Company Address

Ross Video Limited 
8 John Street
Iroquois, Ontario
Canada, K0E 1K0

Ross Video Incorporated 
P.O. Box 880
Ogdensburg, New York
USA 13669-0880

General Business Office: (+1) 613  652  4886

Fax: (+1) 613  652  4425

Technical Support: (+1) 613  652  4886

After Hours Emergency: (+1) 613  349  0006

E-mail (Technical Support): techsupport@rossvideo.com
E-mail (General Information): solutions@rossvideo.com

Website: http://www.rossvideo.com

mailto:techsupport@rossvideo.com?Subject=Information%20Request&Body=Hi,%0D%0D
mailto:solutions@rossvideo.com?Subject=Information%20Request&Body=Hi,%0D%0D
http://www.rossvideo.com
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Introduction
This guide covers the configuration and operation of the Ultriscape licensed feature for all Ultrix 
routers. The following chapters are included:

• “Introduction” summarizes the guide and provides important terms, and conventions.
• “Getting Started” provides an overview of the Ultriscape feature including how to install an 

Ultriscape license key, and displaying the interfaces in DashBoard. 
• “Configuring the Global Settings” outlines the how to configure the parameters that are 

common between PiPs, tallies, and labels.
• “Mapping an Ultriscape Head” outlines how to identify and assign the Ultriscape Heads to 

destinations in the active database.
• “Mapping the Ultriscape PiPs” summarizes how to identify Ultriscape PiPs in a database, and 

map your PiPs to destinations.
• “Creating a Layout” describes how to create a new layout using one of the default templates or 

start with a blank layout then add your PiPs based on the selected PiP size settings.
• “Adding Objects to a Layout” outlines how to add specific object types to a single layout.
• “Using PiP Templates in Layouts” outlines how to apply a PiP template, and save a PiP as a new 

template.
• “Managing the Layouts” outlines general tasks such as how to save a layout, load a layout, 

exporting/importing layouts, and deleting layouts.
• “Assigning a Layout to an Ultriscape Head” summarizes how to assign a layout to an Ultriscape 

Head.
• “Assigning Sources to PiPs” summarizes how to assign router sources to PiPs in a layout.
• “Audio Meter Modes Setup” outlines how to set up and monitor audio meters for PiPs that are 

configured for Normal or Default Source modes.
• “Clock Control” outlines how to operate a countdown or stopwatch clock object in an Ultriscape 

layout, and the supported RossTalk commands for Ultriscape Clock state control.
• “Monitoring Options” outlines how to add an Alarms display object to a Multiviewer Layout, and 

specify what conditions to monitor.
• “Ultriscape Menus Overview” summarizes the functions, menus, and parameters of the 

Ultriscape tabs and windows in DashBoard.

If you have questions pertaining to the operation of Ultriscape, contact us at the numbers listed   
“Contacting Technical Support”. Our technical staff is always available for consultation, training, 
or service.

Related Publications
It is recommended to consult the following Ross documentation before configuring Ultriscape:

• DashBoard User Manual, Ross Part Number: 8351DR-004
• Ultricore BCS User Guide, Ross Part Number: 2201DR-106
• Ultrix and Ultricore Database Guide, Ross Part Number: 2201DR-109
• ULTRIX-FR1, ULTRIX-FR2, and ULTRIX-FR5 Installation Guide, Ross Part Number: 2101DR-003
• ULTRIX-FR12 Installation Guide, Ross Part Number: 2101DR-603
• ULTRIX-FR12 User Guide, Ross Part Number: 2101DR-604
• ULTRIX-MODX-IO User Guide, Ross Part Number: 2101DR-020
• Walkabout Application Note, Ross Part Number: 2201DR-003
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Documentation Conventions
Special text formats are used in this guide to identify parts of the user interface, text that a user 
must enter, or a sequence of menus and sub-menus that must be followed to reach a particular 
command.

Interface Elements
Bold text is used to identify a user interface element such as a dialog box, menu item, or button. For 
example:

In the Save As dialog, click OK.

User Entered Text
Courier text is used to identify text that a user must enter. For example:

In the Language box, enter English.

Referenced Guides
Italic text is used to identify the titles of referenced guides, manuals, or documents. For example:

For more information, refer to the ULTRIX-FR12 Installation Guide.

Menu Sequences
Menu arrows are used in procedures to identify a sequence of menu items that you must follow. 
For example, if a step reads “File > Save As,” you would click the File menu and then click Save As.

Important Instructions
Star icons are used to identify important instructions or features. For example:

 An error message displays when an object overlaps a tile in the workspace.

Contacting Technical Support
At Ross Video, we take pride in the quality of our products, but if problems occur, help is as close as 
the nearest telephone.

Our 24-hour Hot Line service ensures you have access to technical expertise around the clock. 
After-sales service and technical support is provided directly by Ross Video personnel. During 
business hours (Eastern Time), technical support personnel are available by telephone. After hours 
and on weekends, a direct emergency technical support phone line is available. If the technical 
support person who is on call does not answer this line immediately, a voice message can be left 
and the call will be returned shortly. This team of highly trained staff is available to react to any 
problem and to do whatever is necessary to ensure customer satisfaction.

• Toll Free Technical Support (North America): 1-844-652-0645
• Toll Free Technical Support (International): +800 1005 0100
• Technical Support: (+1)613-652-4886
• After Hours Emergency: (+1) 613-349-0006
• E-mail: techsupport@rossvideo.com 
• Website: http://www.rossvideo.com 

mailto:techsupport@rossvideo.com?Subject=Information%20Request&Body=Hi,%0D%0D
http://www.rossvideo.com
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Getting Started
This chapter provides an overview of the Ultriscape feature including how to install an Ultriscape 
license key, and displaying the interfaces in DashBoard.

Overview
Ultriscape provides:

• 3 Ultriscape Heads (Multiviewer outputs) per slot
• 1080i or 1080p configurable output standard
• Ultriscape Head layout switched by any router controlling device
• Flexible PiP sizing:

› 3 system-wide configurable type (PiP A, B, and C1)
› 1 head-specific configurable type (PiP X)

• 21 layout templates
• Flexible Layout Editor to create up to 250 custom layouts
• PiPs may follow a router input, router output, or be switched as a destination
• Flexible audio metering per PiP
• Dynamic or static PiP labeling
• Option to add a Closed Caption display object to a PiP (requires the Ultriscape-CA license)
• TSL protocol controls border, indicator, and label tallies

Before You Begin
Keep the following in mind as you implement your Ultriscape Heads:

• You must have assigned a router OUT BNC to each Ultriscape Head that is licensed in each slot.
• Moving overlay elements on the DashBoard interfaces are in real time, and there is a rendering 

delay on the Ultriscape Head output making layout changes/updates non- real time. Refer to 
Table 1 for approximate refresh times (once the layout is selected and applied). 

For More Information on...
• installing a license for an Ultriscape Head, refer to “Installing an Ultriscape License Key”.
• cabling a blade for Ultriscape, refer to the Ultrix Installation Guide for your router.

1. Supported only on the ULTRIX-HDX-IO and ULTRIX-MODX-IO blades.

Table 1  Ultriscape — Refresh Times

Element Refresh Time
Label Change 0.5 seconds

Layout Change 1 second/layout

Audio Meters All meters update every 10 frames
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Workflow
The Ultriscape licensed feature allows you to view multiple video sources from a single output on an 
Ultrix router. Any video source on the router can be assigned to any PiP on an Ultriscape layout. 
Each layout is configured independently and can be applied to one or more outputs (Heads). Each 
router slot supports up to three Heads. 

Once the router is listed in the Tree View of DashBoard, and the Ultriscape licensed feature is 
enabled for each head, the Ultriscape nodes are displayed in the tree of that router.

The Ultriscape setup includes the following tasks:

1. Install the Ultriscape license keys for your router.

2. Assign each Ultriscape Head to a physical output on the router.

3. Plan your layouts for each Ultriscape Head. This will determine the number of PiPs and outputs 
you will need to set up in the database.

 Ultriscape can have PiPs that are shared between all Head outputs (shared PiPs), or PiPs that are 
specific to a particular Head (local PiPs). The shared PiPs are particularly useful when the same 
source or destination is to be shown on one or more Ultriscape outputs.

4. Assign each PiP to a Destination in the database. Refer to the Ultrix and Ultricore Database 
Guide.

Installing an Ultriscape License Key
The number of Ultriscape Heads for a router depends on the number of installed Ultriscape license 
keys. One Ultriscape license enables one Ultriscape Head on one router slot only. For example, if 
you wanted to enable three Ultriscape Heads on slot 1, you would install three Ultriscape licenses 
on slot 1.

 You must have at least one Ultriscape license installed for each slot that will provide an Ultriscape 
Head.

To install an Ultriscape license key

1. Launch the DashBoard client. 

2. Locate the Ultrix node in the Tree View.

3. Expand the Ultrix node to display a list of sub-nodes in the Tree View.

4. Expand the Devices node.

5. Expand the Controllers + Matrices node.

6. Double-click the node for your Ultriscape router.

The Device Configuration interface opens.

7. Select .

The Licenses page opens with License Keys sub-tab automatically selected.
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8. Make a note of the character string in the Request Code field for the Ultriscape license.

9. Contact Ross Video Technical Support using the information in “Contacting Technical 
Support”.

a. When you speak to your Technical Support representative, tell them:

• your name,
• your facility name, and 
• the Request Code from step 8.

b. You will be given a License Key for the licensed feature.

10. Enter the provided License Key in the applicable License Key field of the Licenses tab.

 You can also right-click on the row for the License Key you are installing, and copy the Request 
Code to or paste the License Key from the Microsoft® Windows® clipboard.

11. Click Apply in the row for the License Key you entered in step 10.

12. Verify that the Count field is updated to report each installed License Key.

To activate an Ultriscape license for a specific slot/head

1. Install the license key as outlined in the procedure “To install an Ultriscape license key”.

2. In the Licenses sub-tab, select the Ultriscape sub-tab.

• Each row in the tab represents a slot and Ultriscape Head in the Ultriscape router (with slot 1 
as the topmost slot in the router). 

• The Port column in the tab represents the output for the head. 
• The Format column represents the video format assigned to that head.

3. In the Port column, select the cell for the Ultriscape Head you want to enable.

A drop-down menu opens with a list of the available ports.

4. Select Enable to apply the Ultriscape license to that Ultriscape Head.

Accessing the Ultriscape Interfaces
The Ultriscape interfaces are accessed by expanding the Ultrix router node in the DashBoard Tree 
View, and then expanding the first Ultriscape node. The settings and options for the Ultriscape 
feature are represented as sub-nodes in the Ultriscape tree.
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To access the Ultriscape interfaces in DashBoard

1. Launch the DashBoard client. 

2. Locate the Ultrix node in the Tree View.

3. Expand the Ultrix node to display a list of sub-nodes in the Tree View.

4. Expand the Ultriscape node to display its sub-nodes.

5. Double-click the Configuration sub-node to display its interface in the DashBoard window.

The Configuration interface provides global layout editor settings that apply to all Ultriscape 
layouts and heads in the database.

6. Double-click the Layout Editor sub-node to display its interface in the DashBoard window.

The Layout Editor interface displays the workspace for customizing a Multiviewer layout.
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7. Double-click the Head Selection sub-node to display its interface in the DashBoard window.

The Head Selection interface displays the options for selecting a layout for a Multiviewer Head, 
defining the audio meter settings, and applying an alias label set (optional). After selecting a 
layout, the bottom area reports the global PiP sizes the layout includes.

8. Double-click the Clock Control sub-node to display its interface in the DashBoard window.

The Clock Control interface displays the options for controlling the defined clock objects in 
your layout(s). Refer to “Clock Control” for details. 
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Configuring the Global Settings
Ultriscape provides a central Configuration interface that allows you to set parameters that are 
common between PiPs, tallies, and labels. Global settings apply to all layouts with either Shared or 
Local PiPs. This chapter outlines the how to configure these Global settings.

 Layout configurable properties are stored on the router and are accessible from any DashBoard 
client on the same network.

For More Information on...
• the differences between Shared and Local PiPs, refer to “PiP Types”.
• configuring the tally settings for Ultriscape, refer to the Ultrix User Guide for your router.
• the Closed Caption display settings, refer to “Displaying Closed Caption Data”.

Configuring the Local and Global PiP Layout Settings
Ultriscape supports four concurrent PiP sizes (A, B, C, and X). Each PiP can be set to a specific 
dimension, allowing you to quickly set the size for the PiPs and build layouts using the PiPs.

 PiP C is supported only on the ULTRIX-HDX-IO and ULTRIX-MODX-IO blades.

To set the Local PiP settings for all layouts

1. Double-click the Configuration node located under the Ultriscape node.

The Configuration interface opens.

2. Select the PiP Layout tab.

3. Use the PiP Size A field to set the first of the common PiP sizes for the Ultriscape layout.

4. Use the PiP Size B field to set the second of the common PiP sizes for the Ultriscape layout.

5. Use the PiP Size C field to set the third of the common PiP sizes for the Ultriscape layout.

6. If applicable, use the PiP SD Aspect Ratio options to set the aspect ratio to match the expected 
SD-SDI signal format.

7. Use the Audio Meter options to set the audio meter green to yellow transition level.

 Applying changes to PiP sizes may prevent the currently selected layout from displaying correctly.

8. Click Apply.
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Configuring the Global PiP Border Settings
 You can specify the PiP border width and placement for all layouts.

To specify the border location for the PiPs

1. Double-click the Configuration node located under the Ultriscape node.

The Configuration interface opens.

2. Select the PiP Layout tab.

3. Locate the PiP Video Alignment area in the PiP Layout tab.

4. Use the Video options to specify where the PiP borders are drawn. Choose from the following:

• Overlap — The border displays as a layer over the video. The thicker the border width, the 
less of the video image displays within the PiP. This is the default. The Pip Border Width 
Override fields are now read-only.

• Frame — The border surrounds the image within the PiP. The image is scaled to fit within the 
PiP. This will override individual PiP border settings. Continue to “To set the global PiP 
border widths for all layouts”.

5. Click Apply.

To set the global PiP border widths for all layouts

1. Ensure the Video option is set to Frame.

2. Locate the PiP Border Width area in the PiP Layout tab.

3. Use the Border field to specify the border width in number of pixels.

4. Click Apply.

Configuring the Global Label Settings
You can also edit the global settings relating to the display of tally objects and the level of 
transparency for the label boxes overlaid on the PiPs. 

 Ultriscape does not support Unicode characters.

To set the global label transparency setting for all layouts

1. Double-click the Configuration node located under the Ultriscape node.

2. Select the Label Settings tab.
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3. If the Destination Follow feature is configured in your database, set the Dest Follow Label 
Displays setting to DST:SRC.

4. Use the Opacity slider to adjust the background transparency level of all label boxes in all PiPs 
of all Ultriscape Heads where:

• 0 — The label background is completely opaque. Only the label text is visible.
• 100 — The label background is completely transparent; the video in the PiP is visible through 

the label background.
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Mapping an Ultriscape Head
Ultriscape Heads (Multiviewer outputs) can be mapped as logical destinations. To the router control 
system, they are a destination of the router and may be controlled as such from external controlling 
devices. This chapter outlines how to assign a licensed Ultriscape Head to a destination within the 
router database.

Identifying Ultriscape Heads in the Database
The Ultriscape Heads are identified much like a physical BNC using the standard nomenclature of 
Frame.Slot.Port.Type.Channel. Ultriscape Heads are identified as frame.slot 
n.head[x].sdi.ch1 where x represent the Head ID within a given slot (there can be up to 3). In 
Figure 1, there are three Ultriscape Heads in slot 1 (HEAD 1-3), and three Ultriscape Heads in slot 2 
(HEAD 4-6).

Figure 1  Example of Ultriscape Heads Mapped to Destinations in a Database

For More Information on...
• using the MV Head template to assign destinations in the database, refer to the Ultrix and 

Ultricore Database Guide.

Assigning Ultriscape Head Destinations
Only certain physical outputs may be designated as Ultriscape outputs. For example, if you installed 
a second Ultriscape license for an ULTRIX-HDX-IO in slot 2, you must assign either AUX B or OUT 5 
as the second Ultriscape Head output. 

Table 2 lists the connections on the rear panel that are available for Ultriscape Heads based on the 
type of blade installed in the slot. 

Table 2  Outputs Allocated for Ultriscape Heads

Blade Model Ultriscape Head 1 Ultriscape Head 2 Ultriscape Head 3
ULTRIX-HDBNC-IO AUX A or OUT 1 OUT 5 or OUT 7 OUT 11 or OUT 13

ULTRIX-HDX-IO AUX A or OUT 1 AUX B or OUT 5 OUT 13

ULTRIX-IP-IO AUX A or OUT 1 AUX B or OUT 9 --

ULTRIX-IPX-IO AUX A or OUT 1 AUX B or OUT 5 OUT 13

ULTRIX-MODX-IO AUX A or MOD1.out1 AUX B or MOD2.out1 MOD4.out1

ULTRIX-SFP-IO AUX A or SFP 1 SFP 5 or SFP 7 SFP 11 or SFP 13
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For More Information on...
• the cabling designations of your blade, refer to the Ultrix Installation Guide and/or 

ULTRIX-MODX-IO User Guide.

To assign an Ultriscape Head to a router output

1. Locate the Ultrix router in the Tree View of DashBoard.

2. Expand the Ultrix node to display a list of sub-nodes in the Tree View.

3. Expand the System sub-node.

4. Expand the Configuration sub-node.

5. Double-click the Ultrix node.
The Device Configuration interface opens.

6. Select .

The License Keys sub-tab is automatically selected.

7. Verify that the License Keys interface reports the correct number of licensed Ultriscape Heads 
for your router.

 The router rear panel map at the top of the Frame View interface will display a Monitor icon 
above each output port that has the Ultriscape enabled for it.

8. Select the Ultriscape sub-tab.
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9. Locate the row for the Ultriscape Head you want to assign.

10. Use the Port field to select the physical OUT BNC on the router you want to assign to the 
Ultriscape Head. Choose from the following:

• Disable — Select Disable if you do not wish to assign the physical OUT BNC as the Ultriscape 
Head output.

• slot#.[#] — Specifies which physical OUT BNC on the router will be the Ultriscape Head 
output. Note that the options listed depend on the slot.

• slotx.AUX#-out[#] with loopback — refer to “Configuring a Loopback” for details.

11. Use the Format field to specify the output video format for the Ultriscape Head. Choose from 
the following:

 This adds video processing for some interlace formats to ensure stability by introducing 1 frame 
of delay.

• 1080p (3Gbps SDI)
• 1080i (1.5Gbps SDI)
• 1080i-LC (1.5Gbps SDI)
• 2160p-UC (11.88Gbps SDI)

12. Repeat steps 9 to 11 for additional Ultriscape Heads.

The Ultriscape sub-tab updates to report the selected Ultriscape Head is now licensed. In the 
following example, the user assigned two Ultriscape Heads: slot2.head1 and slot2.head3.

Configuring a Loopback
Any Ultriscape Head that has an AUX output can be configured for a loopback. This internally routes 
the AUX output to the AUX input, allowing the Ultriscape Head to be routed to other outputs 
without the use of a physical SFP in that AUX port. This option is supported on the 
ULTRIX-HDBNC-IO, ULTRIX-HDX-IO, ULTRIX-SFP-IO, ULTRIX-IP-IO, ULTRIX-IPX-IO, and 
ULTRIX-MODX-IO blades.

 Before proceeding, ensure the AUX port is configured and available in your database. Note that 
the AUX port will work with loopback regardless of its SFP mode (as set in the SFP Configuration  
interface). Refer to the Ultrix User Guide for your router to learn more about configuring the AUX 
ports.

To map an AUX port as a loopback of an Ultriscape Head

1. On the License Keys > Ultriscape sub-tab, locate the row for the Ultriscape Head.

2. Select the cell in the Port column.
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3. Select the option slotx.AUX#-out[#] with loopback.

4. To confirm the setting:

a. Display the Frame View page.

b. Hover your mouse cursor over the AUX port until a tool-tip displays.

You can now route this AUX input (via a soft panel) to any output on the router to view the 
Ultriscape Head on that output. Refer to the Ultrix and Ultricore Database Guide to learn more 
about using soft panels to route your inputs and outputs. 

Mapping an Ultriscape Head to a Destination
The assignment of Ultriscape Heads enable the Ultriscape sub-nodes in the Device Tree for further 
Ultriscape configuration.

 You can also assign destinations by selecting and applying the MV Head template. Refer to the 
Ultrix and Ultricore Database Guide for details.

To map an Ultriscape Head to a destination in the database

1. Display the Database > Configuration > Destinations interface.

The number of Destinations rows are determined by the active database.

 If required, you can add Destinations to the list to accommodate the assignment of Ultriscape 
Heads and PiPs.

2. If desired, type a new name for the destination in the Name cell as outlined in “To specify a 
label for a destination”.

3. In the table of the Destinations tab, locate the column for the level.

4. Click a cell of the Destination row to display a list of available Destinations sockets.

5. Select the Ultriscape Head you want to assign.

Using a Template to Map the Ultriscape Heads
Templates can be used to quickly map the Ultriscape Heads in the active database. Each template 
provides a unique configuration. Selecting a template automatically maps all the Ultriscape Heads 
in the active database. Refer to the Ultrix and Ultricore Database Guide for details on using 
templates.

To map the Ultriscape Heads using a template

1. In the Database > Configuration > Destinations interface, click Fill I/Os.

2. Click Templates.
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The Templates dialog opens.

3. Select MV Head.

Using UltriStream
 The UltriStream license requires router software version 5.2.0 or higher. An UltriStream license is 

supported on the ULTRIX-NS-FR1, ULTRIX-NS-FR2, ULTRIX-(NS)-FR5, and ULTRIX-FR12.

The UltriStream licensed feature provides the ability to encode one NDI stream of a configured 
Ultriscape Multiviewer Head per ULTRIX-HDX-IO or ULTRIX-MODX-IO blade. 

The Ultriscape Multiviewer Head for the video source must be one from the same blade that is 
transmitting the NDI stream. For example, a licensed ULTRIX-MODX-IO blade in Slot 1 cannot send 
an NDI stream of a Multiviewer Head from a licensed ULTRIX-HDX-IO blade in Slot 2.

For More Information on...
• the UltriStream licensed feature, refer to the Ultrix User Guide for your router.
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Mapping the Ultriscape PiPs
Ultriscape PiPs (Picture-in-Picture tiles) are required to be mapped in as logical destinations. To the 
router control system, they are a destination of the router and may be controlled as such from 
external controlling devices.

This chapter outlines how to assign the PiP of an Ultriscape Head to a destination within the router 
database.

For More Information on...
• using the MV PiP template to assign destinations in the database, refer to the Ultrix and Ultricore 

Database Guide.
• defining your database, refer to the Ultrix and Ultricore Database Guide.

Identifying Ultriscape Destinations in the Database
The Ultriscape PiPs are identified much like a physical BNC using the standard nomenclature of 
Frame.Slot.Port.Type.Channel.

• Ultriscape Local PiPs are identified as frame.slot n.headx-pip[y].sdi.ch1 where x 
represents the Ultriscape Head ID and y represents the individual PiP. For example:

• Ultriscape Shared PiPs are identified as frame.slot0.pip[y].sdi.ch1 where y represents the 
individual PiP number. For example:

Assigning an Ultriscape Destination
The assignment of Ultriscape PiPs will enable the Ultriscape sub-nodes in the Device Tree for 
further Ultriscape configuration.

 You can also assign destinations by selecting and applying the MV PiP template. Refer to the 
Ultrix and Ultricore Database Guide for details.
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To display the destinations in your database

1. Expand the Database node.

2. Expand the Configuration sub-node.

3. Double-click the Destinations node.

 If required, you can add Destinations to the list to accommodate the assignment of Ultriscape 
PiPs.

4. In the table of the Destinations tab, locate the column for the level.

To assign a single PiP to a destination

1. Select the cell for the Destination to assign to the PIP.

2. If desired, type a new name for the PiP destination in the Name cell.

 Ensure the new name clearly identifies the destination as a PiP. You may also want to include a 
reference to the Ultriscape Head.

3. Perform one of the following:

• Click the cell of the row in the table to display a list of available Destinations sockets; or
• Choose a PiP from the available list.

To associate a range of PiPs

1. In the Database > Configuration > Destinations interface, click Edit.

2. Select the first cell in the table column.

3. Press and hold Shift.

4. Select the last cell in the table column. 

5. Select a range of PiPs in the available list with same click, shift-click method.

6. Click Assign.

Configuring Destination Follow
The Destination Follow feature enables you to route a specific destination’s source signal to another 
destination. For example, set S1H1 PIP1 to follow DST1 so when DST1 is switched to a different 
source, S1H1 PIP1 is also switched to that same source. You can set multiple destinations to follow 
another single destination, or each following their own unique destination.
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Controlling a destination that has a follow directly will overwrite the current status. Any subsequent 
changes to the followed destination will again update that destination. For example, if DST1 follows 
DST6 and a controller requests a new source to DST1, that source is routed to DST1. If a controller 
then requests a new source to DST6, DST1 will then also change status to the new source.

To configure the Destination Follow for Ultriscape

1. Double-click the Destination Follow node located under the Database node.

The Destination Follow interface opens.

2. Select the Multiviewer tab.

All the PiPs in your database are listed in the left pane in the Destination column. 

3. In the Destinations column, locate the row for the PiP to configure.

4. In the Following table, select the output that the selected Destination will follow.

In the following example, the user assigned S1H1 PIP1 to follow DST1, and S1H1 PIP2 to 
follow DST2.

Using the Auto-Fill Function
You can also use the auto-fill function to populate the PiPs in the Destinations database.

When using the auto-fill function, we recommend naming PiPs for a particular Ultriscape Head a 
base name that will distinguish them from PiPs for other Ultriscape Heads. For example, using base 
names of S1H1P, S2H2P, and S3H3P for the first Ultriscape Head on Slot 1, the second Ultriscape 
Head on Slot 2, and the third head on Slot 3, respectively, would generate names for PiPs as follows:

S1H1P1, S1H1P2, S1H1P3, ...

S1H2P1, S1H2P2, S1H2P3, ...

S1H3P1, S1H3P2, S1H3P3, ...

In order to achieve these results, the auto-generation would have to be done as three separate 
operations.

To use the auto-fill function to assign PiPs to destinations

1. In the Database > Configuration > Destinations interface, click Fill I/Os.

2. If the database includes more than one device, use the Devices options to select which device 
to edit the destination labels.
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3. Use the Slots options to select the router slot for the Ultriscape Head.

It should be of the form <frame name>.slot<n>.head-pip, where n is the slot of interest on 
the designated router.

 Virtual ports are available via slot0.internal.

4. Use the Ports options to select the PiPs.

It should be of the form <frame name>.slot<n>.head<m>-pip[x], where m is the head 
whose PiPs are being assigned, and x is the PIP number. Normally x will be 1 (the first PiP on 
the Ultriscape Head).

5. Select the starting channel. 

This should be of the form <frame name>.slot<n>.head-pip[x].sdi.ch1.

6. Specify the levels on which the PiPs for the selected Ultriscape Head will be active.

7. Click Fill Destinations.

The Fill I/O dialog closes.

8. Repeat the process for Ultriscape Heads whose PiPs will be assigned while ensuring the correct 
slot, port, and starting channel are selected.

Using a Template to Map the PiPs
Templates can be used to quickly map the PiPs in the active database. Each template provides a 
unique configuration. Selecting a template automatically maps the PiPs to destinations in the active 
database. Refer to the Ultrix and Ultricore Database Guide for details on using templates.

To map the destinations using the MV PIP template

1. In the Database > Configuration > Destinations interface, click Fill I/Os.

2. Click Templates.

The Templates dialog opens.

3. Select MV PIP.
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Creating a Layout
Ultriscape layouts are created and stored within Ultrix to be assigned to a live Ultriscape Head when 
needed. You create a new layout using one of the default templates or start with a blank layout then 
add your PiPs based on the selected PiP size settings. Both methods are outlined here.

 You can save up to a maximum of 250 layouts.

PiP Types
A layout is comprised of a series of tiles organized into a grid layout. Each tile in a layout represents 
a single Picture in Picture (PiP) element. Each tile displays a number that represents the PiP 
number. There are two types of PiPs: Local and Shared.

Local PiPs
Local PiPs are for use only on a per Ultriscape Head basis. Keep the following in mind:

• The PiP A and B settings are global, but may be edited on a specific layout. For example, the 
global size for PiP A is 1/4 and PiP B is 1/2; you can still create a layout where PiP A is 1/2 and PiP 
B is 1/4 on that layout only.

• The PiP C size in the layout must match the global size as selected in “To set the Local PiP 
settings for all layouts”.

• You can only assign sources to a PiP C tile from an ULTRIX-HDX-IO or ULTRIX-MODX-IO blade. If 
you are attempting to switch a non-supported source to a PiP C tile, an error message displays in 
the PiP label of your Multiviewer.

Shared PiPs
Shared PiPs are PiPs that may be displayed on multiple Ultriscape Heads. Updating the source for 
shared PiPs updates all Multiviewer layouts that contain that Shared PiP definition. Shared PiPs (for 
use with any Ultriscape Head), require additional configuration. Refer to “Using Shared PiPs”.

Creating a Layout using a Template
By default, the PiPs are organized with PiP1 in the top left corner of each layout. You can create a 
new layout using one of the default templates that come standard with Ultriscape.

To load a layout template

1. Double-click the Layout Editor node located under the Ultriscape node.

The Layout Editor interface opens.

2. From the main toolbar, select File > Load Layout Template from Ultricore.

The Load Layout Template dialog opens.

3. Select a template from the provided list.

4. Click OK.

The Layout Templates dialog closes and the workspace displays the selected template layout.
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Creating a Custom Layout
Before creating a custom layout, clear the workspace and then add your Local PiPs.

 PiP C is supported only on the ULTRIX-HDX-IO and ULTRIX-MODX-IO blades.

To create a custom layout

1. Double-click the Layout Editor node located under the Ultriscape node.

The Layout Editor interface opens.

2. From the main toolbar, select File > New Layout.

The Create Blank Layout dialog opens.

3. Click OK to close the dialog and clear the workspace.

4. Set the required dimensions for PiP sizes A, B, C, and/or X using the applicable fields in the 
lower toolbar of the Layout Editor.

 You can create a layout with different PiP sizing to the currently configured. The new layout will 
not output from the Ultriscape Head if the PiP A, B, or C tiles do not match the values set in the 
Configuration > PiP Layout > PiP Size Selection. The PiP X tile size is defined by the layout it is in.

In the following example, the user is selecting a new size for PiP C.

To add a Local PiP to a layout

1. From the Objects toolbar, choose one of the following:

• Click PIP • A to add a PiP A tile to the layout.
• Click PIP • B to add a PiP B tile to the layout.
• Click PIP • C to add a PiP C tile to the layout.
• Click PIP • X to add a PiP X tile to the layout.

 You many only place one instance of a PiP X tile per layout.

2. If you wish, click Toggle Grid to display a grid background (and optionally snap to). The grid can 
help with the placement of the PiPs on your layout.

 You can change the grid dimensions by selecting Format > Grid from the main toolbar, 
specifying the horizontal (h) and vertical spacing (v), then clicking OK.

3. On the Layout Editor workspace, select the location for the Local PiP.

The layout updates to display a new PiP. 

In the following example, one large PiP was positioned on the right margin and two medium 
PiPs were positioned near the left margin. A PiP C was positioned near the top of the 
workspace.

 PiP C is supported only on the ULTRIX-HDX-IO and ULTRIX-MODX-IO blades.
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4. Reposition the PiP by selecting and dragging with your mouse. 

 For more precise positioning of PiPs on the layout, select Format > Grid > Snap To Grid.

• For fine, accurate movements, the keyboard arrow keys move the PiP in 2 pixel increments. 
• The top left of a PiP may be set by defining the left and top coordinates in the tool bar.   
• When PiPs overlap, a red Overlap message displays on the top right of the Layout Editor 

interface. Overlapping PiPs and/or elements will not function. The layout cannot be saved 
until the overlap is corrected.

5. Repeat for each PiP you wish to add to the layout.

 You may place multiple instances of PiP A, B, and/or C tiles on a single layout. There can only be 
one instance of the PiP X tile on a single layout.

6. To save your layout to the system, select File > Save to Ultricore.

Using Shared PiPs
Shared PiPs are PiPs that may be displayed on multiple Ultriscape Heads. Updating the source for 
shared PiPs updates all Multiviewer layouts that contain that shared PiP definition.

For More Information on...
• the Shared PiP settings, refer to “Shared PiPs Tab”.

To configure a Shared PiP

1. Double-click the Layout Editor node located under the Ultriscape node.

The Layout Editor interface opens.

2. Select the Shared Pips tab.

The Shared Pips tab is organized as a table where each row represents a specific Shared PiP.

3. To configure a new Shared PiP, right-click the last row in the table and select Insert Row Below.
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4. Use the Mode field to determine how sources are assigned to the PiP when in a layout 
regardless of the Ultriscape Head. Choose from the following:

• Normal — The PiP monitors the Source that the Destination the PiP is assigned to is currently 
switched to (e.g. a PiP acts like a regular router destination).

• Follow — The source that the PiP displays is dependent on the source routed to the specified 
Destination.

• Source — The PiP displays the specified Source in the database.

5. Use the Source field to specify the resource that the Shared PiP will monitor. This applies to all 
layouts with this Shared PiP in all Ultriscape Heads.

 The list of available resources depends on the database currently loaded.

6. If the Mode is set to Normal, use the Audio Mode field to configuring the audio meters for the 
Shared PiP in a layout regardless of the Ultriscape Head. Choose from the following:

• Logical — the audio bars on the Shared PiP displays audio levels based on a source’s logical 
definition. The bars index from left to right (meter port channel 1 represents the leftmost 
audio meter bar, and meter port channel 16 represents rightmost possible audio meter bar).

• Physical — the audio bars on the Shared PiP represents the audio that is embedded in the 
SDI stream.

7. To configure the channel numbering for the audio meters in the Shared PiP:

a. Select the Audio Bars cell for the Shared PiP.

The Audio Channels dialog opens.

b. If the Audio Mode is set to Logical, select the audio levels to map to the audio meters.

 To select multiple levels/channels, press Ctrl then click the levels/channels to include.

c. If the Audio Mode is set to Physical, select the audio channels to map to the audio meters.

The Audio Bars cell updates to display the selected items, separated by commas.

8. Click Apply to save your changes.

Adding a Shared PiP to a Layout
You can add a Shared PiP to any layout.

To add a Shared PiP to a layout

1. Create or load a layout in the Ultriscape Layout Editor.

2. Right-click the PiP Number on the PiP tile you wish to convert to a Shared PiP.

The Set Shared PiP ID dialog opens. 

In the following example, PiP 3 was selected.
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3. Use the Shared PiP ID menu to select the ID of the Shared PiP you want to add.

4. Click Set.

The Set Shared PiP dialog closes. The layout displays the Shared PiP ID inside the selected PiP.

5. To save your layout to the system, select File > Save to Ultricore.

Changing the Layout Background
The Ultriscape Layout editor provides the option to insert a background color or background image. 
This will display in the space between PiPs.

To change the background color of a layout

1. Create a new layout as outlined in “Creating a Layout” or load an existing layout as outlined in 
“To load a previously saved layout in Ultricore”.

2. From the bottom toolbar, set the Background menu to Solid Color.

3. Select the Background Color menu.

4. Select a color from the provided color grid in the dialog.

5. Click Choose to update the layout background.

To change the background image of a layout

1. Create a new layout as outlined in “Creating a Layout”.

2. From the top toolbar, select File > Upload Background Image.

The Upload Background Image dialog opens.

3. Click Choose File.

The Open dialog opens.

4. Navigate to the image file you want to display, then click Open.

 Images must be 1920x1080 pixels or less.

The Open dialog closes. The Upload Background Image dialog updates with the new image.

5. Click OK to confirm the file upload to Ultrix.

6. Use the Background menu, located in the bottom toolbar, to select the image file.

The layout displays the selected image.
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Editing the Border for a PiP
You can specify the border thickness for a single PiP or all the PiPs in a layout. Figure 2 shows a 
layout of four PiPs where PiP1 and PiP4 have a border set to 16. If the border is for a tally, as seen in 
PiP 2, the border color is always dark blue. Refer to “Adding a Tally Border to a PiP” for details.

Figure 2  Example of Borders

To edit the border width for a PiP

1. Create a layout in the Ultriscape Layout Editor as outlined in “Creating a Layout”.

2. From the Objects toolbar, click SELECT.

3. Select the PiP to edit the border width for.

The PiP displays with a dotted yellow border and the Border Width field now displays under 
the Main toolbar. In the example below, PiP1 is selected.

 To deselect a single PiP, press Ctrl then click the PiP on the layout.

4. From the top toolbar, use the Border Width field to specify the border width in number of 
pixels and lines.

5. Press Enter to apply the new width value.
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To edit the border width for all PiPs in a layout

1. Create or load a layout in the Ultriscape Layout Editor.

2. Right-click any PiP in the layout.

3. Click Select All.

The PiPs display with a dotted yellow border and the Border Width field now displays under 
the Main toolbar.

4. In the Border Width field, specify the border width in number of pixels and click Enter.

The border width for each PiP in the layout updates to the new size.
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Adding Objects to a Layout
Once a layout is created, you can add objects using Edit Mode. This chapter outlines how to add 
specific object types to a single layout.

What is a Layout Object?
An object is any element in a layout that is not a direct video source from the router. For example, a 
block of audio meters, or a text label. The following objects can be added to an Ultriscape layout.

• UMD Labels — This object is a text area. The Under Monitor Display (UMD) or label can display 
static text, database names, or text from a TSL tally manager device. Refer to “Adding a 
UMD/Label”.

• Audio Meters — Each PiP can display up to 16 channel of audio meters. The audio meters can be 
positioned anywhere on the layout including outside of a PiP. Refer to “Adding a Block of Audio 
Meters” and “Audio Meter Modes Setup”.

• Tally Borders, Labels, and Lamps — When tallies are enabled in a database, Ultrix will track the 
current tally status for all sources that have an associated Tally Display ID. When a PiP has a tally 
display object defined (such as a label, lamp, and/or border), the current source that is displayed 
on the PiP determines what is shown on the Ultriscape Head display (based on the associated 
tally ID for that source). Refer to the Ultrix User Guide for your router.

• PiP Borders — You can adjust the size of each PiP border. A global setting sets the border to 
overlay on top of the video, or resize the video to fit within the border confines.

• Clocks — You can add a clock that reports the time of day, counts down from a set point, or 
counts up from zero. Refer to “Adding a Clock Object to a Layout”.

• CC — When the Ultriscape-CA license is enabled, you can add a Closed Caption display object to a 
PiP. Refer to “Displaying Closed Caption Data”.

• Clip Data — When the Ultriscape-CA license is enabled, you can add a Clip metadata display 
object to a PiP. Refer to “Configuring an Ultriscape Head to Display Metadata”.

• Alarming — When the Ultriscape-CA license is enabled, you can add an Alarms display object to a 
PiP. Refer to “Monitoring Options”.

Managing the Objects in a Layout
You can add new objects to PiPs in a layout using the options in the Objects toolbar. Simply select a 
PiP in the layout, select the tool for the object type you want to add, and draw a box to place the 
object on the PiP. Each object provides a series of menus for configuring the look and feel of the 
object on a PiP. You can add multiple objects to a single PiP, but objects cannot span multiple PiPs. 

Editing an Object

Any object in a layout can be re-sized, re-positioned, or deleted. The available configuration options 
for the object depends on its type. 

Grouping Objects in a Layout

You can select multiple PiPs in a layout by pressing Ctrl and then clicking the PiPs you want to group 
together. This enables you to quickly select and edit the properties of specific PiPs.
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Cut/Paste Objects

You can select an object on a PiP, copy it, and then paste it to another location within that same PiP, 
to a different PiP in the same layout, or to a PiP in a separate layout.

Adding a UMD/Label
Labels can provide source information. A PiP label (or Under Monitor Display) shows the database 
name for the currently displayed source (this will update when a different source is routed to the 
PiP). A PiP label may overlay the PiP image area, or be positioned outside the PiP if there free space 
available.

When a PiP C is added to a layout, a Warning label is automatically assigned to the PiP. This label 
will report when a source is routed to that PiP that is not from an ULTRIX-HDX-IO or 
ULTRIX-MODX-IO blade. The Warning label cannot be deleted, but it can be moved to a different 
position on the layout.

When you place a label on a layout, the menus under the main toolbar update to include options 
for configuring your label. The top left corner of the label is defined by the Top and Left fields (in 
absolute pixels). The label height and width are defined by the corresponding fields. Additionally, 
labels may also be configured to show static text or tally text from a tally management system.

The label type options change depending if placed on a PiP, or placed in free space:

• on a PiP — choose between PiP Source or Static Text
• in free space — choose between Static Text or the Ultriscape Head identifier

To create a label using the database name as the content

1. Create or load a layout in the Ultriscape Layout Editor.

2. From the Objects toolbar, click UMD.

3. Select the PiP to add the label to.

The PiP displays a new text area. It will automatically size to proportionally to the size of PiP the 
label was placed on. The Label Settings displays under the main toolbar.

4. Click and drag the label to a position outside of the PiP area if required.

For More Information on...
• adding a tally label, refer to “Adding a Tally Label to a PiP”.

To add static text to a label

1. From the Objects toolbar, click SELECT.

2. Select the label you wish to edit.

3. From the Type menu in the main toolbar, select Static to display the Text: field.

The text box on the PiP automatically displays “Input Text”.
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4. In the Text: field, enter the content to display in the label for the PiP to a maximum of 121 
characters. The text automatically re-sizes to fit inside the label.

5. Click Enter.

The label on the PiP automatically updates with the new text.

To re-size a label

1. From the Objects toolbar, click SELECT.

2. Select the label box you wish to re-size.

The box displays with a dotted yellow border with white nodes at the corners.

3. Perform one of the following:

• Hover your cursor over the label box and expand its height using the provided tools; or
• Use the height menu to specify the number of pixels for the box height.

The text in the box automatically adjusts to the new box dimensions.

To re-position a label

1. From the Objects toolbar, click SELECT.

2. Select the label box you wish to move. 

The box displays with a dotted blue border with white nodes at the corners.

3. Perform one of the following:

• Hover your cursor over the label box and drag it into the new position on the PiP; or
• Use the top menu to specify the number of pixels to offset the box from the top of the PiP; or
• Use the keyboard arrow keys to nudge selected objects around a PiP.

Adding a UMD Label to the Background
Layouts with blank areas, or sections where no PiP is positioned, can also display various labels. 
These labels are not associated with any PiP, and can display static text, the Multiviewer Head label, 
or text from a remote protocol. 

For More Information on...
• the RossTalk commands your router supports, refer to its Ultrix User Guide.
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To add a UMD label to free space

1. Create or load a layout in the Ultriscape Layout Editor. Ensure the layout includes a blank area 
to position the UMD label in.

2. From the Objects toolbar, click UMD.

3. Select a PiP to place a UMD label on that PiP.

4. Select and drag the PiP UMD label to a blank area.

The text box on the layout automatically updates with “Unknown” and the Type menu displays.

To create a UMD label with static text

1. Create or load a layout in the Ultriscape Layout Editor.

2. Ensure the layout includes a blank area to position the UMD label in.

3. From the Objects toolbar, click UMD.

4. Click an area of the layout background.

5. From the Type menu, select Static to display the text field under the main toolbar.

The text box updates to display “Input Text”.

6. In the Text: field, enter the content to display in the label.

7. Click Enter.

The text box on the PiP automatically updates with the new text.

To create a UMD label that displays the identifier of the Ultriscape Head output

1. Create or load a layout in the Ultriscape Layout Editor.

2. Ensure the layout includes a blank area to position the UMD label in.

3. From the Objects toolbar, click UMD.

4. Click an area of the layout background.

5. Select Multiviewer Head Name from the Type menu.

The text box on the PiP updates to display “Unknown”.

 The label will automatically update when the layout is assigned to an Ultriscape Head. Refer to 
“Assigning a Layout to an Ultriscape Head”.
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Displaying a RossTalk Label
You can add a text label that is defined via the RossTalk communication protocol. A RossTalk label 
may be added to any Ultriscape layout. The RossTalk TXTLABEL command can control the text, the 
label background color, and the text color.

For More Information on...
• the RossTalk commands your router supports, refer to the Ultrix User Guide for your router.

To add a RossTalk label

1. Create or load a layout in the Ultriscape Layout Editor.

2. Ensure the layout includes a blank area to position the RossTalk label in.

3. From the Objects toolbar, click UMD.

4. Click an area of the layout background.

5. From the Type menu, select Remote.

6. Assign a numerical value to the text field. 

This number correlates to the TXTLABEL ID filed of the RossTalk command.

7. Control the label with the following RossTalk command: 

TXTLABEL ID:<id>; TEXT:<text>; BGCLR:<bgcolor>; TXTCLR:<textcolor>

Adding a Block of Audio Meters
For each PiP, you have the ability to display up to 16 channels of audio in a single block of audio 
meters. The meters can be positionable individually anywhere in the layout (even outside of the 
PIP). The meters display the peak level of the waveform no matter how brief its duration. The audio 
meters report the audio peak level measurements for your audio channels. Measurement units are 
in decibel full scale (dBFS) where 0dBFS is the maximum digital value. Each audio meter displays 
audio level information as illustrated in Figure 3.
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Figure 3  Illustrative Example of Audio Level Information

Audio meters may be configured in either Physical or Logical mode. Physical mode ensures the 
meter responds to audio that is associated with SDI currently feeding the PiP. Logical mode allows 
other audio sources to display.

To add an audio meter to a PiP

1. Create or load a layout in the Ultriscape Layout Editor.

2. From the Objects toolbar, click METER.

3. Use the mouse pointer to indicate where to create the box for the audio meter on a PiP of the 
layout.

The box auto-populates with two static audio meters and the Audio Meter menus display under 
the main toolbar. An error message displays in the top right corner of the Layout Editor 
interface when a block of audio meters overlaps more than one PiP or another object in a 
layout.

 By default, the audio meters are aligned to the upper left corner of the selected PiP. Ensure that 
you click in a region that allows the meter to be positioned within the PiP to avoid the overlap.

4. To place audio meters outside a PiP:

a. Place the audio meters on a PiP.

b. Click and drag the meters to the required location on the layout.

5. Use the Number of Channels field to specify how many channels to display. 

0.00 dBFS

-10.00

-20.00 (or -18.00)

-70.00 No audio Non-PCM format Dolby format Silence
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To assign an audio channel to a meter

1. From the Objects toolbar, click SELECT.

2. Select the audio meters you want to configure.

The Audio Meter menus display under the main toolbar. The selected meters display a dotted 
yellow border.

3. Assign the first meter to a channel using the Meter Channels menu.

4. Click Assign Channels to update the channel assignments.

The channel assigned to the first meter determines the series of channels displayed in the 
meters. In the example below, a meter block of 8 channels was created in PiP 1.

To re-position a block of audio meters

1. From the Objects toolbar, click SELECT.

2. Select the block of audio meters you wish to re-position.

The audio meters display with a dotted yellow border.

3. Perform one of the following:

• Click and drag the audio meters to their new position on the layout; or
• Use the keyboard arrow keys to nudge the audio meters on a PiP.

Assigning Logical Audio Meter Destinations
Audio meters may be set to Logical Mode to allow the display of audio levels of sources not 
associated with the video currently displayed on a PiP. The process is similar to defining a standard 
destination for the video level and any audio levels in the system. 

Keep the following in mind when assigning logical audio meters:

• Local PiP metering is identified by frame.slot n.head x.pip[y].meter.ch z where x 
represents the Ultriscape Head number, y represents the PiP number, and z represents the 
audio channel number.

• Shared PiP metering is identified by the frame.slot 0.pip[y].meter.ch z where y 
represents the PiP number, and z represents the audio channel number.
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To assign metering for logical operation

1. Assign a PiP to the video level.

2. Assign a PiP meter to the audio levels.

3. Refer to “Configuring the Audio Meter Logical Source Mode”.

Copying Objects in a Layout
Using hot-keys, you can quickly select, and copy individual or groups of objects from one PiP to 
another PiP, multiple PiPs, or to a PiP in another layout. When you select a PiP, all of its associated 
objects are also selected (as a group) and can be move or re-sized as a group. Clicking the PiP again, 
or any of the objects, will then select that object only.

To copy a single object in a PiP

1. Create or load a layout in the Ultriscape Layout Editor.

2. Configure the object of the PiP as required.

3. From the Objects toolbar, click SELECT.

4. Select the object in the PiP.

The object displays a dotted yellow border.

5. Press Ctrl + C or right-click the object and select Copy.

To copy all objects in a single PiP

1. Create or load a layout in the Ultriscape Layout Editor.

2. Configure the objects of the PiP as required.

3. From the Objects toolbar, click SELECT.

4. Select the PiP with the objects you want to copy. 

The PiPs displays a dotted yellow border.

5. Press Ctrl + C or right-click the object and select Copy.

To copy a selection of objects in a single PiP

1. Create or load a layout in the Ultriscape Layout Editor.

2. Configure the objects in your layout as required.

3. From the Objects toolbar, click SELECT.

4. Select the first object you want to copy. 

The object displays a dotted yellow border.

5. Press and hold Ctrl as you select additional objects to copy.

The additional selected objects now display a blue border.

6. Press Ctrl + C.
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Pasting Objects in a Layout
Using hot-keys, you can quickly paste objects from one PiP to another PiP, multiple PiPs, or to a PiP 
in another layout. If you are pasting the contents of one PiP to another PiP of a different size, the 
objects are automatically re-sized to fit the new PiP. The position of the objects within the new PiP 
reflects the position in the original PiP.

 An object is pasted where your cursor was last positioned within the selected PiP. For example, if 
you selected a PiP by clicking in its center, the object will be pasted to the center of the new PiP.

To paste an object to a PiP in the same layout

1. Copy the object using one of the methods in “Copying Objects in a Layout”.

2. From the Objects toolbar, click SELECT.

3. Select the PiP to paste the object into.

The PiP displays with a dotted yellow border.

4. Press Ctrl + V.

A copy of the object is added to the selected PiP.

 If the PiP that the object is pasted into is a different size from the original PiP, an error message 
displays alerting you that the pasted object now straddles multiple PiPs.

To paste an object to multiple PiPs in the same layout

1. Copy the object using one of the methods in “Copying Objects in a Layout”.

2. From the Objects toolbar, click SELECT.

3. Select the PiPs to paste the object into.

The selected PiPs display with a dotted yellow border.

4. Press Ctrl + V.

A copy of the object is added to all the selected PiPs.

To paste an object to a PiP of a different layout

1. Save the changes to the current layout if required as outlined in “To save a layout to the local 
DashBoard client computer”.

2. Copy the object(s) using one of the methods in “Copying Objects in a Layout”.

3. Load the layout you wish to paste the object(s) into as outlined in “To load a layout template”.

4. From the Objects toolbar, click SELECT.

5. Select the PiP to paste the object(s) into.

The PiP displays with a dotted yellow border.

6. Press Ctrl + V.

A copy of the object(s) is added to the selected PiP.

 If the PiP that the object is pasted into is a different size from the original PiP, an error message 
displays alerting you that the pasted object now straddles multiple PiPs.
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Displaying Closed Caption Data
Ultriscape supports the display of CEA-608, CEA-708, and OP-47 closed caption data.1 Both SDI 
(SMPTE 291M) and IP streams (SMTPE 2110-40) are supported as sources of closed caption data. Up 
to 64 closed caption displays may be active (on configured and selected Ultriscape layouts) at any 
one time, with a maximum 16 closed captions per Ultriscape Head.

 Ultriscape closed caption displays are for confidence monitoring and may not adhere to 
accessibility standards. 

Before You Begin
The Ultriscape-CA license must be installed on the Ultrix router. Refer to “Software License Keys” 
for details on enabling licensed features.

Configuring an Ultriscape Head to Display Closed Caption Data
Once the Ultriscape-CA license is enabled, a Closed Caption (CC) display object may be added to any 
single PiP of an Ultriscape layout2. A CC display object is a four line text display object. The different 
closed caption formats will dictate how the space is utilized. For each CC display object, you can 
adjust:

• the height of the object but the text will scale to always fit four text lines vertically.
• the width but the characters may be truncated if the line is longer than available space.

To add a Closed Caption display object to a layout

1. Create or load a layout in the Ultriscape Layout Editor.

2. From the Objects toolbar, click CC.

3. Select the PiP that will display the CC data.

4. Use the Options menu to specify the Closed Caption format. Choose from the following:

• Auto — auto detects the format from data.
• CEA-608 — formats the data as defined by CEA-608/EIA-608.
• CEA-708 — formats the data as defined by CEA-708.
• OP-47 — formats the data as defined by OP-47.

1. Requires software version 4.6 or higher and the Ultriscape-CA license.
2. Caption options may not be visible/accessible if license is not enabled.
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5. Click Apply.

6. Save the layout as outlined in “Saving a Layout”.

To re-size a CC display object

1. From the Objects toolbar, click SELECT.

2. Select the CC display object you wish to re-size.

The box displays with a dotted yellow border with white nodes at the corners.

3. Perform one of the following:

• Hover your cursor over the box and expand its size using the provided tools; or
• Use the CC menus to specify the number of pixels for the box layout.

Caption Settings Tab

Table 3 summarizes the options displayed in the Layout Editor Settings > Caption Settings tab.

 

Configuring an Ultriscape Head to Display Metadata
Once the Ultriscape-CA license is enabled, the Clip Data display object can be added to any single 
PiP of a layout1. A Clip Data display object is a five-line field that is auto-populated with the following 
Evertz® DreamCatcher™ metadata found in the embedded ANC packets: 

• Clip Name — the top line reports the name assigned to the clip assigned to the PiP.
• Clip ID — the second line reports the Clip identifier in the format of Page/Bank/Slot/Angle of the 

cued content. For example, a line that displays 1/2/3/4
• Playlist Name — the third line reports which playlist the cued content was sourced from.
• Playlist Status — the fourth line reports the overall playout speed as a percentage (%). 
• Clip Time Remaining — the bottom line reports the runtime of the currently cued content in the 

format of HH:MM:SS.

To add a Clip Data display object to a layout

1. Create or load a layout in the Ultriscape Layout Editor.

2. From the Objects toolbar, click CLIP DATA.

3. Select the PiP that will display the closed caption metadata.

4. Click Apply.

5. Save the layout as outlined in “Saving a Layout”.

Table 3  Layout Editor Settings — Caption Settings Tab

Item Parameters Description
Caption Settings

Caption Logging 
Mode

Errors Only* The Ultriscape Closed Caption system creates event 
logs which are not user accessible but may be 
required by Ross Technical Support. 
Do not set to All unless instructed by Ross Technical 
Support. 

All

Captions in Use 
(read-only)

# Indicates the quantity of captions currently 
displayed across the Ultriscape Multiviewer system

1. Caption options may not be visible/accessible if license is not enabled.
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To re-size a Clip Data display object

1. From the Objects toolbar, click SELECT.

2. Select the Clip Data display object you wish to re-size.

The box displays with a dotted yellow border with white nodes at the corners.

3. Hover your cursor over the box and expand its size using the provided tools. 
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Using PiP Templates in 
Layouts
Once you have configured a PiP, you can save it as a PiP template to be applied to other PiPs in the 
same layout, or other active layouts. 

 A PiP template only captures the objects and their placement on the PiP and not the PiP 
Simulation Color.

To save a PiP as a new template

1. Create or load a layout in the Ultriscape Layout Editor.

2. Configure the objects of the PiP as required.

3. From the Objects toolbar, click SELECT.

4. Select the PiP.

The PiP displays with a dotted yellow border.

5. From the main toolbar, click SAVE PiP.

The Save PiP Template dialog opens.

6. In the PiP Template Name field, type a unique identifier.

7. Click OK to save the current PiP settings as a new PiP template and close the dialog.

To apply a PiP template

1. Create or load a layout in the Ultriscape Layout Editor.

2. From the Objects toolbar, click SELECT.

3. Select the PiP to apply the template to.

The PiP displays with a dotted yellow border.

4. From the main toolbar, click LOAD PiP.

The Load PiP Template dialog opens.
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5. Select a template from the list.

6. Click OK to apply the template to the selected PiP and close the dialog.

To delete a PiP template

1. From the main toolbar, select File > Delete PiP.

The Delete PiP Templates dialog opens.

2. Select a template from the list.

3. Click OK to apply the template to the selected PiP and close the dialog.

Any PiPs that had the template applied are not affected, but the PiP template will no longer be 
made available for applying to future PiPs.
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Managing the Layouts
This chapter outlines general tasks such as how to save a layout, load a layout, export/import a 
layout, and delete a layout.

Saving a Layout
Before a layout can be assigned to an Ultriscape Head, you must first publish the layout and make it 
available to the Multiviewer system. Once a layout is published, it is available for use by all 
Ultriscape Heads in your routing system and appears in the Activate Layout area of the Ultriscape 
Head interface.

To save a layout to the database

1. Create or load a layout in the Ultriscape Layout Editor.

2. Edit your PiPs as required.

3. Save your layout changes.

4. From the main toolbar, select File > Save to Ultricore.

The Save Layout dialog opens.

5. To overwrite a previously published layout in the Ultricore system:

a. Select a layout to overwrite from the provided list.

b. Click OK.

6. To publish the layout as a new layout in the Ultricore system:

a. Type a unique identifier for the layout in the Layout Name field.

b. Click OK.

Saving a Layout as a Local Copy
When you save a layout, it saves a local copy to the computer running your DashBoard client. To 
make the layout available to the routing system, you must publish the layout as outlined in “Saving 
a Layout”.

To save a layout to the local DashBoard client computer

1. Create or load a layout in the Ultriscape Layout Editor.

2. Edit your PiPs as required.

3. From the main toolbar, select File > Save to Local.

The Save to Local dialog opens.

4. Type a unique identifier for the layout in the Layout Name field.

5. Click OK to save your changes.

The Save to Local dialog closes.
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Loading a Previously Saved Layout
Loading a saved layout automatically clears the Layout Editor workspace. 

To load a previously saved local layout

1. From the main toolbar, select File > Load from Local.

The Open Layout dialog opens.

2. Select a layout from the provided list.

3. Click OK.

The Load Layout dialog closes and the Ultriscape Layout Editor workspace updates with the 
selected layout.

To load a previously saved layout in Ultricore

1. From the main toolbar, select File > Load from Ultricore.

The Load Layout dialog opens.

2. Select a layout from the provided list.

3. Click OK.

The Load Layout dialog closes and the Ultriscape Layout Editor workspace updates with the 
selected layout.

Archiving the Layouts
A layout can be archived by saving it as a *.lay file to a specified location. This enables you to import 
and export an archived layout.

 This feature requires DashBoard v8.2 or higher and Ultrix software version 2.0 or higher.

Exporting a Layout
You create an archive of a layout (as a *.lay file) using the options in the System Status > Transfer 
tab.

 The following information is not captured: hardware specifics, and license settings.

To export an Ultriscape layout

1. In the Tree View of DashBoard, double-click the System Status node.

The System Interfaces display in the DashBoard window.

2. Select the Transfer tab.

3. Select the Ultriscape Layout tab.

4. Locate the Export Ultriscape Layout area on the tab.

5. Use the Layout field to select the layout to export.

6. Click Browse... to specify the location to save the *.lay file to.

The Save As read-only field updates with the selected path and layout name.

7. Click Export.

The Downloading Archive dialog opens to report the status of the export.
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Importing a Layout
Once a layout is imported from the archive to your system, you can select it from the list of layouts 
to load in the Ultriscape > Layout Editor > Load from Local menu and the Head Selection > 
Activate Layout area.

To import an Ultriscape layout

1. In the Tree View of DashBoard, double-click the System Status node.

The System Interfaces display in the DashBoard window.

2. Select the Transfer tab.

3. Select the Ultriscape Layout tab.

4. Locate the Import Ultriscape Layout area.

5. Select the *.lay file you wish to import as follows:

a. Click Browse... 

The Open dialog opens.

b. Use the Open dialog to specify the *.lay file to import.

c. Click Open to load the file.

6. Click Import.

The Uploading Archive dialog opens to report the status of the transfer.

7. Verify that the imported layout is now available for selection in the following locations:

a. Ultriscape > Layout Editor > Load from Ultricore menu

b. Ultriscape > Head Selection > Activate Layout area

Deleting a Layout
 If the layout is not displayed in the Delete Layout dialog, it is currently in use by a Ultriscape 

Head.

To delete a layout from the Ultricore system

1. From the main toolbar, select File > Delete Layout from Ultricore.

The Delete Layout dialog opens.

2. Select the layout from the provided list.

3. Click OK to delete the layout from the Ultricore system.

Clearing the Workspace
Changes to layouts and PiPs take effect if you save the new settings. You can clear the workspace 
and start over and any unsaved changes to the current layout will be discarded.

To clear the workspace

• From the main toolbar, select Edit > Clear All.
The workspace area is now blank.
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Assigning a Layout to an 
Ultriscape Head
This chapter summarizes how to assign a layout to an Ultriscape Head.

For More Information on...
• assigning a Head to a router output, refer to “To assign an Ultriscape Head to a router output”.
• the UltriStream licensed feature, refer to the Ultrix User Guide for your router.

Before You Begin
Keep the following in mind when configuring an Ultriscape Head:

• The Ultriscape Layout Editor display matches the output Ultriscape Head to the pixel. The output 
can be 1080p or 1080i. Refer to “To assign an Ultriscape Head to a router output”.

• The Ultriscape license is on a per head basis. When not licensed, the Ultriscape Layout Editor is 
available, but you cannot assign any layouts to an Ultriscape Head.

• Ancillary data is stripped, except for audio; SMPTE 352 and AFD packets are re-generated and 
output by the system.

• The output aspect ratio is always 16:9.
• If a PIP is set to follow a router destination, audio levels reflect any processing applied (gain, 

shuffle etc.).
• If a PIP is set to follow a source, it reports the source audio information without any processing.
• Ultrix does not support Unicode characters.

Head Selection Interface
The Head Selection interface is organized into a series of tabs, each representing an enabled Head. 
(Figure 4) Each Head Selection tab is divided into three areas: Activate Layouts (top area), MV Head 
Settings (middle area), and Read-only Fields (bottom area).

Figure 4  Example of the Head Selection Interface
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Activate Layout Area

The Activate Layout area is the top half of the interface. This area provides a visual representation 
of each layout that is enabled in your routing system. Multiple routers can load a layout at the same 
time. Each PiP is numbered (1, 2, 3 etc.) to enable quick identification when assigning sources. The 
currently selected Layout for the Ultriscape Head output displays a blue border, and its name is 
displayed in the Layout Name field. In Figure 4, 4box.lay is selected. A layout will appear gray to 
indicate the PiP sizes within the layout do not match the current settings. These layouts cannot be 
selected for Ultriscape output until the Configuration > PiP Layout > PiP Size Selection settings for 
Pip A and PiP B match those on the layout. 

MV Head Settings Area

Use the option in this area to customize the MV Head and layout settings.

Read-only Fields

The bottom area of the tab provides read-only information about the PiPs (e.g. dimensions).

Assigning a Layout to an Ultriscape Head
Each Ultriscape Head in your system can use the same layout, or different layouts depending on 
your needs. 

To assign a layout to an Ultriscape Head

1. Double-click the Ultrix router in the Basic Tree View of DashBoard.

2. Expand the Ultriscape node.

3. Double-click the Head Selection node.

The Head Selection tab displays in the right side of the DashBoard window. Each Ultriscape 
Head displays as a sub-tab in this window.

4. Select the tab for the Ultriscape Head you want to configure.

5. Select a layout from the Activate Layout area of the tab.

The Head Selection tab updates to provide the editable options and read-only information for 
the selected layout. In the example below, 4box.lay is selected for slot1.head1.
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6. If required, edit the text reported in the MV Head Name field to assign a new name to the 
current Ultriscape Head, or reset the name to the default nomenclature (slot#.head#).

7. Use the Audio Meter Settings to specify whether the audio bars on PiPs represent the audio 
that is embedded in the SDI stream (Physical mode), or if audio bars on PiPs display audio levels 
based on a source’s logical definition (Logical mode). Refer to “Ultriscape Layout and Head 
Configuration” for more information.

8. Set the Peak Hold to On to enable the audio meters to report the audio peak level 
measurements for your audio channels.

9. Use the Head Alias Set Setting to apply a specific database alias set to the PiPs in this 
Multiviewer Head or not (Default). Refer to the Ultrix and Ultricore Database Guide for details 
on creating alias sets.

10. Click Apply at the bottom of the Head Selection tab.
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Assigning Sources to PiPs
This chapter summarizes how to assign router sources to PiPs in a layout.

For More Information on...
• assigning an Ultriscape Head to an output, refer to “Assigning Ultriscape Head Destinations”.

PiP Layout Mapping Overview
This section provides examples to illustrate the PiP assignment in a layout where:

• x is the slot number counted from the top of the layout starting at 1.
• n is the Ultriscape Output Head number. The physical port this output appears on is defined by 

the Port License tab. Refer to the Ultrix User Guide for your router.

Example using the LAYOUT-01 Template
This template is a 2+8 layout with a total number of 10 PiPs available to map. (Figure 5)

Figure 5  Example of the LAYOUT-01 Template

Table 4 outlines the destination assignment for each PiP in the LAYOUT-01 template. 
Table 4  PiP Layout Mapping — LAYOUT-01 Template

PiP Number Destination Assignment
1 Ultrix.slotx.headn-pip[1]

2 Ultrix.slotx.headn-pip[2]

3 Ultrix.slotx.headn-pip[3]

4 Ultrix.slotx.headn-pip[4]

5 Ultrix.slotx.headn-pip[5]

6 Ultrix.slotx.headn-pip[6]

7 Ultrix.slotx.headn-pip[7]

8 Ultrix.slotx.headn-pip[8]

9 Ultrix.slotx.headn-pip[9]

10 Ultrix.slotx.headn-pip[10]
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Example using the LAYOUT-02 Template
This template is a 2x2 layout with a total number of 4 PiPs available to map. In Figure 6, the user 
altered the template to utilize shared PiPs.

Figure 6  Example of the LAYOUT-02 Template

Table 5 outlines the destination assignment for each PiP in the LAYOUT-02 template. 

Multiple Heads
If multiple heads are configured, destination assignments must be defined for all heads and PiPs.

Table 5  PiP Layout Mapping — LAYOUT-02 Template

PiP Number Destination Assignment
1 Ultrix.slot0.headn-pip[1]

2 Ultrix.slot0.headn-pip[2]

3 Ultrix.slot0.headn-pip[3]

4 Ultrix.slot0.headn-pip[4]

Table 6  PiP Layout Mapping — Multiple Heads

Name Destination Assignment
MV Head 1 Ultrix.slot1.head1.sdi.ch1

MV1 PiP1 Ultrix.slot1.head1-pip[1]

MV1 PiP 2 Ultrix.slot1.head1-pip[2]

...more MV1 PiP Assignments

MV Head 2 Ultrix.slot2.head1.sdi.ch1

MV2 PiP1 Ultrix.slot2.head1-pip[1]

MV2 PiP 2 Ultrix.slot2.head1-pip[2]

...more MV2 PiP Assignments
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Assigning a Source to a PiP
A PiP is controlled by routing just like any destination. Each PiP can be a ‘direct source’ take 
operation or a ‘destination follow’ operation (where multiple outputs switch to the same input 
signal that a destination is switched to).

The Ultrix router directly routes to the PiP via a crosspoint selection on a soft panel. If the input 
signal includes embedded audio, the audio is included in the Ultriscape Head output.

When routing sources to the PiPs of an Ultriscape Head, you can display sources:

• of different formats on the same head at one given time;
• with no assumed timing relationship on the same head at one given time.

To assign a source to a PiP using a soft panel

1. Ensure your database includes destinations assigned to the required Ultriscape Head(s), and 
destinations. Refer to “To assign an Ultriscape Head to a router output”, and “To display the 
destinations in your database”.

2. Assign a layout to the Ultriscape Head. Refer to “To assign a layout to an Ultriscape Head”.

3. Create and load a soft panel that includes the Ultriscape Head(s) and PiP(s). Refer to the Ultrix 
and Ultricore Database Guide for details.

4. Select the crosspoint(s) as required.

In the following example, the user assigned SRC 4 to PIP H1-2, SRC 6 to PIP H1-3, and SRC 8 to 
PIP H1-5.

• A PiP displays the source for the Destination the PiP is assigned to (e.g. a PiP acts like a 
regular router destination). This is the default setting for all PiPs. 

• If the destination has Follow Dest enabled, the source that the PiP displays is dependent on 
the source routed to the specified Destination. For example, PIP H1-5 is set to Follow Dest 10. 
If the user switches Dest 10 to Src 3, PIP H1-5 displays Src 3. If Dest 10 then switches to Src 30, 
PIP H1-5 will then display Src 30.

5. Click TAKE to perform the crosspoint switch on the selected PiPs.
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Audio Meter Modes Setup
This chapter outlines how to set up and monitor audio meters for PiPs that are configured for 
Normal or Default Source modes. There are two source modes when configuring audio meters:

• Physical Source mode — the audio bars on PiPs represent the audio that is embedded in the SDI 
stream. This is the default mode.

• Logical Source mode — the audio bars on PiPs display audio levels based on a source’s logical 
definition. The bars index from left to right (meter port channel 1 represents the leftmost audio 
meter bar, and meter port channel 16 represents rightmost possible audio meter bar).

Overview
A PiP containing a defined audio meter object may be configured to represent the audio from a 
variety of sources as outlined in Table 7.

By default, Ultriscape Heads will be in Physical mode, which shows the levels for the audio 
embedded in the SDI stream currently displayed on the PiP.

To enable an Ultriscape Head to show display audio metering based on the logical source definition, 
select Logical from the Head Audio Meter Settings menu in the Head Selection interface.

Figure 7  Head Audio Meter Settings Menu

Note that when activated, the Logical Mode setting:

• is global to the Ultriscape Head and it affects all PiPs defined on the Head that are not set to Dest 
Follow. The Logical mode is enabled regardless of which layout is applied to the Ultriscape Head.

• causes the affected PiPs to ignore the meter channels assignment made in the active layout's PiP 
definition (which are only used for Physical mode). The same number of meter bars defined in 
the PiP is still displayed.

• requires that PiP meter ports be assigned in the logical database to map the meter to audio 
channels; otherwise no audio levels will be displayed for PiPs that are set to Normal or Source #.

 Audio meters on PiPs set to Dest Follow, by definition, will always show what has been 
embedded into the output SDI stream, regardless of the Head Audio Meter Setting.

Table 7  Audio Meter Settings

PiP Mode
Audio Meter Mode

Physical Logical
Source Audio from the SDI source Router audio channels

Normal Audio from routed SDI source Routed audio channels

Dest Follow Audio from destination SDI Audio from destination SDI
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Configuring the Audio Meter Logical Source Mode
In order for the PiPs to display logical source audio levels, the audio meters' ports must be assigned 
to logical destinations associated with the Ultriscape PiPs.

Each available PiP SDI port in the system will now have associated with it 16 'meter' ports; one for 
each possible audio bar in a meter. These ports should be mapped to the audio levels within the 
database. By default, the bars index from left to right (meter port channel 1 represents the leftmost 
audio meter bar, and meter port channel 16 represents rightmost possible audio meter bar). You 
can choose a different map via your layout.  It is not required to add meter port entries to the 
database for bars that will not be shown in a PiP. 

Figure 8 provides an example with one level for the video source and two audio levels for the 
metering.

Figure 8  Example of Defining the Audio Meter Ports

There are two stages to configuring Audio Meter Logical Source mode support:

1. Ultriscape Layout and Head Configuration

2. Logical Database Configuration

Audio Meter Behaviors
Table 8 summarizes the behaviors for the Audio meters in Physical vs. Logical mode under various 
switching scenarios. Note for all “Logical” switching scenarios, the assumption is that the Ultriscape 
Layout/Head is configured for meters and that the appropriate meter ports have been assigned to 
the database as required.
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Notes
• If the input port is from an UltriMix enabled slot, then the logical definition can be used to route 

the audio.
• To see the physical audio associated with an UltriMix input, there would need to be an additional 

source defined in the logical database that has the appropriate pass through (or audio ports) 
assigned (similar to defining “breakaway” audio sources) (or the user can set the Ultriscape Head 
to Physical mode).

Configuration Example
Consider the following scenario: a bilingual source is defined where the English audio appears on 
embedded channels 1 and 2, and the French audio appears on embedded channels 3 and 4 and a 
PiP destination is defined to have audio metering showing 2 channels.

When the user routes source 'Src 1 EN' to the PiP, it will display the SDI from Slot1.in[1] port, and the 
embedded audio channels 1 and 2 will be mapped to the PiP meters 1 and 2.

When the user routes source 'Src 1 FR' to the PiP, it will display the SDI from Slot1.in[1] port, and the 
embedded audio channels 3 and 4 will be mapped to the PiP meters 1 and 2.

Table 8  Expected Audio Meter Behavior

Audio Meter 
Source Mode Source Port Definition

Input 
License Result

Logical No Logical Audio defined No Bars active (Physical shown)

Logical No Logical Audio defined Yes No bar activity

Logical Logical Audio defined Yes Bars Active (Logical shown)

Logical Logical with pass-through port Yes Bars Active (Logical shown, Physical on pass-through)

Logical Port set to ‘Bypass’ Yes Bars Active (Physical shown)

Physical No Logical defined No Bars active (Physical shown)

Physical No Logical defined Yes Bars active (Physical shown)

Physical Logical Audio defined Yes Bars active (Physical shown)

Physical Logical with pass-through port Yes Bars active (Physical shown)

Physical Port set to ‘Bypass’ Yes Bars active (Physical shown)

Table 9  Example 1

SDI Level Level A1 Level A2
Source Name

Src 1 EN Slot1.in[1] Slot1.in[1].ch1 Slot1.in[1].ch2

Src 1 FR Slot1.in[1] Slot1.in[1].ch3 Slot1.in[1].ch4

Destination Name

PiP1 Head1-pip[1] pip[1].meter.ch1 pip[1].meter.ch2
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Ultriscape Layout and Head Configuration
When activated, the Logical Mode setting is global to the Head and affects all PiPs defined on that 
Head that are not in Dest Follow mode. The Logical Mode is enabled regardless of which layout is 
active on the Head. 

To enable logical source mode on a PiP of an Ultriscape Head

1. Define an Ultriscape layout with PiPs that include audio meters as outlined in “Adding a Block 
of Audio Meters”.

2. Activate the layout on the required Ultriscape Head as outlined in “Assigning a Layout to an 
Ultriscape Head”.

3. Assign the sources for each PiP in the layout as outlined in “Assigning a Source to a PiP”.

4. Make a note of which PiPs in the layout display the audio meter bar(s) you wish to configured. 
This information is required when assigning meter ports in the database.

 The audio meters on PiPs set to Dest Follow mode always represent what has been embedded 
into the output SDI stream, regardless of the Head’s Audio Meter setting.

5. Select Logical from the Head Audio Meter Settings menu located at the bottom of the Head 
Selection tab.

 To disable the Logical Mode, select Physical from the Head Audio Meter Setting menu.

Logical Database Configuration
This section outlines the database configuration steps necessary to enable Logical Source Audio 
meter support on an Ultriscape PiP and Head.

To assign PiP audio meter ports to Multiviewer PiP Destinations

1. Double-click the Destinations node located under the Database node.

The Destinations tab opens. 

2. Assign the Ultriscape Head to a Destination in the database as outlined in “Assigning 
Ultriscape Head Destinations”.

3. Assign a PiP audio meter port to level for that Head Destination as follows:

 The database level to which the meter bar’s port is assigned determines the signal for which the 
bar will display audio meter data when switched. The bar will display the audio meter data from 
the audio port channel assigned to the corresponding level of a logical source when switched to 
the PIP destination.

a. Select the first cell in the first Level column of the Destination row for the Head output.

This will be the first meter bar in the PiP.

b. Choose a PiP meter output from the available list. 

The meter outputs are labeled as Ultrix.slot#head#-pip[#].meter.ch#. For example, 
to assign the first bar for the second PiP of Head 3, you would select 
Ultrix.slot#head3-pip[2].meter.ch1.

c. Click Assign.

4. Repeat step 3 for each audio meter bar you want to assign.

 It is not required to add meter port entries to the database for bars that will not be shown in a 
PiP.
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Clock Control
This chapter outlines how to operate a clock object in an Ultriscape layout, and the supported 
RossTalk commands for Ultriscape clock state control.

For More Information on...
• the Clock Control interface, refer to “Clock Control Interface”.

Adding a Clock Object to a Layout
When creating layouts with a clock object, you first must define the types of clock(s) available to add 
to a layout. The Clocks tab in the Layout Editor is used to define and list the available clocks. 

 You can define a maximum of 20 system clock types in the Layout Editor > Clocks tab. An error 
message displays in the bottom left corner of the Clocks tab if you exceed the maximum.

Defining a Clock
A clock can perform one of the following functions:

• Time-of-day — this clock is a 24 hour display of system time. You can add an offset to display time 
zone relative to the system time. By default, one clock is defined as this type.

• Count down — the clock counts down from a set point. This may be controlled via RossTalk 
commands or the clock control panel.

• Stop watch — the clock counts up from a value of 00:00:00. This may be controlled via RossTalk 
commands or the Clock Control interface.

To define a clock

1. Double-click the Layout Editor node located under the Ultriscape node.

The Layout Editor interface opens.

2. Select the Clocks tab.

The Clocks tab is organized as a table where each row represents a specific clock that is 
available to add to your layouts.

3. Right-click the last row in the tab.

4. Select Insert Row Below.

A new blank row displays in the tab. The text “New Clock #” displays in the Name cell of the 
new row. 

5. To name the clock:

a. Select the Name cell in the new row.

b. Type a unique identifier in the Name cell.

This text will be used to identify this clock object in the Layout Editor menus.

6. To assign a function to the clock:

a. Right-click the Type cell in the new row.

b. Select an option. Refer to Table 20 for a list of options.

7. Use the Offset menu to specify an offset (hh:mm) relative to the system clock.

 This value is only applicable when Type is set to timeofday.

8. Use the Time Value menu to specify the timer start value (hh:mm:ss).
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 This value is only applicable when Type is set to countdown.

9. Click Apply.

Adding a Clock to a Layout
A clock may be placed on a PiP or the layout background.

 You can add up to 16 clock objects per Ultriscape head. For example, on an ULTRX-FR12 with 48 
licensed Ultriscape heads, there can be up to 768 clock objects (16 clocks per head x 48 heads). 
An error message displays in the top right corner of the Layout Editor if you exceed the 
maximum.

To add a clock to a PiP

1. Create or load a layout in the Ultriscape Layout Editor.

2. From the Objects toolbar, click CLOCK.

3. Use the mouse pointer to indicate where to create the box for the clock on a PiP of the layout.

The box auto-populates with the text “Default Clock”. 

4. From the Objects toolbar, click SELECT.

5. Select the clock box you created in step 3.

The Clock menus display under the main toolbar.

6. Use the Clock Source menu to specify the clock to use in the clock selected box.

The box auto-populates with the clock function you selected.

 There may be only four clocks in a horizontal line across the layout. The bounding box (dotted 
outline) of small clocks increases to indicate this.

Using a Clock Object
The procedure for operating a clock in Ultriscape is the same for either countdown or stopwatch 
types. There is no control option for time-of-day clocks.

To use a clock

1. Configure your clock type(s) as outlined in “To define a clock”.

2. Add a clock to an Ultriscape layout as outlined in “Adding a Clock Object to a Layout”.
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3. Assign the layout to an Ultriscape Head as outlined in “Assigning a Layout to an Ultriscape 
Head”.

4. Double-click the Clock Control sud-node in the Ultriscape tree.

The Clock Control tab opens.

5. Select the row for the Clock ID for the stopwatch you wish to use.

6. Use the buttons in the right toolbar to control the clock. Choose from the following:

• PLAY — starts the stopwatch or countdown timer.
• RESET — stops the stopwatch or countdown timer and resets it 00:00:00.
• PAUSE — temporarily stops the stopwatch or countdown timer without resetting to start 

point. Click this button again to re-start the clock.

Using RossTalk with Ultriscape Clock Objects
Table 10 outlines the supported RossTalk commands for Ultriscape Clock state control and 
reporting messages where:

• id represents the unique “global clock id” associated with a clock time source. Note that more 
than one clock display element may point to the same time source clock ID.

• state represents the current or requested state for the clock / time source. Valid state values are:
› run — the clock (or timer/stopwatch) is running. The time-of-day clocks always reports ‘run’.
› stop — the clock is in a stopped state and reflects the default time for its type (e.g. timer: full 

timer value, stopwatch: 0:0:0.0). This is only valid for stopwatch/timer type.
› pause — the clock is paused and displays the current time value. When returned to ‘run’ it will 

resume counting from the current time value. This is only valid for stopwatch/timer type.
› end — a timer has counted fully down and reached 0 time remaining. This is only valid for 

timer type notifications/responses.
› set — assigns the timer value to “value”.

 
Table 10  Ultriscape Clocks — Supported RossTalk Commands

Received Message
Command Description

TIMER id:RUN Request Timer ID to start/resume

TIMER id:STOP Request Timer ID to stop

TIMER id:PAUSE Request Timer ID to pause

TIMER id:END Request Timer ID to end

TIMER id:SET:hh:mm:ss.s Request to set Timer value
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Monitoring Options
A Multiviewer layout can include Alarms display objects. When an alarm condition is triggered, as 
defined in the Alarming Configuration interface, the Ultriscape output displays an error message 
until the condition is no longer detected. This chapter outlines how to add an Alarms display object 
to a Multiviewer Layout, and specify what conditions to monitor.

Overview
The steps to add an Alarms display object on a Multiviewer layout are as follows: 

1. Ensure an Ultriscape-CA license is enabled on the router. Refer to “Software License Keys”.

2. Create a Multiviewer layout using the Layout Editor. Refer to “Creating a Layout”.

3. Add an Alarms display object to the PiP(s). Refer to “Adding an Alarm Display Object to a 
Layout”.

4. Assign the layout to an Ultriscape Head. Refer to “Assigning a Layout to an Ultriscape Head”

5. Specify the alarm messages to report on the layout. Refer to “Selecting an Alarm Condition to 
Monitor”.

This chapter outlines how to add an Alarms display object to a Multiviewer Layout (step 3), and 
specify what conditions to monitor (step 5). 

Adding an Alarm Display Object to a Layout
Adding an Alarm display object is much like adding a layout object as outlined in “Adding Objects 
to a Layout”. 

 Alarm display objects doe not have a limitation on where they are located other than they cannot 
overlap with another alarm object, or UMD/Label object. This enables you to position an Alarm 
display object outside a PiP to avoid blocking the video image.

To add an Alarm display object to a layout

1. Create or load a layout in the Ultriscape Layout Editor.

2. From the Objects toolbar, click Alarming.

3. Select the PiP that will display the Alarms display object.

The Alarms object on the PiP automatically displays “Alarms”.

In the example below, the user added an Alarms object to PiP 1 and PiP 2.
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4. If required, re-position the Alarms display object on the PiP. 

5. Save the layout as outlined in “Saving a Layout”.

Selecting an Alarm Condition to Monitor
Once the Alarm display objects are added to the PiP(s), and the layout is assigned to an Ultriscape 
Head, proceed to configure what messages the layout will report. The content of the Alarm display 
object is configured using the options in the Alarming Configuration interface.

To access the Alarming Configuration interface

1. Launch the DashBoard client. 

2. Locate the Ultrix node in the Tree View.

3. Expand the Ultrix node to display a list of sub-nodes in the Tree View.

4. Double-click the Alarming Configuration sub-node.

The Alarming Configuration interface opens in the DashBoard window.

Video Monitoring
The Video Alarms tab arranges the options in a table where each row represents a specific router 
port and the columns are the monitoring options. Each port can be configured for monitoring as 
required.

To enable video monitoring

1. Display the Alarming Configuration interface as outlined in “To access the Alarming 
Configuration interface”.

2. Select the Alarming Config tab.

3. Select the Video Alarms sub-tab.
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4. Locate the row for the first port you wish to monitor.

5. To trigger an alarm when the video signal is set to black:

a. Select the Video Black box.

b. Use the Video Black Hysteresis to specify the number of seconds the video is set to black 
before an error is reported.

6. To trigger an alarm when there is an extended amount of time with no active picture changes:

 If there is a loss of signal that produces a frozen image, and the Video LOS alarm is enabled for 
the port, a Video LOS message takes precedence.

a. Select the Video Freezes box.

b. Use the Video Freezes Hysteresis (ms) to specify the number of milliseconds the signal is 
set to a single frame of video before an error is reported.

7. To trigger an alarm when a valid SDI signal is no longer detected:

a. Select the Video LOS box.

b. Use the Video LOS Hysteresis (ms) to specify the number of milliseconds a valid SDI signal is 
absent before an error is reported.

8. To trigger an alarm when the input video format does not match the user's selected format:

 The video format is reported on the PiP to help the diagnose the problem.

a. Select the Video Format box.

b. Use the Video Format Hysteresis (ms) to specify the number of milliseconds the signal is 
incompatible before an error is reported.

9. To trigger an alarm for monitoring the closed caption data of a signal:

 The closed caption format is reported on the PiP to help the diagnose the problem.

a. Select the Caption Format box.

b. Use the Caption Format Hysteresis (ms) to specify the number of milliseconds the closed 
captioning data is lost before an error is reported.
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Audio Monitoring
The Audio Alarms tab arranges the options in a table where each row represents a specific audio 
channel and the columns are the monitoring options. Each audio channel can be configured for 
monitoring as required.

To enable audio monitoring

1. Display the Alarming Configuration interface as outlined in “To access the Alarming 
Configuration interface”.

2. Select the Alarming Config tab.

3. Select the Audio Alarms sub-tab.

4. Locate the row for the first audio channel you wish to monitor.

5. Use the Audio Silence Threshold (ms) field to specify the maximum number of milliseconds 
any audio channels are silent before an alarm is triggered.

6. To trigger an alarm when there is invalid audio signal:

a. Select the Audio LOS box.

b. Use the Audio LOS Hysteresis (ms) to specify the number of milliseconds a valid audio 
signal is absent before an error is reported.

7. To trigger an alarm when the audio signal is muted or silent for a specific channel:

a. Select the Audio Silence box.

b. Use the Audio Silence Hysteresis (ms) to specify the number of milliseconds the audio 
signal is muted/silent before an error is reported.

Monitoring via an Ultriscape Output
To be used for alarming, a PiP must include an Alarms display object; and is assigned to a source 
that has at least one alarm trigger enabled.

When an alarm is trigged, an error message displays on the output to indicate the status. Once the 
error status is cleared (such as when the Video LOS alarm is enabled, the signal is lost but then the 
signal is restored), the error message no longer displays. Figure 9 shows that Src 1 is reporting two 
errors: a loss of video and a loss of audio.
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Figure 9  Example of a PiP Reporting Two Alarm Messages via an Ultriscape Output

Monitoring via the Alarming Status Tab in DashBoard
The Alarming Status tab provides a summary of the alarms currently trigged. (Figure 10) Select an 
Ultriscape Head from the MV Head list to filter the Messages area.

Figure 10  Example of Messages Reported in the Alarming Status Tab
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Ultriscape Menus Overview
This chapter summarizes the nodes, tabs, menus, and parameters for the Ultriscape feature in 
DashBoard.

For More Information on...
• the DashBoard client software, refer to the DashBoard User Manual.
• navigating the interfaces in DashBoard, refer to “Accessing the Ultriscape Interfaces”.

Ultriscape in DashBoard
The Ultriscape licensed feature provides the following nodes in the DashBoard tree view: 
Configuration, Layout Editor, and Head Selection. (Figure 11) Double-click a node to displays its 
interface in the DashBoard window. 

The Ultriscape tree provides access to the global configuration options, the Ultriscape Layout Editor, 
and the Head Selection interfaces. Use the Ultriscape Layout Editor to manage the layouts and the 
Head Selection to assign sources to the Ultriscape Head outputs. 

Figure 11  Ultriscape Nodes

Terminology
Throughout the DashBoard interface, actual sockets (inputs and outputs) of a router (or matrix) are 
referred to by hierarchical dotted notation: Frame.Slot.Port.Type.Channel where:

• Frame identifies the physical router chassis housing the matrix/matrices.
• Slot identifies which slot in the matrix the socket is located in.
• Port identifies the physical input or output socket.
• Type identifies the generic signal type (e.g. SDI, audio).
• Channel identifies the audio channel within an SDI stream.

These designators may be assigned more user friendly names if required by editing the Port Labels 
interface.

Licenses > Ultriscape Tab
The Device Configuration > Licenses > Ultriscape interface reports on the number of Ultriscape 
licenses installed, and the number of Ultriscape Heads enabled on the Ultrix router. (Figure 12) 
From this tab, you can assign an Ultriscape Head to a physical OUT socket on the router.
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Figure 12  Example of the Device Configuration > Licenses > Ultriscape Tab

 At least one Ultriscape license must be installed for a slot before you can assign an Ultriscape 
Head to a router output in that slot.

The Ultriscape tab is organized into three columns:

• Head — read-only fields that report the physical address name of an Ultriscape output.
• Port — used to enable/assign an Ultriscape Head.
• Format — used to select the an Ultriscape output format.

Configuration Interface
The Configuration interface is the first node listed in the Ultriscape tree. This interface provides 
global layout editor settings that apply to all Ultriscape layouts and heads in the current database. 
(Figure 13) From this interface you can specify the Global PiP settings, tally colors, and tally label 
behavior.

Figure 13  Example of the Configuration Interface
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PiP Layout Tab
Table 11 summarizes the options displayed in the Layout Editor Settings > PiP Layout tab.

Table 11  Layout Editor Settings — PiP Layout Tab

Item Parameters Description
PiP Size Selection

PiP Size A # Specifies the default dimensions of the PiP Size A 
template for all layouts created with the current 
database. The default is 1/4 (480x270).

PiP Size B # Specifies the default dimensions of the PiP Size B 
template for all layouts created with the current 
database. The default is 1/2 (960x540).

PiP Size C # Specifies the default dimensions of the PiP Size C 
template for all layouts created with the current 
database. The default is 1/8 (240x135).

PiP Video Alignment

Video Overlap The PiP border overlaps the video image. The PiP 
Border Width Override fields are set to read-only.

Frame The PiP border frames the video image. The video 
image is modified to fit inside the PiP but not 
overlap the border.

PiP Border Width Override

Border # Sets the border width (in number of pixels) for all 
layouts created with the current database

PiP SD Aspect Ratio

SD is 4:3 270Mbit SD SDI is 4x3 format

16:9 270Mbit SD SDI is of 16x9 format

Audio Meter

Auto Meter 
Standard

-20dBFS Audio meter green to yellow transition equates to 
audio level of -20dBFS

-18dBFS Audio meter green to yellow transition equates to 
audio level of -18dBFS

Cancel Click this button to cancel the settings. No changes 
to the PiP Layout tab will be made.

Apply Click this button to apply the new tab settings.
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Tally Settings Tab
Table 12 summarizes the options displayed in the Layout Editor Settings > Tally Settings tab.

Table 12  Layout Editor Settings — Tally Settings Tab

Item Parameters Description
Tally Lamp Color

Tally #a

a. The function of Tally 0 and Tally 1 is determined by the TSL UMD protocol version as outlined in the Ultrix 
User Guide.

Red When the tally is active (on), the tally object is set to 
red in the Ultriscape layout. By default, Tally 0 is set 
to Red.

Green When the tally is active (on), the tally object is set to 
green in the Ultriscape layout. By default, Tally 1 is 
set to Green.

Tally Label Text Settings

Source Mode overwrite When a PiP is assigned to Src # in the Head Selection 
interface, and the Label Type is set to Tally, the label 
text is determined by the tally label.

append When a PiP is assigned to Src # and the Label Type is 
set to Tally, the label text is src : tally where:
• src — represents the source label defined in the 

Ultrix database.
• tally — represents the text defined by the tally 

label.

Follow Dest Mode overwrite When a PiP is assigned to Follow Dest # in the Head 
Selection interface, and the Label Type is set to Tally, 
the label text is determined by the tally label.

append When a PiP is assigned to Follow Dest # and the Label 
Type is set to Tally, the label text is dest : tally 
where:
• dest — represents the destination label defined in 

the Ultrix database.
• tally — represents the text defined by the tally 

label.

Tally Behavior Settings

When both tallies 
are on:

Red tally only Only the red tally indicator is lit. The green is off.

Both tallies lit Both the red and green tally indicators are lit.
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Label Settings Tab
Table 13 summarizes the options displayed in the Layout Editor Settings > Label Settings tab.

 

Caption Settings Tab
Table 14 summarizes the options displayed in the Layout Editor Settings > Caption Settings tab.

 

Layout Editor Interface
The Layout Editor interface is the second node displayed in the Ultriscape tree. The Ultriscape 
Layout Editor provides a central workspace with menus and options organized into toolbars that 
enable you to customize a layout. The interface also includes three tabs at the top: Layout Editor, 
Shared PiPs, and Clocks.

Table 13  Layout Editor Settings — Label Settings Tab

Item Parameters Description
Label Settings

Dest Follow Label 
Displays

DST:SRC Select this option if the Destination Follow feature is 
enabled in the routing database. The label text 
reports as Destination : Source.

SRC The label text reports the Source name only

Label Background 
Opacity (%)

0 to 100 Adjusts the background transparency level of all 
label boxes in all PiPs of all Ultriscape Heads where:
• 0 — The label background is completely opaque. 

Only the label text is visible.
• 100 — The label background is completely 

transparent; the video in the PiP is visible through 
the label background.

Table 14  Layout Editor Settings — Caption Settings Tab

Item Parameters Description
Caption ANC Logging

Caption Logging 
Mode

Errors Only* The Ultriscape Closed Caption system creates event 
logs which are not user accessible but may be 
required by Ross Technical Support. 

Do not set to All unless instructed by Ross 
Technical Support. 

All

CEA-608 Settings

Extended character 
automatic 
backspace

Selected Enables support for the limited set of CEA-608 
extended characters (including backspaces). 
Select this option if your external devices require 
extended ASCII characters.

Cleared Disables this feature
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Layout Editor Tab
The Layout Editor tab includes a toolbar at the top of the interface, the workspace in the middle, 
rulers along the top and left side of the workspace, and a toolbar for selecting and adding objects to 
the layout. (Figure 14) From the Ultriscape Layout Editor interface you can edit, load and save 
layouts, add objects to a layout, and modify the tiles within a layout.

Figure 14  Example of the Layout Editor with a Loaded Layout

Main Toolbar
The Main toolbar is located under the Layout Editor tab. (Figure 15) The options are organized into 
two areas: a row of menus at the top, and a row of buttons and fields at the bottom. The buttons 
and fields will change depending on what is selected in the workspace.

Figure 15  Layout Editor — Main Toolbar when a PiP is Selected

Table 15 outlines the menus and buttons available from the Main toolbar. 
Table 15  Main Toolbar Menus and Buttons

Name Description
File Provides options for loading templates, publishing layouts to the 

Ultriscape Head interface, opening a previously saved layout, managing 
PiP templates, and saving the changes to the currently loaded layout.

Edit Provides options, such as copy, paste, delete, and select all, for 
managing the objects in the currently loaded layout.

Format Provides global options for distributing the PiPs within a layout.

View Provides options for changing how the loaded layout is currently 
displayed in the Ultriscape Layout Editor. The default is 100%.
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Ultriscape Layout Editor Keyboard Shortcuts
Table 16 outlines the keyboard shortcuts for the Ultriscape Layout Editor. 

Toggle Grid Click to toggle to display or hide the workspace grid. The grid is hidden 
by default.
To change the dimensions of the grid, select Format > Grid and use the 
Configure Grid dialog to specify the grid spacing (in number of pixels). 
You must also select the User Spacing check box to apply the new 
dimension.

UNDO Reverses the last change made to the layout.

REDO Repeats the last change made to the layout.

Layout Name Displays the filename of the layout currently loaded in the Ultriscape 
Layout Editor workspace.

Layout UID Displays the unique identifier of the layout currently loaded in the 
Ultriscape Layout Editor workspace. This is an auto-generated number.

LOAD PiP This button only displays when you select a PiP on the loaded layout. 
Enables you to load and apply a previously saved PiP template.

SAVE PiP This button only displays when you select a PiP on the loaded layout. 
Use it to save the current PiP as a template to be recalled and applied 
to other PiPs.

Border Width This field only displays when you select a PiP on the loaded layout. Use 
this field to specify the border width in number of pixels and lines.

Border Type This field only displays when you select a PiP on the loaded layout. Use 
this field to define the border applied to the selected PiP.

Table 16  Keyboard Shortcuts

Task Keyboard Shortcut
File Menu

New Layout Alt+N

Load from Local Ctrl+Shift+O

Save to Local Ctrl+Shift+L

Delete from Local Ctrl+Shift+D

Load from Ultricore Alt+O

Save to Ultricore Alt+S

Delete from Ultricore Alt+D

Load Layout Template from Ultricore Alt+T

Load PiP from Ultricore Shift+O

Save PiP to Ultricore Shift+S

Delete PiP from Ultricore Ctrl+D

Upload Background Image Ctrl+Shift+U

Table 15  Main Toolbar Menus and Buttons (Continued)

Name Description
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Objects Toolbar
The Objects toolbar is located on the left side of the interface and provides tools for adding and 
editing the objects in a loaded layout. Objects are elements that you can place, re-size, and 
re-position as required within the layout. 

Table 17 outlines the menus available from the Objects toolbar. Refer to “Managing the Objects in 
a Layout” for more details. 

Edit Menu

Undo Ctrl+Z

Redo Ctrl+Shift+Z

Copy Ctrl+C

Paste Ctrl+V

Clear All Ctrl+Shift+C

Delete Del

Select All Ctrl+A

Refresh F5

View Menu

Zoom 100% Ctrl+0

Zoom 50% Ctrl+5

Zoom 25% Ctrl+2

Table 17  Objects Toolbar Icons

Name Description
SELECT This pointer tool enables you to select objects and PiPs in the loaded 

layout. When selecting a PiP, the overlay settings are displayed in the 
Main toolbar. Select more than one PiP to make global overlay changes 
to the layout.

PIP A Enables you to add a new pre-defined PiP A to the layout. Specify the 
settings for PiP A in the Layout Editor > Configuration tab.

PIP B Enables you to add a new pre-defined PiP B to the layout. Specify the 
settings for PiP B in the Layout Editor > Configuration tab.

PIP C Enables you to add a new pre-defined PiP C to the layout. Specify the 
settings for PiP C in the Layout Editor > Configuration tab. A Warning 
label is automatically added to the PiP (label cannot be deleted, but can 
be re-positioned).
Supported only on the ULTRIX-HDX-IO and ULTRIX-MODX-IO blades.

PIP X Enables you to add a new pre-defined PiP X to the layout. Specify the 
settings using the PiP Size X menu located in the Bottom toolbar.

UMD Enables you to add a new label box on the loaded layout.

METER Enables you to add a new set of audio meters on the loaded layout.

TALLY Enables you to add tally lamps to the selected PiP. Refer to the Ultrix 
User Guide for details.

Table 16  Keyboard Shortcuts (Continued)

Task Keyboard Shortcut
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Bottom Toolbar
The Bottom toolbar of the interface enables you to customize the overall look of the currently 
loaded layout.(Figure 16)

Figure 16  Layout Editor — Bottom Toolbar Example

Table 18 outlines the menus available from the Bottom toolbar. 

CLOCK Enables you to add a clock to the layout. Specify the settings for the 
clock in the Layout Editor > Clocks tab.

CC Enables you to add a Closed Caption display object to a PiP. Refer to 
“Displaying Closed Caption Data”. 

CLIPDATA When the Ultriscape-CA license is enabled, you can add a Clip metadata 
display object to a PiP. Refer to “Configuring an Ultriscape Head to 
Display Metadata”.

ALARMING Enables you to add an alarms display object to the layout. Refer to 
“Adding an Alarm Display Object to a Layout”

Table 18  Bottom Toolbar Menus

Name Description
PiP Size A Specifies the dimensions for Local PiP A. This applies to the current layout using 

PiP A created/edited during this session.

PiP Size B Specifies the dimensions for Local PiP B. This applies to the current layout using 
PiP B created/edited during this session.

PiP Size C Specifies the dimensions for Local PiP C. This applies to the current layout using 
PiP C created/edited during this session.
Supported only on the ULTRIX-HDX-IO and ULTRIX-MODX-IO blades.

PiP Size X Specifies the dimensions for Local PiP X. This applies to the current layout using 
the PiP X applied during this session. Note that each layout can only include a 
maximum of one PiP X tile.

Background Specifies the background the entire layout (solid color or a loaded still image). 
The default is Solid Color.

Background Color Specifies the layout background color when Background is set to Solid Color. 
The default is black.

PiP Fill Specifies the background of the PiPs in the layout. Choose from a Solid Color or 
75% Color Bars.

PiP Fill Color If you set the PiP Simulation to Solid Color, this menu enables you to specify the 
color for the PiP backgrounds in the Layout Editor and Ultriscape Head 
interfaces

Point X Indicates the horizontal position of your cursor on the Layout Editor workspace

Point Y Indicates the vertical position of your cursor on the Layout Editor workspace

Table 17  Objects Toolbar Icons (Continued)

Name Description
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Shared PiPs Tab
The Shared PiPs tab lists the configured PiPs to be shared by various layouts in this database. 
(Figure 17) From this tab you can assign the operation mode, the video source, the audio mode, 
and specify the audio bar numbering scheme.

Figure 17  Example of the Shared PiPs Tab

Table 19 summarizes the options displayed in the Layout Editor Settings > Shared PiPs tab.

Table 19  Layout Editor — Shared PiPs Tab

Item Parameters Description
ID (read-only) # The unique identifier for the Shared PiP

Mode Normal The PiP does not monitor a specific resource; the 
Source is automatically set to Normal

Follow The PiP monitors a specific destination (as specified 
in the Source column of this tab)

Source The PiP monitors a specific source (as specified in 
the Source column of this tab)

Source # Specifies the resource the PiP will monitor when 
Mode is set to Follow or Source

Audio Mode Logical The PiP audio signals use the source/destination 
logical mapping.

Physical The PiP audio signals map to the physical IN 
connection on the rear panel. Use the Audio Bars 
field to specify which channels to included in the 
PiP Ultriscape Head output

Audio Bars # Specifies up to 16 audio channel(s) the PiP will 
monitor; separate each channel with a comma (e.g. 
1,2,3,4)
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Clocks Tab
Table 20 summarizes the options displayed in the Layout Editor Settings > Clocks tab.

Head Selection Interface
The Head Selection interface is displayed by selecting the third node listed in the Ultriscape tree. 
The interface displays a tab for each Ultriscape Head. (Figure 18) From the Head Selection interface 
you can recall a layout and assign it to an Ultriscape Head, assign matrix sources to each PiP of a 
layout (any router source can be assigned to a head), assign a layout to an Ultriscape Head, and 
display it in the head output.

 You must have at least one Ultriscape license key enabled to use the Head Selection interface.

Figure 18  Example of the Head Selection Interface

For More Information on...
• the Head Selection interface, refer to “Assigning a Layout to an Ultriscape Head”.

Table 20  Layout Editor — Clocks Tab

Item Parameters Description
ID (read-only) # The numerical identifier for the clock

Name <text> Assigns a unique identifier for the clock

Type timeofday The clock reports the time of day as determined by 
the NTP Server it is using

stopwatch The clock functions as a free running timer that 
counts up from 00:00. The count will reset after a 
maximum of 23:59:59.

countdown The clock counts down from a value specified by 
the user

TZ Offset +/-HH:MM Specifies an offset to the reported time zone value

Time Value HH:MM:SS Specifies the value the clock counts down from 
(when Type is set to countdown)
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Clock Control Interface
The Clock Control interface is displayed by selecting the fourth node listed in the Ultriscape tree. 
The interface is organized into two distinct areas: a table that lists the configured clocks in the 
database and a toolbar with function buttons. (Figure 19)

Figure 19  Example of the Clock Control Interface

Configured Clocks Area

The table lists, in numeric order based on the ID automatically assigned to each clock, the clocks 
that are configured for the current database.

Clock Buttons

Some buttons are only available on count down timers and stopwatch clock elements.

Alarming Configuration
Use the options in the Alarming Configuration interface to specify what messages the layout will 
report. 

Alarming Config
The options are organized into two sub-tabs: Video and Audio.

Video Alarms

Table 21 summarizes the options displayed in the Alarming Config > Video Alarms sub-tab. Each 
row in the sub-tab represents a specific input port.

Table 21  Alarming Config — Video Alarms Tab

Item Parameters Description
Video Black Selected Triggers an alarm when the video signal is set to 

black

Cleared An alarm is not reported for this condition
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Audio Alarms

Table 22 summarizes the options displayed in the Alarming Config > Audio Alarms sub-tab.

Video Black 
Hysteresis

# Specifies the number of seconds the video is set to 
black before an error is reported

Video Freeze Selected Triggers an alarm when there is an extended 
amount of time with no active picture changes

Cleared An alarm is not reported for this condition

Video Freeze 
Hysteresis (ms)

# Specifies the number of milliseconds the signal is 
set to a single frame of video before an error is 
reported

Video LOS Selected Triggers an alarm when a valid SDI signal is no 
longer detected

Cleared An alarm is not reported for this condition

Video LOS 
Hysteresis (ms)

# Specifies the number of milliseconds a valid SDI 
signal is absent before an error is reported

Video Format Selected Triggers an alarm when the input video format 
does not match the user's selected format

Cleared An alarm is not reported for this condition

Video Format 
Hysteresis (ms)

# Specifies the number of milliseconds the signal is 
incompatible before an error is reported

Caption Format 
(read-only)

# Reports the closed caption data of a signal

Caption Format 
Hysteresis (ms)

# Specifies the number of milliseconds the closed 
captioning data is lost before an error is reported

Table 22  Alarming Config — Audio Alarms Tab

Item Parameters Description
Audio Silence 
Threshold (ms) 

# Specifies the maximum number of milliseconds any 
audio channels are silent before an alarm is 
triggered

Audio LOS Selected Triggers an alarm when there is invalid audio signal

Cleared An alarm is not reported for this condition

Audio LOS 
Hysteresis (ms) 

# Specifies the number of milliseconds a valid audio 
signal is absent before an error is reported

Audio Silence Selected Triggers an alarm when the audio signal is muted or 
silent for a specific channel

Cleared An alarm is not reported for this condition

Audio Silence 
Hysteresis (ms)

# Specifies the number of milliseconds the audio 
signal is muted/silent before an error is reported

Table 21  Alarming Config — Video Alarms Tab (Continued)

Item Parameters Description
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