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Thank You for Choosing Ross
You've made a great choice. We expect you will be very happy with your purchase of Ross Technology. 
Our mission is to:

1. Provide a Superior Customer Experience

• offer the best product quality and support

2. Make Cool Practical Technology

• develop great products that customers love
Ross has become well known for the Ross Video Code of Ethics. It guides our interactions and empowers 
our employees. I hope you enjoy reading it below.
If anything at all with your Ross experience does not live up to your expectations be sure to reach out to 
us at solutions@rossvideo.com.

David Ross
CEO, Ross Video
dross@rossvideo.com

Ross Video Code of Ethics
Any company is the sum total of the people that make things happen. At Ross, our employees are a 
special group. Our employees truly care about doing a great job and delivering a high quality customer 
experience every day. This code of ethics hangs on the wall of all Ross Video locations to guide our 
behavior:

1. We will always act in our customers’ best interest.

2. We will do our best to understand our customers’ requirements.

3. We will not ship crap.

4. We will be great to work with.

5. We will do something extra for our customers, as an apology, when something big goes 
wrong and it's our fault.

6. We will keep our promises.

7. We will treat the competition with respect.

8. We will cooperate with and help other friendly companies.

9. We will go above and beyond in times of crisis. If there's no one to authorize the required 
action in times of company or customer crisis - do what you know in your heart is right. (You may 
rent helicopters if necessary.)
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Canon Camera Paint Control Setup Guide
• Ross Part Number: 8351DR-020-9.9
• Publication Date: April 12, 2024. Printed in Canada.
• Software Issue: 9.9
The information contained in this Guide is subject to change without notice or obligation.

Copyright
© 2024 Ross Video Limited. Ross® and any related marks are trademarks or registered trademarks of 
Ross Video Limited. All other trademarks are the property of their respective companies. PATENTS 
ISSUED and PENDING. All rights reserved. No part of this publication may be reproduced, stored in a 
retrieval system, or transmitted in any form or by any means, mechanical, photocopying, recording, or 
otherwise, without the prior written permission of Ross Video. While every precaution has been taken in 
the preparation of this document, Ross Video assumes no responsibility for errors or omissions. Neither 
is any liability assumed for damages resulting from the use of the information contained herein.

Patents
Ross Video products are protected by patent numbers US 7,034,886; US 7,508,455; US 7,602,446; US 
7,802,802 B2; US 7,834,886; US 7,914,332; US 8,307,284; US 8,407,374 B2; US 8,499,019 B2; US 8,519,949 
B2; US 8,743,292 B2; GB 2,419,119 B; GB 2,447,380 B. Other patents pending.

Environmental Information
The equipment that you purchased required the extraction and use of natural resources for its 
production. It may contain hazardous substances that could impact health and the environment.
To avoid the potential release of those substances into the environment and to diminish the need for the 
extraction of natural resources, Ross Video encourages you to use the appropriate take-back systems. 
These systems will reuse or recycle most of the materials from your end-of-life equipment in an 
environmentally friendly and health conscious manner.
The crossed-out wheeled bin symbol invites you to use these systems.

If you need more information on the collection, reuse, and recycling systems, please contact your local or 
regional waste administration.
You can also contact Ross Video for more information on the environmental performances of our 
products.
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Company Address and Contact Information

Ross Video Limited 

8 John Street
Iroquois, Ontario
Canada, K0E 1K0

Ross Video Incorporated 

P.O. Box 880
Ogdensburg, New York
USA 13669-0880

General Business Office: (+1) 613  652  4886 

Fax: (+1) 613  652  4425 

Toll Free Technical Support: 1-844-652-0645 (North 
America)

+800 1005 0100 (International)

Technical Support: (+1) 613  652  4886 

E-mail for Technical Support: techsupport@rossvideo.com

ROSS VIDEO | HELP CENTER: https://support.rossvideo.com/h
c/en-us

E-mail for General Information: solutions@rossvideo.com

Ross Video Website: http://www.rossvideo.com

mailto:techsupport@rossvideo.com
mailto:solutions@rossvideo.com
http://www.rossvideo.com
https://support.rossvideo.com/hc/en-us
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Welcome
This is the Setup Guide for Ross Video’s Canon Camera Paint Control.

Canon Camera Paint Control enables you to adjust lens iris, focus mode, camera paint settings, and all 
camera menu settings for the Canon EOS C500 Mark II camera.

Canon Camera Paint Control can be set up as a standalone camera control system, or be integrated with 
a Ross Robotics robotic camera system.

This Setup Guide describes how to install and configure Canon Camera Paint Control as a standalone 
camera control system.

Tip: If you set up a standalone system, and later purchase Ross Robotics, you can reconfigure the Canon 
Camera Paint Control to integrate it with your Robotics system.

For information about how to use Canon Camera Paint Control, see the Canon Camera Paint Control 
User Guide (8351DR-021-xx).

Documentation Conventions

Text Format Conventions
Special text formats are used in this Setup Guide to identify parts of the user interface, text that a user 
must enter, or a sequence of menus and submenus that must be followed to reach a particular 
command.

Text Format Meaning

Bold text Bold text is used to identify a user interface element such as 
a dialog box, menu item, or button.

For example:

In the Display Name box, enter a name for the node.

Courier text Courier text is used to identify text that a user must enter.

For example:

In the address bar, enter localhost and press Enter.

Italic text Italic text is used to identify the titles of referenced guides, 
manuals, or documents.

For example:

For more information, see the Canon Camera Control 
System User Guide (8351DR-021-xx).

> Menu arrows are used in procedures to identify a sequence 
of menu items that you must follow. 

For example, if a step reads “File > New,” you would select 
the File menu and then select New.
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User Interface Conventions
You can interact with Canon Camera Paint Control using a touch screen and/or a keyboard and mouse. 
The instructions in this Setup Guide describe how to interact with the Camera Control Panel using a 
touch screen. The following table provides equivalent actions for using a keyboard and mouse.

Contacting Technical Support

At Ross Video, we take pride in the quality of our products, but if problems occur, help is as close as the 
nearest telephone.

Our 24-hour Hot Line service ensures you have access to technical expertise around the clock. After-sales 
service and technical support is provided directly by Ross Video personnel.

During business hours (Eastern time), technical support personnel are available by telephone any time. 
Emergency after hours calls are answered by an answering service (live person) who will patch your call 
to the on-call support specialist. In the event that the on-call person is assisting another customer, the 
answering service will contact the back-up support specialist. 

Our team of highly trained staff is available to react to any problem and to do whatever is necessary to 
ensure customer satisfaction.

• Toll Free Technical Support 24/7: 1-844-652-0645 (North America), or +800 1005 0100 (International)
• Technical Support: (+1) 613-652-4886
• E-mail for Technical Support: techsupport@rossvideo.com 
• ROSS VIDEO | HELP CENTER: https://support.rossvideo.com/hc/en-us 
• E-mail for General Information: solutions@rossvideo.com 
• Ross Video Website: http://www.rossvideo.com

Instruction Touch Screen Keyboard and Mouse

select Select the object briefly. Click the object.

Click refers to pressing the left 
mouse button briefly.

Right-click refers to pressing 
the right mouse button briefly.

touch and hold Touch the object and hold your 
finger on it until a circle 
appears, and then release it.

Right-click and hold your finger 
on the mouse button until the 
expected action occurs.

drag Touch the object, hold your 
finger on it, and drag your 
finger on the screen to move 
the object.

Click and drag the object.

mailto:techsupport@rossvideo.com
https://support.rossvideo.com/hc/en-us
mailto:solutions@rossvideo.com
http://www.rossvideo.com
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System Overview and Planning
This section provides information about the Canon Camera Paint Control that can help you plan your 
installation. It contains the following topics:
• “System Overview” on page 8
• “Planning the Workstation Components” on page 8
• “Planning the Studio and Network Components” on page 9
• “Hardware and Software Checklist” on page 10

System Overview

Canon Camera Paint Control enables you to remotely adjust lens iris, focus mode, shutter, filters, camera 
paint settings, and various menu settings for supported the Canon EOS C500 Mark II camera. It can be 
set up as a standalone camera control system, or integrated with a Ross Robotics robotic camera system.

This Setup Guide describes how to install and configure Canon Camera Paint Control as a standalone 
camera control system.

This section lists the components of the system.

Workstation Components
Canon Camera Paint Control includes one or more camera control workstations. Each workstation can 
control all cameras. Each workstation consists of the following:
• A Camera Control Computer that serves as a workstation supporting DashBoard. 
• A Camera Video Monitor. 
• A Camera Paint Box (Optional). The Camera Paint Box features physical knobs for adjusting iris and 

paint controls (gains and pedestals). These settings can also be controlled through the Camera Control 
Panel.

For more detailed information about the workstation components, see “Planning the Workstation 
Components” on page 8. 

Planning the Workstation Components

This section describes the components of a camera control workstation, to help you plan your 
installation.

The main topics in this section are as follows:
• “Camera Control Workstation and Accessories” on page 8
• “Video Monitor” on page 9
• “Camera Paint Box (optional)” on page 9

Camera Control Workstation and Accessories
You need one Camera Control Computer running DashBoard at each camera control workstation. 
DashBoard is free, but Canon Camera Paint Control is a licensed application. You require one license for 
each camera control workstation.

You can purchase your Camera Control Computer(s) from Ross Video. Alternatively, you can use any 
computer that meets the Windows or Mac OS system requirements for installing DashBoard. To view the 
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DashBoard system requirements, download the Dashboard User Guide (8351DR-004-xx) at: 
https://www.rossvideo.com/support/software-downloads/dashboard 

Video Monitor
The camera video monitor can display video from the camera being controlled, so you can see on-screen 
menus and monitor the effect of adjustments as you make them. The camera video monitor is a carefully 
calibrated reference monitor. Sometimes two monitors are used, to compare video output of two 
cameras side-by-side. Video routing equipment is required to direct the desired video feed to the 
monitor(s).

Note: Camera video monitors and routing equipment operate independent of the Camera Control 
System. The Camera Control Panel application and Camera Paint Box do not select video to be displayed 
on camera video monitors.

Camera video monitors, video routing equipment, and waveforms/vectorscopes are not included as part 
of Canon Camera Paint Control.

Camera Paint Box (optional)
The Camera Paint Box is an optional accessory that features physical knobs for adjusting iris and paint 
controls (gains and pedestals). These settings can also be controlled through the Camera Control Panel.

Each camera control workstation may or may not include a Camera Paint Box.

The Camera Paint Box is connected to the camera control computer by a USB cable. The Camera Paint 
Box is designed to occupy 1RU in a standard 19” component rack. 

Planning the Studio and Network Components

This section describes the studio and network components of a camera control workstation, to help you 
plan your installation.

The main topics in this section are as follows:
• “Cameras” on page 9
• “Proxy Server Computer” on page 9
• “Network Configuration” on page 10

Cameras
The only Canon camera supported by Ross Video’s Canon Camera Paint Control is the EOS C500 Mark II.

Proxy Server Computer
If your system includes multiple camera control workstations, the camera control computers are set up 
with a client-server topology that allows you to configure the connection to the camera once, then access 
it from multiple locations.

Note: Setting up a proxy server is optional and depends on the needs of your deployment.

On the proxy server, DashBoard is configured to be the 'proxy server' instance. On each camera control 
computer, DashBoard is configured to be a client of the proxy server instance. All camera control 
requests from camera control computers are handled by the proxy server.

For more information on proxy servers, refer to the DashBoard User Guide 
https://www.rossvideo.com/support/software-downloads/dashboard

https://www.rossvideo.com/support/software-downloads/dashboard/
https://www.rossvideo.com/support/software-downloads/dashboard/
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Network Configuration
Components of Canon Camera Paint Control communicate over an Ethernet or wireless network. You 
can use a dedicated network switch, or an existing network.

The following components require Ethernet network connections:
• Each Camera Control Computer
• The proxy server (only required for systems that have multiple camera control workstations)

Note: Ethernet cables between components are not included.

Hardware and Software Checklist

The tables in this section list everything you need to purchase for your system, and can serve as a 
checklist for setting up your workstation.

Table 1 -  Camera Control Workstation Equipment and Software

Quantity Item Source Notes / Requirements

Computer Workstation

Must include monitor, 
keyboard, and mouse.

Ross Video

Other

One computer per workstation.

Ross Video sells an all-in-one computer for this 
purpose.

Computers must meet Windows system 
requirements for DashBoard installation.

Computers require power supply outlets.

Canon camera control 
license

Ross Video One license per camera control workstation.

Camera Paint Box Ross Video Maximum one per workstation. Optional accessory.

The Camera Paint Box requires a power supply 
outlet.

Video monitor and 
waveform/vectorscope

Other Minimum one per workstation.

Can have multiple monitors for side-by-side 
comparison of camera outputs.

May also require waveform/vectorscope for 
fine-tuning camera output.

Monitors and waveform/vectorscopes require power 
supply outlets.

Routing and switching 
equipment for camera 
video monitor(s)

Must include video 
cabling between 
cameras and router, and 
between router and 
monitor(s).

Ross Video

Other

Independent of DashBoard.

Typically, an existing video router is used.

Ross Video can provide video routing solutions.

Routing equipment requires power supply outlets.
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Table 2 - Studio and Network Equipment

Quantity Item

Source

(Ross or Other) Notes

Canon EOS C500 Mark 
II

Other Each camera requires a power supply outlet.

Proxy server for camera 
control [optional]

Ross Video

Other

Optional if you wish to set up multiple camera 
control workstations in a client-server 
configuration with only one connection to the 
camera.

Ross Video sells servers for this purpose

Server must meet Windows and Mac system 
requirements for DashBoard installation.

Server requires a power supply outlet.

Canon camera control 
license for proxy server 
computer [optional]

Ross Video License fees are based on the number of 
camera control workstations in your system.

Note: This is only required if you want to view 
the UI for camera control from your proxy 
server computer.

Ethernet network cables Other The following require network connections:

• Each Camera Control Computer
• Proxy server (if equipped)
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Installing and Configuring the 
System
This section describes how to install and configure a standalone Canon Camera Paint Control system for 
the EOS C500 Mark II camera.

Before you install the system, you need to plan the installation. For more information, see “System 
Overview and Planning” on page 8.

The contents of this chapter include:
• “Upgrade Canon Camera Firmware” on page 12
• “Install DashBoard Software” on page 12
• “Set Up the Camera Control Computer(s)” on page 13
• “Set Up the Canon Camera” on page 13
• “Configure the Camera’s Network Connection” on page 13
• “Configure the Camera’s On-Screen Display” on page 14
• “Configure the Camera Picture Settings” on page 14
• “Configure Workstation” on page 15
• “Install Camera Paint Boxes” on page 20
• “Configure the Camera Paint Box Connection” on page 20

Upgrade Canon Camera Firmware

If the camera has an older version of firmware installed, you must upgrade it. Canon Camera Paint 
Control must connect with an EOS C500 Mark II camera running firmware version 1.0.6.1 or newer.

To install the latest Canon EOS C500 Mark II firmware:

1. Go to the downloadable drivers available through Canon support.
2. Download the latest driver for your camera and follow Canon’s installation instructions.

Install DashBoard Software

Install the latest version of DashBoard (v9.9 or higher) available at: 
https://www.rossvideo.com/support/software-downloads/dashboard

DashBoard and the DashBoard User Guide are available as free downloads from Ross Video. The 
DashBoard User Guide contains instructions for installing DashBoard, and is available at: 
https://www.rossvideo.com/support/product-documentation/dashboard

https://www.rossvideo.com/support/software-downloads/dashboard
https://www.rossvideo.com/support/software-downloads/dashboard
https://www.rossvideo.com/support/product-documentation/dashboard/
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Set Up the Camera Control Computer(s)

Each workstation includes one camera control computer. This section describes how to install a camera 
control computer provided by Ross Video. If your computer is not provided by Ross Video, these steps 
may vary.

To install a Camera Control Computer and Peripherals:

1. Connect the camera control computer to the monitor, keyboard, and mouse for your workstation.
Tip: Ensure that the monitor is visible to the operator, and that the optical drive, accessory ports, and 
buttons on the right and left edges of the computer are accessible.

2. Ensure the computer is connected to your local wireless or Ethernet network. 
3. Configure the networking parameters (IP address, subnet mask, and gateway).

Set Up the Canon Camera

This section describes how to perform an initial set up of the Canon camera in order to control Iris and 
Focus features from the DashBoard panel. 

To enable automatic iris and automatic focus:

1. Position and mount the camera.
2. On the camera lens, find the IRIS switch and set it to the Automatic (A) position.
3. On the camera lens, find the FOCUS switch and set it to the Automatic Focus (AF) position.

Configure the Camera’s Network Connection

The Canon Camera Paint Control requires wired camera connection following firmware upgrades and XC 
protocol to communicate with DashBoard.

To set the camera to XC protocol:

1. Open the On-Screen Menu in the Canon camera.
2. Select the Network Settings tab > Submenu Item 1 > New Conn. Setting > XC Protocol.

To establish the camera’s network connection:

1. Open the On-Screen Menu in the Canon camera.
2. Select the Network Settings tab > Submenu Item 1 > New Conn. Setting > Ethernet > Setup with 

Network Conn. > Automatic > Disable.
3. Enter the network credentials into the device. 

Note: Add the IPv6 network information if necessary.
4. Select Create New Conn. Setting > Digest Authentication > Set Username/Password.
5. Enter the username and password.

Note: Keep a record of these login credentials for future use. 
6. Select Choose a Conn.Setting Save Destination > Done. 
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Configure the Camera’s On-Screen Display

The following section enables you to use the camera’s On-Screen Display (OSD) modify the video output 
so that it’s compatible with your monitor. 

Note: In order to see on-screen display, the camera video output needs to be connected to the monitor.

To set the on-screen display monitor output:

1. Open the On-Screen Menu in the Canon camera.
2. Select Monitoring Setup > Submenu Item 7 > OSD Output: MON./HDMI > On.
3. Connect the output of the camera to a monitor using Mon Out. 

To change the video format:

Tip: If the video output is not visible, the following instructions 

1. Open the On-Screen Menu in the Canon camera.
2. Select the Recording/Media Setup tab > Submenu Item 2 > Resolution/Color Sampling.
3. Select the desired video format.

The Canon Camera Paint Control system can now access the On-Screen Display.

Configure the Camera Picture Settings

This section describes how to configure Canon EOS C500 Mark II picture settings optimally for your 
workstation. These configurations ensure the best quality performance for your video and are required 
for Canon Paint Control to work correctly. 

To set up the lens:

Note: For various lenses, you may see the outline of the lens on the edge of the video output. 
Use the following instructions to resolve this issue.

1. Open the On-Screen Menu in the Canon camera.
2. Select Recording/Media Setup tab > Submenu Item 1 > Sensor Mode > Super 35mm (Cropped).

To set up the pedestal or gain values:

If you cannot change the pedestal or gain values on the camera using the panel, you must Unprotect the 
Custom Picture (CP) file that is in use on the camera. When CP is protected, changes to the color or 
black gains are restricted.

1. Open the On-Screen Menu in the Canon camera.
2. Select the CP (Custom Picture) tab > Select CP File.

Note: If the file has a Key symbol next to it, it is protected, and changes cannot be made to color 
settings. 

3. Choose the desired CP File from the drop-down menu provided. 
4. Select Edit CP File then change Protect setting to Unprotect.

You can now make changes to Pedestal and Gain values on the camera. 
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To enable smooth gain adjustment:

1. Open the On-Screen Menu.
2. Select the Camera Setup tab > Submenu Item 2.
3. Set Gain Increment to Fine.

To use Kelvin scale values for White Balance color temperature:

1. Open the On-Screen Menu.
2. Select the Camera Setup tab > Submenu Item 3.
3. Set C. Temp. Increment to Kelvin.

Note: Canon Camera Paint Control only supports Kelvin scale values for White Balance color 
temperature.

Configure Workstation

This section describes how to configure DashBoard for a single computer that connects directly to 
cameras.

If you want to have additional workstations, set up a DashBoard proxy server. Follow the steps in this 
section for the proxy server computer only, and then configure the other workstations to access the 
cameras through the DashBoard proxy server. For more information about how to configure a DashBoard 
proxy server, see the DashBoard User Guide (8351DR-004-xx).
Note: To perform the steps in this section, you need to have good working knowledge of basic computer 
networking procedures.

 

To add a camera:

Add each camera as a device in DashBoard.

If you are using one or more third-party cameras, such as Sony BRC cameras or Panasonic PTZ cameras, 
you will require a license key code from Ross Video. Because the key code is a response to a prompt that 
appears while you are adding the first camera, the key code cannot be obtained in advance. Be prepared 
to contact Ross Video Technical Support when you add the first camera. 

Note: PTZ-12G and PTZ-NDI cameras, PIVOTCam-SE cameras, Sony PTZ cameras, Canon PTZ cameras, 
and Lumens  PTZ cameras communicate with DashBoard via UDP through port 52381 on the DashBoard 
computer. If you are using these types of cameras, ensure that port 52381 is accessible and is not 
blocked by a firewall application.

To add a camera:

1. Open DashBoard.
2. Select the + button from the Basic Tree View.

 
Tip: You can alternatively select File > New > Other.

3. Expand Cameras, select Canon Cinema Camera, and then select Next.
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The Canon Cinema Camera dialog box appears.

4. In the IP Address field, enter the IP address of the camera you want to add.
5. Enter the Port number for the camera you want to add.
6. Enter a desired Display Name, ensuring it’s unique from other display names already in use.
7. In the Slot box, specify a slot number for the camera. Valid slot numbers start at 1.

Note: Assigning a slot number is optional. If left blank, DashBoard assigns the lowest available slot 
number by default. 
Tip: In the Camera Control Panel, the order of camera selection buttons is determined by slot 
number, starting with the lowest number at the top.

8. If the camera fails to appear in the DashBoard tree, or appears with a red dot, do the following:

a. Ensure that power is connected to the camera, and that the cameras is turned ON.

b. Check the IP address you typed in Step 4 and ensure that it matches the IP address of the 
camera.

c. Ensure that no other application on the computer is already connected to, or trying to connect to, 
the camera (for example, another instance of DashBoard).

Tip: If an instance of DashBoard is already connected to the camera, the following error message 
may appear:

Error - unable to bind to UDP port for camera

9. Integrating a third-party camera with DashBoard necessitates license activation. DashBoard 
supports two licensing options: Software-Based Licensing and Ross Key Based Licensing.

Software-based licensing involves connection of DashBoard to the Ross activation server either 
directly or via a Ross Product Manager licensing server on prem. To use software-based licensing, 
you will need a product key provided by Ross.

Ross Key Based Licensing is a fixed license tied to your hardware.  During the licensing process you 
will need to send a key code to Ross technical support who will return a license key for you to enter 
into DashBoard.

For more information, refer to the DashBoard User Guide 8351DR-004-XX.

Note: Product key packs do not require a hardware request code but does require an RPM sever or 
access to the Activation server.
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For activating DashBoard licensed features, refer to the following procedures:

To update DashBoard licensed features (Software Based Licensing method)

a. From the main toolbar, select Window > Preferences. Refer to Figure 1.

Figure 1 - DashBoard Licensed Features - Software Based Licensing tab

b. The Preferences dialog box opens.

c. From the Preferences dialog box, select Licensed Features.

d. In the Licensed Features dialog box, ensure the Software Based License tab is selected.

e. Select the Server type that you are using to provide licensing.

f. If you are using the Ross Platform Manager server type, enter the Host Name and Port of the 
server and whether to Use HTTPS connection. 
Note: Select Apply to save your server settings.
Note: Use the Test Connection button to confirm a successful connection if necessary.

g. Once connection to the server is established, select Add and enter the product key provided to 
you.
If successful, the feature you added will appear in the Licensed Features table.
Note: Select Apply to confirm your changes.
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To update DashBoard licensed features (Ross Keys Based Licensing method)
For obtaining and entering a Ross licensing key code, complete the following:

a. From the main toolbar, select Window > Preferences. Refer to Figure 2.

Figure 2 - DashBoard Licensed Features - Ross Key Based Licensing tab

b. The Preferences dialog box opens.

c. From the Preferences dialog box, select Licensed Features.

d. In the Licensed Features dialog box, ensure the Ross Key Based License tab is selected.

e. From either the Active or Available subfolder, select the feature you want to update.

f. To obtain a Ross License Key by completing the following:

i.    Click Install/Update License.
ii.   The Enter License Key dialog box opens. Refer to Figure 3.

Figure 3 - DashBoard Licensed Features - Enter License Key

iii.    Select Copy to Clipboard to copy your request code.

iv.   Paste the request code into an e-mail to Ross Video (techsupport@rossvideo.com), 
requesting a corresponding license key. Be sure to include the original Ross Video sales order 
number. 
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CAUTION: Do not close the Enter License Key dialog box until you receive and apply an 
activation code from Ross Video. If you leave the Enter License Key dialog box, the activation 
code you receive will not work. It is valid only for the session during which it was generated.
v.     When you receive the license key via email, copy and paste it into the License Key box, and 
then tap Install.
vi.   The selected feature updates and the most current data is displayed in the License Details.

10. If the camera is ceiling-mounted (inverted), we recommend you turn On the Image Flip and 
Image Mirror options (also known as Ceiling Mount for some cameras) before you create any 
presets. Changing these settings after presets exist renders the presets useless.
The Image Flip and Image Mirror options are available in the PTZ Camera Control plugin at Config > 
Camera > Camera Options.

To view camera controls:

1. In the DashBoard Component Tree, expand the Canon Cameras node.
2. Expand the Slot node for the camera you just added.
3. Double-tap Remote Control.

To enter a license key:

1. In the Enter License Key interface, select Copy to Clipboard.
The request code is copied to the clipboard.

2. Paste the request code into an e-mail to Ross Video (techsupport@rossvideo.com), requesting a 
corresponding license key. Be sure to include the original Ross Video sales order number.
Note: If you leave the Enter License Key page, the license key you receive from Ross Video will not 
work. It is valid only for the session during which it was generated.

3. When you receive the license key, copy it into the License Key field and select Install.
The License Installed message appears. Select OK.

4. Restart DashBoard. 

Note: If you are setting up a proxy server, right-click on each node and share. You can configure other 
camera control computers by setting up DashBoard to point to the IP address and port of the proxy 
server on your proxy server computer. Refer to the DashBoard User Guide (8351DR-004-xx) for more 
information.

To link/unlink camera selection between Canon Camera Paint Control and other control interfaces:

1. Open the DashBoard Component Tree, navigate to DashBoard Services, and then double-tap 
Selector UI Mappings.
The Selection Mapping interface appears.
You can use the UI Follows Selection buttons (OFF / ON) to control whether selecting a camera in 
one interface selects it in all interfaces.

mailto:techsupport@rossvideo.com
mailto:techsupport@rossvideo.com
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2. Do one of the following:
• To turn Selection Follow ON, select the ON button.

If you select a camera in one interface, it becomes selected in all others. For example, if you select 
a camera on a joystick panel, it is also selected in SmartShell and in the Camera Control Panel.
Note: SmartShell must be configured for Selection Follow. For more information, contact Ross 
Video Technical Support.

• To turn Selection Follow OFF, select the OFF button.
Camera selection in the Camera Control Panel is independent of camera selection in other 
interfaces.

Install Camera Paint Boxes

The Camera Paint Box is an optional accessory that enables physical control of paint settings. Each work 
station may or may not include a Camera Paint Box.

To install a Camera Paint Box:

1. Position the Camera Paint Box in the camera control workstation location.
Ensure that the Camera Paint Box is within easy reach of the operator.
The Camera Paint Box can sit on a flat surface, or occupy 1RU in a standard 19” component rack.

2. Plug one end of the provided USB cable into the Camera Paint Box. Plug the other end into a USB 
connector on the back of the camera control computer.

3. Plug the power cable into the Camera Paint Box, and into a suitable power outlet.
On the front of the Camera Paint Box, a green LED indicates that the unit is powered.

Configure the Camera Paint Box Connection

Each camera paint box is connected to a camera control computer via a USB cable. 

DashBoard communicates with the Camera Paint Box through a service called the bridge server. To 
establish communication with the Camera Paint Box, you must:

1. Install the bridge server software.
2. Add and configure a DashBoard gateway for the Camera Paint Box.

Note: The Green Pedestal and Green Gain have no effect on the Canon camera. 

To install the bridge server software:

1. Obtain the Bridge Server software zip file from Ross Video, and save it on the camera control 
computer.

2. Unzip the file to C:\Ross.
3. Open a command prompt window as Administrator, and change directory to the location where 

you unzipped the file, for example:

cd "C:\Ross\Bridge Server 4.5.0.4093"
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IRIS RED GAIN

RED PED BLUE PED

BLUE GAIN MASTER PED

GREEN PED

UPPER

LOWER
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4. Enter the command to install the ManagedServicesHost.exe file and then press Enter. An example 
of the command is as follows:

C:\> "Ross\Bridge Server 4.5.0.4093\ManagedServicesHost.exe" -install

5. Press Enter.
The Bridge Server software is installed. A message in the command prompt window appears when 
the installation is complete.

6. Close the command prompt window.
7. In a web browser, navigate to the Bridge Server configuration page at localhost:3000.
8. If the PaintBox Bridge service is not running, select Start.

Tip: From the configuration page, you can start or stop the server. Alternatively, you can start or stop 
the Bridge Service Host from the Services tab in Windows Task Manager.

To add a DashBoard gateway for the Camera Paint Box:

1. In DashBoard, from the File menu, select New, and then select TCP/IP DashBoard Connect or 
openGear Device.
The New TCP openGear Frame Connection dialog box appears.

2. In the IP Address box, enter the IP address of the computer, or enter localhost.
3. In the Display Name box, enter a name for the node as you want it to appear in the DashBoard 

component tree, for example, Robotics DashBoard Gateway.
4. Select the JSON protocol.
5. In the Port box, enter the desired port number.
6. Select the Remember connection settings for this frame check box.
7. Select Finish.

A new gateway node with the name you specified appears in the DashBoard component tree.
Tip: After you complete this procedure, you can expand the gateway node and double-clickselect 
Station 1 to open an interface that displays real-time data received from the Camera Paint Box.

To configure a DashBoard gateway for the Camera Paint Box:

1. In the DashBoard component tree, expand the DashBoard Services node.
2. Select Device Class Mappings.
3. For each Class, in the Selected Device list, select the only available option in the list.
4. In the DashBoard component tree, select Selector UI Mappings.
5. Set the Autowire Follows UI setting to ON.
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