Thank You for Choosing Ross

You’ve made a great choice. We expect you will be very happy with your purchase of Ross Technology. Our mission is to:

1. Provide a Superior Customer Experience
   • offer the best product quality and support
2. Make Cool Practical Technology
   • develop great products that customers love

Ross has become well known for the Ross Video Code of Ethics. It guides our interactions and empowers our employees. I hope you enjoy reading it below.

If anything at all with your Ross experience does not live up to your expectations be sure to reach out to us at solutions@rossvideo.com.

David Ross
CEO, Ross Video
dross@rossvideo.com

Ross Video Code of Ethics

Any company is the sum total of the people that make things happen. At Ross, our employees are a special group. Our employees truly care about doing a great job and delivering a high quality customer experience every day. This code of ethics hangs on the wall of all Ross Video locations to guide our behavior:

1. We will always act in our customers’ best interest.
2. We will do our best to understand our customers’ requirements.
3. We will not ship crap.
4. We will be great to work with.
5. We will do something extra for our customers, as an apology, when something big goes wrong and it’s our fault.
6. We will keep our promises.
7. We will treat the competition with respect.
8. We will cooperate with and help other friendly companies.
9. We will go above and beyond in times of crisis. *If there’s no one to authorize the required action in times of company or customer crisis - do what you know in your heart is right. (You may rent helicopters if necessary.*)
XPression Maps User Guide

- Ross Part Number: 3500DR-021-3.2
- Release Date: August 20, 2021.
- Software Issue: 3.2

The information contained in this Guide is subject to change without notice or obligation.

Copyright

© 2021 Ross Video Limited, Ross®, and any related marks are trademarks or registered trademarks of Ross Video Limited. All other trademarks are the property of their respective companies. PATENTS ISSUED and PENDING. All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted in any form or by any means, mechanical, photocopying, recording or otherwise, without the prior written permission of Ross Video. While every precaution has been taken in the preparation of this document, Ross Video assumes no responsibility for errors or omissions. Neither is any liability assumed for damages resulting from the use of the information contained herein.

Patents


Notice

The material in this manual is furnished for informational use only. It is subject to change without notice and should not be construed as commitment by Ross Video Limited. Ross Video Limited assumes no responsibility or liability for errors or inaccuracies that may appear in this manual.
End User Software License Agreement

This End User Software License Agreement is a legal agreement between you (the "Licensee") and Ross Video Limited ("Ross Video") specifying the terms and conditions of your installation and use of the Software and all Documentation (as those terms are defined herein).

IMPORTANT:

BY DOWNLOADING, ACCESSING, INSTALLING OR USING THE SOFTWARE AND/OR DOCUMENTATION LICENSEE AGREES TO THE TERMS OF THIS AGREEMENT AND THE LICENSE GRANTED HEREUNDER SHALL BE EFFECTIVE AS OF AND FROM SUCH DATE. IF YOU DO NOT WISH TO ACCEPT THE TERMS AND CONDITIONS OF THIS AGREEMENT, DO NOT DOWNLOAD, ACCESS, INSTALL, REFER TO OR OTHERWISE USE THE SOFTWARE AND/OR DOCUMENTATION.

1. INTERPRETATION. In this Agreement, (a) words signifying the singular number include the plural and vice versa, and words signifying gender include all genders; (b) every use of the words "herein", "hereof", "hereunder" and similar words shall be construed to refer to this Agreement in its entirety and not to any particular provision hereof; (c) reference to any agreement or other document herein will be construed as referring to such agreement or other document as from time to time amended, modified or supplemented (subject to any restrictions on such amendment, modification or supplement set forth therein); (d) every use of the words "including" or "includes" is to be construed as meaning "including, without limitation" or "includes, without limitation", respectively; and (e) references to an Article or a Section are to be construed as references to an Article or Section of or to this Agreement unless otherwise specified.

2. DEFINITIONS. In this Agreement, in addition to the terms defined elsewhere in this Agreement, the following terms have the meanings set out below:

"Affiliate" means, with respect to any Person, any other Person who directly or indirectly controls, is controlled by, or is under direct or indirect common control with, such Person. A Person shall be deemed to control a Person if such Person possesses, directly or indirectly, the power to direct or cause the direction of the management and policies of such Person, whether through the ownership of voting securities, by contract or otherwise; and the term "controlled" and "controlling" shall have a similar meaning.

"Agreement" means this End User Software License Agreement including the recitals hereto, as the same may be amended from time to time in accordance with the provisions hereof.

"Backup System" means the secondary piece of Designated Equipment upon which the Software is installed and mirrored for the sole purpose of replacing a Primary System in the event such Primary System is not available or functioning properly for any reason.

"Change of Control" means (a) the direct or indirect sale, transfer or exchange by the shareholders of a Party of more than fifty percent (50%) of the voting securities of such Party, (b) a merger or amalgamation or reorganization or other transaction to which a Party is party after which the shareholders of such Party immediately prior to such transaction hold less than fifty percent (50%) of the voting securities of the surviving entity, (c) the sale, exchange, or transfer of all or substantially all of the assets of a Party.

"Confidential Information" means all data and information relating to the business and management of either Party, including the Software, trade secrets and other technology to which access is obtained or granted hereunder by the other Party, and any materials provided by Ross Video to Licensee; provided, however, that Confidential Information shall not include any data or information which:

(i) is or becomes publicly available through no fault of the other Party;

(ii) is already in the rightful possession of the other Party prior to its receipt from the other Party;

(iii) is already known to the receiving Party at the time of its disclosure to the receiving Party by the disclosing Party and is not the subject of an obligation of confidence of any kind;

(iv) is independently developed by the other Party;

(v) is rightfully obtained by the other Party from a third party; or

(vi) is disclosed with the written consent of the Party whose information it is.

"Designated Equipment" shall mean (a) the hardware products sold by Ross Video to Licensee on which the Software is installed and licensed for use, as the same may be replaced from time to time by Ross Video; or (b) in the case of Software sold on a stand-alone basis, the equipment of Licensee on which the Software is to be installed and meets the minimum specifications set out in the Documentation.
“Documentation” shall mean manuals, instruction guides, user documentation and other related materials of any kind pertaining to the Software (whether in electronic, hard-copy or other media format) that are furnished to Licensee by or on behalf of Ross Video in relation to the Software.

“Governmental Authority” means (a) and federal, provincial, state, local, municipal, regional, territorial, aboriginal, or other government, governmental or public department, branch, ministry, or court, domestic or foreign, including any district, agency, commission, board, arbitration panel or authority and any subdivision of any of them exercising or entitled to exercise any administrative, executive, judicial, ministerial, prerogative, legislative, regulatory, or taxing authority or power of any nature; and (b) any quasi-governmental or private body exercising any regulatory, expropriation or taxing authority under or for the account of any of them, and any subdivision of any of them.

“Improvements” means all inventions, works, discoveries, improvements and innovations of or in connection with the Software, including error corrections, bug fixes, patches and other updates in Object Code form to the extent made available to Licensee in accordance with Ross Video’s release schedule.

“License Fee” means the fee(s) payable in respect of the Software in accordance with the relevant invoice(s) or other purchase documents delivered in connection with this Agreement.

“License Period” means the period of time that Licensee will have the rights granted under this Agreement, as may be specified in a Quote.

“Maintenance Fee” means the yearly maintenance fee(s) payable by Licensee to Ross Video, as determined by Ross Video, for the support, maintenance and update of the Software after the expiry of the Maintenance Period as set forth in this Agreement.

“Maintenance Period” means, in connection with the Software, the maintenance period of one (1) year from the date of shipment unless otherwise specified in the table below:

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Software Maintenance Period</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switchers</td>
<td>For the life of the Designated Equipment</td>
</tr>
<tr>
<td>Routers (excluding Ultrix)</td>
<td>For the life of the Designated Equipment</td>
</tr>
<tr>
<td>Master Control System Software (DashBoard)</td>
<td>For the life of the Designated Equipment</td>
</tr>
<tr>
<td>Gear</td>
<td>For the life of the Designated Equipment</td>
</tr>
<tr>
<td>Nielsen Encoders</td>
<td>For the life of the Designated Equipment</td>
</tr>
<tr>
<td>Sports Analysis</td>
<td>For the License Period</td>
</tr>
</tbody>
</table>

“Modifications” means any enhancements, changes, corrections, translations, adaptations, revisions, developments, upgrades or updates thereto; and “Modify” shall mean the creation of any of the foregoing.

“Object Code” means the machine readable executable form of a computer software program.

“Parties” means both Ross Video and Licensee and “Party” means either one of them as the context requires.

“Person” will be broadly interpreted and includes (a) a natural person, whether acting in his or her own capacity, or in his or her capacity as executor, administrator, estate trustee, trustee or personal or legal representative; (b) a corporation or a company of any kind, a partnership of any kind, a sole proprietorship, a trust, a joint venture, as association, an unincorporated association, an unincorporated syndicate, an unincorporated organization or any other association, organization or entity of any kind; and (c) a Governmental Authority.

“Primary System” means the Designated Equipment upon which the Software is installed and executed to deliver it’s intended functionality.

“Quote” means the document provided by Ross Video to Licensee detailing the Ross Video products contemplated for purchase, the corresponding fees and any License Period that may apply to the Software.

“Software” shall mean the version of the Object Code sold and delivered to Licensee by Ross Video concurrently with delivery of this Agreement and any subsequent error corrections, updates, Modifications or Improvements provided to Licensee by Ross Video pursuant to this Agreement, but specifically excluding any features or plug-ins that may be purchased by you directly from third parties as upgrades or enhancements to the Software.
3. LICENSE. Subject to the terms and conditions of this Agreement, upon payment of the applicable License Fee by Licensee, Ross Video hereby grants to Licensee a non-transferable and nonexclusive right to Use the Software and Documentation solely for the internal use of Licensee (the “License”), during the License Period. In the event that a License Period is not identified on the Quote, such License Period shall be deemed to be perpetual, subject to Section 7 D of this Agreement. The Software shall only be used in connection with or installed on the Designated Equipment and, where applicable, shall only be used on the Primary System, provided such Primary System is operating properly. If the Primary System is not operating properly for any reason, the Software may be used on the designated Backup System for that Primary System until such time that the Primary System begins operating properly. The Software and Documentation are provided to Licensee for the exclusive use by Licensee’s organization for its ordinary business purposes and shall not be used by any third party for any purposes. Licensee may make copies of the Software as required for internal backup and archival purposes. To the extent permitted hereunder, Licensee may distribute copies of the Software and/or Documentation to members of its organization, provided (a) this Agreement is included with each copy, (b) any member of its organization who uses the Software and/or Documentation accepts and agrees to be bound by the terms of this Agreement and by any other license agreements or other agreement incorporated by reference into this Agreement, and (c) Licensee has paid any applicable additional License Fees in respect of copying and redistributing of the Software. To the extent Licensee is permitted to make copies of the Software under this Agreement, Licensee agrees to reproduce and include on any copy made or portion merged into another work, all Ross Video proprietary notices, including any notices with respect to copyrights, trademarks and this License. With the exception of copying the Software for backup or archival purposes, Licensee agrees to keep a record of the number and location of all such copies and will make such record available at Ross Video’s request. The Software may include mechanisms to limit or inhibit copying.

4. LICENSE RESTRICTIONS. Except as otherwise provided in section 2 above, Licensee shall not: (1) copy any Software or Documentation, or part thereof, which is provided to Licensee by Ross Video pursuant to this Agreement, in Object Code form, Source Code form or other human or machine readable form, including written or printed documents, without the prior written consent of Ross Video; (2) in any way market, distribute, export, translate, transmit, merge, Modify, transfer, adapt, loan, rent, lease, assign, share, sub-license, sell, make available for download on any website or make available to another Person, the Software and/or Documentation, in whole or in part, provided that Licensee shall not be prohibited from renting or leasing the Software if Ross Video has consented, in writing, to Licensee engaging in such activities in respect of the Software; (3) reverse engineer, decompile or disassemble the Software or electronically transfer it into another computer language; or (4) otherwise Use the Software or Documentation in a manner that is inconsistent with the License granted hereunder or that will result in a breach of this Agreement. Licensee agrees to take all reasonable precautions to prevent third parties from using the Software and/or Documentation in any way that would constitute a breach of this Agreement, including such precautions Licensee would ordinarily take to protect its own proprietary software, hardware or information.

5. DELIVERY. Ross Video shall deliver to Licensee one (1) master copy of the Software in compiled binary (executable) form suitable for reproduction in electronic files only and Ross Video shall deliver to Licensee a minimum of one copy of the Documentation.

6. IMPROVEMENTS. Licensee may from time to time request Ross Video to incorporate certain Improvements into the Software. Ross Video may, in its sole discretion, undertake to incorporate and provide such Improvements to Licensee with or without payment of a fee to be negotiated at the time of such request. All Improvements, whether recommended and developed by Ross Video or Licensee, shall be considered the sole property of Ross Video and shall be used by Licensee pursuant to the terms of the License granted under this Agreement.

7. LIMITED REPRESENTATIONS AND WARRANTIES.

(A) Software Warranties
Ross Video represents and warrants that

   (i) During the Maintenance Period the Software is warranted to be free from material defects under normal use;
(ii) Ross Video has the authority to enter into this Agreement, is the owner or licensee of the Software and Documentation and has the right to grant all of the license rights herein;

(iii) Except as expressly stated herein, no disabling mechanism or protection feature designed to prevent the Software’s Use, including any computer virus, worm, lock, drop dead device, Trojan-horse routine, trap door, time bomb or any other codes or instructions that may be used to access, Modify, delete, damage or disable the Software or any other hardware or computer system, will be used or activated by Ross Video in respect of Software that is delivered to Licensee under a valid License; and

(iv) The Software, if properly installed and used with Designated Equipment, will perform substantially as described in Ross Video’s then current Documentation for such Software for the Maintenance Period.

(B) Warranty Exclusions and Inclusions
Notwithstanding the above, all of Ross Video’s obligations with respect to the warranties set out in 7(A) above shall be contingent on Licensee’s use of the Software in accordance with the terms and conditions of this Agreement and Ross Video's instructions as provided in the Documentation. Ross Video shall have no warranty obligations where any Software failure occurs as a result of misuse, neglect, accident, abuse, misapplication, improper installation, unauthorized modification, extreme power surge or extreme electromagnetic field or other Act of God. Ross Video shall pass through to Licensee the benefit of all warranties from third party manufacturers and suppliers.

(C) Remedy
If the Software becomes defective, and a valid claim is received by Ross Video during the Maintenance Period, Ross Video will, at its sole option and sole discretion, either (1) repair the defective Software at no charge, or (2) exchange the defective Software for a comparable product at no charge. The remedies set forth in this Section shall be the exclusive remedies available to Licensee in connection with a breach of the limited warranties set out above.

(D) Maintenance Charges
Technical support for the Software by telephone and email contact with Ross Video is provided by Ross Video to Licensee at no extra charge for the life of the product. During the Maintenance Period, Ross Video shall supply downloadable Software Modifications upon request of Licensee, when available, at no extra charge to Licensee. Notwithstanding the foregoing, Ross Video shall be under no legal obligation to create or release Software Modifications at any time or in accordance with a fixed schedule. Upon expiry of the Maintenance Period, where applicable, Licensee may purchase Software maintenance, including downloadable Software upgrades in one (1) year increments at the then applicable extended Maintenance Fee rates offered by Ross Video, in which case the warranties granted by this Agreement shall survive and remain in full force and effect during each such one (1) year term.

8. OWNERSHIP.

The Parties acknowledge and agree that, as between the Parties, Ross Video shall be the owner of all intellectual property rights in the Software, Documentation and all related Modifications and Improvements, written materials, logos, trademarks, trade names, copyright, patents, trade secret and moral rights, registered or unregistered. No proprietary interest or title in or to the intellectual property in the Software, Documentation or any Improvements or Modifications is transferred to Licensee by this Agreement. Ross Video reserves all rights not expressly licensed to Licensee under section 3.

9. THIRD PARTY SOFTWARE.

Licensee acknowledges that the Third Party Software is not owned by Ross Video. Notwithstanding any other provision of this Agreement, Ross Video, to the extent permitted by applicable law, offers no warranties (whether express, implied, statutory or by course of communication or dealing with Licensee, or otherwise) with respect to the Third Party Software. Ross Video may pass through to Licensee, if and to the extent permitted by applicable law, any warranties expressly provided by such third parties to Ross Video for such Third Party Software.

10. INTELLECTUAL PROPERTY INDEMNITY.

Ross Video agrees to defend, indemnify and hold harmless Licensee from final damages awarded by a court of competent jurisdiction (hereinafter referred to as the “Losses”), which Licensee, or any of its officers or directors, may incur, suffer or become liable for as a result of, or in connection with, any third party claim asserted against Licensee to the extent such claim is based on a contention that the Software, Documentation or any portion thereof, infringes any valid, registered, enforceable patents, copyrights, trade secrets, trademarks or other intellectual property rights of any third party, provided that (a) the allegedly infringing Software or Documentation has been used within the scope of and in accordance with the terms of this Agreement, and (b) Licensee notifies Ross Video in writing of such claim within ten (10) days of a responsible officer of Licensee becoming aware of such claim. If the Software, Documentation or any portion thereof is held to constitute an
infringement of a third party’s intellectual property rights, and use thereof is enjoined, Ross Video shall, at its
election and expense, either (i) procure the right to use the infringing element of the Software or Documentation;
or (ii) replace or modify the element of the Software or Documentation so that the infringing portion is no longer
infringing and still performs the same function without any material loss of functionality. Ross Video shall make
every reasonable effort to correct the situation with minimal effect upon the operations of Licensee.

Notwithstanding the above, Ross Video reserves the right to terminate this Agreement and the License granted
hereunder on immediate notice to Licensee, and without liability to Licensee, in the event that the Software or
Documentation constitutes or may, in Ross Video’s determination, constitute, an infringement of the rights of a
third party that Ross Video, in its sole discretion, does not consider to be affordably remediable.

Either party may terminate this Agreement immediately should any Software become, or in either party’s opinion
be likely to become, the subject of a claim of infringement of any intellectual property right and, in such event,
there shall be no claim by either Licensee or Ross Video against the other arising out of such termination,
provided that the foregoing shall not apply to a claim for infringement by Ross Video against Licensee in the
event that Licensee is alleged to have infringed Ross Video’s intellectual property rights, in which case Licensee
shall remain liable for all outstanding License Fees and other amounts owing to Ross Video.

Notwithstanding the foregoing, Ross Video shall have no liability for any claim of infringement based on use of
other than a current, unaltered release of the Software and/or Documentation available from Ross Video if such
infringement would have been avoided by the use of a current, unaltered release of the Software and/or
Documentation provided that such current, unaltered release performs substantially in conformance with the
specifications set out in the Documentation and was provided, at no additional cost by Ross Video, to those
subscribing for maintenance services for the Software or Documentation.

11. CONFIDENTIALITY.

Each Party shall maintain in confidence all Confidential Information of the other Party, shall use such
Confidential Information only for the purpose of exercising its rights and fulfilling its obligations under this
Agreement, and shall not disclose any Confidential Information of the disclosing Party to any third party except
as expressly permitted hereunder or make any unauthorized use thereof. Each Party shall disclose the
Confidential Information only to those of its employees, consultants, advisors, and/or subcontractors who have a
need to know the Confidential Information. Each Party shall, prior to disclosing the Confidential Information to
such employees, consultants, advisors and/or subcontractors, obtain their agreement to receive and use the
Confidential Information on a confidential basis on the same terms and conditions contained in this Agreement.
The receiving Party shall treat the Confidential Information of the disclosing Party with the same degree of care
against disclosure and/or unauthorized use as it affords to its own information of a similar nature, or a
reasonable degree of care, whichever is greater. The receiving Party further agrees not to remove or destroy
any proprietary or confidential legends or markings placed upon any documents or other materials of the
disclosing Party. The obligations of confidence set forth in this Agreement shall extend to any Affiliates that have
received Confidential Information of the disclosing Party and shall also cover Confidential Information disclosed
by any Affiliate. The receiving Party shall be responsible for any actions or omissions of its Affiliates as if such
actions or omissions were its own.

Either party may disclose certain Confidential Information if it is expressly required to do so pursuant to legal,
judicial, or administrative proceedings, or otherwise required by law, provided that (i) such Party provides the
other Party with reasonable written notice prior to such disclosure; (ii) such Party seeks confidential treatment
for such Confidential Information; (iii) the extent of such disclosure is only to the extent expressly required by law
or under the applicable court order; and (iv) such Party complies with any applicable protective or equivalent
order.

Each of Ross Video and Licensee (the “Indemnifying Party”, as applicable) agree to indemnify the other (the
“Indemnified Party”, as applicable) for all Losses incurred by the Indemnified Party as a result of a failure of the
Indemnifying Party to comply with its obligations under this Section 11 provided that the Indemnified Party has
given prompt notice of any such claim and, to the extent that a claim may lie against a third party for the
unauthorized disclosure of such Confidential Information, the right to control and direct the investigation,
preparation, action and settlement of each such claim and, further, provided that the Indemnified Party
reasonably co-operates with the Indemnifying Party in connection with the foregoing and provides the
Indemnifying Party with all information in the Indemnified Party’s possession related to such claim and such
further assistance as reasonably requested by the Indemnifying Party.

The Parties acknowledge and agree that any breach of the confidentiality provisions of this Agreement by one
Party may cause significant and irreparable injury to the other Party that is not compensable monetarily, as well
as damages that may be difficult to ascertain, and agrees that, in addition to such other remedies that may be
available at law or in equity, the other Party shall be entitled to seek injunctive relief (including temporary
restraining orders, interim injunctions and permanent injunctions) in a court of competent jurisdiction in the event
of the breach or threatened breach by such party of any of the confidentiality provisions of this Agreement. The relief contemplated in this Section shall be available to each Party without the necessity of having to prove actual damages and without the necessity of having to post any bond or other security. Each Party further agrees to notify the other Party in the event that it learns of or has reason to believe that any Person has breached the confidentiality provisions of this Agreement.

12. LIMITATION OF LIABILITY.

The limitation of liability provisions of this Agreement reflect an informed voluntary allocation of the risks (known and unknown) that may exist in connection with the licensing of the Software or Documentation hereunder by Ross Video, and that voluntary risk allocation represents a material part of the Agreement reached between Ross Video and Licensee. Should Ross Video be in breach of any obligation, Licensee agrees that Licensee’s remedies will be limited to those set forth in this Agreement. No action, regardless of form, arising out of this Agreement may be brought by Licensee more than twelve (12) months after the facts giving rise to the cause of action have occurred, regardless of whether those facts by that time are known to, or reasonably ought to have been discovered by, Licensee.

(A) EXCEPT AS EXPRESSLY PROVIDED IN THIS AGREEMENT, THE SOFTWARE AND DOCUMENTATION ARE PROVIDED “AS IS” AND ROSS VIDEO (I) MAKES NO OTHER REPRESENTATIONS, AND PROVIDES NO WARRANTIES OR CONDITIONS OF ANY KIND, EXPRESS OR IMPLIED, STATUTORY, BY USAGE OF TRADE CUSTOM OF DEALING, OR OTHERWISE, AND (II) SPECIFICALLY DISCLAIMS ALL IMPLIED WARRANTIES INCLUDING ANY IMPLIED WARRANTY OF UNINTERRUPTED OR ERROR FREE OPERATION, MERCHANTABILITY, QUALITY OR FITNESS FOR A PARTICULAR PURPOSE. ROSS VIDEO DOES NOT REPRESENT OR WARRANT THAT THE SOFTWARE WILL MEET ANY OR ALL OF LICENSEE’S PARTICULAR REQUIREMENTS, THAT THE USE AND OPERATION OF THE SOFTWARE WILL OPERATE ERROR-FREE OR UNINTERRUPTED, THAT ALL PROGRAMMING ERRORS IN THE SOFTWARE CAN BE FOUND IN ORDER TO BE CORRECTED, OR THAT THE SOFTWARE WILL BE COMPATIBLE WITH OTHER PROGRAMS, SYSTEMS, AND HARDWARE.

(B) IN NO EVENT SHALL ROSS VIDEO, ITS AFFILIATES AND LICENSORS, AND THEIR RESPECTIVE DIRECTORS, OFFICERS, EMPLOYEES AND AGENTS, BE LIABLE FOR ANY CLAIM FOR INDIRECT, CONSEQUENTIAL, SPECIAL, INCIDENTAL, PUNITIVE, EXEMPLARY, AGGRAVATED DAMAGES; LOST PROFITS, OR LOST REVENUE ARISING FROM OR IN CONNECTION WITH THIS AGREEMENT, REGARDLESS OF THE FORM OF ACTION, WHETHER IN CONTRACT, OR IN TORT, EVEN IF THE PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

(C) IN ANY EVENT THE AGGREGATE LIABILITY OF ROSS VIDEO, ITS AFFILIATES AND LICENSORS, AND THEIR RESPECTIVE DIRECTORS, OFFICERS, EMPLOYEES AND AGENTS, FOR ANY CLAIM FOR DIRECT DAMAGES WITH RESPECT TO THE SUBJECT MATTER OF THIS AGREEMENT SHALL NOT EXCEED THE AMOUNT OF THE PURCHASE PRICE PAID TO ROSS VIDEO UNDER THIS AGREEMENT.

13. TERM AND TERMINATION.

(1) Unless terminated earlier in accordance with the terms of this Agreement, the term of this Agreement shall commence upon Licensee’s first download, access, installation, or other use of the Software or Documentation and continues until, in the case of Software sold with Designated Equipment provided by Ross Video, the earliest of (a) the end of the License Period, or (b) if the Designated Equipment is assigned or transferred in accordance with this Agreement, the date on which the Designated Equipment is no longer owned by Licensee;

(2) Either Party shall have the right to terminate this Agreement on notice to the other Party if:

(a) the other Party fails to pay any fees or other amounts when due hereunder or under any other agreement between the Parties (or any Affiliates of the Parties, as applicable) in connection with the Software and/or Designated Equipment and such breach is not cured within thirty (30) days after written notice of such failure to pay is given to the defaulting Party by the non-defaulting Party;

(b) the other Party shall file a voluntary petition in bankruptcy or insolvency or shall petition for reorganization under any bankruptcy law, consent to an involuntary petition in bankruptcy, or if a receiving order is given against it under the Bankruptcy and Insolvency Act (Canada) or the comparable law of any other jurisdiction (and such is not dismissed within ten (10) days);

(c) there shall be entered an order, judgment or decree by a court of competent jurisdiction, upon the application of a creditor, approving a petition seeking reorganization or appointing a receiver, trustee or liquidator of all or a substantial part of the other Party’s assets and such order, judgment or decree continues in effect for a period of thirty (30) consecutive days; or
(d) the other Party shall fail to perform any of the other material obligations set forth in this Agreement and such default, in the case of a default which is remediable, continues for a period of thirty (30) days after written notice of such failure has been given by the nondefaulting Party or, in the case of a non-remediable default, immediately upon notice.

(3) Notwithstanding any to the contrary contained in this Agreement:

(a) Ross Video may forthwith terminate this Agreement if Licensee is in breach of any of sections 3, 4 or 11 of this Agreement. For greater certainty, in such instances Ross Video shall provide written notice of such termination as soon as practicable but written notice shall not be a necessary prerequisite to such termination; and

(b) in the event of a Change of Control of Licensee, Ross Video shall have the rights to terminate this Agreement and the License granted hereunder upon thirty (30) days' prior written notice to Licensee. For greater certainty, Ross Video’s right to terminate in the event of a Change of Control of Licensee shall continue for a period of six (6) months from the date Licensee delivers notice of such Change of Control to Ross Video.

(c) Ross Video may terminate the License immediately on the date on which it provides notice to Licensee, if its agreements for Third Party Software are terminated.

(4) Upon the termination or expiry of this Agreement:

(a) Licensee shall immediately cease and desist all use of the Software and Documentation;

(b) Licensee shall immediately deliver to Ross Video any of Ross Video’s Confidential Information provided hereunder (including the Software and Documentation) then in its possession or control, if any, and shall deliver a certificate of an officer of Licensee certifying the completeness of same;

(c) Licensee shall refrain from further use of such Confidential Information; and

(d) Licensee shall forthwith pay all amounts owing to Ross Video or any of its Affiliates hereunder.

14. SURVIVAL.

The provisions of sections 1, 2, 4, 6, 8, 9, 11, 12, 13, 14, 17 and 19 herein shall survive the expiry or termination of this Agreement.

15. FORCE MAJEURE.

Dates and times by which Ross Video is required to render performance under this Agreement shall be automatically postponed to the extent and for the period that Ross Video is prevented from meeting them by reason of events of force majeure or any cause beyond its reasonable control provided Ross Video notifies Licensee of the commencement and nature of such cause and uses its reasonable efforts to render performance in a timely manner.

16. ASSIGNMENT.

Ross Video may assign this Agreement, or any of its rights or obligations hereunder, in whole or in part, upon notice to Licensee. Licensee shall not assign this Agreement, or any of its rights or obligations hereunder, in whole or in part, without the prior written consent of Ross Video, which consent may not be unreasonably withheld. This Agreement enures to the benefit of and is binding upon each of the Parties and their respective successors and permitted assigns.

17. GOVERNING LAW.

This Agreement shall be governed by and construed in accordance with the laws of the Province of Ontario and federal laws of Canada applicable therein and shall be treated, in all respects, as an Ontario contract. Each Party irrevocably and unconditionally submits and attorns to the exclusive jurisdiction of the courts of the Province of Ontario to determine all issues, whether at law or in equity, arising from this Agreement.

18. LANGUAGE.

The Parties have expressly required that this Agreement and all documents relating thereto be drawn-up in English. Les parties ont expressément exigé que cette convention ainsi que tous les documents qui s’y rattachent soient rédigés en anglais.
19. GOVERNMENT CONTRACTS.

If the Software and/or Documentation to be furnished to Licensee hereunder are to be used in the performance of a government contract or subcontract, the Software and/or Documentation shall be provided on a "restricted rights" basis only and Licensee shall place a legend, in addition to applicable copyright notices, in the form provided under the applicable governmental regulations. For greater certainty, Ross Video shall not be subject to any flowdown provisions required by any customers of Licensee that are a Governmental Authority unless Ross Video expressly agrees to be bound by such flowdown provisions in writing.

20. EXPORT AND IMPORT LAWS.

Licensee acknowledges and agrees that the Software (including any technical data and related technology) may be subject to the export control laws, rules, regulations, restrictions and national security controls of the United States and other applicable countries (the "Export Controls") and agrees not export, re-export, import or allow the export, re-export or import of such export-controlled Software (including any technical data and related technology) or any copy, portion or direct product of the foregoing in violation of the Export Controls. Licensee hereby represents that it is not an entity or person to whom provision of the Software (including any technical data and related technology) is restricted or prohibited by the Export Controls. Licensee agrees that it has the sole responsibility to obtain any authorization to export, re-export, or import the Software (including any technical data and related technology), as may be required. Licensee will defend, indemnify and hold Ross Video harmless from any and all claims, losses, liabilities, damages, fines, penalties, costs and expenses (including attorney's fees) arising from or relating to any breach by Licensee of its obligations under this Section.

21. AMENDMENT AND WAIVER.

No amendment, discharge, modification, restatement, supplement, termination or waiver of this Agreement or any Section of this Agreement is binding unless it is in writing and executed by the Party to be bound. No waiver of, failure to exercise or delay in exercising, any Section of this Agreement constitutes a waiver of any other Section (whether or not similar) nor does any waiver constitute a continuing waiver unless otherwise expressly provided.

22. SEVERABILITY.

Each Section of this Agreement is distinct and severable. If any Section of this Agreement, in whole or in part, is or becomes illegal, invalid, void, voidable or unenforceable in any jurisdiction by any court of competent jurisdiction, the illegality, invalidity or unenforceability of that Section, in whole or in part, will not affect (a) the legality, validity or enforceability of the remaining Sections of this Agreement, in whole or in part; or (b) the legality, validity or enforceability of that Section, in whole or in part, in any other jurisdiction.

23. ENTIRE AGREEMENT.

This Agreement, and any other documents referred to herein, constitutes the entire agreement between the Parties relating to the subject matter of this Agreement and supersedes all prior written or oral agreements, representations and other communications between the Parties.
Licensing

The Bing™ Aerial, Bing Aerial Label and Bing Road map styles come from Microsoft® Bing Maps. Bing Maps is a registered trademark of Microsoft in the United States and/or other countries.

Users must conform with the Microsoft® Bing™ Maps Broadcast, Media and Entertainment Terms of Use, in particular, the Content Attribution Requirements.

The Microsoft® Bing™ Maps Broadcast, Media and Entertainment Terms of Use are an extension of the Microsoft® Bing™ Maps Platform APIs’ Terms of Use.

The Blue Marble map style comes from 'NASA Earth Observatory'. Add the following credit line to your closing credits or web page: "Blue Marble: Next Generation by NASA's Earth Observatory."

NDI™ is a trademark of NewTek, Inc. For details visit NDI.NewTek.com.

libav is used in this work under the "GNU LESSER GENERAL PUBLIC LICENSE" Version 2.1, February 1999. The files LICENSE and COPYING.LGPLv2.1 distributed in Ext_License/libav contain additional details.

FFmpeg is used in this work under the "GNU LESSER GENERAL PUBLIC LICENSE" Version 2.1, February 1999. The files LICENSE.md and COPYING.LGPLv2.1 distributed in Ext_License/ffmpeg contain additional details.

The encoding of the video media in combination with FFmpeg or libav is licensed under the following patent portfolio licenses from MPEG LA, LLC, 6312 S. Fiddlers Green Circle, Suite 400E, Greenwood Village, Colorado 80111 U.S.A.:

The MPEG-2 PATENT PORTFOLIO, The MPEG-4 VISUAL PATENT PORTFOLIO, The VC-1 PATENT PORTFOLIO, and The AVC PATENT PORTFOLIO.

Portions of this software are copyright ©2006 The Free Type Project (www.freetype.org). All rights reserved. The FTL.TXT file distributed in Ext_License/freetype contains additional details.

Freelmage is released under the "Freelmage Public License - Version 1.0". The license-fi.txt file distributed in Ext_License/Freelmage contains additional details. The “Source Code” is used in this work unchanged and can be downloaded direct from Free Image (http://freeimage.sourceforge.net).

GStreamer 1.0 and Glib 2.0 are used in this work under the "GNU LESSER GENERAL PUBLIC LICENSE" Version 2, June 1991. The file COPYING distributed in Ext_License/GStreamer 1.0 contains additional details.

GDAL/OGR is released under the MIT/X license. The LICENSE.TXT file distributed in Ext_License/GDAL-OGR contains additional details.

GTS is released under the "GNU LIBRARY GENERAL PUBLIC LICENSE" Version 2, June 1991. The files COPYING and AUTHORS distributed in Ext_License/GTS contain additional details.

The shape database "Natural Earth" used in this software comes out of the public domain. For details visit http://www.naturalearthdata.com/about/terms-of-use/.

©ARTS Computer Technologies GmbH 2008-2020
Warranty and Repair Policy

Ross Video Limited (Ross) warrants its XPression systems to be free from defects under normal use and service for the following time periods from the date of shipment:

- **XPression Maps Server** — 12 months
- **XPression Maps Software Upgrades** — 12 months free of charge
- **System and Media hard drives** — 60 months

If an item becomes defective within the warranty period Ross will repair or replace the defective item, as determined solely by Ross.

Warranty repairs will be conducted at Ross, with all shipping FOB Ross dock. If repairs are conducted at the customer site, reasonable out-of-pocket charges will apply. At the discretion of Ross, and on a temporary loan basis, plug in circuit boards or other replacement parts may be supplied free of charge while defective items undergo repair. Return packing, shipping, and special handling costs are the responsibility of the customer.

This warranty is void if products are subjected to misuse, neglect, accident, improper installation or application, or unauthorized modification.

In no event shall Ross Video Limited be liable for direct, indirect, special, incidental, or consequential damages (including loss of profit). Implied warranties, including that of merchantability and fitness for a particular purpose, are expressly limited to the duration of this warranty.

This warranty is TRANSFERABLE to subsequent owners, subject to Ross’ notification of change of ownership.

Extended Warranty

For customers that require a longer warranty period, Ross offers an extended warranty plan to extend the standard warranty period by one year increments. For more information about an extended warranty for your XPression system, contact your regional sales manager.
Environmental Information

The equipment that you purchased required the extraction and use of natural resources for its production. It may contain hazardous substances that could impact health and the environment.

To avoid the potential release of those substances into the environment and to diminish the need for the extraction of natural resources, Ross Video encourages you to use the appropriate take-back systems. These systems will reuse or recycle most of the materials from your end-of-life equipment in an environmentally friendly and health conscious manner.

The crossed-out wheeled bin symbol invites you to use these systems.

If you need more information on the collection, reuse, and recycling systems, please contact your local or regional waste administration.

You can also contact Ross Video for more information on the environmental performances of our products.
Company Address

Ross Video Limited
8 John Street
Iroquois, Ontario
Canada, K0E 1K0

Ross Video Incorporated
P.O. Box 880
Ogdensburg, New York
USA 13669-0880

General Business Office:  (+1) 613 • 652 • 4886
Fax:  (+1) 613 • 652 • 4425

Toll Free Technical Support:  1-844-652-0645 (North America)
+800 1005 0100 (International)

Alternately, you can contact:
Technical Support:  (+1) 613 • 652 • 4886
After Hours Emergency:  (+1) 613 • 349 • 0006

E-mail for Technical Support: techsupport@rossvideo.com
E-mail for General Information: solutions@rossvideo.com
Website: http://www.rossvideo.com
# Contents

## Introduction
- About This Guide .............................................. 1-1
- Documentation Conventions ..................................... 1-1
- Contacting Technical Support ................................... 1-2

## User Interface Overview
- XPression Maps User Interface .................................. 2-1
- Launching XPression Maps ........................................ 2-2

## Configuring Preferences
- Output ........................................................................ 3-2
- Map .............................................................................. 3-4
- Web Interface ............................................................. 3-5
- Connection ...................................................................... 3-8
- Proxy ............................................................................ 3-10
- Dynamic Data (Optional) ............................................. 3-11
- Control .......................................................................... 3-12
- Video I/O (Optional) .................................................... 3-13
- Interactive (Optional) ................................................... 3-15

## Tools
- Undoing a Stack ........................................................ 4-2
- Measuring Distances ................................................... 4-3
- Reloading the Active Map .......................................... 4-4
- Selecting the Edit Mode .............................................. 4-4
- Undoing/Redoing Operations ....................................... 4-5
- Taking Snapshots ....................................................... 4-5
- Exporting Maps ........................................................ 4-6
- View Menu ..................................................................... 4-7
- Help Menu ..................................................................... 4-7
- Log Information .......................................................... 4-8
- Download Information ............................................... 4-9

## Map Styles
- Using Map Styles ....................................................... 5-2
  - Animated Map Style .................................................. 5-2
  - Automatic Map Style ............................................... 5-3
- Editing Map Styles ...................................................... 5-6
- Map Style Properties ................................................... 5-10

## Managing Templates
- Managing Scene Template Groups ............................... 6-2
- Managing Scene Templates .......................................... 6-5
- Scenes .......................................................................... 6-6

## Drawing Management
- Drawing Management Editor ....................................... 7-2
- Managing Groups ......................................................... 7-3
- Managing Drawings ....................................................... 7-5
  - Text and OSM Replacement Drawings .......................... 7-8
  - Area Drawings .......................................................... 7-20
  - Line Drawings ........................................................... 7-22
  - Icon Drawings ......................................................... 7-24
  - Magnifier Drawings ................................................... 7-27
  - Locator Drawings ..................................................... 7-30
  - Dynamic Data Drawings ............................................ 7-33
  - Background Drawings ............................................... 7-36
  - Video Input Drawings ............................................... 7-37

## Creating Scenes
- Output Window .......................................................... 8-2
- Opening a Scene ......................................................... 8-3
- Adding and Editing Drawings ....................................... 8-6
  - Editing the Background Drawing ................................. 8-11
  - Ordering Drawings .................................................... 8-12
- Drawing Toolbox ........................................................ 8-13
- Flight Points ............................................................... 8-16
- Animation Control ...................................................... 8-19
- Camera Control .......................................................... 8-21
  - Camera Selection ..................................................... 8-22
  - Camera Parameters .................................................. 8-23
  - Camera Parameter Key Frames ................................... 8-24
  - Easing Methods ......................................................... 8-25
- Safe Title / Safe Area .................................................. 8-26
- Overlay Layer ............................................................. 8-28
- Saving a Scene ........................................................... 8-29
- Exporting a Scene ....................................................... 8-30

## Editors
- Shape Editor ............................................................. 9-2
- Adding and Deleting Shapes ........................................ 9-3
- Editing Shapes ........................................................... 9-5
- Relocating Shapes ....................................................... 9-7
- Shape Styles ............................................................. 9-8
- Shape Style Properties ................................................. 9-12
- Drawing Editor .......................................................... 9-16
  - Common Parameters ............................................... 9-17
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specific Parameters</td>
<td>9-19</td>
</tr>
<tr>
<td>Search Editor</td>
<td>9-26</td>
</tr>
<tr>
<td>Searching for a Location</td>
<td>9-27</td>
</tr>
<tr>
<td>Shape Database Viewer</td>
<td>9-30</td>
</tr>
<tr>
<td>Shape Label Properties</td>
<td>9-31</td>
</tr>
<tr>
<td>Shape Label Translation</td>
<td>9-32</td>
</tr>
<tr>
<td>Bookmark Editor</td>
<td>9-35</td>
</tr>
<tr>
<td>Adding and Deleting Bookmark Folders</td>
<td>9-36</td>
</tr>
<tr>
<td>Adding and Deleting Bookmarks</td>
<td>9-37</td>
</tr>
<tr>
<td>Recalling and Editing Bookmarks</td>
<td>9-38</td>
</tr>
<tr>
<td>Saving and Loading Bookmarks</td>
<td>9-38</td>
</tr>
<tr>
<td>Adding a Pause to a Flight</td>
<td>9-38</td>
</tr>
<tr>
<td>OSM (OpenStreetMap) Style Editor</td>
<td>9-39</td>
</tr>
<tr>
<td>Editing Overview</td>
<td>9-40</td>
</tr>
<tr>
<td>Editing OpenStreet Maps</td>
<td>9-41</td>
</tr>
<tr>
<td>OSM Replacement Drawings</td>
<td>9-49</td>
</tr>
<tr>
<td>Show Information Layers</td>
<td>9-52</td>
</tr>
<tr>
<td>Editing Individual Layer Elements</td>
<td>9-53</td>
</tr>
<tr>
<td>Creating Animations</td>
<td>10</td>
</tr>
<tr>
<td>Adding and Deleting Key Frames</td>
<td>10-2</td>
</tr>
<tr>
<td>Animation Control</td>
<td>10-3</td>
</tr>
<tr>
<td>Location and View Animation</td>
<td>10-4</td>
</tr>
<tr>
<td>Drawing Animation</td>
<td>10-5</td>
</tr>
<tr>
<td>Line Animation</td>
<td>10-6</td>
</tr>
<tr>
<td>Zoom Animation</td>
<td>10-7</td>
</tr>
<tr>
<td>Shape Animation</td>
<td>10-8</td>
</tr>
<tr>
<td>Recording Animations</td>
<td>11</td>
</tr>
<tr>
<td>Custom Data</td>
<td>12</td>
</tr>
<tr>
<td>Custom Shapes</td>
<td>12-2</td>
</tr>
<tr>
<td>Managing Custom Groups</td>
<td>12-2</td>
</tr>
<tr>
<td>Managing Custom Shapes</td>
<td>12-4</td>
</tr>
<tr>
<td>Custom Maps</td>
<td>12-8</td>
</tr>
<tr>
<td>Creating a Map Data Source</td>
<td>12-8</td>
</tr>
<tr>
<td>Importing Map Data</td>
<td>12-10</td>
</tr>
<tr>
<td>Creating Levels</td>
<td>12-11</td>
</tr>
<tr>
<td>Using Custom Maps</td>
<td>12-12</td>
</tr>
<tr>
<td>Map Data Configurator</td>
<td>13</td>
</tr>
<tr>
<td>Configuring Data Sources</td>
<td>13-2</td>
</tr>
<tr>
<td>Data Source Sharing</td>
<td>13-3</td>
</tr>
<tr>
<td>Data Source Description</td>
<td>13-4</td>
</tr>
<tr>
<td>HTML5 Client</td>
<td>14</td>
</tr>
<tr>
<td>Launching the HTML5 Client</td>
<td>14-2</td>
</tr>
<tr>
<td>Using the HTML5 Client</td>
<td>14-4</td>
</tr>
<tr>
<td>Selecting a Template or Scene</td>
<td>14-5</td>
</tr>
<tr>
<td>Modifying Templates in the HTML5 Client</td>
<td>14-5</td>
</tr>
<tr>
<td>Changing the Camera View</td>
<td>14-7</td>
</tr>
<tr>
<td>Modifying the Safe Title Area</td>
<td>14-7</td>
</tr>
<tr>
<td>Adding, Editing and Deleting Shapes</td>
<td>14-8</td>
</tr>
<tr>
<td>Adding, Editing and Deleting Labels</td>
<td>14-10</td>
</tr>
<tr>
<td>Adding, Editing, Deleting and Ordering Drawings</td>
<td>14-12</td>
</tr>
<tr>
<td>Adding a Flight Point</td>
<td>14-15</td>
</tr>
<tr>
<td>Downloading a Still Image</td>
<td>14-17</td>
</tr>
<tr>
<td>Playing Saved Scenes in the HTML5 Client</td>
<td>14-18</td>
</tr>
<tr>
<td>Deleting and Duplicating Saved Scenes</td>
<td>14-19</td>
</tr>
<tr>
<td>Managing Saved Scene Folders</td>
<td>14-20</td>
</tr>
<tr>
<td>Playing Saved Scenes in a Host Application</td>
<td>14-22</td>
</tr>
</tbody>
</table>

**Interactive User Interface** .............................................. 15

Selecting Interactive Mode ...................................................................... 15-2
Creating Interactive Projects .................................................................. 15-3
Opening and Loading Projects .................................................................. 15-4
Creating an Overlay ................................................................................ 15-5
Creating a Home Position and Scenes .................................................... 15-5
Editing a Scene ....................................................................................... 15-6
Previewing Projects .................................................................................. 15-7
Deleting Projects ..................................................................................... 15-8
Making Animated Scenes Usable in the Touch Client .................................. 15-9
Managing Interactive Scenes .................................................................... 15-10
Editing Projects ....................................................................................... 15-14

**Touch Client** ...................................................................................... 16

Launching the Touch Client ....................................................................... 16-2
Using the Touch Client ............................................................................. 16-3
Overview of the Interface .......................................................................... 16-4
Loading Projects ........................................................................................ 16-6
Controlling Projects and Scenes ............................................................ 16-7
Managing Saved Scene Folders .................................................................. 16-9

**User Management** ................................................................................ 17

Managing Users ......................................................................................... 17-2
Managing Groups ....................................................................................... 17-6
Changing your Password ........................................................................... 17-8

**Appendix A: Keyboard Shortcuts** .................................................... A

File Menu Shortcuts .................................................................................. A-1
Edit Menu Shortcuts .................................................................................. A-1
Output Menu Shortcuts ............................................................................... A-2
Animation Menu Shortcuts ......................................................................... A-2
Output Window Shortcuts .......................................................................... A-2
Appendix B: Managing Network Security

Buying an SSL Certificate .................................. B-1
Installing the Certificate ..................................... B-1
Introduction

XPression Maps is an application that allows the user to design animations such as virtual flights, over maps and create video files from these animations. XPression Maps allows you to select different map styles, like the maps from Microsoft Bing, and switch between them on the fly. You can also build customized maps with colorization of regions, counties and cities, animated world maps, and maps showing animated routes.

XPression Maps is sold in three configurations:

- XPression Maps Design Workstation
  Create still and animated maps for use as is or as templates for use with XPression Maps Server MOS workflow tools.
- XPression Maps Server
  Provides access to map templates to XPression News MOS users, while maintaining control over the look of maps and increasing the number of maps and the number of designers creating maps.
- XPression Maps Touch
  Create interactive scenes and projects that can be controlled in the XPression Maps Touch Client and interacted with on a remote touch screen.

About This Guide

This user guide describes XPression Maps, its configuration, and operation.

If at any time, you have a question pertaining to the installation or operation of XPression Maps, please contact us at the numbers listed in the section “Contacting Technical Support” on page 1–2. Our technical staff are always available for consultation, training, or service.

Documentation Conventions

Special text formats are used in this guide to identify parts of the user interface, text that a user must enter, or a sequence of menus and submenus that must be followed to reach a particular command.

**Bold text**

Bold text is used to identify a user interface element such as a dialog box, menu item, or button.

For example:

In the **Drawing Toolbox**, right-click a drawing and select **Edit Drawing** from the context menu.

**Courier text**

Courier text is used to identify text that a user needs to enter.

For example:

Enter `localhost` when the DataLinq server is running on the same computer as XPression.

> Menu arrows are used in procedures to identify a sequence of menu items that you need to follow.

For example, if a step reads “Click **File > Preferences**”, you would click **File** first and then click **Preferences**.

The *XPression Maps User Guide* is supplied as a print-ready PDF file. Locate the guide in C:\Archives to open the guide PDF in Adobe® Reader® for viewing or printing.
Contacting Technical Support

At Ross Video, we take pride in the quality of our products, but if problems occur, help is as close as the nearest telephone.

Our 24-hour Hot Line service ensures you have access to technical expertise around the clock. After-sales service and technical support is provided directly by Ross Video personnel. During business hours (eastern time), technical support personnel are available by telephone any time. After hours and on weekends, a direct emergency technical support phone line is available. If the technical support person who is on call does not answer this line immediately, a voice message can be left and the call will be returned shortly. This team of highly trained staff is available to react to any problem and to do whatever is necessary to ensure customer satisfaction.

• Technical Support:
  › (+1) 613-652-4886
  › +1-844-652-0645 (North America)
  › +800 1005 0100 (International)

• After Hours Emergency: (+1) 613-349-0006

• E-mail: techsupport@rossvideo.com

• Website: http://www.rossvideo.com
User Interface Overview

The XPression Maps interface is used to configure and edit drawings, such as icons, lines, areas, and text, in order to highlight and describe situations on the map in an animated way.

XPression Maps User Interface

The following screen capture displays the main elements of the XPression Maps user interface. Descriptions of individual elements are contained in the table below the diagram.

1. **Menu Bar**: Use this menu bar to access the File, Edit, Style, Custom, Output, Animation, View and Help menus.

2. **Tool Bar**: Use this tool bar to access XPression Maps tools.

3. **Editors**: Use these editors to create shapes, edit drawings, search for maps and create bookmarks.

4. **Output Window**: Displays the map/scene for output.

5. **OSM (OpenStreetMap) Style Editor, Drawing Toolbox, Flight Points, Log Information, Map Styles, and Download Information**: Use these sections to customize OpenStreetMaps, create, edit and add drawings and flight points, to view log information, to select map styles, and to view map download information.

6. **Animation Control**: Use this section to control the animation playback of a map.

---

**Figure 2.1 XPression Maps User Interface**

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1. <strong>Menu Bar</strong>: Use this menu bar to access the File, Edit, Style, Custom, Output, Animation, View and Help menus.</td>
<td>2. <strong>Tool Bar</strong>: Use this tool bar to access XPression Maps tools.</td>
</tr>
<tr>
<td>3. <strong>Editors</strong>: Use these editors to create shapes, edit drawings, search for maps and create bookmarks.</td>
<td>4. <strong>Output Window</strong>: Displays the map/scene for output.</td>
</tr>
<tr>
<td>5. <strong>OSM (OpenStreetMap) Style Editor, Drawing Toolbox, Flight Points, Log Information, Map Styles, and Download Information</strong>: Use these sections to customize OpenStreetMaps, create, edit and add drawings and flight points, to view log information, to select map styles, and to view map download information.</td>
<td>6. <strong>Animation Control</strong>: Use this section to control the animation playback of a map.</td>
</tr>
</tbody>
</table>
Launching XPression Maps

To launch XPression Maps, right-click on the XPression Maps desktop icon and select Run as administrator from the shortcut menu to run the software as a local administrator.

If you will always be running the program as an administrator, you can specify this in the properties.

To always run as administrator:

1. Right-click on the XPression Maps desktop icon and select Properties.

   ![Figure 2.2 XPression Maps Properties]

2. In the Shortcut tab, click the Advanced button.

3. In the Advanced Properties screen, select the Run as administrator checkbox.

   ![Figure 2.3 XPression Maps Advanced Properties]

4. Then click OK and in the Properties screen, click Apply.
Configuring Preferences

Before beginning to use the application to create map-based video files, you can configure the XPression Maps environment to suit your own needs. The Preferences dialog contains multiple tabs with different sets of parameters.

To configure your preferences:

1. Select File > Preferences.
2. Click on the tabs to edit the parameters, as described in the following sections.
   - “Output” on page 3–2
   - “Map” on page 3–4
   - “Web Interface” on page 3–5
   - “Connection” on page 3–8
   - “Proxy” on page 3–10
   - “Dynamic Data (Optional)” on page 3–11
   - “Control” on page 3–12
   - “Video I/O (Optional)” on page 3–13
   - “Interactive (Optional)” on page 3–15 (appears only if you’ve purchased this option.
3. Click Save to save changes you’ve made to the parameters.
4. When you are finished editing your preferences, click OK to apply the changes and close the Preferences dialog.
Output

In the Output tab you can select the screen resolution and recording format, enable or disable various startup and default settings and define the location and level of detail to be included in the logfile.

![Figure 3.1 Preferences - Output Tab]

**To edit the Output parameters:**

1. In the **Screen** section, from the **Resolution** drop-down, select the video resolution and frame rate used by your facility.

2. In the **Video Creation** section, from the **Field Render** drop-down, select whether to render the **Upper Field First** or **Lower Field First**. The drop-down is available only when the selected screen resolution is an interlaced format.

3. In the **Misc** section, select one of the following options:
   - **Start in Server Mode**: Select this mode to use the XPression Maps HTML5 Client.
   - **Start in Interactive Mode**: Select this mode to use the XPression Maps Touch UI (default).

   If you change the startup mode, you will need to restart the XPression Maps application.

4. Also in the **Misc** section, enable the following default behaviors if desired:
   - Select the **Compact Scene on Save** checkbox to remove unused map styles from the **Map Styles** list and unused shape styles from the **Shape** style list when the scene is saved or exported.
     This is useful for scenes that are exported to the XPression Maps HTML5 Client plugin for XPression MOS workflows.
   - Select the **Load scene using map style from Map Style Database** checkbox to enable the **Use Scene Styles From Database** parameter in the **Scene Templates** editor.

     The **Use Scene Styles From Database** parameter allows you to apply the map style that has been saved in the database in place of the map style in the selected scene.
• Select the **Limit Map View to Video Size** checkbox to match the map view to the video size.
  If unchecked, the map view will be as large as possible.
• Select the **Turn Auto Zoom On for OSM Replacement Drawings**, checkbox if you generally prefer to have your replacement labels stay the same size, regardless of the zoom level of the map.
  You can still disable **Auto Zoom** in the **Drawing Editor** if necessary in individual cases.

5. In the **Logfile** section, click the **Browse** button beside the **Location** field to navigate to the location where you want to store the logfile.
   The default location is `C:\XPressionMaps_3.0\bin64\log`.

6. From the **Log Priority** drop-down, select the level of detail to be stored to the logfile.
   • **Always** - Logs a small set of specific information, such as the start time and version number of the application.
   • **Critical** - Logs activity that could result in unpredictable behavior.
   • **Error** - Logs errors only.
   • **Warning** - Logs unsuccessful operations.
   • **Information** - For internal use only, for technical support.
   • **Debug** - For internal use only, for technical support.
   • **Debug2** - For internal use only, for technical support.

**To save your configuration:**

• At the bottom of the **Output** tab, click **Save** and then click **OK**.
Map

In the Map tab you can edit the parameters related to the map data.

![Preferences - Map Tab](image)

**Figure 3.2 Preferences - Map Tab**

To edit the Map parameters:

1. In the **Country** section, from the **Code** drop-down, select the language/country to be used for the system.
   
   The Bing Road maps will be downloaded in the selected language. The Bing search results will be displayed in the selected language and the shape labels will take the translation table of the selected language.

2. Select the **Include English Search Results** checkbox when using a language other than English, to get the best results.
   
   The English search results will be displayed in magenta in the Search Editor.

3. In the **Rendering** section, select the **Use MipMap** checkbox to render the map tiles with MipMapping and select the **3D** checkbox to enable rendering of maps with the 3D height model.
   
   - MipMapping reduces aliasing artifacts but decreases rendering speed.
   - The 3D height model renders maps that visually indicate elevation.

4. In the **Data Configuration** section, click the **Browse** button beside the **File** field, to navigate to the location in which the information database file (**WNMDBInfo.db**) will be stored.
   
   The default location is `C:\XPressionMaps\DB\WNMDBInfo.db`.
   
   The information database file is used to resolve all database connections and is configured with the “Map Data Configurator” on page 13–1 application in the subfolder `C:\XPressionMaps\MapDataConfigurator`.

5. In the **OSM Server** section, click the **Browse** button beside the **Config File** field to navigate to the location of the external OpenStreetMap tile server configuration file (**osm-mapserver-setup.xml**).
   
   The default location is `C:\XPressionMaps\OSMStyles\osm-mapserver-setup.xml`.

To save your configuration:

- At the bottom of the Map tab, click **Save** and then click **OK**.
Web Interface

In the **Web Interface** tab you can configure the XPression Maps Server details and handshake with the XPression Maps Database and the XPression Maps Gateway.

![Image of Preferences - Web Interface Tab]

**Figure 3.3 Preferences - Web Interface Tab**

To edit the Web Interface parameters:

1. In the **Web Template Database** section enter the parameters for connecting to the database server.
   - **Hostname**: The IP address or host name of the computer on which the database is stored.
   - **Port**: The port used to connect to the database server. The default for MySQL/mariaDB is **3306**.
   - **Username**: Leave the default username as is.
   - **Password**: Leave the default password as is.

   The **Username** and **Password** are used to access the database.

2. If you are using a remote template server, select the **Access Remote Template Server** checkbox and then click the **Browse** button to navigate to the location of the **Config File** that identifies the server.

3. In the **Web Server Details** section enter the parameters for communicating with the Apache web server.
   - The **WS Client Port** is the port on which the web server and client communicate. The default **Client Port** is **8877**.
   - Select the **SSL** checkbox to enable the Secure Socket Layer protocol (optional).
     If you select the **SSL** checkbox, you will also need to change the **Application Port** in the Web Gateway section to **443**.
     See “**Appendix B: Managing Network Security**” on page B–1 for more information.
   - Click the **Browse** button beside the **Preview Folder** field to navigate to the location where XPression Maps will create the preview video clips and from which the web server will stream the clips to the clients.
4. In the **Web Gateway** section, enter the parameters for communicating with the gateway.
   - The **Server Name** field is the same as the **Hostname** in the **Web Template Database** section.
   - The **Application Port** field is the port on which the server and gateway communicate.
   The default **Application Port** is **9977**.

5. In the **Output** section enter the parameters for the final clip generation.
   a. From the **Format** drop-down, select the **AVI** format (if it is not already selected).
      If you are changing the format from ffmpeg to AVI, a dialog box opens asking you to update the file format.

      ![Update File Format](image)
      \(\text{Figure 3.4 Update Format File to AVI Dialog}\)

   b. Click **Creating AVI File** to create the file.
      The **Video Compression** dialog opens.

      ![Video Compression](image)
      \(\text{Figure 3.5 Video Compression Dialog}\)

   c. Select the **XPression Video Codec** and click **OK**.
      The **Save Format File** window opens.

      ![Save Format File](image)
      \(\text{Figure 3.6 Save Format File}\)
By default, the **File name** field will be populated with **AVICodec.bin**.

d. Click **Save** to save this format file.

   In the **Web Interface** tab, the **Format File** field will be automatically populated with the path to the codec file.

e. Click the **Browse** button beside the **Final Clip Folder** field to navigate to the folder where the video clips will be stored.

f. In the **Max Clip Space** field, enter or use the arrows to select the amount of system disk space, in GBs, which can be used before the automatic cleanup mechanism starts to free up disk space by erasing the loaded clips.

g. Click the **Browse** button beside the **Preview Format File** field to navigate to the **Web Service Video Format File** folder to select the type of video format file you want.

h. Select the **Clip Copy to Hotfolder** checkbox, if you want to store your clips in a separate folder.

i. In the **Hotfolder** field, click the **Browse** button to navigate to the folder in which to store your clips.

**To save your configuration:**

• At the bottom of the **Web Interface** tab, click **Save** and then click **OK**.
Connection

In the Connection tab you can define the map tile download and change the position and style of the Bing Map logo in the output window.

![Figure 3.7 Preferences - Connection Tab](image)

To define the map tile download:

1. In the Bing Map Access section, enter the Application Key to define the Bing Map download account.
   
   All customers need a Bing Maps application key. This may have been set up already by your commissioning team. If not, see the document Using Bing Maps in XPression Maps in the in C:\Archives folder on your desktop for instructions on setting up a Bing Maps account and getting an application key.
   
   The Account ID and Account Email fields are optional and are provided for you to keep track of the Bing Maps account and email address under which the application key is running.

2. Click the Validate Key button.

3. If the key is valid, the text on the button turns green and says "Key is Valid".
   
   • If the key is invalid, the Bing Map Application Key Validation dialog opens requesting that a valid key be entered.
   • To remove the key, select and delete it.
   • Editing the field will invalidate the key.
   • In the case of an invalid or non-existent key, the integrated XPression Maps Bing account will be used. This account is suitable for set up, testing, training, etc. but not for broadcast.
4. In the Bing Map Logo section, enter or use the arrows to select a value to determine whether to use the Bing logo or an English or German credit string.
   
   The options are:
   
   0 = Bing logo
   1 = Source: Bing™
   2 = Quelle: Bing™

5. In the Mode section, select the Offline checkbox to use the application without downloading new map tiles from the server.

   **To save your configuration:**

   • At the bottom of the Connection tab, click **Save** and then click **OK**.
The XPression Maps software requires access to the Internet to function properly. If your organization uses an Internet proxy server, enter information about your organization's proxy server in this tab.

Consult your local IT administrator for the proxy server access information.

To connect the Maps application to the Internet through a proxy server:

1. In the **Hostname** field, enter the IP address of the proxy server.
2. In the **Port** field, enter the port number over which the application and server will communicate.
3. In the **Username** field, enter a user name for the proxy server.
4. In the **Password** field, enter a password for the proxy server.

To save your configuration:

- At the bottom of the **Proxy** tab, click **Save** and then click **OK**.
Dynamic Data (Optional)

If you have purchased the Dynamic Data feature, this tab will appear in Preferences.

In the Dynamic Data tab you can specify the location of the folder where the following information is stored:

- **Query Folder**: contains files with the data that will be generated when you add a Dynamic Data drawing to your scene
- **Layout Folder**: contains files that specify the layout of the data that is generated

![Figure 3.9 Preferences - Dynamic Data Tab](image)

To specify which query and layout files to use:

1. In the **Query Folder** section, click the **Browse** button beside the **Folder** field and navigate to the folder from which you want to get the dynamic data information.
   - The default location is `C:\XPressionMaps\DDQueries`.
2. In the **Layout Folder** section, click the **Browse** button beside the **Folder** field and navigate to the folder from which you want to get the dynamic data layouts.
   - The default location is `C:\XPressionMaps\DDLayouts`.

To save your configuration:

- At the bottom of the Dynamic Data tab, click **Save** and then click **OK**.
Control

In the Control tab you can specify the port numbers for the external Telnet commands and touch control commands.

To specify port numbers:

1. In the Telnet Control section, in the Port field, enter the number of the port that will be used to listen for external Telnet commands.
   The default port is 9900.
2. In the Touch Control section, in the Port field, enter the number of the port that will be used to listen for touch commands.
   The default port is 7077.

To save your configuration:

- At the bottom of the Control tab, click Save and then OK.
Video I/O (Optional)

Video Inputs and outputs are functions enabled by a variety of licensing options and may not be present in your configuration.

If you do have this feature, you can configure the video inputs and outputs as either SDI or NDI. The number of Inputs will be limited to a total of four and can be mixed between HD-SDI or NDI™ sources. The number of outputs is limited to two, and can be configured as a Video and Alpha pair.

![Figure 3.11 Preferences - Video I/O Tab](image)

To configure an SDI video output:

1. In the Video Output - SDI section, select the Enable checkbox, if you are using an SDI output.
2. Select the Enable Key checkbox if you want to see the Key image in the output.
   The Key image is automatically put on the next frame buffer above the one used for the output (ie on frame buffer 4 if the output is on frame buffer 3).
3. From the Device drop-down, select the video card in your XPression Maps hardware.
4. From the Reference drop-down, select one of the following options:
   • The FREERUN reference (used for testing)
   • An external reference (REF).
   • Sync with the corresponding video input.
5. From the Test Pattern drop-down, select any of a number of different patterns, if you want to see a test pattern in the output (for testing purposes) or select OFF for on air viewing.

To configure an NDI video output:

1. In the Video Output - NDI section, select the Enable checkbox, if you are using an NDI output.
2. In the Stream Name field, enter the streaming service being used.
   The default service is Maps NDI Stream.
3. Select the Send Alpha checkbox, if you want to see the Alpha image in the output.
To configure video inputs:

1. In the Video Input section, for each input, use the drop-down to select whether that input is Disabled or is an SDI or NDI input.
   If you select either SDI or NDI, you will see additional parameters for each input.
2. For an SDI input:
   • From the Device drop-down, select the video source for the input.
   • In the Buffer field, enter a value or use the arrows to select which frame buffer to use?
3. For an NDI input, use the drop-down to select the Name of the input source.

To save your configuration:

• At the bottom of the Video I/O tab, click Save and then click OK.
Interactive (Optional)

The Interactive tab is included in Preferences if you have licensed this option. In this tab, you can configure the locations for interactive scripts and project folders, startup behavior, the connection to the XPression Maps HTML5 Client and the connection to the scene database.

There is also a section called Advanced Script Mode, which should only be used by technical support personnel. Leave this checkbox empty.

To configure:

1. In the Scripts section, use the Browse button to the right of the Folder field to change the location for the Scripts folder.
   The default location is C:/XpressionMaps_3.x/Interactive. There is no need to change this folder.
2. In the Project section, use the Browse button to the right of the Main Folder field to change the location for the Projects folder.
   The default location is C:/XpressionMaps_3.x/Projects.
3. Select the Startup options.
   - Select the Load Last Project checkbox if you want your current project to be loaded automatically the next time you launch XPression Maps (optional).
   - Select the Fullscreen checkbox to display the project at fullscreen when it is launched (optional). Typically, you would launch the project at fullscreen only when it is complete and ready for air.
4. Enter the parameters for the Browser Interface.
   - In the Hostname field, enter the IP address or computer name of the PC on which the XPression Maps HTML5 Client is running.
   - The UI Port is the port that is used to access the Web browser.
   The default UI Port is 8880.
• The **Data Port** is the port through which the main application and the Touch Client communicate. The default **Data Port** is 7770.

• The **Folder** field contains the path to the folder in which the interactive interface elements are stored. There is no need to change this folder.

• Select the **Use SSL** checkbox to enable the Secure Socket Layer protocol (optional). If you select the **SSL** checkbox, you will also need to change the **Application Port** in the **Web Interface** tab, in the Web Gateway section to **443**.

  See “Appendix B: Managing Network Security” on page B–1 for more information.

5. In the **Scene Database** section, enter the parameters for connecting to the database server.

• **Hostname**: The IP address or computer name of the computer on which the database is stored.

• **Port**: The port used to connect to the database server.

  The default port is **3306**.

• **Username**: Replace the default username with one of your own choosing.

• **Password**: Replace the default password with one that conforms to your IT policy.

**To save your configuration:**

• At the bottom of the **Interactive** tab, click **Save** and then click **OK**.
Tools

XPRESSION Maps contains a number of operational and informational tools, as described in the following sections:

- “Undoing a Stack” on page 4–2
- “Measuring Distances” on page 4–3
- “Reloading the Active Map” on page 4–4
- “Selecting the Edit Mode” on page 4–4
- “Undoing/Redoing Operations” on page 4–5
- “Taking Snapshots” on page 4–5
- “Exporting Maps” on page 4–6
- “View Menu” on page 4–7
- “Help Menu” on page 4–7
- “Log Information” on page 4–8
- “Download Information” on page 4–9
Undoing a Stack

XPression Maps keeps a list of the commands that have been performed in a scene, called a “stack”. At any point, you can go back to a previous command and effectively undo the commands that followed it. This is useful if you want to undo many moves, as it is faster than using the Undo menu command or icon to remove each individual step.

To undo a stack:

1. Click Edit > Undo Stack in the menu bar.

   The Undo Command List dialog opens. The first command is at the top of the list. The most recent command is at the bottom of the list.

   ![Figure 4.1 Undo Stack](image)

2. Click the last command you want to keep to select it.

   You may need to use the scroll bar on the right, to find the command you want, if the stack is long.

   The commands following the selected command will be removed from the scene, but will remain in the stack.

   ![Figure 4.2](image)

3. Select a command further down in the list to restore commands that you have undone, if necessary.

4. Click the X in the top-right corner of the dialog to close it.
Measuring Distances

The Measurement Tool allows you to calculate the distance between 2 points on the map and add a text drawing to display the result.

You can also use the tool to display an area of interest of a specific circumference, for example, the extent of shockwaves of an earthquake.

The distance can be calculated in either the Metric or Imperial measurement system

To use the Measurement Tool:

1. Click Edit > Measurement Tool.
   Alternatively, you can click the Measurement Tool button in the toolbar.

Figure 4.3 XPression Maps Toolbar - Measurement Tool

The Measurement Tool opens.

Figure 4.4 Measurement Tool

2. Select the Show Circle checkbox to display a circle whose radius is determined by the distance between two locations or by the size of the area of interest (optional).

3. From the Units drop-down, select whether to display the distance using the Metric or Imperial system.

4. Left-click on the starting location (represented in the Measurement Tool by the Head coordinates) and drag the cursor to the destination (represented by the Tail coordinates).
   A white circle is drawn on the map and the measurement is calculated and indicated along the straight line.

Figure 4.5 Measurement Tool Illustration - Calculation
5. In the **Drawing Toolbox**, in the **Text** group, click on a text drawing.

6. Then click on the white measurement text on the map.
   
   The measurement is automatically displayed in the text drawing, provided the **Zoom** level of the map is within the drawing **Visibility In** and **Out** parameters.

7. Adjust the location of the text drawing, if necessary.

8. To finish, click **Done**.
   
   The white circle, line and original measurement text are removed, leaving just the text drawing with the measurement and the **Measurement Tool** closes.

9. Add an area or custom drawing to illustrate an area if desired.

10. To start over, before clicking **Done**, click **Reset**.

### Reloading the Active Map

This feature is used to refresh the current map. This is useful if your scene is missing map tiles or displaying map tiles remaining from a previous map.

**To reload the active map:**

- Click **Edit > Reload Active Map**.

### Selecting the Edit Mode

The **Edit** option allows you to select one of the following modes:

- **Standard** - default mode for creating scenes
- **Presentation** - mode that allows one-touch zoom in and out, useful in full-screen presentations

The selected mode will be indicated with a checkmark.

**To select an Edit Mode:**

1. Click **Edit > Edit Mode**.
2. From the menu, select **Standard** or **Presentation**.
Undoing/Redoing Operations

You can undo an operation(s) or redo an operation that was undone, from the Edit menu or the toolbar.

To undo the last operation:

• Click Edit > Undo in the menu bar or click the Undo button in the toolbar or press Ctrl+Z.

![Figure 4.7 XPression Maps Toolbar - Undo](image)

To redo the last operation:

• Click Edit > Redo in the menu bar or click the Redo button in the toolbar or press Ctrl+Y.

![Figure 4.8 XPression Maps Toolbar - Redo](image)

Taking Snapshots

The Snapshot tool saves the content of the output window as a still image.

To take a snapshot:

1. Click Output > Snapshot in the menu bar or click the Snapshot button in the toolbar.

![Figure 4.9 XPression Maps Toolbar - Snapshot](image)

2. In the Save dialog, navigate to the folder in which you want to save the image file.
3. In the File name field, enter a name for the image file.
4. From the File Type drop-down, select the file format for your image.
   The options are .jpg, .png and .tga.
5. Click Save.
Exporting Maps

The Export Map feature allows you to write an .hdr file of a selected portion of the output. An .hdr file is a header file that stores the georeferencing information of an associated raster file.

Four files are created:

- a .png image containing the RGB information
- an .igb file containing the elevation data
- an .hdr file containing information about the boundaries of the exported map (minimum and maximum longitude and latitude coordinates), as well as information about the .igb file
- an _N.png image that shows the normals that are calculated out of the elevation data

You can export a newly created map or an existing one that has previously been exported.

To export a new map:

1. With a map displayed in the Output window, click Output > Export Map in the menu bar.
   
   The Export Map dialog opens.
   
   The camera projection type is set to Linear (a map with variables that change proportionally), the Tilt value of the camera is set to 0 and a bounding box marks the portion of the map that will be exported.
   
   When the Export Map dialog is closed, the camera projection type and tilt are reset and the bounding box is removed.

   ![Figure 4.10 Export Map](image)

2. Click and drag the corner points of the bounding box to expand or decrease the portion of the map to be exported.
   
   You can also right-click inside the bounding box and drag it to change the position of the box as a whole.

3. In the Export Map dialog, click the Browse button beside the Map Name field to navigate to the location to which you want to export the map file.

4. In the Export Map File file browser, enter a File name for the map and click Save.

5. In the Export Map dialog, in the Image section, select the Resolution in pixels.
   
   The options are:
   - 512
   - 1024
   - 2048
   - 3072
   - 4096
   
   The height of the exported image has the selected resolution. The width is calculated so that the aspect ratio is preserved.

6. Click Save to save the scene name, resolution and bounding box to disk.
   
   The Save File dialog opens.
7. Navigate to the folder where you want to save the Bounding Box file (the .xml file), enter a name in the File name field and click Save.

   The path to the Bounding Box file is entered into the Name field.

8. Click Export to export the files.

   This creates the export files and a bounding box file with the extension .xml.

   This might take some time. When the export is finished, the Export Map dialog closes.

   Clicking Cancel closes the Export Map dialog without creating the files.

To export an existing map:

1. Click Output > Export Map in the menu bar.

   The Export Map dialog opens.

   ![Export Map](image)

   **Figure 4.11 Export Map**

2. Click Load and in the Bounding File file explorer, select the file to load and click Open.

   The associated .hdr file name appears in the Map Name field and the .xml file appears in the Name field of the Bounding Box section.

3. Then click Export.

View Menu

The View menu contains options for changing the output window to fullscreen mode and for showing or hiding the various editors, controls and toolbars.

To change to fullscreen mode:

- Click View > FullScreen in the menu bar.

To change to windowed mode:

- Press the Esc key.

To show or hide an editor, control or toolbar:

1. Click View in the menu bar.

2. In the menu, check the options you want to show and clear the options you don’t require.

Help Menu

The Help menu contains the About screen which provides version, copyright and licensing information for the XPression Maps application.
Log Information

The Log Information window displays information based on the Log Level selected. You can also clear the display when the information is no longer of use to you.

![Log Information Window](image)

**Figure 4.12 Log Information Window**

To select the level of information you want displayed:

- In the Log Information section, from the Log Level drop-down, select the level of information you want to see generated.

  The options are:
  - **Critical** - Logs activity that could result in unpredictable behavior.
  - **Error** - Logs errors only.
  - **Warning** - Logs unsuccessful operations.
  - **Information** - For internal use only, for technical support.
  - **Debug** - For internal use only, for technical support.

To clear the log information:

- Click the Clear button.
Download Information

The Download Information window displays the map download activity.

Map requests are scheduled for download and up to 30 map downloads can be active at the same time. The progress bar in the window displays how many map parts remain to be downloaded. The progress bar can display the following colors:

- **Green** — low load
- **Orange** — all download links in use
- **Red** — high load

Values higher than 100 on the progress bar can result when you play a camera animation for the first time, when the quality of the map has a value greater than 0, or when the globe is tilted to a small viewing angle.

* Zooming in from the satellite view to the street level view of a city will go through many map zoom levels and all visible map parts need to be downloaded first.
Map Styles

In XPression Maps, the handling of the maps is based on the structure delivered by Bing maps. Maps in Bing are images with seamless tiles with a size of 256 x 256 pixels each. The tiles are available in 21 quality/zoom levels. The first level shows the full map of the earth on 1 tile. Each next level will divide the content of a tile into four sections of 256 x 256 pixels, so the quality of the content is doubled in the X and Y coordinates for each level. Depending on the map quality in the Bing database, this process stops in higher quality levels and the best possible quality image is used.

XPression Maps uses Bing maps, the Blue Marble map from NASA and OpenStreetMaps. You can select a map style from the default styles provided or create your own.

You can select different map styles in the Map Styles tab and edit map styles in the Map Style Manager. The properties are described in the Map Style Properties section.

The following topics are discussed in this section:

- “Using Map Styles” on page 5–2
- “Editing Map Styles” on page 5–6
- “Map Style Properties” on page 5–10
Using Map Styles

A different map style can be selected without changing any of the other elements of a scene. You can select map styles that will change during animation in one of two ways:

- **Animated**: Predefined map styles appear as specified by key frames.
- **Automatic**: Specified map styles appear at different zoom levels.

**Animated Map Style**

Use the **Animated Map** style to create a scene in which the map style changes at set points in the timeline, specified by key frames.

To use an animated map style:

1. In the **Map Styles** section to the right of the **Output** window, select the **Animated** radio button, if it’s not already selected.

   ![Figure 5.1 Map Styles - Animated Option](image)

2. In the **Search Editor**, enter the location at which you want to animate the map and click **Search** or press the **Enter** key.

   ![Figure 5.2 Enter Location](image)

3. In the **Map Styles** section, from the **Style** drop-down, select the map style for the beginning of the animation.

   ![Figure 5.3 Map Styles - Select Style](image)

4. From the camera parameters below the **Output** window, select a starting **Zoom Level**.

   ![Figure 5.4 Camera Parameters - Zoom Level](image)
5. With the timeline slider at the beginning of the timeline, click the radio button to the right of the **Style** drop-down to key frame the starting map style.

![Map Style Key Frame](image)

**Figure 5.5 Map Style Key Frame**

6. Then click the **Add Camera Key Frame** button to key frame the starting zoom level.

![Add Camera Key Frame](image)

**Figure 5.6 Add Camera Key Frame**

7. Move the timeline slider to the point in the timeline at which you want to change the map style.
   Alternatively, you can click on any point in the timeline to move the slider to that point or enter the position in the frame counter to the left of the timeline.

![Frame Counter](image)

**Figure 5.7 Frame Counter**

8. From the **Style** drop-down, select the next map style you want to apply to your scene.

9. From the camera parameters below the **Output** window, select a **Zoom Level** for the new map style.

10. In the **Map Styles** section, click the radio button to the right of the **Style** drop-down to key frame the new map style.

11. Click the **Add Camera Key Frame** to key frame the new zoom level.

12. Click the green **Play** button in the animation toolbar to play the animation.

**Automatic Map Style**

Use the **Automatic Map** style to create a scene in which the map style changes at specified zoom levels.

**To use an automatic map style:**

1. In the **Map Styles** section to the right of the **Output** window, select the **Automatic** radio button.

   ![Map Styles Tab - Automatic Option](image)

**Figure 5.8 Map Styles Tab - Automatic Option**

2. Move the map in the **Output** window to the location that you want to show.
   Alternatively, in the **Search Editor**, enter a location in the **Location / Address, City, Country** field and click **Search**.

3. Click the **Editor** button that appears beside the **Style** selector.
   The **Map Layer Manager** opens.
4. Click **Add** to add a new layer.
   
   Each layer represents a point at which the map style will change.
   
   By default, the current map style will be entered for the new layer along with a default zoom level of 20.

5. In the **Name** column, double-click **New Layer** and give the layer a meaningful name.
   
   This could be the name of the country or the area of the map that you want to display at the selected **Zoom** level.

6. In the **Style** column, double-click the map style and from the drop-down, select the style of map you want to apply to the layer. See “Editing Map Styles” on page 5–6 for more information.

7. In the **Zoom** column, double-click the default **Zoom** level and enter a value or click the arrows to select the **Zoom** level to apply to the layer.
   
   ★ The table is ordered by ascending **Zoom** levels, so a change in the **Zoom** value can result in a reordering of the layers.

8. Repeat steps 2 to 6 to add additional layers and then click **Done** to close the **Map Layer Manager**.
   
   During animation, as each **Zoom** level is reached, the map style will change according to the table.

9. Click **File > Save** to save the scene.
10. Create an animation that uses the zoom levels added to the **Map Layer Manager**.
11. Click the green **Play** button in the animation toolbar to play the animation.

**To delete a map layer:**

1. Click the **Editor** button that appears beside the **Style** selector to open the **Map Layer Manager**.
2. In the **Map Layer Manager**, select the layer you want to delete and click **Delete**.
   
   The **Delete Map Layer** confirmation dialog opens.

   ![Delete Map Layer](image)

   **Do you want to delete the selected layer [Start]?**
   
   - **Yes**
   - **No**

3. In the **Delete Map Layer** confirmation dialog, click **Yes**.
4. When you have finished deleting layers, click **Done** to close the **Map Layer Manager**.
Editing Map Styles

In the **Map Style Manager**, shown below, you can add and delete map styles and edit an existing map style.

![Map Style Manager](image)

*Figure 5.11* **Map Style Manager**

There are system map styles available that can be used as they are or can be modified to create a new map style. The system map styles are:

- Bing Aerial
- Bing Aerial Label
- Bing Aerial Label Mercator
- Bing Aerial Mercator
- Bing Road
- Bing Road Dark
- Bing Road Gray
- Bing Road Light
- Blue Marble Colored
- Blue Marble Colored Mercator Styled
- Blue Marble Satellite
- None
- OSM-Basic*
- OSM-Basic Aerial*
- OSM-Basic Shadow*
- OSM-Custom Example*
- OSM-Style-A*
- OSM-Style-A Aerial*
- OSM-Style-B*
- OSM-Style-B 3D Building*
- OSM-Style-B Aerial*

* OpenStreetMap

If **Compact Scene on Save** is selected in the **Output** tab in **File > Preferences**, all unused styles in the map style list and in the shape style list are removed.
To add a new map style:

1. Click **Style > Map Styles** to open the **Map Style Manager**. Alternatively, you can click the **Map Styles** button in the toolbar.

   ![Figure 5.12 XPression Maps Toolbar - Map Styles](image)

2. Click **Add**. The **Add Map Style** dialog opens.

   ![Figure 5.13 Map Style Manager - Add Map Style](image)

3. In the **Name** field, enter a name for the new map style.

4. From the **Copy from** drop-down, select one of the existing map styles to use as a base for the new map style and click **OK**. The **Edit Map Style** editor opens.

   ![Figure 5.14 Edit Map Style Editor](image)
5. Modify the properties of the new map style and click OK.
   See “Map Style Properties” on page 5–10 for information about modifying the properties.
   The new map style appears in the Map Style Manager with the Save Style icon beside it.

6. Click the Save Style icon.
   The Save Map Style confirmation dialog opens.
   
   ![Save Map Style Confirmation Dialog](image)
   
   **Figure 5.15** Save Map Style Confirmation Dialog

7. Click Yes to save your new map style into the database.

To delete a map style:

1. Click Style > Map Styles to open the Map Style Manager.
2. Select the map style you want to delete and click Delete.
   The system map styles cannot be deleted. Only custom map styles can be deleted.
   The Delete Map Style confirmation dialog opens.
   
   ![Delete Map Style Confirmation Dialog](image)
   
   **Figure 5.16** Delete Map Style Confirmation Dialog

3. In the Delete Map Style confirmation dialog, click Yes to delete the map style.
To edit an existing map style:

1. Click **Style > Map Styles** to open the **Map Style Manager**.
2. Select the map style you want to modify and click **Edit** or double-click the selected map style. The **Edit Map Style** editor opens.

![Image of Edit Map Style Editor](image)

**Figure 5.17 Edit Map Style Editor**

3. Modify the properties of the map style and click **OK**. See “**Map Style Properties**” on page 5–10 for more information.

The **Edit Map Style** dialog box closes and the **Map Style Manager** reopens. The edited style is highlighted and the **Save** icon and **Reset** icon are displayed beside it.

4. Click the **Save** icon if you want to save your changes into the default database or click the **Reset** icon to discard your changes and revert to the last saved version of the style. Then click **Done** to close the **Map Style Manager**.

An exclamation mark at the left of the map style indicates that the style is saved in the scene but not in the database. That style will not be available to be used in other scenes.

The **Save All** button at the bottom of the dialog box saves all changes made to all styles in the database.

The **Reset All** button at the bottom of the dialog box resets all styles in the database to their last saved version.
Map Style Properties

Many of the properties of map styles can be customized for a different look. Properties such as map type, brightness, country borders, light direction and mountain height can be edited in the Edit Map Style dialog. These properties and others are described in the sections below:

- “Main” on page 5–10
- “Options” on page 5–11
- “Overlay” on page 5–11
- “Custom Data” on page 5–12
- “Light” on page 5–12
- “3D” on page 5–13
- “Color Map” on page 5–14

Main

Use the Main section to change the Map Type and Projection. The Name is derived from the style selected in the Map Styles > Style drop-down.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name assigned to the map style. System style names cannot be edited. If you’ve created your own map style, you’ll be able to change the name if you want.</td>
</tr>
<tr>
<td>Map Type</td>
<td>The style type of the map. System style types cannot be edited. The available map types are as follows:</td>
</tr>
<tr>
<td></td>
<td>• None — this style removes the map from the output. It can be used to show free-standing colored country shapes and drawings on a background image.</td>
</tr>
<tr>
<td></td>
<td>• Bing Aerial — this style displays satellite maps from Bing. You can zoom into street level. The Bing logo appears in the output.</td>
</tr>
<tr>
<td></td>
<td>• Bing Aerial with Label — this style displays satellite or structural maps from Bing with country, city, and road information on top of the maps. You can zoom into street level. The Bing logo appears in the output.</td>
</tr>
<tr>
<td></td>
<td>• Bing Road — this style displays road maps from Bing in color. You can zoom into street level. The Bing logo appears in the output.</td>
</tr>
<tr>
<td></td>
<td>• Blue Marble Satellite — this style shows the topographic world image from the NASA Blue Marble image gallery. The resolution of this map is reduced to 500m/px. No logo will be shown in the output.</td>
</tr>
<tr>
<td></td>
<td>• Blue Marble Colored — this style displays a colored map generated from the Blue Marble height model and a color table. It displays selected elevations in different colors. See “Color Map” on page 5–14 for more information.</td>
</tr>
<tr>
<td></td>
<td>• Bing Road Dark — this style displays road maps from Bing on a dark canvas, useful for highlighting data. You can zoom into street level. The Bing logo appears in the output.</td>
</tr>
<tr>
<td></td>
<td>• Bing Road Gray — this style displays road maps from Bing on a grayscale canvas, useful for highlighting data. You can zoom into street level. The Bing logo appears in the output.</td>
</tr>
<tr>
<td></td>
<td>• Bing Road Light — this style displays road maps from Bing on a light canvas, useful for highlighting data. You can zoom into street level. The Bing logo appears in the output.</td>
</tr>
<tr>
<td></td>
<td>• VT (Vector Tiles) OSM Basic — this style is based on Open Street Map data.</td>
</tr>
<tr>
<td></td>
<td>• VT (Vector Tiles) OSM Style A — this style is based on Open Street Map data.</td>
</tr>
<tr>
<td></td>
<td>• VT (Vector Tiles) OSM Style B — this style is based on Open Street Map data.</td>
</tr>
<tr>
<td>Projection</td>
<td>Defines the projection type of the map. Select one of the following options:</td>
</tr>
<tr>
<td></td>
<td>• Sphere — uses a round shape like a globe</td>
</tr>
<tr>
<td></td>
<td>• Mercator — uses a cylindrical map projection</td>
</tr>
<tr>
<td></td>
<td>• Linear — uses a map with variables that change proportionally</td>
</tr>
</tbody>
</table>
Once the external map tile server is configured (OpenStreetMap server), new map types that correspond to the configuration will be displayed.

Options
Use the Options section to adjust the general appearance of a map style.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quality</td>
<td>Increases or decreases the amount of image content and Zoom level for a map style.</td>
</tr>
<tr>
<td></td>
<td>- 0: Normal</td>
</tr>
<tr>
<td></td>
<td>- 1: Increases the Zoom level by 1 and downloads 3 times more image content than normal. Labels on Bing Aerial and Bing Road maps will be smaller. The available quality range is -3 to 3.</td>
</tr>
<tr>
<td></td>
<td>- -1: Decreases the Zoom level by 1 and downloads 3 times less image content than normal. Labels on Bing Aerial and Bing Road maps will be larger. The available quality range is -3 to 3.</td>
</tr>
<tr>
<td>Brightness</td>
<td>Increases or decreases the brightness level for the map style.</td>
</tr>
<tr>
<td>Gamma</td>
<td>Increases or decreases the gamma level for the map style.</td>
</tr>
<tr>
<td>Contrast</td>
<td>Increases or decreases the contrast level for the map style.</td>
</tr>
</tbody>
</table>

Overlay
These parameters control the appearance of geographical elements such as country borders, country names, state borders, roads, rivers, lakes, and oceans. Also, a full raster image (a fullscreen image that lies on top of the globe and has some transparent part) can be defined. The location and spelling of the country names can be set through the Shape Database Viewer.

See the “Shape Database Viewer” on page 9–30 for more information.

To configure the overlay parameters:

1. Select the checkbox of the geographical element(s) you want to include in the map.
2. For Country Borders, Country Names, State Borders and Rivers, enter or select a value for the line width or font size using the field next to the selected element. Valid values are 0.10 to 10.00.
3. Click the Color button to select a color for the element.
4. From the Name Style drop-down, select the style in which you want the names of countries, states and regions to appear.
5. For Lakes and Ocean Mask, select the checkbox and click the Color button to select a color for the element. If you want to use the Apply Ocean Mask feature to hide the parts of a shape that extend into the ocean, the Ocean Mask checkbox needs to be selected.
6. If you want to use a raster image to create a border around the map, select the checkbox for Full Raster Image and then select a background image from the drop-down. The background image needs to have a transparent section in the middle for the map to show through.
7. For the **Overlay Layers**, select an overlay type from the drop-down.

   A preset overlay of the layers (each using different colors, icons, etc.) is superimposed on the selected map style.

   The options are:
   - VT OSM Basic Trans
   - VT OSM Style A Trans
   - VT OSM Style B Trans

**Custom Data**

In the **Custom Data** section, satellite and elevation maps that have been imported in the **Custom > Custom Maps** editor can be selected. If enabled, they are drawn on top of the regular (Bing or Blue Marble) maps, ensuring that there are no missing areas. The parameters in the **Custom Data** section are only available when a custom map has been selected.

**To configure the custom data parameters:**

1. Select **Style > Map Styles**, and in the **Map Style Manager**, select the map style for which you want to add a custom map.

   OR

   Create a new map style with your custom map. See "**To add a new map style:**" on page 5–7.

2. Click **Edit**.

3. In the **Custom Data** section:
   - To use a custom map, select the **Map** checkbox and from the corresponding drop-down, select the custom satellite map you want to use.
   - To use an elevation map, select the **Elevation** checkbox and from the corresponding drop-down, select the elevation map you want to use.

**Light**

Use this section to edit the parameters for the lighting on the map.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Light Direction Longitude</strong></td>
<td>Enter or select the longitudinal direction for the light on the map. This parameter only takes effect if <strong>Shading</strong> or <strong>Height Shading</strong> are selected.</td>
</tr>
<tr>
<td><strong>Light Direction Latitude</strong></td>
<td>Enter or select the latitudinal direction for the light on the map. This parameter only takes effect if <strong>Shading</strong> or <strong>Height Shading</strong> are selected.</td>
</tr>
<tr>
<td><strong>Shading</strong></td>
<td>Select this checkbox to enable shading on the map. The <strong>Shading</strong> function activates a rendering mode that lights the globe with a spotlight from the light direction to simulate the look of sunlight. The <strong>Intensity</strong> and <strong>Blending</strong> parameters work together to define the spotlight:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Intensity</strong> — increases or decreases the intensity of the spotlight. With <strong>Blending</strong> set to 100, a value of 0.05 will create a small intense spotlight, while a value of 1 or more will create a large, more diffuse spotlight. As you lower the <strong>Blending</strong> value, the spotlight becomes less noticeable. Range is 0 to 10.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Blending</strong> — increases or decreases the amount of shading around the spotlight. A value of 0 displays no shading and the globe looks the same as if <strong>Shading</strong> was disabled. A value of 100 will provide a large amount of shade, making the spotlight more noticeable.</td>
</tr>
</tbody>
</table>
The 3D section allows you to create a real three dimensional surface of the world generated from the Blue Marble map type height data.

### Parameter Description

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Height Shading</strong></td>
<td>Select this checkbox to enable height shading on the map. <strong>Height Shading</strong> makes the elevated areas of the map more noticeable. The following parameters adjust the height shading appearance:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Blending</strong> — increases or decreases the amount of relief that is displayed. A value of 0 shows no relief and a value of 100 shows complete relief.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Diffuse Factor</strong> — enter or select an amount to define how the light will affect the parts of the relief away from the sun. A value of 0 will result in a black color for the affected areas of the map and a value of 100 will result in a shiny white color for the affected areas of the map. The second parameter for the <strong>Diffuse Factor</strong> defines an offset to the relief as whole. For a value of 0, some parts of the relief will be totally black. A value of 100 makes the relief totally white.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Specular Factor</strong> — determines how the light will affect the parts of the relief on which the sun shines directly. A value of 0 will result in a black color for the affected areas of the map and a value of 100 will result in a shiny white color for the affected areas of the map.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Min. Clamp</strong> — enter or select an amount of shading relief used at locations where the height is equal to or greater than the value of <strong>Min. Clamp</strong>. The value 0 corresponds to sea level. This parameter only applies to the Blue Marble Colored map type.</td>
</tr>
<tr>
<td><strong>Mountain Height</strong></td>
<td>Enter or select a scale factor for the height data to make mountains appear higher or lower than normal. A value of 1 corresponds to the correct height. For street level views, the height is interpolated to 0 because the resolution of Blue Marble height data is not sufficient.</td>
</tr>
</tbody>
</table>

3D

The 3D section allows you to create a real three dimensional surface of the world generated from the Blue Marble map type height data.
Color Map

This section applies to Blue Marble Colored map types only.

Use this section to add, edit, and delete color maps for a style. A color map is a table of height values and colors that will graphically show elevation data in a map.

To add a new color map:

1. Click Style > Map Styles to open the Map Style Manager.
2. Select the map style you want to edit (must be a Blue Marble Colored map style) and click Edit.
3. Then, in the Edit Map Style editor, in the Color Map section, click the A button.
The New Color Map dialog opens.

![New Color Map dialog](image)

**Figure 5.19 Add Color Map**

4. In the New Color Map dialog, enter a name for your new color map.

5. If you want to copy an existing color map to use as a template, from the Copy from drop-down, select the color map you want to copy.

There are several default color maps from which to choose: Default Color Map, OSM-Style-AStyled, and LightGrey. As you create new color maps, they will appear in the drop-down.

The Edit Color Map dialog box opens.

![Edit Color Map dialog](image)

**Figure 5.20 Edit Color Map**

6. In the Edit Color Map dialog, select a row and do any of the following:
   - Double-click a value in the Height column to change the elevation.
   - Click in any of the color columns to open the Select Color window and change the color of that elevation.
   - Click Add to duplicate the row and then edit the duplicate row.
   - Click Delete to remove the row.

   Any changes will cause a reordering of the table so that the height values are sorted in descending order.

7. When you are satisfied with how your color map looks, click OK to close the dialog.

8. In the Edit Map Style dialog, adjust the properties of the map style as described in “Map Style Properties” on page 5–10.

9. Then click OK to close the dialog.

10. In the Map Style Manager, click the Save button beside the map style you edited to save the new color map to the database.

11. In the Save Map Style confirmation dialog, click Yes and then click Done to close the Map Style Manager.
To edit the color map parameters:

1. Click Style > Map Styles to open the Map Style Manager.
2. Select the map style you want to edit (must be a Blue Marble Colored map style) and click Edit.
3. In the Edit Map Style dialog, in the Color Map section, from the Name drop-down, select the color map you want to edit.
4. Click the Edit button beside the Name drop-down to open the Edit Color Map editor and edit the selected color map as described in "To add a new color map:" on page 5–14.
5. When you have finished editing the color map, click OK.
6. In the Edit Map Style dialog, click OK to close the dialog.
7. In the Map Style Manager, click the Save button beside the edited map style to save the new color map to the database.
8. In the Save Style confirmation dialog, click Yes and then click Done to close the Map Style Manager.

To delete a color map:

1. Click Style > Map Styles to open the Map Style Manager.
2. Select any Blue Marble Colored map style and click Edit.
3. In the Edit Map Style dialog, in the Color Map section, from the Name drop-down, select the color map you want to delete.
4. Click the D button.

The Delete Color Map confirmation dialog appears.

5. Click Yes to delete the selected color map.
6. In the Edit Map Style dialog, click OK to close the dialog.
7. In the Map Style Manager, click the Save All button to save your change.
8. Then click Done to close the Map Style Manager.
Managing Templates

You can configure scene templates with location labels, drawings and shape styles to be available for use with the XPression Maps HTML5 Client, which is used in XPression NRCS MOS workflows and the XPression graphics designer. You can also organize the scene templates into groups to make them easier to find.

The templates are managed in the Scene Templates editor.

You must be running in Server Mode to use scene templates. See “Launching the HTML5 Client” on page 14–2 for instructions on changing the startup mode.

The following topics are discussed in this section:

• “Managing Scene Template Groups” on page 6–2
• “Managing Scene Templates” on page 6–5
• “Editing Saved Templates” on page 6–19
Managing Scene Template Groups

In the Scene Templates editor, you can add, edit and delete groups.

For information about adding, editing and deleting scene templates, see “Managing Scene Templates” on page 6–5.

To add a scene template group:

1. Click Output > Manage Templates in the menu bar or click the Manage Templates button in the toolbar.

![Figure 6.1 XPression Maps Toolbar - Manage Templates](image1)

The Scene Templates editor opens.

![Figure 6.2 Scene Templates Editor](image2)
2. In the Scene Templates editor, click the Browse button beside the Group drop-down.

The Template Groups dialog opens.

![Template Groups Dialog](image)

**Figure 6.3 Template Groups Dialog**

3. In the Template Groups dialog, in the Name field, enter a name for the new template group.
4. In the Description field, enter a description of the type of maps that will be saved in this group.
5. Then click Add.
6. Add scenes, location labels, drawings and shape styles to the new group.
7. Click Done to close the dialog.

To edit a scene template group:

1. Click Output > Manage Templates in the menu bar or click the Manage Templates button in the toolbar.

![XPression Maps Toolbar - Manage Templates](image)

**Figure 6.4 XPression Maps Toolbar - Manage Templates**

The Scene Templates editor opens.

2. In the Scene Templates editor, from the Group drop-down, select the scene template group you want to edit.
3. Click the Browse button beside the Group drop-down to open the Template Groups dialog.
4. In the Template Groups dialog, enter a new name for the group or edit the description.
5. Click Update.
6. Click Done to close the Scene Templates editor.

To delete a scene template group:

1. Click Output > Manage Templates in the menu bar or click the Manage Templates button in the toolbar.

![XPression Maps Toolbar - Manage Templates](image)

**Figure 6.5 XPression Maps Toolbar - Manage Templates**

The Scene Templates editor opens.

2. In the Scene Templates editor, from the Group drop-down, select the scene template group you want to delete.
3. Click the Browse button beside the Group drop-down to open the Template Groups dialog.
4. In the Template Groups dialog, click Delete.
5. In the **Delete Group** confirmation dialog, click **Yes** to delete the group and all templates in it.

6. Click **Done** to close the **Scene Templates** editor.
Managing Scene Templates

The **Scene Templates** editor lists the elements that are associated with each group and that will be available in the **HTML5 Client** editor. In the editor, you can add and delete scene templates or their associated elements and edit their details. You can also load templates, preparing them for use in the **HTML5 Client** editor.

The associated scene elements are described in the sections below:

- “**Scenes**” on page 6–6
- “**Adding Location Labels**” on page 6–10
- “**Adding Drawings**” on page 6–13
- “**Adding Shape Styles**” on page 6–15

For information about loading templates, see “**Loading Scene Templates**” on page 6–17.

For information about adding, editing and deleting groups, see “**Managing Scene Template Groups**” on page 6–2..
Scenes

In the Scenes tab, the available scene templates are listed by thumbnail, name and type. The Name and Description and a few other parameters can be edited in the Details side of the editor.

To add a new scene template:

1. Click Output > Manage Templates in the menu bar or click the Manage Templates button in the toolbar.

![Figure 6.6 XPression Maps Toolbar - Manage Templates]

The Scene Templates editor opens.

![Figure 6.7 Scene Templates Editor]

2. In the Scene Templates editor, from the Group drop-down, select the group to which you want to add a new scene template.
3. Click the Add Actual button to add the currently displayed scene.
   OR
   Click the Add button to navigate to a saved scene.
The WNM Scene File browser opens.

![WNM Scene File browser](image)

Figure 6.8 Scene File Selection

4. In the WNM Scene File browser, navigate to the folder where you have saved your scenes.

   By default, the WNM Scene File window opens to the C:\XPression Maps\Scene folder, where scenes are saved. If you are saving your scenes to a different folder, navigate to that location.

5. Select the scene from which you want to create a template and click Open.

   The scene is added to the top of the list in the Scenes tab and a thumbnail is displayed, along with the name and the Type.

   By default, the scene is added as a Video type. To switch to a Still type, in the Details section to the right of the Scenes list, select the Still As Default checkbox and click Update.

   You can reorder the list by clicking and dragging an item to another spot in the list.

6. Now you can edit the scene template details, add location labels, drawings or shapes styles to the template or click Done to close the Scene Templates editor.

To edit the scene template details:

1. Click Output > Manage Templates in the menu bar or click the Manage Templates button in the toolbar.

   ![XPression Maps Toolbar - Manage Templates](image)

   Figure 6.9 XPression Maps Toolbar - Manage Templates

   The Scene Templates editor opens.

2. In the Scene Templates editor, in the Scenes tab, select the scene template you want to edit.

3. In the Details section, edit the information as necessary:

   - Enter a new name for the scene in the Name field.
   - From the drop-down beside the Name field, select one of the following flight types:
     - User Defined - The template is animated. It must have a starting flight point. A flight point is automatically created if one does not exist. The duration of the flight is determined by the Flight End parameter and played out accordingly in the HTML5 Client application, when this template is used.
Automatic - The template is animated. It must have a starting flight point. A flight point is automatically created if one does not exist. The duration of the flight is the shortest possible time that the application can reasonably complete the flight during playout. The Flight Start and Clip Length parameters are respected, allowing for a set time for a static image to be displayed before and after the flight.

- In the Flight Start field, enter a value or use the arrows to select a time, in seconds that the clip will wait before the flight starts. By default this value is set to 1.00.
- In the Max. Flight End field, enter a value or use the arrows to select the point in the clip by which the flight needs to end.
- In the Clip Length field, enter a value or use the arrows to select the length of the clip, in seconds. The Clip Length value needs to be the same as or greater than the Max. Flight End value.
- Select the Still As Default checkbox to create a still image in the XPression Maps Client application.

OR

Deselect the Still As Default checkbox, to create a video (clip) in the XPression Maps Client application.

In Automatic videos, the animation will have the duration set in the Clip Length parameter. The flight to the location defined in the Client app will start after the number of seconds set in the Flight Start parameter and will end at latest after the number of seconds set in the Max. Flight End parameter. If the distance between the start and end flight points is short, the flight may finish earlier. The flight end location will be displayed for the duration set in the Clip Length parameter.

In User Defined videos, the animation will have the duration set in the Clip Length parameter. The flight to the location defined in the Client app will start after the number of seconds set in the Flight Start parameter and will end after the number of seconds set in the Flight End parameter. The flight end location will be displayed for the duration set in the Clip Length parameter.

4. Select the Use Scene Styles from Database checkbox, if you want the map style that’s currently saved in the database to be used, instead of the map style in the selected scene.

This parameter is only available if you have selected the Load Scene using map style from Map Style Database checkbox in File > Preferences > Output.

5. In the Description field, enter a description of the template.

6. Click Update to save the changes.

7. Click Done to close the Scene Templates editor.
To delete a scene:

1. Click **Output > Manage Templates** in the menu bar or click the **Manage Templates** button in the toolbar.

   ![XPression Maps Toolbar - Manage Templates](image1)

   **Figure 6.10** XPression Maps Toolbar - Manage Templates

   The **Scene Templates** editor opens.

2. In the **Scene Templates** editor, from the **Group** drop-down, select the group that contains the scene template you want to delete.

3. In the **Scenes** tab of the selected group, select the scene template you want to delete.

   ![Scene Templates - Scenes Tab](image2)

   **Figure 6.11** Scene Templates - Scenes Tab

4. Click **Remove** and in the **Remove Scene** confirmation dialog, click **Yes**.

   ![Remove Scene Confirmation Dialog](image3)

   **Figure 6.12** Remove Scene Confirmation Dialog

5. Click **Done** to close the **Scene Templates** editor.
Adding Location Labels

In the Location Labels tab, the available location labels for the selected group are listed by thumbnail, name, and type.

A location label is a text drawing with or without a defined marker image. This drawing will be used after a location search is made in the client and the text of the drawing will be populated with the location text.

To add a new location label:

1. Click Output > Manage Templates in the menu bar or click the Manage Templates button in the toolbar.

   ![Figure 6.13 XPression Maps Toolbar - Manage Templates](image)

   The Scene Templates editor opens.

2. In the Scene Templates editor, from the Group drop-down, select the group to which you want to add a location label.

3. In the Location Labels tab, click the Add button.

   ![Figure 6.14 Scene Templates - Location Labels Tab](image)
The **Add Location Label** editor opens.

![Add Location Label Editor](image)

**Figure 6.15 Add Location Label Editor**

4. In the **Add Location Label** editor, click the **Toolbox** drop-down and select the group that contains the drawing you want to use as a location label.

   Typically, text, icon and dynamic data drawings are used for location labels.

5. From the **Location Label** list, select the drawing that you want to add to the group and click **Add**.

   The new location label drawing is added to the list in the **Location Labels** tab and a thumbnail is displayed, along with the name and **Type**. This label will now be available for all scene templates in the current group.

   You can reorder the list by clicking and dragging an item to another spot in the list.

**To edit the location label details:**

1. Click **Output > Manage Templates** in the menu bar or click the **Manage Templates** button in the toolbar.

![XPression Maps Toolbar - Manage Templates](image)

**Figure 6.16 XPression Maps Toolbar - Manage Templates**

   The **Scene Templates** editor opens.

2. In the **Scene Templates** editor, from the **Group** drop-down, select the group that contains the location label you want to edit.

3. In the **Location Labels** tab, select the location label you want to edit.

4. In the **Details** section, edit the name or enter a new name for the location label.

5. Click **Update** to save the changes.

6. Click **Done** to close the **Scene Templates** editor.

**To delete a location label:**

1. Click **Output > Manage Templates** in the menu bar or click the **Manage Templates** button in the toolbar.

![XPression Maps Toolbar - Manage Templates](image)

**Figure 6.17 XPression Maps Toolbar - Manage Templates**
The **Scene Templates** editor opens.

2. In the **Scene Templates** editor, from the **Group** drop-down, select the group that contains the location label you want to delete.

3. In the **Location Labels** tab, select the location label you want to delete.

4. Click **Remove** and in the **Remove Location Label** confirmation dialog, click **Yes**.

5. Click **Done** to close the **Scene Templates** editor.
Adding Drawings
In the Drawings tab, the available drawings for the selected group are listed.

To add a new drawing:

1. Click Output > Manage Templates in the menu bar or click the Manage Templates button in the toolbar.

   ![Figure 6.18 XPression Maps Toolbar - Manage Templates]

   The Scene Templates editor opens.

2. In the Scene Templates editor, from the Group drop-down, select the group to which you want to add a drawing.

3. Click the Add button.

   The Add Drawing editor opens.

   ![Figure 6.19 Add Drawing Editor]

4. In the Add Drawing editor, click the Toolbox drop-down and select a drawing group.

5. From the Drawing list, select the drawing that you want to add to the group and click Add.

   The new drawing is added to the list in the Drawings tab and a thumbnail is displayed, along with the name and Type. This drawing will now be available for all scene templates in the current group.

   You can reorder the list by clicking and dragging an item to another spot in the list.

To edit the drawing details:

1. Click Output > Manage Templates in the menu bar or click the Manage Templates button in the toolbar.

   ![Figure 6.20 XPression Maps Toolbar - Manage Templates]

   The Scene Templates editor opens.

2. In the Scene Templates editor, from the Group drop-down, select the group that contains the drawing you want to edit.
3. In the Drawings tab, select the drawing you want to edit.
4. In the Details section, in the Name field, edit the name or enter a new name for the drawing.
5. Click Update to save the changes.
6. Click Done to close the Scene Templates editor.

To delete a drawing:

1. Click Output > Manage Templates to open the Scene Templates editor.
2. In the Scene Templates editor, from the Group drop-down, select the group that contains the drawing you want to delete.
3. In the Drawings tab, select the drawing you want to delete.
4. Click Remove and in the Remove Drawing confirmation dialog, click Yes.

![Remove Drawing Confirmation Dialog](image)

*Figure 6.21 Remove Drawing Confirmation Dialog*

5. Click Done to close the Scene Templates editor.
**Adding Shape Styles**

In the **Shape Styles** tab, the available shape styles for the selected group can be associated with the scene template group.

**To add a new shape style:**

1. Click **Output > Manage Templates** to open the **Scene Templates** editor.
2. In the **Scene Templates** editor, from the **Group** drop-down, select the group to which you want to add a shape style.
3. In the **Shape Styles** tab, click the **Add** button.

![Figure 6.22 Scene Templates - Shape Styles Tab](image)
The **Add Shape Style** editor opens.

![Add Shape Style Editor](image)

**Figure 6.23 Add Shape Style Editor**

4. In the **Add Shape Style** editor, select the shape style you want to add and click **Add**.

   The new shape style is added to the list in the **Shape Styles** tab. This shape will now be available for all scene templates in the current group.

   You can reorder the list by clicking and dragging an item to another spot in the list.

5. Click **Update** to save the changes.

6. Click **Done** to close the **Scene Templates** editor.

To **edit the shape style details:**

1. Click **Output > Manage Templates** in the menu bar or click the **Manage Templates** button in the toolbar.

   ![XPression Maps Toolbar - Manage Templates](image)

   **Figure 6.24 XPression Maps Toolbar - Manage Templates**

   The **Scene Templates** editor opens.

2. In the **Scene Templates** editor, from the **Group** drop-down, select the group that contains the shape style you want to edit.

3. In the **Shape Styles** tab, select the shape style you want to edit.

4. In the **Details** section, in the **Name** field, edit the name or enter a new name for the shape style

5. Click **Update** to save the changes.

6. Click **Done** to close the **Scene Templates** editor.

To **delete a shape style:**

1. Click **Output > Manage Templates** in the menu bar or click the **Manage Templates** button in the toolbar.

   ![XPression Maps Toolbar - Manage Templates](image)

   **Figure 6.25 XPression Maps Toolbar - Manage Templates**

   The **Scene Templates** editor opens.
2. In the **Scene Templates** editor, from the **Group** drop-down, select the group that contains the shape style you want to delete.

3. In the **Scene Templates** editor, in the **Shape Styles** tab, select the shape style you want to delete.

4. Click **Remove** and in the **Remove Shape Style** confirmation dialog, click **Yes**.

![Remove Shape Style Confirmation Dialog](image)

*Figure 6.26 Remove Shape Style Confirmation Dialog*

5. Click **Done** to close the **Scene Templates** editor.

**Loading Scene Templates**

When a scene is loaded to the database, it is prepared for use in the **HTML5 Client**. All camera key frames are deleted and if there are no flight points in the scene, **Start** and **Stop** flight points are added.

**To load a template:**

1. Click **Output > Manage Templates** in the menu bar or click the **Manage Templates** button in the toolbar.

![XPression Maps Toolbar - Manage Templates](image)

*Figure 6.27 XPression Maps Toolbar - Manage Templates*

The **Scene Templates** editor opens.

2. In the **Scene Templates** editor, from the **Group** drop-down, select the group that contains the scene template you want to load.

3. In the **Scenes** tab of the selected group, select the scene template you want to load.

4. Click **Load**.

The template is loaded into the database, the editor closes and the scene is visible in the output window. The icon in the menu bar is highlighted, indicating that the template can be edited.

**To save a loaded template after editing (Method 1):**

1. In the menu bar, click the **Save** icon.

A confirmation dialog opens asking if you want to save the edited scene back into the database as a template.

![Save Scene Back as Template Confirmation Dialog](image)

*Figure 6.28 Save Scene Back as Template Confirmation Dialog*

2. Click **Yes** to save it.

3. In the **Save** window, navigate to the folder where you want to save the template and enter a name for the scene.
   - Entering the original name will automatically overwrite the template in the **Scene Editor**.
   - Entering a different name will save it as a new scene, but you will then have to add it to the **Scene Editor** if you want it available for use in the **HTML5 Client**. See "To add a new scene template:" on page 6–6.

4. Then click **Save**.

The scene is added to the database as a template. The icon in the menu bar is no longer highlighted, as the scene can no longer be edited.
To save a loaded template after editing (Method 2):

1. In the menu bar, click the **Manage Templates** button in the menu bar.
   A confirmation dialog opens asking if you want to overwrite the last loaded scene in the database.

   ![Image: Overwrite Last Loaded Scene Confirmation Dialog]

   Figure 6.29 Overwrite Last Loaded Scene Confirmation Dialog

2. Click **Yes** to save it.
   The original template is overwritten and the edited template is available for use in the **HTML5 Client**.
Editing Saved Templates

Templates that have been saved in the XPression Maps HTML5 Client appear in the Saved Scene Templates editor. From the editor, you can load a saved template, make any necessary changes and then save.

1. Click Output > Edit Saved Templates in the menu bar or click the Edit Saved Templates button in the toolbar.

![Figure 6.30 XPression Maps Toolbar - Edit Saved Templates](image)

The Saved Scene Templates editor opens.

![Figure 6.31 Saved Scene Templates Editor](image)

2. Select the group containing the template you want to edit, then select the template and click Load.

When the template is loaded, the Edit Saved Templates button turns red, indicating that it can be edited.

![Figure 6.32 XPression Maps Toolbar - Edit Saved Templates Active](image)

3. Make any necessary changes to the template.

4. Then click the Save button in the menu bar.

A confirmation dialog opens asking if you want to save the scene back to the HTML5 Client.

![Figure 6.33 Save Scene in HTML5 Client](image)

5. If you want to make the edited template available in the the Web Client, click Yes.

OR

Click No to only save the template into your Scenes folder.
Drawing Management

Maps provides the ability to select drawings from a library, modify their properties and assign them to a group, using the Drawing Management Editor. These drawings can then be accessed from the Drawing Toolbox and added to a scene.

The following topics are discussed in this section:

• “Drawing Management Editor” on page 7–2
• “Managing Groups” on page 7–3
• “Managing Drawings” on page 7–5
Drawing Management Editor

The Drawing Management Editor shown below, is used to select, modify and manage drawings. You can also organize the drawings into groups.

![Drawing Management Editor](image)

**Figure 7.1** Drawing Management Editor
Managing Groups

The Drawing Management Editor comes with a predefined set of groups to which you can add drawings. You can also add a new group, rename a group or delete a groups you don’t need.

To add a group:

1. Select Edit > Manage Drawings to open the Drawing Management Editor.
2. At the bottom of the Group section on the left side, click the New button.
   The Add Group dialog opens.

   ![](image)

3. In the Group Name field, enter a name for the new group and click OK.
   The new group appears in the Name drop-down at the top of the Group section. Because it’s new, there are no drawings in it yet.

To rename a group:

1. Select Edit > Manage Drawings to open the Drawing Management Editor.
2. In the Group section on the left side, from the Name drop-down, select the group you want to rename.
3. At the bottom of the Group section, click Rename.
   The Change Group Name dialog opens.

   ![](image)

4. Enter a new name for the group and click OK.
   The new group name appears in the Name drop-down and contains the drawings that were in the old group, if there were any.

To delete a group:

1. Select Edit > Manage Drawings to open the Drawing Management Editor.
2. In the Group section on the left side, from the Name drop-down, select the group you want to delete.
3. At the bottom of the Group section, click Delete.
   The Delete Group confirmation dialog opens.

![Delete Group Confirmation](image)

Figure 7.4 Delete Group Confirmation

4. Click Yes.
   The group and all its drawings are deleted.
Managing Drawings

In the Drawing section of the Drawing Management Editor, you can add a new drawing, view and modify the properties of an existing drawing, copy a drawing and delete a drawing. The following types of drawings are available in the library:

- “Text and OSM Replacement Drawings” on page 7–8
- “Area Drawings” on page 7–20
- “Line Drawings” on page 7–22
- “Icon Drawings” on page 7–24
- “Magnifier Drawings” on page 7–27
- “Locator Drawings” on page 7–30
- “Dynamic Data Drawings” on page 7–33
- “Background Drawings” on page 7–36
- “Video Input Drawings” on page 7–37

To add a drawing:

1. Select Edit > Manage Drawings to open the Drawing Management Editor.
2. In the Group section on the left side, from the Name drop-down, select the group to which you want to add your drawing.
   
   If an appropriate group doesn’t already exist, you can add a new group. See “To add a group:” on page 7–3 for instructions.
3. In the Drawing section on the right side, click New at the bottom of the section.
   
   The New Drawing dialog opens.

   ![](New_Drawing.png)

   Figure 7.5 New Drawing

4. From the Select Drawing Type drop-down, select the type of drawing you want to add and click OK.
   
   The options are:
   
   - Text
   - Area
   - Line
   - Icon
   - Magnifier
   - Locator
   - Dynamic Data
   - Background
   - Video Input
The **Drawing** properties are displayed and a preview of the drawing with its default properties appears below the property fields.

![Figure 7.6 New Drawing](image)

5. If you change your mind about creating this drawing type, click **New** again and in the **Save Drawing** dialog, click **Discard**.

   The **New Drawing** dialog will open again and you can select a new drawing type.

6. In the **Name** field, enter a descriptive name for the drawing.

   The **Type** field is automatically populated and is not editable.

7. Modify the default properties as described in “To modify a drawing:” on page 7–6.

   After editing the drawing name or properties, the **Update** button at the bottom of the **Drawing** section is enabled.

8. Click **Update**.

   The **Drawing** section is cleared and the new drawing is added to the selected group, but is not yet available in the **Drawing Toolbox**.

9. Click **Done** to close the editor and make your drawing available in the **Drawing Toolbox**.

**To modify a drawing:**

1. Select **Edit > Manage Drawings** to open the **Drawing Management Editor**.

2. In the **Group** section on the left side, from the **Name** drop-down, select the group that contains the drawing you want to modify.

3. From the **Group** list, select the drawing you want to modify.

   The properties of the selected drawing are displayed in the **Drawing** section on the right side.
4. Modify the properties of the drawings as described in the section corresponding to your drawing.
   - “Text and OSM Replacement Drawings” on page 7–8
   - “Area Drawings” on page 7–20
   - “Line Drawings” on page 7–22
   - “Icon Drawings” on page 7–24
   - “Magnifier Drawings” on page 7–27
   - “Locator Drawings” on page 7–30
   - “Dynamic Data Drawings” on page 7–33
   - “Video Input Drawings” on page 7–37

5. Click Update at the bottom of the Drawing section to save your changes.

6. Click Done to close the editor and make your drawing available in the Drawing Toolbox.

To copy a drawing:

1. Select Edit > Manage Drawings to open the Drawing Management Editor.
2. On the Group side of the editor, from the Name drop-down, select the group that contains the drawing you want to copy and then select the drawing.
3. From the Group drop-down, select the folder into which you want to copy the selected drawing.
   The drawing will appear in the list for the selected group.
5. Click Done to close the Drawing Management Editor.

To move a drawing:

1. Select Edit > Manage Drawings to open the Drawing Management Editor.
2. On the Group side of the editor, from the Name drop-down, select the group that contains the drawing you want to move and then select the drawing.
3. From the Group drop-down, select the folder into which you want to move the selected drawing.
   The drawing is removed from the original folder and moved to the selected folder.
5. Click Done to close the Drawing Management Editor.

To delete a drawing:

1. Select Edit > Manage Drawings to open the Drawing Management Editor.
2. On the Group side of the editor, from the Name drop-down, select the group that contains the drawing you want to delete
3. Select the drawing you want to delete.
4. On the Drawing side of the editor, click Delete.
   The Delete Drawing confirmation dialog opens.

5. Click Yes to delete the drawing.
6. Click Done to close the Drawing Management Editor.
Text and OSM Replacement Drawings

Use **Text** drawings to add your own labels to a map, as shown in the example below. The labels can be key framed to appear and/or disappear at specific points in the timeline during animation.

**OSM Replacement** drawings are text drawings that can be used to replace existing labels on a map. They have all the same properties as text drawings but are used only in OSM maps. With replacement drawings, you can insert labels for only those locations that are of interest and all other labels will be hidden in the production output. For details, see “**OSM Replacement Drawings**” on page 9–49.

![Figure 7.8 Example - Text Drawing](image)

**Text** and **OSM Replacement** drawings have many editable properties. The properties are divided into tabs and are described below.
General Tab

![Image of General Tab properties in XPression Maps](https://via.placeholder.com/150)

**Figure 7.9 Properties - Text Drawings - General Tab**

The properties found in the **General** tab are described in the following table.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Direction</strong></td>
<td>Sets the writing direction for the text that is used in the drawing. Options are <strong>Left to Right</strong> or <strong>Right to Left</strong>.</td>
</tr>
<tr>
<td><strong>Default Text</strong></td>
<td>The example text that appears in the preview. This text also appears as the preview icon in the group of drawings in which it is located.</td>
</tr>
<tr>
<td><strong>Default Scale</strong></td>
<td>The default size of the text. Select the <strong>Auto</strong> checkbox to make the text size scale automatically as the map zooms in and out. This effect can be changed in the <strong>Drawing Editor</strong>, when the drawing is selected in the output window. See “Size” on page 9–17.</td>
</tr>
<tr>
<td><strong>Offset X</strong></td>
<td>The distance that the text drawing is offset from the center of the text along the X-axis of the map. Set to something other than 0.0 to make the callout arrow or line visible.</td>
</tr>
<tr>
<td><strong>Offset Y</strong></td>
<td>The distance that the text drawing is offset from the center of the text along the Y-axis of the map. Set to something other than 0.0 to make the callout arrow or line visible.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Visibility</td>
<td>How a drawing appears (In) and disappears (Out) during animation. Options are:</td>
</tr>
<tr>
<td>In and Out</td>
<td>None — the drawing appears/disappears instantly at the frame to which the key frame is set.</td>
</tr>
<tr>
<td></td>
<td>Dissolve — the drawing blends in/out over the number of seconds selected in the Time field. The drawing animates in and out at the level set in the corresponding Zoom fields.</td>
</tr>
<tr>
<td></td>
<td>Typewriter — the drawing appears/disappears one character at a time over the number of seconds selected in the Time field. The drawing animates in and out at the level set in the corresponding Zoom fields.</td>
</tr>
<tr>
<td></td>
<td>Alpha — the drawing blends in/out one character at a time over the number of seconds selected in the Time field. The drawing animates in and out at the level set in the corresponding Zoom fields.</td>
</tr>
<tr>
<td></td>
<td>Wipe —</td>
</tr>
<tr>
<td></td>
<td>Wipe Reverse —</td>
</tr>
<tr>
<td></td>
<td>Wipe Left — the drawing appears/disappears from the left over the number of seconds selected in the Time field. The drawing animates in and out at the level set in the corresponding Zoom fields.</td>
</tr>
<tr>
<td></td>
<td>Wipe Right — the drawing appears/disappears from the right over the number of seconds selected in the Time field. The drawing animates in and out at the level set in the corresponding Zoom fields.</td>
</tr>
<tr>
<td></td>
<td>Wipe Bottom — the drawing appears/disappears from the bottom over the number of seconds selected in the Time field. The drawing animates in and out at the level set in the corresponding Zoom fields.</td>
</tr>
<tr>
<td></td>
<td>Wipe Top — the drawing appears/disappears from the top over the number of seconds selected in the Time field. The drawing animates in and out at the level set in the corresponding Zoom fields.</td>
</tr>
<tr>
<td></td>
<td>The effect can be changed in the Drawing Editor in the Effect section, when the drawing is selected in the output window. See &quot;Effect&quot; on page 9–18.</td>
</tr>
</tbody>
</table>
### Label Tab

![Image: Properties - Text Drawings - Label Tab](image)

**Figure 7.10 Properties - Text Drawings - Label Tab**

The properties found in the **Label** tab are described in the following table.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Text</strong></td>
<td><strong>Font</strong> — Select an existing font using the drop-down or click the <strong>Browse</strong> button to add a new font to be applied to the text.</td>
</tr>
<tr>
<td></td>
<td><strong>Color</strong> — Select an existing color using the drop-down or click the <strong>Browse</strong> button to add a new color.</td>
</tr>
<tr>
<td></td>
<td>If no color is selected, the text drawing will not be visible.</td>
</tr>
<tr>
<td></td>
<td><strong>Transform</strong> — Select either <strong>None</strong>, <strong>UPPERCASE</strong> or <strong>lowercase</strong>.</td>
</tr>
<tr>
<td></td>
<td>• <strong>None</strong>: The text will be displayed exactly as entered.</td>
</tr>
<tr>
<td></td>
<td>• <strong>UPPERCASE</strong>: The text will be displayed as all uppercase, regardless of how it is entered.</td>
</tr>
<tr>
<td></td>
<td>• <strong>lowercase</strong>: The text will be displayed as all lowercase, regardless of how it is entered.</td>
</tr>
<tr>
<td></td>
<td><strong>Kerning</strong> — Enter a value or use the arrows to set the amount of space between letters.</td>
</tr>
<tr>
<td></td>
<td>This effect can be changed in the <strong>Drawing Editor</strong> in the <strong>Text</strong> section, when the drawing is selected in the output window.</td>
</tr>
<tr>
<td></td>
<td><strong>Line Spacing</strong> — Enter a value or use the arrows to set the amount of space between multiple lines of text.</td>
</tr>
<tr>
<td></td>
<td>This effect can be changed in the <strong>Drawing Editor</strong> in the <strong>Text</strong> section, when the drawing is selected in the output window.</td>
</tr>
<tr>
<td><strong>Alignment</strong></td>
<td><strong>Horizontal</strong> - The longitude coordinate of the text drawing corresponds to the left side of the text if this property is set to <strong>Left</strong>, to the right side of the text if this property is set to <strong>Right</strong> and to the center of the text if this property is set to <strong>Center</strong>.</td>
</tr>
<tr>
<td></td>
<td><strong>Vertical</strong> - If this property is set to <strong>Top</strong>, the latitude coordinate of the text drawing will correspond to the highest theoretical possible character in the first line. This is to have static baselines. If the latitude coordinate actually corresponded to the top of the text, the baselines (and so the whole text) would change position whenever the text changes. Accordingly, for <strong>Center</strong>, the latitude coordinate is not really in the center of the text but at a position close to the center where baselines only change when the number of lines changes.</td>
</tr>
<tr>
<td></td>
<td>For <strong>Bottom</strong>, the baseline of the last line in the text will correspond to the latitude coordinate.</td>
</tr>
<tr>
<td></td>
<td>For <strong>Baseline</strong>, the baseline of the first line of the text will correspond to the latitude coordinate.</td>
</tr>
</tbody>
</table>
Decoration Tab

The properties found in the Decoration tab are described in the following table.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
</table>
| Shadow   | Click the Shadow checkbox to add a shadow to each text character. When enabled, the shadow will have the properties configured in this section.  
  **Color** — Select an existing color using the drop-down or click the Browse button to add a new color.  
  **Angle** — The angle of the shadow in degrees.  
  0 = The shadow falls to the right of the text.  
  90 = The shadow falls above the text.  
  180 = The shadow falls to the left of the text.  
  -90 = The shadow falls below the text.  
  **Distance** — The distance that the shadow falls from the text. A larger value moves the shadow further away from the text.  
  **Enlarge** — Enter a value or use the arrows to set an amount by which to enlarge the shadow.  
  **Blur** — Enter a value or use the arrows to set the degree by which the shadow appears out-of-focus. |
| Border   | Click the Border checkbox to add a border around the outside of the text characters.  
  **Color** — Select an existing color using the drop-down or click the Browse button to add a new color.  
  **Enlarge** — Enter a value or use the arrows to set an amount by which to enlarge the border. |
| Glow     | Click the Glow checkbox to add a glow effect around the outside of the text characters.  
  **Enlarge** — Enter a value or use the arrows to set an amount by which to enlarge the glow.  
  **Blur** — Enter a value or use the arrows to set the degree by which the glow appears out-of-focus. |
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
</table>
| Bevel    | Click the Bevel checkbox to add a bevel effect around the outside of the text characters, giving them a 3D appearance.  
  **Enlarge** — Enter a value or use the arrows to set an amount by which to enlarge the bevel.  
  **Direction** — Enter a value or use the arrows to set the degree at which the bevel will appear on the text characters. |
Background Tab

![Figure 7.12 Properties - Text Drawings - Background Tab](image)

The properties found in the **Background** tab are described in the following table.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Scale** | Enter a value or use the arrows to set the default size of the rectangle that forms the background for the text drawing.  
1.00 is the minimum size. 2.0 makes the background double the size of the text box. |
| **Aspect** | Enter a value or use the arrows to set the ratio of background to text.  
Available only when **Unlinked** or **BackgroundFitsTextKeepAspect** is selected. |
| **TextFit** | From the dropdown, select the option that looks best when you are changing the text within an object.  
**Unlinked** — the size of the background image remains the same regardless of how much text is entered.  
**BackgroundFitsText** — only the width of the background image will increase or decrease to fit the amount of text.  
**BackgroundFitsTextKeepAspect** — the size of the background image will increase or decrease to fit the amount of text and maintain the aspect ratio. |
| **Color** | Select an existing color using the drop-down or click the **Browse** button to add a new color.  
If only a background color is selected, a rectangle in this color will be drawn behind the text.  
If both a background color and an image are selected, they will be combined.  
If no background color, image or outline color are selected, there will be no background.  
The size of the rectangle is relative to the text size, so the background rectangle grows as the text grows. |
| **Image** | Select an existing image using the drop-down or click the **Browse** button to add a new image.  
The image will be drawn behind the text.  
If both a background color and an image are selected, they will be combined.  
If no background color, image or outline color are selected, there will be no background.  
The size of the image is relative to the text size, so the background image grows as the text grows. |
Pause At End: Enter or use the arrows to set the number of frames for which an image sequence will pause at the last image before looping.

Slowdown: When an animated image is selected, this is the number of frames, expressed as a percentage, by which the movement of the animated image will be slowed. Accordingly, a negative value will speed up the movement.

Outline Color: Adds the selected color to the outline of the background. Select an existing color using the drop-down or click the Browse button to add a new color. If no background color is selected, only an outline in the color selected will be displayed.

Outline Width: Enter a value or use the arrows to set a width for the outline (border) of the background. If the px checkbox is selected, the width of the outline will remain the same regardless of the zoom level of the map. If the px checkbox is cleared, the width of the outline will scale relative to the background as the zoom level of the map changes.

Shadow Color: Select an existing color using the drop-down or click the Browse button to add a new color to apply to the shadow of the background.

Shadow Angle: The angle of the shadow in degrees. 0 = The shadow falls to the right of the background. 90 = The shadow falls above the background. 180 = The shadow falls to the left of the background. -90 = The shadow falls below the background.

Shadow Distance: The distance that the shadow falls from the background. A larger value moves the shadow further away from the background.
Marker Tab

The properties found in the Marker tab are described in the following table.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image</td>
<td>Select an existing image using the drop-down or click the Browse button to add a new image from the Images folder. By default, the image will be drawn behind the text. The size of the image is relative to the text size, so the image grows as the text grows. To remove the image from the drawing, click the drop-down arrow and select the blank area at the top of the drop-down list. To delete an image, click the Browse button beside the image field and in the Images folder, click Delete. You cannot delete an image that is currently being used in a drawing.</td>
</tr>
<tr>
<td>Animated</td>
<td>The Animated column indicates whether or not the image is part of a sequence, creating an animated drawing.</td>
</tr>
<tr>
<td>Pause At End</td>
<td>Enter or use the arrows to the number of frames for which an image sequence will pause at the last image before looping.</td>
</tr>
</tbody>
</table>
In order to see the marker, the Offset X and Offset Y values in the general tab need to be something other than 0.00. Otherwise, the marker will be hidden behind the text or background. Changing the offset defines the default offset between the text and the point of interest.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slowdown</td>
<td>When an animated image is selected, this is the number of frames, expressed as a percentage, by which the movement of the animated image will be slowed. Accordingly, a negative value will speed up the movement.</td>
</tr>
<tr>
<td>Scale</td>
<td>Enter a value or use the arrows to increase or decrease the size of the marker image. Default is 1.00. Selecting 2.00 will make the image twice as large.</td>
</tr>
<tr>
<td>Offset X</td>
<td>The distance that the marker image is offset from the center of the text along the X-axis of the map.</td>
</tr>
<tr>
<td></td>
<td>0.0 = Center</td>
</tr>
<tr>
<td></td>
<td>A value higher than 0.00 = Right of center</td>
</tr>
<tr>
<td></td>
<td>A value lower than 0.00 = Left of center</td>
</tr>
<tr>
<td>Offset Y</td>
<td>The distance that the marker image is offset from the center of the text along the Y-axis of the map.</td>
</tr>
<tr>
<td></td>
<td>0.0 = Center</td>
</tr>
<tr>
<td></td>
<td>A value higher than 0.00 = Above the center</td>
</tr>
<tr>
<td></td>
<td>A value lower than 0.00 = Below the center</td>
</tr>
<tr>
<td>Marker is in front</td>
<td>Select this checkbox to move the marker in front of the text.</td>
</tr>
</tbody>
</table>
Callout Tab

![Image of Callout Tab](image)

*Figure 7.14 Text Properties - Callout Tab*

The properties found in the Callout tab are described in the following table.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td>Select the type of callout used to draw the connection between the text-background panel and the location of the point of interest. A background color or an outline color must be defined in the Background tab in order to use a callout. Callout options are Arrow and Line. <strong>Arrow</strong> draws a triangle from the panel to the location on the map in the same style as the background. The Color, Offset, and Width properties are not used in this type. <strong>Line</strong> draws a line between the text-panel and the location on the map. If Line is chosen, the Color, Offset and Width properties become available. For both arrows and lines, the starting point near the panel is calculated automatically for optimal appearance of the callout.</td>
</tr>
<tr>
<td><strong>Alignment</strong></td>
<td>Select whether the arrow or line should be aligned at center or automatically.</td>
</tr>
<tr>
<td><strong>Color</strong></td>
<td>Select an existing color using the drop-down or click the Browse button to add a new color for the callout line. Applies only to the Line type.</td>
</tr>
<tr>
<td><strong>Marker Offset</strong></td>
<td>Enter a value or use the arrows to change the position of the arrow or line in relationship to the marker.</td>
</tr>
<tr>
<td><strong>Label Offset</strong></td>
<td>Enter a value or use the arrows to set an offset that creates a gap between the label and the beginning of the marker. Change the Offset X and Offset Y parameter in the General tab beyond the 0,0 location to see the callout in the example image below the properties.</td>
</tr>
<tr>
<td><strong>Line Width</strong></td>
<td>Enter a value or use the arrows to set the width of the callout line. If the px checkbox is selected, the width of the line will remain the same regardless of the zoom level of the map. If the px checkbox is cleared, the width of the line will scale relative to the background as the zoom level of the map changes.</td>
</tr>
<tr>
<td><strong>Arrow Width</strong></td>
<td>Enter a value or use the arrows to set the width of the callout arrow.</td>
</tr>
</tbody>
</table>
To add callout text to a scene:

1. In the Drawing Toolbox, click the callout text drawing, then click in the scene at the exact position to which you want the arrow or line of the callout to point.
2. Double-click in the bounding box and enter the new text.
3. Place the cursor inside the bounding box, then left-click and drag the bounding box to adjust the position of the callout arrow or line.
4. To reposition the callout, left-click and drag the white point at the top of the handle of the bounding box.
Area Drawings

Use Area drawings to call out an area of the map to which you want to draw attention, as shown in the example below. Area drawings can be still or animated.

![Example - Area Drawing](image1.png)

**Figure 7.15** Example - Area Drawing

![Properties - Area Drawings](image2.png)

**Figure 7.16** Properties - Area Drawings

The Area drawing properties are described in the following table.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Select an existing color using the drop-down or click the Browse button to add a new color for the drawing. The selected color will be applied to the image, if an image is selected.</td>
</tr>
<tr>
<td>Image</td>
<td>Select an existing image from the drop-down or click the Browse button to add a new image. If an image is selected, the area will be textured with this image.</td>
</tr>
<tr>
<td>Pause At End</td>
<td>Enter a value or use the arrows to set the number of frames for which an image sequence will pause at the last image before looping.</td>
</tr>
<tr>
<td>Slowdown</td>
<td>When an animated image is selected, this is the number of frames, expressed as a percentage, by which the movement of the animated image will be slowed. Accordingly, a negative value will speed up the movement.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| **In Effect** | The default effect that plays as the drawing appears during animation. The effect can only be seen when the animation is played. Options are:  
*None* — the drawing appears instantly at the frame to which the key frame is set.  
*Dissolve* — the drawing blends in over the number of seconds selected in the **Time** field. The drawing animates in at the level set in the corresponding **Zoom** field.  
The effect can be changed in the Drawing Editor in the **Effect** section, when the drawing is selected in the output window.  
See “**Effect**” on page 9–18. |
| **Out Effect** | The default effect that plays as the drawing disappears during animation. The effect can only be seen when the animation is played. Options are:  
*None* — the drawing disappears instantly at the frame to which the key frame is set.  
*Dissolve* — the drawing blends out over the number of seconds selected in the **Time** field. The drawing animates out at the level set in the corresponding **Zoom** field.  
The effect can be changed in the Drawing Editor in the **Effect** section, when the drawing is selected in the output window.  
See “**Effect**” on page 9–18. |
Line Drawings

Use **Line** drawings to show a route on the map, as shown in the example below. **Line** drawings can be still or animated.

![Figure 7.17 Example - Line Drawing](image)

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Color</strong></td>
<td>Select an existing color using the drop-down or click the <strong>Browse</strong> button to add a new color for the drawing.</td>
</tr>
<tr>
<td></td>
<td>The selected color will be applied to the image, if an image is selected.</td>
</tr>
<tr>
<td></td>
<td>If no color is selected, the drawing will not be visible.</td>
</tr>
</tbody>
</table>

![Figure 7.18 Properties - Line Drawings](image)
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Image</strong></td>
<td>Select an existing image from the drop-down or click the <strong>Browse</strong> button to add a new image. If an image is selected, the line will be textured with this image.</td>
</tr>
<tr>
<td><strong>Pause At End</strong></td>
<td>Enter a value or use the arrows to set the number of frames for which an image sequence will pause at the last image before looping.</td>
</tr>
<tr>
<td><strong>Slowdown</strong></td>
<td>When an animated image is selected, this is the number of frames, expressed as a percentage, by which the movement of the animated image will be slowed. Accordingly, a negative value will speed up the movement.</td>
</tr>
<tr>
<td><strong>Default Scale</strong></td>
<td>The default value of the <strong>Scale</strong> property for the drawing. The default scale can be changed in the <strong>Drawing Editor</strong>. See “<strong>Size</strong>” on page 9–17.</td>
</tr>
<tr>
<td><strong>In Effect</strong></td>
<td>The default effect that plays as the drawing appears during animation. The effect can only be seen when the animation is played. Options are:</td>
</tr>
<tr>
<td></td>
<td><strong>None</strong> — the drawing appears instantly at the frame to which the key frame is set.</td>
</tr>
<tr>
<td></td>
<td><strong>Dissolve</strong> — the drawing blends in over the number of seconds selected in the <strong>Time</strong> field. The drawing animates in at the level set in the corresponding <strong>Zoom</strong> field.</td>
</tr>
<tr>
<td></td>
<td>The effect can be changed in the <strong>Drawing Editor</strong> in the <strong>Effect</strong> section, when the drawing is selected in the output window. See “<strong>Effect</strong>” on page 9–18.</td>
</tr>
<tr>
<td><strong>Out Effect</strong></td>
<td>The default effect that plays as the drawing disappears during animation. The effect can only be seen when the animation is played. Options are:</td>
</tr>
<tr>
<td></td>
<td><strong>None</strong> — the drawing disappears instantly at the frame to which the key frame is set.</td>
</tr>
<tr>
<td></td>
<td><strong>Dissolve</strong> — the drawing blends out over the number of seconds selected in the <strong>Time</strong> field. The drawing animates out at the level set in the corresponding <strong>Zoom</strong> field.</td>
</tr>
<tr>
<td></td>
<td>The effect can be changed in the <strong>Drawing Editor</strong> in the <strong>Effect</strong> section, when the drawing is selected in the output window. See “<strong>Effect</strong>” on page 9–18.</td>
</tr>
</tbody>
</table>
Icon Drawings

Use Icon drawings to mark a specific location, as shown in the example below. Icon drawings can be still or animated.

![Example - Icon Drawing](image)

**Figure 7.19** Example - Icon Drawing

The Icon drawing properties are described in the following table.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Select an existing color using the drop-down or click the <strong>Browse</strong> button to add a new color for the icon drawing. The selected color will be applied to the image, if an image is selected. If no color is selected, the drawing will not be visible.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Image</strong></td>
<td>Select an existing image from the drop-down or click the <strong>Browse</strong> button to add a new image.</td>
</tr>
<tr>
<td></td>
<td>If an image is selected, the drawing will be textured with this image.</td>
</tr>
<tr>
<td></td>
<td>If no image is selected, the drawing will be a rectangle of the selected color.</td>
</tr>
<tr>
<td><strong>Pause At End</strong></td>
<td>Enter a value or use the arrows to set the number of frames for which an image sequence will pause at the last image before looping.</td>
</tr>
<tr>
<td><strong>Slowdown</strong></td>
<td>When an animated image is selected, this is the number of frames, expressed as a percentage, by which the movement of the animated image will be slowed. Accordingly, a negative value will speed up the movement.</td>
</tr>
<tr>
<td><strong>Default Scale</strong></td>
<td>The default value of the <strong>Scale</strong> property for the drawing.</td>
</tr>
<tr>
<td></td>
<td>The effect can be changed in the <strong>Drawing Editor</strong>, when the drawing is selected in the output window.</td>
</tr>
<tr>
<td></td>
<td>See “<strong>Size</strong>” on page 9–17.</td>
</tr>
<tr>
<td><strong>In Effect</strong></td>
<td>The default effect that plays as the drawing appears during animation. The effect can only be seen when the animation is played.</td>
</tr>
<tr>
<td></td>
<td>Options are:</td>
</tr>
<tr>
<td></td>
<td><strong>None</strong> — the drawing appears instantly at the frame to which the key frame is set.</td>
</tr>
<tr>
<td></td>
<td><strong>Dissolve</strong> — the drawing blends in over the number of seconds selected in the <strong>Time</strong> field. The drawing animates in at the level set in the corresponding <strong>Zoom</strong> field.</td>
</tr>
<tr>
<td></td>
<td><strong>Wipe Left</strong> — the drawing appears from the left over the number of seconds selected in the <strong>Time</strong> field. The drawing animates in at the level set in the corresponding <strong>Zoom</strong> field.</td>
</tr>
<tr>
<td></td>
<td><strong>Wipe Right</strong> — the drawing appears from the right over the number of seconds selected in the <strong>Time</strong> field. The drawing animates in at the level set in the corresponding <strong>Zoom</strong> field.</td>
</tr>
<tr>
<td></td>
<td><strong>Wipe Bottom</strong> — the drawing appears from the bottom over the number of seconds selected in the <strong>Time</strong> field. The drawing animates in at the level set in the corresponding <strong>Zoom</strong> field.</td>
</tr>
<tr>
<td></td>
<td><strong>Wipe Top</strong> — the drawing appears from the top over the number of seconds selected in the <strong>Time</strong> field. The drawing animates in at the level set in the corresponding <strong>Zoom</strong> field.</td>
</tr>
<tr>
<td></td>
<td>The effect can be changed in the <strong>Drawing Editor</strong> in the <strong>Effect</strong> section, when the drawing is selected in the output window.</td>
</tr>
<tr>
<td></td>
<td>See “<strong>Effect</strong>” on page 9–18.</td>
</tr>
</tbody>
</table>
### Out Effect

The default effect that plays as the drawing becomes invisible during animation. The effect can only be seen when the animation is played.

- **None** — the drawing appears instantly at the frame to which the key frame is set.
- **Dissolve** — the drawing blends in over the number of seconds selected in the **Time** field. The drawing animates in and out at the level set in the corresponding **Zoom** fields.
- **Wipe Left** — the drawing disappears from the left over the number of seconds selected in the **Time** field. The drawing animates out at the level set in the corresponding **Zoom** field.
- **Wipe Right** — the drawing disappears from the right over the number of seconds selected in the **Time** field. The drawing animates out at the level set in the corresponding **Zoom** field.
- **Wipe Bottom** — the drawing disappears from the bottom over the number of seconds selected in the **Time** field. The drawing animates out at the level set in the corresponding **Zoom** field.
- **Wipe Top** — the drawing disappears from the top over the number of seconds selected in the **Time** field. The drawing animates out at the level set in the corresponding **Zoom** field.

The effect can be changed in the **Drawing Editor** in the **Effect** section, when the drawing is selected in the output window. See “Effect” on page 9–18.

### Interactivity

The default behaviour of icon drawings that are used as touch icons. This property is only available if you are working in **Interactive** mode.

Options are:

- **ActivateScene1 - 5** — touching the icon activates the corresponding scene.
- **ContinueAnimation** — touching the icon resumes an animation that has been stopped.
- **FlyHome** — touching the icon returns the map to the Home scene.
- **PlayAnimation** — touching the icon plays the corresponding animation.
- **SetStartActivateScene1 - 5** — touching the icon gets the scene ready to be activated, but you’ll need to press a **Play** icon to activate the scene.
- **StopAnimation** — touching the icon stops the animation.

### Pressed Image

The default image used to indicate that an icon has been touched, typically a different colored version of the icon.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Out Effect</td>
<td>The default effect that plays as the drawing becomes invisible during animation. The effect can only be seen when the animation is played.</td>
</tr>
<tr>
<td>None</td>
<td>the drawing appears instantly at the frame to which the key frame is set.</td>
</tr>
<tr>
<td>Dissolve</td>
<td>the drawing blends in over the number of seconds selected in the <strong>Time</strong> field. The drawing animates in and out at the level set in the corresponding <strong>Zoom</strong> fields.</td>
</tr>
<tr>
<td>Wipe Left</td>
<td>the drawing disappears from the left over the number of seconds selected in the <strong>Time</strong> field. The drawing animates out at the level set in the corresponding <strong>Zoom</strong> field.</td>
</tr>
<tr>
<td>Wipe Right</td>
<td>the drawing disappears from the right over the number of seconds selected in the <strong>Time</strong> field. The drawing animates out at the level set in the corresponding <strong>Zoom</strong> field.</td>
</tr>
<tr>
<td>Wipe Bottom</td>
<td>the drawing disappears from the bottom over the number of seconds selected in the <strong>Time</strong> field. The drawing animates out at the level set in the corresponding <strong>Zoom</strong> field.</td>
</tr>
<tr>
<td>Wipe Top</td>
<td>the drawing disappears from the top over the number of seconds selected in the <strong>Time</strong> field. The drawing animates out at the level set in the corresponding <strong>Zoom</strong> field.</td>
</tr>
<tr>
<td>Interactivity</td>
<td>The default behaviour of icon drawings that are used as touch icons. This property is only available if you are working in <strong>Interactive</strong> mode.</td>
</tr>
<tr>
<td>Pressed Image</td>
<td>The default image used to indicate that an icon has been touched, typically a different colored version of the icon.</td>
</tr>
</tbody>
</table>
Magnifier Drawings

Use **Magnifier** drawings to zoom in on a section of the map to get a closer look, as shown in the example below.

![Example Magnifier Drawing](image)

**Figure 7.21 Example - Magnifier Drawing**

The **Magnifier** drawing properties are described in the following table.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Defines the color of the image selected in the <strong>Image</strong> property. Select an existing color using the drop-down or click the <strong>Browse</strong> button to add a new color for the locator drawing. The selected color will be applied to the image, if one is selected. If no color is selected, the selected border image will be invisible.</td>
</tr>
</tbody>
</table>
Image

Select an existing image from the drop-down or click the Browse button to add a new image. The image provides a border for the map that is highlighted in the drawing. For the Magnifier drawing to work properly, there must be a transparent area in the center of the image that is completely surrounded by graphics. Towards the edges of the image, transparent areas are possible. The image defines the area where the maps (Bing Aerial, Bing Aerial Label, or any of the Bing Road maps) are shown.

The drawing will be textured with this image.

An image must be selected for a Magnifier drawing.

In Effect

The default effect that plays as the drawing appears during animation. The effect can only be seen when the animation is played.

Options are:

- None — the drawing appears instantly at the frame to which the key frame is set.
- Dissolve — the drawing blends in over the number of seconds selected in the Time field. The drawing animates in and out at the level set in the corresponding Zoom fields.
- Wipe Left — the drawing enters from the left over the number of seconds selected in the Time field. The drawing animates in and out at the level set in the corresponding Zoom field.
- Wipe Right — the drawing enters from the left over the number of seconds selected in the Time field. The drawing animates in at the level set in the corresponding Zoom field.
- Wipe Bottom — the drawing enters from the bottom over the number of seconds selected in the Time field. The drawing animates in at the level set in the corresponding Zoom field.
- Wipe Top — the drawing enters from the top over the number of seconds selected in the Time field. The drawing animates in at the level set in the corresponding Zoom field.

The effect can be changed in the Drawing Editor in the Effect section, when the drawing is selected in the output window.

See “Effect” on page 9–18.

Out Effect

The default effect that plays as the drawing disappears during animation. The effect can only be seen when the animation is played.

Options are:

- None — the drawing disappears instantly at the frame to which the key frame is set.
- Dissolve — the drawing blends out over the number of seconds selected in the Time field. The drawing animates out at the level set in the corresponding Zoom field.
- Wipe Left — the drawing disappears from the left over the number of seconds selected in the Time field. The drawing animates out at the level set in the corresponding Zoom field.
- Wipe Right — the drawing disappears from the right over the number of seconds selected in the Time field. The drawing animates out at the level set in the corresponding Zoom field.
- Wipe Bottom — the drawing disappears from the bottom over the number of seconds selected in the Time field. The drawing animates out at the level set in the corresponding Zoom field.
- Wipe Top — the drawing disappears from the top over the number of seconds selected in the Time field. The drawing animates out at the level set in the corresponding Zoom field.

The effect can be changed in the Drawing Editor in the Effect section, when the drawing is selected in the output window.

See “Effect” on page 9–18.
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Zoom Level** | The default value of the **Zoom Level** for this drawing.  
|              | Valid values are 1 to 21.  
|              | The effect can be changed in the **Drawing Editor**, when the drawing is selected in the output window.  
|              | See “**Magnifier Drawing Parameters**” on page 9–23.                                                                                                                                 |
| **Map Style** | Defines the default map style for this drawing.  
|              | Options are:  
|              | • Bing Aerial  
|              | • Bing Aerial Label  
|              | • Bing Road  
|              | • Bing Road Dark  
|              | • Bing Road Gray  
|              | • Bing Road Light  
|              | The effect can be changed in the **Drawing Editor**, when the drawing is selected in the output window.  
|              | See “**Magnifier Drawing Parameters**” on page 9–23.                                                                                                                                 |
| **Map Zoom**  | The zoom value for the highlighted area of a map.  
|              | The effect can be changed in the **Drawing Editor**, when the drawing is selected in the output window.  
|              | See “**Magnifier Drawing Parameters**” on page 9–23.                                                                                                                                 |
Locator Drawings

Use **Locator** drawings to show where the location you’re looking at is found in the context of a larger map. For example, if you place a locator drawing on a city and enlarge it, as shown in the example below, you’ll see in what part of the country that city is found. Locator drawings are typically used in the **Overlay Layer**. See "Overlay Layer" on page 8–28.

![Figure 7.23 Example - Locator Drawing](image)

![Figure 7.24 Properties - Locator Drawings](image)
The Locator drawing properties are described in the following table.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Color</strong></td>
<td>Defines the color of the image selected in the <strong>Image</strong> property. Select an existing color using the drop-down or click the <strong>Browse</strong> button to add a new color for the locator drawing. The selected color will be applied to the image, if one is selected. If no color is selected, the selected border image will be invisible.</td>
</tr>
<tr>
<td><strong>Image</strong></td>
<td>Select an existing image from the drop-down or click the <strong>Browse</strong> button to add a new image. The image provides a border for the map that is highlighted in the drawing. For the locator drawing to work properly, there must be a transparent area in the center of the image that is completely surrounded by graphics. Towards the edges of the image, transparent areas are possible. The image defines the area where the maps (Bing Aerial, Bing Aerial Label, or Bing Road) are shown. The drawing will be textured with this image. An image must be selected for a Locator drawing.</td>
</tr>
</tbody>
</table>
| **In Effect** | The default effect that plays as the drawing appears during animation. The effect can only be seen when the animation is played. Options are:  
**None** — the drawing appears instantly at the frame to which the key frame is set.  
**Dissolve** — the drawing blends in over the number of seconds selected in the **Time** field. The drawing animates in and out at the level set in the corresponding **Zoom** fields.  
**Wipe Left** — the drawing enters from the left over the number of seconds selected in the **Time** field. The drawing animates in and out at the level set in the corresponding **Zoom** field.  
**Wipe Right** — the drawing enters from the left over the number of seconds selected in the **Time** field. The drawing animates in at the level set in the corresponding **Zoom** field.  
**Wipe Bottom** — the drawing enters from the bottom over the number of seconds selected in the **Time** field. The drawing animates in at the level set in the corresponding **Zoom** field.  
**Wipe Top** — the drawing enters from the top over the number of seconds selected in the **Time** field. The drawing animates in at the level set in the corresponding **Zoom** field. The effect can be changed in the **Drawing Editor** in the **Effect** section, when the drawing is selected in the output window.  
See “**Effect**” on page 9–18. |
### Property | Description
--- | ---
**Out Effect** | The default effect that plays as the drawing disappears during animation. The effect can only be seen when the animation is played.
Options are:
None — the drawing disappears instantly at the frame to which the key frame is set.
Dissolve — the drawing blends out over the number of seconds selected in the **Time** field. The drawing animates out at the level set in the corresponding **Zoom** field.
Wipe Left — the drawing disappears from the left over the number of seconds selected in the **Time** field. The drawing animates out at the level set in the corresponding **Zoom** field.
Wipe Right — the drawing disappears from the right over the number of seconds selected in the **Time** field. The drawing animates out at the level set in the corresponding **Zoom** field.
Wipe Bottom — the drawing disappears from the bottom over the number of seconds selected in the **Time** field. The drawing animates out at the level set in the corresponding **Zoom** field.
Wipe Top — the drawing disappears from the top over the number of seconds selected in the **Time** field. The drawing animates out at the level set in the corresponding **Zoom** field.

The effect can be changed in the **Drawing Editor** in the **Effect** section, when the drawing is selected in the output window.
See “Effect” on page 9–18.

**Zoom Level** | The default value of the **Zoom Level** for this drawing.

The effect can be changed in the **Drawing Editor**, when the drawing is selected in the output window.
See “Locator Drawing Parameters” on page 9–24.

**Map Style** | Defines the default map style for this drawing.
Options are:
• Bing Aerial
• Bing Aerial Label
• Bing Road
• Bing Road Dark
• Bing Road Gray
• Bing Road Light

The effect can be changed in the **Drawing Editor**, when the drawing is selected in the output window.
See “Locator Drawing Parameters” on page 9–24.

**Map Zoom** | Defines the default map zoom value for this drawing.
The effect can be changed in the **Drawing Editor**, when the drawing is selected in the output window.
See “Locator Drawing Parameters” on page 9–24.
Dynamic Data Drawings

Use Dynamic Data drawings to show information about a particular location, such as weather, population, etc., as shown in the example below. This feature is an option that needs to be selected when ordering your system. It is not included in all systems.

For more information on options available for XPression Maps, please reach out to your Ross Video sales professional.

![Example - Dynamic Data Drawings](image1)

**Figure 7.25** Example - Dynamic Data Drawings

![Properties - Dynamic Data Drawings](image2)

**Figure 7.26** Properties - Dynamic Data Drawings
The **Dynamic Data** drawing properties are described in the following table.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Writing Direction</td>
<td>Select the writing direction for the text that is used in the dynamic data drawing. Options are <strong>Left to Right</strong> or <strong>Right to Left</strong>.</td>
</tr>
<tr>
<td>Layout</td>
<td>Select the layout file that defines the look of the dynamic data drawing.</td>
</tr>
<tr>
<td>Font</td>
<td>Select an existing font using the drop-down or click the <strong>Browse</strong> button to add a new font to apply to the text of the dynamic data drawing.</td>
</tr>
<tr>
<td>Color</td>
<td>Select an existing color using the drop-down or click the <strong>Browse</strong> button to add a new color to apply to the text of the dynamic data drawing. If no color is selected, the text will be invisible.</td>
</tr>
<tr>
<td>Background Color</td>
<td>This property only takes effect if there is no background image selected. If a background color is selected, a rectangle in this color will be drawn behind the text. The size of the rectangle corresponds to the text size with a small offset.</td>
</tr>
<tr>
<td>Background Image</td>
<td>Select an existing image using the drop-down or click the <strong>Browse</strong> button to add a new image. If a background image is selected, the background color (if set) will not be applied. A rectangle textured with the image will be drawn behind the text. The size of the rectangle corresponds to the actual text size with a small offset, so the background image grows as the text grows.</td>
</tr>
<tr>
<td>Default Scale</td>
<td>The default value of the <strong>Scale</strong> property for the drawing.</td>
</tr>
<tr>
<td>Shadow Color</td>
<td>Select an existing color using the drop-down or click the <strong>Browse</strong> button to add a new color to apply to the shadow of the text.</td>
</tr>
</tbody>
</table>
| Shadow Angle    | **Angle** — The angle of the shadow in degrees.  
0 = The shadow falls to the right of the text.  
90 = The shadow falls above the text.  
180 = The shadow falls to the left of the text.  
-90 = The shadow falls below the text.                                                                                                                  |
| Shadow Distance | The distance that the shadow falls from the text. A larger value moves the shadow further away from the text.                                                                                                  |
| In Effect       | The default effect that plays as the drawing appears during animation. The effect can only be seen when the animation is played. Options are:  
**None** — the drawing appears instantly at the frame to which the key frame is set.  
**Dissolve** — the drawing blends in over the number of seconds selected in the **Time** field. The drawing animates in and out at the level set in the corresponding **Zoom** fields.  
**Wipe Left** — the drawing enters from the left over the number of seconds selected in the **Time** field. The drawing animates in and out at the level set in the corresponding **Zoom** field.  
**Wipe Right** — the drawing enters from the left over the number of seconds selected in the **Time** field. The drawing animates in at the level set in the corresponding **Zoom** field.  
**Wipe Bottom** — the drawing enters from the bottom over the number of seconds selected in the **Time** field. The drawing animates in at the level set in the corresponding **Zoom** field.  
**Wipe Top** — the drawing enters from the top over the number of seconds selected in the **Time** field. The drawing animates in at the level set in the corresponding **Zoom** field.  
The effect can be changed in the **Drawing Editor** in the **Effect** section, when the drawing is selected in the output window.  
See “**Effect**” on page 9–18.
### Property | Description
--- | ---
**Out Effect** | The default effect that plays as the drawing disappears during animation. The effect can only be seen when the animation is played.

Options are:

- **None** — the drawing disappears instantly at the frame to which the key frame is set.
- **Dissolve** — the drawing blends out over the number of seconds selected in the **Time** field. The drawing animates out at the level set in the corresponding **Zoom** field.
- **Wipe Left** — the drawing disappears from the left over the number of seconds selected in the **Time** field. The drawing animates out at the level set in the corresponding **Zoom** field.
- **Wipe Right** — the drawing disappears from the right over the number of seconds selected in the **Time** field. The drawing animates out at the level set in the corresponding **Zoom** field.
- **Wipe Bottom** — the drawing disappears from the bottom over the number of seconds selected in the **Time** field. The drawing animates out at the level set in the corresponding **Zoom** field.
- **Wipe Top** — the drawing disappears from the top over the number of seconds selected in the **Time** field. The drawing animates out at the level set in the corresponding **Zoom** field.

The effect can be changed in the **Drawing Editor** in the **Effect** section, when the drawing is selected in the output window.

See “Effect” on page 9–18.
Background Drawings

Use a Background drawing to change the background of a map, as shown in the example below.

![Default background](image1)  ![New background](image2)

*Figure 7.27 Example - Background Drawing*

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Color</strong></td>
<td>Defines the fullscreen background color, independent of Background Mode. See “Editing the Background Drawing” on page 8–11 for more information. Select an existing color using the drop-down or click the Browse button to add a new color to apply to the background drawing. If no color is selected, the background will be transparent.</td>
</tr>
<tr>
<td><strong>Image</strong></td>
<td>Select an existing image using the drop-down or click the Browse button to add a new image. If selected, the image is used as the background when this drawing is selected in the Scene Properties editor or from the Drawing Toolbox. See “Editing the Background Drawing” on page 8–11 for instructions for replacing the background drawing from either the Scene Properties editor or the Drawing Toolbox.</td>
</tr>
<tr>
<td><strong>Pause At End</strong></td>
<td>Enter a value or use the arrows to set the number of frames for which an image sequence will pause at the last image before looping.</td>
</tr>
<tr>
<td><strong>Slowdown</strong></td>
<td>When an animated image is selected, this is the number of frames, expressed as a percentage, by which the movement of the animated image will be slowed. Accordingly, a negative value will speed up the movement.</td>
</tr>
</tbody>
</table>
Video Input Drawings

Use Video Input drawings to define the look and behaviour of video inputs in the scene. You can add a frame around the video input and attach a label, if desired.

You can have up to 8 video inputs in a scene.

The Video Input drawing properties are divided into 3 tabs and are described below.

![Example - Video Input Drawing](image)

*Figure 7.29 Example - Video Input Drawing*
General Tab

![Figure 7.30 Properties - Video Input Drawings - General Tab]

The properties found in the General tab are described in the following table.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Input</strong></td>
<td>Select the input source to be displayed in the drawing.</td>
</tr>
<tr>
<td></td>
<td>There are 8 possible inputs.</td>
</tr>
<tr>
<td><strong>Visibility</strong></td>
<td>How a video input drawing appears (In) and disappears (Out) during animation.</td>
</tr>
<tr>
<td>(In and Out)</td>
<td>Options are:</td>
</tr>
<tr>
<td></td>
<td>None — the drawing appears/disappears instantly at the frame to which the key frame is set.</td>
</tr>
<tr>
<td></td>
<td>Dissolve — the drawing blends in/out over the number of seconds selected in the Time field. The drawing animates in and out at the level set in the corresponding Zoom fields.</td>
</tr>
<tr>
<td></td>
<td>Typewriter — the drawing appears/disappears one character at a time over the number of seconds selected in the Time field. The drawing animates in and out at the level set in the corresponding Zoom fields.</td>
</tr>
<tr>
<td></td>
<td>Alpha — the drawing blends in/out one character at a time over the number of seconds selected in the Time field. The drawing animates in and out at the level set in the corresponding Zoom fields.</td>
</tr>
<tr>
<td></td>
<td>Wipe —</td>
</tr>
<tr>
<td></td>
<td>Wipe Reverse —</td>
</tr>
<tr>
<td></td>
<td>Wipe Left — the drawing appears/disappears from the left over the number of seconds selected in the Time field. The drawing animates in and out at the level set in the corresponding Zoom fields.</td>
</tr>
<tr>
<td></td>
<td>Wipe Right — the drawing appears/disappears from the left over the number of seconds selected in the Time field. The drawing animates in and out at the level set in the corresponding Zoom fields.</td>
</tr>
<tr>
<td></td>
<td>Wipe Bottom — the drawing appears/disappears from the bottom over the number of seconds selected in the Time field. The drawing animates in and out at the level set in the corresponding Zoom fields.</td>
</tr>
<tr>
<td></td>
<td>Wipe Top — the drawing appears/disappears from the top over the number of seconds selected in the Time field. The drawing animates in and out at the level set in the corresponding Zoom fields.</td>
</tr>
</tbody>
</table>

The effect can be changed in the Drawing Editor in the Effect section, when the drawing is selected in the output window. See “Effect” on page 9–18.
Transform Tab

![Transform Tab](image)

**Figure 7.31** Properties - Video Input Drawings - Transform Tab

The properties found in the **Transform** tab are described in the table below.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Crop</td>
<td>Enter a value or use the arrows to select a percentage by which to crop the video input.</td>
</tr>
<tr>
<td>Scale</td>
<td>In the X and Y fields, enter a value or use the arrows to increase or decrease the size of the video input.</td>
</tr>
</tbody>
</table>
Decoration Tab

![Figure 7.32 Properties - Video Input Drawings - Decoration Tab](image)

The properties found in the **Decoration** tab are described in the table below.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Color</strong></td>
<td>Select an existing color using the drop-down or click the <strong>Browse</strong> button to add a new color to apply to the frame image for the video input.</td>
</tr>
<tr>
<td><strong>Frame Image</strong></td>
<td>Select an existing image using the drop-down or click the <strong>Browse</strong> button to add a new image to apply to the frame for the video input.</td>
</tr>
<tr>
<td><strong>Label</strong></td>
<td>Select the <strong>Label</strong> checkbox if you want to add a label to the video input drawing. Use the <strong>Reference</strong> drop-down to select a text drawing for the label. Use the <strong>Position</strong> drop-down to select the location of the label: <strong>Top, Left, Right</strong> or <strong>Bottom</strong>.</td>
</tr>
</tbody>
</table>
Creating Scenes

XPression Maps is an application that allows the user to design virtual animations over maps and create video files out of these animations. Drawings such as icons, lines, areas, and text, can be used to highlight and describe situations on the map in an animated way. You can create a story out of the virtual animation. During the creation of a scene the application downloads all necessary map information from the Bing web service.

An integrated library of country and state boundaries can be used to highlight countries and regions of interest.

The application must be connected to the Internet because all new map tiles are downloaded from the web map service.

The following topics are discussed in this section:

- "Output Window" on page 8–2
- "Opening a Scene" on page 8–3
- "Adding and Editing Drawings" on page 8–6
- "Ordering Drawings" on page 8–12
- "Drawing Toolbox" on page 8–13
- "Flight Points" on page 8–16
- "Animation Control" on page 8–19
- "Camera Control" on page 8–21
- "Safe Title / Safe Area" on page 8–26
- "Overlay Layer" on page 8–28
- "Saving a Scene" on page 8–29
- "Exporting a Scene" on page 8–30
Output Window

The first time you launch the application, the output window displays the world globe at a random location. Subsequently, when you launch the application, the map opens to where it was positioned when the application was last closed.

In the output window, you can:

• Move and zoom into any location of the world using the mouse or enter a location in the Search Editor.
• Add shapes and drawings to the scene.
• Create animated scenes.

Manipulating the Globe

The globe in the output window can be rotated and zoomed in or out to a specific location.

To rotate the globe:

• Rotate the globe by clicking the left mouse button and dragging the globe in the desired direction.
• Spin the globe clockwise and counter-clockwise by pressing Ctrl + left mouse button and dragging the globe in the desired direction.
• Tilt the globe vertically by pressing Ctrl + right mouse button and dragging the globe in the desired direction.

To zoom in or out:

• Use the scroll wheel of the mouse or right-click the mouse button and draw a rectangle around the area of interest.

Camera Focus

In the center of the Output window, there is a crosshairs. When you search for a specific location, it will be positioned on the crosshairs. This is also a useful tool for centering the area of interest in the scene.
Opening a Scene

A scene consists of a map and a number of drawings you add to create an animated sequence. By default, the application launches with a new scene displayed, but you can also choose to open an existing scene or a recently opened scene.

To open a new scene:

1. Click File > New in the menu bar or click the New icon in the toolbar.

   ![Figure 8.1 XPression Maps Toolbar - New](image)

   If the current scene has unsaved changes, a confirmation dialog opens asking if you want to save it.

   ![Figure 8.2 Save Scene Confirmation](image)

2. Click Yes to save the current scene or No to discard it.

To open an existing scene:

1. Click File > Open in the menu bar or click the Open Scene button in the toolbar.

   ![Figure 8.3 XPression Maps Toolbar - Open Scene](image)

   If the current scene has unsaved changes, a confirmation dialog opens asking if you want to save it.

   ![Figure 8.4 Save Scene Confirmation](image)

2. Click Yes to save the current scene or No to discard it.
3. Then select an existing scene from the XPression Maps **Scenes** folder (or whichever folder you’ve stored your scenes in) and click **Open**.

If the selected scene has a different video format, a confirmation dialog opens, asking if you want to set the new format.

![Video Format Confirmation](image)

*Figure 8.5 Video Format Confirmation*

4. Click **Yes** to set the new format or **No** to keep the current format.

Clicking the X in the top-right corner gives the same result as clicking **No**.

To open a recently opened scene:

1. Click **File** and select a scene from the list of recently opened scenes.

![Recently Opened Scenes](image)

*Figure 8.6 Recently Opened Scenes*

If the current scene has unsaved changes, a confirmation dialog opens asking if you want to save it.

![Save Scene Confirmation](image)

*Figure 8.7 Save Scene Confirmation*
2. Click Yes to save the current scene or No to discard it.

If the selected scene has a different video format, a confirmation dialog opens asking if you want to set the new format.

![Video Format Confirmation]

Figure 8.8 Video Format Confirmation

3. Click Yes to set the new format or No to keep the current format.
Adding and Editing Drawings

Drawings in the Drawing Toolbox are added to a scene in the Output window. They become part of the scene and as such will be saved and loaded with the scene.

For information about creating drawings, see “Managing Drawings” on page 7–5.

To add a drawing to the scene:

1. In the Drawing Toolbox, from the Folder drop-down, select the folder that contains the drawing you want to add to your scene.
2. Then do one of the following:
   - a. Click a thumbnail in the preview pane and then click in the scene where you want the drawing to appear. Left-clicking multiple times in the scene will add additional instances of the drawing.
   - OR
   - b. Left-click and drag a thumbnail from the preview pane into the scene.
3. After adding a drawing, right-click the mouse to add just one instance of the drawing or continue clicking to add multiple instances.

This method applies to text, icon, magnifier, locator, dynamic data and background drawings. For information about adding and editing area and line drawings, see the following sections:

- “Adding and Editing Area Drawings” on page 8–8
- “Adding and Editing Line Drawings” on page 8–9

When you add a drawing to a scene, it is displayed within a white bounding box with a handle attached to the middle, as shown below:

![Selected Drawing in the Output Window](image)

The bounding box, the handle and the various icons attached to the bounding box are used to manipulate the drawing. You can move the drawing and modify the size, visibility, orientation, and rotation using these tools. Not all tools apply to every drawing type. Drawings display only those tools that apply to them.

To copy and paste a drawing:

1. In the output window, select a drawing in the scene.
2. Click Edit > Copy Drawing in the menu bar or press Ctrl+C.
   - The drawing and its parameter values are stored internally.
4. Click Edit > Paste Drawing in the menu bar or press Ctrl+V.
   - A copy of the stored drawing is placed in the middle of the output window.

To cut a drawing:

1. In the output window, select a drawing in the scene.
2. Click Edit > Cut Drawing in the menu bar or press Ctrl+X or press the Delete key.
   - This copies the drawing while simultaneously deleting it, so if you change your mind, you can paste it back in.
To edit a drawing:

1. Click a drawing in the output window to select the drawing.

   The selected drawing will display the bounding box and its tools:

2. Use the tools to change the size, position and appearance of the drawing as described in the table below:

<table>
<thead>
<tr>
<th>Tool</th>
<th>How to Use the Tool</th>
</tr>
</thead>
<tbody>
<tr>
<td>Center Point</td>
<td>Click and hold, then drag to move the drawing around the scene. You can also click and hold anywhere inside the bounding box to move the drawing.</td>
</tr>
<tr>
<td>Corner Points</td>
<td>Click and hold, then drag to scale the drawing.</td>
</tr>
<tr>
<td>Handle</td>
<td>Click and hold the end of the handle, then drag to rotate the drawing. For line and area drawings, the handles can also be used to adjust the path of the line or the shape of the area.</td>
</tr>
<tr>
<td>Scale</td>
<td>Click to enable Auto Scaling. In the Drawing Editor, you'll see that in the Size section, the Auto checkbox is selected. When selected, the drawing remains the same size as you zoom in and out on the map. When the Auto checkbox is cleared, the drawing will scale larger when you zoom in and smaller when you zoom out on the map.</td>
</tr>
<tr>
<td>Eye Icon</td>
<td>Click to toggle the visibility of the drawing.</td>
</tr>
<tr>
<td>Face Icon</td>
<td>Click to toggle the placement of a drawing, either angled to match the map surface or perpendicular to the map surface and facing the camera. For drawings that are created on the Overlay Layer, this icon does not appear.</td>
</tr>
<tr>
<td>Double-Ended Arrow</td>
<td>Click the double-ended arrow to flip the drawing horizontally.</td>
</tr>
</tbody>
</table>

In addition to the tools described above, some types of drawings have additional ways to manipulate them, that are specific to the drawing type.

These additional methods are described in the following sections.

- "Editing Text Drawings" on page 8–8
- "Adding and Editing Area Drawings" on page 8–8
- "Adding and Editing Line Drawings" on page 8–9
- "Editing Locator Drawings" on page 8–11
- "Editing the Background Drawing" on page 8–11
Editing Text Drawings

Text drawings display a predefined text in a predefined font that has been created in the Drawing Management Editor.

See “Drawing Management Editor” on page 7–2 for more information.

To edit a text drawing

• Double-click the text drawing and enter the new text directly in the output window or in the Drawing Editor, in the Text pane, edit the default text.
• When the text drawing has a callout marker:
  › Click and hold inside the bounding box to move the label and its background without moving the marker.
  › Click and hold the white point at the top of the handle inside the bounding box to move the label, background and marker together.

Adding and Editing Area Drawings

Area drawings display a closed area filled with color and texture. The fill is defined in the Drawing Management Editor. In the Drawing Toolbox preview pane, area drawings are identified with the area drawing icon, shown below.

![Figure 8.10 Area Drawing Icon](image)

Area drawings can be added with or without Touchscreen Edit mode enabled. Enabling Touchscreen Edit mode makes it possible to draw an area on the screen using your finger. The Touchscreen Edit parameter is located below the Drawing Toolbox. Once added to the scene, the area drawings can be manipulated to change their appearance, location, size, etc.

![Figure 8.11 Touchscreen Edit](image)

To add an area drawing with Touchscreen Edit mode enabled:

1. Below the Drawing Toolbox, select the Touchscreen Edit checkbox to enable it.
2. In the Drawing Toolbox, left-click on the thumbnail of the area drawing you want to add to your scene.
3. In the output window, left-click on the map where you want the area to start, then drag through the area you want to display, left-clicking each time you change direction.

   Drag and click as if you’re creating the outline of the area, ending up at the same point where you started, to get roughly the shape of the area you intend.
4. Release the mouse button when you reach the end of the area, to stop drawing.

To add an area drawing with Touchscreen Edit mode disabled:

1. Below the Drawing Toolbox, clear the Touchscreen Edit checkbox to disable it.
2. In the Drawing Toolbox preview pane, left-click on the area drawing thumbnail you want to add to your scene.
3. In the output window, left-click on the map where you want the area to start.
4. Move the mouse and left-click at individual points along the area you want to display. Click as if you’re creating the outline of the area, and end up at the same point where you started, to get roughly the shape of the area you intend.

5. Right-click when you reach the end of the area, to stop drawing.

To delete an area drawing:

1. Select the area drawing but don’t click on a location point.
2. Then press the Delete key to remove the drawing.

To edit an area drawing:

• Select the area drawing and do any of the following:
  › Double-click positions along the border of the area drawing to create new location points.
  › Click and hold on a location point and then drag it to a new position to adjust the shape of the area drawing.
  › Click a location point while holding the CTRL key to toggle between a sharp corner and a smooth path at the location point.
    By default the location points are linked and the line forms a smooth round path through the points. Unlinking a location point makes a sharp corner at this position.
  › Click the end of a handle and drag to adjust the shape of the area drawing.
  › Click a location point (turning it red) and press the Delete key to remove the point.

Adding and Editing Line Drawings

Line drawings display a predefined textured line that is created in the Drawing Management Editor. See “Drawing Management Editor” on page 2 for further information.

In the Drawing Toolbox preview pane, line drawings are identified with the line drawing icon, shown below.

![Figure 8.12 Line Drawing Icon](image)

Line drawings can be added with or without Touchscreen Edit mode enabled. Enabling Touchscreen Edit mode makes it possible to draw a line on the screen using your finger. The Touchscreen Edit parameter is located below the Drawing Toolbox. Once added to the scene, the line drawings can be manipulated to change their appearance, location, size, etc.

![Figure 8.13 Touchscreen Edit](image)

To add a line drawing with Touchscreen Edit mode enabled:

1. Below the Drawing Toolbox, select the Touchscreen Edit checkbox to enable it.
2. In the Drawing Toolbox preview pane, left-click on the line drawing thumbnail you want to add to your scene.
3. In the output window, left-click and hold down the mouse button on the map where you want the line to start, then drag the line along the route you want to display.
4. Release the mouse button when you reach the end of the route, to stop drawing.
To add a line drawing with Touchscreen Edit mode disabled:

1. Below the **Drawing Toolbox**, clear the **Touchscreen Edit** checkbox to disable it.
2. In the **Drawing Toolbox** preview pane, left-click on the line drawing thumbnail you want to add to your scene.
3. In the output window, left-click on the map where you want the line to start.
4. Move the mouse and left-click at individual points along the route you want to display.
5. Right-click when you reach the end of the route, to stop drawing.

To delete a line drawing:

1. Select the line drawing but don’t click on a location point.
2. Then press the **Delete** key to remove the drawing.

To edit a line drawing:

- Add a location point to a selected line by double-clicking on or in front of the head of the line.
- Double-click after the last location point to add a new line segment to the line. Continue adding line segments and then right-click to stop adding location points.
- Select a line to see the location points that define the line.
- Click and hold the left mouse button on a location point and drag the point to move it to a new location.
- Click a location point (turning it red) and press the **Delete** key (or click **Ctrl+X**) to remove the point.
- De-select all location points by clicking on the line between the location points or on an area away from the line drawing.
- Click a location point while holding the **CTRL** key to toggle between a sharp corner and a smooth path at the location point.
  By default the location points are linked and the line forms a smooth round path through the points. Unlinking a location point makes a sharp corner at this position.
- Click and drag the white points at either end of the line to change the line width.
- Click and hold the blue point on the handle at the head of the line, while moving it horizontally to reverse the progress of the line and retrace the original path.
  You can also accomplish the same task by clicking the white point at the top corner of the bounding box and moving it to the right or left.
- Use the longitude and latitude parameters in the **Location** section of the **Drawing Editor** to relocate the line on the map.

To connect an icon or text drawing to a line drawing:

1. Place an icon or text drawing into the scene.
2. Move the icon or text drawing onto the head of the line, until a glowing yellow box indicates that the drawing is in the right position to connect.
   The head of the line is the end farthest from the bounding box.
   A connected drawing will be positioned together with the head of the line when the progress property of the line is changed.
   The rotation angle of a connected drawing will be adjusted automatically as it moves along the line, if the **Use Spline Rotation** parameter is enabled for the connected drawing.

To disconnect an icon or text drawing from a line drawing:

- Click and then drag a connected drawing away from the head of the line to disconnect the drawing.
Editing Locator Drawings

Locator drawings display a “map within a map” showing the position of the searched location within the world. Typically, it is placed on the Overlay Layer, though it can also be put into the normal layer. The center of the locator drawing points to the actual position of the camera if a Map Offset is not set in the Drawing Editor.

The appearance of the locator drawing is defined in the Drawing Management Editor.

The area within the locator drawing can be presented by Bing Aerial, Bing Aerial Label or Bing Road maps, as selected in the Locator section of the Drawing Editor.

To edit a locator drawing:

- Click the yellow point in the middle of the bounding box and move the mouse.
  This changes the Map Offset parameters in the Drawing Editor accordingly.
  For information about Map Offset parameters in locator drawings, see “Locator Drawings” on page 7–30.

Editing the Background Drawing

Background drawings are images that can be used to replace the background behind the globe. XPression Maps comes with a default background drawing behind the globe. This background is black with stars to give the impression of outer space.

Background images are by default scaled to be fully visible inside the selected video format. Use the same size as the video format to get a fullscreen background image. The background image will only be visible when the Zoom Level camera parameter is such that the edges of the globe are visible.

The default background drawing can be replaced with another drawing of your choosing from the Scene Properties menu or from the Drawing Toolbox.

To replace the background drawing from the Scene Properties dialog:

1. Click Style > Scene Properties in the menu bar.

2. Select the Use Alpha Channel checkbox, if you want to use the alpha channel in the final output and see a checkerboard pattern in the preview.

3. In the Scene Properties dialog, from the Drawing drop-down, select the background drawing you want to use.

4. From the Mode drop-down, select the scaling of the drawing.
   - Fullscreen shows the background over the whole output window. This may distort the drawing.
   - Letterbox makes the width fit into the output window, while preserving the aspect ratio.
   - Pillarbox makes the height fit into the output window, while preserving the aspect ratio.

5. Close the dialog.
To replace the background drawing from the Drawing Toolbox:

1. In the **Drawing Toolbox**, from the **Group** drop-down, select the group that contains the background drawing you want to use.
2. Left-click and drag the background drawing into the **Output** window or click the drawing and click in the background of the scene.
3. Release the mouse button to replace the current background.

**Ordering Drawings**

You may have several drawings that you want to place one on top of the other, in a scene. For example, you could have an area drawing with a line drawing and icon drawing on top of it and a text drawing to accompany the icon. In such a case, you would want all of the other drawings to appear on top of the area drawing and you might want the text drawing to appear on top of the line drawing. You can use the drawing order commands to move each drawing to the layer in which you want it to appear.

To order a drawing:

1. Click on the drawing in the output window.
2. Click **Edit** in the menu bar and select one of the following options:
   - **Move Drawing To Top** - moves the selected drawing to the top-most position in the scene so that it will appear on top of all other drawings.
     You can also use the keyboard shortcut `Ctrl+PgUp` or click the **Move Drawing To Top** button in the toolbar.

   ![Figure 8.15 XPression Maps Toolbar - Move Drawing To Top](image)

   - **Move Drawing Up** - moves the selected drawing up one layer in the scene.
     You can also use the keyboard shortcut `Ctrl+Up` or click the **Move Drawing Up** button in the toolbar.

   ![Figure 8.16 XPression Maps Toolbar - Move Drawing Up](image)

   - **Move Drawing Down** - moves the selected drawing down one layer in the scene.
     You can also use the keyboard shortcut `Ctrl+Down` or click the **Move Drawing Down** button in the toolbar.

   ![Figure 8.17 XPression Maps Toolbar - Move Drawing Down](image)

   - **Move Drawing to Bottom** - moves the selected drawing to the bottom-most layer in the scene, so that it will appear beneath all other drawings.
     You can also use the keyboard shortcut `Ctrl+PgDown` or click the **Move Drawing To Bottom** button in the toolbar.

   ![Figure 8.18 XPression Maps Toolbar - Move Drawing To Bottom](image)

3. Click **Save** to store your changes to the scene.
Drawing Toolbox

Use the Drawing Toolbox located to the right of the output window, to add drawings from the database to a scene, to create a new drawing or to edit an existing drawing.

You can also designate a default drawing, which is used whenever drawings are generated automatically. For example, you can automatically create a text drawing with the name of a country or a state when the corresponding shape is created. In this case, the settings of the default text drawing are used for the label text drawing. You can designate a default drawing for text, icon and dynamic data drawings.

In addition, you can specify that a text or dynamic data drawing be created exactly at the search location.

See “Drawing Management” on page 7–1 for information on the setup and management of drawings.

To add a drawing to the scene:

1. In the Drawing Toolbox, from the Folder drop-down, select the folder containing the drawing you want to add to a scene.
   Thumbnails of the drawings contained in that folder are displayed in the preview pane.
2. Left-click the thumbnail and then left-click the place in the scene where you want the drawing to appear.
   OR
   Left-click and hold down the mouse button on the thumbnail and drag it to the place in the scene where you want the drawing to appear.
3. Keep clicking in the scene to add more instances of the same drawing to the scene.
   Each click adds another drawing, or in the case of a line or area drawing, another point.
4. Right-click in the scene to end the generation process.

To replace a drawing:

1. In the Drawing Toolbox, from the Folder drop-down, select the folder containing the drawing you want to add to a scene.
   Thumbnails of the drawings contained in that folder are displayed in the preview pane.
2. Left-click and hold down the mouse button on the thumbnail and drag it on top of the drawing you want to replace.
   The position, scale and entered text (if applicable) will remain the same.
To create a new drawing:

1. In the **Drawing Toolbox**, from the **Folder** drop-down, select the folder to which you want to add a new drawing.

2. Click the **New Drawing** thumbnail to open the **Drawing Management Editor**.

   ![New Drawing Thumbnail](image1)

   *Figure 8.20 New Drawing Thumbnail*

3. In the **Drawing Management Editor**, in the **New Drawing** dialog, select the drawing type from the drop-down and click **OK**.

   When you select the icon or background drawing type, you will be taken to the **Open Image File** dialog, from which you can select an image. If you prefer to use one of the default images, close this dialog and select the image from the **Image** drop-down in the **Drawing Management Editor**.

4. Define the properties of the drawing as described in “Managing Drawings” on page 7–5.

5. When you’ve finished defining the properties, click **Done**.
   
   The new drawing is added to the list of drawings in the preview pane of the **Drawing Toolbox**.

To edit a drawing:

1. In the **Drawing Toolbox**, from the **Folder** drop-down, select the folder that contains the drawing you want to edit.

2. In the preview pane, right-click on the thumbnail of the drawing you want to edit and select **Edit Drawing**.
   
   You can also access the **Drawing Management Editor** by clicking **Edit > Manage Drawings** and then selecting the drawing from the group.
   
   The **Drawing Management Editor** opens.

   ![Drawing Management Editor](image2)

   *Figure 8.21 Drawing Management Editor*

3. Define the properties of the drawing as described in “Managing Drawings” on page 7–5.

4. When you’ve finished defining the properties, click **Done**.
   
   Changing the properties of a drawing will affect all scenes using this drawing, except for those scenes that have been exported (have a ".wnm_exp extension).
To designate a default drawing:

1. In the Drawing Toolbox, in the preview pane, right-click the thumbnail of the drawing that you want to designate as the default drawing.
   
   You can designate a default drawing for Text, Icon and Dynamic Data drawings.

2. From the context menu, select Set as Default [name of drawing].
   
   The background of the default drawing will turn yellow.

   ![Figure 8.22 Default Drawing](image)

To create a drawing from the Search location:

1. In the Search Editor, enter a location and click the Search button.

2. In the Drawing Toolbox, in the preview pane, right-click the thumbnail of the drawing that you want to create at the Search location.

   This feature is only available in Text and Dynamic Data drawings.

3. From the context menu, select Create Drawing From Search.

   ![Figure 8.23 Create Drawing From Search](image)

   The selected drawing appears at the exact coordinates of the searched location, with the corresponding content already displayed (location name or weather data, for example).
Flight Points

You can create a flight animation in a scene template in which the map moves from one location to another, by adding flight points in the **Flight Points** editor. You can have multiple flight points in one animation. These flight animations are not recorded in a regular scene animation.

See “Adding a Flight Point” on page 14–15 for more information on creating a flight animation in the HTML5 Client application.

The Flight Points editor can be found in the editor stack next to the output window, as shown in the image below.

![Flight Points Editor Tab Location](image)

**Figure 8.24** Flight Points Editor Tab Location
To create a flight animation:

1. Click on the Flight Points editor tab.
   The Flight Points editor opens.

   ![Flight Points Editor]
   
   *Figure 8.25 Flight Points Editor*

2. With your map open in the output window, navigate to the location where you want the flight to begin.
   - If you want the flight point to just be in the general area, position the map so that the location is in the center of the output window.
   - If you want the flight point to be an exact location, enter the Longitude and Latitude coordinates in the Camera Parameters fields.

   ![Camera Parameters - Longitude and Latitude]
   
   *Figure 8.26 Camera Parameters - Longitude and Latitude*

3. Adjust the Zoom Level, Tilt and Roll parameters, if necessary.
4. In the Flight Points pane, press New to create a flight point with the displayed camera values.

   ![Add Flight Point]
   
   *Figure 8.27 Add Flight Point*

5. Enter the name of the flight point and click OK.
   The flight point is entered into the Flight Points pane, along with the camera parameters for the point.
6. Navigate to the location of the next flight point and repeat steps 2 to 5.
   For a scene template only, the first flight point in the list is integral. The second and any other points will be overwritten in the web interface.
7. Continue entering new flight points until the flight is complete.

The *Flight Points* editor will look something like the following image:

![Flight Points Editor - Populated](image)

**Figure 8.28 Flight Points Editor - Populated**

8. Click the key frame button beside the **Start** button to add a camera key frame at each flight point.

To view a flight simulation:

- Click **Start** to view the flight in the output window.

To delete a flight point:

1. In the **Flight Points** pane, select a flight point.
2. Press **Delete**.

To edit a flight point:

1. In the **Flight Points** pane, select the flight point you want to edit.
2. Edit the **Camera Parameters**, as necessary.
3. Press **Update** to save the new camera parameter values into the flight point.
4. Click the **Wait** value and enter a new time in seconds that the animation will pause at the flight point.

You can also add a pause at a flight point by inserting a bookmark at that position. See “**Adding a Pause to a Flight**” on page 9–38 for instructions.
Animation Control

In XPression Maps, select drawing parameters can be animated in the Drawing Editor. The parameters that can be animated have a key frame button to the right of the input field.

To create or delete a key frame:

- Click the key frame button beside the parameter.

![Drawing Editor with Parameters Key Framed](image)

*Figure 8.29* Drawing Editor with Parameters Key Framed

When the key frame button is yellow, it indicates that a key frame exists in the timeline for this parameter. When the key frame button is cleared, no key frame exists in the timeline for this parameter.

To set the easing method:

1. Right-click the key frame radio button beside the parameter.
2. From the context menu, select Easing.

![Key Frame Easing Selection](image)

*Figure 8.30* Key Frame Easing Selection

3. Then select one of the following easing methods:
   - When easing is set to None ( ), the animation from one key frame to the next is linear (maintains the same speed from beginning to end).
   - When easing is set to Out ( ), the animation from the previous key frame is linear but the animation from this key frame to the next key frame is accelerated.
   - When easing is set to In ( ), the animation from the previous key frame to this one is decelerated, but the animation to the next key frame is linear.
   - If In/Out ( ) is selected, the animation from the previous key frame to this one is decelerated and the starting animation of this key frame is accelerated.
**Timeline**

The timeline is the large horizontal slider at the bottom of the application.

![Timeline](image)

*Figure 8.31 Timeline*

**To manipulate the timeline:**

- Click and drag the handle of the slider to move the position of the animation within the displayed range. The full video animation can be viewed by playing the animation.
- Enter the frame range in the minimum and maximum value fields to the left and right of the slider. The minimum position cannot go below zero. The scale of the timeline is adjusted whenever one of these two values is changed.
- Click the blue left and right arrow buttons (LEFT_ARROW, RIGHT_ARROW) next to the minimum and maximum fields to move the current animation position one frame in the direction of the respective arrow.
- The field at the left end of the timeline displays the current position of the animation.
- Key frames are shown as blue rectangles (KEY_FRAME) on the scale above and below the groove of the timeline slider. The key frames on top correspond to camera, map style, and lock camera key frames. The key frames below correspond to all other key frames. If a drawing is selected, only the key frames of the drawing are shown. All key frames corresponding to the lower scale are shown if there is no drawing selected.
- Press the **Ctrl** key while clicking the **Left Arrow** button (LEFT_ARROW) to move the current animation position to the previous key frame position.
- Press the **Ctrl** key while clicking the **Right Arrow** button (RIGHT_ARROW) to move the current position to the next key frame position.
- Click on a key frame to select it. Selected camera key frames are red. Selected drawing key frames are green.
- Press the **Ctrl** key and click to select multiple key frames or left-click in the timeline and drag a selection box around multiple key frames. The selected key frames change from blue to green (drawing key frames) or red (camera key frames).
- Click and hold the cursor on a key frame and move the mouse to move the key frame to a new location on the timeline.
Camera Control

This section describes the parameters and control functions of the camera views.

The following topics are discussed:

• “Camera Selection” on page 8–22
• “Camera Parameters” on page 8–23
• “Camera Parameter Key Frames” on page 8–24
• “Easing Methods” on page 8–25
Camera Selection

In the camera selection area you can switch between five different camera views: View Camera, Work Camera 1, Work Camera 2, Work Camera 3 and Work Camera 4. The selected camera view is indicated by a red outline.

![Figure 8.32 Camera Selection](image)

**View Camera** displays what will be recorded. You can enable the **Overlay Layer** only when this camera is selected. The other four camera views are the working cameras. These camera views can be used to store other views during editing. For example, if you want to extend an animation to cover a wider area than can be seen in the View Camera, you can do that in a Work Camera. Key frames used to animate the scene are added in the View Camera. The **Camera Key Frame** button is disabled when a Work Camera is selected. Only the view in the working camera is copied to the View Camera, not objects added in the Work Camera.

To set a specific camera view:

1. Click one of the **Work Cameras**.
2. Move the map to the location you want to display in that camera view.
3. Add drawings to the scene if required or extend a line animation.

   The scene will be saved in the selected **Work Camera** and can be copied to the **View Camera** when needed.

   When you save the scene, any **Work Camera** views are saved as well.

To switch to a different camera view:

- Click the corresponding button.

To copy a camera view:

- Drag and drop one camera view button to another camera.

   The destination camera becomes the active camera and has the same view as the source camera. This is useful if you want to save the current camera view before making changes.

To extend an animation using a Work Camera:

1. With the **View Camera** selected, navigate manually to the starting location you want to display on the map or use the **Search Editor** to set the starting location.
2. Adjust the **Zoom Level** to get the view you want.
3. Add a line animation.
   
   See “**Line Animation**” on page 10–6 for instructions.
4. In the **Drawing Editor**, in the **Misc** section, select the **Lock Camera** checkbox.

   This locks the camera to the line drawing, so it will follow the path of the line.
5. Click on **Work Camera 1**.
6. Move the map to a location that is outside of the current scene, to add this location to the scene.
7. Extend the line animation to a point in the new part of the scene.
8. Click the **View Camera**.
9. Now click the green arrow to run the animation.

   You can continue adding new views for **Work Cameras 2, 3, and 4** as needed.
Camera Parameters

There are five parameters that show the actual values for the camera: **Zoom Level**, **Longitude**, **Latitude**, **Tilt**, and **Roll**.

![Camera Parameters](image)

**Figure 8.33 Camera Parameters**

Zoom Level

The **Zoom Level** parameter displays the camera distance to the earth landscape.

A new scene starts with a **Zoom Level** value of 0.

A higher value zooms into the map.

- >30 country level
- >70 region level
- >130 city level
- >180 street level
- 250 is the maximum zoom level. However, satellite maps tend to only appear up to a zoom level of 200.

**To adjust the Zoom Level value:**

- Enter a value in the **Zoom** field.
  - OR
  - Click and drag the up and down arrows beside the **Zoom** field.
  - OR
  - Click in the output window and move the scroll button on the mouse.

Longitude

Along with the **Latitude** parameter, the **Longitude** parameter displays the global position, in degrees, of the location at the center of the output window.

When no drawing is selected, rotating the globe changes this parameter.

**To adjust the Longitude value:**

- Enter a value in the **Longitude** field.
  - OR
  - Click and drag the up and down arrows beside the **Longitude** field.

  * Animating the **Longitude** and **Latitude** parameters with easing will provide the best results when both parameters have the same settings.

Latitude

Along with the **Longitude** parameter, the **Latitude** parameter displays the global position, in degress, of the location at the center of the output window.

**To adjust the Latitude value:**

- Enter a value in the **Latitude** field.
  - OR
  - Click and drag the up and down arrows beside the **Latitude** field.

  * Animating the **Longitude** and **Latitude** parameters with easing will provide the best results when both parameters have the same easing settings.
**Tilt**

The **Tilt** parameter of the camera rotates the globe around the point of the world that is closest to the camera. The range is 0 to 85 degrees.

- At 0, the camera looks down vertically onto the map.
- >0, the camera faces the direction of the horizon, giving the map a perspective angle.

**To adjust the Tilt value:**

- Enter a value in the **Tilt** field.
- OR
- Click and drag the up and down arrows beside the **Tilt** field.
- OR
- Press and hold the Ctrl key, then right-click in the output window and move the mouse up or down.

**Roll**

The **Roll** parameter spins the globe clockwise and counter-clockwise along the axis visible in the output window. For example, turning the globe upside down so that the north pole is at the bottom. The range is 0 to 360 degrees.

**To adjust the Roll value:**

- Enter a value in the **Roll** field.
- OR
- Click and drag the up and down arrows beside the **Roll** field.
- OR
- Press and hold the Ctrl key, then left-click in the output window and move the mouse left or right.

**Pause Dur.**

The **Pause Dur.** parameter pauses the animation for the number of frames entered.

**To add a pause:**

1. Move the timeline slider to the point in the animation where you want to pause.
2. In the **Pause Dur.** field, enter the number of frames for which you want the pause to last (applies to an animation recordings or to touch projects).
   - OR
   - Enter "0" if you want to continue the animation by touching an interactive button on the screen (applies to touch projects only).
3. Then click the key frame button beside the field to add a camera key frame at this point.

**Camera Parameter Key Frames**

Camera parameters can be animated using the key frame button to the right of the input field.

**To create or delete a key frame:**

- Click the key frame button beside the parameter.

![Camera Parameters with Zoom Level Key Framed](image)

*Figure 8.34 Camera Parameters with Zoom Level Key Framed*

When the key frame button is yellow, it indicates that a key frame exists in the timeline for this parameter. When the key frame button is cleared, no key frame exists in the timeline for this parameter.
Easing Methods

You can select an easing method to control how the animation behaves as it approaches and leaves the key frame.

To set the easing method:

1. Right-click the key frame radio button beside the parameter.
2. From the context menu, select Easing.

![Figure 8.35 Camera Parameters Key Frame Easing Selection](image)

3. Then select one of the following easing methods:
   - When easing is set to None ( ), the animation from one key frame to the next is linear (maintains the same speed from beginning to end).
   - When easing is set to Out ( ), the animation from the previous key frame is linear but the animation from this key frame to the next key frame is accelerated.
   - When easing is set to In ( ), the animation from the previous key frame to this one is decelerated, but the animation to the next key frame is linear.
   - If In/Out ( ) is selected, the animation from the previous key frame to this one is decelerated and the starting animation of this key frame is accelerated.
   - Automatic ( ) is the default setting and simulates a “flight” between key frames. The animation zooms out from the starting key frame, moves to the next key frame and zooms back in. When using this method, it is best to set key frames for each of the 5 camera parameters at the same timeline positions. It is necessary to at least have key frames on the Zoom level.

All parameters must have the same easing method. When you select an easing method for one parameter, the rest will automatically change to the same one.
Safe Title / Safe Area

The Safe Title settings allow you to configure the position of the safe area, map attribution and logo in the output window.

The Safe Area is the area inside the output window defined by the white rectangles. Keep all your drawings and information inside this area for full visibility on air.

![Safe Title / Safe Area](image)

**Figure 8.36 Safe Title / Safe Area**

To configure the Safe Title / Safe Area:

1. Click the **Settings** icon beside the **Safe Title** drop-down.
   - The **Safe Title Management Editor** opens.

![Safe Title Management Editor](image)

**Figure 8.37 Safe Title Management Editor**

2. Click **New** to set up a new configuration.
   - The default configuration is called **Full Screen**.
3. In the **Name** field, enter a name for the new configuration.
4. In the **Action Safe** section, use the arrows or enter a value in the **Left**, **Right**, **Lower** and **Upper** fields to adjust the size of the outer rectangle (the red rectangle in the image below).

![Figure 8.38 Safe Title / Safe Area Outer and Inner Rectangles](image)

Entering values of 0.00 in all these fields will make the entire output window a safe area.

5. In the **Title Safe** field, use the arrows or enter a value to adjust the size of the inner rectangle (the yellow rectangle in the image above).

The Bing logo and attribution text can only be positioned within the inner rectangle (the **Title Safe** area).

6. In the **Attribution** section, use the arrows or enter values in the **Position X** and **Y** fields to adjust the location of the attribution text within the inner rectangle.

You can also left-click and drag the attribution in the **Output** window (while the **Safe Title Management Editor** is open) to position it.

7. In the **Bing Logo** section, use the arrows or enter values in the **Position X** and **Y** fields to adjust the location of the Bing logo within the the inner rectangle.

You can also left-click and drag the Bing logo in the **Output** window (while the **Safe Title Management Editor** is open) to position it.

8. When you have the configuration you want, click **Done** to save it.

You can create as many different **Safe Title / Safe Area** configurations as you need.
Overlay Layer

The overlay layer is an editing area independent of the camera view. Drawings placed in the overlay layer will not move together with the underlying map; they will stay on an invisible layer in front of the camera. Drawings on the overlay layer can be animated the same way as all other drawings. The overlay layer is useful for placing logos or text that you want to keep in the same spot regardless of the movement of the map or drawings.

To use the Overlay layer:

1. Select the Overlay checkbox next to the camera view buttons.
   A transparent gray overlay indicates that the overlay layer is activated.
2. Place your drawings on the map.
   Drawings placed on the Overlay layer are fixed in place and can only be selected and edited or deleted when the Overlay layer is activated.
   In the example below, the title text “U.S. ELECTION 2020” is placed on the Overlay layer and remains stationary while the scene animation is played.

![Overlay Layer](image)

3. Deselect the Overlay checkbox to return to your main layer and play your animation.

Figure 8.39 Overlay Layer
Saving a Scene

Saving a scene will store all information about the scene including camera flights and drawings with references to the drawings in the database. Saved files have the extension *.wnm.

Scenes can be opened in XPression Maps where they were created. Saved scenes use the references to the drawing database to create the drawings. Changes made to the drawings in the database will affect any scene that uses those drawings, unless the scene has been exported.

See “Exporting a Scene” on page 8–30 for further information.

If Compact Scene on Save is selected in Preferences > Output, all unused styles in the map style list and in the shape style list are removed.

To save a new scene:

1. Click File > Save in the menu bar or click the Save button in the toolbar.

   ![Figure 8.40 XPression Maps Toolbar - Save](image)

   The file browser opens.

   ![Figure 8.41 Save File](image)

2. Select a folder or destination where the scene is to be saved.
   The default location is C:\XPressionMaps_3.0\Scene.

3. In the File name field, enter a name for the scene.

4. Click Save.

To save an existing scene with a new name:

1. Click File > Save As in the menu bar or click the Save button in the toolbar.

   ![Figure 8.42 XPression Maps Toolbar - Save](image)

2. In the Save As window, in the File name field, enter a new name for the scene and click Save.
Exporting a Scene

Exporting a scene saves a scene along with all of the drawings used in the scene. This way a scene can be opened in any XPression Maps application and changes to drawings in the database do not affect the exported scene.

After opening an exported scene, drawings saved in the scene are shown in the Drawing Toolbox, in the Imported Scene Drawings section, from where they can be used again in the scene. Exported files have the extension .wnm_exp. When the scene is edited and saved again it is automatically saved as an exported file.

☆ Compact Scene on save is selected in Preferences > Output, all unused styles in the map style list and in the shape style list are removed.

To export a scene:

1. Click File > Export in the menu bar.
   The file browser opens.
2. Select a folder or destination where the scene is to be exported.
3. Click Save.
   The file browser closes and the scene is exported to the selected location, with the extension .wnm_exp.

☆ Export the scene for use in different XPression Maps applications and for archiving a scene. This ensures that changes in the drawing database will not affect the scene.

To open an exported scene:

1. Click File > Open.
2. In the file browser, from the File Type drop-down, select XPression Maps export files (*.wnm_exp).
   The browser will be populated with a list of exported files.
3. From the list of files, select the exported file you want and click Open.

To use imported scene drawings:

1. Open an exported scene.
2. In the Drawing Toolbox in the Imported Scene Drawings section, click on a drawing and then click on the scene in the Output Window to add the drawing to the scene.
   The Imported Scene Drawings section is hidden, unless there is an exported scene open in the Output window.
Editors

A group of editors located on either side of the output window allows you to create and edit shapes and drawings used in your maps, search for locations and shapes, create bookmarks for frequently used locations and customize your OpenStreetMap scenes.

The editors can be docked to the left or right of the output window, using the docking icon in the top-right corner of the editors.

See the following topics for further information:

- “Shape Editor” on page 9–2
- “Drawing Editor” on page 9–16
- “Search Editor” on page 9–26
- “Bookmark Editor” on page 9–35
- “OSM (OpenStreetMap) Style Editor” on page 9–39
Shape Editor

XPression Maps comes with a library of national and interstate borders from around the world, allowing you to integrate political information quickly and easily. You can fill in one or more countries, states or regions with color for greater emphasis and apply map colors and outlines to your own layouts. You can also add, edit and delete predefined or custom shapes.

Use the Shape Editor, shown below, to modify the parameters of the shapes. The Shape Editor displays a list of all the shapes that have been added to the current scene.

![Figure 9.1 Shape Editor Location](image)

The following topics are discussed in this section:

- “Adding and Deleting Shapes” on page 9–3
- “Editing Shapes” on page 9–5
- “Relocating Shapes” on page 9–7
- “Shape Styles” on page 9–8
- “Shape Style Properties” on page 9–12
In the upper portion of the Shape Editor there is a list of the shapes in the current scene. Icons indicate if the shape is a country ( ), a state ( ), or a region ( ). Up and Down arrows are located to the right of the top level shape, allowing you to change the order of the shapes in the list. For example, pressing the up arrow moves the shape up one line (if possible). Each shape is on its own layer and the order of the list corresponds to the order of the layers, where the first line is the back (or bottom) layer and the last line is the front (or top) layer. The shapes shown in the list appear in the scene in the Output window as shown in the following diagram.

![Figure 9.2 Illustration of Shapes in a Scene](image)

Adding and Deleting Shapes
In order to add a shape to the scene, you have to first find and select the shape in the Search Editor.

To add a shape:

1. In the Search Editor, in the Filter section, select the checkbox for Country, States and/or Region depending on the location for which you are searching.

2. In the Location field, enter the location you want to display in the scene and click Search.
   
   For more accurate results, be specific about the location you want to search. Enter the region, province/state and country in the Location field, separated by commas, as in the example shown below:
   
   Ottawa, Ontario, Canada

3. Then, in the Search Related Shapes list, double-click the shape you want to add to the scene.
   
   The default shape style is automatically applied to the shape, Country Default for a country, State Default for a state and Region Default for a region. The shape style can be changed in the Shape Editor. The shape name appears in the Name list of the Shape Editor.

OR

1. In the Search Editor, click Shape Database Viewer, navigate through the list to the shape you want to add and double-click the shape.

2. Then click Done to close the Shape Database Viewer.
   
   The default shape style is automatically applied to the shape, Country Default for a country, State Default for a state and Region Default for a region. The shape style can be changed in the Shape Editor.

   The shape name appears in the Name list of the Shape Editor.

   You can also add a custom shape, that you’ve created yourself. See “Custom Shapes” on page 12–2 for further instructions.
To add child shapes:

1. In the **Shape Editor**, once a country or state shape has been added, select the shape for which you’d like to add the states or regions.

2. Right-click the selected shape and from the context menu, select **Load Children**.

   ![Figure 9.3 Add Child Shapes](image)

   - If a country shape has been selected, all the states of that country are loaded and displayed hierarchically below the country.
   - If a state shape has been selected, all the regions of that state are loaded and displayed hierarchically below the state.
   - It is possible that no children exist for a shape (for example, no regions are available for a state or the shape is already a region).

To delete a shape:

1. In the **Shape Editor**, from the list of shapes, select the shape you want to delete.

   ![Figure 9.4 Delete Shape](image)

2. Right-click the selected shape and from the context menu, select **Delete**.
   - Press **Ctrl** and click on another shape name in the list to select multiple shapes to delete.
   - Click a shape in the list, then press **Shift** and click on another shape to select all the shapes between the first and last selected shape to delete.
   - If children have been loaded, select and right-click the parent shape and from the context menu, select **Delete Children** to remove all the child shapes.
Editing Shapes

In the Shape Editor, you can apply a predefined style to a shape and overwrite certain parameters, allowing you to change the appearance of an individual shape without changing the style itself. This is useful if you have applied the same style to multiple shapes and don’t want to change all of them.

You can also change the opacity and visibility of the shape, add an image to the shape and edit the shape boundaries.

Finally, you can create new Shape Styles to suit your production. See “Shape Styles” on page 9–8 for more information.

To edit a shape:

1. In the Shape Editor, select the shape you want to edit.
   - Press Ctrl and click on another shape in the list to select multiple shapes.
   - Click a shape in the list, then press Shift and click on another shape to select all the shapes between the first and last selected shape to edit.
   - A shape can also be selected by clicking on it in the output window.

2. In the shape list, double-click the shape or right-click the shape and select Go to Shape on Map from the context menu to adjust the view of the camera so that the shape is centered in the output window.

   ![Go to Shape](image)

   **Figure 9.5 Go to Shape**

3. From the Style drop-down, select a predefined shape style to apply to the shape.

   When a shape is selected, the Style drop-down indicates which shape style is currently applied to that shape.

4. In the Overwrite Style section, you can adjust the following default parameters of the selected shape style:
   - **Zoom In** — enable this checkbox, then enter or select a value to define at which camera Zoom Level the shape will be visible. If Visible is enabled, the shape will not be visible as long as the camera Zoom Level value is smaller than the Zoom In value.
   - **Zoom Out** — enable this checkbox, then enter or select a value to define at which camera Zoom Level the shape will be visible. If Visible is enabled, the shape will not be visible as long as the camera Zoom Value is larger than the Zoom Out value.
   - **Area Color** — enable this checkbox, then click the Color button to open the Color Selection editor and select a color to overwrite the color of the selected shape style.

   The color style overwrite can also be applied in tandem with the Zoom In and Zoom Out overwrite parameters when they are enabled.

5. In the Properties section of the editor:
   a. Enter a value or use the arrows to adjust the Opacity.
      - A value of 1 makes the shape completely opaque (a solid color).
      - A value between .99 and .01 makes the shape increasingly transparent.
      - A value of 0 makes the shape invisible.

      Opacity does not affect children associated with the shape.
   b. Select the Visible checkbox to display the selected shape and its children.

      If the Visible checkbox is cleared, only the parent shape will be displayed.

      Shapes will blend in or out for the number of seconds set in the Effect In and Effect Out parameters set in the Edit Shape Style editor when animated, starting at the key frame that makes the drawing visible or invisible. See “Shape Style Properties” on page 9–12.
   c. In the Scale fields, enter a value or use the arrows to adjust the Scale of the shape.
d. In the Offset fields, enter a value or use the arrows to increase or decrease the value by which the shape will be offset from the actual boundaries.
   - The X field offsets the shape horizontally.
   - The Y field offsets the shape vertically.

e. Select the checkbox beside the Offset fields to be able to move the shape to a different location.
   For details about using this feature, see “Relocating Shapes” on page 9–7.

f. In the Extrude field, enter a value or use the arrows to increase or decrease the height of the extruded shape.
   - This setting becomes more visible if the map is tilted.

6. In the Media section:
   a. Select the Use checkbox, if you want to use an image file in the scene.
      When the Use checkbox is selected, the Type and File fields and File Browse button become available.
   b. From the Type drop-down, select the type of media file to use.
      - Currently, only the File type is supported.
   c. Click the Browse button beside the File field to navigate to the media file you want to use in the scene.
      - The supported media file formats are .jpg and .png.
   d. In the Scale fields, enter a value or use the arrows to increase or decrease the size of the image.
      - The X field adjusts the size of the image horizontally.
      - The Y field adjusts the size of the image vertically.
   e. In the Translate fields, enter a value or use the arrows to move the image within the shape.
      - A positive value in the X field moves the image to the right horizontally.
      - A negative value in the X field moves the image to the left horizontally.
      - A positive value in the Y field moves the image up vertically.
      - A negative value in the Y field moves the image down vertically.
   f. In the Angle field, enter a value or use the arrows to tilt the image.
      - A positive value tilts the image towards the right.
      - A negative value tilts the image towards the left.
   g. From the Mapping drop-down, select one of the following options to define how an image is displayed in the selected shape:
      - UV Relative: The image is locked to the shape and moves with the shape. When this option is selected, the image is placed at a pre-calculated position relative to the shape center and cannot be moved.
      - UV Absolute: The image is locked to the shape and moves with the shape. When this option is selected, you can adjust the Long. and Lat. values to position the image where you want it within the shape. You can also adjust the Size of the image.
      - UV Static: The image is locked to the background, so when you move the shape, you see different parts of the image.
   h. Select the Repeat checkbox, if you want the image file to repeat to fill the selected shape or leave it blank if you want only one instance of the image.
   i. In the Long. and Lat. fields, enter a value or use the arrows to adjust the values to position the image within the selected shape (available for the UV Absolute option only).
   j. In the Size field, enter a value or use the arrows to increase or decrease the size of the image (available for the UV Absolute option only).

If the color of the shape style that has been applied to the shape conflicts with the colors in the image, you can overwrite the color in the Overwrite Style section of the Shape Editor. Refer to step 4 on page 9-5 for further information.
Relocating Shapes

There are cases where you want to see all states, territories, districts, etc of a country in your scene, but some are far from the mainland. For example, in the United States, Alaska and Hawaii are not visible when the camera is centered on the mainland. Fortunately, you can move the shapes of the areas that are out of view.

If the shape style you’re using includes labels, you may need to move the default locations of the labels in the Shape Database Viewer.

For instructions on moving the labels, see “Shape Label Properties” on page 9–31.

To relocate the state shapes, you’ll need to first isolate them and then move them. You may also need to resize the shapes to make them fit in the scene and be properly visible.

To isolate the state shapes:

1. At the bottom of the Search editor, click the Shape Database Viewer button and select the country you want to illustrate in your scene.
2. Click the arrow to expand the country and then select the country name.
3. On the right side of the Shape Database Viewer, click Add State Shape.
4. Then select the states that are not visible when the camera is centered on the mainland of the country and click Add State Shape for each. The default shape style is added but can be changed if necessary. See “Shape Styles” on page 9–8.
5. In the Shape editor, in the Name list, right-click on the country name and from the context menu, select Load Children.
6. In the Children list, select each of the states that you added separate shapes for in the Shape Database Viewer and press the Delete key.
7. Collapse the list. You should have the country name and the states you selected from the Shape Database Viewer displayed.

To move the state shapes:

1. Select one of the shapes you want to move.
2. In the Shape editor, in the Properties section, select the checkbox beside the Offset parameters.
3. Then left-click and drag the shape close to the mainland of the country.
4. If necessary, use the Scale parameters to resize the shape.
5. When the shape is positioned and sized as necessary, deselect the checkbox.
6. Click File > Save.

The image below is an example of how you might relocate Alaska and Hawaii.

Figure 9.6 Relocating Shapes
Shape Styles

XPRESSion Maps comes with a set of predefined shape styles that can be applied to the shapes you add to your scene. The styles are available through the Style editor, in the Style section, as described in Step 3 of “To edit a shape style:” on page 9–10. You can also create your own custom shape style in the Shape Style Manager.

To create a new shape style:

1. In the Style editor, in the Style section, click the Browse button ( ) beside the Style drop-down. The Shape Style Manager opens, displaying a list of predefined styles.

   ![Shape Style Manager](image)

   **Figure 9.7 Shape Style Manager**

2. Click Add.

   The Add Shape Style dialog opens.

   ![Add Shape Style](image)

   **Figure 9.8 Shape Style Manager - Add Shape Style**

3. In the Name field, enter a name for the new shape style.

4. If you want to copy the properties of one of the existing styles, from the Copy from drop-down, select the style you want to copy and click OK.
5. Edit the shape style as necessary.  
   See “Shape Style Properties” on page 9–12 for information on editing shape style properties.

6. When you have finished editing the shape style properties, click OK.  
   In the Shape Style Manager, your new style is added to the list and the Save icon appears beside it.

![Figure 9.9 Edit Shape Style Dialog](image)

Figure 9.9 Edit Shape Style Dialog

![Figure 9.10 Shape Style Manager](image)

Figure 9.10 Shape Style Manager
7. Click the **Save** icon and in the **Save Shape Style** confirmation dialog, click **Yes** to save the new shape style into the shape style database.

   If you don’t save the shape style, it will only be applied in the current scene and will not be available to use again.

   ![Save Shape Style Confirmation Dialog](image)

   **Figure 9.11** Save Shape Style Confirmation Dialog

8. Then click **Done** to close the **Shape Style Manager**.

**To edit a shape style:**

1. In the **Shape Editor**, in the **Style** section, click the **Browse** button beside the **Style** drop-down.

   The **Shape Style Manager** opens, displaying a list of predefined styles.

2. Select the shape style you want to change and click **Edit** or double-click the shape style.

   The **Edit Shape Style** dialog opens.

3. Edit the properties of the new style and click **OK**.

   See “**Shape Style Properties**” on page 9–12 for information on editing shape style properties.

   The **Edit Shape Style** dialog box closes and the **Shape Style Manager** reopens. The edited style is highlighted and the **Save** icon and **Reset** icon are displayed beside it.

   ![Shape Style Manager](image)

   **Figure 9.12** Shape Style Manager

4. Click the **Save** icon and in the **Save Shape Style** confirmation dialog, click **Yes** to save the shape style into the shape style database.

   An exclamation mark at the left of the shape style indicates that the style is saved in the scene but not in the database. That style will not be available to be used in other scenes.

   **OR**

   Click the **Reset** icon and in the **Reset Shape Style** confirmation dialog, click **Yes** to reset the shape style to its previously saved state.

5. Then click **Done** to close the **Shape Style Manager**.
To delete a shape style:

1. In the Shape Editor, in the Style section, click the Browse button ( ) button beside the Style drop-down. The Shape Style Manager opens, displaying a list of predefined styles.

   ![Shape Style Manager](image)

   *Figure 9.13  Shape Style Manager*

2. Select the shape style you want to delete and click Delete.

3. In the Delete Shape Style confirmation dialog, click Yes to delete the style.

   ![Delete Shape Style Confirmation](image)

   *Figure 9.14  Delete Shape Style Confirmation*

4. Then click Done to close the Shape Style Manager.
Shape Style Properties

Many of the properties of shape styles can be customized for a different appearance. Properties such as border and fill area color, name visibility and style and the zoom level at which the shape style becomes visible can be edited in the Edit Shape Style dialog. Changes in these properties are visible in the output window but not saved into the Shape Style until you click OK.

If the shape is a state rather than a country, the corresponding regions are shown, if available. Names and borders of regions are available only for states that have region shapes defined. Check the Shape Database Viewer to see whether region shapes are available for a state.

See “Shape Database Viewer” on page 9–30 for information about the Shape Database.

If the shape is a region, the settings in the Children Shape Properties section do not have any effect.

These properties and others are described in the table below.

<table>
<thead>
<tr>
<th>Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Enter a name for the new style</td>
</tr>
<tr>
<td>Default For</td>
<td>Use the drop-down to select whether you want to make this style the default style for countries, states, or regions, or not make it the default for anything (by selecting None). Only one default style exists for each country, state or region. Setting a style to default will over-ride any previously defined default style.</td>
</tr>
<tr>
<td>Border</td>
<td>When enabled, the outline of the shapes using this style will be displayed in the color that is set in the corresponding Color Selection editor to the right of the checkbox. Borders are drawn on top of the selected map style and therefore take precedence over the borders of the map style. The border width can be adjusted by entering a value or using the arrows to increase or decrease the value in the field beside the checkbox. Maximum is 10 pixels.</td>
</tr>
<tr>
<td>Fill Area</td>
<td>When enabled, the shapes using this style will be filled with the color that is set in the corresponding Color Selection editor to the right of the checkbox.</td>
</tr>
<tr>
<td>Name</td>
<td>When enabled, the name associated with the shape will be visible in the output and will be the color that is set in the corresponding Color Selection editor to the right of the checkbox. The size of the name can be scaled by entering a value or using the arrows to increase or decrease the value in the field beside the checkbox. When not enabled, no name is displayed. This can be useful if you are using a map style that includes names.</td>
</tr>
<tr>
<td>Name Style</td>
<td>Use the drop-down to select a text drawing style to apply to the names. When you select a Name Style, you can preview it in the Output window, but it is not saved into the Shape Style until you click OK.</td>
</tr>
<tr>
<td>Use Abbreviation for Name</td>
<td>When enabled, abbreviations will be used for the names of the top level shapes. Children shapes need to be separately configured</td>
</tr>
<tr>
<td>Use Scene Style Shading</td>
<td>When enabled, the height shading in the scene will be displayed. In order for this to work, the Height Shading parameter in the Edit Map Style editor must also be enabled. See “Height Shading” on page 5–13 for more information.</td>
</tr>
<tr>
<td>Apply Ocean Mask</td>
<td>When enabled, all parts of a shape that extend into the ocean will be hidden. In order for this to work, the Ocean Mask overlay parameter in the Edit Map Style editor must also be enabled. See “Overlay” on page 5–11 for more information.</td>
</tr>
<tr>
<td>Properties</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| **Zoom In**         | Enter or use the arrows to select the camera **Zoom Level** value at which the shape will be visible.  
If the camera **Zoom Level** value is smaller than the **Zoom In** value, the shape will not be visible. |
| **Zoom Out**        | Enter or use the arrows to select a camera **Zoom Level** value at which the shape will no longer be visible.  
If the camera **Zoom Level** value is larger than the **Zoom Out** value, the shape will not be visible. |
| **Effect**          | These two parameters define how a shape appears and disappears during its visible animation. This effect can be seen when the animation is played or when the zoom level is changed.  
- **In** - When set to **Dissolve**, the shape will blend in for the number of seconds selected in the corresponding field, starting at the key frame at which the shape is set to appear.  
When set to **None**, the shape appears at the frame to which the key frame is set.  
- **Out** - When set to **Dissolve**, the shape will blend out for the number of seconds selected in the corresponding field, starting at the key frame at which the shape is set to disappear.  
When set to **None**, the shape disappears at the frame to which the key frame is set. |
| **Blend Mode**      | Use the drop-down to select how the **Fill Area** color of the shape is combined with the underlying map. The options are:  
- **Regular** — the area color is combined with the underlying map color.  
This is the most common blend method.  
- **Multiply** — the area color is multiplied with the underlying map color.  
- **Add** — the area color is added to the underlying map color.  
- **Hue From Map** — the hue (dominant color) of the shape style is discarded and the hue of the underlying map is used instead.  
- **Saturation From Map** — the saturation (intensity) of the shape style is discarded and the saturation of the underlying map is used instead.  
- **Value From Map** — the value (lightness or darkness) of the shape style is discarded and the value of the underlying map is used instead.  
- **Saturation and Value From Map** — the hue (dominant color) of the shape style is combined with the saturation (intensity) and value (lightness or darkness) from the underlying map. |
| **Children Shape Properties** | Description                                                                                                                                 |
| **Borders**         | When enabled, state or region borders will be visible in the output. Enter or use the arrows to select a width for the child borders.  
Click the **Color** button to open the **Color Selection** editor and set a color for the child borders. |
| **Names**           | When enabled, the names of the states or regions will be visible in the output. Enter or use the arrows to select a size for the name of the children.  
Click the **Color** button to open the **Color Selection** editor and set a color for the child names.  
The name style is determined by the **Name Style** selected in the **Properties** section. |

The **Height Shading** and **3D** of the scene style is also applied to the shapes.
<table>
<thead>
<tr>
<th>Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database Automation</td>
<td>When <strong>Database Automation</strong> is enabled and <strong>Border Color</strong> is selected, the border color queried from the SQL database that is defined in the file selected in the <strong>File</strong> field is applied to the shape.</td>
</tr>
<tr>
<td></td>
<td>When <strong>Database Automation</strong> is enabled and <strong>Fill Area Color</strong> is selected, the fill area color queried from the SQL database that is defined in the file selected in the <strong>File</strong> field is applied to the shape.</td>
</tr>
<tr>
<td>File</td>
<td>Click the <strong>Browse</strong> button beside the <strong>File</strong> field to navigate to the .xml configuration file which contains the pointer to the <strong>Shape Color Database</strong> in which the <strong>Border</strong> and <strong>Fill Area</strong> colors are defined.</td>
</tr>
</tbody>
</table>
**Drawing Editor**

Use the **Drawing Editor**, shown below, to modify the parameters of a selected drawing that has been added to the map. If a parameter is greyed out, it doesn’t apply to the selected drawing.

![Figure 9.1 Drawing Editor Location](image)

The following topics are discussed in this section:

- “**Common Parameters**” on page 9–17
- “**Specific Parameters**” on page 9–19
  - “**Line Drawing Parameters**” on page 9–20
  - “**Text and OSM Replacement Drawing Parameters**” on page 9–21
  - “**Area Drawing Parameters**” on page 9–22
  - “**Magnifier Drawing Parameters**” on page 9–23
  - “**Locator Drawing Parameters**” on page 9–24
  - “**Dynamic Data Drawing Parameters**” on page 9–25
Common Parameters

The upper part of the Drawing Editor contains the parameters that are common to most drawings. Select the drawing in the scene before adjusting the parameters.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Location</td>
<td>The Longitude and Latitude parameters, in degrees, determine the location of the selected drawing. Click the radio buttons beside the Longitude and Latitude fields to add a key frame for that location. Right-click the radio buttons to select an Easing method for the animation to and from that key frame.</td>
</tr>
<tr>
<td>Rotation</td>
<td>The Angle parameter, in degrees, determines the rotation of the selected drawing. This parameter does not apply to Line and Area drawings.</td>
</tr>
<tr>
<td>Size</td>
<td>The Scale and Zoom parameters are used to resize a drawing. New drawings are always created in the same size in pixels. When a drawing is created in the Drawing Management Editor, the default Scale value is 1.</td>
</tr>
<tr>
<td></td>
<td>• Scale - Enter a value or use the arrows to increase or decrease the scale of the drawing in the Output window. For Line drawings, the Scale parameter adjusts the width of the line.</td>
</tr>
<tr>
<td></td>
<td>• Zoom - Enter a value or use the arrows to increase or decrease the zoom level of the drawing. Adjust the camera Zoom Level of the map to the level at which you want the drawing to appear before adding it.</td>
</tr>
<tr>
<td></td>
<td>• Auto - when checked, the drawing remains the same size in pixels, while the camera animates through the different zoom levels. When unchecked, the drawing increases or decreases in size as the camera animates through the different zoom levels.</td>
</tr>
<tr>
<td>Aspect</td>
<td>The Value parameter increases or decreases the width of the drawing, relative to the height.</td>
</tr>
<tr>
<td></td>
<td>• If the value is less than 1, the width (X) decreases relative to the height (Y).</td>
</tr>
<tr>
<td></td>
<td>• If the value is greater than 1, the width increases relative to the height. When you make the drawing larger or smaller by clicking and dragging a corner of the bounding box, the set Aspect ratio is maintained. The default is 1.</td>
</tr>
</tbody>
</table>
### Misc
Parameters that affect visibility and the speed of the animation.
- **Opacity** - Enter or select a value between 0 and 1 that defines the transparency of the drawing.
  A value of 1 is opaque and a value of 0 is transparent.
- **Visible** - Select to make the drawing visible.
  It has the same effect as clicking the Eye icon (👁️) in the output window.
- **Frontface** - Select to have the front side of the drawing face the camera.
  You can also toggle this parameter in the output window by clicking the Frontface icon (🪕) at the bottom of the drawing's bounding box.
  This parameter does not apply to Line and Area drawings.
- **Keep Orientation** - Select to align a text drawing to the screen. Clear to align a text drawing to the camera. Applies to **Text** drawings only.
- **Lock Camera** - Select to force the playout camera to look at the drawing.
  The play out camera can no longer be moved in its normal fashion.
  The View Camera button in the camera control area changes to indicate that this camera is locked (🔒). Only one drawing at a time can lock the playout camera.
  For a line drawing, the playout camera looks at the head of the line when locked.
- **Use Spline Rotation** - Select to have the rotation angle of the drawing change according to the direction of the line.
  This parameter is only applicable for drawings that are connected to the head of a line.
  In order to connect a drawing to a line, it must be dragged and dropped to the head of the line in the output window. A yellow rectangle indicates that the drawing will be connected to the line when the drawing is dropped.
  To disconnect a drawing, drag it away from the head of the line until the yellow rectangle disappears.
- **Animation Slowdown** - Enter or select the number of frames in which an image is repeated in an image sequence before the next image is shown.
  The default value is 0.
  This parameter is only applicable to icon, area and line drawings.
  Image sequences loop independently of the timeline animation.

### Effect (In and Out)
These parameters define how a drawing appears (**In**) and disappears (**Out**) during animation.
Options are:
- **None** - the drawing appears instantly at the frame to which the key frame is set.
- **Dissolve** - the drawing blends in over the number of seconds selected in the **Time** field, starting at the key frame at which the drawing is set to appear.
- **Typewriter** - the drawing appears one character at a time over the number of seconds selected in the **Time** field. Applies to text drawings only.
- **Alpha** - the drawing blends in one character at a time over the number of seconds selected in the **Time** field. Applies to text drawings only.
Specific Parameters

The lower part of the editor will display parameters that are specific to the selected drawing. See the following sections for details:

- “Line Drawing Parameters” on page 9–20
- “Text and OSM Replacement Drawing Parameters” on page 9–21
- “Area Drawing Parameters” on page 9–22
- “Magnifier Drawing Parameters” on page 9–23
- “Locator Drawing Parameters” on page 9–24
- “Dynamic Data Drawing Parameters” on page 9–25
Line Drawing Parameters

The **Line** section contains the parameters that are specific to line drawings. Select the line drawing in the scene before adjusting the parameters.

![Line Drawing Parameters](image)

**Figure 9.2 Line Drawing Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Texture</strong></td>
<td></td>
</tr>
<tr>
<td>Aspect</td>
<td>- enter or select an aspect value to define how the image is mapped on the line.</td>
</tr>
<tr>
<td>Scale</td>
<td>- enter or select a scale value to define how the image is mapped on the line.</td>
</tr>
<tr>
<td>Angle</td>
<td>- enter or select an angle value to define how the image is mapped on the line.</td>
</tr>
<tr>
<td><strong>Progress</strong></td>
<td></td>
</tr>
<tr>
<td>Value</td>
<td>- enter or use the slider to select a percentage between 0 and 100 to define how much of the line is visible.</td>
</tr>
<tr>
<td><strong>Point</strong></td>
<td></td>
</tr>
</tbody>
</table>
| Index | - enter or select a value for the active point of the line.  
A value of 0 means no active point.  
The active point is red in the output. All other points are green.  
The active point can also be set by left-clicking the mouse on the point.  |
| Longitude | - enter or select a longitudinal value for the active point of the line.  |
| Latitude | - enter or select a latitudinal value for the active point of the line. |
Text and OSM Replacement Drawing Parameters

The **Text** section contains the parameters for modifying the alignment of text and OSM Replacement drawings. Select the drawing in the scene before adjusting the parameters.

![Text Drawing Parameters](image)

**Figure 9.3 Text Drawing Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Alignment** | ![Left](image) - align the text to the left.  
![Center](image) - center the text.  
![Right](image) - align the text to the right.  
![Justified](image) - align the text to the left and right margins. |
| **Kerning** | Enter a value or use the arrows to set the amount of space between letters. |
| **Line Spacing** | Enter a value or use the arrows to set the amount of space between multiple lines of text. |
| **Text Box** | Use the text box to edit the text on one or more lines. Press the **Enter** key to move text to the next line. |
Area Drawing Parameters

The Area section contains the parameters that are specific to area drawings. Select the area drawing in the scene before adjusting the parameters.

![Image of Area Drawing Parameters]

**Figure 9.4 Area Drawing Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Texture</strong></td>
<td>Aspect — Enter or select a value to define the appearance of the pattern in the area. \nScale — Enter or select a value to define the size of the pattern in the area. \nAngle — Enter or select a value to define the angle of the pattern in the area. \nBlend Mode — Use the drop-down to select how the area texture is mixed with the underlying map. \nThe options are: \n• Regular — the area is blended with the map. \n• Multiply — the area color is multiplied with the map color. \n• Add — the area color is added to the map color.</td>
</tr>
</tbody>
</table>

![Images of Regular, Multiply, Add blend modes]

| **Point** | \n• Index - enter or select a value for the active point of the line. \nA value of 0 means no active point. \nThe active point is red in the output. All other points are green. \nThe active point can also be set by left-clicking the mouse on the point. \n• Longitude - enter or select a longitudinal value for the active point of the area. \n• Latitude - enter or select a latitudinal value for the active point of the area. |
Magnifier Drawing Parameters

The Magnifier section contains the parameters that are specific to magnifier drawings. Select the magnifier drawing in the scene before adjusting the parameters.

![Magnifier Parameters](image)

**Figure 9.5 Magnifier Drawing Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Zoom Level</strong></td>
<td>Enter or select a zoom level between 1 and 21 to define how much detail is displayed in the highlighted area. A higher zoom level value means more detail is shown.</td>
</tr>
</tbody>
</table>
| **Map Style**   | Use the drop-down to select a map style. The options are:  
- Bing Aerial  
- Bing Aerial Label  
- Bing Road  
- Bing Road Dark  
- Bing Road Gray  
- Bing Road Light |
| **Map Zoom**    | Enter or select a zoom value for the highlighted area of a map.  
- 0 - 1: The area is magnified.  
- >1: The area is made smaller.  
The resolution of the map is not changed, so it does not show more or fewer details when zoomed in or out. |
| **Map Offset X**| Enter or select a value to move the highlighted area within the drawing along the X coordinate.                                              |
| **Map Offset Y**| Enter or select a value to move the highlighted area within the drawing along the Y coordinate.                                              |
| **Map Location**| Displays the longitude and latitude coordinates of the highlighted area. This is defined by the position of the drawing at creation.               |
| **Reload Map**  | If you move the magnifier drawing within the scene, click Reload Map to set the Map Location coordinates to the actual location of the drawing. This updates the map in the highlighted area. |
Locator Drawing Parameters

The Locator section contains the parameters that are specific to locator drawings. Select the locator drawing in the scene before adjusting the parameters.

![Locator Drawing Parameters](image)

**Figure 9.6 Locator Drawing Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Zoom Level</strong></td>
<td>Enter or select a zoom level between 1 and 21 to define how much detail is displayed in the highlighted area. A higher zoom level value means more detail is shown.</td>
</tr>
</tbody>
</table>
| **Map Style**   | Use the drop-down to select a map style. The options are:  
  • Bing Aerial  
  • Bing Aerial Label  
  • Bing Road  
  • Bing Road Dark  
  • Bing Road Gray  
  • Bing Road Light |
| **Map Zoom**    | Enter or select a zoom value for the highlighted area of a map.  
  • 0 - 1: The area is magnified.  
  • >1: The area is made smaller.  
  The resolution of the map is not changed, so it does not show more or fewer details when zoomed in or out. |
| **Map Offset X**| Enter or select a value to move the highlighted area within the drawing along the X coordinate.                                                |
| **Map Offset Y**| Enter or select a value to move the highlighted area within the drawing along the Y coordinate.                                                |
Dynamic Data Drawing Parameters

The Dynamic Data section contains the Data Filter parameter which is specific to dynamic data drawings. Select the dynamic data drawing in the scene before adjusting the parameters.

Dynamic Data is an optional feature for XPression Maps and the XPression Maps Server.

![Dynamic Data Drawing Parameter](image)

**Figure 9.7 Dynamic Data Drawing Parameter**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Filter</td>
<td>Defines a filter parameter for the dynamic data query. For example, if you place a Dynamic Data Drawing on the map which draws information about a city from an SQL database, and you want to move this drawing away from the location of the city on the map, enter the name of the city in the Data Filter parameter and use an SQL statement in the Dynamic Data Query such that the SQL statement is using the $(Filter) parameter for the selection of the data. The data will be updated to be specific to that city. Updating requires that you move the drawing slightly in the output window.</td>
</tr>
</tbody>
</table>
Search Editor

Use the integrated Microsoft® search editor to find maps of locations throughout the world by searching for addresses, cities, countries and even prominent buildings. You can also add default names, icons or dynamic data drawings to the scene and edit shape label properties from this editor.

Use the **Search Editor**, shown below to specify a location.

The following topics are discussed in this section:

- “Searching for a Location” on page 9–27
- “Shape Database Viewer” on page 9–30
- “Shape Label Properties” on page 9–31
- “Shape Label Translation” on page 9–32
Searching for a Location

You can search for a location using the Search field or by using the Geo Location button beside the Search button. Both methods are described below:

To search for a location using the Search field:

1. In the Search Editor, in the Search (Location/Address, City, Country) field, enter the location for which you want to find a map.
   - Separate the different parts of the location with a comma, for example, “Ottawa, Ontario, Canada”.
   - Enter more parameters, such as a street address, to narrow the search results.
   - In the Filter section, select the appropriate checkbox if you want to search for a country, state, region or any combination of the three.
2. If you want the map to go directly to the location you are searching, select the Go to Result checkbox.
3. Then click the Search button.

The search results show all locations found that match the entered information.

Where multiple results are returned, the first result is shown in the Output window and lower quality results will be highlighted in yellow in the Result pane in the editor.

In the Search Related Shapes section, a list of the available shapes for the searched location appears. This list is dependent on the search filters selected (Country, States and/or Region).

4. In the Result pane, click the arrow beside the location to see details such as the country and latitude and longitude of the location.

If you haven’t selected the Go to Result checkbox, double-click on any result to switch to that location in the Output window.
To search for a location using Geo Location:

1. Click the Geo Location button located next to the Search button.
   The Geo Location dialog box opens.

   ![Figure 9.3 Geo Location Dialog](image)

2. Enter the Longitude and Latitude coordinates of the location you want to find.
3. Then from the Zoom Level drop-down, select how broad a view you want.
   Options are:
   • Country
   • State
   • City
   • Street
   • Address
4. Click Go To.
   Geo Location moves the map to the specified longitude and latitude.

To add a name, an icon or drawing data to the map:

1. Right-click on a search result.
2. From the context menu that opens, select one of the following options.
   • Add Name to Map: If you have identified a text drawing as the default, the name of the location will be added to the map using the style of the default text drawing.
   • Add Icon to Map: If you have identified an icon drawing as the default, the default icon will be added to the map at the corresponding location.
   • Add Dynamic Data Drawing to Map: If you have identified a dynamic data drawing as the default, the default dynamic data drawing for the corresponding location is added to the map.
To add a shape layer to a location:

1. After searching for a location in the Search Editor, in the Search Related Shapes list, double-click on the country, state or region shape you want to add to the scene.

```
<table>
<thead>
<tr>
<th>Name</th>
<th>In</th>
</tr>
</thead>
<tbody>
<tr>
<td>Canada</td>
<td></td>
</tr>
<tr>
<td>Ontario</td>
<td>Canada</td>
</tr>
<tr>
<td>Ottawa</td>
<td>Ontario</td>
</tr>
</tbody>
</table>
```

![Search Related Shapes List](image)

**Figure 9.4 Search Related Shapes List**

OR

Click the Shape Database Viewer button and select a shape from the database.

To add a label to a shape:

1. In the Label area, select Auto Create to enable labeling.

2. Then, in the Search Related Shapes list, double-click a shape to automatically add a label, if there isn’t already one for that shape.

   The shape keeps a reference to its label so that the label is visible for as long as the shape exists and is visible. This label is created with the default text style and can be moved and scaled like a regular drawing. You can drag a different text style onto the label to change it.
Shape Database Viewer

The Shape Database Viewer provides direct access to the shapes of all countries and their states (and regions, where available). When using the Shape Database Viewer, it is not necessary to first search a location.

The countries are arranged in alphabetical order.

To add a shape:

1. In the Search Editor, select or clear the Adjust Map to New Shape checkbox.
   - When selected, the map in the output window moves to the location of the shape you’re adding and adds the shape at its default zoom level, which is different for each shape.
   - When cleared, you need to manually adjust the map to the area of interest but then each shape is added to the map at the same zoom level.

2. Then click the Shape Database Viewer button.

3. Do one of the following:
   - Select a country from the list.
   - Click the arrow beside a country to select a state from the list.
   - Click the arrow beside a country and then the arrow beside a state to select a region from the list (if regions are available for the selected state).

4. Click the Add State Shape button or double-click the selected country, state or region to create a shape for the country.

The shape appears on the map in the output window and in the Shape list in the Shape Editor.

5. If you want to make changes to the label of a shape, select the shape in the list and click the Edit Label Properties button. See “Shape Label Properties” on page 9–31 for details.

6. When you have finished adding shapes and editing shape labels, click Done to close the Shape Database Viewer.

   The same shape can be created multiple times. This can be useful if you want to swap different views of a single shape. In an election map, for example, you might want a state to change color to show which party controlled the state before and after the election.
Shape Label Properties

The **Shape Label Properties** editor provides access to the label details of a shape and is accessed from the **Shape Database Viewer**. You can change the name of the shape label, the position, the size and the zoom level at which it appears and you can add search terms to the search info.

To edit the shape label properties:

1. In the **Search Editor**, click the **Shape Database Viewer** button at the bottom of the editor.
   The **Shape Database Viewer** opens.

   ![Shape Database Viewer](image)
   *Figure 9.6 Shape Database Viewer*

2. From the list, select the shape whose label you want to edit.

3. Click the **Edit Label Properties** button at the right.
   The **Shape Label Properties** editor opens.

   ![Shape Label Properties Editor](image)
   *Figure 9.7 Shape Label Properties Editor*
4. Edit the parameters in the **Shape Label Properties** editor, as described in the table below, to configure the shape label.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td>The name of the label. You might want to change the name that’s displayed if you are translating it into a language that isn’t configurable in the <strong>Preferences</strong>, i.e. English (en-US), Canadian French (fr-CA) or German (de-de). See “<strong>Shape Label Translation</strong>” on page 9–32.</td>
</tr>
<tr>
<td><strong>Longitude</strong></td>
<td>Enter or use the arrows to select a longitudinal coordinate for the label to reposition it within the shape boundaries. In the output window, the labels for all the shapes associated with your selection appear, so that you can judge how far and in what direction to move the label. Only the label you’ve selected will be changed.</td>
</tr>
<tr>
<td><strong>Latitude</strong></td>
<td>Enter or use the arrows to select a latitudinal coordinate for the label to reposition it within the shape boundaries. In the output window, the labels for all the shapes associated with your selection appear, so that you can judge how far and in what direction to move the label. Only the label you’ve selected will be changed.</td>
</tr>
<tr>
<td><strong>Size</strong></td>
<td>Enter or use the arrows to select a size for the label. The value of the size parameter is equal to the zoom parameter of a drawing. A value of 20 will make the label readable at a zoom level of 20. A larger value will make the label smaller, so that it is readable at a larger zoom value. Valid range is 0.00 to 100.</td>
</tr>
<tr>
<td><strong>Zoom Level</strong></td>
<td>Enter or select the zoom level of the map on which the shape will be created. The shape will become visible at this zoom level.</td>
</tr>
<tr>
<td><strong>Search Info</strong></td>
<td>Enter a group of search terms which can be used to find the shape in the database when searching for a location.</td>
</tr>
</tbody>
</table>

5. Click **Update** to save your changes.
6. Click **Done** to close the **Shape Database Viewer**. The new labels will not yet be updated in the scene.
7. Click **Save**.
8. Then click **File** and select the scene from the **Recent Scenes** list to re-open the same scene and apply the label changes.

**Shape Label Translation**

The shape labels are stored by language (Country code) in the shape database. The default language is English (en-US) and an initial translation for Canadian French (fr-CA) and German (de-de) exists. The labels for other languages need to be changed manually in the **Shape Label Properties** editor.

See “**Shape Label Properties**” on page 9–31 for more information.

The language can be changed in **File > Preferences** in the **Map** tab.
Bookmark Editor

The **Bookmark Editor** allows you to save map positions and organize them in folders for later use.

Use the **Bookmark Editor** shown below, to add and delete folders and bookmarks. These functions are useful for creating presets of commonly used locations. Using folders allows you to categorize bookmarks for different map types, styles, or other use cases. The application saves the bookmarks you’ve created on exit and reloads the bookmarks upon the next start.

The **Bookmark Editor** only saves the map position, not drawings that have been added to the scene. All bookmarks are shown in the currently selected map style, regardless of the map style selected when the bookmark was added. Bookmarks can also be used to add a pause to a flight.

![Figure 9.1 Bookmark Editor Location](image)

The following topics are discussed in this section:

- “Adding and Deleting Bookmark Folders” on page 9–36
- “Adding and Deleting Bookmarks” on page 9–37
- “Recalling and Editing Bookmarks” on page 9–38
- “Saving and Loading Bookmarks” on page 9–38
- “Adding a Pause to a Flight” on page 9–38
Adding and Deleting Bookmark Folders

Keep your bookmarks organized to make them easier to locate by sorting them into folders.

To add a bookmark folder:

1. In the Bookmark Editor, click the arrow beside the Add Bookmark button, to open the Bookmark menu shown below.

![Bookmark Menu](image)

*Figure 9.2 Bookmark Menu*

2. Select Add Folder.

3. In the New Folder dialog, shown below, enter a name for the folder and click OK.

![Add New Bookmark Folder](image)

*Figure 9.3 Add New Bookmark Folder*

The new folder is added at the bottom of the Bookmark tab.

![New Bookmark Folder](image)

*Figure 9.4 New Bookmark Folder*

To delete a folder:

1. In the Bookmark editor, click on the folder you want to delete, to make it the active folder.

2. Then click the arrow beside the Add Bookmark button to open the Bookmark menu.

3. From the Bookmark menu, select Delete Folder.

   The Delete Bookmark Folder confirmation dialog opens.

![Delete Bookmark Folder](image)

*Figure 9.5 Delete Bookmark Folder*

4. Click Yes to delete the folder.
5. The folder is deleted from the current view, but remains

**Adding and Deleting Bookmarks**

Adding a bookmark allows you to quickly get back to a specific location with the same camera parameters that were used when the bookmark was created.

**To add a bookmark:**

1. With the map location selected and displayed in the **Output** window, click **Add Bookmark** at the bottom of the **Bookmark** editor.

   The **New Bookmark** dialog opens.

   ![New Bookmark dialog](image)

   **Figure 9.6 Add New Bookmark**

2. In the **Name** field, add an identifying name for the bookmark and click **OK**.

   A thumbnail of the map is added to the **Bookmark** folder.

**To delete a bookmark:**

1. In the **Bookmark Editor**, select the folder containing the bookmark you want to delete.

2. Click on the red X in the corner of the bookmark.

   ![Bookmark](image)

   **Figure 9.7 Bookmark**

   The **Delete Bookmark** confirmation dialog opens.

   ![Delete Bookmark dialog](image)

   **Figure 9.8 Delete Bookmark Confirmation Dialog**

3. Click **Yes** to delete the bookmark.
Recalling and Editing Bookmarks
You can recall a saved bookmark to include it in your production or to edit the bookmark name.

To recall a bookmark:
1. In the **Bookmark Editor**, select the folder containing the bookmark you want, to open it.
2. Then click on the bookmark thumbnail.

To change a bookmark name:
1. In the **Bookmark Editor**, select the folder containing the bookmark whose name you want to change.
2. Double-click on the name of the bookmark.
3. In the **Change Bookmark Name** dialog that opens, type in the new name and click **OK**.

Saving and Loading Bookmarks
Your bookmarks are automatically saved into a default folder when you exit the XPression Maps application and reloaded when you launch the application. You can also save them into a folder of your choice.

To save your bookmarks:
1. In the **Bookmark Editor**, click the arrow beside the **Add Bookmark** button, to open the **Bookmark** menu.
2. From the **Bookmark** menu, select **Save Bookmarks**.
3. In the **Save File** dialog, navigate to the folder where you want to save your bookmarks and click **Save**.
   The bookmarks are saved in an xml file, which can then be loaded as needed.

To load your saved bookmarks:
1. In the **Bookmark Editor**, click the arrow beside the **Add Bookmark** button, to open the **Bookmark** menu.
2. From the **Bookmark** menu, select **Load Bookmarks**.
3. In the **Load File** dialog, navigate to the folder containing the bookmark file with your saved bookmarks.
4. Select the bookmark file and click **Open**.

Adding a Pause to a Flight
You can use a bookmark to add a pause during a flight animation, for example if you wanted to provide further information at that point in the flight.

To add a pause to a flight:
1. Click **File > Open** to open a flight animation scene in which the flight goes from point A to B to C without stopping.
   Alternatively, you can create a new flight animation.
   For information on creating a flight animation, see “**Flight Points**” on page 8–16.
2. If necessary, move the key frames following flight point B towards the end of the timeline to leave space for the pause.
3. Move the timeline handle to point B and in the **Bookmark Editor**, click **Add Bookmark**.
4. Now move the timeline handle to a position after flight point B, where you want the pause to end and click on the bookmark you created in the previous step.
5. Add a camera key frame at that position.
6. Click the green **Play** button in the animation toolbar to play the animation.
OSM (OpenStreetMap) Style Editor

The OSM Style Editor allows you to customize scenes that use OpenStreetMaps as the map style.

Use the OSM Style Editor shown below, to change the background color of an OSM map as well as the visibility, colors, parameters and labels of the layers of the selected map or its overlay. Each layer contains one element, such as landcover_grass, water, buildings, etc. The elements are grouped into categories to make them easier to find.

![Figure 9.1 OSM Style Editor](image)

All street name suffixes in OSM maps are styled the same in XPression Maps. By default, an abbreviated suffix with no punctuation is used (ST, AVE, RD, DR, etc.). It is possible to change the suffix style. If this is something you would like to do, contact techsupport@rossvideo.com.

The following topics are discussed in this section:

- “Editing Overview” on page 9–40
- “Editing OpenStreet Maps” on page 9–41
- “OSM Replacement Drawings” on page 9–49
- “Show Information Layers” on page 9–52
- “Editing Individual Layer Elements” on page 9–53
Editing Overview

Here is an overview of the procedure for editing OpenStreet maps. For detailed instructions on using the OSM Style Editor, see “Editing OpenStreet Maps” on page 9–41.

To edit and save a new OpenStreet map:

1. In the Map Styles section below the OSM Style Editor, from the Style drop-down, select an OpenStreet map style.
   
   It is preferable to add a new map style copied from an existing style and edit the new one.
   
   For instructions on adding a map style see “To add a new map style:” on page 5–7.

2. Edit the style according to the instructions in Editing OpenStreet Maps.

3. Click Style > Map Styles to open the Map Style Manager.

4. Select the map style you have modified.

5. Click the Save icon to save your changes into the default database or click the Reset icon to discard your changes and revert to the last saved version of the style.
   
   An exclamation mark at the left of the map style indicates that the style is saved in the scene but not in the database. That style will not be available to be used in other scenes.
   
   The Save All button at the bottom of the dialog box saves all changes made to all styles in the database.
   
   The Reset All button at the bottom of the dialog box resets all styles in the database to their last saved version.

6. Click Done to close the Map Style Manager.
**Editing OpenStreet Maps**

This section provides instructions for changing the background color, visibility, layer color, and layer highlight color of an OpenStreet map. It also describes how to edit the layer parameters and individual layer elements.

* Right-click on the layer in the Output window to highlight that layer in the OSM Style Editor.

**To change the background color of an OSM map:**

1. In the OSM Style Editor, from the layer list, select the **Background** layer.
2. Then click the **Color** button.
   
   The Color Selector opens.

   ![Color Selector](image)

   **Figure 9.3 OSM Style Editor Color Selector - Background**

3. Select a color swatch from the **Basic colors** or use the slider or RGB values to create a custom color.
   
   If you create a custom color, click **Add to Custom Colors** so that it’s available for subsequent use.

4. Click **OK**.
   
   The background color changes to the new color.

![Before and After](image)

**Figure 9.4 Background Color Change**
To change the visibility of a layer:

- In the OSM Style Editor, in the Visible column, clear the checkbox beside a layer to hide it or select the checkbox to show the layer.

![Figure 9.5 OSM Style Editor Visibility Checkbox](image)

To change the color of a layer:

1. In the OSM Style Editor, in the Color column, click the color swatch beside the layer.

![Figure 9.6 OSM Style Editor Color Swatch](image)

   The Color Selector for that layer opens.

2. Select a color swatch from the Basic colors or use the slider or RGB values to create a custom color. If you create a custom color, click Add to Custom Colors so that it's available for subsequent use.

3. Then click OK.
To change the highlight color of a layer:

1. In the OSM Style Editor, in the High column, click the highlight color swatch beside the layer.

![Figure 9.8 OSM Style Editor Highlight Swatch](image)

The Highlight Selector for that layer opens.

![Figure 9.9 OSM Style Editor Highlight Selector](image)

2. Select a color swatch from the Basic colors or use the slider or RGB values to create a custom color.
   
   If you create a custom color, click Add to Custom Colors so that it's available for subsequent use.
   
3. Then click OK.
To switch a layer from color to highlight:

- Do one of the following:
  
  Double-click on the layer in the **Output Window** to toggle between using the configured **Color** or **Highlight**. Double-clicking selects all the parts of a layer that have the same ID.

  ![Figure 9.10 Double-click to Change Color](image)

  **Figure 9.10** Double-click to Change Color

  **OR**
  
  Right-click on the layer in the **Output Window** and from the context menu, select **Set Color < Color** or **Set Color > Highlight**. Right-clicking selects the part of the layer on which you are clicking.

  ![Figure 9.11 Right-click to Change Color](image)

  **Figure 9.11** Right-click to Change Color
To edit the parameters of a layer:

1. In the OSM Style Editor, in the Edit column, click the Edit button for the layer you want to edit.

![Figure 9.12 OSM Style Editor Edit Button]

The OSM Layer Parameters dialog opens. There are at least 4 editable parameters for each layer, Use As Information, Zoom In, Zoom Out and Opacity. The other parameters depend on the type of layer that is selected.

![Figure 9.13 OSM Layer Parameters]

2. Select the Use As Information checkbox if you don’t want the layer to appear in the final output but want it showing while you edit the map.

You can also deselect the Visible checkbox for a category of layers if you don’t want any of them to appear in the final output. For example, if you don’t want any buildings in the final output, deselect the building layer checkbox.

3. Enter a value or use the arrows to adjust the Zoom In level at which the layer will appear.

The adjacent field determines the amount of time, in seconds, it will take for the layer to dissolve in.

0.00 = The layer is fully visible as soon as the Zoom In level is reached.

9.00 = The layer dissolves gradually over 9 seconds once the Zoom In level is reached.

4. Enter a value or use the arrows to adjust the Zoom Out level at which the layer will disappear.

The adjacent field determines the amount of time, in seconds, it will take for the layer to dissolve out.

0.00 = The layer disappears immediately after the Zoom Out level has been reached.

9.00 = The layer dissolves gradually over 9 seconds, after the Zoom Out level has been reached.

5. Enter a value or use the arrows to adjust the Opacity of a layer, making it more or less transparent.
6. Adjust any additional parameters as described in the following table:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Background Color</strong></td>
<td>Click the Color button to open the Color Selector and select the color for the Text Background.</td>
</tr>
<tr>
<td><strong>Background Opacity</strong></td>
<td>Enter a value or use the arrows to adjust the opacity of the background color for the text.</td>
</tr>
<tr>
<td><strong>Font</strong></td>
<td>Use the drop-down to select a font for the text.</td>
</tr>
<tr>
<td><strong>Icon Color</strong></td>
<td>Click the Color button to open the Color Selector and select a color for the icon.</td>
</tr>
<tr>
<td><strong>Icon Opacity</strong></td>
<td>Enter a value or use the arrows to adjust the opacity of the icon.</td>
</tr>
<tr>
<td><strong>Icon Size</strong></td>
<td>Enter a value or use the arrows to adjust the size of the icon.</td>
</tr>
<tr>
<td><strong>Icon Text Fit</strong></td>
<td>Select to link the size of the icon to the text or the size of the text to the icon. Some examples are shown below.</td>
</tr>
<tr>
<td><strong>Ignore Collision</strong></td>
<td>When checked, all OSM layers will be displayed, even if they overlap at the current zoom level. When cleared, higher level layers will be displayed until a zoom level is reached that allows room for other level layers to be displayed. Applies to text layers only.</td>
</tr>
<tr>
<td><strong>Line Stipple</strong></td>
<td>Select if you want to give a road a dotted line effect.</td>
</tr>
<tr>
<td><strong>Line Stipple Pattern</strong></td>
<td>Enter a value or use the arrows to adjust the width of the dot (1st field) and the width of the space between the dots (2nd field).</td>
</tr>
<tr>
<td><strong>Line Width</strong></td>
<td>Enter a value or use the arrows to adjust the width of the line.</td>
</tr>
<tr>
<td><strong>Line GapWidth</strong></td>
<td>Enter a value or use the arrows to adjust the gap between the 2 lines of a casing, such as the bridge_major_casing.</td>
</tr>
<tr>
<td><strong>Opacity</strong></td>
<td>Enter a value or use the arrows to adjust the opacity of text.</td>
</tr>
<tr>
<td><strong>Outline Color</strong></td>
<td>Click the Color button to open the Color Selector and select a new color for the outline of buildings (applies to building layer only).</td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Shadow</td>
<td>Select the checkbox to add a shadow to the layer.</td>
</tr>
<tr>
<td>Shadow Color</td>
<td>If you’ve chosen to add a shadow, click the Color button to open the Color Selector and select a color for the shadow.</td>
</tr>
<tr>
<td>Shadow Offset</td>
<td>Use the arrows or enter a value in the Offset fields to change the position of the shadow. The first field changes the horizontal position. The second field changes the vertical position. See illustration below:</td>
</tr>
<tr>
<td>Text Background</td>
<td>Select the checkbox to insert a rectangle as a background to the text. Click the Color button to open the Color Selector and select a color for the background. See illustration below:</td>
</tr>
<tr>
<td>Text Halo Blur</td>
<td>Enter a value or use the arrows to adjust the amount of blur in the text halo.</td>
</tr>
<tr>
<td>Text Halo Color</td>
<td>Click the Color button to open the Color Selector and select a color that will surround the text characters.</td>
</tr>
<tr>
<td></td>
<td>This parameter only works if the value in Text Halo Width is greater than 0.</td>
</tr>
<tr>
<td>Text Halo Width</td>
<td>Enter a value or use the arrows to adjust the thickness of the text halo.</td>
</tr>
<tr>
<td>Text Letter Spacing</td>
<td>Enter a value or use the arrows to adjust the amount of space between the characters of the text.</td>
</tr>
<tr>
<td>Text Line Height</td>
<td>Enter a value or use the arrows to increase or decrease the space between lines of text.</td>
</tr>
<tr>
<td>Text Max Width</td>
<td>Enter a value or use the arrows to increase or decrease the maximum number of characters allowed in one line of text.</td>
</tr>
<tr>
<td></td>
<td>Exceeding the Text Max Width will cause a line break, where possible.</td>
</tr>
<tr>
<td>Text Size</td>
<td>Enter a value or use the arrows to adjust the size of the existing label text.</td>
</tr>
<tr>
<td>Text Transform</td>
<td>Use the drop-down to select whether the text should be UPPERCASE, lower case or None (mixed case).</td>
</tr>
</tbody>
</table>
Click **Done** if you are satisfied with your changes.

**OR**

Click **Reset** to restore the **OSM Layer Parameters** to their original settings.

**OR**

Click **Cancel** to discard your changes.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Defined Replacement</td>
<td>Check to add a user-defined replacement drawing for the layer. Then click the <strong>Browse</strong> button to select a replacement drawing from one of the following groups in the <strong>Drawing Toolbox</strong>:</td>
</tr>
<tr>
<td>Drawing</td>
<td>• Text</td>
</tr>
<tr>
<td></td>
<td>• Web Examples</td>
</tr>
<tr>
<td></td>
<td>• OSM Replacement</td>
</tr>
<tr>
<td></td>
<td>• Your custom group</td>
</tr>
<tr>
<td></td>
<td>When unchecked, a replacement drawing that is the same as the OSM text will be added. This could be used to add a label at a location where there isn’t one or to change the size or the orientation of the text.</td>
</tr>
</tbody>
</table>
OSM Replacement Drawings

Replacement drawings are text drawings that can be used to replace existing labels on a map. The replacement drawings are placed in roughly the same location as the existing label and when the scene is used in production, all layers that have been configured as Use As Information will be hidden and only the replacement labels and items that are not configured to be hidden, will be displayed. This allows for a less cluttered map that shows only those items that are necessary for the production.

![Figure 9.14 OSM Replacement Drawings (Original and Production)](image)

To add a replacement drawing to a scene:

1. Right-click on a label on the map.
2. From the context menu, select Add Replacement Drawing. The replacement drawing that has been defined for the selected layer is added to the scene.

![Figure 9.15 Add Replacement Drawing Context Menus](image)

- Alternatively, you can double-click on a place label on the map to automatically add the replacement drawing for that layer.

For information about defining a replacement drawing, see “User Defined Replacement Drawing” on page 9–48.
The replacement drawing is placed on top of the existing place label and is selected by default. You can reposition the replacement drawing as needed.

![Replacement Drawing Added](image)

**Figure 9.16 Replacement Drawing Added**

To edit user-defined replacement drawings:

1. In the Drawing Toolbox, from the Group drop-down, select the group that contains the replacement drawing you want to edit.
   - Typically, replacement drawings are found in the Text, OSM Replacement, or Web Examples groups or in a custom group.
   - The available drawings are displayed. The example below shows OSM Replacement drawings.

![Drawing Toolbox - OSM Replacement Drawings](image)

**Figure 9.17 Drawing Toolbox - OSM Replacement Drawings**

2. Right-click the drawing you want to edit and select Edit Drawing.

3. Make the changes you want to the drawing and then click Done.
4. If you want to make your edited drawing the default drawing for that layer, right-click the drawing again and select **Set as Default Text**.

   The drawing will still have to be designated as the replacement drawing in the **OSM Layer Parameters** in the **User Defined Replacement Drawing** section. See “**User Defined Replacement Drawing**” on page 9–48.

**To delete a replacement drawing from the scene:**

1. In the **Output** window, select the drawing you want to delete.
2. Press the **Delete** key.
3. To delete a replacement drawing from a group in the **Drawing Toolbox**, see “**To delete a drawing:**” on page 7–7.
Show Information Layers

You may not want all the layers of a map to be displayed in your final output. Selected layers can be hidden in the OSM Style Editor. The exception is that if you’ve highlighted a particular road, area, building, etc., then that element will remain visible in the final output, while all other elements in the selected layer will be hidden.

To hide a layer:

1. In the OSM Style Editor, click the Edit button beside the layer you want to hide.
   The OSM Layer Parameters dialog opens.

   ![OSM Layer Parameters](Figure 9.18 OSM Layer Parameter)

2. In the OSM Layer Parameters dialog, select the Use As Information checkbox and click Done.
3. In the OSM Style Editor, click the Show Information Layers button to view the scene with the selected layers hidden.

   By default, the Show Information Layers button is red, indicating that all layers are visible. When clicked, the button turns grey, indicating that the layers which have been chosen to be hidden, will not be visible.

   ![OSM Style Editor](Figure 9.19 OSM Style Editor)

4. Click Show Information Layers again to view your scene with the layers displayed.

   When the scene is recorded, those layers will not be visible.
Editing Individual Layer Elements

For each element of a layer, you can switch between the main color and the highlight color or hide the element. You can also add a replacement drawing on top of a place label.

To edit individual elements:

1. Right-click on the element in the map.
   A menu opens, listing each layer that appears in that location.

   ![OSM Editing Menu]

   Figure 9.20 OSM Editing Menu

2. To change the color of an element, click Set color and from the context menu, select either Color or Highlight. Alternatively, you can double-click the layer to switch between the Color and Highlight colors.
   The layer changes to the color or highlight that has been selected for that layer in the OSM Style Editor.

3. To hide the element, click Hide.
   To make the element visible again, press Alt + Right-click.

4. To add a replacement drawing on top of a text label, click Add Replacement Drawing.
   If a user-defined replacement drawing has been set for that layer in the OSM Style Editor the text label will be replaced by that replacement drawing. If no user-defined replacement drawing has been set, a drawing that is identical to the text label will be added.

   For information on defining a replacement drawing, see “User Defined Replacement Drawing” on page 9–48.
Creating Animations

You can create interesting animations to illustrate your story, using the timeline and the key frame controls. The following topics are discussed in this section:

• “Adding and Deleting Key Frames” on page 10–2
• “Location and View Animation” on page 10–4
• “Drawing Animation” on page 10–5
• “Line Animation” on page 10–6
• “Zoom Animation” on page 10–7
• “Shape Animation” on page 10–8
Adding and Deleting Key Frames

You can add and delete key frames using the Key Frame toolbar beside the timeline or the Edit menu.

![Figure 10.1 Key Frame Toolbar - Location]

There are three options:

- **Add Camera Key Frame** - creates key frames for the camera parameters, **Zoom Level**, **Longitude**, **Latitude**, **Tilt** and **Roll** all at once, to record the location and view of the map. Additionally, it creates a key frame for the map style if it has changed and for the lock camera parameter if it has changed.

![Figure 10.2 Camera Parameters with Key Frames]

Camera, map style, and camera lock key frames are shown in the upper scale of the timeline slider.

- **Add Drawing Key Frame** - creates key frames for drawings. The **Location**, **Rotation**, and **Scale** parameters are recorded when adding a key frame for a drawing. If a drawing is selected, only the parameters for this drawing are recorded, otherwise the above mentioned parameters of all drawings are recorded.

Drawing key frames are shown in the lower part of the timeline scale.

- **Delete Selected Key Frames** - deletes all selected key frames.

To add a camera key frame:

1. With the timeline slider at the position where you want to start your animation, rotate the globe to the location where you want the animation to begin.
2. In the menu bar, click **Edit > Add Camera Key Frame** or click the **Add Camera Key Frame** button.

![Figure 10.3 Add Camera Key Frame]

3. Move the slider in the timeline to a different position and change the location of the globe.
4. Click **Edit > Add Camera Key Frame** or click the **Add Camera Key Frame** button again to record the new location.
5. Repeat steps 3 and 4 until you have added all the key frames you want.

   The animation can be viewed by playing it or by moving the timeline slider.

To add a drawing key frame:

1. With the timeline slider at the position where you want to start your animation, place a drawing on the map.
2. With the drawing selected, click **Edit > Add Drawing Key Frame** in the menu bar or click the **Add Drawing Key Frame** button.

![Figure 10.4 Add Drawing Key Frame]

   The new **Location**, **Rotation**, **Scale** and **Zoom** parameters are recorded.
3. Move the timeline slider to a different position and change the location or parameters of the drawing.
4. Click the **Add Drawing Key Frame** button to record the new location and/or parameters.

   The drawing will animate all recorded parameters between the two positions of the timeline.
To delete key frames:

1. From the timeline slider, select the key frame you want to delete.
   Press Ctrl and click to select multiple key frames or left-click in the timeline and drag a selection box around multiple key frames.
   The selected key frames change from blue to green (drawing key frames) or red (camera key frames).
2. Click Edit > Delete Selected Key Frames in the menu bar or click the Delete Selected Key Frames button.

   Figure 10.5 Delete Selected Key Frames

Moving Between Key Frames
There are several ways to move from one key frame to another.

To move between key frames:

• Click Edit > Jump to Next Key Frame or Jump to Previous Key Frame, as required.
• Press Ctrl+Right Arrow to move to the next key frame or Ctrl+Left Arrow to move to the previous key frame.
• In the timeline, click on the key frame to which you want to move.

Animation Control
The Animation menu contains the animation playback controls. These controls are also provided in the toolbar shown below, located at the bottom-left side of the application.

   Figure 10.6 Animation Playback Toolbar

To use the animation playback controls:

• Click Animation in the menu bar and then select one of the following controls:
  › Rewind - rewind the animation to the beginning; you can also press Ctrl+B
  › Play - play the animation from the beginning; you can also press Ctrl+Space
  › Continue - continue playing the animation from the position on the timeline; you can also press Ctrl+G
  › Stop - stop playing the animation; you can also press Ctrl+H
  › Forward - fast-forward the animation to the end; you can also press Ctrl+M
Location and View Animation

You can use a location and view animation to draw attention to multiple locations and different map views.

To animate multiple locations:

1. In the Search Editor, enter the location at which you want to begin your animation.
   The location you enter will be displayed in the center of the map.
   Alternatively, you can left-click on the map and move it to the location you want.
2. Adjust the Zoom Level, Tilt and Roll values to change the viewpoint of the map, if desired.
3. Click the Add Camera Key Frame button.

   Figure 10.7 Add Camera Key Frame

4. Drag the slider in the timeline to a different position.
   Alternatively, you can click on any point in the timeline to move the slider to that point or enter the position in the frame counter to the left of the timeline.

   Figure 10.8 Frame Counter

5. Repeat steps 1 to 3 for each location you want to show.
6. Click the green Play Animation button in the Animation Control toolbar to view your animation.

   Figure 10.9 Play Animation

7. When you are satisfied with the animation, save it.
**Drawing Animation**

You can make drawings appear and/or disappear at specific points in an animation.

**To create a drawing animation:**

1. With the map positioned where you want to start your animation and the timeline slider at "0", click the **Add Camera Key Frame** button in the **Key Frames** toolbar.

2. Drag the timeline slider to the point in the timeline where you want a drawing to appear.
   
   Alternatively, you can click on any point in the timeline to move the slider to that point or enter the position in the frame counter to the left of the timeline.

   ![Frame Counter](image)

   **Figure 10.10 Frame Counter**

3. Add a drawing to your scene and keep it selected.

4. In the **Drawing Editor**, in the **Misc** section, select the **Visible** checkbox (or clear the checkbox if you want the drawing to disappear) and click the radio button beside the checkbox to key frame the visibility.

5. Then click the **Add Drawing Key Frame** button in the **Key Frames** toolbar.

6. Repeat steps 2 to 5 for each additional drawing you want to include in your scene.

7. Click the green **Play Animation** button in the **Animation Control** toolbar to view your animation.

   ![Play Animation](image)

   **Figure 10.11 Play Animation**

8. When you are satisfied with the animation, save it.
Line Animation

You can use a line animation to show the progression of a route across a map, for example the route to take to get from point A to point B, or the route that will be followed for a race.

To animate a line:

1. Add a line drawing to your scene to mark a route. See “Adding and Editing Line Drawings” on page 8–9 for instructions on adding a line drawing.

2. In the output window, select the line drawing you want to animate.

3. In the frame counter to the right of the timeline slider enter the number of frames you want to have in your animation.

   The timeline will display up to 9999 frames. The speed of the animation playback depends on the screen resolution selected in File > Preferences > Output. For example, HD 1080 50i will play 25 frames per second and HD 1080 60p will play 60 frames per second.

4. Then move the timeline slider to the last frame.

   Alternatively, you can click on any point in the timeline to move the slider to that point or enter the position in the frame counter to the left of the timeline.

5. In the Drawing Editor, in the Progress section, click the radio button beside the Value field.

   This creates a key frame on the timeline at the slider position.

6. Move the timeline slider to the left to the “0” position.

   This marks the point on the timeline as the ending key frame (100.0000) of the animation.

7. In the Drawing Editor, in the Progress section, move the Value slider all the way to the left to the “0” position and click the radio button beside the Value field.

   This creates the starting key frame of the animation.

8. If your animation covers a large area of the map and you want the map to move with the line, in the Drawing Editor, in the Misc section, click the Lock Camera checkbox.

9. Click the green Play Animation button in the Animation Control toolbar to view your animation.

10. When you are satisfied with the animation, save it.
Zoom Animation

You can use a zoom animation to draw the viewer’s attention to a specific location, beginning from a distant camera view and zooming in to a close-up view or starting close-up and zooming out.

To animate a zoom into a location:

1. In the frame counter to the right of the timeline slider enter the number of frames you want to have in your animation.
   The timeline will display up to 9999 frames. The speed of the animation playback depends on the video format and on the screen resolution selected in File > Preferences > Output. For example, HD 1080 50i will play 25 frames per second and HD 1080 60p will play 60 frames per second.

2. In the Search Editor, in the Location field, enter the name of the city, the area of the city or the landmark that you want to zoom into and click Search.
   The map in the output window will move to the specified location.

3. In the camera parameters beneath the output window, adjust the Zoom Level parameter to a level that gives you the desired starting view of the country or area of your location.
   Alternatively, you can scroll with your mouse to the desired zoom level.

4. With the timeline slider at the beginning of the timeline, click the Add Camera Key Frame button in the Key Frame toolbar.

5. Drag the timeline slider to the right as many frames as you want the animation to take to zoom into or out of the location.
   Alternatively, you can click on any point in the timeline to move the slider to that point or enter the position in the frame counter to the left of the timeline.

6. Adjust the Zoom Level parameter to a level that gives you the desired final view of the target location and add another camera key frame at this position.
   The animation will automatically move through the levels to the final zoom level.

7. Click the green Play Animation button in the Animation Control toolbar to view your animation.

8. When you are satisfied with the animation, save it.
Shape Animation

You can use a shape animation to draw the viewer’s attention to specific related locations, by having each location appear in the scene individually. An example would be a map showing election results. Each location is represented by a shape that appears at a specific point in the animation.

To animate a shape:

1. In the frame counter to the right of the timeline slider enter the number of frames you want to have in your animation.
   The timeline will display up to 9999 frames. The speed of the animation playback depends on the screen resolution selected in File > Preferences > Output. For example, HD 1080 50i will play 25 frames per second and HD 1080 60p will play 60 frames per second.
2. With the map positioned where you want to create your animation and the timeline slider at the beginning of the timeline, click the Add Camera Key Frame button in the Key Frames toolbar.
3. Drag the timeline slider to the point on the timeline where you want to display the shape.
   Alternatively, you can click on any point on the timeline to move the slider to that point or enter the position in the frame counter to the left of the timeline.

   ![Figure 10.18 Frame Counter](image1)

   Incrementing the frame count by the same amount each time helps to create a smooth animation.

4. In the Search Editor, at the bottom, make sure the Adjust Map to New Shape checkbox is cleared.
   When cleared, shapes added using the Shape Database Viewer will appear at the current zoom level, rather than the zoom level set in the Shape Database Viewer.
5. Click the Shape Database Viewer button and select the shape you want to add.
6. Click Add Shape (or double-click the shape name) and then click Done.
   The shape appears on the map, using the default shape style defined in the Shape Editor.
7. In the Shape Editor, select the new shape you just added from the list and in the Properties section, make sure the Visible checkbox is selected and click the radio button beside the Visible checkbox to add a key frame.
   This will make the shape become visible at this point in the timeline.
8. Click the Add Camera Key Frame button.
9. Repeat steps 3 to 7 to add additional shapes to the scene.
10. Click the green Play Animation button in the Animation Control toolbar to view your animation.

   ![Figure 10.19 Play Animation](image2)

11. When you are satisfied with the animation, save it.
Recording Animations

The **Record Animation** function renders the full animation of a scene into either an AVI (Audio Video Interleaved) file or one of several ffmpeg file formats.

**To record an animation as an AVI file:**

1. Click **Output > Record Animation** in the menu bar or click the **Record Animation** button in the toolbar.

![XPression Maps Toolbar - Record Animation](image1)

   **Figure 11.1**  XPression Maps Toolbar - Record Animation

   The **Animation Recording** dialog opens.

![Animation Recording - AVI](image2)

   **Figure 11.2**  Animation Recording - AVI

2. Select the **AVI** tab if it is not already selected.

3. In the **Output** section, click the **Browse** button beside the **File** field, to navigate to the location where you want to save the video file.

   The **Save Video** dialog opens.

![Save Video in AVI Format](image3)

   **Figure 11.3**  Save Video in AVI Format

4. In the **Save Video** dialog, in the **File name** field, enter a name for the video file and click **Save**.

   In the **Animation Recording** dialog, in the **Output** section, the **File** field is populated with the path to the video file.
5. Select the **Overwrite File** checkbox if you want to overwrite an existing copy of the animation or clear the checkbox if you want to keep existing copies and create a new video file.

If you choose not to overwrite an existing copy, you need to change the file name.

6. In the **Configuration** section, click **AVI Setup** to open the **Video Compression** dialog.

![Figure 11.4 AVI Video Compression](image)

**Figure 11.4 AVI Video Compression**

a. Select a video compression option and click **OK**.

   The options are:
   - Intel IYUV codec
   - Intel IYUV codec
   - Microsoft RLE
   - Microsoft Video 1
   - XPRESSion Video Codec 8.0
   - TechSmith Screen Capture Codec
   - TechSmith Screen Codec 2
   - Full Frames (Uncompressed)

   Some options will activate the **Compression Quality** slider and/or the **Configure** button and require further configuration.

b. Click **OK** when you have finished configuring the video compression.

7. In the **Save Format File**, select a video format file and click **Save**.

8. When you have finished configuring the output, click **Record** to record your animation.

   The **Animation Recording** progress dialog opens. When the recording is complete, the dialog closes.

![Figure 11.5 Animation Recording Progress Dialog - AVI](image)

**Figure 11.5 Animation Recording Progress Dialog - AVI**
To record an animation in an ffmpeg file format:

1. Click **Output > Record Animation** in the menu bar or click the **Record Animation** button in the toolbar.

   ![Figure 11.6](image)

   The **Animation Recording** dialog opens.

2. Select the **ffmpeg** tab if it is not already selected.

3. In the **Output** section, click the **Browse** button beside the **File** field, to navigate to the location where you want to save the video file.

   ![Figure 11.7 Animation Recording - ffmpeg](image)

   The **Save Video** dialog opens.

   ![Figure 11.8 Save Video in ffmpeg Format](image)
4. In the **Save Video** dialog, in the **File** name field, enter a name for the video file and click **Save**. Include the appropriate file extension in your file name.

In the **Animation Recording** dialog, in the **Output** section, the **File** field is populated with the path to the video file.

5. Select the **Overwrite File** checkbox if you want to overwrite an existing copy of the animation or clear the checkbox if you want to keep existing copies and create a new video file.

If you choose not to overwrite an existing copy, you need to change the file name.

6. When you have finished configuring the output, click **Record** to record your animation.

The **Animation Recording to ffmpeg** progress dialog opens. When the recording is complete, the dialog closes.

![Animation Recording Progress Dialog - ffmpeg](image)

**Figure 11.9** Animation Recording Progress Dialog - ffmpeg

To stop recording an animation:

- In the **Animation Recording** dialog, click **Cancel** or click the **Stop Animation Recording** button in the toolbar.

![XPression Maps Toolbar - Stop Animation Recording](image)

**Figure 11.10** XPression Maps Toolbar - Stop Animation Recording

To play a recorded animation:

1. Navigate to the folder in which you’ve saved your recorded animations.

2. Double-click the recording you want to play.
Custom Data

Custom data can be imported through the Custom menu in the menu bar. It allows the user to import custom shapes and maps.

The following topics are discussed in this section:

• “Custom Shapes” on page 12–2
• “Custom Maps” on page 12–8
Custom Shapes

Custom shapes can be area or line shapes. Most common projection formats can be used.

Country or state borders are examples of area shapes. This kind of shape can be filled with a color and the border can be colored as well.

Streets, rivers and train lines are examples of line shapes. The lines can be colored.

It’s a good idea to create a folder outside of the XPression Maps folder to store your custom shapes, to avoid inadvertently losing them when you upgrade your version of XPression Maps.

Once you’ve imported a custom shape, you’ll want to create a custom shape style for that shape. See “Shape Styles” on page 9–8 for more information.

Managing Custom Groups

Custom shapes can be organized into groups, for easier retrieval. You can add, edit or delete custom groups, as described in the following sections.

To add a custom group:

1. Click Custom > Shapes in the menu bar to open the Custom Shapes editor.

   ![Figure 12.1 Custom Shapes Editor]

2. In the Custom Shapes editor, click the Browse button beside the Group drop-down. The Custom Groups dialog opens.

   ![Figure 12.2 Custom Groups Dialog]

3. Click the Add button to open the Add Custom Group dialog.

   ![Figure 12.3 Add Custom Group]
4. In the **Group Name** field, enter a name for the new custom group and click **OK**.
5. In the **Custom Groups** dialog, click **Done** to close the dialog.
6. Then click **Done** to close the **Custom Shapes** editor.
   The new group will appear in the **Group** drop-down.

To edit a custom group:

1. Click **Custom > Shapes** in the menu bar to open the **Custom Shapes** editor.
2. From the **Group** drop-down, select the group you want to edit.
   The table in the center of the **Custom Shapes** editor displays the data for the selected group.
3. Select a data row in the table.
4. Click the **Edit** tab.
5. Edit the **Name**, **Layer Name** or **Search Info** parameters and click **Update**.
6. Then click **Done** to close the **Custom Shapes** editor.

To delete a custom group:

1. Click **Custom > Shapes** in the menu bar to open the **Custom Shapes** editor.
   **OR**
   In the **Shape Editor**, click the **Add Custom Shapes** button at the top of the editor to open the **Custom Shapes** editor.
2. Click the **Browse** button beside the **Group** drop-down to open the **Custom Groups** dialog.
3. In the **Custom Groups** dialog, from the **Group Name** drop-down, select the group you want to delete.
4. Click **Delete**.
5. In the **Delete Custom Group** confirmation dialog that opens, click **Yes** to delete the group and all its contents.
6. In the **Custom Groups** dialog, click **Done** to close the dialog.
7. Then click **Done** to close the **Custom Shapes** editor.
Managing Custom Shapes

You can add custom shapes which you’ve created or acquired and stored locally on disk and use those shapes when creating new scenes.

Once you’ve added a custom shape to a scene, you’ll want to create a shape style that will make it stand out. See “Shape Styles” on page 9–8 for more information.

To import a custom shape:

1. Click Custom > Shapes in the menu bar to open the Custom Shapes editor.

   The Custom Shapes editor opens.

2. From the Group drop-down, select the group to which you want to add the imported custom shape.

   If the group already contains shapes, the table in the center of the Custom Shapes editor displays the data for the shapes in the group.
3. Click **Import**.

The **Shape Import** editor opens.

![Shape Import Editor](image)

**Figure 12.6 Shape Import Editor**

If you've previously imported custom shapes, the **Shape Folder** field will display the last shape folder that was opened.

4. To open a different folder, click the **Browse** button beside the **Shape Folder** field, navigate to the folder containing the custom shape you want to import and click **Open**.

All shape archives in the selected folder are listed in the upper table of the editor. Information for each archive is displayed as follows:

- **Name**: The name of the shape archive.
- **Type**: The type can be 2D or 3D for **Polygon** (a closed shape where the beginning of each line is connected to its end), **Line String** (which is simply a line), or **Point** (a location reference).
- **Object Count**: The number of shape objects in the archive.
- **Bounding**: The area in which the shapes are contained, expressed in longitude and latitude coordinates.
- **Attributes**: The number of attribute columns with additional data for the shape, that are stored in the archive.

5. Click the archive containing the shape you want to import.

The layers of the selected archive appear in the bottom-half of the **Shape Import** editor.

6. Select the layer(s) you want to import.

- Check the **Select All** checkbox to select all the layers.
- Check the **Combine Parts** checkbox to combine multiple layers into one shape.

7. Click **Import**.
The **Shape Import Report** dialog opens indicating if there were any errors during the import.

![Shape Import Report Dialog](image)

**Figure 12.7** Shape Import Report Dialog

8. If there were no errors, click **OK** to close the dialog and then click **Done**.
   The shapes from the selected archive appear in the table in the **Custom Shapes** editor.

9. Click **Done** to close the **Custom Shapes** editor or continue to add the custom shape to a scene.

To add a custom shape to a scene:

1. Open the scene to which you want to add a custom shape.
2. Click **Custom > Shapes** in the menu bar to open the **Custom Shapes** editor, if it is not already open.
3. In the **Custom Shapes** editor, double-click the shape you want to add to your scene and click **Done**.
   The shape is added to the **Shape Editor** on the left.
4. Double-click the shape in the **Shape Editor** to display it in the **Output** window.
5. If the map in the **Output** window isn't displaying the selected shape, in the **Shape Editor**, right-click on the shape and select **Go to Shape on Map**.

To search for custom shapes:

1. Click **Custom > Shapes** in the menu bar to open the **Custom Shapes** editor.
2. In the **Custom Shapes** editor, in the **Filter** tab, enter one or more of the **Name**, **Layer Name** or **Search Information** parameters to narrow down the number of custom shapes displayed in the table.
3. Click **Refresh** to display the new search results.

To delete custom shapes:

1. Click **Custom > Shapes** in the menu bar to open the **Custom Shapes** editor.
   OR
   In the **Shape Editor**, click the **Add Custom Shapes** button at the top of the editor to open the **Custom Shapes** editor.
2. In the **Custom Shapes** editor, from the **Group** drop-down, select the group containing the custom shape(s) you want to delete.
3. Select the shape you want to delete or press Ctrl and click several shapes if you want to delete multiple shapes.
4. Go to the Manage tab and click Delete.
5. In the Delete Shapes confirmation dialog, click Yes to delete the selected shape(s).
6. Click Done to close the Custom Shapes editor.
Custom Maps

Custom maps can be high-quality satellite images which have a geo-reference to the world. A geo-reference means this image has an exact mapping location, so that it can be mapped onto the globe in its exact position in the world. One of the most used formats is Geo-Tiff.

Each image, mostly large in resolution and size, is calculated and its position in between the 21 map levels is found. It is also cut into small images and stored in the database with exact location reference information. This allows for taking only the visible parts of the image.

For information on map setup, see “Map Styles” on page 5–1.

The Custom Maps editor displays all map data sources that contain imported map data or are ready to import map data.

Creating a Map Data Source

Before importing maps, you will need to create a data source. The data source will use either an Sqlite or MariaDB database.

The Sqlite database requires no additional program and can be used immediately with XPression Maps. However, the amount of data that can be stored in such a database is limited. A performance drop in reading and writing data into the one Sqlite file is the result.

If you plan to import more than 4 GB total of image data, the setup of a MariaDB (MySQL) server is recommended.

To create a map data source:

1. Click Custom > Maps to open the Custom Maps editor.

![Figure 12.8 Custom Maps Editor](image)

2. In the Custom Maps editor, click New.

   The Data Sources editor opens.

![Figure 12.9 Datasources Editor](image)

3. In the Data Source Name field, enter a unique name.
4. From the Type drop-down, select whether the data source will use an Sqlite file or the mysql (MariaDB) connection to the server.

   a. If you select Sqlite, in the Database Details section, click the Browse button beside the Data Source File field to navigate to the SQLite file you want to use and click Save. The file will be created if it does not exist. Then click OK and continue with Step 5.

   ![Figure 12.10 Datasources Editor - SQLite](image)

   **Figure 12.10 Datasources Editor - SQLite**

   b. If you select mysql, in the Database Details section, enter the Server Name, Database Name, User Name and User Password for the database you want to use, to establish a connection with the server. On this server, a separate database needs to be created and the name of the database entered into the Database Name field. Creation of the database on the server can be done using the HeidiSQL program. Consult the database manual for how to create an empty database. Then continue with Step 5.

   ![Figure 12.11 Datasources Editor - MySQL (MariaDB)](image)

   **Figure 12.11 Datasources Editor - MySQL (MariaDB)**

   The default Details for the XPression Maps Database are:

   **Server Name**: localhost

   **Database Name**: name of the database

   **User Name**: your user name

   **User Password**: your password

5. Click the Test Connection button to open a connection to the database and check if read and write access exists.

6. If the connection is successful, click OK.
Importing Map Data

Import and level creation is a process which takes a lot of time depending on how much data is imported. Ensure that this procedure is performed ahead of time, if possible, and be aware that the XPression Maps system is busy importing during this time.

To import map data:

1. Click Custom > Maps to open the Custom Maps editor.
2. In the Satellite Maps tab, select the data source for the custom map you want to import.
3. Then click Import.
   
   The Map File explorer opens.

   ![](Map_File_Explorer.png)

   **Figure 12.12 Map File Explorer**

4. Select all geo-referenced image files (.tif) needed for the import and click Open.
   
   The Map Import editor opens and the selected image files are listed in the Maps list.

   ![](Map_Import_Editor.png)

   **Figure 12.13 Map Import Editor**
Below the list, you’ll see information displayed about the selected image, as follows:

- **Type**: the data type of the image
- **Size**: the image size
- **Level**: the calculated level where the maximal image resolution is reached
- **Tile Progress**: displays the progress of the imported file.
  - If you want the level creation to be started automatically at the end of the import, select the **Create Levels after Import** checkbox. See “Creating Levels” on page 12–11 for details about level creation.
- **Total Progress**: displays the overall progress of the import
- **Create Levels after Import**: select this checkbox to automatically start the level creation at the end of the import.

5. Click **Start** to begin the import process.
   The **Map Import** confirmation dialog appears when the import is successfully completed.

To display a custom map:

1. Click **Style > Map Styles** and in the **Map Style Manager**, click **Edit** to open the **Edit Map Style** editor.
2. In the **Custom Data** section, select the **Map** checkbox.
3. From the drop-down, select your custom map.

**Creating Levels**

In the map data importing procedure, the maps are cut into parts and stored in the database with information about where in the world each map part is located and the resolution (level) of this map part.

![Map Import Editor](image)

**Figure 12.14 Map Import Editor**

In the **Map Import** editor image above, we can see that the example data will be imported into level 13. This means that we will see the map once we zoom into the location of the imported map in a height somewhere above street level. Without any level creation, we will only see our imported maps in this level. The level creation process, started by clicking the **Create Levels** button in the **Custom Maps** editor or by selecting the **Create Levels after Import** checkbox in the **Map Import** editor, calculates map tiles for lower levels out of the imported map tiles.

The next level with higher quality provides four tiles with the same resolution for one tile. This makes the resolution two times higher in X and Y. For the creation of a tile in the lower levels, we combine four map tiles to one tile, scale this new tile down to the needed tile size, and write it back into the database for the lower level.

Once the next lower level (in our example, level 12) is created the process continues with the next lower level based on the newly generated level, until the top level is generated. This process reads and writes heavily from and into the database, and the process usually takes longer than the import of the images. If you plan to import several map regions, wait until all maps are imported before creating the levels.

* If you import more groups of maps, do not select the automatic **Create Levels after Import** checkbox before you start the last import.
Using Custom Maps

Imported custom maps can be activated in an existing Blue Marble Colored or Blue Marble Satellite style. This means that when the style is used, the custom map is drawn on top.

To use a custom map:

1. Click **Style > Map Styles** and in the **Map Style Manager**, add a new map style to assign to your custom map. See “To add a new map style:” on page 5–7.
   
   Custom maps can only be assigned to map types using the **Sphere** projection.

2. Select the new map style and click **Edit**.

3. In the **Edit Map Style** editor, in the **Custom Data** section, select the **Map** checkbox.

4. From the **Map** drop-down, select which data source to use.

   ![Custom Data](image1)

   **Figure 12.15 Imported Map Style**

5. At the bottom of the **Edit Map Style** editor, click **OK**.
   
   The **Edit Map Style** editor closes and the **Map Style Manager** reopens. The edited style is highlighted and the **Save** icon  is displayed beside it. If you are editing an existing map style, the **Reset** icon  will also be displayed.

6. Click the **Save** icon  to save your changes into the default database or click the **Reset** icon  to discard your changes and revert to the last saved version of the style.

   The **Save All** button  at the bottom of the dialog box saves all changes made to all styles in the database.

   The **Reset All** button  at the bottom of the dialog box resets all styles in the database to their last saved version.

7. In the **Save Map Style** confirmation dialog that opens, click **Yes**.

8. Click **Done** to close the **Map Style Manager**.
Map Data Configurator

The Map Data Configurator defines which data will be taken from local files (QSQLITE) and which will be shared through a database server (QMYSQL). The sharing of data is required to combine an instance of XPression Maps in the graphics department with the XPression Maps server in the machine room where scenes, drawings, and styles can be created and shared.

The main window of the application provides a list of data sources. It shows the data source type and indicates if the connection to the data source is available. You can also edit the parameters of each data source.

SQLite is a database setup where there is a file on the disk and the application can open and browse the data inside the file in a direct way. But SQLite is limited in parallel user access. Most files inside of the DB sub-folder are SQLite files.

To get around the limitation of the parallel user access, you can use the MariaDB database server software. MariaDB can host several databases and can be accessed through the network by multiple users at the same time in parallel.
Configuring Data Sources

The following sections provide instructions for launching the **Map Data Configurator** and defining which data sources will be used by XPression Maps.

If you have upgraded from a previous version of XPression Maps, you will have loaded a new **Shape** database. This could mean that some scenes in your projects may have to be modified to accommodate the new database. If you want to continue using the old **Shape** database, you can do so by selecting it in the **Data Sources** editor in the Map Data Configurator. See “To edit a data source:” on page 13–3.

**To launch the Map Data Configurator:**

1. Go to `C:\XPressionMaps\MapDataConfigurator`.

   The **Map Data Configurator** opens.

![Map Data Configurator](image)

**Figure 13.1 Map Data Configurator**
To edit a data source:

1. Open the Map Data Configurator.
2. Select a data source from the list (eg. Select Shapes to change the Shapes Database).
3. In the Edit column, click the corresponding ... button.
   The Data Sources editor opens.

![Figure 13.2 Data Sources Editor](image)

4. From the Type drop-down, select whether the data source will use the Sqlite file or the MariaDB connection to the server.
5. Some databases, like the Shape database can only use the SQLite data file.
   Alternatively, if you just want to change the Type, you can right-click in the Type column of a database and select either Set SQlite or Set MariaDB from the context menu.

![Figure 13.3 Set Database Type](image)

   a. If you select Sqlite, in the Database Details section, click the Browse button beside the Data Source File field to navigate to the SQLite file you want to use and click Save.
      For example, if you are changing to the 3.0 version of the Shape database, you would select the WorldNewsMapperShapeDB_3.0.1.db SQLite file.
      Then click OK and continue with Step 5.
   b. If you select MariaDB, in the Database Details section, enter the Server Name, Database Name, User Name and User Password for the database you want to use and then continue with Step 5.
      If the XPression Maps Database is installed, the default Database Details are:
      Server Name: hostname of the XPression Maps server where the MariaDB database is installed
      Database Name: same as the data source
      User Name: mapsuser
      User Password: wnmdb
The following data types need to be changed to QMYSQL in a configuration with a server:

- DrawingFeatures
- CustomShapes
- SceneStyles
- ShapeStyles
- SafeTitle
- OSMLocalData
- CustomMaps

6. Click the **Test Connection** button.
   a. If the database exists, a confirmation dialog opens indicating that it exists.
      Click **OK** to close the dialog.
   b. If the database does not exist, a confirmation dialog will open asking if you want to create the database and tables in the server.
      Click **Yes** to create the database or **No** to cancel.
      If you click **Yes**, the **Map Data Configurator** will create the database and tables, but they will be empty.

7. Click **Import Data**.
   This step only needs to be done for the first XPression Maps system. Other systems will automatically use the same data. See “**Data Source Sharing**” on page 13–4.

8. In the **SQLite** file window, select the database you want to use and click **Open**.
   This step only needs to be done for the first XPression Maps system. Other systems will automatically use the same data. See “**Data Source Sharing**” on page 13–4.
   The data from the selected database is copied to the MariaDB database.

**Data Source Sharing**

The first XPression Maps system joins the shared data on the server used to import the data. The second system only needs to connect to the server and use the data.
**Data Source Description**

The following data sources can be configured in the Map Data Configurator. Only some of the data sources can be shared, as indicated in the table.

<table>
<thead>
<tr>
<th>Data Source</th>
<th>Description</th>
<th>Sharing</th>
</tr>
</thead>
<tbody>
<tr>
<td>BingMaps</td>
<td>The map tiles download from Bing</td>
<td>N/A</td>
</tr>
<tr>
<td>DrawingFeatures</td>
<td>All drawing objects</td>
<td>Yes</td>
</tr>
<tr>
<td>CustomShapes</td>
<td>Shapes imported by the user</td>
<td>Yes</td>
</tr>
<tr>
<td>SceneStyles</td>
<td>The map styles</td>
<td>Yes</td>
</tr>
<tr>
<td>ShapeStyles</td>
<td>The styles for the shapes</td>
<td>Yes</td>
</tr>
<tr>
<td>SafeTitle</td>
<td>All Safe Titles generated in the Safe Titles editor.</td>
<td>Yes</td>
</tr>
<tr>
<td>OSMLocalData</td>
<td>All local changes to the OSM data</td>
<td>Yes</td>
</tr>
<tr>
<td>HeightMap</td>
<td>The Blue Marble height model</td>
<td>N/A</td>
</tr>
<tr>
<td>OceanMap</td>
<td>The ocean overlay data</td>
<td>N/A</td>
</tr>
<tr>
<td>CustomMaps</td>
<td>Maps imported by the user</td>
<td>Yes</td>
</tr>
<tr>
<td>WorldCityNames</td>
<td>Name database for the offline mode</td>
<td>N/A</td>
</tr>
<tr>
<td>VideoConfiguration</td>
<td>Deprecated</td>
<td>N/A</td>
</tr>
<tr>
<td>BlueMarbleMap</td>
<td>The Blue Marble satellite images</td>
<td>N/A</td>
</tr>
<tr>
<td>Shapes</td>
<td>The internal shape database</td>
<td>N/A</td>
</tr>
</tbody>
</table>
HTML5 Client

The XPression Maps HTML5 Client is a web-based control interface that allows you to access, edit, preview and play scenes that have been created from templates in the XPression Maps database.

The following topics are discussed in this section:

- “Launching the HTML5 Client” on page 14–2
- “Using the HTML5 Client” on page 14–4
- “Playing Saved Scenes in the HTML5 Client” on page 14–18
- “Playing Saved Scenes in a Host Application” on page 14–22
Launching the HTML5 Client

The XPression Maps main application needs to be running in Server mode in order to use the HTML5 Client. Refer to the instructions below.

To select Server mode:

1. Launch XPression Maps.
2. In File > Preferences > Output, in the Misc section, select the Start in Server Mode checkbox.

![Figure 14.1 Preferences - Output - Server Mode]

3. Click Save and OK.

   XPression Maps is launched and immediately minimized to the Windows system tray.
5. Continue with the next section to launch the HTML5 Client.
To launch the HTML5 Client:

1. With the XPression Maps main application running in **Server** mode, open your browser and in the address field, enter “computername/maps/” (without the quotation marks).
   Instead of “computername” you can also enter the IP address of the computer on which you want to run the HTML5 Client.
2. Press **Enter**.
   The XPressionMaps HTML5 Client opens.

3. Enter your **Username** and **Password** and click **Log in**.
   The **HTML5 Client Home** page is displayed.

   ![Figure 14.2 XPression Maps HTML5 Client Application - Login](image)

To return to the main XPression Maps application:

- In the Windows system tray, right-click on the XPression Maps icon and from the context menu, select **Return**.
Using the HTML5 Client

You can use the XPression Maps HTML5 Client to modify a template to create a new scene. You can also access a scene that has been saved in the HTML5 client and drag it into a host application to play it there.

Templates that have been created in the XPression Maps main application are automatically available in the HTML5 client in the New tab.

Templates that have been modified in the HTML5 client and saved as scenes, are found in the Saved tab.

The following topics are discussed in this section:

• “Selecting a Template or Scene” on page 14–5
• “Modifying Templates in the HTML5 Client” on page 14–5
• “Deleting and Duplicating Saved Scenes” on page 14–19
• “Managing Saved Scene Folders” on page 14–20
Selecting a Template or Scene

After launching the HTML5 client and logging in, you can either select a template and create a new scene or select a saved scene and edit it.

To select a template or scene:

- In the New tab, select the folder containing the type of map from which you want to create a scene and in the Output window, click on the template you want to use.
- OR
- In the Saved tab, select the folder containing the scene you want to edit and in the Output window, click on the scene you want to edit.

Modifying Templates in the HTML5 Client

In the XPression Maps HTML5 Client, you can modify templates that were created in the main application, to create a new scene. You can change the camera view, modify the safe title area, add, edit or delete labels, shapes and drawings and add a flight point.

If the template has an animation, the scene you create from that template will also contain the animation, but the only animation you can add within the HTML5 client is a simple flight from Point A to Point B.

The ability to delete a saved scene is one of the privileges that is assigned to a user group. If your group doesn’t have that privilege, you will not be able to delete a scene.

To modify a template:

1. Select the template you want to edit.
2. Modify the template, as described in the following sections:
   • “Changing the Camera View” on page 14–7
   • “Modifying the Safe Title Area” on page 14–7
   • “Adding, Editing and Deleting Shapes” on page 14–8
   • “Adding, Editing and Deleting Labels” on page 14–10
   • “Adding, Editing, Deleting and Ordering Drawings” on page 14–12
   • “Adding a Flight Point” on page 14–15
   • “Downloading a Still Image” on page 14–17
4. To return to the Home page, click the Home icon 🏡.

**To save a scene:**

1. In the Save tab, in the Name field, enter a name for your scene.

![Figure 14.6 HTML5 Client - Save Scene](image)

2. In the Description field, enter a description of the scene (optional).
3. In the Folder field, click the folder icon at the right of the field and select the folder to which you want to save the scene.

   You can only save into an existing folder. Creating new folders is an Administrator privilege.

   Once you’ve saved a scene the first time, the folder will be selected automatically if you edit the scene and save it again.

4. Then click the Save 📄 icon.

   Once a scene has been saved, the Media ID icon becomes active and you can drag it into a host project such as XPression, to play.

   For more information, see “Playing Saved Scenes in a Host Application” on page 14–22.
Changing the Camera View

In the XPression Maps HTML5 Client you can change the camera view of the scene in the template.

To change the camera view:

1. Select the template or scene you want to edit.
2. In the Scene tab, in the Camera section, adjust the Longitude, Latitude, Tilt, Roll and Zoom Level as desired.

Modifying the Safe Title Area

The Safe Title Area is the area inside the output window defined by the white rectangles. Content inside this area will be fully visible on air. The Safe Title Area is defined in the main application but you can decide whether or not to use it in the HTML5 Client. You can also select the style of the safe title area.

To modify the Safe Title Area:

1. Select the template or scene you want to edit.
2. In the Scene tab, in the Safe Title area, do one of the following:
   a. Select the checkbox to use the configured safe title area.
   OR
   b. Deselect the checkbox to use the entire output window.
3. From the Style drop-down, select how the safe title area should be displayed.
   The options are:
   • Fullscreen — the map credits appear in the bottom corners of the scene
   • OTS (Over the shoulder) — the map credits appear centered in the scene
Adding, Editing and Deleting Shapes

In the XPression Maps HTML5 Client, you can add a shape for any location that exists in the shape database. You can also change the shape that has been applied to the location, to any shape that has been added to the Shapes tab for the original template in the main application.

To add a shape:

1. Select the template or scene to which you want to add a shape.
2. In the Search tab, enter the location for which you want to add a shape and click the Search icon or press Enter.
3. In the Shapes section, click on the location for which you want to add a shape and then click the + sign to the right of the location to add the default shape to the scene.

   The new shape appears on the map. The shape appears at the Zoom level set in the shape style, so you may have to zoom in or out (using the scroll wheel on your mouse) in order to see the new shape.

4. Save your new scene. See “To save a scene:” on page 14-6.
To edit a shape:

1. Select the template or scene you want to edit.
2. In the Output window, click on the shape.
3. In the Edit tab, from the Style drop-down, select a different shape style.

4. In the Opacity field, enter a value or use the up and down arrows to change the transparency of the shape.
5. Save your new scene. See “To save a scene:” on page 14–6.

To delete a shape:

1. Select the template or scene you want to edit.
2. In the Output window, select the shape you want to delete.
3. In the Edit tab, click the Delete Shape button.

Alternatively, with the shape selected, press the Delete key.
Adding, Editing and Deleting Labels

In the XPression Maps HTML5 Client, you can add a label anywhere in the scene. The labels that can be added are those that have been added to the Location Labels tab for the original template in the main application.

You can also set a default label which will be added automatically by clicking the + sign beside the location in the Result section and override a default label in the current scene only.

To add a label:

1. Select the template or scene to which you want to add a label.
2. In the Search tab, in the Location field, enter the location to which you want to add a label.
3. Click on the arrow beside the XPression Maps title to open the Label and Drawing menus.

4. From the Labels list, click on the label style you want to use and drag it to the desired location.

   The label appears at the Zoom level set in the label style, so you may have to zoom in or out (using the scroll wheel on your mouse) in order to see the new label.

   Alternatively, you can set a default label style to use in any scene in the current folder. See “To add a default label:” on page 14–10

To add a default label:

1. Select the template or scene to which you want to add a label.
2. In the Search tab, in the Location field, enter the location to which you want to add a label.
3. Click on the arrow beside the XPression Maps title to open the Label and Drawing menus.
4. Then click on the three dots in the top-right corner of the label you want to use and click Set Default.
5. In the **Result** section, click the + sign beside the location for which you want to add a label.

The label is inserted in the correct location on the map, with the **Locality** name. This label style will be used by default for all scenes in the current folder.

**To override a default label:**

- Click on a different label style and drag it on top of the default label, to change only that instance of the label.
In other scenes in the same folder, the default label will remain the same.

**To edit a label:**

1. Select the template or scene you want to edit.
2. In the **Output** window, select the label you want to edit.
3. In the **Edit** tab, in the **Drawing** section, adjust the following properties as necessary.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action</td>
<td>Place the label on top of or behind other text in the scene or delete the label</td>
</tr>
<tr>
<td>Zoom</td>
<td>Enter a value or use the arrows to adjust the size of the label in relation to the map.</td>
</tr>
<tr>
<td>Longitude, Latitude and Rotation</td>
<td>Enter a value or use the arrows to adjust the position of the label.</td>
</tr>
<tr>
<td>GPS</td>
<td>The GPS coordinates of the label.</td>
</tr>
<tr>
<td>Size</td>
<td>Enter a value or use the arrows to adjust the absolute size of the label.</td>
</tr>
<tr>
<td>Frontface</td>
<td>Select to have the front side of the label face the camera.</td>
</tr>
</tbody>
</table>
You can also toggle this parameter in the output window by clicking the **Frontface** icon ( ) at the bottom of the label’s bounding box.
| Auto Zoom            | Select to have the label stay the same size, regardless of the **Zoom** level.              |
| Visible              | Select if you want the label to be visible or deselect to hide the label.                  |

4. In the **Text** section, you can change the text of the label if you want.
5. When you’ve finished modifying the label, save your new scene. See “**To save a scene:**” on page 14–6.

**To delete a label:**

1. Select the template you want to edit.
2. In the **Output** window, select the label you want to delete.
3. In the **Edit** tab, click the **Delete Drawing** button.

![Image](image.png)

**Figure 14.12** HTML5 Client - **Delete Drawing Button**

Alternatively, with the label selected, press the **Delete** key.
Adding, Editing, Deleting and Ordering Drawings

You can add drawings to your scenes, providing the drawings have been added to the Drawings tab of the template group that contains your template. You can also delete and edit drawings and change their order, putting one in front of another. For more information, see “Adding Drawings” on page 6–13.

![Figure 14.13 Scene Templates - Drawings Tab](image)

**Figure 14.13 Scene Templates - Drawings Tab**

To add a drawing:

1. Select the template or scene to which you want to add a drawing.
2. Click the arrow beside the XPression Maps logo to open the Label and Drawing lists and select the Drawing tab.

![Figure 14.14 HTML5 Client - Drawing List](image)

**Figure 14.14 HTML5 Client - Drawing List**
3. In the **Drawing** list, click the drawing that you want to add to the scene and then click on the map where you want to place the drawing.

   For **Line** and **Area** drawings, click and drag the mouse on the map until the line or area is complete.

**To edit a drawing:**

1. Select the scene you want to edit.
2. Select the drawing you want to edit.
3. In the **Edit** tab, in the **Drawing** section, adjust the following properties as required.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Action</strong></td>
<td>Place the drawing on top of or behind other drawings in the scene or delete the drawing.</td>
</tr>
<tr>
<td><strong>Zoom</strong></td>
<td>Enter a value or use the arrows to adjust the size of the drawing in relation to the map.</td>
</tr>
<tr>
<td><strong>Longitude, Latitude and Rotation</strong></td>
<td>Enter a value or use the arrows to adjust the position of the drawing.</td>
</tr>
<tr>
<td><strong>GPS</strong></td>
<td>The GPS coordinates of the drawing.</td>
</tr>
<tr>
<td><strong>Size</strong></td>
<td>Enter a value or use the arrows to adjust the absolute size of the drawing.</td>
</tr>
<tr>
<td><strong>Frontface</strong></td>
<td>Select to have the front side of the drawing face the camera. You can also toggle this parameter in the output window by clicking the <strong>Frontface</strong> icon ( ) at the bottom of the drawing’s bounding box.</td>
</tr>
<tr>
<td><strong>Auto Zoom</strong></td>
<td>When checked, the drawing remains the same size in pixels, while the camera animates through the different zoom levels. When unchecked, the drawing increases or decreases in size as the camera animates through the different zoom levels.</td>
</tr>
<tr>
<td><strong>Visible</strong></td>
<td>Select if you want the drawing to be visible.</td>
</tr>
<tr>
<td><strong>Texture</strong></td>
<td>Applies to line drawings and area drawings that have an image or pattern.</td>
</tr>
<tr>
<td><strong>Scale</strong></td>
<td>Multiplies the scale of the drawing. For example, a line drawing of a road with a scale of 1, will be a single 2-lane road, while a road with a scale of 2 will be a 4-lane road.</td>
</tr>
<tr>
<td><strong>Rotation</strong></td>
<td>Increases the rotation of the drawing, making it appear spiralled.</td>
</tr>
<tr>
<td><strong>Aspect</strong></td>
<td>Increases or decreases the width of the drawing, relative to the height.</td>
</tr>
<tr>
<td></td>
<td>• If the value is less than 1, the width (X) decreases relative to the height (Y).</td>
</tr>
<tr>
<td></td>
<td>• If the value is greater than 1, the width increases relative to the height.</td>
</tr>
<tr>
<td><strong>Point</strong></td>
<td>Applies to area drawings only.</td>
</tr>
<tr>
<td><strong>Index</strong></td>
<td>Identifies each point in the drawing based on the order in which it was added. The selected point turns red.</td>
</tr>
<tr>
<td><strong>Longitude</strong></td>
<td>Enter a value or use the arrow to adjust the longitudinal position of the selected <strong>Index</strong> point.</td>
</tr>
<tr>
<td><strong>Latitude</strong></td>
<td>Enter a value or use the arrow to adjust the latitudinal position of the selected <strong>Index</strong> point.</td>
</tr>
</tbody>
</table>

4. When you’ve finished modifying the drawing, save your new scene. See “**To save a scene:**” on page 14–6.
To replace a drawing:

1. Select the scene you want to edit.
2. From the Drawings list, click on a different drawing of the same type (line, area, text, etc.) and drag it on top of the drawing you want to replace.

To set a default text drawing:

1. Select the scene you want to edit.
2. From the Drawings list, click on the text drawing you want to set as a default for all scenes in the current folder.
3. Then click on the three dots in the top-right corner of the text drawing you want to use and click Set Default.

To delete a drawing:

1. Open the scene from which you want to delete a drawing.
2. Click on the drawing you want to delete to select it
3. In the Edit tab, click the Delete Drawing button.

Alternatively, you can click on the drawing you want to delete and then press the Delete key.

To order drawings:

1. Open the scene in which you want to reorder the drawings.
2. Select the drawing you want to move.
3. In the Edit tab, click the Move Drawing to Front button to move the drawing to the front.

OR

Click the Move Drawing to Back button to move the drawing to the back.
Adding a Flight Point

Start and Stop flight points are automatically added to each template if none exist. You can add one additional flight point in the XPression Maps HTML5 client to create a flight animation. If you add more than one additional flight point, only the last one added will be kept. The flight is calculated automatically between the initial flight point, stored inside of the template, and the ending location selected by the user in the client application.

To add a flight point:

1. In the Home screen, from the New tab, select the group that contains the template you want to use for your scene.
2. In the Select Scene from: pane, select the template to modify.
3. In the Search field, enter the location where you want to add the flight point.
4. In the Scene tab, use the Zoom Level parameter to adjust the zoom level of the map at that location. Alternatively, you can scroll the mouse wheel to adjust the zoom level.
5. Then, in the Control section, click the Add Flight Point button.
6. Click the **Preview** icon to play the animation.

![HTML5 Client - Preview](image)

**Figure 14.20** HTML5 Client - Preview

7. If no further edits are required, in the **Save** tab, save your new scene. See “**To save a scene:**” on page 14–6.
Downloading a Still Image

You can download a still image of any scene if desired.

To download a still:

1. Select the scene you want to save as a still image.
2. In the Scene tab, from the Type dropdown, select Still.

3. Then click the Preview button.
4. In the bottom-right corner of the scene, click the Download button.

The Opening PNG dialog appears.

5. Select Save File in the Opening PNG dialog and navigate to the location where you want to save the still image.
6. Give the still image a name and click Save.
Playing Saved Scenes in the HTML5 Client

Any template that has been added to the Scene Templates feature in the XPression Maps main application is automatically available in the HTML5 client.

To play a saved scene:

1. Launch the XPression Maps HTML5 Client.
   
   See “Launching the HTML5 Client” on page 14–2.

2. Click on the Saved tab and open the folder containing the scene you want to play.

3. In the Scenes pane, click on the scene you want to play.

4. In the Scene tab, click Preview.
Deleting and Duplicating Saved Scenes

Only users with the **Delete Saved Scenes** privilege can delete a scene, but anyone can duplicate a scene.

**To delete a scene:**

1. In the **Home** screen, from the **Saved** tab, select the group that contains the scene you want to delete.
   The group expands to display subgroups, if there are any.
2. In the **Select Scene from: Saved** panel, in the top-right corner of the scene, move the cursor over the 3 dots and select **Delete Scene**.

   ![Figure 14.24 HTML5 Client - Delete Scene](image)

3. In the confirmation dialog that opens, click **Yes** to delete the scene.

**To duplicate a scene:**

1. In the **Home** screen, from the **Saved** tab, select the folder that contains the scene you want to duplicate.
   The group expands to display subfolders, if there are any.
2. In the **Select Scene from: Saved** panel, in the top-right corner of the scene, move the cursor over the 3 dots and select **Duplicate Scene**.

   ![Figure 14.24 HTML5 Client - Duplicate Scene](image)

3. The scene is opened for editing.
4. Make any needed changes to the scene.
5. Then, in the **Save** tab, enter a new name for the scene.
6. Click the **Folder** icon to select a folder to which to save the scene.
7. Click the **Save** icon.
Managing Saved Scene Folders

User who have been assigned the privilege of Managing Saved Scene Folders can add, delete and rename folders and sub-folders.

To add a folder:

1. In the Saved tab, click the Add New Folder icon.

   ![Figure 14.25 HTML5 Client - Add New Folder Icon](image)

2. In the New Folder dialog, enter a name for the folder and then click OK.

   ![Figure 14.26 HTML5 Client - Add New Folder](image)

To add a sub-folder:

1. In the Saved tab, select the folder to which you want to add a sub-folder.
2. Then click the Add New Sub-Folder icon.

   ![Figure 14.27 HTML5 Client - Add New Sub-Folder Icon](image)

3. In the New Sub-Folder dialog, enter a name for the sub-folder and then click OK.

   ![Figure 14.28 HTML5 Client - Add New Sub-Folder](image)

To delete a folder:

1. In the Saved tab, select the folder or sub-folder you want to delete and click the Delete Folder icon.

   ![Figure 14.29 HTML5 Client - Delete Folder Icon](image)

2. In the Delete Folder dialog, select the checkbox to confirm that you want to delete the folder and all its contents and then click Delete.
To rename a folder:

1. In the Saved tab, select the folder you want to rename and click the Rename Folder icon.

2. In the Change Folder Name dialog, enter a new name for the folder and then click OK.
Playing Saved Scenes in a Host Application

Saved scenes created in the XPression Maps HTML5 Client application can be dragged into projects in host applications such as XPression Studio.

You’ll also need to configure the host application, as described below. The instructions provided are for configuring an XPression rendering engine, but the same process (or something similar) will need to be done for any rendering or preview engine on which you want to run your XPression Maps HTML5 Client scene.

To configure a host application:

1. In XPression, click Edit > OpenMAM Setup.

   The OpenMAM Setup dialog opens.

   ![Figure 14.33 XPression OpenMAM Setup Dialog](image)

2. Click Add.

   The Add OpenMAM Server dialog opens.

   ![Figure 14.34 Add OpenMAM Server Dialog](image)
3. Select the XPression Maps option and click OK.
   The XPression Maps Server dialog opens.

4. In the Server ID section, in the ID field, enter the name of the server that is running XPression Maps.
   You can find this address in the XPression Maps main application in File > Preferences > Web Interface, in the Web Template Database section, in the Hostname field. Do not include “http://” or anything after “.rossvideo.com”.

5. In the Description field, enter a user-readable name, for example, XPression Maps Server to identify the server.

6. In the Connection Settings section, in the Server URL field, enter the same information as in the Server ID field.

7. In the Plugin App field, enter the path to the XPression Maps HTML5 Client application executable file.
   Typically this path is C:\XPressionMapsWebClient\XPressionMapswebclient.exe.

8. Then click OK and in the OpenMAM Setup dialog, click OK again.

To drag a scene into a host application:

1. Open a project in the host application (XPression Studio, for example) and add a new blank scene.

2. Launch the XPression Maps HTML5 Client application.

3. In the HTML5 Client application, from the Saved tab, navigate to the scene you want to bring into the host application.
   The scene must be saved before you drag it into the host application.

4. Select the scene and in the Save tab, click and hold the mouse button down on the Media ID icon and drag the cursor into the XPression scene.
The **Asset Transfer** progress dialog appears and closes when the transfer is complete.

![Asset Transfer Progress Dialog](image)

*Figure 14.38 Asset Transfer Progress Dialog*

Alternatively, with the HTML5 Plugin open in your news room system, you can just drag a saved map straight from the HTML5 Client into the **Object/Field Content** section in the plugin, as shown below:

![Dragging into the HTML5 Plugin](image)

*Figure 14.39 Dragging into the HTML5 Plugin*
The map appears in the **Preview** pane of the HTML5 Plugin and the video can be viewed.

![Figure 14.40 Map Added to the HTML5 Plugin](image)

*Figure 14.40 Map Added to the HTML5 Plugin*
Interactive User Interface

The XPression Maps Interactive user interface is an optional feature set that is used to create interactive scenes and projects that can be loaded and controlled by the XPression Maps Touch Client, a web-based interface.

When you want to create interactive scenes and projects, you’ll need to first select the **Interactive** mode and configure the **Interactive** tab in **Preferences**.

The following topics are discussed in this section:

- “Selecting Interactive Mode” on page 15–2
- “Creating Interactive Projects” on page 15–3
- “Managing Interactive Scenes” on page 15–10
- “Editing Projects” on page 15–14
Selecting Interactive Mode

The XPression Maps main application needs to be running in **Interactive** mode in order to use the Touch Client. Refer to the instructions below.

**To select Interactive mode:**

1. Launch XPression Maps.
2. In **File > Preferences > Output**, in the **Misc** section, select the **Start in Interactive Mode** checkbox.

![Preferences - Output - Select Interactive Mode](image)

3. Click **Save** and **OK**.

The **Interactive** menu appears in the main menu bar. It contains options to edit your projects, manage your interactive scenes, execute a project and add an overlay layer to a project. You can also view the scenes you’ve created in your project.

In addition, a new group of corresponding buttons appears in the toolbar section. This group is called the **Interactive Toolbar**.

![Interactive Toolbar](image)
Creating Interactive Projects

You can use the XPression Maps Interactive user interface to create a complete project with an Overlay layer on which you can place touch icons to navigate through the scenes.

Use existing saved scenes or create new scenes for your Touch project.

The following topics are covered in this section:

• “Opening and Loading Projects” on page 15–4
• “Creating an Overlay” on page 15–5
• “Creating a Home Position and Scenes” on page 15–6
• “Editing a Scene” on page 15–7
• “Previewing Projects” on page 15–8
• “Deleting Projects” on page 15–8
• “Making Animated Scenes Usable in the Touch Client” on page 15–9
Opening and Loading Projects

To begin you'll need to open a new project or load an existing project. Then you'll select a Home Position from which the navigation will begin, up to 5 additional scenes and the Overlay layer. When you're finished, you'll be able to execute the project and make it available to the XPression Maps Touch Client.

To open a new project:

1. Click File > New Project.
   The New Project dialog opens.

2. In the Group section, accept the Default project group to store your project or use the drop-down to select a different group.
   The Default project group is located in C:\XPressionMaps_3.x\Projects. If you want to create a new project group, you'll need to create a folder in that location. The new folder will then appear in the Group drop-down.

3. In the Project section, enter a name for the project.

4. Then click New.
   A new map opens in the Output window.

To load an existing project:

1. Click File > Load Project.
   The Load Project editor opens.

2. Click the arrow beside the group containing the project you want to open and select the project.

3. Then click Load.

4. The selected project opens in the Output window.
Creating an Overlay

The **Overlay** layer contains the icons that will be used to interact with the project while it’s on air. One overlay will work across all scenes in the project.

Sample touch icons and backplates are located in the **Drawing Toolbox** in the **Interactive** group. Each drawing needs to be configured to behave in the desired manner and then added to the scene.

To create an overlay:

1. In the **Menu** bar, click **Interactive > Main Overlay**.
   Alternatively, you can click the **Main Overlay** button in the **Interactive** toolbar.

   ![Interactive Toolbar - Main Overlay](image)

   A transparent red layer appears on top of the map in the **Output** window.

2. In the **Drawing Toolbox** to the right of the **Output** window, from the **Group** drop-down, select the **Interactive** group.
   A default set of interactive drawings is displayed.

3. Click to select each type of icon you want to use and from the context menu, click **Edit Drawing**.

4. In the **Drawing Management Editor** that opens, from the **Interactivity** drop-down, select the desired behavior.
   The options are:
   - **ActivateScene1 - 5** — touching the icon activates the corresponding scene.
   - **ContinueAnimation** — touching the icon resumes an animation that has been stopped.
   - **FlyHome** — touching the icon returns the map to the Home scene.
   - **PlayAnimation** — touching the icon plays the corresponding animation.
   - **SetStartActivateScene1 - 5** — touching the icon gets the scene ready to be activated, but you’ll need to press a **Play** icon to activate the scene.
   - **StopAnimation** — touching the icon stops the animation.

5. Then from the **Pressed Image** drop-down, select the image that will indicate that an icon has been touched, typically a different colored version of the same icon.

6. Click **Done** to close the **Drawing Management Editor**.

7. If you want to have a background for the touch icons, select a backplate drawing and add it to the scene.

8. With your icons are configured, click on each one and then click on the scene to add it.
   You can add the icons on top of the backplate, if you are using one.

9. Click **File > Save Project**.
Creating a Home Position and Scenes

For each interactive project, you’ll need a Home Position and one or more scenes. You can create new scenes or use an existing saved scene.

To create a Home Position:

1. Open a new project as described in “Opening and Loading Projects” on page 15–4.
2. In the Menu bar, select the Interactive Toolbar and click the Home Position button.

   Figure 15.6 Interactive Toolbar - Home Position

3. From the Map Styles drop-down, select the type of map you want to use for your project.
   For information about map styles, see “Map Styles” on page 5–1.
4. Adjust the map to reflect the location and Zoom level you want to see as the Home Position.
5. Add labels or drawings as necessary.
6. Click File > Save Project.

To create a scene:

1. In the Main Menu bar, in the Interactive Toolbar, click the Scene 1 button.

   Figure 15.7 Interactive Toolbar - Scene 1

   A new map is displayed in the Output window. The map style will be the same as the map that was open the last time the application was launched.
2. Create your scene using the same map style as your Home Position scene, to make a smoother transition from one scene to the next.
3. Add drawings and labels to your scene, as needed.
   For detailed information about creating scenes, see “Creating Scenes” on page 8–1.
4. In the timeline Frame Range field, enter the number of frames over which the flight from the previous location to the location in this scene will occur.

   Figure 15.8 Timeline - Frame Range

   A minimum frame range of 100 is recommended. A lower frame range creates a flight that is unpleasantly quick. You can set a higher frame range for a slower flight.
5. Move the Timeline slider to the end frame and add a camera key frame at this point.

   Figure 15.9 Add Camera Key Frame Button

6. Click File > Save Project.
7. Repeat the above steps for each additional scene in your project.
To use an existing scene:

1. Click File > Open.

2. Select a scene with the same map style as your Home Position scene.
   
   If the selected scene doesn’t have the same map style as your Home Position scene, use the Map Styles drop-down to change the style.
   
   This will make a smoother transition from one scene to the next.

3. Add drawings and labels to your scene, as needed.
   
   For detailed information about creating scenes, see “Creating Scenes” on page 8–1.

4. In the timeline Frame Range field, enter the number of frames over which the flight from the previous location to the location in this scene will occur.

   ![Figure 15.10 Timeline - Frame Range](image)

   A minimum frame range of 100 is recommended. A lower frame range creates a flight that is unpleasantly quick. You can set a higher frame range for a slower flight.

5. Move the Timeline slider to the end frame and add a camera key frame at this point.

   ![Figure 15.11 Add Camera Key Frame Button](image)

6. Click File > Save Project.

**Editing a Scene**

If you need to make some changes to a scene you’ve created, you’ll need to add a new camera frame to the scene, as described in the following instructions.

**To edit a scene:**

1. Click File > Load Project to open an existing project and in the Interactive toolbar, click the Scene button for the scene you want to edit.

   ![Figure 15.12 Interactive Toolbar - Scene 1](image)

2. Move the timeline slider to the last camera key frame.

3. Make any necessary changes to the scene.

4. Then click the Add Camera Key Frame button to mark this point in the new scene.

5. Click File > Save Project.
**Previewing Projects**

Once you’ve created your interactive project, the **Execute** button allows you to preview it in the **Output** window.

To preview your project:

1. In the **Menu** bar, click **Interactive > Execute**.
   
   Alternatively, you can press **F5** or click the **Execute** button in the **Interactive** toolbar.

   ![Interactive Toolbar - Execute](image)

   **Figure 15.13** Interactive Toolbar - Execute

2. Click on the interactive icons that you added to the **Overlay** layer to navigate the project.

**Deleting Projects**

1. Click **File > Delete Project**.
2. The **Delete Project** editor opens.

3. Click the **Default** drop-down and select the project you want to delete.
4. Then click **Delete**.
5. In the **Delete Project** confirmation dialog, click **Yes**.
6. Click **Close** to exit the **Delete Project** editor.
Making Animated Scenes Usable in the Touch Client

Any scene that has been created in XPression Maps can be used in the Touch Client, providing it contains at least one camera key frame. If the scene contains an animation, you will need to make an adjustment, as described below.

To make an animated scene usable in the Touch Client:

1. Click File > Open.
2. Select a scene with the same map style as your Home Position scene.
   If the selected scene doesn’t have the same map style as your Home Position scene, use the Map Styles drop-down to change the style.
   This will make a smoother transition from one scene to the next.
3. Left-click in the timeline and drag the selection box around the key frames.
   The selected key frames change from blue to green (drawing key frames) or red (camera key frames).
4. Then click and hold one key frame and drag it to the right, to advance the group of key frames on the timeline.
5. Move the timeline slider to a position before the first key frame and add another camera key frame.
   This will give the animation time to play before the end of the flight.
Managing Interactive Scenes

When you have finished creating an interactive scene or project, use the Manage Interactive Scenes editor to save home positions, scenes and overlays. This makes them available to be loaded in the Touch Client.

You can store home positions, scenes and overlays in separate folders or you can store them all in one project folder, perhaps with sub-folders for each.

There are already folders in the editor for home positions and overlays, but you’ll need to add at least one folder, to store your scenes.

To add a folder:

1. In the Interactive Toolbar, click the Manage Interactive Scenes button.

   ![Interactive Toolbar - Manage Interactive Scenes](image1)

   Figure 15.15 Interactive Toolbar - Manage Interactive Scenes

   The Manage Interactive Scenes editor opens.

   ![Manage Interactive Scenes Editor](image2)

   Figure 15.16 Manage Interactive Scenes Editor

2. On the left side, above the Folder panel, click the Add Folder button.

   ![Manage Interactive Scenes Editor - Add Folder](image3)

   Figure 15.17 Manage Interactive Scenes Editor - Add Folder

3. In the New Folder dialog, enter a name for the folder, (for example, the project name) and click OK.
To add a scene:

1. Do one of the following:
   a. From the Interactive Toolbar, when you’ve finished creating a project, select a scene (Home Position, Overlay or Scenes 1 - 5).
      When adding a scene other than the Overlay, make sure that the Overlay button is not also selected.
      OR
   b. Click File > Open to load a saved scene from the database into the Output window.

2. In the Interactive Toolbar, click the Manage Interactive Scenes button.

   **Figure 15.18** Interactive Toolbar - Manage Interactive Scenes

   The Manage Interactive Scenes editor opens. Notice that the title bar indicates the type of scene that was selected in Step 1.

   **Figure 15.19** Manage Interactive Scenes Editor

3. From the Folder list, select the folder in which you want to save your scene or click the Add Folder button to add a new folder.

4. In the Scenes panel to the right of the Folders, click the Add Scene button to add the scene to the selected folder.

   **Figure 15.20** Manage Interactive Scenes - Add Scene Button
The **Add Scene** dialog opens. If you are adding an **Overlay** scene, the **Add Overlay Scene** dialog opens. If you are adding a **Home Position** scene, the **Add Home Scene** dialog opens. The next steps are the same.

![Add Scene](image)

**Figure 15.21 Manage Interactive Scenes Editor - Add Scene**

5. In the **Name** field, enter a name for the scene.
6. From the **User** drop-down, select the name of the person creating the scene (optional). This can be used to filter results by creator, if necessary.
7. In the **Comment** field, enter a description of the scene (optional).
8. Then click **OK**.

The scene appears in the **Scenes** panel and is now stored in the selected folder.

![Manage Interactive Scenes Editor - Add Scene to Folder](image)

**Figure 15.22 Manage Interactive Scenes Editor - Add Scene to Folder**

9. Click **Close** to exit the **Manage Interactive Scenes** editor.

Complete the above steps for each scene you want to add to the editor.
To delete a scene:

1. In the Interactive Toolbar, click the Manage Interactive Scenes button to open the editor.

![Interactive Toolbar - Manage Interactive Scenes](image)

*Figure 15.23  Interactive Toolbar - Manage Interactive Scenes*

2. From the Folder list, select the folder containing the scene you want to delete.

3. In the Scenes panel, select the scene you want to delete and click the Delete Scene button.

![Manage Interactive Scenes - Delete Scene Button](image)

*Figure 15.24  Manage Interactive Scenes - Delete Scene Button*

4. In the confirmation dialog, click Yes.

![Manage Interactive Scenes - Delete Scene Confirmation](image)

*Figure 15.25  Manage Interactive Scenes - Delete Scene Confirmation*
Editing Projects

When you save your projects or scenes in the Manage Interactive Projects editor, the Edit Project editor is automatically updated with the project and scene names for the loaded project.

You can rename the loaded project and the scenes to be used in the project with the Edit Project option. You can also add any scene that has been saved in the XPression Maps Scene folder.

The XPression Maps Scene folder is found at: C:\XPressionMaps_3.0\Scene

To edit a project:

1. Load a project.
2. In the Menu Bar, click Interactive > Edit Project.
   The Edit Project dialog opens.

   ![Figure 15.26  Touch UI - Edit Project Editor](image)

3. In the Name field, edit the project name and select the Overwrite checkbox.
   In the Overlay section, the overlay applied to the scene currently in the Output window is automatically selected and normally would not be changed.
4. In the Home Position section, use the drop-down to navigate to the folder where you have saved your scenes and select a different scene to designate as the Home Position scene.
5. In the Scene 1 to Scene 5 fields, use the drop-down to navigate to the folder where you have saved your scenes and select a different scene.
   It’s best to select scenes that have been created in the same or a complimentary map style to make the transition between scenes smooth.
6. When you have finished editing your project, click Save.
Touch Client

The XPression Maps Touch Client is a web-based control interface that allows you to load and control interactive scenes and projects that are created in the XPression Maps interactive user interface.

Typically, the Touch Client would be used in one of two workflows:

• To load and control a project that has been created in the main application and is ready to be used on air.
• To load and control individual MOS or Touch scenes that have been created in the main application and saved into the database.

The following topics are discussed in this section:

• “Launching the Touch Client” on page 16–2
• “Using the Touch Client” on page 16–3
Launching the Touch Client

Once you’ve started XPression Maps in Interactive mode, you can launch the XPression Maps Touch Client.

To launch the Touch Client:

1. Open your browser and in the address field, enter “computername:8880” (without the quotation marks). Instead of “computername” you can also enter the IP address of the computer on which you want to run the Touch Client.
2. Press Enter.

The XPressionMaps Touch Client opens.

3. Enter your Username and Password and click Log in.

The XPression Maps Touch Client Home page opens.

If your Home page is missing the elements in the lower half of the screen, it's because you don't have the required user privileges. See section on “User Management” on page 17–1.

🌟 The Touch Client times out after 10 minutes of inactivity, requiring you to log in again.
Using the Touch Client

The XPression Maps Touch client provides an interface for loading and controlling interactive projects and scenes and managing project/scene folders. Loading individual scenes and managing project/scene folders requires specific user privileges, assigned by the administrator.

The following topics are discussed in this section:

• “Overview of the Interface” on page 16–4
• “Loading Projects” on page 16–6
• “Controlling Projects and Scenes” on page 16–7
• “Managing Saved Scene Folders” on page 16–9
Overview of the Interface

If a project is open in the main application, it will appear in the **Home** page. Otherwise, the **Program** slot and the **Scene 1** slot will display whatever is in the **Output** window of the main application and the remaining slots will display the corresponding scenes of the last project opened.

![Figure 16.3 XPression Maps Touch Client - Home Page](image)

Once a project is loaded, the folder and project name are displayed at the top of the UI.

![Figure 16.4 XPression Maps Touch Client - Folder and Project](image)

The **Home Position** and scenes are displayed in slots across the top of the page. Each scene contains a map and some basic information.

![Figure 16.5 Touch Client - Scene Information](image)

The information provided is as follows:

- The name of the scene, as entered in the **Manage Interactive Scenes** editor.
- The style of map used to create the scene.
- The duration of the transition from the previous scene to this scene.
- A description of the scene, as entered in the **Manage Interactive Scenes** editor (optional).

Just beneath the right corner of the scene is the control for placing the scene on air.

![Figure 16.6 Touch Client - On Air Control](image)
In the lower half of the Touch Client **Home** page, you’ll find the following tabs:

- Control (if your user privileges include this option)
- Load MOS Scene
- Load Touch Scene
- Home Position

The **Control** tab contains scene selection buttons for the home position and scenes 1 to 5 and a standard set of animation buttons for controlling a scene on air. It also contains 2 application buttons which activate a remote touch screen that can be operated by the onscreen talent.

The **Load MOS Scene** tab contains a list of folders from which you can select scenes that have been saved as **.wnm** files in the **Scene** database in the main application. To the right of the list, when a folder is selected, you’ll see the scenes contained in that folder.

The **Load Touch Scene** tab contains a list of folders from which you can select scenes that have been stored in the **Manage Interactive Scenes** editor in the Interactive UI. To the right of the list, when a folder is selected, you’ll see the scenes contained in that folder.

The **Home Position** tab displays the scene that has been designated as a **Home Position** scene in the selected project. You can change the **Home Position** scene to display a different location or zoom level.
Loading Projects

When a project has been created in the main application and saved, it can be accessed in the Touch Client.

To load a project:

• On the left side of the Home page, click Projects > Default and from the list select the project you want.

![Figure 16.7 XPression Maps Touch Client - Select Project](image)

The project is loaded and the scenes displayed as described in “Overview of the Interface” on page 16–4.
Controlling Projects and Scenes

In the tabs in the lower half of the Home page, you can play or edit the Home Position scene and up to 5 other scenes, activate a remote touch screen, and load scenes (all depending on your user privileges).

To play the Home Position scene on air:

- In the Control tab, click the Fly Home button.

To play scenes 1 to 5 on air:

1. In the Control tab, from the Scenes group, select a scene.
   
   This brings the scene on air as a still image.

2. Then activate the scene as follows:
   
   - In the Animation group, click the Play button.
   - Click the Stop button to pause the animation, if necessary.
   - Click the Continue button to resume.
   - Click the Begin button to go immediately to the start of the animation.
   - Click the End button to go immediately to the end of the animation.

To activate a remote touch screen:

- In the Control tab, in the Application section:
  
  › Click the Full Screen button to activate the selected project or scene at full screen.
  
  OR
  
  › Click the Execute button to activate the selected project or scene within the XPression Maps main application for testing purposes.
To load a MOS or Touch scene:

1. With a project open, in the top row, click the slot in which you want to place a new scene.
   ∗ Make sure you’re not replacing a scene that is on air.
2. In the Load MOS Scene or Load Touch Scene tab, select the folder containing the scene you want to use in the selected slot.
   It’s best to select scenes that have been created in the same or a complimentary map style as the other scenes in the project to make the transition between scenes smooth.
3. Click the scene you want to place in the selected slot.
   The new scene appears in the selected slot and is ready to go on air.

To edit the Home Position scene:

• In the Home Position tab:
  › Left-click and drag the map to change the location.
  OR
  › Use the mouse scroll wheel to zoom in or out on the map.
     You can also right-click and draw a rectangle over the area you want to zoom in to.
Managing Saved Scene Folders

User who have been assigned the privilege of Managing Saved Scene Folders can add, delete and rename folders and sub-folders.

To add a folder:

1. In the Load MOS Scene or Load Touch Scene tab, click the Add New Folder icon.

![Figure 16.10 Touch Client - Add New Folder Icon](image)

2. In the New Folder dialog, enter a name for the folder and then click OK.

![Figure 16.11 Touch Client - Add New Folder](image)

To add a sub-folder:

1. In the Load MOS Scene or Load Touch Scene tab, select the folder to which you want to add a sub-folder.
2. Then click the Add New Sub-Folder icon.

![Figure 16.12 Touch Client - Add New Sub-Folder Icon](image)

3. In the New Sub-Folder dialog, enter a name for the sub-folder and then click OK.

![Figure 16.13 Touch Client - Add New Sub-Folder](image)

To delete a folder:

1. In the Load MOS Scene or Load Touch Scene tab, select the folder or sub-folder you want to delete and click the Delete Folder icon.

![Figure 16.14 Touch Client - Delete Folder Icon](image)

2. In the Delete Folder dialog, select the checkbox to confirm that you want to delete the folder and all its contents and then click Delete.

![Figure 16.15 Touch Client - Delete Folder](image)
To rename a folder:

1. In the Load MOS Scene or Load Touch Scene tab, select the folder you want to rename and click the Rename Folder icon.

   Figure 16.16 Touch Client - Rename Folder icon

2. In the Change Folder Name dialog, enter a new name for the folder and then click OK.

   Figure 16.17 Touch Client - Change Folder Name
User Management

XPression Maps supports the management of user accounts and privileges for the XPression Maps HTML5 Client and XPression Maps Touch Client. A drop-down menu in the top-right corner of both clients allows an administrator or superuser to add or delete users, assign them to user groups and edit their account information. This menu is also used to log out of the client.

Any user can use this feature to change their account password.

The following topics are discussed in this section:

• “Managing Users” on page 17–2
• “Managing Groups” on page 17–6
• “Changing your Password” on page 17–8
Managing Users

There are a number of operations that the administrator can perform, as follows:

- Adding users and assigning them to groups
- Deleting users
- Editing user details

To add a user:

1. From the **User Management Menu**, select **New User**.
   The **New User** form opens.

   ![New User Form](image)
   
   **Figure 17.3 User Management - New User Form**

2. Enter the **Username**, **Password**, **First Name** and **Last Name** of the new user.

3. If the user will be an administrator, select the **Is Administrator** checkbox.

4. From the **Web Client Group** drop-down, assign the user to a user group.

5. For more information on user privileges, see "**Managing Groups**" on page 17–6.

   The user groups and default privileges are:
   
   - **Artist** — Delete Saved Scenes
   - **Journalist** — None
   - **Producer** — Manage Saved Folders / Delete Saved Scenes
   - **Production** — None
   - **Superuser** — Manage Saved Folders / Delete Saved Scenes

6. Similarly, from the **Touch Group** drop-down, assign the user to a user group.

   The user groups and default privileges are:
   
   - **Artist** — All Users Scenes / Change Home / Load Scene
   - **Journalist** — Change Home / Load Scene
   - **Producer** — All Users Scenes / Change Home / Load Scene / Use Controls
   - **Production** — All Users Scenes / Change Home / Load Scene
   - **Superuser** — All Users Scenes / Change Home / Load Scene / Use Controls
7. In the **E-Mail** field, enter an e-mail address for the user (required).
8. In the **Phone Number** field, enter a phone number for the user (optional).
9. Click **Submit** to add the user.

**To delete a user:**

1. From the **User Management Menu**, select **Manage Users**.
   
   The **Manage Users** screen is displayed.

   ![Figure 17.4 User Management - Manage Users](image)

   **Figure 17.4** User Management - Manage Users

2. In the **Users** list, select the user you want to delete.
   
   The **Details** panel is populated with the user’s information.

   ![Figure 17.5 User Management - User Details](image)

   **Figure 17.5** User Management - User Details
3. In the **Details** panel, click **Delete User**.

   A confirmation dialog opens.

   ![Confirmation Dialog](image)

   *Figure 17.6 Web and Touch Client - Delete User Confirmation*

4. Click **OK**.

5. Click **Exit** to close the **Manage Users** screen.

To edit user details:

1. From the **User Management Menu**, select **Manage Users**.

   The **Manage Users** screen is displayed.

   ![Manage Users Screen](image)

   *Figure 17.7 User Management - Manage Users*
2. From the **Users** list, select the user whose information you want to edit. The **Details** panel is populated with the user’s information.

![Figure 17.8 User Management - User Details](image)

3. Edit the user details as necessary and click **Update**. A message appears above the **Update** button, indicating that the update was successful.

4. Click **Exit** to close the **Manage Users** screen.
Managing Groups

Users can be assigned to Web User Groups or Touch User Groups or both. Within those groups, they can be further assigned to one of a number of sub-groups:

A sub-group of users can have the right to manage scene folders and/or delete saved scenes, as determined by the administrator.

To edit user groups:

1. From the User Management Menu, select Web User Groups or Touch User Groups.
   The Manage User Groups screen for that group is displayed.

2. Select the sub-group you want to edit.
   The Details panel is populated with the group’s details.
3. In the **Details** panel, select or deselect the check boxes to assign privileges to the group.

   In the **Web User Groups**, the options are:
   - **Manage Saved Folders** — the user will be able to add and delete **Group** folders and **Sub-folders** and edit the folder names.
   - **Delete Saved Scenes** — the user will be able to delete scenes from the **Saved** tab.

   In the **Touch User Groups**, the options are:
   - **All Users Scenes** — The user can load scenes created by anyone. If this option is unchecked, the user will only be able to load scenes they’ve created themselves.
   - **Change Home** — The user can change the location of the **Home Position** scene by manipulating the globe.
   - **Load Scene** — The user can load a saved scene.
   - **Use Controls** — The user can use the playout controls to manage the scene animation. If this option is unchecked, the **Control** tab is removed.

4. Click **Update** to save your changes.

5. Click **Exit** to close the **Manage Web User Groups** or **Manage Touch User Groups** screen.
Changing your Password

Any user can change their own password.

To change your password:

1. From the User Management Menu, select Account.
   
   The User Details screen opens.

2. In the Change Password section, enter your current password and then enter your new password twice.
3. Click Save and then click Exit to close the User Details screen.
Appendix A: Keyboard Shortcuts

Shortcuts for the following menus and windows are included in this section:

- “File Menu Shortcuts” on page A–1
- “Edit Menu Shortcuts” on page A–1
- “Output Window Shortcuts” on page A–2
- “Animation Menu Shortcuts” on page A–2
- “Output Window Shortcuts” on page A–2

File Menu Shortcuts

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>CTRL+N</td>
</tr>
<tr>
<td>Open</td>
<td>CTRL+O</td>
</tr>
<tr>
<td>Save</td>
<td>CTRL+S</td>
</tr>
<tr>
<td>Save As</td>
<td>CTRL+SHIFT+S</td>
</tr>
<tr>
<td>Export</td>
<td>CTRL+E</td>
</tr>
<tr>
<td>Open Recent Used</td>
<td>CTRL+0...4</td>
</tr>
<tr>
<td>Exit</td>
<td>CTRL+Q</td>
</tr>
</tbody>
</table>

Edit Menu Shortcuts

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>CTRL+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>CTRL+Y</td>
</tr>
<tr>
<td>Copy Drawing</td>
<td>CTRL+C</td>
</tr>
<tr>
<td>Cut Drawing</td>
<td>CTRL+X</td>
</tr>
<tr>
<td>Paste Drawing</td>
<td>CTRL+V</td>
</tr>
<tr>
<td>Move Drawing to Top</td>
<td>CTRL+Page Up</td>
</tr>
<tr>
<td>Move Drawing Up</td>
<td>CTRL+Up</td>
</tr>
<tr>
<td>Move Drawing Down</td>
<td>CTRL+Down</td>
</tr>
<tr>
<td>Move Drawing to Bottom</td>
<td>CTRL+Page Down</td>
</tr>
<tr>
<td>Next Animation Key Frame</td>
<td>CTRL+Right Arrow</td>
</tr>
<tr>
<td>Previous Animation Key Frame</td>
<td>CTRL+Left Arrow</td>
</tr>
<tr>
<td>Add Camera Key Frame</td>
<td>CTRL+</td>
</tr>
<tr>
<td>Add Drawing Key Frame</td>
<td>CTRL+</td>
</tr>
<tr>
<td>Delete Selected Key Frames</td>
<td>CTRL+D</td>
</tr>
</tbody>
</table>
Output Menu Shortcuts

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Snapshot</td>
<td>CTRL+P</td>
</tr>
<tr>
<td>Record Animation</td>
<td>CTRL+R</td>
</tr>
</tbody>
</table>

Animation Menu Shortcuts

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rewind Animation</td>
<td>CTRL+B</td>
</tr>
<tr>
<td>Play Animation</td>
<td>CTRL+Space Bar</td>
</tr>
<tr>
<td>Continue Animation</td>
<td>CTRL+G</td>
</tr>
<tr>
<td>Stop Animation</td>
<td>CTRL+H</td>
</tr>
<tr>
<td>Forward Animation</td>
<td>CTRL+M</td>
</tr>
</tbody>
</table>

Output Window Shortcuts

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toggle Framerate Display</td>
<td>F</td>
</tr>
<tr>
<td>Select Previous Point (shape, area object, or line object)</td>
<td>Left Arrow</td>
</tr>
<tr>
<td>Select Next Point (shape, area object, or line object)</td>
<td>Right Arrow</td>
</tr>
<tr>
<td>Delete drawing or point (shape, area drawing, line drawing)</td>
<td>Delete</td>
</tr>
</tbody>
</table>
Appendix B: Managing Network Security

Secure Sockets Layer (SSL) protocol protects sensitive information as it travels across computer networks. It provides privacy, critical security and data integrity.

This section describes how to enable the SSL protocol in XPression Maps.

An SSL certificate must be purchased and installed on the XPression Maps Gateway and in the XPression Maps application. Purchase an SSL certificate from a trusted root authority (our certificates are purchased from DigiCert, so these instructions will use the steps for DigiCert as an example).

Buying an SSL Certificate

To purchase an SSL certificate, a CSR file must be generated and sent to the certificate authority. The CSR file describes the server machine that will hold the certificate as well as your Company and Organization details.

The CSR can usually be generated using a tool provided by the certificate authority (or they will provide documentation on how to generate the CSR).

Installing the Certificate

The certificate authority will provide you with the SSL certificate files.

Once the certificates have been installed, they must be configured and bound to the ports used by the XPression Maps Gateway and the XPression Maps application.

To install the certificates:

- Copy the Security Certificate (.crt) and the KEY file (.key) into the following locations:
  - C:\XPressionMaps_3.x\bin64\certs
  - C:\XPressionMapsGateway\certs

To configure the Maps Gateway:

1. Navigate to C:\XPressionMapsGateway\bin64\ and double-click the MapsGatewayConfig.xml file.

2. In the editor, change the SSL value to "1" and the HttpServer Port to "443".

3. Click File > Save.
4. Open the Windows **Computer Management** application and from **Services and Applications**, select **Services > Maps Gateway Service.**

![Maps Gateway Service](image)

*Figure B.2 Maps Gateway Service*

5. In the **Services** pane, click **Restart the service.**

To configure XPression Maps:

1. Launch the XPression Maps application.
2. Go to **File > Preferences > Web Interface.**
3. In the **Web Server Details** section, select the **SSL** checkbox.
4. In the **Web Gateway** section, change the **UI Port** from **80** to **443**.
5. Click **OK** and relaunch the application.
Contact Us

Contact our friendly and professional support representatives for the following:

- Name and address of your local dealer
- Product information and pricing
- Technical support
- Upcoming trade show information

**Technical Support**

<table>
<thead>
<tr>
<th>Telephone:</th>
<th>+1-844-652-0645 (North America)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>+800 1005 0100 (International)</td>
</tr>
<tr>
<td><strong>After Hours Emergency:</strong></td>
<td>+1 613 • 349 • 0006</td>
</tr>
<tr>
<td><strong>Email:</strong></td>
<td><a href="mailto:techsupport@rossvideo.com">techsupport@rossvideo.com</a></td>
</tr>
</tbody>
</table>

**General Information**

<table>
<thead>
<tr>
<th>Telephone:</th>
<th>+1 613 • 652 • 4886</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Fax:</strong></td>
<td>+1 613 • 652 • 4425</td>
</tr>
<tr>
<td><strong>Email:</strong></td>
<td><a href="mailto:solutions@rossvideo.com">solutions@rossvideo.com</a></td>
</tr>
<tr>
<td><strong>Website:</strong></td>
<td><a href="http://www.rossvideo.com">http://www.rossvideo.com</a></td>
</tr>
</tbody>
</table>

Visit Us

Visit our website for:

- Company information and news
- Related products and full product lines
- Online catalog
- Testimonials