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Thank You for Choosing Ross

You've made a great choice. We expect you will be very happy with your purchase of Ross
Technology.

Our mission is to:

1. Provide a Superior Customer Experience

· offer the best product quality and support

2. Make Cool Practical Technology

· develop great products that customers love

Ross has become well known for the Ross Video Code of Ethics. It guides our interactions and
empowers our employees. I hope you enjoy reading it below.

If anything at all with your Ross experience does not live up to your expectations be sure to reach
out to us at solutions@rossvideo.com.

David Ross

CEO, Ross Video

dross@rossvideo.com

Ross Video Code of Ethics

Any company is the sum total of the people that make things happen. At Ross, our employees are
a special group. Our employees truly care about doing a great job and delivering a high quality
customer experience every day. This code of ethics hangs on the wall of all Ross Video locations
to guide our behavior:

1. We will always act in our customers’ best interest.

2. We will do our best to understand our customers’ requirements.

3. We will not ship crap.

4. We will be great to work with.

5. We will do something extra for our customers, as an apology, when something big goes wrong
and it's our fault.

6. We will keep our promises.

7. We will treat the competition with respect.

8. We will cooperate with and help other friendly companies.

9. We will go above and beyond in times of crisis. If there's no one to authorize the required
action in times of company or customer crisis - do what you know in your heart is right. (You
may rent helicopters if necessary.)

mailto:solutions@rossvideo.com
mailto:dross@rossvideo.com
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End User Software License Agreement

This End User Software License Agreement is a legal agreement between you (the “Licensee”) and Ross
Video Limited (“Ross Video”) specifying the terms and conditions of your installation and use of the
Software and all Documentation (as those terms are defined herein).

IMPORTANT:

BY DOWNLOADING, ACCESSING, INSTALLING OR USING THE SOFTWARE AND/OR
DOCUMENTATION AND/OR BY AUTHORIZING ANY THIRD PARTY, INCLUDING WITHOUT
LIMITATION AN INSTALLER OR COMMISSIONER ACTING ON YOUR BEHALF TO DO SO, LICENSEE
AGREES TO THE TERMS OF THIS AGREEMENT AND THE LICENSE GRANTED HEREUNDER SHALL BE
EFFECTIVE AS OF AND FROM SUCH DATE. IF YOU DO NOT WISH TO ACCEPT THE TERMS AND
CONDITIONS OF THIS AGREEMENT, DO NOT DOWNLOAD, ACCESS, INSTALL, REFER TO OR
OTHERWISE USE THE SOFTWARE AND/OR DOCUMENTATION.

1. INTERPRETATION. In this Agreement, (a) words signifying the singular number include the plural and
vice versa, and words signifying gender include all genders; (b) every use of the words "herein",
"hereof", “hereto” "hereunder" and similar words shall be construed to refer to this Agreement in its
entirety and not to any particular provision hereof; (c) reference to any agreement or other document
herein will be construed as referring to such agreement or other document as from time to time
amended, modified or supplemented (subject to any restrictions on such amendment, modification or
supplement set forth therein); (d) every use of the words “including” or “includes” is to be construed as
meaning “including, without limitation” or “includes, without limitation”, respectively; and (e)
references to an Article or a Section are to be construed as references to an Article or Section of or to
this Agreement unless otherwise specified.

2. DEFINITIONS. In this Agreement, in addition to the terms defined elsewhere in this Agreement, the
following terms have the meanings set out below:

“Affiliate” means, with respect to any Person, any other Person who directly or indirectly controls, is
controlled by, or is under direct or indirect common control with, such Person. A Person shall be
deemed to control a Person if such Person possesses, directly or indirectly, the power to direct or cause
the direction of the management and policies of such Person, whether through the ownership of voting
securities, by contract or otherwise; and the term “controlled” and “controlling” shall have a similar
meaning.

“Agreement” means this End User Software License Agreement including the recitals hereto, as the
same may be amended from time to time in accordance with the provisions hereof.

“Backup System” means the secondary piece of Designated Equipment upon which the Software is
installed and mirrored for the sole purpose of replacing a Primary System in the event such Primary
System is not available or functioning properly for any reason.

“Change of Control” means (a) the direct or indirect sale, transfer or exchange by the shareholders of
a Party of more than fifty percent (50%) of the voting securities of such Party, (b) a merger or
amalgamation or reorganization or other transaction to which a Party is party after which the
shareholders of such Party immediately prior to such transaction hold less than fifty percent (50%) of
the voting securities of the surviving entity, (c) the sale, exchange, or transfer of all or substantially all
of the assets of a Party.



“Confidential Information” means all data and information relating to the business and management
of either Party, including the Software, trade secrets and other technology to which access is obtained
or granted hereunder by the other Party, and any materials provided by Ross Video to Licensee;
provided, however, that Confidential Information shall not include any data or information which:

(i) is or becomes publicly available through no fault of the other Party;

(ii) is already in the rightful possession of the other Party prior to its receipt from the other Party;

(iii) is already known to the receiving Party at the time of its disclosure to the receiving Party by the
disclosing Party and is not the subject of an obligation of confidence of any kind;

(iv) is independently developed by the other Party;

(v) is rightfully obtained by the other Party from a third party; or

(vi) is disclosed with the written consent of the Party whose information it is.

“Designated Equipment” shall mean (a) the hardware products sold by Ross Video to Licensee on
which the Software is installed and licensed for use, as the same may be replaced from time to time by
Ross Video; or (b) in the case of Software licensed on a stand-alone basis, the equipment of Licensee
on which the Software is to be installed and meets the minimum specifications set out in the
Documentation.

“Documentation” shall mean manuals, instruction guides, user documentation and other related
materials of any kind pertaining to the Software (whether in electronic, hard-copy or other media
format) that are furnished to Licensee by or on behalf of Ross Video in relation to the Software.

“Freeware” means Software that is available free of charge from Ross Video, and includes, without
limitation the master control system software known as "DashBoard".

"Governmental Authority" means (a) any federal, provincial, state, local, municipal, regional,
territorial, aboriginal, or other government, governmental or public department, branch, ministry, or
court, domestic or foreign, including any district, agency, commission, board, arbitration panel or
authority and any subdivision of any of them exercising or entitled to exercise any administrative,
executive, judicial, ministerial, prerogative, legislative, regulatory, or taxing authority or power of any
nature; and (b) any quasi-governmental or private body exercising any regulatory, expropriation or
taxing authority under or for the account of any of them, and any subdivision of any of them.

“Improvements” means all inventions, works, discoveries, improvements and innovations of or in
connection with the Software, including error corrections, bug fixes, patches and other updates in
Object Code form to the extent made available to Licensee in accordance with Ross Video’s release
schedule.

"License Fee" means the fee(s), if any, payable in respect of the Software in accordance with the
relevant invoice(s) or other purchase documents delivered in connection with this Agreement.

“License Period” means the period of time that Licensee will have the rights granted under this
Agreement, as may be specified in an Order.

“Modifications” means any enhancements, changes, corrections, translations, adaptations, revisions,
developments, upgrades or updates thereto; and “Modify” shall mean the creation of any of the
foregoing.

“Object Code” means the machine readable executable form of a computer software program.



"Open Source Components" means third party Open Source software, libraries or other components.

"Open Source License" means the license that governs each Open Source Component.

"Order" means the documents provided by Ross Video to Licensee detailing the Ross Video products
contemplated for purchase, the corresponding fees and License Period that may apply to the Software,
including any and all quotations, purchase orders, acknowledgments, pro formas, invoices and other
purchase documentation.

“Parties” means both Ross Video and Licensee and “Party” means either one of them as the context
requires.

“Person” will be broadly interpreted and includes (a) a natural person, whether acting in his or her own
capacity, or in his or her capacity as executor, administrator, estate trustee, trustee or personal or legal
representative; (b) a corporation or a company of any kind, a partnership of any kind, a sole
proprietorship, a trust, a joint venture, an association, an unincorporated association, an
unincorporated syndicate, an unincorporated organization or any other association, organization or
entity of any kind; and (c) a Governmental Authority.

“Primary System” means the Designated Equipment upon which the Software is installed and
executed to deliver its intended functionality.

“Released Claims” has the meaning ascribed to it in Section 9(b). 

“Released Parties” has the meaning ascribed to it in Section 9(b). 

“Ross Video” means Ross Video Limited and its Affiliates. 

“Software” means the version of the Object Code licensed and delivered to Licensee by Ross Video
concurrently with delivery of this Agreement, including without limitation the Freeware, and any
subsequent error corrections, updates, Modifications or Improvements provided to Licensee by Ross
Video pursuant to this Agreement, but specifically excluding any features or plug-ins that may be
purchased by you directly from third parties as upgrades or enhancements to the Software.

“Source Code” means the human readable form of a computer software program, and all tools and
documentation necessary for a reasonably competent computer programmer to understand, maintain
and Modify the Software.

“Third Party Software” means those portions of the Software, if any, which are owned or controlled
by third parties and licensed to Ross Video pursuant to certain license agreements or arrangements
with such third parties, including the Open Source Components and NDI®1 software (http://NDI.video);
and

“Use” means to execute, run, display, store, merge, network, Modify, translate, host or integrate with
Licensee’s products or other third party software.

1 NDI® is a registered trademark of Vizrt NDI AB.

http://NDI.video


3. LICENSE. Subject to the terms and conditions of this Agreement, upon payment of the applicable
License Fee by Licensee, or, in the case of Freeware only, upon download of the Software by Licensee
onto its Designated Equipment, Ross Video hereby grants to Licensee a non-transferable and non-
exclusive right to Use the Software and Documentation solely for the internal use of Licensee (the
“License”), during the License Period. In the event that a License Period is not identified on the Order,
such License Period shall be deemed to be perpetual, subject to paragraph 10 (c) of this Agreement.
The Software shall only be used in connection with or installed on the Designated Equipment and,
where applicable, shall only be used on the Primary System, provided such Primary System is operating
properly."

If the Primary System is not operating properly for any reason, the Software may be used on the
designated Backup System for that Primary System until such time that the Primary System begins
operating properly. The Software and Documentation are provided to Licensee for the exclusive use by
Licensee’s organization for its ordinary business purposes and shall not be used by any third party for
any purposes. Licensee may make copies of the Software as required for internal backup and archival
purposes. To the extent permitted hereunder, Licensee may distribute copies of the Software and/or
Documentation to members of its organization, provided (a) this Agreement is included with each copy,
(b) any member of its organization who uses the Software and/or Documentation accepts and agrees to
be bound by the terms of this Agreement and by any other license agreements or other agreement
incorporated by reference into this Agreement, and (c) Licensee has paid any applicable additional
License Fees in respect of copying and redistributing of the Software. To the extent Licensee is
permitted to make copies of the Software under this Agreement, Licensee agrees to reproduce and
include on any copy made or portion merged into another work, all Ross Video proprietary notices,
including any notices with respect to copyrights, trademarks and this License. With the exception of
copying the Software for backup or archival purposes, Licensee agrees to keep a record of the number
and location of all such copies and will make such record available at Ross Video’s request. The
Software may include mechanisms to limit or inhibit copying.

4. LICENSE RESTRICTIONS. Except as otherwise provided in section 3 above, Licensee shall not: (1)
copy any Software or Documentation, or part thereof, which is provided to Licensee by Ross Video
pursuant to this Agreement, in Object Code form, Source Code form or other human or machine
readable form, including written or printed documents, without the prior written consent of Ross Video;
(2) in any way market, distribute, export, translate, transmit, merge, Modify, transfer, adapt, loan,
rent, lease, assign, share, sub-license, sell, make available for download on any website or make
available to another Person, the Software and/or Documentation, in whole or in part, provided that
Licensee shall not be prohibited from renting or leasing the Software if Ross Video has consented, in
writing, to Licensee engaging in such activities in respect of the Software; (3) reverse engineer,
decompile or disassemble the Software or electronically transfer it into another computer language; or
(4) use the Software or Documentation in a manner that is inconsistent with the License granted
hereunder or that will result in a breach of this Agreement. Licensee agrees to take all reasonable
precautions to prevent third parties from using the Software and/or Documentation in any way that
would constitute a breach of this Agreement, including such precautions Licensee would ordinarily take
to protect its own proprietary software, hardware or information.

5. DELIVERY. Ross Video shall deliver to Licensee one (1) master copy of the Software in compiled
binary (executable) form suitable for reproduction in electronic files only and Ross Video shall deliver to
Licensee a minimum of one copy of the Documentation.

6. IMPROVEMENTS. Licensee may from time to time request Ross Video to incorporate certain
Improvements into the Software. Ross Video may, in its sole discretion, undertake to incorporate and
provide such Improvements to Licensee with or without payment of a fee to be negotiated at the time
of such request. All Improvements, whether recommended and developed by Ross Video or Licensee,
shall be considered the sole property of Ross Video and shall be used by Licensee pursuant to the terms
of the License granted under this Agreement.



7. FREEWARE. Other than the obligation to pay a License Fee, which does not apply to the Freeware, all
other provisions of this End User Software License Agreement apply to the Freeware in the same way
as they apply to all other Software that is the subject of this Agreement. In addition, in connection with
the Freeware, the following provisions apply: 

a. Licensee will not Use the Freeware to engage in or allow others to engage in any illegal activity.

b. Licensee will not Use the Freeware in any way that will interfere with or damage the operation of the
services of any third parties by overburdening/disabling network resources through automated
queries, excessive usage or similar conduct.

c. Licensee will not Use the Freeware to engage in any activity that will violate the rights of others,
including, without limitation, by using it for operations that involve child labour, suppressing the
right of freedom of expression or endangering the security of person.

8. OWNERSHIP. The Parties acknowledge and agree that, as between the Parties, Ross Video shall be
the owner of all intellectual property rights in the Software, Documentation and all related Modifications
and Improvements, written materials, logos, trademarks, trade names, copyright, patents, trade
secrets and moral rights, registered or unregistered. No proprietary interest or title in or to the
intellectual property in the Software, Documentation or any Improvements or Modifications is
transferred to Licensee by this Agreement. Ross Video reserves all rights not expressly licensed to
Licensee under section 3.

9. OPEN SOURCE SOFTWARE. 

a. Software may use and/or be provided with Open Source Components, including those detailed in the
Third Party section below. To the extent stipulated by its Open Source License, each such Open
Source Component is licensed directly to Licensee from its respective licensors and not sub-licensed
to Licensee by Ross Video, and such Open Source Component is subject to its respective Open
Source License, and not to this Agreement. If, and to the extent, an Open Source Component
requires that this Agreement effectively impose, or incorporate by reference, certain disclaimers,
permissions, provisions, prohibitions or restrictions, then such disclaimers, permissions, provisions,
prohibitions or restrictions shall be deemed to be imposed, or incorporated by reference into this
Agreement, as required, and shall supersede any conflicting provision of this Agreement, solely with
respect to the corresponding Open Source Component which is governed by such Open Source
License. 

b. If Licensee, or another party on Licensee’s behalf, modifies, replaces or substitutes any Open Source
Component used in or provided with this Software, Licensee hereby fully, forever, irrevocably and
unconditionally releases and discharges Ross Video, its Affiliates and its and their employees,
officers, directors, resellers, distributors and representatives (collectively, “Released Parties”) from
any and all claims, charges, complaints, demands, actions, causes of action, suits, rights, debts,
covenants, liabilities, warranties, performance and maintenance and support obligations
(collectively, “Released Claims”), of every kind and nature, with respect to such Software, including
without limitation any such Released Claims that arise as a matter of applicable Law. 

c. If an Open Source License requires that the source code of its corresponding Open Source
Component be made available to Licensee, and such source code was not delivered to Licensee with
the Software, then Ross Video hereby extends a written offer, valid for the period prescribed in such
Open Source License, to obtain a copy of the source code of the corresponding Open Source
Component, from Ross Video from https://www.rossvideo.com/open-source-information/.

https://www.rossvideo.com/open-source-information/


10. THIRD PARTY SOFTWARE. 

a. Licensee acknowledges that the Third Party Software is not owned by Ross Video. Notwithstanding
any other provision of this Agreement, Ross Video, to the extent permitted by applicable law, offers
no warranties (whether express, implied, statutory or by course of communication or dealing with
Licensee, or otherwise) with respect to the Third Party Software. Ross Video may pass through to
Licensee, if and to the extent permitted by applicable law, any warranties expressly provided by
such third parties to Ross Video for such Third Party Software.

b. FFmpeg Notice. The Software may utilize FFmpeg video components and their included libraries.
FFmpeg is a trademark of Fabrice Bellard (originator of the FFmpeg project). Ross Video disclaims
any ownership claim to FFmpeg. Please refer to http://ffmpeg.org (copyright is in the FFmpeg
developers). FFmpeg is licensed under the GNU Lesser General Public License v2.1 or Lesser General
Public License v3.0. GNU Lesser General Public License contact information: Free Software
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. Licensee can
distribute it and/or modify it under the terms of such licenses.

11. INTELLECTUAL PROPERTY INDEMNITY. 

a. Ross Video agrees to defend, indemnify and hold harmless Licensee from final damages awarded by
a court of competent jurisdiction (hereinafter referred to as the “Losses”), which Licensee, or any of
its officers or directors, may incur, suffer or become liable for as a result of, or in connection with,
any third party claim asserted against Licensee to the extent such claim is based on a contention
that the Software, Documentation or any portion thereof, infringes any valid, registered, enforceable
patents, copyrights, trade secrets, trademarks or other intellectual property rights of any third
party, provided that (a) the allegedly infringing Software or Documentation has been used within the
scope of and in accordance with the terms of this Agreement, and (b) Licensee notifies Ross Video in
writing of such claim within ten (10) days of a responsible officer of Licensee becoming aware of
such claim. If the Software, Documentation or any portion thereof is held to constitute an
infringement of a third party’s intellectual property rights, and use thereof is enjoined, Ross Video
shall, at its election and expense, either (i) procure the right to use the infringing element of the
Software or Documentation; or (ii) replace or modify the element of the Software or Documentation
so that the infringing portion is no longer infringing and still performs the same function without any
material loss of functionality. Ross Video shall make every reasonable effort to correct the situation
with minimal effect upon the operations of Licensee.

b. Notwithstanding the above, Ross Video reserves the right to terminate this Agreement and the
License granted hereunder on immediate notice to Licensee, and without liability to Licensee, in the
event that the Software or Documentation constitutes or may, in Ross Video’s determination,
constitute, an infringement of the rights of a third party that Ross Video, in its sole discretion, does
not consider to be affordably remediable.

c. Either party may terminate this Agreement immediately should any Software become, or in either
party's opinion be likely to become, the subject of a claim of infringement of any intellectual
property right and, in such event, there shall be no claim by either Licensee or Ross Video against
the other arising out of such termination, provided that the foregoing shall not apply to a claim for
infringement by Ross Video against Licensee in the event that Licensee is alleged to have infringed
Ross Video's intellectual property rights, in which case Licensee shall remain liable for all
outstanding License Fees and other amounts owing to Ross Video.

d. Notwithstanding the foregoing, Ross Video shall have no liability for any claim of infringement based
on use of other than a current, unaltered release of the Software and/or Documentation available
from Ross Video if such infringement would have been avoided by the use of a current, unaltered
release of the Software and/or Documentation provided that such current, unaltered release
performs substantially in conformity with the specifications set out in the Documentation and was
provided, at no additional cost by Ross Video, to those subscribing for maintenance services for the
Software or Documentation.



12. CONFIDENTIALITY. Each Party shall maintain in confidence all Confidential Information of the other
Party, shall use such Confidential Information only for the purpose of exercising its rights and fulfilling
its obligations under this Agreement, and shall not disclose any Confidential Information of the
disclosing Party to any third party except as expressly permitted hereunder or make any unauthorized
use thereof. Each Party shall disclose the Confidential Information only to those of its employees,
consultants, advisors, and/or subcontractors who have a need to know the Confidential Information.
Each Party shall, prior to disclosing the Confidential Information to such employees, consultants,
advisors and/or subcontractors, obtain their agreement to receive and use the Confidential Information
on a confidential basis on the same terms and conditions contained in this Agreement. The receiving
Party shall treat the Confidential Information of the disclosing Party with the same degree of care
against disclosure and/or unauthorized use as it affords to its own information of a similar nature, or a
reasonable degree of care, whichever is greater. The receiving Party further agrees not to remove or
destroy any proprietary or confidential legends or markings placed upon any documents or other
materials of the disclosing Party. The obligations of confidence set forth in this Agreement shall extend
to any Affiliates that have received Confidential Information of the disclosing Party and shall also cover
Confidential Information disclosed by any Affiliate. The receiving Party shall be responsible for any
actions or omissions of its Affiliates as if such actions or omissions were its own.

Either party may disclose certain Confidential Information if it is expressly required to do so pursuant to
legal, judicial, or administrative proceedings, or otherwise required by law, provided that (i) such Party
provides the other Party with reasonable written notice prior to such disclosure; (ii) such Party seeks
confidential treatment for such Confidential Information; (iii) the extent of such disclosure is only to the
extent expressly required by law or under the applicable court order; and (iv) such Party complies with
any applicable protective or equivalent order.

Each of Ross Video and Licensee (the “Indemnifying Party”, as applicable) agree to indemnify the
other (the “Indemnified Party”, as applicable) for all Losses incurred by the Indemnified Party as a
result of a failure of the Indemnifying Party to comply with its obligations under this Section 12
provided that the Indemnified Party has given prompt notice of any such claim and, to the extent that a
claim may lie against a third party for the unauthorized disclosure of such Confidential Information, the
right to control and direct the investigation, preparation, action and settlement of each such claim and,
further, provided that the Indemnified Party reasonably co-operates with the Indemnifying Party in
connection with the foregoing and provides the Indemnifying Party with all information in the
Indemnified Party’s possession related to such claim and such further assistance as reasonably
requested by the Indemnifying Party.

The Parties acknowledge and agree that any breach of the confidentiality provisions of this Agreement
by one Party may cause significant and irreparable injury to the other Party that is not compensable
monetarily, as well as damages that may be difficult to ascertain, and agrees that, in addition to such
other remedies that may be available at law or in equity, the other Party shall be entitled to seek
injunctive relief (including temporary restraining orders, interim injunctions and permanent injunctions)
in a court of competent jurisdiction in the event of the breach or threatened breach by such party of
any of the confidentiality provisions of this Agreement. The relief contemplated in this Section shall be
available to each Party without the necessity of having to prove actual damages and without the
necessity of having to post any bond or other security. Each Party further agrees to notify the other
Party in the event that it learns of or has reason to believe that any Person has breached the
confidentiality provisions of this Agreement.



13. LIMITATION OF LIABILITY. The limitation of liability provisions of this Agreement reflect an
informed voluntary allocation of the risks (known and unknown) that may exist in connection with the
licensing of the Software or Documentation hereunder by Ross Video, and that voluntary risk allocation
represents a material part of the Agreement reached between Ross Video and Licensee. Should Ross
Video be in breach of any obligation, Licensee agrees that Licensee’s remedies will be limited to those
set forth in this Agreement. No action, regardless of form, arising out of this Agreement may be
brought by Licensee more than twelve (12) months after the facts giving rise to the cause of action
have occurred, regardless of whether those facts by that time are known to, or reasonably ought to
have been discovered by, Licensee.

(A) EXCEPT AS EXPRESSLY PROVIDED IN THIS AGREEMENT, THE SOFTWARE AND DOCUMENTATION
ARE PROVIDED “AS IS” AND ROSS VIDEO (I) MAKES NO OTHER REPRESENTATIONS, AND PROVIDES
NO WARRANTIES OR CONDITIONS OF ANY KIND, EXPRESS OR IMPLIED, STATUTORY, BY USAGE OF
TRADE CUSTOM OF DEALING, OR OTHERWISE, AND (II) SPECIFICALLY DISCLAIMS ALL IMPLIED
WARRANTIES INCLUDING ANY IMPLIED WARRANTY OF UNINTERRUPTED OR ERROR FREE OPERATION,
MERCHANTABILITY, QUALITY OR FITNESS FOR A PARTICULAR PURPOSE. ROSS VIDEO DOES NOT
REPRESENT OR WARRANT THAT THE SOFTWARE WILL MEET ANY OR ALL OF LICENSEE’S PARTICULAR
REQUIREMENTS, THAT THE USE AND OPERATION OF THE SOFTWARE WILL OPERATE ERROR-FREE OR
UNINTERRUPTED, THAT ALL PROGRAMMING ERRORS IN THE SOFTWARE CAN BE FOUND IN ORDER TO
BE CORRECTED, OR THAT THE SOFTWARE WILL BE COMPATIBLE WITH OTHER PROGRAMS, SYSTEMS,
AND HARDWARE.

(B) IN NO EVENT SHALL ROSS VIDEO, ITS AFFILIATES AND LICENSORS, AND THEIR RESPECTIVE
DIRECTORS, OFFICERS, EMPLOYEES AND AGENTS, BE LIABLE FOR ANY CLAIM FOR INDIRECT,
CONSEQUENTIAL, SPECIAL, INCIDENTAL, PUNITIVE, EXEMPLARY, AGGRAVATED DAMAGES; LOST
PROFITS, OR LOST REVENUE ARISING FROM OR IN CONNECTION WITH THIS AGREEMENT,
REGARDLESS OF THE FORM OF ACTION, WHETHER IN CONTRACT, OR IN TORT, EVEN IF THE PARTY
HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

(C) IN ANY EVENT THE AGGREGATE LIABILITY OF ROSS VIDEO, ITS AFFILIATES AND LICENSORS, AND
THEIR RESPECTIVE DIRECTORS, OFFICERS, EMPLOYEES AND AGENTS, FOR ANY CLAIM FOR DIRECT
DAMAGES WITH RESPECT TO THE SUBJECT MATTER OF THIS AGREEMENT SHALL NOT EXCEED THE
AMOUNT OF THE PURCHASE PRICE PAID TO ROSS VIDEO UNDER THIS AGREEMENT.

14. TERM AND TERMINATION.

(1) Unless terminated earlier in accordance with the terms of this Agreement, the term of this
Agreement shall commence upon Licensee’s first download, access, installation, or other use of the
Software or Documentation and continues until, in the case of Software licensed with Designated
Equipment provided by Ross Video, the earliest of (a) the end of the License Period, or (b) if the
Designated Equipment is assigned or transferred in accordance with this Agreement, the date on
which the Designated Equipment is no longer owned by Licensee;

(2) Either Party shall have the right to terminate this Agreement on notice to the other Party if: 

(a) the other Party fails to pay any fees or other amounts when due hereunder or under any
other agreement between the Parties (or any Affiliates of the Parties, as applicable) in
connection with the Software and/or Designated Equipment and such breach is not cured
within thirty (30) days after written notice of such failure to pay is given to the defaulting
Party by the non-defaulting Party; 

(b) the other Party shall file a voluntary petition in bankruptcy or insolvency or shall petition for
reorganization under any bankruptcy law, consent to an involuntary petition in bankruptcy, or
if a receiving order is given against it under the Bankruptcy and Insolvency Act (Canada) or
the comparable law of any other jurisdiction (and such is not dismissed within ten (10) days);



(c) there shall be entered an order, judgment or decree by a court of competent jurisdiction,
upon the application of a creditor, approving a petition seeking reorganization or appointing a
receiver, trustee or liquidator of all or a substantial part of the other Party’s assets and such
order, judgment or decree continues in effect for a period of thirty (30) consecutive days; or

(d) the other Party shall fail to perform any of the other material obligations set forth in this
Agreement and such default, in the case of a default which is remediable, continues for a
period of thirty (30) days after written notice of such failure has been given by the non-
defaulting Party or, in the case of a non-remediable default, immediately upon notice.

(3) Notwithstanding anything to the contrary contained in this Agreement:

(a) Ross Video may forthwith terminate this Agreement if Licensee is in breach of any of sections
3, 4 or 12 of this Agreement. For greater certainty, in such instances Ross Video shall provide
written notice of such termination as soon as practicable but written notice shall not be a
necessary prerequisite to such termination; and

(b)  in the event of a Change of Control of Licensee, Ross Video shall have the right to terminate
this Agreement and the License granted hereunder upon thirty (30) days’ prior written notice
to Licensee. For greater certainty, Ross Video’s right to terminate in the event of a Change of
Control of Licensee shall continue for a period of six (6) months from the date Licensee
delivers notice of such Change of Control to Ross Video.

(c) Ross Video may terminate the License immediately on the date on which it provides notice to
Licensee, if its agreements for Third Party Software are terminated.

(4) Upon the termination or expiry of this Agreement:

(a) Licensee shall immediately cease and desist all use of the Software and Documentation;

(b) Licensee shall immediately deliver to Ross Video any of Ross Video’s Confidential Information
provided hereunder (including the Software and Documentation) then in its possession or
control, if any, and shall deliver a certificate of an officer of Licensee certifying the
completeness of same;

(c) Licensee shall refrain from further use of such Confidential Information; and

(d) Licensee shall forthwith pay all amounts owing to Ross Video or any of its Affiliates
hereunder.

15. SURVIVAL. The provisions of sections 1, 2, 6, 8, 9, 10, 11, 12, 13, 14, 18, 22, 23, and 24 herein shall
survive the expiry or termination of this Agreement.

16. FORCE MAJEURE. Dates and times by which Ross Video is required to render performance under this
Agreement shall be automatically postponed to the extent and for the period that Ross Video is
prevented from meeting them by reason of events of force majeure or any cause beyond its reasonable
control provided Ross Video notifies Licensee of the commencement and nature of such cause and uses
its reasonable efforts to render performance in a timely manner.

17. ASSIGNMENT. Ross Video may assign this Agreement, or any of its rights or obligations hereunder, in
whole or in part, upon notice to Licensee. Licensee shall not assign this Agreement, or any of its rights
or obligations hereunder, in whole or in part, without the prior written consent of Ross Video, which
consent may not be unreasonably withheld. This Agreement enures to the benefit of and is binding
upon each of the Parties and their respective successors and permitted assigns.



18. GOVERNING LAW. If Licensee acquired the Ross Product(s) in the United States or Canada, the laws
of the state or province where Licensee’s principal place of business is located govern the interpretation
of this Agreement, claims for its breach, and all other claims regardless of conflict of laws principles. If
Licensee acquired the Ross Product(s) in the European Union or the United Kingdom, then the laws of
England and Wales apply. If Licensee acquired the Ross Product(s) in any other country, then the laws
of the Province of Ontario, Canada shall apply.

19. LANGUAGE. The Parties have expressly required that this Agreement and all documents relating
thereto be prepared in English. Les parties ont expressément exigé que cette convention ainsi que tous
les documents qui s’y rattachent soient rédigés en anglais.

20. GOVERNMENT CONTRACTS. If the Software and/or Documentation to be furnished to Licensee
hereunder are to be used in the performance of a government contract or subcontract, the Software
and/or Documentation shall be provided on a "restricted rights" basis only and Licensee shall place a
legend, in addition to applicable copyright notices, in the form provided under the applicable
governmental regulations. For greater certainty, Ross Video shall not be subject to any flow-down
provisions required by any customer of Licensee that is a Governmental Authority unless Ross Video
expressly agrees to be bound by such flow-down provisions in writing.

21. EXPORT AND IMPORT LAWS. Licensee acknowledges and agrees that the Software (including any
technical data and related technology) may be subject to the export control laws, rules, regulations,
restrictions and national security controls of the United States and other applicable countries (the
“Export Controls”) and agrees not to export, re-export, import or allow the export, re-export or import
of such export-controlled Software (including any technical data and related technology) or any copy,
portion or direct product of the foregoing in violation of the Export Controls. Licensee hereby represents
that it is not an entity or person to whom provision of the Software (including any technical data and
related technology) is restricted or prohibited by the Export Controls. Licensee agrees that it has the
sole responsibility to obtain any authorization to export, re-export, or import the Software (including
any technical data and related technology), as may be required. Licensee will defend, indemnify and
hold Ross Video harmless from any and all claims, losses, liabilities, damages, fines, penalties, costs
and expenses (including attorney’s fees) arising from or relating to any breach by Licensee of its
obligations under this Section.

22. AMENDMENT AND WAIVER. No amendment, discharge, modification, restatement, supplement,
termination or waiver of this Agreement or any Section of this Agreement is binding unless it is in
writing and executed by the Party to be bound. No waiver of, failure to exercise or delay in exercising,
any Section of this Agreement constitutes a waiver of any other Section (whether or not similar) nor
does any waiver constitute a continuing waiver unless otherwise expressly provided.

23. SEVERABILITY. Each Section of this Agreement is distinct and severable. If any Section of this
Agreement, in whole or in part, is or becomes illegal, invalid, void, voidable or unenforceable in any
jurisdiction by any court of competent jurisdiction, the illegality, invalidity or unenforceability of that
Section, in whole or in part, will not affect (a) the legality, validity or enforceability of the remaining
Sections of this Agreement, in whole or in part; or (b) the legality, validity or enforceability of that
Section, in whole or in part, in any other jurisdiction.

24. ENTIRE AGREEMENT. This Agreement, and any other documents referred to herein, constitutes the
entire agreement between the Parties relating to the subject matter of this Agreement and supersedes
all prior written or oral agreements, representations and other communications between the Parties.

Updated: November 1, 2023



Warranty and Repair Policy

Ross Video Limited (Ross) warrants its Tessera systems to be free from defects under normal use and
service for the following time periods from the date of shipment:

· Tessera Server — 12 months

· Tessera Software Upgrades — 12 months free of charge

· System and Media hard drives — 12 months

If an item becomes defective within the warranty period Ross will repair or replace the defective item, as
determined solely by Ross.

Warranty repairs will be conducted at Ross, with all shipping FOB Ross dock. If repairs are conducted at the
customer site, reasonable out-of-pocket charges will apply. At the discretion of Ross, and on a temporary
loan basis, plug in circuit boards or other replacement parts may be supplied free of charge while defective
items undergo repair. Return packing, shipping, and special handling costs are the responsibility of the
customer.

This warranty is void if products are subjected to misuse, neglect, accident, improper installation or
application, or unauthorized modification.

In no event shall Ross Video Limited be liable for direct, indirect, special, incidental, or consequential
damages (including loss of profit). Implied warranties, including that of merchantability and fitness for a
particular purpose, are expressly limited to the duration of this warranty.

This warranty is TRANSFERABLE to subsequent owners, subject to Ross’ notification of change of ownership.

Extended Warranty

For customers that require a longer warranty period, Ross offers an extended warranty plan to extend the
standard warranty period by one year increments. For more information about an extended warranty for
your Tessera system, contact your regional sales manager.



Environmental Information

The equipment that you purchased required the extraction and use of natural resources for its production. It
may contain hazardous substances that could impact health and the environment.

To avoid the potential release of those substances into the environment and to diminish the need for the
extraction of natural resources, Ross Video encourages you to use the appropriate take-back systems. These
systems will reuse or recycle most of the materials from your end-of-life equipment in an environmentally
friendly and health conscious manner.

The crossed-out wheeled bin symbol invites you to use these systems.

If you need more information on the collection, reuse, and recycling systems, please contact your local or
regional waste administration.

You can also contact Ross Video for more information on the environmental performances of our products.



Company Address

Ross Video Limited 

8 John Street
Iroquois, Ontario
Canada, K0E 1K0

Ross Video Incorporated 

P.O. Box 880
Ogdensburg, New York
USA 13669-0880

General Business Office:

Toll Free:

Fax:

(+1) 613-228-0688

(+1) 844-652-0645

(+1) 613-652-4425

Toll Free Technical Support: 1-833-859-0499 (North America)

+800 3540 3545 (International)

Alternately, you can contact:

Technical Support: (+1) 613-686-1557

Australia/Sydney Local
Support:

1300 007 677*

E-mail for Technical Support: techsupport@rossvideo.com

E-mail for General Information: solutions@rossvideo.com

Website: http://www.rossvideo.com

*If the local support specialist is not available, your call will be transferred automatically to our North
America center.

mailto:techsupport@rossvideo.com?Subject=Information Request&Body=Hi,%0D%0D
mailto:solutions@rossvideo.com?Subject=Information Request&Body=Hi,%0D%0D
http://www.rossvideo.com
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Introduction
Thank you for choosing a Ross Video Tessera system.

Ross Video designed Tessera with the needs of live production in mind. Tessera is part of Ross Video’s broad
line of real-time graphics products and workflow tools. It is a multi-display real-time graphics
designer/controller for sports venues & studio video walls.

Tessera enables users to link together multiple XPression engines to create a scalable matrix of channels for
seamless output of scenes across large or irregularly assembled display panels. Perfect for sports
scoreboards, ribbon boards, and studio video walls, Tessera’s resolution can scale just by adding more
XPression engines or “Tessera nodes” and adding to the mapping.

Frame-accurate, non-tearing recall of graphics and clips across any or all nodes is made possible with
XPression’s Multi-Engine Sync technology. More importantly, XPression’s unlimited scene layering on output
is preserved across Tessera nodes for incredibly dynamic animations and transitions.

The Tessera Region Manager allows operators to divide scenes into regions and assign those regions to
specific nodes. The Tessera Node Manager allocates the XPression engines and channels to be used as
render nodes. And, the XPression Project Server handles the automatic one-click publishing of scene
updates and resources to all nodes for ultimate efficiency.

Whether you need to drive large displays in sports venues or build a studio video wall, XPression Tessera is
the most powerful and cost-effective solution available.

We appreciate your business and sincerely hope that you have a great experience with your new Tessera
system. As always, if there is anything we at Ross Video can do to assist you, please do not hesitate to
contact us. 
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About This Guide

This guide covers the use of the Tessera system. 

If, at any time, you have questions pertaining to the operation of Tessera, please contact us at the numbers
listed in the section Getting Help. Our technical staff is always available for consultation, training, or service.

Documentation Conventions

Special text formats are used in this guide to identify parts of the user interface, text that a user must
enter, or a sequence of menus and sub-menus that must be followed to reach a particular command.

Bold text Bold text identifies a user interface element such as a dialog box, menu item, or
button.

For example:

In the Slug column, type a slug name for the story.

Italic text Italic text is used to identify the titles of referenced guides, manuals, or
documents.

For example:

For more information, refer to the DashBoard User Guide.

Courier text Courier text identifies text that a user must type.

For example:

In the Username box, type postgres.

Menu Sequences Menu arrows are used in procedures to identify a sequence of menu items that you
must follow.

For example:

If a step reads Server > Save As, you would select the Server menu and then
select Save As.

Hypertext Identifies a hyperlink to a related topic.
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Getting Help

Tessera documentation is available online at Product Documentation and is also accessible on the product
USB key and by selecting the Help icon in the user interface.

Contacting Technical Support

At Ross Video, we take pride in the quality of our products, but if problems occur, help is as close as the
nearest telephone.

Our 24-hour Hot Line service ensures you have access to technical expertise around the clock. After-sales
service and technical support is provided directly by Ross Video personnel. During business hours (Eastern
Time), technical support personnel are available by telephone. After hours and on weekends, a direct
emergency technical support phone line is available. If the technical support person who is on call does not
answer this line immediately, a voice message can be left and the call will be returned shortly. This team of
highly trained staff is available to react to any problem and to do whatever is necessary to ensure customer
satisfaction.

Technical Support:

· 1-613-686-1557

· 1-833-859-0499 (Toll free within North America)

· +800 3540 3545 (Toll free International)

· 1300 007 677 (Australia/Sydney)*

· E-mail: techsupport@rossvideo.com

· Website: http://www.rossvideo.com

*If the local support specialist is not available, your call will be transferred automatically to our North
America center.

https://www.rossvideo.com/support/product-documentation
mailto:techsupport@rossvideo.com
http://www.rossvideo.com
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Tessera User Interface Overview
This section provides a user interface overview for the XPression Tessera Region Mapper. It includes the
following:

XPression Tessera Region Mapper - Source Region Layout Settings

XPression Tessera Region Mapper - Destination Region Layout Settings
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XPression Tessera Region Mapper - Source Region Layout
Settings

The following screen capture displays the main elements of the XPression Tessera Region Mapper window in
XPression with the Source Region Layout section of the selected source region.

1. Menu Bar — use the File menu to load a
configured region map from a saved file or save a
configuration.

2. Source Region Layouts — use this section to
add and delete source outputs of specific
resolution and regions across multiple channels of
XPression on multiple render engines.

3. Source Region Layout Settings — use this
section to configure the settings for a selected
source, including defining the region and mapping
sources to destinations.

4. Destination Region Layouts — use this section
to add and delete destination framebuffer outputs
with rendered regions that are mapped to source
outputs.
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XPression Tessera Region Mapper - Destination Region
Layout Settings

The following screen capture displays the main elements of the XPression Tessera Region Mapper window in
XPression with the Destination Region Layout section of the selected destination region.

1. Menu Bar — use the File menu to load a
configured region map from a saved file or save a
configuration.

2. Source Region Layouts — use this section to
add and delete source outputs of specific
resolution and regions across multiple channels of
XPression on multiple render engines.

3. Destination Region Layout Settings — use
this section to configure the settings for a
selected destination, including defining the
region.

4. Destination Region Layouts — use this section
to add and delete destination framebuffer outputs
with rendered regions that are mapped to source
outputs.
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XPression Tessera Setup
· The XPression Tessera setup consists of the following concepts and workflow:

· Tessera can consist of either a master controller and output node engines, or a single engine setup. The
master controller has no actual physical outputs. Output nodes are render devices which do not require a
user interface. In single engine mode, the single engine acts as the master controller and output engine.

· Scenes are typically created at the actual size (resolution) that they are to be displayed, but do not have
to be.

· There are two elements to a Tessera mapping: Source Region Layouts and Destination Region Layouts.

· Source Region Layouts are "region masks" applied to an XPression scene, and in turn these regions are
mapped to destination regions.

· Destination Region Layouts can be viewed as if they are framebuffer outputs. Each destination has regions
that will be rendered to, allowing for the slicing of pieces of the overall full resolution canvas should non-
standard resolution displays be rendered to.

· Source Region Layouts are eventually mapped to Destination Region Layouts. For example, a destination
could have two regions from two sources that would be stitched together.

· Every engine must have GenLock. All engines must be locked to the same GenLock/reference.

· Each XPression turnkey engine has two network cards. One network interface can link to a public network
for internet, and the other can link to the private Tessera network. The network synchronization is
accomplished using UDP.

Note: managed networks may prioritize TCP over UDP, affecting the performance of the synchronization.

· When using multiple engines, projects are centrally located on an XPression Project Server. Every Tessera
graphics project MUST be uploaded once to the project server and then re-deployed to the local disk. If
the project is simply saved, it will not be synced.

The following topics are discussed in this section:

Tessera Multiple Engine Mode

Tessera Single Engine Mode

Region Mapping

Scenes

Saving a Project

Saving Region Mappings

Tessera Backup System

Assigning a Source Output to a Scene or Scene Group in the Object Inspector
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Tessera Multiple Engine Mode

Using the Tessera Settings dialog, the output node engines and the master engine can be defined and
configured. Once the engines have been set up, the output nodes can be configured.

The following items should be completed before setting up an XPression Tessera project:

· Ensure that the master XPression engine, the output node XPression render engines, and the XPression
Project Server are connected within the network. All render engines must be linked to the same Project
Server or else the render engines will not be able to retrieve the master project.

· If using multiple engines, ensure that projects have been centrally located on the XPression Project Server
where they can be deployed from the master engine.

 Use the following sections to configure the multiple engine Tessera set up:

Setting Up the Output Node Engines

Setting Up the Master Engine

Tessera Output Nodes

Using Clips with Tessera Multiple Engine Mode

Using DataLinq with Tessera Multiple Engine Mode
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Setting Up the Output Node Engines

Output node engines can be configured in XPression Studio and/or XPression BlueBox. Setting up the output
render engines first allows for a one-stop configuration of the controlling master engine after.

«Output node channels should only be hardware channels; server channels or virtual outputs should not be

used.

«Ensure in the Editor section of the Preferences menu (in Studio) and the BlueBox section of the

Preferences menu (in BlueBox) that the Do Not Create Untitled Project checkbox is selected.

«For the Tessera Master Duo edition, you can only have two nodes, either one primary node and one

backup node, or two primary nodes.

To set up an output node engine:

1. Depending on whether the output node engine is being configured on Studio or BlueBox, do one of the
following:

· In XPression Studio on an output node engine, select Edit > Tessera > Settings to open the Tessera
Settings dialog.

· On an XPression BlueBox machine, right-click on the XPression BlueBox icon ( ) in the Windows
system tray and select Tessera Setup from the menu to open the Tessera Setup dialog.

The Tessera Settings / Tessera Setup dialog opens.

«The Master section with the Clock Node ID field is only available on Studio versions.
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2. In the General section, from the Mode drop-down, select Output Node.

The Tessera NET, Output Node, and UDP Network sections become available for configuration.

3. In the Tessera NET section, in the NET ID field, enter or select a NET ID if using multiple master/node
combinations in parallel on the same network.

4. In the Output Node section, in the Engine ID field, enter or select an engine ID to use to indicate to
other machines which output device this output node engine is, relative to the rest of the system.

A different engine ID is required for each output node engine in the system.

5. In the UDP Network section, from the Broadcast Mode drop-down, set the broadcast mode to one of
the following and then follow the instructions in the link to configure the IP address and port:

· Local Broadcast — broadcast packets to all local network addresses.

· Broadcast IP — broadcast packets to a specific subsection of the network, for example, 192.168.1.255.

«Some routers prevent broadcasting packets as a local broadcast. For example, 255.255.255.

· Multicast — allow Tessera to subscribe and send data to a Multicast group using any source multicast.

Local Broadcast

If using the Local Broadcast option, do the following:

· In the IP Address field, enter 255.255.255.255 as the IP broadcast address to broadcast packets to
all of the local network addresses.

· In the Port field, enter the port number to use for communication between the output node engine and
master engine. 

The default port is 7575.
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Broadcast IP

If using the Broadcast IP option, do the following:

· In the IP Address field, enter the IP address of the broadcast network.

This address is used as an IP filter. For example, if the system is set up to function in a 192.168.1.XXX
space, use 192.168.1.255 as the IP address to indicate that devices could be located anywhere
between 192.168.1.1 and 192.168.1.254. This also ensures that if dual network cards are used, and
one of the cards is on a different network address range, Tessera synchronization traffic will not be
broadcast to the public side of the network.

Select Retrieve to have XPression determine the subnet to use for broadcasting.

· In the Port field, enter the port number to use for communication between the output node engine and
master engine. 

The default port is 7575.

Multicast

If using the Multicast option, do the following:

· In the IP Address field, enter the IP address of the broadcast network.

Select Retrieve to have XPression determine the subnet to use for broadcasting.

· In the Port field, enter the port number to use for communication between the output node engine and
master engine. 

The default port is 7575.

· In the Interface field, enter the IP address of the machine from which the broadcast will come.

6. Select OK.

The output node engine settings are applied and the dialog closes.

7. Repeat steps 1 to 6 for any other output node engines in the system.
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Setting Up the Master Engine

The master engine can only be configured in Studio versions. Only one master can be configured, and there
should be no hardware channels, virtual outputs, or server channels in the hardware profile. They should all
be blank.

For the controlling master engine, use the Tessera Settings dialog to configure the master engine settings.

To set up the master engine:

1. In XPression on the master engine, select Edit > Tessera > Settings.

The Tessera Settings dialog opens.
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2. In the General section, from the Mode drop-down, select Master.

The Master and UDP Network sections become available for configuration.

3. In the Tessera NET section, in the NET ID field, enter or select a NET ID if using multiple master/node
combinations in parallel on the same network.

4. In the Master section, in the Primary Clock Node ID field, enter or select the primary engine node ID
to set the clock for all the engines. 

For a single controller setup, the Primary Clock Node ID will only be set to 1.

5. In the Backup Clock Node ID field, enter or select an output node engine ID as the backup for the
Tessera master should the Primary Clock Node ID enter a non-responsive state (Output Node Timed
Out, No Communication, or Unknown).

6. In the Region Map Selection section, select one of the following:

· Use Global Region Map — use region maps saved globally on the engine.

· Use Region Maps from Projects — use region maps stored in a project file (required for Multicast
broadcast).

«Using region maps from projects requires a project server.

7. In the UDP Network section, from the Broadcast Mode drop-down, select one of the following
broadcast modes and then follow the instructions in the link to configure the IP address and port:

· Local Broadcast — broadcast packets to all local network addresses.

· Broadcast IP — broadcast packets to a specific subsection of the network, for example, 192.168.1.255.

«Some routers prevent broadcasting packets as a local broadcast. For example, 255.255.255.

· Multicast — allow Tessera to subscribe and send data to a Multicast group using any source multicast.



14 • XPression Tessera Setup User Guide (v12.6)

Local Broadcast

If using the Local Broadcast option, do the following:

· In the IP Address field, enter 255.255.255.255 as the IP broadcast address to broadcast packets to
all of the local network addresses.

· In the Port field, enter the port number to use for communication between the master and output
node engines. 

The default port is 7575.

Broadcast IP

If using the Broadcast IP option, do the following:

· In the IP Address field, enter the IP address of the broadcast network.

This address is used as an IP filter. For example, if the system is set up to function in a 192.168.1.XXX
space, use 192.168.1.255 as the IP address to indicate that devices could be located anywhere
between 192.168.1.1 and 192.168.1.254. This also ensures that if dual network cards are used, and
one of the cards is on a different network address range, Tessera synchronization traffic will not be
broadcast to the public side of the network.

Select Retrieve to have XPression determine the subnet to use for broadcasting.

· In the Port field, enter the port number to use for communication between the master and the output
node engines. 

The default port is 7575.

Multicast

If using the Multicast option, do the following:

· In the IP Address field, enter the IP address of the broadcast network.

This address is used as an IP filter. For example, if the system is set up to function in a 192.168.1.XXX
space, use 192.168.1.255 as the IP address to indicate that devices could be located anywhere
between 192.168.1.1 and 192.168.1.254. This also ensures that if dual network cards are used, and
one of the cards is on a different network address range, Tessera synchronization traffic will not be
broadcast to the public side of the network.

Select Retrieve to have XPression determine the subnet to use for broadcasting.

· In the Port field, enter the port number to use for communication between the output node engine and
master engine. 

The default port is 7575.

· In the Interface field, enter the IP address of the machine from which the broadcast will come.

8. Select OK.

The master engine settings are applied and the dialog closes.
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Tessera Output Nodes

Use the XPression Tessera Output Nodes dialog box to direct the master device to the XPression output
engines (configured as output nodes). Output nodes are only configurable in Studio versions.

To configure the output nodes:

1. In XPression on the master device, select Edit > Tessera > Output Nodes.

The XPression Tessera Output Nodes dialog opens.

2. Select Add to add a network node to the Network Nodes list.

The XPression Tessera Network Node dialog opens.

3. From the Engine ID drop-down, select the output node engine ID for the output node.

4. In the Host Name field, enter the UNC or IP address of the network to connect the output engines.

5. In the Name field, enter a custom name for the output node if necessary.

6. In the Description field, enter a brief description for the output node if necessary.

7. In the Location field, define the physical location of the engine if necessary.
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8. From the Type drop-down, select the engine type. 

The options are:

· Primary Engine — use the network node as a primary engine. The primary engine is used to direct
the master device to the XPression output engines (configured as output nodes).

· Backup Engine — use the network node as a backup engine. In the event that a primary engine is
unavailable, the backup engine is used to direct the master device to the XPression output engines
(configured as output nodes). The engine ID of the backup engine should be matched with a primary
engine that uses the same engine ID.

9. Select OK.

Primary engines are added to the Primary Engines list and backup engines are added to the Backup
Engines list.

10.Repeat steps 1 to 9 for any other output engines.

Using Clips with Tessera Multiple Engine Mode

When using clips with Tessera multiple engine mode, ensure that the XPression Clip Store Manager is
running on all engines. The master engine then needs to sync its contents to the Clip Stores on all the
other engines so that they all have the same clip assets available.

Using DataLinq with Tessera Multiple Engine Mode

When using DataLinq with Tessera multiple engine mode, the XPression DataLinq Server only needs to
run on the master engine.
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Tessera Single Engine Mode

Use the Tessera single engine option to enable local area mapping within an XPression system.

To set up a single engine system:

1. In XPression on the master engine, select Edit > Tessera > Settings.

The Tessera Settings dialog opens.
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2. In the General section, from the Mode drop-down, select Single Engine.

3. In the Region Map Selection section, select one of the following:

· Use Global Region Map — use region maps saved globally on the engine.

· Use Region Maps from Projects — use region maps stored in a project file.

«Using region maps from projects requires a project server.

4. Select OK.

The Tessera Settings dialog closes.

In single engine mode, there are no output nodes to configure.
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Region Mapping

Use the XPression Tessera Region Mapper to map the sources, destinations, and regions. Region
mapping is only configurable in Studio versions.

Destination regions are used to display a source that is mapped to it once the sources have been
configured. 

Source regions are used to select specific sections or portions of a source in order to add them to a specific
playback destination.

Multiple sources can be mapped to multiple regions within the destination, which is then outputted to a
channel on the output engine. For example, to stitch together multiple full resolution channels into one
logical channel, create a region of the full resolution of the output channel, starting it at pixel coordinate
width 0, height 0.

Once source regions are configured, they need to be mapped to a destination. Mapping indicates to each
engine which area of the overall scene is to be rendered.

Configuring a Destination Region Layout

Configuring a Source Region Layout

Mapping a Source to a Destination
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Configuring a Destination Region Layout

To configure a destination region layout:

1. In XPression on the master device, select Edit > Tessera > Region Mapping (or press
Shift+Ctrl+Alt+R).

The XPression Tessera Region Mapper opens.

2. In the Destination Region Layouts section, right-click and select Add Destination from the shortcut
menu.
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A new destination is added to the Destination Region Layouts list.

3. In the Destination Region Layout Settings section, configure the source ID, output node, output
resolution, and regions.

4. Repeat steps 2 to 3 to add more destinations as necessary.

The destination is the playback channel.

To configure the source ID:

1. In the ID section, in the Name field, enter a custom name for the destination. 

Assuming the output resolution is the same as what is displayed, it is recommended to give it a name.
Enter a name that makes sense within the system (for example, CG 1-1, which might indicate output
node 1-first output channel, etc.).

2. In the Description field, enter a description of the destination.

To configure the Output Node:

1. In the Output Node section, from the Node drop-down, select the output node of the output engine to
be used to output the destination. 

The list is populated by the output nodes previously configured in the XPression Tessera Output Nodes
dialog, or if using Tessera in single engine mode, is restricted to <local engine>.

2. From the Channel drop-down, select a playback channel on the output engine for outputting the
destination region. 

Although there are 12 channels in the list, the number of usable channels is dependent on the number of
channels available on the output engine.
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3. If using multiple Tessera SE or Tessera Master systems in a MOS workflow, from the Net ID drop-down,
select a net ID to indicate to which Tessera system the MOS object should be sent. 

To configure the Output Resolution:

1. In the Output Resolution section, from the Standard drop-down, select a standard pixel dimension or
select Custom to use a custom resolution.

2. If using a custom resolution, in the Horizontal and Vertical fields, enter or select the dimensions for
the custom resolution. 

Also, simply entering or selecting a different value will automatically select Custom from the Standard
drop-down.

3. In the two Aspect fields, enter or select the aspect ratio for the destination. 

These fields are automatically entered if the Standard output resolution is selected.

4. In the Opacity field, enter or select the transparency value for the background image.

5. Select Browse (...) to locate and select a file to use as the background in the destination, or enter a file
path in the Background field.

Backgrounds are used as a reference to clearly delineate between regions and color code them as desired
(for example, red regions can represent advertisements, blue regions can represent stats, etc.). Do this
by creating an image file that fits the canvas and is representative of the regions.

To configure a Region:

1. From the Zoom drop-down, select a percentage size of the destination canvas to display in the Region
Editor display. 

Selecting To Fit will size the canvas to fit the size of the Region Editor display.

2. In the Region Editor section, select Add to create a destination region.

The New Region dialog opens.

3. In the Width and Height fields, enter or select a size (in pixels) for the new region and select OK.
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A region is added to the destination canvas in the Region Editor display and a thumbnail image is added
to the Destination Region Layouts list.

4. In the Position X and Y fields, enter the coordinates to adjust the location of the region along the X-axis
and Y-axis within the destination canvas.

5. In the Width and Height fields, enter the desired size (in pixels) of the region.

6. From the Rotation drop-down, select a degree of rotation for the region. 

The options are:

· <none> — apply no degree of rotation to the selected region.

· 90 degrees 

· 180 degrees 

· 270 degrees 

«The rotation is only visible on the output and not in the region editor.

7. In the Name field, enter a name for the region.

8. In the Description field, enter a description about the region.

9. Repeat steps 2 to 8 to add more regions to the destination as necessary.

To copy and paste a region:

1. Right-click on a region in the Region Editor and select Copy Region from the shortcut menu. 

2. Right-click in the same or a different Region Editor and select Paste Region from the shortcut menu.
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Configuring a Source Region Layout

To configure a source region layout:

1. In the Source Region Layouts section, right-click and select Add Source from the shortcut menu.

A new source is added to the Source Region Layouts list. Sources in the list can be dragged and
dropped into a different order.

2. In the Source Region Layout Settings section, configure the source ID, virtual dimensions, regions,
and mapping.

Because Tessera renders one single scene to multiple output channels, there is no single channel in
which to render. So a virtual channel must be created, called a source.

To configure the source ID:

1. In the ID section, in the Name field, enter a custom name for the source.

2. In the Description field, enter a custom description of the source.

3. Select the Optimize Rendering for large number of destination regions checkbox for high
performance rendering when a source is mapped to many destination regions and the scene size is
extremely wide or tall. 

This useful in ribbon board workflows, etc.

To configure the virtual dimensions:

1. In the Virtual Dimension section, in the Horizontal and Vertical fields, enter or select the horizontal
and vertical dimensions (in pixels) for the source.

2. In the two Aspect fields, enter or select the aspect ratio for the source.

The Virtual Dimension and Aspect fields automatically data-fill depending on which is configured first.
For example, aspect ratios do not need to be manually calculated if the dimensions have been entered.
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3. In the Opacity field, enter or select the percentage of opacity for the selected background.

4. Select Browse (...) to locate and select a file to use as the background in the source, or enter a file path
in the Background field.

Backgrounds are used as a reference to clearly delineate between regions and color code them as desired
(for example, red regions can represent advertisements, blue regions can represent stats, etc.). Do this
by creating an image file that fits the canvas and is representative of the regions.

To configure a region:

1. Use the Zoom drop-down to select a percentage size of the region dimension to display in the Region
Editor display. 

Selecting To Fit will size the source to fit the size of the Region Editor display.

2. In the Region Editor section, select Add to create a source region.

The New Region dialog opens.

3. In the Width and Height fields, enter or select a size (in pixels) for the new region and select OK.

A region is added to the source canvas in the Region Editor display, and the Source To Destination
Mapping list, and a thumbnail image is added to the Sources list.

4. In the Position X and Y fields, enter coordinates to adjust the location of the region along the X-axis
and Y-axis within the source canvas.
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5. In the Width and Height fields, enter the desired size (in pixels) of the region.

6. In the Name field, enter a name for the region.

7. In the Description field, enter a description of the region.

8. Repeat steps 2 to 7 for any other source region layouts as necessary.

To duplicate a source region layout:

· Right-click a source and from the shortcut menu, select Duplicate Source.
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Mapping a Source to a Destination

To map a source to a destination:

1. In the Source To Destination Mapping table, select <none> under a source Region and from the
drop-down, select the desired playback destination or destination region for the source region.

If mapping the source to the entire destination canvas, select the destination. If mapping the source to a
region within the destination canvas, select the specific region within the destination.

2. Repeat step 1 for all regions in the table.

3. Select File > Save To File to save the region mapping to an .xprgm file.

To copy and paste a region:

1. Right-click on a region in the Region Editor and select Copy Region from the shortcut menu. 

2. Right-click in the same or a different Region Editor and select Paste Region from the shortcut menu.
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Using a Preview Output on a Tessera Master

The Tessera master can use local framebuffers as a preview output.

To set up a preview output:

1. On the Tessera master, select Edit > Hardware Setup.

The Hardware Setup dialog opens.

2. Configure an output.

The output is added to the Inputs / Outputs list.
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3. Select the Preview & Monitor tab.

The Preview & Monitor tab opens.

4. In the Video Preview Output section, from the Up Next Preview Output drop-down, select the
output to use for the Tessera master preview.

For More Information on...

· configuring a framebuffer output, refer to the XPression User Guide.
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Scenes

Projects can be designed as they are always designed in XPression, with a couple of caveats:

· Orthogonal cameras cannot be used in combination with Tessera.

· Background objects cannot be used in combination with Tessera.

These objects are not compatible with how Tessera renders the scene.

Any size of scene can be used. It typically makes sense to have the aspect of the source scenes match the
aspect of the destination.

To create a custom size scene:

1. Right-click inside the Scene Manager and select New > Custom Size Scene from the shortcut menu.

The New Scene dialog opens.

2. In the Virtual Dimensions section, in the Width field, enter or select the width (in pixels) of the new
scene.

3. In the Height field, enter or select the height (in pixels) for the new scene.

The Area Mapping table is not applicable in the Tessera workflow.

4. Select OK to create the new scene with the defined settings.

The New Scene dialog closes and the new scene is added to the Scene Manager window below the
scene or scene group selected in the scene list.
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Saving a Project

Saving projects varies depending on whether Tessera uses multiple engines (master and output nodes) or a
single engine.

Multiple Engines

Tessera using multiple engines uses the Project Server to automatically sync the project amongst the render
engines (output nodes). To enable this mechanism it is required that certain steps are completed.

To enable the Save Project and Publish To Project Server button:

1. Save the project to disk.

2. Save the project to the project server.

3. Deploy the project in XPression.

4. Select the Save Project and Publish To Project Server button ( ) to save the project and ensure all
systems are queued to sync.

Single Engine

If using Tessera with a single engine, the Project Server is not required and saving the project to disk is
sufficient.

To save a project using a single engine:

· Save the project to disk.
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Saving Region Mappings

Individual region mappings can be saved and loaded in the XPression Tessera Region Mapper.

To save a region mapping:

1. In the XPression Tessera Region Mapper, select File > Save To File.

The Save As file browser opens.

2. Select a folder for the file and select Save to save the region mapping to an .xprgm region mapper file.

To load a saved file:

· In the XPression Tessera Region Mapper, select File > Load From File.
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Tessera Backup System

This section describes the XPression Tessera Output Nodes status list and its use in monitoring the
status of the Tessera primary and backup nodes and assigning a backup node to act as a primary node. The
XPression Tessera Output Nodes status list can be used to determine if a Tessera system is active and
ready to be used. 

To determine if a system is ready, confirm that all output nodes show a status of Output Node Running
and display the correct number of Projects Loaded. If a primary or backup node shows Output Node
Running and has the correct number of projects loaded, it is ready to receive commands from the Tessera
master.

The Backup Clock Node and Backup Tessera Master methods and maintaining the backup system are
also described.

The following topics are discussed:

Tessera Output Nodes Status List

Using a Backup Node

Using the Keyboard/GPI Map to Assign Backup Nodes

Video Routing

Backup Tessera Output Node Maintenance

Backup Clock Node

Using a Backup Tessera Master

Backup Tessera Master Maintenance
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Tessera Output Nodes Status List

Open the XPression Tessera Output Nodes window and access the Tessera output nodes status list on the
master engine by selecting Edit > Tessera > Output Nodes.

This window lists all the primary and backup output nodes to which the Tessera master is connected.

The output nodes are divided by Primary Engines and Backup Engines. Primary engines are actively
being used by the Tessera master and the backup engines can be assigned a backup state at any time. By
default, backup engines will be in the <standby> state.
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Primary & Backup Nodes

In the Primary Engines and Backup Engines lists are the configured primary and backup nodes
respectively.

· Name — the name of the node. Does not affect operation. For example, Left Mainboard Engine.

· Engine ID — the Tessera output node engine ID set in the Tessera output node configuration on each
node (Primary or Backup).

· Location — the location of the node. Does not affect operation. For example, Rack 10 Row 20.

· Description — a description of the node. Does not affect operation. For example, node used for interior
boards.

· Host Name — the IP address or host name of the Tessera node running XPression Studio or BlueBox.

· Status — displays the status of the node. See Node Status below for more information.

Node Status

Tessera primary and output nodes will continuously send the Tessera master a status message when
running.

There are four possible statuses that can be shown in the XPression Tessera Output Nodes status list:

· Output Node Running — the output node is running XPression Studio or BlueBox and is sending status
packets.

Ø Projects Loaded — number of projects loaded in the output node.

Ø Memory Fragmentation — memory usage of XPression on the output node.

Ø Rendering Time — uptime of the output node XPression Studio or BlueBox software application.

· Output Node Timed Out — the output node has stopped sending status messages. If an output node
enters this state, the Tessera master will stop waiting for this node to respond to commands.Possible
cause: XPression Studio or BlueBox is in a non-responsive state.
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· No Communication — the Tessera master has not received status packets from the node in 15 seconds
or more.

Possible causes:

Ø Network communication lost.

Ø XPression Studio or BlueBox has not been closed since being launched.

· Unknown — the Tessera master has not yet received any status packets from the output node.

Possible cause: XPression Studio or BlueBox has not been launched on that output node since the Tessera
master has been active.
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Using a Backup Node

Backup Engines can be activated without interrupting or changing the behavior of the Tessera system.
Backup Engines can be used as warm or hot backups. A warm backup can be assigned any Primary Engine
ID and a hot backup can be left running in parallel with any Primary Engine ID.

To use a backup node:

1. On the XPression Tessera master, select Edit > Tessera > Output Nodes.

The XPression Tessera Output Nodes window opens.

2. In the Backup Engines list, select a backup engine.

3. Select the Backup State column.

The Backup State column displays a drop-down menu that lists all the primary engines from the
Primary Engines list by name and engine ID.

4. Select a primary engine for the backup state.

The backup engine will now respond to all commands from the Tessera master that are assigned to that
engine ID.

· If the primary engine is in Output Node Running status, both the primary engine and backup engine
assigned to it will run in parallel (hot backup).

· If the primary engine is in Output Node Timed Out/No Communication or Unknown the Tessera
master will only wait for the backup engine for playout.

A backup engine will only respond to commands sent from the Tessera master after it has been assigned
a Primary Engine ID. It will not retroactively engage commands that were sent before it was assigned
a Primary Engine ID or bring online take items that were already online on the primary engine.
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Using the Keyboard/GPI Map to Assign Backup Nodes

XPression Keyboard and GPI mapping can also be used to assign a backup engine and primary engine node
ID.

To assign backup nodes:

1. On the XPression Tessera master, select Edit > Keyboard / GPI Mapping.

The Keyboard / GPI Mapping dialog opens.

2. In the Available Global Functions section, expand the Tessera menu and select Tessera Backup.

3. Drag the Tessera Backup function and drop it on an available Global Shortcut.

4. In the Tessera Backup Options section, from the Backup Node ID drop-down, select the backup
node.

5. From the Assign as backup of drop-down, select the node to backup using the selected backup node
ID.

6. Select OK.

The Keyboard / GPI Mapping dialog closes.
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Video Routing

Once a backup engine has been assigned as a primary engine, the video feed from the backup engine will
need to be routed to the same destination that the primary engine had been. For example, this could be
done as a router salve/macro or a video switcher custom control. Ensure that macros for every combination
of backup engine replacing a primary engine are accounted for.

For example:

· Backup Node 4 replacing Primary Node 1, 2, and 3.

· Backup Node 5 replacing Primary Node 1, 2, and 3.
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Backup Tessera Output Node Maintenance

Include the backup Tessera output node engines in the regular system maintenance schedule.

If using XPression Clip Store, verify that the Clip Stores on the Tessera backup engines are all being synced
with the master Clip Store.

For More Information on...

· setting up Clip Store sync, refer to the XPression Clips Workflow User Guide.
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Backup Clock Node

Tessera uses one of the outputs nodes as a clock node. The clock node is used as the clock generator
(timer) by the Tessera master for triggering Tessera commands synchronously across all nodes. A backup
clock node can also be configured, and this node will be used by the Tessera master if the primary clock
node enters the Output Node Timed Out, No Communication, or Unknown states.

To configure a backup clock node:

1. On the XPression Tessera master, select Edit > Tessera > Settings.

The Tessera Settings dialog opens.

2. Ensure that the Mode in the General section is set to Master.

3. In the Master section, in the Primary Clock Node ID field, enter or select the primary engine node ID
to set the clock for all the engines.

4. In the Backup Clock Node ID field, enter or select an output node engine ID as the backup for the
Tessera master should the Primary Clock Node ID enter a non-responsive state (Output Node Timed
Out, No Communication, or Unknown).

5. Select OK.
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Using a Backup Master

Using a backup Tessera master requires system changes to allow a backup master to replace the primary
master. Because the primary master receives commands from control systems like DashBoard or OverDrive
and triggers from video switchers, the IP address of the backup master must be changed to the IP address
of the primary master (and the primary taken offline).

To use a backup Tessera master:

1. Ensure that the primary Tessera master system is offline by running the Deactivate Primary.bat batch
file.

Running this batch file:

· Closes XPression Studio/Designer.

· Changes the IP to a placeholder IP.

2. Turn on the Backup master.

3. Ensure that XPression is closed.

4. Run the Activate Backup.bat batch file.

Running this batch file:

· Changes the IP to the primary master IP.

· Launches XPression.

5. In XPression, select File > Load Project > Tessera Project Server Deploy to load a project.

6. Once the project has loaded, select Edit > Tessera > Output Nodes to open the XPression Tessera
Output Nodes status list.

7. Verify that each output node status shows that all project(s) are loaded.
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Backup Tessera Master Maintenance

Include the backup Tessera master in the regular system maintenance schedule.

Keep the backup master Tessera deploy folder up to date by deploying the latest revision of the Tessera
project(s) from the XPression Project Server.

To deploy latest Tessera project(s):

· Select File > Project Server > Deploy on the XPression Tessera master. 

To save updated sequencer list Take Items on the backup, save the project on the primary.

If using DashBoard, keep the backup Tessera master DashBoard up to date with the latest Dashboard .grid
files.

If using XPression Clip Store, check that the XPression Clip Stores on the Tessera backup master are being
synced with the master Clip Store.

For More Information on...

· setting up Clip Store sync, refer to the XPression Clips Workflow User Guide.



44 • XPression Tessera Setup User Guide (v12.6)

Tessera Master / Tessera SE Replication

You can create a backup system to replace a failed Tessera Master or Tessera SE system. The backup
system will monitor one or more Master or SE systems and keep a deployed copy of all projects used on
those systems, as well as copies of the framebuffer configurations, preferences, Tessera settings, etc.

If the monitored engine fails, the backup can load the projects and configuration files and take over control
of any distributed Tessera output nodes. 

This procedure should not be used to replicate output nodes.

In a MOS workflow, any edits in the Tessera Master MOS sequences will not be brought over to the
replication Master, as all changes are coming in from MOS.

You can assign keyboard/GPI actions for taking control of the system and turning monitoring on and off. 

Prerequisites

· You must have a Tessera license for version 10.0 or newer.

· All engines must have the same type of framebuffer board (do not mix X.mio2 and DSXLE4 and/or IP
boards).

· XPression Project Server is required and all engines must be connected to the same project server.

· In a MOS workflow, there cannot be a combination of a MOS sequence and a non-MOS sequence in the
first Tessera Master.

To replicate a Tessera Master or SE system:

1. In XPression, select Edit > Tessera > Tessera Master / SE Replication.

The Tessera Master / SE Replication Settings dialog opens.
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2. Select Add.

The Edit Tessera Master / SE Engine Details dialog opens.

3. In the Settings section, enter the following details:

· In the Name field, enter the name of the Tessera engine to be monitored and replicated if necessary.

· In the Location field, enter the location of the Tessera engine to be monitored and replicated if
necessary.

· In the Description field, enter the description of the Tessera engine to be monitored and replicated if
necessary.

· In the Host field, enter the IP address of the Tessera engine to be monitored and replicated if
necessary.

The Port field is populated with the port number on which the Tessera Master is communicating with
the output nodes.

4. In the Synchronization sections, select the checkboxes of the items to be included in the backup.

It is recommended that all items be selected.

5. Select OK to save the details and close the dialog. 

The described engine is added to the Tessera Master / Tessera SE Engines to Monitor list.
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6. Repeat steps 2 to 5 to add any other engines to the list. 

7. When all engines to be monitored are added, select OK to close the dialog.

To monitor the status of the engines:

1. In XPression, select Display > Replication Status.

The Replication Status dialog opens.

The Replication Status dialog displays the connection status of the engines. It can be moved and
docked anywhere. 

2. Select Monitor On to monitor the status of the engines or Monitor Off when not required.

The Node Status is indicated above the Take Control button.

3. Select the underlined node status text to open the Output Node dialog to see the status of all the
nodes.

To take control of a failed engine:

1. In the Replication Status dialog, select the engine that has failed and select Take Over [Name of
Engine].

The status of the takeover will be displayed as synchronization of each item is completed.

2. When the synchronization is complete, on the backup engine, at the top of the XPression UI, select the
Take Control button to give control of the output nodes to the backup engine.

3. When the primary engine is ready to resume operation, select the Take Control button on the primary
engine to give control back to the primary engine.

For More Information on...

· backing up output nodes, refer to Tessera Backup System.
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Assigning a Source Output to a Scene or Scene Group in
the Object Inspector

Tessera source outputs can be assigned to a scene or scene group using the Tessera tab in the Object
Inspector of the selected scene or scene group.

To assign a source output:

1. In the XPression Editor, select a scene or scene group.

2. In the Object Inspector, select the Tessera tab.

The Tessera tab opens.

3. In the Source Template section, from the Source drop-down, select a source output for the scene
object.

The selected source output is assigned to the scene object and a preview of the layout is displayed in the
Source Layout section.
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Tessera Playback
Once the correct setup has been implemented for the Tessera workflow, use the XPression Sequencer in the
master for playback. No outputs will be listed in the Output list in the Sequencer. The Tessera source
regions previously created, which serve as an overlay for the current scene targeting the destination
regions, are listed by name instead. Any scene or scene size can be sent to any channel, but sending the
appropriate scene for the appropriate source will avoid distorting the output.

Taking elements to air is the same as it is in a regular XPression workflow.

«Source outputs can also be assigned using the Tessera tab in the Object Inspector of a scene or scene

group. For more information on assigning source outputs in the Object Inspector, refer to Assigning a
Source Output to a Scene or Scene Group in the Object Inspector.
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