Thank You for Choosing Ross

You've made a great choice. We expect you will be very happy with your purchase of Ross Technology. Our mission is to:

1. Provide a Superior Customer Experience
   • offer the best product quality and support
2. Make Cool Practical Technology
   • develop great products that customers love

Ross has become well known for the Ross Video Code of Ethics. It guides our interactions and empowers our employees. I hope you enjoy reading it below.

If anything at all with your Ross experience does not live up to your expectations be sure to reach out to us at solutions@rossvideo.com.

David Ross
CEO, Ross Video
dross@rossvideo.com

Ross Video Code of Ethics

Any company is the sum total of the people that make things happen. At Ross, our employees are a special group. Our employees truly care about doing a great job and delivering a high quality customer experience every day. This code of ethics hangs on the wall of all Ross Video locations to guide our behavior:

1. We will always act in our customers’ best interest.
2. We will do our best to understand our customers’ requirements.
3. We will not ship crap.
4. We will be great to work with.
5. We will do something extra for our customers, as an apology, when something big goes wrong and it’s our fault.
6. We will keep our promises.
7. We will treat the competition with respect.
8. We will cooperate with and help other friendly companies.
9. We will go above and beyond in times of crisis. If there’s no one to authorize the required action in times of company or customer crisis - do what you know in your heart is right. (You may rent helicopters if necessary.)
Warranty and Repair Policy

Ross Video Limited (Ross) warrants its XPression systems to be free from defects under normal use and service for the following time periods from the date of shipment:

- **XPression Server** — 12 months
- **XPression Software Upgrades** — 12 months free of charge
- **System and Media hard drives** — 12 months

If an item becomes defective within the warranty period Ross will repair or replace the defective item, as determined solely by Ross.

Warranty repairs will be conducted at Ross, with all shipping FOB Ross dock. If repairs are conducted at the customer site, reasonable out-of-pocket charges will apply. At the discretion of Ross, and on a temporary loan basis, plug in circuit boards or other replacement parts may be supplied free of charge while defective items undergo repair. Return packing, shipping, and special handling costs are the responsibility of the customer.

This warranty is void if products are subjected to misuse, neglect, accident, improper installation or application, or unauthorized modification.

In no event shall Ross Video Limited be liable for direct, indirect, special, incidental, or consequential damages (including loss of profit). Implied warranties, including that of merchantability and fitness for a particular purpose, are expressly limited to the duration of this warranty.

This warranty is TRANSFERABLE to subsequent owners, subject to Ross’ notification of change of ownership.

**Extended Warranty**

For customers that require a longer warranty period, Ross offers an extended warranty plan to extend the standard warranty period by one year increments. For more information about an extended warranty for your XPression system, contact your regional sales manager.
Environmental Information

The equipment that you purchased required the extraction and use of natural resources for its production. It may contain hazardous substances that could impact health and the environment.

To avoid the potential release of those substances into the environment and to diminish the need for the extraction of natural resources, Ross Video encourages you to use the appropriate take-back systems. These systems will reuse or recycle most of the materials from your end-of-life equipment in an environmentally friendly and health conscious manner.

The crossed-out wheeled bin symbol invites you to use these systems.

If you need more information on the collection, reuse, and recycling systems, please contact your local or regional waste administration.

You can also contact Ross Video for more information on the environmental performances of our products.
**Company Address**

<table>
<thead>
<tr>
<th>Ross Video Limited</th>
<th>Ross Video Incorporated</th>
</tr>
</thead>
<tbody>
<tr>
<td>8 John Street</td>
<td>P.O. Box 880</td>
</tr>
<tr>
<td>Iroquois, Ontario</td>
<td>Ogdensburg, New York</td>
</tr>
<tr>
<td>Canada, K0E 1K0</td>
<td>USA 13669-0880</td>
</tr>
</tbody>
</table>

- **General Business Office**: (+1) 613 • 652 • 4886
- **Fax**: (+1) 613 • 652 • 4425

- **Toll Free Technical Support**: 1-844-652-0645 (North America)
  +800 1005 0100 (International)

Alternately, you can contact:
- **Technical Support**: (+1) 613 • 652 • 4886
- **After Hours Emergency**: (+1) 613 • 349 • 0006

- **E-mail for Technical Support**: techsupport@rossvideo.com
- **E-mail for General Information**: solutions@rossvideo.com
- **Website**: http://www.rossvideo.com
Contents

Introduction 1
About This Guide 1-1
Documentation Conventions 1-1
Getting Help 1-1
Contacting Technical Support 1-2

User Interface Overviews 2
The XPression Gateway User Interface 2-2
The XPression ActiveX MOS Plugin User Interface - Browse 2-3
The XPression ActiveX MOS Plugin User Interface - Graphics 2-4
The XPression ActiveX MOS Plugin User Interface - Clips 2-5
The XPression ActiveX MOS Plugin User Interface - Edit Graphics 2-6
The XPression ActiveX MOS Plugin User Interface - Edit Clips 2-7
The XPression HTML5 MOS Plugin User Interface - Overview - Browse 2-8
The XPression HTML5 MOS Plugin User Interface - Overview - Graphics 2-9
The XPression HTML5 MOS Plugin User Interface - Overview - Edit 2-10
The XPression HTML5 MOS Plugin User Interface - Overview - OpenMAM 2-11
The XPression NLE Plugin and Edius Plugin User Interface - Templates 2-12
The XPression NLE Plugin and Edius Plugin User Interface - Edit Mode 2-13
The XPression Template Builder User Interface - Templates 2-14
The XPression Template Builder User Interface - Edit Mode 2-15
The XPression Rundown Controller User Interface 2-16
The XPression Remote Sequencer User Interface 2-17
The XPression Remote Sequencer User Interface (Legacy) 2-18

MOS Workflow Setup 3
Overview 3-1
Required Components 3-1
Optional Components 3-1
Setting Up the XPression Gateway 3-2
Setting Up and Using Multiple XPression Gateways 3-22
Setting Up the XPression ActiveX MOS Plugin 3-29
Setting Up the XPression HTML5 MOS Plugin 3-32
Installing an SSL Certificate for the XPression HTML5 MOS Plugin 3-34

MOS Workflow Operation 4
Using Graphics in the XPression ActiveX MOS Plugin 4-2
Applying Underline, Superscript, and Subscript to Text 4-7
Using Clips in the XPression ActiveX MOS Plugin 4-13
Assigning Take IDs to MOS Objects in the XPression ActiveX MOS Plugin 4-20
Using Spell Check in the XPression ActiveX MOS Plugin 4-21
Changing Existing XPression ActiveX MOS Plugin Items to a Template in a Different Project 4-23
Using Streamline OpenMAM with the XPression ActiveX MOS Plugin 4-25
Using Graphics and Clips in the XPression HTML5 MOS Plugin 4-29

NLE Workflow Setup 5
Overview 5-1
Required Components 5-1
Optional Components 5-1
Setting Up the XPression Gateway for the XPression NLE Plugin and Edius Plugin 5-2
Setting Up the XPression Gateway for the XPression Template Builder 5-8

NLE Workflow Operation 6
Using Graphics in the XPression NLE Plugin, XPression Template Builder, and Edius Plugin 6-2
Using Clips in the XPression NLE Plugin, XPression Template Builder, and Edius Plugin 6-7
Assigning Take IDs to Objects 6-12
Using Spell Check in the XPression NLE Plugin, XPression Template Builder, and Edius Plugin 6-13

OpenMAM 7
Adding and Configuring an OpenMAM Server 7-2
Using OpenMAM Filter Strings With Streamline 7-7

XPression Rundown Controller 8
Add a Remote Connection Point 8-2
Edit a Remote Connection Point 8-3
Delete a Remote Connection Point 8-4
Select Rundowns 8-5
XPression Remote Sequencer 9
Configuring Smart GPI / RossTalk 9-2
Setting Preferences 9-4
Saving and Resetting the Layout 9-7
Adding a Remote Connection Point 9-8
Editing a Remote Connection Point 9-9
Deleting a Remote Connection Point 9-10
Selecting a Channel Group 9-11
Selecting Active Rundowns 9-12
Create a Manual Rundown 9-13
Keyboard / GPI Mapping 9-17
Channels 9-26
Scene Manager 9-27
Up Next Preview 9-28
Linear Rundown 9-29
Take Item Inspector 9-31
Clip Browser 9-33
Control Sequence Playout 9-35

XPression Remote Sequencer (Legacy) 10
Configuring Smart GPI / RossTalk 10-2
Setting Preferences 10-4
Resetting the Layout 10-7
Adding a Remote Connection Point 10-8
Editing a Remote Connection Point 10-9
Deleting a Remote Connection Point 10-10
Selecting a Channel Group 10-11
Selecting Active Rundowns 10-12
Control Sequence Playout 10-13
Introduction

In today's fast-paced news, sports, branding, and entertainment environments, the best graphics engines are only as good as the workflow tools that take those graphics to air. XPression offers a complete line of hardware and software products for efficient collaboration and media moving.

About This Guide

This user guide describes the XPression MOS, NLE, and Template Builder workflows, their configuration, and functions.

If, at any time, you have a question pertaining to the installation, configuration, or operation of the XPression workflow tools, please contact us at the numbers listed in the section “Contacting Technical Support” on page 1–2. Our technical staff are always available for consultation, training, or service.

Documentation Conventions

Special text formats are used in this guide to identify parts of the user interface, text that a user must enter, or a sequence of menus and submenus that must be followed to reach a particular command.

**Bold text**  
Bold text is used to identify a user interface element such as a dialog box, menu item, or button.

For example:
In the **3D Model Files** section, use the **Mode** list to select the folder used to store 3D model files.

**Courier text**  
Courier text is used to identify text that a user must enter.

For example:
Enter **localhost** when the DataLinq server is running on the same computer as XPression.

>  
Menu arrows are used in procedures to identify a sequence of menu items that you must follow.

For example, if a step reads “**Display > Widgets**,” you would click the **Display** menu and then click **Widgets**.

Getting Help

The *XPression Distributed Workflow User Guide* is supplied as a print-ready PDF file. Locate the guide in the C:\Archive folder to open a guide PDF in Adobe® Reader® for viewing or printing.
Contacting Technical Support

At Ross Video, we take pride in the quality of our products, but if problems occur, help is as close as the nearest telephone.

Our 24-hour Hot Line service ensures you have access to technical expertise around the clock. After-sales service and technical support is provided directly by Ross Video personnel. During business hours (eastern time), technical support personnel are available by telephone any time. After hours and on weekends, a direct emergency technical support phone line is available. If the technical support person who is on call does not answer this line immediately, a voice message can be left and the call will be returned shortly. This team of highly trained staff is available to react to any problem and to do whatever is necessary to ensure customer satisfaction.

- **Technical Support:**
  - 1-844-652-0645 (North America)
  - +800 1005 0100 (International)
- **After Hours Emergency:** (+1) 613-349-0006
- **E-mail:** techsupport@rossvideo.com
- **Website:** http://www.rossvideo.com
User Interface Overviews

This section provides user interface overviews for the various components used in the XPression distributed workflow. For information on the XPression Project Server, refer to the *XPression Project Server User Guide*.

The following user interfaces are discussed in this section:

- The XPression Gateway User Interface
- The XPression ActiveX MOS Plugin User Interface - Browse
- The XPression ActiveX MOS Plugin User Interface - Graphics
- The XPression ActiveX MOS Plugin User Interface - Clips
- The XPression ActiveX MOS Plugin User Interface - Edit Graphics
- The XPression ActiveX MOS Plugin User Interface - Edit Clips
- The XPression HTML5 MOS Plugin User Interface Overview - Browse
- The XPression HTML5 MOS Plugin User Interface Overview - Graphics
- The XPression HTML5 MOS Plugin User Interface Overview - Edit
- The XPression HTML5 MOS Plugin User Interface Overview - OpenMAM
- The XPression NLE Plugin and Edius Plugin User Interface - Templates
- The XPression NLE Plugin and Edius Plugin User Interface - Edit Mode
- The XPression Template Builder User Interface - Templates
- The XPression Template Builder User Interface - Edit Mode
- The XPression Rundown Controller User Interface
- The XPression Remote Sequencer User Interface
- The XPression Remote Sequencer User Interface (Legacy)
The XPression Gateway User Interface

The following screen capture displays the main elements of the XPression Gateway user interface. Descriptions of individual elements are contained below the diagram.

1) **Menu Bar** — use this menu bar to access the Gateway menu.
2) **Output Engines List** — lists the output engines that have been configured for each XPression system being used for playout.
3) **Preview and Offline Render Engines List** — lists the preview engines that have been configured for each XPression Bluebox OFL system being used for motion and still preview in the XPression MOS Plugin, NLE Plugin, Template Builder, and Remote Sequencer.
4) **MOS Object Monitor** — displays the currently monitored and MOS active rundowns on the Gateway. Stories that contain graphics can be expanded to view the associated MOS objects.
5) **Log Area** — displays the activities of the Gateway. Select a tab to view the activity log for the Gateway, the information sent or received by the Gateway, or the connected plugin clients, user, last activity, and connection time.
The XPression ActiveX MOS Plugin User Interface - Browse

The following screen capture displays the main elements of the XPression ActiveX Plugin user interface Browse tab. Descriptions of individual elements are contained below the diagram.

1) **Saved Items Folders** — view and select graphics, clips, or rundown from the folders list.

2) **Options Menu** — use this menu to open the Configuration dialog box or to select the primary or secondary MOS Gateway.

3) **Thumbnails / List** — view and select graphics or clips from the Browse tab display results. Use the filter at the top to locate specific graphics or clips.

4) **Display** — use the display functions to select the viewing method (Tile, Thumbnail, or List), resize thumbnails, and refresh the display results.

5) **Button Controls** — use these buttons to connect to an openMAM server, update a story, or cancel an edit.
The XPression ActiveX MOS Plugin User Interface - Graphics

The following screen capture displays the main elements of the XPression ActiveX Plugin user interface Graphics tab. Descriptions of individual elements are contained below the diagram.

1) **Show / Filter** — displays the selected show. Use the filter to display specific saved graphic templates.
2) ** Thumbnails / List** — view and select graphics in either thumbnail or list views.
3) **Options Menu** — use this menu to open the Configuration dialog box or to select the primary or secondary MOS Gateway.
4) **Button Controls** — use these buttons to connect to an openMAM server, update a story, or cancel an edit.
The XPression ActiveX MOS Plugin User Interface - Clips

The following screen capture displays the main elements of the XPression ActiveX Plugin user interface Clips tab. Descriptions of individual elements are contained below the diagram.

⚠️ XPression Clips is optional for XPression and the XPression MOS workflow. If you do not have XPression Clips. If you do not have XPression Clips and you are interested in adding it to your workflow, please contact your Ross Video sales representative.

1) **Search Area** — use the Quick Find search field to display specific saved clips, or click the Show/Hide advanced search button to enter detailed search criteria. Use the Reset search filter button to clear all search fields.

2) **Clips** — view and select clips from the list.

3) **Options Menu** — use this menu to open the Configuration dialog box or to select the primary or secondary MOS Gateway.

4) **Button Controls** — use these buttons to connect to an openMAM server, update a story, or cancel an edit.
The XPression ActiveX MOS Plugin User Interface - Edit Graphics

The following screen capture displays the main elements of the XPression ActiveX Plugin user interface in Edit tab for graphics. Descriptions of individual elements are contained below the diagram.

1) **Show / Filter** — displays the selected show. Use the filter to display specific saved graphic templates.

2) **Thumbnails / List** — view and select graphics in either thumbnail or list views.

3) **Editor** — use this area to edit the object/field contents and template playout information. Use the OpenMAM menu to select a MAM system. Click the Save button to save any changes.

4) **Preview Area** — view the graphic template and any changes made in the Editor. Use the playback controls to play animations.

5) **Options Menu** — use this menu to open the Configuration dialog box or to select the primary or secondary MOS Gateway.

6) **Button Controls** — use these buttons to connect to an openMAM server, update a story, or cancel an edit.
The XPression ActiveX MOS Plugin User Interface - Edit Clips

The following screen capture displays the main elements of the XPression ActiveX Plugin user interface in Edit tab for clips. Descriptions of individual elements are contained below the diagram.

XPression Clips is optional for XPression and the XPression MOS workflow. If you do not have XPression Clips. If you do not have XPression Clips and you are interested in adding it to your workflow, please contact your Ross Video sales representative.

1) **Search Area** — use the Quick Find search field to display specific saved clips, or click the Show/Hide advanced search button to enter detailed search criteria. Use the Reset search filter button to clear all search fields.

2) **Clips** — view and select clips from the list.

3) **Editor** — use this area to edit the object/field contents & template playout information. Use the OpenMAM menu to select a MAM system. Click the Save button to save any changes.

4) **Preview Area** — preview the clips. Use the playback controls to control preview playback.

5) **Options Menu** — use this menu to open the Configuration dialog box or to select the primary or secondary MOS Gateway.

6) **Button Controls** — use these buttons to connect to an openMAM server, update a story, or cancel an edit.
The XPression HTML5 MOS Plugin User Interface Overview - Browse

The following screen capture displays the main elements of the XPression HTML5 Plugin user interface Browse tab. Descriptions of individual elements are contained below the diagram.

1) **Settings** — use this menu to open the Configuration panel.
2) **Saved Items Folders** — view and select graphics, clips, or rundowns from the folders list.
3) **Search** — use this field to locate specific graphics or clips and then click the Refresh icon to update the thumbnail results.
4) **Display** — use the display functions to select the viewing method (Grid, Details, or Table), and resize thumbnails.
5) **Thumbnails** — view and select graphics or clips in the Browse tab display results.
The XPression HTML5 MOS Plugin User Interface Overview - Graphics

The following screen capture displays the main elements of the XPression HTML5 Plugin user interface Graphics tab. Descriptions of individual elements are contained below the diagram.

1) **Search** — use this field to locate specific graphics or clips and then click the **Refresh** icon to update the thumbnail results.
2) **Show / Filter** — displays the selected show. Use the filter to display specific saved graphic templates.
3) **Expand / Collapse / Thumbnails / List** — expand or collapse the categories and then view and select graphics in either thumbnail or list views.
4) **Thumbnails** — view and select graphics or clips. Double-clicking a thumbnail opens the selected graphic in **Edit** mode.
The XPression HTML5 MOS Plugin User Interface Overview - Edit

The following screen capture displays the main elements of the XPression HTML5 Plugin user interface Edit tab for graphics. Descriptions of individual elements are contained below the diagram.

1) **Editor** — use this area to edit the object/field contents and template playout information. Use the OpenMAM menu to select an openMAM system. Click the Save button to save any changes.

2) **Preview Area** — view the graphic template and any changes made in the Editor. Use the playback controls to play animations.

3) **Button Controls** — use these buttons to spellcheck your edits, update a story, cancel an edit, add the graphic to a story, close the plugin or cancel the operation.
The XPression HTML5 MOS Plugin User Interface Overview - OpenMAM

The following screen capture displays the main elements of the XPression HTML5 Plugin user interface OpenMAM tab. Descriptions of individual elements are contained below the diagram.

1) **Button** — click to open an asset management system that has been configured in the XPression Gateway.
The XPression NLE Plugin and Edius Plugin User Interface - Templates

The following screen capture displays the main elements of the XPression NLE Plugin user interface in Templates mode. Descriptions of individual elements are contained below the diagram.

1) **Thumbnails / List** — view and select templates in thumbnail or list views. Use the filter at the top to locate specific templates.

2) **Saved Graphics** — view and select saved graphics. Use the filter at the top to locate specific saved graphics.

3) **Options and Button Controls** — use the menu to open the Configuration dialog box or to select the primary or secondary MOS Gateway. Use the button controls to apply or cancel changes.
The XPression NLE Plugin and Edius Plugin User Interface - Edit Mode

The following screen capture displays the main elements of the XPression NLE Plugin user interface in Edit Mode. Descriptions of individual elements are contained below the diagram.

1) Editor — use this area to view and edit the objects and fields of the template and to save graphics.
2) Preview Area — view the template and any changes made in the Editor. Use the playback controls to play animations.
3) Options and Button Controls — use the menu to open the Configuration dialog box or to select the primary or secondary MOS Gateway. Use the button controls to apply or cancel changes.
The XPression Template Builder User Interface - Templates

The following screen capture displays the main elements of the XPression Template Builder user interface in Templates mode. Descriptions of individual elements are contained below the diagram.

1) **Thumbnails / List** — view and select templates in thumbnail or list views. Use the filter at the top to locate specific templates.

2) **Saved Graphics** — view and select saved graphics. Use the filter at the top to locate specific saved graphics.

3) **Options and Button Controls** — use the menu to open the Configuration dialog box or to select the primary or secondary MOS Gateway. Use the button controls to apply or cancel changes.
The XPression Template Builder User Interface - Edit Mode

The following screen capture displays the main elements of the XPression Template Builder user interface in Edit Mode. Descriptions of individual elements are contained below the diagram.

1) **Editor** — use this area to view and edit the objects and fields of the template and to save graphics.
2) **Preview Area** — view the template and any changes made in the Editor. Use the playback controls to play animations.
3) **Options Menu** — use the menu to open the Configuration dialog box or to select the primary or secondary MOS Gateway.
The XPression Rundown Controller User Interface

The following screen capture displays the main elements of the XPression Rundown Controller user interface. Descriptions of individual elements are contained in the legend below the diagram.

1) **Menu Bar** — use this menu bar to access the File and Help menus.
2) **Toolbar** — use this toolbar to access Connection Groups.
3) **Rundown List** — use this to view and select rundowns and show styles.
4) **Selection Area** — use this area to filter through rundowns and apply the selected rundown settings.
The XPression Remote Sequencer User Interface

The following screen capture displays the main elements of the XPression Remote Sequencer user interface. Descriptions of individual elements are contained below the diagram.

1) **Menu Bar** — use this menu bar to access the File, Docking, and Display menus.
2) **Toolbar** — use this toolbar to quickly select rundowns, access and edit Connection Points and Channel Groups, select saved docking layouts, and view the status of connections to the Project Server, ClipStore, and DataLinq Server.
3) **Channels** — use the channels to view, select, and modify the items on a particular channel in the Linear Rundown.
4) **Scene Manager** — use this window to view and manage the scenes and scene groups contained in a project.
5) **Up Next Preview** — use this to preview the upcoming scene.
6) **Linear Rundown** — use this to view and control a list of scenes or scene groups.
7) **Next Up Preview** — displays the upcoming take items in the queue.
8) **Take Item Inspector / Clip Browser** — toggle between the Take Item Inspector and the Clip Browser. Use the Take Item Inspector to edit the properties of a selected group or take item. Use the Clip Browser to browse for clips to drop into the Linear Rundown for preview and playout.
The XPression Remote Sequencer User Interface (Legacy)

The following screen capture displays the main elements of the XPression Remote Sequencer (Legacy) user interface. Descriptions of individual elements are contained below the diagram.

1) **Menu Bar** — use this menu bar to access the File, Docking, and Help menus.
2) **Toolbar** — use this toolbar to quickly select rundowns, access and edit Connection Points and Channel Groups, and use the Fast Recall feature.
3) **Sequencer** — use this to view and control a list of scenes or scene groups.
4) **Preview Area** — displays the upcoming take items in the queue.
5) **Status Area** — displays the current status of the Remote Sequencer.
MOS Workflow Setup

Overview

The XPression Gateway serves as a communication hub between the customer supplied newsroom control system and the various XPression components required to complete the XPression MOS workflow. The XPression MOS Plugin, XPression Remote Sequencer, XPression Rundown Controller, XPression preview engine, and Clip Store Server all connect to the XPression Gateway. MOS messages created using the MOS plugin are added to stories in the customer supplied newsroom control system. These MOS messages are then parsed from active rundowns by the XPression Gateway and used to create take items in the necessary XPression playout device.

Before you start using the XPression MOS workflow, the various components and settings need to be configured for operability.

The following topics are discussed in this section:

• Required Components
• Optional Components
• Setting Up the XPression Gateway
• Setting Up and Using Multiple XPression Gateways
• Setting Up the XPression ActiveX MOS Plugin
• Setting Up the XPression HTML5 MOS Plugin
• Installing an SSL Certificate for the XPression HTML5 MOS Plugin

Required Components

The following is a list of the required components for the XPression MOS workflow:

• XPression Gateway
• XPression Studio, Prime, or BlueBox OFL (preview engine)
• XPression MOS Plugin or HTML5 MOS Plugin
• XPression Studio/Prime/BlueBox (playout engine)

Optional Components

The following items are optional for the XPression MOS workflow:

• XPression Project Server
• XPression Remote Sequencer
• XPression Rundown Controller
• XPression Desktop Preview Server
• Supported MAM system
• XPression Clips
• XPression Tessera (requires project-based region mapping and XPression Project Server)

For More Information on...

• The XPression Gateway user interface, refer to the section “The XPression Gateway User Interface” on page 2–2.
• The XPression MOS Plugin user interface, refer to the section “The XPression ActiveX MOS Plugin User Interface - Graphics” on page 2–4 and “The XPression ActiveX MOS Plugin User Interface - Clips” on page 2–5.
Setting Up the XPression Gateway

The following steps explain the XPression Gateway configuration for the MOS workflow.

If you have any Citrix programs installed, such as GoToMeeting, ensure that the DNE LightWeight Filter is disabled in the Local Area Connection Properties window of any machine that is connected to the XPression Gateway, including the XPression Gateway itself.

1. Open the XPression Gateway.
2. Click Gateway > Settings.
   The XPression Gateway - Settings dialog box opens.
3. Click Gateway to configure the XPression Gateway settings.
   The Gateway configuration area opens.

By default, the XPression Gateway - Settings dialog box opens in the Gateway configuration area.

Gateway

a. In the MOS Server section, use the Media Object Port box to enter or select a port number on which the newsroom control system will accept connections from MOS devices. The default is 10540.
   Only change the Media Object Port number if there is a port conflict.

b. Use the Running Order Port box to enter or select a port number on which the MOS will accept connections from the newsroom control system. The default is 10541.
   Only change the Running Order Port number if there is a port conflict.

c. In the Primary MOS ID box, enter the MOS ID that you are using in your newsroom control system. An optional secondary ID can be entered in the Secondary MOS ID box.
d. In the NCS ID box, enter your newsroom control system ID.
e. In the **MOS Objects & Messages** section, configure the following options as necessary:

- **Parse roStorySend Messages** — select this check box to parse all incoming MOS objects, including those for unrelated devices. It is recommended that this option is left unselected if not using multiple gateways.

  Some newsroom systems require this on for basic functionality (for example, Dalet).

  Select the **Accept Items With Incorrect MOS ID** check box to allow the XPression Gateway to accept items with incorrect MOS IDs. This requires parsing the roStorySend MOS messages to see the other MOS ID objects.

- **Don't Send Status Messages** — select this check box to disable reporting the MOS status of graphics and clips to the NRCS.

f. In the **MOS Message Encoding** section, configure the following options as necessary:

- **Use UTF8** — select this check box to use UTF8 8-bit character encoding.

- **Encode MOS Payload** — select this check box to encode the MOS payload of MOS items to avoid issues with Unicode and older versions of some newsroom systems.

- **Strip Unicode Chars from MOS Abstracts** — select this check box to strip Unicode characters in the MOS abstracts or slugs if the newsroom system does not support Unicode text.

4. Click **Rundowns** to configure the rundown settings.

The **Rundowns** configuration area opens.

---

**Rundowns**

a. In the **Settings** section, select the **Auto Activate New Rundowns** check box to automatically trigger new rundowns.

b. Select the **Don't Delete Active Rundowns** check box to prevent rundowns from being removed when they are still activated for playout.

c. Select the **Deactivate rundown** check box to hold a rundown active after the NRCS un-monitors it.

  Use the minutes box to enter or select an amount of time to wait before deactivating the rundown.
5. Click **Client Plugins** to configure the plugin settings.

The **Client Plugins** configuration area opens.

![Client Plugins Configuration Area](image)

**Client Plugins**

a. In the **Global Settings** section, use the **Plugin Server Port** box to enter or select a port number on which the XPression MOS Plugin communicates with the XPression Gateway. The default is 10550.

*Only change the Plugin Server Port number if there is a port conflict.*

b. Configure the following options as necessary:

- **Enforce the Gateway’s MOS ID** — select this check box to set the MOS ID in any connected ActiveX or HTML5 plugin to the MOS ID entered in the XPression Gateway.
  
  It is recommended that this option is selected.

- **Enable MOS Timing Fields** — select this check box to allow in and out information to be inserted into the MOS message for autonomous triggering of graphics.
  
  - **Default Inpoint** — enter or select a default in point time for the MOS message.
  
  - **Default Duration** — enter or select a default duration time for the MOS message.
  
  Check with your newsroom and production automation provider to see if this functionality is supported.

- **Enable Remote Plugin Updates** — select this check box to prompt users of the XPression ActiveX Plugin to update the plugin if the version does not match the version of the XPression Gateway.

- **Show Template List on Edit Mode tab** — select this check box to allow users of the XPression ActiveX Plugin to browse templates while the plugin is in edit mode.

- **Empty Material Fields Show as <none>** — select this check box to remove the display of `<none>` from empty material fields.

- **Disable Channel and Layer** — select this check box to disable the channel and layer settings for the MOS objects.

- **Hide frames in timing fields** — select this check box to hide frames in the ActiveX and HTML5 Plugin timing fields.

- **Enable OverDrive Fields** — select this check box to enable the use of fields for the OverDrive automation system.

- **Enable Mosart Fields** — select this check box to enable the use of fields for the Mosart automated news system.

- **Enable Ignite Fields** — select this check box to enable the use of fields for the Ignite automated news system.

- **Hide hours in timing fields** — select this check box to hide the hours in timing fields in the ActiveX Plugin.
c. In the **Layer Options** section, click the **Edit Default Layers** button to configure custom layers available in the layer drop-down menu in the MOS plugin.

The **Custom Layer List** dialog box opens.

Perform the following to edit and add layers as necessary:

- Click a layer in the list and edit the **Name** and **Layer** assignments as necessary.
- Click **Add** to add a new layer to the list and edit the **Name** and **Layer** assignments as necessary.
- Select a layer in the list and click to **Delete** to delete the selected layer.
- Use the **Move Up** and **Move Down** buttons to move a selected layer up or down within the list.
- Click **Close** to exit the Custom Layer List dialog box.

d. Use the **Default Layer** list to establish default layer assignments for MOS generated take items. The options are:

- **Default for Channel** — assign take items to the default layer for the framebuffer.
- **Default for Template** — assign take items to the layer assignment of the scene object.

Use the following default layer options to have scenes play on the selected layer:

- **Layer -3 (background)**
- **Layer -2**
- **Layer -1**
- **Layer 0 (middle)**
- **Layer 1**
- **Layer 2**
- **Layer 3 (foreground)**

e. In the **Render Options** section, select the **Clients connect directly to offline and preview engines** check box to direct ActiveX clients to render directly to the offline and preview engines.
6. Click MOS Objects to configure the MOS object settings.

The MOS Objects configuration area opens.

MOS Objects

a. In the MOS Abstract section, use the Maximum MOS Abstract Length box to enter or select a maximum number of characters for the MOS abstracts.

A MOS abstract is a human-readable description of a MOS item. Most newsroom systems will display the MOS abstract to the user in the MOS story. The MOS abstract can be configured to contain a number of different descriptive fields that will automatically be populated based on the contents of the MOS item.

b. In the Format box, use tags to build a descriptive text string that will be used to format the MOS abstract field. Any characters outside of a given tag will be carried over to the MOS abstract. For example: @TEMPLATE@:@CONTENT@ may become 'Lower Third:First Name'.

The format can also be entered by right-clicking inside the box and selecting Insert and the necessary tag from the shortcut menu.

The available tags are:
- @TEMPLATE@
- @CLIP@
- @CONTENT@
- @DESCRIPTION@
- @TIMING@
- @INPOINT@
- @OUTPOINT@
- @DURATION@
- @CHANNEL@
- @VCNAME@
- @GWID@
- @TYPE@
- @TAKEID@
- @OUTMETHOD@

Some newsrooms (for example, Autocue) display the ObjSlug field to the user instead of the MOS abstract. Select the Apply MOS Abstract format to ObjSlug field check box to use the MOS abstract format definition to build up the ObjSlug field.

c. In the Options section, select the Include Item Timing in MOS Editorial Fields check box to include the item timing in the editorial time fields of the MOS object.
d. In the **Tessera** section, use the **Value for <itemChannel>** field box to enter the item abstract value for the itemChannel tags of MOS objects when using Tessera with MOS workflow. The default value is TESSERA.

7. Click **Remote Sequencer** to configure the Remote Sequencer server port.

   The **Remote Sequencer** configuration area opens.

   ![Remote Sequencer Configuration](image)

   **Remote Sequencer**
   
   a. In the **Server** section, use the **Sequencer Server Port** box to enter or select the port number for the Remote Sequencer.
   
   b. In the **Settings** section, use the **Purge locally modified MOS Items older than** box to enter a time in days or hours to purge modified MOS items on a local folder. Select the **Days** or **Hours** radio button to set the respective degree of time until the purge.

8. Click **Output Engines** to configure the output engine settings.

   The **Output Engines** configuration area opens.

   ![Output Engines Configuration](image)
Output Engines

Use the Output Engines section to add and configure XPression output engines or XPression Tessera masters/single engines for use in a MOS workflow.

**Output Engines**

* An output engine needs to be added for each XPression system being used for on air playout.
  
a. In the **Output Engines** section, click **Add**.

   The XPression Output Engine dialog box opens.

   ![XPression Output Engine Dialog Box]

   b. In the **Engine ID** section, use the **Name** box to enter an ID for the output engine.

c. Use the **Description** box to enter a brief descriptive detail for the output engine.

d. In the **Remote XPression Engine** section, use the **Host** box to enter the IP address of the XPression system for the output engine.

e. Use the **Port** box to enter or select the port number for the XPression system.

f. Click **OK**.

   The XPression Output Engine dialog box closes and the output engine is added to the **Output Engines** list.

**Tessera Masters / Solo Engines**

a. In the **Tessera Masters / Solo Engines** section, click **Add**.

   The XPression Tessera Master dialog box opens.

   ![XPression Tessera Master Dialog Box]

   b. In the **Tessera Details** section, use the **Name** box to enter the name of the Tessera master or solo engine.

c. Use the **Description** box to enter a brief descriptive detail for the Tessera master or solo engine.

d. In the **Network Settings** section, use the **Host** box to enter the IP address of the Tessera master or solo engine.

e. Use the **Port** box to enter or select the port number for the Tessera master or solo engine.
f. If using a Tessera master (and not a solo engine), click Add in the Tessera Output Nodes section to add output engines for the Tessera master.

The XPression Output Engine dialog box opens.

![XPression Output Engine dialog box]

g. In the Engine ID section:
   - Use the Name box to enter the name of the Tessera output node.
   - Use the Description box to enter a brief descriptive detail for the Tessera output node.

h. In the Remote XPression Engine section:
   - Use the Host box to enter the IP address of the Tessera output node.
   - Use the Port box to enter or select the port number for the Tessera output node.

i. Click OK.

The XPression Output Engine dialog box closes and the output node is added to the Tessera Output Nodes list.

j. Repeat steps f to i for any other output nodes.

k. Click OK.

The XPression Tessera Master dialog box closes and the Tessera master or solo engine is added to the Tessera Masters / Solo Engines list.

l. Repeat steps a to k for any other Tessera masters or solo engines.

9. Click Virtual Channel Mapping to configure individual outputs on separate devices into a single pool of output channels for operation.

The Virtual Channel Mapping configuration area opens.

![Virtual Channel Mapping dialog box]
Virtual Channel Mapping

Virtual channels represent an individual layer on a specific output. This makes it possible to configure more virtual channels than there are physical outputs because a virtual channel can be configured for one of potentially many layers used on the output.

a. In the Channels section, click Add.

The Virtual Channel Routing dialog box opens.

b. In the Channel ID section, use the Name box to enter an ID for the channel.

c. Use the Description box to enter a brief descriptive detail for the channel.

d. In the Engine Routing list, select the check box of the engine you want to use.

e. Click inside the Output column of the selected engine and enter or select the output to use for the engine.

f. Click inside the Layer column of the selected engine and enter or select the layer to use for the engine.

g. If using XPression Clips with the MOS workflow, click inside the Server Channel column of the selected engine and enter or select the virtual server channel for previewing and playing out clips.

h. Use the Desktop Preview Server Channel box to enter or select a preview output channel from the Desktop Preview Server.

i. Click OK.

The Virtual Channel Routing dialog box closes and the channel and engine are added to the Channels list.

10. Click Channel Groups to configure channel groups.

The Channel Groups configuration area opens.
Channel Groups

Channel groups must be configured before the MOS workflow is functional.

Channel groups are a way of organizing virtual channels and activating them on multiple output engines in different locations.

The diagram below illustrates just one example of how you might use channel groups to facilitate your workflow.

a. In the Channel Groups section, click Add.
   The Channel Group Settings dialog box opens.

b. In the Channel Group section, use the Name box to enter a name for the channel group.
c. Use the **Description** box to enter a brief descriptive detail for the channel group.

d. Use the **Allowed IPs** box to limit the Remote Sequencers that can use the new channel group.

   Click **Add** and enter the IP addresses of permitted Remote Sequencers. Leaving the field blank allows all Remote Sequencers to use that channel group.

e. Use the **Running Order Filter** box to limit the running orders that can be loaded to the channel group.

   Click **Add** and enter the names of permitted running orders. Wildcards are allowed, such as "*6PM*", to further filter the running orders. Leaving the field blank allows all running orders to use that channel group.

f. In the **Active Engines** section, for each channel, select the check box for the engine(s) that will be active on that channel.

g. Click **OK**.

   The **Channel Group Settings** dialog box closes and the channel group is added to the **Channel Groups** list.

11. Click **Preview & Offline Engines** to configure the preview engines.

   The **Preview & Offline Engines** configuration area opens.

   ![Preview & Offline Engines](image)

   **Preview & Offline Engines**

   `*` A preview engine needs to be added for motion and still preview in the XPression MOS Plugin and XPression Remote Sequencer.

   a. In the **Preview & Offline Render Engines** section, click **Add**.

      The **XPression Preview Engine** dialog box opens.

      ![XPression Preview Engine](image)

   b. In the **Engine ID** section, use the **Name** box to enter an ID for the engine.
c. Use the **Description** box to enter a brief descriptive detail for the engine.

d. In the **Remote XPression Engine** section, use the **Host** box to enter the IP address of the XPression system for the preview engine.

e. Use the **Port** box to enter or select the port number for the XPression system.

f. In the **Options** section, select the **Reserve engine for NLE client rendering** check box to send preview requests from the NLE to any OFL engine(s) reserved for NLE use.

Any MOS plugin requests will be sent to the non-reserved OFL engines. If all OFL engines in the Gateway have this check box enabled, MOS plugin requests will go to any of the OFL engines. If none of the OFL engines have this check box enabled, previews from NLE clients will be assigned to any one of the OFL engines.

g. Click **OK**.

The **XPression Preview Engine** dialog box closes and the preview engine is added to the **Preview & Offline Render Engines** list.

If using an XPression Desktop Preview Server, select the **Enabled** check box in the **Desktop Preview Server** section and configure the **Host** and **Port** settings. Use the **Up Next Channel** box to select the preview channel for the preview that is going to air next.

12. Click **Project Server** to configure the XPression Project Server settings.

The **Project Server** configuration area opens.

![Project Server Configuration](image)

The XPression Project Server is optional for XPression MOS workflow. If you do not have the Project Server, proceed to the next section. If you are interested in adding the XPression Project Server to your workflow, please contact your Ross Video sales representative.

**Project Server**

The XPression Project Server offers centralized storage and creative collaboration within a facility or across an enterprise. Designers and operators can access any XPression project from any XPression workstation, share projects while working locally, then re-publish to the server.

The login and password must be configured in the Project Server before you can connect the XPression Gateway.

a. In the **Project Server** section, select the **Enabled** check box to use the Project Server.

b. Use the **Host** box to enter the IP address of the Project Server.

c. Use the **Port** box to enter or select the port number for the Project Server.

d. In the **Login** box, enter your username for the Project Server.

e. In the **Password** box, enter the password for your Project Server login.
f. Select the **Allow all plugin users to access any project** check box to allow all plugin users to access any project from the Project Server.

13. Click **Clip Store** to configure the Clip Store Server and settings to use XPression Clips in the MOS workflow.

   The **Clip Store** configuration area opens.

   ![Clip Store Configuration](image)

   XPression Clips is optional for XPression and the XPression MOS workflow. If you do not have XPression Clips, proceed to the next section. If you are interested in adding the XPression Clips to your workflow, please contact your Ross Video sales representative.

   **Clip Store**

   With a Clip Store configured on the XPression Gateway, the XPression MOS Plugin offers the ability to browse, preview, and select clips as MOS items to include in an NRCS running order. It integrates with the XPression output and preview engines and the Remote Sequencer.

   a. In the **Clip Store Server** section, select the **Enabled** check box to use the Clip Store Server in the MOS workflow.

   b. Use the **Host** box to enter the IP address of the Clip Store Server.

   c. Use the **Port** box to enter or select the port number for the Clip Store Server.

   d. Select the **Use HTTPS / SSL** check box to enable the use of HTTPS/SSL in the HTTP Server configuration. Selecting this option requires a pre-installed SSL certificate.

   e. Select the **Resolve hostname before sending to plugins** check box to resolve the ClipStore hostname to an IP before being provided to the client plugins.

   f. In the **Clips Settings** section, use the **Default Channel** list to select the default engine and channel to which the clips will be assigned.

   g. Select the **Clips added to running order should be recalled via their Recall ID** check box to retrieve clips added to a rundown using their recall IDs. When this feature is selected, if newer versions of clips are incoded, the new version will be recalled.
14. Click **Persistent Templates** to select and configure a folder for persistent graphics for the XPression Gateway.

   The **Persistent Templates** configuration area opens.

   ![Persistent Templates Configuration](image)

   **Persistent Templates**

   Use persistent templates to save persistent graphics in the XPression MOS Plugin to the XPression Gateway engine.

   a. Use the **Path** box to enter a file path or click the **Browse (...)** button to open a file browser to select a folder to which graphics will be saved from the XPression MOS Plugin and XPression Template builder.

      Select the **Delete source file after parsing** to delete the source file once it has been saved to the watch folder.

15. Click **Saved Items** to select and configure a graphics folder for the XPression Gateway.

   The **Saved Items** configuration area opens.

   ![Saved Items Configuration](image)
Saved Items

Saved Items are templates that are saved to the XPression Gateway and edited via the XPression MOS Plugin. These pre-populated templates can be saved in user configured folders that can be stored permanently, or in the daily graphics folder that can be automatically purged after a user defined duration.

a. In the Database section, use the Path box to enter a file path or click the Browse (...) button to open a file browser to select a permanent or daily graphics folder.

b. Use the Date format list to select an order for the date that the graphic was saved. The options are:
   - dd-mm-yyyy — Day-Month-Year (for example, 15-07-2015)
   - mm-dd-yyyy — Month-Day-Year (for example, 07-15-2015)
   - yyyy-mm-dd — Year-Month-Day (for example, 2015-07-15)

c. Use the Purge daily templates after X days box to enter or select an amount of days before the daily graphics folder is automatically purged. Set to 0 for no purging.

16. Click OpenMAM to configure a supported asset management system.

   The OpenMAM configuration area opens.

   ![OpenMAM Configuration](image)

   OpenMAM is optional for XPression MOS workflow. If you are not using Dali, MediaBeacon 3.0, MediaBeacon 5.0, Streamline, or XPression Maps asset management systems, proceed to the next section.

   If you are configuring an OpenMAM driver, please refer to the section “Adding and Configuring an OpenMAM Server” on page 7–2 for information on configuring the Dali, MediaBeacon 3.0, MediaBeacon 5.0, Streamline, and XPression Maps connections.
17. Click **DataLinq** to configure the XPression DataLinq Server settings. The **DataLinq** configuration area opens.

DataLinq

a. In the **DataLinq Options** section, select the **Enable DataLinq Server** check box to enable the connection to the DataLinq Server in the **DataLinq Connection Settings** section below.

b. Select the **MOS/NLE Plugins connect to DataLinq Server directly** check box to directly connect the plugins to the DataLinq Server.

   Enabling this check box results in DataLinq messaging bypassing the XPression Gateway. Disabling this check box results in the DataLinq messaging traveling through the XPression Gateway and the XPression Gateway managing the connections. This path through the XPression Gateway is required for the HTML5 plugin.

c. In the **DataLinq Server** section, use the **Host** box to enter the IP address of the XPression DataLinq Server.

d. Use the **Port** box to enter or select the port number for the XPression DataLinq Server.

18. Click **OverDrive** to configure the OverDrive connection settings. The **OverDrive** configuration area opens.
OverDrive
OverDrive is a production control system that enables control over all the devices used in a production environment.

a. In the **OverDrive Settings** section, select the **Accept Incoming Connections** check box to enable the XPression Gateway to accept incoming connections from OverDrive for automatic rundown activation.

b. Use the **Port** box to enter or select the port number for the incoming OverDrive connections.

c. Use the **Channel Group** list to select a pre-configured channel group for the OverDrive connection.

⚠️ Channel groups need to be configured in the Channel Groups configuration area of the XPression Gateway settings before they are available for selection for the OverDrive connection.

19. Click **Running Order Export** to configure the settings for exporting running orders to an XML file.

The **Running Order Export** configuration area opens.

---

**Running Order Export**

a. In the **Export Options** section, select the **Enable Running Order Export** check box to export running orders to an XML file.

The XML file can be used to set up a DataLinq to XPression to use the running order information in graphics.

b. Select the **Start at Current Active Story** check box to place the current on-air story at the top of the XML file.

c. Select the **Exclude Stories with Empty Headline Field** check box to ensure that graphics without headlines do not make it to air.

d. Use the **Headline Field** box to enter the path to the customizable headline field in the MOS object to be written to the exported rundown.

e. Use the **Headline Qualifier** box to enter the path to the customizable headline qualifier in the MOS object to be written to the exported rundown.

f. Use the **Destination Folder** box to enter a folder path or click the **Browse (…)** button to open a file browser and navigate to the folder to use for the exported running order XML file.
20. Click **HTTP Server** to enable and configure a web server.

The **HTTP Server** configuration area opens.

**HTTP Server**

a. In the **Web Server Settings** section, select the **Enable Web Server** check box to use the HTML5 MOS Plugin.

b. Use the **Port** box to enter or select the port number of the HTML5 MOS Plugin.

c. Use the **Client Timeout** box to enter or select the number of minutes after which the plugin will timeout.

d. Select the **Use HTTPS / SSL** check box to establish an encrypted link between the web server and the browser.

   A pre-installed SSL (Secure Sockets Layer) certificate is required. See “Installing an SSL Certificate for the XPression HTML5 MOS Plugin” on page 3–34.

e. In the **Server Settings** section, use the **Plugin Asset Root Folder** box to enter a folder path or click the **Browse** (…) button to open a file browser and navigate to a folder to store the assets used in the plugin. This folder will be seen in the plugin as the root location when the user clicks **Select** in a material field to browse for an image or video to insert.

f. Select the **Show Add to Story Button** check box to display the Add to Story button in the HTML5 MOS Plugin interface.

g. Select the **Show OK Button** check box to display the OK button in the HTML5 MOS Plugin interface.

h. Select the **Show Cancel Button** check box to display the Cancel button in the HTML5 MOS Plugin interface.

i. Select the **Show Update Story Button** check box to display the Update Story button in the HTML5 MOS Plugin interface.

j. Select the **Edit mode cleared by drag** check box to

k. Select the **Block non NRCS user** check box to block use without an NRCS.
21. Click **Lucid Studio Integration** to configure the Lucid Studio Integration settings and enable the Lucid Studio Engine in a Channel Group.

   The **Lucid Studio Integration** configuration area opens.

   ![Lucid Studio Integration configuration area](image)

   **Lucid Studio Integration**

   a. In the **Lucid Studio Integration** section, select the **Enabled** check box to enable Lucid Studio integration with MOS.

   b. Use the **Lucid MOS Service Host** box to enter the IP address of the machine running Lucid MOS Service. The **Port** is automatically detected.

   c. In the **Lucid Studio Engines** section, click **Add**.

   The **Lucid Studio Engine** dialog box opens.

   ![Lucid Studio Engine dialog box](image)

   d. In the **Lucid Studio ID** section, use the **Name** box to enter a name for the engine. The default name is Lucid Studio Engine 1.

   e. Use the **Description** box to enter a description, such as the location of the engine (optional).

   f. Ensure the **Synchronize Running Orders on Project Load** check box is selected.

   g. In the **Connection Settings** section, use the **Host** box to enter the IP address of the machine running Lucid Studio.

   The **Port** number 7791 is entered by default. If this port is in use, enter a different port number.
22. Click **Miscellaneous** to configure miscellaneous settings such as the project frame rate and running orders. The **Miscellaneous** configuration area opens.

![Miscellaneous Settings](image)

**Miscellaneous**

a. In the **Misc** section, select the **Start With Windows** box to launch the XPression Gateway upon Windows startup.

b. Select the **Show Gateway Online / Offline controls** check box to display the online and offline radio button options in the XPression Gateway interface in order to take the gateway offline so that it will not communicate with the engines when multiple gateways are connecting to shared engines.

c. Select the **Enable TCP Keep Alive For ActiveX Plugins** check box to enable the ActiveX TCP connection from breaking during periods of inactivity.

d. In the **Project Settings** section, use the **Frames Per Second** box to enter or select a frame rate for projects.

e. In the **Running Orders Thumbnails** section, select the **Only render on plugin requests** box to only render the thumbnails from a running order when selected in the **Browse** tab in the XPression MOS Plugin, as opposed to having them render as soon as the running order is monitored.

f. In the **Graphics / Clips** section, select the **Enable Graphics tab in plugin** check box to display the Graphics tab in the MOS Plugin interface to use graphics in the MOS workflow.

g. Select the **Enable Clips tab in plugin** check box to display the Clips tab in the MOS Plugin interface to use clips in the MOS workflow.

23. Click **OK**.

The **XPression Gateway - Settings** dialog box closes and the settings are applied to the XPression Gateway.

**For More Information on...**

- XPression Project Server, refer to the **XPression Project Server User Guide**.
- using a secondary gateway, refer to "Setting Up and Using Multiple XPression Gateways" on page 3–22.
- Lucid Studio Integration with MOS, refer to the **Lucid Studio User Guide**.
Setting Up and Using Multiple XPression Gateways

In the event that the primary XPression Gateway fails, having multiple gateways allows for redundancy. The secondary XPression Gateway must be connected to manually, as the fail-over is not automatic. The following procedures explain the configuration and use of multiple XPression Gateways within a MOS workflow:

- Setting Up Multiple XPression Gateways
- Verify the Connections
- Switching Over to Another XPression Gateway

Setting Up Multiple XPression Gateways

The virtual channel mapping configuration should be identical in both XPression Gateways.

1. Configure the primary and secondary XPression Gateway MOS IDs in your newsroom control system.
2. Open an XPression Gateway to use as the primary gateway.

Primary XPression Gateway Configuration

a. Click Gateway > Settings.
   The XPression Gateway - Settings dialog box opens.

b. Click Gateway.
   The Gateway configuration area opens.

c. In the MOS Server section, use the Primary MOS ID box to enter the MOS ID for the primary gateway you are using in your newsroom control system. The primary MOS ID is the local MOS ID.

d. Use the Secondary MOS ID box to enter the MOS ID for the secondary gateway you are using in your newsroom control system.

e. Use the NCS ID box to enter your newsroom control system ID.

f. In the MOS Objects & Messages section, select the Parse roStorySend Messages check box.
g. Click **Rundowns**.  
   The **Rundowns** configuration area opens.

![Rundowns Configuration Area](image1)

h. In the **Settings** section, ensure that the **Auto activate new rundowns** check box is disabled.

i. Click **Miscellaneous**.  
   The **Miscellaneous** configuration area opens.

![Miscellaneous Configuration Area](image2)

j. In the **Misc** section, select the **Show Gateway Online / Offline controls** check box to display the Online/Offline radio button options for the **Engine Connections** in the XExpression Gateway interface.

k. Click **OK**.  
   The **XPression Gateway - Settings** dialog box closes.

3. On another machine, open the **XPression Gateway** to use as the *secondary* gateway.
Secondary XPression Gateway Configuration

a. Click Gateway > Settings.
   The XPression Gateway - Settings dialog box opens.

b. Click Gateway.
   The Gateway configuration area opens.

c. In the MOS Server section, because the primary MOS ID is the local MOS ID, use the Primary MOS ID box to enter the MOS ID for the secondary gateway you are using in your newsroom control system. This should be the same ID entered for the secondary MOS ID in the steps for the primary XPression Gateway.

d. Use the Secondary MOS ID box to enter the MOS ID for the primary gateway you are using in your newsroom control system. This should be the same ID entered for the primary MOS ID in the steps for the primary XPression Gateway.

e. Use the NCS ID box to enter your newsroom control system ID.

f. In the MOS Objects & Messages section, select the Parse roStorySend Messages check box.

g. Click Rundowns.
   The Rundowns configuration area opens.
h. In the **Settings** section, ensure that the **Auto activate new rundowns** check box is disabled.

i. Click **Miscellaneous**.

The **Miscellaneous** configuration area opens.

![Miscellaneous Configuration Area](image)

j. In the **Misc** section, select the **Show Gateway Online / Offline controls** check box to display the **Online/Offline** radio button options for the **Engine Connections** in the XPression Gateway interface.

k. Click **OK**.

The **XPression Gateway - Settings** dialog box closes.

4. Ensure that the **Online** setting for the **Engine Connections** in the XPression Gateway is selected for only one gateway and disabled for the other.

![Gateway Interface](image)

For example, select **Online** in the primary gateway and **Offline** in the secondary gateway.
XPression ActiveX MOS Plugin Configuration

5. Configure the XPression ActiveX Plugin to connect to the primary and secondary XPression Gateways:

a. In the XPression ActiveX Plugin, click Options > Configuration.

   The XPression ActiveX Plugin Configuration dialog box opens.

b. In the XPression MOS Gateways section, click Add.

   The XPression Gateway Config dialog box opens.

c. In the XPression Gateway Settings section, use the Name box to enter a name for the XPression Gateways.

d. In the Primary section, use the Host Address box to enter the IP address of the primary XPression Gateway.

e. Use the Server Port box to enter or select the port number of the XPression Gateway.

f. In the Secondary section, use the Host Address box to enter the IP address of the secondary XPression Gateway.

g. Use the Server Port box to enter or select the server port number of the secondary XPression Gateway.
h. Click OK.

The XPRESSION GATEWAY CONFIG dialog box closes and the primary gateway with secondary host is added to the XPRESSION MOS Gateways list.

Repeat steps b to h for any additional gateways.
Existing gateways in the list can be edited by selecting a gateway and clicking Edit, or removed by selecting a gateway and clicking Delete.

XPRESSION REMOTE SEQUENCER

6. If using an XPRESSION Remote Sequencer:
   • configure a connection point for the primary XPRESSION Gateway and a connection point for the secondary XPRESSION Gateway.
   • configure a connection group for the primary XPRESSION Gateway connection and a connection group for the secondary XPRESSION Gateway connection.

FOR MORE INFORMATION ON...
   • configuring the XPRESSION Gateway, refer to “SETTING UP THE XPRESSION GATEWAY” on page 3–2.
   • configuring the XPRESSION MOS Plugin, refer to “SETTING UP THE XPRESSION ACTIVEX MOS PLUGIN” on page 3–29.
   • configuring the connection points and groups in the XPRESSION Remote Sequencer, refer to “XPRESSION REMOTE SEQUENCER” on page 9–1.

VERIFY THE CONNECTIONS

You can ensure the multiple XPRESSION Gateway setup is functional by performing the following steps:

1. In the XPRESSION MOS PLUGIN, click OPTIONS > USE GATEWAY and select:
   • Secondary (if currently using the primary gateway)
   • Primary (if currently using the secondary gateway)

2. Click OPTIONS > CONFIGURATION.
   The XPRESSION MOS PLUGIN CONFIGURATION dialog box opens.

3. In the NRCS section, ensure the MOS ID of the gateway you selected in step 1 of this procedure is displayed in the MOS ID box.
Switching Over to Another XPression Gateway

This procedure assumes that the primary gateway is used as the main gateway and that the secondary is used as the fail-over gateway.

1. If the primary XPression Gateway fails or is taken offline for maintenance, select **Offline** for the **Engine Connections** in the primary XPression Gateway.

    ![Gateway Connections](image)

2. In the secondary **XPression Gateway**, select **Online** for the **Engine Connections**.

3. Do the following depending on whether using the ActiveX plugin or HTML5 plugin:
   - In the **XPression ActiveX Plugin**, click **Options > Use Gateway > Secondary**.
   - For the HTML5 plugin, the MOS device is configured in the NRCS to connect to a single gateway. Open the HTML5 plugin that is configured for the active XPression Gateway within the NRCS.

4. If using the **XPression Remote Sequencer**, select the connection group assigned to the secondary XPression Gateway connection.

For More Information on...

- selecting a connection group, refer to “Open a Connection Group” on page 9–15.
Setting Up the XPression ActiveX MOS Plugin

The XPression ActiveX plugin is accessed from within the customer supplied newsroom client system. The plugin allows users to edit the contents of templates by manipulating published fields defined during the template creation process. These edited templates can then be added to rundowns as MOS messages in the newsroom system.

* If you have any Citrix programs installed, such as GoToMeeting, ensure that the DNE LightWeight Filter is disabled in the Local Area Connection Properties of any machine that is connected to the XPression Gateway, including the XPression Gateway itself.

1. Open the XPression ActiveX Plugin in the newsroom client.

   The XPression ActiveX Plugin opens.

2. Click Options > Configuration.

   The XPression ActiveX Plugin Configuration dialog box opens.
3. In the **XPression MOS Gateways** section, click **Add**. The **XPression Gateway Config** dialog box opens.

4. In the **XPression Gateway Settings** section, use the **Name** box to enter a name for the XPression Gateway.
5. In the **Primary** section, use the **Host Address** box to enter the IP address of the XPression Gateway.
6. Use the **Server Port** box to enter or select the port number of the XPression Gateway.
   * You can optionally configure a connection to a second XPression MOS Gateway using the **Secondary** section.
7. Click **OK**.
   The gateway is added to the XPression MOS Gateways list.

8. In the **NRCS** section, use the **MOS ID** box to enter the MOS ID that has been entered in the XPression MOS Gateway.
   If you have selected **Enforce the Gateway’s MOS ID** in the **Client Plugins** section of the settings for the XPression Gateway, the MOS ID will automatically appear in the **MOS ID** box.
9. In the **Spell Check** section, use the **Dictionary** list to select a language for the spell check. Words can be added to a local dictionary per user.
10. In the **XPression Local Preview Engine** section, select the **Active** check box if you are using a preview engine other than the one configured on the XPression Gateway.
    a. Enter the IP address of the preview engine in the **Host Address** box.
    b. Enter or select the port number of the preview engine in the **Server Port** box.
11. In the **Misc** section, configure the following:

- **Floating Preview** — select this check box to display the preview in a scalable window detached from the plugin.
- **Show Timing Fields** — select this check box to enable the in point and duration fields to be used by production automation for automatically inserting and removing graphics.
- **Show Hours in Timing Fields** — select this check box to enable hour counts in the in point and duration timing fields.
- **Show template list on Edit Mode tab** — select this check box to display the template list in the plugin while in edit mode.
- **Use Windows Explorer instead of Texture Browser** — select this check box to use Windows Internet Explorer to browse for images and videos instead of the built in texture browser.

12. Click **OK**.

The **XPression ActiveX Plugin Configuration** dialog box closes.

For More Information on...

- setting up multiple gateways, refer to **“Setting Up and Using Multiple XPression Gateways”** on page 3–22.
- using the spell check, refer to **“Using Spell Check in the XPression ActiveX MOS Plugin”** on page 4–21.
Setting Up the XPression HTML5 MOS Plugin

The XPression HTML5 Plugin is accessed from within the customer supplied newsroom client system. The plugin allows users to edit the contents of templates by manipulating published fields defined during the template creation process. These edited templates can then be added to rundowns as MOS messages in the newsroom system.

1. Open the XPression HTML5 Plugin in the newsroom client.

   The XPression HTML5 Plugin opens.

2. Click the Configuration button ( ) in the top-right corner of the plugin interface.

   The XPression HTML5 Plugin Configuration panel opens.

3. In the NRCS section, in the MOS ID field, enter the MOS ID that has been entered in the XPression Gateway.

   If Enforce the Gateway’s MOS ID is selected in the Client Plugins section of the settings for the XPression Gateway, the MOS ID will automatically appear in the MOS ID field and editing is disabled.

4. In the Spell Check section, from the Dictionary list, select a language for the spell check. Words can be added to a custom dictionary that is saved on the XPression Gateway and shared by all users.
5. In the Misc section, configure the following:

- **Show Timing Fields** — select this check box to add the In Point, Duration and Manual Timing fields to the graphics Editor to allow automation of the graphic.
- **Show Hours in Timing Fields** — select this check box to enable hour counts in the In Point and Duration timing fields.
- **Show Console Logging** — select this check box to enable the viewing of the console logs within the HTML5 interface for NRCS troubleshooting that does not facilitate a Chrome browser.
- **MOS Object includes ncsItem/item depth** — if using iNEWS, select this check box to enable MOS objects to include the NRCS item/item depth. It is selected by default.

6. Click **Save**.

The XPression HTML5 Plugin Configuration panel closes.
Installing an SSL Certificate for the XPression HTML5 MOS Plugin

In order for the XPression HTML5 plugin to operate over SSL/HTTPS connections, an SSL certificate must be purchased and installed on the XPression Gateway server. This section outlines the steps.

**Prerequisites**

A purchased SSL certificate from a trusted root authority (our certificates our purchased from DigiCert, so these instructions will use the steps for DigiCert as an example).

**Buying an SSL Certificate**

To purchase an SSL certificate, a CSR file must be generated and sent to the certificate authority. The CSR file describes the server machine that will hold the certificate as well as the Company and Organization details for the purchaser. This must be generated on the Gateway machine and must be registered against the server/domain that the HTML5 plugins will use to connect to the gateway.

The CSR can usually be generated using a tool provided by the Certificate Authority (or they should provide documentation on how to generate the CSR).

When purchasing from DigiCert, the platform can be specified as “Other”. This will provide you with .CRT files containing the certificates.

**Installing the Certificate**

DigiCert provides a DigiCert Key Utility that can be used to install the three certificate files (Root, Intermediate, and the actual gateway certificate).

![DigiCert Key Utility](image)

Once the certificates have been installed, they must be configured and bound to the port that the XPression Gateway will use.
To install the SSL certificate:

1. Open Windows MMC by pressing **Win+R**, typing **MMC** and pressing **Enter**.
2. In the **Console1** window, from the **File** menu, select **Add/Remove Snap-in**....

![Add or Remove Snap-ins](image1.png)

3. In the **Available snap-ins** list, double-click **Certificates**.

![Certificates snap-in](image2.png)
4. In the **Certificates** snap-in dialog, select **Computer Account** and click **Next**.

5. In the **Select Computer** dialog, select **Local Computer** and click **Finish**.

6. In the **Add or Remove Snap-ins** dialog, click **OK**.

7. Click **Personal > Certificates** and find the certificate. In this example, it is *.rossvideo.com.*
8. Double click the certificate and go to **Details->Thumbprint**.

9. Copy and paste the thumbprint text to a clipboard or notepad.

10. Open the Windows command prompt console as administrator and run the following command:

    ```
    netsh http add sslcert ipport=0.0.0.0:9443 certhash=%thumbprint% appid=(3CF6A009-07A4-4A80-BB43-F3A6E147B00A)
    ```

    where `%thumbprint%` should be the thumbprint you copied from MMC.

    A message should be received indicating successful installation of the certificate.

To remove a certificate from a port:

- Open the Windows command prompt console as administrator and run the following command:

  ```
  netsh http delete sslcert ipport=0.0.0.0:9443
  ```

  Existing bindings must be deleted before a certificate can be reassigned to an existing port.

To see a list of bound SSL certificates to ports:

- Open the Windows command prompt console as administrator and run the following command:

  ```
  netsh http show sslcert
  ```

  If the certificate is correctly bound, it should show up like this:
Configuring the XPression Gateway

Enable the use of HTTPS/SSL in the HTTP Server configuration.
When HTTPS is enabled, the port will be forced to 9443.
Troubleshooting

If there are issues with the webserver starting on XPression Gateway; this command can be run from the Windows command prompt console to view what URLs have been registered with the Web Server:

```
netsh http show urlacl
```

There should be three URLs registered against 9500 (if not using HTTPS), and 9443 (if using HTTPS):

![Image of URL ACLs](image.png)

These URLs can be deleted if necessary, and the gateway should recreate them as needed, with the following command (repeated 3 times for each of client, static, and plugin):

```
netsh http delete urlacl url=https://+:9443/CLIENT
```
Certificate Not Attached to Private Key

If the certificate is manually imported into the personal certificate store (by right-clicking import in the MMC certificate plugin); the certificate may not be linked with the private key.

This is visible by the certificate missing the "key" icon in its thumbnail:

If this is the case, open up the certificate and find its serial number:

Then open the Windows command prompt console as administrator and run the following command:

```
certutil -repairstore my %serialnumber%
```

where `%serialnumber%` is replaced with the `serialnumber` of the certificate.
MOS Workflow Operation

This section describes how to use the templates and saved graphics in the XPression MOS Plugin.

The following topics are discussed in this section:

- Using Graphics in the XPression ActiveX MOS Plugin
- Applying Underline, Superscript, and Subscript to Text
- Using Clips in the XPression ActiveX MOS Plugin
- Assigning Take IDs to MOS Objects in the XPression ActiveX MOS Plugin
- Using Spell Check in the XPression ActiveX MOS Plugin
- Changing Existing XPression ActiveX MOS Plugin Items to a Template in a Different Project
- Using Streamline OpenMAM with the XPression ActiveX MOS Plugin
- Using Graphics and Clips in the XPression HTML5 MOS Plugin

For More Information on...

- The XPression MOS Plugin and XPression HTML5 MOS Plugin user interfaces, refer to the section "User Interface Overviews" on page 2–1.
Using Graphics in the XPression ActiveX MOS Plugin

The Graphics tab in the XPression ActiveX Plugin is used for adding graphics to the story in the NRCS or for adding a clip to a material in a graphic.

1. Open the XPression ActiveX Plugin in the newsroom client.
2. In the XPression ActiveX Plugin, click Graphics.
   The Graphics tab opens.

3. Select one of the following viewing methods for the graphics browser:
   • Thumbnails — click this tab to view the graphics in a thumbnail layout.
   • List — click this tab to view the graphics in a name list.

4. Select and edit your graphics:
   • To select graphics from the Project Server, refer to the section “Browsing Graphics From Project Server” on page 4–3.
   • To select graphics without Project Server, refer to the section “Browsing Graphics Without Project Server” on page 4–3.
   • To edit graphics, refer to the section “Editing Graphics” on page 4–4.
   • To browse the metadata of a graphic or template, refer to the section “Browsing the Metadata of a Graphic or Template” on page 4–5.
Browsing Graphics From Project Server

If a revision of a project is published in XPression, the XPression ActiveX Plugin will receive a notification of the revision.

a. Click Browse (...).

The Show, Category and Style Selection dialog box opens.

b. Select a show and category from the Show and Category tree.

c. In the Style list, select a style.

d. Click OK.

The Show, Category and Style Selection dialog box closes and the graphics associated with the selected style are available for selection in the Thumbnails / List.

Use the Filter box to enter a graphic name or keyword to search for specific graphics. The filter also searches the metadata of graphics when available.

e. Double-click a graphic from the Thumbnails or List.

Browsing Graphics Without Project Server

Browse graphics in the Thumbnails / List. Use the Filter box to enter a graphic name or keyword to search for specific graphics. The filter also searches the metadata of graphics when available.

The available graphics are dictated by what has been loaded on the preview engine. This must be done manually.
**Editing Graphics**

 Ramirez distributed workflow prevents the changes from being overwritten by new updates in the Xpression ActiveX Plugin.

a. In the **Graphics** tab, double-click a graphic from the **Thumbnails**, **List**, or **Saved Graphics**. The template opens in the **Edit** tab.

The graphic is visible in the preview window and the published fields will be displayed in the **Object / Field** and **Content** lists. If **Enable User Input Controls** is selected in the **Data Source** tab of the **Object Inspector** in Xpression, the **Content** cell will contain a list of available static text, global list, and DataLinq values. If radio button user input controls have been configured, they can be selected using the **Up** and **Down** arrows on the keyboard.

Users can play animations from the graphic using the playback controls below the preview window.

b. **Fixed Take ID numbers can be assigned to MOS objects. For more information, refer to “Assigning Take IDs to MOS Objects in the Xpression ActiveX MOS Plugin” on page 4–20.**

b. Edit clip information such as **Channel**, **Layer**, **Description**, **In Point**, and **Duration** as necessary.

Select the **Manual Timing** check box to use a manual time instead of the in point/duration timing fields of the graphic when under automation control.

If using Xpression Tessera, use the **Channel** list to select a source rather than a channel (for example, **Source 1**, **Source 2**, etc.).

c. Edit the **Object / Field** information in the **Content** column. The changes appear in the preview.

The information can also be selected by clicking on the object in the preview window.

Clear a field by right-clicking it and selecting **Clear Field** from the shortcut menu; or revert to the template values by selecting **Revert all fields to template values**.

A clip can be copied (**Ctrl+C**) from the Clips browser and pasted (**Ctrl+V**) in the material field.

d. Click **Add To Story**.

You can also click and drag from the preview window to the newsroom client interface.

You can open a graphic from the story in the NRCS to edit or update by double-clicking it. The graphic will open in the **Edit** tab and a colored bar at the top of the edit tab indicates that the graphic was opened from the NRCS. Once edited/updated, click **Update Story** to update the story or apply the changes.
Browsing the Metadata of a Graphic or Template

Metadata is an option that can be designed into a scene.

a. In the Graphics or Edit tab, right-click on a graphic or template from the Thumbnails, List, or Saved Graphics.

b. Select Browse Metadata.

The Browse Metadata window opens.

5. Save and select your saved graphics:

- To save your graphics, refer to the section “Saving Graphics” on page 4–5.
- To select your graphics, refer to the section “Selecting Saved Graphics” on page 4–6.

Saving Graphics


b. Click Save.

The Save Item to Folder dialog box opens.

c. Select one of the following save options:

- **Save as Daily Item** — select this radio button to save the graphic to a daily items folder. This will create an items folder for the current date that is subject to the Saved Items settings in the XPression Gateway.
- **Save to Specific Folder** — select this radio button to save the graphic to a specific folder selected from the Saved Items folder structure.

d. Enter a **Name** for the graphic and click **OK**.

The Save Item to Folder dialog box closes and the graphic is saved.
Selecting Saved Graphics

In the **Browse** tab, select a graphic from the **Saved Items** folder structure. These graphics need to have been pre-populated with information and saved to a user specified folder.

Graphics can also be browsed from the **Rundowns** area. This enables users to select graphics used in MOS rundown that are being monitored by the XPression Gateway. The graphics can be copied to other rundown or modified from their current state using the **Edit** tab and then added to a rundown.

Users can create new folders in the Saved Items folder on the XPression Gateway. These folders will appear in the Saved Items folder structure in the XPression ActiveX Plugin. Folders can also be deleted from the Saved Items folder on the XPression Gateway by right-clicking and selecting **Delete Folder**.

Graphics can also be saved to the daily folders. These folders are auto-generated with the current date and can be set to purge after a specified period of time.

Exporting a Graphic to a PNG File

The preview image for a graphic can be saved as a PNG file.

a. In the preview section, right-click on the preview image and select **Export Image** from the shortcut menu.

b. Use the file browser to locate a folder in which to save the .png file.

For More Information on...

- Saved Items folders, refer to the section “Setting Up the XPression Gateway” on page 3–2.
- creating user input controls for static text, global list, and DataLinq objects, refer to the XPression Help File in XPression.
- XPression Project Server, refer to the XPression Project Server User Guide.
Applying Underline, Superscript, and Subscript to Text

Underline, superscript, and subscript font formats can be applied to the text of graphics opened for editing in the plugin.

The following commands are used to apply or end underlines, superscripts, and subscripts:

- `{U}` — apply underline attribute
- `{/U}` — end underline attribute
- `{SUP}` — apply superscript attribute
- `{/SUP}` — end superscript attribute
- `{SUB}` — apply subscript attribute
- `{/SUB}` — end subscript attribute
- `{}` — end all text attributes

Font tags are not case-sensitive.

To apply underline, superscript, or subscript:

1. In the Graphics tab, double-click a graphic from the Thumbnails, List, or Saved Graphics.

   The template opens in the Edit tab.

   a. Click the Object / Field with the text for the underline and place the cursor in front of the text for applying the underline.
b. Enter \( \{U\} \) to apply the underline.

The underline is applied to all text after the \( \{U\} \) command.

c. To end the underline at a specific location within the text, place the cursor at the end of the text intended to include the underline and enter \( \{\} \).

The underline is applied to the text within the \( \{U\} \) and \( \{\} \) commands.

**Superscript**

a. Click the **Object / Field** with the text for the superscript and place the cursor in front of the text for applying the superscript.
b. Enter \{SUP\} to apply the superscript.

The superscript is applied to all text after the \{SUP\} command.

c. To end the superscript at a specific location within the text, place the cursor at the end of the text intended to include the superscript and enter \{\}.

The superscript is applied to the text within the \{SUP\} and \{\} commands.

Subscript

a. Click the Object / Field with the text for the subscript and place the cursor in front of the text for applying the superscript.
b. Enter \{SUB\} to apply the subscript.

The subscript is applied to all text after the \{SUB\} command.

c. To end the subscript at a specific location within the text, place the cursor at the end of the text intended to include the subscript and enter \{\}.

The subscript is applied to the text within the \{SUB\} and \{\} commands.

Underline with Superscript or Subscript

a. Click the Object / Field with the text for the underline with superscript or subscript and place the cursor in front of the text for applying the underline with superscript or subscript.
b. Enter \{U\} and \{SUP\} (or \{SUB\}) to apply the underline with superscript (or subscript).

The underline and superscript (or subscript) is applied to all text after the \{U\} and \{SUP\} (or \{SUB\}) commands.

To end the underline after a certain point in the text but keep the superscript (or subscript) for the rest of the text, enter \{/U\} in the location to end the underline.
Conversely, to end the superscript (or subscript) after a certain point in the text but keep the underline for the rest of the text, enter \(^{/SUP}\) (or \(^{/SUB}\)) in the location to end the superscript (or subscript).

* Underline, superscript, and subscript are row independent in the Content section for the Object / Field. A new line removes all tags. Tags must be added manually to every row.
Using Clips in the XPression ActiveX MOS Plugin

🌟 XPression Clips is optional for XPression and the XPression MOS workflow. If you do not have XPression Clips and are interested in adding it to your workflow, please contact your Ross Video sales representative.

🌟 If using a Project Server and a revision of a project is published in XPression, the XPression ActiveX Plugin will receive a notification of the revision.

The Clips tab in the XPression ActiveX Plugin is used for adding clips to the story in the NRCS.

Selecting and Searching Clips

1. Open the XPression ActiveX Plugin in the newsroom client.
2. In the XPression ActiveX Plugin, click Clips.
   
   The Clips tab opens.

3. Click on a clip to select it or use the Advanced Search Options to locate a specific clip:

   Advanced Search Options

   Click the Show/Hide advanced search options buttons to open and close the advanced search options.

   - **Name** — use this box to enter the name of a clip to search.
   - **Recall ID** — use this box to enter a recall ID to search.
   - **Source** — use this box to enter a location to search for a clip.
   - **ID Min** — use this box to enter or select a minimum clip ID number to search.
   - **ID Max** — use this box to enter or select a maximum clip ID number to search.
   - **Duration Min** — use this box to enter a minimum duration time to search for the clip.
   - **Duration Max** — use this box to enter a maximum duration time to search for the clip.
   - **Project** — use this list to select a project to search for the clip.
   - **Added Min** — use the calendar to select a minimum date to search that the clip was added.
   - **Added Max** — use the calendar to select a maximum date to search that the clip was added.
   - **Expires Min** — use the calendar to select the minimum expiry date to search for the clip.
   - **Expires Max** — use the calendar to select the maximum expiry date to search for the clip.
   - **Never Expires** — select this check box to search for a clip with no expiry date set.
   - **Audio Ch Min** — use this box to enter or select a minimum amount of embedded audio channels to search for the clip.
• **Audio Ch Max** — use this box to enter or select a maximum amount of embedded audio channels to search for the clip.
  > **No Audio** — select this check box to search for a clip with no embedded audio.
• **Reset Filter** — click this button to clear all the fields in the Advanced Search Options.
• **Show all sub clips** — select this check box to display any sub clips of a clip in the Clip Browser list when performing an advanced search.

4. Click **Save default search criteria** ( ) to save the search criteria as a default if necessary.

### Create a Clip Placeholder

A placeholder based on recall ID can be created for a clip to be placed into a rundown. The recall ID is what will link the new MOS object with a current or future clip from the Clip Store.

* Placeholder recall IDs can only be created if the **Clips added to running order should be recalled via their Recall ID** check box is enabled in the **Clip Store** settings in the XPression Gateway. Also, the **Create Placeholder** button will not appear unless all Clip Stores in the workflow have the recall ID option **Allow same Recall ID to be used in different projects** disabled in their Clip Store Managers.

1. Open the **XPression ActiveX Plugin** in the newsroom client.
2. In the XPression ActiveX Plugin, click **Clips**.
   
The **Clips** tab opens.

3. Click **Create Placeholder**.
   
The **Create a clip placeholder** dialog box opens.

4. Use the **Recall ID** box to enter a placeholder recall ID for the MOS object.
5. Use the **Clip Name** box to enter a name for the clip placeholder.
   
   This does not have to match the clip name in the Clip Store. It will populate the field in the MOS object so that the object in the running order displays a meaningful name.

6. Use the **Description** box to enter a brief description for the clip placeholder.
   
   This does not apply to the clip in the Clip Store. It will populate the field in the MOS object so that the object in the running order displays a meaningful description.

7. Click **OK**.

A clip placeholder recall ID is created that can be dragged and dropped into the rundown. However, a clip with the newly created recall ID will need to be ingested for it to function properly.

If a clip exists in the rundown that already uses the recall ID entered, a notice is displayed in the **Create a clip placeholder** dialog box.

If necessary, the existing recall ID can be removed from the existing clip by clicking **Remove Recall ID**.

* Clip placeholders can also be created in the **Edit** tab by clicking the **Create Placeholder** button ( ).
Editing Clips

1. Double-click a clip from the list of clips.
   The clip opens in the Edit tab.

   ![Editing Clips Image]

   The graphic is visible in the preview window and the clip info will be displayed in the Timing and Source Information sections.

   Users can play the clip using the playback controls below the preview window.

   * Fixed Take ID numbers can be assigned to MOS objects. For more information, refer to “Assigning Take IDs to MOS Objects in the XPression ActiveX MOS Plugin” on page 4–20.

2. Edit clip information such as Channel, Layer, and Description as necessary.

3. Click Update Story.
   You can also click and drag from the thumbnail list to the newsroom client interface.

Saving Clips, Selecting Saved Clips, and Exporting to PNG

1. Save your clips, select your saved clips, and export a clip to PNG:
   • To save your clips, refer to the section “Saving Clips” on page 4–16.
   • To select your clips, refer to the section “Selecting Saved Clips” on page 4–17.
   • To export a clip to a PNG file, refer to the section “Exporting a Clip to a PNG File” on page 4–17.

   Saving Clips
   a. Edit a clip in the Edit tab (refer to “Editing Clips” on page 4–16).
b. Click **Save**.

The **Save Item to Folder** dialog box opens.

![Save Item to Folder dialog box]

- Select one of the following save options:
  - **Save as Daily Item** — select this radio button to save the clip to a daily items folder. This will create an items folder for the current date that is subject to the Saved Items settings in the XPression Gateway.
  - **Save to Specific Folder** — select this radio button to save the clip to a specific items folder selected from the **Saved Items** folder structure.

- Use the **Name** box to enter a name for the saved clip.

- Click **OK**.

The **Save Item to Folder** dialog box closes and the clip is saved.

**Selecting Saved Clips**

In the **Browse** tab, select a clip from the **Saved Items** folder structure. These clips need to have been pre-populated with information and saved to a user specified folder.

Clips can also be browsed from the **Rundowns** area. This enables users to select clips used in MOS rundowns that are being monitored by the XPression Gateway.

The clips can be copied to other rundowns or modified from their current state using the **Edit** tab and then added to a rundown.

- Users can create new folders in the Saved Items folder on the XPression Gateway. These folders will appear in the Saved Items folder structure in the XPression ActiveX Plugin.

Clips can also be saved to the daily folders. These folders are auto-generated with the current date and can be set to purge after a specified period of time.

**Exporting a Clip to a PNG File**

The preview image for a clip can be saved as a PNG file.

- In the preview section, right-click on the preview image and select **Export Image** from the shortcut menu.

  A **Save As** file browser opens.

- Use the file browser to locate a folder in which to save the .png file.

- Click **Save**.
Adding a Clip to a MOS Graphic

Clips can be added to a video or image field by copying a clip (Ctrl+C) in the Clips tab and pasting the clip (Ctrl+V) in the video or image field of the Object / Field list of a graphic in the Edit tab, or, by following the procedure below.

1. Open a graphic in the Edit tab that contains a video or image Object / Field.

2. Click the Clips tab.
   The Clips tab opens.
3. Click and drag a clip over the **Edit** tab.
   The **Edit** tab opens.

![Image of XPression user interface](image)

4. Drop the clip onto the video or image **Field / Object**.
   The clip is added to the video or image **Field / Object** selected in the graphic and the clip is displayed in the preview for the graphic.

![Image of XPression user interface](image)

For More Information on...
- Saved Items folders, refer to the section “Setting Up the XPression Gateway” on page 3–2.
- assigning Take IDs to MOS objects, refer to “Assigning Take IDs to MOS Objects in the XPression ActiveX MOS Plugin” on page 4–20.
- XPression Clips, refer to the **XPression Clips User Guide**.
Assigning Take IDs to MOS Objects in the XPression ActiveX MOS Plugin

Take ID numbers can be assigned to graphics and clips in the XPression ActiveX Plugin.

* Take IDs on the Remote Sequencer will not match the Take IDs assigned to the XPression Sequencer items.

1. In **Edit**, right-click inside the top section of the XPression ActiveX Plugin editor and select **Assigned Fixed ID**.
   The **Set Take ID** dialog box opens.

2. Select one of the following:
   - **Automatically Generate Take ID** — select this radio button to automatically assign a Take ID based on the next available Take ID number. This is the default setting.
   - **Fixed Take ID** — select this radio button to manually assign a static Take ID.
     Use the box to enter or select a Take ID number.

* When a fixed Take ID is assigned, no checks or safeguards are performed to prevent duplicate IDs from being used in the rundown. When two rundowns are loaded in the XPression Sequencer with duplicates, one of the Take IDs will automatically be renumbered. It is recommended that when two rundowns use duplicate Take ID numbers that only one rundown be activated at a time.

It is also recommended that all static Take IDs be assigned numbers over 2000 to avoid conflicts between automatically generated Take ID numbers and the static Take ID numbers.

3. Click **OK**.
   The **Set Take ID** dialog box closes.

* When the Take ID is set, you recall and edit the graphic or clip from the rundown and the fixed ID is retained in the rundown only.
Using Spell Check in the XPression ActiveX MOS Plugin

The XPression ActiveX Plugin offers spell check with a local dictionary to which words can be added on a per user basis.

1. In the XPression ActiveX Plugin, click Options > Configuration.
   The XPression ActiveX Plugin Configuration dialog box opens.

2. In the Spell Check section, use the Dictionary list to select a language for the spell check.
3. Click OK.
   The XPression ActiveX Plugin Configuration dialog box closes.
4. Open a graphic in the Edit tab of the XPression ActiveX Plugin.

5. Click inside the Content cell of a text Object / Field.
   Any existing text content is highlighted.
6. Highlight a specific word or enter and highlight a new word to use for the spell check.
7. Click **Spellcheck**.
   - If the word is spelled correctly, or it has already been added to the dictionary, an information window opens that indicates that the spell check is complete.
   - If the word is spelled incorrectly, or has not been added to the dictionary, the **Spell Check** dialog box opens.

![Spell Check Dialog Box]

8. Do one of the following:
   - Click **Ignore** to return to the XPression MOS Plugin without making any changes.
   - Select a word from the **Suggestions** list and click **Change** to correct the spelling.
   - Click **Add** to add the word to the dictionary.
     An information window opens indicating the spell check is complete.

9. Click **OK** to exit the information window.
   Depending on the actions taken in Step 8, the text content is either the same or corrected/changed.
Changing Existing XPression ActiveX MOS Plugin Items to a Template in a Different Project

Existing MOS items can be changed to a template in a different project when the Object / Field names are the same in the templates in both projects. This enables quick and easy transfer of MOS items for templates between multiple projects.

1. Open a project in the XPression ActiveX Plugin.
2. Double click a graphic from the template in the Graphics tab.
3. The selected item opens in the Edit tab.

4. Click Browse (...).
   The Show, Category and Style Selection dialog box opens.

5. In the Style list, select a style. The new style can come from the show and category already selected, or from a different show and category in the Show and Category list.

6. Click OK.
   The Show, Category and Style Selection dialog box closes and the graphics associated with the selected style are available for selection in the Thumbnails / List.
   The Object / Field and Content lists are grayed out, indicating that the previous project’s MOS items have been copied to the clipboard.
7. Press and hold Shift.
8. Double-click an item from the Thumbnails or List.
   The item opens in the editor and any corresponding Object / Field items and their Content are populated from the previous project.
Using Streamline OpenMAM with the XPression ActiveX MOS Plugin

The XPression ActiveX Plugin can be used with Ross Video’s Streamline browser-based media asset management system to seamlessly drag and drop Streamline media assets into the XPression ActiveX Plugin.

The following topics are covered in this section:

- Adding an Integrated Streamline Browser to the XPression ActiveX MOS Plugin
- Opening Streamline in the XPression ActiveX MOS Plugin
- Adding Streamline Assets to a Template

Adding an Integrated Streamline Browser to the XPression ActiveX MOS Plugin

To add an integrated Streamline browser to the XPression ActiveX Plugin, select the Integrated Streamline Browser check box when installing the plugin (it is selected by default):

Streamline can then be accessed within the plugin using the Assets tab.

Opening Streamline in the XPression ActiveX MOS Plugin

1. Open the XPression ActiveX Plugin.
2. Click the **OpenMAM** drop-down list and select a Streamline server. Streamline opens in the **XPression Asset Browser**.

3. Use the **Username** box to enter a login name.

4. Use the **Password** box to enter the password for the username.

5. Click **Login**.

   The Streamline MAM browser opens.

* In the Streamline browser, click **Settings** to set the browser to stay on top and/or close on drop.

**For More Information on...**

- the Streamline MAM system, refer to the Streamline Online Help file.
Adding Streamline Assets to a Template

1. In the XPression ActiveX Plugin, select a template to edit that contains a video shader.  
The template opens in the **Edit** tab.

2. Open Streamline in the **XPression Asset Browser** and select a media asset.

3. Drag and drop the selected media asset onto the **Object / Field** of the selected template.  
The media asset is added to the template.
For More Information on...

• the Streamline MAM system, refer to the Streamline Online Help file.
Using Graphics and Clips in the XPression HTML5 MOS Plugin

The **Graphics** tab in the XPression HTML5 Plugin is used for adding graphics to the story in the Newsroom Computer System (NRCS). The **Clips** tab in the XPression HTML5 Plugin is used for adding clips to the story in the Newsroom Computer System (NRCS) or for adding a clip to a material in a graphic.

🌟 The **Add to Story**, **Update Story**, **OK**, and **Cancel** buttons in the XPression HTML5 Plugin can be conditionally rendered using the **HTTP Server** settings in the **XPression Gateway - Settings** dialog box.

🌟 XPression Clips is optional for XPression and the XPression MOS workflow. If you do not have XPression Clips and are interested in adding it to your workflow, please contact your Ross Video sales representative.

🌟 If using a Project Server and a revision of a project is published in XPression, the XPression HTML5 Plugin will receive a notification of the revision.

The following topics are covered in this section:

- Browsing Graphics
- Opening Graphics
- Saving and Exporting Graphics
- Replacing and Converting Graphics
- Editing Graphics in the XPression HTML5 MOS Plugin
- Selecting Images and Video for Graphics in the XPression HTML5 MOS Plugin
- Applying Underline, Superscript, and Subscript to Text
- Searching, Viewing, and Editing Clips
- Saving and Selecting Saved Clips
- Adding a Clip to an XPression HTML5 MOS Plugin Graphic
- Using Spellcheck
- Adding Resources from Streamline OpenMAM
- Using the Preview Window
Browsing Graphics

The **Browse** tab in the Xpression HTML5 Plugin is used for selecting graphics that have been pre-populated with information and saved to a user-specified folder. You can also delete graphics, add or delete folders, browse the metadata of a graphic and copy a MOS object to a text editor, for troubleshooting purposes.

Graphics can also be browsed from the **Rundowns** area. This enables users to select graphics used in MOS rundowns that are being monitored by the Xpression Gateway. The graphics can be copied to other rundowns or modified from their current state using the **Edit** tab and then added to a rundown.

**To select a graphic:**

1.  In the Xpression HTML5 Plugin, click **Browse**.
   
   The **Browse** tab opens.

2.  In the **Browse** tab, click on a folder in the **Saved Items** folder structure or in the **Rundowns**.

3.  Double-click on a graphic to select it.
   
   The graphic opens in the **Edit** tab.

**To delete a graphic:**

1.  In the Xpression HTML5 Plugin, click **Browse**.

2.  In the **Browse** tab, in the folder structure, browse to the graphic to be deleted.

3.  Select the graphic and click on the options button ( ) in the bottom-right corner of the graphic.

4.  Select **Delete Item**.
   
   The **Delete Item** confirmation dialog opens.

5.  Click **Delete**.
To add a folder:
1. In the XPression HTML5 Plugin, click Browse.
2. Select a folder in the folder structure.
   Folders can be added to the Daily and Persistent folders and to the sub-folders of the User Favorites folder, but not to the top-level User Favorites or Rundowns folders.
3. Click Add (+) at the top of the folder structure.
   The New Folder dialog opens.

   ![New Folder dialog]

4. In the Name field, enter a name for the folder.
5. Click OK.
   The new folder appears as a sub-folder in the structure.

To delete a folder:
1. In the XPression HTML5 Plugin, click Browse.
2. Select a folder in the folder structure.
   Folders can be deleted from the Daily and Persistent folders and from the sub-folders of the User Favorites folder, but not from the top-level User Favorites or Rundowns folders.
3. Click the trash can icon at the top of the folder structure.
   The Delete Folder confirmation dialog opens.

   ![Delete Folder dialog]

4. Click Yes.
   The folder and its contents are deleted from the folder structure.
To browse the metadata of a graphic:

1. In the Graphics or Browse tab, select a graphic and click on the options button ( ) in the bottom-right corner of the graphic.
2. Select Browse Metadata.

The Metadata window opens.

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>metadata</td>
<td>Headshot</td>
</tr>
<tr>
<td>element</td>
<td>Five bullet points</td>
</tr>
</tbody>
</table>
To Copy MOS:

1. In the **Graphics** or **Browse** tab, select a graphic and click on the options button ( ) in the bottom-right corner of the graphic.
2. Select **Copy MOS**.

3. Open a text editor.
4. Right-click and select **Paste**.

   The MOS data for the graphic is copied into the text editor.
Opening Graphics

* Graphics do not have to be opened from a show on a project server, but it is recommended. Graphics can also be opened from an openMAM system.

To open a graphic:

1. Open the XPression HTML5 Plugin in the newsroom client.
2. In the XPression HTML5 Plugin, click Graphics.

   The Graphics tab opens. By default, it will show graphics from the last show that was opened.

3. To select graphics from a different show, click Show. The Show button is not available if there is no project server.

   The Show, Category, and Style window opens.

4. Click the Browse tab and select another show, category, and/or style and click OK.

   Use the search Filter box to enter a show name to quickly retrieve a show instead of scrolling through the list of shows.

5. Click the Collapse all button ( ) in the top-right corner to view the category headings of the graphics and then click a heading to expand the category containing the graphic to add to the story.

   Click the Expand all button ( ) to expand all the category headings of the graphics.

6. Click the Change view type and scale button ( ) in the top-right corner to open the settings:
Select one of the following viewing methods for the graphics browser:

- **Grid** — click this tab to view the graphics in a grid layout.
- **List** — click this tab to view the graphics in a name list.
- **Size bar** — click on the bar and drag it either in the plus direction or the minus direction to adjust the thumbnail size in the Graphics tab.

7. Double-click a graphic to select it and click **Add To Story**.

The graphic is added to the story that is currently open in the **Story Editor Panel** of the NRCS. It appears as a MOS object placeholder in the NRCS and reflects the MOS abstract as configured in the Gateway. It displays the channel, layer, graphic name, etc.

8. Click **Save** in the **Story Editor Panel** to save the graphic in the story.
Saving and Exporting Graphics

To save a graphic to a folder:

1. Click the options button ( ) in the top-right corner of the graphics editor and select Save to folder from the menu.

![Image of Save to folder dialog]

The Save Item to Folder dialog opens.

2. Select one of the following save options:
   - **Save as daily item** — select this radio button to save the graphic to a daily items folder. This will create a folder for the current date. The path, date format, and purge frequency are set in the XPression Gateway > Saved Items panel.
   - **Save to specific folder** — select this radio button to save the graphic to a specific folder selected from the Saved Items folder structure.

3. In the Name field, enter a name for the graphic.
4. Click Save.

   The Save Item to Folder dialog closes and the graphic is saved.

   The folder might have to be refreshed to see the added graphic.
To export a preview image of the graphic:

1. With the graphic open in the Graphic Editor, click the options button ( ▼ ) in the top-right corner of the Editor and select Export preview image to file from the sub-menu.

2. In the Save As window, navigate to a folder to store the image and click Save.

   If the Save As window does not open, it is because this option has not been selected in the web browser settings. To enable the Save As window, edit the web browser settings to allow the file browser to open to select a specific folder. Otherwise, the image will be saved in Downloads.
Replacing and Converting Graphics

To replace graphic templates:
1. Double-click a graphic in the NRCS to select it for editing.
2. From the Graphics tab, select the graphic template to use instead.
3. Click the options button ( ) in the bottom-right corner of the graphic and select Replace Template from the sub-menu.

   The Replace Template confirmation dialog opens.

4. Click OK.
   The original graphic is replaced with the new graphic and all field content is reset.
5. Click Add to Story to save the new graphic.

To convert graphic templates:
1. From the Graphics tab, double-click a graphic to open it.
2. Edit the graphic.
3. To change the template of the graphic, before adding it to the story, click the Graphics tab again and select the graphic to use instead.
4. Click the options button ( ) in the bottom-right corner of the graphic and select Convert Template from the sub-menu.

   The Convert Template confirmation dialog opens.
5. Click **OK**.

The template is replaced, but field content in the original template that corresponds with the new template is maintained.
Editing Graphics in the XPression HTML5 MOS Plugin

The Edit tab in the XPression HTML5 Plugin is used for editing graphics and saving graphics. A preview image of the graphic can also be exported to a file.

To edit a graphic:

1. Double-click the MOS object placeholder representing the graphic in the Story Editor Panel of the NRCS.
   
   The Graphic Editor displays Edit Mode at the top to indicate that the graphic can now be edited.

2. Edit graphic information such as Channel, Layer, Description, In Point, and Duration as necessary.
   
   These settings are only available if they have been set up in the Configuration panel. See “Setting Up the XPression HTML5 MOS Plugin” on page 3–32.

   If using XPression Tessera and a Net ID has been assigned to a channel for a destination region in the Region Mapper, selecting that channel in the HTML5 plugin will include the assigned Net ID.

3. Select the Manual Timing check box to use a manual time instead of the In Point /Duration timing fields of the graphic when under automation control.

   The Manual Timing check box is only available if it has been set up in the Configuration panel. See “Setting Up the XPression HTML5 MOS Plugin” on page 3–32.

   If using an XPression Tessera project, use the Channel list to select a source rather than a channel (for example, Source 1, Source 2, etc.).
4. To assign a Take ID to the graphic, click the options button ( ) in the top-right corner of the Graphic Editor and select Enable take ID input from the sub-menu.

Take ID input can be disabled after enabling by selecting Disable take ID input.

By default, Automatic is selected in the Take ID field, which assigns a Take ID based on the next available Take ID number. For more information, refer to “Assigning Take IDs to MOS Objects in the XPression ActiveX MOS Plugin” on page 4–20.

5. Click a field in the Content column to edit it.

Alternatively, the object can be selected by clicking it in the preview window.

The changes appear in the preview window. Animations from the graphic can be played by using the playback controls below the preview window.

The preview window can be opened in a floating window by clicking the icon in the bottom-right corner. It can then be resized and moved to another screen.

6. To revert to the default values for each field, click the options button ( ) in the top-right corner of the Graphics Editor and select Revert all fields to template values.

7. Click Update Story.
Selecting Images and Video for Graphics in the XPression HTML5 MOS Plugin

1. Open the XPression HTML5 Plugin in the newsroom client.
2. In the XPression HTML5 Plugin, open a graphic template that contains a video shader.
3. Click Add To Story, then double-click the MOS object placeholder representing the graphic in the Story Editor.
4. In the Graphic Editor, in the Object/Field Content section, click in the Content field beside the video shader object.

5. Click Select and browse to the folder containing the graphic or video to use.

6. Click the thumbnail of the graphic or video and then click Select.
7. Make other changes to the template if necessary and click **Update Story**.

8. In the **Story Editor**, click **Save**.
Applying Underline, Superscript, and Subscript to Text

Underline, superscript, and subscript font formats can be applied to the text of graphics opened for editing in the plugin.

The following font tag commands are used to apply or end underlines, superscripts, and subscripts:

- `{U}` — apply underline attribute
- `{/U}` — end underline attribute
- `{SUP}` — apply superscript attribute
- `{/SUP}` — end superscript attribute
- `{SUB}` — apply subscript attribute
- `{/SUB}` — end subscript attribute
- `{}` — end all text attributes

Font tags are not case-sensitive.

To apply underline, superscript, or subscript:

1. In the Graphics tab, double-click a graphic from the Thumbnails, List, or Saved Graphics.
   
The template opens in the Edit tab.

   ![Image of XPression interface showing a graphic with text]

**Underline**

a. Click the Object / Field with the text for the underline and place the cursor in front of the text for applying the underline.
b. Enter {U} to apply the underline.

The underline is applied to all text after the {U} command.

c. To end the underline at a specific location within the text, place the cursor at the end of the text intended to include the underline and enter {].

The underline is applied to the text within the {U} and {] commands.

Superscript

a. Click the Object / Field with the text for the superscript and place the cursor in front of the text for applying the superscript.
b. Enter \{SUP\} to apply the superscript.
The superscript is applied to all text after the \{SUP\} command.

\[ \text{SUP} \]

To end the superscript at a specific location within the text, place the cursor at the end of the text intended to include the superscript and enter \{\}

The superscript is applied to the text within the \{SUP\} and \{\} commands.

\[ \text{SUP} \]

Subscript

a. Click the Object / Field with the text for the subscript and place the cursor in front of the text for applying the superscript.
b. Enter \{SUB\} to apply the subscript.

The subscript is applied to all text after the \{SUB\} command.

![Image](image1.png)

To end the subscript at a specific location within the text, place the cursor at the end of the text intended to include the subscript and enter \}.

The subscript is applied to the text within the \{SUB\} and \} commands.

![Image](image2.png)

**Underline with Superscript or Subscript**

a. Click the **Object / Field** with the text for the underline with superscript or subscript and place the cursor in front of the text for applying the underline with superscript or subscript.
b. Enter \{U\} and \{SUP\} (or \{SUB\}) to apply the underline with superscript (or subscript).

The underline and superscript (or subscript) is applied to all text after the \{U\} and \{SUP\} (or \{SUB\}) commands.

To end the underline after a certain point in the text but keep the superscript (or subscript) for the rest of the text, enter \{/U\} in the location to end the underline.
Conversely, to end the superscript (or subscript) after a certain point in the text but keep the underline for the rest of the text, enter \{/SUP\} (or \{/SUB\}) in the location to end the superscript (or subscript).

Underline, superscript, and subscript are row independent in the **Content** section for the **Object / Field**. A new line removes all tags. Tags must be added manually to every row.
Searching, Viewing, and Editing Clips

1. Open the XPression HTML5 Plugin in the newsroom client.
2. In the XPression HTML5 Plugin, click Clips.
   The Clips tab opens.

   Use the Search box to locate a specific clip if necessary.
   Hovering over a clip thumbnail provides a preview of the clip.

3. Double-click a clip to view it.
   The clip opens in the View tab.

   The clip is visible in the preview window and the clip info will be displayed in the Timing and Source Information sections.
   To preview the clip, click on the preview window. Click the Settings ( ) button in the bottom-right of the preview window to access options to download the clip, adjust the play speed, and use picture-in-picture.

4. Edit clip information such as Channel, Layer, and Description as necessary.
   If using XPression Tessera and a Net ID has been assigned to a channel for a destination region in the Region Mapper, selecting that channel in the HTML5 plugin will include the assigned Net ID.

5. Change the Take ID if necessary:
   a. Click the options button ( ) and select Enable take ID input.
      Disable the Take ID input by selecting Disable take ID input.
   b. In the Take ID box, enter or select a take ID for the clip.

6. Click Add To Story.
Saving and Selecting Saved Clips

1. Save clips and select saved clips:
   - To save your clips, refer to the section “Saving Clips” on page 4–51.
   - To select your clips, refer to the section “Selecting Saved Clips” on page 4–51.

Saving Clips

a. Edit a clip in the View tab (refer to “Searching, Viewing, and Editing Clips” on page 4–50).

b. Click the options button ( ) and select Save to folder.

   The Save Item To Folder dialog box opens.

   ![Save Item To Folder dialog box]

   c. Select one of the following save options:
      - Save as daily item — select this radio button to save the clip to a daily items folder. This will create an items folder for the current date that is subject to the Saved Items settings in the XPression Gateway.
      - Save to specific folder — select this radio button to save the clip to a specific items folder selected from the Saved Items folder structure.

d. Use the Name box to enter a name for the saved clip.

e. Click Save.

   The Save Item to Folder dialog box closes and the clip is saved.

Selecting Saved Clips

In the Browse tab, select a clip from the Saved Items folder structure. These clips need to have been pre-populated with information and saved to a user specified folder.

Clips can also be browsed from the Rundowns area. This enables users to select clips used in MOS rundowns that are being monitored by the XPression Gateway.

The clips can be copied to other rundowns or modified from their current state using the Edit tab and then added to a rundown.

Users can create new folders in the Saved Items folder on the XPression Gateway or through the plugin. These folders will appear in the Saved Items folder structure in the XPression HTML5 Plugin.

Clips can also be saved to the daily folders. These folders are auto-generated with the current date and can be set to purge after a specified period of time.
Adding a Clip to an XPression HTML5 MOS Plugin Graphic

1. Open a graphic in the **Edit** tab that contains a video or image **Object / Field**.

2. Click the **Clips** tab.
   
The **Clips** tab opens.

3. Click and drag a clip over the **Edit** tab.
   
The **Edit** tab opens.
4. Drop the clip onto the video or image Field / Object.

The clip is added to the video or image Field / Object selected in the graphic and the clip is displayed in the preview for the graphic.

For More Information on...
- Saved Items folders, refer to the section “Setting Up the XPression Gateway” on page 3–2.
- XPression Clips, refer to the XPression Clips User Guide.
Using Spellcheck

The XPression HTML5 Plugin offers spell check with a local dictionary to which words can be added on a per user basis. The dictionary used is set up in the Configuration panel. See “Setting Up the XPression HTML5 MOS Plugin” on page 3–32.

To spell check a graphic:

1. Select a graphic either from the Story Editor or from the Graphics tab.
2. Click Spellcheck.

   The Spellcheck dialog opens. The first word in the graphic that is incorrectly spelled or not in the dictionary appears in the Not in dictionary field.

3. Do one of the following:
   - Click Ignore to ignore that word without making any changes.
   - Click Add to Dictionary to add the word to the dictionary.
   - Select a word from the Suggestions list and click Change to correct the spelling.

   An information window opens indicating that the spell check is complete once all the text fields have been spell checked.

4. Click OK.

   Depending on the actions taken in Step 3, the text content is either the same or corrected/changed.
Adding Resources from Streamline OpenMAM

An integrated Streamline openMAM browser can be used in the XPression HTML5 Plugin for adding images and video to graphics in the XPression HTML5 Plugin. For information about configuring an asset management system, see “Adding and Configuring an OpenMAM Server” on page 7–2.

Images and video can be dragged and dropped directly from Streamline openMAM into the XPression HTML5 Plugin.

Launching an OpenMAM server while in iNews opens the iNews web browser as it supports drag-and-drop functionality.

To drag and drop an image or video from Streamline into the XPression HTML5 Plugin:

1. Open the Xpression HTML5 Plugin in the newsroom client.
2. Click Add To Story, then double-click the MOS object placeholder representing the graphic in the Story Editor.
3. Do one of the following:
   • Access Streamline from the Streamline Tab.
   • Access Streamline from the Streamline button in the Edit Tab.

Streamline Tab
a. In the Xpression HTML5 Plugin, click the OpenMAM tab.
   Streamline opens in a new window. If using iNEWS, open Streamline manually.

Edit Tab
a. In the Graphic Editor, in the Object/Field Content section, click in the Content field beside the video shader object.

The Streamline icon ( ) with a Select button is displayed.
b. Click the Streamline icon ( ).
Streamline opens in a new window.

4. Log in to Streamline and browse to the image or video to use.
5. Select the image or video.
6. Drag and drop the image or video into the image field in the Object / Field section of the Graphic Editor in the XPression HTML5 Plugin.

7. Click Update Story.
8. In the Story Editor, click Save.
Using the Preview Window

Use the Preview window to preview the graphic that is open in the Edit tab.

- **Play** — click this button to play the preview of the graphic.
- **Stop** — click this button to stop the preview of the graphic.
- **Pre-load all frames** — click this button to pre-load all preview frames of the graphic to avoid displaying blank preview images when scrubbing over the preview timeline. The button appears red when frames are not pre-loaded and changes to green after being clicked and all frames have been successfully loaded.
- **Jump to preview frame** — click this button to move the preview timeline of the graphic to the preview frame.
- **Scrub bar** — click and hold the scrub bar and move left or right along the timeline to scroll through the preview of the graphic or click inside the timeline to move the preview and scrub bar to the selected point inside the timeline.
- **Open in floating window** — click this button to open the Preview window in a separate floating window. To close the floating Preview window, click the **Close floating window** button ( ).
NLE Workflow Setup

Overview

The XPression Gateway serves as a communication hub between the XPression NLE plugins, XPression Template Builder, or Edius plugins installed on NLE workstations running supported NLE software and the Bluebox Offline Engines rendering XPression templates. These renderings are transported over TCP/IP to be applied to the users editing timeline.

Before you start using the XPression NLE workflow, the various components and settings need to be configured for operability.

The XPression NLE Plugin is supported in Adobe Premier Pro 2019.

The following topics are discussed in this section:

• Required Components
• Optional Components
• Setting Up the XPression Gateway for the XPression NLE Plugin and Edius Plugin
• Setting Up the XPression Gateway for the XPression Template Builder

Required Components

The following is a list of the required components for the XPression NLE workflow:

• XPression Gateway
• Studio, Prime, or BlueBox OFL (preview engine)
• XPression NLE Plugin, XPression Template Builder, or Edius Plugin

◆ The XPression Edius Plugin requires the Microsoft Visual Studio 2013 redistributable in order to install. This is automatically done during installation, however, an internet connection is required to connect to the Microsoft website during the install.

Optional Components

The following items are optional for the XPression NLE workflow:

• XPression Project Server
• Supported MAM system

For More Information on...

• The XPression Gateway user interface, refer to the section “The XPression Gateway User Interface” on page 2–2.
• The XPression NLE Plugin and XPression Edius Plugin user interface, refer to the section “The XPression NLE Plugin and Edius Plugin User Interface - Templates” on page 2–12 and “The XPression NLE Plugin and Edius Plugin User Interface - Edit Mode” on page 2–13.
Setting Up the XPression Gateway for the XPression NLE Plugin and Edius Plugin

The following steps explain the XPression Gateway configuration for the NLE workflow when using the NLE Plugin or Edius Plugin.

* If you have any Citrix programs installed, such as GoToMeeting, ensure that the DNE LightWeight Filter is disabled in the Local Area Connection Properties window of any machine that is connected to the XPression Gateway, including the XPression Gateway itself.

1. Open the XPression Gateway.
2. Click Gateway > Settings.
   
   The XPression Gateway - Settings dialog box opens.

3. Click Client Plugins to configure the client plugin settings.
   
   The Client Plugins configuration area opens.
Client Plugins

a. In the **Global Settings** section, select the **Enable Remote Plugin Updates** check box to prompt users of the XPression NLE Plugin or Edius Plugin to update the plugin if the version does not match the version of the XPression Gateway.

b. Select the **Show Template List on Edit Mode tab** check box to allow users of the XPression NLE Plugin or Edius Plugin to browse templates while the plugin is in edit mode.

4. Click **Preview & Offline Engines** to configure the preview engines.

The **Preview & Offline Engines** configuration area opens.

![Preview & Offline Engines Configuration](image)

**Preview & Offline Engines**

* A preview engine needs to be added for every XPression Bluebox OFL system being used for motion and still preview in the XPression NLE Plugin and Edius Plugin.

a. In the **Preview & Offline Render Engines** section, click **Add**.

The **XPression Preview Engine** dialog box opens.

![XPression Preview Engine Dialog](image)

b. In the **Engine ID** section, use the **Name** box to enter an ID for the engine.

c. Use the **Description** box to enter a brief descriptive detail for the engine.

d. In the **Remote XPression Engine** section, use the **Host** box to enter the IP address of the XPression system for the preview engine.

e. Use the **Port** box to enter or select the port number for the XPression system.
f. In the **Options** section, select the **Reserve engine for NLE client rendering** check box to send preview requests from the NLE to any OFL engine(s) reserved for NLE use.

Any MOS plugin requests will be sent to the non-reserved OFL engine(s). If all OFL engines in the Gateway have this check box enabled, MOS plugin requests will go to any of the OFL engines. If none of the OFL engines have this check box enabled, previews from NLE clients will be assigned to any one of the OFL engines.

g. Click **OK**.

The **XPression Preview Engine** dialog box closes and the preview engine is added to the **Preview & Offline Render Engines** list.

5. Click **Project Server** to configure the XPression Project Server settings.

The **Project Server** configuration area opens.

! The XPression Project Server is optional for XPression NLE workflow. If you do not have the Project Server, proceed to step 6. If you are interested in adding the XPression Project Server to your workflow, please contact your Ross Video sales representative.

**Project Server**

The XPression Project Server offers centralized storage and creative collaboration within a facility or across an enterprise. Designers and operators can access any XPression project from any XPression workstation, share projects while working locally, then re-publish to the server.

! The login and password must be configured in the Project Server before you can connect the XPression Gateway.

a. In the **Project Server** section, select the **Enabled** check box to use the Project Server.

b. Use the **Host** box to enter the IP address of the Project Server.

c. Use the **Port** box to enter or select the port number for the Project Server.

d. In the **Login** box, enter your username for the Project Server.

e. In the **Password** box, enter the password for your Project Server login.
6. Click **Saved Items** to select and configure a graphics folder for the XPression Gateway. The **Saved Items** configuration area opens.

![Saved Items configuration area](image1)

**Saved Items**

Saved Items are templates that are saved to the gateway and edited via the XPression NLE Plugin and Edius Plugin. These pre-populated templates can be saved in user configured folders that can be stored permanently, or in the daily graphics folder that can be automatically purged after a user defined duration.

a. In the **Database** section, use the **Path** box to enter a file path or click the **Browse (...)** button to open a file browser to select a permanent or daily graphics folder.

b. Use the **Date format** list to select an order for the date that the graphic was saved. The options are:
   - **dd-mm-yyyy** — Day-Month-Year (for example, 15-07-2015)
   - **mm-dd-yyyy** — Month-Day-Year (for example, 07-15-2015)
   - **yyyy-mm-dd** — Year-Month-Day (for example, 2015-07-15)

c. Use the **Purge daily templates after X days** box to enter or select an amount of days before the daily graphics folder is automatically purged. Set to 0 for no purging.

7. Click **OpenMAM** to configure a supported asset management system. The **OpenMAM** configuration area opens.

![OpenMAM configuration area](image2)
OpenMAM is optional for XPression NLE workflow. If you are not using MediaBeacon 3.0, MediaBeacon 5.0, Streamline, or XPression Maps asset management systems, proceed to step 9.

If you are configuring an OpenMAM driver, please refer to the section “Adding and Configuring an OpenMAM Server” on page 7–2 for information on configuring the MediaBeacon 3.0, MediaBeacon 5.0, Streamline, or XPression Maps connections.

8. Click Reserved Client Slots to reserve IP slots for NLE clients.

The Reserved Client Slots configuration area opens.

Reserved Client Slots

Reserved Client Slots are a list of NLE client IP addresses that can always connect. If the reserved client list is less than the maximum number of allowed clients, then the extra slots can be connected by anyone but only as many as are remaining, even if no reserved IPs are being used. Reserved IPs will always connect.

a. In the NLE section, click Add.

The Reserved Slot dialog box opens.

b. In the Slot section, use the IP Address box to enter an IP address to reserve for the floating NLE client.

c. Use the Description box to enter a brief descriptive detail for the IP address reservation.

d. Click OK.

The Reserved Slot dialog box closes and the IP address is added to the NLE reserved client list.

9. Click OK.

The XPression Gateway - Settings dialog box closes and the settings are applied to the XPression Gateway.

If access to a reserved IP address is attempted, or if the maximum amount of licenses are in use, the following warning message is sent by the XPression Gateway:
For More Information on...
• XPression Project Server, refer to the *XPression Project Server User Guide*. 
Setting Up the XPression Gateway for the XPression Template Builder

The following steps explain the XPression Gateway configuration for the XPression Template Builder in an NLE workflow.

1. Open the XPression Gateway.
2. Click Gateway > Settings.
   The XPression Gateway - Settings dialog box opens.
3. Click Preview & Offline Engines to configure the preview engines.
   The Preview & Offline Engines configuration area opens.

Preview & Offline Engines

A preview engine needs to be added for every XPression Bluebox OFL system being used for motion and still preview in the XPression Template Builder.

a. In the Preview & Offline Render Engines section, click Add.
   The XPression Preview Engine dialog box opens.

b. In the Engine ID section, use the Name box to enter an ID for the engine.

c. Use the Description box to enter a brief descriptive detail for the engine.

d. In the Remote XPression Engine section, use the Host box to enter the IP address of the XPression system for the preview engine.

e. Use the Port box to enter or select the port number for the XPression system.
f. Click OK. The XPression Preview Engine dialog box closes and the preview engine is added to the Preview & Offline Render Engines list.

4. Click Project Server to configure the XPression Project Server settings.

The Project Server configuration area opens.

* The XPression Project Server is optional for XPression Template Builder workflow. If you do not have the Project Server, proceed to step 5. If you are interested in adding the XPression Project Server to your workflow, please contact your Ross Video sales representative.

Project Server

The XPression Project Server offers centralized storage and creative collaboration within a facility or across an enterprise. Designers and operators can access any XPression project from any XPression workstation, share projects while working locally, then re-publish to the server.

* The login and password must be configured in the Project Server before you can connect the XPression Gateway.

a. In the Project Server section, select the Enabled check box to use the Project Server.

b. Use the Host box to enter the IP address of the Project Server.

c. Use the Port box to enter or select the port number for the Project Server.

d. In the Login box, enter your username for the Project Server.

e. In the Password box, enter the password for your Project Server login.
5. Click **Saved Graphics** to select and configure a graphics folder for the XPression Gateway.

The **Saved Graphics** configuration area opens.

![Saved Graphics Configuration](image)

**Saved Graphics**

Saved Graphics are templates that are saved to the gateway and edited via XPression Template Builder. These prepopulated templates can be saved in user configured folders that can be stored permanently, or in the daily graphics folder that can be automatically purged after a user defined duration.

a. In the **Database** section, use the **Path** box to enter a file path or click the **Browse (…)** button to open a file browser to select a permanent or daily graphics folder.

b. Use the **Purge daily templates after X days** box to enter or select an amount of days before the daily graphics folder is automatically purged. Set to 0 for no purging.

6. Click **OpenMAM** to configure a supported asset management system.

OpenMAM is optional for XPression Template Builder. If you are not using MediaBeacon 3.0 or MediaBeacon 5.0 asset management systems, proceed to step 7.

If you are configuring an OpenMAM driver, please refer to the section “Adding and Configuring an OpenMAM Server” on page 7–2 for information on configuring the MediaBeacon 3.0 and MediaBeacon 5.0 connections.

7. Click **OK**.

The **XPression Gateway - Settings** dialog box closes and the settings are applied to the XPression Gateway.

For More Information on...

* XPression Project Server, refer to the **XPression Project Server User Guide**.
NLE Workflow Operation

This section describes how to use the templates and saved graphics in the XPression NLE Plugin and Edius Plugin.

The following topics are discussed in this section:

- Using Graphics in the XPression NLE Plugin, XPression Template Builder, and Edius Plugin
- Using Clips in the XPression NLE Plugin, XPression Template Builder, and Edius Plugin
- Assigning Take IDs to Objects
- Using Spell Check in the XPression NLE Plugin, XPression Template Builder, and Edius Plugin

For More Information on...

Using Graphics in the XPression NLE Plugin, XPression Template Builder, and Edius Plugin

The Graphics tab is used for adding graphics to the story in the NRCS.

1. Open the XPression NLE Plugin, XPression Template Builder, or Edius Plugin in the newsroom client.
2. Click Graphics.
   The Graphics tab opens.

3. Select one of the following viewing methods for the graphics browser:
   - Thumbnails — click this tab to view the graphics in a thumbnail layout.
   - List — click this tab to view the graphics in a name list.

4. Select and edit your graphics:
   - To select graphics from the Project Server, refer to the section “Browsing Graphics From Project Server” on page 6–3.
   - To select graphics without Project Server, refer to the section “Browsing Graphics Without Project Server” on page 6–3.
   - To edit graphics, refer to the section “Editing Graphics” on page 6–4.
   - To browse the metadata of a graphic or template, refer to the section “Browsing the Metadata of a Graphic or Template” on page 6–5.
Browsing Graphics From Project Server

If a revision of a project is published in the NLE Plugin, Template Builder, and Edius Plugin will receive a notification of the revision.

a. In the Graphics tab, click Templates.

b. Click Browse (…).

The Show, Category and Style Selection dialog box opens.

c. Select a show and category from the Show and Category tree.

d. In the Style list, select a style.

e. Click OK.

The Show, Category and Style Selection dialog box closes and the graphics associated with the selected style are available for selection in the Thumbnails / List.

Use the Filter box to enter a graphic name or keyword to search for specific graphics. The filter also searches the metadata of graphics when available.

f. Double-click a graphic from the Thumbnails or List.

Browsing Graphics Without Project Server

In the Graphics tab, browse graphics in the Thumbnails / List. Use the Filter box to enter a graphic name or keyword to search for specific graphics. The filter also searches the metadata of graphics when available.

The available graphics are dictated by what has been loaded on the preview engine. This must be done manually.
## Editing Graphics

- Modifying the text template data fields of MOS items in XPression prevents the changes from being overwritten by new updates in the MOS Plugin.

  a. In the **Graphics** tab, double-click a graphic from the **Thumbnails**, **List**, or **Saved Graphics**.

     The template opens in the **Edit** tab.

     The graphic is visible in the preview window and the published fields will be displayed in the **Object / Field** and **Content** lists. When using static text, if **Enable User Input Controls** is selected in the **Data Source** tab of the **Object Inspector** in XPression, the **Content** cell will contain a list of available static text values.

     Users can play animations from the graphic using the playback controls below the preview window.

     Use the **Filter** box to enter a graphic name or keyword to search for specific graphics. The filter also searches the metadata of graphics when available.

     Fixed Take ID numbers can be assigned. For more information, refer to “Assigning Take IDs to Objects” on page 6–12.

  b. Edit the **Object / Field** information in the **Content** column. The changes appear in the preview.

     The information can also be selected by clicking on the object in the preview window.

     Clear a field by right-clicking it and selecting **Clear Field** from the shortcut menu; or revert to the template values by selecting **Revert all fields to template values**.

  c. Click **Save**.

     You can also click and drag from the preview window to the newsroom client interface.

- When using the NLE Plugin or Edius Plugin, you can open a graphic from the story in the NRCS to edit or update by double-clicking it. The graphic will open in the **Edit** tab. Once edited/updated, click **Save** to apply the changes.
Browsing the Metadata of a Graphic or Template

a. In the Graphics or Edit tab, right-click on a graphic or template from the Thumbnails, List, or Saved Graphics.

b. Select Browse Metadata.

The Browse Metadata window opens.

5. Save and select your saved graphics:
   • To save your graphics, refer to the section “Saving Graphics” on page 6–5.
   • To select your graphics, refer to the section “Selecting Saved Graphics” on page 6–6.

Saving Graphics


b. Click Save.

The Save Item to Folder dialog box opens.

c. Select one of the following save options:
   • Save as Daily Item — select this radio button to save the graphic to a daily items folder. This will create an items folder for the current date that is subject to the Saved Items settings in the XPression Gateway.
   • Save to Specific Folder — select this radio button to save the graphic to a specific folder selected from the Saved Items folder structure.

d. Click OK.

The Save Item to Folder dialog box closes and the graphic is saved.
Selecting Saved Graphics

In the **Browse** tab, select a graphic from the **Saved Items** folder structure. These graphics need to have been pre-populated with information and saved to a user specified folder.

Graphics can also be browsed from the **Rundowns** area. This enables users to select clips used in rundowns that are being monitored by the XPression Gateway. The graphics can be copied to other rundowns or modified from their current state using the **Edit** tab and then added to a rundown.

* Users can create new folders in the Saved Items folder on the XPression Gateway. These folders will appear in the Saved Items folder structure in the NLE Plugin, Template Builder, and Edius Plugin.

Graphics can also be saved to the daily folders. These folders are auto-generated with the current date and can be set to purge after a specified period of time.

**Exporting a Graphic to a PNG File**

The preview image for a graphic can be saved as a PNG file.

a. In the preview section, right-click on the preview image and select **Export Image** from the shortcut menu.

   A **Save As** file browser opens.

b. Use the file browser to locate a folder in which to save the .png file.

c. Click **Save**.

**Utilizing Saved Graphics in Template Builder for Playout**

Saved graphics and clips can be dragged and dropped into the **Sequencer** in XPression to generate take items for playback.

* If using Project Server, this drag and drop will initiate deployment of the required project to the playout engine. If not using Project Server, take items created by drag and drop must be manually synchronized with the correct project.

* Copying and pasting graphics only works from Template Builder to a newsroom system. It does not function like the Template Builder drag and drop feature.

**For More Information on...**

- Saved Items folders, refer to the section “**Setting Up the XPression Gateway for the XPression NLE Plugin and Edius Plugin**” on page 5–2.
- assigning Take IDs, refer to “**Assigning Take IDs to Objects**” on page 6–12.
- creating user input controls for static text objects, refer to the **XPression Help File** in XPression.
- XPression Project Server, refer to the **XPression Project Server User Guide**.
Using Clips in the XPression NLE Plugin, XPression Template Builder, and Edius Plugin

XPression Clips is optional for XPression and the XPression NLE workflow. If you do not have XPression Clips and are interested in adding it to your workflow, please contact your Ross Video sales representative.

If using a Project Server and a revision of a project is published in the NLE Plugin, Template Builder, and Edius Plugin will receive a notification of the revision.

The Clips tab is used for adding clips to a template. The Clips tab in the NLE Plugin and Edius Plugin can also be used for adding clips to the story in the NRCS.

Selecting and Searching Clips

1. Open the XPression NLE Plugin, XPression Template Builder, or Edius Plugin.
2. Click Clips.

   The Clips tab opens.

3. Click on a clip to select it or use the Advanced Search Options to locate a specific clip:

   Advanced Search Options

   Click the Show/Hide advanced search options ( ) buttons to open and close the advanced search options.
   • Name — use this box to enter the name of a clip to search.
   • Recall ID — use this box to enter a recall ID to search.
   • Source — use this box to enter a location to search for a clip.
   • ID Min — use this box to enter or select a minimum clip ID number to search.
   • ID Max — use this box to enter or select a maximum clip ID number to search.
   • Duration Min — use this box to enter a minimum duration time to search for the clip.
   • Duration Max — use this box to enter a maximum duration time to search for the clip.
   • Project — use this list to select a project to search for the clip.
   • Added Min — use the calendar to select a minimum date to search that the clip was added.
   • Added Max — use the calendar to select a maximum date to search that the clip was added.
   • Expires Min — use the calendar to select the minimum expiry date to search for the clip.
   • Expires Max — use the calendar to select the maximum expiry date to search for the clip.
   • Never Expires — select this check box to search for a clip with no expiry date set.
• **Audio Ch Min** — use this box to enter or select a minimum amount of embedded audio channels to search for the clip.

• **Audio Ch Max** — use this box to enter or select a maximum amount of embedded audio channels to search for the clip.

  • **No Audio** — select this check box to search for a clip with no embedded audio.

• **Reset Filter** — click this button to clear all the fields in the Advanced Search Options.

• **Show all sub clips** — select this check box to display any sub clips of a clip in the Clip Browser list when performing an advanced search.

---

**Editing Clips**

1. Double-click a clip from the list of clips.

   The clip opens in the **Edit** tab.

   ![Image of clip open in Edit tab]

   The graphic is visible in the preview window and the clip info will be displayed in the **Timing** and **Source Information** sections.

   Users can play the clip using the playback controls below the preview window.

   • Fixed Take ID numbers can be assigned. For more information, refer to “Assigning Take IDs to Objects” on page 6–12.

2. Use the **Description** box to enter a brief descriptor as necessary.

3. Click **Save**.

   You can also click and drag from the thumbnail list to the newsroom client interface if using the NLE Plugin or Edius Plugin.

---

**Saving Clips, Selecting Saved Clips, and Exporting to PNG**

1. Save your clips, select your saved clips, and export a clip to PNG:

   • To save your clips, refer to the section “**Saving Clips**” on page 6–8.

   • To select your clips, refer to the section “**Selecting Saved Clips**” on page 6–9.

   • To export a clip to a PNG file, refer to the section “**Exporting a Clip to a PNG File**” on page 6–9.

   **Saving Clips**

   a. Edit a clip in the **Edit** tab (refer to “**Editing Clips**” on page 6–8).
b. Click **Save**.

The **Save Item to Folder** dialog box opens.

c. Select one of the following save options:

- **Save as Daily Item** — select this radio button to save the clip to a daily items folder. This will create an items folder for the current date that is subject to the Saved Items settings in the XPression Gateway.
- **Save to Specific Folder** — select this radio button to save the clip to a specific items folder selected from the **Saved Items** folder structure.

d. Use the **Name** box to enter a name for the saved clip.

e. Click **OK**.

The **Save Item to Folder** dialog box closes and the clip is saved.

Selecting Saved Clips

In the **Browse** tab, select a clip from the **Saved Items** folder structure. These clips need to have been pre-populated with information and saved to a user specified folder.

Clips can also be browsed from the **Rundowns** area. This enables users to select clips used in rundowns that are being monitored by the XPression Gateway.

The clips can be copied to other rundowns or modified from their current state using the **Edit** tab and then added to a rundown.

Users can create new folders in the **Saved Items** folder on the XPression Gateway. These folders will appear in the Saved Items folder structure in the NLE Plugin, Template Builder, and Edius Plugin.

Clips can also be saved to the daily folders. These folders are auto-generated with the current date and can be set to purge after a specified period of time.

Exporting a Clip to a PNG File

The preview image for a clip can be saved as a PNG file.

a. In the preview section, right-click on the preview image and select **Export Image** from the shortcut menu.

A **Save As** file browser opens.

b. Use the file browser to locate a folder in which to save the .png file.

a. Click **Save**.
Adding a Clip to a Graphic

1. Open a graphic in the Edit tab that contains a video or image Object / Field.

2. Click the Clips tab.

The Clips tab opens.
3. Click and drag a clip over the Edit tab. The Edit tab opens.

4. Drop the clip onto the video or image Field / Object. The clip is added to the video or image Field / Object selected in the graphic and the clip is displayed in the preview for the graphic.

For More Information on...
• Saved Items folders, refer to the section “Setting Up the XPression Gateway for the XPression NLE Plugin and Edius Plugin” on page 5–2.
• assigning Take IDs, refer to “Assigning Take IDs to Objects” on page 6–12.
• XPression Clips, refer to the XPression Clips User Guide.
Assigning Take IDs to Objects

Take ID numbers can be assigned to graphics and clips in the XPression NLE Plugin, XPression Template Builder, and Edius Plugin.

Take IDs on the Remote Sequencer will not match the Take IDs assigned to the XPression Sequencer items.

1. In Edit, right-click inside the top section of the editor and select Assigned Fixed ID.

   The Set Take ID dialog box opens.

2. Select one of the following:
   - **Automatically Generate Take ID** — select this radio button to automatically assign a Take ID based on the next available Take ID number. This is the default setting.
   - **Fixed Take ID** — select this radio button to manually assign a static Take ID.
     
     Use the box to enter or select a Take ID number.

   When a fixed Take ID is assigned, no checks or safeguards are performed to prevent duplicate IDs from being used in the rundown. When two rundowns are loaded in the XPression Sequencer with duplicates, one of the Take IDs will automatically be renumbered. It is recommended that when two rundowns use duplicate Take ID numbers that only one rundown be activated at a time.

   It is also recommended that all static Take IDs be assigned numbers over 2000 to avoid conflicts between automatically generated Take ID numbers and the static Take ID numbers.

3. Click OK.

   The Set Take ID dialog box closes.

   When the Take ID is set, you recall and edit the graphic or clip from the rundown and the fixed ID is retained in the rundown only.
Using Spell Check in the XPression NLE Plugin, XPression Template Builder, and Edius Plugin

The NLE Plugin, Template Builder, and Edius Plugin offer spell check with a local dictionary to which words can be added on a per user basis.

1. Click **Options > Configuration**.

   The respective **Configuration** dialog box opens for the NLE Plugin, Template Builder, or Edius Plugin.

   ![Configuration dialog box](image)

2. In the **Spell Check** section, use the **Dictionary** list to select a language for the spell check.

3. Click **OK**.

   The **Configuration** dialog box closes.

4. Open a graphic in the **Edit** tab of the XPression MOS Plugin.

   ![Edit tab](image)

5. Click inside the **Content** cell of a text **Object / Field**.

   Any existing text content is highlighted.

6. Highlight a specific word or enter and highlight a new word to use for the spell check.
7. Click **Spellcheck**.
   - If the word is spelled correctly, or it has already been added to the dictionary, an information window opens that indicates that the spell check is complete.
   - If the word is spelled incorrectly, or has not been added to the dictionary, the **Spell Check** dialog box opens.

![Spell Check dialog box](image)

8. Do one of the following:
   - Click **Ignore** to return to the Edit tab without making any changes.
   - Select a word from the **Suggestions** list and click **Change** to correct the spelling.
   - Click **Add** to add the word to the dictionary.
     An information window opens indicating the spell check is complete.

9. Click **OK** to exit the information window.
   Depending on the actions taken in Step 8, the text content is either the same or corrected/changed.
OpenMAM

OpenMAM is optional for XPression MOS and NLE workflows.

This section describes how to setup OpenMAM for the XPression MOS and NLE workflows.

The following topics are discussed in this section:

- Adding and Configuring an OpenMAM Server
- Using OpenMAM Filter Strings With Streamline
Adding and Configuring an OpenMAM Server

ाई OpenMAM is optional for XPression MOS and NLE workflows.

This section explains the procedure for adding an OpenMAM server for the XPression MOS and NLE workflows and provides instructions for configuring each driver.

1. In the XPression Gateway, click Gateway > Settings.
   The XPression Gateway - Settings dialog box opens.
2. Click OpenMAM to configure a supported asset management system.
   The OpenMAM section opens.

3. In the OpenMAM Servers section, click Add.
   The Add OpenMAM Server dialog box opens.

4. In the Select OpenMAM Driver section, select an OpenMAM driver. The available options are:
   • Dali Driver
   • XPression Maps
   • MediaBeacon (v3.0) Driver
   • MediaBeacon (v5.0+) Driver
   • Streamline Driver
5. Click OK.
   The driver configuration dialog box of the selected asset management system opens.
Dali Driver

a. In the **Server ID** section, use the **ID** box to assign the Dali Driver server ID. Make a note of this ID because it will be the same for any other XPression device connecting to the Dali Driver server.
b. Use the **Description** box to enter a brief descriptive detail for the server.
c. In the **Connection Settings** section, use the **Server URL** box to enter the URL of the Dali Driver server.
d. Use the **Path to Dali Plugin** box to enter the file path for the Dali Driver Web Client executable.
e. Click the **Local Cache** tab.

   The **Local Cache** tab is displayed.

f. In the **Local Asset Cache Settings** section, select the **Retrieve assets from a local Asset Cache Server** check box to retrieve assets from a cache server.
g. Use the **Path** box to enter the location of the local server or click **Browse (...)** to select a location.
h. Click **OK**.

   The **Dali Server Configuration** dialog box closes and the server is added to OpenMAM Servers list.

XPression Maps

a. In the **Server ID** section, use the **ID** box to assign the XPression Maps server ID. Make a note of this ID because it will be the same for any other XPression device connecting to the XPression Maps server.
b. Use the **Description** box to enter a brief descriptive detail for the server.
c. In the **Connection Settings** section, use the **Server URL** box to enter the URL of the XPression Maps server.
d. Use the **Plugin App** box to enter the file path for the XPression Maps Web Client executable.

e. Click **OK**.

The **XPression Maps Server** dialog box closes and the server is added to OpenMAM Servers list.

**MediaBeacon (v3.0) Driver**

![MediaBeacon (v3.0) Driver Configuration dialog box](image)

- a. In the Server Info section, use the **ID** box to assign the MediaBeacon server ID. Make a note of this ID because it will be the same for any other XPression device connecting to the MediaBeacon server.

- b. Use the **Description** box to enter a brief descriptive detail for the server.

- c. In the **Connection Settings** section of the **MediaBeacon Driver Configuration** dialog box, use the **Host** box to enter the IP address of the MediaBeacon server.

- d. Use the **Port** box to enter or select the port number for the MediaBeacon server.

- e. In the **Login** box, enter the username configured on the MediaBeacon server.

- f. In the **Password** box, enter the password for the MediaBeacon username.

- g. Click **OK**.

The **MediaBeacon Driver Configuration** dialog box closes and the server is added to OpenMAM Servers list.

**MediaBeacon (v5.0+) Driver**

To connect the XPression Gateway to a MediaBeacon 5.0+ server, you must first register the MediaBeacon plugin on the MediaBeacon server.

- ![MediaBeacon (v5.0+) Driver Configuration dialog box](image)

  a. In the **Connection Settings** section of the **Configuration** tab, use the **Plugin ID** box to enter or select the plugin identification number.

  b. In the **Server Settings** section, use the **ID** box to assign the MediaBeacon server ID. Make a note of this ID because it will be the same for any other XPression device connecting to the MediaBeacon server.

  c. Use the **Description** box to enter a brief descriptive detail for the server.

  d. Use the **IP Address** box to enter the IP address of the MediaBeacon server.

  e. Use the **Port** box to enter or select the port number for the MediaBeacon server. This port number must be set to 80.
f. If this is the first device you are connecting to the server, click **Register Plugin** to be redirected to the MediaBeacon login screen in Google Chrome. Enter the login information.

Once the login information has been entered, you should see a message indicating the plugin has been successfully registered.

* The plugin only has to be registered once. When configuring other engines, use the same plugin ID.

g. Click the **Local Cache** tab.

The **Local Cache** tab is displayed.

h. In the **Local Asset Cache Settings** section, select the **Retrieve assets from a local Asset Cache Server** to retrieve assets from a cache server.

Use the **Path** box to enter the location of the local server or click **Browse (...)** to select a location.

i. Click **OK**.

The **MediaBeacon Driver Configuration** dialog box closes and the server is added to OpenMAM Servers list.

**Streamline Driver**

a. In the **Server ID** section, use the **MOS ID** box to assign the MOS ID of the Streamline server.

b. Use the **Description** box to enter a brief descriptive detail for the server.

c. In the **Connection Settings** section, use the **Server URL** box to enter the URL of the Streamline server.

d. Use the **API Key** box to enter the API key of the Streamline user.

e. In the **Miscellaneous Settings** section, select the **Allow use of unapproved assets** check box if allowing the use of unapproved assets.

f. Use the **Streamline Version** menu to select the version of Streamline software being used in the workflow.
g. Click the **Local Cache** tab.

The **Local Cache** tab is displayed.

![Local Cache Tab](image)

h. In the **Local Asset Cache Settings** section, select the **Retrieve assets from a local Asset Cache Server** to retrieve assets from a cache server.

Use the **Path** box to enter the location of the local server or click **Browse (…)** to select a location.

i. Click **OK**.

The **Streamline Server** dialog box closes and the server is added to OpenMAM Servers list.

6. In the **Client Plugins** section, select the **Disable local asset browser** check box to disable browsing of the local cache.

7. Click **OK**.

The **XPression Gateway - Settings** dialog box closes.

For More Information on...

- configuring the Parse roStorySend messages in the XPression Gateway settings, refer to “Setting Up the **XPression Gateway**” on page 3–2.
Using OpenMAM Filter Strings With Streamline

★ OpenMAM is optional for XPression MOS and NLE workflows.
★ Streamline 4.1 or higher.

The following steps explain the how to use user input controls to dynamically adjust openMAM filters for the faces of background, quad, sphere, cube, cylinder, torus, and slab objects in XPression when using Streamline.

1. Enable the OpenMAM properties tab in the Object Inspector:
   a. In the XPression click Edit > Preferences.
      The Preferences dialog box opens.
   b. Click Remote Server.
      The Remote Server panel opens.
   c. In the Automation section, select the Show Automation / OpenMAM Properties Tab in Object Inspector check box to display the OpenMAM tab in the Object Inspector of a selected background, quad, sphere, cube, cylinder, torus, or slab object.
   d. Click OK.
      The Preferences dialog box closes.
2. In the **Scene Manager**, select the scene that contains an object and text to use for the openMAM filter.

   ![Scene Manager](image1.png)

   a. In the **Object Manager**, select the text object and enter a meaningful name in relation to the filter to be created. For example; GraphicType.

   ![Object Manager](image2.png)

   b. In the **Object Inspector**, click the **Data Source** tab.

   ![Object Inspector](image3.png)

   The **Data Source** tab is displayed.

   c. In the **Select Data Source** section of the **Data Source** tab, select the **Static Text** radio button.
d. Select the **Enable User Input Controls** check box and:
   - Use the **Type** list to select a user input control for the filter. For example, **Radio Buttons**.
   - De-select the **Allow custom values** check box.

![Image of user interface showing Enable User Input Controls checkbox and Type dropdown]

e. In the **User Control** section, select the **Static List** radio button.

f. Click **Add** to add a radio button to the list and enter a description. Repeat this step for the necessary radio buttons for the Streamline folders. For example; OTS, Headshot, Generic.

![Image of user interface showing User Control section with Static List selected and radio buttons]

g. Right-click inside the list and select **Add Column** from the shortcut menu.
   
   The **Add New Column** dialog box opens.
   
   ![Image of Add New Column dialog box]

h. In the **Add New Column** dialog box, use the name box to enter the column name ‘Filter’ and click **OK**.

   The new column is added to the list.

![Image of user interface showing new column added to the list]
i. Click inside the **Filter** row of a radio button description (for example ‘OTS’) and enter the file path to the respective Streamline folder (for example '/images/OTS') on the Streamline server. Repeat this step for all respective radio button filter rows.

![Image of Filter row in Object Inspector](image)

Entering a ‘*’ variable for the generic filter will create a file path to the root folder in Streamline.

3. In the **Object Manager**, select the object to use for the openMAM filter. For example, a quad.

![Image of Object Manager](image)

a. In the **Object Inspector**, click the **Template Links** tab.

The **Template Links** tab opens.

![Image of Template Links tab](image)

b. In the **Template Links** section, select the **Publish Object** check box to publish the selected object.
c. In the Object Inspector, click the OpenMAM tab.
   
   The OpenMAM tab is displayed.

   ![Object Inspector with OpenMAM tab](image)

   ![OpenMAM tab highlighted](image)

   d. In the list of object faces in the OpenMAM tab, select the face of the object to which a filter string is to be applied.

   e. In the OpenMAM Options section, use the Filter String box to enter a filter string to link the object face in Streamline. For example, '@GraphicType@'.

4. Click Save Project and Publish To Project Server ( ).

5. Open the project in the XPression Plugin.

6. Open the scene with the openMAM filters in the Edit tab of the plugin.
a. In the **Object / Field** list, click on the **Content** row for the **GraphicType**. The user input controls created in XPression for the scene are displayed. In this example, radio buttons for OTS, Headshots, and Generic.

b. Select one of the radio buttons. For example, Headshots.
c. In the Object / Field list, click the Streamline button for an object face.

Login to Streamline, if prompted.

The Streamline XPression Asset Browser browser opens on the folder of the selected user input control. In this example, Headshots.

To access a different folder in the Streamline XPression Asset Browser, in the plugin, select a different user input control for the object face (for example, OTS) and click the Streamline button.

The Streamline XPression Asset Browser opens on the folder of the newly selected user input control.
XPression Rundown Controller

* The XPression Rundown Controller is optional when using an XPression workflow.

The XPression Rundown Controller is used to activate rundowns from the XPression Gateway for playout in the XPression Sequencer.

Before you start using the XPression Rundown Controller, the remote connection points need to be configured. A connection point is a link between the XPression Rundown Controller and an XPression Gateway.

The following topic is discussed in this section:
- Add a Remote Connection Point
- Edit a Remote Connection Point
- Delete a Remote Connection Point
- Select Rundowns
Add a Remote Connection Point

A connection point is a link between the XPression Rundown Controller and the XPression Gateway. Use the following procedure to add a connection point between the XPression Rundown Controller and an XPression Gateway.

1. In the XPression Rundown Controller, use the File menu to select Connection Points.

   The Remote Connection Points dialog box opens.

2. Click the Add button to add a remote connection point.

   The Remote Connection Point dialog box opens.

   a. In the Connection ID section, use the Name box to enter a name for the connection.
   b. Use the Category list to select or enter a category to identify the connection point.
   c. Use the Description box to enter a descriptor for the connection.
   d. In the Remote Address section, use the Connection Type list to select a connection type for the remote address.
   e. Use the Host box to enter the remote host IP address.
   f. In the Port box, enter or select the host port number of the remote address.

3. Click OK.

   The Remote Connection Point dialog box closes and the new connection point appears in the Remote Connections list in the Remote Connection Points dialog box.

4. Click OK.

   The Remote Connection Points dialog box closes.
**Edit a Remote Connection Point**

Use the following procedure to edit a connection point between the XPression Rundown Controller and an XPression Gateway.

1. In the **XPression Rundown Controller**, use the **File** menu to select **Connection Points**.
   
The Remote Connection Points dialog box opens.

2. In the **Remote Connections Points** dialog box, select a remote connection point from the **Remote Connections** list.

3. Click the **Edit** button.
   
The Remote Connection Point dialog box opens.

   a. In the **Connection ID** section, use the **Name** box to edit the name of the connection.

   b. Use the **Category** list to select or edit a category to identify the connection point.

   c. Use the **Description** box to enter or edit the descriptor for the connection.

   d. In the **Remote Address** section, use the **Connection Type** list to select a connection type for the remote address.

   e. Use the **Host** box to select or edit the remote host IP address.

   f. In the **Port** box, select or edit the host port number.

4. Click **OK**.
   
The Remote Connection Point dialog box closes and the edited connection point appears in the Remote Connections list in the Remote Connection Points dialog box.

5. Click **OK**.
   
The Remote Connection Points dialog box closes.
Delete a Remote Connection Point

Use the following procedure to delete a connection point between the XPression Rundown Controller and an XPression Gateway.

1. In the XPression Rundown Controller, use the File menu to select Connection Points.
   The Remote Connection Points dialog box opens.

   ![Remote Connections dialog box]

2. In the Remote Connection Points dialog box, select a remote connection point from the Remote Connections list.

3. Click the Delete button.
   A Warning box opens.

   ![Warning box]

4. Click Yes.
   The Warning box closes and the connection point is deleted from the Remote Connections list in the Remote Connection Points dialog box.

5. Click OK.
   The Remote Connection Points dialog box closes.
Select Rundowns

Select rundowns to update the XPression Gateway for the playout engine.

1. In the Rundown List, select the check box of the rundown(s) to use in the playout engine.
   - The Sort Filter box can be used to enter a rundown or keyword to move the rundown to the top of the rundown list.

2. If applicable, select the radio button of the style(s) template to use.

3. Click Apply Settings.
   - The rundown selections are sent to the XPression Gateway and are available for playout in the playout engine.
XPression Remote Sequencer

The XPression Remote Sequencer is used to control remote XPression engines and playout graphics and clips from a MOS rundown.

This section describes how to configure the remote sequencer preferences, reset the layout, configure connection points and groups, select rundowns, and control sequence playout.

The following topics are discussed in this section:

• Configuring Smart GPI / RossTalk
• Setting Preferences
• Saving and Resetting the Layout
• Adding a Remote Connection Point
• Editing a Remote Connection Point
• Deleting a Remote Connection Point
• Selecting a Channel Group
• Selecting Active Rundowns
• Keyboard / GPI Mapping
• Channels
• Scene Manager
• Up Next Preview
• Linear Rundown
• Take Item Inspector
• Clip Browser
• Control Sequence Playout
Configuring Smart GPI / RossTalk

Use the following procedure to configure the Smart GPI / RossTalk Settings for the XPression Remote Sequencer.

1. In the XPression Remote Sequencer, use the File menu to select Hardware Setup.
   The Hardware Setup dialog box opens.

2. In the GPI Boards tab, click Add.
   The Add New GPI Board dialog box opens.

3. Use the Brand list to select a GPI board. The available option is:
   • Smart GPI / RossTalk
4. Click OK.
   The Smart GPI / RossTalk Setup dialog box opens.

5. In the Settings section, select Enabled from the State list. Select Disabled to turn off Smart GPI/RossTalk.
6. Select a Mode for Smart GPI/RossTalk:
   • Serial RS232 — select to use RS232 to send Smart GPI/RossTalk signals to XPression Remote Sequencer.
   • TCP — select to use TCP/IP to send Smart GPI/RossTalk signals to XPression Remote Sequencer.
   • UDP — select to use UDP sockets to send Smart GPI/RossTalk signals to XPression Remote Sequencer.

7. Configure the selected GPI mode.
   Serial RS232
   a. In the RS232 GPI Settings box, use the **Port** list to select the Communication port that receives GPI signals.
   b. Use the **Baudrate** list to select the communication speed for GPI signals.
   c. Use the **Data Bits** list to select the number of bits used to represent one character of data for GPI signals.
   d. Use the **Parity** list to select the method used to check for lost data in a GPI signal.
   e. Use the **Stop Bits** list to select the number of bits used to indicate the end of a byte in a GPI signal.
   f. Use the **Flow Control** list to select the data transmission rate controller for a GPI signal.

   When using Smart GPI/RossTalk, the flow control can be set to **Hardware** or **None**, but it must be set the same in both XPression and the transmitting device.

   **TCP**
   a. In the **Incoming Network Settings** box, use the **TCP Port** box to enter or select the communication port that receives GPI signals from an external source.
   b. In the **Outgoing Network Settings** section, use the **Hostname** box to enter the host name of a remote device that is to receive RossTalk messages from the local XPression engine.
   c. Use the **TCP Port** box to enter or select the communication port that receives the signals.

   **UDP**
   a. In the **Incoming Network Settings** box, use the **UDP Port** box to enter or select the communication port that receives GPI signals from an external source.

8. Click **OK**.

The Smart GPI/RossTalk is displayed in the GPI Board list.

9. Click **Close**.

The Hardware Setup dialog box closes.

For More Information on...
• configuring and working with GPIs, refer to the **GPI White Paper** available from Ross Video.
Setting Preferences

Use the following procedure to configure the settings for the XPression Remote Sequencer.

1. In the XPression Remote Sequencer, use the File menu to select Preferences. The Preferences dialog box opens.
2. Click the General panel to set project preferences for the XPression Remote Sequencer.

   a. In the Sequencer section, select the Loop On End check box to loop the cursor to the start of a rundown when it has reached the end.
   
   b. Select the Center online item in view check box to center the online take item in the view of the rundown.
   
   c. Select the Advance focus after taking item offline (with minus key) check box to advance to the focus to the next take item after taking a take item offline using the minus (-) key.
   
   d. Select the Disable ESC-ESC from clearing channels check box to disable the ESC-ESC keyboard command from clearing all channels.
   
   e. In the Display Preferences section, select the Highlight online and cued items check box to distinguish online and cued items in the Linear Rundown and Channel lists by highlighting them.
   
   f. Select the Channel Sequencers should follow linear sequencer check box to have the channel sequencers items follow the up next items in the linear sequencer (all channel items highlight/focus to the next/upcoming item in the list).

      Select the Only the channel assigned to the selected item should follow check box to have only the item focused in the Linear Rundown follow in the channel list.

   g. Select the Show empty stories in MOS rundowns check box to display stories in the rundown that don’t contain items.
   
   h. Select the Show preview image / layer list for individual channels check box to display the preview image and layers for a selected item in individual channels.
3. Click the **Channel Colors** panel to configure channel colors for the XPression Remote Sequencer.

   ![Channel Colors panel]

   a. In the **Channel Colors** section, select the **Use Channel Colors** check box to colorize Next Up Preview thumbnails, Linear Rundown Take IDs, Virtual Channel columns, and Channel Take Item lists.

   b. Click inside the **Color** column of a **Ch #** to open the **Color Editor** to configure a custom color for the channel:

   ![Color Editor]

   - Use the **Basic Colors** section to simply select a preexisting color from the list and Click **OK**.
   - Use the **Custom Colors** section to select a color from the list of custom created colors.

   Click **Define Custom Colors** to open a color spectrum to configure a specific color:

   ![Color Spectrum]
Configure the color mode for the custom color as HSL, RGB, or by simply using the scale and the color box:

- **H** — select this option, then use one of the following methods to set the hue value for the new color:
  - In the box to the right of this option, enter or select the hue value.
  - Place the slider along the scale to set the hue value.
  - After setting this value, the S and L color values can be set by clicking a color in the color box.

- **S** — select this option, then use one of the following methods to set the saturation value for the new color:
  - In the box to the right of this option, enter or select the saturation value.
  - Place the slider along the scale to set the saturation value.
  - After setting this value, the H and L color values can be set by clicking a color in the color box.

- **L** — select this option, then use one of the following methods to set the lightness value for the new color:
  - In the box to the right of this option, enter or select the lightness value.
  - Place the slider along the scale to set the lightness value.
  - After setting this value, the H and L color values can be set by clicking a color in the color box.

- **R** — select this option, then use one of the following methods to set the red value for the new color:
  - In the box to the right of this option, enter or select the red value.
  - Place the slider along the scale to set the red value.
  - After setting this value, the G and B color values can be set by clicking a color in the Color Box.

- **G** — select this option, then use one of the following methods to set the green value for the new color:
  - In the box to the right of this option, enter or select the green value.
  - Place the slider along the scale to set the green value.
  - After setting this value, the R and B color values can be set by clicking a color in the Color Box.

- **B** — select this option, then use one of the following methods to set the blue value for the new color:
  - In the box to the right of this option, enter or select the blue value.
  - Place the slider along the scale to set the blue value.
  - After setting this value, the R and G color values can be set by clicking a color in the Color Box.

- **Scale** — place the slider along this scale to set the selected color value.

- **Color Box** — click a color in this box to set the color values that are not selected.

Once a custom color has been created, click **Add to Custom Colors** to add the color to the **Custom Colors** list and click **OK**.

**c.** Click the **Default** button to use the default channel colors.

**4.** Click **OK**.

The **Preferences** dialog box closes.

**For More Information on...**

- enabling the **Parse roStorySend Messages** check box to use the **Show Story Number Column** feature, refer to “Setting Up the XPression Gateway” on page 3–2.
Saving and Resetting the Layout

To save the layout:

1. In the XPression Remote Sequencer, click the Save docking layout button ( ) to save a layout.
   The Save Docking Layout dialog box opens.

2. Use the Name box to enter a name for the layout.
3. Click OK.
   The layout is saved.
   The layout is now available to select in the layouts list as well as the default layout.

To reset the layout:

1. In the XPression Remote Sequencer, use the Docking menu to select Reset Layout (or press Ctrl+Alt+R).
   A Warning box opens.

2. Click Yes.
   The Warning box closes and the XPression Remote Sequencer layout is reset.
Adding a Remote Connection Point

A connection point is a link between the XPression Remote Sequencer and the XPression Gateway. Use the following procedure to add a connection point between the XPression Remote Sequencer and an XPression Gateway.

1. In the **XPression Remote Sequencer**, use the **File** menu to select **Connection Points**.
   
   The **Remote Connection Points** dialog box opens.

2. Click the **Add** button to add a remote connection point.
   
   The **Remote Connection Point** dialog box opens.

   a. In the **Connection ID** section, use the **Name** box to enter a name for the connection.
   
   b. Use the **Category** list to select or enter a category or location to identify the connection point. For example Site 1, Site 2, etc.
   
   c. Use the **Description** box to enter a descriptor for the connection.
   
   d. In the **Remote Address** section, use the **Connection Type** list is automatically populated with the XPression Gateway.
   
   e. Use the **Host** box to enter the remote host IP address.
   
   f. In the **Port** box, enter or select the port number set in the Remote Sequencer configuration area of the XPression Gateway settings.

3. Click **OK**.
   
   The **Remote Connection Point** dialog box closes and the new connection point appears in the **Remote Connections** list in the **Remote Connection Points** dialog box.

4. Click **OK**.
   
   The **Remote Connection Points** dialog box closes.
Editing a Remote Connection Point

Use the following procedure to edit a connection point between the XPression Remote Sequencer and an XPression Gateway.

1. In the XPression Remote Sequencer, click File > Connection Points.
   
The Remote Connection Points dialog box opens.

2. In the Remote Connections Points dialog box, select a remote connection point from the Remote Connections list.

3. Click the Edit button.
   
The Remote Connection Point dialog box opens.

4. Click OK.
   
The Remote Connection Points dialog box closes and the edited connection point appears in the Remote Connections list in the Remote Connection Points dialog box.

5. Click OK.
   
The Remote Connection Points dialog box closes.
Deleting a Remote Connection Point

Use the following procedure to delete a connection point between the XPression Remote Sequencer and an XPression Gateway.

1. In the XPression Remote Sequencer, use the File menu to select Connection Points.
   
The Remote Connection Points dialog box opens.

2. In the Remote Connection Points dialog box, select a remote connection point from the Remote Connections list.

3. Click the Delete button.
   
   A Warning box opens.

4. Click Yes.
   
   The Warning box closes and the connection point is deleted from the Remote Connections list in the Remote Connection Points dialog box.

5. Click OK.
   
   The Remote Connection Points dialog box closes.
Selecting a Channel Group

Channel groups are created in the XPression Gateway settings, in the Channel Groups configuration area. A channel group can be selected once a connection point has been established to an XPression Gateway with channel groups configured.

This procedure describes how to select a channel group in the XPression Remote Sequencer.

1. In the XPression Remote Sequencer toolbar, use the **Gateway** list to select a connection point.
2. Use the **Channel Group** list to select a channel group.

The selected channel group opens in the Remote Sequencer as configured in the Gateway.

For More Information on...
- creating channel groups, see “Channel Groups” on page 3–11.
Selecting Active Rundowns

Active rundowns can be selected to open in the XPression Remote Sequencer for playout.

1. In the XPression Remote Sequencer toolbar, click the Rundown Selection browse button or press Ctrl + R.
   The Select Active Rundowns dialog box opens.

2. In the Rundown List, select the check box of the rundown(s) to open in the remote sequencer.
   The Sort Filter box can be used to enter a rundown or keyword to move the rundown to the top of the rundown list.

3. Click OK.
   The selected rundown(s) and associated style open in the remote sequencer.
Create a Manual Rundown

Manual rundowns can be created in the XPression Remote Sequencer that are not linked to a MOS NRCS.

1. In the Linear Rundown window of the XPression Remote Sequencer, click Rundowns > Open / Manage Rundowns.

   The Manage Rundowns dialog box opens.

2. Click New Rundown.

   The Create Rundown dialog box opens.

Other options include:

   • **Delete** — click to delete a selected rundown.
   • **Import** — click to import a rundown from any selected location.
   • **Export** — click to export a selected rundown to a desired location as a .xprundown or .csv file.

3. In the Rundown Name box, enter a name for the rundown.
4. Click **OK**.
   The **Create Rundown** dialog box closes and the rundown is added to the list.

5. Select the new rundown and click **Open Rundown**.
   The rundown opens in the **Linear Rundown** window and in the **Channel** columns.
6. Select an item from the **Scene Manager** or **Clip Browser** and drag and drop the item into the linear rundown list or a channel. Repeat for as many items as necessary. The items are added to the rundown or channel.

7. Right-click on the rundown and select **Activate Rundown**.

   The **Select Active Rundowns** dialog box opens.
8. Select the check box for the rundown and click **OK**.

The rundown is activated.

Inactive rundowns can be closed by clicking **Rundowns > Close Inactive Rundowns**. Only active rundowns will remain visible in the list.
Keyboard / GPI Mapping

Keyboard and GPI mapping enables many of the Remote Sequencer functions to be assigned to keyboard shortcuts or GPI input triggers. Many of the existing default keyboard shortcuts can also be customized.

The following topics are discussed in this section:

- Create a Custom Keyboard Map
- Assign a Global Shortcut
- Assign a Local Shortcut
- Create a Custom Smart GPI / RossTalk Map
Create a Custom Keyboard Map


2. Click the Save Keyboard Mapping ( ) button to create a new custom keyboard mapping. The default keyboard map cannot be edited.
   
   The Save Keyboard Mapping dialog box opens.

3. In the Save Keyboard Mapping dialog box, enter a name for the new custom keyboard mapping.
4. Click OK.
   The added custom keyboard mapping appears in the Current Keyboard Map list and is saved as a .kbd file.

For More Information on...

• assigning a Global Shortcut, refer to “Assign a Global Shortcut” on page 9–19.
• assigning a Local Shortcut, refer to “Assign a Local Shortcut” on page 9–22.
Assign a Global Shortcut

Global Shortcuts represent functions that can be assigned to keyboard hotkeys that are active at any time while XPression Remote Sequencer is running.

   - The Keyboard / GPI Mapping dialog box opens.

2. Select a a keyboard map from the **Current Keyboard Map** list or create a custom keyboard map.

3. In the **Available Global Functions** list, drag and drop the **Group** function or click the **Add Group** button in the toolbar to create a group branch in the **Global Shortcuts** tree.

4. In the **Available Global Functions** list, select a function and drag and drop it into the desired spot in the **Global Shortcuts** tree to add the function.
   - Entering a function in the **Filter** box lets you search the **Available Global Functions** list for a specific function.
5. In the **Global Shortcuts** table, right-click on an item in the shortcuts tree and select **Assign Shortcut** to assign a custom keyboard control to the selected item.

![Global Shortcuts Table]

6. In the **Shortcut Details** section, perform the following:

   a. In the **Name** box, edit the name of the selected item if necessary.

   b. In the **Shortcut** box, enter a keyboard shortcut to assign to the selected item by entering the command on the keyboard.

   The assigned keyboard shortcut appears in the **Shortcut** box and in the row for the selected item under the **Direct Access Shortcut** column in the **Global Shortcuts** table.

   If the assigned keyboard shortcut is already in use by another item, a hazard icon (澪) will appear next to the command in the **Direct Access Shortcut** column. Place the cursor over the hazard icon to view where the conflict occurs.

   c. Select the **Include In Quick Menu** check box to include the keyboard shortcut in a Quick Menu.

   Quick Menus are shortcut menus that appear when a Quick Key for a Global Shortcut is entered. The keyboard shortcuts available for the selected Global Shortcut are listed in the Quick Menu that appears. This feature only applies to Global Shortcut branches that contain children nodes.

   In the **Quick Key** box, enter a letter or number as the Quick Menu command.

7. In the options section located to the right of the **Shortcut Details** section, configure the shortcut options (if options are available) of various functions:

   **Clear Single Channel Options**
   - **Framebuffer** — use the list to select a framebuffer for clearing the channel.

   **Cue Item Options**
   - Select **Current Sequence Item** to apply the shortcut to the current focused item in a sequencer, or select **Take ID** and enter or select a Take ID number in the box to apply the shortcut to the specific Take ID.
   - **Channel** — use the list to assign a channel if using current sequence item.
   - **Move Sequencer Focus to Item** — check this box to set sequencer focus to the selected Take ID.

   **Focus Channel Options**
   - **Channel** — use the list to assign the linear sequence or a channel to set the focus.

   **Next Item Options**
   - **Channel** — use the list to assign the linear sequence or a channel to the next item.
Next Story Options
• Channel — use the list to assign a channel to the next story.

Previous Item Options
• Channel — use the list to assign the linear sequence or a channel to the previous item.

Previous Story Options
• Channel — use the list to assign a channel to the previous story.

Swap Channel Options
• Channel — use the list to assign a channel to swap.

Take Offline Options
• Select Current Sequence Item to apply the shortcut to the current item in a sequence, or select Take ID and enter or select a Take ID number in the box to apply the shortcut to the specific Take ID, or select Entire Framebuffer to take all layers off of a framebuffer and use the list to select the framebuffer.

Take Options
• Select Current Sequence Item to apply the shortcut to the current item in a sequence, or select Take ID and enter or select a Take ID number in the box to apply the shortcut to the specific Take ID.
• Channel — use the list to assign a channel if using current sequence item.
• Move Sequencer Focus to Item — select this box to set sequencer focus to the selected Take ID.
• Advance Sequence After Take — check this box to advance to the next Take Item in the sequence after the current or selected Take Item has finished playing.

8. Click OK.

For More Information on...
• creating a custom keyboard map, refer to “Create a Custom Keyboard Map” on page 9–18.
Assign a Local Shortcut

Local shortcuts represent keyboard hotkeys that apply to one particular component of XPression Remote Sequencer, such as the File menu, and are only active when the particular component of XPression Remote Sequencer has keyboard/mouse focus.

   The Keyboard / GPI Mapping dialog box opens.

2. Select a a keyboard map from the Current Keyboard Map list or create a custom keyboard map.

3. In the Local Shortcuts table, right-click on an item in the shortcuts tree and select Assign Shortcut to assign a custom keyboard control to the selected item.

4. In the Shortcut Details section, perform the following:
   a. In the Name box, edit the name of the selected item if necessary.
   b. In the Shortcut box, enter a keyboard shortcut to assign to the selected item by entering the command on the keyboard.
      The assigned keyboard shortcut appears in the Shortcut box and in the row for the selected item under the Direct Access Shortcut column in the Local Shortcuts table.
      If the assigned keyboard shortcut is already in use by another item, a hazard icon (▲) will appear next to the command in the Direct Access Shortcut column. Place the cursor over the hazard icon to view where the conflict occurs.

5. Click OK.

For More Information on...
- creating a custom keyboard map, refer to “Create a Custom Keyboard Map” on page 9–18.
Create a Custom Smart GPI / RossTalk Map

1. Use the Hardware Setup dialog box to configure a GPI board for XPression Remote Sequencer.

3. Create a custom keyboard mapping that includes global shortcuts.
4. In the **Global Shortcuts** tree, right-click on a global shortcut and select **Edit GPI Assignment**. The same GPI trigger can be assigned to multiple global functions to execute them in order.

**a.** Select a GPI board from the list.

**b.** In the **GPI** box, enter or select a GPI input to assign to the selected global shortcut.

If the assigned GPI input is already in use by another item, a hazard icon (⚠️) will appear next to the GPI details in the GPI column. Place the cursor over the hazard icon to view where the conflict occurs.

5. Click **OK**.
For More Information on...

- adding a Smart GPI/RossTalk board, refer to “Configuring Smart GPI / RossTalk” on page 9–2.
- creating a custom keyboard, refer to “Create a Custom Keyboard Map” on page 9–18.
- configuring and working with GPIs, refer to the GPI White Paper available from Ross Video.
Channels

The Remote Sequencer can have up to eight channels configured in the XPression Gateway. Channels are distinguished by number and color. Each channel lists all items that have been assigned to the respective channel.

Channel User Interface

Take items in the Channel windows are displayed in black and blue text:

- Black items are from the NRCS and can not be deleted in a Channel list.
- Blue items are added locally and can be deleted in a Channel list.

Local items can be dragged and dropped into rundowns, including MOS rundowns. However, MOS items can not be dragged and dropped into other places in rundown because their order is determined by the MOS rundown. Items within the Channel list can be rearranged by dragging and dropping within the Channel list.

When editing existing items, no further MOS updates for that item will be applied unless the local changes are reverted by right-clicking on the item and selecting Revert changes to MOS item from the shortcut menu.

Local modifications can be purged by configuring the purge settings in the Settings section of the Remote Sequencer panel in the Gateway Settings. For more information, refer to step step 7 on page 3-7 of “Setting Up the XPression Gateway”.

The Channel window contains a preview thumbnail of the selected scene in the top-left corner as well as the following:

- **Channel** — displays the channel number and lists the layers, take ID, scene name, and the text object content for the selected scene.
- **Take ID** — use this column to select or enter an identification number for a take item.
- **State** (read-only) — this column displays the current playout state of a take item.
- **Scene** (read-only) — this column displays the scene or scene group name of a take item. When using clips, it will list whether the item is a clip or a still. When a clip is played, it displays a progress bar and a timer that counts down the time remaining in the clip (XPression Clips Option only).
- **Thumbnail** (read-only) — this column displays a thumbnail of the scene.
- **Story Num** (read-only) — this column displays the MOS story number column from the NRCS.
- **Name** (read-only) — this column displays the name for a take item.
- **Content** (read-only) — this column displays text object content provided to a take item. Content values for a take item are set in the Template Data tab of the Take Item Inspector window.
- **Virtual Channel** — this column displays the channel number assigned to the take item. Click inside the column to open a list of the virtual channels and select a channel to assign the take item to that channel.
- **Layer** — use this column to select or enter the output framebuffer layer to place a take item.
- **In Point** (read-only) — lists the drop frame timecode starting point for the clip.
Out Point (read-only) — lists the drop frame timecode ending point for the clip.
Duration (read-only) — this column displays the time duration of a take item.
Description (read-only) — this column displays the number of entries in a particular scene group.

Right-clicking on the column headers and selecting Columns allows the selection of specific columns for the list to be hidden or displayed. The columns can also be reordered by dragging individual columns to another location. Selecting Reset To Default will reset the list to the default layout.

Shortcut Menu

Right-click on a take item to access the following shortcut menu:
Cue — select this command to cue the selected take item.
Take Offline — select this command to take the selected take item off-line.
Focus in Linear Sequence — select this command to set the focus in the linear rundown on the selected item in the channel window.
Revert changes to MOS Item — select this command to revert a MOS take item to its original settings if changes have been made.
Layer > Default For Channel — select this command to use the take item on the default layer for the channel.
Layer > Default For Template — select this command to use the take item on the default layer of the template for the item.
Copy — select this command to copy the selected take item.
Paste — select this command to paste a copied take item into another channel or the sequence list in the Linear Rundown window. Pasting a copied take item from one channel to another will place the take item on the channel in which it is pasted.
Delete Item — select this command to remove the selected take item from the channel. The associated scene or scene group is not deleted. Only manually edited take items can be deleted; NRCS take items can not be deleted.

Scene Manager

Use the Scene Manager window to view all of the scenes and scene groups contained in a rundown.
Show — displays the show that is open in the Scene Manager. Click Browse (...) to open the Show, Category, and Style Selection dialog box to select a new show, category, or style to open in the Scene Manager.
Filter — use this box to search for scenes using words to filter for specific scene names.
Thumbnails — click this tab to view the scenes as a list of thumbnails that display an image of the scenes.
List — click this tab to view the scenes as a list of scene names.

Use the toolbar to adjust the display of the Scene Manager:

- Expand Categories — click this button to expand all categories in the Scene Manager.
- Collapse Categories — click this button to collapse all categories in the Scene Manager.
- Resize Thumbnails / Resize Items — click this button to resize the thumbnails or items (depending on the which display is selected). Use the scroll bar that opens to slide the bar right to increase the size or left to decrease the size.
- Refresh — click this button to refresh the items in the Scene Manager when the Remote Sequencer provides notification that the project has been updated in the Project Server.
Show, Category, and Style Selection

Use the Show, Category, and Style Selection dialog box to select a new show, category, or style to open in the Scene Manager.

1. In the Scene Manager, click **Browse (...)**.

   The **Show, Category, and Style Selection** dialog box opens.

   ![Show, Category, and Style Selection dialog box](image)

2. Select a show and category from the **Show and Category** tree.
3. In the **Style** list, select a style.
4. Click **OK**.

   The **Show, Category and Style Selection** dialog box closes and the graphics associated with the selected style are available for selection in the **Thumbnails / List**.

Adding Scenes to the Linear Rundown

Scenes can be added to the Linear Rundown from the Scene Manager.

1. Select a scene in the **Scene Manager**.
2. Drag and drop the scene onto the sequence in the Linear Rundown window.

   The scene is added to the Linear Rundown where it was dropped within the sequence.

Up Next Preview

Use the Up Next Preview window to view the next scene in the sequence of the Linear Rundown.
Play Animation — click this button to play a preview of the scene.
Pause Animation — click this button to pause the preview of the scene when playing.
Stop Animation — click this button to stop the preview of the scene when playing.
Move to Preview Frame — click this button to move the scroll bar to the preview frame of the scene.

Scoll Bar — click and hold on the scroll bar and move it forward or backward along the timeline to view specific parts of the scene.

**Linear Rundown**

Use the Linear Rundown window to view and manage the scenes and scene groups to playout from a sequence, in the order from top to bottom. The sequence is populated by opening rundowns and by dragging scenes or scene groups from the Scene Manager or clips from the Clip Browser into the sequence list.

### Linear Rundown User Interface
Take items in the Linear Rundown window are displayed in black and blue text:
- Black items are from the NRCS and can not be deleted in the Remote Sequencer Linear Rundown.
- Blue items are added locally and can be deleted in the Remote Sequencer Linear Rundown.

Local items can be dragged and dropped into rundowns, including MOS rundowns. However, MOS items can not be dragged and dropped into other places in rundowns because their order is determined by the MOS rundown.

* When editing existing items, no further MOS updates for that item will be applied unless the local changes are reverted by right-clicking on the item and selecting **Revert changes to MOS item** from the shortcut menu.

Local modifications can be purged by configuring the purge settings in the Settings section of the Remote Sequencer panel in the Gateway Settings. For more information, refer to step step 7 on page 3-7 of “**Setting Up the XPression Gateway**”.

The Linear Rundown window contains the following interface items:

**Take ID** — use this column to select or enter an identification number for a take item.

**State** (read-only) — this column displays the current playout state of a take item.

**Scene** (read-only) — this column displays the scene or scene group name of a take item. When using clips, it will list whether the item is a clip or a still. When a clip is played, it displays a progress bar and a timer that counts down the time remaining in the clip (XPression Clips Option only).

**Thumbnail** (read-only) — this column displays a thumbnail of the scene.

**Story Num** (read-only) — this column displays the MOS story number column from the NRCS.

**Name** (read-only) — this column displays the name for a take item.
**Content** (read-only) — this column displays text object content provided to a take item. Content values for a take item are set in the Template Data tab of the Take Item Inspector window.

**Virtual Channel** — this column displays the channel number assigned to the take item. Click inside the column to open a list of the virtual channels and select a channel to assign the take item to that channel.

**Layer** — use this column to select or enter the output framebuffer layer to place a take item.

**In Point** (read-only) — lists the drop frame timecode starting point for the clip.

**Out Point** (read-only) — lists the drop frame timecode ending point for the clip.

**Duration** (read-only) — this column displays the time duration of a take item.

**Description** (read-only) — this column displays the number of entries in a particular scene group.

Right-clicking on the column headers and selecting **Columns** allows the selection of specific columns for the list to be hidden or displayed. The columns can also be reordered by dragging individual columns to another location. Selecting **Reset To Default** will reset the list to the default layout.

When the **Enable Edit** button in the toolbar at the top of the Remote Sequencer interface is enabled, it will enable framebuffer/layer changes in the linear rundown and template data modifications. The button is green when enabled and gray when disabled.

**Next Up Preview** (read-only) — displays a preview list of the upcoming scenes in the sequence list. Channel and take item info is displayed, as well as a preview thumbnail.

**Shortcut Menu**

Right-click on a take item to access the following shortcut menu:

**Cue** — select this command to cue the selected take item(s).

**Take Offline** — select this command to take the selected take item off-line.

**Revert changes to MOS Item** — select this command to revert a MOS take item to its original settings if changes have been made.

**Layer > Default For Channel** — select this command to use the take item on the default layer for the channel.

**Layer > Default For Template** — select this command to use the take item on the default layer of the template for the item.

**Copy** — select this command to copy the selected take item.

**Paste** — select this command to paste a copied take item into another area of the sequence or into a Channel window list. Pasting a copied take item into a different channel than to which it is set will place the take item on the channel in which it is pasted.

**Delete Item** — select this command to remove the selected take item from the sequence list. The associated scene or scene group is not deleted.
Take Item Inspector

Click the Take Item Inspector tab to open the Take Item Inspector. Use the Take Inspector Item window to view and set properties for the take item selected in the Linear Rundown window.

Take Item Tab User Interface

Use this tab to set the properties for a take item. Edits to take items are live/dynamic.

![Take Item Inspector tab](image)

**Entry**

Use this section to enter or change the name of the take item.

Name (read-only) — displays the name of the selected take item.

**Target**

Use this section to configure the playout settings for the take item.

Framebuffer — use the Framebuffer list to select the default channel used to playout the take item.

Layer — use this list to select the layer of the output framebuffer on which to playout the take item.

**MOS**

This section lists the MOS details of the take item.

ObjID (read-only) — displays the Object ID.

ItemID (read-only) — displays the Item ID.

StoryID (read-only) — displays the Story ID.
Template Data Tab User Interface

Use this tab to edit published fields.

Selecting a published object in the Up Next Preview window will highlight/select that published object in the Template Data tab list.

Object List

This table lists the template objects and attributes, and their values.

- **Select Previous Object** — click this button to select the previous object.
- **Select Next Object** — click this button to select the next object.
- **Expand All Object Nodes** — click this button to expand all objects.
- **Collapse All Object Nodes** — click this button to collapse all objects.
- **Refresh the template data fields from the MOS Gateway** — click this button to refresh the template data fields using the values from the XPression Gateway.

- **Objects** — this column lists the template objects. Expand the template objects to view the attributes.
- **Values** — this column lists the value of the template data associated with the attribute.

Static

Use this tab to configure text object attributes or to select static text items from previously configured user input controls.

Image Files

Select this tab to open the list of image file thumbnails. Double-click an image file thumbnail to apply the image as the value of the object attribute.

- **File Drop-Down List** — use this list to select a location/folder of an image.
- **Browse** — click this button to move up a location/folder level.
- **OpenMAM** — click this button to select and open an OpenMAM server to browse images on that server.
- **Icon Size** — use this list to select a display size for the image thumbnails in the list of image files.

Video Files

Select this tab to open the list of video material thumbnails. Double-click a video file thumbnail to apply the video file as the value of the object attribute. If the object had originally been assigned a video file, the properties of that video will be applied to the newly assigned video.

- **File Drop-Down List** — use this list to select a location/folder of an image.
- **Browse** — click this button to move up a location/folder level.
- **OpenMAM** — click this button to select and open an OpenMAM server to browse videos on that server.
**Object Properties**

When an object is expanded in the Object List, specific properties applicable to the selected object are available for editing, such as position, scale, etc.

**Position** — configure the following settings to adjust the position of the object:
- **X** — use this box to enter or select the X coordinate for the object location.
- **Y** — use this box to enter or select the Y coordinate for the object location.
- **Z** — use this box to enter or select the Z coordinate for the object location.

**Rotation** — configure the following settings to adjust the rotation of the object:
- **X** — use this box to enter or select the degrees to rotate an object around the X axis.
- **Y** — use this box to enter or select the degrees to rotate an object around the Y axis.
- **Z** — use this box to enter or select the degrees to rotate an object around the Z axis.

**Scale** — configure the following settings to adjust the scale of the object:
- **X** — use this box to enter or select the scale factor to apply to an object along the X (horizontal) axis.
- **Y** — use this box to enter or select the scale factor to apply to an object along the Y (vertical) axis.
- **Z** — use this box to enter or select the scale factor to apply to an object along the Z (depth) axis.
- **XYZ** — select this option to equally adjust the Y and Z scale factors when changing the X scale factor. Changing the Y or Z scale factor does not adjust the X scale factor.
- **XY** — select this option to equally adjust the Y scale factor when changing the X scale factor. Changing the Y scale factor does not adjust the X scale factor.
- **XZ** — select this option to equally adjust the Z scale factor when changing the X scale factor. Changing the Z scale factor does not adjust the X scale factor.
- **None** — select this option to independently change scale factors.

**Pivot** — configure the following settings to adjust the pivot point of the object:
- **X** — use this box to enter or select the X coordinate for the object pivot point.
- **Y** — use this box to enter or select the X coordinate for the object pivot point.
- **Z** — use this box to enter or select the X coordinate for the object pivot point.

**Visibility** — select this check box to make the object visible in the scene. It is selected by default.

**Texture Position** — configure the following settings to adjust the position of the texture applied to the object:
- **X** — use this box to enter or select the X coordinate for the texture location.
- **Y** — use this box to enter or select the Y coordinate for the texture location.

**Texture Scale** — configure the following settings to adjust the scale of the texture applied to the object:
- **X** — use this box to enter or select the scale factor to apply to the texture along the X (horizontal) axis.
- **Y** — use this box to enter or select the scale factor to apply to the texture along the Y (vertical) axis.

**Clip Browser**

Click the **Clip Browser** tab to open the Clip Browser if not already open. Use the Clip Browser to drag and drop clips into sequences in the Linear Rundown window or onto channels as take items.
**Clip Browser User Interface**

The Clip Browser contains a toolbar for searching clips and a list of clips available to use as take items.

**Clip Browser Toolbar**

Use the toolbar for searching clips.

- **Quick Find** — use this box to enter keywords to search for clips listed in the Clip Browser.
- **Show/Hide advanced search options** — click this button to show or hide the Advanced Search Options in the Clip Browser.
- **Reset search filter** — click this button to clear the Quick Find box and any entries in the fields of the Advanced Search Options.

**Advanced Search Options**

Use the Advanced Search Options to enter specific criteria for locating a clip.

- **Name** — use this box to enter the name of a clip to search.
- **Recall ID** — use this box to enter a recall ID to search.
- **Source** — use this box to enter a location to search for a clip.
- **Duration Min** — use this box to enter a minimum duration time to search for the clip.
- **Duration Max** — use this box to enter a maximum duration time to search for the clip.
- **Project** — use this list to select a project to search for the clip.
- **Added Min** — use the calendar to select a minimum date to search that the clip was added.
- **Added Max** — use the calendar to select a maximum date to search that the clip was added.
- **Expires Min** — use the calendar to select the minimum expiry date to search for the clip.
- **Expires Max** — use the calendar to select the maximum expiry date to search for the clip.
- **Never Expires** — select this check box to search for a clip with no expiry date set.
- **Audio Ch Min** — use this box to enter or select a minimum amount of embedded audio channels to search for the clip.
- **Audio Ch Max** — use this box to enter or select a maximum amount of embedded audio channels to search for the clip.
- **No Audio** — select this check box to search for a clip with no embedded audio.
- **Reset Filter** — click this button to clear all the fields in the Advanced Search Options.
- **Show all sub clips** — select this check box to display any sub clips of a clip in the clip list when performing a search.

**Clip List**

Drag clips from the list and drop them into the sequence in the Linear Rundown window or a specific channel for playout. Multiple clips can be selected and added to the Linear Rundown.

- **#** (read-only) — list number in the Clip Browser list. A ‘+’ indicates that the clip listing can be expanded to show any associated sub clips.
- **Thumbnail** — provides a thumbnail image of the clip or still. Thumbnails can be enlarged by clicking and dragging the right border of the thumbnail column title. Review a flip book playout of the clip by hovering the cursor over the thumbnail. The flip book is rendered over a checkerboard pattern so that the alpha channel is visible unless the clip is full frame. Still image thumbnails display an icon (تذكر) indicating that they are still images and not clips.
- **Name** (read-only) — lists the name of the clip.
- **In Point** (read-only) — lists the drop frame timecode starting point for the clip.
- **Out Point** (read-only) — lists the drop frame timecode ending point for the clip.
- **Length** (read-only) — lists the drop frame timecode duration of the clip.
- **Format** (read-only) — lists the formatting used for the clip.
Flags (read-only) — if using clips that have been transcoded by the XPression INcoder that include tags in the filename, this column lists the tags that have been parsed from the filename of the clip. The possible flags include:

- LE — indicates that looping has been enabled.
- HF — indicates that the clip will hold the last frame.

Audio Ch (read-only) — lists the amount of audio channels embedded in the clip.

Bit Depth (read-only) — lists the quality of the signal quantization for the clip.

Recall ID (read-only) — lists the ID number for the clip when it is recalled.

Project (read-only) — lists the name of the project to which the clip has been added.

Added (read-only) — lists the date the clip was added to the project.

Expires (read-only) — lists the expiry date for the clip, if applicable.

Codec (read-only) — lists the codec format of the clip.

File Ext (read-only) — lists the file type of the clip.

File Size (read-only) — lists the file size of the clip.

Alpha — provides a thumbnail of the clip with the alpha channel visible.

First Frame TC — lists the timecode for the first frame of the clip.

Control Sequence Playout

Multiple take item groups can be played out using the XPression Remote Sequencer. Items can be played out using the Linear Rundown or the Channel windows.

Control sequence playout using the linear rundown:

1. Open a Connection Group.

   ✷ The take items of the take item groups opened in the Remote Sequencer are numbered according to their order in the Remote Sequencer and not the Sequencer in XPression.

2. In the Linear Rundown window, select the take item group that contains the take items to playout.

3. Double-click a take item to playout the selected take item.

   The selected take item plays out through the default output, and the State changes to online for take items or Active for take item groups. In the Scene column, clip take items will also display a playback progress bar with a counter showing the time remaining.

4. On the keyboard, press Number Pad - to stop the playout of an online take item or Active take item group.

Control sequence playout using channel windows:

1. Open a Connection Group.

   ✷ The take items of the take item groups opened in the Remote Sequencer are numbered according to their order in the Remote Sequencer and not the Sequencer in XPression.

2. In a Channel window, select the take item group that contains the take items to playout.

3. Double-click a take item to playout the selected take item.

   The selected take item plays out through the default output, and the State changes to online for take items or Active for take item groups. In the Scene column, clip take items will also display a playback progress bar with a counter showing the time remaining.

4. On the keyboard, press Number Pad - to take a take item or Active take item group offline.
Keyboard Control

The keyboard number pad can also be used to control the playout of a sequence in the Linear Rundown window. The following keyboard shortcuts are available in the Sequencer:

- **Cursor Up Arrow** — select the previous take item in the sequence.
- **Cursor Down Arrow** — select the next take item in the sequence.
- **Ctrl-Home** — select the first take item in the sequence.
- **Ctrl-End** — select the last take item in the sequence.
- **Number Pad +** — playout the selected take item and select the next take item in the sequence.
- **Number Pad -** — take a take item or **Active** take item group offline.
- **Number Pad Enter** — playout the selected take item. This shortcut requires the Fast Recall feature to be enabled.
- **Number Pad +/-** — increase (+) or decrease (-) the speed of a roll/crawl while it is online.
- **Number Pad .** — cue a take item in the sequence.
XPression Remote Sequencer (Legacy)

The XPression Remote Sequencer is used to control remote XPression engines and playout graphics and clips from a MOS rundown.

Before you start using the XPression Remote Sequencer, the remote sequencer needs to be setup. This section describes how to configure the remote sequencer preferences, reset the layout, configure connection points and groups, select rundowns, and control sequence playout.

The following topic is discussed in this section:

• Configuring Smart GPI / RossTalk
• Setting Preferences
• Resetting the Layout
• Adding a Remote Connection Point
• Editing a Remote Connection Point
• Deleting a Remote Connection Point
• Selecting a Channel Group
• Selecting Active Rundowns
• Control Sequence Playout
Configuring Smart GPI / RossTalk

Use the following procedure to configure the Smart GPI / RossTalk Settings for the XPression Remote Sequencer.

1. In the **XPression Remote Sequencer**, use the **File** menu to select **Hardware Setup**.
   
   The **Hardware Setup** dialog box opens.

2. In the **GPI Boards** tab, click **Add**.
   
   The **Add New GPI Board** dialog box opens.

3. Use the **Brand** list to select a GPI board. The available option is:
   
   • **Smart GPI / RossTalk**

4. Click **OK**.
   
   The **Smart GPI / RossTalk Setup** dialog box opens.

5. In the **Settings** section, select **Enabled** from the **State** list. Select **Disabled** to turn off Smart GPI/RossTalk.
6. Select a **Mode** for Smart GPI/RossTalk:
   - **Serial RS232** — select to use RS232 to send Smart GPI/RossTalk signals to XPression Remote Sequencer.
   - **TCP** — select to use TCP/IP to send Smart GPI/RossTalk signals to XPression Remote Sequencer.
   - **UDP** — select to use UDP sockets to send Smart GPI/RossTalk signals to XPression Remote Sequencer.

7. Configure the selected GPI mode.
   **Serial RS232**
   - a. In the RS232 GPI Settings box, use the **Port** list to select the Communication port that receives GPI signals.
   - b. Use the **Baudrate** list to select the communication speed for GPI signals.
   - c. Use the **Data Bits** list to select the number of bits used to represent one character of data for GPI signals.
   - d. Use the **Parity** list to select the method used to check for lost data in a GPI signal.
   - e. Use the **Stop Bits** list to select the number of bits used to indicate the end of a byte in a GPI signal.
   - f. Use the **Flow Control** list to select the data transmission rate controller for a GPI signal.
      When using Smart GPI/RossTalk, the flow control can be set to **Hardware** or **None**, but it must be set the same in both XPression and the transmitting device.

   **TCP**
   - a. In the **Incoming Network Settings** box, use the **TCP Port** box to enter or select the communication port that receives GPI signals from an external source.
   - b. In the **Outgoing Network Settings** section, use the **Hostname** box to enter the host name of a remote device that is to receive RossTalk messages from the local XPression engine.
   - c. Use the **TCP Port** box to enter or select the communication port that receives the signals.

   **UDP**
   - a. In the **Incoming Network Settings** box, use the **UDP Port** box to enter or select the communication port that receives GPI signals from an external source.

8. Click **OK**.
   The Smart GPI/RossTalk is displayed in the GPI Board list.

9. Click **Close**.
   The **Hardware Setup** dialog box closes.

For More Information on...
- configuring and working with GPIs, refer to the **GPI White Paper** available from Ross Video.
Setting Preferences

Use the following procedure to configure the settings for the XPression Remote Sequencer.

1. In the XPression Remote Sequencer, use the File menu to select Preferences. The Preferences dialog box opens.
2. Click the General panel to set project preferences for the XPression Remote Sequencer.

   a. In the Sequencer section, select the Loop On End check box to loop the cursor to the start of a rundown when it has reached the end.

   b. Select the Show Story Number Column (ENPS) check box to add a column with the story number of the rundown (ENPS only).

   c. Select the Center online item in view check box to center the online take item in the view of the rundown.

   d. Select the Group items into stories check box to group items in the rundown into their individual stories.

   e. Select the Advance focus after taking item offline (with minus key) to advance to the focus to the next take item after taking a take item offline using the minus (-) key.

3. Click the Channel Colors panel to select the channel colors for the XPression Remote Sequencer.

   a. In the Channel Colors section, select the Use Channel Colors check box to colorize Next Up Preview thumbnails, Linear Rundown Take IDs, Virtual Channel columns, and Channel Take Item lists.
b. Click inside the **Color** column of a **Ch #** to open the **Color Editor** to configure a custom color for the channel:

- Use the **Basic Colors** section to simply select a preexisting color from the list and Click **OK**.
- Use the **Custom Colors** section to select a color from the list of custom created colors. Click **Define Custom Colors** to open a color spectrum to configure a specific color:

Configure the color mode for the custom color as HSL, RGB, or by simply using the scale and the color box:

- **H** — select this option, then use one of the following methods to set the hue value for the new color:
  - In the box to the right of this option, enter or select the hue value.
  - Place the slider along the scale to set the hue value.
  - After setting this value, the S and L color values can be set by clicking a color in the color box.
- **S** — select this option, then use one of the following methods to set the saturation value for the new color:
  - In the box to the right of this option, enter or select the saturation value.
  - Place the slider along the scale to set the saturation value.
  - After setting this value, the H and L color values can be set by clicking a color in the color box.
- **L** — select this option, then use one of the following methods to set the lightness value for the new color:
  - In the box to the right of this option, enter or select the lightness value.
  - Place the slider along the scale to set the lightness value.
  - After setting this value, the H and L color values can be set by clicking a color in the color box.
› **R** — select this option, then use one of the following methods to set the red value for the new color:
  - In the box to the right of this option, enter or select the red value.
  - Place the slider along the scale to set the red value.
  - After setting this value, the G and B color values can be set by clicking a color in the Color Box.

› **G** — select this option, then use one of the following methods to set the green value for the new color:
  - In the box to the right of this option, enter or select the green value.
  - Place the slider along the scale to set the green value.
  - After setting this value, the R and B color values can be set by clicking a color in the Color Box.

› **B** — select this option, then use one of the following methods to set the blue value for the new color:
  - In the box to the right of this option, enter or select the blue value.
  - Place the slider along the scale to set the blue value.
  - After setting this value, the R and G color values can be set by clicking a color in the Color Box.

› **Scale** — place the slider along this scale to set the selected color value.

  **Color Box** — click a color in this box to set the color values that are not selected.

Once a custom color has been created, click **Add to Custom Colors** to add the color to the **Custom Colors** list and click **OK**.

**c.** In the **Channel Colors** section, select a **Ch #** and click the **Delete** button to delete the name and associated color from the list.

**d.** Click the **Default** button to use the default channel colors.

4. Click **OK**.

The **Preferences** dialog box closes.
Resetting the Layout

1. In the XPression Remote Sequencer, use the Docking menu to select Reset Layout. A Warning box opens.

   ![Warning box]

2. Click Yes. The Warning box closes and the XPression Remote Sequencer layout is reset.
Adding a Remote Connection Point

A connection point is a link between the XPression Remote Sequencer and the XPression Gateway. Use the following procedure to add a connection point between the XPression Remote Sequencer and an XPression Gateway.

1. In the XPression Remote Sequencer, use the File menu to select Connection Points. The Remote Connection Points dialog box opens.

2. Click the Add button to add a remote connection point. The Remote Connection Point dialog box opens.

   a. In the Connection ID section, use the Name box to enter a name for the connection.
   b. Use the Category list to select or enter a category or location to identify the connection point. For example Site 1, Site 2, etc.
   c. Use the Description box to enter a descriptor for the connection.
   d. In the Remote Address section, use the Connection Type list is automatically populated with the XPression Gateway.
   e. Use the Host box to enter the remote host IP address.
   f. In the Port box, enter or select the port number set in the Remote Sequencer configuration area of the XPression Gateway settings.

3. Click OK. The Remote Connection Point dialog box closes and the new connection point appears in the Remote Connections list in the Remote Connection Points dialog box.

4. Click OK. The Remote Connection Points dialog box closes.
Editing a Remote Connection Point

Use the following procedure to edit a connection point between the XPression Remote Sequencer and an XPression Gateway.

1. In the XPression Remote Sequencer, click File > Connection Points.
   The Remote Connection Points dialog box opens.

2. In the Remote Connections Points dialog box, select a remote connection point from the Remote Connections list.

3. Click the Edit button.
   The Remote Connection Point dialog box opens.

   a. In the Connection ID section, use the Name box to edit the name of the connection.
   b. Use the Category list to edit the category or location that identifies the connection point. For example, Site 1, Site 2, etc.
   c. Use the Description box to edit the descriptor for the connection.
   d. In the Remote Address section, the Connection Type list is automatically populated and not editable.
   e. Use the Host box to edit the IP address of the machine hosting the XPression Gateway.
   f. In the Port box, select or edit the port number according to the number configured in the Remote Sequencer configuration area of the XPression Gateway settings.

4. Click OK.
   The Remote Connection Point dialog box closes and the edited connection point appears in the Remote Connections list in the Remote Connection Points dialog box.

5. Click OK.
   The Remote Connection Points dialog box closes.
Deleting a Remote Connection Point

Use the following procedure to delete a connection point between the XPression Remote Sequencer and an XPression Gateway.

1. In the **XPression Remote Sequencer**, use the **File** menu to select **Connection Points**.
   The **Remote Connection Points** dialog box opens.

2. In the **Remote Connection Points** dialog box, select a remote connection point from the **Remote Connections** list.

3. Click the **Delete** button.
   A **Warning** box opens.

4. Click Yes.
   The **Warning** box closes and the connection point is deleted from the **Remote Connections** list in the **Remote Connection Points** dialog box.

5. Click **OK**.
   The **Remote Connection Points** dialog box closes.
Selecting a Channel Group

Channel groups are created in the XPression Gateway settings, in the Channel Groups configuration area. A channel group can be selected once a connection point has been established to an XPression Gateway with channel groups configured. This procedure describes how to select a channel group in the XPression Remote Sequencer.

1. In the XPression Remote Sequencer toolbar, use the Gateway list to select a connection point.
2. Use the Channel Group list to select a channel group.

   The selected channel group is opened.

For More Information on...

• creating channel groups, see “Channel Groups” on page 3–11.
Selecting Active Rundowns

Active rundowns can be selected to open in the XPression Remote Sequencer for playout.

1. In the XPression Remote Sequencer toolbar, click the Rundown Selection browse button.
   The Select Active Rundowns dialog box opens.

2. In the Rundown List, select the check box of the rundown(s) to open in the remote sequencer.
   The Sort Filter box can be used to enter a rundown or keyword to move the rundown to the top of the rundown list.

3. Click OK.
   The selected rundown(s) and associated style open in the remote sequencer.
Control Sequence Playout

Multiple take item groups can be played out using the XPression Remote Sequencer.

1. Open a Connection Group.

   The take items of the take item groups opened in the Remote Sequencer are numbered according to their order in
   the Remote Sequencer and not the Sequencer in XPression.

2. Select the take item group that contains the take items to playout.

3. In the Sequencer, double-click a take item to playout the selected take item.

   The selected take item plays out through the default output, and the State changes to online for take items or
   Active for take item groups. In the Scene column, clip take items will also display a playback progress bar with
   a counter showing the time remaining.

4. On the keyboard, press Number Pad - to stop the playout of an online take item or Active take item group.

Keyboard Control

The keyboard number pad can also be used to control the playout of a sequence. The following keyboard shortcuts
are available in the Sequencer:

- **Cursor Up Arrow** — select the previous take item in the sequence.
- **Cursor Down Arrow** — select the next take item in the sequence.
- **Ctrl-Home** — select the first take item in the sequence.
- **Ctrl-End** — select the last take item in the sequence.
- **Number Pad +** — playout the selected take item and select the next take item in the sequence.
- **Number Pad -** — stop the playout of an online take item or Active take item group.
- **Number Pad +/-** — increase (+) or decrease (-) the speed of a roll/crawl while it is online.
- **Number Pad .** — cue a take item in the sequence.
Notes:
Notes:
Notes:
Contact Us

Contact our friendly and professional support representatives for the following:

- Name and address of your local dealer
- Product information and pricing
- Technical support
- Upcoming trade show information

### Technical Support

Telephone: +1-844-652-0645
(North America)
+800 1005 0100
(International)

After Hours Emergency: +1 613 • 349 • 0006
Email: techsupport@rossvideo.com

### General Information

Telephone: +1 613 • 652 • 4886
Fax: +1 613 • 652 • 4425
Email: solutions@rossvideo.com
Website: http://www.rossvideo.com

Visit Us

Visit our website for:

- Company information and news
- Related products and full product lines
- Online catalog
- Testimonials