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Thank You for Choosing Ross

You've made a great choice. We expect you will be very happy with your purchase of Ross
Technology.

Our mission is to:

1. Provide a Superior Customer Experience

· offer the best product quality and support

2. Make Cool Practical Technology

· develop great products that customers love

Ross has become well known for the Ross Video Code of Ethics. It guides our interactions and
empowers our employees. I hope you enjoy reading it below.

If anything at all with your Ross experience does not live up to your expectations be sure to reach
out to us at solutions@rossvideo.com.

David Ross

CEO, Ross Video

dross@rossvideo.com

Ross Video Code of Ethics

Any company is the sum total of the people that make things happen. At Ross, our employees are
a special group. Our employees truly care about doing a great job and delivering a high quality
customer experience every day. This code of ethics hangs on the wall of all Ross Video locations
to guide our behavior:

1. We will always act in our customers’ best interest.

2. We will do our best to understand our customers’ requirements.

3. We will not ship crap.

4. We will be great to work with.

5. We will do something extra for our customers, as an apology, when something big goes wrong
and it's our fault.

6. We will keep our promises.

7. We will treat the competition with respect.

8. We will cooperate with and help other friendly companies.

9. We will go above and beyond in times of crisis. If there's no one to authorize the required
action in times of company or customer crisis - do what you know in your heart is right. (You
may rent helicopters if necessary.)

mailto:solutions@rossvideo.com
mailto:dross@rossvideo.com
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End User Software License Agreement

This End User Software License Agreement is a legal agreement between you (the “Licensee”) and Ross
Video Limited (“Ross Video”) specifying the terms and conditions of your installation and use of the
Software and all Documentation (as those terms are defined herein).

IMPORTANT:

BY DOWNLOADING, ACCESSING, INSTALLING OR USING THE SOFTWARE AND/OR
DOCUMENTATION AND/OR BY AUTHORIZING ANY THIRD PARTY, INCLUDING WITHOUT
LIMITATION AN INSTALLER OR COMMISSIONER ACTING ON YOUR BEHALF TO DO SO, LICENSEE
AGREES TO THE TERMS OF THIS AGREEMENT AND THE LICENSE GRANTED HEREUNDER SHALL BE
EFFECTIVE AS OF AND FROM SUCH DATE. IF YOU DO NOT WISH TO ACCEPT THE TERMS AND
CONDITIONS OF THIS AGREEMENT, DO NOT DOWNLOAD, ACCESS, INSTALL, REFER TO OR
OTHERWISE USE THE SOFTWARE AND/OR DOCUMENTATION.

1. INTERPRETATION. In this Agreement, (a) words signifying the singular number include the plural and
vice versa, and words signifying gender include all genders; (b) every use of the words "herein",
"hereof", “hereto” "hereunder" and similar words shall be construed to refer to this Agreement in its
entirety and not to any particular provision hereof; (c) reference to any agreement or other document
herein will be construed as referring to such agreement or other document as from time to time
amended, modified or supplemented (subject to any restrictions on such amendment, modification or
supplement set forth therein); (d) every use of the words “including” or “includes” is to be construed as
meaning “including, without limitation” or “includes, without limitation”, respectively; and (e)
references to an Article or a Section are to be construed as references to an Article or Section of or to
this Agreement unless otherwise specified.

2. DEFINITIONS. In this Agreement, in addition to the terms defined elsewhere in this Agreement, the
following terms have the meanings set out below:

“Affiliate” means, with respect to any Person, any other Person who directly or indirectly controls, is
controlled by, or is under direct or indirect common control with, such Person. A Person shall be
deemed to control a Person if such Person possesses, directly or indirectly, the power to direct or cause
the direction of the management and policies of such Person, whether through the ownership of voting
securities, by contract or otherwise; and the term “controlled” and “controlling” shall have a similar
meaning.

“Agreement” means this End User Software License Agreement including the recitals hereto, as the
same may be amended from time to time in accordance with the provisions hereof.

“Backup System” means the secondary piece of Designated Equipment upon which the Software is
installed and mirrored for the sole purpose of replacing a Primary System in the event such Primary
System is not available or functioning properly for any reason.

“Change of Control” means (a) the direct or indirect sale, transfer or exchange by the shareholders of
a Party of more than fifty percent (50%) of the voting securities of such Party, (b) a merger or
amalgamation or reorganization or other transaction to which a Party is party after which the
shareholders of such Party immediately prior to such transaction hold less than fifty percent (50%) of
the voting securities of the surviving entity, (c) the sale, exchange, or transfer of all or substantially all
of the assets of a Party.



“Confidential Information” means all data and information relating to the business and management
of either Party, including the Software, trade secrets and other technology to which access is obtained
or granted hereunder by the other Party, and any materials provided by Ross Video to Licensee;
provided, however, that Confidential Information shall not include any data or information which:

(i) is or becomes publicly available through no fault of the other Party;

(ii) is already in the rightful possession of the other Party prior to its receipt from the other Party;

(iii) is already known to the receiving Party at the time of its disclosure to the receiving Party by the
disclosing Party and is not the subject of an obligation of confidence of any kind;

(iv) is independently developed by the other Party;

(v) is rightfully obtained by the other Party from a third party; or

(vi) is disclosed with the written consent of the Party whose information it is.

“Designated Equipment” shall mean (a) the hardware products sold by Ross Video to Licensee on
which the Software is installed and licensed for use, as the same may be replaced from time to time by
Ross Video; or (b) in the case of Software licensed on a stand-alone basis, the equipment of Licensee
on which the Software is to be installed and meets the minimum specifications set out in the
Documentation.

“Documentation” shall mean manuals, instruction guides, user documentation and other related
materials of any kind pertaining to the Software (whether in electronic, hard-copy or other media
format) that are furnished to Licensee by or on behalf of Ross Video in relation to the Software.

“Freeware” means Software that is available free of charge from Ross Video, and includes, without
limitation the master control system software known as "DashBoard".

"Governmental Authority" means (a) any federal, provincial, state, local, municipal, regional,
territorial, aboriginal, or other government, governmental or public department, branch, ministry, or
court, domestic or foreign, including any district, agency, commission, board, arbitration panel or
authority and any subdivision of any of them exercising or entitled to exercise any administrative,
executive, judicial, ministerial, prerogative, legislative, regulatory, or taxing authority or power of any
nature; and (b) any quasi-governmental or private body exercising any regulatory, expropriation or
taxing authority under or for the account of any of them, and any subdivision of any of them.

“Improvements” means all inventions, works, discoveries, improvements and innovations of or in
connection with the Software, including error corrections, bug fixes, patches and other updates in
Object Code form to the extent made available to Licensee in accordance with Ross Video’s release
schedule.

"License Fee" means the fee(s), if any, payable in respect of the Software in accordance with the
relevant invoice(s) or other purchase documents delivered in connection with this Agreement.

“License Period” means the period of time that Licensee will have the rights granted under this
Agreement, as may be specified in an Order.

“Modifications” means any enhancements, changes, corrections, translations, adaptations, revisions,
developments, upgrades or updates thereto; and “Modify” shall mean the creation of any of the
foregoing.

“Object Code” means the machine readable executable form of a computer software program.



"Open Source Components" means third party Open Source software, libraries or other components.

"Open Source License" means the license that governs each Open Source Component.

"Order" means the documents provided by Ross Video to Licensee detailing the Ross Video products
contemplated for purchase, the corresponding fees and License Period that may apply to the Software,
including any and all quotations, purchase orders, acknowledgments, pro formas, invoices and other
purchase documentation.

“Parties” means both Ross Video and Licensee and “Party” means either one of them as the context
requires.

“Person” will be broadly interpreted and includes (a) a natural person, whether acting in his or her own
capacity, or in his or her capacity as executor, administrator, estate trustee, trustee or personal or legal
representative; (b) a corporation or a company of any kind, a partnership of any kind, a sole
proprietorship, a trust, a joint venture, an association, an unincorporated association, an
unincorporated syndicate, an unincorporated organization or any other association, organization or
entity of any kind; and (c) a Governmental Authority.

“Primary System” means the Designated Equipment upon which the Software is installed and
executed to deliver its intended functionality.

“Released Claims” has the meaning ascribed to it in Section 9(b). 

“Released Parties” has the meaning ascribed to it in Section 9(b). 

“Ross Video” means Ross Video Limited and its Affiliates. 

“Software” means the version of the Object Code licensed and delivered to Licensee by Ross Video
concurrently with delivery of this Agreement, including without limitation the Freeware, and any
subsequent error corrections, updates, Modifications or Improvements provided to Licensee by Ross
Video pursuant to this Agreement, but specifically excluding any features or plug-ins that may be
purchased by you directly from third parties as upgrades or enhancements to the Software.

“Source Code” means the human readable form of a computer software program, and all tools and
documentation necessary for a reasonably competent computer programmer to understand, maintain
and Modify the Software.

“Third Party Software” means those portions of the Software, if any, which are owned or controlled
by third parties and licensed to Ross Video pursuant to certain license agreements or arrangements
with such third parties, including the Open Source Components and NDI®1 software (http://NDI.video);
and

“Use” means to execute, run, display, store, merge, network, Modify, translate, host or integrate with
Licensee’s products or other third party software.

1 NDI® is a registered trademark of Vizrt NDI AB.

http://NDI.video


3. LICENSE. Subject to the terms and conditions of this Agreement, upon payment of the applicable
License Fee by Licensee, or, in the case of Freeware only, upon download of the Software by Licensee
onto its Designated Equipment, Ross Video hereby grants to Licensee a non-transferable and non-
exclusive right to Use the Software and Documentation solely for the internal use of Licensee (the
“License”), during the License Period. In the event that a License Period is not identified on the Order,
such License Period shall be deemed to be perpetual, subject to paragraph 10 (c) of this Agreement.
The Software shall only be used in connection with or installed on the Designated Equipment and,
where applicable, shall only be used on the Primary System, provided such Primary System is operating
properly."

If the Primary System is not operating properly for any reason, the Software may be used on the
designated Backup System for that Primary System until such time that the Primary System begins
operating properly. The Software and Documentation are provided to Licensee for the exclusive use by
Licensee’s organization for its ordinary business purposes and shall not be used by any third party for
any purposes. Licensee may make copies of the Software as required for internal backup and archival
purposes. To the extent permitted hereunder, Licensee may distribute copies of the Software and/or
Documentation to members of its organization, provided (a) this Agreement is included with each copy,
(b) any member of its organization who uses the Software and/or Documentation accepts and agrees to
be bound by the terms of this Agreement and by any other license agreements or other agreement
incorporated by reference into this Agreement, and (c) Licensee has paid any applicable additional
License Fees in respect of copying and redistributing of the Software. To the extent Licensee is
permitted to make copies of the Software under this Agreement, Licensee agrees to reproduce and
include on any copy made or portion merged into another work, all Ross Video proprietary notices,
including any notices with respect to copyrights, trademarks and this License. With the exception of
copying the Software for backup or archival purposes, Licensee agrees to keep a record of the number
and location of all such copies and will make such record available at Ross Video’s request. The
Software may include mechanisms to limit or inhibit copying.

4. LICENSE RESTRICTIONS. Except as otherwise provided in section 3 above, Licensee shall not: (1)
copy any Software or Documentation, or part thereof, which is provided to Licensee by Ross Video
pursuant to this Agreement, in Object Code form, Source Code form or other human or machine
readable form, including written or printed documents, without the prior written consent of Ross Video;
(2) in any way market, distribute, export, translate, transmit, merge, Modify, transfer, adapt, loan,
rent, lease, assign, share, sub-license, sell, make available for download on any website or make
available to another Person, the Software and/or Documentation, in whole or in part, provided that
Licensee shall not be prohibited from renting or leasing the Software if Ross Video has consented, in
writing, to Licensee engaging in such activities in respect of the Software; (3) reverse engineer,
decompile or disassemble the Software or electronically transfer it into another computer language; or
(4) use the Software or Documentation in a manner that is inconsistent with the License granted
hereunder or that will result in a breach of this Agreement. Licensee agrees to take all reasonable
precautions to prevent third parties from using the Software and/or Documentation in any way that
would constitute a breach of this Agreement, including such precautions Licensee would ordinarily take
to protect its own proprietary software, hardware or information.

5. DELIVERY. Ross Video shall deliver to Licensee one (1) master copy of the Software in compiled
binary (executable) form suitable for reproduction in electronic files only and Ross Video shall deliver to
Licensee a minimum of one copy of the Documentation.

6. IMPROVEMENTS. Licensee may from time to time request Ross Video to incorporate certain
Improvements into the Software. Ross Video may, in its sole discretion, undertake to incorporate and
provide such Improvements to Licensee with or without payment of a fee to be negotiated at the time
of such request. All Improvements, whether recommended and developed by Ross Video or Licensee,
shall be considered the sole property of Ross Video and shall be used by Licensee pursuant to the terms
of the License granted under this Agreement.



7. FREEWARE. Other than the obligation to pay a License Fee, which does not apply to the Freeware, all
other provisions of this End User Software License Agreement apply to the Freeware in the same way
as they apply to all other Software that is the subject of this Agreement. In addition, in connection with
the Freeware, the following provisions apply: 

a. Licensee will not Use the Freeware to engage in or allow others to engage in any illegal activity.

b. Licensee will not Use the Freeware in any way that will interfere with or damage the operation of the
services of any third parties by overburdening/disabling network resources through automated
queries, excessive usage or similar conduct.

c. Licensee will not Use the Freeware to engage in any activity that will violate the rights of others,
including, without limitation, by using it for operations that involve child labour, suppressing the
right of freedom of expression or endangering the security of person.

8. OWNERSHIP. The Parties acknowledge and agree that, as between the Parties, Ross Video shall be
the owner of all intellectual property rights in the Software, Documentation and all related Modifications
and Improvements, written materials, logos, trademarks, trade names, copyright, patents, trade
secrets and moral rights, registered or unregistered. No proprietary interest or title in or to the
intellectual property in the Software, Documentation or any Improvements or Modifications is
transferred to Licensee by this Agreement. Ross Video reserves all rights not expressly licensed to
Licensee under section 3.

9. OPEN SOURCE SOFTWARE. 

a. Software may use and/or be provided with Open Source Components, including those detailed in the
Third Party section below. To the extent stipulated by its Open Source License, each such Open
Source Component is licensed directly to Licensee from its respective licensors and not sub-licensed
to Licensee by Ross Video, and such Open Source Component is subject to its respective Open
Source License, and not to this Agreement. If, and to the extent, an Open Source Component
requires that this Agreement effectively impose, or incorporate by reference, certain disclaimers,
permissions, provisions, prohibitions or restrictions, then such disclaimers, permissions, provisions,
prohibitions or restrictions shall be deemed to be imposed, or incorporated by reference into this
Agreement, as required, and shall supersede any conflicting provision of this Agreement, solely with
respect to the corresponding Open Source Component which is governed by such Open Source
License. 

b. If Licensee, or another party on Licensee’s behalf, modifies, replaces or substitutes any Open Source
Component used in or provided with this Software, Licensee hereby fully, forever, irrevocably and
unconditionally releases and discharges Ross Video, its Affiliates and its and their employees,
officers, directors, resellers, distributors and representatives (collectively, “Released Parties”) from
any and all claims, charges, complaints, demands, actions, causes of action, suits, rights, debts,
covenants, liabilities, warranties, performance and maintenance and support obligations
(collectively, “Released Claims”), of every kind and nature, with respect to such Software, including
without limitation any such Released Claims that arise as a matter of applicable Law. 

c. If an Open Source License requires that the source code of its corresponding Open Source
Component be made available to Licensee, and such source code was not delivered to Licensee with
the Software, then Ross Video hereby extends a written offer, valid for the period prescribed in such
Open Source License, to obtain a copy of the source code of the corresponding Open Source
Component, from Ross Video from https://www.rossvideo.com/open-source-information/.

https://www.rossvideo.com/open-source-information/


10. THIRD PARTY SOFTWARE. 

a. Licensee acknowledges that the Third Party Software is not owned by Ross Video. Notwithstanding
any other provision of this Agreement, Ross Video, to the extent permitted by applicable law, offers
no warranties (whether express, implied, statutory or by course of communication or dealing with
Licensee, or otherwise) with respect to the Third Party Software. Ross Video may pass through to
Licensee, if and to the extent permitted by applicable law, any warranties expressly provided by
such third parties to Ross Video for such Third Party Software.

b. FFmpeg Notice. The Software may utilize FFmpeg video components and their included libraries.
FFmpeg is a trademark of Fabrice Bellard (originator of the FFmpeg project). Ross Video disclaims
any ownership claim to FFmpeg. Please refer to http://ffmpeg.org (copyright is in the FFmpeg
developers). FFmpeg is licensed under the GNU Lesser General Public License v2.1 or Lesser General
Public License v3.0. GNU Lesser General Public License contact information: Free Software
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. Licensee can
distribute it and/or modify it under the terms of such licenses.

11. INTELLECTUAL PROPERTY INDEMNITY. 

a. Ross Video agrees to defend, indemnify and hold harmless Licensee from final damages awarded by
a court of competent jurisdiction (hereinafter referred to as the “Losses”), which Licensee, or any of
its officers or directors, may incur, suffer or become liable for as a result of, or in connection with,
any third party claim asserted against Licensee to the extent such claim is based on a contention
that the Software, Documentation or any portion thereof, infringes any valid, registered, enforceable
patents, copyrights, trade secrets, trademarks or other intellectual property rights of any third
party, provided that (a) the allegedly infringing Software or Documentation has been used within the
scope of and in accordance with the terms of this Agreement, and (b) Licensee notifies Ross Video in
writing of such claim within ten (10) days of a responsible officer of Licensee becoming aware of
such claim. If the Software, Documentation or any portion thereof is held to constitute an
infringement of a third party’s intellectual property rights, and use thereof is enjoined, Ross Video
shall, at its election and expense, either (i) procure the right to use the infringing element of the
Software or Documentation; or (ii) replace or modify the element of the Software or Documentation
so that the infringing portion is no longer infringing and still performs the same function without any
material loss of functionality. Ross Video shall make every reasonable effort to correct the situation
with minimal effect upon the operations of Licensee.

b. Notwithstanding the above, Ross Video reserves the right to terminate this Agreement and the
License granted hereunder on immediate notice to Licensee, and without liability to Licensee, in the
event that the Software or Documentation constitutes or may, in Ross Video’s determination,
constitute, an infringement of the rights of a third party that Ross Video, in its sole discretion, does
not consider to be affordably remediable.

c. Either party may terminate this Agreement immediately should any Software become, or in either
party's opinion be likely to become, the subject of a claim of infringement of any intellectual
property right and, in such event, there shall be no claim by either Licensee or Ross Video against
the other arising out of such termination, provided that the foregoing shall not apply to a claim for
infringement by Ross Video against Licensee in the event that Licensee is alleged to have infringed
Ross Video's intellectual property rights, in which case Licensee shall remain liable for all
outstanding License Fees and other amounts owing to Ross Video.

d. Notwithstanding the foregoing, Ross Video shall have no liability for any claim of infringement based
on use of other than a current, unaltered release of the Software and/or Documentation available
from Ross Video if such infringement would have been avoided by the use of a current, unaltered
release of the Software and/or Documentation provided that such current, unaltered release
performs substantially in conformity with the specifications set out in the Documentation and was
provided, at no additional cost by Ross Video, to those subscribing for maintenance services for the
Software or Documentation.



12. CONFIDENTIALITY. Each Party shall maintain in confidence all Confidential Information of the other
Party, shall use such Confidential Information only for the purpose of exercising its rights and fulfilling
its obligations under this Agreement, and shall not disclose any Confidential Information of the
disclosing Party to any third party except as expressly permitted hereunder or make any unauthorized
use thereof. Each Party shall disclose the Confidential Information only to those of its employees,
consultants, advisors, and/or subcontractors who have a need to know the Confidential Information.
Each Party shall, prior to disclosing the Confidential Information to such employees, consultants,
advisors and/or subcontractors, obtain their agreement to receive and use the Confidential Information
on a confidential basis on the same terms and conditions contained in this Agreement. The receiving
Party shall treat the Confidential Information of the disclosing Party with the same degree of care
against disclosure and/or unauthorized use as it affords to its own information of a similar nature, or a
reasonable degree of care, whichever is greater. The receiving Party further agrees not to remove or
destroy any proprietary or confidential legends or markings placed upon any documents or other
materials of the disclosing Party. The obligations of confidence set forth in this Agreement shall extend
to any Affiliates that have received Confidential Information of the disclosing Party and shall also cover
Confidential Information disclosed by any Affiliate. The receiving Party shall be responsible for any
actions or omissions of its Affiliates as if such actions or omissions were its own.

Either party may disclose certain Confidential Information if it is expressly required to do so pursuant to
legal, judicial, or administrative proceedings, or otherwise required by law, provided that (i) such Party
provides the other Party with reasonable written notice prior to such disclosure; (ii) such Party seeks
confidential treatment for such Confidential Information; (iii) the extent of such disclosure is only to the
extent expressly required by law or under the applicable court order; and (iv) such Party complies with
any applicable protective or equivalent order.

Each of Ross Video and Licensee (the “Indemnifying Party”, as applicable) agree to indemnify the
other (the “Indemnified Party”, as applicable) for all Losses incurred by the Indemnified Party as a
result of a failure of the Indemnifying Party to comply with its obligations under this Section 12
provided that the Indemnified Party has given prompt notice of any such claim and, to the extent that a
claim may lie against a third party for the unauthorized disclosure of such Confidential Information, the
right to control and direct the investigation, preparation, action and settlement of each such claim and,
further, provided that the Indemnified Party reasonably co-operates with the Indemnifying Party in
connection with the foregoing and provides the Indemnifying Party with all information in the
Indemnified Party’s possession related to such claim and such further assistance as reasonably
requested by the Indemnifying Party.

The Parties acknowledge and agree that any breach of the confidentiality provisions of this Agreement
by one Party may cause significant and irreparable injury to the other Party that is not compensable
monetarily, as well as damages that may be difficult to ascertain, and agrees that, in addition to such
other remedies that may be available at law or in equity, the other Party shall be entitled to seek
injunctive relief (including temporary restraining orders, interim injunctions and permanent injunctions)
in a court of competent jurisdiction in the event of the breach or threatened breach by such party of
any of the confidentiality provisions of this Agreement. The relief contemplated in this Section shall be
available to each Party without the necessity of having to prove actual damages and without the
necessity of having to post any bond or other security. Each Party further agrees to notify the other
Party in the event that it learns of or has reason to believe that any Person has breached the
confidentiality provisions of this Agreement.



13. LIMITATION OF LIABILITY. The limitation of liability provisions of this Agreement reflect an
informed voluntary allocation of the risks (known and unknown) that may exist in connection with the
licensing of the Software or Documentation hereunder by Ross Video, and that voluntary risk allocation
represents a material part of the Agreement reached between Ross Video and Licensee. Should Ross
Video be in breach of any obligation, Licensee agrees that Licensee’s remedies will be limited to those
set forth in this Agreement. No action, regardless of form, arising out of this Agreement may be
brought by Licensee more than twelve (12) months after the facts giving rise to the cause of action
have occurred, regardless of whether those facts by that time are known to, or reasonably ought to
have been discovered by, Licensee.

(A) EXCEPT AS EXPRESSLY PROVIDED IN THIS AGREEMENT, THE SOFTWARE AND DOCUMENTATION
ARE PROVIDED “AS IS” AND ROSS VIDEO (I) MAKES NO OTHER REPRESENTATIONS, AND PROVIDES
NO WARRANTIES OR CONDITIONS OF ANY KIND, EXPRESS OR IMPLIED, STATUTORY, BY USAGE OF
TRADE CUSTOM OF DEALING, OR OTHERWISE, AND (II) SPECIFICALLY DISCLAIMS ALL IMPLIED
WARRANTIES INCLUDING ANY IMPLIED WARRANTY OF UNINTERRUPTED OR ERROR FREE OPERATION,
MERCHANTABILITY, QUALITY OR FITNESS FOR A PARTICULAR PURPOSE. ROSS VIDEO DOES NOT
REPRESENT OR WARRANT THAT THE SOFTWARE WILL MEET ANY OR ALL OF LICENSEE’S PARTICULAR
REQUIREMENTS, THAT THE USE AND OPERATION OF THE SOFTWARE WILL OPERATE ERROR-FREE OR
UNINTERRUPTED, THAT ALL PROGRAMMING ERRORS IN THE SOFTWARE CAN BE FOUND IN ORDER TO
BE CORRECTED, OR THAT THE SOFTWARE WILL BE COMPATIBLE WITH OTHER PROGRAMS, SYSTEMS,
AND HARDWARE.

(B) IN NO EVENT SHALL ROSS VIDEO, ITS AFFILIATES AND LICENSORS, AND THEIR RESPECTIVE
DIRECTORS, OFFICERS, EMPLOYEES AND AGENTS, BE LIABLE FOR ANY CLAIM FOR INDIRECT,
CONSEQUENTIAL, SPECIAL, INCIDENTAL, PUNITIVE, EXEMPLARY, AGGRAVATED DAMAGES; LOST
PROFITS, OR LOST REVENUE ARISING FROM OR IN CONNECTION WITH THIS AGREEMENT,
REGARDLESS OF THE FORM OF ACTION, WHETHER IN CONTRACT, OR IN TORT, EVEN IF THE PARTY
HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

(C) IN ANY EVENT THE AGGREGATE LIABILITY OF ROSS VIDEO, ITS AFFILIATES AND LICENSORS, AND
THEIR RESPECTIVE DIRECTORS, OFFICERS, EMPLOYEES AND AGENTS, FOR ANY CLAIM FOR DIRECT
DAMAGES WITH RESPECT TO THE SUBJECT MATTER OF THIS AGREEMENT SHALL NOT EXCEED THE
AMOUNT OF THE PURCHASE PRICE PAID TO ROSS VIDEO UNDER THIS AGREEMENT.

14. TERM AND TERMINATION.

(1) Unless terminated earlier in accordance with the terms of this Agreement, the term of this
Agreement shall commence upon Licensee’s first download, access, installation, or other use of the
Software or Documentation and continues until, in the case of Software licensed with Designated
Equipment provided by Ross Video, the earliest of (a) the end of the License Period, or (b) if the
Designated Equipment is assigned or transferred in accordance with this Agreement, the date on
which the Designated Equipment is no longer owned by Licensee;

(2) Either Party shall have the right to terminate this Agreement on notice to the other Party if: 

(a) the other Party fails to pay any fees or other amounts when due hereunder or under any
other agreement between the Parties (or any Affiliates of the Parties, as applicable) in
connection with the Software and/or Designated Equipment and such breach is not cured
within thirty (30) days after written notice of such failure to pay is given to the defaulting
Party by the non-defaulting Party; 

(b) the other Party shall file a voluntary petition in bankruptcy or insolvency or shall petition for
reorganization under any bankruptcy law, consent to an involuntary petition in bankruptcy, or
if a receiving order is given against it under the Bankruptcy and Insolvency Act (Canada) or
the comparable law of any other jurisdiction (and such is not dismissed within ten (10) days);



(c) there shall be entered an order, judgment or decree by a court of competent jurisdiction,
upon the application of a creditor, approving a petition seeking reorganization or appointing a
receiver, trustee or liquidator of all or a substantial part of the other Party’s assets and such
order, judgment or decree continues in effect for a period of thirty (30) consecutive days; or

(d) the other Party shall fail to perform any of the other material obligations set forth in this
Agreement and such default, in the case of a default which is remediable, continues for a
period of thirty (30) days after written notice of such failure has been given by the non-
defaulting Party or, in the case of a non-remediable default, immediately upon notice.

(3) Notwithstanding anything to the contrary contained in this Agreement:

(a) Ross Video may forthwith terminate this Agreement if Licensee is in breach of any of sections
3, 4 or 12 of this Agreement. For greater certainty, in such instances Ross Video shall provide
written notice of such termination as soon as practicable but written notice shall not be a
necessary prerequisite to such termination; and

(b)  in the event of a Change of Control of Licensee, Ross Video shall have the right to terminate
this Agreement and the License granted hereunder upon thirty (30) days’ prior written notice
to Licensee. For greater certainty, Ross Video’s right to terminate in the event of a Change of
Control of Licensee shall continue for a period of six (6) months from the date Licensee
delivers notice of such Change of Control to Ross Video.

(c) Ross Video may terminate the License immediately on the date on which it provides notice to
Licensee, if its agreements for Third Party Software are terminated.

(4) Upon the termination or expiry of this Agreement:

(a) Licensee shall immediately cease and desist all use of the Software and Documentation;

(b) Licensee shall immediately deliver to Ross Video any of Ross Video’s Confidential Information
provided hereunder (including the Software and Documentation) then in its possession or
control, if any, and shall deliver a certificate of an officer of Licensee certifying the
completeness of same;

(c) Licensee shall refrain from further use of such Confidential Information; and

(d) Licensee shall forthwith pay all amounts owing to Ross Video or any of its Affiliates
hereunder.

15. SURVIVAL. The provisions of sections 1, 2, 6, 8, 9, 10, 11, 12, 13, 14, 18, 22, 23, and 24 herein shall
survive the expiry or termination of this Agreement.

16. FORCE MAJEURE. Dates and times by which Ross Video is required to render performance under this
Agreement shall be automatically postponed to the extent and for the period that Ross Video is
prevented from meeting them by reason of events of force majeure or any cause beyond its reasonable
control provided Ross Video notifies Licensee of the commencement and nature of such cause and uses
its reasonable efforts to render performance in a timely manner.

17. ASSIGNMENT. Ross Video may assign this Agreement, or any of its rights or obligations hereunder, in
whole or in part, upon notice to Licensee. Licensee shall not assign this Agreement, or any of its rights
or obligations hereunder, in whole or in part, without the prior written consent of Ross Video, which
consent may not be unreasonably withheld. This Agreement enures to the benefit of and is binding
upon each of the Parties and their respective successors and permitted assigns.



18. GOVERNING LAW. If Licensee acquired the Ross Product(s) in the United States or Canada, the laws
of the state or province where Licensee’s principal place of business is located govern the interpretation
of this Agreement, claims for its breach, and all other claims regardless of conflict of laws principles. If
Licensee acquired the Ross Product(s) in the European Union or the United Kingdom, then the laws of
England and Wales apply. If Licensee acquired the Ross Product(s) in any other country, then the laws
of the Province of Ontario, Canada shall apply.

19. LANGUAGE. The Parties have expressly required that this Agreement and all documents relating
thereto be prepared in English. Les parties ont expressément exigé que cette convention ainsi que tous
les documents qui s’y rattachent soient rédigés en anglais.

20. GOVERNMENT CONTRACTS. If the Software and/or Documentation to be furnished to Licensee
hereunder are to be used in the performance of a government contract or subcontract, the Software
and/or Documentation shall be provided on a "restricted rights" basis only and Licensee shall place a
legend, in addition to applicable copyright notices, in the form provided under the applicable
governmental regulations. For greater certainty, Ross Video shall not be subject to any flow-down
provisions required by any customer of Licensee that is a Governmental Authority unless Ross Video
expressly agrees to be bound by such flow-down provisions in writing.

21. EXPORT AND IMPORT LAWS. Licensee acknowledges and agrees that the Software (including any
technical data and related technology) may be subject to the export control laws, rules, regulations,
restrictions and national security controls of the United States and other applicable countries (the
“Export Controls”) and agrees not to export, re-export, import or allow the export, re-export or import
of such export-controlled Software (including any technical data and related technology) or any copy,
portion or direct product of the foregoing in violation of the Export Controls. Licensee hereby represents
that it is not an entity or person to whom provision of the Software (including any technical data and
related technology) is restricted or prohibited by the Export Controls. Licensee agrees that it has the
sole responsibility to obtain any authorization to export, re-export, or import the Software (including
any technical data and related technology), as may be required. Licensee will defend, indemnify and
hold Ross Video harmless from any and all claims, losses, liabilities, damages, fines, penalties, costs
and expenses (including attorney’s fees) arising from or relating to any breach by Licensee of its
obligations under this Section.

22. AMENDMENT AND WAIVER. No amendment, discharge, modification, restatement, supplement,
termination or waiver of this Agreement or any Section of this Agreement is binding unless it is in
writing and executed by the Party to be bound. No waiver of, failure to exercise or delay in exercising,
any Section of this Agreement constitutes a waiver of any other Section (whether or not similar) nor
does any waiver constitute a continuing waiver unless otherwise expressly provided.

23. SEVERABILITY. Each Section of this Agreement is distinct and severable. If any Section of this
Agreement, in whole or in part, is or becomes illegal, invalid, void, voidable or unenforceable in any
jurisdiction by any court of competent jurisdiction, the illegality, invalidity or unenforceability of that
Section, in whole or in part, will not affect (a) the legality, validity or enforceability of the remaining
Sections of this Agreement, in whole or in part; or (b) the legality, validity or enforceability of that
Section, in whole or in part, in any other jurisdiction.

24. ENTIRE AGREEMENT. This Agreement, and any other documents referred to herein, constitutes the
entire agreement between the Parties relating to the subject matter of this Agreement and supersedes
all prior written or oral agreements, representations and other communications between the Parties.

Updated: November 1, 2023



Warranty and Repair Policy

Ross Video Limited (Ross) warrants its XPression Clips systems to be free from defects under normal use
and service for the following time periods from the date of shipment:

· XPression Clips Server — 12 months

· XPression Clips Software Upgrades — 12 months free of charge

· System and Media hard drives — 12 months

If an item becomes defective within the warranty period Ross will repair or replace the defective item, as
determined solely by Ross.

Warranty repairs will be conducted at Ross, with all shipping FOB Ross dock. If repairs are conducted at the
customer site, reasonable out-of-pocket charges will apply. At the discretion of Ross, and on a temporary
loan basis, plug in circuit boards or other replacement parts may be supplied free of charge while defective
items undergo repair. Return packing, shipping, and special handling costs are the responsibility of the
customer.

This warranty is void if products are subjected to misuse, neglect, accident, improper installation or
application, or unauthorized modification.

In no event shall Ross Video Limited be liable for direct, indirect, special, incidental, or consequential
damages (including loss of profit). Implied warranties, including that of merchantability and fitness for a
particular purpose, are expressly limited to the duration of this warranty.

This warranty is TRANSFERABLE to subsequent owners, subject to Ross’ notification of change of ownership.

Extended Warranty

For customers that require a longer warranty period, Ross offers an extended warranty plan to extend the
standard warranty period by one year increments. For more information about an extended warranty for
your XPression Clips system, contact your regional sales manager.



Environmental Information

The equipment that you purchased required the extraction and use of natural resources for its production. It
may contain hazardous substances that could impact health and the environment.

To avoid the potential release of those substances into the environment and to diminish the need for the
extraction of natural resources, Ross Video encourages you to use the appropriate take-back systems. These
systems will reuse or recycle most of the materials from your end-of-life equipment in an environmentally
friendly and health conscious manner.

The crossed-out wheeled bin symbol invites you to use these systems.

If you need more information on the collection, reuse, and recycling systems, please contact your local or
regional waste administration.

You can also contact Ross Video for more information on the environmental performances of our products.



Company Address

Ross Video Limited 

8 John Street
Iroquois, Ontario
Canada, K0E 1K0

Ross Video Incorporated 

P.O. Box 880
Ogdensburg, New York
USA 13669-0880

General Business Office:

Fax:

(+1) 613 · 652 · 4886

(+1) 613 · 652 · 4425

Toll Free Technical Support: 1-844-652-0645 (North America)

+800 3540  3545 (International)

Alternately, you can contact:

Technical Support: (+1) 613 · 652 · 4886

After Hours Emergency: (+1) 613 · 349 · 0006

E-mail for Technical Support: techsupport@rossvideo.com

E-mail for General Information: solutions@rossvideo.com

Website: http://www.rossvideo.com

mailto:techsupport@rossvideo.com?Subject=Information Request&Body=Hi,%0D%0D
mailto:solutions@rossvideo.com?Subject=Information Request&Body=Hi,%0D%0D
http://www.rossvideo.com
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Introduction
Pre-rolls are a thing of the past with XPression Clips, a production clip server for live production that
incorporates the latest advances in IT technologies. Built on the industry-leading XPression real-time
graphics platform, XPression Clips offers you instant recall times and back-to-back clip transitions from an
intuitive user interface or via automation triggers from other devices like Ross Video productions switchers. 

You can simultaneously ingest multiple channels of baseband video and output multiple channels of clips to
air. Both NAS and SAN configurations are available for attached storage, in addition to ample local hard
drive space. Database management and synchronization are possible with the Clip Store that supports user
rights and roles. 

Key features of XPression Clips include:

· Multi-channel ingest and playout

· 1, 2, or 4 channels of baseband video ingest

· 2 or 4 channels of playout (user-definable fill/fill or fill/key configuration). Only one channel of 1080p 50
f/s or 1080p 59.94 f/s for fill/key.

· Back-to-back transitions

· Multiple clips on the same output

· Clip Browser with searching

· Clip trimming and looping

· VDCP, AMP, PBus, and RossTalk automation protocols

· PBus Manager for intelligent clip assignment

· Clip Manager application with user rights for database management and synchronization setup

· NAS or SAN attached storage with SNS storage (Studio Network Solutions)

Streamline your production clips workflow with Ross Video’s next-generation production clip servers and
transcoding applications. XPression Clips brings lightning-fast recall speeds, baseband video ingest, and
multi-layer clip playback to the control room.

For More Information on...

· VDCP and AMP protocols, refer to the Media Control Gateway section of the XPression Clips Workflow
User Guide.

· Clip Manager, refer to the XPression Clips Workflow User Guide.
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About This Guide

This user guide describes the XPression Clips workflow, its configuration, and functions.

If, at any time, you have a question pertaining to the installation, configuration, or operation of the
XPression Clips tools, please contact us at the numbers listed in the section Contacting Technical Support.
Our technical staff are always available for consultation, training, or service.

Documentation Conventions

Special text formats are used in this guide to identify parts of the user interface, text that a user must
enter, or a sequence of menus and sub-menus that must be followed to reach a particular command.

Bold text Bold text identifies a user interface element such as a dialog box, menu item, or
button.

For example:

In the Slug column, type a slug name for the story.

Italic text Italic text is used to identify the titles of referenced guides, manuals, or
documents.

For example:

For more information, refer to the DashBoard User Guide.

Courier text Courier text identifies text that a user must type.

For example:

In the Username box, type postgres.

Menu Sequences Menu arrows are used in procedures to identify a sequence of menu items that
you must follow.

For example:

If a step reads Server > Save As, you would select the Server menu and then
select Save As.

Hypertext Identifies a hyperlink to a related topic.
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Getting Help

The XPression Clips User Guide is supplied as a print-ready PDF file. Locate the guide in the C:\Archive
folder.

Contacting Technical Support

Special text formats are used in this guide to identify parts of the user interface, text that a user must
enter, or a sequence of menus and sub-menus that must be followed to reach a particular command.

Bold text Bold text identifies a user interface element such as a dialog box, menu item, or
button.

For example:

In the Slug column, type a slug name for the story.

Italic text Italic text is used to identify the titles of referenced guides, manuals, or
documents.

For example:

For more information, refer to the DashBoard User Guide.

Courier text Courier text identifies text that a user must type.

For example:

In the Username box, type postgres.

Menu Sequences Menu arrows are used in procedures to identify a sequence of menu items that
you must follow.

For example:

If a step reads Server > Save As, you would select the Server menu and then
select Save As.

Hypertext Identifies a hyperlink to a related topic.
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Installation Notes

NVIDIA Drivers

If NVIDIA drivers are installed while XPression is running and actively outputting graphics, the output will
turn green and not recover until XPression is restarted.

Windows® updates can install NVIDIA drivers automatically, which can create this situation.

Solution:

Schedule Windows updates for a time when XPression is not running.

XPression Updates

When installing a new XPression build or updates to XPression, if the installation is canceled before it
finishes, the existing framebuffers will be cleared and clips will not play out. 

Solution:

Reinstall XPression fully.
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User Interface Overview
The following screen capture displays the main elements of the XPression Clips user interface. Descriptions
of individual elements are contained in the legend below the diagram.

1. Menu Bar & Toolbar — access the File, Edit,
Windows, Projects, Display, Tools, and Help
menus. Use the toolbar to quickly access
XPression tools.

2. Project Manager — view and manage the
projects and project groups.

3. Server Channels — preview, playout, and edit
clips.

4. Preview — use this window to preview a
selected take item from the sequencer.

5. Output Monitors — select the output
framebuffer. Each output framebuffer contains
an infinite number of layers. The hierarchical
order for visibility runs from +# to -#, with
positive layers being the top layers and negative
layers being the lower layers.

6. Clip Browser — browse for clips to drop into the
Server Channels or Sequencer for preview and
playout. Clips can also be edited and sub clips
can be created.

7. Sequencer — view and control a list of take
items or take item groups to be played in the
order from top to bottom. A list is built by adding
take items from the Clip Browser.

8. Take Inspector — edit the properties of a
selected group or take item.
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System Setup
Before you start using XPression Clips to playout clips, it needs to be configured for your environment. In
addition to describing how to set preferences for XPression Clips, this section also describes how to
configure GPIs, video framebuffers, audio devices, video preview, and audio monitors.

«A backup copy of the preferences and hardware setup are created when changes in the Preferences and

Hardware Setup dialog box are made and OK is clicked, or when XPression is exited.

The following topics are discussed in this section:

Configuring XPression Clips for XPression Clip Store

Setting Preferences

Configuring an AJA NTV2 Video FrameBuffer

Configuring an AJA Video FrameBuffer (Legacy)

Configuring a Blackmagic Design FrameBuffer

Configuring a Blackmagic Design FrameBuffer (Legacy)

Configuring a Graphite FrameBuffer

Configuring a Matrox DSX, X.mio3 and X.mio5 FrameBuffer

Configuring a Matrox Video X.mio2 FrameBuffer

Configuring the NewTek™ Network Device Interface (NDI™)

Configuring an XPression Desktop Preview Client

Configuring an XPression RossLinq Connector

Configuring an XPression Virtual Output

Changing the Order of Video Inputs / Outputs

Deleting a Video Input / Output

Configuring an Audio Device

Deleting an Audio Device

Adding a Timecode Source

Configuring the Video Preview and Audio Monitor

Configuring RS232 CTS/DSR GPI for Contact Closures

Configuring a 25-Pin GPIO Port

Configuring a SeaLevel GPIO Board

Configuring Smart GPI / RossTalk

Configuring the PBus Interface and PBus Recalls

Setting Up Server Channels
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Configuring XPression Clips for the XPression Clips Store

1. Once the XPression Clip Store has been configured using the Clip Store Manager, XPression needs to
be set up for use with the Clip Store.

2. In XPression, select Edit > Clip Store Setup.

The Clip Store Setup dialog opens.

3. In the Hostname field, enter the IP address of the Clip Store service if using remotely. 

OR

If using the Clip Store service locally, use localhost (default).

4. In the Port field, enter or select the port number for the Clip Store server connection. 

The default port is 9595.

5. Select OK.

XPression is now connected to the Clip Store service.



8 • System Setup XPression Clips User Guide (12.5)

Setting Preferences

Before you start using XPression Clips, take some time to set up your project preferences.

To set preferences:

1. In XPression, select Edit > Preferences.

The Preferences window opens.

2. From the list on the left side, select a component.

3. Follow the instructions in the topics below to configure each component.

Editor Remote Server

Hardware Renderer CII

Folders RossTalk

On Disk Cache Video Engine

Sequencer ClipStore

Sequencer (cont.) As Run Log

MOS Settings Advanced

XML Take Item List
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Editor

Use the Editor panel to set project preferences for XPression Clips.

To configure the Editor settings:

1. Select Edit > Preferences. 

2. In the Preferences window, select the Editor panel.

 

3. In the On Startup section, select from the following options as needed:

· Select the Load Most Recent Project checkbox to automatically load the last opened project after
starting XPression.

· Select the Do Not Create Untitled Project chec box to avoid creating a new project when launching
XPression. 

This is useful for MOS workflows.

4. Select OK to close the Preferences window or select another panel to continue with configuring your
preferences.
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Hardware Renderer

Use the Hardware Renderer panel to select the graphics device installed in the XPression computer and
the Anti Alias quality and to optimize the GPU.

To configure the Hardware Renderer settings:

1. Select Edit > Preferences. 

2. In the Preferences window, select the Hardware Renderer panel.

3. From the Adapter drop-down, select the graphics device used by XPression to render scenes to output
framebuffers.

4. From the Anti-Alias drop-down, select the sampling value used to control the visual quality of rendered
output.

The higher the sampling value, the smoother the rendered graphic edges. The <none> option is equal
to 1x multi-sampling. 

For most situations, set the sampling value according to the best quality/performance ratio, usually
around 8x.

5. In the GPU Optimizations section, select Optimize NVIDIA settings on startup to optimize the
NVIDIA global settings on startup to disable options like Anti-aliasing Gamma Correction. 

This option is selected by default.

6. Select OK to close the Preferences window or select another panel to continue with configuring your
preferences.
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Folders

Use the Folders panel to select the folder used by XPression to store files created by the Record Client.

To configure the Folders options:

1. Select Edit > Preferences. 

2. In the Preferences window, select the Folders panel.

3. In the Record Folder section, from the Mode drop-down, select the mode of folder management to use
to store files created by the Record Client. 

The options are:

· Project | Last Used — save the files to the last folder used in a project folder for saving a file.

· Last Used — save the files to the last folder used for saving a file.

· Fixed — always save the files to the folder file path entered or selected in the Path field.

· Project — always save the files to the last project folder used for saving a file.

4. If using the Fixed folder mode, in the Path field, enter the full path to the folder in which to save files
created using the Record Client, or select Browse (...) to locate and select a folder.

5. Select OK to close the Preferences window or select another panel to continue with configuring your
preferences.
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On Disk Cache

Use the On Disk Cache panel to set the folder locations used by XPression to store cache files on disk.

To configure the Texture & Image Cache settings:

1. Select Edit > Preferences. 

2. In the Preferences window, select the On Disk Cache panel.

3. In the Shader Objects section, do the following:

· In the Path field, enter the full path to the folder in which to cache shader object files or select
Browse (...) to locate and select the Shader Objects Cache folder.

· In the Max Size field, enter or select the size limit in MB for the total of all the cache files stored in the
Shader Objects Cache folder.

4. In the MipMap Objects section, do the following:

· In the Path field, enter the full path to the folder in which to cache MipMap object files or select
Browse (...) to locate and select the MipMap Objects Cache folder.

· Select Limit Size to limit the total size of MipMap object files stored in the cache folder.

· In the Max Size field, enter or select the size limit in MB for the total of all the cache files stored in the
MipMap Objects Cache folder.

5. In the Thumbnail Cache section, do the following:

· In the Path field, enter the full path to the folder in which to cache thumbnails or select Browse (...)
to locate and select the Thumbnails Cache folder.

· In the Max Size field, enter or select the size limit in MB for the total of all the Thumbnail files stored
in the Thumbnails Cache folder.

6. Select OK to close the Preferences window or select another panel to continue with configuring your
preferences.
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Sequencer

Use the Sequencer panel to control the behavior of the sequencer.

To configure the Sequencer behavior:

1. Select Edit > Preferences. 

2. In the Preferences window, select the Sequencer panel.

3. In the Take Item List section, select from the following options as needed:

· Select Loop at end to automatically loop a sequence list when the end is reached manually.

· Select Center online item in view to position the active scene in a sequence list in the middle of the
view, provided the sequence list extends the size of the view.

· Select Center focused item in view to position a focused scene in a sequence list in the middle of
the view, provided the sequence list extends the size of the view.

4. In the Fast Recall section, select from the following:

· Select the Fast Recall enabled on startup to automatically enable fast recall in the sequencer on
startup.

· Select the Disable Fast Recall Input Timeout to turn off the user entered input timeout for Take
IDs in the sequencer.

· Select the Expand sequence groups when selecting an item with Fast Recall to expand the
parent group of an item when it is selected using Fast Recall.

5. Select OK to close the Preferences window or select another panel to continue with configuring your
preferences.
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Sequencer (cont.)

Use the Sequencer (cont.) panel to configure more options for controlling the behavior of the sequencer.

To configure the additional Sequencer behavior settings:

1. Select Edit > Preferences. 

2. In the Preferences window, select the Sequencer (cont.) panel.

3. In the Cueing section, select from the following options as needed:

· Select Cue should re-cue take items already on air to re-cue on air take items when the cue
button is pressed.

· Select Cue should re-cue server channels already playing to re-cue on air server channels when
the cue button is pressed.

· Select All cued items on a framebuffer should be put on-air when any one of them are taken
to take all cued items on a framebuffer on air when one of them is taken online.

4. In the Advanced section, select Disable saving of take item thumbnails to project to save projects
without take item thumbnails. 

This results in faster saving, but the thumbnails might need to be regenerated upon loading of the
project.

5. In the Preview section, select from the following options:

· Select Show transparency in sequencer preview to display transparency when previewing a take
item in the sequencer preview window. 

This option can also be applied by right-clicking in the sequencer Preview window and selecting Show
Transparency from the shortcut menu.

· Select Use Asterisk (*) key to play animated preview to enable the display of a live moving
preview in the sequence mode when the asterisk key (*) is pressed on the number pad.

· Select Render previews even when preview window is closed to allow for external previews to be
updated or for logic in OnPreviewRender scripts to be executed even when the preview window is
closed.

6. Select OK to close the Preferences window or select another panel to continue with configuring your
preferences.
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MOS Settings

Use the MOS Settings panel to configure the MOS settings when using XPression Clips within a MOS
workflow.

To configure the MOS settings:

1. Select Edit > Preferences. 

2. In the Preferences window, select the MOS Settings panel.

3. In the MOS Settings section, select from the following options as needed:

· Disable thumbnail rendering for take items created by automation — disable displaying scene
thumbnails in the Sequencer Playlist for MOS items.

· Save MOS created items to the project — save MOS items in the sequencer.

· Take IDs in loaded projects have precedence over MOS Take IDs — give priority to the take IDs
of take items from a subsequently loaded project over those from MOS.

· Maximum length for Content string — enter or select a maximum character length for the take
item content string in the sequencer.

· Starting Take ID for MOS created items — enter or select a take ID number at which to start the
MOS take IDs in the sequencer.

4. In the Advanced section, in the MOS Preview Threads field, enter or select the number of
simultaneous MOS previews that can be rendered at a time.

5. Select the Use advanced NLE stream compression checkbox to use RLE and LZO compression for
NLE if the network connection is saturated.

6. Select OK to close the Preferences window or select another panel to continue with configuring your
preferences.
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XML Take Item List

Use the XML Take Item List panel to configure the path and settings for XML Take Items.

To configure the XML Take Items settings:

1. Select Edit > Preferences. 

2. In the Preferences window, select the XML Take Item List panel.

3. In the XML Take Item List Watch Folder section, select Enabled to use XML Take Items from a
folder.

4. Select Delete source file after parsing to delete XML Take Items after they are parsed from the
selected folder.

5. In the Folder field, enter the full path to the folder containing the XML Take Items or select Browse
(...) to locate and select the folder.

6. In the XML Take Item List Importer section, select Allow deletion of online items to enable the
removal of take items that are currently active on an output.

7. From the After import sort items on drop-down, select a method to sort the imported take items. 

The available options are as follows:

· <do not sort> — do not sort the take items.

· take item id — sort the take items by ID.

· take item state — sort the take items by state.

· take item scene name — sort the take items by scene name.

· take item name — sort the take items by name.

· take item layer — sort the take items by layer.

· take item framebuffer — sort the take items by framebuffer.

8. Select Include groups when sorting to import the XML Take Items according to the groups to which
the items have been assigned.

9. Select OK to close the Preferences window or select another panel to continue with configuring your
preferences.
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Remote Server

Use the Remote Server panel to configure the TCP server settings.

To configure the TCP server settings:

1. Select Edit > Preferences. 

2. In the Preferences window, select the Remote Server panel.

3. In the TCP Server section, enter or select the port number for the remote server.

This is the port number on which XPression will listen for incoming connections from other applications
such as the MOS Gateway, CII gateway, and Media Control Gateway.

4. Select OK to close the Preferences window or select another panel to continue with configuring your
preferences.
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CII

Use the CII panel to configure the CII settings.

To configure the CII settings:

1. Select Edit > Preferences. 

2. In the Preferences window, select the CII panel.

3. In the CII Page Recall section, select Use Unique Gateway ID instead of Take Item ID to recall CII
pages using a Unique Gateway ID.

4. Select Process UPNEXT command even if no Preview Output is defined to process UPNEXT
commands from OverDrive when no preview output has been defined in the hardware setup.

5. Select OK to close the Preferences window or select another panel to continue with configuring your
preferences.
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RossTalk

Use the RossTalk panel to configure the RossTalk settings for XPression Clips.

To configure the RossTalk settings:

1. Select Edit > Preferences. 

2. In the Preferences window, select the RossTalk panel.

3. In the RossTalk Settings section, select Ignore TAKE / SEQI commands for items already online
to ignore TAKE and SEQI RossTalk commands for an item if it is already in the online state.

4. Select Apply template data changes to items already on-air to allow RossTalk TEMPLATEDATA
commands to update published fields in sequencer items that are already on-air. 

This option is selected by default.

5. Select OK to close the Preferences window or select another panel to continue with configuring your
preferences.
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Video Engine

Use the Video Engine panel to configure the cache size and select the CPU core of the video clients. You
can also cache video files and set the Input Cache Size.

To configure the video client settings:

1. Select Edit > Preferences. 

2. In the Preferences window, select the Video Engine panel.

3. In the Maximum Cache Size Per Video Client section, select Cache Clips on GPU instead of Host
Memory to cache directly on the GPU to improve playback performance.

If Cache Clips on GPU instead of Host Memory is selected, the GPU color space conversion option
is automatically enabled.

This option means that the XPVC2 video codec will provide XPression with YCoCg 4:2:2 data, which
requires less bandwidth than ARGB (4:4:4).

This option is only for XPVC2 and requires both XPression and the codec to be of build 12.4.6094 or later.

4. In the Size field, enter or select the maximum cache size in MB per video client.

5. In the Video Decoder Engine CPU Affinity section, select the CPU core of the video client.

6. In the Video File Disk Cache section, do the following:

· Select the Enable memory caching of video files to enable video file caching.

· In the Size field, enter or use the arrows to select the size (in GB) of the video file cache.

· In the Threads field, enter or use the arrows to select the number of threads to use for simultaneous
loading of video data into memory.

7. In the Record Settings section, in the Input Cache Size field, enter or select the number of frames to
cache when recording with the Record Client.

8. Select OK to close the Preferences window or select another panel to continue with configuring your
preferences. 
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ClipStore

Use the ClipStore panel to configure the ClipStore Texture Shader options for XPression Clips.

To configure the ClipStore Texture Shader option:

1. Select Edit > Preferences. 

2. In the Preferences window, select the ClipStore panel.

3. In the ClipStore Options section, select from the following as needed:

· Use texture shader for playing back stills from ClipStore to assign ClipStore stills to published
material using a texture shader instead of a video shader.

· Pre-fetch all ClipStore info for Sequencer purposes to speed up cueing take items containing
several clips from the ClipStore.

4. Select OK to close the Preferences window or select another panel to continue with configuring your
preferences.
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As Run Log

Use the As Run Log panel to configure the file settings and format for the XPression As Run Log. 

The As Run Log is located in C:\Program Files (x86)\XPressionClips\logs\AsRun.

To configure the As Run Log settings:

1. Select Edit > Preferences. 

2. In the Preferences window, select the As Run Log panel.

3. In the File Settings section, from the Log Rotation drop-down, select the frequency with which the
logging takes place. 

The available options are:

· Daily 

· Weekly 

· Monthly 

4. In the Limit number of logs to field, enter or select the maximum number of log files to keep.

«XPression Clips needs to be restarted for any changes to the file settings to take effect.

5. In the Format section, select Use Standard As Run Log Formatter Layout to set the As Run Log
format to the standard layout required by the (external) XPression As Run Log formatter.

6. In the text field, enter a tag string for the items you want to log. 

Use the example string and output to assist in constructing the format using the available tags.

7. In the Maximum length for Take Item Content string field, enter or select a maximum character
length for the take item content string logged in the As Run Log.

8. Select OK to close the Preferences window or select another panel to continue with configuring your
preferences.
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Advanced

Use the Advanced panel to manage screen settings.

To configure the screen settings:

1. Select Edit > Preferences. 

2. In the Preferences window, select the Advanced panel.

3. In the XPression Process section, from the Priority drop-down, select the CPU usage priority for
XPression. 

The available CPU usage priorities are:

· Normal — evenly distribute the CPU time between system processes with similar priority.

· High — give XPression preference and allocate the majority of the CPU time to XPression.

· Real-Time — allocate all CPU time to XPression.

«Use the Real-Time CPU usage priority with caution, as this priority may cause other applications

running on the XPression computer to freeze.

4. Select Allow Monitor Power Saving to allow the monitor to run in sleep mode.

5. Select Allow Screen Saver to allow the screen saver to run. 

«A screen saver may compromise output performance. For maximum performance, clear this checkbox

to stop the screen saver from running on the XPression computer.

6. Select Disable Initialization of Human Interface Devices to ignore a 3Dconnexion 3D mouse
connected to an XPression system.
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7. In the Video Export Settings section, do the following:

· In the Path to FFMPEG.exe field, enter the full path to an FFMPEG executable or select Browse (...)
to locate the executable (if using XPression 64-bit).

«XPression 64-bit editions cannot use QuickTime for export, so it is necessary to use a user-supplied

FFMPEG version to perform a .MOV export.

· Select the Render clip proxies for MOS workflows checkbox, to automatically generate proxies
when clips are created in the Sequencer and/or sent to the clipstore directly from the Record Client.

8. Select OK to close the Preferences window.
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Configuring an AJA NTV2 Video FrameBuffer

This topic describes the selection and configuration of an AJA NTV2 video framebuffer.

To select an AJA NTV2 Video FrameBuffer:

1. In XPression Clips, select Edit > Hardware Setup.

The Hardware Setup dialog opens.

2. Select the Inputs / Outputs tab.

3. Select Add.

The Add New FrameBuffer Board dialog opens.

4. From the Brand drop-down, select AJA NTV2 Video.

5. Select OK.

The AJA NTV2 Video - Framebuffer Setup dialog opens.

Continue with configuring the Hardware, GenLock and I/O settings in the Board tab.

When the configuration is complete, the configured AJA NTV2 Video framebuffer board is added to the
Inputs / Outputs tab of the Hardware Setup dialog.

6. Select Close to exit the Hardware Setup dialog.
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Board

This section describes how to configure an AJA NTV2 video framebuffer board.

To configure the AJA NTV2 Video FrameBuffer Board:

1. Select the Board tab.

2. Configure the following settings:

Hardware 

Genlock

I/O Configuration

Hardware

To configure the Hardware board:

· In the Hardware section, from the Board drop-down, select the installed board.

This menu is automatically populated based on installed hardware (such as Corvid22, Corvid88, Kona IP).
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Genlock

· In the GenLock section, from the Source drop-down, select the source of the GenLock signal with which
to synchronize XPression Clips. 

The available GenLock signal sources are as follows:

External Reference — Synchronize with a GenLock signal received from an external application through
the GenLock In port of the XPression Clips computer. Ross Video recommends using an external reference
for the GenLock signal source.

Input 1 — Sync to Video In 1 source signal.

Input 2 — Sync to Video In 2 source signal.

Input 3 — Sync to Video In 3 source signal.

Input 4 — Sync to Video In 4 source signal.

Input 5 — Sync to Video In 5 source signal.

Input 6 — Sync to Video In 6 source signal.

Input 7 — Sync to Video In 7 source signal.

Input 8 — Sync to Video In 8 source signal.

Free Running — Do not synchronize XPression Clips with an external source.

«The availability of inputs depends on the output board of the XPression Clips system. For example: up

to two inputs with the Corvid22 or up to eight inputs with the Corvid88.

«If the output keying mode is set to Internal in the Output tab, it is recommended that the GenLock

source be set to an SDI input.



28 • System Setup XPression Clips User Guide (12.5)

I/O Configuration

1. In the I/O Configuration section, select Add to add an input or output channel.

The Select I/O Type dialog opens.

2. From the Type drop-down, select an input /output type. 

The options are:

· <none> (this option is not applicable)

· Fill-Only Output (1 output, no input) (requires a separate license or the XPression Clips option)

· Fill/Key Outputs (2 outputs, no input)

· Fill Input (1 input, no output)

· Internal Keyer (1 input, 1 output)

«If the installed card does not have bidirectional I/Os, adding the output channels before the input

channels is recommended.

3. Select OK.

The input/output assignment is added to the I/O Configuration list.

4. Repeat steps 1 to 3 to add as many input and output channels as necessary.

«SDI channel assignments are automatic and any channels beyond the number of channels supported

by the graphics card will be listed as N/A.

Continue with configuring the Output settings.
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Outputs

This section describes how to configure the output channels of an AJA NTV2 video framebuffer.

To configure the Output Channels:

1. Select an Output tab to configure output channel settings.

2. In the Video Mode section, from the Standard drop-down, select the video format in which to output
an XPression Clips project.

«When configuring more than one output, they must share the same base frame rate that matches the

GenLock reference.

The available formats depend on the graphics card in your system.

Video Formats

· <from project> — automatically switch the output video format to the video format of the currently
loaded project.

The project video format is ignored when a specific output video format is selected, and the selected
video format is used to play out scenes.

· PAL, 720x576, 25 frames/second 

· NTSC, 720x486, 29.97 frames/second 

· HD 1080i, 1920x1080, 25 frames/second 

· HD 1080i, 1920x1080, 29.97 frames/second 

· HD 1080p, 1920x1080, 23.976 frames/second 

· HD 1080p, 1920x1080, 29.97 frames/second 
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· HD 1080p, 1920x1080, 50 frames/second 

· HD 1080p, 1920x1080, 59.94 frames/second 

· HD 1080p, 1920x1080, 60 frames/second 

· HD 720p, 1280x720, 50 frames/second 

· HD 720p, 1280x720, 59.94 frames/second 

· HD 720p, 1280x720, 60 frames/second 

· HD 1080psf, 1920x1080 23.976 frames/second 

· HD 1080psf, 1920x1080 24 frames/second 

· HD 1080psf, 1920x1080 25 frames/second 

· HD 1080psf, 1920x1080 29.97 frames/second 

· HD 1080psf, 1920x1080 30 frames/second 

· UHD 2160p (Quad), 3840x2160, 29.97 frames/second 

· UHD 2160p (Quad), 3840x2160, 50 frames/second 

· UHD 2160p (Quad), 3840x2160, 59.94 frames/second 

· UHD 2160p (2SI), 3840x2160, 29.97 frames/second 

· UHD 2160p (2SI), 3840x2160, 50 frames/second 

· UHD 2160p (2SI), 3840x2160, 59.94 frames/second 

· UHD 2160psf (Quad), 3840x2160, 23.976 frames/second 

· UHD 2160psf (Quad), 3840x2160, 24 frames/second 

· UHD 2160psf (Quad), 3840x2160, 25 frames/second 

«UHD formats are only available on cards that support UHD.

3. In the Keying section, from the Mode drop-down select how graphics are output to a video stream. 

The available modes are as follows:

· Off (Fill Only) — output a video signal with no key.

· External — output the key and fill graphics as separate video signals. Graphics mixing occurs in an
external keyer/mixer.

· Internal — key and fill graphics are mixed internally and output as a single video signal from the
framebuffer. In this mode the framebuffer functions as the keyer/mixer.

«Selecting external or internal keying will change the number of inputs/outputs required and the I/O

assignments in the Board tab.

«If the output keying mode is set to Internal, it is recommended that the GenLock source in the Board

tab be set to an SDI input.
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4. When External is selected from the Mode drop-down, use the Fill drop-down to select the method used
to process fill graphics before output. 

The available processing methods are as follows:

· Shaped (premultiplied) — multiply/shape the fill signal color information by the luminance
information in the key signal.

· Unshaped — output fill and key signals “as is”.

5. In the Hardware Buffers section, in the Queue Size field, enter or select the number of frames to
buffer in memory before sending to the output.

Use this setting to avoid buffer under runs, which may cause frame skipping. Larger queue sizes ensure
smooth playout of generated graphics, but add delay to the output.

6. In the Pre Queue field, enter or select the number of frames to buffer for the pre-queue. 

The pre-queue size can be between 1 and 8.

7. In the Audio section, select the Audio Loop Through checkbox to enable embedded audio loop
through. 

This option applies to internal keyer only.

8. In the Ancillary Data section, select the Pass Ancillary Data From checkbox and from the drop-down,
select an input from which to pass the vertical ancillary data from a live source. 

The functionality of this feature is based on the availability of an ancillary input that is determined by the
installed output board.

9. In the Misc section, select the Output Super Black and Super White to output using the full super
black to super white range.

Continue with configuring the Input settings.
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Inputs

This section describes how to configure the input channels of an AJA NTV2 video framebuffer.

To configure the input channels:

1. Select the Input tab to configure input settings.

2. In the Video Mode section, from the Standard drop-down, select the video format in which to receive
video.

3. In the Hardware Buffers section, in the Queue Size field, enter or select the number of frames to
buffer in memory before sending to XPression Clips.

4. In the Input to Output Latency section, in the Latency field, enter or select a fixed delay, in frames,
between the input and output. 

To remain fixed, the delay must be large enough to accommodate the Queue Size and Pre Queue
values in the Hardware Buffers section.

Continue with configuring the Miscellaneous settings.
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Misc

This section describes how to configure the miscellaneous settings of an AJA NTV2 video framebuffer.

To configure the miscellaneous settings:

1. Select the Misc tab.

«Analog output and HDMI output are only available on cards that provide them.

2. In the Analog Output Mode section, from the Mode drop-down, select the video format in which to
output an analog video signal.

3. In the HDMI Output Mode section, from the Color Space drop-down, select the specific organization of
colors for the HDMI output. 

The options are:

· YCbCr 

· RGB 

4. From the Range drop-down, select the color range for the selected color space. 

The options are:

· SMPTE Range 

· Full Range 
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5. From the Bit Depth drop-down, select the number of bits used for a pixel. 

The options are:

· 8-bit 

· 10-bit 

6. From the Audio Channels drop-down, select the number of audio channels to output. 

The options are:

· 2 channels 

· 8 channels 

7. In the Digital Output Timing Offset section, enter the following information:

· In the Horizontal field, enter or select the horizontal delay timing offset with regards to an external
reference. 

This setting is for external reference only.

· In the Vertical field, enter or select the number of lines for vertical delay timing offset with regards to
an external reference. 

This setting is for external reference only.

8. In the Finalization section, from the Shutdown drop-down, select the video state at shutdown. 

The available states are as follows:

· Retain Current State — do not clear the content of the framebuffers on shutdown.

· Clear Framebuffers — clear all framebuffers from the output framebuffer.

If the installed card provides up/down conversion, continue with the Conversion settings to enable or
disable output conversion to a predefined signal. 

Otherwise, continue with configuring the IP settings.
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Conversion

This section describes how to configure the conversion settings of an AJA NTV2 video framebuffer.

To configure the conversion settings:

1. Select the Conversion tab to enable or disable output conversion to a predefined signal. 

2. In the Up/Down Conversion section, from the Conversion drop-down, select the video mode for the
conversion.

3. From the Up drop-down, select a format for the up converted output. 

The available output formats are:

· Anamorphic — display a full-screen image.

· Pillar box 4:3 — display a 4:3 image in the center of the screen with black sidebars.

· Zoom 14:9 — display a 4:3 image zoomed to fill a 14:9 image with black sidebars.

· Letterbox — display an image zoomed to fill letterbox displays or display a reduced image with black
bars added to top and bottom of the image area with aspect ratio preserved.

· Zoom Wide — display an image zoomed and horizontally stretched to fill full screen.

4. From the Down drop-down, select a format for the down converted output. 

The available output formats are:

· Letterbox — display a reduce image with black bars added to the top and bottom of the image area
with the aspect ratio preserved.

· Crop — crop the image to fit the new screen size.

· Anamorphic — display a 16:9 image in a 4:3 box.
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5. In the Conversion Path section, select the checkbox or checkboxes of the outputs to use to display the
converted video:

· SDI Output (Channel 1) 

· Analog Output 

· HDMI Output 

If configuring a Kona IP card, continue with configuring the IP settings.

Otherwise, your AJA NTV2 framebuffer is now fully configured.
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IP

This section describes how to configure the IP settings of an AJA NTV2 video framebuffer.

The settings in the IP tab will depend on the card firmware configuration. There are 2 options:

1-SFP — the primary streams will be on the top SFP module. If 1-SFP is enabled with 2022-7 protocol, the
bottom SFP module will be used for the redundant streams.

See the following sections for instructions:

Configuring the IP Settings with Redundancy

Configuring the IP Settings without Redundancy

2-SFP, the same primary streams will be on the top SFP module and others on the bottom SFP module. 

Specifically:

· output streams 1 and 2 on the bottom

· output streams 3 and 4 on the top

· input streams 1 and 2 on the top

· input streams 3 and 4 on the bottom

See the following section for instructions:

2-SFP



38 • System Setup XPression Clips User Guide (12.5)

1-SFP

This section describes the configuration for a 1-SFP module setup, with and without redundancy.

Configuring the IP settings with Redundancy

If you are using a second SFP module to provide redundancy, the output streams will include both a primary
and secondary stream.

To configure the Network settings with redundancy:

1. Select the IP tab.

The IP tab is displayed.

2. In the Network section, select the Enable 2022-7 checkbox to use the 2022-7 standard to enable
redundancy for the SFP module connection. 

3. In the SFP Top and SFP Bottom tabs, in the Local IP Address field, enter the IP address of the
location to connect the small form-factor pluggable transceiver.

4. In the Subnet Mask field, enter the subnet mask of the location to connect the small form-factor
pluggable transceiver.

5. In the Gateway Address field, enter the IP address of the location to connect the small form-factor
pluggable transceiver.

6. Continue with configuring the Output Streams.
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To configure the Output Streams:

1. In the Output Streams section, select an output stream and then select Configure.

The AJA NTV2 - IP Output Stream Setup dialog opens.

2. In the Primary Output Stream - SFP Top section, configure the following settings:

· Source Port — use this box to enter or select the port number of the primary output stream source.

· Remote IP Addr — use this box to enter the remote IP address of the primary output stream.

· Remote Port — use this box to enter or select the remote port number for the primary output stream.

3. In the Secondary Output Stream - SFP Bottom section, configure the following settings:

· Source Port — use this box to enter or select the port number of the secondary output stream source.

· Remote IP Addr — use this box to enter the remote IP address of the secondary output stream.

· Remote Port — use this box to enter or select the remote port number for the secondary output
stream.

4. Select OK.

The AJA NTV2 - IP Output Stream Setup dialog closes and the settings are added to the selected
output stream.

5. Repeat steps 1 to 4 for any other output streams.

6. Continue with configuring the Input Streams.
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To configure the Input Streams:

1. In the Input Streams section, select an input stream and then select Configure.

The AJA NTV2 - IP Input Stream Setup dialog opens.

2. In the Primary Input Stream - SFP Top section, configure the following settings:

· Remote IP Addr — use this box to enter the remote IP address of the primary video input stream.

· Remote Port — use this box to enter or select the remote port number for the primary video input
stream.

· Match Port — select this check box to enable that the remote IP address and remote port must
match. When not selected, only the remote IP address needs to match and the remote port is ignored.

3. In the Secondary Input Stream - SFP Bottom section, configure the following settings:

· Remote IP Addr — use this box to enter the remote IP address of the secondary video input stream.

· Remote Port — use this box to enter or select the remote port number for the secondary video input
stream.

· Match Port — select this check box to enable that the remote IP address and remote port must
match. When not selected, only the remote IP address needs to match and the remote port is ignored.

4. Select OK.

The AJA NTV2 - IP Input Stream Setup dialog closes and the settings are added to the selected input
stream.

5. Repeat steps 1 to 4 for any other input streams.

6. When you have finished configuring the input streams, in the Hardware Setup dialog, select Close.

The Hardware Setup dialog closes.

The configured AJA Video framebuffer board is added to the Inputs / Outputs tab of the Hardware
Setup dialog.
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Configuring the IP Settings without Redundancy

If you do not require redundancy, you will only have primary output and input streams.

To configure the Network settings without redundancy:

1. Select the IP tab.

The IP tab is displayed.

2. In the Network section, in the SFP Top and SFP Bottom tabs, in the Local IP Address field, enter the
IP address of the location to connect the small form-factor pluggable transceiver.

3. In the Subnet Mask field, enter the subnet mask of the location to connect the small form-factor
pluggable transceiver.

4. In the Gateway Address field, enter the IP address of the location to connect the small form-factor
pluggable transceiver.

5. Continue with configuring the Output Streams.
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To configure the Output Streams:

1. In the Output Streams section, select an output stream and then select Configure.

The AJA NTV2 - IP Output Stream Setup dialog opens.

2. Configure the following settings:

· Source Port — enter or select the port number of the primary output stream source.

· Remote IP Addr — enter the remote IP address of the primary output stream.

· Remote Port — enter or select the remote port number for the primary output stream.

3. Select OK.

The AJA NTV2 - IP Output Stream Setup dialog closes and the settings are added to the selected
output stream.

4. Repeat steps 1 to 3 for any other output streams.

5. Continue with configuring the Input Streams.

To configure the Input Streams:

1. In the Input Streams section, select an input stream and then select Configure.

The AJA NTV2 - IP Input Stream Setup dialog opens.

2. Configure the following settings:

· Remote IP Addr — enter the remote IP address of the primary video input stream.

· Remote Port — enter or select the remote port number for the primary video input stream.

· Match Port — select this checkbox to require that the remote IP address and remote port match. 

«When not selected, only the remote IP address needs to match and the remote port is ignored.

3. Select OK.

The AJA NTV2 - IP Input Stream Setup dialog closes and the settings are added to the selected input
stream.

4. Repeat steps 1 to 3 for any other input streams.

5. When you have finished configuring the input streams, in the Hardware Setup dialog, select Close.

The Hardware Setup dialog closes.

The configured AJA Video framebuffer board is added to the Inputs / Outputs tab of the Hardware
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Setup dialog.
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2-SFP

This section describes the configuration for a 2-SFP module setup.

1. Select the IP tab.

2. The IP tab is displayed.

3. In the Network section, in the SFP Top and SFP Bottom tabs, in the Local IP Address field, enter the
IP address of the location to connect the small form-factor pluggable transceiver.

4. In the Subnet Mask field, enter the subnet mask of the location to connect the small form-factor
pluggable transceiver.

5. In the Gateway Address field, enter the IP address of the location to connect the small form-factor
pluggable transceiver.

6. Continue with configuring the Output Streams.
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To configure the Output Streams:

1. In the Output Streams section, select an output stream and then select Configure.

The AJA NTV2 - IP Output Stream Setup dialog opens.

2. In the Primary Output Stream - SFP Top section, configure the following settings:

Source Port — enter or select the port number of the primary output stream source.

Remote IP Addr — enter the remote IP address of the primary output stream.

Remote Port — enter or select the remote port number for the primary output stream.

3. In the Secondary Output Stream - SFP Bottom section, configure the following settings:

Source Port — enter or select the port number of the secondary output stream source.

Remote IP Addr — enter the remote IP address of the secondary output stream.

Remote Port — enter or select the remote port number for the secondary output stream.

4. Select OK.

The AJA NTV2 - IP Output Stream Setup dialog closes and the settings are added to the selected
output stream.

5. Repeat steps 1 to 3 for any other output streams.

6. Continue with configuring the Input Streams.
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To configure the Input Streams:

1. In the Input Streams section, select an input stream and then select Configure.

The AJA NTV2 - IP Input Stream Setup dialog opens.

2. Configure the following settings:

· Remote IP Addr — use this box to enter the remote IP address of the primary video input stream.

· Remote Port — use this box to enter or select the remote port number for the primary video input
stream.

· Match Port — select this check box to enable that the remote IP address and remote port must
match. When not selected, only the remote IP address needs to match and the remote port is ignored.

3. Select OK.

The AJA NTV2 - IP Input Stream Setup dialog closes and the settings are added to the selected input
stream.

4. Repeat steps 1 to 3 for any other input streams.

5. Select OK.
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Configuring an AJA Video FrameBuffer (Legacy)

This topic describes the selection and configuration of an AJA Video framebuffer.

To configure an AJA Video framebuffer:

1. In XPression Clips, select Edit > Hardware Setup.

The Hardware Setup dialog opens.

2. Select the Inputs / Outputs tab.

3. Select Add.

4. The Add New FrameBuffer Board dialog opens.

5. From the Brand drop-down, select AJA Video (legacy) and then select OK.

6. Select OK.

The AJA Video (Legacy) - Framebuffer Setup dialog opens.

Continue with configuring the Board settings.

When the configuration is complete, the configured AJA Video framebuffer board is added to the
Inputs / Outputs tab of the Hardware Setup dialog.

7. Select Close to exit the Hardware Setup.
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Board

This section describes how to configure the AJA video framebuffer board.

To configure the AJA video framebuffer board:

1. Select the Board tab.

2. In the Hardware section, from the Board drop-down, select the installed board.

This menu is automatically populated based on installed hardware.

3. In the GenLock section, from the Source drop-down, select the source of the GenLock signal with which
to synchronize XPression Clips. 

The available GenLock signal sources are as follows:

External Reference — Synchronize with a GenLock signal received from an external application
through the GenLock In port of the XPression Clips computer. 

«Ross Video recommends using an external reference for the GenLock signal source.

Input 1 — Sync to Video In 1 source signal.

Input 2 — Sync to Video In 2 source signal.

Free Running — Do not synchronize XPression Clips with an external source.

«If the output keying mode is set to Internal in the Output tab, the GenLock source needs to be set to

an SDI input.

Continue with configuring the Output settings.
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Outputs

This section describes how to configure the outputs of the AJA video framebuffer.

To configure the outputs:

1. Select the Output tab.

2. In the Video Mode section, from the Standard drop-down, select the video format in which to output
an XPression Clips project. 

«When configuring more than one output, they must share the same base frame rate that matches the

GenLock reference.

The available video formats are:

· <from project> — automatically switch to the output video format to the video format of the
currently loaded project.

The project video format is ignored when a specific output video format is selected, and the selected
video format is used to play out scenes.

· PAL, 720x576, 25 frames/second 

· NTSC, 720x486, 29.97 frames/second 

· HD 1080i, 1920x1080, 25 frames/second 

· HD 1080i, 1920x1080, 29.97 frames/second 

· HD 1080p, 1920x1080, 23.976 frames/second 

· HD 1080p, 1920x1080, 50 frames/second 

· HD 1080p, 1920x1080, 59.94 frames/second 

· HD 1080p, 1920x1080, 60 frames/second 

· HD 720p, 1280x720, 50 frames/second 

· HD 720p, 1280x720, 59.94 frames/second 
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3. In the Keying section, from the Mode drop-down, select how graphics are output to a video stream.

The available modes are as follows:

· External — Output the key and fill graphics as separate video signals. Graphics mixing occurs in an
external keyer/mixer.

· Internal — Key and fill graphics are mixed internally and output as a single video signal from the
framebuffer. In this mode the framebuffer functions as the keyer/mixer.

4. When External is selected as the keying mode, from the Fill drop-down, select the method used to
process fill graphics before output. 

The available processing methods are:

Shaped (premultiplied) — Multiply/shape the fill signal color information by the luminance information
in the key signal.

Unshaped — Output fill and key signals “as is”.

5. In the Hardware Buffers section, in the Queue Size field, enter or select the number of frames to
buffer in memory before sending to the output.

«Use this setting to avoid buffer under runs, which may cause frame skipping. Larger queue sizes

ensure smooth playout of generated graphics, but add delay to the output.

6. In the Up/Down Conversion section, from the Conversion drop-down, select whether to enable or
disable output conversion to a predefined signal.

7. From the Path drop-down, select the source display on the output.

8. From the Up drop-down, select the format for up converted output. 

The available output formats are:

· Anamorphic — Display a full-screen image.

· Pillar box 4:3 — Display a 4:3 image in the center of the screen with black sidebars.

· Zoom 14:9 — Display a 4:3 image zoomed to fill a 14:9 image with black sidebars.

· Letterbox — Display an image zoomed to fill full screen.

· Zoom Wide — Display an image zoomed and horizontally stretched to fill full screen.

9. From the Down drop-down, select the format for down converted output. 

The available output formats are:

· Letterbox — Display a reduce image with black bars added to the top and bottom of the image area
with the aspect ratio preserved.

· Crop — Crop the image to fit the new screen size.

· Anamorphic — Display a 16:9 image in a 4:3 box.

Continue with configuring the Input settings.
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Inputs

This section describes how to configure the inputs of the AJA video framebuffer.

To configure the inputs:

1. Select the Input tab.

2. In the Video Mode section, from the Standard drop-down, select the analog video format in which to
receive video.

3. In the Hardware Buffers section, in the Queue Size field, enter or select the number of frames to
buffer in memory before sending to XPression Clips.

Continue with configuring the Miscellaneous settings.
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Misc

This section describes how to configure the miscellaneous settings of the AJA video framebuffer.

To configure the miscellaneous settings:

1. Select the Misc tab.

2. In the Analog Output Mode section, from the Mode drop-down, select the video format in which to
output an analog video signal.

3. In the Digital Output Timing Offset section, in the Horizontal field, enter or select the number of
lines for horizontal delay timing offset with regards to an external reference.

4. In the Vertical field, enter or select the number of lines for vertical delay timing offset with regards to
an external reference.

5. In the Initialization / Finalization section, from the Startup drop-down, select the video state at
startup. 

The available states are:

· Retain Current State — Retain resources to use once again.

· Clear Framebuffers — Clear all framebuffers from the output framebuffer.

6. From the Shutdown drop-down, select the video state at shutdown. 

The available states are:

· Retain Current State — Retain resources to use once again.

· Clear Framebuffers — Clear all framebuffers from the output framebuffer.

7. In the Audio section, select the Audio Loop Through checkbox to enable embedded audio loop
through.

8. Select OK.
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Configuring a Blackmagic Design FrameBuffer

This topic describes the selection and configuration of an Blackmagic Design framebuffer.

To select a Blackmagic Design framebuffer:

1. In XPression, select Edit > Hardware Setup.

The Hardware Setup dialog opens.

2. Select the Inputs / Outputs tab.

3. Select Add.

The Add New FrameBuffer Board dialog opens.

4. From the Brand drop-down, select Blackmagic Design and then select OK.

The Blackmagic Design - Framebuffer Setup dialog opens.

5. Continue with the instructions for configuring the hardware settings.
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To configure the hardware settings:

1. Select the Board tab to configure the hardware settings.

2. In the Hardware section, from the Board drop-down, select the installed Blackmagic Design card to
configure.

3. In the GenLock section, from the Source drop-down, select the source of the GenLock signal with which
to synchronize XPression. 

The available GenLock signal sources are as follows:

· External Reference — Synchronize with a GenLock signal received from an external application
through the GenLock In port of the XPression computer. Ross Video recommends using an external
reference for the GenLock signal source.

· Free Running — Do not synchronize XPression with an external source.

4. In the I/O Configuration section, select Add to add an input or output channel.

The Select I/O Type dialog opens.
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5. From the Type drop-down, select an input /output type. 

The options are:

· <none> (this option is not applicable)

· Fill-Only Output (uses 1 output) (requires a separate license or the XPression Clips option)

· Fill/Key Output (uses 2 outputs)

· Fill Input (uses 1 input)

· Internal Keyer (uses 1 input, 1 output)

6. Select OK.

The input/output assignment is added to the I/O Configuration list.

7. Repeat steps 3 to 5 for as many channels as necessary.

«SDI channel assignments are automatic and any channels beyond the number of channels supported

by the graphics card will be listed as Exceeds device capacity.

8. Continue with the instructions for configuring the output settings.
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To configure the output settings:

1. Select the Output tab to configure output settings.

2. In the Video Mode section, from the Standard drop-down, select the video format in which to output
an XPression project.

3. In the Keying section, from the Mode drop-down, select how graphics are output to a video stream. 

The modes are:

· Off (Fill Only) — Only output a video signal. In this mode, graphics are excluded from the output.

· External — Output the key and fill as separate video signals. Graphics and video mixing occurs in an
external keyer/mixer.

· Internal — Key and fill are mixed internally. Graphics and video input are outputted as a single video
signal from the framebuffer. In this mode the framebuffer functions as the keyer/mixer.

4. When External is selected in the Mode list, from the Fill drop-down, select the method used to process
fill graphics before output. 

The available processing methods are as follows:

· Shaped (premultiplied) — Multiply/shape the fill signal color information by the luminance
information in the key signal.

· Unshaped — Output fill and key signals “as is”.



XPression Clips User Guide (12.5) System Setup • 57

5. In the Misc section, in the Queue Size field, enter or select the number of frames to buffer in memory
before sending to the output.

Use this setting to avoid buffer under runs, which may cause frame skipping. Larger queue sizes ensure
smooth playout of generated graphics, but add delay to the output.

6. In the Pre Queue field, enter or select the number of frames to buffer for the pre-queue.

The pre-queue size can be between 1 and 8.

7. Continue with the instructions for configuring the input settings.
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To configure the input settings:

1. Select the Input tab to configure input settings.

2. In the Video Mode section, from the Standard drop-down, select the analog video format in which to
receive video. 

The only option currently available is <auto detect>.

3. In the Input to Output Latency section, in the Latency field, enter or select a fixed delay, in frames,
between the input and output. 

To remain fixed, the delay must be large enough to accommodate the Queue Size and Pre Queue
values in the Hardware Buffers section of the corresponding Output tab.

4. Select Apply.

The changes to the Blackmagic Design framebuffer board are applied.

5. Select OK.

The configured Blackmagic Design framebuffer board is added to the Inputs / Outputs tab of the
Hardware Setup dialog.

6. Select Close to exit the Hardware Setup dialog.



XPression Clips User Guide (12.5) System Setup • 59

Configuring a Blackmagic Design FrameBuffer (Legacy)

This topic describes the selection and configuration of a Blackmagic Design framebuffer. This option is only
available in the 32-bit version of XPression.

To configure a Blackmagic Design framebuffer:

1. In XPression, select Edit >Hardware Setup.

The Hardware Setup dialog opens.

2. Select the Inputs / Outputs tab.

3. Select Add.

The Add New FrameBuffer Board dialog opens.

4. From the Brand drop-down, select Blackmagic Design (Legacy) and select OK.

The Blackmagic Design (Legacy) - Framebuffer Setup dialog opens.
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5. Select the Board tab to configure hardware settings.

6. In the Hardware section, from the Board drop-down, select the installed DeckLink Studio card to
configure.

7. In the Input / Output Options section, from the Output drop-down, select when to activate video
output from the Blackmagic Design framebuffer. 

The options are:

· Always active — Always output video.

· Active on use only — Only output video when the card is in use.

8. From the Input drop-down, select when to activate video input through the Blackmagic Design
framebuffer. 

The options are:

· Will deactivate the output when activated — automatically deactivate the output when the input is
activated.

· Can only be activated when the output is not active — input can only be activated when the
output is not active.

· Always disabled — disable the input.

· Always enabled (output will always be disabled) — enable the input and disable the output at all
times.

«Input grabbing may compromise output performance.

9. Continue with configuring the output settings.
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To configure the output settings:

1. Select the Output tab.

2. In the Video Mode section, from the Standard drop-down, select the video format in which to output
an XPression project.

3. In the Keying section, from the Mode drop-down, select how graphics are output to a video stream. 

The modes are:

· External — Output the key and fill as separate video signals. Graphics and video mixing occurs in an
external keyer/mixer.

· Internal — Key and fill are mixed internally. Graphics and video are output as a single video signal
from the framebuffer. 

In this mode the framebuffer functions as the keyer/mixer.

· Off — Only output a video signal. In this mode, graphics are excluded from the output.

4. When External is selected as the keying mode, from the Fill drop-down, select the method used to
process fill graphics before output. 

The available processing methods are as follows:

· Shaped (premultiplied) — Multiply/shape the fill signal color information by the luminance
information in the key signal.

· Unshaped — Output fill and key signals “as is”.

5. In the Software Buffers section, in the Queue Size field, enter or select the number of frames to
buffer in memory before sending to the output.

«Use this setting to avoid buffer underruns, which may cause frame skipping. Larger queue sizes ensure

smooth playout of generated graphics, but add delay to the output.

6. In the Audio Delay Offset field, enter or select an amount of frames as a buffer.
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7. In the Analog Output section, from the Mode drop-down, select the type of analog video signal to
output. 

The available output video signals are:

· Composite — output a single video signal that combines luminance and chroma.

· Component — output three channels (Y, R-Y, and B-Y).

· S-Video — output a video signal that carries the video data as two separate signals (brightness and
color), unlike composite video which carries the entire set of signals through a signal line.

8. When Component is selected output video signal, from the Component Level drop-down, select the
output component analog level. 

The available levels are:

· SMPTE — use this level for monitoring component analog video.

· Betacam — use this level for output to Sony Betacam SP decks.

9. From the Black Level drop-down, select the default black level analog video signal. 

The available levels are as follows:

· 7.5 IRE (USA) — standard black level for all NTSC countries except Japan.

· 0.0 IRE (Japan) — standard black level for Japan.

10.Continue with configuring the input settings.
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To configure the input settings:

1. Select the Input tab.

2. In the Video Mode section, from the Standard drop-down, select the analog video format in which to
receive video.

3. In the Audio Mode section, from the Channels drop-down, select the channel inputs in which to receive
the embedded audio. 

The options available are:

· 2 channel 

· 4 channel 

· 6 channel 

· 8 channel 

· 10 channel 

· 12 channel 

· 16 channel 

4. Select OK.

The configured Blackmagic Design framebuffer board is added to the Inputs / Outputs tab of the
Hardware Setup dialog.

5. Select Close to exit the Hardware Setup dialog.
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Configuring a Graphite FrameBuffer

This topic describes the selection and configuration of an Graphite framebuffer.

To select a Graphite framebuffer:

1. In XPression, select Edit > Hardware Setup.

The Hardware Setup dialog opens.

2. Select the Inputs / Outputs tab.

3. Select Add.

The Add New FrameBuffer Board dialog opens.
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4. From the Brand drop-down, select Graphite and then select OK.

The Graphite - Framebuffer Setup dialog opens.

To configure the board settings:

1. Select the Board tab to choose and configure an installed card.

This menu is automatically populated based on installed hardware.

2. In the Hardware section, from the Board drop-down, select a Graphite card to configure, if not already
selected.

The I/O Configuration list will be populated according to the type of XPression system:

· XPression Graphite and XPression Studio SCE:

3 Fill/Key Outputs

1Fill/Key Input

· XPression Studio:

4 Fill/Key Outputs

4 Fill/Key Inputs

3. Continue with configuring the output channels.
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To configure the output channels:

1. Select an Output Chan (Output Channel) tab.

2. In the Hardware Buffers section, in the Queue Size field, enter or select the number of frames to buffer
in memory before sending to the output.

«Use this setting to avoid buffer under runs, which may cause frame skipping. Larger queue sizes

ensure smooth playout of generated graphics, but add delay to the output.

3. In the Pre Queue field, enter or select the number of frames to buffer for the pre-queue. 

The pre-queue size can be between 1 and 8.

4. In the Misc section, select the Use GPU Color Space Conversion to use the GPU to perform the color
space conversion on the outputs. 

This option provides optimal performance.

5. Continue with configuring the input channels.
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To configure the input channels:

1. Select an Input Chan (Input Channel) tab.

2. In the Input to Output Latency section, in the Latency field, enter or select a fixed delay, in frames,
between the input and output. 

To remain fixed, the delay must be large enough to accommodate the Queue Size and Pre Queue
values in the Hardware Buffers section of the corresponding Output tab.

3. In the Settings section, select the Use Alpha Channel when Input used in Live Source Shader
checkbox to use the alpha channel when the selected input is used in a live source shader.

4. Repeat steps 1 to 3 for as many channels as necessary.

5. When all input channels have been configured, select OK.

The configured Graphite framebuffer board is added to the Inputs / Outputs tab of the Hardware
Setup dialog.

6. Select Close to exit the Hardware Setup dialog.
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Configuring a Matrox DSX, X.mio3 or X.mio5 FrameBuffer

Use the following procedure to configure a Matrox DSX LE4, DSX LE5 D25, X.mio3, or X.mio5 framebuffer
board.

«No 2SI support with XPression Clips 10.5 combined with Matrox driver version 10.0.3. Matrox driver 10.1

is required.

To add a new framebuffer:

1. In XPression Clips, select Edit > Hardware Setup.

The Hardware Setup window opens.

2. Select the Inputs / Outputs tab.

3. Select Add.

The Add New FrameBuffer Board dialog opens.

4. From the Brand drop-down, select Matrox DSX. 
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5. Select OK.

The Matrox DSX - Framebuffer Setup dialog opens.

6. Select the Board tab to choose and configure an installed DSX LE4, DSX LE5 D25, or X.mio3 card.

Continue with configuring the Hardware and GenLock settings in the Board tab.
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Board

To configure the Hardware and GenLock settings:

1. From the Board drop-down, select the installed framebuffer card to configure.

The read-only I/O Mode displays the input and output configuration for the card. These options vary
based on the card and in what configuration it was flashed. 

The defaults are:

2 IN / 6 Out (for DSX LE4/8/100 and X.mio3/6/100)

4 IN / 4 Out (for DSX LE IP and X.mio3 IP)

8 IN / 8 OUT, 2 IN / 2 OUT for UHD (for DSX LE5 D25)

Depending on the XPression Clips software version, extra fill outputs on the DSX LE4, DSX LE5 D25, and
X.mio3 can be used for preview purposes. Contact a Ross representative for details.

2. In the GenLock section, from the Source drop-down, select the source of the GenLock signal with which
to synchronize XPression Clips. 

The available GenLock signal sources vary based on the card and card configuration. 

Examples include:

External Reference — Synchronize with a GenLock signal received from an external application
through the GenLock In port of the XPression Clips computer. Ross Video recommends using an
external reference for the GenLock signal source.

SDI IN # — sync to an available SDI Input source signal. The SDI input numbers will vary based on the
card and how it was flashed.

IP Reference (SMPTE ST 2059-2) 

SFP A (SMPTE ST 2059-2) 

SFP B (SMPTE ST 2059-2) 

Free Running — do not synchronize XPression Clips with an external source.

3. From the Standard drop-down, select the format of the incoming GenLock signal.

4. In the Clock Domain field, enter or select the PTP clock domain when using an IP GenLock (SMPTE ST-
2059). 

This option is only available on cards supporting IP.

5. In the Announce Timeout field, enter or select the number of announce messages that can be missed
before triggering the Best Master Clock Algorithm (BMCA) to find a new Grand Master (GM).

6. In the I/O Configuration section, select Add to add an input or output channel.

The Select I/O Type dialog opens.
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7. From the Type drop-down, select an input /output type. 

The options are:

· <none> (this option is not applicable)

· Fill-Only Output (uses 1 output) (requires a separate license or the XPression Clips Clips option)

· Fill/Key Outputs (uses 2 outputs)

· Fill Input (uses 1 input)

· Fill/Key Inputs (uses 2 inputs)

· Internal Keyer (uses 1 input, 1 output)

8. Select OK.

9. Add more inputs and outputs as necessary.

«For DSXLE4, when adding three fill/key and one fill, the one fill must be at the bottom of the list. If

not, one fill/key will show as exceeding device capacity and will be removed from the hardware setup I/O
list.

Continue with configuring the Output settings.
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Outputs

To configure an Output:

1. Select an Output tab to configure the parameters of the selected output.

2. Configure the following parameters:

Video Mode

Keying

Watchdog

Hardware Frame Buffer Queue

Horizontal Timing Offset

Misc

Ancillary Data

Audio
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Video Mode

1. In the Video Mode section, from the Standard drop-down, select the video format for the output.

«When configuring more than one output, they must share the same base frame rate that matches the

GenLock reference.

2. From the Colorimetry drop-down, select the range of colors that can be represented in the color space:

<from project> (appears only when <from project> is selected in the Standard list) 

ITU-R BT.709 (HD) 

ITU-R BT.2020 (WCG) 

3. From the Transfer Function drop-down, select the dynamic range standard to use on the output. 

The options are:

<from project> (appears only when <from project> is selected in the Standard list) 

ITU-R BT.1886 (SDR) 

ITU-R BT.2100 (HLG) 

Keying

To configure the Keying mode and fill:

1. In the Keying section, from the Mode drop-down, select a keying mode for the output. 

The available modes are as follows:

Off (Fill-Only) — select to only output a video signal. In this mode, key is excluded from the output.

External — select to output video and alpha channels.

Internal — select to key  clips to the associated input.

«If the output mode is set to Internal, the GenLock Source in the Board tab needs to be set to an

SDI input.

2. From the Fill drop-down, select the fill mode. 

The available fill options are as follows:

Shaped (premultiplied) — select to use an additive key to cut precise holes for the fill.

Unshaped — select to use a multiplicative key based on the gradient values of the alpha.

Watchdog

To configure the Watchdog settings:

1. In the Watchdog section, select the Route Input To Output On Application Failure & System
Reboot checkbox to route the input to an output in the event of application failure or a system reboot. 

2. From the Key Channel drop-down, select the On Failure Set to % Key (transparent) channel. 

This is currently the only available key channel and it is set to 0%.
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Hardware Frame Buffer Queue

To configure the Hardware Frame Buffer Queue settings:

1. In the Queue Size field, enter or select the framebuffer queue size. 

The framebuffer queue size can be between 2 and 7.

2. In the Pre Queue field, enter or select the pre-queue size. 

The pre-queue size can be between 1 and 6.

Horizontal Timing Offsets

To configure the Horizontal Timing Offsets:

1. In the Fill Offset field, enter or select the offset of the fill.

2. In the Key Offset field, enter or select the offset of the key.

Misc

To configure the Misc settings:

1. Select the Clip Chroma Levels checkbox to limit the chroma levels in the output.

2. Select the Enable Full Range Output checkbox to output using the full super black to super white
range.

3. Select the Use GPU Color Space Conversion chec box to use the GPU to perform the fastest possible
color space conversion on the output. 

It is selected by default.

«If you are using the HLG transfer function, the Use GPU Color Space Conversion checkbox should

always be selected.

4. Select the Enable On-Board Compositing checkbox to allow use of the low latency material scaler with
a Live Source material.

Ancillary Data

To configure the Ancillary Data settings:

1. From the VANC Output drop-down, select the vertical ancillary data output. 

The options are:

· None — do not set a vertical ancillary data output.

· Input — pass the vertical ancillary data from an input to the selected output.

· Video Shader (Closed Captioning) — select this option to output 608 closed caption (in a 708 CDP)
when a video shader is playing back a file with embedded captioning.
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When the XPression INcoder is set to a target folder, it will extract 608 closed captioning from an MOV
file. The INcoder will transcode the MOV file to an XPression AVI file as well as an XMD file that contains
the closed caption metadata. When the AVI file is played back from XPression Clips, XPression Clips will
look for the XMD file and play out with the AVI file.

«Files played back from the Clip Store do not support Closed Captioning.

2. Select the Send payload ID (SMPTE ST 352) checkbox to send the video payload ID (SMPTE ST 352)
in the ancillary data.

3. Select the Embedded Audio checkbox to include embedded audio in the ancillary data.

Audio

To configure the Audio settings:

· In the Audio section, from the Channels drop-down, select the number of audio channels to output in
the IP audio stream. 

The options available are:

2 channel 

4 channel 

8 channel 

«The output audio channels are only available when using the DSX LE4 IP, DSX LE5 D25 IP, or X.mio3 IP

board in SMPTE 2110 mode.

Continue with configuring the Input settings.
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Inputs

To configure the inputs:

1. Select an Input tab to configure the parameters of the selected input.

2. Configure the following parameters:

Video Mode

Input To Output Latency

Key Options

Audio Channel Mapping

Misc
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Video Mode

1. From the Standard drop-down, select the video format for the input.

2. From the Colorimetry drop-down, select the range of colors that can be represented in the color space:

· <from project> (appears only when <from project> is selected in the Standard list) 

· ITU-R BT.709 (HD) 

· ITU-R BT.2020 (WCG) 

3. From the Transfer Function drop-down, select the dynamic range standard to use on the output. 

The options are:

· <from project> (appears only when <from project> is selected from the Standard drop-down) 

· ITU-R BT.1886 (SDR) 

· ITU-R BT.2100 (HLG) 

Input To Output Latency

· In the Latency field, enter or select a time interval offset, in frames, between the input and output.

Key Options

· From the Sources drop-down, select the keying options for the input. 

The options are:

None (Fill Only) 

Paired Input (Fill/Key) 

Audio Channel Mapping

1. From the Capture drop-down, select the audio type for the input.

2. In the AES/EBU Pair Mapping area, use the Pair drop-downs to define the mapping of the AES/EBU
inputs.

«The AES/EBU pair mapping is only available on cards that support AES audio.

Misc.

To use the GPU to perform the fastest possible color space conversion on the input:

· In the Misc section, select the Use GPU Color Space Conversion checkbox.

Continue with configuring the Misc settings.
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Misc

To configure the horizontal and vertical offsets:

1. Select the Misc tab .

2. In the Timing Offset section, do the following:

· In the Horizontal field, enter or select a horizontal delay timing offset (in nanoseconds) with regards
to an external reference. 

This setting is for external reference only.

· In the Vertical field, enter or select a vertical delay timing offset (in nanoseconds) with regards to an
external reference. 

This setting is for external reference only.

3. In the Finalization section, from the Shutdown drop-down, select one of the following options for the
outputs on shutdown:

· Retain Outputs Topology — retain the output topology when XPression Clips is closed.

· Clear Outputs Topology — clear the output topology when XPression Clips is closed so that NMOS
senders are no longer reported after XPression Clips closes.
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4. In the AES/EBU Output Mapping section, use the Pair drop-downs for Group A and Group B to
define the mapping of the AES/EBU outputs.

The default settings are framebuffer one to AES Group A and framebuffer two to AES Group B.

«The AES/EBU output mapping is only available if using the DSX LE4 FH card.

If you are configuring a DSX LE4 IP, DSX LE5 D25, X.mio3, or X.mio 5 IP card, continue with configuring
the IP settings.
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IP

This section applies to the DSX LE4 IP, DSX LE5 D25, X.mio3, or X.mio 5 IP cards only.

To configure the IP settings:

1. Select the IP tab.

The available settings depend on the card configuration and protocol. The Matrox DSXLE5 D25 and
X.mio5 Q25 only support the SMPTE 2110 protocol and not SMPTE 2022-6.

2. Select the appropriate protocol link for further instructions:

SMPTE 2110

SMPTE 2110 with 2022-7

SMPTE 2022-6

SMPTE 2022-6 with 2022-7
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SMPTE 2110

If the IP card is configured for SMPTE 2110 protocol, the IP tab is displayed as follows:

To configure the Network settings:

For Matrox DSXLE4 and X.mio3

1. In the Network section, in the SFP A and SFP B tabs, in the Local IP Address field, enter the IP
address of the small form-factor pluggable transceivers (Matrox DSXLE4 and X.mio3 only).

2. Select the Enable 2022-7 checkbox to use the 2022-7 standard to enable redundancy for the SFP
module connection. If using 2022-7 redundancy, see SMPTE 2110 with 2022-7 for more information.
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For Matrox DSXLE5 and X.mio5

1. Open Network Connections in Windows. 

2. Depending on the configuration, there can be up to four SFPs (SFP A, SFP B, SFP C, and SFP D).

3. Right-click on the Matrox Ethernet Adapter and select Properties.

The Ethernet Properties window opens.
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4. In the Networking tab, select Internet Protocol Version 4 (TCP/IPv4) and then select Properties.

The Internet Protocol Version 4 (TCP/IPv4) Properties window opens.

5. Configure the properties as necessary.

6. Repeat this procedure for any remaining Matrox Ethernet Adapters.

To configure the NMOS setting:

· In the IP tab, in the NMOS section, select the Accept IS-05 connection requests checkbox to accept
connection requests to use IS-05 via NMOS.
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To configure the Output Streams:

1. In the Output Streams section, select an output stream and select Configure.

The Matrox DSX - IP Output Stream Setup dialog opens.

2. In the Primary Video Output Stream section configure the following settings:

Source Port — enter or select the local port number of the primary video output stream source.

Enable Stream — enable the primary video output stream.

Remote IP Addr — enter the remote IP address of the primary video output stream.

DSCP — enter or select the differentiated services code point of the primary video output stream.

Remote Port — enter or select the remote port number for the primary video output stream.

RTP Payload ID — enter or select the dynamic payload type chosen in the range of 96 through 127,
signaled as specified in section 6 of IETF RFC 4566, unless a fixed payload type designation exists for
that RTP stream within the IETF standard which specifies it.
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3. In the Primary Audio Output Stream section configure the following settings:

Source Port — enter or select the local port number of the of the primary audio output stream source.

Enable Stream — enable the primary audio output stream.

Remote IP Addr — enter the remote IP address of the primary audio output stream.

DSCP — enter or select the differentiated services code point of the primary audio output stream.

Remote Port — enter or select the remote port number for the primary audio output stream.

RTP Payload ID — enter or select the dynamic payload type chosen in the range of 96 through 127,
signaled as specified in section 6 of IETF RFC 4566, unless a fixed payload type designation exists for
that RTP stream within the IETF standard which specifies it.

4. Repeat step 5 for any other primary audio output streams.

5. In the Primary Ancillary Output Stream section configure the following settings:

Source Port — enter or select the local port number of the of the primary ancillary output stream
source.

Enable Stream — enable the primary ancillary output stream.

Remote IP Addr — enter the remote IP address of the primary ancillary output stream.

DSCP — enter or select the differentiated services code point of the primary ancillary output stream.

Remote Port — enter or select the remote port number for the primary ancillary output stream.

RTP Payload ID — enter or select the dynamic payload type chosen in the range of 96 through 127,
signaled as specified in section 6 of IETF RFC 4566, unless a fixed payload type designation exists for
that RTP stream within the IETF standard which specifies it.

6. Repeat steps 1 to 5 for any other output streams.

7. Select OK.

The Matrox DSX - IP Output Stream Setup dialog closes and the settings are added to the selected
output stream.
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To configure the Input Streams:

1. In the Input Streams section, select an input stream and select Configure.

The Matrox DSX - IP Input Stream Setup dialog opens.

2. In the Primary Video Input Stream section configure the following settings:

· Remote IP Addr — enter the remote IP address of the primary video input stream.

· Enable Stream — enable the primary video input stream.

· Remote Port — enter or select the remote port number for the primary video input stream.

· Multicast Join — select an internet group management protocol for joining an IP multicast for the
primary video input stream. 

The options are:

Ø None — select this option if not using IP multicast. This is the default setting.

Ø IGMP v2 — use internet group management protocol version 2.

Ø IGMP v3 — use internet group management protocol version 3.
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3. Select the Source Filter button to configure IP multicast source filtering if using multicast.

The Matrox DSX - IGMP Multicast Source Filter dialog opens.

a. From the Filter Type drop-down, select one of the following filtering options:

· Exclude — exclude specific source addresses from the IP multicast.

· Only Include — include specific source addresses from the IP multicast.

b. Select Add to add and enter a source address to either exclude or only include (depending on the
filter type selected) specific source addresses. 

c. Once any necessary addresses have been added, select OK.

4. In the Primary Audio Input Stream section configure the following settings:

· Remote IP Addr — enter the remote IP address of the primary audio input stream.

· Enable Stream — enable the primary audio input stream.

· Remote Port — enter or select the remote port number for the primary audio input stream.

· Multicast Join — select an internet group management protocol for joining an IP multicast for the
primary audio input stream. 

The options are:

Ø None — select this option if not using IP multicast. This is the default setting.

Ø IGMP v2 — use internet group management protocol version 2.

Ø IGMP v3 — use internet group management protocol version 3.
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5. Select the Source Filter button to configure IP multicast source filtering if using multicast.

The Matrox DSX - IGMP Multicast Source Filter dialog opens.

a. From the Filter Type drop-down, select one of the following filtering options:

· Exclude — exclude specific source addresses from the IP multicast.

· Only Include — include specific source addresses from the IP multicast.

b. Select Add to add and enter a source address to either exclude or only include (depending on the
filter type selected) specific source addresses.

c. Once any necessary addresses have been added select OK.

6. Repeat step 4 and optionally, step 5 for any other primary audio input streams.

7. In the Primary Ancillary Input Stream section configure the following settings:

· Remote IP Addr — enter the remote IP address of the primary ancillary input stream.

· Enable Stream — enable the primary ancillary input stream.

· Remote Port — enter or select the remote port number for the primary ancillary input stream.

· Multicast Join — select an internet group management protocol for joining an IP multicast for the
primary ancillary input stream. 

The options are:

Ø None — select this option if not using IP multicast. This is the default setting.

Ø IGMP v2 — use internet group management protocol version 2.

Ø IGMP v3 — use internet group management protocol version 3.



XPression Clips User Guide (12.5) System Setup • 91

8. Select the Source Filter button to configure IP multicast source filtering if using multicast.

The Matrox DSX - IGMP Multicast Source Filter dialog opens.

a. From the Filter Type drop-down, select one of the following filtering options:

· Exclude — exclude specific source addresses from the IP multicast.

· Only Include — include specific source addresses from the IP multicast.

b. Select Add to add and enter a source address to either exclude or only include (depending on the
filter type selected) specific source addresses.

c. Once any necessary addresses have been added select OK.

The Matrox DSX - IP Input Stream Setup dialog closes and the settings are added to the selected
input stream.

9. Repeat steps 1 to 8 for any other input streams.

To configure the Input Clean Switch settings:

1. If using the DSX LE4 IP, DSX LE5 D25, X.mio3 IP, or X.mio5 Q25, in the Input Clean Switch section,
select the Pair inputs to allow remote clean switch checkbox to create pairs of inputs (effectively
dividing the number of available inputs by two) so that when doing a switch, the ‘inactive’ input is
prepared with the new multicast settings first, then made active when ready.

2. If selected, configure the following settings:

· Clean switch prepare delay — enter or select the number of frames to prepare the delay for the IP
clean switch option.

· Group NMOS requests received within — enter or select time in seconds to configure a delay to
collect any NMOS connection requests (video/audio/ancillary) received for an input within that time
period before applying the IP clean switch.
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SMPTE 2110 with 2022-7

If the IP card is configured for SMPTE 2110 protocol and the Enable 2022-7 checkbox is selected, the IP
tab is displayed as follows:

To configure the Network settings:

For Matrox DSXLE4 and X.mio3

1. In the Network section, in the SFP A and SFP B tabs, in the Local IP Address field, enter the IP
address of the small form-factor pluggable transceivers (Matrox DSXLE4 and X.mio3 only).

2. Select the Enable 2022-7 checkbox to use the 2022-7 standard to enable redundancy for the SFP
module connection.
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For Matrox DSXLE5 and X.mio5

1. Open Network Connections in Windows. 

2. Depending on the configuration, there can be up to four SFPs (SFP A, SFP B, SFP C, and SFP D).

3. Right-click on the Matrox Ethernet Adapter and select Properties.

The Ethernet Properties window opens.
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4. In the Networking tab, select Internet Protocol Version 4 (TCP/IPv4) and then select Properties.

The Internet Protocol Version 4 (TCP/IPv4) Properties window opens.

5. Configure the properties as necessary.

6. Repeat this procedure for any remaining Matrox Ethernet Adapters.
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To configure the Primary Video Output Stream:

1. Select an output stream and select Configure.

The Matrox DSX - IP Output Stream Setup dialog opens.

2. In the Primary Video Output Stream - SFP A section configure the following settings:

· Source Port — enter or select the local port number of the primary video output stream source.

· Enable Stream — enable the primary video output stream.

· Remote IP Addr — enter the remote IP address of the primary video output stream.

· DSCP — enter or select the differentiated services code point of the primary video output stream.

· Remote Port — enter or select the remote port number for the primary video output stream.

· RTP Payload ID — enter or select the dynamic payload type chosen in the range of 96 through 127,
signaled as specified in section 6 of IETF RFC 4566, unless a fixed payload type designation exists for
that RTP stream within the IETF standard which specifies it.
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To configure the Secondary Video Output Stream:

· In the Secondary Video Output Stream - SFP B section configure the following settings:

Ø Source Port — enter or select the local port number of the primary video output stream source.

Ø Enable Stream — enable the secondary video output stream.

Ø Remote IP Addr — enter the remote IP address of the primary video output stream.

Ø Remote Port — enter or select the remote port number for the primary video output stream.

To configure the Primary Audio Output Stream:

1. In the Primary Audio Output Stream - SFP A section configure the following settings:

· Source Port — enter or select the local port number of the of the primary audio output stream source.

· Enable Stream — enable the primary audio output stream.

· Remote IP Addr — enter the remote IP address of the primary audio output stream.

· DSCP — enter or select the differentiated services code point of the primary audio output stream.

· Remote Port — enter or select the remote port number for the primary audio output stream.

· RTP Payload ID — enter or select the dynamic payload type chosen in the range of 96 through 127,
signaled as specified in section 6 of IETF RFC 4566, unless a fixed payload type designation exists for
that RTP stream within the IETF standard which specifies it.

2. Repeat step 1 for any other audio output streams.

To configure the Secondary Audio Output Stream:

1. In the Secondary Audio Output Stream - SFP B section configure the following settings:

· Source Port — enter or select the local port number of the of the primary audio output stream source.

· Enable Stream — enable the secondary audio output stream.

· Remote IP Addr — enter the remote IP address of the primary audio output stream.

· Remote Port — enter or select the remote port number for the primary audio output stream.

2. Repeat step 1 for any other secondary audio output streams.
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To configure the Primary Ancillary Output Stream:

· In the Primary Ancillary Output Stream - SFP A section configure the following settings:

Ø Source Port — enter or select the local port number of the of the primary ancillary output stream
source.

Ø Enable Stream — enable the primary ancillary output stream.

Ø Remote IP Addr — enter the remote IP address of the primary ancillary output stream.

Ø DSCP — enter or select the differentiated services code point of the primary ancillary output stream.

Ø Remote Port — enter or select the remote port number for the primary ancillary output stream.

Ø RTP Payload ID — enter or select the dynamic payload type chosen in the range of 96 through 127,
signaled as specified in section 6 of IETF RFC 4566, unless a fixed payload type designation exists for
that RTP stream within the IETF standard which specifies it.

To configure the Secondary Ancillary Output Stream:

1. In the Secondary Ancillary Output Stream - SFP B section configure the following settings:

· Source Port — enter or select the local port number of the of the primary ancillary output stream
source.

· Enable Stream — enable the secondary ancillary output stream.

· Remote IP Addr — enter the remote IP address of the primary ancillary output stream.

· Remote Port — enter or select the remote port number for the primary ancillary output stream.

2. Select OK.

The Matrox DSX - IP Output Stream Setup dialog closes and the settings are added to the selected
output stream.

3. Repeat the above steps for any other output streams
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To configure the Primary Video Input Stream:

1. In the Input Streams section, select an input stream and select Configure.

The Matrox DSX - IP Input Stream Setup dialog opens.

2. In the Primary Video Input Stream - SFP A section configure the following settings:

· Remote IP Addr — enter the remote IP address of the primary video input stream.

· Enable Stream — enable the primary video input stream.

· Remote Port — enter or select the remote port number for the primary video input stream.

· Multicast Join — select an internet group management protocol for joining an IP multicast for the
primary video input stream. 

The options are:

Ø None — select this option if not using IP multicast. This is the default setting.

Ø IGMP v2 — use internet group management protocol version 2.

Ø IGMP v3 — use internet group management protocol version 3.
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To configure the Secondary Video Input Stream:

· In the Secondary Video Input Stream - SFP B section configure the following settings:

Ø Remote IP Addr — enter the remote IP address of the primary video input stream.

Ø Enable Stream — enable the secondary video input stream.

Ø Remote Port — enter or select the remote port number for the primary video input stream.

To configure the Primary Audio Input Stream:

1. In the Primary Audio Input Stream - SFP A section configure the following settings:

· Remote IP Addr — enter the remote IP address of the primary audio input stream.

· Enable Stream — enable the primary audio input stream.

· Remote Port — enter or select the remote port number for the primary audio input stream.

· Multicast Join — select an internet group management protocol for joining an IP multicast for the
primary audio input stream. 

The options are:

Ø None — select this option if not using IP multicast. This is the default setting.

Ø IGMP v2 — use internet group management protocol version 2.

Ø IGMP v3 — use internet group management protocol version 3.

2. Repeat step 1 for any other primary audio input streams.

To configure the Secondary Audio Input Stream:

1. In the Secondary Audio Input Stream - SFP B section configure the following settings:

· Remote IP Addr — enter the remote IP address of the primary audio input stream.

· Enable Stream — enable the secondary audio input stream.

· Remote Port — enter or select the remote port number for the primary audio input stream.

2. Repeat step 1 for any other primary audio input stream.
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To configure the Primary Ancillary Input Stream:

· In the Primary Ancillary Input Stream - SFP A section configure the following settings:

Ø Remote IP Addr — enter the remote IP address of the primary ancillary input stream.

Ø Enable Stream — enable the primary ancillary input stream.

Ø Remote Port — enter or select the remote port number for the primary ancillary input stream.

Ø Multicast Join — select an internet group management protocol for joining an IP multicast for the
primary ancillary input stream. 

The options are:

§ None — select this option if not using IP multicast. This is the default setting.

§ IGMP v2 — use internet group management protocol version 2.

§ IGMP v3 — use internet group management protocol version 3.

To configure the Secondary Ancillary Input Stream:

1. In the Secondary Ancillary Input Stream - SFP B section configure the following settings:

· Remote IP Addr — enter the remote IP address of the primary ancillary input stream.

· Enable Stream — enable the seconday ancillary input stream.

· Remote Port — enter or select the remote port number for the primary ancillary input stream.

2. Select OK.

The Matrox DSX - IP Input Stream Setup dialog closes and the settings are added to the selected
input stream.

3. Repeat the above steps for any other input streams.
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SMPTE 2022-6

«SMPTE 2022-6 is not supported on the Matrox DSXLE5 D25 and X.mio5 Q25.

If the IP card is configured for SMPTE 2022-6 protocol, the IP tab is displayed as follows:

To configure the Network settings:

1. In the Network section, in the SFP A and SFP B tabs, in the Local IP Address field, enter the IP
address of the small form-factor pluggable transceiver .

2. Select the Enable 2022-7 check box to use the 2022-7 standard to enable redundancy for the SFP
module connection. If using 2022-7 redundancy, see SMPTE 2022-6 with 2022-7 for more information.
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To configure the Primary Output Stream:

1. In the Output Streams section, select an output stream and select Configure.

The Matrox DSX - IP Output Stream Setup dialog opens.

2. In the Primary Output Stream - SFP A section configure the following settings:

· Source Port — enter or select the local port number of the primary video output stream source.

· Remote IP Addr — enter the remote IP address of the primary video output stream.

· DSCP — enter or select the differentiated services code point of the primary video output stream.

· Remote Port — enter or select the remote port number for the primary video output stream.

· RTP Payload ID — enter or select the dynamic payload type chosen in the range of 96 through 127,
signaled as specified in section 6 of IETF RFC 4566, unless a fixed payload type designation exists for
that RTP stream within the IETF standard which specifies it.

3. Repeat steps 1 and 2 for any other output streams.

To configure the Primary Input Stream:

1. In the Input Streams section, select an input stream and select Configure.

The Matrox DSX - IP Input Stream Setup dialog opens.

2. In the Primary Input Stream - SFP A section configure the following settings:

· Remote IP Addr — use this box to enter the remote IP address of the primary video input stream.

· Remote Port — use this box to enter or select the remote port number for the primary video input
stream.

· Multicast Join — use this list to select an internet group management protocol for joining an IP
multicast for the primary video input stream. 

The options are:

Ø None — select this option if not using IP multicast. This is the default setting.

Ø IGMP v2 — use internet group management protocol version 2.

Ø IGMP v3 — use internet group management protocol version 3.

3. Select OK.

The Matrox DSX - IP Input Stream Setup dialog closes and the settings are added to the selected
input stream.

4. Repeat steps 1 and 2 for any other input streams.
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SMPTE 2022-6 with 2022-7

If the IP card is configured for SMPTE 2022-6 protocol and the Enable 2022-7 checkbox is selected, the IP
tab is displayed as follows:
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To configure the Primary Output Stream:

1. In the Output Streams section, select an output stream and select Configure.

The Matrox DSX - IP Output Stream Setup dialog opens.

2. In the Primary Output Stream - SFP A section configure the following settings:

· Source Port — enter or select the local port number of the primary video output stream source.

· Remote IP Addr — enter the remote IP address of the primary video output stream.

· DSCP — enter or select the differentiated services code point of the primary video output stream.

· Remote Port — enter or select the remote port number for the primary video output stream.

· RTP Payload ID — enter or select the dynamic payload type chosen in the range of 96 through 127,
signaled as specified in section 6 of IETF RFC 4566, unless a fixed payload type designation exists for
that RTP stream within the IETF standard which specifies it.

3. In the Secondary Output Stream - SFP B section configure the following settings:

Source Port — enter or select the local port number of the primary video output stream source.

Remote IP Addr — enter the remote IP address of the primary video output stream.

Remote Port — enter or select the remote port number for the primary video output stream.

4. Select OK.

The Matrox DSX - IP Output Stream Setup dialog closes and the settings are added to the selected
output stream.

5. Repeat steps 1 to 4 for any other output streams.



XPression Clips User Guide (12.5) System Setup • 105

To configure the Primary Input Stream:

1. In the Input Streams section, select an input stream and select Configure.

The Matrox DSX - IP Input Stream Setup dialog opens.

2. In the Primary Input Stream - SFP A section configure the following settings:

· Remote IP Addr — enter the remote IP address of the primary video input stream.

· Remote Port — enter or select the remote port number for the primary video input stream.

· Multicast Join — select an internet group management protocol for joining an IP multicast for the
primary video input stream. 

The options are:

· None — select this option if not using IP multicast. This is the default setting.

· IGMP v2 — use internet group management protocol version 2.

· IGMP v3 — use internet group management protocol version 3.

3. In the Secondary Input Stream - SFP B section configure the following settings:

· Remote IP Addr — enter the remote IP address of the primary video input stream.

· Remote Port — enter or select the remote port number for the primary video input stream.

4. Select OK.

The Matrox DSX - IP Input Stream Setup dialog closes and the settings are added to the selected
input stream.

5. Repeat steps 1 to 3 for any other input streams.

6. Select Apply to implement the settings.

7. Select OK.

The configured Matrox framebuffer board is added to the Inputs / Outputs tab of the Hardware Setup
dialog.
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Configuring a Matrox Video X.mio2 FrameBuffer

If using Matrox X.mio2 and upgrading to XPression Clips 64-bit, Matrox driver 9.4.2.9297 must be installed.

To add a Matrox Video X.mio2 framebuffer card:

1. In XPression Clips, select Edit > Hardware Setup.

The Hardware Setup dialog opens.

2. Select the Inputs / Outputs tab.

3. Select Add.

The Add New FrameBuffer Board dialog opens.

4. From the Brand drop-down, select Matrox Video X.mio2.

5. Select OK.

The Matrox XMIO - Framebuffer Setup dialog opens.

Continue with configuring the Hardware and Genlock settings in the Board tab.
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Board

To configure the Hardware and GenLock settings:

1. From the Output Mode drop-down, select the output configuration for the card:

· 2 Fill/Key Outputs 

The AES outputs will be mapped as follows:

Ø Output 1: AES Output A 1-16

Ø Output 2: AES Output B 1-16

· 1 Fill/Key + 2 Fill Outputs 

The AES outputs will be mapped as follows:

Ø Output 1 Fill/Key: AES Output A 1-16

Ø Output 2 Fill: AES Output B 1-8

Ø Output 3 Fill: AES Output B 9-16

· 4 Fill Outputs 

The AES outputs will be mapped as follows:

Ø Output 1: AES Output A 1-8

Ø Output 2: AES Output B 1-8

Ø Output 3: AES Output A 9-16

Ø Output 4: AES Output B 9-16

If using XPression Clips Studio SCE, select the output configuration for the card from the following
options:

· 1 Fill/Key Output 

· 2 Fill Outputs 

«These options are only available if the Fill-Only option has been purchased for XPression Clips Studio

and XPression Clips Studio SCE. Otherwise, the only options are 2 Fill/Key for XPression Clips Studio
and 1 Fill/Key for XPression Clips Studio SCE.

2. In the GenLock section, from the Source drop-down, select the source of the GenLock signal with which
to synchronize XPression Clips. 

The available GenLock signal sources are:

· Internal — generate internal sync on the video card for all output channels.

· Blackburst — sync to analog black.

· SDI Input 1 — sync to SDI Input 1 source signal.

· SDI Input 2 — sync to SDI Input 2 source signal.

· SDI Input 3 — sync to SDI Input 3 source signal.

· SDI Input 4 — sync to SDI Input 4 source signal.

«If the output mode is set to Internal in the Output tab, the GenLock Source needs to be set to an

SDI input.

3. From the Standard drop-down, select the format of the incoming GenLock signal.
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4. In the Timing Offset section, in the Horizontal field, enter or select the number of nanoseconds for
horizontal timing offset with regards to an external reference.

5. In the Vertical field, enter or select the number of lines for vertical delay timing offset with regards to
an external reference.

If configuring an XMIO card when using XPression Clips with a switcher, the Horizontal timing offset
must be set to 9930 and the Vertical timing offset must be set to 1124 if using 1080i/29.27 frames per
second and a Tri Level Sync reference.

Continue with configuring the Output settings.
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Outputs

To configure the outputs:

1. Select an Output tab to configure the parameters of the selected output.

2. Configure each section as needed.

Video Mode

Keying

WatchDog

Hardware Frame Buffer Queue

Horizontal Timing Offset (ns)

Misc

Ancillary Data
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Video Mode

1. In the Video Mode section, from the Standard drop-down, select the video format for the output.

«When configuring more than one output, they must share the same base frame rate that matches the

GenLock reference.

2. From the Transfer Function drop-down, select how the physical (linear) light is mapped and encoded. 

The options are:

· <from project> (appears only when <from project> is selected in the Standard drop-down) 

· ITU-R BT.1886 (SDR) 

· ITU-R BT.2100 (HLG) 

Keying

1. In the Keying section, from the Mode drop-down, select a keying mode for the output. 

The options are:

· External — output video and alpha channels.

· Internal — key clips to the associated input.

«If the output mode is set to Internal, set the GenLock Source in the Board tab to an SDI input.

2. From the Fill drop-down, select the fill mode. 

The options are:

· Shaped (premultiplied) — use an additive key to cut precise holes for the fill.

· Unshaped — use a multiplicative key based on the gradient values of the alpha.

WatchDog

1. In the WatchDog section, select the Route Input To Output On Application Failure & System
Reboot checkbox to route the input to an output in the event of application failure or a system reboot. 

2. From the Key Channel drop-down, select a transparent or opaque key channel.

The options are:

· On Failure Set to 0% Key (transparent) — set the key channel to transparent in the event of
failure.

· On Failure Set to 100% Key (opaque) — set the key channel to opaque in the event of failure. 
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Hardware Frame Buffer Queue

1. In the Hardware Frame Buffer Queue section, in the Queue Size field, enter or select the
framebuffer queue size. 

The framebuffer queue size can be between 2 and 7.

2. In the Pre Queue field, enter or select the pre-queue size. 

The pre-queue size can be between 1 and 6.

Horizontal Timing Offset (ns)

1. In the Horizontal Timing Offset (ns) section, in the Fill Offset field, enter or select the offset of the
fill.

2. In the Key Offset field, enter or select the offset of the key.

Misc

1. In the Misc section, select the Clip Chroma Levels checkbox to limit the chroma levels in the output.

2. Select the Allow Super Black chec box to output using the full super black to super white range.

3. From the Color Space Conversion drop-down, select the color space conversion for the outputs. 

The options are:

· Hardware (GPU - Fastest) (default)

· Hardware (Board) 

· Software (No Chroma Filter) 

«If using the HLG transfer function, always select the Hardware (GPU - Fastest) option.

4. Select the Enable RGBA -> YUV Filter checkbox to enhance the conversion from 4:4:4 RGB to 4:2:2
YUV color space by filtering the down-conversion of the chrominance. 

If running in 1080p video modes, you should not enable this on more than one channel simultaneously.
This option is only available with Matrox drivers 9.4.2 or higher.

Ancillary Data

· In the Ancillary Data section, from the VANC Output drop-down, set the vertical ancillary data output. 

The options are:

Ø None — do not set a vertical ancillary data output.

Ø Pass VANC from Input 1 to Output 1 — pass the vertical ancillary data from input 1 to output 1

Ø Use Closed Captioning from Video Shader — when using a Matrox card, select this option to output
608 closed caption (in a 708 CDP) when a video shader is playing back a file with embedded captioning.



112 • System Setup XPression Clips User Guide (12.5)

When the XPression Clips INcoder is set to a target folder, it will extract 608 closed captioning from an
MOV file. The INcoder will transcode the MOV file to an XPression Clips AVI file as well as an XMD file that
contains the closed caption metadata. When the AVI file is played back from XPression Clips, XPression
Clips will look for the XMD file and play out with the AVI file.

«Files played back from the Clip Store do not support Closed Captioning.

Continue with configuring the Input settings.
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Inputs

To configure the inputs:

1. Select an Input tab to configure the parameters of the selected input.

2. In the Video Mode section, from the Standard drop-down, select the video format for the input.

3. In the Audio Channel Mapping section, from the Capture drop-down, select the audio type for the
input.

4. In the AES/EBU Pair Mapping section, use the Pair drop-downs to define the mapping of the AES/EBU
inputs.

5. In the Ancillary Data section, select the Pass VANC data from Input 1 to Output 1 checkbox to pass
vertical ancillary data from Input 1 to Output 1 when using a Live Source shader in the scene and a
Matrox board.

«Requires Matrox DSX version 7.5.2.457.

6. In the Options section, in the Input to Output Latency field, enter or select a time interval offset, in
frames, between the input and output.

7. If configuring Input 2, select the Use Input 2 as Key Channel for Input 1 to use the input as the key
channel for Input 1, if necessary.

8. Select OK.

The configured Matrox framebuffer board is added to the Inputs / Outputs tab of the Hardware Setup
dialog.

9. In the Hardware Setup dialog, select Close.
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Configuring a Ross GeminiIO FrameBuffer

This topic describes the selection and configuration of a Ross GeminiIO framebuffer. The Ross GeminiIO
framebuffer supports HD and UHD and the following configuration options:

· 3 Outputs/2 Inputs (default)

· 2 Outputs/2 Inputs

· 2 Outputs/4 Inputs (if an output is configured as an Internal Keyer, you can use the same input as a live
source)

«The video format configured for the output and the corresponding input in this configuration must

match.

· 1 Output/2 Inputs

· 4 Outputs/0 Inputs

To select a GeminiIO board:

1. In XPression Clips, select Edit > Hardware Setup.

2. Select the Inputs / Outputs tab.

3. Select Add.

The Add New FrameBuffer Board dialog opens.

4. From the Brand drop-down, select Ross GeminiIO and then select OK.
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The Ross Gemini - Framebuffer Setup dialog opens.

5. Continue with the instructions for configuring the board.



116 • System Setup XPression Clips User Guide (12.5)

Board

To configure the board:

1. In the Board tab, from the Board drop-down, select GeminiIO.

The default configuration of three HD outputs and 2 inputs is shown in the I/O Configuration section.

2. In the GenLock section, from the Source drop-down, select the source of the GenLock signal with which
to synchronize XPression Clips. 

The available GenLock signal sources are as follows:

External Reference — Synchronize with a GenLock signal received from an external application through
the GenLock In port of the XPression Clips computer. Ross Video recommends using an external
reference for the GenLock signal source.

Free Running — Do not synchronize XPression Clips with an external source.

3. From the Standard drop-down, select the format of the incoming GenLock signal or select <auto
detect> to allow the correct standard to be automatically selected.

4. In the I/O Configuration section, double-click an output to change the configuration if the default isn't
appropriate for your project.

5. Continue with configuring an output.
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Outputs

To configure an output:

1. Select an Output tab to configure the parameters of the selected output.

2. Configure the following parameters:

Video Mode

Keying

Watchdog

Hardware Buffers

Audio

Adding an Output

Configuring a UHD Output

Video Mode

1. In the Video Mode section, from the Standard drop-down, select the video format for the output or
select <from project> to automatically switch the output video format to the video format of the
currently loaded project.

The project video format is ignored when a specific output video format is selected, and the selected
video format is used to play out scenes.

«When configuring more than one output, they must share the same base frame rate that matches the

GenLock reference.
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2. From the Colorimetry drop-down, select the range of colors that can be represented in the color space:

<from project> (appears only when <from project> is selected in the Standard list) 

ITU-R BT.709 (HD) 

ITU-R BT.2020 (WCG) 

3. From the Transfer Function drop-down, select the dynamic range standard to use on the output. 

The options are:

<from project> (appears only when <from project> is selected in the Standard list) 

ITU-R BT.1886 (SDR) 

ITU-R BT.2100 (HLG) 

Keying

To configure the Keying mode and fill:

1. In the Keying section, from the Mode drop-down, select a keying mode for the output. 

The available modes are as follows:

Off (Fill-Only) — select to only output a video signal. In this mode, key is excluded from the output.

External — select to output video and alpha channels.

Internal — select to key XPression Clips scenes to the associated input.

«If the output mode is set to Internal, the GenLock Source in the Board tab needs to be set to an

SDI input.

2. From the Fill drop-down, select the fill mode. 

The available fill options are as follows:

Shaped (premultiplied) — select to use an additive key to cut precise holes for the fill.

Unshaped — select to use a multiplicative key based on the gradient values of the alpha.

Watchdog

To configure the Watchdog settings:

1. In the Watchdog section, select the On Application Failure & After System Reboot checkbox to
enable the following options in the event of an application failure or a system reboot.

2. From the Fill drop-down, select one of the following options:

 Set Fill to Black — clears the screen.

 Route Input to Output — video coming in goes directly to the output.

3. From the Key drop-down, select one of the following options:

Set Key to 0% (transparent) — the input remains visible.

Set Key to 100% (opaque) — the screen goes to solid white.

Route Key Input to Key Output — video coming in goes directly to the output.
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Hardware Buffers

To configure the Hardware Frame Buffer Queue settings:

1. In the Queue Size field, enter or select the number of frames to buffer in memory before sending to the
output.

The framebuffer queue size can be between 2 and 6.

2. In the Pre Queue field, enter or select the number of frames to buffer for the pre-queue.

The pre-queue size can be between 1 and 6.

Audio

To configure the Audio settings:

· In the Audio section, select one of the following options:

Output Embedded Audio — to play out any imbedded audio.

Audio Loop Through — not currently supported

This option applies to internal keyer only.

Adding an Output

To add an output:

1. Select each of the two inputs and select Delete.

2. Select Add.

3. In the Select I/O Type dialog, from the Type drop-down, select either Fill Only Output or Fill/Key
Output.

4. Then select OK.

5. In the Ross Gemini - Framebuffer Setup dialog, select Apply.

Configuring a UHD Output

To configure a UHD output:

1. Load a UHD project or convert the project mode to UHD.

(Select Project > Convert Project Mode and from the Editing Mode drop-down, select either UHD
2160p or 2160psf.)

2. Select any existing HD output and select Delete.

3. Select Add.

4. In the Select I/O Type dialog, from the Type drop-down, select either Fill Only Output or Fill/Key
Output. 

5. Then select OK.
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6. In the Ross Gemini - Framebuffer Setup dialog, select Apply.

Continue with configuring the Input settings.
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Inputs

To configure an input:

1. Select an Input tab to configure the parameters of the selected input.

2. In the Video Mode section, from the Standard drop-down, select the video format for the input.

The Colorimetry and Transfer Function settings are not currently supported.

3. In the Key Options section, from the Source drop-down, select the keying options for the input. 

The options are:

· None (Fill Only) 

· Paired Input (Fill/Key) 

4. In the Input to Output Latency section, in the Latency field, enter or select a time interval offset, in
frames, between the input and output.

5. Select Apply.

6. Select OK to close the Ross Gemini Framebuffer Setup dialog.
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Configuring the NewTek™ Network Device Interface
(NDI™)

XPression Clips versions 8.5 build 4518 and newer support up to eight channels of audio.

Only one NDI framebuffer can be created on single channel XPression Clips hardware and up to two NDI
framebuffers can be created on two-channel XPression Clips hardware.

XPression Clips video recordings are in the format and video mode of the input NDI source, not the project
mode.

To configure a NewTek Network Device:

1. In XPression Clips, select Edit > Hardware Setup.

The Hardware Setup dialog opens.

2. Select the Inputs / Outputs tab.

3. Select Add.

The Add New FrameBuffer Board dialog opens.

4. From the Brand drop-down, select NewTek Network Device Interface and then select OK.
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The NewTek Device Interface - Framebuffer Setup dialog opens.

5. In the Settings tab, in the Output Name field, enter an output name for the NDI output source (for
example, NDI Output 1). 

This output name will be the source to connect the device receiving the output signal.

6. In the Input Name Contains field, enter the Host Name and Stream Name.

For example: XPN (VLC), where XPN is the Host Name of the computer where the NDI stream is
playing and VLC is the name of the NDI source stream.

7. Configure the following settings in the Output section as necessary:

· Fill-Only — select this check box to output the video signal with no key.

· Use GPU Color Space Conversion — select this checkbox to use the GPU to perform the color space
conversion on the outputs.

8. In the Input section, select the Use GPU Color Space Conversion checkbox to use the GPU to perform
the color space conversion on the inputs.

9. Select the Fill Only (Ignore incoming alpha channel) checkbox to view fill only and ignore the
incoming alpha channel and select OK.

The configured NDI framebuffer is added to the Inputs / Outputs tab of the Hardware Setup dialog.

10.Select Close to exit the Hardware Setup dialog.
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To configure a self-contained data source panel for XPression Clips in DashBoard or connect to
another XPression Clips as the output for the NDI source:

DashBoard

1. In DashBoard, create an NDI data source video monitor for XPression Clips using PanelBuilder.

2. In the NDI Tag Attributes section of the Insert into ABS Component dialog, from the Source Name
drop-down, select an NDI output for the NDI data source video monitor in the DashBoard panel.

3. Select OK.

When the source NDI output is online in the Sequencer in XPression Clips, it will display in the NDI data
source video monitor in the DashBoard panel.

XPression Clips

1. In XPression Clips, select Edit > Hardware Setup.

The Hardware Setup dialog opens.

2. Select the Inputs / Outputs tab.

3. Select Add.

The Add New FrameBuffer Board dialog opens.

4. From the Brand drop-down, select NewTek Network Device Interface and then select OK.
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The NewTek Device Interface - Framebuffer Setup dialog opens.

5. In the Settings tab, in the Input Name Contains field, enter the name of the NDI input source to use
(for example, NDI Output 1). 

This input name is the output name from the device outputting the signal.

6. Select OK.

The configured NDI framebuffer is added to the Inputs / Outputs tab of the Hardware Setup dialog.

7. Select Close to exit the Hardware Setup dialog.
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Configuring an XPression Desktop Preview Client

The XPression Desktop Preview Server offers an IP based preview server for multi-channel and MOS
Remote Sequencer workflows.

To configure an XPression Desktop Preview Server Client:

1. In XPression, select Edit > Hardware Setup.

The Hardware Setup dialog opens.

2. Select the Inputs / Outputs tab.

3. Select Add.

The Add New FrameBuffer Board dialog opens.

4. From the Brand drop-down, select XPression Desktop Preview Server Client and then select OK.

The Desktop Preview Client - Setup dialog opens.

5. In the Host field, enter the IP address of the XPression Desktop Preview Server.

6. From the Channel drop-down, select a preview channel in the XPression Desktop Preview Server for the
output and then select OK.
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A Desktop Preview Client connection is added to the Inputs / Outputs tab of the Hardware Setup
dialog. 

7. Select Close to exit the Hardware Setup dialog. 

For More Information on...

· the XPression Desktop Preview Server, refer to the XPression Desktop Preview Server User Guide.
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Configuring an XPression Direct Display Output

The XPression Direct Display Output allows XPression to output directly from the NVIDIA GPUs monitor
output or NVIDIA Mosaic display.  Direct Display outputs support custom resolutions and 4:4:4 color space
and are useful for feeding LED display processors that only support Display Port or HDMI connections and
for driving high resolution workflows from a single XPression system. 

«Audio is not currently supported.

«Ensure that the Allow Monitor Power Saving and Allow Screen Saver options are NOT enabled in

Edit > Preferences > Advanced.

Prerequisites:

· Two display monitors connected initially.

· M9 platform or better.

· Windows 11 for Workstation.

· XPression 12.5

To configure display monitors:

1. Right-click on the desktop and select Display Settings.

2. Select Advanced display.

3. From the Select a display to view or change its settings drop-down, select the second display
monitor.

4. Turn the Remove display from desktop option off for this monitor.
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To configure an XPression Direct Display Output:

1. Launch your XPression Clips project.

2. Select Edit > Hardware Setup.

The Hardware Setup dialog opens.

3. Select the Inputs / Outputs tab.

4. Select Add.

The Add New FrameBuffer Board dialog opens.

5. From the Brand drop-down, select XPression Direct Display Output and then select OK.
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The XPression Direct Display - Framebuffer Setup dialog opens.

6. From the Display drop-down, select XPression Direct Display Output.

7. In the Vertical Sync section, from the Source drop-down, select Vertical Sync: Free Running.

In the I/O Configuration section, you will see Out 1 - Fill Only Output.
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8. Select OK.

An XPression Direct Display Output is added to the Inputs / Outputs tab of the Hardware Setup
dialog. 

9. Select Close to exit the Hardware Setup dialog.

To view the output:

1. Drag a clip from the Clip Browser into the Sequencer.

2. In the Take Inspector, in the Take Item tab, from the Framebuffer drop-down, select Framebuffer
1.
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Configuring an XPression RossLinq Connector

The XPression RossLinq Connector feature allows you to connect XPression Clips directly to RossLinq
compatible devices over Ethernet and have XPression Clips render images and graphics to the RossLinq
compatible devices without using any of the video input BNC.

To configure an XPression RossLinq Connector:

1. In XPression Clips, select Edit > Hardware Setup.

The Hardware Setup dialog opens.

2. Select the Inputs / Outputs tab.

3. Select Add.

The Add New FrameBuffer Board dialog opens.

4. From the Brand drop-down, select XPression RossLinq Connector and then select OK.
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The RossLinq Setup dialog opens.

5. In the Connection Settings section, do the following:

· In the Host field, enter the IP address of the RossLinq compatible device.

· From the Channel drop-down, select the channel on the device that you want to upload images to. 

· From the Switcher Type drop-down, select either Hardware switcher or Software switcher, as
appropriate.

· Select Passive Connection to establish a passive FTP connection.

6. In the Override Login section, do the following:

· Select Override Login to override the username and password for the connection.

· In the User field, enter a username for the connection to the RossLinq compatible device.

· In the Password field, enter a password for the connection to the RossLinq compatible device.

7. In the Secure Connection section, do the following:

· Select the Secure Connection checkbox to enable File Transfer Protocol Secure (FTPS).

· Select the Ignore Certificate Validity checkbox to allow certificates certificates that have not been
vetted by a certificate authority (not recommended).

· Select the Allow Self Signed Certificates checkbox to allow certificates that have verified by the
user, rather than by a certificate authority. 
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8. In the Output Settings section, do the following:

·  From the Frame Size drop-down, select the resolution of the images rendered and sent to the
compatible RossLinq device. 

The available options are:

Ø <from project> — use the same format as the project.

Ø PAL, 720x576 

Ø NTSC, 720x486 

Ø HD 720p, 1280x720 

Ø HD 1080i, 1920x1080 

Ø HD 1080p, 1920x1080 

Ø UHD 2160p, 3840x2160 

· Select Send Black Image when Framebuffer is Cleared to display a black screen when the
framebuffer is cleared and then select OK.

An XPression RossLinq connection is added to the Inputs / Outputs tab of the Hardware Setup dialog.

9. Select Close to exit the Hardware Setup dialog.
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Configuring an XPression Clips Virtual Output

The XPression Clips Virtual Output enables XPression software to run without any framebuffer cards
installed in the XPression Clips computer. In this case, the Virtual Output is used to display output in a
window on the XPression Clips computer. 

To configure an XPression Clips Virtual Output:

1. In XPression Clips, select Edit > Hardware Setup.

The Hardware Setup dialog opens.

2. Select the Inputs / Outputs tab.

3. Select the Add button.

The Add New FrameBuffer Board dialog opens.

4. From the Brand drop-down, select XPression Clips Virtual Output and then select OK.

The Virtual Output Settings dialog opens.

5. In the Description field, enter a name or brief description for the virtual output.

6. In the Options section, configure the following:

· Show On Startup — select to have the virtual output open when XPression Clips is launched.

· Fullscreen — make the virtual output window fullscreen.
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· Stay On Top — select to always display the virtual output on top of all other open and/or active
windows on the screen.

· Vertical Sync — currently not implemented.

· Render at Monitor Refresh Rate — currently not implemented.

· Adjust Aspect Ratio to Match First Scene — change the aspect ratio of the virtual framebuffer to
match the scene played on it as opposed to the format of the project.

7. Select OK.

An XPression Clips Virtual Output is added to the Inputs / Outputs tab of the Hardware Setup
dialog.

8. In the Hardware Setup dialog, select Close.
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Changing the Order of Video Inputs / Outputs

With several inputs and outputs configured, you may prefer to have certain inputs or outputs at the top of
the list to make them easy to find. The inputs and outputs can be reordered to suit your needs.

To change the order of video inputs and outputs:

1. In XPression, select Edit > Hardware Setup.

The Hardware Setup dialog opens.

2. Select the Inputs / Outputs tab.

3. In the Inputs / Outputs list, select an input or output to move in the list.

4. At the bottom of the dialog, select Move Down to move the selected device down one position in the
Inputs / Outputs list, or Move Up to move up one position in the list.
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The Move Up button is not available when the selected device is positioned at the top of the list. The
Move Down button is not available when the selected device is positioned at the bottom of the list.

5. Select Close to exit the Hardware Setup dialog.
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Deleting a Video Input / Output

1. In XPression, select Edit > Hardware Setup.

The Hardware Setup dialog opens.

2. Select the Inputs / Outputs tab.

3. In the Inputs / Outputs list, select the input or output to delete.

4. Select Delete at the bottom of the dialog.

A Warning dialog opens.

5. Select Yes.

The selected video device is deleted from Inputs / Outputs list.

6. Select Close.
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Configuring an Audio Device

«Adding an audio device is not required to output embedded or AES audio.

To configure an audio device:

1. In XPression, select Edit > Hardware Setup.

The Hardware Setup dialog opens.

2. Select the Audio Devices tab.

3. Select Add.

The Add Audio Device dialog opens.

4. From the Engine drop-down, select the engine to use to produce audio.

5. From the Device drop-down, select the sound card to use to output audio.

6. Select OK.

The Audio Engine Setup dialog opens. The Configuration settings may differ slightly depending on the
audio device selected.
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7. In the Configuration section, do the following:

· From the Speaker Configuration drop-down, select the speaker type.

· From the Sample Rate drop-down, select the sample rate for the audio signal.

The selected sample rate defines the number of samples per second taken from an analog signal to
make a digital signal. A sample rate of 48 kHz is the recommended setting, but 44.1 kHz can also be
used.

· In the Delay (frames) field, enter or select the number of frames to delay the audio signal.

8. Select OK.

The configured audio device is added to the Audio Devices tab of the Hardware Setup dialog.

9. In the Hardware Setup dialog, select Close.
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Deleting an Audio Device

1. In XPression Clips, select Edit > Hardware Setup.

The Hardware Setup window opens.

2. Select the Audio Devices tab.

3. From the Audio Devices list, select the Audio Device to delete.

4. Select Delete at the bottom of the window.

A Warning dialog opens.

5. Select Yes.

The selected audio device is deleted from the Audio Devices list.

6. Select Close.

The Hardware Setup window closes.
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Adding a Timecode Source

In XPression Clips you can select and configure a timecode source for your project.

To add a timecode source:

1. In XPression Clips, select Edit > Hardware Setup.

The Hardware Setup window opens.

2. Select the Timecode I/O tab.

3. Select Add.

4. The Add New TimeCode Source dialog opens.

5. From the Brand drop-down, select a timecode source. 

The possible options include:

Adrienne TC/GPIO Card — if installed, select the Adrienne TC/GPIO card as the timecode source.

Blackmagic Design (Legacy) — if installed, select the Blackmagic Design (legacy) card as the
timecode source.

Countdown Timer Broadcast — send countdown clocks via UDP to DashBoard or other devices.

Free Running Timecode — use the system clock of the machine or a custom preset time as the
timecode source.

6. Select OK.

The setup dialog for the selected timecode source opens.

7. Select the timecode source from the following list to see the configuration instructions for that source:

  Adrienne TC/GPIO Card
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· In the Timecode Settings section, from the Mode drop-down, select the frame rate to use for the
timecode.

The options are:

· 24 Frames Per Second

· 25 Frames Per Second

· 29.97 Frames Per Second

· 30 Frames Per Second

  Blackmagic Design (Legacy) Card

1. In the Timecode Settings section, from the Source Mode drop-down, select a source mode for the
timecode data. 

The options are:

· VITC (Vertical Interval Time Code) 

· HANC (Horizontal Ancillary Data) 

· RS-422 (Serial) 

2. From the Input drop-down, select an input on the card to receive the timecode data.

3. From the Video Format drop-down, select the video format of the received video signal.
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  Countdown Timer Broadcast Card

1. In the Network Settings section, select the Enabled checkbox to send countdown clocks via UDP to
DashBoard or other devices. 

It is enabled by default.

2. In the UDP Destination IP field, enter the IP address of the device to receive the countdown timer.

3. Select the UDP Broadcast checkbox to send UDP countdown timer packets to a range of IP
addresses within a subnet. 

When the UDP Broadcast checkbox is selected, the UDP Destination IP field changes to Broadcast
Address.

4. In the Port field, enter or select the port number to use for the connection.

5. In the Options section, use the Clock Format checkboxes to select the format of the timer to send
to the receiving device:

· Include Hours — use hours in the clock format.

· Include Frames — use frames in the clock format.

6. In the Layers to Include field, enter the framebuffer layers to include in the clock format.

  XPression - Free Running Timecode Card

1. In the Timecode Settings section, from the Timecode Source drop-down, select a source mode for
the timecode. 

The options are:

· System Clock — use the internal system clock for the timecode.

· Preset Time — use a custom start time for the timecode.

If using a preset time, in the Timecode Start field, enter a start time for the timecode.

2. Select the Wrap at 23:59:59.xx checkbox to restart at the configured preset start time when the
time has reached 23:59:59:xx.
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3. From the Mode drop-down, select the frame rate to use for the timecode.

4. From the State drop-down, select a status for the timecode:

· Active — use the selected timecode.

· Inactive — disable the selected timecode.

8. When you have finished configuring the timecode source, select OK.

The timecode source is added to the list in the Timecode I/O tab.

9. In the Options section, enter or select a number of frames to offset the timecode when playing out a
scene or clip and select Close.
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Configuring the Video Preview and Audio Monitor

In the Preview & Monitor tab, you can select a framebuffer on an output to preview video and select an
audio output device from which to monitor audio.

To configure video preview and audio monitor:

1. In XPression Clips, select Edit > Hardware Setup.

The Hardware Setup dialog opens.

2. Select the Preview & Monitor tab.

3. In the Video Preview Output section, from the Up Next Preview Output drop-down, select the video
output device on which to preview video. 

All framebuffers can be used to preview video.

When <none selected> is the selected preview output, video preview is only possible within XPression
Clips.

«If a configured framebuffer from the Inputs / Outputs tab is used as a preview output, the

Hardware Setup dialog must be closed and reopened before the configured framebuffer is available in
the Output list.
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4. In the Output list, click inside the Assigned Preview Output column and from the Assigned Preview
Output drop-down, select a framebuffer as the individual preview output for the selected framebuffer.

5. In the Audio Monitor section, from the Device drop-down, select the audio output device from which to
monitor audio.

The audio monitor device monitors audio from the Scene Director in the scene loaded in the layout. It is
not used for any scenes on framebuffer outputs, etc.

6. Select Close to exit the Hardware Setup dialog.
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Configuring RS232 CTS/DSR GPI for Contact Closures

Ensure that a USB-232 dongle is installed and assigned to a Communication port or that the system has a
built-in RS232 port before configuring GPI for RS232.

Not all USB to serial converters support contact closures.

When enabled, RS232 GPI (General Purpose Interface) is used to control functions of XPression in sequencer
mode. RS232 GPI can trigger the state of the next take of scenes and scene groups from top to bottom of a
sequence.

A standard RS232 serial port can support two GPI signals using the CTS and DSR pins. Connect Pins 6 and 7
for GPI 1 and connect Pins 7 and 8 for GPI 2.

To configure an RS232 CTS/DSR GPI for contact closures:

1. In XPression, select Edit > Hardware Setup.

The Hardware Setup window opens.

2. Select the GPI / Tally Boards tab.

3. Select Add.

The Add New GPI Board dialog opens.
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4. From the Brand drop-down, select Serial GPI (CTS/DSR) and then select OK.

The Serial GPI Setup dialog opens.

5. In the RS232 GPI Settings section, from the State drop-down, select Enabled. 

Select Disabled to turn off RS232 GPI.

6. From the Port drop-down, select the Communication port that receives RS232 GPI signals.

7. In the Debounce Time field, enter or select the number of milliseconds between sequential GPI pulses.

When using a contact closure GPI on the CTS/DSR lines, some devices might send GPI signals that are
noisy. Connecting the GPI to a mechanical push-button may also exhibit this problem. If the connection
is noisy, it could generate multiple triggers that cause the sequence to advance by two or three events at
a time. Setting a Debounce Time can help filter out any noise during the GPI trigger. This value is the
amount of time XPression will wait before acting upon a second GPI trigger. A value of 50-100
milliseconds should be sufficient.

8. Select OK.

The Serial GPI Setup dialog closes and the configuration appears in the GPI / Tally Boards list.

For More Information on...

· configuring and working with GPIs, refer to the GPI White Paper available from Ross Video.
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Configuring a 25-Pin GPIO Port

The Adrienne TC/GPIO card is installed in Ross Video Turnkey systems. The 25-pin GPIO port can be
accessed through .NET applications or by using the Keyboard / GPI Mapping dialog to configure
functions.

To configure a 25-pin GPIO port:

1. In XPression, select Edit > Hardware Setup.

The Hardware Setup window opens.

2. Select the GPI / Tally Boards tab.

3. Select Add.

The Add New GPI Board dialog opens.

4. From the Brand drop-down, select Adrienne TC/GPIO Card and then select OK.

The Adrienne Setup (GPI) dialog opens.

5. In the Polling Frequency field, enter or select a polling frequency in milliseconds for checking the GPI
inputs.

6. From the Initial Output Pin State drop-down, select the state of the pins when XPression is launched. 

The options are:

· Low (0v) 
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· High (+5v) 

7. Select Active Low Outputs to use the active low status (0v) when the GPI is activated in XPression.

 If not enabled, the GPI is +5v when the GPI is activated in XPression.

8. Select OK.

The Adrienne TC/GPIO card is displayed in the GPI / Tally Board list.

9. Select Close to exit the Hardware Setup dialog.

For More Information on...

· configuring and working with GPIs, refer to the GPI White Paper available from Ross Video.

· creating a custom GPI, refer to the section Creating a Custom GPI Map.
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Configuring a SeaLevel GPIO Board

SeaLevel 8004e and SeaLevel 8012 GPIO cards are customer-supplied.

The 32 pin GPIO port can be accessed through .NET applications or by using the Keyboard / GPI Mapping
dialog to configure functions.

To configure a SeaLevel GPIO Board:

1. In XPression Clips, select Edit > Hardware Setup.

The Hardware Setup window opens.

2. Select the GPI / Tally Boards tab.

3. Select Add.

The Add New GPI Board dialog opens.

4. From the Brand drop-down, select Sealevel GPIO and then select OK.

The SeaLevel I/O Setup dialog opens.

5. From the State drop-down, select Enabled.

6. From the Card drop-down, select the SeaLevel GPIO card to use.
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7. In the Debounce Time (ms) field, enter or select the number of milliseconds between sequential GPI
pulses.

8. Select OK.

The SeaLevel 8004e card is displayed in the GPI / Tally Board list.

9. Select Close to exit the Hardware Setup dialog.

For More Information on...

· configuring and working with GPIs, refer to the GPI White Paper available from Ross Video.

· creating a custom GPI, refer to the section Creating a Custom GPI Map.
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Configuring Smart GPI / RossTalk

Smart GPI/RossTalk is an ASCII based protocol that can be sent over TCP/IP, UDP or RS232 to trigger
various actions in XPression Clips. For more information on configuring and working with GPIs, refer to the
GPI White Paper available from Ross Video tech support.

To configure Smart GPI / RossTalk:

1. In XPression Clips, select Edit > Hardware Setup.

The Hardware Setup window opens.

2. Select the GPI / Tally Boards tab.

3. Select Add.

The Add New GPI Board dialog opens.

4. From the Brand drop-down, select Smart GPI / RossTalk and then select OK.

The Smart GPI / RossTalk Setup dialog opens.

mailto:techsupport@rossvideo.com
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5. In the Settings section, from the State drop-down, select Enabled. 

Select Disabled to turn off Smart GPI/RossTalk.

6. Select a network connection Mode:

· Serial RS232 — use RS232 to send Smart GPI/RossTalk signals to XPression Clips. 

· TCP — use TCP to send Smart GPI/RossTalk signals to XPression Clips. 

If TCP is selected, you can also select Secure Listen to secure communications between TCP and
Smart GPI/RossTalk, making them unreadable by other machines.

· UDP — use UDP sockets to send Smart GPI/RossTalk signals to XPression Clips. 

7. Configure the selected GPI mode.

Serial RS232

· From the Port drop-down, select the communication port that receives GPI signals.

· From the Baudrate drop-down, select the communication speed for GPI signals.

· From the Data Bits drop-down, select the number of bits used to represent one character of data for
GPI signals.

· From the Parity drop-down, select the method used to check for lost data in a GPI signal.

· From the Stop Bits drop-down, select the number of bits used to indicate the end of a byte in a GPI
signal.

· From the Flow Control drop-down, select the data transmission rate controller for a GPI signal.

Flow Control can be set to Hardware or None, but it must be set the same in both XPression Clips
and the transmitting device. 

TCP

· In the Incoming Network Settings section, in the TCP Port field, enter or select the communication
port that receives GPI signals.

· In the Outgoing Network Settings section, in the Hostname field, enter the host name of a remote
device that is to receive RossTalk messages.

· In the TCP Port field, enter or select the communication port that receives the signals. 

· If Secure Listen was selected in the Network Mode section, then select the Secure Connect
checkbox to secure communications between TCP and Smart GPI/RossTalk, making them unreadable
by other machines.

· If Secure Connect has been selected, you have the option to select the Allow Invalid Certificates
checkbox to allow certificates that have not been vetted by a certificate authority (not recommended).

UDP

· In the Incoming Network Settings section, in the UDP Port field, enter or select the communication
port that receives GPI signals.

· In the Outgoing Network Settings section, in the Hostname field, enter the host name of a remote
device that is to receive RossTalk messages.

· In the UDP Port field, enter or select the communication port that receives the signals. 

8. Select OK.

The Smart GPI/RossTalk GPI board is displayed in the GPI / Tally Board list.

9. Select Close to exit the Hardware Setup dialog.
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Configuring a TSL Tally Input

A TSL Tally Input allows a device to send or receive tally information, such as "on-air" or "preview" status,
to indicate which camera, source, or output is currently live or queued for live.

«TSL Version 3.1 and 4.0 are supported.

To configure a TSL Tally input:

1. In XPression Clips, select Edit > Hardware Setup.

The Hardware Setup window opens.

2. Select the GPI / Tally Boards tab.

3. Select Add.

The Add New GPI Board dialog opens.
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4. From the Brand drop-down, select TSL Tally and then select OK.

The TSL Tally Input Settings dialog opens.

5. In the Settings section, from the State drop-down, select Enabled. 

Select Disabled to turn off TSL Tally Input.

6. Select a network connection Mode:

· Serial RS232 — use RS232 to send TSL Tally Input signals to XPression Clips. 

· TCP — use TCP/IP to send TSL Tally Input signals to XPression Clips. 

· UDP — use UDP sockets to send TSL Tally Input signals to XPression Clips. 

7. Configure the selected GPI mode.

Serial RS232

· From the Port drop-down, select the communication port that receives GPI signals.

· From the Baudrate drop-down, select the communication speed for GPI signals.

· From the Data Bits drop-down, select the number of bits used to represent one character of data for
GPI signals.

· From the Parity drop-down, select the method used to check for lost data in a GPI signal.

· From the Stop Bits drop-down, select the number of bits used to indicate the end of a byte in a GPI
signal.

· From the Flow Control drop-down, select the data transmission rate controller for a GPI signal.

Flow Control can be set to Hardware or None, but it must be set the same in both XPression Clips
and the transmitting device. 

TCP

· In the Incoming Network Settings section, in the TCP Port field, enter or select the communication
port that receives GPI signals.

UDP

· In the Incoming Network Settings section, in the UDP Port field, enter or select the communication
port that receives GPI signals.
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8. In the Options section, configure the following:

· Select the Use preview / green tally checkbox to use the green tally to indicate previews (red will
be used for on-air).

· Select the Swap Red/Green tally checkbox to reverse the colors (e.g., use red for previews and
green for on-air).

9. Select OK.



160 • System Setup XPression Clips User Guide (12.5)

Configuring an X-Keys Device

X-Key devices are customer-supplied programmable devices, that are ideal for use with 1RU and 2RU
systems. They can be accessed by using the Keyboard / GPI Mapping dialog to configure functions.

The X-Keys GPIO supports:

· USB 3.0 and USB 3.1.

· Inputs and Outputs

· X-Keys Software Modes PID 1351 and PID 1354.

To configure an X-Keys device:

1. Using the official X-Keys software, configure the Unit ID and all pins.

2. In XPression Clips, select Edit > Hardware Setup.

The Hardware Setup window opens.

3. Select the GPI / Tally Boards tab.

4. Select Add.

The Add New GPI Board dialog opens.
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5. From the Brand drop-down, select P I Engineering.

The XKeys GPIO HD15 Setup dialog opens.

 

6. From the Device drop-down, select the connected X-Keys device.

If you don't see your device in the drop-down, select Refresh to update the list.

7. Select the Log Device Data to show logging in the XPression Live Log and save logging in the
XPression logs.

The XPression Clips logs are located in C:\ProgramData\Ross Video\XPression\XPression
Clips\logs.

8. In the Selected Device section, select the Flash Green LED or Flash Red LED checkbox to aid in
identifying the selected device in a server room.

The device will blink the selected colored LED.

In the Device Pins Status section, colored LEDs indicate how each pin is configured.

9. Select OK to save the configuration and close the setup dialog. 
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Configuring the PBus Interface and PBus Recalls

PBus is an industry standard protocol designed to allow production switchers to communicate with external
devices. 

XPression normally does not perform any action when a PBus recall command is issued. Instead, it stores
the recall ID to be used later when a PBus trigger command is issued.

To configure the PBus interface and PBus recalls:

1. In XPression Clips, select Edit > Hardware Setup.

The Hardware Setup window opens.

2. Select the GPI / Tally Boards tab.

3. Select Add.

The Add New GPI Board dialog opens.
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4. From the Brand drop-down, select PBus and then select OK.

The PBus Setup dialog opens.

5. In the Settings section, from the State drop-down, select Enabled. 

Select Disabled to turn off PBus.

6. Select a network connection Mode:

· Serial RS232 — use RS232 to send PBus signals to XPression. 

· TCP — use TCP/IP to send PBus signals to XPression. 

· UDP — use UDP sockets to send PBus signals to XPression. 

7. Configure the selected mode.

Serial RS232

· From the Port drop-down, select the communication port that receives signals.

· From the Baudrate drop-down, select the communication speed for signals.

· From the Data Bits drop-down, select the number of bits used to represent one character of data for
the signals.

· From the Parity drop-down, select the method used to check for lost data in a signal.

· From the Stop Bits drop-down, select the number of bits used to indicate the end of a byte in a signal.

· From the Flow Control drop-down, select the data transmission rate controller for a signal.

Flow Control can be set to Hardware or None, but it must be set the same in both XPression and
the transmitting device. 

TCP and UDP

· In the Network Settings section, in the TCP or UDP Port field, enter or select the communication
port that receives the signals.
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8. In the PBus Options section, configure the PBus recall options.

Clear layer on recall — when a PBus recall command is received, XPression Clips will check to which
channel and layer the take item being recalled has been assigned. It will then immediately clear that
layer and channel. However, the take item will not be read to air until such time as a PBus Trigger
command is received to put the item on air. This configuration option is recommended in situations
where XPression Clips might be used to play back clips/graphics and to ensure that as soon the recall
command is issued, any previous graphic that might have been left over on the layer will be removed.

Move sequencer focus on recall — moves the sequencer focus to the item that is being recalled. This
can be useful as a means of generating a preview output that will show a rendered frame from the item
that will be put on air when the PBus trigger command is received.

Cue item on recall — places the take item into a cued state when the recall command is received. This
is useful when using video clips which might take a few frames to cue.

Video Clips cue directly to framebuffer — video clips from the Clip Store that are assigned to a PBus
register will be cued directly onto the hardware output of XPression Clips in a paused state. When the
play command is received, they will begin playing.

Ignore LEARN command — ignores the LEARN command. LEARN stores the clip currently loaded into a
server channel into the PBus register list when the LEARN command is received.

9. From the Data Logger drop-down, select an encoding scheme for the data log. 

The options are:

None — do not use data logging.

ASCII — use ASCII encoding for the data log.

HEX — use HEX file formatting for the data log.

Both — use both ASCII encoding and HEX file formatting for the data log.

10.Select OK.

PBus is displayed in the GPI / Tally Board list.

11.Select Close to exit the Hardware Setup dialog.

For More Information on...

· configuring and working with GPIs, refer to the GPI White Paper available from Ross Video.
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Setting Up Server Channels

The Server Channels are used for previewing and playing out clips.

Before using the server channels, they must be configured in the XPression Clips Hardware Setup. Once
outputs have been configured in XPression Clips, use the following procedure to set up the server channels.

A virtual channel should be assigned a real physical output onto which the clip will be played. It is these
virtual channels that the AMP/VDCP Media Control Gateway is controlling.

To set up server channels:

1. In XPression Clips, select Edit > Hardware Setup.

The Hardware Setup dialog opens.

2. Select the Server Channels tab.

The Server Channels tab opens.

3. Select Add.

The Select Server Channel # dialog opens.
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4. From the Channel drop-down, select a server channel number and then select OK.

The server channel is added to the list.

5. Configure the following as necessary:

· In the Name column, enter a name for the server channel. The default is Server Channel #.

· In the Framebuffer column, use the list to select an output framebuffer for the server channel.

· In the Layer column, enter or select a layer for rendering. The default is 0 (middle).

· In the Options section, select Cue video clips directly to framebuffer to cue clips to air
immediately when dropped on a server channel from the Clip Browser.

6. Repeat steps 3 to 6 to add more server channels as necessary.

7. Select Close to exit the Hardware Setup dialog.

For More Information on...

· configuring outputs, refer to Configuring an AJA Video FrameBuffer (Legacy), Configuring a Blackmagic
Design FrameBuffer (Legacy), or Configuring an XPression Virtual Output.
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Clips
The following topics are discussed in this section:

XPression Clips Playback Overview

Creating a Project

Adding Clips to the Clip Store

Generating Proxies for Clips

Loading a Clip in the Server Channels

Using the Clip Browser

Ganging Fill and Key in the Clip Browser

Using the Server Channels

Editing a Clip/Adding Sub Clip

Updating the Thumbnail in the Clip Browser

Creating a 4-Point Loop

Creating a 3-Point Loop
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XPression Clips Playback Overview

Clip playback within XPression Clips can be performed in many ways. The most basic is to drag clips from
the Clip Browser and drop them into the Sequencer. This creates a take item which can be assigned an
output framebuffer and layer, or server channel, and then played back as a regular take item or placed into
a cued state using the number pad period key [Num pad .].

The number of clips that can be played back simultaneously falls under the same performance limitations as
normal XPression scenes with clips (e.g. play back will be dependent on current generation hardware).

While playing back, a timer counts down the remaining time in the clip and a time bar indicates the playback
amount completed:

Many clips can be dragged into a timed sequence group for a pseudo-playlist capability. Dissolves can even
be set on the take items for transitions between the playlist items:

Clips within the Clip Browser can be sorted and filtered using the options in the Advanced Search
Options. In the example image below they were filtered by Project Name.
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Creating a Project

Once your preferences and system setup have been configured, you can get started with creating a new
project. You can use any of the many presets that are provided or you can create a custom preset.

To create a project:

1. In XPression, select File > New.

If there is a project currently open, the Confirm dialog opens.

2. Select one of the following options for the current project:

· Yes — save changes to the current project, then close the project.

· No — close the project without saving changes.

· Cancel — continue working on the project.

3. After selecting Yes or No, the New Project dialog opens.

4. In the Presets tree view, expand any video format node to view the available presets for the selected
video format.

The available presets for the selected video format are displayed in the Settings section on the right
side of the dialog.

5. Select the preset to use for the new project.

6. Select Browse to the right of the Location field to select a folder in which save the new project.
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The Select Project Folder dialog opens.

7. In the Folder tree view, locate and select a folder in which save the new project and choose Select
Folder.

In the New Project dialog, the full path of the selected folder is displayed in the Location field.

8. In the Name field, enter a name for the new project.

Project names may only contain letters, numbers, spaces, hyphens, or underscores. 

Project files are saved with the extension .xpf.

9. Select Create Project Structure to automatically create folders within the project folder to store
project items (audio, video, dedicated fonts, images. models, etc.) and select OK.

The new project is saved in the project folder.

To create a custom preset:

1. Select New Preset. 

2. In the New Preset field, enter a name for the preset.

3. In the Settings section configure the new preset.

4. Select Save Preset.
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5. Select Browse to the right of the Location field to select a folder in which save the new project.

The Select Project Folder dialog opens.

6. In the Folder tree view, locate and select a folder in which save the new project and choose Select
Folder.

In the New Project dialog, the full path of the selected folder is displayed in the Location field.

7. In the Name field, enter a name for the new project.

Project names may only contain letters, numbers, spaces, hyphens, or underscores. 

Project files are saved with the extension .xpf.

8. Select Create Project Structure to automatically create folders within the project folder to store
project items (audio, video, dedicated fonts, images. models, etc.) and select OK.

The new project is saved in the project folder.
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Adding Clips to the Clip Store

To add a clip to the clip store:

1. In XPression Clips, select Tools > Record Client.

The Record Client dialog opens.

2. In the Destination Folder field, select Browse (…) navigate to the folder containing the clips you want
to add to the clip store.

Alternatively, you can navigate to the folder in the folder tree in the left column.

The folder you selected opens in the Record Client and the clips are displayed.
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3. In the folder containing your clips, right-click on a clip file and select Send to Clip Store.

The Send to Clip Store dialog opens with the clip file selected.

4. In the Metadata section, the Name field is automatically populated with the name of the video file, but
you can change it if you want.

5. In the Recall ID field, if it hasn’t been automatically populated, enter a Recall ID (typically this is the
same as the name).

6. In the Project field, enter the name of the project or use the drop-down to select a project.

7. Then select Send to Clip Store.

You can see the progress of the import in the File Progress bar and when the import is complete, the
Status will indicate Import Complete.

8. Select Close to exit the Send to Clip Store dialog.
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Generating Proxies for Clips

You will need to generate proxies (browser-friendly video files) for your clips in order to play them in the
HTML5 plugin.

To generate proxies for clips:

1. Go to C:\Program Files (x86)\XPression Clip Store\bin and double-click the xpCSProxyTool.exe
file.

The XPression ClipStore Proxy Generator tool opens.

2. Select Start Proxy Generation to generate proxies for any clips in the clip store that do not already
have proxies.

In the Active Transcodes section, you will see the clip(s) being transcoded and the progress is
indicated in the Overall Progress bar.

3. When the Overall Progress bar indicates 100%, select the X in the top-right corner to close the Proxy
Generator.

The clip is now ready to be used in the HTML5 plugin.
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Loading a Clip in the Server Channels

For clips to load in the Server Channels window, server channels must be configured in the Server
Channels tab of the XPression Clips Hardware Setup. See Setting Up Server Channels .

To load a clip in the server channels:

1. In the Clip Browser, select a clip.

If clips have been sent to the Clip Browser from the Record Client, or if clips have been transcoded by
the INcoder into the Watch Folder, clips will automatically load into the Clip Browser.

2. Drag and drop a clip from the Clip Browser onto a Server Channel in the Server Channels window.

The clip is added to the Preview channel for the Server Channel (or directly to the Server Channel if
the preview has been disabled in the options).

The clip will be loaded to its pre-configured in point.

3. If loaded in the Preview, select Take to play the clip on air on the Server Channel. 

While a clip is on air, clips can be cued on the Preview channel while still allowing the on air clip to be
controlled and have its timecode and countdown visible.

Server Channel playback controls are provided or the space bar can be used to pause and start
playback.

A realtime proxy of the clip is shown as it plays in the server channel along with audio meters and a time
remaining counter.

Take items or timed groups in the Sequencer can also be dragged onto a server channel for playback.
To preserve the original server channel assignment of a take item, press and hold Ctrl while dragging
and dropping from the Sequencer to a server channel.
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«Clips can also be loaded to a channel by double-clicking them in the Clip Browser. They will be loaded

onto the active server channel, as shown by a cyan outline around the channel. Once a clip is loaded to a
server channel, it can be dragged and dropped from one server channel to another as a duplicate. The
active channel can be changed by double-clicking any other server channel.

Clips can also be dragged and dropped directly from Windows Explorer for situations where the clip is not
loaded into the Clip Store (or there is no Clip Store present).

4. Select the Transition tab to set the in and out transitions for the clip in the active server channel:

5. In the In tab, select a Transition style and Mode:

The options are:

· Cut — select to use an instantaneous transition from the take item to the next take item.

· Dissolve — select to use a gradual transition where a take item dissolves into the next take item. 

Configure the mode for the dissolve:

Ø Fade — select to fade in to, or out from, the clip.

Ø Over Black — select to fade in or out from black.

Ø Additive — select to gradually add light to the clip when transitioning in or out.

Ø Saturate — select to saturate the clip when transitioning in or out.

Ø Desaturate — select transition to desaturate the clip when transitioning in or out.

Ø Invert — select to invert the clip when transitioning in or out.

· Push — select to use a sliding transition where the take item pushes out the previous take item. 

Configure the mode for the push:

Ø Right To Left — select to push from right to left.

Ø Left To Right — select to push from left to right.

Ø Top To Bottom — select to push from top to bottom.

Ø Bottom To Top — select to push from bottom to top.

Ø Bottom Right — select to push to the bottom right.

Ø Top Right — select to push to the top right.

Ø Bottom Left — select to push to the bottom left.

Ø Top Left — select to push to the top left.

· Distort — select to use a transition where a take item is warped out. 

Configure the mode for the distortion:

Ø Diverge — select to use multiple splits in the image in the clip.

Ø Pixelate — select to pixelate the clip.

Ø Sine Wave — select to apply a sine wave pattern to the clip.
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Ø Shrink — shrink the clip in a uniform manner from full screen down to a single pixel when
transitioning from online to offline; expand the clip in a uniform manner from a single pixel to full
screen when transitioning from offline to online.

Ø Shrink Diff — shrink the clip in a non-uniform manner from full screen down to a single pixel
when transitioning from online to offline; expand clip in a non-uniform manner from a single pixel
to full screen when transitioning from offline to online.

Ø Spiral — select to spin the clip.

6. Select the Reverse checkbox to reverse a Dissolve, Push, or Distort transition.

7. Select the Transition Audio checkbox to transition the audio along with the Take Item.

8. Use the Duration field to enter or select the duration of the transition in number of frames.

9. Select the Out tab and repeat steps 5 to 7 to configure the Transition style and Mode for the out
transition.

10.Select the Cue video clips directly to framebuffer checkbox to cue clips to air immediately when
dropped on a server channel from the Clip Browser or Sequencer.

For More Information on...

· setting up server channels and virtual outputs, refer to Setting Up Server Channels.

· sending clips from the Record Client to the Clip Browser, refer to Sending a Video or Image to the Clip
Store.

· configuring a Watch Folder for the INcoder, refer to the INcoder User Guide.
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Using the Clip Browser

To use the Clip Browser:

1. In the Clip Browser, select a clip in the clip list to play out. 

To search for a specific clip or sub clip, use one of the following methods:

· Select the Fast Recall button (the button is green when turned on). 

When turned on, fast recall enables searching clips by recall ID by entering a recall ID number using
the number pad on the keyboard.

The clip will be automatically selected in the Clip Browser. Pressing Enter will cue the clip, and
pressing Enter a second time will play the clip.

Clear a recall ID from the Quick Find field by pressing Esc.

A clip can be cued by entering the recall ID and pressing cue [.].

· In the Quick Find field, enter a clip name or keyword to search for a specific clip in the Clip Browser. 

Press Esc to clear the field.

· Select the Show/Hide advanced search options button ( ) to enter more criteria to search for a
specific clip.

· Select the Show all sub clips for matching clips checkbox to display any sub clips of a clip in the
clip list when performing a Quick Find.

2. Right-click on a clip and select one of the following options:

· Edit — select this command to open the Edit Clip dialog.

· Add Sub Clip — select this command to open the Add Sub Clip dialog to create a sub clip from the
selected clip.

· Set Recall ID — use the Set Recall ID dialog to enter a recall ID to assign to a selected clip or the
starting recall ID for the range of selected clips.

· Adjust Loop / Hold Last > Enable Looping — enable looping for a clip or a range of selected clips.

· Adjust Loop / Hold Last > Disable Looping — disable looping for the clip or a range of selected
clips if looping is enabled.

· Adjust Loop / Hold Last > Enable Hold Last Frame — hold the last frame of the clip or a range of
selected clips when playout ends. 

«Do not select this function if taking the clip(s) offline automatically using an out transition.

· Adjust Loop / Hold Last > Disable Hold Last Frame — disable holding the last frame of the clip or
a range of selected clips when playout ends if holding the last frame is already enabled.
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· Add to Sequencer — add selected clip or range of clips to the Sequencer.

3. Add the clip to one of the following locations:

Server Channels

Sequencer

Server Channels

· Drag and drop the selected clip onto a Server Channel in the Server Channels window. 

OR

Double-click the clip.

OR

Right-click the clip and select Cue on Server Channel.

The clip is added to the selected Server Channel.
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Sequencer

· Drag and drop the selected clip into the Sequencer. 

When dragging a clip into the Sequencer from the Clip Browser, the take ID assigned uses the recall ID
or the next higher available number.

· Shift-click or Ctrl-click to select, drag and drop multiple clips into the Sequencer.

The clip is added to the Sequencer.

For More Information on...

· the Sequencer, refer to Sequences.
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Ganging Fill and Key Clips in the Clip Browser

In XPression Clips, you can combine or "gang" two clips together, using the fill of one clip with the second
clip used as its key (alpha).

1. In XPression Clips, open the Sequence layout.

2. In the Menu bar, select Display > Clip Browser.

The Clip Browser window opens.

3. Select the clip you want to use as fill, then press Ctrl and select the clip you want to use as its key.

Alternatively, you can left-click on each clip to select it.

4. Right-click and from the shortcut menu, select Gang Fill (name of the fill clip).

After the association is made, the names of the clips being ganged will be displayed in the Ganged Clip
column and their usage (Fill or Key) will be displayed in the Ganged As column. 

To edit ganged clips:

· Right-click on the clip in the Ganged Key column and from the shortcut menu, select Edit to edit the key.

· Right-click anywhere else in the clip row and from the shortcut menu, select Edit to edit the fill.

To separate ganged clips:

1. Select either of the ganged clips. 

2. Right-click and select Ungang Selected Clips.



182 • Clips XPression Clips User Guide (12.5)

Using the Server Channels

To use the server channels:

1. In the Server Channels window, load a clip onto a Server Channel.

2. Select the Transition tab and configure the in and out transition for the clip:

In the In and Out tabs, select an in and out transition for the clip:

· Cut — transition instantaneously to and from the clip.

· Dissolve — the clip gradually dissolves in or out.

· Push — the clip slides in or out.

· Distort — the clip is warped in or out.

3. In the Mode section, configure the Dissolve, Push, and Distort transition mode:

Dissolve 

· Fade — fade in to, or out from, the clip.

· Over Black — fade in or out from black.

· Additive — gradually add light to the clip when transitioning in or out.

· Saturate — saturate the clip when transitioning in or out.

· Desaturate — desaturate the clip when transitioning in or out.

· Invert — invert the clip when transitioning in or out.

Push 

· Right To Left — push from right to left.

· Left To Right — push from left to right.

· Top To Bottom — push from top to bottom.

· Bottom To Top — push from bottom to top.

· Bottom Right — push toward the bottom right.

· Top Right — push toward the top right.
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· Bottom Left — push toward the bottom left.

· Top Left — push toward the top left.

Distort 

· Diverge — use multiple splits in the image in the clip.

· Pixelate — pixelate the clip.

· Sine Wave — apply a sine wave pattern to the clip.

· Shrink — expand the clip from a shrunken image.

· Shrink Diff — expand the clip from a shrunken image.

· Spiral — spin the clip.

· Duration — enter or select the duration of the transition in number of frames.

4. Select the Reverse checkbox to reverse a Dissolve, Push, or Distort transition.

5. Select the Transition Audio checkbox to transition the audio along with the Take Item.

6. Use the Duration field to enter or select the duration of the transition in number of frames.

7. In the Options tab, select the Cue video clips directly to framebuffer checkbox to cue clips to air
immediately when dropped on a server channel from the Clip Browser or Sequencer.

8. Use the playback controls to play out the clip:

 
Eject remove a loaded clip from the server channel.

Back return to the beginning of a clip.

Pause pause the clip.

Play play out the clip.

Forward go to the end of the clip.

Loop continuously play the clip. When this button is green, the loop function is turned on.
Pressing it again will turn off the loop function.

Scrub Bar select and hold the marker to drag it forward or backward along the time bar to
move the clip position to a particular location.

9. Right-click inside the Server Channel and:

· select Adjust Clip Volume to open the Adjust Clip Volume dialog box and adjust the clip volume, if
necessary.

· select Edit Clip to open the Edit Clip dialog and edit a clip, if necessary.

· select Show Viewport to open a separate server channel window.
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To see a larger preview:

1. Right-click on the Server Channel and select Show Viewport.

2. Drag out from the sides, top, or bottom of the viewport to enlarge it.

To dock a server channel on a secondary display:

1. Right-click on the Server Channel and select Show Viewport.

2. Select the viewport and drag it onto another display.

For More Information on...

· loading a clip on a server channel, refer to Loading a Clip in the Server Channels.

· editing a clip, refer to Editing a Clip/Adding a Sub Clip.
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Editing a Clip / Adding a Sub Clip

Use the Edit Clip and Add Sub Clip dialogs to configure metadata for a clip. The Add Sub Clip dialog has
the same interface as the Edit Clip dialog but is used to create a trimmed clip from an existing clip. A video
can have multiple sub-clips defined within it, each with distinctive in/out points. Loading a sub-clip for
playout is identical to loading a normal clip.

· The Edit Clip dialog can be accessed by right-clicking in the Clip Browser window and Server Channels
window.

· The Add Sub Clip dialog can only be accessed by right-clicking in the Clip Browser window.

Video

This section displays the clip that has been selected for editing or creating a sub clip. The clip is rendered
over a checkerboard pattern so that the alpha channel is visible unless the clip is full frame.

The following actions and commands can be performed:

· Use the timeline marker to select a specific frame in the timeline.

· The video can be scrubbed using the timeline bar; or using common NLE shortcuts like H,J,K to
play/rewind at different speeds.

· During scrubbing, audio can be heard by configuring an Audio Monitor device in the Hardware Setup.

· Right-click inside the Clip, Local Events, or Event Track timeline to access the shortcut menu.
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«Event Track timelines are available if global event tracks have been configured in the Clip Store

Manager and added as a processor in the INcoder. They will appear in the timeline as named in the Clip
Store Manager. They can be assigned as local events by selecting Preset Event Track > Copy Events
to Local Event Track from the shortcut menu.

Ø Looping > Set Loop Start — select the current position of the timeline marker as the start of the
video loop.

Ø Looping > Set Loop End — select the current position of the timeline marker as the end of the video
loop.

Ø Looping > Reset Loop — clear the loop settings.

Ø Clear In Point — clear a configured start time for the clip.

Ø Clear Out Point — clear a configured end time for the clip.

Ø Clear In and Out Points — clear the configured start and end times for the clip.

Ø Update Clip Thumbnail — update the thumbnail for the clip to reflect any edits or to use a specific
frame as the thumbnail in the Clip Browser.

Ø Add Event > Rosstalk Event — add a RossTalk event directly onto the clip timeline.

Ø Add Event > Scene Director Trigger — add a Scene Director trigger event directly onto the clip
timeline.

Ø Rename Event — rename a selected RossTalk or Scene Director trigger event on the clip timeline.

Ø Delete Event — delete a selected RossTalk or Scene Director trigger event on the clip timeline.

For More Information on...

· using global event tracks, refer to the XPression Clips Workflow User Guide.

· setting up an audio monitor device, refer to Configuring the Video Preview and Audio Monitor .

· updating the thumbnail in the Clip Browser, refer to Updating the Thumbnail in the Clip Browser .

· looping, refer to Looping Tab.
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Video Controls

Set In Point Set the start time of the clip where the timeline marker
has been positioned. Keyboard shortcut ‘I’ can be used
to mark an in point.

Set Out Point Set the end time of the clip where the timeline marker
has been positioned. Keyboard shortcut ‘O’ can be used
to mark an out point.

Move current position to in point Return to the in point of the clip.

Start playback Play the clip.

Move current position to end point Go to the end of the clip.

Loop Loop the playback of the clip. Press the button a second
time to turn off looped playback.

Clip Timing (read-only)

Position — indicates the position of the timeline marker in the timeline for the clip.

In — displays the in point for the clip.

Out — displays the displays the out point for the clip.

Length — displays the total duration of the clip in frames.

Duration — displays the time length of the clip.

Source Information (read-only)

Resolution — displays the video format of the source clip.

Frame Rate — displays the frame rate of the source clip.

File Size — displays the file size of the source clip.

Bit Depth — displays the quality of the signal quantization of the source clip.

Audio Channels — displays the amount of embedded audio channels used in the source clip.

Codec UID — displays the type of encoding used for the source clip.

Source TC — displays the timecode of the source clip.

Duration — displays the total duration in frames of the source clip.
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Clip Tab

Name — enter or edit a name for the clip.

Recall ID — enter an ID number for the clip when it is recalled.

Hold Last Frame — hold the last frame of the clip when playout ends. Do not select this checkbox if taking
the clip offline automatically using an out transition.

In Point — enter a starting point for the clip.

Out Point — enter an ending point for the clip.

Audio Level — enter or select a volume level for the clip in decibels. Changing the audio level in the Edit
Clip dialog box will not affect live clips on a Server Channel. However, it will apply to the audio monitor if an
audio monitor is configured in the Hardware Setup.

Source (read-only) — lists the location where the clip is stored.

File Name (read-only) — lists the name and file extension of the clip.

Project — select a project for the clip.

Added (read-only) — lists the date the clip was added to the clip store.

Last Modified (read-only) — lists the date the clip was last edited.

Expires — use the calendar to select an expiry date for the clip, if necessary.

Does not expire — use no expiry date for the clip.

Looping Tab

Enable Looping — enable looping for the clip.

Multi-Point — enable the multi-point loop settings.

Multi-Point Loop Settings 

Use the multi-point loops to create free running 4-point and 3-point loops:

· 4-point loops use a frame in point, a loop section of start and end frames, and a frame out point.

· 3-point loops use a loop section of start and end frames with either a frame in point the same as the loop
start frame or a frame out point the same as the loop end frame.

Loop
Start

Enter a starting frame for the loop within the clip time.

Loop
End 

Enter an end frame for the loop within the clip time.

Loop
Count

Enter or select an amount of playbacks the clip will loop before stopping. Use 0 for infinite
looping.

Set the start time or end time of the loop at the position of the timeline marker.

Skip to the start of the loop.
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Skip to the end of the loop.

For More Information on...

· creating a 4-point loop, refer to Creating a 4-Point Loop .

· creating a 3-point loop, refer to Creating a 3-Point Loop .

Additional

Original File Name (read-only) — displays the original name of the file as uploaded.

Premultiplied / Shaped — select this checkbox to multiply/shape the fill signal color information by the
luminance information in the key signal.

Event Tracks

Event tracks are configured in the Clip Store Manager, added as processors in the INcoder, and then
available to use when editing clips from the Clip Browser. The Event Tracks tab provides a list of available
global event tracks.

Assigned Event Tracks — lists the event tracks assigned to the clip.

Available Event Tracks — lists the available event tracks that can be assigned to the clip.

Add Track — select an available event track and select this button to assign it to the clip.

Remove Track — select an assigned event track and select this button to remove it from the clip.

For More Information on...

· using global event tracks, refer to the XPression Clips Workflow User Guide.

Other

Export — use this list to select one of the following options for exporting a clip:

· To Video — open the Export to Video dialog to save the clip as an AVI or MOV video file.

· Still to Disk — open a save dialog to save a still as a Targa (.TGA), Targa (RLE Compressed) (.TGA),
Portable Network Graphic (.PNG), or JPEG (.JPG) format image file.

· Still to Clipstore — open the Send to Clip Store dialog to send a still to the Clip Store database to be
used within the Clips workflow.

· Interlaced Settings > Frame Based — capture the image file without deinterlacing. This setting works
best for scenes with minimal motion.

· Interlaced Settings > Field (line doubled) — capture the image file with each line doubled. For
example, it will replace field two with a duplicate of field one.

· Interlaced Settings > Field (line interpolated) — capture the image file by interpolating between odd
lines to form even lines.
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Updating the Thumbnail in the Clip Browser

You can update the thumbnail in the Clip Browser to provide a more representative or preferred image to
illustrate the content of the clip.

1. In the Clip Browser, right-click on a clip and select Edit Clip or Add Sub Clip.

The Edit Clip / Add Sub Clip dialog opens.
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2. In the Edit Clip or Add Sub Clip dialog, move the timeline marker to a desired frame in the timeline.
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3. Right-click inside the timeline and select Update Clip Thumbnail from the shortcut menu.

4. Click Save.

The thumbnail for the clip is updated in the Clip Browser.
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Creating a 4-Point Loop

4-point loops use a frame in point, a loop section of start and end frames, and a frame out point.

To create a 4-point loop:

1. In the Edit Clip / Add Sub Clip dialog, select the Clip tab.

The Clip tab opens.

2. In the In Point field, enter a frame in point.

3. In the Out Point field, enter a frame out point.
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4. Select the Looping tab.

The Looping tab opens.

5. In the Looping tab, select the Enable Looping checkbox.

6. Select the Multi-Point checkbox.

7. In the Multi-Point Loop Settings section:

· In the Loop Start field, enter a frame start for the loop.

· In the Loop End field, enter a frame stop for the loop.

· In the Loop Count field, enter or select the number of times to play out the loop. Enter 0 for infinite
looping.

8. Select Save.

The edited clip is updated in the Clip Browser.
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Creating a 3-Point Loop

3-point loops use a loop section of start and end frames with either a frame in point the same as the loop
start frame or a frame out point the same as the loop end frame.

To create a 3-point loop:

1. In the Edit Clip / Add Sub Clip dialog, select the Clip tab.

The Clip tab opens.

2. In the In Point field, enter a frame in point.

3. In the Out Point field, enter a frame out point.
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4. Select the Looping tab.

The Looping tab opens.

5. In the Looping tab, select the Enable Looping checkbox.

6. Select the Multi-Point checkbox.

7. In the Multi-Point Loop Settings section:

· In the Loop Start field, enter a frame start for the loop.

· In the Loop End field, enter a frame stop for the loop.

· In the Loop Count field, enter or select the number of times to play out the loop. Enter 0 for infinite
looping.

8. Select Save.

The edited clip is updated in the Clip Browser.
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Importing / Exporting Clips

Clips and subclips can be imported from another project or exported to a .XCP file and saved to be used in
another project.

You can bulk export multiple clips and subclips. 

To import clips:

1. In XPression Clips, select any spot in the Clip Browser, right-click and select Import / Export Clip(s)
> Import Clip(s).

2. In the Open window, navigate to the folder containing your clips and select the clip to import.

3. Then select Open.

If the clip you selected is a duplicate of one currently in the Clip Browser, you have the option to import
the clip with a new GUID or skip the import.

If you import a duplicate clip, the new clip will assume the Recall ID of the original clip and the original
clip will have no Recall ID.
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To export clips:

1. In XPression Clips in the Clip Browser, right-click a clip and select Import / Export Clip(s) > Export
Selected Clip(s).

Alternatively, press Shift and select the first and last clip, or press Ctrl and select individual clips to
export multiple clips.

2. In the Save XPression Clips window, navigate to the folder where you want to save the clip.

3. In the File name field, enter a name for the clip and select Save.

The Clip Exporter window opens displaying the progress of the export.

4. When the Clip Store has completed processing the clip, select Close.
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To export all clips in the clip browser:

1. In XPression Clips, select any spot in the Clip Browser, right-click and select Import / Export Clip(s)
> Export All Clip(s).

2. In the Save XPression Clips window, navigate to the folder in which to save your clips.

3. In the File name field, enter a name for the group of clips and select Save.

The Clip Exporter window opens displaying the progress of the export.

4. When the Clip Store has completed processing the clip, select Close.
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Sequences
XPression Clips uses the Sequencer to play out the scenes in a project.

The following topics are discussed in this section:

Creating a Sequence

Controlling Sequence Playout

Playing Out a Sequence in Manual Mode

Playing Out a Sequence in Automatic Mode

Playing Out a Take Item or Take Item Group Using Timecode

Rendering Take Items to Video
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Creating a Sequence

After you have created all the necessary clips for your project, you can organize them for playout in the
Sequencer. Clips can be organized into groups and the groups can be configured to automatically play out
the take items in the group.

To create a sequence:

1. Load clips into the Clip Browser.

2. In the Clip Browser, select and drag the clips to play out into the Sequencer.

Each clip added to the Sequencer list is given a Take ID and becomes a take item.

To reorder take items in the Sequencer 

· Select and drag a take item to a new position in the Sequencer list.

Toolbar tools, shortcut menu commands, and keyboard shortcuts can also be used to reorder take items.

To group take items in the sequencer:

1. Select the Create a New Group  button in the toolbar.

A take item group is added to the Sequencer.

2. Click in the Name column for the group and enter a new name for the group.

3. Select and drag take items from the Sequencer list into the new group.

To color code take items:

1. Select one or more take items and/or take item groups.

2. Right-click and select Color.

The Color menu opens.

3. Select a highlight color from the Color menu.
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4. The background of the selected take items in the Sequencer list is shaded with the selected color. 

Coloring the background of a take item group colors each take item in the group.

To adjust the font size of take items:

· Select the Increase the size of the sequencer font  button to make the font size larger.

· Select the Decrease the size of the sequencer font  button to make the font size smaller. 

For More Information on...

· controlling sequence playout, refer to Controlling Sequence Playout.
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Controlling Sequence Playout

Use the Sequencer to organize and control the playout of scenes and scene groups in XPression Clips.

To control sequence playout:

1. In the Sequencer, select the Create a New Group  button in the toolbar to create a take item group
to contain the take items to play out.

2. From the Clip Browser, select and drag clips into the new take item group in the Sequencer.

The selected clips are added to the take item group.

3. Select and drag a take item to a new position in the group to create the playout order.

4. Select the take item group that contains the take items to play out.
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5. In the Take Inspector, in the Group tab, from the Playout Mode drop-down, select Manual.

6. In the Sequencer, double-click a take item to play out the selected take item.

The selected take item plays out through the default output, and the State changes to online for take
items or Active for take item groups.

7. To stop playout of an online or Active take item, right-click the take item and from the shortcut menu,
select Take Offline.
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Keyboard Control

The keyboard number pad can also be used to control the playout of a sequence. 

The following keyboard shortcuts are available in the Sequencer:

· Cursor Up Arrow — select the previous take item in the sequence.

· Cursor Down Arrow — select the next take item in the sequence.

· Cursor Left Arrow — collapse an expanded sequence group.

· Cursor Right Arrow — expand a collapsed sequence group.

· Home — select the first take item in the sequence.

· End — select the last take item in the sequence.

· Ctrl-Cursor Up Arrow — move the selected take item up one position in the sequence.

· Ctrl-Cursor Down Arrow — move the selected take item down one position in the sequence.

· Delete — remove the selected take item from the sequence. 

· Number Pad Enter — play out the selected take item. This shortcut requires the Fast Recall button to
be enabled.

· Number Pad + — play out the selected take item and select the next take item in the sequence.

· Number Pad - — take the current take item offline if it is online.

· Number Pad . — cue a selected take item prior to putting them online by pressing the decimal key on
the number pad. Cueing them will pre-cache all video clips in the scene. Multiple items can be cued and
brought to air simultaneously.

· Number Pad * — focus a take item. This shortcut requires the Fast Recall button to be enabled.
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Playing Out a Sequence in Manual Mode

Sequences can be played out in Manual or Automatic mode. These instructions describe how to use
Manual mode.

See Playing Out a Sequence in Automatic Mode  for instructions for that mode.

To play out a sequence in Manual mode:

1. In the Sequencer, select the take item group that contains the take items to play out.

2. In the Take Inspector, from the Playout Mode drop-down, select Manual.

3. In the Sequencer, select the take item to play out.

The selected take item plays out through the default output.
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4. To stop playout of a take item, right-click the take item and select Take Offline from the shortcut menu.

For More Information on...

· creating sequences, refer to Creating a Sequence.

· controlling sequence playout, refer to the procedure Controlling Sequence Playout.
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Playing Out a Sequence in Automatic Mode

Sequences can be played out in Manual or Automatic mode. These instructions describe how to use
Automatic mode.

See Playing Out a Sequence in Manual Mode  for instructions for that mode.

To play out a sequence in automatic mode:

1. In the Sequencer, select the take item group that contains the take items to play out.

2. In the Take Inspector, from the Playout Mode drop-down, select Timed.

3. From the Start at drop-down, select the playout start time for the group. 

The options are:

· Immediate — start playout immediately upon selecting a take item group for playout.

· Clock Time — start playout at the time set in the Start Time field after selecting a take item group
for playout.

4. From the Item Timing drop-down, select the item level on which to base playout duration.

The options are:

· Item Duration — use the playout durations set for the items in the group.

The playout duration for the item group equals the total of all the item durations.

· Group Duration — set a playout duration for the entire group.

Set the duration in the Group Duration field.

· Fixed Item Duration — use the specified playout duration for each of the items in the group
regardless of the durations of the individual take items.

Set the duration in the Item Duration field.



XPression Clips User Guide (12.5) Sequences • 209

· Scene Director — use the default scene director of a scene to control when an item group should
advance.

· Advance Manually — double-click the scene group or use a script to advance the item group.

5. From the Repeat drop-down, select the number of times to playout the item group.

The options are:

· Never — do not repeat playout; only play out the item group once.

· When Done — repeat the playout of an item group when the playout ends.

With this option, playout repeats until it is manually stopped.

· After — repeat the playout of an item group after the time set in the Time Value field and Time Unit
drop-down.

With this option, playout repeats until it is manually stopped.

· Every — repeat the playout of an item group at the time interval set in the Time Value field and
Time Unit drop-down.

6. From the When Finished drop-down, set the action to complete after finishing the playout of the take
item group.

The options are:

· Keep Online — leave the take item group status as Active, making the group available for immediate
playout.

· Take Offline — change the take item group status to Offline.

7. In the Sequencer, double-click the take item group that contains the take items to playout.

The selected take item group plays out through the default output, and the State changes to Active.

For More Information on...

· creating sequences, refer to Creating a Sequence.

· controlling sequence playout, refer to the procedure Controlling Sequence Playout.
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Playing Out a Take Item or Take Item Group Using
Timecode

You can play out take items or take item groups in the Sequencer using a timecode source. A timecode
source needs to be configured in the Hardware Setup before using timecode with a take item group.

To play out a take item or group using a timecode source:

1. In the Sequencer, enable timecode by right-clicking inside the column headers of the sequence list and
selecting Columns > Timecode Start.

The Timecode Start column is added to the displayed columns of the sequence list.

2. Select a take item or take item group in the sequence list.
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3. If you select a take item, do the following:

a. In the Take Inspector, select the Scene Control tab.

The Scene Control tab opens.

b. In the Timecode / Automation section, select the Play at Timecode checkbox to enable a
timecode start for the selected take item.

c. In the Play at Timecode field, enter or select a specific timecode start time for the selected take
item.

OR

If you select a take item group, do the following:

a. In the Take Inspector, select the Timecode / Automation tab. 

The Timecode / Automation tab opens.

b. In the Timecode Settings section, select the Enabled checkbox to enable a timecode source for the
selected take item group.

c. From the Timecode Source drop-down, select an available timecode source.

This menu is populated with the internal clock of the XPression Clips system and the timecode sources
that have been configured in the Timecode Sources tab of the Hardware Setup dialog.

For More Information on...

· configuring a timecode source, refer to Adding a Timecode Source.
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Rendering Take Items to Video

Export take items in the Sequencer to video and store in a folder or in the Clip Store. Sequencer clip items
automatically apply the HDR color space that is native to the clip, when that information is available.

To render a take item to video:

1. Select a take item in the Sequencer.

      

2. Right-click the take item and select Export Take Item To > Video.

The Export to Video dialog opens.

3. In the Export to Video dialog, select the checkbox(es) of the Take ID(s) to export. 

4. Select a Destination for the video(s):

· Folder — save the video(s) to a target folder.

· Clip Store — save the video(s) to the Clip Store for use within a clips workflow.

5. If you selected Folder, see Folder for further instructions.

If you selected Clip Store, see Clip Store for further instructions.
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Folder

To save the video file to a folder:

1. From the Naming drop-down, select the name to use for the video.

The options are:

· Base Name — use a fixed base name for the video.

If selected, in the Base Name field, enter a base name for the file or files to be exported. Unicode is
supported for file names.

· Use Item Name — use the take item name(s) for the file(s) to be exported.

2. From the File Numbering drop-down, select the numbering convention for the file(s) to be exported.

The options are:

· Take ID — save the file or files by Take ID number.

· Incremental — save the file or files by incremental numbers.

3. Select the Force Duration checkbox to make the video conform to the number of frames set in the
adjacent field.

4. Select the Render Out Transition checkbox to render the take item using the transition in/out effect in
the Take Inspector - Transition settings for the take item.

5. In the Target Folder field, enter a file path for the target folder where the video will be saved, or select
the Browse button to locate and select a folder.

To select the video format and codec:

1. From the Exporter drop-down, select the video format for the file or files.

The options are:

· MOV (QuickTime encoder required)

· AVI

2. From the Codec drop-down, select an encoder.

3. If the XPression Video Encoder is selected, select Codec Settings.

The XPression Video Codec 2 dialog opens.
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a. In the Compression Settings section, in the Quantization Level field, enter or select the
percentage of the color sampling.

The higher the percentage, the better the color sampling quality. The default of 80 is recommended.

b. From the Mode drop-down, select the encoding mode, either Normal or High Bitrate.

Consider using the High Bitrate option for high resolution clips (like UHD). 

«Files that are encoded in High Bitrate mode require an XPression Video Codec 2 of build 12.0

6094 or later.

c. In the Input Format section, from the Color Space drop-down, select the specific organization of
colors for the compression

The options are:

· Standard RGB (sRGB)

· ITU-R-BT.601 / Rec. 601

· ITU-R BT.709 / Rec. 709

· ITU-R BT.2020 / Rec. 2020

d. From the Gamma Curve drop-down, select the method for optimizing the usage of bits for encoding
the video.

The options are:

· Standard Dynamic Range

· Hybrid Log Gamma (HLG)

· Perceptual Quantization (PQ)

e. Select the Ignore alpha channel for 64 bit input formats checkbox to ignore the alpha channel in
the encoding when using 64-bit input formats.

f. Select OK.

The XPression Video Codec 2 dialog closes.

4. The video settings can be saved to a file by selecting the Save Profile button. 

5. Select Load Profile to open a file browser to locate and select previously saved video settings.

To configure the remaining settings:

1. From the Frame Mode drop-down, select the frame mode for the video(s).

The options are:

· From Project — use the project frame mode.

· Upper Field First — render in upper field first video.

· Lower Field First — render in lower field first video.

· Frame Based — render the video(s) as frame based.

2. From the Color Mode drop-down, select a color mode for the video file.

The options are:

· True Color — use 24-bit color.

· True Color + Alpha — use 24-bit color with alpha.
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3. From the Size drop-down, select a frame size for the video(s).

The options are:

· From Project — use the project dimensions.

· From Project (virtual) — use the viewport resolution. This is only applicable to video formats with
non-square pixels.

· From Scene —  use the scene dimensions.

4. From the Fill Mode drop-down, select the method used to process fill before output.

The options are:

· Shaped — shape the fill signal color information by the luminance information in the key signal.

· Unshaped — output the fill and key signals “as is”.

5. From the Audio drop-down, select an audio setting for the video(s).

The options are:

· None — do not use audio for the video(s).

· Linear PCM, 16bit, 2ch — export with two-channel audio.
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Clip Store

To save the video file to the clip store:

1. From the Naming drop-down, select the name to use for the video.

The options are:

· Base Name — use a fixed base name for the video.

If selected, in the Base Name field, enter a base name for the file or files to be exported. Unicode is
supported for file names.

· Use Item Name — use the sequence item name(s) for the file(s) to be exported.

2. From the File Numbering drop-down, select the numbering convention for the file or files to be
exported.

The options are:

· Take ID — save the file or files by Take ID number.

· Incremental — save the file or files by incremental numbers.

3. From the Project drop-down, select a project in the Clip Store in which to save the video, or enter a new
project name to add to the Clip Store.

4. Select the Looping checkbox to save the video with looping enabled by default.

5. Select the Hold Last Frame checkbox to hold the last frame of the saved video by default.

6. Select the Force Duration checkbox to make the file or files the number of frames specified in the
adjacent field.

7. Select the Render Out Transition checkbox to render the take item using the transition in/out effect in
the Take Inspector - Transition settings for the take item.

To configure the remaining settings:

1. From the Frame Mode drop-down, select the frame mode for the video(s).

The options are:

· From Project — use the project frame mode.

· Upper Field First — render in upper field first video.

· Lower Field First — render in lower field first video.

· Frame Based — render the video(s) as frame based.

2. From the Color Mode drop-down, select a color mode for the video file.

The options are:

· True Color — use 24-bit color.

· True Color + Alpha — use 24-bit color with alpha.
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3. From the Size drop-down, select a frame size for the video(s).

The options are:

· From Project — use the project dimensions.

· From Project (virtual) — use the viewport resolution. This is only applicable to video formats with
non-square pixels.

· From Scene —  use the scene dimensions.

4. From the Fill Mode drop-down, select the method used to process fill before output.

The options are:

· Shaped — shape the fill signal color information by the luminance information in the key signal.

· Unshaped — output the fill and key signals “as is”.

5. From the Audio drop-down, select an audio setting for the video(s).

The options are:

· None — do not use audio for the video(s).

· Linear PCM, 16bit, 2ch — export with two-channel audio.

6. Select Export.

The take item is exported to video. The Progress bar displays the progress of the video(s) being saved.
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Record Client
Use the Record Client dialog to record an input as a video file or as a still image.

The following topics are discussed in this section:

Recording a Video from an Input

Capturing a Still Image from an Input

Using Multiple Records Clients

Using Fill/Key Simultaneously

Sending a Video or Image to the Clip Store
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Recording a Video from an Input

Use the Record Client to record and save input video as a video file. The recordings will be made into the
XPression Video Codec AVI format.

«When using a NewTek™ Network Device Interface (NDI™), XPression Clips video recordings are in the

format and video mode of the input NDI source, not the project mode.

1. In XPression Clips, select the Record Client ( ) toolbar icon.

The Record Client dialog opens.
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2. From the Input drop-down, select the input that contains the source video for the file to be recorded.

The video loads in the preview window.

3. In the Base Name field, enter a name for the video file to be recorded.

4. From the Bit Depth drop-down, select the quality of the signal quantization for the clip:

· 24 bit RGB or

· 32 bit RGBA to include the alpha.

5. From the Audio Channels drop-down, select the number of active audio channels to use with the
recording.

6. In the Destination Folder field, enter a file path for the destination folder where the video will be
stored or select Browse (...) to open a file browser and select a file path.

Any videos or images that have been previously stored in the selected destination folder will appear as
AVI and TGA thumbnails next to the folder tree.

«A default record folder can be configured in the Folders section of the Preferences dialog.
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7. Select Crash Record to start recording the video.

The video begins recording and an .avi video file thumbnail is displayed.

An indicator appears at the top of XPression Clips that lists the active recording.

8. Select Stop Record to stop recording the video.

The .avi video thumbnail is completed and the video is added to the Recent Recordings list.
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To view the video file:

· Select Explore to locate and open the video file for viewing in a media player.

To manage the Record Client dialog:

· Select the Split button to stop the recording and begin recording a new video from the input. 

This is helpful when recording a lengthy video feed, such as a live feed. The filename for the new
recording increments automatically.

· If the Record Client dialog has been closed or minimized, select the Active Recording indicator to open
the Record Client dialog.

· If using the XPression Clips Clip Server option, multiple Record Clients can be active and the Active
Recording indicator will display multiple active recordings. 

In this case, selecting the Active Recording indicator will open the Record Monitor window where the
multiple recordings can be tracked and managed.

For More Information on...

· using multiple Record Clients, refer to Using Multiple Record Clients.

· configuring a default record folder, refer to Folders.
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Capturing a Still Image from an Input

Use the Record Client to capture and save input video as a still image.

To capture a still image from an input:

1. In XPression Clips, select the Record Client ( ) toolbar icon.

The Record Client dialog opens.
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2. From the Input drop-down, select the input that contains the video to be captured as a still image file.

The video loads in the preview window.

3. In the Base Name field, enter a name for the image file to be captured.

4. From the Bit Depth drop-down, select the quality of the signal quantization for the image:

· 24 bit RGB or

· 32 bit RGBA to include the alpha.

5. From the Grab Settings menu, select one of the following interlace options for the image file:

· Interlaced Settings > Frame Based — capture the image file without deinterlacing. This setting
works best for scenes with minimal motion.

· Interlaced Settings > Field (line doubled) — capture the image file with each line doubled. For
example, it will replace field two with a duplicate of field one.

· Interlaced Settings > Field (line interpolated) — capture the image file by interpolating between
odd lines to form even lines.

6. From the Grab Settings menu, select one of the following image file formats for the image:

· TGA (Targa)

· PNG (Portable Network Graphic)

· JPG 
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7. In the Destination Folder field, enter a file path for the folder where the image will be stored or select
Browse (...) to open a file browser and select a file path.

Any videos or images that have been previously stored in the selected destination folder will appear as
AVI and TGA, PNG, or JPG thumbnails next to the folder tree.

«A default record folder can be configured in the Folders section of the Preferences dialog.

8. Select Grab Still to capture a frame from the input video as a still image. 

Still images can be captured without recording the video or while the video is being recorded. Field-
based still images can also be captured.

A .tga, .png, or .jpg image thumbnail is displayed.

In this procedure, the Base Name for the recording and still images has been changed to “crash record
still grabs” for demonstrative purposes.
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To capture still images while recording the input video:

1. While recording the input video, select Grab Still as many times as necessary for the desired still
images.

Multiple .tga, .png, or .jpg image thumbnails are displayed.

2. Select Stop Record to stop recording the video once you have finished grabbing still images.

The .avi video thumbnail(s) is completed and the video is added to the Recent Recordings list.
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To view the video file:

· Select Explore to locate and open the video file for viewing in a media player.

For More Information on...

· configuring a default record folder, refer to Folders.



228 • Record Client XPression Clips User Guide (12.5)

Using Multiple Record Clients

Multiple Record Clients can be opened and used simultaneously to record videos and capture still images.

«There is no limit to how many Record Clients can be open, but it is highly recommended that no more

than 4 recordings occur at a time providing there is nothing being sent to output during recording.
Otherwise, performance issues could occur. Recording to network locations (NAS/SAN) may or may not be
possible depending on the bandwidth available.

To configure multiple Record Clients:

1. In XPression Clips, select the Record Client ( ) icon to open the Record Client dialog. 

2. Select the Record Client ( ) toolbar icon again to open a second Record Client dialog, select it a third
time to open a third, etc.

3. From the Input drop-down, select the input from which you will record a video file.

4. In the Base Name field in each Record Client, enter a name for the video file to be recorded.

5. From the Bit Depth drop-down in each Record Client, select the quality of the signal quantization for
the clip:

· 24 bit RGB or

· 32 bit RGBA to include the alpha.

6. From the Audio Channels drop-down in each Record Client, select the number of active audio
channels to use with the recording.

7. From the Grab Settings drop-down, select the Interlaced Settings and File Format to use for the still
image to be taken (if one will be taken).

8. In the Destination Folder field in each Record Client, enter a file path for the destination folder where
the video will be stored or select Browse (...) to locate and select a folder.

When selecting a Destination Folder to store videos and images, if the selected folder already has
stored videos or images, these previously created files will appear next to the folder tree as AVI and
TGA thumbnails. 

If the same folder has been selected across multiple Record Clients, these files will appear in the area
next to the folder tree in all the open Record Clients that are using that file path, as well as any
currently recording video using that file path.

All recent recordings, regardless of the selected file path, will appear in each of the open Record Clients
in the Recent Recordings list.

When recording a video using the Record Client, an indicator appears at the top of the UI that lists the
number of active recordings.
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To record a video:

1. Select Crash Record to begin recording from the input. 

2. Select Stop Record to stop recording.

If a selected recording has been stopped in its respective Record Client, the Active status will be listed
as Stopped.

3. Select Grab Still to save an image to go with the recording.

To view all active recordings in all open Record Clients:

· Select the Active Recordings indicator to open the Record Monitor window.

To open an active Record Client:

· Select an active recording and select Open Record Client.

To delete an active recording:

· Select an active recording and select Delete to discard the selected recording.

For More Information on...

· recording an input video, refer to Recording a Video from an Input.

· capturing an input still image, refer to Capturing a Still Image from an Input.



230 • Record Client XPression Clips User Guide (12.5)

Using Fill/Key Simultaneously

«This option is only available if using the Matrox XMIO board with XPression Clips.

Using the Record Client, a video plus alpha can be recorded simultaneously by configuring the option in the
Input tab in the Matrox XMIO - Framebuffer Setup dialog.

1. In XPression Clips, select Edit > Hardware Setup.

2. In the Inputs / Outputs tab, select the Matrox Video X.mio2 FrameBuffer board and then select
Configure.

The Matrox XMIO - Framebuffer dialog opens.

The Matrox XMIO - Framebuffer dialog opens.

3. Select the Input 2 tab.
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4. In the Options section, select the Use Input 2 as Key Channel for Input 1 checkbox to use key/fill
simultaneously.

For More Information on...

· configuring the Matrox XMIO board, refer to Configuring a Matrox Video X.mio2 FrameBuffer.
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Sending a Video or Image to the Clip Store

Once a recording has been completed it can be sent to the Clip Store database to be used within the Clips
workflow. Proxies of video clips are automatically generated when sent to the Clip Store.

1. In XPression Clips, select the Record Client ( ) toolbar icon.

Alternatively, select Tools > Record Client.

The Record Client dialog opens.
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2. Create a video in the Record Client.

OR

In the folder tree, select the video or image you want to send to the Clip Store.

3. Right-click on the video or image thumbnail and select Send to Clip Store from the shortcut menu. 

Multiple videos and images can be selected by using Shift + click or holding Ctrl and selecting individual
videos and images.

«Only XPression codec clips should be sent to the Clip Store.
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The Send to Clip Store dialog opens.

4. In the Metadata section, configure the following items:

· Name — enter a new name for the video or image in Clip Store, if necessary.

· Recall ID — enter an identifier to recall the video or image from an external device.

· Project — from the drop-down, select any existing projects from Clip Store or enter a new project
name for the video or image. New projects are automatically added to the Clip Store.

· Looping — select to infinitely replay the video each time it reaches the end.

· Hold Last Frame — select to freeze the video on the last frame after playing.

· Premultiplied (Shaped) — select to multiply/shape the fill signal color information by the luminance
information in the key signal.
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5. Select Send to ClipStore.

The video or image is transferred to the Clip Store. Once the transfer has successfully completed, the
Status is listed as Clip and proxy successfully sent to Clip Store, the Progress bar is at 100%, and
Destination details are listed.

6. Select Close to exit the dialog.

For More Information on...

· creating a video file in the Record Client, refer to Recording a Video from an Input.

· creating an image file in the Record Client, refer to Capturing a Still Image from an Input.
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PBus Interface
The following topics are discussed in this section:

PBus Overview

PBus Triggers

PBus LEARN Commands

PBus Mapping

Using PBus from a Switcher to Recall Items

Using PBus for Clips
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PBus Overview

PBus (Peripheral Bus) is an industry standard protocol designed to allow production switchers to
communicate with external devices. Most large production switchers have some capability of sending PBus
commands to a device.

XPression Clips supports PBus over standard RS232 or TCP/UDP sockets.

The chassis of some turnkey XPression Clips systems might not include a standard RS232 port. However, it
is possible to use an RS232-USB adapter.

If the production switcher has an RS422 serial port, then you will require an RS232 to RS422 adapter. This
adapter will require its own power supply. Generally, the adapters that are port-powered will not function for
these purposes.

«On an XPression Clips Bluebox system, a limited subset of PBus functionality is available. PBus commands

can be used to trigger take items that have been pre-built in an XPression Clips sequence using either
XPression Clips Designer or Studio. It is not possible to customize the PBus registers actions using Bluebox.
Each register number corresponds to a specific take item number and can not be changed. It is not possible
to load the PBM or PBMS PBus mapping files on Bluebox.

For More Information on...

· configuring the PBus interface and PBus recalls, refer to Configuring the PBus Interface and PBus Recalls.



238 • PBus Interface XPression Clips User Guide (12.5)

PBus Triggers

XPression Clips supports many PBus Trigger commands.

PBus Trigger Command Description

Trigger 0 – Play Item This trigger can be overridden in the PBus mapping.

Trigger 0 is normally used to play a take item to air.
However, this can be overridden to perform other
actions on a per-register basis. These actions can be
configured in the PBus mapping menu.

Trigger 1 – Take Sequence Item Off-Air Trigger 1 is used to take an item off air (assuming it
was already on air). The item taken off air will be the
take item that was previously recalled using a PBus
recall command.

Trigger 2 – Execute GPI Trigger 2 is used to emulate a standard GPI input. In
the XPression Clips Keyboard/GPI Mapping, various
actions can be configured to be executed on a GPI
input being triggered. It is possible to trigger up to 99
different GPIs through PBus. The GPI number that will
be triggered is the number that was previously recalled
using a PBus recall command.

Trigger 3 – Clear Framebuffer Trigger 3 will clear the framebuffer assigned to the
device in the PBus channel configuration. If the channel
is set to <default>, this trigger will clear Channel 1.

Trigger 4 – Clear Framebuffer Channel 2 Trigger 4 will clear the framebuffer assigned to the
device in the PBus channel configuration. If the channel
is set to <default>, this trigger will clear Channel 2.

Trigger 5 – Read Current Sequence Item to Air Trigger 5 will take the currently selected sequence item
from the sequencer to air. It ignores the PBus recall
command and uses whichever item currently has focus
in the XPression Clips sequencer.

Trigger 6 – Resume Channel Trigger 6 will resume all paused graphics currently on
the framebuffer assigned to the device in the PBus
Channel Configuration. If the framebuffer is set to
<default>, this will resume Channel 1.

Trigger 7 – Resume Channel Trigger 7 will resume all paused graphics currently on
the framebuffer assigned to the device in the PBus
Channel Configuration. If the framebuffer is set to
<default>, this will resume Channel 2.

Trigger 8 – Resume Take Item Trigger 8 will resume a single paused take item. The
take item will be the item previously recalled by a PBus
recall command.

Trigger 10 – Bank 0 Trigger 10 will change the last recall command into an
ID in the 0-99 range (refer to the Bank 1 command
below for more details).
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PBus Trigger Command Description

Trigger 11 – Bank 1 Trigger 11 is used to allow switchers that can only send
PBus recall commands up to 99 to be able to recall
take items with values of between 100 and 199.

This “bank 1” command will add 100 to the last
recalled item using a PBus recall command. For
example; to recall take ID 135 and put it on air, a
switcher could send:

· Recall 035

· Trigger 11 (changes the 035 into 135)

· Trigger 0

It is not necessary to switch back to bank 0 after
sending a bank 1 command. XPression Clips will
automatically revert to bank 0 for the next PBus recall
command.

Trigger 12 – Bank 2 Changes the last PBus recall command into an ID in the
200-299 range.

Trigger 13 – Bank 3 Changes the last PBus recall command into an ID in the
300-399 range.

Trigger 14 – Bank 4 Changes the last PBus recall command into an ID in the
400-499 range.

Trigger 15 – Bank 5 Changes the last PBus recall command into an ID in the
500-599 range.

For More Information on...

· configuring the PBus interface and PBus recalls, refer to Configuring the PBus Interface and PBus Recalls.
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PBus LEARN Commands

When a PBus LEARN command is received from a remote device, XPression Clips will look to the configured
server channel for the PBus device, and if there is a clip currently cued on that server channel it will assign
that clip into the PBus register via the recall ID, if assigned.

There is an option Ignore LEARN command in the PBus Setup dialog in Hardware Setup. This option is
useful if you are manually assigning clips to PBus registers and you do not want to change/overwrite them
when storing memories on the production switcher. Most production switchers automatically send the PBus
LEARN command when storing the memory.

For More Information on...

· the PBus LEARN command, refer to the appropriate switcher documentation.
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PBus Mapping

Enter topic text here.Use PBus mapping to assign clips, functions, scenes, scripts, and other actions and
functions to device registers, and then save and load the maps.

The following procedures are covered in this section:

Configuring PBus Mapping

Assigning an Action to a PBus Register

Remapping a PBus Register

Loading and Saving Maps

For More Information on...

· configuring the PBus interface and PBus recalls, refer to Configuring the PBus Interface and PBus Recalls.

Configuring PBus Mapping

Use the PBus Device Configuration dialog to configure the Device IDs and server channels.

To configure PBus Mapping:

1. In XPression Clips, select Display > PBus Mapping.

The PBus Mapping window opens.
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2. Select the Setup Device Configuration ( ) icon.

The PBus Device Configuration dialog box opens.

3. Select Add to add a Device ID.

A device ID is added to the PBus Device Configuration list. At least one Device ID must be added.
The Device ID is the ID number that will be sent in PBus messages transmitted from the production
switcher.

4. Click inside the Device ID column of the ID and enter or select a different ID number from the default
number, if necessary.

PBus Device IDs must be between 0 and 23.

5. Click inside the Name column of the ID and enter a name to refer to the Device ID. For example,
Device D.

6. Click inside the Server Channel column of the ID and from the drop-down, select a specific output
framebuffer or use the <default> framebuffer.

If the framebuffer is set to anything other than <default> when a PBus recall command is received for a
specific Device ID, the item will be played on the selected framebuffer. If <default> is selected, the
item will be played on the framebuffer for which the original take item was configured. When a clip from
the Clip Store is assigned to a register and <default> was selected for the Server Channel, the first
device configured will use Server Channel 1, the next will use Server Channel 2, etc.
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7. Repeat steps 3 to 6 to add additional PBus devices as necessary.

8. When all PBus devices have been added and configured, select OK.

The Device IDs are added as tabs at the bottom of the PBus Mapping window under the assigned
device names. If there are no tabs added, then a Device ID was not added to the PBus Device
Configuration list.

Assigning an Action to a PBus Register

Each device has a list of 4095 registers which can be recalled through PBus.

«Some switchers can only support the first 99 registers.

Each PBus register can be assigned an action that will be executed after the register is recalled and Trigger
0 is received. The default action for each register is to play the corresponding Take Item with the same
number as the PBus register.

To assign an action to a PBus register:

1. In the PBus Mapping window, select an action from the actions list to the right of the devices.
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2. Drag and drop the action onto a register.

The action is added to the register.
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Adding a Global Macro to a Take Item

XPression supports the use of global macros, allowing user to dynamically replace clips associated with a
register, based on macro values like team names or network IDs.

To add a global macro to a Take Item:

1. In the XPression Clips Sequence editor, select Display > PBus Mapping.

The PBus Mapping window opens.

2. Select the take item for which you want to add a global macro.

3. Left-click in the Recall ID column for that take item and enter the macro.
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Remapping a PBus Register

To remap a PBus register to play a different take item, the take item can be dragged and dropped from the
Sequencer or the Clip Browser onto the register in the PBus Mapping window or you can enter or select
a different take ID using the Take ID field in the Recall Take Item section of the PBus Mapping window.

Duplicate Recall Ids are supported. If two clips with the same Recall ID are added to the register, in the
Project column, you can enter which project the clip comes from. Global macros are supported in the
Project column.

To remap a PBus register using drag and drop from the Sequencer:

1. In the Sequencer, select a take item from the Take ID list.

2. Drag and drop the take item onto a register in the PBus Mapping window.
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The take item is added to the register.

To remap a PBus register using drag and drop from the Clip Browser:

1. In the Clip Browser, select a clip from the list.
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2. Drag and drop the clip onto a register in the PBus Mapping window.

The clip is added to the register.
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To remap a register using the Take ID field:

1. In the PBus Mapping window, select a register number from the devices to the left of the actions list.

2. In the Recall Take Item section, in the Take ID field, enter or select a take item to add to the selected
register.
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The take item is added to the selected PBus register.
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Loading and Saving Maps

PBus maps are not loaded and saved with XPression Clips projects. They are loaded and saved to disk as
.pbm or .pbms files using the PBus Mapping window. The .pbm file extension is used for a single PBus map
and the .pbms file extension is used for multiple PBus maps.

Use the following PBus Mapping window toolbar icons to load and save PBus maps:

Load — open a file browser to select a PBus map or multiple PBus maps to load.

Save All — save multiple PBus maps to disk.

Save — save a single PBus map to disk.
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Using PBus from a Switcher to Recall Items

«Consult the switcher documentation for a complete description of how to use PBus with your particular

manufacturer/model. This section is only intended to provide some background information and tips.

Normally switchers will send a PBus recall command when an EMEM is recalled. The following procedure is
an example using take item 0005.

For More Information on...

· configuring the PBus interface and PBus recalls, refer to Configuring the PBus Interface and PBus Recalls .

To recall and play a specific take item from XPression:

1. In XPression, in the Sequencer, create a take item and give it an ID of 0005.

2. Create an EMEM/Memory on the switcher and store it as EMEM 5.

3. Within EMEM 5, ensure that you have enabled the sending of PBus commands.

4. Within the timeline for EMEM 5, issue a PBus Trigger 0 command.

5. When EMEM 5 is recalled, it will send a PBus recall 5 command to XPression. 

This command will not yet do anything (unless the configuration options discussed in the Configuring the
PBus Interface and PBus Recalls  section are enabled).

When the timeline is run, the switcher will send a PBus Trigger 0 command. At this time, XPression will
put take item #5 on the output channel/layer previously assigned to that item in the sequencer.

«There may be several frames of delay between issuing the Trigger 0 command and when the video

for the item appears on the SDI output of XPression. This is normal and should be accounted for inside of
the timeline on the switcher. For example, you will need a delay between the issuing of Trigger 0 and
when the keyer containing the XPression is keyed onto the PGM output.

6. To recall different take items, copy the timeline on the switcher into different switcher registers.

For More Information on...

· PBus triggers, refer to PBus Triggers.
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Using PBus for Clips

Firstly, the PBus configuration must be set to assign a PBus device ID to a specific server channel. This
controls the server channel onto which PBus commands to a device will load the clip. Valid device IDs are
from 0 to 23.

By default, every PBus register (0 to 4095) will cue/play the corresponding take item with that ID number.
However, clips from the Clip Browser can be assigned to a PBus register simply by dragging them from the
Clip Browser onto a PBus register. Alternatively, various actions (same ones accessible in the keyboard
mapping menu) can be assigned to a PBus register by dragging them from the action list on the right to a
PBus register. This is useful for assigning scripts or actions like Take Next/Clear Channel, etc. to a PBus
register. 

Right-click on a register with a clip and select Find Clip in Clip Browser to find a clip or select a different
clip in the Clip Browser.

A PBus register map can be saved to disk to a file using the .PBM extension, or maps for all devices can be
saved to a .PBMS file. Maps can be loaded from these PBM files or from a specific format of XML file. When
using the XML file import, it will assign clips to PBus registers using their recall ID from the clip database.

Using PBus for Clips with Recall IDs

The PBus map contains a column named Recall ID.

If a clip in the Clip Store exists with that recall ID, it will be assigned to that PBus register. A clip’s recall ID
can also be entered into the column to assign it to the respective register. The PBus register will always
recall the clip with that specific recall ID, so if a new clip is ingested with a matching recall ID, the PBus
register will recall the new clip instead. If the clip is manually edited and the recall ID is changed or
removed, the PBus register will no longer recall that clip.

A similar behavior exists when dragging a clip with a recall ID into the PBus register; meaning that the PBus
register is bound to a specific recall ID and not to a specific clip. Holding Ctrl-Shift and dragging a clip onto
a PBus register will link the clip with the PBus register, and it will not be replaced even if a clip with a
duplicate recall ID is ingested.
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Output
The output of an XPression Clips project can be sent to preview in a virtual output.

The following topic is discussed in this section:

Previewing Output in a Virtual Output

Rendering Output to an AVI File
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Previewing Output in a Virtual Output

To preview output in a Virtual Output:

1. In Edit > Hardware Setup, configure an XPression Virtual Output.

See Configuring an XPression Virtual Output  for instructions.

2. In the Clip Browser, select and drag the clip to output into the Sequencer.

3. Double-click the clip to take it online.

Alternatively, right-click the clip and select Take Online from the shortcut menu.

4. In the Output Monitors window, note the framebuffer number of the Virtual Output output monitor.

5. Use the drop-down in the Output column of the Sequencer to select the framebuffer number of the
Virtual Output for clip to output.

6. Double-click the clip in the Sequencer to take it online.

The XPression Virtual Output window opens to display the output of the selected clip.

7. Right-click the output in the XPression Virtual Output window and select Full Screen to use full
screen display.
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Rendering Output to an AVI File

It is necessary to render the output of a take item or take item group as an .AVI file in order to play it in
XPression.

To add a scene or scene group to the Sequencer:

1. Select the Sequence tab.

2. Select a clip or clips from the Clip Browser and drag it into the Sequencer.

3. In the Output Monitors window, note the framebuffer number of the AVI Output.

4. In the Output column of the Sequencer, click in the row for the scene or scene group to output to AVI
and from the drop-down, select the Framebuffer number shown in the Output Monitors window. 

5. Continue with the instructions for exporting the output.
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To save the AVI file:

1. Right-click the selected take item or take item group in the Sequencer and select Export Take Item
To > Video.

The Export To Video dialog opens.

2. In the Export to Video dialog, select the checkbox of the Take ID to export. 

Select the respective checkboxes of Take IDs if exporting multiple videos.

3. Select a Destination for the video(s):

· Folder — save the video(s) to a target folder.

· Clip Store — save the video(s) to the Clip Store for use within a clips workflow.

4. Select the Force Duration checkbox to make the video conform to the number of frames set in the
adjacent field.

5. Select the Render Out Transition checkbox to render the take item using the transition in/out effect in
the Take Inspector - Transition settings for the take item.

6. In the Target Folder field, enter the path to the folder in which to save the AVI file or select Browse to
locate and select the folder.
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To select the video format and codec:

1. From the Exporter drop-down, select AVI.

2. From the Codec drop-down, select an encoder.

3. If the XPression Video Encoder is selected, select Codec Settings.

The XPression Video Codec 2 dialog opens.

a. In the Compression Settings section, in the Quantization Level field, enter or select the
percentage of the color sampling.

The higher the percentage, the better the color sampling quality. The default of 80 is recommended.

b. In the Input Format section, from the Color Space drop-down, select the specific organization of
colors for the compression

The options are:

· Standard RGB (sRGB)

· ITU-R-BT.601 / Rec. 601

· ITU-R BT.709 / Rec. 709

· ITU-R BT.2020 / Rec. 2020

c. From the Gamma Curve drop-down, select the method for optimizing the usage of bits for encoding
the video.

The options are:

Standard Dynamic Range

Hybrid Log Gamma (HLG)

Perceptual Quantization (PQ)

d. Select the Ignore alpha channel for 64 bit input formats checkbox to ignore the alpha channel in
the encoding when using 64-bit input formats.

e. Select OK.

The XPression Video Codec 2 dialog closes.

4. The video settings can be saved to a file by selecting the Save Profile button. 

5. Select Load Profile to open a file browser to locate and select previously saved video settings.
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To configure the remaining settings:

1. From the Frame Mode drop-down, select the mode to use.

The options are:

· From Project — use the project frame mode.

· Upper Field First — render in upper field first video.

· Lower Field First — render in lower field first video.

· Frame Based — render the video as frame based. 

2. From the Color Mode drop-down, select a color mode for the video file.

The options are:

True Color — use 24-bit color.

True Color + Alpha — use 24-bit color with alpha.

3. From the Size drop-down, select a frame size for the video(s).

The options are:

From Project — use the project dimensions.

From Project (virtual) — use the viewport resolution. This is only applicable to video formats with non-
square pixels.

From Scene —  use the scene dimensions.

4. From the Fill Mode drop-down, select the method used to process fill before output.

The options are:

Shaped — shape the fill signal color information by the luminance information in the key signal.

Unshaped — output the fill and key signals “as is”.

5. From the Audio drop-down, select an audio setting for the video(s).

The options are:

· None — do not use audio for the video(s).

· Linear PCM, 16bit, 2ch — export with two-channel audio.

6. Select Export.

The take item is exported to an AVI file. The Progress bar displays the progress of the video(s) being
saved.
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Keyboard and GPI Mapping
Enter topic text here.Keyboard and GPI mapping enables many of the XPression functions to be assigned to
keyboard shortcuts or GPI input triggers. Many of XPression’s existing default keyboard shortcuts can also
be customized. 

The following topics are discussed in this section:

Creating a Custom Keyboard Map

Assigning a Project Shortcut

Assigning a Global Shortcut

Assigning a Local Shortcut

Creating a Custom GPI Map

Using the Quick Menu
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Creating a Custom Keyboard Map

You can use the default keyboard map as a basis for creating a custom keyboard map, specific to your
needs. 

«The default keyboard map cannot be edited.

To create a custom keyboard map:

1. In XPression, select Edit > Keyboard / GPI Mapping. 

The Keyboard / GPI Mapping dialog opens. 

2. Select the Save Keyboard Mapping  button to create a new custom keyboard mapping. 

The Save Keyboard Mapping dialog opens. 

3. In the Save Keyboard Mapping dialog, enter a name for the new custom keyboard mapping. 

4. Select OK. 

The added custom keyboard mapping appears in the Current Keyboard Map list and is saved as a .kbd
file.
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For More Information on...

· assigning a Global Shortcut, refer to Assigning a Global Shortcut. 

· assigning a Local Shortcut, refer to Assigning a Local Shortcut. 
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Assigning a Project Shortcut

Project shortcuts represent keyboard hotkeys that apply to a specific XPression project. 

To assign a project shortcut:

1. In XPression, select Edit > Keyboard / GPI Mapping. 

The Keyboard / GPI Mapping dialog opens. 

2. From the Current Keyboard Map drop-down, select a a keyboard map  or create a custom keyboard
map. 

3. Drag an item from the Global Functions list into the Project Shortcuts table as necessary.

4. In the Project Shortcuts table, right-click on an item in the shortcuts tree and select Assign Shortcut
to assign a custom keyboard control to the selected item. 

5. In the Shortcut Details section, do the following: 

· In the Name field, edit the name of the selected item if necessary. 

· In the Shortcut field, enter a keyboard shortcut to assign to the selected item by entering the
command on the keyboard. 

The assigned keyboard shortcut appears in the Shortcut field and in the Project Shortcuts table, in the
row for the selected item in the Direct Access Shortcut column. 

If the assigned keyboard shortcut is already in use by another function, a warning icon  will appear
next to the command in the Direct Access Shortcut column.
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6. Place the cursor over the warning icon to view where the conflict occurs and select another shortcut for
one of the items.

7. Select OK. 

For More Information on...

· creating a custom keyboard map, refer to Creating a Custom Keyboard Map. 
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Assigning a Global Shortcut

Global shortcuts represent functions that can be assigned to keyboard hotkeys that are active at any time
while XPression is running. 

1. In XPression, select Edit > Keyboard / GPI Mapping. 

The Keyboard / GPI Mapping dialog opens. 

2. From the Current Keyboard Map drop-down, select a keyboard map or create a custom keyboard
map. 

«The default keyboard map cannot be edited.

3. In the Available Global Functions list, drag and drop the Group function onto the Quick Menu item in
the Global Shortcuts tree.

Alternatively, select the Quick Menu item in the Global Shortcuts tree and then select the Add Group

 button in the toolbar. 

4. From the Available Global Functions list, select a function and drag and drop it into the new group you
created in the Global Shortcuts tree to add the function. 

You can also enter a function in the Filter field to find a specific function.
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5. In the Global Shortcuts table, right-click on an item in the shortcuts tree and select Assign Shortcut
to assign a custom keyboard control to the selected item.

6. In the Shortcut Details section, do the following:

· In the Name field, edit the name of the selected item if necessary. 

· In the Shortcut field, select the Set button and then enter a keyboard shortcut to assign to the
selected item. 

The assigned keyboard shortcut appears in the Shortcut field and in the Global Shortcuts table, in
the row for the selected item in the Direct Access Shortcut column. 

If the assigned keyboard shortcut is already in use by another item, a Warning icon  will appear
next to the command in the Direct Access Shortcut column. Place the cursor over the warning icon
to view where the conflict occurs and select another shortcut for one of the items.

· Select the Include In Quick Menu checkbox to include the keyboard shortcut in a Quick Menu.

Quick Menus are shortcut menus that appear when a Quick Key for a Global Shortcut is entered.
The keyboard shortcuts available for the selected Global Shortcut are listed in the Quick Menu that
appears. This feature only applies to Global Shortcut branches that contain child nodes. 

· In the Quick Key field, enter a letter or number as the Quick Menu command. 

The Function Options section will be populated with the options for the selected function.
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7. In the Function Options section, configure the options for a selected function:

Clear Layer Options Send RossTalk Message Options

Clear Single Channel Options Set Framebuffer Options

Clip Browser Options Set GPI Output Options

Color Options Set Layer Options

Cue Item Options Set Transition Options

Debug Options Take Offline Options

Display Menu Options Take Options

Group Options Tools Menu Options

Project Menu Options Windows Menu Options

Project Server Options

Clear Layer Options

Framebuffer From the drop-down, select a framebuffer for clearing the layer.

Layer In the Layer field, enter or select the number of the layer to clear.

Clear Single Channel Options

Framebuffer From the drop-down, select the framebuffer for clearing the layer.

Clip Browser Options

Run all children actions when
group triggered 

Run all of the keyboard shortcuts of the children when the Quick
Key assigned to a Clip Browser group is triggered.

Color Options

Run all children actions when
group triggered 

Run all of the keyboard shortcuts of the children when the Quick
Key assigned to a Color group is triggered.

Cue Item Options

Current Sequence Item Apply the shortcut to the item currently in focus in the sequencer.

Take ID Enter or select a Take ID number to which to apply the shortcut.

Move Sequencer Focus to Item Set the Sequencer focus to the Take ID.

Framebuffer Select a framebuffer for the item.

Debug Options

Run all children actions when
group triggered 

Run all of the keyboard shortcuts of the children when the Quick
Key assigned to a Debug group is triggered.

Display Menu Options

Run all children actions when
group triggered

Run all of the keyboard shortcuts of the children when the Quick
Key assigned to a Display Menu group is triggered.
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 Group Options

Run all children actions when
group triggered

Run all of the keyboard shortcuts of the children when the Quick
Key assigned to a group is triggered.

Project Menu Options

Run all children actions when
group triggered 

Run all of the keyboard shortcuts of the children when the Quick
Key assigned to a Project Menu group is triggered.

Project Server Options

Run all children actions when
group triggered

Run all of the keyboard shortcuts of the children when the Quick
Key assigned to a Project Server group is triggered.

 Send RossTalk Message Options

GPI Board From the GPI Board drop-down, select a GPI board for sending
RossTalk messages.

RossTalk Message From the RossTalk Msg drop-down, select a message to send
using the assigned shortcut.

The options are:

CLFB [channel]:[layer] — clear a single layer on the channel.

CLRA — clear all framebuffers.

CUE [takeid]:[channel]:[layer] — cue a Take Item on a
specified layer of a channel.

DOWN — move the current selection in the sequencer to the item
below it.

FOCUS [takeid] — set sequencer focus to a specific Take Item.

GPI [gpi num] — used to trigger a simulated GPI input.
RossTalk/Smart GPI supports up to 64 simulated inputs.v

LAYEROFF [channel]:[layer] — clear a single layer on the
framebuffer specified by the channel. If the layer is not specified,
every layer on the channel will be cleared.

NEXT — read the current selection in the sequencer to air and
advance the current selection to the next item.

READ — read the current selection in the sequencer to air.

RESUME [channel]:[layer] — resume a single layer on the
framebuffer specified by the channel. If the layer is not specified,
every layer on the channel will resume.

EQI [takeid]:[layer] — loads a template to air on the specified
layer and the template-defined output channel.

SEQO [takeid] — takes the template off air.

SWAP [channel] — switches from the current channel to the one
specified in the message.

TAKE [takeid]:[channel]:[layer] — takes a template to air on
the specific framebuffer and layer without moving the sequencer
focus to that item.
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TEMPLATEDATA [takeid]:[object name]:[property]:[value] —
set the value of a specified object in a specified take item.

UP — move the current selection in the sequencer to the item
above it.

UPNEXT — set the preview in the sequencer without moving the
focus bar.

Set Framebuffer Options

Framebuffer From the Framebuffer drop-down, select a framebuffer or select
<none>.

Set GPI Output Options

GPI Board From the drop-down, select a GPI board for sending the GPI
command.

GPI# Enter or select a GPI pin number.

State From the State drop-down, select the state of the signal.

Low (Inactive) — Use low voltage for the signal.

Low (Active) — Use high voltage for the signal.

Set Layer Options

Layer Enter or select the layer number.

Set Transition Options

Current Sequence Item Use the transition options for the currently selected take item in the
sequencer.

Take ID Use the transition options for the specified Take ID.

Server Channel From the drop-down, select the channel on which the transition will
occur.

Transition In/Out Select the in and out transitions for a take item. 

The available options are:

Cut — Use and instantaneous transition from the selected take
item to the next take item.

Dissolve — Use a gradual transition where the selected take item
dissolves into the next take item.

Push — Use a sliding transition where the next take item pushes
out the selected take item.

Distort — Use a transition where the selected take item is warped
out.

Duration Enter or select the duration of the transition.
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Take Offline Options

Current Sequence Item Apply the shortcut to the item currently in focus in the sequencer.

Take ID Enter or select a Take ID number to which to apply the shortcut.

Entire Framebuffer Take all layers off of the framebuffer selected from the drop-down.

Take Options 

Current Sequence Item Apply the shortcut to the item currently in focus in the sequencer.

Take ID Enter or select a Take ID number to which to apply the shortcut.

Move Sequencer Focus to Item Set the Sequencer focus to the Take ID.

Framebuffer Select a framebuffer for the item.

Advance Sequence After Take Advance to the next Take Item in the sequence after the current or
selected Take Item has finished playing.

Tools Menu Options

Run all children actions when
group triggered 

Run all of the keyboard shortcuts of the children when the Quick
Key assigned to a Tool Menu group is triggered.

Windows Menu Options

Run all children actions when
group triggered 

Run all of the keyboard shortcuts of the children when the Quick
Key assigned to a Windows Menu group is triggered.

8.  When you have finished configuring the function options, select OK.

For More Information on...

· creating a custom keyboard map, refer to Creating a Custom Keyboard Map. 

· using a Quick Menu, refer to Using the Quick Menu.
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Assigning a Local Shortcut

Local shortcuts represent keyboard hotkeys that apply to one particular component of XPression, such as
the Sequencer, and are only active when the particular component of XPression has keyboard/mouse
focus. 

To assign a local shortcut:

1. In XPression, select Edit > Keyboard / GPI Mapping. 

The Keyboard / GPI Mapping dialog opens. 

2. From the Current Keyboard Map drop-down, select a a keyboard map or create a custom keyboard
map. 

3. In the Local Shortcuts table, right-click on an item in the shortcuts tree and select Assign Shortcut to
assign a custom keyboard control to the selected item. 

4. In the Shortcut Details section, do the following: 

· In the Name field, edit the name of the selected item if necessary. 

· In the Shortcut field, enter a keyboard shortcut to assign to the selected item. 

The assigned keyboard shortcut appears in the Shortcut field and in the Local Shortcuts table, in the
row for the selected item in the Direct Access Shortcut column. 

If the assigned keyboard shortcut is already in use by another item, a Warning icon  will appear
next to the command in the Direct Access Shortcut column.
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5. Place the cursor over the warning icon to view where the conflict occurs and select another shortcut for
one of the items.

6. Select OK. 

For More Information on...

· creating a custom keyboard map, refer to Creating a Custom Keyboard Map. 
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Creating a Custom GPI Map

You can create a custom GPI map to use GPI triggers to execute events.

To create a custom GPI map:

1. In Hardware Setup, configure a GPI board for XPression. 

2. Then select Edit > Keyboard / GPI Mapping. 

The Keyboard / GPI Mapping dialog opens. 

3. Create a custom keyboard mapping that includes global shortcuts. 
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4. In the Global Shortcuts tree, right-click on a global shortcut and select Edit GPI Assignment. 

The same GPI trigger can be assigned to multiple global functions to execute them in order. 

5. In the GPI column of the Global Shortcuts table, perform the following to the selected global shortcut:

· Select a GPI board from the drop-down. 

· In the GPI field, enter or select a GPI input to assign to the selected global shortcut. 

If the assigned keyboard shortcut is already in use by another item, a Warning icon  will appear
next to the command in the Direct Access Shortcut column.

Place the cursor over the warning icon to view where the conflict occurs and select another shortcut for
one of the items.

6. Select OK. 

For More Information on...

· adding an Adrienne TC/GPIO card, refer to Configuring a 25-Pin GPIO Port. 

· adding a Serial GPI board, refer to Configuring RS232 CTS/DSR GPI for Contact Closures. 

· adding a Smart GPI/RossTalk board, refer to Configuring Smart GPI / RossTalk. 

· creating a custom keyboard, refer to Creating a Custom Keyboard Map.
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Using the Quick Menu

When you have created shortcuts and included them in the Quick Menu, they can be selected from the
associated Global Shortcuts branch in User Guide.

To use the Quick Menu:

1. Create a custom keyboard mapping that includes Global Shortcuts. 

2. In XPression, enter the keyboard shortcut for a Global Shortcut branch. 

The Quick Menu for the Global Shortcut branch opens. 

3. In the Quick Menu perform one of the following:

· Press a Quick Key on the keyboard to select an item from the Quick Menu. 

OR

· Use the keyboard arrows to select an item and press Enter. 

The selected Quick Menu item action is triggered. 

4. Press Esc at any time to close the Quick Menu.

For More Information on...

· creating a custom keyboard, refer to Creating a Custom Keyboard Map.

· assigning a Global Shortcut, refer to Assigning a Global Shortcut. 
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Project Manager
The Project Manager window is used to manage XPression Clips projects.

The following topics are discussed in this section:

Opening Multiple Projects in the Project Manager

Activating a Project from a Project Group

Removing a Project from a Project Group
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Opening Multiple Projects in the Project Manager

To open multiple projects in the project manager:

1. In the Project Manager, right-click on the Project Group  node.

The Project Group shortcut menu opens.

2. Select one of the following options:

· Add New Project — select to open the New Project dialog and create a new project to add to the
Project Group.

· Add Existing Project — select to open the browser and select an existing project to open in the
Project Group.

The new or existing project displays as a project node in the Project Group and opens in XPression Clips. 

3. Repeat the above steps to add more projects.

For More Information on...

· creating a new project in XPression, refer to the procedure Creating a Project.
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Activating a Project from a Project Group

To activate a project from a project group:

1. Open multiple projects in XPression Clips.

The projects appear in the Project Manager.

2. In the Project Manager, right-click on the Project  node of the project to be activated.

The project shortcut menu opens.

3. Select Activate from the shortcut menu.

The selected project is activated in the XPression Clips Editor and Sequencer.

For More Information on...

· opening multiple projects in XPression Clips, refer to Opening Multiple Projects in the Project Manager.

· creating a new project in XPression Clips, refer to Creating a Project.
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Removing a Project from a Project Group

You can remove unwanted projects from a project group.

To remove a project from a project group:

1. In the Project Manager, right-click on the Project  node of the project to be removed from the
project group.

The project shortcut menu opens.

2. Select Remove Project from the shortcut menu.

The selected project is removed from the Project Group.

For More Information on...

· opening multiple projects in XPression, refer to the procedure Opening Multiple Projects in the Project
Manager.
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Appendix A: Keyboard Shortcuts
Use the keyboard shortcuts in this section to perform various functions in XPression Clips.

Menu Shortcuts

Sequencer Shortcuts

Clip Browser Shortcuts

Server Channel Shortcuts
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Menu Shortcuts

Menu Keyboard Shortcut Function

File CTRL + ALT + N New project

CTRL + O Open project

F9 Revert project

CTRL + S Save project

CTRL + ALT + S Save project as...

CTRL + SHIFT + ALT + S Increment and save project

Project CTRL + ALT + E Display project path in Windows Explorer

Help F1 Display Online Help
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Sequencer Shortcuts

Keyboard Shortcut Function

UP ARROW Select previous take item

DOWN ARROW Select next take item

CTRL + UP ARROW Move selected take item up the list

CTRL + DOWN ARROW Move selected take item down the list

HOME Select first take item

END Select last take item

CTRL + Fn KEY Remove selected take item from the framebuffer represented by
the Fn key

NUMPAD * Scroll the Sequencer list to the currently focused item and, if
applicable, expand the group containing the focused item. Requires
the Fast Recall button to be enabled.
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Clip Browser Shortcuts

Keyboard Shortcut Function

ALT + Q Enable Quick Find

ESC Clear Quick Find

ENTER Cue/Play when Fast Recall is enabled.
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Server Channel Shortcuts

Keyboard Shortcut Function

ALT + # Select a Server Channel number as the focused Server Channel.



Contact Us

Contact our friendly and professional support representatives for the following:

· Name and address of your local dealer

· Product information and pricing

· Technical support

· Upcoming trade show information

Technical
Support

Telephone: +1-844-652-0645 (North America)

+800 3540 3545 (International)

After Hours Emergency: +1 613 • 349 • 0006

Email: techsupport@rossvideo.com

General
Information

Telephone: +1 613 • 652 • 4886

Fax: +1 613 • 652 • 4425

Email: solutions@rossvideo.com

Website: http://www.rossvideo.com

Visit Us

Visit our website for:

· Company information and news

· Related products and full product lines

· Online catalog

· Testimonials
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