
Trackless Studio User Guide

Version 01



Thank You for Choosing Ross
You've made a great choice. We expect you will be very happy with your purchase of Ross Technology. 

Our mission is to:

1. Provide a Superior Customer Experience

• offer the best product quality and support

2. Make Cool Practical Technology

• develop great products that customers love

Ross has become well known for the Ross Video Code of Ethics. It guides our interactions and 
empowers our employees. I hope you enjoy reading it below.

If anything at all with your Ross experience does not live up to your expectations be sure to reach out to 
us at solutions@rossvideo.com.

David Ross
CEO, Ross Video
dross@rossvideo.com

Ross Video Code of Ethics
Any company is the sum total of the people that make things happen. At Ross, our employees are a 
special group. Our employees truly care about doing a great job and delivering a high quality customer 
experience every day. This code of ethics hangs on the wall of all Ross Video locations to guide our 
behavior:

1. We will always act in our customers’ best interest.

2. We will do our best to understand our customers’ requirements.

3. We will not ship crap.

4. We will be great to work with.

5. We will do something extra for our customers, as an apology, when something big goes wrong and 
it's our fault.

6. We will keep our promises.

7. We will treat the competition with respect.

8. We will cooperate with and help other friendly companies.

9. We will go above and beyond in times of crisis. If there's no one to authorize the required action in 
times of company or customer crisis - do what you know in your heart is right. (You may rent 
helicopters if necessary.)
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Important Regulatory and Safety Notices to Service Personnel

Before using this product and any associated equipment, refer to the "Important Safety Instructions" listed below so 
as to avoid personnel injury and to prevent product damage.

Products may require specific equipment, and /or installation procedures be carried out to satisfy certain regulatory 
compliance requirements. Notices have been included in this publication to call attention to these Specific 
requirements.

Symbol Meanings

Protective Earth — This symbol identifies a Protective Earth (PE) terminal, which is 
provided for connection of the supply system’s protective earth (green or green/yellow) 
conductor.

The exclamation point within an equilateral triangle is intended to alert the user to the presence 
of important operating and maintenance (servicing) instructions in the literature accompanying 
the product. Failure to heed this information may present a risk of damage or injury to persons 
or equipment.

Warning — The symbol with the word "Warning" within the equipment manual indicates a 
potentially hazardous situation, which if not avoided, could result in death or serious injury

Caution — The symbol with the word "Caution" within the equipment manual indicates a 
potentially hazardous situation, which if not avoided, may result in minor or moderate injury. It 
may also be used to alert against unsafe practices.

Notice — The symbol with the word "Notice" within the equipment manual indicates a 
situation, which if not avoided, may result in major or minor equipment damage or a situation, 
which could place the equipment in a non-compliant operating state. 

Warning Hazardous Voltages — The lightning flash with arrowhead symbol within an 
equilateral triangle is intended to alert the user to the presence of uninsulated "dangerous 
voltage" within the product's enclosure that may be of sufficient magnitude to constitute a risk of 
shock to persons.

ESD Susceptibility — This symbol is used to alert the user that an electrical or electronic 
device or assembly is susceptible to damage from an ESD event.



Important Safety Instructions

EMC Notices

US

FCC Part 15

This equipment has been tested and found to comply with the limits for a class A Digital device, pursuant to part 15 
of the FCC Rules. These limits are designed to provide reasonable protection against harmful interference when the 
equipment is operated in a Commercial environment. This equipment generates, uses, and can radiate radio 
frequency energy and, if not installed and used in accordance with the instruction manual, may cause harmful 

1) Read these instructions.

2) Follow all instructions and heed all warning.

3) Refer all servicing to qualified service personnel.

4) The equipment's AC appliance inlets are the means to disconnect the product from the 
AC Mains and must remain readily operable for this purpose.

5) Parts of the equipment's power supplies can still present a safety hazard even when the 
product is in the "OFF" state. To avoid the risk of electrical shock and to completely 
disconnect the apparatus from the AC Mains, remove all power supply cords from the 
product's AC appliance inlets prior to servicing.

6) The product chassis is to be rack mounted only. To ensure safe operation and maintain 
long-term system reliability, proper installation requires that the front and back area of the 
chassis remain clear of obstructions so as not to restrict airflow.

Warning 7) Indoor Use: To reduce the risk of fire or electric shock, do not expose this apparatus to 
rain or moisture.

Warning 8) This apparatus when equipped with multiple power supplies can generate high leakage 
currents. To reduce the risk of electric shock to operator and service personnel the 
following requirements must be met:

a) The equipment is to be installed in a restricted access area.

A restricted access area is one where access can only be gained by SERVICE 
PERSONS or by USERS who have been instructed about the reasons for the 
restrictions applied to the location and about any precautions that shall be taken; and

access is through the use of a TOOL or lock and key, or other means of security, and 
is controlled by the authority responsible for the location

b) the building installation shall provide a means for connection to protective earth 
and;

c) the product's protective earth terminal is connect to facility's protective earth using 
a 1.5mm2 (14AWG) conductor and a #8 1.5mm2 ring terminal and;

d) a SERVICE PERSON shall check whether or not the socket-outlet from which the 
equipment is to be powered provides a connection to the building protective earth.

Caution 9) This apparatus contains a Lithium battery, which if replaced incorrectly, or with an 
incorrect type, may cause an explosion. Replace only with the same type recommended by 
the manufacturer. Dispose of used batteries according to the manufacturer's instruction by 
qualified service personnel.

Notice 10) THE XPRESSION PROJECT SERVER IS NOT TO BE USED AS A BACK-UP 
SERVER.



interference to radio communications. Operation of this equipment in a residential area is likely to cause harmful 
interference in which case the user will be required to correct the interference at his own expense.

CANADA

This Class “A” digital apparatus complies with Canadian ICES-003. 

Cet appareil numerique de la classe “A” est conforme a la norme NMB-003 du Canada.

EUROPE

This equipment is in compliance with the essential requirements and other relevant provisions of CE Directive 
93/68/EEC.

INTERNATIONAL

This equipment has been tested to CISPR 22:1997 along with amendments A1:2000 and A2:2002 and found to 
comply with the limits for a Class A Digital device.

Warranty and Repair Policy

Ross Video Limited (Ross) warrants its XPression systems to be free from defects under normal use and service for 
the following time periods from the date of shipment:

• XPression Server — 12 months

• XPression Software Upgrades — 12 months free of charge

• System and Media hard drives — 12 months

If an item becomes defective within the warranty period Ross will repair or replace the defective item, as 
determined solely by Ross.

Warranty repairs will be conducted at Ross, with all shipping FOB Ross dock. If repairs are conducted at the 
customer site, reasonable out-of-pocket charges will apply. At the discretion of Ross, and on a temporary loan basis, 
plug in circuit boards or other replacement parts may be supplied free of charge while defective items undergo 
repair. Return packing, shipping, and special handling costs are the responsibility of the customer.

This warranty is void if products are subjected to misuse, neglect, accident, improper installation or application, or 
unauthorized modification.

In no event shall Ross Video Limited be liable for direct, indirect, special, incidental, or consequential damages 
(including loss of profit). Implied warranties, including that of merchantability and fitness for a particular purpose, 
are expressly limited to the duration of this warranty.

This warranty is TRANSFERABLE to subsequent owners, subject to Ross’ notification of change of ownership.

Extended Warranty

For customers that require a longer warranty period, Ross offers an extended warranty plan to extend the standard 
warranty period by one year increments. For more information about an extended warranty for your XPression 
system, contact your regional sales manager.

Notice Changes or modifications to this equipment not expressly approved by Ross Video Ltd. could 
void the user’s authority to operate this equipment.

Notice This is a Class A product. In domestic environments, this product may cause radio interference, 
in which case the user may have to take adequate measures.



Environmental Information

The equipment that you purchased required the extraction and use of natural resources for its production. It may 
contain hazardous substances that could impact health and the environment.

To avoid the potential release of those substances into the environment and to diminish the need for the extraction 
of natural resources, Ross Video encourages you to use the appropriate take-back systems. These systems will reuse 
or recycle most of the materials from your end-of-life equipment in an environmentally friendly and health 
conscious manner.

The crossed-out wheeled bin symbol invites you to use these systems.

If you need more information on the collection, reuse, and recycling systems, please contact your local or regional 
waste administration.

You can also contact Ross Video for more information on the environmental performances of our products.

Company Address

Ross Video Limited 

8 John Street
Iroquois, Ontario
Canada, K0E 1K0

Ross Video Incorporated 

P.O. Box 880
Ogdensburg, New York
USA 13669-0880

General Business Office:

Fax:

(+1) 613  652  4886

(+1) 613  652  4425

Technical Support: (+1) 613  652  4886

After Hours Emergency: (+1) 613  349  0006

E-mail for Technical Support: techsupport@rossvideo.com

E-mail for General Information: solutions@rossvideo.com

Website: http://www.rossvideo.com

mailto:techsupport@rossvideo.com?Subject=Information%20Request&Body=Hi,%0D%0D
mailto:solutions@rossvideo.com?Subject=Information%20Request&Body=Hi,%0D%0D
http://www.rossvideo.com
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Introduction
Trackless Studio provides a cost-effective virtual studio solution, using a small studio space and fixed cameras. This 
means no encoded camera heads or pedestals are required. Complex camera movements, simulation of dramatic 
moving “jib” shots are possible, using the virtual cameras within the Trackless Studio virtual sets. The intuitive 
interface provide controls for multiple camera presets, transitions, and even the ability to trigger events to manage 
media within the set or even adding insert graphics on layers above the virtual set shots. A complete production 
studio is now available within a single XPression real-time 3D render engine and your cameras as XPression inputs 
used as Live Sources.

Trackless Studio can support multiple cameras, based on the input capacity (1, 2 or 4 inputs) of the host XPression 
engine. User interfaces are provided on the main user interface, which can be used on a touch screen monitor, a 
customized XKeys Shotbox, Ross Video Dashboard, Carbonite (using Ross Talk) and even a web page interface 
can be used to either supplement the main operator position.

About This Guide

This user guide describes XPression Trackless Studio, its configuration, and operation.

If, at any time, you have a question pertaining to the installation or operation of XPression Trackless Studio, please 
contact us at the numbers listed in the section “Contacting Technical Support” on page 1–2. Our technical staff 
are always available for consultation, training, or service.

Documentation Conventions

Special text formats are used in this guide to identify parts of the user interface, text that a user must enter, or a 
sequence of menus and submenus that must be followed to reach a particular command.

Getting Help

The XPression Trackless Studio User Guide is supplied as print-ready PDF files. Locate the guide in the 
C:\Archives to open the guide PDF in Adobe® Reader® for viewing or printing.

Bold text Bold text is used to identify a user interface element such as 
a dialog box, menu item, or button.

For example:

In the 3D Model Files section, use the Mode list to select 
the folder used to store 3D model files.

Courier text Courier text is used to identify text that a user must enter.

For example:

Enter localhost when the DataLinq server is running of 
the same computer as XPression.

> Menu arrows are used in procedures to identify a sequence 
of menu items that you must follow. 

For example, if a step reads “Display > Widgets,” you 
would click the Display menu and then click Widgets.
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Contacting Technical Support

At Ross Video, we take pride in the quality of our products, but if problems occur, help is as close as the nearest 
telephone.

Our 24-hour Hot Line service ensures you have access to technical expertise around the clock. After-sales service 
and technical support is provided directly by Ross Video personnel. During business hours (eastern time), technical 
support personnel are available by telephone any time. After hours and on weekends, a direct emergency technical 
support phone line is available. If the technical support person who is on call does not answer this line immediately, 
a voice message can be left and the call will be returned shortly. This team of highly trained staff is available to 
react to any problem and to do whatever is necessary to ensure customer satisfaction.

• Technical Support: (+1) 613-652-4886

• After Hours Emergency: (+1) 613-349-0006

• E-mail: techsupport@rossvideo.com

• Website: http://www.rossvideo.com

mailto:techsupport@rossvideo.com?Subject=Information%20Request&Body=Hi,%0D%0D
http://www.rossvideo.com
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Technical Overview
This chapter covers the following:

• Trackless Studio Requirements

• Hardware Connections

• Audio Delay Options

Trackless Studio Requirements
• Minimum of an XPression M4 machine (or equivalent); XPression M5 for optimal performance.

• XPression Studio or BlueBox edition software.

• Trackless license dongle.

• XPression Chroma Key and DataLinq licenses.

• Trackless Studio GUI requires a 1920x1080 Windows® display resolution.

• Firewall must be disabled or properly configured to enable required network communication.

To view more information on Trackless Studio for XPression, click Help > About in the Trackless Studio interface.

Hardware Connections

The following diagram describes a sample hardware connection configuration for running Trackless Studio using 
two customer supplied cameras and optional controllers (shotbox and Ross Carbonite switcher):

• Ross XPression Studio or BlueBox Edition systems running on XPression M4 hardware (or equivalent) or 
higher.

• 1 Full HD SDI Camera connected to Input A on XPression; 1 Full HD SDI Camera connected to Input B on 
XPression.

• If using a 4 input XPression system, 1 Full HD SDI Camera connected to Input C on XPression; 1 Full HD SDI 
Camera connected to Input D on XPression.

• Shotbox connected to XPression via 1 USB 2.0 port.

• Ross Carbonite Switcher connected to the same local area network as the XPression machine.

• 1 Full HD 1920x1080 display for Trackless Studio GUI.
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Audio Delay Options

The following diagrams demonstrate the AES and embedded audio delay options when syncing audio in Trackless 
Studio.

AES Audio

Embedded Audio
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Setup
This chapter covers the following:

• Starting Trackless Studio and Configuring the Settings

• Trackless Studio RossTalk Commands

• Shotbox

• Trackless Studio in DashBoard

• Trackless Studio VISCA Controller — Carbonite Joystick

Starting Trackless Studio and Configuring the Settings

 Always launch XPression and open your virtual set project before launching Trackless Studio.

1. Launch Trackless Studio Settings from the desktop or Start menu.

The Trackless Studio Settings dialog box opens on the Scenes tab.

2. In the Scenes tab, configure the properties of the scenes to be used by Trackless Studio:

a. In the Name box, enter a scene name from the XPression project. The default names used by Trackless 
Studio are Scene1, Scene2, Scene3, and Scene4.

b. Use the Home Position boxes to enter or select the X, Y, and Z values for the default position of the virtual 
camera in the scene. The default is X:0, Y:0, and Z:0.

c. Set the orientation of the camera input for Talent 1, Talent 2, Talent 3, and Talent 4 in the scene using the 
Camera 0X Orientation list for the respective talent. The options are:

• Horizontal 

• Rotate 90° Right 

• Rotate 90° Left 

The default for Talent 1 is Rotate 90° Right. The default for Talent 2, Talent 3, and Talent 4 is 
Horizontal.

d. Repeat steps a to c for Scene 2, Scene 3, and Scene 4.



3–2 Trackless Studio User Guide (v01)

3. Click the Effects tab.

The Effects tab opens.

4. In the Effects tab, configure the default effects for the camera animations and the transitions:

a. In the Camera Animation (Interpolation) section, use the Default list to select a default interpolation for 
the camera movement in Trackless Studio. The options are:

• Bezier (Smooth) — select this option to use a bezier curve between the start of the animated camera 
movement and the end of the animated camera movement.

• Linear — select this option to use a linear trajectory between the start of the animated camera movement 
and the end of the animated camera movement.

The default is Bezier (Smooth).

b. Use the Max Speed (px/s) box to enter or select the maximum interpolation speed in pixels per second.

The default is 300.

c. Use the Default Speed (px/s) box to enter or select the default speed of the interpolation in pixels per 
second.

The default speed is 90.

d. In the Transition section, use the Default Effect list to select a default transition for the scenes. The 
options are:

• Dissolve — select a gradual transition where a preset dissolves into the next preset:

› Crossfade — transition the presets using a fade from one preset to the other.

› Through Black — transition the presets by fading into, and then, from black.

› Additive — transition the presets by gradually adding light to the image.

› Saturate — transition the presets using saturation.

• Push — select a sliding transition where the preset pushes out the previous preset:

› Right to Left — push a preset out to the left while the next preset enters from the right.push a preset 
out to the right while the next preset enters from the left.

› Left to Right — push a preset out to the right while the next preset enters from the left.

› Top to Bottom — push a preset out the bottom while the next preset enters from the top.

› Bottom to Top — push a preset out the top while the next preset enters from the bottom.
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• Distort — select a transition where a preset is warped out:

› Diverge — transition a preset by splitting it into multiple pieces.

› Pixelate — transition a preset by making it appear as though it is at a lower resolution.

› Sine Wave — transition a preset by using a sine wave pattern.

› Shrink — transition a preset by shrinking it.

• Cut — select a clean cut between presets:

› Cut — transition presets by using an instantaneous transition from one preset to the next.

The default is Crossfade.

e. Use the Max Duration (frames) box to enter or select the maximum duration speed in frames for the scene 
transition.

The default is 300.

f. Use the Default Duration (frames) box to enter or select the default speed of the scene transition in 
frames.

The default is 30.

5. Click the Network tab.

The Network tab opens.

6. In the Network tab, configure the network settings for Trackless Studio:

a. In the Web Server section, use the Port box to enter or select a port where web connections will be 
accepted for the web server interface. See “Web Server” on page A–6 for more information.

The default is 80.

Select the Enabled check box to enable the web server interface.

By default it is enabled.

b. In the RossTalk In section, use the Port box to enter or select a port where RossTalk commands will be 
received.

The default is 7789. This must be a different Smart GPI/RossTalk setup port than on the local XPression 
machine.

Select the Enabled check box to enable the RossTalk protocol.

By default it is enabled.
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c. In the DashBoard Controller (openGear) section, use the Frame Port box to enter or select a port where 
incoming commands will be received.

The default is 5253.

Select the Enabled check box to enable DashBoard Controller.

By default it is enabled.

d. Use the Web Port box to enter or select the port used by openGear.

The default is 8080.

Select the Enabled check box to enable the openGear protocol.

By default it is enabled.

e. In the Sony Visca Controller section, use the Port box to enter or select the port to which the VISCA 
device is connected.

The default is 12907.

Select the Enabled check box to enable the VISCA protocol.

By default it is enabled.

7. Click the Other tab.

The Other tab opens.

8. In the Other tab, view the prefixes for XPression objects or configure the manual controls and other general 
settings.

 The prefixes for XPression objects cannot be modified and are for reference only.

a. In the Manual Controls section, use the Xkeys Sensitivity box to enter or select the controller sensitivity 
multiplier if using a shotbox.

The default is 0.050.

b. If using a 3DConnexion controller, use the 3DConnexion Sensitivity box to enter or select the controller 
sensitivity multiplier.

The default is 0.002.

c. Use the Touch Navigation Sensitivity box to enter or select the sensitivity of the arrows in the Production 
Control window when using the touchscreen.

The default is 1.000.
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d. In the General section, use the Language list to select the display language for the Trackless Studio 
interface. The options are:

• English 

• Spanish 

The default is English.

e. Use the Frame Rate box to enter or select the frame rate at which XPression projects will be used.

The default is 29.97.

f. Use the Default Layer box to enter or select the default layer on which scenes will be taken online.

The default is -999.

g. Use the Default UI Display box to enter or select the Windows monitor where the application is displayed.

The default is 1.

h. Use the Default Output Channel list to select the framebuffer where scenes will be taken online.

The default is 0.

9. Press Save & Launch.

A file browser opens.

10. Locate and select an XPression .xpf file virtual set project.

11. Click Open.

Trackless Studio finishes loading and opens.

 Do not modify objects in the XPression project while running Trackless Studio. Always exit Trackless Studio 
first, modify the required elements, and then start Trackless Studio again.

When Save & Launch is selected in the Trackless Studio Settings dialog box, a Trackless software 
configuration file is created (settings.xml) and stored in C:\XPressionApps\Trackless Studio. Save this 
configuration file in a safe location and manually replace it after performing a Trackless Studio upgrade in order 
to restore previous talent camera orientations, effects, network settings, and general settings.



3–6 Trackless Studio User Guide (v01)

Trackless Studio RossTalk Commands

The inbound RossTalk port is configured in the Trackless Settings and must be a different Smart GPI/RossTalk 
setup port on the local XPression machine.

 Default Port: TCP 7789; enable in Trackless Studio settings.

Table 3.1  Scene 1, Scene 2, NEXT, FOCUS, & SEQI GPI Commands

GPI Command GPI Command

GPI 01 Call Scene 01 GPI 02 Call Scene 02

GPI 10 Call Scene 1 Preset 1 GPI 20 Call Scene 2 Preset 1

GPI 11 Call Scene 1 Preset 2 GPI 21 Call Scene 2 Preset 2

GPI 12 Call Scene 1 Preset 3 GPI 22 Call Scene 2 Preset 3

GPI 13 Call Scene 1 Preset 4 GPI 23 Call Scene 2 Preset 4

GPI 14 Call Scene 1 Preset 5 GPI 24 Call Scene 2 Preset 5

GPI 15 Call Scene 1 Preset 6 GPI 25 Call Scene 2 Preset 6

GPI 16 Call Scene 1 Preset 7 GPI 26 Call Scene 2 Preset 7

GPI 17 Call Scene 1 Preset 8 GPI 27 Call Scene 2 Preset 8

GPI 18 Call Scene 1 Preset 9 GPI 28 Call Scene 2 Preset 9

GPI 19 Call Scene 1 Preset 10 GPI 29 Call Scene 2 Preset 10

GPI 80 Save Scene 1 Preset 1 GPI 90 Save Scene 2 Preset 1

GPI 81 Save Scene 1 Preset 2 GPI 91 Save Scene 2 Preset 2

GPI 82 Save Scene 1 Preset 3 GPI 92 Save Scene 2 Preset 3

GPI 83 Save Scene 1 Preset 4 GPI 93 Save Scene 2 Preset 4

GPI 84 Save Scene 1 Preset 5 GPI 94 Save Scene 2 Preset 5

GPI 85 Save Scene 1 Preset 6 GPI 95 Save Scene 2 Preset 6

GPI 86 Save Scene 1 Preset 7 GPI 96 Save Scene 2 Preset 7

GPI 87 Save Scene 1 Preset 8 GPI 97 Save Scene 2 Preset 8

GPI 88 Save Scene 1 Preset 9 GPI 98 Save Scene 2 Preset 9

GPI 89 Save Scene 1 Preset 10 GPI 99 Save Scene 2 Preset 10

NEXT Next item in sequence

FOCUS X Sequence position X

SEQI X Call event X
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Table 3.2  Scene 3 & Scene 4 GPI Commands

GPI Command GPI Command

GPI 03 Call Scene 03 GPI 04 Call Scene 04

GPI 30 Call Scene 3 Preset 1 GPI 40 Call Scene 4 Preset 1

GPI 31 Call Scene 3 Preset 2 GPI 41 Call Scene 4 Preset 2

GPI 32 Call Scene 3 Preset 3 GPI 42 Call Scene 4 Preset 3

GPI 33 Call Scene 3 Preset 4 GPI 43 Call Scene 4 Preset 4

GPI 34 Call Scene 3 Preset 5 GPI 44 Call Scene 4 Preset 5

GPI 35 Call Scene 3 Preset 6 GPI 45 Call Scene 4 Preset 6

GPI 36 Call Scene 3 Preset 7 GPI 46 Call Scene 4 Preset 7

GPI 37 Call Scene 3 Preset 8 GPI 47 Call Scene 4 Preset 8

GPI 38 Call Scene 3 Preset 9 GPI 48 Call Scene 4 Preset 9

GPI 39 Call Scene 3 Preset 10 GPI 49 Call Scene 4 Preset 10

GPI 100 Save Scene 3 Preset 1 GPI 110 Save Scene 4 Preset 1

GPI 101 Save Scene 3 Preset 2 GPI 111 Save Scene 4 Preset 2

GPI 102 Save Scene 3 Preset 3 GPI 112 Save Scene 4 Preset 3

GPI 103 Save Scene 3 Preset 4 GPI 113 Save Scene 4 Preset 4

GPI 104 Save Scene 3 Preset 5 GPI 114 Save Scene 4 Preset 5

GPI 105 Save Scene 3 Preset 6 GPI 115 Save Scene 4 Preset 6

GPI 106 Save Scene 3 Preset 7 GPI 116 Save Scene 4 Preset 7

GPI 107 Save Scene 3 Preset 8 GPI 117 Save Scene 4 Preset 8

GPI 108 Save Scene 3 Preset 9 GPI 118 Save Scene 4 Preset 9

GPI 109 Save Scene 3 Preset 10 GPI 119 Save Scene 4 Preset 10
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Shotbox

Trackless Studio Shotbox is a an application that allows the user to configure the shortcuts for the optional shotbox 
controller and joystick. Use the dropdowns to select the shortcut to assign to the selected key.

The enabled Pan on Handle Twist check box indicates that Trackless Studio will pan the camera if the handle on 
the joystick is twisted.
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Trackless Studio in DashBoard

1. In the Trackless Studio Settings window, ensure that the Frame Port in the DashBoard Controller 
(openGear) section of the Network tab is set to 5253 and Enabled.

2. Ensure that the Web Port in the DashBoard Controller (openGear) section of the Network tab is set to 8080.

3. In DashBoard, click File > New > TCP/IP DashBoard Connect or openGear Device.

The New TCP openGear Frame Connection window opens.

4. In the IP Address box, enter the IP address of the Trackless Studio machine.

 Do not click Detect Frame Information.

5. In the Display Name box, enter a display name such as “Trackless Studio”.

6. Ensure the Protocol options are set to OGP.

7. Ensure the Port is set to 5253 (default).

8. Ensure the Remember connection settings for this frame check box is selected.

9. Click Finish.

The Trackless Studio openGear item is added to the Basic Tree View in DashBoard.
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10. Double-click the Trackless Studio openGear item to open the panel for manually moving the camera, calling 
camera presets using the thumbnails, and calling events using the buttons.

For More Information on...

• Trackless Studio in DashBoard, refer to “DashBoard” on page 4–16.

Trackless Studio VISCA Controller — Carbonite Joystick

Trackless Studio supports Sony VISCA protocol for using a Ross Carbonite Switcher to manually move the virtual 
camera.

1. In the Trackless Studio Settings window, ensure that the Port in the Sony Visca Controller section of the 
Network tab is set to 12907 and Enabled.

2. In Carbonite, configure a new Sony VISCA camera device with the IP address of the XPression machine and 
the port configured in the Trackless Studio Settings (default 12907).
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Operation
This chapter covers the following:

• Trackless Studio Interface

• Shutting Down Trackless Studio

• DashBoard

Trackless Studio Interface

The following section describes the Trackless Studio interface and its functions.

Menus

File > Settings > Load — select this option to load Trackless Studio settings for a project from a file (*.tss).

File > Settings > Save — select this option to save Trackless Studio settings for a project to a file (*.tss).

File > Settings > Save As — select this option to save Trackless Studio settings for a project to a new file (*.tss).

File > Settings > Increment and Save — select this option to save Trackless Studio settings for a project to a new 
file (*.tss) without overwriting the previously saved file.

File > XPression > Load Project — select this option to load an XPression project.

File > XPression > Save Project — select this option to save an XPression project.

File > XPression > Save Project As — select this option to save an XPression project to a new file.

File > Exit — select this option to exit and close Trackless Studio.

XPression > Show GUI — select this option to open the XPression interface.

Help > About — select this option to view information about Trackless Studio such as the version and 
requirements.
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For More Information on...

• exiting and closing Trackless Studio, refer to “Shutting Down Trackless Studio” on page 4–15.

Playout - Production Control

Click Production Control under the Playout heading to open the Production Control interface. Use this section to 
playout scenes by triggering presets, camera movements, and transitions, or using manual camera controls.

Scene1/Scene2/Scene3/Scene4

Click a preset thumbnail (e.g. (Q)01, (W)02, etc.) to select it. Click multiple preset thumbnails in a row to add them 
to the Trackless Queued Commands List. When selecting the presets, it helps to keep the camera speed in the 
Camera Movement section slow (e.g. 10%). Click the Camera Control tab to display all scenes and hide the 
camera controls.

Use the scroll bar on the right to scroll down to access Scene3 and Scene4.

Events — use this list to select an event/macro to trigger for a selected preset.

Trigger — click this button to activate a selected event.

Talent A — use this list to select the quad to use in the scene.

Go — click this button to move the camera to the selected talent quad in the scene.

Save — click this button to save the current scene configurations.
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Right-click on a preset thumbnail to access the following shortcut menu:

• Preset Settings — select this option to open the Preset Setting window:

The following describes the Preset Setting window:

› Duration Multiplier — use this box to enter a higher number value if you want to increase the time of the 
camera movement (interpolation) when selecting the current preset. Enter a lower number value (decimal) if 
you want to decrease the time for the camera movements when selecting the current preset.

› GPIO Output — select the check boxes to define a specific state (ON/OFF) for the GPIO board of the 
XPression machine when calling a specific preset. When calling a specific preset, Trackless can automatically 
set an OUT Pin to ON (5V+) or OFF (0V+) if desired. This can be useful, for example, to turn tally lights on 
or off directly from Trackless. As Trackless virtual cameras are not directly related to physical cameras, this 
has to be set manually, and you can have two live camera inputs in view with one virtual camera preset.

› OK — click to apply any changes and close the window.

› Cancel — click to cancel any changes and close the window.

• Queue > Show Queue — select this option to open the Trackless Queued Command List:

The following describes the Trackless Queued Commands List interface:

› Command — this list displays the commands that have been queued for the animated camera movements 
from the selected Scene.

› OK — click this button to exit and close the Trackless Queued Commands List.

› Clear Queue — click this button to clear and close the Trackless Queued Commands List. If camera 
movement is already in progress, the movement to the preset target will complete but will stop at the end and 
not move to another preset.

• Queue > Clear Queue — select this option to clear the queued command list.

• Delete Preset — select this option to delete the preset from the scene.
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Camera Control

Right-click on Camera Control to access the following shortcut menu:

• Camera Control > Show Queue — select this option to open the Trackless Queued Command List (see the 
description for Scene1/Scene2/Scene3/Scene4 above for details).

• Camera Control > Clear Queue — select this option to clear the queued command list.

Camera Movement

Speed — use the slider to increase or decrease the speed of the animated camera movement.

Stop Move — click this button to stop or break the animated camera movement.

Clear Queue — click this button to clear or flush animated camera movement commands from the queue.

Delay (s) — use this box to enter or select a delay time in seconds for the animated camera movement presets.

Interpolation

Delay (s) — use this box to enter or select a delay time in seconds for the animated camera movement presets.

Bezier (Smooth) — select this option to use a bezier interpolation between the start of the animated camera 
movement and the end of the animated camera movement.

Linear — select this option to use a linear trajectory between the start of the animated camera movement and the 
end of the animated camera movement.

Disable — select this option to disable the interpolation calculations.

Scene Transitions

Dissolve — select a gradual transition where a preset dissolves into the next preset:

• Crossfade — transition the presets using a fade from one preset to the other.

• Through Black — transition the presets by fading into, and then, from black.

• Additive — transition the presets by gradually adding light to the image.

• Saturate — transition the presets using saturation.

Push — select a sliding transition where the preset pushes out the previous preset:

• Right to Left — push a preset out to the left while the next preset enters from the right.

• Left to Right — push a preset out to the right while the next preset enters from the left.

• Top to Bottom — push a preset out the bottom while the next preset enters from the top.

• Bottom to Top — push a preset out the top while the next preset enters from the bottom.

Distort — select a transition where a preset is warped out:

• Diverge — transition a preset by splitting it into multiple pieces.

• Pixelate — transition a preset by making it appear as though it is at a lower resolution.

• Sine Wave — transition a preset by using a sine wave pattern.

• Shrink — transition a preset by shrinking it.
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Cut — select a clean cut between presets:

• Cut — transition presets by using an instantaneous transition from one preset to the next.

Duration (Frames) — use the slider to increase or decrease the duration in frames for the transition between 
presets.

Manual Camera Control

Arrow Keys — select this option to enable keyboard arrows for manual camera control.

Shortcut Keys — select this option to enable keyboard shortcuts to call presets or events. The available keyboard 
shortcuts are:

 
Table 4.1  Camera Presets

Shortcut Function

Preset 1-1 to 1-10

1. Shift + Q Preset 1-1

2. Shift + W Preset 1-2

3. Shift + E Preset 1-3

4. Shift + R Preset 1-4

5. Shift + T Preset 1-5

6. Shift + Y Preset 1-6

7. Shift + U Preset 1-7

8. Shift + I Preset 1-8

9. Shift + O Preset 1-9

10. Shift + P Preset 1-10

Preset 2-1 to 2-10

1. Shift + A Preset 2-1

2. Shift + S Preset 2-2

3. Shift + D Preset 2-3

4. Shift + F Preset 2-4

5. Shift + G Preset 2-5

6. Shift + H Preset 2-6

7. Shift + J Preset 2-7

8. Shift + K Preset 2-8

9. Shift + L Preset 2-9

10. Shift + ; Preset 2-10
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 Keyboard shortcuts are not available for Scene3 and Scene4. 

Analog Joystick — select this option to control camera movements using the shotbox joystick.

 It is also possible to wirelessly enable the talent to trigger an event action sequence in order, moving previous 
and next events, using a wireless pointer.

Go Home — click this button to return to the starting point of the virtual set configured in the Trackless settings.

0.1X/1.0X — select the camera movement speed sensitivity. 0.1X is slowest and 1.0X is fastest.

Stop Manual — click this button to stop any active manual camera movement. This is useful if a connection 
problem occurs between the shotbox joystick or Carbonite joystick, or if there is an arrow key issue. Any manual 
camera movement input action currently in the queue will be stopped and removed from the queue.

Z+ — click this button to move the camera forward along the Z-axis.

Z- — click this button to move the camera backward along the Z-axis.

X+ — click this button to move the camera right along the X-axis.

X- — click this button to move the camera left along the X-axis.

Y+ — click this button to move the camera up along the Y-axis.

Y- — click this button to move the camera down along the Y-axis.

Tilt+ — click this button to rotate the camera upward.

Tilt- — click this button to rotate the camera down.

Pan+ — click this button to rotate the camera to the right.

Pan- — click this button to rotate the camera to the left.

Table 4.2  Movement

Shortcut Function

Ctrl + Left Arrow Move camera left

Ctrl + Right Arrow Move camera right

Ctrl + Up Arrow Move camera forward

Ctrl + Down Arrow Move camera backward

Shift + Left Arrow Pan camera left

Shift + Right Arrow Pan camera right

Shift + Up Arrow Tilt camera up

Shift + Down Arrow Tilt camera down

Ctrl + Shift + Up Arrow Move camera up

Ctrl + Shift + Down Arrow Move camera down

Table 4.3  Other

Shortcut Function

Shift + Esc Quit the program
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Settings - Chroma Keyer

 The live source camera input functionality requires a chroma keyer license option. Contact your Ross Video 
sales representative for information.

Click Chroma Keyer under the Settings heading to open the Chroma Keyer interface. Use this section to adjust the 
settings for the color of the live source material and the size of the talent quad.

Color

Select a liveinputcam from the list of live sources and configure the color settings for the chroma key:

Color Box — click a color in this box to set the RGB color value.

Scale — place the slider along this scale to set the selected RGB color value.

R — use the slider to adjust the red value or use the box to enter a red value.

G — use the slider to adjust the green value or use the box to enter a green value

B — use the slider to adjust the blue value or use the box to enter a blue value

A — use the slider to adjust the alpha value or use the box to enter an alpha value.

Dropper Tool — use the dropper tool to add the color to the chroma key for the live source material by clicking 
inside the talent quad in the Talent Quad section below the Color section or the scene next to the Color section.

Active — select this check box to enable the chroma key.
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Refresh — click this button to refresh the image from the live source feed.

To select a different live source, right-click on a liveinputcam and select Select Input Source to open the Select 
Input Frame Buffer dialog box and choose a different input source for the live input.

Matte Generation 

• Max. Angle — enter or select an angle to set the maximum difference in color between the selected chroma key 
color and the input color to be chroma keyed.

• Edge Width — enter or select a value to adjust the outside edge of the foreground image as follows:

› Increasing the value increases the amount that the key encroaches onto the foreground image.

› Decreasing the value decreases the amount that the key encroaches onto the foreground image.

• FG Clipping — enter or select a value to determine the range of colors which are considered foreground colors. 
Adjust the clipping as follows:

› Increasing the value removes lower-saturated colors from the foreground image. 

› Decreasing the value includes lower-saturated colors in the foreground image.

• Edge Hardness — enter or select a value to add or remove edge hardening of the foreground image as follows:

› Increasing the value increases the amount of hardness applied to the foreground edges.

› Decreasing the value decreases the amount of hardness applied to the foreground edges.

Matte Post-Processing 

• Soften — enter or select the value used to blur the edge of the generated matte.

• Sharpen Range — enter or select the range to apply the sharpen value.

• Sharpen — enter or select the value to set the amount of sharpening applied to the edge of the generated matte.

Spill Suppression 

• Range — enter or select the range of the chroma key color, within the set Max Angle, to apply desaturation.

• Desaturation — enter or select the amount of key color to remove from the set range. A value of 1 = 100% of 
the key color.

Luma Clipping 

• Clip Low — use this box to adjust the value to counteract dark areas of the chroma key backdrop and prevent 
them from being keyed out.

• Clip High — use this box to adjust the value to counteract bright areas of the chroma key backdrop and prevent 
them from being keyed out.

• Clip Softness — enter or select the value used to blur the edges between what has been keyed out and what has 
been prevented from being keyed out.

Auto Apply — select this check box to automatically apply any changes made to the chroma key settings.

Apply — click to apply the changes made to the chroma key settings.

Load Settings — click to open a browser to select a chroma key settings file (*.cks) to load.

Save Settings — click to save the chroma key settings to a file (*.cks).
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Talent Quad/Cropping

Select a talent quad from the list to crop or apply the color setting for the chroma key using the dropper tool in the 
Color section.

Click, hold, and then move the mouse inside the talent quad image to create a cropping box to crop the talent quad. 
Release the mouse when the cropping is sized as necessary.

Click the dropper tool from the Color section inside the talent quad image to add the configured color for the 
chroma key to the live source for the talent quad.

Refresh List — click this button to refresh the enabled vtalent items in the talent quad list. Refreshing enabled 
items in the list will update the camera view for the talent quad if it has been adjusted.

Reset Cropping — click this button to reset any cropping made to the talent quad.

Talent Size

Scale — enter or select a percentage to scale the talent quad.

W — enter or select a width in pixels to scale the talent quad.

H — enter or select a width in pixels to scale the talent quad.

Apply — click to apply the changes to the talent quad size.

Talent Position

Z+ — click this button to move the talent quad forward along the Z-axis.

Z- — click this button to move the talent quad backward along the Z-axis.

X+ — click this button to move the talent quad right along the X-axis.

X- — click this button to move the talent quad left along the X-axis.

Y+ — click this button to move the talent quad up along the Y-axis.

Y- — click this button to move the talent quad down along the Y-axis.

0.1px — select this option to move the talent quad 0.1 pixels for each change in position.

1px — select this option to move the talent quad 1 pixel for each change in position.

10px — select this option to move the talent quad 10 pixels for each change in position.

100px — select this option to move the talent quad 100 pixels for each change in position.

Reset — click this to reset the talent position to X:0, Y:0, Z:0.
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Settings - Media

Click Media under the Settings heading to open the Media settings interface. Use this section to set up or update 
media lists to be used in either hot-swap mode or event-based triggering in the Production Control interface.

Media assets must be encoded by XPression.

Setup Media for Events

Click this tab to set up media for events. The materials are meant to be used as displays triggered in the virtual set 
(e.g. virtual monitors, etc.). Only materials that have been configured according to the naming convention prefix in 
the settings will be available.

Id — the media list ID number.

Name — click inside a cell to enter or edit a name for the media.

Input — displays the source of the media.

Material — click inside a cell to select a material for the media.

New — click to add a new media item for events to the list.

Delete — click to delete a selected media item from the list.

Drives (C:\, etc.) — expand a drive to locate a media file. Drag and drop the media file onto a media list item to add 
it.

Live Sources — drag and drop a live source onto a media list item to add it.

Refresh — click to update the live source images.
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Media Hot Swap

Click this tab for hot-swap mode. Hot-swap is used to modify or update media in Trackless Studio such as a video, 
live source, or still image that might be used on something such as a virtual monitor. This allows for quick changes 
live during production.

Up/Down Arrows — use these buttons to move up and down the materials list.

Materials List — select a material to select it for the object for the media hot-swap.

Object Items List — displays the specific object assigned to which the selected material has been assigned.

Media Items — once a material has been selected, click on a media item to add it to that material. A preview is 
displayed to the right of the media items.

Assign — click this to assign the media item to the selected material. A material and media item must each be 
selected before they can be assigned.

Drives (C:\, etc.) — expand a drive to locate a media file. Drag and drop the media file onto a media item to add it 
to the Media Items list.

Live Sources — select a material from the Materials List and an object from the Object Items List and then 
double-click a live source to place it on the chosen object.

Refresh — click to update the live source images.
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Settings - Events / Sequences

Events add the ability to trigger a variety of features simultaneously.This includes modifying DataLinq keys, setting 
layers online/offline (e.g. lower thirds, crawls, etc.), playing media (e.g. video, textures, etc.), scene directors, and 
animation controllers, triggering camera presets, and sending RossTalk commands to other RossTalk compatible 
machines. Each event has an ID, a name, a keyboard shortcut, a RossTalk shortcut (a SEQI command), and a group, 
and can be used in a sequence.

Events

Id — the event list ID number.

Name — click inside the cell to enter a name for the event. This name is used for reference when listed in the 
Shotbox section, web server, and sequences.

Keyboard — click inside the cell to select a key to assign as a keyboard shortcut for the event. Shortcut Keys must 
be enabled in the Production Control section to assign a keyboard shortcut.

RossTalk In — displays the RossTalk SEQI command support for the event. The commands are assigned 
sequentially based on the event ID number.

Group — click inside the cell to select a group for the event, if necessary. This enables ease of use within the web 
application.

Trigger — click to trigger the event.

Print — click to print the event list.

Export — click to export the event list to a text file.

New Event — click to add a new event to the list.

Delete Event — click to delete a selected event from the list.

 Triggers are not executed simultaneously. They are executed in the following order: Datalinq Keys, Layers, 
Media, Scene Directors, Animation Controllers, Camera Presets, and RossTalk commands.
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Groups

Groups are used for better flow within the web application. Each event can be assigned to a group from the Group 
list and called from the Events button of the web interface homepage.

New Group — click to add a new group. When the Group Name window opens, enter a name for the new group 
and click OK to add the group to the list.

Delete Group — click to delete a selected group from the list.

Event Items

DataLinq Key

Use this tab to add and modify DataLinq Key values for an event.

Scene, Key ID — click inside the cell to select the DataLinq scene and Key ID from the DataLinq Keys tab in the 
Object Inspector in XPression.

Value — click inside the cell to enter the DataLinq Key value.

Add DataLinq Key — click to add a DataLinq Key 

Remove DataLinq Key — click to delete a selected DataLinq Key from the list.

Insert Graphics

Use this section to add a layer to a scene for graphics.

Scene — click inside the cell to select a scene for the graphic.

Transition — click inside the cell to select a transition for the graphic.

Output Framebuffer — click inside the cell to select an output framebuffer for the graphic.

Layer Index — click inside the cell to select the layer index for a selected layer in the output.

Text Object — click inside the cell to select a text object from the scene to update if necessary.

Text Value — click inside the cell to modify the text value of a text object before the scene goes on air if a text 
object has been selected to update. This can be useful to update, for example, lower thirds, titles, and subtitles.

Online — select the check box to put the graphic online.

Media

Use this section to add a configured media source to the event.

Media — click inside the cell to select a media source from the Setup Media for Events tab in the Media section.

Add Media — click to add a media item to the list.

Remove Media — click to remove a selected media item from the list.

Object

Use this section to add an object from a scene to the event.

Scene - Object — click inside the cell to select an object from a scene for the event.

Action — click inside the cell to select an action for the object. The options are:

• Show 

• Hide 

• FadeIn 

• FadeOut 

• Toggle 

• ToggleFade 

Add Object — click to add an object to the list.
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Remove Object — click to delete a selected object from the list.

Scene Director

Use this section to add a scene director to the event.

Scene, Scene Director — click inside the cell to select a scene director to add to the event.

Comment — displays any pertinent information about the selected scene director.

Add Scene Director — click to add a scene director to the list.

Remove Scene Director — click to remove a selected scene director from the list.

Animation Controller

Use this section to add an animation controller to the event.

Scene, Animation — click inside the cell to select an animation controller to add to the event.

Add Animation Controller — click to add an animation controller to the list.

Remove Animation Controller — click to remove a selected animation controller from the list.

Preset

Use this section to add a camera preset to the event.

Scene — click inside the cell to select the scene with the camera preset to add to the event.

Preset — click inside the cell to select the camera preset to use with the event.

Add Camera Preset — click to add an camera preset to the list.

Remove camera Preset — click to remove a selected camera preset from the list.

RossTalk Out

Use this section to add RossTalk commands to the event.

Command — click inside the cell to select the RossTalk command output for the event. The options are:

• GPI 

• UP 

• DOWN 

• NEXT 

• TAKE 

Extra Parameters — click inside the cell to enter added parameters to complete the full string for the RossTalk 
command, such as the GPI pin number.

Host — click inside the cell to enter the host IP address of the target RossTalk device or enter localhost.

Port — click inside the cell to enter the port number of the target RossTalk device or local host.

Protocol — click inside the cell to select the command protocol.

Sequences

Sequences are similar to events. They are used to trigger a sequential list of either camera presets and/or events. A 
Sequence can consist of a list of events, a list of camera presets, or a mixture of both. The RossTalk FOCUS 
command allows the user to select any sequence on the list (starting at FOCUS 0000). Use this section to add or 
remove sequences.

New Sequence — click to add a new sequence to the list.

Delete Sequence — click to delete a selected sequence from the list.
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Sequence Items

Sequence items are triggered by either moving up or down with the arrow buttons to the right of the items list 
and/or with the RossTalk command NEXT.

Reset — click to move to the beginning of the listed sequence items.

New Item — click to add a camera preset or event to the sequence items list of the selected sequence.

Remove Item — click to remove a camera preset or event from the sequence items list of the selected sequence.

Settings - Shotbox

As a reference, the Shotbox section lists all shortcuts available when using the shotbox controller option.

Shutting Down Trackless Studio

 Always close Trackless Studio before closing XPression.

1. In Trackless Studio, click File > Exit.

A Trackless Studio prompt opens.
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2. Select one of the following exit options:

• Yes — exit and save any changes in Trackless Studio.

A second Trackless Studio prompt opens.

Select one of the following options:

› Yes — exit and save any changes in the XPression project.

› No — exit without saving any changes in the XPression project.

› Cancel — do not exit Trackless Studio. The changes in Trackless Studio are still saved, but not the 
changes to the XPression project.

• No — exit without saving any changes in Trackless Studio.

• Cancel — do not exit Trackless Studio.

3. In XPression, click File > Exit.

DashBoard

Low-level integration with DashBoard with an OpenGear frame card enables easy control from a remote 
DashBoard panel. The DashBoard panel is created automatically when connecting to Trackless Studio, utilizing 
direct real-time bidirectional controls for manual camera movements, events, and preset thumbnails.
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Control

Camera Position

Click and hold on the joystick to move the camera position left or right along the X-axis and forward or backward 
along the Z-axis.

Y-Axis Position

Click and hold on the handle to move the camera up or down along the Y-axis.

Camera Angle

Click and hold on the joystick to tilt the camera position up or down and rotate the camera position left or right.

Interpolation Speed

Use the slider to increase or decrease the speed of the animated camera movement. The default is 10.

Interpolation Effect

Bezier — select this option to use a bezier curve between the start of the animated camera movement and the end of 
the animated camera movement.

Linear — select this option to use a linear trajectory between the start of the animated camera movement and the 
end of the animated camera movement.

Disable — select this option to use a bezier curve between the start of the animated camera movement and the end 
of the animated camera movement.

Transition Frames

Use the slider to increase or decrease the duration in frames for the transition between presets. The default is 30.

Transition Effect

Cut — select this option to transition presets by using an instantaneous transition from one preset to the next.

Crossfade — select this option to transition the presets using a fade from one preset to the other.

Through Black — select this option to transition the presets by fading into, and then, from black.

Additive — select this option to transition the presets by gradually adding light to the image.

Saturate — select this option to transition the presets using saturation.

Right to Left — select this option to push a preset out to the left while the next preset enters from the right.

Left to Right — select this option to push a preset out to the right while the next preset enters from the left.

Top to Bottom — push a preset out the bottom while the next preset enters from the top.

Bottom to Top — push a preset out the top while the next preset enters from the bottom.

Diverge — transition a preset by splitting it into multiple pieces.

Pixelate — transition a preset by making it appear as though it is at a lower resolution.

Sine Wave — transition a preset by using a sine wave pattern.

Shrink — transition a preset by shrinking it.
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Camera Presets

In this tab, click a preset thumbnail (e.g. Preset 1-1, Preset 1-2, etc.) to select it. Click multiple preset thumbnails in 
a row to add them to the Trackless Queued Commands List. When selecting the presets, it helps to keep the 
camera speed in the Camera Movement section slow (e.g. 10%).

Events

In this tab, click an Event button to trigger a pre-configured event.

For More Information on...

• events, refer to “Settings - Events / Sequences” on page 4–12.
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Secondary Interfaces
Trackless Studio can be also controlled from a web interface.

Web GUI

Trackless Studio includes an internal web server for calling camera presets and events from web browser enabled 
devices such as Android WiFi tablets and IPad WiFi, among others.

Camera Presets

Use the Camera Presets interface to control the selection of camera movements. Click Home to return to the web 
GUI homepage.
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Events

Use the Events interface to trigger pre-configured events in Trackless Studio. Click Go Back to return to the 
previous web GUI page that was visited. Click Home to return to the web GUI homepage.
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Appendix A - Settings
This appendix covers the following settings for XPression and Trackless Studio:

• XPression Setup Recommendations

• Windows 7 Setting Recommendations

• TCP Ports Conflict

• View Trackless Studio Logs and XPression Debug Monitor

XPression Setup Recommendations
• At least one output framebuffer (configured in the Inputs / Outputs tab in the XPression Hardware Setup 

dialog box).

• Select the Keep Input Active check box in the Input Options section of the Inputs / Outputs tab in the 
Hardware Setup dialog box.
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• Select the Enable anti-flicker filter for interlaced SD output modes check box in the Output Options section 
of the Inputs / Outputs tab in the Hardware Setup dialog box. Also, select the Enable softening filter check 
box and use the Softness Level box to enter or select a level of 3.0 to soften the video image.

• Higher anti alias values can lead to low performance. From the Hardware Renderer section of the XPression 
Preferences dialog box, 8x CSAA High Quality is recommended as the Anti Alias setting.
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Performance Recommendations

If there is noticeable reduction in performance in the output, it is recommended to adjust the following settings:

Output Framebuffer

In XPression, increase the queue size of the output framebuffer in the Output tabs of the Matrox XMIO - 
Framebuffer Setup to improve performance.

In the Hardware Frame Buffer Queue section, use the Queue Size box to increase the size of the framebuffer 
queue and click Apply and then OK.

Windows 7 Setting Recommendations

Fonts

Adjust Windows font size for Trackless Studio.

In Control Panel, select Display > Smaller - 100% (default).
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Windows Themes and GUI Effects

Disable any Windows themes and GUI effects.

To disable Windows themes:

1. In Control Panel, select Personalization.

The Change the visuals and sounds on your computer section opens.

2. In the Basic and High Contrast Themes, click Windows 7 Basic.
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To disable GUI effects:

1. In Control Panel, select System > Advanced system settings.

The Advanced tab of the System Properties window opens.

2. In the Performance section, click Settings.

The Performance Options window opens.
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3. Select Adjust for best performance.

4. Click Apply.

5. Click OK.

The Performance Options window closes.

6. Click OK.

The System Properties window closes.

Media Preview

Media preview requires DirectShow Codecs installed, for example:

• Apple QuickTime, for Apple Quicktime .MOV.

• K-Lite Codec Pack, for other common video file formats (basic package at a minimum).

Media assets must be encoded by XPression.

TCP Ports Conflict

Web Server

Check that no other applications are currently using the same ports that Trackless Studio uses, especially the port 
being used for the Trackless Studio web server (default 80).

You can list all the services using port 80 with the following command on Windows Command Prompt:

C:\Users\XPression>netstat -aon | findstr :80 
  TCP    0.0.0.0:80             0.0.0.0:0              LISTENING       61540 

Then, when you get the Process Id (for example 61450), you can look for the application name using the following 
command prompt command:

C:\Users\XPression>tasklist /svc /FI "PID eq 61540" 

https://www.apple.com/quicktime/download/
http://www.codecguide.com/download_k-lite_codec_pack_basic.htm
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Common applications such as Skype, Microsoft IIS, and Microsoft SQL Server uses port 80.

You can modify the Trackless web port to use a port other than 80 or you can disable the other external conflicting 
services.

Image Name                     PID Services 
========================= ======== ============================================ 
Skype.exe                    61540 N/A 

To disable other external conflicting services:

1. Click Control Panel > Administrative Tools.

The Administrative Tools browser opens.

2. Double click Services.

The Services window opens.

3. Select the following items to disable by stopping the service:

• Web Deployment Agent Service

• World Wide Web Publishing Service

• Microsoft Internet Information Services

You can also disable the IIS services from the Programs and Features option in the Control Panel.
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To disable the IIS services:

1. Click Control Panel > Programs and Features > Turn Windows features on or off.

The Windows Features window opens.

2. Locate Internet Information Services in the list and de-select the check box.

3. Click OK.

For More Information on...

• how to disable IIS services, check the following Microsoft Support link: 

https://support.microsoft.com/en-us/kb/321141 

Microsoft SQL Server also uses port 80 for reporting services. You can modify the TCP port inside Reporting 
Services Configuration Manager > Web Service URL.

View Trackless Studio Logs and XPression Debug Monitor

Logs

Access the Trackless Studio logs to view activity by opening the logs folder. The logs folder can be found using the 
following file path: C:\XPressionApps\Trackless Studio\logs.

Debug Monitor

The XPression Debug Monitor icon ( ) appears in the Windows toolbar when Trackless Studio is launched. Click 
it to open the XPression Debug Monitor window:

https://support.microsoft.com/en-us/kb/321141
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Contact Us

Contact our friendly and professional support representatives for the following:

• Name and address of your local dealer

• Product information and pricing

• Technical support

• Upcoming trade show information

Visit Us

Visit our website for:

• Company information and news

• Related products and full product lines

• Online catalog

• Testimonials

Technical        
Support

Telephone: +1 613 • 652 • 4886

After Hours Emergency: +1 613 • 349 • 0006

Email: techsupport@rossvideo.com

General     
Information

Telephone: +1 613 • 652 • 4886

Fax: +1 613 • 652 • 4425

Email: solutions@rossvideo.com

Website: http://www.rossvideo.com
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