Thank You for Choosing Ross

You’ve made a great choice. We expect you will be very happy with your purchase of Ross Technology. Our mission is to:

1. Provide a Superior Customer Experience
   • offer the best product quality and support
2. Make Cool Practical Technology
   • develop great products that customers love

Ross has become well known for the Ross Video Code of Ethics. It guides our interactions and empowers our employees. I hope you enjoy reading it below.

If anything at all with your Ross experience does not live up to your expectations be sure to reach out to us at solutions@rossvideo.com.

David Ross
CEO, Ross Video
dross@rossvideo.com

Ross Video Code of Ethics

Any company is the sum total of the people that make things happen. At Ross, our employees are a special group. Our employees truly care about doing a great job and delivering a high quality customer experience every day. This code of ethics hangs on the wall of all Ross Video locations to guide our behavior:

1. We will always act in our customers’ best interest.
2. We will do our best to understand our customers’ requirements.
3. We will not ship crap.
4. We will be great to work with.
5. We will do something extra for our customers, as an apology, when something big goes wrong and it’s our fault.
6. We will keep our promises.
7. We will treat the competition with respect.
8. We will cooperate with and help other friendly companies.
9. We will go above and beyond in times of crisis. *If there’s no one to authorize the required action in times of company or customer crisis - do what you know in your heart is right. (You may rent helicopters if necessary.*)
Trackless Studio · User Guide

- Ross Part Number: 3500DR-018-02
- Release Date: October 5, 2018.
- Software Issue: 02

The information contained in this Guide is subject to change without notice or obligation.

Copyright

©2018 Ross Video Limited, Ross®, and any related marks are trademarks or registered trademarks of Ross Video Limited. All other trademarks are the property of their respective companies. PATENTS ISSUED and PENDING. All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted in any form or by any means, mechanical, photocopying, recording or otherwise, without the prior written permission of Ross Video. While every precaution has been taken in the preparation of this document, Ross Video assumes no responsibility for errors or omissions. Neither is any liability assumed for damages resulting from the use of the information contained herein.

Patents


Notice

The material in this manual is furnished for informational use only. It is subject to change without notice and should not be construed as commitment by Ross Video Limited. Ross Video Limited assumes no responsibility or liability for errors or inaccuracies that may appear in this manual.
Important Regulatory and Safety Notices to Service Personnel

Before using this product and any associated equipment, refer to the "Important Safety Instructions" listed below so as to avoid personnel injury and to prevent product damage.

Products may require specific equipment, and/or installation procedures be carried out to satisfy certain regulatory compliance requirements. Notices have been included in this publication to call attention to these Specific requirements.

Symbol Meanings

**Protective Earth** — This symbol identifies a Protective Earth (PE) terminal, which is provided for connection of the supply system’s protective earth (green or green/yellow) conductor.

The exclamation point within an equilateral triangle is intended to alert the user to the presence of important operating and maintenance (servicing) instructions in the literature accompanying the product. Failure to heed this information may present a risk of damage or injury to persons or equipment.

**Warning** — The symbol with the word "Warning" within the equipment manual indicates a potentially hazardous situation, which if not avoided, could result in death or serious injury.

**Caution** — The symbol with the word "Caution" within the equipment manual indicates a potentially hazardous situation, which if not avoided, may result in minor or moderate injury. It may also be used to alert against unsafe practices.

**Notice** — The symbol with the word "Notice" within the equipment manual indicates a situation, which if not avoided, may result in major or minor equipment damage or a situation which could place the equipment in a non-compliant operating state.

**Warning Hazardous Voltages** — The lightning flash with arrowhead symbol within an equilateral triangle is intended to alert the user to the presence of uninsulated "dangerous voltage" within the product's enclosure that may be of sufficient magnitude to constitute a risk of shock to persons.

**ESD Susceptibility** — This symbol is used to alert the user that an electrical or electronic device or assembly is susceptible to damage from an ESD event.
Important Safety Instructions

1) Read these instructions.
2) Follow all instructions and heed all warnings.
3) Refer all servicing to qualified service personnel.
4) The equipment's AC appliance inlets are the means to disconnect the product from the AC Mains and must remain readily operable for this purpose.
5) Parts of the equipment's power supplies can still present a safety hazard even when the product is in the "Off" state. To avoid the risk of electrical shock and to completely disconnect the apparatus from the AC Mains, remove all power supply cords from the product's AC appliance inlets prior to servicing.
6) The product chassis is to be rack mounted only. To ensure safe operation and maintain long-term system reliability, proper installation requires that the front and back area of the chassis remain clear of obstructions so as not to restrict airflow.

**Warning**
7) Indoor Use: To reduce the risk of fire or electric shock, do not expose this apparatus to rain or moisture.

**Warning**
8) This apparatus when equipped with multiple power supplies can generate high leakage currents. To reduce the risk of electric shock to operator and service personnel the following requirements must be met:

   a) The equipment is to be installed in a restricted access area.
      A restricted access area is one where access can only be gained by SERVICE PERSONS or by USERS who have been instructed about the reasons for the restrictions applied to the location and about any precautions that shall be taken; and access is through the use of a TOOL or lock and key, or other means of security, and is controlled by the authority responsible for the location;
   b) the building installation shall provide a means for connection to protective earth and;
   c) the product's protective earth terminal is connected to the facility's protective earth using a 1.5mm2 (14AWG) conductor and a #8 1.5mm2 ring terminal and;
   d) a SERVICE PERSON shall check whether or not the socket-outlet from which the equipment is to be powered provides a connection to the building protective earth.

**Caution**
9) This apparatus contains a Lithium battery, which if replaced incorrectly, or with an incorrect type, may cause an explosion. Replace only with the same type recommended by the manufacturer. Dispose of used batteries according to the manufacturer's instruction by qualified service personnel.

EMC Notices

**US**

**FCC Part 15**

This equipment has been tested and found to comply with the limits for a class A Digital device, pursuant to part 15 of the FCC Rules. These limits are designed to provide reasonable protection against harmful interference when the equipment is operated in a Commercial environment. This equipment generates, uses, and can radiate radio frequency energy and, if not installed and used in accordance with the instruction manual, may cause harmful interference to radio communications. Operation of this equipment in a residential area is likely to cause harmful interference in which case the user will be required to correct the interference at his own expense.

**Notice** Changes or modifications to this equipment not expressly approved by Ross Video Ltd. could void the user’s authority to operate this equipment.
CANADA
This Class “A” digital apparatus complies with Canadian ICES-003.

Cet appareil numérique de la classe “A” est conforme à la norme NMB-003 du Canada.

EUROPE
This equipment is in compliance with the essential requirements and other relevant provisions of CE Directive 93/68/EEC.

INTERNATIONAL
This equipment has been tested to CISPR 22:1997 along with amendments A1:2000 and A2:2002 and found to comply with the limits for a Class A Digital device.

Notice This is a Class A product. In domestic environments, this product may cause radio interference, in which case the user may have to take adequate measures.

Warranty and Repair Policy
Ross Video Limited (Ross) warrants its XPression systems to be free from defects under normal use and service for the following time periods from the date of shipment:

• XPression Server — 12 months
• XPression Software Upgrades — 12 months free of charge
• System and Media hard drives — 12 months

If an item becomes defective within the warranty period Ross will repair or replace the defective item, as determined solely by Ross.

Warranty repairs will be conducted at Ross, with all shipping FOB Ross dock. If repairs are conducted at the customer site, reasonable out-of-pocket charges will apply. At the discretion of Ross, and on a temporary loan basis, plug in circuit boards or other replacement parts may be supplied free of charge while defective items undergo repair. Return packing, shipping, and special handling costs are the responsibility of the customer.

This warranty is void if products are subjected to misuse, neglect, accident, improper installation or application, or unauthorized modification.

In no event shall Ross Video Limited be liable for direct, indirect, special, incidental, or consequential damages (including loss of profit). Implied warranties, including that of merchantability and fitness for a particular purpose, are expressly limited to the duration of this warranty.

This warranty is TRANSFERABLE to subsequent owners, subject to Ross’ notification of change of ownership.

Extended Warranty
For customers that require a longer warranty period, Ross offers an extended warranty plan to extend the standard warranty period by one year increments. For more information about an extended warranty for your XPression system, contact your regional sales manager.
Environmental Information

The equipment that you purchased required the extraction and use of natural resources for its production. It may contain hazardous substances that could impact health and the environment.

To avoid the potential release of those substances into the environment and to diminish the need for the extraction of natural resources, Ross Video encourages you to use the appropriate take-back systems. These systems will reuse or recycle most of the materials from your end-of-life equipment in an environmentally friendly and health conscious manner.

The crossed-out wheeled bin symbol invites you to use these systems.

If you need more information on the collection, reuse, and recycling systems, please contact your local or regional waste administration.

You can also contact Ross Video for more information on the environmental performances of our products.

Company Address

**Ross Video Limited**
8 John Street
Iroquois, Ontario
Canada, K0E 1K0

**Ross Video Incorporated**
P.O. Box 880
Ogdensburg, New York
USA 13669-0880

**General Business Office:** (+1) 613 • 652 • 4886
**Fax:** (+1) 613 • 652 • 4425

**Toll Free Technical Support:** 1-844-652-0645 (North America)
+800 1005 0100 (International)

Alternately, you can contact:

**Technical Support:** (+1) 613 • 652 • 4886
**After Hours Emergency:** (+1) 613 • 349 • 0006

**E-mail for Technical Support:** techsupport@rossvideo.com
**E-mail for General Information:** solutions@rossvideo.com
**Website:** http://www.rossvideo.com
Contents

Introduction ....................................... 1
  About This Guide .................................1-1
  Documentation Conventions ................1-1
  Getting Help ....................................1-1
  Contacting Technical Support ..............1-2

Technical Overview .......................... 2
  Trackless Studio Requirements ...........2-1
  Hardware Connections ........................2-2
  Audio Delay Options ............................2-3
    AES Audio ............................................2-3
    Embedded Audio..................................2-3

Setup ................................................ 3
  Trackless Studio Settings ....................3-1
  RossTalk Commands...........................3-7
  Shotbox..............................................3-10
  Trackless Studio in DashBoard...........3-11
  Trackless Studio VISCA Controller ....3-14
  Trackless Studio and Graphite...........3-15
      Configuring Graphite .......................3-15
      Setting up the Chroma Keyer ......3-16
      Graphite and the RAVE Audio Engine3-21

Operation.......................................... 4
  Trackless Studio Interface ...................4-1
    Menus .................................................. 4-2
      File ................................................. 4-2
      XPression ......................................... 4-2
      Help ............................................... 4-3
    Playout .............................................. 4-4
    Settings ............................................ 4-8
      Chroma Keyer .................................... 4-8
      Media............................................. 4-11
      Events / Sequences ....................4-13
    Shotbox ........................................... 4-18
      Camera Control Shortcuts ........4-19
    Shutting Down Trackless Studio ....4-23

DashBoard.......................................... 5
  Control ............................................. 5-1
  Camera Presets .................................. 5-2
  Events ............................................. 5-2

Web Interface ................................. 6
  Accessing the Web Interface ..............6-1
  Camera Presets ..................................6-2
  Events ............................................. 6-2

Appendix A: Settings ......................... A
  XPression Setup ..................................A-1
    Performance Recommendations ..........A-4
    Memory Cache ................................ A-4
    Output Framebuffer ......................... A-4
  Windows 7 Settings .........................A-6
    Fonts .............................................. A-6
    Windows Themes and GUI Effects ....A-6
    Media Preview ................................ A-9
  TCP Ports Conflict ............................ A-10
  Web Server ....................................... A-10
  View Trackless Studio Logs ............A-12
  View XPression Debug Monitor ..........A-12

Appendix A: Settings ......................... A
  XPression Setup ..................................A-1
    Performance Recommendations ..........A-4
    Memory Cache ................................ A-4
    Output Framebuffer ......................... A-4
  Windows 7 Settings .........................A-6
    Fonts .............................................. A-6
    Windows Themes and GUI Effects ....A-6
    Media Preview ................................ A-9
  TCP Ports Conflict ............................ A-10
  Web Server ....................................... A-10
  View Trackless Studio Logs ............A-12
  View XPression Debug Monitor ..........A-12
Introduction

Trackless Studio provides a cost-effective virtual studio solution, using a small studio space and fixed cameras. Encoded camera heads and pedestals are not required. Complex camera movements and simulation of dramatic moving “jib” shots are possible, using the virtual cameras within the Trackless Studio virtual sets. The intuitive interface provides controls for multiple camera presets, transitions, and the ability to trigger events to manage media within the set and add insert graphics on layers above the virtual set shots.

Trackless Studio can support multiple cameras, based on the input capacity (1, 2 or 4 inputs) of the host XPression engine. The application can be operated remotely by a touch screen, a customized XKeys Shotbox, Ross Video Dashboard, Carbonite (using Ross Talk) or a Web browser.

About This Guide

This user guide describes XPression Trackless Studio, its configuration, and operation.

If, at any time, you have a question pertaining to the installation or operation of XPression Trackless Studio, please contact us at the numbers listed in the section Contacting Technical Support. Our technical staff are always available for consultation, training, or service.

Documentation Conventions

Special text formats are used in this guide to identify parts of the user interface, text that a user must enter, or a sequence of menus and submenus that must be followed to reach a particular command.

**Bold text**

Bold text is used to identify a user interface element such as a dialog box, menu item, or button.

For example:

In the **3D Model Files** section, use the **Mode** list to select the folder used to store 3D model files.

**Courier text**

Courier text is used to identify text that a user must enter.

For example:

Enter **localhost** when the DataLinq server is running on the same computer as XPression.

> Menu arrows are used in procedures to identify a sequence of menu items that you must follow.

For example, if a step reads “Display > **Widgets**,“ you would click the **Display** menu and then click **Widgets**.

Getting Help

The XPression Trackless Studio User Guide is supplied as print-ready PDF files. Locate the guide in C:\Archives to open the PDF in Adobe® Reader® for viewing or printing.
Contacting Technical Support

At Ross Video, we take pride in the quality of our products, but if problems occur, help is as close as the nearest telephone.

Our 24-hour Hot Line service ensures you have access to technical expertise around the clock. After-sales service and technical support is provided directly by Ross Video personnel. During business hours (eastern time), technical support personnel are available by telephone any time. After hours and on weekends, a direct emergency technical support phone line is available. If the technical support person who is on call does not answer this line immediately, a voice message can be left and the call will be returned shortly. This team of highly trained staff is available to react to any problem and to do whatever is necessary to ensure customer satisfaction.

- **Technical Support:** (+1) 613-652-4886
  - 1-844-652-0645 (North America)
  - +800 1005 0100 (International)
- **After Hours Emergency:** (+1) 613-349-0006
- **E-mail:** techsupport@rossvideo.com
- **Website:** https://www.rossvideo.com
Technical Overview

This chapter covers the following topics:

- Trackless Studio Requirements
- Hardware Connections
- Audio Delay Options

Trackless Studio Requirements

- Minimum of an XPression M4 machine (or equivalent); XPression M5 for optimal performance
- XPression Studio or BlueBox edition software version specified for this version of Trackless Studio (contact Technical Support to make sure you have the correct version). See Contacting Technical Support.
- Trackless license dongle
- XPression Chroma Key and DataLinQ licenses
- Trackless Studio GUI requires a 1920 x 1080 Windows® display resolution
- Firewall must be disabled or properly configured to enable required network communication

To view more information on Trackless Studio for XPression, click Help > About in the Trackless Studio interface.
Hardware Connections

The following diagram describes a sample hardware connection configuration for running Trackless Studio using two customer-supplied cameras and optional controllers (shotbox and Ross Carbonite switcher):

1. Ross XPression Studio or BlueBox Edition systems running on XPression M4 hardware (or equivalent) or higher
2. 1 Full HD SDI Camera connected to Input A on XPression
3. 1 Full HD SDI Camera connected to Input B on XPression
   If using a 4 input XPression system, 1 Full HD SDI Camera connected to Input C on XPression; 1 Full HD SDI Camera connected to Input D on XPression.
4. Shotbox connected to XPression via 1 USB 2.0 port
5. Ross Carbonite switcher connected to the same local area network as the XPression machine
6. 1 Full HD 1920 x 1080 display for the Trackless Studio GUI
Audio Delay Options

The following diagrams demonstrate the AES and embedded audio delay options when syncing audio in Trackless Studio.

AES Audio

Embedded Audio
Setup

This chapter covers the following topics:

- Trackless Studio Settings
- RossTalk Commands
- Shotbox
- Trackless Studio in DashBoard
- Trackless Studio VISCA Controller
- Trackless Studio and Graphite

Trackless Studio Settings

☐ Always launch XPression and open your virtual set project before launching Trackless Studio.

The first time you use Trackless Studio, you will need to configure the Trackless Studio Settings.

To open Trackless Studio Settings:

- Click Trackless Studio Settings in the Start menu or click the Trackless Studio Settings icon on the desktop.

The Trackless Studio Settings dialog box opens on the Scenes tab.

![Trackless Studio Settings - Scenes Tab](image)

**Figure 3.1 Trackless Studio Settings - Scenes Tab**

To configure the Scene settings:

1. Click the Scenes tab.
2. In the Name box, enter a scene name from the XPression project.
   
   The default names used by Trackless Studio are Scene1, Scene2, Scene3, and Scene4.
3. In the Home Position fields, enter or use the arrows to select the X, Y, and Z values for the default position of the virtual camera in the scene.
   
   The default positions are X:0, Y:0, and Z:0.
4. Use the Camera 0x Orientation drop-down for each talent to set the orientation of the camera input for up to 4 talents in each scene.
The options are:

- **Horizontal**
- **Rotate 90° Right**
- **Rotate 90° Left**

The default for **Talent 1** is **Rotate 90° Right**. The default for **Talent 2**, **Talent 3**, and **Talent 4** is **Horizontal**.

5. Repeat Steps 2 to 4 for each scene.

**To configure the Effects settings:**

1. Click the **Effects** tab.

![Figure 3.2 Trackless Studio Settings - Effects Tab](image)

2. In the **Camera Animation (Interpolation)** section, use the **Default** drop-down to select a default interpolation for the camera movement between presets.

   The options are:

   - **Bezier (Smooth)** — select this option to use a bezier curve between the start of the animated camera movement and the end of the animated camera movement.
   - **Linear** — select this option to use a linear trajectory between the start of the animated camera movement and the end of the animated camera movement.
   - **Disable** — select this option to cut directly from one preset to the other.

   The default is **Bezier (Smooth)**.

3. In the **Max Speed (px/s)** field enter or use the arrows to select the maximum interpolation speed in pixels per second.

   The default is 300.

4. In the **Default Speed (px/s)** field enter or use the arrows to select the default speed of the interpolation in pixels per second.

   The default is 30.

   The **Default Speed** cannot be the same as the **Max Speed**.

5. In the **Transition** section, use the **Default Effect** list to select a default transition between scenes.

   The options are:

   - **Dissolve** — select a gradual transition where a preset dissolves into the next preset:
     - **Crossfade** — transition the presets using a fade from one preset to the other.
     - **Over Black** — transition the presets by fading into, and then, from black.
     - **Additive** — transition the presets by gradually adding light to the image.
Saturate — transition the presets using saturation.

• Push — select a sliding transition where the preset pushes out the previous preset:
  › Right to Left — push a preset out to the left while the next preset enters from the right.
  › Left to Right — push a preset out to the right while the next preset enters from the left.
  › Top to Bottom — push a preset out the bottom while the next preset enters from the top.
  › Bottom to Top — push a preset out the top while the next preset enters from the bottom.

• Distort — select a transition where a preset is warped out:
  › Diverge — transition a preset by splitting it into multiple pieces.
  › Pixelate — transition a preset by making it appear as though it is at a lower resolution.
  › Sine Wave — transition a preset by using a sine wave pattern.
  › Shrink — transition a preset by shrinking it.

• Cut — select a clean cut between presets:
  › Cut — transition presets by using an instantaneous transition from one preset to the next.

The default is Crossfade.

6. In the Max Duration (frames) field enter or use the arrows to select the maximum duration speed in frames for the transition between scenes.
   The default is 120.

7. In the Default Duration (frames) field enter or use the arrows to select the default speed of the scene transition in frames.
   The default is 30.

To configure the Network settings:

1. Click the Network tab.

   ![Figure 3.3 Trackless Studio Settings - Network Tab](image)

2. In the Web Server section, in the Port field enter or use the arrows to select a port where web connections will be accepted for the web server interface and then select the Enabled checkbox to enable the web server interface.
   See Web Server for more information.
   The default Web Server port is 8083.

3. In the PBus Server section, in the Port field enter or use the arrows to select a port where web connections will be accepted for the PBus server interface and then select the Enabled checkbox to enable the PBus server interface.
The default **PBus Server** port is **7790**.

4. In the **RossTalk In** section, in the **Port** field enter or use the arrows to select a port where RossTalk commands will be received and then select the **Enabled** checkbox to enable the RossTalk protocol.

   The default **RossTalk In** port is **7789**. This must be a different Smart GPI/RossTalk setup port than on the local XPression machine.

5. In the **DashBoard Controller (openGear)** section, in the **Frame Port** field enter or use the arrows to select a port where incoming commands will be received.

   The default **Frame** port is **5253**.

6. In the **Web Port** field enter or use the arrows to select the port used by openGear.

   The default **Web** port is **8080**.

7. Then select the **Enabled** checkbox to enable the openGear protocol.

8. In the **Sony Visca Controller** section, in the **Port** field enter or use the arrows to select the port to which the VISCA device is connected and then select the **Enabled** checkbox to enable the VISCA protocol.

   The default port is **12907**.

**To configure the Graphite settings:**

1. If you will be using Graphite, click the **Graphite** tab.

   ![Figure 3.4 Trackless Studio Settings - Graphite Tab](image)

2. Select the **Hide Chroma Keyer Tab if detected** checkbox.

3. Select the **Disable Software Chroma Keyer if detected** checkbox.

4. Click **Save** or if you are ready to launch Graphite, click **Save & Launch**.

   By default both options are checked.

   For more information, see the following topics:

   - Trackless Studio and Graphite
   - Setting up the Chroma Keyer

**To configure the Other settings:**

1. Click the **Other** tab.

   The prefixes for XPression objects cannot be modified and are for reference only. When creating objects in XPression that will be used in Trackless Studio events/sequences, make sure the object names contain these prefixes.
2. In the **Manual Controls** section, in the **Xkeys Sensitivity** field enter or use the arrows to select the controller sensitivity multiplier if using a shotbox.
   
   The default is 0.050.

3. If you are using a 3DConnexion controller, in the **3DConnexion Sensitivity** field enter or use the arrows to select the controller sensitivity multiplier.
   
   The default is 0.002.

4. In the **Touch Navigation Sensitivity** field enter or use the arrows to select the sensitivity of the arrows in the Production Control window when using the touchscreen.
   
   The default is 1.000.

5. In the **General** section, from the **Language** drop-down select the display language for the Trackless Studio interface. The options are:
   
   - **English**
   - **Spanish**
   
   The default is **English**.

6. In the **Frame Rate** field enter or use the arrows to select the frame rate at which XPression projects will be used.
   
   The default is 29.97.

7. In the **Default Layer** field enter or use the arrows to select the default layer on which scenes will be taken online.
   
   The default is -999.

8. In the **Default UI Display** field enter or use the arrows to select the Windows monitor where the application is displayed.
   
   The default is 1.

9. From the **Default Output Channel** drop-down, select the framebuffer where scenes will be taken online.
   
   The default is 1.

10. Select the **Global Camera** checkbox when you are using a global camera in any of your XPression project scenes.
    
    This option allows you to keep an object in the same position, relative to the virtual scene, even when the camera for the virtual scene is moving.
    
    By default, the checkbox is cleared (disabled).
To store the Trackless Studio settings:

1. In any tab, press **Save** to store the current settings.
   
   **OR**
   
   Press **Save & Launch** to store the current settings and launch the application.

2. If you select **Save & Launch**, a file browser opens.

3. Locate and select your XPression .xpf file virtual set project.

4. Click **Open**.

   Trackless Studio finishes loading and opens.

To reset the Trackless Studio settings:

- In any tab, click **Reset to Default**.

  The settings in every tab will be reset to the original settings at installation.

- Do not modify objects in the XPression project while running Trackless Studio. Always exit Trackless Studio first, modify the required elements, and then start Trackless Studio again.

- When **Save & Launch** is selected in the **Trackless Studio Settings** dialog box, a Trackless software configuration file is created (settings.xml) and stored in `C:\XPressionApps\Trackless Studio`.

  Save this configuration file in a safe location and manually replace it after performing a Trackless Studio upgrade in order to restore previous talent camera orientations, effects, network settings, and general settings.
RossTalk Commands

- The *inbound* RossTalk port is configured in the Trackless Studio Settings and must be a different Smart GPI/RossTalk setup port than on the local XPression machine.
- *Outbound* RossTalk commands can only be used to control the **Sequencer** in an XPression instance that is not on the same machine as Trackless Studio.
- When using RossTalk commands to trigger Trackless Studio events, use port **7789**, configured in the Trackless Studio Settings application in **Network > RossTalk In**
- When using RossTalk commands to trigger XPression Studio scenes, use the same port that was configured in XPression in **Edit > Hardware Setup > GPI Boards > Incoming Network Settings > TCP Port**.

The following table provides the RossTalk commands for Scenes 1 and 2.

<table>
<thead>
<tr>
<th>Scene 1</th>
<th>Scene 2</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Command</strong></td>
<td><strong>Extra Parameters</strong></td>
</tr>
<tr>
<td>GPI</td>
<td>01</td>
</tr>
<tr>
<td>GPI</td>
<td>10</td>
</tr>
<tr>
<td>GPI</td>
<td>11</td>
</tr>
<tr>
<td>GPI</td>
<td>12</td>
</tr>
<tr>
<td>GPI</td>
<td>13</td>
</tr>
<tr>
<td>GPI</td>
<td>14</td>
</tr>
<tr>
<td>GPI</td>
<td>15</td>
</tr>
<tr>
<td>GPI</td>
<td>16</td>
</tr>
<tr>
<td>GPI</td>
<td>17</td>
</tr>
<tr>
<td>GPI</td>
<td>18</td>
</tr>
<tr>
<td>GPI</td>
<td>19</td>
</tr>
<tr>
<td>GPI</td>
<td>80</td>
</tr>
<tr>
<td>GPI</td>
<td>81</td>
</tr>
<tr>
<td>GPI</td>
<td>82</td>
</tr>
<tr>
<td>GPI</td>
<td>83</td>
</tr>
<tr>
<td>GPI</td>
<td>84</td>
</tr>
<tr>
<td>GPI</td>
<td>85</td>
</tr>
<tr>
<td>GPI</td>
<td>86</td>
</tr>
<tr>
<td>GPI</td>
<td>87</td>
</tr>
<tr>
<td>GPI</td>
<td>88</td>
</tr>
<tr>
<td>GPI</td>
<td>89</td>
</tr>
</tbody>
</table>
The following table provides the RossTalk commands for Scenes 3 and 4.

<table>
<thead>
<tr>
<th>Command</th>
<th>Extra Parameters</th>
<th>Description</th>
<th>Command</th>
<th>Extra Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GPI</td>
<td>03</td>
<td>Call Scene 03</td>
<td>GPI</td>
<td>04</td>
<td>Call Scene 04</td>
</tr>
<tr>
<td>GPI</td>
<td>30</td>
<td>Call Scene 3 Preset 1</td>
<td>GPI</td>
<td>40</td>
<td>Call Scene 4 Preset 1</td>
</tr>
<tr>
<td>GPI</td>
<td>31</td>
<td>Call Scene 3 Preset 2</td>
<td>GPI</td>
<td>41</td>
<td>Call Scene 4 Preset 2</td>
</tr>
<tr>
<td>GPI</td>
<td>32</td>
<td>Call Scene 3 Preset 3</td>
<td>GPI</td>
<td>42</td>
<td>Call Scene 4 Preset 3</td>
</tr>
<tr>
<td>GPI</td>
<td>33</td>
<td>Call Scene 3 Preset 4</td>
<td>GPI</td>
<td>43</td>
<td>Call Scene 4 Preset 4</td>
</tr>
<tr>
<td>GPI</td>
<td>34</td>
<td>Call Scene 3 Preset 5</td>
<td>GPI</td>
<td>44</td>
<td>Call Scene 4 Preset 5</td>
</tr>
<tr>
<td>GPI</td>
<td>35</td>
<td>Call Scene 3 Preset 6</td>
<td>GPI</td>
<td>45</td>
<td>Call Scene 4 Preset 6</td>
</tr>
<tr>
<td>GPI</td>
<td>36</td>
<td>Call Scene 3 Preset 7</td>
<td>GPI</td>
<td>46</td>
<td>Call Scene 4 Preset 7</td>
</tr>
<tr>
<td>GPI</td>
<td>37</td>
<td>Call Scene 3 Preset 8</td>
<td>GPI</td>
<td>47</td>
<td>Call Scene 4 Preset 8</td>
</tr>
<tr>
<td>GPI</td>
<td>38</td>
<td>Call Scene 3 Preset 9</td>
<td>GPI</td>
<td>48</td>
<td>Call Scene 4 Preset 9</td>
</tr>
<tr>
<td>GPI</td>
<td>39</td>
<td>Call Scene 3 Preset 10</td>
<td>GPI</td>
<td>49</td>
<td>Call Scene 4 Preset 10</td>
</tr>
<tr>
<td>GPI</td>
<td>100</td>
<td>Save Scene 3 Preset 1</td>
<td>GPI</td>
<td>110</td>
<td>Save Scene 4 Preset 1</td>
</tr>
<tr>
<td>GPI</td>
<td>101</td>
<td>Save Scene 3 Preset 2</td>
<td>GPI</td>
<td>111</td>
<td>Save Scene 4 Preset 2</td>
</tr>
<tr>
<td>GPI</td>
<td>102</td>
<td>Save Scene 3 Preset 3</td>
<td>GPI</td>
<td>112</td>
<td>Save Scene 4 Preset 3</td>
</tr>
<tr>
<td>GPI</td>
<td>103</td>
<td>Save Scene 3 Preset 4</td>
<td>GPI</td>
<td>113</td>
<td>Save Scene 4 Preset 4</td>
</tr>
<tr>
<td>GPI</td>
<td>104</td>
<td>Save Scene 3 Preset 5</td>
<td>GPI</td>
<td>114</td>
<td>Save Scene 4 Preset 5</td>
</tr>
<tr>
<td>GPI</td>
<td>105</td>
<td>Save Scene 3 Preset 6</td>
<td>GPI</td>
<td>115</td>
<td>Save Scene 4 Preset 6</td>
</tr>
<tr>
<td>GPI</td>
<td>106</td>
<td>Save Scene 3 Preset 7</td>
<td>GPI</td>
<td>116</td>
<td>Save Scene 4 Preset 7</td>
</tr>
<tr>
<td>GPI</td>
<td>107</td>
<td>Save Scene 3 Preset 8</td>
<td>GPI</td>
<td>117</td>
<td>Save Scene 4 Preset 8</td>
</tr>
<tr>
<td>GPI</td>
<td>108</td>
<td>Save Scene 3 Preset 9</td>
<td>GPI</td>
<td>118</td>
<td>Save Scene 4 Preset 9</td>
</tr>
<tr>
<td>GPI</td>
<td>109</td>
<td>Save Scene 3 Preset 10</td>
<td>GPI</td>
<td>119</td>
<td>Save Scene 4 Preset 10</td>
</tr>
</tbody>
</table>
The following table provides additional RossTalk commands that can be used in either Trackless or XPression, or both, as indicated.

<table>
<thead>
<tr>
<th>Command</th>
<th>Extra Parameters</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>UP</td>
<td>N/A</td>
<td>Selects the item preceding the current item in the XPression sequence.</td>
</tr>
<tr>
<td>DOWN</td>
<td>N/A</td>
<td>Selects the item following the current item in the XPression sequence.</td>
</tr>
<tr>
<td>NEXT</td>
<td>N/A</td>
<td>Selects the next item in the selected Trackless Studio or XPression sequence.</td>
</tr>
<tr>
<td>TAKE</td>
<td>XXX</td>
<td>Selects the item identified in the Extra Parameters column from either the Trackless Studio or XPression sequence.</td>
</tr>
<tr>
<td>SEQI X</td>
<td>XXX</td>
<td>Selects the item identified in the Extra Parameters column from Trackless Studio. Command supported in 3rd party control systems only.</td>
</tr>
<tr>
<td>FOCUS X</td>
<td>XXX</td>
<td>Selects the sequence identified in the Extra Parameters column from either Trackless Studio or XPression. Command supported in 3rd party control systems only.</td>
</tr>
</tbody>
</table>
Trackless Studio Shotbox is an application that allows the user to configure the shortcuts for the optional shotbox controller and joystick. Use the drop-downs to select the shortcut to assign to the selected key.

The enabled **Pan on Handle Twist** checkbox indicates that Trackless Studio will pan the camera if the handle on the joystick is twisted.
Trackless Studio in DashBoard

You can use DashBoard to operate Trackless Studio, manually move the camera, call camera presets using the thumbnails, and call events using the buttons. This requires that you verify the DashBoard Controller settings in the Trackless Studio Settings application and then connect Trackless Studio to DashBoard.

You can also imbed audio, whether it comes already synced with the video or from a separate source, assign it to your XPression channels and control it through DashBoard.

To verify the DashBoard Controller settings in the Trackless Studio Settings application:

1. From the Windows Start menu, launch the Trackless Studio Settings application.
2. In the Network tab, in the DashBoard Controller (openGear) section, ensure that the Frame Port is set to 5253 and the Web Port is set to 8080 and that Enabled is checked.
3. Click Save & Launch.

To connect Trackless Studio to DashBoard:

1. Launch DashBoard from the desktop icon.
2. Click the Add button in the Basic Tree View toolbar to open the Select Equipment or Service Type to Add dialog.

![Select Equipment or Service Type to Add Dialog](image)

*Figure 3.7 Select Equipment or Service Type to Add Dialog*

3. Expand the openGear / DashBoard Connect folder.
4. Select TCP/IP DashBoard Connect or openGear Device and click Next.
   The New TCP openGear Frame Connection dialog opens.

5. In the IP Address field, enter the IP address of the computer running Trackless Studio.
   Do not click Detect Frame Information.

6. In the Display Name field, enter Trackless Studio.

7. Select the OGP Protocol option.

8. Set the Port to 5253 (default).

9. Select the Remember connection settings for this frame checkbox and click Finish.
   In the Basic Tree View, you’ll see that Trackless Studio as been added to the list.

10. Expand the Trackless Studio node and double-click the Trackless Studio openGear item to open the panel for manually moving the camera, calling camera presets using the thumbnails, and calling events using the buttons.
    The DashBoard panel is created automatically when connecting to Trackless Studio.
For More Information on...

- Trackless Studio in DashBoard, refer to **DashBoard**.
Trackless Studio VISCA Controller

Trackless Studio supports Sony VISCA protocol for using a Ross Carbonite Switcher joystick to manually move the virtual camera.

1. In the Trackless Studio Settings window, ensure that the Port in the Sony Visca Controller section of the Network tab is set to 12907 and Enabled.

2. In Carbonite, configure a new Sony VISCA camera device with the IP address of the XPression machine and the port configured in the Trackless Studio Settings (default 12907).
Trackless Studio and Graphite

Graphite is an all-in-one production system that merges a switcher, a single channel XPression 3D motion graphics system, a two channel clip server, and an advanced audio engine. Trackless Studio brings the power of Graphite into a virtual studio, with just stationary cameras and a small studio space. With Graphite, you can also take advantage of the more powerful hardware Chroma Keyer feature and ....

Remember to launch XPression before launching Trackless.

Configuring Graphite

To get Graphite and Trackless Studio working together, you need to configure XPression and the Trackless Studio Settings application.

To configure Graphite in XPression:

1. In XPression, go to Edit > Hardware Setup > Inputs/Outputs.

![Figure 3.10 XPression - Hardware Setup - Inputs/Outputs Tab](image)

2. In the Inputs/Outputs tab, expand the Graphite framebuffer.

3. For each input channel that will be used, double-click the channel, enable the Use Alpha Channel setting and click OK.
4. In XPression, click **File > Open Project** and open the project you want to run.

**To configure Graphite in Trackless Studio Settings:**

1. From the Windows **Start** menu, select **Trackless Studio Settings**.
2. In the **Graphite** tab, ensure that **Hide Chroma Keyer Tab if detected** and **Disable Software Chroma Keyer if detected** are selected.
3. Click **Save & Launch**.

**Setting up the Chroma Keyer**

To use the hardware Chroma Keyer in Graphite, you first need to route your camera feed and alpha channel to XPression, using the DashBoard interface. Then you’ll set up the **Chroma Key**.

For best results, take the key online first, and then identify the areas where you need to adjust the key.

**To route your camera feed and alpha channel to XPression:**

1. Launch Dashboard from the desktop.
2. In the **Basic Tree View**, select **Graphite** and double-click **Configuration**.
The **Configuration** panel opens.

3. At the bottom of the panel go to the **Outputs** tab.

4. For each Trackless camera, determine which ME bus you want to use as the source and define the camera feed and alpha channel.
   
   Example: XPin1V and XPin1A might be the two properties of Trackless camera 1.
5. In the **Source** column, for XPin1V, select either ME1 or PGM as the camera feed.

![Image of DashBoard - Graphite - Routing Camera Feed](image1)

**Figure 3.13** DashBoard - Graphite - Routing Camera Feed

6. In the **Source** column, for XPin1A, select either ME1 CLN or CLN.

![Image of DashBoard - Graphite - Routing Alpha Channel](image2)

**Figure 3.14** DashBoard - Graphite - Routing Alpha Channel
7. Then go to the **System** tab at the bottom of the panel, and for each ME, click the corresponding **On** button to enable **Layer Mode**.

To set up a Graphite chroma key:

1. In **DashBoard**, from the **Basic Tree View**, select **Graphite > Panel**.

2. Select the **ME1** button, select a video source and take the **Key 1 Cut** button online.
3. Now from the Basic Tree View select Live Assist.

4. Then click ME and select ME 1 and Key 1.

5. Select the Chroma Key button.

6. Click Basic.

7. Click the Color button for the color you want to key out.

8. Click Init to initialize the chroma key.
9. Click an **Additive Keying** button to turn it on or off.
   - Off — Reduces the level of detail in the edges of the chroma key as well as the overall noise in the key image that can be the result of certain lighting conditions or high detail camera settings. This is the default setting.
   - On — Include the maximum detail in the edges of the chroma key.

10. Adjust the **Chroma Key Parameters** sliders to fine tune the chroma key.
    For further information about adjusting the Chroma Key parameters, see your [*Graphite User Guide*](#).

### Graphite and the RAVE Audio Engine

For each SDI video source that contains the audio mix, you would use the default **Passthrough** audio setup for the corresponding XPression video input.

If you are embedding a separate audio source, using the RAVE engine, follow the instructions below:

**To embed audio from a source separate from the video:**

1. Make sure the physical input/output connections are set up as shown in the diagram below.
   - RAVE engine output to **IN12**
   - **OUT4** to the RAVE input for monitoring

2. Launch Dashboard from the desktop.
3. In the **Basic Tree View**, expand the **Graphite** node and select **Audio Mixer**.

The **Main** mix panel opens displaying **SDI** channels 1 through 12, followed by the **XPression** channels and then **Analog** channels 1 through 8. Use the horizontal scroll bar at the bottom of the channels to see them all.

![Figure 3.19 DashBoard - Graphite Audio Configuration - Main Mix](image)

4. Click the **Aux 1** mix button.

![Figure 3.20 DashBoard - Graphite Audio Configuration - Aux 1 Mix](image)

5. For each XPression channel, click the button above the fader to select either **Pre** or **Post**.
   - Select **Pre** if you want to adjust the signal before it’s been processed in **Main**.
   - Select **Post** if you want to adjust the signal after it’s been processed in **Main**.

6. In the **Basic Tree View**, select **Graphite**.
7. Double-click **Configuration** and go to the **Outputs** tab.

![Figure 3.21 DashBoard - Graphite Configuration Outputs Tab](image)

8. For each XPression input, in the **Audio Mix** column, select the **Aux 1** bus that was set up in Step 5.

![Figure 3.22 DashBoard - Graphite Configuration - AudioMix](image)
Operation

This chapter covers the following topics:

- Trackless Studio Interface
  - Menus
  - Playout
  - Settings
  - Camera Control Shortcuts
- Shutting Down Trackless Studio

Trackless Studio Interface

The following section describes the Trackless Studio interface and its functions.

![Trackless Studio User Interface](image)

*Figure 4.1 Trackless Studio User Interface*
Menus

There are three menus in the top-left corner of the Trackless Studio UI:

- **File**
- **XPression**
- **Help**

**File**

The **File** menu contains options for loading and saving your Trackless Studio project settings and your XPression Studio project and for exiting the application.

**To load and save your Trackless Studio project settings:**

- Click **File > Settings** and from the context menu shown below, select one of the following options:
  - **Load** to load project settings from a *.tss file.
  - **Save** to save project settings to a *.tss file.
  - **Save As** to save project settings to a new file.
  - **Increment and Save** to save project settings to a new file without overwriting the previously saved file.

**To load and save your XPression project:**

- Click **File > XPression** and from the context menu shown below, select one of the following options:
  - **Load Project** to load an XPression project.
  - **Save Project** to save an XPression project.
  - **Save Project As** to save an XPression project to a new file.

**To exit the Trackless Studio application:**

- Click **File > Exit**.

**For More Information on...**

- exiting and closing Trackless Studio, refer to **Shutting Down Trackless Studio**.

**XPression**

The **XPression** menu contains one option, for opening the XPression interface.
To open the XPression interface:

• Click XPression > Show GUI.

Help

The Help menu contains one option, the About screen, which provides information about Trackless Studio such as the version, license number and requirements.

This screen also indicates for which version of XPression the application has been compiled.

To access the About screen:

• Click Help > About.
Playout

Use the **Playout - Production Control** section to play out scenes by triggering presets, camera movements, and transitions, or using manual camera controls.

**To open the Production Control interface:**

- Click **Production Control** under the **Playout** heading.

![Figure 4.4 Playout - Production Control](image1)

**To add a preset scene:**

1. Select the scene you want to add a preset to and click **Save** at the left of the row of thumbnails.

![Figure 4.5 Scenes/Presets](image2)

2. Then click a blank thumbnail (e.g. (Q)01, (W)02, etc.).

   The current scene configuration will be saved as a preset in the selected thumbnail location.

**To add presets to the Trackless Queued Commands List:**

- Click 2 or more preset thumbnails to add them to the list.

   When selecting the presets, it helps to keep the camera speed in the **Camera Movement** section slow (e.g. 10%).

**To delete a preset:**

1. Right-click the preset.
2. From the context menu, select **Delete Preset**.
To display all scenes:

- Click the Camera Control tab.

![Figure 4.6 Trackless Studio - Camera Control](image)

If your project has more than two scenes, use the scroll bar on the right to scroll down to access Scene3 and Scene4.

**Other Playout Controls**

- **Events** — use this list to select an event/macro that has been set up in Events / Sequences to trigger a selected preset.
- **Trigger** — click this button to activate a selected event.
- **Talent A** — use this list to select the quad to use in the scene.
- **Go** — click this button to move the camera to the selected talent quad in the scene.
To access the Preset shortcuts:

- Right-click on a preset thumbnail and select one of the following shortcuts:
  - **Preset Setting** — select this option to open the **Preset Setting** window:

    ![Preset Setting window](image)

    The following describes the **Preset Setting** window:

    - **Duration Multiplier** — use this box to enter a higher number value if you want to increase the time of the camera movement (interpolation) when selecting the current preset. Enter a lower number value (decimal) if you want to decrease the time for the camera movements when selecting the current preset.
- **GPIO Output** — select the checkboxes to define a specific state (ON/OFF) for the GPIO board of the XPression machine when calling a specific preset. When calling a specific preset, Trackless can automatically set an OUT Pin to **ON (5v+)** or **OFF (0v+)** if desired. This can be useful, for example, to turn **Tally** lights (identifying the live camera) on or off directly from Trackless. As Trackless virtual cameras are not directly related to physical cameras, this has to be set manually, and you can have two live camera inputs in view with one virtual camera preset.

- **OK** — click to apply any changes and close the window.

- **Cancel** — click to cancel any changes and close the window.

- **Queue > Show Queue** — select this option to open the **Trackless Queued Command List**:

![Trackless Queued Commands List](image)

The following describes the **Trackless Queued Commands List** interface:

- **Command** — this list displays the commands that have been queued for the animated camera movements from the selected **Scene**.

- **OK** — click this button to exit and close the Trackless Queued Commands List.

- **Clear Queue** — click this button to clear and close the Trackless Queued Commands List. If camera movement is already in progress, the movement to the preset target will complete but will stop at the end and not move to another preset.

- **Queue > Clear Queue** — select this option to clear the queued command list.

- **Delete Preset** — select this option to delete the preset from the scene.
Settings

In the **Settings** section, there are pages for using the **Chroma Keyer**, setting up **Media** for events, creating **Events / Sequences**, and a **Shotbox** controller reference page.

Chroma Keyer

☐ The live source camera input functionality requires a chroma keyer license option. Contact your Ross Video sales representative for information.

Click **Chroma Keyer** under the **Settings** heading to open the Chroma Keyer interface. Use this section to adjust the settings for the color of the live source material and the size of the talent quad.

![Chroma Keyer Interface](image)

**Figure 4.7 Settings - Chroma Keyer**

Color

Select a **liveinputcam** from the list of live sources and configure the color settings for the chroma key:

![Color Settings](image)

**Figure 4.8 Settings - Chroma Keyer - Color**

**Color Box** — click a color in this box to set the RGB color value.

**Scale** — place the slider along this scale to set the selected RGB color value.

**R** — use the slider to adjust the red value or use the box to enter a red value.

**G** — use the slider to adjust the green value or use the box to enter a green value.

**B** — use the slider to adjust the blue value or use the box to enter a blue value.

**A** — use the slider to adjust the alpha value or use the box to enter an alpha value.
**Dropper Tool** — use the dropper tool to add the color to the chroma key for the live source material by clicking inside the talent quad in the Talent Quad section below the Color section or the scene next to the Color section.

**Active** — select this check box to enable the chroma key.

**Refresh** — click this button to refresh the image from the live source feed.

To select a different live source, right-click on a `liveinputcam` and select **Select Input Source** to open the **Select Input Frame Buffer** dialog box and choose a different input source for the live input.

---

**Matte Generation**

The Matte Generation settings are located at the right of the Chroma Keyer screen.

- **Max. Angle** — enter or select an angle to set the maximum difference in color between the selected chroma key color and the input color to be chroma keyed.
- **Edge Width** — enter or select a value to adjust the outside edge of the foreground image as follows:
  - Increasing the value increases the amount that the key encroaches onto the foreground image.
  - Decreasing the value decreases the amount that the key encroaches onto the foreground image.
- **FG Clipping** — enter or select a value to determine the range of colors which are considered foreground colors. Adjust the clipping as follows:
  - Increasing the value removes lower-saturated colors from the foreground image.
  - Decreasing the value includes lower-saturated colors in the foreground image.
- **Edge Hardness** — enter or select a value to add or remove edge hardening of the foreground image as follows:
  - Increasing the value increases the amount of hardness applied to the foreground edges.
  - Decreasing the value decreases the amount of hardness applied to the foreground edges.

**Matte Post-Processing**

- **Soften** — enter or select the value used to blur the edge of the generated matte.
- **Sharpen Range** — enter or select the range to apply the sharpen value.
- **Sharpen** — enter or select the value to set the amount of sharpening applied to the edge of the generated matte.

**Spill Suppression**

- **Range** — enter or select the range of the chroma key color, within the set Max Angle, to apply desaturation.
- **Desaturation** — enter or select the amount of key color to remove from the set range. A value of 1 = 100% of the key color.

**Luma Clipping**

- **Clip Low** — use this box to adjust the value to counteract dark areas of the chroma key backdrop and prevent them from being keyed out.
- **Clip High** — use this box to adjust the value to counteract bright areas of the chroma key backdrop and prevent them from being keyed out.
- **Clip Softness** — enter or select the value used to blur the edges between what has been keyed out and what has been prevented from being keyed out.

**Auto Apply** — select this check box to automatically apply any changes made to the chroma key settings.

**Apply** — click to apply the changes made to the chroma key settings.

**Load Settings** — click to open a browser to select a chroma key settings file (*.cks) to load.

**Save Settings** — click to save the chroma key settings to a file (*.cks).
**Talent Quad/Cropping**

Select a talent quad from the list to crop or apply the color setting for the chroma key using the dropper tool in the **Color** section.

![Figure 4.9 Settings - Chroma Keyer - Talent Quad](image)

Click, hold, and then move the mouse inside the talent quad image to create a cropping box to crop the talent quad. Release the mouse when the cropping is sized as necessary.

Click the dropper tool from the **Color** section inside the talent quad image to add the configured color for the chroma key to the live source for the talent quad.

**Refresh List** — click this button to refresh the enabled **vtalent** items in the talent quad list. Refreshing enabled items in the list will update the camera view for the talent quad if it has been adjusted.

**Reset Cropping** — click this button to reset any cropping made to the talent quad.

**Talent Size**

**Scale** — enter or select a percentage to scale the talent quad.

**W** — enter or select a width in pixels to scale the talent quad.

**H** — enter or select a width in pixels to scale the talent quad.

**Apply** — click to apply the changes to the talent quad size.

**Talent Position**

**Z+** — click this button to move the talent quad forward along the Z-axis.

**Z-** — click this button to move the talent quad backward along the Z-axis.

**X+** — click this button to move the talent quad right along the X-axis.

**X-** — click this button to move the talent quad left along the X-axis.

**Y+** — click this button to move the talent quad up along the Y-axis.

**Y-** — click this button to move the talent quad down along the Y-axis.

**0.1px** — select this option to move the talent quad 0.1 pixels for each change in position.

**1px** — select this option to move the talent quad 1 pixel for each change in position.

**10px** — select this option to move the talent quad 10 pixels for each change in position.

**100px** — select this option to move the talent quad 100 pixels for each change in position.

**Reset** — click this to reset the talent position to X:0, Y:0, Z:0.
Media

Click Media under the Settings heading to open the Media settings interface. Use this section to set up or update media lists to be used in either hot-swap mode or event-based triggering in the Production Control interface.

- Media assets must be encoded by XPression.

Setup Media for Events

Click this tab to set up media for events. The materials are meant to be used as displays triggered in the virtual set (e.g. virtual monitors, etc.). Only materials that have been configured according to the naming convention prefix in the settings will be available.

![Image of Media settings interface]

**Figure 4.10 Settings - Media - Setup Media for Events**

- **Id** — the media list ID number.
- **Name** — click inside a cell to enter or edit a name for the media.
- **Input** — displays the source of the media.
- **Material** — click inside a cell to select a material for the media.
- **New** — click to add a new media item for events to the list.
- **Delete** — click to delete a selected media item from the list.
- **Drives** (C:\, etc.) — expand a drive to locate a media file. Drag and drop the media file onto a media list item to add it.
- **Live Sources** — drag and drop a live source onto a media list item to add it.
- **Refresh** — click to update the live source images.
Media Hot Swap

Click this tab for hot-swap mode. Hot-swap is used to modify or update media in Trackless Studio such as a video, live source, or still image that might be used on something such as a virtual monitor. This allows for quick changes live during production.

Figure 4.11  Settings - Media- Hot Swap

Up/Down Arrows — use these buttons to move up and down the materials list.

Materials List — select a material to select it for the object for the media hot-swap.

Object Items List — displays the specific object assigned to which the selected material has been assigned.

Media Items — once a material has been selected, click on a media item to add it to that material. A preview is displayed to the right of the media items.

Assign — click this to assign the media item to the selected material. A material and media item must each be selected before they can be assigned.

Drives (C:\, etc.) — expand a drive to locate a media file. Drag and drop the media file onto a media item to add it to the Media Items list.

Live Sources — select a material from the Materials List and an object from the Object Items List and then double-click a live source to place it on the chosen object.

Refresh — click to update the live source images.
**Events / Sequences**

In the **Events/Sequences** page, you can set up **Events** that can trigger actions and create Groups and Sequences to make playing the events easier.

**Events**

Events add the ability to trigger a variety of features simultaneously. This includes modifying DataLinq keys, setting layers online/offline (e.g., lower thirds, crawls, etc.), playing media (e.g., video, textures, etc.), scene directors, and animation controllers, triggering camera presets, and sending RossTalk commands to other RossTalk compatible machines. Each event has an ID, a name, a keyboard shortcut, a RossTalk shortcut (a SEQI command), and a group, and can be used in a sequence.

![Figure 4.12 Settings - Events/Sequences](image)

**Id** — the event list ID number.

**Name** — click inside the cell to enter a name for the event. This name is used for reference when listed in the Shotbox section, web server, and sequences.

**Keyboard** — click inside the cell to select a key to assign as a keyboard shortcut for the event. **Shortcut Keys** must be enabled in the **Production Control** section to assign a keyboard shortcut.

**RossTalk In** — displays the RossTalk SEQI command support for the event. The commands are assigned sequentially based on the event ID number.

**Group** — click inside the cell to select a group for the event, if necessary. This enables ease of use within the web application.

**Trigger** — click to trigger the event.

**Print** — click to print the event list.

**Export** — click to export the event list to a text file.

**New Event** — click to add a new event to the list.

**Delete Event** — click to delete a selected event from the list.
Triggers are not executed simultaneously. They are executed in the following order: Datalinq Keys, Layers, Media, Scene Directors, Animation Controllers, Camera Presets, and RossTalk commands.

**Groups**

Groups are used for better flow within the web application. Each event can be assigned to a group from the Group list and called from the Events button of the web interface homepage.

- **New Group** — click to add a new group. When the Group Name window opens, enter a name for the new group and click OK to add the group to the list.
- **Delete Group** — click to delete a selected group from the list.

**Event Items**

**DataLinq Key**

Use this tab to add and modify DataLinq Key values for an event.

- **Scene, Key ID** — click inside the cell to select the DataLinq scene and Key ID from the DataLinq Keys tab in the Object Inspector in XPression.
- **Value** — click inside the cell to enter the DataLinq Key value.
- **Add DataLinq Key** — click to add a DataLinq Key
- **Remove DataLinq Key** — click to delete a selected DataLinq Key from the list.

**Insert Graphics**

Use this section to add a layer to a scene for graphics.

- **Scene** — click inside the cell to select a scene for the graphic.
- **Transition** — click inside the cell to select a transition for the graphic.
- **Output Framebuffer** — click inside the cell to select an output framebuffer for the graphic.
- **Layer Index** — click inside the cell to select the layer index for a selected layer in the output.
- **Text Object** — click inside the cell to select a text object from the scene to update if necessary.
- **Text Value** — click inside the cell to modify the text value of a text object before the scene goes on air if a text object has been selected to update. This can be useful to update, for example, lower thirds, titles, and subtitles.
- **Online** — select the check box to put the graphic online.

**Media**

Use this section to add a configured media source to the event.

- **Media** — click inside the cell to select a media source from the Setup Media for Events tab in the Media section.
- **Add Media** — click to add a media item to the list.
- **Remove Media** — click to remove a selected media item from the list.
Object

Use this section to add an object from a scene to the event. XPression object names must be prefixed as follows:

- **Perspective Camera**: `vcam_`
- **Talent**: `vtalent_`
- **Display Material**: `mat_display_`
- **Target Object**: `tg_`

**Scene - Object** — click inside the cell to see the list of objects in the scene and select an object for the event. Only those objects with the appropriate prefix will be shown.

**Action** — click inside the cell to see the list of possible actions and select an action for the object. The options are:

- **Show**
- **Hide**
- **FadeIn**
- **FadeOut**
- **Toggle**
- **ToggleFade**

**Add Object** — click to add an object to the list.

**Remove Object** — click to delete a selected object from the list.

Scene Director

Use this section to add a scene director to the event.

**Scene, Scene Director** — click inside the cell to select a scene director to add to the event.

**Comment** — displays any pertinent information about the selected scene director.

**Add Scene Director** — click to add a scene director to the list.

**Remove Scene Director** — click to remove a selected scene director from the list.

Animation Controller

Use this section to add an animation controller to the event.

**Scene, Animation** — click inside the cell to select an animation controller to add to the event.

**Add Animation Controller** — click to add an animation controller to the list.

**Remove Animation Controller** — click to remove a selected animation controller from the list.

Preset

Use this section to add a camera preset to the event.

**Scene** — click inside the cell to select the scene with the camera preset to add to the event.

**Preset** — click inside the cell to select the camera preset to use with the event.

**Add Camera Preset** — click to add an camera preset to the list.

**Remove camera Preset** — click to remove a selected camera preset from the list.
RossTalk Out

Use this section to add RossTalk commands to the event.

**Command** — click inside the cell to select the RossTalk command output for the event. The options are:

- GPI
- UP
- DOWN
- NEXT
- TAKE

**Extra Parameters** — click inside the cell to enter added parameters to complete the full string for the RossTalk command, such as the GPI pin number.

**Host** — click inside the cell to enter the host IP address of the target RossTalk device or enter localhost.

**Port** — click inside the cell to enter the port number of the target RossTalk device or local host.

**Protocol** — click inside the cell to select the command protocol.

**Sequences**

Sequences are used to trigger a sequential list of either camera presets and/or events. A sequence can consist of a list of events, a list of camera presets, or a mixture of both. The RossTalk FOCUS command allows the user to select any sequence on the list (starting at FOCUS 0000). Use this section to add or remove sequences.

**To add a new sequence:**

- At the bottom of the **Sequences** pane, click **New Sequence**.

**To rename a sequence:**

1. Right-click the sequence and from the context menu, select **Rename**.
   
   Alternatively, you can select the sequence and press **F2**.
   
   The **Rename Sequence** dialog opens.

   ![Figure 4.13 Rename Sequence](image)

2. Enter a new name for the sequence and click **OK**.

**To delete a sequence:**

1. From the **Sequences** list, select the sequence you want to delete.
2. Click **Delete Sequence**.
   
   Alternatively, you can right-click the sequence you want to delete and from the context menu, select **Delete** or select the sequence you want to delete and press the **Delete** key on your keyboard.

**Sequence Items**

Sequence items are triggered by either moving up or down with the arrow buttons to the right of the items list and/or with the RossTalk command NEXT.
To add items to a sequence:

1. Click the **New Item** button.
   
   The **Add Sequence Item** dialog opens.

   ![Add Sequence Item](image)

   *Figure 4.14 Add Sequence Item*

2. From the list, select the item(s) you want to add to the sequence and click **Add Event**.
   
   Only one item can be added at a time.

To delete items from a sequence:

1. From the **Sequence Items** list, select the item you want to delete.

2. Click the **Remove Item** button.
   
   Alternatively, you can right-click the item you want to delete and from the context menu select **Delete** or press the **Delete** key on your keyboard.

To return to the beginning of a sequence:

- At any time during the running of a sequence, click the **Reset** button.
  
  The next time you click the down arrow, the first item in the sequence will run.
Shotbox

As a reference, the Shotbox section lists all shortcuts available when using the shotbox controller option.
Camera Control Shortcuts

The lower part of the Trackless Studio interface contains controls that allow you to adjust the speed and behavior of camera movement, the interpolation mode, the scene transitions and duration of effects. These settings are initially set in the Trackless Studio Settings screen. It also contains the Manual Camera Control settings.

To access the Camera Control shortcuts:

- Right-click on Camera Control to access the following shortcut menu, if it is not already displayed:

![Camera Controls](image)

**Figure 4.16 Camera Controls**

Camera Movement Controls

**Speed** — use the slider to increase or decrease the speed of the animated camera movement between presets. The speed is expressed as a percentage of the Max Speed set in the Trackless Studio Settings - Effects Tab. The default value is saved in the Trackless Studio Settings (.tss) file.

**Stop Move** — click this button to stop the animated camera movement. Resume the movement by clicking the target preset again.

**Clear Queue** — click this button to clear animated camera movement commands from the queue.

Interpolation Controls

The following options are available to transition between presets in the same scene:

**Delay (s)** — use this box to enter or select a delay time in seconds for the animated camera movement presets.

**Bezier (Smooth)** — select this option to use a bezier interpolation between the start of the animated camera movement and the end of the animated camera movement. With this option, the transition begins slowly, speeds up and then slows again at the end.

**Linear** — select this option to use a linear trajectory between the start of the animated camera movement and the end of the animated camera movement. With this option, the transition is completed at the same speed throughout.

**Disable** — select this option to disable the interpolation calculations. This option is the same as a Cut between presets in different scenes. See Scene Transitions.

Scene Transitions

The following options are available to transition from one scene to another scene.

**Dissolve** — select a gradual transition where one scene dissolves into another:

- **Crossfade** — transition using a fade from one scene to the other.
- **Over Black** — transition by fading into, and then, from black.
- **Additive** — transition by gradually adding light to the image.
- **Saturate** — transition using saturation.

**Push** — select a sliding transition where one scene pushes out the previous scene:

- **Right to Left** — push a scene out to the left while the next scene enters from the right.
- **Left to Right** — push a scene out to the right while the next scene enters from the left.
- **Top to Bottom** — push a scene out the bottom while the next scene enters from the top.
• **Bottom to Top** — push a scene out the top while the next scene enters from the bottom.

**Distort** — select a transition where a scene is warped out:

• **Diverge** — transition by splitting it into multiple pieces.
• **Pixelate** — transition by making it appear as though it is at a lower resolution.
• **Sine Wave** — transition using a sine wave pattern.
• **Shrink** — transition by shrinking the scene.

**Cut** — select a clean cut between scenes:

• **Cut** — transition instantaneously from one scene to another.

**Duration (Frames)** — use the slider to increase or decrease the duration in number of frames for the transition between scenes. The default value is set in the Trackless Studio Settings - Effects Tab and saved in the Trackless Studio Settings (.tss) file.

**Manual Camera Control**

**Arrow Keys** — select this option to enable keyboard arrows for manual camera control.

**Shortcut Keys** — select this option to enable keyboard shortcuts to call presets or camera movements for Scene1 and Scene2.

Keyboard shortcuts are not available for Scene3 and Scene4.

The available keyboard shortcuts are:

![Shortcut Keys on Keyboard](image)

**Table 4.1 Shortcut Keys - Presets**

<table>
<thead>
<tr>
<th>Shortcut - Scene 1</th>
<th>Function</th>
<th>Shortcut - Scene 2</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Shift + Q</td>
<td>Scene 1 - Preset 1</td>
<td>1. Shift + A</td>
<td>Scene 2 - Preset 1</td>
</tr>
<tr>
<td>2. Shift + W</td>
<td>Scene 1 - Preset 2</td>
<td>2. Shift + S</td>
<td>Scene 2 - Preset 2</td>
</tr>
<tr>
<td>3. Shift + E</td>
<td>Scene 1 - Preset 3</td>
<td>3. Shift + D</td>
<td>Scene 2 - Preset 3</td>
</tr>
<tr>
<td>4. Shift + R</td>
<td>Scene 1 - Preset 4</td>
<td>4. Shift + F</td>
<td>Scene 2 - Preset 4</td>
</tr>
<tr>
<td>5. Shift + T</td>
<td>Scene 1 - Preset 5</td>
<td>5. Shift + G</td>
<td>Scene 2 - Preset 5</td>
</tr>
</tbody>
</table>
Analog Joystick — select this option to control camera movements using the shotbox joystick.

It is also possible to wirelessly enable the talent to trigger an event action sequence in order, moving previous and next events, using a wireless pointer.

**Go Home** — click this button to return to the starting point of the virtual set configured in the Trackless settings.

**0.1X/1.0X** — select the camera movement speed sensitivity. 0.1X is slowest and 1.0X is fastest.

**Stop Manual** — click this button to stop any active manual camera movement. This is useful if a connection issue occurs between the shotbox joystick or Carbonite joystick, or if there is an arrow key issue. Any manual camera movement input action currently in the queue will be stopped and removed from the queue.

**Z+** — click this button to move the camera forward along the Z-axis.

**Z-** — click this button to move the camera backward along the Z-axis.

**X+** — click this button to move the camera right along the X-axis.

**X-** — click this button to move the camera left along the X-axis.

**Y+** — click this button to move the camera up along the Y-axis.

**Y-** — click this button to move the camera down along the Y-axis.

---

**Table 4.1 Shortcut Keys - Presets**

<table>
<thead>
<tr>
<th>Shortcut - Scene 1</th>
<th>Function</th>
<th>Shortcut - Scene 2</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>6. Shift + Y</td>
<td>Scene 1 - Preset 6</td>
<td>6. Shift + H</td>
<td>Scene 2 - Preset 6</td>
</tr>
<tr>
<td>7. Shift + U</td>
<td>Scene 1 - Preset 7</td>
<td>7. Shift + J</td>
<td>Scene 2 - Preset 7</td>
</tr>
<tr>
<td>8. Shift + I</td>
<td>Scene 1 - Preset 8</td>
<td>8. Shift + K</td>
<td>Scene 2 - Preset 8</td>
</tr>
<tr>
<td>9. Shift + O</td>
<td>Scene 1 - Preset 9</td>
<td>9. Shift + L</td>
<td>Scene 2 - Preset 9</td>
</tr>
<tr>
<td>10. Shift + P</td>
<td>Scene 1 - Preset 10</td>
<td>10. Shift + ;</td>
<td>Scene 2 - Preset 10</td>
</tr>
</tbody>
</table>

**Table 4.2 Arrow Keys - Camera Movement**

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + Left Arrow</td>
<td>Move camera left</td>
</tr>
<tr>
<td>Ctrl + Right Arrow</td>
<td>Move camera right</td>
</tr>
<tr>
<td>Ctrl + Up Arrow</td>
<td>Move camera forward</td>
</tr>
<tr>
<td>Ctrl + Down Arrow</td>
<td>Move camera backward</td>
</tr>
<tr>
<td>Shift + Left Arrow</td>
<td>Pan camera left</td>
</tr>
<tr>
<td>Shift + Right Arrow</td>
<td>Pan camera right</td>
</tr>
<tr>
<td>Shift + Up Arrow</td>
<td>Tilt camera up</td>
</tr>
<tr>
<td>Shift + Down Arrow</td>
<td>Tilt camera down</td>
</tr>
<tr>
<td>Ctrl + Shift + Up Arrow</td>
<td>Move camera up</td>
</tr>
<tr>
<td>Ctrl + Shift + Down Arrow</td>
<td>Move camera down</td>
</tr>
</tbody>
</table>

**Table 4.3 Other**

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift + Esc</td>
<td>Quit the program</td>
</tr>
</tbody>
</table>
Tilt+ — click this button to rotate the camera upward.
Tilt- — click this button to rotate the camera down.
Pan+ — click this button to rotate the camera to the right.
Pan- — click this button to rotate the camera to the left.
Shutting Down Trackless Studio

Always close Trackless Studio before closing XPression.

To close Trackless Studio:

1. In Trackless Studio, click File > Exit.
   
   A Trackless Studio prompt opens.

   ![Prompt: Would you like to save your current Trackless Studio work?]

   ![Yes | No | Cancel]

   2. Select one of the following exit options:
      
      - **Yes** — exit and save any changes in Trackless Studio.
      
      A second Trackless Studio prompt opens.

      ![Prompt: Would you like to save the current XPression Project?]

      ![Yes | No | Cancel]

      Select one of the following options:
      
      - **Yes** — exit and save any changes in the XPression project.
      - **No** — exit without saving any changes in the XPression project.
      - **Cancel** — do not exit Trackless Studio. The changes in Trackless Studio are still saved, but not the changes to the XPression project.
      - **No** — exit without saving any changes in Trackless Studio.
      - **Cancel** — do not exit Trackless Studio.

   3. In XPression, click File > Exit.
DashBoard

Low-level integration with DashBoard with an OpenGear frame card enables easy control of Trackless Studio operations from a remote DashBoard panel, utilizing direct real-time bidirectional controls for manual camera movements, events, and preset thumbnails.

![Figure 5.1 DashBoard Trackless Studio Panel](image)

For instructions on connecting DashBoard to Trackless Studio, see Trackless Studio in DashBoard.

**Control**

**Camera Position**

Click and hold on the joystick to move the camera position left or right along the X-axis and forward or backward along the Z-axis.

**Y-Axis Position**

Click and hold on the handle to move the camera up or down along the Y-axis.

**Camera Angle**

Click and hold on the joystick to tilt the camera position up or down and rotate the camera position left or right.

**Interpolation Speed**

Use the slider to increase or decrease the speed of the animated camera movement. The default is 25.

**Transition Frames**

Use the slider to increase or decrease the duration in frames for the transition between presets. The default is 138.

**Interpolation Effect**

- **Bezier** — select this option to use a bezier curve between the start of the animated camera movement and the end of the animated camera movement.
- **Linear** — select this option to use a linear trajectory between the start of the animated camera movement and the end of the animated camera movement.
Disable — select this option to use a bezier curve between the start of the animated camera movement and the end of the animated camera movement.

**Transition Effect**

The following options are available to transition from a preset in one scene to a preset in another scene.

- **Cut** — transition instantaneously from one preset to another.
- **Crossfade** — transition using a fade from one preset to the other.
- **Over Black** — transition by fading into, and then, from black.
- **Additive** — transition by gradually adding light to the image.
- **Saturate** — transition using saturation.
- **Right to Left** — push a preset out to the left while the next preset enters from the right.
- **Left to Right** — push a preset out to the right while the next preset enters from the left.
- **Top to Bottom** — push a preset out the bottom while the next preset enters from the top.
- **Bottom to Top** — push a preset out the top while the next preset enters from the bottom.
- **Diverge** — transition by splitting it into multiple pieces.
- **Pixelate** — transition by making it appear as though it is at a lower resolution.
- **Sine Wave** — transition using a sine wave pattern.
- **Shrink** — transition by shrinking a preset.

**Camera Presets**

In this tab, click a preset thumbnail (e.g. Preset 1-1, Preset 1-2, etc.) to select it. Click multiple preset thumbnails in a row to add them to the **Trackless Queued Commands List**. When selecting the presets, it helps to keep the camera speed in the **Camera Movement** section slow (e.g. 10%).

**Events**

In this tab, click an **Event** button to trigger a pre-configured event.

**For More Information on...**

- events, refer to **Events / Sequences**.
Web Interface

Trackless Studio can also be controlled from a Web interface. Trackless Studio includes an internal Web server for calling camera presets and events from web browser-enabled devices such as Android WiFi tablets and IPad WiFi, among others.

This chapter covers the following topics:

- Accessing the Web Interface
- Camera Presets
- Events

Accessing the Web Interface

You will need to configure the Web server port number in Trackless Studio Settings and in your Web browser, as described below:

To access the Web interface:

1. Launch the Trackless Studio Settings application.
2. In the Network tab, enable the Web Server port and note the Port number.
   By default, the Port number is 8083.
3. Click Save and then Exit.
4. With Trackless Studio running, open a Web browser and in the URL field, enter the IP address of the computer running Trackless Studio, followed by the Web Server port number, separated by a colon, eg. 127.0.0.1:8083.
   The Web GUI is launched.

![Trackless Studio Web GUI](image)

Figure 6.1 Web GUI - Home
Camera Presets

• Use the Camera Presets interface to control the selection of camera movements.

![Camera Presets interface](image)

*Figure 6.2 Web GUI - Camera Presets*

• Click Home to return to the web GUI homepage.

Events

• Use the Events interface to trigger pre-configured events in Trackless Studio.

![Events interface](image)

*Figure 6.3 Web GUI - Events*

• Click Go Back to return to the previous web GUI page that was visited.

• Click Home to return to the web GUI homepage.
Appendix A: Settings

This appendix covers the following recommended settings for XPression and Trackless Studio:

- **XPression Setup**
- **Windows 7 Settings**
- **TCP Ports Conflict**

This appendix also covers instructions for viewing logs and debugging information.

- **View Trackless Studio Logs**
- **View XPression Debug Monitor**

**XPression Setup**

- At least one output framebuffer (configured in the **Inputs / Outputs** tab in the XPression **Hardware Setup** dialog box).
• Select the **Keep Input Active** check box in the **Input Options** section of the **Inputs / Outputs** tab in the **Hardware Setup** dialog box.

• Select the **Enable anti-flicker filter for interlaced SD output modes** check box in the **Output Options** section of the **Inputs / Outputs** tab in the **Hardware Setup** dialog box. Also, select the **Enable softening filter** check box and use the **Softness Level** box to enter or select a level of 3.0 to soften the video image.
Higher anti alias values can lead to low performance. From the **Hardware Renderer** section of the XPression Preferences dialog box, **8x CSAA High Quality** is recommended as the **Anti Alias** setting.
Performance Recommendations

If there is a noticeable reduction in performance in the output, adjust the following settings:

- Memory Cache
- Output Framebuffer

Memory Cache

Increase the size of the memory cache in XPression to improve performance.

To increase the memory cache:

1. In XPression, click Edit > Preferences and select In Memory Cache from the list.
2. In the Limit allocated memory pool to field, enter or select an increase in the megabytes for the cache and click OK.

   The recommended size is 3000 MB.

   ![Figure A.1 In Memory Cache](image)

Output Framebuffer

Increase the queue size of the output framebuffer in XPression to improve performance.

To increase the output framebuffer queue size:

1. In XPression, click Edit > Hardware Setup.
2. Double-click the Matrox Video XMIO framebuffer.
3. In the Matrox XMIO - Framebuffer Setup dialog, in each Output tab, in the Hardware Frame Buffer Queue section, use the Queue Size field to increase the size of the framebuffer queue.
4. Click Apply and then OK.
Figure A.2 Matrox XMIO Framebuffer Setup
Windows 7 Settings

Fonts
Adjust Windows font size for Trackless Studio.

In Control Panel, select Display > Smaller - 100% (default).

Windows Themes and GUI Effects
Disable any Windows themes and GUI effects.

To disable Windows themes:

1. In Control Panel, select Personalization.
   The Change the visuals and sounds on your computer section opens.
2. In the Basic and High Contrast Themes, click Windows 7 Basic.

To disable GUI effects:

1. In Control Panel, select System > Advanced system settings.
   
The Advanced tab of the System Properties window opens.
2. In the **Performance** section, click **Settings**.
   
The **Performance Options** window opens.

![Performance Options Window](image1)

3. Select **Adjust for best performance**.

![Performance Options Window](image2)

4. Click **Apply**.

5. Click **OK**.
   
The **Performance Options** window closes.

6. Click **OK**.
   
The **System Properties** window closes.
Media Preview

Media preview requires DirectShow Codecs installed, for example:

- [Apple QuickTime](https://apple.com/quicktime), for Apple Quicktime .MOV.
- [K-Lite Codec Pack](https://k-lite.com), for other common video file formats (basic package at a minimum).

Media assets must be encoded by XPression.
TCP Ports Conflict

Use the instructions provided to resolve any conflict with other TCP ports.

Web Server

Check that no other applications are currently using the same ports that Trackless Studio uses, especially the port being used for the Trackless Studio web server (default 80).

You can list all the services using port 80 with the following command on Windows Command Prompt:

C:\Users\XPression>netstat -aon | findstr :80
TCP 0.0.0.0:80 0.0.0.0:0 LISTENING 61540

Then, when you get the Process Id (for example 61450), you can look for the application name using the following command prompt command:

C:\Users\XPression>tasklist /svc /FI "PID eq 61540"

Common applications such as Skype, Microsoft IIS, and Microsoft SQL Server uses port 80.

You can modify the Trackless web port to use a port other than 80 or you can disable the other external conflicting services.

<table>
<thead>
<tr>
<th>Image Name</th>
<th>PID</th>
<th>Services</th>
</tr>
</thead>
<tbody>
<tr>
<td>Skype.exe</td>
<td>61540</td>
<td>N/A</td>
</tr>
</tbody>
</table>

To disable other external conflicting services:

1. Click Control Panel > Administrative Tools.

   The Administrative Tools browser opens.
2. Double click Services.

The Services window opens.

![Services window]

3. Select the following items to disable by stopping the service:
   - Web Deployment Agent Service
   - World Wide Web Publishing Service
   - Microsoft Internet Information Services

   You can also disable the IIS services from the Programs and Features option in the Control Panel.

   **To disable the IIS services:**

   1. Click Control Panel > Programs and Features > Turn Windows features on or off.

   The Windows Features window opens.

   ![Windows Features window]

   2. Locate Internet Information Services in the list and de-select the check box.

   3. Click OK.

   **For More Information on...**

   - how to disable IIS services, check the following Microsoft Support link:

     https://support.microsoft.com/en-us/kb/321141

   Microsoft SQL Server also uses port 80 for reporting services. You can modify the TCP port inside Reporting Services Configuration Manager > Web Service URL.
View Trackless Studio Logs

You can view activity in the Trackless Studio logs.

To access Trackless Studio logs:

• Using the file explorer, navigate to C:\XPressionApps\Trackless Studio\logs.

View XPression Debug Monitor

You can view debug messages in the XPression Debug Monitor.

To access the XPression Debug Monitor:

• In the Windows toolbar, click the gear icon ( ).

The XPression Debug Monitor opens.

![Figure A.3 XPression Debug Monitor](image-url)
Contact Us

Contact our friendly and professional support representatives for the following:

- Name and address of your local dealer
- Product information and pricing
- Technical support
- Upcoming trade show information

---

Technical Support

**Telephone:** +1-844-652-0645 (North America)
+800 1005 0100 (International)

**After Hours Emergency:** +1 613 • 349 • 0006

**Email:** techsupport@rossvideo.com

---

General Information

**Telephone:** +1 613 • 652 • 4886

**Fax:** +1 613 • 652 • 4425

**Email:** solutions@rossvideo.com

**Website:** http://www.rossvideo.com

---

Visit Us

Visit our website for:

- Company information and news
- Related products and full product lines
- Online catalog
- Testimonials