XPression

RossTalk / Smart GPI on XPression

GPI (General Purpose Interface) is a method by which electronic pulses from one device, such as a vision mixer, are
used to trigger functions on another device, such as XPression.

The GPIs are supported during playback of XPression sequences and allow the user to play templates to air without
using a full PC keyboard.

XPression supports two types of GPIs:
e Advance-next - contact-closure GPI
e Smart GPI / RossTalk - string based commands

XPression supports GPI triggers through an RS232 connector. The trigger is a simple contact-closure, which triggers
the next event in the currently loaded sequence.

XPression offers two GPI options on a 9 pin D-SUB RS232 connector:
e GPI 1 - "Data Set Ready” pin 6 and 7

e GPI 2 - “Clear To Send” pin 8 and 7
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Pin Signal Pin Signal
1 Data Carrier Detect 6 Data Set Ready
2 | Received Data 5 Request to Send
3 | Transmitted Data 8 Clear to Send
4 | Data Terminal Ready 9 Ring Indicator
5 | Signal Ground

To create an RS232 based GPI trigger, create a device that short-circuits either pin 8-7 or 6-7 on the 9 PIN D-SUB
Female connector.

* Do not add any additional power to the circuit, as that will damage the RS232 port.

Some turnkey XPression chassis' may not have a standard DB9 serial port. If this is the case then a USB Serial dongle
may be used to provide one. Some USB Serial dongles may not properly support the RTS/CTS lines, therefore we
recommend the one supplied Ross Video (contact Ross Video for more information).

Some chassis' may have a serial port in the form of an RJ45 connector. If this is the case, the pinouts will be different
from the above, however it is still the DSR/RTS pins or the CTS/RTS pins that should be shorted. Consult the manual
for the correct pinouts for your serial port.

When using a contact closure GPI on the CTS/DSR lines, some devices might send GPI signals that are noisy.
Connecting the GPI to a mechanical push-button might also cause this problem. If the connection is noisy, it might
generate multiple triggers causing the sequence to advance by 2 or 3 events at a time. In the Hardware GPI
configuration, it is possible to set a Debounce Time, which is the amount of time in milliseconds, XPression will wait
before acting upon a second GPI trigger.

Phone: +1 613-686-1557 e Technical Support: +1-833-859-0499 (North America) ¢ +800 3540 3545 (Int'l) e 1 300 007 677
(Australia) 3500DR-513-14 Rev 3 e January 2026 © 2026 Ross Video Limited. Ross® and any related marks are trademarks or

registered trademarks of Ross Video Limited. All other trademarks are the property of their respective companies. PATENTS ISSUED

and PENDING. All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted in any

form or by any means, mechanical, photocopying, recording or otherwise, without the prior written permission of Ross Video. While ——

every precaution has been taken in the preparation of this document, Ross Video assumes no responsibility for errors or omissions.
Neither is any liability assumed for damages resulting from the use of the information contained herein.




XPression

Enabling GPI over RS232 on XPression

To enable GPI over RS232 on XPression:

1. From the Edit menu, select Hardware Setup.
The Hardware Setup dialog opens.
2. Select the GPI / Tally Boards tab.
3. Select Add.
The Add New GPI Board dialog opens.
4. From the Brand list, select Serial GPI (CTS/DSR).
The Serial GPI Setup dialog opens.
5. In the RS232 GPI Settings section, from the State drop-down, select Enabled.
6. From the Port drop-down, select the Communication port that receives RS232 GPI signals.
7. In the Debounce Time (ms) field, enter or select the amount of milliseconds between sequential GPI pulses.
A value of around 50-100 milliseconds should be sufficient for filtering out any noise during the GPI trigger.
8. Select OK.
The Serial GPI Setup dialog closes and the configuration appears in the GPI / Tally Boards tab list.

XPression will now accept GPI triggers when a sequence is loaded and will advance through the playlist.
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25-Pin GPIO Port (12 In/12 Out)

The 25-pin GPIO port is supported in software version 3.2 or later and is only available in Turnkey systems.
Limited support was available in version 3.1 but it could only be accessed through external .NET API applications.

The pinout for the 25-pin GPIO port is as follows:

1- GND 14 - GPI OUT 12
2- GPIIN12 15 - GPI OUT 11
3- GPIIN11 16 - GPI OUT 10
4 - GPIIN 10 17 - GPI OUT 9
5- GPIINOS 18 - GPI OUT 8
6 - GPIINS8 19 - GPI OUT 7
7- GPIIN7 20 - GPI OUT 6
8- GPIING6 21 - GPIOUT 5
9- GPIINS 22 - GPIOUT 4
10 - GPIIN 4 23 - GPI OUT 3
11 - GPTIN 3 24 - GPI OUT 2
12 - GPIIN 2 25-GPIOUT 1
13-GPIIN 1

To configure the 25 pin GPIO port:

1. From the Edit menu, select Hardware Setup.
The Hardware Setup dialog opens.

2. In the GPI / Tally Boards tab, select Add.
The Add New GPI Board dialog opens.

3. From the Brand drop-down, select Adrienne TC/GPIO Card.
There are no required options to configure.

The 25-pin GPIO port can be accessed through .NET applications or by configuring it to trigger functions in the
Keyboard/GPI Mapping feature.
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Smart GPI / RossTalk

Smart GPI / RossTalk allows the user to send Take IDs as part of the trigger. Smart GPI / RossTalk also allows the
user to recall templates in any desired order, in contrast to the Advance-next GPI, which airs templates in sequence.

Each command should be terminated by a Carriage Return and Line Feed (CR/LF).

X When using RossTalk with Tessera, all commands that include framebuffer parameters must include a value.
However, since Tessera does not use framebuffers, the framebuffer value will be ignored.

XPression Smart GPI / RossTalk is supported on both RS232 and TCP/IP.
On a serial connection Smart GPI / RossTalk utilizes standard RS232 communication.

If the transmitting device uses standard RS232 pinouts, then a NULL modem will be required between the
transmitting device and XPression.
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On TCP/IP Smart GPI / RossTalk the communication is sent on a user-definable IP port.

Windows HyperTerminal is a good tool for testing the communication for both RS232 and TCP/IP-based Smart GPI /
RossTalk GPIs.

# Test - HyperTerminal - O X
File Edit View Call Transfer Help

SEQT 8002:9 .
SEQ0 0602

v
< >

Connected 0:00.09  Auto detect SCROLL

When using HyperTerminal to send Smart GPI / RossTalk commands, it should be configured to send a Carriage
Return/Line Feed (CR/LF) pair when the Enter key is pressed.

To configure HyperTerminal to send a CR/LF pair:

1. Select File > Properties > Settings > ASCII Setup.

2. Then select the Send line ends with line feeds checkbox.
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Configuring Smart GPI / RossTalk in XPression

To enable Smart GPI / RossTalk in XPression:

1. From the Edit menu, select Hardware Setup.
The Hardware Setup dialog opens.
2. In the GPI / Tally Boards tab, select Add.
The Add New GPI Board dialog opens.
3. From the Brand drop-down, select Smart GPI / RossTalk and select OK.
The Smart GPI / RossTalk Setup dialog opens.
4. In the Settings section, from the State drop-down, select Enabled.
Select Disabled to turn off Smart GPI / RossTalk.
5. Select a Mode for the Smart GPI / RossTalk:
Serial RS232 — select to use RS232 to send Smart GPI signals to XPression.
TCP — select to use TCP/IP to send Smart GPI / RossTalk signals to XPression.
UDP — select to use UDP sockets to send Smart GPI / RossTalk signals to XPression.

6. Configure the selected GPI mode:
Serial RS232:

a. From the Port drop-down, select the communication port that receives GPI signals.
b. From the Baudrate drop-down, select the communication speed for GPI signals.

c. From the Data Bits drop-down, select the number of bits used to represent one character of data for GPI
signals.

d. From the Parity drop-down, select the method used to check for lost data in a GPI signal.
e. From the Stop Bits drop-down, select the number of bits used to indicate the end of a byte in a GPI signal.
f. From the Flow Control drop-down, select the data transmission rate controller for a GPI signal.

When using Smart GPI / RossTalk GPIs, the Flow Control can be set to Hardware or None, but it must be set
the same in both XPression and the transmitting device.
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TCP and UDP:

a. In the Incoming Network Settings section, use the TCP/UDP Port field to enter or select the
communication port that receives GPI signals.

b. In the Outgoing Network Settings section, use the Hostname field to enter the host name of a remote
device that is to receive RossTalk messages.

c. In the TCP/UDP Port field, enter or select the communication port that receives the signals.
7. Select OK.
The Smart GPI / RossTalk is displayed in the GPI Board list.
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XPression Smart GPI / RossTalk Commands

XPression Smart GPI / RossTalk supports the following commands:

CLFB [framebuffer]:[layer] — clear a layer on the framebuffer.

To clear layer 2 on the first framebuffer, the command would look as follows: CLFB 0000:2.
If the layer is not specified, the framebuffer specified by the buffer ID will be cleared.

To clear the first framebuffer, the command would look as follows: CLFB 0000.

When using XPression Tessera, this command can be used to clear layers. The the framebuffer parameter will be
ignored (set to 0).

CLRA — clear all framebuffers.

CUE [takeid]:[framebuffer]:[layer] — cue a Take Item on a specified layer of a framebuffer. If no parameters
are indicated, the focused Take Item is cued.

DATALINQKEY [takeid]:[key]:[value] — set the value of a specified DataLinq Key for a specified Take Item.
For example: DATALINQKEY 0002 :Names:John.

DOWN — move the current selection in the sequencer to the item below it.

FOCUS [takeid] — set sequencer focus to a specific Take Item.

GAMESTATE — log an item in the As Run Log for each game state, such as first half, second half, etc.

GPI [gpi num]:[state] — trigger a simulated GPI input which can be assigned to global functions in the
Keyboard/GPI mapping menu. RossTalk/Smart GPI supports up to 64 simulated inputs.

An optional state value can be provided to simulate a level-based GPI which can be read from the API. The state
value should be either 0 or 1. If not provided, the state shall be assumed to be 1.

LAYEROFF [framebuffer]:[layer] — if there is a scene on the specific framebuffer/layer, take it offline using its
out transition.

To remove the scene on layer 2 on the first framebuffer, the command would look as follows: LAYEROFF 0000:2.
NEXT — read the current selection in the sequencer to air and advance the current selection to the next item.
READ — read the current selection in the sequencer to air.

RESUME [framebuffer]:[layer] — resume a single layer on the framebuffer specified by the channel. If the layer
is not specified, every layer on the framebuffer will resume.

To resume the layer 2 on the first framebuffer, the command would look as follows: RESUME 0000:2.

This command can also contain a Tessera source hame to resume all layers on that source. E.g., RESUME Ribbon
Boards.

ROUTEIPIN <input>:<ip>:<port>[:AUDIO:<audio ip>:<audio port>] — perform a clean switch on a 2110
IP input. This command is supported on the Matrox DSX IP board with the Pair inputs to allow remote clean
switch option enabled.
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o SEQI [takeid]:[layer] — loads a template to air on the specified layer and the template-defined output
framebuffer.

To air Take ID 0005 on layer 7, the command would look as follows: SEQT 0005:7.
e SEQO [takeid] — takes the template off air.
To take Take ID 0005 off air, the command would look as follows: SEQ0 0005.

o SWAP [framebuffer] — place all the Take Items that are currently in the cued state to air in framebuffer number
buffer ID. If a framebuffer is not specified, all cued Take Items are taken to air. For example, swap 0 takes all the
cued Take Items in framebuffer 1 to air.

This command can also be used with the XPression Remote Sequencer to swap all channels.

o TAKE [takeid]:[framebuffer]:[layer] - takes a template to air on the specific framebuffer and layer without
moving the sequencer focus to that item (XPression 3.6 and later).

To air Take ID 5 on the first framebuffer layer 7, the command would look as follows: TAKE 5:0:7.

e TEMPLATEDATA [takeid]:[object name]:[property]:[value] — set the value of a specified object in a specified
Take Item.

E.g., TEMPLATEDATA 0002:Textl:Visibility:0.
e UNCUE [takeid] — uncue a Take Item that is currently in the cued state.
e UNCUEALL — uncue all Take Items that are currently in the cued state.
e UP — move the current selection in the sequencer to the item above it.

e UPNEXT [takeid] — set the preview in the sequencer without moving the focus bar.
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Remote Sequencer (2.0) Smart GPI / RossTalk Commands

The Remote Sequencer (2.0) Smart GPI / RossTalk supports the following commands:

CHANCUE [chan] — cue the current selection of a specified channel.
CHANDOWN [chan] — move the current selection in a specified channel to the item below.

CHANFOCUSSTORY [channel]:[RoID]:[StoryID] — move the current selection to the first item of a specified
story in a specified channel.

CHANNEXT [chan] — read the current selection of a specified channel to air and advance the current selection to
the next item.

CHANREAD [chan] — read the current selection of a specified channel to air.
CHANUP [chan] — move the current selection in a specified channel to the item above.

FOCUSSTORY [RoID]:[StoryID] — move the current selection to the first item of a specified story in the linear
rundown.

NEXTSTORY — move the current selection to the top item of the next story in the linear rundown.

PREVSTORY — move the current selection to the top item of the previous story in the linear rundown.
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Upgrading from Versions Prior to 3.2

In versions prior to 3.2 the CTS/DSR GPIs could only be used for one action: to take the current sequence item online
and advance to the next item. This was configured in the Hardware Setup menu on a tab labeled GPI. This tab is
removed in version 3.2 and later. In order to duplicate this functionality, it is required to perform some additional
configuration steps in version 3.2. These steps are now necessary as a result of the additional flexibility that has been
added to the entire GPI system.

Replicating the previous behavior of a GPI advancing the Sequencer requires the user to map the GPI to a custom
Keyboard/GPI action.

The Serial GPI plugin needs to be added to the GPI Boards tab (refer to Enabling RS232 CTS/DSR-Based GPIs).
To create a keyboard map:

1. From the Edit menu, select Keyboard / GPI Mapping.
The Keyboard / GPI Mapping window opens.

2. Select Save Keyboard Mapping %4 to create a new custom keyboard mapping.
The Save Keyboard Mapping dialog opens.
3. In the Save Keyboard Mapping dialog, enter a name for the new custom keyboard mapping.
4. Select OK.
The added custom keyboard mapping appears in the Current Keyboard Map list.
5. In the Global Shortcuts list, right-click on the Take Next function in the Sequencer tree.

6. If the Take Next function is not present in the current keyboard map, use the Available Global Functions list to
add the function by dragging it into the keyboard map.

For more information on editing the Keyboard/GPI map, please refer to the XPression User Guide.
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