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Thank You for Choosing Ross

You've made a great choice. We expect you will be very happy with your purchase of Ross Technology.
Our mission is to:
1. Provide a Superior Customer Experience
+ offer the best product quality and support
2. Make Cool Practical Technology
» develop great products that customers love

Ross has become well known for the Ross Video Code of Ethics. It guides our interactions and
empowers our employees. | hope you enjoy reading it below.

If anything at all with your Ross experience does not live up to your expectations be sure to reach out to
us at solutions@rossvideo.com.

—D.‘Q 2\55

David Ross
CEO, Ross Video
dross@rossvideo.com

Ross Video Code of Ethics

Any company is the sum total of the people that make things happen. At Ross, our employees are a
special group. Our employees truly care about doing a great job and delivering a high quality customer
experience every day. This code of ethics hangs on the wall of all Ross Video locations to guide our
behavior:

1. We will always act in our customers’ best interest.

We will do our best to understand our customers’ requirements.
We will not ship crap.

We will be great to work with.

o DN

We will do something extra for our customers, as an apology, when something big goes wrong and
it's our fault.

We will keep our promises.
We will treat the competition with respect.

We will cooperate with and help other friendly companies.

© o N

We will go above and beyond in times of crisis. If there's no one to authorize the required action in
times of company or customer crisis - do what you know in your heart is right. (You may rent
helicopters if necessary.)
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Warranty and Repair Policy

Ross Video Limited (Ross) warrants its Streamline Server systems to be free from defects under normal use and
service a time period of 15 months from the date of shipment:

If an item becomes defective within the warranty period Ross will repair or replace the defective item, as
determined solely by Ross.

Warranty repairs will be conducted at Ross, with all shipping FOB Ross dock. If repairs are conducted at the
customer site, reasonable out-of-pocket charges will apply. At the discretion of Ross, and on a temporary loan basis,
plug in circuit boards or other replacement parts may be supplied free of charge while defective items undergo
repair. Return packing, shipping, and special handling costs are the responsibility of the customer.

This warranty is void if products are subjected to misuse, neglect, accident, improper installation or application, or
unauthorized modification.

In no event shall Ross Video Limited be liable for direct, indirect, special, incidental, or consequential damages
(including loss of profit). Implied warranties, including that of merchantability and fitness for a particular purpose,
are expressly limited to the duration of this warranty.

This warranty is TRANSFERABLE to subsequent owners, subject to Ross’ notification of change of ownership.

Extended Warranty

For customers that require a longer warranty period, Ross offers an extended warranty plan to extend the standard
warranty period by one year increments. For more information about an extended warranty for your Streamline
Server system, contact your regional sales manager.



Environmental Information

The equipment that you purchased required the extraction and use of natural resources for its production. It may
contain hazardous substances that could impact health and the environment.

To avoid the potential release of those substances into the environment and to diminish the need for the extraction
of natural resources, Ross Video encourages you to use the appropriate take-back systems. These systems will reuse
or recycle most of the materials from your end-of-life equipment in an environmentally friendly and health
conscious manner.

The crossed-out wheeled bin symbol invites you to use these systems.

If you need more information on the collection, reuse, and recycling systems, please contact your local or regional
waste administration.

You can also contact Ross Video for more information on the environmental performances of our products.

Use of Hazardous Substances in Electrical and Electronic Products (China RoHS)

Ross Video Limited has reviewed all components and processes for compliance to:

“Management Methods for the Restriction of the Use of Hazardous Substances in Electrical and Electronic
Products” also known as China RoHS.

The “Environmentally Friendly Use Period” (EFUP) and Hazardous Substance Tables have been established for all
products. We are currently updating all of our Product Manuals.

The Hazardous substances tables are available on our website at:

http://www.rossvideo.com/about-ross/company-profile/green-practices/china-rohs.html
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Company Address

Ross Video Limited

8 John Street
Iroquois, Ontario
Canada, KOE 1KO0

General Business Office:

Fax:

Technical Support:

After Hours Emergency:

E-mail (Technical Support):
E-mail (General Information):
Website:

Ross Video Incorporated

P.O. Box 880
Ogdensburg, New York
USA 13669-0880

(+1) 613 ® 652 ® 4886
(+1) 613 ® 652 ® 4425

(+1) 613 ® 652 ® 4886
(+1) 613 @ 349 ® 0006

techsupport@rossvideo.com
solutions@rossvideo.com

http://www.rossvideo.com
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Introduction

A Word of Thanks

Thank you for choosing Ross Video Streamline as your media asset management solution.

We are committed to providing you with the highest level of customer satisfaction possible. If, for any reason, you
have questions or comments, please call Ross Video at +1-613-652-4886 or send us an e-mail at
techsupport@rossvideo.com.

We hope that you visit our website www.rossvideo.com to stay up to date with ongoing software releases, join our
customer forum and learn more about the complete range of Ross Video products.

Note that software maintenance and extended warranties are available for your system to protect and extend the life
of your investment. Our sales team is more than happy to provide further information on the plans available.
Members of our sales team will promptly response to e-mails sent to: solutions@rossvideo.com.

Again, thank you for your purchase of a Streamline media asset management solution from Ross Video. We are
confident of your future pleasure with your choice.

Yours Sincerely,

Christopher Kelly
Marketing Product Manager — Asset Management & Storage
ckelly@rossvideo.com
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About This Guide

This guide contains the following chapters that cover the installation and configuration of Streamline software:

e Chapter 1, “Introduction” summarizes the guide and provides important terms, conventions and feature
descriptions.

* Chapter 2, “System Requirements” provides the recommended minimum hardware and software requirements
to ensure that the Streamline software functions correctly.

» Chapter 3, “Software Upgrades” provides instructions on how to upgrade the Streamline software.

* Chapter 4, “Software Installation” provides instructions on how to install the Streamline software on a
computer after a system re-image.

» Chapter 5, “Software Licensing” provides instructions for licensing Streamline software.

* Chapter 6, “System Configuration” provides instructions on how to configure Streamline software options.

If you have questions pertaining to the operation of the Ross Video product, please contact us at the numbers listed
in the section “Contacting Technical Support” on page 1-3. Our technical staff is always available for
consultation, training, or service.

Documentation Conventions

Special text formats are used in this guide to identify parts of the user interface, text that a user must enter, or a
sequence of menus and sub-menus that must be followed to reach a particular command.

Interface Elements

Bold text is used to identify a user interface element such as a dialog box, menu item, or button. For example:

In the Work Order Manager panel, click Create New Work Order.

User Entered Text
Courier text is used to identify text that a user must enter. For example:

In the Language box, enter English.

Referenced Guides
Italic text is used to identify the titles of referenced guides, manuals, or documents. For example:

For more information, refer to the section “Creating a Work Order” in the Streamline User Guide.

Menu Sequences

Menu arrows are used in procedures to identify a sequence of menu items that you must follow. For example, if a
step reads “File > Save As,” you would click the File menu and then click Save As.

Important Instructions

Star icons are used to identify important instructions or features. For example:

* When the Streamline Client cannot connect to the network, a Message dialog box opens to report the connection
problem.
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Getting Help

The Ross Video product Online Help system is accessed by selecting Help Topics from the Help menu in the
product. Alternatively, press the F1 key while working in a client or dialog box.

The Online Help system contains the following navigation tabs to locate information contained in the Online Help
topics and User Guide:

« Contents — table of contents
* Index — keyword reference
¢ Search — full text search

» Favorites — preferred information storage and access

Ross Video product guides are also supplied as print-ready PDF files on the Ross Video product Software
Installation DVD.

Contacting Technical Support

Technical Support is staffed by a team of experienced specialists ready to assist you with any question or technical
issue.

Ross Video has technical support specialists strategically located around the globe to ensure a prompt response to
technical inquiries. Our primary technical support center is located in Ottawa, Ontario, Canada. In addition, we
have offices in The United Kingdom (London), Australia (Sydney), and Singapore with satellite locations in New
York City, The Netherlands, and China. As we expand our presence globally, we are constantly evaluating other key
locations to have a local technical support specialist in order to better service our customers.

North America

Our North America center located in Ottawa, Ontario, Canada and is open Monday to Friday 8:30 a.m. to 6:00 p.m.
EST, with 24/7/365 on-call service after hours.

Our telephone number is: +1-613-652-4886
Toll free within North America: +1 844-652-0645

EMEA

Our EMEA center is located in Buckinghamshire, England, United Kingdom and is open Monday to Friday 8:30
a.m. to 5:00 p.m. GMT. After hours support is provided by our North America location.

Our telephone number is: +44 (0)1189502446
International toll free: +800 1005 0100

Emergency After-hours Support

Our telephone number is: +1-613-349-0006

Toll free within North America: +1 844-652-0645
International toll free: +800 1005 0100

Online

E-mail: techsupport@rossvideo.com

Website: use the link http://www.rossvideo.com/support/tech-support.html to open a support request.
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System Requirements

Ross Video base Streamline products on mainstream PC hardware that use the Microsoft® Windows® operating
system. To ensure that the Streamline functions correctly, verify that the computer selected to run Streamline
software meets the recommended requirements described in the following sections:

e Hardware

¢ Software
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Hardware

Ross Video recommends the following minimum computer hardware configuration to run Streamline software:
* CPU — quad-core Intel® Xeon® E3 with Hyper-Threading

« RAM — 32GB

* Hard Drive — Minimum 2 GB free

+ LAN — 100 MB/s

Software

Ross Video recommends the following minimum computer software configuration to run Streamline software:

* Microsoft® Windows® Server 2016 64-bit English only with latest patches, or
Microsoft® Windows® Server 2016 64-bit English only with latest patches, or
Microsoft® Windows® Server 2012 R2 64-bit English only with latest patches

Streamline can be accessed using one of the following web browsers:

* Microsoft® Internet Explorer® version 9 or greater
* Mozilla® Firefox® version 3.6 or greater

* Google® Chrome™ version 17.x or greater
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Software Upgrades

This chapter provides instructions for upgrading the Streamline software on your computer to the latest version of
the Streamline software.

The following topics are discussed in this chapter:

» Before a Software Upgrade
» Upgrade to the Latest Streamline Software

* Setting a Custom Password for the Database Superuser
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Before a Software Upgrade

Before you start an upgrade of the Streamline software on your Streamline Server, perform the following tasks:

* Have a qualified Ross Video technician perform any required maintenance or repairs on the Streamline Server.
* Use Add/Remove Programs control panel to remove any existing version of Streamline software.
* Exit all other Windows® programs currently running on the Streamline Server.

» Temporarily disable anti-virus software running on the Streamline computer. Some heuristic-based intrusion
detection systems prevent the upgrade of Streamline software. Re-enable anti-virus software after upgrading the
Streamline software.

Contact a Ross Video sales representative about Streamline commissioning, training, and update services.

X After upgrading Streamline software, you must obtain feature licenses from Ross Video Technical Support
before users can access Streamline features.

For More Information on...

* Ross Video Technical Support phone numbers, refer to the section “Contacting Technical Support” on
page 1-3.

Upgrade to the Latest Streamline Software

This section provides instructions for upgrading Streamline software versions

* When upgrading Streamline software, do not uninstall the Streamline Database. Streamline software upgrade
procedures only require the uninstall of the previous version of Streamline software.

X Performance tuned Streamline settings must be re-tuned after a Streamline software upgrade.
To upgrade Streamline software

1. Use Add/Remove Programs on the Control Panel of your computer to remove the Streamline software
installed on the Streamline computer.

2. Restart the Streamline computer.

3. After the Streamline computer restart, log in to the Streamline computer and run the Ross Streamline Setup
wizard (Streamline-4.x.x-xxx-xxx.msi) on the Streamline Software DVD. For the complete installation
procedure, refer to the chapter “Software Installation” on page 4-1.

4. After the Streamline computer restarts, log in to the Streamline computer and continue with one of the
following:

 Ifyour Streamline Database uses the standard password of postgres for the database superuser postgres,
continue with step 5 in this procedure.

» If your Streamline Database does not use the standard password of postgres for the database superuser
postgres, complete the procedure in the section “Setting a Custom Password for the Database
Superuser” on page 3-3.
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5. Use one of the following methods to open the Streamline web page:

* On the Desktop, double-click the Ross Streamline icon.

» Use the Start menu to select All Programs > Ross Streamline > Ross Streamline.

The Upgrade Required web page opens in a web browser window. If the Upgrade Required web page does
not open, contact Ross Video Technical Support.

B Upgrade Required X+

& = O oot ¥ |

M
N I
O a

streamline> Upgrade Required

Adatal
your

unti
Start Upgrade

6. Click Start Upgrade.

After the upgrade completes, the Streamline Login screen opens. If the Streamline Login screen does not
display, contact Ross Video Technical Support.

streamline>

Username

Password

Advanced

7. Retune the Streamline settings by completing the procedure “To tune Streamline settings in the jvm.conf
file” on page 4-11.

Setting a Custom Password for the Database Superuser

During the installation of the PostgreSQL database, you must set the password for the database superuser and
service account named postgres. If the password set for postgres is not the standard password of postgres,
the installer must configure the Streamline software to use the custom postgres password.

To set a custom postgres password
1. Use one of the following methods to open the Streamline web page:

e On the Desktop, double-click the Ross Streamline icon.
* Use the Start menu to select All Programs > Ross Streamline > Ross Streamline.

The Streamline Login screen opens. If the Streamline Login screen does not open, contact Ross Video
Technical Support.

2. At the Streamline Login screen, enter the following user name and password in the provided boxes:

¢ Username — maintenance

¢ Password — maintenance
3. Click Login.

You are logged into the Streamline.
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4.

10.
11.

12.

13.

14.
15.

In the Tools section of the Streamline toolbar, click the [ Configuration icon.

The Database tab of the Configuration panel opens.

) Configuration

@ orver
@ure

@ Usemame:

@ Passwore

B

Database | Licensing  System

Mail Server

Database Configuration

PostgresaL. &

[idbe:postaresat/ocalnosstreamiine

[pores

In the Password box, enter the custom password set for the database superuser named postgres.

Click OK.

An Alert dialog box opens.

In the Alert dialog box, click OK.

The Alert and Configuration dialog boxes close.

On the Streamline toolbar, click the Logout icon.

A Message dialog box opens.

In the Message dialog box, click OK to log out of Streamline.
Close the web browser.

From the Windows® Desktop, press Windows Key+R.

The Run dialog box opens.

In the Open box, type the following application name: services.msc
Click OK.

The Services window opens.

Help

B> >»mnn

(Local)

Select an item to view its description.
™:
A
A
™:
A
A
™:
A
™:
A
A
™:
™:
™:
™:
™:
Di
™:
Mar

Startup Type

btended (Sanderd

In the Services list, locate and select the Ross Streamline service.

Click Restart for the Ross Streamline service.
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16. Use the File menu to select Exit.
The Service dialog box closes.
17. Use one of the following methods to open the Streamline web page:

* On the Desktop, double-click the Ross Streamline icon.
» Use the Start menu to select All Programs > Ross Streamline > Ross Streamline.

The Upgrade Required web page opens in a web browser window.

B Upgrade Required X+

- @
& = O oot Y| = % o -

streamline> Upgrade Rqui_r?fi

A database upgrade is required. This may take a while, depending on the size of
your database. Do not restart your web server until the upgrade is complete.

Start Upgrade

X If the Upgrade Required web page does not open, contact Ross Video Technical Support.
18. Click Start Upgrade.

After the upgrade completes, an Alert dialog opens with the Streamline Login screen. If the Streamline
Login screen does not open, contact Ross Video Technical Support.

streamline>

Username
Password

v Advanced

19. Retune Streamline settings by completing the procedure “To tune Streamline settings in the jvm.conf file” on
page 4-11.
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Software Installation

This chapter provides instructions for installing Streamline software on a Streamline computer after a system
re-image.

The following topics are discussed in this chapter:

» Before a Software Install

* Installing Streamline Database Software

* Installing Streamline Software

* Setting a Custom Password for the Database Superuser

* Tuning the Streamline and Database for Performance

Streamline Installation Guide (v4.5) Software Installation « 4-1



Before a Software Install

Before you install Streamline software on a Streamline computer, perform the following tasks:

» Have a qualified Ross Video technician perform any required maintenance or repairs on the Streamline
computer.

 Exit all other Windows® programs currently running on the Streamline computer.

* Temporarily disable anti-virus software running on the Streamline computer. Some heuristic-based intrusion
detection systems prevent the installation of Streamline software. Re-enable anti-virus software after installing
the Streamline software.

Contact a Ross Video sales representative for information about Streamline commissioning, training, and update
services.

X After installing Streamline software, you must obtain Streamline feature licenses from Ross Video Technical
Support before users can access Streamline features.

For More Information on...

* Ross Video Technical Support phone numbers, refer to the section “Contacting Technical Support” on
page 1-3.

Installing Streamline Database Software

Streamline uses the PostgreSQL database to store and manage application data. Only the initial installation or
recover installations of Streamline software on a computer require the installation of the PostgreSQL database
software.

* You must install and configure PostgreSQL database software on the Streamline computer before installing
Streamline on the computer.

Upgrading Streamline software to a new version does not require a re-installation of the PostgreSQL database
software. For the complete upgrade procedure, refer to the chapter “Software Upgrades” on page 3—1.

To install PostgreSQL database software for an initial install of Streamline software
1. On the Streamline computer, exit all currently running Windows® applications.

2. Insert the Streamline software DVD into the DVD-ROM drive.

3.  On the Desktop, open My Computer.

4. In the My Computer explorer window, open the DVD-ROM Drive.

5

Right-click the postgresql-9.3.5-3-windows-x64.exe icon and select Run as administrator from the Shortcut
menu.

Open

J  Run as administrator

Troubleshoot compatibility
IZArc
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The Setup wizard opens.

- a X
—
PostgreSQL
Packaged by:
ENTERPRISEDB
6. Click Next.
The Installation Directory dialog opens.
& Setup - o X
Instalation Directory R
Please specify the directory where PostgreSQL wil be installed.
ettt reciry [CoPraganFiesPosigesaes | |5
7. Click Next.
The Data Directory dialog box opens.
& Setup - o X
Data Directory R

8. Replace the folder name in the Data Directory box with the following folder name:
C:\ProgramData\PostgreSQL\9.3\data
9. Click Next.

The Password dialog box opens.
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10. In the Password box, type the following password for the data base super user named postgres:
postgres

If the password of postgres does not meet the password security requirements set by your organization, enter
a different password that meets the requirements. Remember to replace the password postgres with your
password when installing, re-installing, or upgrading the Streamline software.

11. In the Retype Password box, type the password you set in step 10.
12. Click Next.
The Port dialog box opens.

& Setup - o x

port R

13. Click Next.
The Advanced Options dialog box opens.

& Setup - o x

Advanced Options R

Select the locale to be used by the new database custer.
Locale | Defaultlocale]

14. Use the Locale list to select [Default locale].

The [Default locale] option sets the PostgreSQL database local to the same locale set for the Windows
operating system.

15. Click Next.
The Ready to Install dialog box opens.

& Setup - o x
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16. Click Next.

The Installing panel opens. A progress bar displays the installation status. After the installer finishes installing
the required files, the Completing the PostgreSQL Setup Wizard dialog box opens.

& Setup - o x

Completing the PostgreSQL Setup Wizard

PostgreSQL

Packaged by:
-

17. Clear the Stack Builder check box.
Click Finish.

18. The Setup wizard closes.

To configure the data base for Streamline

1. From the Windows Desktop, use the Start menu to select All Programs > PostgreSQL 9.0 > pgAdminIII.
The pgAdminlII window opens.

P pgadmin Il - o x

Ele Edit Plugins View Tools Help

| -

Properties | Statistcs | Dependencies | Dependents

B senes (1) Properties
B PostoresQl 9.3 focakhost:5432) INo propertes are available for the current selection

SQL pane x

Retrieving detais on servers... Done, 0.00secs

2. Inthe Object Browser tree view, right-click the PostgreSQL 9.3 (localhost:5432) database and select
Connect from the shortcut menu.

The Connect to Server dialog box opens.

3. Inthe Password box, type the following password:
postgres

If the password of postgres does not meet the password security requirements set by your organization, enter
the custom password set during installation of the Streamline software on the Streamline computer.
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4. Click OK.
The PostgreSQL 9.0 node expands in the Object Browser tree view.

5. In the expanded PostgreSQL 9.0 node, right-click the Databases node and select New Database from the
shortcut menu.

The New Database dialog box opens.

Privieges  Securty Labels SQU

mmmmmmm

6. Inthe Name box, type the following name:

streamline
7. Click OK.

PostgreSQL adds the Streamline database to the Properties tab of the pgAdmin IIT window.
8. In the pgAdmin III window, use the File menu to select Exit.

The pgAdmin III window closes.

Streamline Service User
You must also set the user that runs the PostgreSQL database service before you install Streamline software.
To set the user that runs the PostgreSQL database service
1. From the Windows Desktop, press Windows Key+R.
The Run dialog box opens.

Run X

— Typethe name of a program, folder, document, or Internet
E=) resource, and Windows will open it for you.

o

pent

2. Inthe Open box, type the following application name:

services.msc

4—6 « Software Installation Streamline Installation Guide (v4.5)



3. Click OK.

The Services window opens.

> > mun

) Services (Local) | (7 Services (Local)

Select an item to view its description. StartupType  LogOnAs  ~

ocal Syste.
ocal Syste.
ocal Syste.
ocal Syste.
ocal Syste.
ocal Syste.

L
L
L
L
L
L

™:
A
A
™:
A
A
™:
Au
™:
A
A
™:
™:
™:
™:

€ Background Intell

btended (Sanderd

4. In the Services list, locate the postgresql-x64-9.3 service.
5. Right-click the postgresql-x64-9.3 service and select Properties from the shortcut menu.
The postgresql-x64-9.3 Properties dialog box opens.

postgresql-x64-0.3 Properties (Local Computer)

postgresql4649.3

Provides relational database storage.

Path to executable:
“C\Program Fies\PosigreSQL\9.3bin'pg_etl exe” unsenvics N "postares

Satptpe: | Atomatic v

6. Click the Log On tab.
The Log On tab opens.

postgresql-x64-9.3 Properties (Local Computer) x

7. Select the Local System Account option.
8. Click OK.

The Services alert dialog box opens.
9. In the Services alert, click OK.

The Services alert and the postgresql-x64-9.3 Properties dialog box close.
10. In the Services window, click Restart for the postgresql-x64-9.3 service.
11. Use the File menu to select Exit.

The Services window closes.
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Installing Streamline Software

After installing and configuring the PostgreSQL database software on the Streamline computer, you can install the
Streamline software.

* After installing Streamline software, you must obtain Streamline feature licenses from Ross Video Technical
Support before users can access Streamline features.

To install Streamline software
1. On the Streamline computer, exit all currently running applications.
2. Temporarily disable anti-virus software running on the Streamline computer.
Some heuristic-based intrusion detection systems prevent the installation of Streamline software.
3. Insert the Streamline software DVD into the DVD-ROM drive.
4. On the Desktop, open My Computer.
5. Inthe My Computer explorer window, open the DVD-ROM Drive.
6. Double-click Streamline-4.x.x-XXXX-XXXX.msi.

If a Security Warning displays, click Run.

The Ross Streamline Setup wizard opens.

8 Ross Sreamiine Setup x

streamline>
Welcome to the Ross
Streamline Setup Wizard

7. Click Next.
The End-User License Agreement screen opens.

38 Ross st

Streamline Software License Grant

TERMS AND CONDITIONS

8. Read the Streamline Software License Grant.
9. Select the I accept the terms of the license agreement option.
10. Click Next.

The Choose Setup Type screen opens.

8 Ross Sreamiine Setup x
ch Tvpe
-~
Choose the setp tpe thatbeststsyour needs

]
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11. Click the Ross Streamline icon.

The Ready to Install screen opens.

12. Click Install.

After installation of the Streamline is complete, the Installation Complete screen opens.

X

streamline>

Installation Complete

13. Click Finish.
The Ross Streamline Setup wizard closes and adds the following icons to the Desktop:

¢ Streamline Readme
¢ Streamline Release Notes

* Ross Streamline
The Streamline starts automatically after the installation of the Streamline software.
14. Re-enable anti-virus software.
15. Continue with one of the following:
» Ifyour Streamline database uses the standard password of postgres for the database superuser postgres,

do the following:

» Performance tune the Streamline and database by completing the procedure in the section “Tuning the
Streamline and Database for Performance” on page 4-11.

» License the Streamline software by completing the procedures in the chapter “Software Licensing” on
page 5-1.
» If your Streamline database does not use the standard password of postgres for the database superuser

postgres, complete the procedure in the section “Setting a Custom Password for the Database
Superuser” on page 4-9.

Setting a Custom Password for the Database Superuser

During the installation of the PostgreSQL database, you must set the password for the database superuser and
service account named postgres. If the password set for postgres is not the standard password of postgres,
the installer must configure the Streamline software to use the custom postgres password.
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To set a custom postgres password
1. Use one of the following methods to open the Streamline web page:

e On the Desktop, double-click the Ross Streamline icon.

* Use the Start menu to select All Programs > Ross Streamline > Ross Streamline.

The Streamline Login screen opens. If the Streamline Login screen does not open, please contact Ross Video
Technical Support.

2. At the Streamline Login screen, enter the following user name and password in the provided boxes:

¢ Username — maintenance

* Password —maintenance
3. Click Login.
You are logged into the Streamline.
4. In the Streamline toolbar, click the 5§ Configuration icon.

The Database tab of the Configuration panel opens.

) Configuration

of Y

o &

5. Inthe Password box, enter the custom password set for the database superuser named postgres.
6. Click OK.
An Alert dialog box opens.
7. Inthe Alert dialog box, click OK.
The Alert and Configuration dialog boxes close.
8. On the Streamline toolbar, click the Logout icon.
A Message dialog box opens.
9. Inthe Message dialog box, click OK to log out of Streamline.
10. Close the web browser.
11. From the Windows Desktop, press Windows Key+R.
The Run dialog box opens.

Run X

- Typethe name of a program, folder, document, of Internet
= resource, and Windows wil open it for you.

o

pen v
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12. In the Open box, type the following application name:
services.msc

13. Click OK.
The Services window opens.

% Services - o x
File Action View Help
LN T

) Services (Local) | (7 Services (Local)

Select an item to view its descriptior e logOnAs A
ocal Syste.
ocal Syste.
ocal Syste.
ocal Syste.
ocal Syste.
ocal Syste.
ocal Servi

ocal Syste.
ocal Syste.
ocal Syste.
ocal Servi
ocal Syste.
ocal Servi

L
L
L
L
L
L
L
Local Syste.
L
L
L
L
L
L
L

ocal Syste
Local Syste.
ed Netuorks.
Manual (Trg... ~Local Sen
Manual LocalSyste.. v

btended (Sanderd

14. In the Services list, locate and select the Ross Streamline service.
15. Click Restart for the Ross Streamline service.
16. Use the File menu to select Exit.

The Services dialog box opens.

17. Performance tune the Streamline and database by completing the procedure in the section “Tuning the
Streamline and Database for Performance” on page 4-11.

18. License the Streamline software by completing the procedures in the chapter “Software Licensing” on
page 5-1.

Tuning the Streamline and Database for Performance

The goal of the Streamline and database performance tuning is to maximize use of system resources to perform
work as efficiently and rapidly as possible. The installation or upgrade of Streamline software configures the
Streamline and the Streamline database to manage work effectively, but it is possible to greatly improve
performance by tuning the values of a few key Streamline and database settings.

Streamline Settings
The Streamline saves configuration settings in the jvm.conf file. The settings to tune are as follows:
* wrapper.java.initmemory — sets the initial Java heap size for the Streamline.
* wrapper.java.maxmemory — sets the maximum Java heap size for the Streamline.
* You must retune Streamline settings after each install or upgrade of Streamline software.
To tune Streamline settings in the jvm.conf file
1. On the Streamline computer, locate the jvm.conf file in the following folder:
C:\Program Files\Ross Video\Streamline\configuration
2. Use a text editor to open and edit the jvm.conf file.
3. Inthe jvm.conf file, locate the following setting:

wrapper. java.initmemory
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Replace the default memory value for the wrapper.java.initmemory setting with a tuned value. The tuned
value depends on the amount of RAM installed in the Streamline system. Use the following table to set the
wrapper.java.initmemory value for your Streamline system:

System RAM
2GB 4GB 8 GB 12 GB 16 GB 32GB
256 512 1024 1536 2048 4096

Locate the following setting:
wrapper.java.maxmemory

Replace the default memory value for the wrapper.java.maxmemory setting with a tuned value. The tuned
value depends on the amount of RAM installed in the Streamline system. Use the following table to set the
wrapper.java.initmemory value for your Streamline system:

System RAM
2GB 4GB 8 GB 12 GB 16 GB 32GB
512 1024 2048 3072 4096 8192

Save the updated jvm.conf file and exit the text editor.

Re-start the Streamline service as follows:

a. From the Windows Desktop, press Windows Key+R.

b. In the Open box, type services.msc.

c. Click OK.

d. In the Services list, locate and select the Ross Streamline service.
e. Click Restart for the Ross Streamline service.

f. Use the File menu to select Exit.

Follow the procedure in the section “Database Settings” on page 4—12 to tune the Streamline database.

Database Settings

PostgreSQL saves configuration settings in the postgresql.conf file. The settings to tune are as follows:

max_connections — sets the maximum number of concurrent connections to the database server.

work_mem — sets the amount of memory that the internal sort operations table and hash table use before
switching to temporary disk files.

shared_buffers — sets the amount of memory dedicated to PostgreSQL to use for caching data.

effective_cache_size — sets the amount of memory available for disk caching by the operating system and
within the database itself.
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To tune database settings in the postgresql.conf file

1. Ifthe Streamline database is not running on the same computer as the Streamline, log in to the Streamline
database computer.

2. Stop the Streamline service as follows:
a. From the Windows Desktop, press Windows Key+R.
b. Inthe Open box, type services.msc.
c. Click OK.
d. In the Services list, locate and select the Ross Streamline service.
e. Click Stop for the Ross Streamline service.

3. Locate the postgresql.conf file stored in the PostgreSQL data folder.
By default, the following folder contains the postgresql.conf file:
D:\Program Files\PostgreSQL\9.0\data

If you changed the Data Directory folder during the PostgreSQL database software install, look for the
postgresql.conf file in the specified Data Directory folder.

4. Use a text editor to open and edit the postgresql.conf file.

5. In the postgresql.conf file, locate the following setting:
max_connections

6. Replace the default connections value for the max_connections setting with the following tuned value:
max_ connections = 200

7. Locate the following line of text:
work_mem

8. If a# character precedes the work_mem setting, delete the # character.

9. Replace the default memory value for the work_mem setting with a tuned value. The tuned value depends on
the type of Streamline system and the amount of RAM installed in the system. Use the following table to set the
work_mem value for your Streamline system:

System RAM
2GB 4 GB 8 GB 16 GB 32GB
Streamline and Database Server 4 MB 8§ MB 16 MB 24 MB 32 MB
Dedicated Database Server 8 MB 16 MB 32 MB 48 MB 64 MB

10. Locate the following line of text:
shared buffers

11. If a # character precedes the shared_buffers setting, delete the # character.

12. Replace the default size value for the shared_buffers setting with the following tuned value:
shared buffers = 512MB

13. In the postgresql.conf file, locate the following line of text:
effective_cache_size

14. If a # character precedes the effective_cache_size setting, delete the # character.
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15. Replace the default memory value for the effective_cache_size setting with a tuned value. The tuned value
depends on the type of Streamline system and the amount of RAM installed in the system. Use the following
table to set the effective_cache_size value for your Streamline system:

System RAM
2GB 4 GB 8 GB 16 GB 32GB

16. Save the updated postgresql.conf file and exit the text editor.

17. Restart the PostgreSQL service as follows:
a. In the Services list of the Services window, locate and select the postgresql-x64-9.0 service.
b. Click Restart for the postgresql-x64-9.0 service.

18. Restart the Streamline service as follows:
a. In the Services list of the Services window, locate and select the Ross Streamline service.
b. Click Restart for the Ross Streamline service.

19. In the Services window, use the File menu to select Exit.
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Software Licensing

Ross Video uses a product key and feature license keys to control user access to Streamline features. You can obtain
a Streamline product key from Ross Video Technical Support. This chapter provides instructions for licensing a
Streamline.

* When a Streamline computer has multiple active network adapters (wireless, wired, or multiple NIC cards),
disabling an adapter after licensing the Streamline may invalidate your Streamline product key. To re-license
your Streamline, restart the server and reactivate the product key.

The following topics are discussed in this chapter:
» Activating a Product Key for Streamline Software

» Reactivating a Product Key
* Deactivating a Product Key
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Activating a Product Key for Streamline Software

Ross Video uses product keys to manage user licenses for Streamline features. You can obtain a Streamline product
key from Ross Video Technical Support.

* When you activate a Streamline software product key, your Streamline computer must contact the Ross Video
Activation Server through the internet.

To activate a Streamline product key
1. Verify that the Streamline computer can connect to the Internet.
2. Use one of the following methods to open the Streamline web page:

* On the Desktop, double-click the Ross Streamline icon.

» Use the Start menu to select All Programs > Ross Streamline > Ross Streamline.

An Alert dialog box opens with the Ross Streamline web page.

streamline>

Username
Password

v Advanced

* If the Ross Streamline web page does not open, contact Ross Video Technical Support.
3. In the Alert dialog box, click OK.
The Alert dialog box closes.
4. At the Streamline Login screen, enter the following user name and password in the provided boxes:

¢ Username — root

* Password — password

5. Click Login.

You are logged into the Streamline as an administrator.

* If a message displays indicating that the system is in maintenance mode, Streamline cannot communicate with
the database. Contact Ross Video Technical Support.

6. In the Tools section of the Streamline toolbar, click the [&] Configuration icon.
The Configuration panel opens.
7. Click the Licensing tab.

The Licensing Configuration tab opens.

) Configuration

Configuration
Please enter your product key as provided by Ross Video.

Name. Status. Description
Streamiine Not Purchasex “The number of Streamiine application nodes.

1OS Uplink Not Purchasex

Support for MOS upink.

Work Orders Not Purchasex

Reports Not Purchase

ven Not Purchasex

Goncurrent Users. Not Purchasex

LDAP Authentication Not Purchasex

4
4
4
4

AP GraphicsBank Not Purchased
4
4
4 Support for LDAP and ActiveDirectory user authentication and integration
4
4

Gustom Metadata Not Purchasex Support for user defined metadata

Messaging Not Purchases Support for messaging
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8. Obtain a Streamline product key from Ross Video Technical Support.
9. In the Product Key box, enter the product key obtained from Ross Video Technical Support.
10. Click Activate.
After activating the entered product key, an Alert dialog box opens requesting a web browser window refresh.
11. Click OK

The Alert dialog box closes and the Licensing Configuration tab updates to display the new feature licenses
associated with the activated product key. The Status column displays one of the following states:

Background Status Description

] Green Active The feature is active and available to Streamline users.

] Yellow Expires in # days  The feature availability for Streamline users expires in the displayed
number of days.

] Red Expired The feature has expired and is no longer available to Streamline
users.

] Red Invalid MAC The feature license key is invalid for the active network interface
card of the Streamline computer.

] White Not Purchased The feature is not accessible to Streamline users, but it is available for
purchase.

12. Click OK.

The Configuration dialog box closes.
13. Refresh your web browser window.

Streamline add icons to the toolbar for the newly activated features, making the features accessible to
Streamline users.

For More Information on...

* Ross Video Technical Support phone numbers, refer to the section “Contacting Technical Support” on
page 1-3.

Reactivating a Product Key

After purchasing new features for a Streamline system, the Streamline product key requires a reactivation to make
the purchased features available to Streamline users.

To reactivate a Streamline product key

1. Log in to Streamline as an administrator.

2. In the Tools section of the Streamline toolbar, click the [ Configuration icon.

The Configuration window opens.

3. On the Configuration window toolbar, click the “5/ System icon.
The System panel opens.

4. Click the Licensing tab.
The Licensing Configuration tab opens.

5. Click the License Options link.
The Product Key ficld displays the currently activate product key.
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6. Click Reactivate.
After reactivating the product key, an Alert dialog box opens requesting a refresh of the web browser window.
7. Click OK.

The Alert dialog box closes, and the Licensing Configuration tab is updates to display with new feature
licenses associated with the reactivated product key.

8. Click OK.
The Configuration dialog box closes.
9. Refresh your web browser window.

Streamline adds icons to the toolbar for the newly activated features, making the features accessible to
Streamline users.

Deactivating a Product Key

When you want to move Streamline software on another computer, you must find deactivate the Streamline
software on the current Streamline computer.

To deactivate a Streamline product key

1. Log in to Streamline as an administrator.

2. In the Tools section of the Streamline toolbar, click the [ Configuration icon.

The Configuration window opens.

3. On the Configuration window toolbar, click the 5/ System icon.
The System panel opens.
4. Click the Licensing tab.
The Licensing Configuration tab opens.
5. Click the License Options link.
The Product Key field displays the currently activate product key.
6. Click Deactivate.
After deactivating the product key, an Alert dialog box opens.
7. Click OK.

The Alert dialog box closes, and the product key shown in the Product Key box deactivates. You can use the
deactivated product key to activate Streamline software on another computer.

Deactivating a product key unlicenses and removes Streamline user access to all the Streamline features
associated with the product key.

8. Click OK.

The Configuration dialog box closes.
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System Configuration

The following topics are discussed in this chapter:
* Changing the Root User Password
* Accessing the Configuration Interface

* Changing the Streamline Wallpaper
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Changing the Root User Password

For security reasons, we recommend you change the default root user password.
To change the root user password

1. Log in to Streamline.

2. In the Tools section of the Streamline toolbar, click the ] Change Password icon.
The Change Password panel opens.

3. Inthe Old Password box, type the root user password:
password

4. In the New Password box, type a new password that you can remember.

5. In the Verify Password box, type the new password again.

6. Click Change Password.

The login password for the root user changes to the newly set password.

Accessing the Configuration Interface

Use the Configuration interface to set up user accounts, user roles, and system properties. Refer to the Streamline
Configuration Guide for more details.

To access the Configuration interface

1. Log in to Streamline.

2. In the Tools section of the Streamline toolbar, click the [23 Configuration icon.

The Configuration panel opens.

Changing the Streamline Wallpaper

You can set up the Streamline wallpaper graphic to appear as your Streamline desktop background image. The
Streamline wallpaper features the Streamline logo, and clearly identifies the computer as a Streamline.

To install Streamline wallpaper

1. On the Streamline computer, open either Microsoft® Internet Explorer® or Google® Chrome®, and then
navigate to:

http://localhost/resources/Streamline/images/wallpaper/1920x1080. jpg
The wallpaper image opens in the web browser.

2. If you want to replace your current Desktop background image with the Streamline wallpaper, do one of the
following:
* In Internet Explorer — right-click the wallpaper graphic file and then click Set as background.

* In Chrome — right-click the wallpaper graphic and then click Save image as....Save the image to your
Desktop. Navigate to the image, right-click it, and then click Set as Desktop background.
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