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Thank You for Choosing Ross

You've made a great choice. We expect you will be very happy with your purchase of Ross
Technology.

Our mission is to:
1. Provide a Superior Customer Experience

o offer the best product quality and support
2. Make Cool Practical Technology

e develop great products that customers love

Ross has become well known for the Ross Video Code of Ethics. It guides our interactions and
empowers our employees. I hope you enjoy reading it below.

If anything at all with your Ross experience does not live up to your expectations be sure to
reach out to us at solutions@rossvideo.com.

’D“g\ 2\!5

David Ross
CEO, Ross Video

dross@rossvideo.com

Ross Video Code of Ethics

Any company is the sum total of the people that make things happen. At Ross, our employees
are a special group. Our employees truly care about doing a great job and delivering a high
quality customer experience every day. This code of ethics hangs on the wall of all Ross Video
locations to guide our behavior:

1. We will always act in our customers’ best interest.

2. We will do our best to understand our customers’ requirements.
3. We will not ship crap.

4. We will be great to work with.
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. We will do something extra for our customers, as an apology, when something big goes
wrong and it's our fault.

We will keep our promises.
We will treat the competition with respect.

We will cooperate with and help other friendly companies.

© ©® N o

We will go above and beyond in times of crisis. If there's no one to authorize the required
action in times of company or customer crisis - do what you know in your heart is right.
(You may rent helicopters if necessary.)
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Copyright

©2023 Ross Video Limited, Ross®, and any related marks are trademarks or registered trademarks of
Ross Video Limited. All other trademarks are the property of their respective companies. PATENTS
ISSUED and PENDING. All rights reserved. No part of this publication may be reproduced, stored in a
retrieval system, or transmitted in any form or by any means, mechanical, photocopying, recording or
otherwise, without the prior written permission of Ross Video. While every precaution has been taken in
the preparation of this document, Ross Video assumes no responsibility for errors or omissions. Neither is
any liability assumed for damages resulting from the use of the information contained herein.

Patents

Patent numbers US 7,034,886; US 7,508,455; US 7,602,446; US 7,802,802 B2; US 7,834,886; US
7,914,332; US 8,307,284; US 8,407,374 B2; US 8,499,019 B2; US 8,519,949 B2; US 8,743,292 B2; GB
2,419,119 B; GB 2,447,380 B; and other patents pending.

Notice

The material in this manual is furnished for informational use only. It is subject to change without notice
and should not be construed as commitment by Ross Video Limited. Ross Video Limited assumes no
responsibility or liability for errors or inaccuracies that may appear in this manual.



End User Software License Agreement

This End User Software License Agreement is a legal agreement between you (the “Licensee”) and Ross
Video Limited ("Ross Video") specifying the terms and conditions of your installation and use of the
Software and all Documentation (as those terms are defined herein).

IMPORTANT:

BY DOWNLOADING, ACCESSING, INSTALLING OR USING THE SOFTWARE AND/OR
DOCUMENTATION LICENSEE AGREES TO THE TERMS OF THIS AGREEMENT AND THE LICENSE
GRANTED HEREUNDER SHALL BE EFFECTIVE AS OF AND FROM SUCH DATE. IF YOU DO NOT
WISH TO ACCEPT THE TERMS AND CONDITIONS OF THIS AGREEMENT, DO NOT DOWNLOAD,
ACCESS, INSTALL, REFER TO OR OTHERWISE USE THE SOFTWARE AND/OR DOCUMENTATION.

1. INTERPRETATION. In this Agreement, (a) words signifying the singular number include the plural
and vice versa, and words signifying gender include all genders; (b) every use of the words "herein",
"hereof", “hereto” "hereunder" and similar words shall be construed to refer to this Agreement in its
entirety and not to any particular provision hereof; (c) reference to any agreement or other
document herein will be construed as referring to such agreement or other document as from time
to time amended, modified or supplemented (subject to any restrictions on such amendment,
modification or supplement set forth therein); (d) every use of the words “including” or “includes” is
to be construed as meaning “including, without limitation” or “includes, without limitation”,
respectively; and (e) references to an Article or a Section are to be construed as references to an
Article or Section of or to this Agreement unless otherwise specified.

2. DEFINITIONS. In this Agreement, in addition to the terms defined elsewhere in this Agreement,
the following terms have the meanings set out below:

“Affiliate” means, with respect to any Person, any other Person who directly or indirectly controls,
is controlled by, or is under direct or indirect common control with, such Person. A Person shall be
deemed to control a Person if such Person possesses, directly or indirectly, the power to direct or
cause the direction of the management and policies of such Person, whether through the ownership
of voting securities, by contract or otherwise; and the term “controlled” and “controlling” shall have
a similar meaning.

“"Agreement” means this End User Software License Agreement including the recitals hereto, as the
same may be amended from time to time in accordance with the provisions hereof.

“"Backup System” means the secondary piece of Designated Equipment upon which the Software is
installed and mirrored for the sole purpose of replacing a Primary System in the event such Primary
System is not available or functioning properly for any reason.

“Change of Control” means (a) the direct or indirect sale, transfer or exchange by the
shareholders of a Party of more than fifty percent (50%) of the voting securities of such Party, (b) a
merger or amalgamation or reorganization or other transaction to which a Party is party after which
the shareholders of such Party immediately prior to such transaction hold less than fifty percent
(50%) of the voting securities of the surviving entity, (c) the sale, exchange, or transfer of all or
substantially all of the assets of a Party.



“Confidential Information” means all data and information relating to the business and
management of either Party, including the Software, trade secrets and other technology to which
access is obtained or granted hereunder by the other Party, and any materials provided by Ross
Video to Licensee; provided, however, that Confidential Information shall not include any data or
information which:

(i) is or becomes publicly available through no fault of the other Party;
(ii) is already in the rightful possession of the other Party prior to its receipt from the other Party;

(iii) is already known to the receiving Party at the time of its disclosure to the receiving Party by the
disclosing Party and is not the subject of an obligation of confidence of any kind;

(iv) is independently developed by the other Party;
(v) is rightfully obtained by the other Party from a third party; or
(vi) is disclosed with the written consent of the Party whose information it is.

“Designated Equipment” shall mean (a) the hardware products sold by Ross Video to Licensee on
which the Software is installed and licensed for use, as the same may be replaced from time to time
by Ross Video; or (b) in the case of Software licensed on a stand-alone basis, the equipment of
Licensee on which the Software is to be installed and meets the minimum specifications set out in
the Documentation.

“Documentation” shall mean manuals, instruction guides, user documentation and other related
materials of any kind pertaining to the Software (whether in electronic, hard-copy or other media
format) that are furnished to Licensee by or on behalf of Ross Video in relation to the Software.

“Freeware” means Software that is available free of charge from Ross Video, and includes, without
limitation the master control system software known as "DashBoard".

"Governmental Authority” means (a) any federal, provincial, state, local, municipal, regional,
territorial, aboriginal, or other government, governmental or public department, branch, ministry,
or court, domestic or foreign, including any district, agency, commission, board, arbitration panel or
authority and any subdivision of any of them exercising or entitled to exercise any administrative,
executive, judicial, ministerial, prerogative, legislative, regulatory, or taxing authority or power of
any nature; and (b) any quasi-governmental or private body exercising any regulatory,
expropriation or taxing authority under or for the account of any of them, and any subdivision of any
of them.

“Improvements” means all inventions, works, discoveries, improvements and innovations of or in
connection with the Software, including error corrections, bug fixes, patches and other updates in
Object Code form to the extent made available to Licensee in accordance with Ross Video's release
schedule.

"License Fee" means the fee(s), if any, payable in respect of the Software in accordance with the
relevant invoice(s) or other purchase documents delivered in connection with this Agreement.

“License Period” means the period of time that Licensee will have the rights granted under this
Agreement, as may be specified in an Order.

“Modifications” means any enhancements, changes, corrections, translations, adaptations,
revisions, developments, upgrades or updates thereto; and “Modify” shall mean the creation of any
of the foregoing.

“Object Code” means the machine readable executable form of a computer software program.



"Open Source Components" means third party Open Source software, libraries or other
components.

"Open Source License" means the license that governs each Open Source Component.

"Order" means the documents provided by Ross Video to Licensee detailing the Ross Video
products contemplated for purchase, the corresponding fees and License Period that may apply to
the Software, including any and all quotations, purchase orders, acknowledgments, pro formas,
invoices and other purchase documentation.

“Parties” means both Ross Video and Licensee and “Party” means either one of them as the context
requires.

“Person” will be broadly interpreted and includes (a) a natural person, whether acting in his or her
own capacity, or in his or her capacity as executor, administrator, estate trustee, trustee or
personal or legal representative; (b) a corporation or a company of any kind, a partnership of any
kind, a sole proprietorship, a trust, a joint venture, an association, an unincorporated association, an
unincorporated syndicate, an unincorporated organization or any other association, organization or
entity of any kind; and (c) a Governmental Authority.

“Primary System” means the Designated Equipment upon which the Software is installed and
executed to deliver its intended functionality.

“Released Claims” has the meaning ascribed to it in Section 9(b).
“Released Parties” has the meaning ascribed to it in Section 9(b).
“Ross Video” means Ross Video Limited and its Affiliates.

“Software” means the version of the Object Code licensed and delivered to Licensee by Ross Video
concurrently with delivery of this Agreement, including without limitation the Freeware, and any
subsequent error corrections, updates, Modifications or Improvements provided to Licensee by Ross
Video pursuant to this Agreement, but specifically excluding any features or plug-ins that may be
purchased by you directly from third parties as upgrades or enhancements to the Software.

“Source Code” means the human readable form of a computer software program, and all tools and
documentation necessary for a reasonably competent computer programmer to understand,
maintain and Modify the Software.

“Third Party Software” means those portions of the Software, if any, which are owned or
controlled by third parties and licensed to Ross Video pursuant to certain license agreements or
arrangements with such third parties, including the Open Source Components and NDI® software
(http://NDI.video); and

“Use” means to execute, run, display, store, merge, network, Modify, translate, host or integrate
with Licensee’s products or other third party software.


http://NDI.video

LICENSE. Subject to the terms and conditions of this Agreement, upon payment of the applicable
License Fee by Licensee, or, in the case of Freeware only, upon download of the Software by
Licensee onto its Designated Equipment, Ross Video hereby grants to Licensee a non-transferable
and non-exclusive right to Use the Software and Documentation solely for the internal use of
Licensee (the “License”), during the License Period. In the event that a License Period is not
identified on the Order, such License Period shall be deemed to be perpetual, subject to paragraph
10(c) of this Agreement. The Software shall only be used in connection with or installed on the
Designated Equipment and, where applicable, shall only be used on the Primary System, provided
such Primary System is operating properly."

If the Primary System is not operating properly for any reason, the Software may be used on the
designated Backup System for that Primary System until such time that the Primary System begins
operating properly. The Software and Documentation are provided to Licensee for the exclusive use
by Licensee’s organization for its ordinary business purposes and shall not be used by any third party
for any purposes. Licensee may make copies of the Software as required for internal backup and
archival purposes. To the extent permitted hereunder, Licensee may distribute copies of the
Software and/or Documentation to members of its organization, provided (a) this Agreement is
included with each copy, (b) any member of its organization who uses the Software and/or
Documentation accepts and agrees to be bound by the terms of this Agreement and by any other
license agreements or other agreement incorporated by reference into this Agreement, and (c)
Licensee has paid any applicable additional License Fees in respect of copying and redistributing of
the Software. To the extent Licensee is permitted to make copies of the Software under this
Agreement, Licensee agrees to reproduce and include on any copy made or portion merged into
another work, all Ross Video proprietary notices, including any notices with respect to copyrights,
trademarks and this License. With the exception of copying the Software for backup or archival
purposes, Licensee agrees to keep a record of the number and location of all such copies and will
make such record available at Ross Video’s request. The Software may include mechanisms to limit
or inhibit copying.

LICENSE RESTRICTIONS. Except as otherwise provided in section 3 above, Licensee shall not: (1)
copy any Software or Documentation, or part thereof, which is provided to Licensee by Ross Video
pursuant to this Agreement, in Object Code form, Source Code form or other human or machine
readable form, including written or printed documents, without the prior written consent of Ross
Video; (2) in any way market, distribute, export, translate, transmit, merge, Modify, transfer,
adapt, loan, rent, lease, assign, share, sub-license, sell, make available for download on any
website or make available to another Person, the Software and/or Documentation, in whole or in
part, provided that Licensee shall not be prohibited from renting or leasing the Software if Ross
Video has consented, in writing, to Licensee engaging in such activities in respect of the Software;
(3) reverse engineer, decompile or disassemble the Software or electronically transfer it into
another computer language; or (4) use the Software or Documentation in a manner that is
inconsistent with the License granted hereunder or that will result in a breach of this Agreement.
Licensee agrees to take all reasonable precautions to prevent third parties from using the Software
and/or Documentation in any way that would constitute a breach of this Agreement, including such
precautions Licensee would ordinarily take to protect its own proprietary software, hardware or
information.

DELIVERY. Ross Video shall deliver to Licensee one (1) master copy of the Software in compiled
binary (executable) form suitable for reproduction in electronic files only and Ross Video shall
deliver to Licensee a minimum of one copy of the Documentation.

IMPROVEMENTS. Licensee may from time to time request Ross Video to incorporate certain
Improvements into the Software. Ross Video may, in its sole discretion, undertake to incorporate
and provide such Improvements to Licensee with or without payment of a fee to be negotiated at
the time of such request. All Improvements, whether recommended and developed by Ross Video
or Licensee, shall be considered the sole property of Ross Video and shall be used by Licensee
pursuant to the terms of the License granted under this Agreement.



FREEWARE. Other than the obligation to pay a License Fee, which does not apply to the Freeware,
all other provisions of this End User Software License Agreement apply to the Freeware in the same
way as they apply to all other Software that is the subject of this Agreement. In addition, in
connection with the Freeware, the following provisions apply:

a.

b.

Licensee will not Use the Freeware to engage in or allow others to engage in any illegal activity.

Licensee will not Use the Freeware in any way that will interfere with or damage the operation of
the services of any third parties by overburdening/disabling network resources through
automated queries, excessive usage or similar conduct.

Licensee will not Use the Freeware to engage in any activity that will violate the rights of others,
including, without limitation, by using it for operations that involve child labour, suppressing the
right of freedom of expression or endangering the security of person.

OWNERSHIP. The Parties acknowledge and agree that, as between the Parties, Ross Video shall be
the owner of all intellectual property rights in the Software, Documentation and all related
Modifications and Improvements, written materials, logos, trademarks, trade names, copyright,
patents, trade secrets and moral rights, registered or unregistered. No proprietary interest or title in
or to the intellectual property in the Software, Documentation or any Improvements or Modifications
is transferred to Licensee by this Agreement. Ross Video reserves all rights not expressly licensed to
Licensee under section 3.

OPEN SOURCE SOFTWARE.

a.

Software may use and/or be provided with Open Source Components, including those detailed in
the Third Party section below. To the extent stipulated by its Open Source License, each such
Open Source Component is licensed directly to Licensee from its respective licensors and not
sublicensed to Licensee by Ross Video, and such Open Source Component is subject to its
respective Open Source License, and not to this Agreement. If, and to the extent, an Open
Source Component requires that this Agreement effectively impose, or incorporate by reference,
certain disclaimers, permissions, provisions, prohibitions or restrictions, then such disclaimers,
permissions, provisions, prohibitions or restrictions shall be deemed to be imposed, or
incorporated by reference into this Agreement, as required, and shall supersede any conflicting
provision of this Agreement, solely with respect to the corresponding Open Source Component
which is governed by such Open Source License.

If Licensee, or another party on Licensee’s behalf, modifies, replaces or substitutes any Open
Source Component used in or provided with this Software, Licensee hereby fully, forever,
irrevocably and unconditionally releases and discharges Ross Video, its Affiliates and its and their
employees, officers, directors, resellers, distributors and representatives (collectively, “Released
Parties”) from any and all claims, charges, complaints, demands, actions, causes of action, suits,
rights, debts, covenants, liabilities, warranties, performance and maintenance and support
obligations (collectively, “Released Claims”), of every kind and nature, with respect to such
Software, including without limitation any such Released Claims that arise as a matter of
applicable Law.

If an Open Source License requires that the source code of its corresponding Open Source
Component be made available to Licensee, and such source code was not delivered to Licensee
with the Software, then Ross Video hereby extends a written offer, valid for the period
prescribed in such Open Source License, to obtain a copy of the source code of the corresponding
Open Source Component, from Ross Video from https://www.rossvideo.com/open-source-
information/.


https://www.rossvideo.com/open-source-information/
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10. THIRD PARTY SOFTWARE.

11.

a. Licensee acknowledges that the Third Party Software is not owned by Ross Video.

Notwithstanding any other provision of this Agreement, Ross Video, to the extent permitted by
applicable law, offers no warranties (whether express, implied, statutory or by course of
communication or dealing with Licensee, or otherwise) with respect to the Third Party Software.
Ross Video may pass through to Licensee, if and to the extent permitted by applicable law, any
warranties expressly provided by such third parties to Ross Video for such Third Party Software.

FFmpeg Notice. The Software may utilize FFmpeg video components and their included libraries.
FFmpeg is a trademark of Fabrice Bellard (originator of the FFmpeg project). Ross Video
disclaims any ownership claim to FFmpeg. Please refer to http://ffmpeg.org (copyright is in the
FFmpeg developers). FFmpeg is licensed under the Lesser GNU Lesser General Public License
v2.1 or Lesser General Public License v3.0. GNU Lesser General Public, Free Software
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. Licensee can
distribute it and/or modify it under the terms of such licenses."

INTELLECTUAL PROPERTY INDEMNITY.

a. Ross Video agrees to defend, indemnify and hold harmless Licensee from final damages awarded

by a court of competent jurisdiction (hereinafter referred to as the “Losses”), which Licensee, or
any of its officers or directors, may incur, suffer or become liable for as a result of, or in
connection with, any third party claim asserted against Licensee to the extent such claim is based
on a contention that the Software, Documentation or any portion thereof, infringes any valid,
registered, enforceable patents, copyrights, trade secrets, trademarks or other intellectual
property rights of any third party, provided that (a) the allegedly infringing Software or
Documentation has been used within the scope of and in accordance with the terms of this
Agreement, and (b) Licensee notifies Ross Video in writing of such claim within ten (10) days of a
responsible officer of Licensee becoming aware of such claim. If the Software, Documentation or
any portion thereof is held to constitute an infringement of a third party’s intellectual property
rights, and use thereof is enjoined, Ross Video shall, at its election and expense, either (i)
procure the right to use the infringing element of the Software or Documentation; or (ii) replace
or modify the element of the Software or Documentation so that the infringing portion is no
longer infringing and still performs the same function without any material loss of functionality.
Ross Video shall make every reasonable effort to correct the situation with minimal effect upon
the operations of Licensee.

Notwithstanding the above, Ross Video reserves the right to terminate this Agreement and the
License granted hereunder on immediate notice to Licensee, and without liability to Licensee, in
the event that the Software or Documentation constitutes or may, in Ross Video’s determination,
constitute, an infringement of the rights of a third party that Ross Video, in its sole discretion,
does not consider to be affordably remediable.

Either party may terminate this Agreement immediately should any Software become, or in
either party's opinion be likely to become, the subject of a claim of infringement of any
intellectual property right and, in such event, there shall be no claim by either Licensee or Ross
Video against the other arising out of such termination, provided that the foregoing shall not
apply to a claim for infringement by Ross Video against Licensee in the event that Licensee is
alleged to have infringed Ross Video's intellectual property rights, in which case Licensee shall
remain liable for all outstanding License Fees and other amounts owing to Ross Video.

Notwithstanding the foregoing, Ross Video shall have no liability for any claim of infringement
based on use of other than a current, unaltered release of the Software and/or Documentation
available from Ross Video if such infringement would have been avoided by the use of a current,
unaltered release of the Software and/or Documentation provided that such current, unaltered
release performs substantially in conformity with the specifications set out in the Documentation
and was provided, at no additional cost by Ross Video, to those subscribing for maintenance
services for the Software or Documentation.



12. CONFIDENTIALITY. Each Party shall maintain in confidence all Confidential Information of the
other Party, shall use such Confidential Information only for the purpose of exercising its rights and
fulfilling its obligations under this Agreement, and shall not disclose any Confidential Information of
the disclosing Party to any third party except as expressly permitted hereunder or make any
unauthorized use thereof. Each Party shall disclose the Confidential Information only to those of its
employees, consultants, advisors, and/or subcontractors who have a need to know the Confidential
Information. Each Party shall, prior to disclosing the Confidential Information to such employees,
consultants, advisors and/or subcontractors, obtain their agreement to receive and use the
Confidential Information on a confidential basis on the same terms and conditions contained in this
Agreement. The receiving Party shall treat the Confidential Information of the disclosing Party with
the same degree of care against disclosure and/or unauthorized use as it affords to its own
information of a similar nature, or a reasonable degree of care, whichever is greater. The receiving
Party further agrees not to remove or destroy any proprietary or confidential legends or markings
placed upon any documents or other materials of the disclosing Party. The obligations of confidence
set forth in this Agreement shall extend to any Affiliates that have received Confidential Information
of the disclosing Party and shall also cover Confidential Information disclosed by any Affiliate. The
receiving Party shall be responsible for any actions or omissions of its Affiliates as if such actions or
omissions were its own.

Either party may disclose certain Confidential Information if it is expressly required to do so
pursuant to legal, judicial, or administrative proceedings, or otherwise required by law, provided
that (i) such Party provides the other Party with reasonable written notice prior to such disclosure;
(ii) such Party seeks confidential treatment for such Confidential Information; (iii) the extent of such
disclosure is only to the extent expressly required by law or under the applicable court order; and
(iv) such Party complies with any applicable protective or equivalent order.

Each of Ross Video and Licensee (the “Indemnifying Party”, as applicable) agree to indemnify the
other (the “Indemnified Party”, as applicable) for all Losses incurred by the Indemnified Party as a
result of a failure of the Indemnifying Party to comply with its obligations under this Section 12
provided that the Indemnified Party has given prompt notice of any such claim and, to the extent
that a claim may lie against a third party for the unauthorized disclosure of such Confidential
Information, the right to control and direct the investigation, preparation, action and settlement of
each such claim and, further, provided that the Indemnified Party reasonably co-operates with the
Indemnifying Party in connection with the foregoing and provides the Indemnifying Party with all
information in the Indemnified Party’s possession related to such claim and such further assistance
as reasonably requested by the Indemnifying Party.

The Parties acknowledge and agree that any breach of the confidentiality provisions of this
Agreement by one Party may cause significant and irreparable injury to the other Party that is not
compensable monetarily, as well as damages that may be difficult to ascertain, and agrees that, in
addition to such other remedies that may be available at law or in equity, the other Party shall be
entitled to seek injunctive relief (including temporary restraining orders, interim injunctions and
permanent injunctions) in a court of competent jurisdiction in the event of the breach or threatened
breach by such party of any of the confidentiality provisions of this Agreement. The relief
contemplated in this Section shall be available to each Party without the necessity of having to prove
actual damages and without the necessity of having to post any bond or other security. Each Party
further agrees to notify the other Party in the event that it learns of or has reason to believe that
any Person has breached the confidentiality provisions of this Agreement.



13. LIMITATION OF LIABILITY. The limitation of liability provisions of this Agreement reflect an
informed voluntary allocation of the risks (known and unknown) that may exist in connection with
the licensing of the Software or Documentation hereunder by Ross Video, and that voluntary risk
allocation represents a material part of the Agreement reached between Ross Video and Licensee.
Should Ross Video be in breach of any obligation, Licensee agrees that Licensee’s remedies will be
limited to those set forth in this Agreement. No action, regardless of form, arising out of this
Agreement may be brought by Licensee more than twelve (12) months after the facts giving rise to
the cause of action have occurred, regardless of whether those facts by that time are known to, or
reasonably ought to have been discovered by, Licensee.

(A) EXCEPT AS EXPRESSLY PROVIDED IN THIS AGREEMENT, THE SOFTWARE AND DOCUMENTATION
ARE PROVIDED “AS IS” AND ROSS VIDEO (I) MAKES NO OTHER REPRESENTATIONS, AND
PROVIDES NO WARRANTIES OR CONDITIONS OF ANY KIND, EXPRESS OR IMPLIED, STATUTORY, BY
USAGE OF TRADE CUSTOM OF DEALING, OR OTHERWISE, AND (II) SPECIFICALLY DISCLAIMS ALL
IMPLIED WARRANTIES INCLUDING ANY IMPLIED WARRANTY OF UNINTERRUPTED OR ERROR FREE
OPERATION, MERCHANTABILITY, QUALITY OR FITNESS FOR A PARTICULAR PURPOSE. ROSS VIDEO
DOES NOT REPRESENT OR WARRANT THAT THE SOFTWARE WILL MEET ANY OR ALL OF LICENSEE'S
PARTICULAR REQUIREMENTS, THAT THE USE AND OPERATION OF THE SOFTWARE WILL OPERATE
ERROR-FREE OR UNINTERRUPTED, THAT ALL PROGRAMMING ERRORS IN THE SOFTWARE CAN BE
FOUND IN ORDER TO BE CORRECTED, OR THAT THE SOFTWARE WILL BE COMPATIBLE WITH
OTHER PROGRAMS, SYSTEMS, AND HARDWARE.

(B) IN NO EVENT SHALL ROSS VIDEO, ITS AFFILIATES AND LICENSORS, AND THEIR RESPECTIVE
DIRECTORS, OFFICERS, EMPLOYEES AND AGENTS, BE LIABLE FOR ANY CLAIM FOR INDIRECT,
CONSEQUENTIAL, SPECIAL, INCIDENTAL, PUNITIVE, EXEMPLARY, AGGRAVATED DAMAGES; LOST
PROFITS, OR LOST REVENUE ARISING FROM OR IN CONNECTION WITH THIS AGREEMENT,
REGARDLESS OF THE FORM OF ACTION, WHETHER IN CONTRACT, OR IN TORT, EVEN IF THE PARTY
HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

(C) IN ANY EVENT THE AGGREGATE LIABILITY OF ROSS VIDEO, ITS AFFILIATES AND LICENSORS,
AND THEIR RESPECTIVE DIRECTORS, OFFICERS, EMPLOYEES AND AGENTS, FOR ANY CLAIM FOR
DIRECT DAMAGES WITH RESPECT TO THE SUBJECT MATTER OF THIS AGREEMENT SHALL NOT

EXCEED THE AMOUNT OF THE PURCHASE PRICE PAID TO ROSS VIDEO UNDER THIS AGREEMENT.

14. TERM AND TERMINATION.

(1) Unless terminated earlier in accordance with the terms of this Agreement, the term of this
Agreement shall commence upon Licensee’s first download, access, installation, or other use of
the Software or Documentation and continues until, in the case of Software licensed with
Designated Equipment provided by Ross Video, the earliest of (a) the end of the License Period,
or (b) if the Designated Equipment is assigned or transferred in accordance with this
Agreement, the date on which the Designated Equipment is no longer owned by Licensee;

(2) Either Party shall have the right to terminate this Agreement on notice to the other Party if:

(a) the other Party fails to pay any fees or other amounts when due hereunder or under any
other agreement between the Parties (or any Affiliates of the Parties, as applicable) in
connection with the Software and/or Designated Equipment and such breach is not cured
within thirty (30) days after written notice of such failure to pay is given to the defaulting
Party by the non-defaulting Party;

(b) the other Party shall file a voluntary petition in bankruptcy or insolvency or shall petition
for reorganization under any bankruptcy law, consent to an involuntary petition in
bankruptcy, or if a receiving order is given against it under the Bankruptcy and Insolvency
Act (Canada) or the comparable law of any other jurisdiction (and such is not dismissed
within ten (10) days);



15.

16.

17.

(c) there shall be entered an order, judgment or decree by a court of competent jurisdiction,
upon the application of a creditor, approving a petition seeking reorganization or
appointing a receiver, trustee or liquidator of all or a substantial part of the other Party’s
assets and such order, judgment or decree continues in effect for a period of thirty (30)
consecutive days; or

(d) the other Party shall fail to perform any of the other material obligations set forth in this
Agreement and such default, in the case of a default which is remediable, continues for a
period of thirty (30) days after written notice of such failure has been given by the non-
defaulting Party or, in the case of a non-remediable default, immediately upon notice.

(3) Notwithstanding anything to the contrary contained in this Agreement:

(a) Ross Video may forthwith terminate this Agreement if Licensee is in breach of any of
sections 3, 4 or 12 of this Agreement. For greater certainty, in such instances Ross Video
shall provide written notice of such termination as soon as practicable but written notice
shall not be a necessary prerequisite to such termination; and

(b) inthe event of a Change of Control of Licensee, Ross Video shall have the right to
terminate this Agreement and the License granted hereunder upon thirty (30) days’ prior
written notice to Licensee. For greater certainty, Ross Video’s right to terminate in the
event of a Change of Control of Licensee shall continue for a period of six (6) months from
the date Licensee delivers notice of such Change of Control to Ross Video.

(c) Ross Video may terminate the License immediately on the date on which it provides notice
to Licensee, if its agreements for Third Party Software are terminated.

(4) Upon the termination or expiry of this Agreement:
(a) Licensee shall immediately cease and desist all use of the Software and Documentation;

(b) Licensee shall immediately deliver to Ross Video any of Ross Video’s Confidential
Information provided hereunder (including the Software and Documentation) then in its
possession or control, if any, and shall deliver a certificate of an officer of Licensee
certifying the completeness of same;

(c) Licensee shall refrain from further use of such Confidential Information; and

(d) Licensee shall forthwith pay all amounts owing to Ross Video or any of its Affiliates
hereunder.

SURVIVAL. The provisions of sections 1, 2, 6, 8, 9, 10, 11, 12, 13, 14, 18, 22, 23, and 24 herein
shall survive the expiry or termination of this Agreement.

FORCE MAJEURE. Dates and times by which Ross Video is required to render performance under
this Agreement shall be automatically postponed to the extent and for the period that Ross Video is
prevented from meeting them by reason of events of force majeure or any cause beyond its
reasonable control provided Ross Video notifies Licensee of the commencement and nature of such
cause and uses its reasonable efforts to render performance in a timely manner.

ASSIGNMENT. Ross Video may assign this Agreement, or any of its rights or obligations hereunder,
in whole or in part, upon notice to Licensee. Licensee shall not assign this Agreement, or any of its
rights or obligations hereunder, in whole or in part, without the prior written consent of Ross Video,
which consent may not be unreasonably withheld. This Agreement enures to the benefit of and is
binding upon each of the Parties and their respective successors and permitted assigns.



18.

19.

20.

21.

22,

23.

24,

GOVERNING LAW. If Customer acquired the Ross Product(s) in the United States or Canada, the
laws of the state or province where Customer’s principal place of business is located govern the
interpretation of this Agreement, claims for its breach, and all other claims regardless of conflict of
laws principles. If Customer acquired the Ross Product(s) in the European Union or the United
Kingdom, then the laws of England and Wales apply. If Customer acquired the Ross Product(s) in any
other country, then the laws of the Province of Ontario, Canada shall apply.

LANGUAGE. The Parties have expressly required that this Agreement and all documents relating
thereto be prepared in English. Les parties ont expressément exigé que cette convention ainsi que
tous les documents qui s’y rattachent soient rédigés en anglais.

GOVERNMENT CONTRACTS. If the Software and/or Documentation to be furnished to Licensee
hereunder are to be used in the performance of a government contract or subcontract, the Software
and/or Documentation shall be provided on a "restricted rights" basis only and Licensee shall place a
legend, in addition to applicable copyright notices, in the form provided under the applicable
governmental regulations. For greater certainty, Ross Video shall not be subject to any flowdown
provisions required by any customer of Licensee that is a Governmental Authority unless Ross Video
expressly agrees to be bound by such flowdown provisions in writing.

EXPORT AND IMPORT LAWS. Licensee acknowledges and agrees that the Software (including any
technical data and related technology) may be subject to the export control laws, rules, regulations,
restrictions and national security controls of the United States and other applicable countries (the
“Export Controls”) and agrees not to export, re-export, import or allow the export, re-export or
import of such export-controlled Software (including any technical data and related technology) or
any copy, portion or direct product of the foregoing in violation of the Export Controls. Licensee
hereby represents that it is not an entity or person to whom provision of the Software (including any
technical data and related technology) is restricted or prohibited by the Export Controls. Licensee
agrees that it has the sole responsibility to obtain any authorization to export, re-export, or import
the Software (including any technical data and related technology), as may be required. Licensee will
defend, indemnify and hold Ross Video harmless from any and all claims, losses, liabilities,
damages, fines, penalties, costs and expenses (including attorney’s fees) arising from or relating to
any breach by Licensee of its obligations under this Section.

AMENDMENT AND WAIVER. No amendment, discharge, modification, restatement, supplement,
termination or waiver of this Agreement or any Section of this Agreement is binding unless it is in
writing and executed by the Party to be bound. No waiver of, failure to exercise or delay in
exercising, any Section of this Agreement constitutes a waiver of any other Section (whether or not
similar) nor does any waiver constitute a continuing waiver unless otherwise expressly provided.

SEVERABILITY. Each Section of this Agreement is distinct and severable. If any Section of this
Agreement, in whole or in part, is or becomes illegal, invalid, void, voidable or unenforceable in any
jurisdiction by any court of competent jurisdiction, the illegality, invalidity or unenforceability of that
Section, in whole or in part, will not affect (a) the legality, validity or enforceability of the remaining
Sections of this Agreement, in whole or in part; or (b) the legality, validity or enforceability of that
Section, in whole or in part, in any other jurisdiction.

ENTIRE AGREEMENT. This Agreement, and any other documents referred to herein, constitutes the
entire agreement between the Parties relating to the subject matter of this Agreement and
supersedes all prior written or oral agreements, representations and other communications between
the Parties.



Warranty and Repair Policy

Ross Video Limited (Ross) warrants its XPression Maps systems to be free from defects under normal use
and service for the following time periods from the date of shipment:

e XPression Maps Server — 12 months
e XPression Maps Software Upgrades — 12 months free of charge
e System and Media hard drives — 12 months

If an item becomes defective within the warranty period Ross will repair or replace the defective item, as
determined solely by Ross.

Warranty repairs will be conducted at Ross, with all shipping FOB Ross dock. If repairs are conducted at
the customer site, reasonable out-of-pocket charges will apply. At the discretion of Ross, and on a
temporary loan basis, plug in circuit boards or other replacement parts may be supplied free of charge
while defective items undergo repair. Return packing, shipping, and special handling costs are the
responsibility of the customer.

This warranty is void if products are subjected to misuse, neglect, accident, improper installation or
application, or unauthorized modification.

In no event shall Ross Video Limited be liable for direct, indirect, special, incidental, or consequential
damages (including loss of profit). Implied warranties, including that of merchantability and fitness for a
particular purpose, are expressly limited to the duration of this warranty.

This warranty is TRANSFERABLE to subsequent owners, subject to Ross’ notification of change of
ownership.

Extended Warranty

For customers that require a longer warranty period, Ross offers an extended warranty plan to extend
the standard warranty period by one year increments. For more information about an extended warranty
for your XPression Maps system, contact your regional sales manager.



Environmental Information

The equipment that you purchased required the extraction and use of natural resources for its production.
It may contain hazardous substances that could impact health and the environment.

To avoid the potential release of those substances into the environment and to diminish the need for the
extraction of natural resources, Ross Video encourages you to use the appropriate take-back systems.
These systems will reuse or recycle most of the materials from your end-of-life equipment in an
environmentally friendly and health conscious manner.

The crossed-out wheeled bin symbol invites you to use these systems.

If you need more information on the collection, reuse, and recycling systems, please contact your local or
regional waste administration.

You can also contact Ross Video for more information on the environmental performances of our
products.



Company Address

Ross Video Limited

8 John Street
Iroquois, Ontario
Canada, KOE 1KO

Ross Video Incorporated

P.O. Box 880
Ogdensburg, New York
USA 13669-0880

General Business Office:

Fax:

Toll Free Technical Support:

Alternately, you can contact:
Technical Support:

After Hours Emergency:

E-mail for Technical Support:
E-mail for General Information:

Website:

(+1) 613 - 652 - 4886
(+1) 613 - 652 - 4425

1-844-652-0645 (North America)
+800 1005 0100 (International)

(+1) 613 - 652 - 4886
(+1) 613 - 349 - 0006

techsupport@rossvideo.com
solutions@rossvideo.com

http://www.rossvideo.com


mailto:techsupport@rossvideo.com?Subject=Information Request&Body=Hi,%0D%0D
mailto:solutions@rossvideo.com?Subject=Information Request&Body=Hi,%0D%0D
http://www.rossvideo.com
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Introduction

XPression Maps is an application that allows the user to design animations such as virtual flights over
maps and create video files from the animations. XPression Maps allows you to select different map
styles, like the maps from Microsoft Bing, and switch between them on the fly. You can also build
customized maps with colorization of regions, countries, and cities, animated world maps, and maps
showing animated routes.

XPression Maps is sold in three configurations:
e XPression Maps Design Workstation

Create still and animated maps for use as is or as templates for use with XPression Maps Server MOS
workflow tools.

o XPression Maps Server

Provides access to map templates to XPression News MOS users, while maintaining control over the look
of maps and increasing the number of maps and the number of designers creating maps.

e XPression Maps Touch

Create interactive scenes and projects that can be controlled in the XPression Maps Touch Client and
interacted with on a remote touch screen.

About This Guide

This user guide describes XPression Maps, its configuration, and operation.

If at any time you have questions pertaining to the installation or operation of XPression Maps, please
contact us at the numbers listed in the section Contacting Technical Support| 3%. Our technical staff are
always available for consultations, training, or service.

XPression Maps User Guide (v3.4) Introduction = 1



Documentation Conventions

Special text formats are used in this guide to identify parts of the user interface, text that a user must
enter, or a sequence of menus and sub-menus that must be followed to reach a particular command.

Bold text Bold text identifies a user interface element such as a dialog box, menu item, or
button.

For example:

In the Slug column, type a slug name for the story.

Bold Italic text Italic text is used to identify the titles of referenced guides, manuals, or
documents.

For example:

For more information, refer to the DashBoard User Guide.
Courier text Courier text identifies text that a user must type.
For example:

In the Username box, type postgres.

Hypertext Identifies a hyperlink to a related topic.
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Getting Help

XPression Maps documentation is available online at Product Documentation and is also accessible on the
product USB key and by clicking on the Help icon in the user interface.

Contacting Technical Support

At Ross Video, we take pride in the quality of our products, but if problems occur, help is as close as the
nearest telephone.

Our 24-hour Hot Line service ensures you have access to technical expertise around the clock. After-sales
service and technical support is provided directly by Ross Video personnel. During business hours
(Eastern Time), technical support personnel are available by telephone. After hours and on weekends, a
direct emergency technical support phone line is available. If the technical support person who is on call
does not answer this line immediately, a voice message can be left and the call will be returned shortly.
This team of highly trained staff is available to react to any problem and to do whatever is necessary to
ensure customer satisfaction.

Technical Support:

1-844-652-0645 (North America)

+800 1005 0100 (International)

After Hours Emergency: (+1) 613-349-0006

E-mail: techsupport@rossvideo.com

Website: http://www.rossvideo.com
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User Interface Overview

The XPression Maps User Interface is used to configure and edit drawings, such as icons, lines, areas, and
text, in order to highlight and describe situations on the map in an animated way.

XPression Maps User Interface

The following screen capture displays the main elements of the XPression Maps User Interface.
Descriptions of individual elements are contained in the table below the diagram.

With XPression Maps you can create layouts in the user interface by dragging and dropping elements into
the preferred placements. The XPression Maps User Interface can be reset to the default setting at any
time.
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XPression Maps User Interface

1. Menu Bar: Use to access the File, Edit, Style, 2. Tool Bar: Use to access XPression Maps tools.
Custom, Output, Animation, View and Help menus.

3. Editors: Use to create shapes, edit drawings, and 4. Output Window: Displays the map/scene for
search for maps. output.
5. Animation Control: Use to control the animation 6. Drawings Overview Panel, RossTalk, Bookmark
playback of a map. Editor: Use to organize, and edit drawings in a
map, use the RossTalk interface and create
bookmarks.

7. Drawing Toolbox, User Predefined Objects, OSM 8. Map Styles and Download Information: Use to
(OpenStreetMap) Style Editor, Flight Points and select map styles and view map download
Log Information: Use to customize information.
OpenStreetMaps, create, edit and add drawings and
flight points and to view log information.

9. Area Line Edit Options: Use to lock OSM Layers to
OSM Map Styles.
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Managing User Interface Layouts

The various components of the XPression Maps User Interface can be rearranged to suit your
preference and saved as a layout. You can have several layouts if necessary. Then you can load the
layout you want. By default, the last loaded layout will load when you launch XPression Maps.

To save a configured layout in the XPression Maps User Interface:

1. From the menu bar, select View > UI Setup and select Save UI Layout.

The Save UI Layout window opens.
|

Name:

New_Layout |

oK Cancel |

Save UI Layout Window
2. Enter a name for the new layout and select OK.

The new layout has been saved.
To load a configured layout into the XPression Maps User Interface:

1. From the menu bar, select View > UI Setup and select Load UI Layout.

The Load UI Layout window opens.

B4 Load Ul Layout ? X

Name:

[defal.it v]
ok || Concel |

Load UI Layout Window
2. From the Name drop-down select the name of the layout you want to load and select OK.

The layout is loaded into the XPression Maps User Interface.
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To delete a configured layout from the XPression Maps User Interface:

1. From the menu bar, select View > UI Setup and select Delete Saved UI Layout.

The Delete UI Layout window opens.

n Delete Ul Layout ? X

Delete UI Layout Window
2. From the Name drop-down select the workspace you want to delete and select OK.

The Delete UI Layout confirmation window opens.

i Delete Ul Layout X

Delete UI Layout Confirmation Window

3. Select Yes.

The layout has been deleted.
To reset the XPression Maps User Interface to the default setting:

1. From the menu bar, select View > UI Setup and select Reset UI to Default.

The Reset UI to default window opens.

i Reset Ul to default X

Reset UI to Default Window
2. Select Yes to reset the layout.

The XPression Maps User Interface resets.
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Launching XPression Maps

To launch XPression Maps, right-click on the XPression Maps desktop icon and select Run as
administrator from the shortcut menu to run the software as a local administrator.

Configure the program properties to have XPression Maps always run as administrator.

To always run as administrator:

1. Right-click on the XPression Maps desktop icon and select Properties.

Move to OneDrive

Run with graphics processor
Open file location

Run as administrator
Troubleshoot compatibility
Pin to Start

7-Zip

CRC SHA

| Edit with Notepad++

Pin to taskbar
Restore previous versions
Send to

Cut

Copy

Create shortcut
Delete

Rename

Properties

XPression Maps Properties
2. In the Shortcut tab, click the Advanced button.

3. In the Advanced Properties screen, select the Run as administrator checkbox.

Advanced Properties X

D Choose the advanced properties you want for this shortcut.

Run as administrator

This option allows you to run this shortcut as an administrator,
while protecting your computer from unauthorized activity.

Run in separate memory space

XPression Maps Advanced Properties
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Configuring Preferences

Before beginning to use the application to create map-based video files, you can configure the XPression
Maps environment to suit your own needs. The Preferences dialog contains multiple tabs with different
sets of parameters.

To configure your preferences:

1. From the menu bar, select File > Preferences.
2. Click on the tabs to edit the parameters, as described in the following sections:
Output[ 9"
Mapm
Web Interfacel 131
Connection[ 16
Proxy[ 8"
Data (Optional)[e
Video I/0 (Optional)l 23
3. Select Save to save changes you’'ve made to the parameters.

4. When you are finished editing your preferences, select OK to apply the changes and close the
Preferences dialog.
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Output

In the Output tab you can select the screen resolution and recording format, enable or disable various
settings, and define the location and level of detail to be included in the lodfile.

i Preferencas =

Preferences - Output Tab
To edit the Output parameters:
1. In the Screen section, from the Resolution drop-down, select the video resolution and frame rate

used by your facility.

2. In the Video Creation section, from the Field Render drop-down, select whether to render the
Upper Field First or Lower Field First. The drop-down is available only when the selected screen
resolution is an interlaced format.

3. In the Misc section, select one of the following options:
4. Also in the Misc section, enable the following default behaviors if desired:

e Select the Compact Scene on Save checkbox to remove unused map styles from the Map Styles
list and unused shape styles from the Shape style list when the scene is saved or exported.

This is useful for scenes that are exported to the XPression Maps HTML5 Client plugin for XPression
MOS workflows.
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e Select the Load scene using map style from Map Style Database checkbox to enable the Use
Scene Styles From Database parameter in the Scene Templates editor.

The Use Scene Styles From Database parameter allows you to apply the map style that has
been saved in the database in place of the map style in the selected scene.

e Select the Limit Map View to Video Size checkbox to match the map view to the video size.
If unchecked, the map view will be as large as possible.

e Select the Turn Auto Zoom On for OSM Replacement Drawings checkbox if you generally
prefer to have your replacement labels stay the same size, regardless of the zoom level of the
map.

You can still disable Auto Zoom in the Drawing Editor if necessary in individual cases.
e Select the Enable Shape Editing checkbox to enable shape editing.

e Select the Invert Mouse Scroll Wheel checkbox to zoom into the map by scrolling forward on the
mouse scroll wheel, and to zoom out of the map by scrolling back on the mouse scroll wheel.

If unchecked, to zoom into the map you must scroll backward on the mouse scroll wheel, and to
zoom out of the map you must scroll forward.

*If you invert the mouse scroll wheel you will need to restart the XPression Maps application for
the change to take effect.

5. In the Logfile section, select the Browse (/= ) button beside the Location field to navigate to the
location where you want to store the lodfile.

The default location is C:\XPressionMaps_3.0\bin64\log.
6. From the Log Priority drop-down, select the level of detail to be stored to the lodfile.

Always - Logs a small set of specific information, such as the start time and version number of the
application.

Critical - Logs activity that could result in unpredictable behavior.
Error - Logs errors only.

Warning - Logs unsuccessful operations.

Information - For internal use only, for technical support.
Debug - For internal use only, for technical support.

Debug2 - For internal use only, for technical support.

7. In the UI Layout section, select the Browse () button beside the File field to select the UI
Layout Data file.

The UI Layout Data file contains saved layout configurations, see Managing Layouts| s1 for
instructions on configuring layouts.

By default, the File name field will be populated with UILayoutData.json.
To save your configuration:

¢ At the bottom of the Output tab, select Save and then select OK.
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Map

In the Map tab you can edit the parameters related to the map data.

B proforances x

Preferences - Map Tab
To edit the Map parameters:
1. In the Country section, from the Code drop-down, select the language/country to be used for the

system.

The Bing Road maps will be downloaded in the selected language. The Bing search results will be
displayed in the selected language and the shape labels will take the translation table of the selected
language.

2. Select the Include English Search Results checkbox when using a language other than English, to
get the best results. The English search results are displayed in magenta in the Search Editor.

3. In the Rendering section, select the Use MipMap checkbox to render the map tiles with
MipMapping and select the 3D checkbox to enable rendering of maps with the 3D height model.

e MipMapping reduces aliasing artifacts but decreases rendering speed.

e The 3D height model renders maps that visually indicate elevation.
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4. In the Data Configuration section, click the Browse button (. - ) beside the File field, to navigate
to the location in which the information database file (WNMDBInfo.db) will be stored.

The default location is C:\XPressionMaps\DB\WNMDBInfo.db.

The information database file is used to resolve all database connections and is configured with the
Map Data Configurator|2el in the subfolder C:\XPressionMaps\MapDataConfigurator.

5. In the OSM Server section, click the Browse button (.= ) beside the Config File field to navigate to
the location of the external OpenStreetMap tile server configuration file (osm-mapserver-
setup.xml).

The default location is C:\XPressionMaps\OSMStyles/osm-mapserver-setup.xml.
To save your configuration:

e At the bottom of the Map tab, select Save and then select OK.
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Web Interface

In the Web Interface tab you can configure the XPression Maps Server details and handshake with the
XPression Maps Database and the XPression Maps Gateway.

B preferences x

Preferences - Web Interface Tab

To edit the Web Interface parameters:

1. In the Web Template Database section enter the parameters for connecting to the database
server.
Hostname: The IP address or host name of the computer on which the database is stored.
Port: The port used to connect to the database server. The default for MySQL/mariaDB is 3306.
Username: Leave the default username as is.
Password: Leave the default password as is.
The Username and Password are used to access the database.

2. If you are using a remote template server, select the Access Remote Template Server checkbox
and then select the Browse button to navigate to the location of the Config File that identifies the
server.
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3. In the Web Server Details section enter the parameters for communicating with the Apache web
server.

e The WS Client Port is the port on which the web server and client communicate.
The default Client Port is 8877.
e Select the SSL checkbox to enable the Secure Socket Layer protocol (optional).

If you select the SSL checkbox, you will also need to change the Application Port in the Web
Gateway section to 443.

See Appendix B: Managing Network Security@ for more information.

e Select the Browse button beside the Preview Folder field to navigate to the location where

XPression Maps will create the preview video clips and from which the web server will stream the
clips to the clients.

4. In the Web Gateway section, enter the parameters for communicating with the gateway.
e The Server Name field is the same as the Hostname in the Web Template Database section.
o The Application Port field is the port on which the server and gateway communicate.
The default Application Port is 9977.
5. In the Output section enter the parameters for the final clip generation.
a. From the Format drop-down, select the AVI format (if it is not already selected).

If you are changing the format from ffmpeg to AVI, a dialog box opens asking you to update the file
format.

=4 Update File Format *

\QI) Update the file format by:
*

Creating AVI File | |Selecting Existing File || Cancel |

Update Format File to AVI Dialog
b. Select Creating AVI File to create the file.

The Video Compression dialog opens.

Video Compression

Compressar: OK

|Fu|| Frames (Uncompressed) j Cancel
Microsoft RLE ~
Microsoft Video 1

TechSmith Screen Capture Cot
TechSmith Screen Codec 2

Full Frames (Uncompressed)

(e,

Video Compression Dialog
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c. Select the XPression Video Codec and select OK.

The Save Format File window opens.

B save Format File ? s
Look in: l C:WPressionMaps_3.0\VideoFormats - I 0 0 0 ﬁ% @
W My Computer || Name +sze  Type  DateModified
| AVICodec.bin 14.es binFile 2019-.29 AM
File name: ‘A\ﬂCodEc.bn| | | Save ]
Files of type: | AVI video format fils (*.bin) v || cancel |

Save Format File
By default, the File name field will be populated with XpressionCodec.bin.
d. Select Save to save this format file.

In the Web Interface tab, the Format File field will be automatically populated with the path to
the codec file.

e. Select the Browse button bebside the Final Clip Folder field to navigate to the folder where the
video clips will be stored.

f. In the Max Clip Space field, enter or use the arrows to select the amount of system disk space,
in GBs, which can be used before the automatic cleanup mechanism starts to free up disk space by
erasing the loaded clips.

g. Select the Browse button (! ) beside the Preview Format File field to navigate to the Web
Service Video Format File folder to select the type of video format file you want.

h. Select the Clip Copy to Hotfolder checkbox, if you want to store your clips in a separate folder.

i. Inthe Hotfolder field, select the Browse button (| - ) to navigate to the folder in which to store
your clips.

To save your configuration:

¢ At the bottom of the Web Interface tab, select Save and then select OK.
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Connection

In the Connection tab you can define the map tile download and change the position and style of the
Bing Map Logo in the Output Window.

Prefarences P
]

Preferences - Connection Tab
To define the map tile download:
1. In the Bing Map Access section, enter the Application Key to define the Bing Maps download

account.

All customers need a Bing Maps application key. This may have been set up already by your
commissioning team. If not, see the document Using Bing Maps in XPression Maps in the in C:
\Archives folder on your desktop for instructions on setting up a Bing Maps account and getting an
application key.

The Account ID and Account Email fields are optional and are provided for you to keep track of the
Bing Maps account and email address under which the application key is running.

2. Select the Validate Key button.
3. If the key is valid, the text on the button turns green and says Key is Valid.

o If the key is invalid, the Bing Map Application Key Validation dialog opens requesting that a
valid key be entered.

e To remove the key, select and delete it.

o Editing the field will invalidate the key.
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e In the case of an invalid or non-existent key, the integrated XPression Maps Bing account will be
used. This account is suitable for set up, testing, training, etc. but not for broadcast.

4. Inthe Bing Map Logo section, enter or use the arrows to select a value to determine whether to use
the Bing Logo or an English or German credit string.

The options are:

0 = Bing logo

1 = Source: Bing™
2 = Quelle: Bing™

5. In the Mode section, select the Offline checkbox to use the application without downloading new
map tiles from the server.

To save your configuration:

e At the bottom of the Connection tab, select Save and then select OK.
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Proxy

The XPression Maps software requires access to the Internet to function properly. If your organization
uses an Internet proxy server, enter information about your organization's proxy server in this tab.

Consult your local IT administrator for the proxy server access information.

[l pocferences k4

Preferences - Proxy Tab
To connect the XPression Maps application to the internet through a proxy server:

1. In the Hostname field, enter the IP address of the proxy server.

2. In the Port field, enter the port number over which the application and server will communicate.
3. In the Username field, enter a user name for the proxy server.
4.

In the Password field, enter a password for the proxy server.
To save your configuration:

o At the bottom of the Proxy tab, select Save and then select OK.
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Data (Optional)

If you purchased the Data feature, this tab will appear in Preferences.

To properly use the Data feature, you must also install the DataLinq Server Software from the USB
drive found within the purchase package. The DatalLinqg Server Software is what brings in the data to
be used in XPression Maps. Without this connection you will not be able to import external data.

Information on installing the DataLinq Server Software can be found in the XPression User Guide.
In the Data tab you can specify the location of the folder where the the following information is stored:

« Dynamic Data Query Folder: contains files with the data that will be generated when you add an
external Data drawing to your scene.

o Dynamic Data Layout Folder: contains files that specify the layout of the data that is generated.

Prefarences ®
o

Preferences - Data Tab
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To specify which query and layout files to use:

1. In the Query Folder section, select the Browse button( | = ) beside the Folder field and navigate to
the folder from which you want to get the external data information.
The default location is C:\XPressionMaps_3.0\DDQueries.

2. In the Layout Folder section, select the Browse button (/- ) beside the Folder field and navigate to
the folder from which you want to get the external data layouts.

The default location is C:\XPressionMaps_3.0\DDLayouts.
To add a DatalLinq Server:

1. Select the Add button.

The Add Datalinq Server window opens.

I Add Dataling Server X
Name: New Server Name|
Host: |o0x.x. XX
Port: [ss38 |2
State 0
oKk || Canel |

Add Dataling Server Window
2. In the Name field, enter a name for the new DataLinq Server.
3. In the Host field, enter the host IP address.
4. In the Port field, enter the port that connects to the DatalLinq Server.
The default port number is 8888.
5. Select the State checkbox to view the status of the DataLinq Server Connection.

If the connection passes the DataLinqg Server will be highlighted in green. If the connection fails the
DatalLing Server will be highlighted in red.

6. Select OK.

The DataLinq Server has been added.
To configure a DatalLinq Server:

1. Select the DataLinq Server you want to edit from the list of servers and select Configure.

The Configure DataLinqg Server window opens.

[ Configure Dataling Server X
Name: Docs Test 1|
Host: X00X.X.XX
Port: [sss8 |2
State of
oK | cancel |

Configure Dataling Server Window
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2. Edit the fields that require a change and select OK.

The DataLinq Server has been configured.
To delete a Datalinq Server:

1. Select the Dataling Server you want to delete from the list of servers.
2. Select Delete.

The Delete Server confirmation dialog opens.

kA Delete Server X

o Do you want to delete the selected server?

Yes Do

Delete Dataling Server Window

3. Select Yes to delete the server.
To export DatalLinq Server Data:

1. Select the Dataling Server data you want to export and select Export.

The Export External Data Server Information File folder opens.

[ Export External Data Server Information File

o

B ThisPC > Local Disk (C:) > XPressionMaps 3.0 > bin64 > Dataling

Organize +  New folder - @

Name ’ Date modified Type

v @b Network
[ L-OTDALBERGA

File name: | Docs test 1.edsif

Save as type: | Extemnal Data Server Information File (*.edsif)

~ Hide Folders Cancel

Export External Data Server Data
2. In the File name field, enter a name for the exported data file.
The default location for saving these files is C:\XPressionMaps_3.0\bin64.

3. Save the file in your local XPressionMaps_3.0 files or create a DatalLinq folder and save the
External Data Server Information File (*edsif).

The external data server information file is saved in the selected folder.
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To import External Data Server Information Files:

1. Select the Import button.
The Import External Data Server Information File window opens.

I import External Data Server Information File
2 Dat. o

1+ ThisPC > Local Disk (C:) > XPressionl Maps 3.0 > biné4 > Dataling
e = O

Organize v New folder
Name
# Quick access

@ Creative Cloud Files
[ This PC

¥ Network
[ |-OTDALBERGA

<
v | | Control External Data Server Fils

File name:

Import External Data Server Data
Select the External Data Server Information File (*edsif) or select the DataLinq folder you
created and then select the file and select Open.

The External Data Server Information File is added to the list.

To save your configurations:

¢ At the bottom of the Data tab, select Save and then select OK.
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Video I/O (Optional)

Video Inputs and Outputs are functions enabled by a variety of licensing options and may not be
present in your configuration.

If you do have this feature, you can configure the video inputs and outputs as either SDI or NDI. The
number of Inputs will be limited to a total of four and can be mixed between HD-SDI or NDI™ sources.
The number of Outputs is limited to two, and can be configured as a Video and Alpha pair.

B Proferences ®

NDIMNewTek.com

Preferences - Video I/0O Tab
To configure an SDI Video Output:

1. In the Video Output - SDI section, select the Enable checkbox, if you are using an SDI output.
2. Select the Enable Key checkbox if you want to see the Key image in the output.

The Key image is automatically put on the next frame buffer above the one used for the output (ie on
frame buffer 4 if the output is on frame buffer 3).

3. From the Device drop-down, select the video card in your XPression Maps hardware.
4. From the Reference drop-down, select one of the following options:

e The FREERUN reference (used for testing).

e An external reference (REF).

e Sync with the corresponding video input.

5. From the Test Pattern drop-down, select from a number of different patterns if you want to see a
test pattern in the output (for testing purposes) or select OFF for on-air viewing.
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To configure an NDI Video Uutput:

1. In the Video Output - NDI section, select the Enable checkbox, if you are using an NDI output.
2. In the Stream Name field, enter the streaming service being used.
The default service is Maps NDI Stream.

3. Select the Send Alpha checkbox, if you want to see the Alpha image in the output.
To configure video inputs:

1. In the Video Input section, for each input, use the drop-down to select whether that input is
Disabled or is an SDI or NDI input.
If you select either SDI or NDI, you will see additional parameters for each input.

2. For an SDI input:
e From the Device drop-down, select the video source for the input.

e In the Buffer field, enter a value or use the arrows to select which frame buffer to use.

3. For an NDI input, use the drop-down to select the Name of the input source.
Full Screen Video Input Layer:

e From the Use drop-down, select an Input Layer.
The options are:
> Off
» Input1l
» Input 2
» Input 3
> Input 4
The Full Screen Video Input Layer is set to Off by default.

To save your configuration:

e At the bottom of the Video I/0 tab, select Save and then select OK.
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Tools

XPression Maps contains a number of operational and informational tools, as described in the following
sections:

Undoing a Stack[ 261
Measuring Distances| 271
Reloading the Active Map[ 21
Selecting the Edit Mode[ 291
Undoing/Redoing Operations| 32
Taking Snapshots| 32
Exporting Maps| 331

View Menul 361

Help Menul s

Log Informationl ss
Download Information[ s

GPU Memory Usage[ 3
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Undoing a Stack

XPression Maps keeps a list of the commands that have been performed in a scene, called a Stack. At
any point, you can go back to a previous command and effectively undo the commands that followed it.
This is useful if you want to undo many moves, as it is faster than using the Undo menu command or

icon to remove each individual step.

To undo a stack:

1. From the menu bar select Edit > Undo Stack.

The Undo Command List dialog opens. The first command is at the top of the list. The most recent
command is at the bottom of the list.

4 Undo Command List ? d

[»

Select Contour
Deselect Contour
Mowve Camera
Create Line
Add Point
Add Point
Add Point
Add Point
Add Point
Add Point
Add Point

Create Icon
Necelert lcnn

Undo Stack Command List

1]

2. Select the last command you want to keep to select it.
You may need to use the scroll bar on the right, to find the command you want, if the stack is long.

The commands following the selected command will be removed from the scene, but will remain in
the stack.

4 Undo Command List ? d

Deselect Text
Create [con
Scale lcon
Deselect lcon -
Mowve Camera
Maowve Camera
Mowve Camera
Mowve Camera
Maowve Camera
Mowve Camera
Maowve Camera
Mowve Camera

[»

1]

Undo Stack Command List

3. Select a command further down in the list to restore commands that you have undone, if necessary.

4. Select the X in the top-right corner of the dialog to close it.
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Measuring Distances

The Measurement Tool allows you to calculate the distance between two points on the map and add a
text drawing to display the result.

You can also use the tool to display an area of interest of a specific circumference, for example, the
extent of shock waves of an earthquake.

The distance can be calculated in either the Metric or Imperial measurement system

To use the Measurement Tool:

1. From the menu bar select Edit > Measurement Tool.
Alternatively, you can click the Measurement Tool button in the toolbar.
Ol DR 4 = QQ[d 3 | . o A

XPression Maps Toolbar - Measurement Tool

The Measurement Tool opens.

B4 Measurement Tool ? *

Tail Longitude: Latitude: | h5.2896 =)

Head Longitude: | -76.4301 [#|  Latitude: (452845 |3

Show Cirde: ]

i rr—

Measurement Tool

2. Select the Show Circle checkbox to display a circle whose radius is determined by the distance
between two locations or by the size of the area of interest (optional).

3. From the Units drop-down, select whether to display the distance using the Metric or Imperial
system.

4. Left-click on the starting location (represented in the Measurement Tool by the Tail coordinates)
and drag the cursor to the destination (represented by the Head coordinates).

A white circle is drawn on the map and the measurement is calculated and indicated along the
straight line.

Measurement Tool Illustration - Calculation
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To display measurement units:

1. In the Drawing Toolbox, in the Text group, select a text drawing.
2. Then click on the white measurement text on the map.

The measurement is automatically displayed in the text drawing, provided the Zoom Level of the
map is within the drawing Visibility In and Out parameters.

W S, e il . o

Measurement Tool Illustrations

3. Adjust the location of the text drawing, if necessary.
4. To finish, select Done.

The white circle, line and original measurement text are removed, leaving just the text drawing with
the measurement.

The Measurement Tool closes.
5. Add an area or custom drawing to illustrate an area if desired.

6. To start over, before selecting Done, select Reset.
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Reloading the Active Map

This feature is used to refresh the current map. This is useful if your scene is missing map tiles or
displaying map tiles remaining from a previous map.

To reload the active map:

e From the menu bar select Edit > Reload Active Map.

Selecting the Edit Mode

The Edit option allows you to select one of the following modes:

Standard - default mode for creating scenes

Presentation - mode that allows one-touch zoom in and out, useful in full-screen presentations

The selected mode will be indicated with a checkmark.

To select an Edit Mode:

1. From the menu bar select Edit > Edit Mode.

2. From the menu, select Standard or Presentation.
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Selecting Disputed Borders

The Disputed Border option allows you to view disputed borders on any map style selected in the
output window and add OpenStreetMap data to the scene.

When activated, the disputed border option displays the disputed borders of regions with two colors;
green and red.

To activate Disputed Borders:

e From the menu bar select Edit > Select Disputed Borders.

The output window will display green and red borders in areas of the map that have disputed border
lines.

+ ? SURINAME" /

Disputed Borders
To add data:

1. Determine the longitude and latitude coordinates of the airport, place or body of water you want to
add to the map.

2. Inthe area of the map to which you want to add data, press Shift + Right click to open the Add
Data window.

Add Data
Add to 'aerodrome/airport-name’

Add to 'places/city’
Add to 'places/country’
Add to 'places/hamlet’
Add to 'places/others’
Add to 'places/town’
Add to 'places/village'

Add to 'water/ocean-name'

Add to ‘water/water-name’

Disputed Borders - Add Data Window
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3. Select the data label you would like to add to the map
The Add OpenStreetMap Data Window opens.

H Add OpenStreetMap Data X

1
e |
PTEEEE——
e |
o |
. .|
e |
 _|

Disputed Border - Add OpenStreetMap Data Window
4. In the Layer/Name drop-down select the layer name you want to add to the map.

5. In the Longitude and Latitude fields, enter the longitude and latitude of the airport, place or body
of water.

6. In the Rank field, use the arrows to determine which ranking the new layer name will take.
The default Rank is 1.

7. In the Default Text field, enter the new layer name for the selected region.

8. Use the Text drop-downs to select the languages in which to display the text.
The default languages are: English, Chinese, Spanish, French, Arabic and Russian.

9. Select Done to save the new layer name.
The new layer name of the selected region will be displayed on the map.

10.Select Edit and clear the Select Disputed Borders checkbox to turn off disputed borders.
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Undoing/Redoing Operations
You can undo an operation(s) or redo an operation that was undone, from the Edit menu or the toolbar.
To undo the last operation:

e From the menu bar, select Edit > Undo or select the Undo button in the toolbar or press Ctri+Z.

XPression Maps Toolbar - Undo

To redo the last operation:

e From the menu bar, select Edit > Redo or select the Redo button in the toolbar or press Ctri+Y.

XPression Maps Toolbar - Redo

Taking Snapshots
The Snapshot tool saves the content of the Output Window as a still image.
To take a snapshot:

1. From the menu bar select Output > Snapshot or select the Snapshot button in the toolbar.

XPression Maps Toolbar - Snapshot

2. In the Save dialog, navigate to the folder in which you want to save the image file.
3. In the File name field, enter a name for the image file.
4. From the File Type drop-down, select the file format for your image.

The options are .jpg, .png and .tga.

5. Select Save.
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Exporting Maps

The Export Map feature allows you to write an .hdr file of a selected portion of the output. An .hdr file
is a header file that stores the georeferencing information of an associated raster file.

Four files are created:
e a .png image containing the RGB information.
e an .igb file containing the elevation data.

e an .hdr file containing information about the boundaries of the exported map (minimum and
maximum longitude and latitude coordinates), as well as information about the .igb file.

¢ an _N.png image that shows the normals that are calculated out of the elevation data.

You can export a newly created map or an existing one that has previously been exported.
To export a new map:

1. With a map displayed in the output window, from the menu bar select Output > Export Map.
The Export Map dialog opens.

The camera projection type is set to Linear (a map with variables that change proportionally), the
Tilt value of the camera is set to 0 and a bounding box marks the portion of the map that will be
exported.

When the Export Map dialog is closed, the camera projection type and tilt are reset and the
bounding box is removed.

“ Export Map ? X

Export Map

2. Click and drag the corner points of the bounding box to expand or decrease the portion of the map to
be exported.

You can also right-click inside the bounding box and drag it to change the position of the box as a
whole.

3. In the Export Map dialog, select the Browse button ( ) beside the Map Name field to navigate to
the location to which you want to export the map file.

4. In the Export Map File file browser, enter a File name for the map and select Save.
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5. In the Image section, select the Resolution in pixels.
The options are:
e 512
e 1024

2048

e 3072
4096

8192

Keep Aspect is selected by default so that the height of the exported image has the selected
resolution, and the width is calculated so that the aspect ratio is preserved.

6. In the Height section select the Format from the drop-down.
The options are:
* png
e raw (igb)

7. Navigate to the folder where you want to save the Bounding Box file (the .xml file), enter a name in
the File name field and select Save.

The path to the Bounding Box file is entered into the Name field.
8. Select Save to save the scene name, resolution and bounding box to disk.
The Save File dialog opens.
9. Select Export to export the files.
This creates the export files and a bounding box file with the extension .xml.
This might take some time. When the export is finished, the Export Map dialog closes.

Selecting Cancel closes the Export Map dialog without creating the files.
To export an existing map:

1. From the menu bar select Output > Export Map in the menu bar.

The Export Map dialog opens.

B Export Map ? X

Export Map
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2. Select Load and in the Bounding File file explorer, select the file to load and select Open.

The associated .hdr file name appears in the Map Name field and the .xml file appears in the Name
field of the Bounding Box section.

3. Then select Export.
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View Menu

The View menu contains options for changing the Output Window to fullscreen mode and for showing
or hiding the various editors, controls and toolbars.

You can also reset the XPression Maps User Interface to its default screen.
To change to fullscreen mode:

e From the menu bar select View > FullScreen.

To change to windowed mode:

e Press the Esc key.

To show or hide an editor, control or toolbar:

1. From the menu bar select View.

2. In the menu, check the options you want to show and clear the options you don’t require.
To reset the XPression Maps User Interface to the default setting:

1. From the menu bar select View > UI Setup and select Reset UI to Default.

The Reset UI to default window opens.

B Reset Ul to default X

o Do you want to reset the Ul and all dialeg positions to the default layout?

Yes No

Reset UI to Default Window
2. Select Yes to reset the layout.

The XPression Maps User Interface resets.
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Help Menu

The Help menu contains the About screen which provides version, copyright and licensing information
for the XPression Maps application.

B About ? X

About

This application allows the user to record animated flights over maps with different kinds of graphical
information.

The Bing™ Aerial, Bing™ Aerial Label and Bing™ Road map styles come from Microsoft® Bing Maps. Bing Maps
is a registered trademark of Microsoft® in the United States and/or other countries.

Users must conform with the Microsoft® ,in
particular, the Content Attribution Requirements.

Help Menu About Screen
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Log Information

The Log Information window displays information based on the Log Level selected in Preferences >
Outputl o7 You can also clear the display when the information is no longer needed.

ARTSRESTMapTileLoader::Metwork Image
Warning: Error downloading http: /f

ecn. t0. tiles, virtualear th.net,tiles/
a1202330030.jpeg?g=5879 - server replied:
Request Time-out
ARTSRESTMapTileLoader::MNetwork Image Error:
[Error downloading http://

ecn. t0. tiles, virtualear th.net,tiles/
21202330030.jpeg?g=5879 - server replied:
Request Time-out] give up retrying!
ARTSRESTMapTileLoader: :Network Image
Warning: Error downloading http: /f

ecn. t1.tiles. virtualear th.netytiles/
21202330103.jpeg?g=5879 - server replied:
Request Time-out
ARTSRESTMapTileLoader::MNetwork Image Error:
[Error downloading hitp:
ecn.tl. tiles. virtualear th.net/tiles/
21202330103.jpeg?g=5879 - server replied:
Request Time-out] give up retrying!
ARTSRESTMapTileLoader::Metwork Image
Warning: Error downloading http: /f

ecn. t3.tiles, virtualear th.net,tiles/
21202330112, jpeg?g=5879 - server replied:
Request Time-out
ARTSRESTMapTileLoader::MNetwork Image Error:
[Error downloading http:/f

ecn. t3.tiles, virtualear th.net/tiles/
a1202330112.jpeg?g=5879 - server replied:
Request Time-out] give up retrying!
ARTSRESTMapTileLoader: :Network Image
Warning: Error downloading http: /f

ecn. t3.tiles, virtualear th.net,tiles/
21202312333.jpeg?g=5879 - server replied:
Request Time-out

ARTSRESTMapTileLoader: :Network Image Error:
[Error downloading hitp:

ecn. t3. tiles. virtualear th.netytiles/
21202312333.jpeg?g=5879 - server replied:
Reguest Time-out] give up retrying!

Log Information Window
To select the level of information you want displayed:
e In the Log Information section, from the Log Level drop-down, select the level of information you
want to see generated.
The options are:
Critical - Logs activity that could result in unpredictable behavior.
Error - Logs errors only.
Warning - Logs unsuccessful operations.
Information - For internal use only, for technical support.

Debug - For internal use only, for technical support.
To clear the log information:

e Select the Clear button.
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Download Information

The Download Information window displays the map download activity.

Download Information Window

Map requests are scheduled for download and up to 30 map downloads can be active at the same time.
The progress bar in the window displays how many map parts remain to be downloaded. The progress
bar can display the following colors:

Green — low load
Orange — all download links in use

Red — high load

Values higher than 100 on the progress bar can result when you play a camera animation for the first
time, when the quality of the map has a value greater than 0, or when the globe is tilted to a small
viewing angle.

* Zooming in from the satellite view to the street level view of a city will go through many map zoom
levels and all visible map parts need to be downloaded first.

GPU Memory Usage

Use the GPU Memory Usage progress bar to track how much memory your graphics processing unit
(GPU) is using at any given moment.

GPU Memory Usage Progress Bar
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Map Styles

In XPression Maps, the handling of the maps is based on the structure delivered by Bing maps. Maps in
Bing are images with seamless tiles with a size of 256 x 256 pixels each. The tiles are available in 21
quality/zoom levels. The first level shows the full map of the earth on 1 tile. Each next level will divide
the content of a tile into four sections of 256 x 256 pixels, so the quality of the content is doubled in the X
and Y coordinates for each level. Depending on the map quality in the Bing database, this process stops
in higher quality levels and the best possible quality image is used.

XPression Maps uses Bing maps, the Blue Marble map from NASA and OpenStreetMaps. You can select a
map style from the default styles provided or create your own.

You can select different map styles in the Map Styles tab and edit map styles in the Map Style
Manager. The properties are described in the Map Style Properties section.

The following topics are discussed in this section:
Using Map Styles[ 4
Editing Map Styles[ 4"

Map Style Properties[ s
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Using Map Styles

A different map style can be selected without changing any of the other elements of a scene. You can
select map styles that will change during animation in one of two ways:

Animated[ 41 Predefined map styles appear as specified by key frames.

Automaticl4Y: Specified map styles appear at different zoom levels.

Animated Map Style

Use the Animated Map style to create a scene in which the map style changes at set points in the
timeline, specified by key frames.

To use an animated map style:

1. In the Map Styles section to the right of the output window, select the Animated Radio button, if
it's not already selected.

Map Styles - Animated Option

2. In the Search Editor, enter the location at which you want to animate the map and select Search or
press the Enter key.

Enter Location

3. In the Map Styles section, from the Style drop-down, select the map style for the beginning of the
animation.

Map Styles - Select Style

4. From the camera parameters below the output window, select a starting Zoom Level.

149138 |2} O its|0.0000 |2/ Q

0.23% |2 Q Roli|0.0000 |3/ Q

Camera Parameters - Zoom Level
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5. With the timeline slider at the beginning of the timeline, select the Radio button to the right of the
Style drop-down to key frame the starting map style.

Map Style Key Frame

6. Then select the Add Camera Key Frame button to key frame the starting zoom level.

Add Camera Key Frame
To add to an animated map style:

1. Move the timeline slider to the point in the timeline at which you want to change the map style.

2. Alternatively, click on any point in the timeline to move the slider to that point or enter the position in
the frame counter to the left of the timeline.

[=1<| [ [3)]

Frame Counter

3. From the Style drop-down, select the next map style you want to apply to your scene.

Map Styles - Select Style

4. From the camera parameters below the output window, select a Zoom Level for the new map style.

Map Style Key Frame

5. In the Map Styles section, select the Radio button to the right of the Style drop-down to key frame
the new map style.

Map Style Key Frame
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6. Select the Add Camera Key Frame to key frame the new zoom level.

Add Camera Key Frame

7. Select the green Play button in the animation toolbar to play the animation.

Automatic Map Style

Use the Automatic Map style to create a scene in which the map style changes at specified zoom levels.

To use an automatic map style:

1. In the Map Styles section to the right of the output window, select the Automatic Radio button.

Map Styles Tab - Automatic Option
2. Move the map in the Output Window to the location that you want to show.

Alternatively, in the Search Editor, enter a location in the Location / Address, City, Country field
and select Search.

3. Select the Editor button that appears beside the Style selector.

The Map Layer Manager opens.

B Map Layer Manager ? *

Map Layer Manager
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4. Select Add to add a new layer.
Each layer represents a point at which the map style will change.

By default, the current map style will be entered for the new layer along with a default zoom level of

20.
B4 Map Layer Manager ? *
Name Style Zoom | | Add |
1| MNew Layer 0O5M-Basic Aerial 20 Delete
Done

Map Layer Manager - Add New Layer
5. In the Name column, double-click New Layer and give the layer a meaningful name.

This could be the name of the country or the area of the map that you want to display at the selected
Zoom Level.

6. In the Style column, double-click the map style and from the drop-down, select the style of map you
want to apply to the layer. See Editing Map Styles for more information.

7. In the Zoom column, double-click the default Zoom Level and enter a value or click the arrows to
select the Zoom Level to apply to the layer.

X The table is ordered by ascending Zoom levels, so a change in the Zoom value can result in a
reordering of the layers.

8. Repeat steps 2 to 6 to add additional layers and then select Done to close the Map Layer Manager.

During animation, as each Zoom Level is reached, the map style will change according to the table.
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To save an automatic map style layer:

1. In the menu bar select File > Save or select the Save button in the toolbar.

XPression Maps Toolbar - Save

The file browser opens.

Fi..er 1/17/2023 11:36 AM
certs Fi..er 1/17/2023 11:36 AM
Export test Fi..er 3/29/2023 6:27 PM
linterface Fi.er 1/17/2023 11:36 AM
imagefermats Fi..er 1/17/2023 11:36 AM
key Fi.er 2/1/202312:43PM
log Fi..er 1/24/2023 11:50 AM
platforms Fi.er 1/17/2023 11:36 AM
sqldrivers Fi.er 1/17/202311:36 AM
Test Fi.er 4/17/202311:43 AM

ame: |Automatic Map Style Layer1.wnm

Save File

2. Select a folder or destination where the scene is to be saved.
The default location is C:\XPressionMaps_3.0\bin64.

3. In the file name field, enter a name for the scene.

4. Select Save.
To create an automatic map style animation:

1. Create an animation that uses the zoom levels added to the Map Layer Manager.

2. Select the green Play button in the animation toolbar to play the animation.
To delete a map layer:

1. Select the Editor button that appears beside the Style selector to open the Map Layer Manager.
2. In the Map Layer Manager, select the layer you want to delete and select Delete.

The Delete Map Layer confirmation dialog opens.

B Delete Map Layer X

3. In the Delete Map Layer confirmation dialog, select Yes.

4. When you have finished deleting layers, select Done to close the Map Layer Manager.
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Editing Map Styles

In the Map Style Manager as shown below, you can add, delete and edit existing map styles.

| Map Style Manager ? X
Name Al A
1 Bing Aerial
2 Bing Aerial Label Delete
3 Bing Aerial Lable Mercator |
4 Bing Aerial Mercator
5 Bing Road
] Bing Road Dark
7 Bing Road Gray
8 Bing Road Light
a Blue Marhle Colored |
| [save Al | | FReset Al | | Done

Map Style Manager

There are system map styles available that can be used as they are, or they can be modified to create a

new map style.

The system map styles are:

Bing Aerial

Bing Aerial Label

Bing Aerial Label Mercator

Bing Aerial Mercator

Bing Road
Bing Road Dark
Bing Road Gray

Bing Road Light

Blue Marble Colored

Blue Marble Colored Mercator

Styled

Blue Marble Satellite

BM Colored Mercator Styled
None

OSM-Basic Aerial
OSM-Basic Shadow
OSM-Custom Example
OSM-Style-A

OSM-Style-A Aerial
OSM-Style-B

OSM-Style-B 3D Building
OSM-Style-B Aerial

OSM-Style-D

* If Compact Scene on Save is selected in the Output tab in File > Preferences, all unused styles
in the map style list and in the shape style list are removed.
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To add a new map style:

1. From the menu bar select Style > Map Styles to open the Map Style Manager.

Alternatively, you can select the Map Styles button in the toolbar.

XPression Maps Toolbar - Map Styles
2. Select Add.
The Add Map Style dialog opens.

B Add Map Style ? x

Map Style Manager - Add Map Style
3. In the Name field, enter a name for the new map style.

4. From the Copy from drop-down, select one of the existing map styles to use as a base for the new
map style and select OK.

The Edit Map Style editor opens.

B cdit Map Style ? X

Edit May Style Editor
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5. Modify the properties of the new map style and select OK.

See Map Style Properties| s for information about modifying the properties.

The new map style appears in the Map Style Manager with the Save Style icon beside it.
6. Select the Save Style icon.

The Save Map Style confirmation dialog opens.

B save Map Style X

Save Map Style Confirmation Dialog

7. Select Yes to save your new map style into the database.
To delete a map style:

1. From the menu bar select Style > Map Styles to open the Map Style Manager.
2. Select the map style you want to delete and select Delete.

The Delete Map Style confirmation dialog opens.

B Delete Map Style x

Delete Map Style Confirmation Dialog
3. In the Delete Map Style confirmation dialog, select Yes to delete the map style.

The map style has been deleted.

* System map styles cannot be deleted. Only custom map styles can be deleted.
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To edit an existing map style:

1. From the menu bar select Style > Map Styles to open the Map Style Manager.

2. Select the map style you want to modify and select Edit or double-click the selected map style.

The Edit Map Style editor opens.

B cdit Map Style ? X

Edit Map Style Editor
3. Modify the properties of the map style and select OK.
See Map Style Properties[ s for more information.

The Edit Map Style dialog box closes and the Map Style Manager reopens. The edited style is
highlighted and the Save icon E=] and Reset icon are displayed beside it.

4. Select the Save icon E=] if you want to save your changes into the default database or select the

Reset icon to discard your changes and revert to the last saved version of the style. Then select
Done to close the Map Style Manager.

An exclamation mark at the left of the map style indicates that the style is saved in the scene but not
in the database. That style will not be available to be used in other scenes.

The Save All button at the bottom of the dialog box saves all changes made to all styles in
the database.

The Reset All button at the bottom of the dialog box resets all styles in the database to their

last saved version.
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Map Style Properties

Many of the properties of map styles can be customized for a different look. Properties such as map type,
brightness, country borders, light direction and mountain height can be edited in the Edit Map Style
dialog. These properties and others are described in the sections below:

Mainl s
Options/ 52
Background| 52
Overlay[s
Custom Datal s
Light[ ss)

3D[ s

Color Mapls
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Main

Use the Main section to change the Map Type and Projection. The Name is derived from the style
selected in the Map Styles > Style drop-down.

Parameter Description

Name The name assigned to the map style. System style names cannot be edited. If
you've created your own map style, you’ll be able to change the name if you want.

Map Type The style type of the map. System style types cannot be edited.

The available map types are as follows:

None — this style removes the map from the output. It can be used to show free-
standing colored country shapes and drawings on a background image.

Bing Aerial — this style displays satellite maps from Bing. You can zoom into
street level. The Bing logo appears in the output.

Bing Aerial with Label — this style displays satellite or structural maps from Bing
with country, city, and road information on top of the maps. You can zoom into
street level. The Bing logo appears in the output.

Bing Road — this style displays road maps from Bing in color. You can zoom into
street level. The Bing logo appears in the output.

Blue Marble Satellite — this style shows the topographic world image from the
NASA Blue Marble image gallery. The resolution of this map is reduced to
500m/px. No logo will be shown in the output.

Blue Marble Colored — this style displays a colored map generated from the Blue
Marble height model and a color table. It displays selected elevations in different
colors. See Color Mapl s for more information.

Bing Road Dark — this style displays road maps from Bing on a dark canvas,
useful for highlighting data. You can zoom into street level. The Bing logo appears
in the output.

Bing Road Gray — this style displays road maps from Bing on a grayscale canvas,
useful for highlighting data. You can zoom into street level. The Bing logo appears
in the output.

Bing Road Light — this style displays road maps from Bing on a light canvas,
useful for highlighting data. You can zoom into street level. The Bing logo appears
in the output.

VT (Vector Tiles) OSM Basic — this style is based on Open Street Map data.

VT (Vector Tiles) OSM Style A — this style is based on Open Street Map data.

VT (Vector Tiles) OSM Style B — this style is based on Open Street Map data.

VT (Vector Tiles) OSM Style C — this style is based on Open Street Map data.

VT (Vector Tiles) OSM Style D — this style is based on Open Street Map data.
Projection Defines the projection type of the map.

Select one of the following options:

Sphere — uses a round shape like a globe

Mercator — uses a cylindrical map projection

Linear — uses a map with variables that change proportionally

Alpha Channel Select the Alpha Channel checkbox if you want to use the Alpha Channel in the
final output and see a checkerboard pattern in the preview.

K Once the external map tile server is configured (OpenStreetMap server), new map types that
correspond to the configuration will be displayed.
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Options

Use the Options section to adjust the general appearance of a map style.

Parameter Description

Quality Increases or decreases the amount of image content and Zoom Level for a map
style.
0: Normal

1: Increases the Zoom Level by 1 and downloads 3 times more image content than
normal.

Labels on Bing Aerial and Bing Road maps will be smaller.

The available quality range is -3 to 3.

-1: Decreases the Zoom Level by 1 and downloads 3 times less image content than
normal.

Labels on Bing Aerial and Bing Road maps will be larger.

The available quality range is -3 to 3.

Brightness Increases or decreases the brightness level for the map style.

Gamma Increases or decreases the gamma level for the map style.

Contrast Increases or decreases the contrast level for the map style.
Background

Use the Background section to adjust the parameters of the background elements in a map/scene.

Parameter Description

Drawing From the Drawing drop-down, select a drawing to be displayed as the map/scene
background.

Mode From the Mode drop-down, select the scaling of the drawing.

Fullscreen — shows the background over the whole output window. This may distort the
drawing.

Letterbox — makes the width fit into the output window, while preserving the aspect ratio.

Pillarbox — makes the height fit into the output window, while preserving the aspect ratio.
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Overlay

These parameters control the appearance of geographical elements such as country borders, country
names, state borders, roads, rivers, lakes, and oceans. Also, a full raster image (a fullscreen image that
lies on top of the globe and has some transparent part) can be defined. The location and spelling of the
country nhames can be set through the Shape Database Viewer.

See the Shape Database Viewer[ 23 for more information.
To configure the overlay parameters:
1. If you want to use a raster image to create a border around the map, select the checkbox for Full

Raster Image and then select a background image from the drop-down.

The background image needs to have a transparent section in the middle for the map to show
through.

2. Select the Overlay Layer(s) you want to use from the drop-down.

A preset overlay of the layers (each using different colors, icons, etc.) is superimposed on the
selected map style.

The options are:
VT OSM Basic Trans
VT OSM Style A Trans
VT OSM Style B Trans
VT OSM Style C Trans
VT OSM Style D Trans
3. Select More to open further configurations.

The Edit Map Style Overlay More window opens.

[ Edit Map Style Overlay More ? X
S'CZ.-m'ysadus: 300 [sf Color
(]Country Names: 1.00 |8  Color

Name Style: | Arial BI v |
[)State Borders: 020 |8 Color
Max-Rark Out Leved

[JRivers: a0 el o (5500 2]
Otaes: o [0 [2]
[10cean Mask: Color

Cancel | ok |

Edit Map Style Overlay More Window
To configure more overlay parameters:

1. Select the checkbox of the geographical element(s) you want to include in the map.

2. For Country Borders, Country Names and State Borders enter or select a value for the line width
or font size using the field next to the selected element.

Valid values are 0.10 to 10.00.
3. Select the Color button to select a color for the element.

4. From the Name Style drop-down, select the style in which you want the names of countries, states
and regions to appear.
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5. For Rivers enter or select a value for the line width or font size using the field next to Rivers.
Valid values are 0.10 to 10.00.
6. Select the Color button to select a color for the element.

7. For Rivers and Lakes enter or select a Max-Rank and Out Level to change the density of the
waterways.

Valid values are 10 to 300.
8. For Ocean Mask, select the Color button to select a color for the element.

If you want to use the Apply Ocean Mask feature to hide the parts of a shape that extend into the
ocean, the Ocean Mask checkbox needs to be selected.

Custom Data

In the Custom Data section, satellite and elevation maps that have been imported in the Custom >
Custom Maps editor can be selected. If enabled, they are drawn on top of the regular (Bing or Blue
Marble) maps, ensuring that there are no missing areas. The parameters in the Custom Data section
are only available when a custom map has been selected.

To configure the custom data parameters:
1. From the menu bar select Style > Map Styles, and in the Map Style Manager, select the map
style for which you want to add a custom map.

OR

Create a new map style with your custom map. See To add a new map style[ s for more
information.

2. Select Edit.
3. In the Custom Data section:

e To use a custom map, select the Map checkbox and from the corresponding drop-down, select the
custom satellite map you want to use.

e To use an elevation map, select the Elevation checkbox and from the corresponding drop-down,
select the elevation map you want to use.

Elevation maps provide crisper, better-defined illustrations of height data.
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Light

Use this section to edit the parameters for the lighting on the map.

Parameter Description

Light Direction  Enter or select the longitudinal direction for the light on the map. This parameter
Longitude only takes effect if Shading or Height Shading are selected.

Light Direction  Enter or select the latitudinal direction for the light on the map. This parameter only
Latitude takes effect if Shading or Height Shading are selected.

Shading Select this checkbox to enable shading on the map. The Shading function activates

a rendering mode that lights the globe with a spotlight from the light direction to
simulate the look of sunlight. The Intensity and Blending parameters work
together to define the spotlight:

Intensity — increases or decreases the intensity of the spotlight. With Blending
set to 100, a value of 0.05 will create a small intense spotlight, while a value of 1 or
more will create a large, more diffuse spotlight. As you lower the Blending value,
the spotlight becomes less noticeable.

Range is 0 to 10.

Blending — increases or decreases the amount of shading around the spotlight. A
value of 0 displays no shading and the globe looks the same as if Shading was
disabled. A value of 100 will provide a large amount of shade, making the spotlight
more noticeable.

Height Shading Select this checkbox to enable Height Shading on the map. Height Shading
makes the elevated areas of the map more noticeable.

The following parameters adjust the height shading appearance:

Blending — increases or decreases the amount of relief that is displayed. A value
of 0 shows no relief and a value of 100 shows complete relief.

Diffuse Factor — enter or select an amount to define how the light will affect the
parts of the relief away from the sun. A value of 0 will result in a black color for the
affected areas of the map and a value of 100 will result in a shiny white color for the
affected areas of the map.

The second parameter for the Diffuse Factor defines an offset to the relief as
whole. For a value of 0, some parts of the relief will be totally black. A value of 100
makes the relief totally white.

Specular Factor — determines how the light will affect the parts of the relief on
which the sun shines directly. A value of 0 will result in a black color for the affected
areas of the map and a value of 100 will result in a shiny white color for the affected
areas of the map.

Min. Clamp — enter or select an amount of shading relief used at locations where
the height is equal to or greater than the value of Min. Clamp. The value 0
corresponds to sea level.

This parameter only applies to the Blue Marble Colored map type.
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3D

The 3D section allows you to create a real three dimensional surface of the world generated from the
Blue Marble map type height data.

Parameter Description

Mountain Height Enter or select a scale factor for the height data to make mountains appear higher
or lower than normal. A value of 1 corresponds to the correct height. For street
level views, the height is interpolated to 0 because the resolution of Blue Marble
height data is not sufficient.
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Color Map

This section applies to Blue Marble Colored map types only.

Use this section to add, edit, and delete color maps for a style. A color map is a table of height values
and colors that will graphically show elevation data in a map.

To add a new color map:

1. In the menu bar select Style > Map Styles to open the Map Style Manager.
2. Select the map style you want to edit (must be a Blue Marble Colored map style) and select Edit.

3. Then, in the Edit Map Style editor, in the Color Map section, select the A button.

| Edit Map Style ? X

Edit Map Style Editor

The New Color Map dialog opens.

B Mew Color Map ? H

Add Color Map

4. Inthe New Color Map dialog, enter a name for your new color map.
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5. If you want to copy an existing color map to use as a template, from the Copy from drop-down,
select the color map you want to copy.

There are several default color maps from which to choose from. As you create new color maps, they
will appear in the drop-down.

The Edit Color Map dialog box opens.

File Edit Stle Custom Output Animation Interactive View Help

Pl DR 4 =QE(dd BRrx NS NS B0
‘Shape Editor e
e ————]
I edit Color Map ? X
Name HyColriap
e fw cem me A
3000 255 255 255 255 [E

1200 255 (255 0 (255

Edit Color Map
6. In the Edit Color Map dialog, select a row and do any of the following:
e Double-click a value in the Height column to change the elevation.

e Click in any of the color columns to open the Select Color window and change the color of that
elevation.

e Select Add to duplicate the row and then edit the duplicate row.
e Select Delete to remove the row.

Any changes will cause a reordering of the table so that the height values are sorted in descending
order.

7. When you are satisfied with how your color map looks, select OK to close the dialog.
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To save a new color map:

1. In the Edit Map Style dialog, adjust the properties of the map style as described in Map Style
Properties|so.

2. Then select OK to close the dialog.

3. In the Map Style Manager, select the Save button beside the map style you edited to save the new
color map to the database.

An exclamation mark indicates a color map that hasn't been saved.

4. In the Save Map Style confirmation dialog, select Yes and then select Done to close the Map Style
Manager.

To edit the color map parameters:

1. From the menu bar select Style > Map Styles to open the Map Style Manager.

N

Select the map style you want to edit (must be a Blue Marble Colored map style) and select Edit.

w

In the Edit Map Style dialog, in the Color Map section, from the Name drop-down, select the color
map you want to edit.

4. Select the Edit | - ' button beside the Name drop-down to open the Edit Color Map editor and edit
the selected color map as described in To add a new color mapl so".

5. When you have finished editing the color map, select OK.
6. In the Edit Map Style dialog, select OK to close the dialog.

7. In the Map Style Manager, select the Save button beside the edited map style to save the new
color map to the database.

8. In the Save Style confirmation dialog, select Yes and then select Done to close the Map Style
Manager.

To delete a color map:

1. From the menu bar select Style > Map Styles to open the Map Style Manager.
2. Select any Blue Marble Colored map style and select Edit.

3. In the Edit Map Style dialog, in the Color Map section, from the Name drop-down, select the color
map you want to delete.

4. Select the D button.

—| 3D
Mounitain Height: 100 |2
—Color -I“Inp -
Mame: Default Color Map - ‘L%
| cancal || oK

Delete Color Map
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The Delete Color Map confirmation dialog appears.

B Delete Color Map X

Delete Color Map
Select Yes to delete the selected color map.
In the Edit Map Style dialog, select OK to close the dialog.

In the Map Style Manager, select the Save All button to save your change.

© N o u

Then select Done to close the Map Style Manager.

The Color Map has been deleted.
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Managing Templates

You can configure scene templates with location labels, drawings and shape styles to be available for use
with the XPression Maps HTMLS5 Client, which is used in XPression NRCS MOS workflows and the
XPression graphics designer. You can also organize the scene templates into groups to make them easier
to find.

The templates are managed in the Scene Templates editor.

You must be running in Server Mode to use scene templates. See Launching the HTML5 Client/s0) for
instructions on changing the startup mode.

The following topics are discussed in this section:
Managing Scene Template Groups/e2
Managing Scene Templates/[ 4

Editing Saved Templates[ s
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Managing Scene Template Groups

In the Scene Templates editor, you can add, edit and delete groups.

For information about adding, editing and deleting scene templates, see Managing Scene Templates| .

To add a scene template group:

From the menu bar select Output > Manage Templates or select the Manage Templates button
in the toolbar.

XPression Maps Toolbar - Manage Templates

The Scene Templates editor opens.

i Scene Templates

Europe

Still Map

Scene Templates Editor
2. In the Scene Templates editor, select the Browse button (iIb beside the Group drop-down.

The Template Groups dialog opens.

i Temnplate Groups

All maps with the satellite style.

Template Groups Dialog
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3. In the Template Groups dialog, in the Name field, enter a name for the new template group.

4. In the Description field, enter a description of the type of maps that will be saved in this group.
Then select Add.

5. Add scenes, location labels, drawings and shape styles to the new group.

6. Select Done to close the dialog.
To edit a scene template group:

1. From the menu bar select Output > Manage Templates or select the Manage Templates button
in the toolbar.

Pld e ¢ = GEds BErE
XPression Maps Toolbar - Manage Templates
The Scene Templates editor opens.

2. In the Scene Templates editor, from the Group drop-down, select the scene template group you
want to edit.

Select the Browse button (/:+ ) beside the Group drop-down to open the Template Groups dialog.
In the Template Groups dialog, enter a new name for the group or edit the description.

Select Update.

o u & W

Select Done to close the Scene Templates editor.
To delete a scene template group:

1. From the menu bar select Output > Manage Templates or select the Manage Templates button
in the toolbar.

ol K 2N 4 Gl eRFs
XPression Maps Toolbar - Manage Templates
The Scene Templates editor opens.

2. In the Scene Templates editor, from the Group drop-down, select the scene template group you
want to delete.

Select the Browse button (/) beside the Group drop-down to open the Template Groups dialog.
In the Template Groups dialog, select Delete.

In the Delete Group confirmation dialog, select Yes to delete the group and all templates in it.

o u & W

Select Done to close the Scene Templates editor.

The Scene Template has been deleted.
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Managing Scene Templates

The Scene Templates editor lists the elements that are associated with each group and that will be
available in the HTML5 Client editor. In the editor, you can add and delete scene templates or their
associated elements and edit their details. You can also load templates, preparing them for use in

HTML5 Client editor.

The associated scene elements are described in the sections below:

Scenesl s

Adding Location Labels| "

Adding Drawings[ 71
Adding Shape Styles| 731

For information about loading templates, see Loading Scene Templates| 7.

For information about adding, editing and deleting groups, see Managing Scene Template Groups|e".

Scenes

In the Scenes tab, the available scene templates are listed by thumbnail, name and type. The Name
and Description and a few other parameters can be edited in the Details side of the editor.

To add a new scene template:

1. From the menu bar select Output > Manage Templates or select the Manage Templates button

in the toolbar.

Rl Jd D8 4 <Ol

XPression Maps Toolbar - Manage Templates

The Scene Templates editor opens.

Name: [United States | | user Defined ~ |

Flight Start: | 100 |2 | FlightEnd: |6.00 |&

ClipLength: | 10.00 |+ | sl AsDefault: [
Use Scene Styles From Database: /7]

[ Scene Templates
Group | Satelte Maps -]
Scenes | Locatonlabels | Drawings | ShapeStles |
Name Type
United States Video
| Middle East Video
Europe Video
Still Map Still
Ottaw: Video
Add || AddActual | |Remove

 EY

Scene Templates Editor

O\

2. In the Scene Templates editor, from the Group drop-down, select the group to which you want to
add a new scene template.
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3. Select the Add Actual button to add the currently displayed scene.

OR

Select the Add button to navigate to a saved scene.

The WNM Scene File browser opens.

]

T » ThisPC » 05(C) » HPressionMaps 3.0 » My Scenes v O Search My Scenes

Organize ~  New folder

I This PC
J 3D Objects
[ Desktop
| Documents
J Downloads
D Music
&= Pictures
8 Videos
PV_Maps
%, 05(C)

¥ Network

A O Name Date modified Type

[} Animated Map Demo.wnm 2019

WNM File
WNM File
WNM File
WNM File
M WNM File

| ] Bangkokwnm
] Drawing Key Frame Demo.wnm

| | Ottawa.wnm

| ] Shape Animation Demo.wnm

File name: [ Bangkok.wnm

| | Scenefiles (wnm *wnm_exq)

Scene File Selection

Open |+

34 KB
36KB
33KB
181KB
41KB

Cancel

‘o

4. In the WNM Scene File browser, navigate to the folder where you have saved your scenes.

By default, the WNM Scene File window opens to the C:\XPression Maps\Scene folder, where
scenes are saved. If you are saving your scenes to a different folder, navigate to that location.

5. Select the scene from which you want to create a template and select Open.

The scene is added to the top of the list in the Scenes tab and a thumbnail is displayed, along with

the name and the Type.

By default, the scene is added as a Video type. To switch to a Still type, in the Details section to the
right of the Scenes list, select the Still As Default checkbox and select Update.

You can reorder the list by clicking and dragging an item to another spot in the list.

6. Now you can edit the scene template details, add location labels, drawings or shapes styles to the
template or select Done to close the Scene Templates editor.
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To edit the scene template details:

1. From the menu bar, select Output > Manage Templates in the menu bar or select the Manage
Templates button in the toolbar.

ol R 4 -ggfs RRr

XPression Maps Toolbar - Manage Templates

The Scene Templates editor opens.
2. In the Scene Templates editor, in the Scenes tab, select the scene template you want to edit.
3. In the Details section, edit the information as necessary:

e Enter a new name for the scene in the Name field.

e From the drop-down beside the Name field, select one of the following flight types:

> User Defined - The template is animated. It must have a starting flight point. A flight point is
automatically created if one does not exist. The duration of the flight is determined by the Flight
End parameter and played out accordingly in the HTML5 Client application, when this template
is used.

> Automatic - The template is animated. It must have a starting flight point. A flight point is
automatically created if one does not exist. The duration of the flight is the shortest possible time
that the application can reasonably complete the flight during playout. The Flight Start and Clip
Length parameters are respected, allowing for a set time for a static image to be displayed
before and after the flight.

In the Flight Start field, enter a value or use the arrows to select a time, in seconds that the clip
will wait before the flight starts. By default this value is set to 1.00.

In the Max Flight End field, enter a value or use the arrows to select the point in the clip by which
the flight needs to end.

In the Clip Length field, enter a value or use the arrows to select the length of the clip, in seconds.

The Clip Length value needs to be the same as or greater than the Flight End value.

Select the Still As Default checkbox to create a still image in the XPression Maps Client
application.

OR

Deselect the Still As Default checkbox, to create a video (clip) In the XPression Maps Client
application.

In Automatic videos, the animation will have the duration set in the Clip Length parameter. The
flight to the location defined in the Client app will start after the number of seconds set in the
Flight Start parameter and will end at latest after the number of seconds set in the Max. Flight
End parameter. If the distance between the start and end flight points is short, the flight may
finish earlier. The flight end location will be displayed for the duration set in the Clip Length
parameter.

In User Defined videos, the animation will have the duration set in the Clip Length parameter.
The flight to the location defined in the Client app will start after the number of seconds set in the
Flight Start parameter and will end after the number of seconds set in the Flight End
parameter. The flight end location will be displayed for the duration set in the Clip Length
parameter.
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4. Select the Use Scene Styles from Database checkbox, if you want the map style that’s currently
saved in the database to be used, instead of the map style in the selected scene.

This parameter is only available if you have selected the Load Scene using map style from Map
Style Database checkbox in File > Preferences > Output.

5. In the Description field, enter a description of the template.
6. Select Update to save the changes.

7. Select Done to close the Scene Templates editor.
To delete a scene:

1. From the menu bar select Output > Manage Templates or select the Manage Templates button
in the toolbar.

Sld e ¢ gl EREE
XPression Maps Toolbar - Manage Templates
The Scene Templates editor opens.

2. In the Scene Templates editor, from the Group drop-down, select the group that contains the
scene template you want to delete.

3. In the Scenes tab of the selected group, select the scene template you want to delete.

A Scene Templates ? X
P

Gmup[s;atenteMaps 'JD

Scenes | Locationlabels | Orawings | ShapesStyles |

Thumbnail Name Type [ Details
il Name: |United States || user Defined ~ |
United States Video
Flight Start: [1.00 |2 FightEnd: |6.00 |&
3 =
¥ Viddle East Video Cliplength: [10.00 3| stil As Default: [
=5

Description:

8 Europe Video

Still Map Still

add || Add Actual | |Remove

Scene Templates - Scenes Tab

4. Select Remove and in the Remove Scene confirmation dialog, select Yes.

B4 Remove Scene X

o Do you want to remove the actual scene?

| Yes | I Mo I

Remove Scene Confirmation Dialog
5. Select Done to close the Scene Templates editor.

The Scene has been deleted.

XPression Maps User Guide (v3.4) Managing Templates « 67



Adding Location Labels

In the Location Labels tab, the available location labels for the selected group are listed by thumbnail,
name, and type. A Location Label is a text drawing with or without a defined marker image. This
drawing will be used after a location search is made in the client and the text of the drawing will be
populated with the location text.

To add a new location label:

1. From the menu bar select Output > Manage Templates or select the Manage Templates button
in the toolbar.

XPression Maps Toolbar - Manage Templates
The Scene Templates editor opens.

2. In the Scene Templates editor, from the Group drop-down, select the group to which you want to
add a location label.

3. In the Location Labels tab, select the Add button.

B Scene Templates ? X

Def Callout

[LEOACE Streetsign

Bl Gotham Black

o102 Arial B

HELV. NEUE BE

T City Name

Scene Templates - Location Labels Tab
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The Add Location Label editor opens.

B4 Add Location Label ? X
Toolbox IText -
Preview | Name Type =l
RIEMEI White on Red Text
AL Gopold Text
2ot Frank. Demi Cd Text
+iic) Anal ltalic Text
“““““““““ Gotham Black Text
| Frankiin Got MCRg Text
HELV. NEUE BE Text
|
e

Add Location Label Editor

4. In the Add Location Label editor, click the Toolbox drop-down and select the group that contains
the drawing you want to use as a location label.

Typically, text, icon and dynamic data drawings are used for location labels.
5. From the Location Label list, select the drawing that you want to add to the group and select Add.

The new location label drawing is added to the list in the Location Labels tab and a thumbnail is
displayed, along with the name and Type. This label will now be available for all scene templates in
the current group.

You can reorder the list by clicking and dragging an item to another spot in the list.
To edit the location label details:

1. From the menu bar select Output > Manage Templates or select the Manage Templates button
in the toolbar.

Pl 2R 4 =gy eRrE

XPression Maps Toolbar - Manage Templates

The Scene Templates editor opens.

2. In the Scene Templates editor, from the Group drop-down, select the group that contains the
location label you want to edit.

In the Location Labels tab, select the location label you want to edit.
In the Details section, edit the name or enter a new name for the location label.

Select Update to save the changes.

o u & W

Select Done to close the Scene Templates editor.
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To delete a location label:

1. From the menu bar select Output > Manage Templates or select the Manage Templates button
in the toolbar.

Pld AN @ Soggi BEEH

XPression Maps Toolbar - Manage Templates

The Scene Templates editor opens.

2. In the Scene Templates editor, from the Group drop-down, select the group that contains the
location label you want to delete.

3. In the Location Labels tab, select the location label you want to delete.
4. Select Remove and in the Remove Location Label confirmation dialog, select Yes.
5. Select Done to close the Scene Templates editor.

The location label has been deleted.
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Adding Drawings

In the Drawings tab, the available drawings for the selected group are listed.

To add a new drawing:

1. From the menu bar select Output > Manage Templates or select the Manage Templates button
in the toolbar.

Rl Jd D8 4 <Ol

Elé‘é WO

XPression Maps Toolbar - Manage Templates

The Scene Templates editor opens.

2. In the Scene Templates editor, from the Group drop-down, select the group to which you want to
add a drawing.

3. Select the Add button.

The Add Drawing editor opens.

b4 Add Drawing

?

X

Toobox | Traffic

Type
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Airplane

Ambulance

) Bicycle

Bus
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Convertible Grey

\ | Construction Barrier
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lcon
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lcon

Icon

Icon

lcon
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| Cancel

Add Drawing Editor

4. In the Add Drawing editor, select the Toolbox drop-down and select a drawing group.

5. From the Drawing list, select the drawing that you want to add to the group and select Add.

The new drawing is added to the list in the Drawings tab and a thumbnail is displayed, along with
the name and Type. This drawing will now be available for all scene templates in the current group.

You can reorder the list by clicking and dragging an item to another spot in the list.
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To edit the drawing details:

1. From the menu bar select Output > Manage Templates or select the Manage Templates button
in the toolbar.

Pl M 4 =l BE s

XPression Maps Toolbar - Manage Templates

The Scene Templates editor opens.

2. In the Scene Templates editor, from the Group drop-down, select the group that contains the
drawing you want to edit.

In the Drawings tab, select the drawing you want to edit.
In the Details section, in the Name field, edit the name or enter a new name for the drawing.

Select Update to save the changes.

o u & W

Select Done to close the Scene Templates editor.
To delete a drawing:

1. From the menu bar select Output > Manage Templates to open the Scene Templates editor.

2. In the Scene Templates editor, from the Group drop-down, select the group that contains the
drawing you want to delete.

3. In the Drawings tab, select the drawing you want to delete.

4. Select Remove and in the Remove Drawing confirmation dialog, select Yes.

4 Remove Drawing *

o Do you want to remove the actual drawing?

| Yes | l Mo ]

Remove Drawing Confirmation Dialog
5. Select Done to close the Scene Templates editor.

The Drawing has been deleted.

72 « Managing Templates XPression Maps User Guide (v3.4)



Adding Shape Styles
In the Shape Styles tab, the available shape styles for the selected group can be associated with the

scene template group.

To add a new shape style:

1. From the menu bar select Output > Manage Templates to open the Scene Templates editor.

2. In the Scene Templates editor, from the Group drop-down, select the group to which you want to
add a shape style.

3. In the Shape Styles tab, select the Add button.

B Scene Templates ? X

State Highlight

Country Highlight

Country Default

Scene Templates - Shape Styles Tab
The Add Shape Style editor opens.

B Add Shape Style 7 X

State Default

Country Default

Regicn Default

States Election

Region Election

Country Highlight

State Highlight

Add Shape Style Editor
4. Inthe Add Shape Style editor, select the shape style you want to add and select Add.

The new shape style is added to the list in the Shape Styles tab. This shape will now be available for
all scene templates in the current group.

You can reorder the list by clicking and dragging an item to another spot in the list.
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5. Select Update to save the changes.

6. Select Done to close the Scene Templates editor.
To edit the shape style details:

1. From the menu bar select Output > Manage Templates or select the Manage Templates button
in the toolbar.

plid 26 @ <ggdls BE s
XPression Maps Toolbar - Manage Templates
The Scene Templates editor opens.

2. In the Scene Templates editor, from the Group drop-down, select the group that contains the
shape style you want to edit.

In the Shape Styles tab, select the shape style you want to edit.
In the Details section, in the Name field, edit the name or enter a new name for the shape style.

Select Update to save the changes.

o u W

Select Done to close the Scene Templates editor.
To delete a shape style:

1. From the menu bar select Output > Manage Templates or select the Manage Templates button
in the toolbar.

Plld e 4 SgE[fs EEE

XPression Maps Toolbar - Manage Templates

The Scene Templates editor opens.

2. In the Scene Templates editor, from the Group drop-down, select the group that contains the
shape style you want to delete.

3. In the Scene Templates editor, in the Shape Styles tab, select the shape style you want to delete.

4. Select Remove and in the Remove Shape Style confirmation dialog, select Yes.

B4 Remove Shape Style *

o Do you want to remove the actual shaoce style?

| Yes | l Mo ]

Remove Shape Style Confirmation Dialog
5. Select Done to close the Scene Templates editor.

The Shape Style has been deleted.
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Adding User Predefined Objects

Add existing User Predefined Objects with containing folders to scene templates in the User Predefined
Objects tab.

For information on creating User Predefined Object Groups and Folders see User Predefined
Objects[ 131,

To add folders to Scene Templates:

1. From the Group drop-down, select the Template Group that you want to add the User Predefined
Objects to.

B scene Templates x

Ottawa Canada Ontario Gatneau Example Area

Scene Templates - User Predefined Objects Tab

2. Select the Browse button (|E) to open the Template Groups window where you can update or
delete Template Group information.

3. Select the Green (+) button to add a folder to the selected Scene Template.

The Add Folder window opens.

B Add Folder X

Scene Templates - User Predefined Objects - Add Folder
4. In the Name field, enter a name for the User Predefined Object folder.
5. In the Description field, enter a description for the User Predefined Object folder.
6. Select Add to add the folder to the Scene Template.

The folder has been added to the Scene Template.
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Adding User Predefined Objects to Scene Template folders:

1. Select the Add button to open the Add User Predefined Object window.

i Add User Predefined Object X

Scene Templates - User Predefined Objects - Add Window
2. From the Group drop-down select the User Predefined Objects group you want to add.
For information on creating User Predefined Object groups see User Predefined Objects[1s1l.

3. If the group has multiple folders with containing elements, select the folder you want to add and
select the Add button to the right of the Folder drop-down.

* Multiple selections can be made and duplicates of folders can get added at once. Continue adding
as many folders as necessary.

The folders have been added.

I Scene Templates

Scene Templates - User Predefined Objects - Folder Added
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4. Use the Details section to view, edit or update the Name, Search Tags and Description for each
folder.

5. When finished, select Done to close the Scene Templates window.
To delete folders from the Scene Templates:

1. From the Group drop-down, select the Template Group with the containing folder you want to
delete.

2. From the Folder drop-down select the folder you want to remove and select the Red (X) button.

The Delete Folder window dialog opens.

b Delete Folder? X

Do you want to delete the actual folder and all its objects?
[[)Confirm the folder delete.

| Yes | Mo |

Scene Templates - User Predefined Objects - Delete Folder Dialog
3. Check the Confirm the folder delete checkbox and select Yes to delete the folder and its objects.
The final red Delete Folder dialog opens.

b Delete Folder? X

?

Scene Templates - User Predefined Objects - Final Delete Folder Dialog
4. Select Yes to delete the folder and its objects.
The folder and its objects has been deleted from the Scene Template.

5. Select Done to close the Scene Templates window.
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Loading Scene Templates

When a scene is loaded to the database, it is prepared for use in the HTML5 Client. All camera key
frames are deleted and if there are no flight points in the scene, Start and Stop flight points are added.

To load a template:

1. From the menu bar select Output > Manage Templates or select the Manage Templates button
in the toolbar.

Rl I AR (4 gﬁalﬁ!ﬁi; B Sl

XPression Maps Toolbar - Manage Templates

The Scene Templates editor opens.

2. In the Scene Templates editor, from the Group drop-down, select the group that contains the
scene template you want to load.

3. In the Scenes tab of the selected group, select the scene template you want to load.
4. Select Load.

The template is loaded into the database, the editor closes and the scene is visible in the output
window. The icon in the menu bar is highlighted, indicating that the template can be edited.

9 A6 4 oy B er e

Manage Templates Icon Highlighted

t‘.&

To save a loaded template after editing (Method 1):

1. In the menu bar, select the Save icon.

A confirmation dialog opens asking if you want to save the edited scene back into the database as a
template.

B Save Scene >

The active scene was loaded from the web template database.
Do you want to save the scene first back as a template?

| ¥es || Mo | cancel |

Save Scene Back as Template Confirmation Dialog
2. Select Yes to save it.

3. In the Save window, navigate to the folder where you want to save the template and enter a name
for the scene.

e Entering the original name will automatically overwrite the template in the Scene Editor.

e Entering a different name will save it as a new scene, but you will then have to add it to the Scene
Editor if you want it available for use in the HTML5 Client. See To add a new scene template[ s
for more information.

4. Then select Save.

The scene is added to the database as a template. The icon in the menu bar is no longer highlighted,
as the scene can no longer be edited.
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To save a loaded template after editing (Method 2):

In the menu bar, select the Manage Templates button in the menu bar.

1.
A confirmation dialog opens asking if you want to overwrite the last loaded scene in the database.

ﬁ' Overwrite Last Loaded Scene! X

e Do you want to overwrite the last loaded scene in the database?

Yes | l Mo I

Overwrite Last Loaded Scene Confirmation Dialog

2. Select Yes to save it.
The original template is overwritten and the edited template is available for use in the HTML5

Client.
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Editing Saved Templates

Templates that have been saved in the XPression Maps HTML5 Client appear in the Saved Scene
Templates editor. From the editor, you can load a saved template, make any necessary changes and
then save

1. From the menu bar select Output > Edit Saved Templates or select the Edit Saved Templates
button in the toolbar.

XPression Maps Toolbar - Edit Saved Templates

The Saved Scene Templates editor opens.

B saved Scene Templates ? x

Mercator
Open Street Maps
P Political (Grey Design)

| Sl Fort MachMurray

Saved Scene Templates Editor
2. Select the group containing the template you want to edit, then select the template and select Load.

When the template is loaded, the Edit Saved Templates button turns red, indicating that it can be
edited.

XPression Maps Toolbar - Edit Saved Templates Active

3. Make any necessary changes to the template.
4. Then select the Save button in the menu bar.

A confirmation dialog opens asking if you want to save the scene back to the HTML5 Client.

B save Scene X

Save Scene in HTML5 Client
5. If you want to make the edited template available in the the Web Client, select Yes.
OR

Select No to only save the template into your Scenes folder.
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Drawing Management

XPression Maps provides the ability to select drawings from a library, modify their properties and assign
them to a group, using the Drawing Management Editor. These drawings can then be accessed from
the Drawing Toolbox and added to a scene.

The Drawings Overview Panel lists the different drawings from within a scene.

The following topics are discussed in this section:

Drawing Management Editor/ e

Managing Groups| &3

Managing Drawings/ s

Drawings Overview Panel [130}

XPression Maps User Guide (v3.4) Drawing Management + 81



Drawing Management Editor

The Drawing Management Editor shown below, is used to select, modify and manage drawings. You
can also organize the drawings into groups.

i Drawing Management Editor >

Arial BI

Arial Bl

Drawing Management Editor
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Managing Groups

The Drawing Management Editor comes with a predefined set of groups to which you can add
drawings.

You can also add a new group, rename a group, or delete groups you don't need.
To add a new group:

1. From the menu bar select Edit > Manage Drawings to open the Drawing Management Editor.
2. At the bottom of the Group section on the left side, select New Group.

The Add Group dialog opens.

A Add Group ? *
Group Name:
|New Group| |
. ok | caneel |
Add Group

3. In the Group Name field, enter a name for the new group and select OK.
The new group appears in the Name drop-down at the top of the Group section.

Because it's a new group there are no drawings in it yet.

To rename a group:

1. From the menu bar select Edit > Manage Drawings to open the Drawing Management Editor.

2. In the Group section on the left side, from the Name drop-down, select the group you want to
rename.

3. At the bottom of the Group section, select Rename Group.

The Change Group Name dialog opens.

B4 Change Group Mame ? *

Mew MName:
| Symbols| |
. ok || cancel |

Change Group Name
4. Enter a new name for the Group and select OK.
The new group name appears in the Name drop-down.

The new group will contain any drawings that were in the old group.
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To delete a group:

1. From the menu bar select Edit > Manage Drawings to open the Drawing Management Editor.

2. In the Group section on the left side, from the Name drop-down, select the group you want to

delete.
3. At the bottom of the Group section, select Delete Group.

4. The Delete Group confirmation dialog opens.
B4 Delete Group? X
o Do you want to delete the actual group and all its objects?
2 Drawings will be deleted with the group!
[[)Confirm the group delete.

| Yes || |

Delete Group Confirmation

5. Select the Confirm the group delete checkbox and select Yes.

The final Delete Group dialog opens.

?

Final Delete Group Dialog
6. Select Yes to delete the group.

The Group and its Drawings are deleted.

84 « Drawing Management

XPression Maps User Guide (v3.4)



Managing Drawings

In the Drawing section of the Drawing Management Editor, you can add a new drawing, view and
modify the properties of an existing drawing, copy a drawing and delete a drawing. The following types
of drawings are available in the library:

Text and OSM Replacement Drawings| ss)

Area Drawings| 1o

Line Drawings/ 08!

Icon Drawings/o8)

Magnifier Drawings/[ 1l

Locator Drawings/ 4l

Dynamic Data Drawingsmﬁ

Background Drawings[ 20

Video Input Drawings[ 123

Inset Drawings[ 12

Container Drawings| 128
To add a drawing:

1. From the menu bar select Edit > Manage Drawings to open the Drawing Management Editor.

2. In the Group section on the left side, from the Name drop-down, select the group to which you want
to add your drawing.

If an appropriate group doesn’t already exist, you can add a new group. See To add a group|ss" for
instructions.

3. In the Drawing section on the right side, select New.

The New Drawing dialog opens.

B4 New Drawing ? >

Select Drawing Type

[Tex‘t 'I
. ok || cancel |

New Drawing
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4. From the Select Drawing Type drop-down, select the type of drawing you want to add and select
OK.

The options are:

Text Line Magnifier Dynamic Data Video Input Container
Area Icon Locator Background Inset

The Drawing properties are displayed and a preview of the drawing with its default properties
appears below the property fields.

New Drawing Window

5. If you change your mind about creating this drawing type, select New again and in the Save
Drawing dialog, select Discard.

The New Drawing dialog will open again and you can select a new drawing type.
6. In the Name field, enter a descriptive name for the drawing.

The Type field is automatically populated and is not editable.
7. Modify the default properties as described in To modify a drawing.[s"

After editing the drawing name and/or properties, the Update button at the bottom of the Drawing
section is enabled.

8. Select Update.

The Drawing section is cleared and the new drawing is added to the selected group, but is not yet
available in the Drawing Toolbox.

9. Select Done to close the editor and make your drawing available in the Drawing Toolbox.
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To modify a drawing:

1. From the menu bar select Edit > Manage Drawings to open the Drawing Management Editor.

2. In the Group section on the left side, from the Name drop-down, select the Group that contains the
drawing you want to modify.

3. From the Group list, select the drawing you want to modify.
The properties of the selected drawing are displayed in the Drawing section on the right side.
4. Modify the properties of the drawings as described in the section corresponding to your drawing.
Text and OSM Replacement Drawings/ s
Area Drawings|1_o4'ﬁ
Line Drawings|1_oe'ﬂ
Icon Drawings| o)
Magnifier Drawings| 1)
Locator Drawings| 114
Dynamic Data Drawingsm
Video Input Drawings/23)
Inset Drawings[ 26!
Container Drawings/zs)
5. Select Update at the bottom of the Drawing section to save your changes.

6. Select Done to close the editor and make your drawing available in the Drawing Toolbox.
To copy a drawing:

1. From the menu bar select Edit > Manage Drawings to open the Drawing Management Editor.

2. On the Group side of the editor, from the Name drop-down, select the Group that contains the
drawing you want to copy and then select the drawing.

3. From the Group drop-down, select the folder into which you want to copy the selected drawing.
4. On the Drawing side, change the name of the drawing and then select Duplicate.
The drawing will appear in the list for the selected group.

5. Select Done to close the Drawing Management Editor.
To move a drawing:

1. From the menu bar select Edit > Manage Drawings to open the Drawing Management Editor.

2. On the Group side of the editor, from the Name drop-down, select the Group that contains the
drawing you want to move and then select the drawing.

3. From the Group drop-down, select the folder into which you want to move the selected drawing.
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4. On the Drawing side, select Move.

A confirmation dialog opens.

B Move Drawing? X

Move Drawing Confirmation Dialog
5. Select Move.
The drawing is removed from the original folder and moved to the selected folder.

6. Select Done to close the Drawing Management Editor.

To delete a drawing:

1. From the menu bar select Edit > Manage Drawings to open the Drawing Management Editor.

2. On the Group side of the editor, from the Name drop-down, select the Group that contains the
drawing you want to delete

3. Select the drawing you want to delete.
4. On the Drawing side of the editor, select Delete.

The Delete Drawing confirmation dialog opens.

B Delete Drawing? it

Delete Drawing Confirmation Dialog

5. Select Yes to delete the drawing.

6. Select Done to close the Drawing Management Editor.

88 « Drawing Management XPression Maps User Guide (v3.4)



Text and OSM Replacement Drawings

Use Text drawings to add your own labels to a map, as shown in the example below. The labels can be
key framed to appear and/or disappear at specific points in the timeline during animation.

OSM Replacement drawings are text drawings that can be used to replace existing labels on a map.
They have all the same properties as text drawings but are used only in OSM maps. With replacement
drawings, you can insert labels for only those locations that are of interest and all other labels will be
hidden in the production output. For details, see OSM Replacement Drawings. [2s3)

i

- C;W Smn Norwich
N b

Coventry

Bing Road Map Bing Road Map wilh Text Drawing 0SM Basic Map with Text and Replacement Drawings
Example - Text Drawing
Text and OSM Replacement Drawings have many editable properties. The properties are divided into
tabs and are described below.

General Tab

i Drawing Management Editor X

Properties - Text Drawings - General Tab
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The properties found in the General tab are described in the following table.

Property

Direction

Default Text

Default Scale

Offset X

Offset Y

Visibility
(In and Out)

Description
Sets the writing direction for the text that is used in the drawing.
Options are Left to Right or Right to Left.

The example text that appears in the preview. This text also appears as the preview
icon in the group of drawings in which it is located.

The default size of the text.

Select the Auto checkbox to make the text size scale automatically as the map
zooms in and out.

This effect can be changed in the Drawing Editor, when the drawing is selected in
the output window.

See Sizel24) for more information.

The distance that the text drawing is offset from the center of the text along the X-
axis of the map.

Set to something other than 0.0 to make the callout arrow or line visible.

The distance that the text drawing is offset from the center of the text along the Y-
axis of the map.

Set to something other than 0.0 to make the callout arrow or line visible.

How a text and OSM replacement drawing appears (In) and disappears (Out) during
animation.

Options are:

None — the drawing appears/disappears instantly at the frame to which the key
frame is set. Use the Delay field to input the number of seconds that the drawing
will delay its animation.

Dissolve — the drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing blends in/out over the number of seconds selected in the
Time field. Use the Delay field to input the number of seconds that the drawing will
delay its animation.

Typewriter — the drawing animates in and out at the level set in the corresponding
Zoom fields. The appears/disappears one character at a time over the number of
seconds selected in the Time field. Use the Delay field to input the number of
seconds that the drawing will delay its animation.

Alpha — the drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing blends in/out one character at a time over the number of
seconds selected in the Time field. Use the Delay field to input the number of
seconds that the drawing will delay its animation.

Wipe — The drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing appears from the right over the number of seconds
selected in the Time field. Use the Delay field to input the number of seconds that
the drawing will delay its animation.

Wipe Reverse — the drawing animates in and out at the level set in the
corresponding Zoom fields. The drawing appears from the left over the humber of
seconds selected in the Time field. Use the Delay field to input the number of
seconds that the drawing will delay its animation.

Wipe Left — the drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing appears/disappears from the left over the number of
seconds selected in the Time field. Use the Delay field to input the number of
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Property Description
seconds that the drawing will delay its animation.

Wipe Right — the drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing appears/disappears from the left over the number of
seconds selected in the Time field. Use the Delay field to input the number of
seconds that the drawing will delay its animation.

Wipe Bottom — the drawing animates in and out at the level set in the
corresponding Zoom fields. The drawing appears/disappears from the bottom over
the number of seconds selected in the Time field. Use the Delay field to input the
number of seconds that the drawing will delay its animation.

Wipe Top — The drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing appears/disappears from the top over the number of
seconds selected in the Time field. Use the Delay field to input the number of
seconds that the drawing will delay its animation.

Flight Mode — Select the flight mode checkbox to enable the drawing to visualize
the data as its clicked and dragged along the map.

The effect can be changed in the Drawing Editor in the Effect section, when the
drawing is selected in the output window. See Effect[2s for more information.
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Label Tab

B Drawing Management Editor

Properties - Text Drawings - Label Tab

The properties found in the Label tab are described in the following table.

Property

Description

Text

Font — Select an existing font using the drop-down or click the Browse button (@)
to add a new font to be applied to the text.

Color — Select an existing color using the drop-down or click the Browse button (
@) to add a new color.

If no color is selected, the text drawing will not be visible.
Transform — Select either None, UPPERCASE or lowercase.
None: The text will be displayed exactly as entered.

UPPERCASE: The text will be displayed as all uppercase, regardless of how it is
entered.

lowercase: The text will be displayed as all lowercase, regardless of how it is
entered.

Kerning — Enter a value or use the arrows to set the amount of space between
letters.

This effect can be changed in the Drawing Editor in the Text section, when the
drawing is selected in the output window.

Line Spacing — Enter a value or use the arrows to set the amount of space
between multiple lines of text.

This effect can be changed in the Drawing Editor in the Text section, when the
drawing is selected in the output window.

92 « Drawing Management

XPression Maps User Guide (v3.4)



Property Description

Alignment Horizontal — The longitude coordinate of the text drawing corresponds to the left
side of the text if this property is set to Left, to the right side of the text if this
property is set to Right and to the center of the text if this property is set to
Center.

Vertical — If this property is set to Top, the latitude coordinate of the text drawing
will correspond to the highest theoretical possible character in the first line. This is to
have static baselines. If the latitude coordinate actually corresponded to the top of
the text, the baselines (and so the whole text) would change position whenever the
text changes.

Accordingly, for Center, the latitude coordinate is not really in the center of the text
but at a position close to the center where baselines only change when the humber
of lines changes.

For Bottom, the baseline of the last line in the text will correspond to the latitude
coordinate.

For Baseline, the baseline of the first line of the text will correspond to the latitude
coordinate.
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Decoration Tab

(=] Drawing Management Editor #

Properties - Text Drawings - Decoration Tab

The properties found in the Decoration tab are described in the following table.

Property Description

Shadow Select the Shadow checkbox to add a shadow to each text character.

When enabled, the shadow will have the properties configured in this section.

Color — Select an existing color using the drop-down or click the Browse button (
@) to add a new color.

Angle — The angle of the shadow in degrees.
0 = The shadow falls to the right of the text.
90 = The shadow falls above the text.

180 = The shadow falls to the left of the text.
-90 = The shadow falls below the text.

Distance — The distance that the shadow falls from the text. A larger value moves
the shadow further away from the text.

Enlarge — Enter a value or use the arrows to set an amount by which to enlarge
the shadow.

Blur — Enter a value or use the arrows to set the degree by which the shadow
appears out-of-focus.

Border Select the Border checkbox to add a border around the outside of the text
characters.

Color — Select an existing color using the drop-down or select the Browse button (
E]) to add a new color.
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Property Description

Enlarge — Enter a value or use the arrows to set an amount by which to enlarge
the border.

Glow Select the Glow checkbox to add a glow effect around the outside of the text
characters.

Enlarge — Enter a value or use the arrows to set an amount by which to enlarge
the glow.

Blur — Enter a value or use the arrows to set the degree by which the glow appears
out-of-focus.

Bevel Select the Bevel checkbox to add a bevel effect around the outside of the text
characters, giving them a 3D appearance.

Enlarge — Enter a value or use the arrows to set an amount by which to enlarge
the bevel.

Direction — Enter a value or use the arrows to set the degree at which the bevel
will appear on the text characters.
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Background Tab

B Drawing Management Editor ps

Properties - Text Drawings - Background Tab

The properties found in the Background tab are described in the following table.

Property Description

Scale X Enter a value or use the arrows to set the default size of the rectangle that forms
the background for the text drawing.

1.00 is the minimum size. 2.0 makes the background double the size of the text
box.

Scale Y Enter a value or use the arrows to set the default size of the rectangle that forms
the background for the text drawing.

1.00 is the minimum size. 2.0 makes the background double the size of the text
box.

TextFit From the drop-down, select the option that looks best when you are changing the
text within an object.

Unlinked — the size of the background image remains the same regardless of how
much text is entered.

BackgroundFitsText — only the width of the background image will increase or
decrease to fit the amount of text.

BackgroundFitsTextKeepAspect — the size of the background image will
increase or decrease to fit the amount of text and maintain the aspect ratio.
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Property Description

Color Select an existing color using the drop-down or select the Browse button (| - ) to
add a new color.

If only a background color is selected, a rectangle in this color will be drawn behind
the text.

If both a background color and an image are selected, they will be combined.

If no background color, image or outline color are selected, there will be no
background.

The size of the rectangle is relative to the text size, so the background rectangle
grows as the text grows.

Image Select an existing image using the drop-down or select the Browse button (/) to
add a new image.

The image will be drawn behind the text.
If both a background color and an image are selected, they will be combined.

If no background color, image or outline color are selected, there will be no
background.

The size of the image is relative to the text size, so the background image grows as
the text grows.

Pause At End Enter or use the arrows to set the nhumber of frames for which an image sequence
will pause at the last image before looping.

Slowdown When an animated image is selected, this is the number of frames, expressed as a
percentage, by which the movement of the animated image will be slowed.
Accordingly, a negative value will speed up the movement.

Outline Color Adds the selected color to the outline of the background.

Select an existing color using the drop-down or select the Browse button (/) to
add a new color.

If no background color is selected, only an outline in the color selected will be
displayed.

Outline Width Enter a value or use the arrows to set a width for the outline (border) of the
background.

If the px checkbox is selected, the width of the outline will remain the same
regardless of the zoom level of the map.

If the px checkbox is cleared, the width of the outline will scale relative to the
background as the zoom level of the map changes.

Shadow Color  Select an existing color using the drop-down or select the Browse button (=) to
add a new color to apply to the shadow of the background.

Shadow Angle ' Angle — The angle of the shadow in degrees.
0 — The shadow falls to the right of the background.
90 — The shadow falls above the background.
180 — The shadow falls to the left of the background.
-90 — The shadow falls below the background.

Shadow The distance that the shadow falls from the background. A larger value moves the
Distance shadow further away from the background.
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Property Description

Shadow Blur Enter a value or use the arrows to set the degree by which the shadow appears out-
of-focus.
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Marker Tab

¥ Drawing Management Editor

Properties - Text Drawings - Marker Tab

The properties found in the Marker tab are described in the following table.

Property

Description

Image

Select an existing image using the drop-down or select the Browse button (@) to
add a new image from the Images folder.

By default, the image will be drawn behind the text.

The size of the image is relative to the text size, so the image grows as the text
grows.

To remove the image from the drawing, click the drop-down arrow and select the
blank area at the top of the drop-down list.

To delete an image, select the Browse button (@) beside the image field and in the
Images folder, select Delete. You cannot delete an image that is currently being
used in a drawing.

B Images ? 'Y

ARTSDesignRahmen

Airplane

The Animated column indicates whether or not the image is part of a sequence,
creating an animated drawing.

Pause At End

Enter or use the arrows to the number of frames for which an image sequence will
pause at the last image before looping.
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Property Description

KX This function only applies to Markers that have animation.

Slowdown When an animated image is selected, this is the number of frames, expressed as a
percentage, by which the movement of the animated image will be slowed.
Accordingly, a negative value will speed up the movement.

X This function only applies to Markers that have animation.

Scale Enter a value or use the arrows to increase or decrease the size of the marker image
Default is 1.00. Selecting 2.00 will make the image twice as large.

Offset X The distance that the marker image is offset from the center of the text along the X-
axis of the map.

0.0 = Center
A value higher than 0.00 = Right of center
A value lower than 0.00 = Left of center

Offset Y The distance that the marker image is offset from the center of the text along the Y-
axis of the map.

0.0 = Center
A value higher than 0.00 = Above the center
A value lower than 0.00 = Below the center

Marker is in Select this checkbox to place the marker in front of the text.
front

Marker aligns  Select this checkbox to align the marker to the text.

X In order to see the marker, the Offset X and Offset Y values in the general tab need to be

something other than 0.00. Otherwise, the marker will be hidden behind the text or background.
Changing the offset defines the default offset between the text and the point of interest.
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Callout Tab

B Drawing Managerment Editor Fe

Text Properties - Callout Tab

The properties found in the Callout tab are described in the following table.

Property Description

Type Select the type of callout used to draw the connection between the text-background
panel and the location of the point of interest.

A background color or an outline color must be defined in the Background tab in
order to use a callout.

Callout options are Arrow and Line.

Arrow draws a triangle from the panel to the location on the map in the same style
as the background. The Color, Offset, and Width properties are not used in this

type.

Line draws a line between the text-panel and the location on the map. If Line is
chosen, the Color, Offset and Width properties become available.

For both arrows and lines, the starting point near the panel is calculated
automatically for optimal appearance of the callout.

Alignment Select whether the arrow or line should be aligned at center or automatically.

Color Select an existing color using the drop-down or select the Browse button (E]) to
add a new color for the callout line. Applies only to the Line type.

Marker Offset | Enter a value or use the arrows to change the position of the arrow or line in
relationship to the marker.
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Property Description

Label Offset Enter a value or use the arrows to set an offset that creates a gap between the label
and the beginning of the marker.

Change the Offset X and Offset Y parameter in the General tab beyond the 0,0
location to see the callout in the example image below the properties.

Line Width Enter a value or use the arrows to set the width of the callout line.

If the px checkbox is selected, the width of the line will remain the same regardless
of the zoom level of the map.

If the px checkbox is cleared, the width of the line will scale relative to the
background as the zoom level of the map changes.

K This function only applies when the Line Type has been selected.
Arrow Width Enter a value or use the arrows to set the width of the callout arrow.

X This function only applies when the Arrow Type has been selected.

To add callout text to a scene:

1. In the Drawing Toolbox, select the Callout text drawing, then click in the scene at the exact
position to which you want the arrow or line of the Callout to point.

2. Double-click in the bounding box and enter the new text.

3. Place the cursor inside the bounding box, then left-click and drag the bounding box to adjust the
position of the Callout arrow or line.

4. To reposition the Callout, left-click and drag the white point at the top of the handle of the bounding
box.

102 « Drawing Management XPression Maps User Guide (v3.4)



Interactivity Tab

' Drawing Management Editor ®

{New Text

Text Properties - Interactivity Tab

X This function is only accessible if XPression Maps is running in Interactive Mode.
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Area Drawings

Use Area drawings to call out an area of the map to which you want to draw attention, as shown in the
example below. Area drawings can be still or animated.

Properties - Area Drawings
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The Area drawing properties are described in the following table.

Property Description

Color Select an existing color using the drop-down or select the Browse button (/= ) to
add a new color for the drawing.

The selected color will be applied to the image, if an image is selected.

Image Select an existing image from the drop-down or click the Browse button (/== ) to
add a new image.

If an image is selected, the area will be textured with this image.

Pause At End Enter a value or use the arrows to set the humber of frames for which an image
sequence will pause at the last image before looping.

Slowdown When an animated image is selected, this is the number of frames, expressed as a
percentage, by which the movement of the animated image will be slowed.
Accordingly, a negative value will speed up the movement.

Outline Select an existing color using the drop-down or click Browse to add a new color for
the outline.

Enter a value or use the arrows to increase or decrease the thickness of the
outline.

The default is no outline.
Visibility How an area drawing appears (In) and disappears (Out) during animation.
(In and Out) Options are:

None — the drawing appears/disappears instantly at the frame to which the key
frame is set. Use the Delay field to input the number of seconds that the drawing
will delay its animation.

Dissolve — the drawing blends in and out over the number of seconds selected in
the Time field. The drawing animates in and out at the level set in the
corresponding Zoom field. Use the Delay field to input the number of seconds that
the drawing will delay its animation.

Flight Mode — Select the flight mode checkbox to enable the drawing to visualize
the data as its clicked and dragged along the map.

The effect can be changed in the Drawing Editor in the Effect section, when the
drawing is selected in the output window.

See Effectl 28 for more information.

Flight Mode When selected, clicking on the visible eye icon removes the drawing from the flight
point (makes invisible); clicking on invisible eye icon adds the drawing to the flight
point (makes visible).
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Line Drawings

Use Line drawings to show a route on the map, as shown in the example below. Line drawings can be
still or animated.

Properties - Line Drawings
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The Line drawing properties are described in the following table.

Property Description

Color Select an existing color using the drop-down or select the Browse button (/=) to
add a new color for the drawing.

The selected color will be applied to the image, if an image is selected.

If no color is selected, the drawing will not be visible.

Image Select an existing image from the drop-down or select the Browse button (. ) to
add a new image.

If an image is selected, the line will be textured with this image.

Pause At End Enter a value or use the arrows to set the number of frames for which an image
sequence will pause at the last image before looping.

Slowdown When an animated image is selected, this is the number of frames, expressed as a
percentage, by which the movement of the animated image will be slowed.
Accordingly, a negative value will speed up the movement.

Default Scale ' The default value of the Scale property for the drawing.

The default scale can be changed in the Drawing Editor. See Size[ 24 for more
information.

Visibility How a line drawing appears (In) and disappears (Out) during animation.
(In and Out) Options are:

None — the drawing appears/disappears instantly at the frame to which the key
frame is set. Use the Delay field to input the number of seconds that the drawing will
delay its animation.

Dissolve — the drawing blends in and out over the number of seconds selected in
the Time field. The drawing animates in and out at the level set in the corresponding
Zoom field. Use the Delay field to input the number of seconds that the drawing will
delay its animation.

Flight Mode — Select the flight mode checkbox to enable the drawing to visualize
the data as its clicked and dragged along the map.

The effect can be changed in the Drawing Editor in the Effect section, when the
drawing is selected in the output window.

See Effect[26) for more information.
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Icon Drawings

Use Icon drawings to mark a specific location, as shown in the example below. Icon drawings can be
still or animated.

Example - Icon Drawing

General Tab

H Drawing Management Editor X

Name: New Icon|

Type: |1con |
General I shadow |
Color: | White A | -
Image: L N | —
Pause At End: \w |
Slow Down: Lo
Default Scale | 1.00 |=| DAt
BlendMode: Regular v
e Effect Zoom  Tme  Delay
In: | None * o [2)0.20 [$][0.00 3]
out: | None * 250 [2)[0.20 [$][0.00 [5]
Flight Mode -

Done Cancel

Properties - Icon Drawings - General Tab
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The properties in the General tab are described in the table below

Property

Color

Image

Pause At End

Slowdown

Default Scale

Blend Mode

Visibility
(In and Out)

Description

Select an existing color using the drop-down or click the Browse button (' ) to add
a new color for the icon drawing.

The selected color will be applied to the image, if an image is selected.

If no color is selected, the drawing will not be visible.

Select an existing image from the drop-down or select the Browse button (/=) to
add a new image.

If an image is selected, the drawing will be textured with this image.
If no image is selected, the drawing will be a rectangle of the selected color.

Enter a value or use the arrows to set the number of frames for which an image
sequence will pause at the last image before looping.

When an animated image is selected, this is the number of frames, expressed as a
percentage, by which the movement of the animated image will be slowed.
Accordingly, a negative value will speed up the movement.

The default value of the Scale property for the drawing.

The effect can be changed in the Drawing Editor, when the drawing is selected in
the output window.

See Sizelz4) for more information.

The default mode is Regular.

Options are:

Regular — the area color is combined with the underlying map color.

This is the most common blend method.

Multiply — the area color is multiplied with the underlying map color.
Add — the area color is added to the underlying map color.

How an icon drawing appears (In) and disappears (Out) during animation.
Options are:

None — the drawing appears/disappears instantly at the frame to which the key
frame is set. Use the Delay field to input the number of seconds that the drawing
will delay its animation.

Dissolve — the drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing blends in/out over the number of seconds selected in the
Time field. Use the Delay field to input the number of seconds that the drawing will
delay its animation.

Wipe Left — the drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing appears/disappears from the left over the number of
seconds selected in the Time field. Use the Delay field to input the number of
seconds that the drawing will delay its animation.

Wipe Right — the drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing appears/disappears from the left over the number of
seconds selected in the Time field. Use the Delay field to input the number of
seconds that the drawing will delay its animation.

Wipe Bottom — the drawing animates in and out at the level set in the
corresponding Zoom fields. The drawing appears/disappears from the bottom over
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Property

Description

the number of seconds selected in the Time field. Use the Delay field to input the
number of seconds that the drawing will delay its animation.

Wipe Top — The drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing appears/disappears from the top over the number of
seconds selected in the Time field. Use the Delay field to input the number of
seconds that the drawing will delay its animation.

Flight Mode — Select the flight mode checkbox to enable the drawing to visualize
the data as its clicked and dragged along the map.

The effect can be changed in the Drawing Editor in the Effect section, when the
drawing is selected in the output window. See Effect[2s for more information.

Shadow Tab

i Drawing Management Editor

Properties - Icon Drawings - Shadow Tab

The properties in the Shadow tab are described in the following table.

Property

Description

Shadow Color

Select an existing color using the drop-down or select the Browse button (@) to
add a new color to apply to the shadow of the background.

Shadow Angle

Enter a value or use the arrows to adjust the angle of the shadows in degrees.

The maximum value is 360, the minimum value is -360.

Shadow The distance that the shadow falls from the background. A larger value moves the
Distance shadow further away from the background.
Shadow Blur Enter a value or use the arrows set to the degree by which the shadow appears out-

of-focus.

The maximum value is 20. The minimum value is 0.
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Magnifier Drawings

Use Magnifier drawings to zoom in on a section of the map to get a closer look, as shown in the
example below.

Name : New Magnifier |
Type: Magrifier |
Color: | white | . |
In Effect: | Nome - |
OutEffect: | Nome - |
Zoom Level: [4 B
Map Style: |Bing Aerial ~ |
Map Zoom: [ 1.00 B

Properties - Magnifier Drawings

XPression Maps User Guide (v3.4) Drawing Management « 111



The Magnifier drawing properties are described in the following table.

Property

Color

Image

In Effect

Description
Defines the color of the image selected in the Image property.

Select an existing color using the drop-down or select the Browse button to add a
new color for the locator drawing.

The selected color will be applied to the image, if one is selected.

If no color is selected, the selected border image will be invisible.

Select an existing image from the drop-down or select the Browse button (/) to
add a new image. The image provides a border for the map that is highlighted in the
drawing.

For the Magnifier drawing to work properly, there must be a transparent area in
the center of the image that is completely surrounded by graphics. Towards the
edges of the image, transparent areas are possible. The image defines the area
where the maps (Bing Aerial, Bing Aerial Label, or any of the Bing Road maps) are
shown.

The drawing will be textured with this image.
An image must be selected for a Magnifier drawing.

The default effect that plays as the drawing appears during animation. The effect can
only be seen when the animation is played.

Options are:
None — the drawing appears instantly at the frame to which the key frame is set.

Dissolve — the drawing animates in at the level set in the corresponding Zoom
Level field.

Wipe Left — the drawing animates from the left at the level set in the
corresponding Zoom Level field.

Wipe Right — the drawing animates from the right at the level set in the
corresponding Zoom Level field.

Wipe Bottom — the drawing animates from the bottom at the level set in the
corresponding Zoom Level field.

Wipe Top — the drawing animates from the top at the level set in the corresponding
Zoom Level field.

The effect can be changed in the Drawing Editor in the Effect section, when the
drawing is selected in the output window.

See Effect[ 224 for more information.
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Property Description

Out Effect The default effect that plays as the drawing disappears during animation. The effect
can only be seen when the animation is played.

Options are:

None — the drawing disappears instantly at the frame to which the key frame is
set.

Dissolve — the drawing blends out at the level set in the corresponding Zoom
Level field.

Wipe Left — the drawing animates out from the left at the level set in the
corresponding Zoom Level field.

Wipe Right — the drawing animates out from the right at the level set in the
corresponding Zoom Level field.

Wipe Bottom — the drawing animates out from the bottom at the level set in the
corresponding Zoom Level field.

Wipe Top — the drawing animates out from the top at the level set in the
corresponding Zoom Level field.

The effect can be changed in the Drawing Editor in the Effect section, when the
drawing is selected in the output window.

See Effect 22 for more information.
Zoom Level The default value of the Zoom Level for this drawing.
Valid values are 1 to 21.

The effect can be changed in the Drawing Editor, when the drawing is selected in
the output window.

See Magnifier Drawing Parameters(zsf) for more information.
Map Style Defines the default map style for this drawing.

Options are:

Bing Aerial

Bing Aerial Label

Bing Road

Bing Road Dark

Bing Road Gray

Bing Road Light

The effect can be changed in the Drawing Editor, when the drawing is selected in
the output window.

See Magnifier Drawing Parameters|zsil for more information.
Map Zoom The zoom value for the highlighted area of a map.

The effect can be changed in the Drawing Editor, when the drawing is selected in
the output window.

See Magnifier Drawing Parameters[zsi for more information.
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Locator Drawings

Use Locator drawings to show where the location you're looking at is found in the context of a larger
map. For example, if you place a locator drawing on a city and enlarge it, as shown in the example
below, you’'ll see in what part of the country that city is found. Locator drawings are typically used in the
Overlay Layer. See Overlay Layer for more information.

Out Effect:
Zoom Level:
Map Style:
Map Zoom:

Properties - Locator Drawings

|Lm3tor1

| Locator

| white

| BirdEyeMag3

[[Issdve

’D’sso&ve

[ 4

|Bing Acrial

| 1.00
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The Locator drawing properties are described in the following table.

Property Description
Color Defines the color of the image selected in the Image property.

Select an existing color using the drop-down or select the Browse button (/== ) to
add a new color for the locator drawing.

The selected color will be applied to the image, if one is selected.

If no color is selected, the selected border image will be invisible.

Image Select an existing image from the drop-down or select the Browse button (/=) to
add a new image. The image provides a border for the map that is highlighted in the
drawing.

For the locator drawing to work properly, there must be a transparent area in the
center of the image that is completely surrounded by graphics. Towards the edges of
the image, transparent areas are possible. The image defines the area where the
maps (Bing Aerial, Bing Aerial Label, or Bing Road) are shown.

The drawing will be textured with this image.
An image must be selected for a Locator drawing.

In Effect The default effect that plays as the drawing appears during animation. The effect can
only be seen when the animation is played.

Options are:
None — the drawing appears instantly at the frame to which the key frame is set.

Dissolve — the drawing animates in at the level set in the corresponding Zoom
Level field.

Wipe Left — the drawing animates from the left at the level set in the
corresponding Zoom Level field.

Wipe Right — the drawing animates from the right at the level set in the
corresponding Zoom Level field.

Wipe Bottom — the drawing animates from the bottom at the level set in the
corresponding Zoom Level field.

Wipe Top — the drawing animates from the top at the level set in the
corresponding Zoom Level field.

The effect can be changed in the Drawing Editor in the Effect section, when the
drawing is selected in the output window.

See Effect 24 for more information.

Out Effect The default effect that plays as the drawing disappears during animation. The effect
can only be seen when the animation is played.

Options are:

None — the drawing disappears instantly at the frame to which the key frame is
set.

Dissolve — the drawing blends out at the level set in the corresponding Zoom
Level field.

Wipe Left — the drawing animates out from the left at the level set in the
corresponding Zoom Level field.

Wipe Right — the drawing animates out from the right at the level set in the
corresponding Zoom Level field.

Wipe Bottom — the drawing animates out from the bottom at the level set in the
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Property Description
corresponding Zoom Level field.

Wipe Top — the drawing animates out from the top at the level set in the
corresponding Zoom Level field.

The effect can be changed in the Drawing Editor in the Effect section, when the
drawing is selected in the output window.

See Effect( 24l for more information.

Zoom Level The default value of the Zoom Level for this drawing.

The effect can be changed in the Drawing Editor, when the drawing is selected in
the output window.

See Locator Drawing Parameters[2s) for more information.
Map Style Defines the default map style for this drawing.

Options are:

Bing Aerial

Bing Aerial Label

Bing Road

Bing Road Dark

Bing Road Gray

Bing Road Light

The effect can be changed in the Drawing Editor, when the drawing is selected in
the output window.

See Locator Drawing Parameters|z:2! for more information.
Map Zoom Defines the default map zoom value for this drawing.

The effect can be changed in the Drawing Editor, when the drawing is selected in
the output window.

See Locator Drawing Parameters 23] for more information.
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Dynamic Data Drawings

Use Dynamic Data drawings to show information about a particular location, such as weather,
population, etc., as shown in the example below. This feature is an option that needs to be selected when
ordering your system. It is not included in all systems.

For more information on options available for XPression Maps, please reach out to your Ross Video sales
professional.

Properties - Dynamic Data Drawings
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The Dynamic Data drawing properties are described in the following table.

Property Description

Writing Select the writing direction for the text that is used in the dynamic data drawing.
Direction Options are Left to Right or Right to Left.

Layout Select the layout file that defines the look of the dynamic data drawing.

Font Select an existing font using the drop-down or select the Browse button (/) to

add a new font to apply to the text of the dynamic data drawing.

Color Select an existing color using the drop-down or select the Browse button (. ) to
add a new color to apply to the text of the dynamic data drawing.

If no color is selected, the text will be invisible.
Background This property only takes effect if there is no background image selected.

Color If a background color is selected, a rectangle in this color will be drawn behind the

text. The size of the rectangle corresponds to the text size with a small offset.

Background Select an existing image using the drop-down or select the Browse button (.- ) to
Image add a new image.

If a background image is selected, the background color (if set) will not be applied.
A rectangle textured with the image will be drawn behind the text.

The size of the rectangle corresponds to the actual text size with a small offset, so
the background image grows as the text grows.

Default Scale The default value of the Scale property for the drawing.

Shadow Color | Select an existing color using the drop-down or select the Browse button ( =) to
add a new color to apply to the shadow of the text.

Shadow Angle | Angle — The angle of the shadow in degrees.
0 — The shadow falls to the right of the text.
90 — The shadow falls above the text.
180 — The shadow falls to the left of the text.
-90 — The shadow falls below the text.

Shadow The distance that the shadow falls from the text. A larger value moves the shadow
Distance further away from the text.
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Property Description
Visibility How a dynamic data drawing appears (In) and disappears (Out) during animation.

(In and Out) The default effect that plays as the drawing appears during animation. The effect
can only be seen when the animation is played.

Options are:
None — the drawing appears instantly at the frame to which the key frame is set.

Dissolve — the drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing blends in over the number of seconds selected in the
Time field. Use the Delay field to input the number of seconds that the drawing will
delay its animation.

Wipe Left — the drawing animates in and out at the level set in the corresponding
Zoom field. The drawing enters from the left over the number of seconds selected
in the Time field. Use the Delay field to input the number of seconds that the
drawing will delay its animation.

Wipe Right — the drawing animates in at the level set in the corresponding Zoom
field. The drawing enters from the right over the number of seconds selected in the
Time field. Use the Delay field to input the number of seconds that the drawing will
delay its animation.

Wipe Bottom — the drawing animates in and out at the level set in the
corresponding Zoom field. The drawing enters from the bottom over the number of
seconds selected in the Time field. Use the Delay field to input the humber of
seconds that the drawing will delay its animation.

Wipe Top — the drawing animates in and out at the level set in the corresponding
Zoom field. The drawing enters from the top over the number of seconds selected
in the Time field. Use the Delay field to input the number of seconds that the
drawing will delay its animation.

Flight Mode — Select the flight mode checkbox to enable the drawing to visualize
the data as its clicked and dragged along the map.

The effect can be changed in the Drawing Editor in the Effect section, when the
drawing is selected in the output window.

See Effect/24) for more information.
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Background Drawings

Use a Background drawing to change the background of a map, as shown in the example below.

Default background New background

Example - Background Drawing

General Tab

Name: New Background|

Type: ‘Bad(gruund ‘
General
Color: | white N || —
Image: |Factory M|
Pause At End: | |
Slow Down: | |
BlendMode: |Reguier M

Properties - Background Drawings - General Tab
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The properties in the General tab are described in the following table.

Property

Color

Image

Pause At End

Slowdown

Blend Mode

Description

Defines the fullscreen background color, independent of Background Mode. See
Editing the Background Drawingl el for more information.

Select an existing color using the drop-down or select the Browse button (/) to
add a new color to apply to the background drawing.

If no color is selected, the background will be transparent.
Select an existing image using the drop-down or select the Browse button (/) to
add a new image.

If selected, the image is used as the background when this drawing is selected in
the Scene Properties editor or from the Drawing Toolbox.

See Editing the Background Drawing[ s for instructions on replacing the background
drawing from either the Scene Properties editor or the Drawing Toolbox.

Enter a value or use the arrows to set the humber of frames for which an image
sequence will pause at the last image before looping.

When an animated image is selected, this is the number of frames, expressed as a
percentage, by which the movement of the animated image will be slowed.
Accordingly, a negative value will speed up the movement.

The default mode is Regular.

Options are:

Regular — the area is color combined with the underlying map color.
This is the most common blend method.

Multiply — the area color is multiplied with the underlying map color.
Add — the area color is added to the underlying map color.

To add a new background drawing:

1. Select the Browse button (/=) to open the Images window.

H Images

1 | 2line_slider_base

3 |70

4 | ARTSDesignRahmen

5 |Airplane

No

No

No

No

No

Add | Change

| { Delete |

Images Window
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2. Select Add.
The local file folder window opens.
3. Choose a local image and select Open.
Acceptable image file formats: .png, .jpg, .gif, tif and .tga.

4. Select Done to close the images window.
To change an existing background drawing:

1. Select the background image you want to change and select Change.
The local file folder window opens.

2. Choose a local image and select Open.
Acceptable image file formats: .png, .jpg, -gif, tif and .tga.

3. Select Done to close the images window.
To delete a background drawing:

1. Select an image from the images window that you want to delete and select Delete.

The Delete Image window opens.

f [ -
' o Do you really want to delete the selected image?
| | Y | M
Delete Image Window

2. Select Yes to delete the image.
The image is deleted.

3. Select Done to close the images window.
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Video Input Drawings

Use Video Input drawings to define the look and behaviour of video inputs in the scene. You can add a
frame around the video input and attach a label, if desired.

You can have up to 8 video inputs in a scene.

The Video Input drawing properties are divided into 3 tabs and are described below.

-

Example - Video Input Drawing

General Tab

| \
Effect Zoom  Time Delay
In: | None >|o |20z [#)o.0 [
out: None > | 200 [$)[0.20 [3)0.00 [2]
FightMode: [

Properties - Video Input Drawings - General Tab
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The properties found in the General tab are described in the following table.

Property
Input

Visibility
(In and Out)

Description

Select the input source to be displayed in the drawing.

There are 8 possible inputs.

How a video input drawing appears (In) and disappears (Out) during animation.
Options are:

None — the drawing appears/disappears instantly at the frame to which the key
frame is set.

Dissolve — the drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing blends in/out over the humber of seconds selected in the
Time field. Use the Delay field to input the number of seconds that the drawing will
delay its animation.

Wipe Left — the drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing appears/disappears from the left over the number of
seconds selected in the Time field. Use the Delay field to input the number of
seconds that the drawing will delay its animation.

Wipe Right — the drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing appears/disappears from the left over the number of
seconds selected in the Time field. Use the Delay field to input the number of
seconds that the drawing will delay its animation.

Wipe Bottom — the drawing animates in and out at the level set in the
corresponding Zoom fields. The drawing appears/disappears from the bottom over
the number of seconds selected in the Time field. Use the Delay field to input the
number of seconds that the drawing will delay its animation.

Wipe Top — the drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing appears/disappears from the top over the number of
seconds selected in the Time field. Use the Delay field to input the number of
seconds that the drawing will delay its animation.

Flight Mode — Select the flight mode checkbox to enable the drawing to visualize
the data as its clicked and dragged along

The effect can be changed in the Drawing Editor in the Effect section, when the
drawing is selected in the output window. See Effect[22 for more information.
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Transform Tab

Properties - Video Input Drawings - Transform Tab

The properties found in the Transform tab are described in the table below.

Property Description

Crop Enter a value or use the arrows to select a percentage by which to crop the video
input.

Scale In the X and Y fields, enter a value or use the arrows to increase or decrease the
size of the video input.

Decoration Tab

Properties - Video Input Drawings - Decoration Tab

The properties found in the Decoration tab are described in the table below.

Property

Description

Color

Select an existing color using the drop-down or select the Browse button (E]) to add
a new color to apply to the frame image for the video input.

Frame Image

Select an existing image using the drop-down or select the Browse button (E]) to
add a new image to apply to the frame for the video input.

Label

Select the Label checkbox if you want to add a label to the video input drawing.
Use the Reference drop-down to select a text drawing for the label.

Use the Position drop-down to select the location of the label: Top, Left, Right or
Bottom.
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Inset Drawings

Inset drawings are used to highlight specific regions while also displaying the larger geographical
location.

You can place Inset drawings on the Overlay Layer or directly onto the map.

Properties - Inset Drawings
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The properties found in the Inset editor are described in the following table.

Property Description
Visibility How an inset drawing appears (In) and disappears (Out) during animation.
(In and Out) Options are:

None — the drawing appears/disappears instantly at the frame to which the key
frame is set.

Dissolve — the drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing blends in/out over the nhumber of seconds selected in the
Time field. Use the Delay field to input the number of seconds that the drawing will
delay its animation.

Wipe Left — the drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing appears/disappears from the left over the number of
seconds selected in the Time field. Use the Delay field to input the humber of
seconds that the drawing will delay its animation.

Wipe Right — the drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing appears/disappears from the left over the number of
seconds selected in the Time field. Use the Delay field to input the number of
seconds that the drawing will delay its animation.

Wipe Bottom — the drawing animates in and out at the level set in the
corresponding Zoom fields. The drawing appears/disappears from the bottom over
the number of seconds selected in the Time field. Use the Delay field to input the
number of seconds that the drawing will delay its animation.

Wipe Top — the drawing animates in and out at the level set in the corresponding
Zoom fields. The drawing appears/disappears from the top over the number of
seconds selected in the Time field. Use the Delay field to input the humber of
seconds that the drawing will delay its animation.

Flight Mode — Select the flight mode checkbox to enable the drawing to visualize
the data as its clicked and dragged along

The effect can be changed in the Drawing Editor in the Effect section, when the
drawing is selected in the output window. See Effect| 2. for more information.

Locator Select a Locator Reference to display a reference point on the map in the output
window.

Click the browse button to open the Select Locator Reference window and select
a tool from the drop-down.

Select the icon you want to use, double-click to select it or press Select.

Adjust the Default Scale to increase or decrease the size of the reference icon you
selected.

The Default Scale value is 1.00.

Shadow Color — Select an existing color using the drop-down or click the Browse button (
=) to add a new color to apply to the shadow of the text.

Angle — The angle of the shadow in degrees.
0 — the shadow falls to the right of the text.
90 — the shadow falls above the text.

180 — the shadow falls to the left of the text.
-90 — the shadow falls below the text.
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Property Description

Distance — The distance that the shadow falls from the text. A larger value moves
the shadow further away from the text.

Blur — Enter a value or use the arrows to set the degree by which the shadow
appears out-of-focus.

Border Color — Select an existing color using the drop-down or click the Browse button (
=) to add a new color to apply to the border.

Width — Enter a value or use the arrows to set the thickness of the border.
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Container Drawings

Container drawings are used to contain and display DataLinq layers on the map.

Container drawings can be placed anywhere on the map, they will not register on final renderings and
act only as a placeholder for external DatalLing information.

Properties - Container Drawings

The properties found in the Container editor are described in the following table.

Property Description
Name Enter a name for the container drawing that relates to the data source.
Type The type is populated by default and is not editable.
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Drawings Overview Panel

The Drawings Overview Panel contains any drawings that have been added to a scene. Each drawing
is listed with an icon that identifies which group it belongs to, see below.

You can organize, rename and delete drawings in the scene from the Drawings Overview Panel.

Search Editor | ShapeEditor | Drawing Editor | Bookmark Editor |

‘}MQSOva\liew 13 [

_i Mew Text
@ Ball Blue
& Flag Red

) DemoLayoutWNM

Drawings Overview Panel with Drawing Icons
To rename a drawing in the Drawings Overview Panel:

1. Double-click to select the drawing you want to rename.
2. Delete the drawing name and enter a new descriptive name for the drawing.

The drawing is renamed.
To delete a drawing in the Drawings Overview Panel:

1. Right-click the drawing you want to delete.
2. Select Delete Drawing.

OR

Press Ctrl+x.

OR

Press the Delete key on the keyboard.

The drawing is deleted.
To hide drawings from the scene:

e Use the checkboxes beside the drawings in the Drawings Overview Panel to make a drawing visible
or invisible in the scene.

If the boxes are unchecked the drawings will still appear in the drawings overview panel.
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User Predefined Objects

The User Predefined Objects panel allows users to manage different groups and folders containing
globally used objects, such as current war zones, pandemic stats, or wildfire locations from a scene.
These groups merge the drawing tools into one object that can be accessed and shared in the database.
You can add, edit and delete groups and folders from within the User Predefined Objects panel.

The following topics are discussed in this section:

Adding and Deleting Groups| 132!

Adding and Deleting Folders[ 134

Creating User Predefined Objects| 136

Deleting User Predefined Objects[140)

User Predefined Objects Panel
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Adding and Deleting Groups

The User Predefined Objects panel allows users to create multiple groups containing as many folders
with collections of drawing tools saved as one object.

In order to merge predefined objects to the User Predefined Objects panel you must first create a group,
and continue to add a folder for each desired scene.

For information on how to create folders see Adding and Deleting Folders[is4l.
To add a new group:

1. In the User Predefined Objects panel select the Browse button (\I]) beside the Group drop-
down.

The Groups Management window opens.

W Groups Management %

‘Some middle east examples

Groups Management Window
2. Select Add.
The Add Group window opens.

Add Group Window

3. In the Name field, enter a name for the new group.

4. In the Description field, enter a description for the new group.
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5. Select Add.
The group has been added to the list.

X You can rearrange groups in the Groups Management window by dragging and dropping them
into position.

To delete a group:

1. From the User Predefined Objects panel, select the Browse button ( - ) beside the Group drop-
down.
2. Select the group you want to delete and select Delete.

The Delete Group window opens.

4 Delete Group? X

Do you want to delete the selected group and all its folders and objects?
[[)Confirm the group delete.

Ys | w0 |

Delete Group Window
3. Select the checkbox to confirm the group delete and select Yes.

The red highlighted Delete Group confirmation dialog opens.

B4 Delete Group? X

Highlighted Delete Group Window
4. Select Yes to delete the group.

The group and its containing folders are now deleted.
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Adding and Deleting Folders

Folders created in the User Predefined Objects window are used to contain the collection of drawing
tools created as one object. In order to save a predefined object you must first create a group and then
add a folder to that group.

For information on creating groups see Adding and Deleting Groupsls).

To add a folder to a group:

1. In the User Predefined Objects panel, from the Group drop-down, select the group to which you
want to add a folder.

2. Right-click in a blank area of the Name box and select Add Folder.
The Add Folder window opens.

[ Add Folder ? X

Name New Folder Name]|
Descriph

i ||
Add Folder Window
3. In the Name field, enter a name for the folder.
4. In the Description field, enter a description for the folder.
5. Select Add.
The folder is added to the group.

To delete a folder from a group:

1. From the User Predefined Objects panel select the group containing the folder you want to delete
from the Group drop-down.

2. Right-click on the folder and select Delete.

The Delete Folder window opens.
B4 Delete Folder? X

Do you want to delete the selected folder and all its objects?
[J)Confirm the folder delete.

Yes No
Delete Folder Window
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3. Select the checkbox to confirm the folder delete and select Yes.

The red highlighted Delete Folder window opens.

|
4

Highlighted Delete Folder Window

4. Select Yes to delete the folder.

The folder is deleted.

* Deleting a folder will delete the objects as well.

XPression Maps User Guide (v3.4) User Predefined Objects « 135



Creating User Predefined Objects

Combine a collection of drawing tools on the map as one predefined object by creating User Predefined
Objects.

Creating User Predefined Objects:
1. In the Search Editor, type in a geographical location to be displayed on the map in the output
window.

For information on using the Search Editor see Search Editor| s

2. Select the Shape Database Viewer button on the bottom of the Search Editor window to open the
Shape Database Viewer.

The Shape Database Viewer opens.

[ shape Database Viewer ? X

The Gambia
Togo

Tonga

Trinidad and Tobago
Tunisia

Turkey

Turkmenistan

Turks and Caicos Islands
Tuvalu

United Arab Emirates
United Kingdom
United States
Uruguay
Uzbekistan
Vanuatu

Vatican City
Venezuela
Vietnam
Western Sahara
Yemen

Zambia
Zimbabwe

Shape Database Viewer

3. Expand the country and select the state you wish to add to the map and select Add State Shape.
The State Shape is added to the Shape Editor.

4. Select Done to close the Shape Database Viewer.

5. Add drawings to the map, as needed.
The drawings are added to the Drawings Overview panel.

6. In the Shape Editor, with the shape selected, expand the Drawing Relation section.
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7. Drag and drop drawings from the Drawings Overview panel into the Drawing Relation panel.

¥ Drawing Relation

1| Odessa O O
2| Star? Red O |0
3| Pin2 Crange O ]
4| Pin2 Red O J

Shape Editor - Drawing Relation

The two columns to the right of the numbered list contain checkboxes that allow you to select if you
want the drawing to be masked by the drawing area or not, as described in the following procedures.

To mask an area with a shape:

1. Add an Area drawing to the map.

2. Drag and drop the Area drawing from the Drawings Overview panel to the Drawing Relation
panel.

3. In the Drawing Relation panel, select the checkbox in the Mask column to the right of the Area
drawing to apply a mask to the part of the Area drawing that falls outside of the shape.

LU Voronezh

€ slgorod

) Volgograd

Krasnodar

Belorade : |
b bing/ Bilich:

Image Displays The Difference Between Drawing Tools Unmasked And Masking By An Area
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To mask a shape by the area:

e Select the checkbox under this icon @ beside the shape that you want to have the area masked by.
Notice the background and borders of the area showing through the drawing tools.

The shape is masked by the area.

enza

rajevo

Image Displays The Difference Between Drawing Tools Being Masked And Unmasked By An Area

To add a completed scene to the User Predefined Objects panel:

1. Select the state shape from the top of the Shape Editor panel and drag it into the selected group
folder created in the User Predefined Objects panel.

The Add User Predefined Objects window opens.

4 Add User Predefined Object ? X
Name: |Ukraine I
Search Tags: |Ukra|ne Donetsk |
Description: Description for the object]

Preview:

Add User Predefined Objects Window

X In order to merge the the collection of drawing tools to the user predefined objects panel you
must first create a group and folder within the group.

For information on how to create groups see Adding and Deleting Groups|132\.
For information on how to create folders see Adding and Deleting Folders[ah,
2. In the Name field, enter a name for the object.
3. In the Search Tags field, enter any identifying terms for the object.

For example, you can identify any masked areas within the scene.
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4. In the Description field, enter a description of the scene and its intended purposes.

5. Select the Snap button beside the Preview image to snap thumbnail of the User Predefined
Object.

To adjust the thumbnail image, close the Edit User Predefined Object window and move the map
or zoom in or out to your preferred position. Double-click the User Predefined Object to open the
Edit User Predefined Object window and select Snap to preview a new thumbnail image.

6. Select Add to add the User Predefined Object to your folder.
The user predefined object is added to the folder.

7. From the menu bar select File > Save to save your project.
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Deleting User Predefined Objects

Users can delete objects from the User Predefined Object folders.

To delete user predefined objects:
1. In the User Predefined Objects panel, select the group containing the object(s) you want to delete
from the Group drop-down.
2. Locate the object you want to delete, right-click and select Delete.
The Delete Object window opens.
b4 Delete Object? X

Do you want to delete the selected object?
f#Canfirm the object delete.

L e | Mo

Delete Object Window
3. Click the checkbox to confirm and select Yes to delete the object.

The User Predefined Object is deleted.
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Creating Scenes

XPression Maps is an application that allows the user to design virtual animations over maps and create
video files out of these animations. Drawings such as icons, lines, areas, and text, can be used to
highlight and describe situations on the map in an animated way. You can create a story out of the virtual
animation. During the creation of a scene the application downloads all necessary map information from
the Bing web service.

An integrated library of country and state boundaries can be used to highlight countries and regions of
interest.

X The application must be connected to the Internet because all new map tiles are downloaded from the
web map service.

The following topics are discussed in this section:
Output Window/ 142

Opening a Scene[143!

Adding and Editing Drawings|ss)
Ordering Drawings/ss)

Drawing Toolbox/ 59

Flight Pointsl1es)

Animation Control[1e)

Camera Controll e

Safe Title / Safe Areal 3
Overlay Layer[

Saving a Scenel 7

Exporting a Scene[179)
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Output Window

The first time you launch the application, the Output Window displays the world globe at a random
location. Subsequently, when you launch the application, the map opens to where it was positioned when
the application was last closed.

In the output window, you can:

e Move and zoom into any location of the world using the mouse or enter a location in the Search
Editor.

e Add shapes and drawings to the scene.

e Create animated scenes.
Manipulating the Globe

The Globe in the output window can be rotated and zoomed in or out to a specific location.
To rotate the globe:

o Left-click on the mouse and drag to rotate the globe in the desired direction.

e Press Ctrl + left-click on the mouse to spin the globe clockwise and counterclockwise and position the
globe into the desired direction

e Press Ctrl + right-click on the mouse to tilt the globe vertically and position the globe into the desired
direction.

To zoom in or out:

e Use the scroll wheel of the mouse or right-click and draw a rectangle around the area of interest.
Camera Focus

In the center of the output window, there is a crosshairs. When you search for a specific location, it will
be positioned on the crosshairs. This is also a useful tool for centering the area of interest in the scene.
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Opening a Scene

A scene consists of a map and a humber of drawings you add to create an animated sequence. By
default, the application launches with a new scene displayed, but you can also choose to open an existing
scene or a recently opened scene.

To open a new scene:

1. From the menu bar select File > New or select the New icon in the toolbar.

XPression Maps Toolbar - New

If the current scene has unsaved changes, a confirmation dialog opens asking if you want to save it.

B save Scene *

Save Scene Confirmation

2. Select Yes to save the current scene or No to discard it.
To open an existing scene:

1. From the menu bar select File > Open or select the Open Scene button in the toolbar.

XPression Maps Toolbar - Open Scene

If the current scene has unsaved changes, a confirmation dialog opens asking if you want to save it.

B save Scene x

Save Scene Confirmation
2. Select Yes to save the current scene or No to discard it.

3. Then select an existing scene from the XPression Maps Scenes folder (or whichever folder you‘ve
stored your scenes in) and select Open.

If the selected scene has a different video format, a confirmation dialog opens, asking if you want to
set the new format.

i Video Record Format Changed *

Video Format Confirmation
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4. Select Yes to set the new format or No to keep the current format.

Clicking the X in the top-right corner gives the same result as clicking No.
To open a recently opened scene:

1. Select File and select a scene from the list of recently opened scenes.

H KPression Maps

[@] New Ctrl+MN
i) Open Ctrl+0
& Save Ctrl+5
I Save As Ctrl+Shift+S
i Export Ctrl+E
@ Preferences
C:/XPressionMaps/Scene/ConventionCenter.wnm Ctrl+0
C:/¥PressionMaps/Scene/Ontaric.wnm Ctrl+1
C:/KPressionMaps/Scene/France.wnm Ctrl+2
C:/KPressi ps/Scene/A lia.wnm Ctrl+3
43 Exit Ctrl+Q

Recently Opened Scenes

If the current scene has unsaved changes, a confirmation dialog opens asking if you want to save it.

B save Scene *

Save Scene Confirmation
2. Select Yes to save the current scene or No to discard it.

If the selected scene has a different video format, a confirmation dialog opens asking if you want to
set the new format.

B Video Format >

Video Format Confirmation

3. Select Yes to set the new format or No to keep the current format.
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Adding and Editing Drawings

Drawings in the Drawing Toolbox are added to a scene in the output window. They become part of the
scene and as such will be saved and loaded with the scene.

For information about creating drawings, see Managing Drawings| ss.

To add a drawing to the scene:

1. In the Drawing Toolbox, from the Group drop-down, select the group that contains the drawing
you want to add to your scene.
2. Then do one of the following:

a. Select a thumbnail in the preview pane and then click in the scene where you want the drawing to
appear.

Left-clicking multiple times in the scene will add additional instances of the drawing.
OR
b. Left-click and drag a thumbnail from the preview pane into the scene.

3. After adding a drawing, right-click on the mouse to add just one instance of the drawing or continue
clicking to add multiple instances.

This method applies to text, icon, magnifier, locator, dynamic data, background, video input and inset
drawings. For information about adding and editing area and line drawings, see the following sections:

Adding and Editing Area Drawings. [ 13!
Adding and Editing Line Drawings. [1s2)

When you add a drawing to a scene, it is displayed within a white bounding box with a handle attached to
the middle, as shown below:

Selected Drawing in the Output Window

The bounding box, the handle and the various icons attached to the bounding box are used to manipulate
the drawing. You can move the drawing and modify the size, visibility, orientation, and rotation using
these tools. Not all tools apply to every drawing type. Drawings display only those tools that apply to
them.
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To copy and paste a drawing:

1. In the output window, select a drawing in the scene.

2. From the menu bar select Edit > Copy Drawing or press Ctrl+C.
The drawing and its parameter values are stored internally.

3. From the menu bar select Edit > Paste Drawing or press Ctrl+V.

A copy of the stored drawing is placed in the middle of the output window.
To cut a drawing:

1. In the output window, select a drawing in the scene.

2. From the menu bar select Edit > Cut Drawing or press Ctrl+X or press the Delete key.
This copies the drawing while simultaneously deleting it, so if you change your mind, you can paste it
back in.

To edit a drawing:

1. Click on a drawing in the output window to select the drawing.
The selected drawing will display the bounding box and its tools.

2. Use the tools to change the size, position and appearance of the drawing as described in the table
below:

Tool How to Use the Tool

Click and hold, then drag to move the drawing around the
scene.

Center Point

You can also click and hold anywhere inside the bounding
box to move the drawing.

Corner Points Click and hold, then drag to scale the drawing.

Handle Click and hold the end of the handle, then drag to rotate
the drawing.

For line and area drawings, the handles can also be used
to adjust the path of the line or the shape of the area.

Scale L Click to enable Auto Scaling.
w

In the Drawing Editor, you’ll see that in the Size
section, the Auto checkbox is selected. When selected,
the drawing remains the same size as you zoom in and
out on the map. When the Auto checkbox is cleared, the
drawing will scale larger when you zoom in and smaller
when you zoom out on the map.
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Tool How to Use the Tool

Eye Icon m Click to toggle the visibility of the drawing.
N
Face Icon Click to toggle the placement of a drawing, either angled
‘} to match the map surface or perpendicular to the map
1’ surface and facing the camera.
L %
For drawings that are created on the Overlay Layer, this
icon does not appear.
Double-Ended Click the double-ended arrow to flip the drawing
Arrow P horizontally.

In addition to the tools described above, some types of drawings have additional ways to manipulate
them, that are specific to the drawing type.

These additional methods are described in the following sections.
Editing Text Drawings/ s

Adding and Editing Area Drawings/149)

Adding and Editing Line Drawings/s2!

Editing Locator Drawings| 1ss!

Editing the Background Drawing[s6!
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Editing Text Drawings

Text drawings display a predefined text in a predefined font that has been created in the Drawing
Management Editor.

See Drawing Management Editor[ ) more information.

To edit a text drawing:

e Double-click the text drawing and enter the new text directly in the output window or in the Drawing
Editor, in the Text pane, edit the default text.

e When the text drawing has a Callout marker:

» Click and hold inside the bounding box to move the label and its background without moving the
marker.

» Click and hold the white point at the top of the handle inside the bounding box to move the label,
background and marker together.
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Adding and Editing Area Drawings

Area drawings display a closed area filled with color and texture. The fill is defined in the Drawing
Management Editor. In the Drawing Toolbox preview pane, area drawings are identified with the
area drawing icon, shown below.

Area Drawing Icon

Area drawings can be added with or without Auto-Trace mode enabled. Enabling the Auto-Trace mode
makes it possible to draw an area on the screen by dragging the drawing without the need to click at
different points. The Auto-Trace parameter is located below the Drawing Toolbox in the Area Line
Edit Options window. Once added to the scene, the area drawings can be manipulated to change their
appearance, location, size, etc.

Auto-Trace Mode

To add an area drawing with Auto-Trace mode enabled:

1. Below the Drawing Toolbox in the Area Line Edit Options window select an option from the Lock
OSM Layer drop-down if you want to have the area drawing locked on to a particular section of the
map so that it doesn't waiver off to other points. Select None to keep the OSM Layer unlocked.

2. Select the Auto-Trace checkbox to enable it.

3. In the Drawing Toolbox, left-click on the thumbnail of the area drawing you want to add to your
scene.

4. In the output window, left-click on the map where you want the area to start, then drag through the
area you want to display, left-clicking each time you change direction.

Drag and click as if you're creating the outline of the area, ending up at the same point where you
started, to get roughly the shape of the area you intend.

5. Release the mouse button when you reach the end of the area, to stop drawing.
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To add an area drawing with Auto-Trace mode disabled:

1.

N

4.
5.

6.

Below the Drawing Toolbox in the Area Line Edit Options window select an option from the Lock
OSM Layer drop-down if you want to have the area drawing locked on to a particular section of the
map so that it doesn't waiver off to other points. Select None to keep the OSM Layer unlocked.

. Clear the Auto-Trace checkbox to disable it.

In the Drawing Toolbox preview pane, left-click on the area drawing thumbnail you want to add to
your scene.

In the output window, left-click on the map where you want the area to start.
Move the mouse and left-click at individual points along the area you want to display.

Click as if you're creating the outline of the area, and end up at the same point where you started, to
get roughly the shape of the area you intend.

Right-click when you reach the end of the area, to stop drawing.

To delete an area drawing:

1.
2.

Select the area drawing but don’t click on a location point.

Then press the Delete key to remove the drawing.

To edit an area drawing:

Select the area drawing and do any of the following:
» Double-click positions along the border of the area drawing to create new location points.

» Click and hold on a location point and then drag it to a new position to adjust the shape of the area
drawing.

» Press the CTRL key and click on a location point to toggle between a sharp corner and a smooth path
at the location point.

The location point turns blue.

By default the location points are linked and the line forms a smooth round path through the points.
Unlinking a location point makes a sharp corner at this position.

> Click the end of a handle and drag to adjust the shape of the area drawing.
» Click a location point (turning it red) and press the Delete key to remove the point.
» Click a location point to toggle between a sharp corner and a smooth path.

By default the location points are linked and the line forms a smooth round path through the points.
Unlinking a location point makes a sharp corner at this position.

» Click the end of a handle and drag to adjust the shape of the area drawing.

» Click a location point (turning it red) and press the Delete key to remove the point.
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Point Creation Mode

Use the Point Creation Mode section to select and modify which style of drawing handles you want to
use when creating line and area drawings.

The styles are:

e Locked Handles

Select the Locked Handles checkbox or press Ctrl+Alt+L to enable a 180 degree connection with
locked handle points when creating a line or area drawing.

e Free Handles

Select the Free Handles checkbox or press Ctrl+Alt+F to enable an unlimited and unlinked
connection of points when creating a line or area drawing.

e No Handles

Select the No Handles checkbox or press Ctrl+Alt+N to enable zero lengths of linear connection
points when creating a line or area drawing.
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Adding and Editing Line Drawings
Line drawings display a predefined textured line that is created in the Drawing Management Editor.
See Drawing Management Editor[e2") for more information.

In the Drawing Toolbox preview pane, line drawings are identified with the line drawing icon, shown
below.

0,_9

Line Drawing Icon

Line drawings can be added with or without Auto-Trace mode enabled. Enabling the Auto-Trace mode
makes it possible to draw a line on the screen by dragging the line without the need to click at different
points. The Auto-Trace parameter is located below the Drawing Toolbox in the Area Line Edit
Options window. Once added to the scene, the line drawings can be manipulated to change their
appearance, location, size, etc.

Auto-Trace Mode

To add a line drawing with Auto-Trace mode enabled:

1. Below the Drawing Toolbox in the Area Line Edit Options window select an option from the Lock
OSM Layer drop-down if you want the line drawing locked on to a particular section of the map so
that it doesn't waiver off to other points. Select None to keep the OSM Layer unlocked.

2. Select the Auto-Trace checkbox to enable it.
3. In the Drawing Toolbox, left-click on the line drawing thumbnail you want to add to your scene.

4. In the output window, left-click and hold down the mouse button on the map where you want the line
to start, then drag the line along the route you want to display.

5. Release the mouse button when you reach the end of the route, to stop drawing.
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To add a line drawing with Auto-Trace mode disabled:

1. Below the Drawing Toolbox in the Area Line Edit Options window clear the Auto-Trace checkbox
to disable it.

In the Drawing Toolbox, left-click on the line drawing thumbnail you want to add to your scene.
In the output window, left-click on the map where you want the line to start.

Move the mouse and left-click at individual points along the route you want to display.

v ok~ wWwN

Right-click when you reach the end of the route, to stop drawing.
To delete a line drawing:

1. Select the line drawing but don’t click on a location point.

2. Then press the Delete key to remove the drawing.
To edit a line drawing:

1. Add a location point to a selected line by double-clicking on or in front of the head of the line.

2. Double-click after the last location point to add a new line segment to the line. Continue adding line
segments and then right-click to stop adding location points.

3. Select a line to see the location points that define the line.

4. Click and hold the left mouse button on a location point and drag the point to move it to a new
location.

5. Click a location point (turning it red) and press the Delete key (or click Ctrl+X) to remove the
point.

6. De-select all location points by clicking on the line between the location points or on an area away
from the line drawing.

7. Click a location point to toggle between a sharp corner and a smooth path at the location point.

By default the location points are linked and the line forms a smooth round path through the points.
Unlinking a location point makes a sharp corner at this position.

8. Click and drag the white points at either end of the line to change the line width.

9. Click and hold the blue point on the handle at the head of the line, while moving it horizontally to
reverse the progress of the line and retrace the original path.

You can also accomplish the same task by clicking the white point at the top corner of the bounding
box and moving it to the right or left.

Use the longitude and latitude parameters in the Location section of the Drawing Editor to relocate
the line on the map.
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To connect an icon or text drawing to a line drawing:

1. Place an icon or text drawing into the scene.

2. Move the icon or text drawing onto the head of the line, until a glowing yellow box indicates that the
drawing is in the right position to connect.

The head of the line is the end farthest from the bounding box.

A connected drawing will be positioned together with the head of the line when the progress property
of the line is changed.

The rotation angle of a connected drawing will be adjusted automatically as it moves along the line, if
the Use Spline Rotation parameter is enabled for the connected drawing.

To disconnect an icon or text drawing from a line drawing:

e Click and then drag a connected drawing away from the head of the line to disconnect the drawing.

Point Creation Mode

Use the Point Creation Mode section to select and modify which style of drawing handles you want to
use when creating line and area drawings.

The styles are:

e Locked Handles

Select the Locked Handles checkbox or press Ctrl+Alt+L to enable a 180 degree connection with
locked handle points when creating a line or area drawing.

e Free Handles

Select the Free Handles checkbox or press Ctrl+Alt+F to enable an unlimited and unlinked
connection of points when creating a line or area drawing.

¢ No Handles

Select the No Handles checkbox or press Ctrl+Alt+N to enable zero lengths of linear connection
points when creating a line or area drawing.
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Editing Locator Drawings

Locator drawings display a “map within a map” showing the position of the searched location within the
world. Typically, it is placed on the Overlay Layer, though it can also be put into the normal layer. The
center of the locator drawing points to the actual position of the camera if a Map Offset is not set in the
Drawing Editor.

The appearance of the locator drawing is defined in the Drawing Management Editor.

The area within the locator drawing can be presented by Bing Aerial, Bing Aerial Label or Bing Road
maps, as selected in the Locator section of the Drawing Editor.

To edit a locator drawing:

e Click the yellow point in the middle of the bounding box and move the mouse.
This changes the Map Offset parameters in the Drawing Editor accordingly.

For information about Map Offset parameters in locator drawings, see Locator Drawings. 114
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Editing the Background Drawing

Background drawings are images that can be used to replace the background behind the globe. XPression
Maps comes with a default background drawing behind the globe. This background is black with stars to
give the impression of outer space.

Background images are by default scaled to be fully visible inside the selected video format. Use the
same size as the video format to get a fullscreen background image. The background image will only be
visible when the Zoom Level camera parameter is such that the edges of the globe are visible.

The default background drawing can be replaced with another drawing of your choosing from the Scene
Properties menu or from the Drawing Toolbox.

To replace the background drawing from the Scene Properties dialog:

1. Select Style > Scene Properties in the menu bar.

b4 Scene Properties ? X
/foverwrite Style Properties
[)Use Alpha Channel
Drawing | default -
Mode |Fulscreen v

Scene Properties
2. Select the Overwrite Style Properties to adjust the parameters.

3. Select the Use Alpha Channel checkbox, if you want to use the alpha channel in the final output and
see a checkerboard pattern in the preview.

4. In the Scene Properties dialog, from the Drawing drop-down, select the background drawing you
want to use.

5. From the Mode drop-down, select the scaling of the drawing.
¢ Fullscreen — shows the background over the whole output window. This may distort the drawing.
o Letterbox — makes the width fit into the output window, while preserving the aspect ratio.
¢ Pillarbox— makes the height fit into the output window, while preserving the aspect ratio.

6. Close the dialog.
To replace the background drawing from the Drawing Toolbox:
1. In the Drawing Toolbox, from the Group drop-down, select the group that contains the background

drawing you want to use.

2. Left-click and drag the background drawing into the output window or select the drawing and click in
the background of the scene.

3. Release the mouse button to replace the current background.
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Editing Inset Drawings

Inset drawings like Locator drawings display a "map within a map" showing the position of the selected
location within the world. Inset drawings can be placed on the Overlay Layer or directly onto the normal
layer.

The appearance of the inset drawing is defined in the Drawing Management Editor. For information
about inset drawing properties, see Inset Drawings| 125,

To edit an inset drawing:

1. With an inset drawing added to the scene, select the green Enter Fullscreen button above the
output window.

-

Inset Drawing Fullscreen
The inset drawing is now shown in full view in the output window.
If an inset drawing has not been added to the scene the button will show as Not Active.

2. Right-click on the mouse button to drag and select a location you want to display with the inset
drawing, or open the Search Editor and type in a location.

In fullscreen mode you can add drawings, shapes and change the Map Style that is displayed with
the inset drawing.

3. After creating the inset drawing select the red Leave Fullscreen button above the output window to
return back to your main map.

Inset: | |

Inset Drawing Leave Fullscreen

The inset drawing will be displayed just as you created it in fullscreen.
To delete an inset drawing:

e With the main map in the output window, select the inset drawing and press the Delete key to delete
it.

You can also use the keyboard shortcut Ctrl+X to delete an inset drawing.
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Ordering Drawings

You may have several drawings that you want to place one on top of the other, in a scene. For example,
you could have an area drawing with a line drawing and icon drawing on top of it and a text drawing to
accompany the icon. In such a case, you would want all of the other drawings to appear on top of the
area drawing and you might want the text drawing to appear on top of the line drawing. You can use the
drawing order commands to move each drawing to the layer in which you want it to appear.

To order a drawing:

1. Select the drawing in the output window.
2. Select Edit in the menu bar and select one of the following options:

a. Move Drawing To Top - moves the selected drawing to the top-most position in the scene so
that it will appear on top of all other drawings.

You can also use the keyboard shortcut Ctrl+PgUp or click the Move Drawing To Top button in
the toolbar.
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XPression Maps Toolbar - Move Drawing To Top
b. Move Drawing Up - moves the selected drawing up one layer in the scene.

You can also use the keyboard shortcut Ctrl+Up or click the Move Drawing Up button in the
toolbar.
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XPression Maps Toolbar - Move Drawing Up
c. Move Drawing Down - moves the selected drawing down one layer in the scene.

You can also use the keyboard shortcut Ctrl+Down or click the Move Drawing Down button in
the toolbar.

ol 2h 4 =gmiy ®eFx
XPression Maps Toolbar - Move Drawing Down

d. Move Drawing to Bottom - moves the selected drawing to the bottom-most layer in the scene,
so that it will appear beneath all other drawings.

You can also use the keyboard shortcut Ctrl+PgDown or click the Move Drawing To Bottom
button in the toolbar.

Pl 2R 4 gl BesE
XPression Maps Toolbar - Move Drawing To Bottom

3. Select Save to store your changes to the scene.
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Drawing Toolbox

Use the Drawing Toolbox located to the right of the output window, to add drawings from the database
to a scene, to create a new drawing or to edit an existing drawing.

You can also designate a default drawing, which is used whenever drawings are generated automatically.
For example, you can automatically create a text drawing with the name of a country or a state when
the corresponding shape is created. In this case, the settings of the default text drawing are used for the
label text drawing. You can designate a default drawing for text, icon and dynamic data drawings.

In addition, you can specify that a text or dynamic data drawing be created exactly at the search
location.

See Drawing Management[ & for information on the setup and management of drawings.
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Drawing Toolbox

To add a drawing to the scene:

1. In the Drawing Toolbox, from the Group drop-down, select the folder containing the drawing you
want to add to a scene.

Thumbnails of the drawings contained in that group are displayed in the preview pane.

2. Left-click the thumbnail and then left-click the place in the scene where you want the drawing to
appear.

OR

Left-click and hold down the mouse button on the thumbnail and drag it to the place in the scene
where you want the drawing to appear.

3. Keep clicking in the scene to add more instances of the same drawing to the scene.
Each click adds another drawing, or in the case of a line or area drawing, another point.

4. Right-click in the scene to end the generation process.
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To replace a drawing:

1. In the Drawing Toolbox, from the Group drop-down, select the folder containing the drawing you
want to add to a scene.
Thumbnails of the drawings contained in that folder are displayed in the preview pane.

2. Left-click and hold down the mouse button on the thumbnail and drag it on top of the drawing you
want to replace.

The position, scale and entered text (if applicable) will remain the same.
To create a new drawing:

1. In the Drawing Toolbox, from the Group drop-down, select the folder to which you want to add a
new drawing.

2. Select the New Drawing thumbnail to open the Drawing Management Editor.

NEW

New Drawing

New Drawing Thumbnail

3. In the Drawing Managment Editor, in the New Drawing dialog, select the drawing type from the
drop-down and select OK.

When you select the icon or background drawing type, you will be taken to the Open Image File
dialog, from which you can select an image. If you prefer to use one of the default images, close this
dialog and select the image from the Image drop-down in the Drawing Management Editor.

4. Define the properties of the drawing as described in Managing Drawings. [

5. When you've finished defining the properties, select Done.

The new drawing is added to the list of drawings in the preview pane of the Drawing Toolbox.
To edit a drawing:
1. In the Drawing Toolbox, from the Folder drop-down, select the folder that contains the drawing

you want to edit.

2. In the preview pane, right-click on the thumbnail of the drawing you want to edit and select Edit
Drawing.

You can also access the Drawing Management Editor by clicking Edit > Manage Drawings and
then selecting the drawing from the group.
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The Drawing Management Editor opens.

BAUHAUS

Drawing Management Editor
3. Define the properties of the drawing as described in Managing Drawings.[es
4. When you've finished defining the properties, select Done.

Changing the properties of a drawing will affect all scenes using this drawing, except for those scenes
that have been exported (have a *.wnm_exp extension).

To designate a default drawing:

1. In the Drawing Toolbox, in the preview pane, right-click the thumbnail of the drawing that you
want to designate as the default drawing.
You can designate a default drawing for Text, Icon and Dynamic Data drawings.

2. From the context menu, select Set as Default [name of drawing].

The background of the default drawing will turn yellow.

Default Drawing
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To create a drawing from the Search location:

1. In the Search Editor, enter a location and select the Search button.

2. In the Drawing Toolbox, in the preview pane, right-click the thumbnail of the drawing that you
want to create at the Search location.

This feature is only available in Text and Dynamic Data drawings.

3. From the context menu, select Create Drawing From Search.
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Create Drawing From Search

The selected drawing appears at the exact coordinates of the searched location, with the
corresponding content already displayed (location name or weather data, for example).
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Flight Points

You can create a flight animation in a scene template in which the map moves from one location to
another, by adding flight points in the Flight Points editor. You can have multiple flight points in one
animation. These flight animations are not recorded in a regular scene animation.

See Adding a Flight Point[ a2l for more information on creating a flight animation in the HTML5 Client
application.

The Flight Points editor can be found in the editor stack next to the output window, as shown in the
image below.
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Flight Points Editor Tab Location
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To create a flight animation:

1. Select the Flight Points editor tab.

The Flight Points editor opens.

Flight Points Editor

2. With your map open in the output window, navigate to the location where you want the flight to
begin.

e If you want the flight point to just be in the general area, position the map so that the location is in
the center of the output window.

e If you want the flight point to be an exact location, enter the Longitude and Latitude coordinates in
the Camera Parameters fields.
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Camera Parameters - Longitude and Latitude

3. Adjust the Zoom Level, Tilt and Roll parameters, if necessary.

4. In the Flight Points pane, press New to create a flight point with the displayed camera values.

B4 Add Flight Point 7 X

Add Flight Point

5. Enter the name of the flight point and select OK.

The flight point is entered into the Flight Points pane, along with the camera parameters for the
point.

6. Navigate to the location of the next flight point and repeat steps 2 to 5.

For a scene template only, the first flight point in the list is integral. The second and any other points
will be overwritten in the web interface.
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7. Continue entering new flight points until the flight is complete.

The Flight Points editor will look something like the following image:
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Flight Points Editor - Populated
8. Click the key frame button beside the Start button to add a camera key frame at each flight point.

To view a flight simulation:
e Select Start to view the flight in the output window.
To delete a flight point:

1. In the Flight Points pane, select a flight point.

2. Press Delete.
To edit a flight point:

1. In the Flight Points pane, select the flight point you want to edit.

2. Edit the Camera Parameters, as necessary.

3. Press Update to save the new camera parameter values into the flight point.

4. Click the Wait value and enter a new time in seconds that the animation will pause at the flight point.

You can also add a pause at a flight point by inserting a bookmark at that position. See Adding a
Pause to a Flight[2«) in Editors > Bookmark Editor for instructions.
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Animation Control

In XPression Maps, select drawing parameters can be animated in the Drawing Editor. The parameters
that can be animated have a key frame button to the right of the input field.

To create or delete a key frame:

e Select the key frame button beside the parameter.
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Drawing Editor with Parameters Key Framed

¢ When the key frame button is yellow, it indicates that a key frame exists in the timeline for this
parameter.

e When the key frame button is cleared, no key frame exists in the timeline for this parameter.
To set the easing method:

1. Right-click the key frame radio button beside the parameter.

2. From the context menu, select Easing.

3. Then select one of the following easing methods:

e When easing is set to None (Q) the animation from one key frame to the next is linear, the
animation maintains the same speed from beginning to end.

e When easing is set to Out (Q) the animation from the previous key frame is linear but the
animation from this key frame to the next key frame is accelerated.

e When easing is set to In (0) the animation from the previous key frame to this one is
decelerated, but the animation to the next key frame is linear.

e When easing is set to In/Out (“) the animation from the previous key frame to this one is
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decelerated and the starting animation of this key frame is accelerated.
Timeline
The timeline is the large horizontal slider at the bottom of the application.

L L L L . S (B e B (EIEY
Timeline

To manipulate the timeline:

e Click and drag the handle of the slider to move the position of the animation within the displayed
range.
The full video animation can be viewed by playing the animation.

e Enter the frame range in the minimum and maximum value fields to the left and right of the slider.

The minimum position can not go below zero. The scale of the timeline is adjusted whenever one of
these two values is changed.

e Select the blue left and right arrow buttons (@, [Zl) next to the minimum and maximum fields to
move the current animation position one frame in the direction of the respective arrow.

e The field at the left end of the timeline displays the current position of the animation.

e Camera key frames are shown as blue rectangles (.) on the scale above and below the groove of the
timeline slider.

e Interactive Event key frames are shown as white circles (i) on the scale above the groove of the
timeline slider.

The key frames on top correspond to camera, map style, and lock camera key frames. The key frames
below correspond to all other key frames. If a drawing is selected, only the key frames of the drawing
are shown. All key frames corresponding to the lower scale are shown if there is no drawing selected.

¢ Press the Ctrl key while clicking the Left Arrow button (@) to move the current animation position to
the previous key frame position.

e Press the Ctrl key while clicking the Right Arrow button (E]) to move the current position to the next
key frame position.

e Click on a key frame to select it.
Selected camera key frames are red. Selected drawing key frames are green.

e Press the Ctrl key and click to select multiple key frames or left-click in the timeline and drag a
selection box around multiple key frames.

The selected key frames change from blue to green (drawing key frames) or red (camera key frames).

e Click and hold the cursor on a key frame and move the mouse to move the key frame to a new
location on the timeline.
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Camera Control

This section describes the parameters and control functions of the camera views.

The following topics are discussed:

Camera Selection[ el

Camera Parameters/i7ol

Camera Parameter Key Frames[73)

Easing Methods/17)

Camera Selection

In the camera selection area you can switch between five different camera views: View Camera, Work

Camera 1, Work Camera 2, Work Camera 3 and Work Camera 4. The selected camera view is
indicated by a red outline.

A @ @@

Camera Selection

View Camera displays what will be recorded. You can enable the Overlay Layer only when this camera
is selected.

The other four camera views are the working cameras. These camera views can be used to store other
views during editing. For example, if you want to extend an animation to cover a wider area than can be
seen in the View Camera, you can do that in a Work Camera. Key frames used to animate the scene
are added in the View Camera. The Camera Key Frame button is disabled when a Work Camera is
selected. Only the view in the working camera is copied to the View Camera, not objects added in the
Work Camera.

To set a specific camera view:

1. Select one of the Work Cameras.
2. Move the map to the location you want to display in that camera view.
3. Add drawings to the scene if required or extend a line animation.

The scene will be saved in the selected Work Camera and can be copied to the View Camera when
needed.

When you save the scene, any Work Camera views are saved as well.
To switch to a different camera view:
e Select the corresponding button.
To copy a camera view:

e Drag and drop one camera view button to another camera.

The destination camera becomes the active camera and has the same view as the source camera. This
is useful if you want to save the current camera view before making changes.
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To extend an animation using a Work Camera:

1. With the View Camera selected, navigate manually to the starting location you want to display on
the map or use the Search Editor to set the starting location.

2. Adjust the Zoom Level to get the view you want.

3. Add a line animation.
See Line Animation|zz) for instructions.

4. In the Drawing Editor, in the Misc section, select the Lock Camera checkbox.

This locks the camera to the line drawing, so it will follow the path of the line.

Select Work Camera 1.

Move the map to a location that is outside of the current scene, to add this location to the scene.
Extend the line animation to a point in the new part of the scene.

Select View Camera.

v © N o u

Now click the green arrow to run the animation.

You can continue adding new views for Work Cameras 2, 3, and 4 as needed.
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Camera Parameters

There are five parameters that show the actual values for the camera: Zoom Level, Longitude,
Latitude, Tilt, and Roll.
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Camera Parameters

Zoom Level

The Zoom Level parameter displays the camera distance to the earth landscape.
A new scene starts with a Zoom Level value of 0.

A higher value zooms into the map.
e >30 country level

e >70 region level

e >130 city level

e >180 street level

e 250 is the maximum zoom level. However, satellite maps tend to only appear up to a zoom level of
200.

To adjust the Zoom Level value:

e Enter a value in the Zoom field.

OR

e Click and drag the up and down arrows beside the Zoom field.

OR

e Click in the output window and move the scroll button on the mouse.

Longitude

Along with the Latitude parameter, the Longitude parameter displays the global position, in degrees,
of the location at the center of the output window.

When no drawing is selected, rotating the globe changes this parameter.
To adjust the Longitude value:

e Enter a value in the Longitude field.
OR

e Click and drag the up and down arrows beside the Longitude field.

* Animating the Longitude and Latitude parameters with easing will provide the best results when
both parameters have the same settings.
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Latitude

Along with the Longitude parameter, the Latitude parameter displays the global position, in degrees,
of the location at the center of the output window.

To adjust the Latitude value:

e Enter a value in the Latitude field.
OR

e Click and drag the up and down arrows beside the Latitude field.

* Animating the Longitude and Latitude parameters with easing will provide the best results when both
parameters have the same easing settings.

Tilt

The Tilt parameter of the camera rotates the globe around the point of the world that is closest to the
camera. The range is 0 to 85 degrees.

e At 0, the camera looks down vertically onto the map.

e >0, the camera faces the direction of the horizon, giving the map a perspective angle.
To adjust the Tilt value:

e Enter a value in the Tilt field.
OR
e Click and drag the up and down arrows beside the Tilt field.
OR
e Press and hold the Ctrl key, then right-click in the output window and move the mouse up or down.

Roll

The Roll parameter spins the globe clockwise and counter-clockwise along the axis visible in the output
window. For example, turning the globe upside down so that the north pole is at the bottom. The range is
0 to 360 degrees.

To adjust the Roll value:

e Enter a value in the Roll field.
OR

e Click and drag the up and down arrows beside the Roll field.
OR

e Press and hold the Ctrl key, then left-click in the output window and move the mouse left or right.
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Pause Dur.

The Pause Dur. parameter pauses the animation for the number of frames entered.

To add a pause:

1. Move the timeline slider to the point in the animation where you want to pause.

2. In the Pause Dur. field, enter the number of frames for which you want the pause to last (applies to
an animation recordings or to touch projects).

OR

Enter 0 if you want to continue the animation by touching an interactive button on the screen (applies
to Touch Projects only).

3. Then click the key frame button beside the field to add a camera key frame at this point.
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Camera Parameter Key Frames

You can select an easing method to control how the animation behaves as it approaches and leaves the
key frame.

To create or delete a key frame:

e Click the key frame button beside the parameter.
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Camera Parameters with Zoom Level Key Framed

¢ When the key frame button is yellow, it indicates that a key frame exists in the timeline for this
parameter.

¢ When the key frame button is cleared, no key frame exists in the timeline for this parameter.
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Easing Methods

You can select an Easing Method to control how the animation behaves as it approaches and leaves the
key frame.

To set the easing method:

1. Right-click the key frame radio button beside the parameter.

2. From the context menu, select Easing.

ZoomLevel:| 195 | % Lomsitudad a7 2200l 20 i 45,0000 (5] Q)

Key F
£y Frame ol 0 noon |21y
o Easing i[&]None
: —, N
|07 € | ofe 10 35 | @ Out
— S Mool oonolonnnlonnola
© In
& In/Out
@ Automatic

Camera Parameters Key Frame Easing Selection

3. Then select one of the following easing methods:

e When easing is set to None (O) the animation from one key frame to the next is linear, the
animation maintains the same speed from beginning to end.

e When easing is set to Out (Q) the animation from the previous key frame is linear but the
animation from this key frame to the next key frame is accelerated.

e When easing is set to In (o) the animation from the previous key frame to this one is
decelerated, but the animation to the next key frame is linear.

e When easing is set to In/Out (Q) the animation from the previous key frame to this one is
decelerated and the starting animation of this key frame is accelerated.

¢ When easing is set to Automatic (*'-"]) the default setting and simulates a flight between key
frames. The animation zooms out from the starting key frame, moves to the next key frame and
zooms back in. When using this method, it is best to set key frames for each of the 5 camera
parameters at the same timeline positions. It is necessary to at least have key frames on the
Zoom level.

* All parameters must have the same easing method. When you select an easing method for one
parameter, the rest will automatically change to the same one.
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Safe Title / Safe Area

The Safe Title settings allow you to configure the position of the safe area, map attribution and logo in

the output window.

The Safe Area is the area inside the output window defined by the white rectangles. Keep all your
drawings and information inside this area for full visibility on air.
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Safe Title / Safe Area
To configure the Safe Title / Safe Area:

1. Select the Settings icon beside the Safe Title drop-down.

The Safe Title Management Editor opens.

b safe Title Management Editor ? X
Full Screen Name
oTs
e ‘Full Screen ‘
V| Image
| saveArea_001 * ]
— Action Safe
Left: |s.00% |+| Right: |5.00% |+
Lower: |5.00% || upper: [5.00% |+

TiteSafe: | 5.00% =/

Posion  X: [90.00% [=|  ¥:|0.01% [2]
[~ Bing Logo
Posion  X: | 10.00% [=|  ¥:|10.00% [2]
New Delete |

Safe Title Management Editor
2. Select New to set up a new configuration.

The default configuration is called Full Screen.
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3. In the Name field, enter a name for the new configuration.
4. Select the Image checkbox to choose a saved background image from the Image drop down.

5. In the Action Safe section, use the arrows or enter a value in the Left, Right, Lower and Upper
fields to adjust the size of the outer rectangle (the red rectangle in the image below).

Zoomevel|0 |2 @ Longitude:| -87.7205[2| & Tit:{0.0000 || & PawseDur: 0 |5| O SafeTite: |Fullsoeen  ~ | 13| (overay.
Latudes| 25 |2| Rk o000 2] 3 saferreas o

Safe Title / Safe Area Outer and Inner Rectangles

Entering values of 0.00 in all these fields will make the entire output window a safe area.

5. In the Title Safe field, use the arrows or enter a value to adjust the size of the inner rectangle (the
yellow rectangle in the image above).

The Bing logo and attribution text can only be positioned within the inner rectangle (the Title Safe
area).

6. In the Attribution section, use the arrows or enter values in the Position X and Y fields to adjust
the location of the attribution text within the inner rectangle.

You can also left-click and drag the attribution in the Output Window (while the Safe Title
Management Editor is open) to position it.

7. In the Bing Logo section, use the arrows or enter values in the Position X and Y fields to adjust the
location of the Bing logo within the the inner rectangle.

You can also left-click and drag the Bing logo in the Output Window (while the Safe Title
Management Editor is open) to position it.

8. When you have the configuration you want, click Done to save it.

You can create as many different Safe Title / Safe Area configurations as you need.
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Overlay Layer

The overlay layer is an editing area independent of the camera view. Drawings placed in the overlay
layer will not move together with the underlying map; they will stay on an invisible layer front of the
camera. Drawings on the overlay layer can be animated the same way as all other drawings. The
overlay layer is useful for placing logos or text that you want to keep in the same spot regardless of the
movement of the map or drawings.

To use the Overlay layer:

1. Select the Overlay checkbox next to the camera view buttons.
A transparent gray overlay indicates that the overlay layer is activated.
2. Place your drawings on the map.

Drawings placed on the Overlay Layer are fixed in place and can only be selected and edited or
deleted when the Overlay Layer is activated.

In the example below, the title text U.S. ELECTION 2020 is placed on the Overlay Layer and
remains stationary while the scene animation is played.

T, o TR

© 2019 Micrasaft Corp:

! orporatiol
,f Earthstar Geographiggy0”_© 2019 He

a (U”A‘

Overlay Layer

3. Deselect the Overlay checkbox to return to your main layer and play your animation.

XPression Maps User Guide (v3.4) Creating Scenes « 177



Saving a Scene

Saving a scene will store all information about the scene including camera flights and drawings with
references to the drawings in the database. Saved files have the extension *.wnm.

Scenes can be opened in XPression Maps where they were created. Saved scenes use the references to
the drawing database to create the drawings. Changes made to the drawings in the database will affect

any scene that uses those drawings, unless the scene has been exported.

See Exporting a Scenel7) for more information.

If Compact Scene on Save is selected in Preferences > Output, all unused styles in the map style

list and in the shape style list are removed.

To save a hew scene:

1. Select File > Save in the menu bar or click the Save button in the toolbar.

XPression Maps Toolbar - Save

The file browser opens.

| ] Chicago Cub w._ade Route.wnm
'] ConventionCenterwnm

|| Crimea Joins Russia_new.wnm
j Ecuador Earth Quake Altwnm
j Ecuador Earth Quake.wnm

j Election Example.wnm

|| Flight MH370_new.wnm

'] Irenmen.70.3.wnm

|| Las Vegas Regional.wnm

|| Mudslide in Oso Wash_new.wnm
|| Natonslratsw __2002_NEW.wnm
j Paris Bombings.wnm

j StyleExamplesEurope_New.wnm
|| Weather Maps E..iddle East.wnm
|| WeatherUS_NAB16.wnm

12KB wn_le
5KB wn_le
31 KB wn..le
TKB wn..le
TKB wn..le
296 KB wn..le
24 KB wn..le
128 KB wn..le
4KB wn._le
21 KB wn..le
2TKB wn_.le
30KB wn..le
18 KB wn..le
9KB wn..le
13 KB wn..le

Animated Map Dema.wnm

Save File

2. Select a folder or destination where the scene is to be saved.
The default location is C:\XPressionMaps_3.0\Scene.

3. In the File name field, enter a name for the scene.

4. Select Save.

To save an existing scene with a new name:

1. Select File > Save As in the menu bar or click the Save button in the toolbar.

XPression Maps Toolbar - Save

2. In the Save As window, in the File name field, enter a new name for the scene and select Save.
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Exporting a Scene

Exporting a scene saves a scene along with all of the drawings used in the scene. This way a scene can
be opened in any XPression Maps application and changes to drawings in the database do not affect the
exported scene.

After opening an exported scene, drawings saved in the scene are shown in the Drawing Toolbox, in
the Imported Scene Drawings section, from where they can be used again in the scene. Exported files
have the extension .wnm_exp. When the scene is edited and saved again it is automatically saved as
an exported file.

* Compact Scene on save is selected in Preferences > Outputl 9", All unused styles in the map style
list and in the shape style list are removed.

To export a scene:

1. Select File > Export in the menu bar.

The file browser opens.
2. Select a folder or destination where the scene is to be exported.
3. Select Save.

The file browser closes and the scene is exported to the selected location, with the extension
.wnm_exp.

* Export the scene for use in different XPression Maps applications and for archiving a scene. This
ensures that changes in the drawing database will not affect the scene.

To open an exported scene:

1. Select File > Open.

2. In the file browser, from the File Type drop-down, select XPression Maps export files
(*.wnm_exp).

The browser will be populated with a list of exported files.

3. From the list of files, select the exported file you want and select Open.
To use imported scene drawings:

1. Open an exported scene.

2. In the Drawing Toolbox in the Imported Scene Drawings section, click on a drawing and then
click on the scene in the output window to add the drawing to the scene.

The Imported Scene Drawings section is hidden, unless there is an exported scene open in the
output window.

XPression Maps User Guide (v3.4) Creating Scenes « 179



Using Dataling

After adding Dataling Servers in File >Preferences > Output[ o9, you can add data sources and configure
how data is displayed in the DataLinq Setup screen.

* To use Dataling for Access data sources, you will need to download and install the Microsoft Access
Database Engine Redistributable (AccessDatabaseEngine.exe) from the Microsoft website.

To add a new data source:

1. Select Edit > DataLinq Setup.

The DatalLinq Setup window opens.

B nssting Sovp

Datalinq Setup Window
2. Select Add New.

The New Data Source window opens.

i New Data Source X

New Data Source

3. In the Name field, enter a source name for the new data source.
4. From the Type drop-down, select a DataLinq Type.

The types are:

DataLinq Shape .

DatalLinq Drawing Db

DatalLing Container Drawing D#

The data source is added to the Datalinq Setup window.

For information on linking data sources and data servers, see Linking Data Sources/+sf.
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Linking Data Sources

For information on linking the correct data source with the Dataling Server select the data type below:
DatalLing Shape|1_aﬁ

DatalLing Drawing@

DataLing Container Drawing[+ss!

Dataling Shape

The following procedure details how to link the Dataling Source to the DataLing Server for the DataLinq
Shape type.

See Data (Optional)[ 191 for information on adding DataLinq Servers.
To link the data source with the DatalLinq Server:

1. From the menu bar select Edit > DataLinq Setup.
2. From the left panel of the DataLinq Setup window, select the data source you want to use.
3. Select the DatalLinq Server from the drop-down menu connected to the data source.

A green icon indicates the Dataling Server connection has been established. A red icon indicates the
DatalLing Server is not connected or is unavailable.

[ Dataling Setup

Dataling Setup Window - DatalLing Server
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4. 1In the Data tab, select the Source from the drop-down.

X These sources are brought in directly from the DataLinq Server. See the XPression User Guide
for information on installing and using the DataLinq Server.

i XPression Dataling Server [port: 8888] - v11.0 build 5650 - O X

File Windows

XPression Dataling Server

5. In the Data tab, select the correct table of data to be shown in the Table drop-down. In instances
where there is more than one sheet of data being imported there will be multiple tables to view.

If only one sheet of data is imported the Table field will read Default.

The data imported from the DataLinq Server Source will populate in the preview screen.

W Dataling Setup

Imported Data from the Dataling Server Source

X For information on configuring the DatalLing Shape Parameters for both Direct Value and
Value Lookup modes see Configuring DatalLing Shapes| 192

182 + Using Datal.inq XPression Maps User Guide (v3.4)



DataLing Drawing

The following procedure details how to link the Dataling Source to the DataLinqg Server for the DataLinq
Drawing type.

See Data (Optional)[ 191 for information on adding DataLinq Servers.
To link the data source with the DatalLinq Server:

1. From the menu bar select Edit > DatalLinq Setup.
2. From the left panel of the DataLinq Setup window, select the data source you want to use.
3. Select the DatalLinq Server from the drop-down menu connected to the data source.

A green icon indicates the Dataling Server connection has been established. A red icon indicates the
DatalLing Server is not connected or is unavailable.

W Dataling Setup

9 2021 Fed Election Results

Votes.

1912651

111318

1117051

279174

25134

Dataling Setup Window - DatalLing Server

4. In the Data tab, from the Source drop-down, select the name of your Dataling source.

X These sources are brought in directly from the DataLinq Server. See the XPression User Guide
for information on installing and using the DatalLinq Server.

il XPression Dataling Server [port: 8888] - v11.0 build 5650 - O X

File Windows

XPression Dataling Server
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5. In the Data tab, select the correct table of data to be shown in the Table drop-down. In instances
where there is more than one sheet of data being imported there will be multiple tables to view.

If only one sheet of data is imported the Table field will read Default.

The data imported from the DataLinq Server Source will populate in the preview screen.

| Dataling Setup

Votes

1912651

11318

117051

279174

25134

Imported Data from the Dataling Server Source

X For information on configuring the DatalLing Drawing Parameters for both Direct Value and
Value Lookup modes see DatalLing Drawing Parameters.
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DataLing Container Drawing

The following procedure describes how to link the Dataling Source to the DatalLing Server for the
DataLinq Container Drawing type.

See Data (Optional)[ 191 for information on adding DataLinq Servers.
To connect the data source with the DatalLinq Server:

1. From the menu bar select Edit > DatalLinq Setup.
2. From the left panel of the DataLinq Setup window, select the data source you want to use.
3. From the DataLinqg Server drop-down select the name of the server connected to the data source.

A green icon indicates the Dataling Server connection has been established. A red icon indicates the
DatalLing Server is not connected or is unavailable.

[ Dataling Setup

Datalinq Setup Window - DatalLinqg Server

4. In the Data tab, from the Source drop-down, select the source.

X These sources are brought in directly from the DataLinq Server. See the XPression User Guide
for information on installing and using the DataLinq Server.

i XPression Dataling Server [port: 8888] - v11.0 build 5650 - O X

File Windows

XPression Dataling Server
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5. In the Data tab, select the correct table of data to be shown in the Table drop-down. In instances
where there is more than one sheet of data in the source there will be multiple tables to view.

If only one sheet of data exists in the source, the Table field will read Default.
The data imported from the DataLinq Server Source will populate in the preview screen.

The preview screen will generate either a table as shown in both DataLinq Shape and DatalLinq
Drawings, or a tree sheet which will list collapsible rows. This will depend on the style of data being

imported from the DataLing Server.

[l Dataling Setup

Dataling Setup Container Drawing - Table View

[ Dataling Setup

Pttty
FIEETEEE §F

Dataling Setup Container Drawing - Tree View

X For information on configuring the Dataling parameters for both tree and table views see
Configuring Configuring DataLing Container Drawings/1s\.
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DataLing Drawing Parameters

In the Dataling Setup window there are different configuration options for DatalLinq Drawings, DataLing
Shapes and Dataling Container Drawings.

For information on adding DataLinq Servers and Sources see Dataling Setupl s,
The following topics are discussed in this section:

Configuring Dataling Drawings|1_s7'ﬁ

Configuring DataLing Shapes| )

Configuring DatalLing Container Drawingsh_e:ﬁ
Configuring DatalLing Drawings

In the DataLinq Setup window there are two modes that can be used to configure DatalLinqg
Drawings:

o Direct Value - Direct Value refers to information directly selected from within the DataLing Data and
they are used as Direct Parameters for displaying that data in the output window.

e Value Lookup — Value Lookup refers to a range of different parameters that can be selected from
within the DatalLing Source data and displayed in the output window.

* If you reconfigure your data source after adding it to the DataLinq Setup window, you may have to
quit and relaunch XPression Maps in order to see the updated table.

To configure the DatalLinq Data with Direct Value Mode:

1. From the menu bar select Edit > DatalLinq Setup and from the left column, select your Dataling
source.

2. In the Data tab, from the Mode drop-down select Direct Value.

The Data No:. field indicates the number of data values being shown on the map with the DatalLing
data.

Select Add to add a new Dataling data value.
Select Del to delete a DatalLing data value.

2. In the Data table, select the column and/or row with the information you want to use as the direct
value parameter.
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3. Right-click and select Use as Direct Parameter.

Votes

1912651

111318

1117051

279174

25134

Direct Parameter Selection

The Direct section on the right of the Data table will display the Column or Row you have
indicated.

Data Tab - Direct Section
4. In the Result section, adjust the parameters for the following:

a. In the Value drop-down, select the Value for the DatalLing data to be displayed. The options
depend on the type of data source.

b. In the Default field, enter the value that you want to display when the value returned is "none".
For example, in election data, if there is no result yet, the default value could be 0.

c. Inthe Prepend field, enter the path to an image file that will be used in place of the actual result,
e.g., an image of a flag to represent a country or state.

d. Inthe Append field, enter the name of the image file that will be used in place of the actual
result, e.g., country.jpg.
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5. In the Test section leave the Result field blank and select Test.

The Result field will generate the direct value parameter you have indicated from within the data

table.

6. Select Save and close the DataLinq Setup window.

To view the Datalinq configurations in the output window:

1. In the Shape Editor select all of the shapes you want to display with the DataLing configurations.

Press Shift+Right click on the mouse button to select more than one shape.

2. In the Dataling tab, select the corresponding DataLinq Source from the drop-down and select the

Source checkbox.

The map in the output window reflects the configurations made in the DataLinq Setup window.

To configure DatalLinq Data with Value Lookup Mode:

1. In the Data tab, in the Mode drop-down select Value Lookup.

The Data No:. field indicates the nhumber of data values being shown on the map with the DatalLing

Data.

Select Add to add a new DatalLing Data value.

Select Del to delete a DataLing Data value.

2. In the Data table, select a column containing the data you want to use as the Value Lookup.

3. Right-click on the mouse button and select Use as Lookup Column.

Data |

<

Source: | Provincal Blection Resuits ~J Mode: |Vaelookp v | DatalNo: |1 ]2|[ Add || pel |
Table: [Defat v
1 2 3 4 5 |/ Lookup

Party Us-e o Lt;okup Colu "’m - Total Votes Column: B v
Progressive { Use as Result Column 83 1912651 Value: |DrawingName  ~
New Democrat 3 0 Ell 111318 - Result
Liberal 2 0 8 1117051 Colmn: |2 ~
Green 1 0 1 279174 Value: |Drawing Longitude ~ |
Independent 1 0 1 25134 Default

Prepend:

Append:

[ Test
Value:
Result

Test

Value Lookup Column
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The Lookup section on the right of the Data table will display the Column you indicated as the
Value Lookup column.

Data Tab - Lookup Column
4. From the Value drop-down, select the value you want to be displayed on the map, the options are:
Drawing Name
Drawing Longitude
Drawing Latitude
Drawing Text
5. In the Data table, select the column containing the data you want to use as the Result Column.

6. Right-click on the mouse button and select Use as Result Column.

RLRREIE]

17051

Result Column

The Result section on the right of the Data table will display the Column you indicated as the Result
Column.

Data Tab - Result Section
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7. In the Result section adjust the parameters for the following:

a. From the Value drop-down, select the value you want to be displayed on the map, the options
are:

Drawing Longitude
Drawing Latitude
Drawing Visibility
Drawing Color
Drawing Text

b. In the Default field, enter the name of the value chosen in the previous step, e.g., the name of
the color you want to use.

c. In the Prepend field, enter the path to an image file, if you want to use an image in the result or
leave it blank if you just want the value chosen in the Value drop-down.

d. In the Append field, enter the image name, if you want to use an image in the result or leave it
blank if you just want the value chosen in the Value drop-down.

8. In the Test section, in the Value field, enter the Lookup Value you want to be displayed on the
map.

Leave the Result field empty.
9. Select Test.
The Result field will generate the Lookup Value you have indicated from within the data table.

10. Select Save and close the DataLinq Setup window.
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Configuring Dataling Shapes

Use the Dataling Shapes data source to display location-based results, that can be visually represented
without text, such as election winners and losers.

* If you reconfigure your data source, you may have to exit and relaunch XPression Maps in order to
view the updated data.

First you will need to create a map with the shapes you want to use and name the shapes to match the

data in your data source.

To create a map for use with DataLinq Shapes:

1. In the Search Editor, in the Location field, enter the name of the country, state/province or city in
which you want to use DatalLinq data.

2. In the Search Related Shapes list, double-click the location you want.

3. In the Shape Editor, right-click the shape and select Load Children if you require the shapes of
states/provinces or counties as well.

4. Select the first shape and then press the Shift key and select the last shape to select all shapes at
once.

5. From the Style drop-down, select the initial shape style you want to use.

6. Then create or select alternate shape styles that will appear when the corresponding data is selected
from the data table and name them to match the data.

For example, you could have a shape style named "Default State Color" as your initial shape style
and 2 alternate shape styles, named "Democrat" and "Republican", with the appropriate color.

7. Continue with Configuring DataLing Datal1e).
Configuring DataLing Data

In the DatalLinq Setup window for DataLinq Shapes, there are two modes that can be used to
configure the data:

e Direct Value — one data item selected from the Datalinq data.

e Value Lookup — multiple data items selected from the Dataling Source Data.
See the following sections for information on using each mode:

To configure DataLing data with Direct Value Mode[192)

To configure DataLing data with Value Lookup Model[ 19}

To configure DataLinq Data with Direct Value Mode:

1. From the menu bar select Edit > DatalLinq Setup and from the left column, select your DatalLing
source.
2. In the Data tab, in the Mode drop-down select Direct Value.

The Data No:. field indicates the number of data values being shown on the map with the Dataling
Data.

» Select Add to add a new DatalLing Data value.
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> Select Del to delete a DataLing Data value.
2. In the Data table, right-click in the column and row containing the data you want to see in your map
and select Use as Direct Parameter.

Note: The first row is "0".

Direct Parameter Selection
The Direct section on the right of the Data tab will display the data you have indicated as the Direct

Value Mode.

Data Tab - Direct Section
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4. In the Result section, in the Value drop-down, select the value for the DatalLing Data to be

6.

displayed. The options are:
Shape Color

Shape Outline Color
Shape Style Name
Shape Extrude

Shape Visibility

In the Default field, enter the value that should be displayed if there are no results, e.g., if a winner
has not yet been selected in an election, you might want to display "Undecided".

In the Prepend field, enter the path to an image file, if you want to use an image in the result or
leave it blank if you just want the value chosen in the Value drop-down.

In the Append field, enter the image name, if you want to use an image in the result or leave it
blank if you just want the value chosen in the Value drop-down.

In the Test section leave the Result field blank and select Test.

The Result field will generate the direct value parameter you have indicated from within the data
table.

Select Save and close the DataLinq Setup window.

To configure DatalLinq data with Value Lookup Mode:

In the Data tab, in the Mode drop-down select Value Lookup.

The Data No:. field indicates the humber of data values being shown on the map with the DataLing
Data.

Select Add to add a new DatalLing data value.
Select Del to delete a DatalLing data value.

In the Data table, right-click anywhere in the column you want to use to look up data from and select
Use as Lookup Column.

Data Type: | Datating (shape) ]

Pamas |15 Blection Resits

Dataling Server: | ® Locahast [+

| Data

Source: LIS Eection Resuts - Mode: | value Lockup -| Data Ho.x |:. | acs || ow |
Table: | “z0z08 = Enabled: e

| State_Mame State Abbr GEQID First Mame_]  Last = [ Lockup
Alabarna AL 2 Denald Tump Cobmn: | Stabe_Name - |
|.ﬂ|a§l=a Vomr s e lEs ) Denald Trump ek |shepetiame = |
..Iirimnu Usz 25 Rezult Calumn | .Jue Biden Result
J— P 5 | onae .Tlump Cobm: | Party_1 -
Califamia s & Joe Biden Vabizt Shape Style Name: )

Value Lookup Column
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The column you select must correspond to one of the fields indicated in the Shape Editor >
Information section. Your data source may have data that doesn't appear in the Information

section and can't be used in XPression Maps, but could be used in XPression.

3. From the Value drop-down, select the value to be displayed on the map.

The options will correspond to the column headings in your data source.

The Lookup section on the right of the Data table will display the column and value selected.

Data Tab - Lookup Column

4. In the Data table, right-click in the column containing the data you want to see in your map and
select Use as Result Column.

LIS Elaction Results

@ Locshost
Dansld amp Use a5 Lockup Colurmn
Donald Tamp Republ
Joe Biden Democrat 1672143 049
Donald Tump. Republican Te0EAT 062
Jae Biden Democrat 11700250 063

Result Column
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5. In the Result section to the right of the Data table, from the Value drop-down, select the data you
want to see in your map.

The options are:

Shape Color

Shape Outline Color
Shape Style Name
Shape Extrude

Shape Visibility

Shape Opacity

Shape Use Media
Shape Media File Name

The option you select needs to correspond with data that can be found in the data source. In the
example here, the column chosen as the Result Column contains the Shape Style Names
"Democrat" and "Republican", so you would use the Shape Style Name for the value.

The Result section to the right of the Data table will display the selected Column and Value.

—Result
comn: | |Party_1 -
vaue: | |shape Stylename
Default | |
prepend: ||
append: ||

Data Tab - Result Section
6. Also, in the Result section, configure the following parameters if needed:

In the Default field, enter a value that will be displayed if there are no results for the selected
Result Column and Value, e.g., Default State Color (to show the color of the state shape before
the winning party is determined.

In the Prepend field, you can enter something that differentiates one shape from another. For
example, if you added shapes called "County Democrat" and "County Republican" and you
wanted to display the county results, you could enter the word "County".

Similarly, in the Append field, if you had additional shape styles called "Democrat Highlight" and
"Republican Highlight", and you wanted to display the highlighted shape styles, you could enter
the word "Highlight".

7. In the Test section, in the Value field, enter the Lookup Value you want to be displayed on the
map.

8. Leave the Result field empty.
9. Select Test.
The Result field will generate the Lookup Value you have indicated from within the data table.

10. Select Save and close the DataLinq Setup window.
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To view the Datalinq configurations in the output window:

1. In the Shape Editor select the shapes you want to display with the DataLing configurations.
Press Shift and left-click on the first and last shapes in the list to select all shapes at once.

2. Expand the Dataling section, select the corresponding DataLinq Source from the drop-down and
select the Source checkbox.

'United States Election
US Election Results

Shape Editor - Dataling

The map in the output window reflects the configurations made in the DataLinq Setup window.
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Configuring DataLing Container Drawings

In the DatalLinq Setup window there are two methods of configuring the Source data for DatalLinq
Container Drawings:

e Method One: Treeltsd

If the Dataling data imported from the DataLinq Server has multiple ranges of expandable
information, the data will be displayed as a collapsible tree list with each data source containing
different units of measure.

e Method Two: Table[202)

If the Dataling data imported from the DataLinq Server has one range of data from an information
data set, the data will be displayed as a table. The data source needs to include Longitude and
Latitude values to be compatible with Dataling container drawings.

* If you reconfigure your data source after adding it to the Dataling Setup window, you may have to
quit and relaunch XPression Maps in order to see the updated table.
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Using a Tree Data Source

Use a tree data source when you want to be able to display multiple values in your map.

* If you reconfigure your data source after adding it to the DatalLing Setup window, you may have to

quit and relaunch XPression Maps in order to see the updated table.

To configure the DataLing Container Drawing data from a tree:

1. From the menu bar select Edit > DatalLinq Setup to open the DataLinq Setup window.

2. In the Data tab, from the Source drop-down, select the source data.

3. In the Data table, select a row, right-click and select Use as Row Index.

The selected row will be added in the Row Index field in the Drawing Creation section.

* A Row Index can only be selected from the top level (Name) column. The Value column
represents the remaining parameters.

Name

Value

v [’:‘T 1 Use as Row Index

'S

#- Longitude
+- Angle
#+- Size

v 4 Data
4+ Latitude
4+ Longitude
#~ Angle
+ Size

¥ % Data
+- Latitude
4+ Longitude
4 Angle
#+- Size

¥ & Data
+- Latitude
4 Longitude
+ Angle
+- Size

¥ % Data
+- Latitude
#+ Longitude
4 Angle
+- Size

-75.9093
0.0
1.0

45.5820
-76.7093
0.0

1.0

45.4820
-76.5093
0.0

1.0

45.3820
-76.3093
00

1.0

45.2820
-76.1093
00

1.0

I RowIndex:  |Data

Longitude: |
Latitude: |
Drawing Name: ‘

Drawing Default: |

Row Index (Sibling Nodes holding the parameter)

Longitude (WGS84, -180.0 - 180.0)
Latitude (WGS84, -90.0 - 90.0)

Size (0.0-10.0, Default = 1.0)

Angle (-360.0 - 360.0, 0.0 = North)

Selecting a Row Index

4. Continue to select the following Index Nodes from the Value column, right-clicking to select each:

Longitude
Latitude

Drawing Name

If the data source doesn't have a Drawing Name value, in the Drawing Default field, enter the

name of the text drawing you will be using to configure the data output.

Text

If you select a Text Drawing tool as an Index Node, you must input the Text tool in the Text
Default field. For example, if you choose a Callout Marker you must identify that as your Text

Default for the result to display in the output window.

Size

Angle
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 Drawing Color

5. Select Save and close the DataLing Setup window.
To add a Container drawing:

1. In the Drawing Toolbox select New Drawing.
2. In the New Drawing dialog, from the Select Drawing Type drop-down, select Container.

The Container Drawing properties sheet opens.

¥ Drawing Management Editar *

New Container Drawing Properties

3. In the Name field, enter the name for the container drawing and select Done.

X The container drawing name must match the data source being configured in the DataLinq Setup
window.

4. Place the new container drawing anywhere in the output window.

X The container drawing acts as a holder for the Dataling data as previously setup in the DataLinq
Setup window. The container drawings placement on the map is not important. The image of the
container drawing will not be shown in the final render.

To configure a text drawing to display the data:

1. From the menu bar select Edit > Manage Drawings.
2. In the Drawing Management Editor, from the Name drop-down, select Text.
3. From the list of text drawings, select the drawing you want to use to display the data in your map.

4. Inthe Drawing panel, in the Name field, enter the name that appears in the Drawing column of
your data source.

If there is no Drawing Name value in your data source, enter any name and in the DataLinq Setup
window, enter the same name in the Drawing Default field.

5. Then select a group in which to save the newly named text drawing and select Duplicate.
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6. If you want to change any of the properties in the text drawing, you can do so now or you can select
the text drawing in the Drawing Toolbox later and edit the properties.

7. Select Done to close the Drawing Management Editor.

To display the source data on the map:

1. In the Search editor, in the Location / Address, City, Country field, enter the location you want
to display on your map.

2. Select the container drawing you added to the map.

3. In the Drawing Editor, expand the DataLinq parameter and from the Source drop-down, select
the data source you are using.

Drawing Editor - DatalLing

4. Select the Source checkbox to view the data in the output window.
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Using a Table Data Source

Use a table data source when you want to display text in specific locations on the map. You can only
display one value type. If you need to display more than one value, use a tree data source instead. See
Using a Tree Data Sourcel 19 for more information. There may be data in your data source that cannot
be used in a DataLling Container drawing.

* If you reconfigure your data source after adding it to the DataLing Setup window, you may have to
quit and relaunch XPression Maps in order to see the updated table.

To configure the DatalLinq Container Drawing Data from a table:

1. From the menu bar select Edit > Datalinq Setup to open the DataLinq Setup window.
2. In the Data tab, from the Source drop-down, select the source data.

3. From the Table drop-down select the sheet that you want to use.

X The Table drop-down will only generate multiple options if the data source has multiple sheets of
information, for example, an Excel spreadsheet with more than one sheet.

4. In the Data table, do the following:
¢ Right-click in the Longitude column and select Use Column as Longitude Parameter.
e Right-click in the Latitude column and select Use Column as Latitude Parameter.

e If the data source has a Drawing column, right-click in the Drawing column and select Use
Column as Drawing Name Parameter.

> If the data source doesn't have a Drawing column, in the Drawing Default field, enter the
name of the text drawing you will be using to configure the data output.

e Right-click in the column containing the data you want to display in your map and select Use
Column as Text Parameter.

¢ In the Text Default field, enter a value to be displayed if there is no value found in the column
selected in the Text drop-down. For example, in election data, if there are no results yet for a
particular polling station or state, you might want the value shown to be O.

¢ Right-click in the Scale column (if one exists) and select Use Column as Scale.
The values in the Scale column affect the size of the text drawing.

e Right-click in the Angle column (if one exists) and select Use Column as Angle.
The values in the Angle column affect the angle of the text drawing.

e Right-click in the Color column (if one exists) and select Use Column as Color.

The values in the Color column affect the color of the text in the text drawing.
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Select Drawing Creation Parameters

5. Select Save and close the DataLinq Setup window.

To add a Container drawing:

1. In the Drawing Toolbox select New Drawing.

2. In the New Drawing dialog, from the Select Drawing Type drop-down, select Container.

The Container Drawing properties sheet opens.

¥ Drawing Management Editor

New Container Drawing Properties
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3. In the Name field, enter a name for the container drawing and select Done.

X The container drawing name must match the data source being configured in the DataLinq Setup
window.

4. Place the new container drawing anywhere in the output window.

X The container drawing acts as a holder for the Dataling data as previously setup in the DatalLinq
Setup window. The container drawings placement on the map is not important. The image of the
container drawing will not be shown in the final render.

To configure a text drawing to display the data:

1. From the menu bar select Edit > Manage Drawings.
In the Drawing Management Editor, from the Name drop-down, select Text.

From the list of text drawings, select the drawing you want to use to display the data in your map.

H LN

In the Drawing panel, in the Name field, enter the name that appears in the Drawing column of
your data source.

If there is no Drawing Name value in your data source, enter any name and in the DatalLinq Setup
window, enter the same name in the Drawing Default field.

5. Then select a group in which to save the newly named text drawing and select Duplicate.

6. If you want to change any of the properties in the text drawing, you can do so now or you can select
the text drawing in the Drawing Toolbox later and edit the properties.

7. Select Done to close the Drawing Management Editor.

To display the source data on the map:

1. In the Search editor, in the Location / Address, City, Country field, enter the location you want
to display on your map.

2. Select the container drawing you added to the map.

3. In the Drawing Editor, expand the DataLinq parameter and from the Source drop-down, select
the data source you are using.

» Misc
b Effect
~ Dataling
Source: ]| o Sightings. Rl
= MFL

b Specif Do

e D#* Locations

De* Sightings

Drawing Editor - Dataling

4. Select the Source checkbox to view the data in the output window.
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Editors

A group of editors located on either side of the output window allows you to create and edit shapes and
drawings used in your maps, search for locations and shapes, create bookmarks for frequently used
locations and customize your OpenStreetMap scenes.

The editors can be docked to the left or right of the output window, using the docking icon in the
top-right corner of the editors.

See the following topics for further information:
Shape Editor|208)

Drawing Editor [223)

Search Editor[z5

Bookmark Editor [242

OSM (OpenStreetMap) Style Editor 24
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Shape Editor

XPression Maps comes with a library of national and interstate borders from around the world, allowing
you to integrate political information quickly and easily. You can fill in one or more countries, states or

regions with color for greater emphasis and apply map colors and outlines to your own layouts. You can
also add, edit and delete predefined or custom shapes.

Use the Shape Editor, shown below, to modify the parameters of the shapes. The Shape Editor
displays a list of all the shapes that have been added to the current scene.
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Shape Editor Location

The following topics are discussed in this section:
Adding and Deleting Shapes| zo7)

Editing Shapes| 208!

Relocating Shapes(z:3)

Shape Styles[2s)

Shape Style Properties| 21!
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In the upper portion of the Shape Editor there is a list of the shapes in the current scene.

layer and the order of the list corresponds to the order of the layers, where the first line is the back (or
bottom) layer and the last line is the front (or top) layer. The shapes shown in the list appear in the
scene in the output window as shown in the following diagram.

You can rearrange the list by dragging and dropping shapes from one position to another, however
children shapes can not be rearranged.

Alberta

British Columbia

CIBCIL ICIRCIENP

Illustration of Shapes in a Scene

orim |

Adding and Deleting Shapes

In order to add a shape to the scene, you have to first find and select the shape in the Search Editor.

To add a shape:

1. In the Search Editor, in the Filter section, select the checkbox for Country, States and/or Region
depending on the location for which you are searching.

2. In the Location field, enter the location you want to display in the scene and select Search.

For more accurate results, be specific about the location you want to search. Enter the region,

province/state and country in the Location field, separated by commas, as in the example shown
below:

Ottawa, Ontario, Canada

3. Then, in the Search Related Shapes list, double-click the shape you want to add to the scene.
The default shape style is automatically applied to the shape, Country Default for a country, State
Default for a state and Region Default for a region. The shape style can be changed in the Shape
Editor.

The shape name appears in the Name list of the Shape Editor.
OR

a. In the Search Editor, select Shape Database Viewer, navigate through the list to the shape
you want to add and double-click the shape.
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b. Then select Done to close the Shape Database Viewer.

The default shape style is automatically applied to the shape, Country Default for a country, State
Default for a state and Region Default for a region. The shape style can be changed in the Shape
Editor.

The shape name appears in the Name list of the Shape Editor.
You can also add a custom shape, that you’ve created yourself. See Custom Shapeslass) for further
instructions.

To add child shapes:

1. In the Shape Editor, once a country or state shape has been added, select the shape for which you'd
like to add the states or regions.

2. Right-click the selected shape and from the context menu, select Load Children.

Shape Editor I (3]
biome Go to Shape on Map
L United States 7
Load Children
Delete

Add Child Shapes

e If a country shape has been selected, all the states of that country are loaded and displayed
hierarchically below the country.

o If a state shape has been selected, all the regions of that state are loaded and displayed
hierarchically below the state.

e It is possible that no children exist for a shape (for example, no regions are available for a state or
the shape is already a region).

To delete a shape:

1. In the Shape Editor, from the list of shapes, select the shape you want to delete.

Shape Editor I ]
Name =t
* | United States

%*_ Alabs Go to Shape on Map

'l.? Alask Load Children

@ Ame Delete

\& Arizona

Delete Shape
2. Right-click the selected shape and from the context menu, select Delete.
e Press Ctrl and click on another shape name in the list to select multiple shapes to delete.

e Select a shape in the list, then press Shift and click on another shape to select all the shapes
between the first and last selected shape to delete.

e If children have been loaded, select and right-click the parent shape and from the context menu,
select Delete Children to remove all the child shapes.
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Editing Shapes

In the Shape Editor, you can apply a predefined style to a shape and overwrite certain parameters,
allowing you to change the appearance of an individual shape without changing the style itself. This is
useful if you have applied the same style to multiple shapes and don’t want to change all of them.

You can also change the opacity and visibility of the shape, add an image to the shape and edit the shape
boundaries.

Finally, you can create new Shape Styles to suit your production. See Shape Styles[215 for more
information.

To edit a shape:

1. In the Shape Editor, select the shape you want to edit.
e Press Ctrl and click on another shape in the list to select multiple shapes.

e Select a shape in the list, then press Shift and click on another shape to select all the shapes
between the first and last selected shape to edit.

e A shape can also be selected by clicking on it in the output window.

2. In the shape list, double-click the shape or right-click the shape and select Go to Shape on Map
from the context menu to adjust the view of the camera so that the shape is centered in the Output

Window.

Shape Editor @ |
Name
¥ i Canada

& Alberta Go to Shape on Map
SENBREEREE L oad Children

& Manitoba Delete
& New Brunswick
& Newfoundland and Labrador

Go to Shape

3. From the Style drop-down, select a predefined shape style to apply to the shape.

When a shape is selected, the Style drop-down indicates which shape style is currently applied to
that shape.

4. In the Overwrite Style section, you can adjust the following default parameters of the selected
shape style:

e Zoom In — enable this checkbox, then enter or select a value to define at which camera Zoom
Level the shape will be visible.

e Zoom Out — enable this checkbox, then enter or select a value to define at which camera Zoom
Level the shape will be visible.

¢ Area Color — enable this checkbox, then select the Color button to open the Color Selection
editor and select a color to overwrite the color of the selected shape style.
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« Shadow Color — enable this checkbox, then select the Color button to open the Color Selection
editor and select a shadow color for the shape style.

The color style overwrite can also be applied in tandem with the Zoom In and Zoom Out overwrite
parameters when they are enabled.

5. In the Properties section of the editor:
a. Enter a value or use the arrows to adjust the Opacity.
e A value of 1 makes the shape completely opaque (a solid color).
e A value between .99 and .01 makes the shape increasingly transparent.
e A value of 0 makes the shape invisible.

e Select the Radio button to place a keyframe on the timeline.

*Opacity does not affect children associated with the shape.
b. Select the Visible checkbox to display the selected shape and its children.
If the Visible checkbox is cleared, only the parent shape will be displayed.
e Select the Radio button to place a keyframe on the timeline.

Shapes will blend in or out for the nhumber of seconds set in the Effect In and Effect Out
parameters set in the Edit Shape Style editor when animated, starting at the key frame that
makes the drawing visible or invisible. See Shape Style Properties|2:9 for more information.

c. Inthe Scale fields, enter a value or use the arrows to adjust the Scale of the shape.
e Select the Radio button to place a keyframe on the timeline.

d. In the Offset fields, enter a value or use the arrows to increase or decrease the value by which
the shape will be offset from the actual boundaries.

e The X field offsets the shape horizontally.
e The Y field offsets the shape vertically.
e Select the Radio button to place a keyframe on the timeline.
e. Select the checkbox beside the Offset fields to be able to move the shape to a different location.
For details about using this feature, see Relocating Shapes[2i3\.

f. In the Extrude fields, enter a value or use the arrows to increase or decrease the height of the
extruded shape.

This setting becomes more visible if the map is tilted.

g. In the Resolution drop-down, select one of the following options to define how the shape is
displayed:

e Auto
e Low (with coastline)

e High (with coastline cut by the water layer)
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6. In the Media section:
a. Select the Use checkbox, if you want to use an image file in the scene.

When the Use checkbox is selected, the Type and File fields and File Browse button become
available.

b. From the Type drop-down, select the type of media file to use.
Currently, only the File type is supported.

c. Select the Browse button () beside the File field to navigate to the media file you want to use
in the scene.

The supported media file formats are .jpg and .png.

d. In the Scale fields, enter a value or use the arrows to increase or decrease the size of the image.

The X field adjusts the size of the image horizontally.

The Y field adjusts the size of the image vertically.

Select the Radio button to place a keyframe on the timeline.

e. In the Translate fields, enter a value or use the arrows to move the image within the shape.

A positive value in the X field moves the image to the right horizontally.

e A negative value in the X field moves the image to the left horizontally.

A positive value in the Y field moves the image up vertically.

¢ A negative value in the Y field moves the image down vertically.

Select the Radio button to place a keyframe on the timeline.

f. In the Angle field, enter a value or use the arrows to tilt the image.

A positive value tilts the image towards the right.

A negative value tilts the image towards the left.

Select the Radio button to place a keyframe on the timeline.

g. From the Mapping drop-down, select one of the following options to define how an image is
displayed in the selected shape:

UV Relative: The image is locked to the shape and moves with the shape. When this option is
selected, the image is placed at a pre-calculated position relative to the shape center and cannot
be moved.

UV Absolute: The image is locked to the shape and moves with the shape. When this option is
selected, you can adjust the Long. and Lat. values to position the image where you want it within
the shape. You can also adjust the Size of the image.

UV Static: The image is locked to the background, so when you move the shape, you see
different parts of the image.

h. Select the Repeat checkbox, if you want the image file to repeat to fill the selected shape or
leave it blank if you want only one instance of the image.

i. Inthe Long. and Lat. fields, enter a value or use the arrows to adjust the values to position the
image within the selected shape (available for the UV Absolute option only).
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j- In the Size field, enter a value or use the arrows to increase or decrease the size of the image
(available for the UV Absolute option only).

If the color of the shape style that has been applied to the shape conflicts with the colors in the
image, you can overwrite the color in the Overwrite Style section of the Shape Editor. Refer to
step 4[200 for further information.

7. In the DataLinq section:

a. From the Source drop-down, select the DataLinq Source. For information on adding DataLinq
Servers see To add a Dataling Server.

b. Select the Source checkbox and view the Dataling data displayed in the output window.
c. For information on configuring the DataLinq Shape Data see Dataling Setuplsi.

9. In the Drawing Relation section, group together different drawing tools from within a selected
shape designated in the output window. These groupings can be added to the User Predefined
Objects window and saved as one object.

See User Predefined Objects| ) for information on creating groups.
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Relocating Shapes

There are cases where you want to see all states, territories, districts, etc. of a country in your scene,
but some are far from the mainland. For example, in the United States, Alaska and Hawaii are not visible
when the camera is centered on the mainland. Fortunately, you can move the shapes of the areas that
are out of view.

If the shape style you're using includes labels, you may need to move the default locations of the labels
in the Shape Database Viewer.

For instructions on moving the labels, see Shape Label Properties. (2411

To relocate the state shapes, you’'ll need to first isolate them and then move them. You may also need to
resize the shapes to make them fit in the scene and be properly visible.

To isolate the state shapes:

1. At the bottom of the Search editor, click the Shape Database Viewer button and select the
country you want to illustrate in your scene.

2. Select the arrow to expand the country and then select the country name.

3. On the right side of the Shape Database Viewer, select Add State Shape.

4. Then select the states that are not visible when the camera is centered on the mainland of the
country and select Add State Shape for each.

The default shape style is added but can be changed if necessary. See Shape Styles|2i3) for more
information.

5. In the Shape editor, in the Name list, right-click on the country name and from the context menu,
select Load Children.

6. In the Children list, select each of the states that you added separate shapes for in the Shape
Database Viewer and press the Delete key.

7. Collapse the list.

You should have the country name and the states you selected from the Shape Database Viewer
displayed.
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To move the state shapes:

1. Select one of the shapes you want to move.

2. In the Shape editor, in the Properties section, select the checkbox beside the Offset parameters.
3. Then left-click and drag the shape close to the mainland of the country.

4. If necessary, use the Scale parameters to resize the shape.

5. When the shape is positioned and sized as necessary, deselect the checkbox.

6. From the menu bar select File > Save.

The image below is an example of how you might relocate Alaska and Hawaii.

Relocating Shapes
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Shape Styles

XPression Maps comes with a set of predefined shape styles that can be applied to the shapes you add to
your scene. The styles are available through the Shape editor, in the Style section, as described in Step
3 of To edit a shape style[217). You can also create your own custom shape style in the Shape Style

Manager.

To create a new shape style:

1. In the Shape Editor, in the Style section, select the Browse button (iIJ) beside the Style drop-

down.

The Shape Style Manager opens, displaying a list of predefined styles.

i Shape Style Manager

Country Default

Country Highlight

France

French States

Mew Country Highlight

New Country Style

MNew Region Shape Style

Ontario

Shape Style Manager
2. Select Add.

The Add Shape Style dialog opens.

B Add Shape Style

Shape Style Manager - Add Shape Style

? X

3. In the Name field, enter a name for the new shape style.
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4. If you want to copy the properties of one of the existing styles, from the Copy from drop-down,

select the style you want to copy and select OK.

The Edit Shape Style dialog opens.

B tdit Shape Style

Edit Shape Style Dialog

5. Edit the shape style as necessary.

See Shape Style Properties[21) for information on editing shape style properties.

6. When you have finished editing the shape style properties, select OK.

In the Shape Style Manager, your new style is added to the list and the Save icon appears beside

it.

i Shape Style Manager

Shape Style Manager

Country Default

Country Highlight

France

Region Default

=

Region Election

State Default

State Highlight
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7. Select the Save icon and in the Save Shape Style confirmation dialog, select Yes to save the new
shape style into the shape style database.

If you don’t save the shape style, it will only be applied in the current scene and will not be available
to use again.

[ 5ave Shape Style X

\9]) Save the Shape Style into the shape database?
4

| Yes | I Mo I

Save Shape Style Confirmation Dialog

8. Then select Done to close the Shape Style Manager.

To edit a shape style:
1. In the Shape Editor, in the Style section, select the Browse button (| - ) beside the Style drop-
down.
The Shape Style Manager opens, displaying a list of predefined styles.
2. Select the shape style you want to change and select Edit or double-click the shape style.
The Edit Shape Style dialog opens.
3. Edit the properties of the new style and select OK.
See Shape Style Properties [219)for information on editing shape style properties. .

The Edit Shape Style dialog box closes and the Shape Style Manager reopens. The edited style is
highlighted and the Save icon = and Reset icon lﬁ are displayed beside it.

A Shape Style Manager ? >
Name Al add |
1 Country Default E | Edit |
2 Country Highlight Delete
ountry Highlig ~ e
\ | |
3 1 France ig 1%1’
4 NewStyle
5 Region Default _‘_.3/
3 Region Election
7 State Default @ —
3 State Highlight
a States Election i
| el ||| gResetal || oone |

Shape Style Manager

4. Select the Save icon and in the Save Shape Style confirmation dialog, select Yes to save the shape
style into the shape style database.

An exclamation mark at the left of the shape style indicates that the style is saved in the scene but
not in the database. That style will not be available to be used in other scenes.

OR

Select the Reset icon and in the Reset Shape Style confirmation dialog, select Yes to reset the
shape style to its previously saved state.
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5. Then select Done to close the Shape Style Manager.

To delete a shape style:

1. In the Shape Editor, in the Style section, select the Browse button (|E) button beside the Style
drop-down.

The Shape Style Manager opens, displaying a list of predefined styles.

i Shape Style Manager

Shape Style Manager

2. Select the shape style you want to delete and select Delete.

Country Default

Country Highlight

France

French States

New Country Highlight

New Country Style

Mew Region Shape Style

Ontario

?

X

3. In the Delete Shape Style confirmation dialog, select Yes to delete the style.

i Delete Shape Style

Delete Shape Style Confirmation

4. Then select Done to close the Shape Style Manager.
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Shape Style Properties

Many of the properties of shape styles can be customized for a different appearance. Properties such as
border and fill area color, name visibility and style and the zoom level at which the shape style becomes
visible can be edited in the Edit Shape Style dialog. Changes in these properties are visible in the
output window but not saved into the Shape Style until you select OK.

If the shape is a state rather than a country, the corresponding regions are shown, if available. Names
and borders of regions are available only for states that have region shapes defined. Check the Shape
Database Viewer to see whether region shapes are available for a state.

See Shape Database Viewer[28 for information about the Shape Database.
If the shape is a region, the settings in the Children Shape Properties section do not have any effect.

These properties and others are described in the table below.

Properties Description
Name Enter a name for the new style

Default For Use the drop-down to select whether you want to make this style the default style for
countries, states, or regions, or not make it the default for anything (by selecting
None).

Only one default style exists for each country, state or region. Setting a style to default
will over-ride any previously defined default style.

Border When enabled, the outline of the shapes using this style will be displayed in the color
that is set in the corresponding Color Selection editor to the right of the checkbox.

Borders are drawn on top of the selected map style and therefore take precedence over
the borders of the map style.

The border width can be adjusted by entering a value or using the arrows to increase or
decrease the value in the field beside the checkbox.

Maximum is 10 pixels.

Fill Area When enabled, the shapes using this style will be filled with the color that is set in the
corresponding Color Selection editor to the right of the checkbox.

Shape Fill When enabled, a shadow will surround the shape fill area. The parameters are:
Shadow
(optional) Shadow — select the Shadow checkbox to enable a shadow color to surround the

Shape area.

Shadow Color — select the Color button to open the Select Color window. Select a
basic color, use the color gradient or input a custom color for the Shadow Color.

Shadow Offset — use the arrows to adjust the Shadow Offset.

> The first entry field adjusts the shadows placement from left to right, a higher number
places the shadow more on the right side of the shape. A lower number places the
shadow on the left side of the shape.

» The second entry field adjusts the shadows placement from top to bottom. A higher
number places the shadow more on top of the shape. A lower number places the
shadow more on the bottom of the shape.

Blur — use the arrows to adjust the level of blur added to the shadow. A higher number
will increase the blur level, a lower number will decrease the blur.
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Properties

Name

Name Style

Use
Abbreviatio
n for Name

Use Scene

Style
Shading

Apply
Ocean
Mask

Zoom In

Zoom Out

Description

Enter O for no blur.

Standalone — select the Standalone checkbox to view the shadow on the same shape
styles on the map. Deselect the Standalone checkbox to view the shadow in only one
area.

No Shadow B Shadow Shadow Offse - Right Shadow Offset - Left Shadow Offset - Top Shadow Offset - Bottom

When enabled, the name associated with the shape will be visible in the output and will
be the color that is set in the corresponding Color Selection editor to the right of the
checkbox.

The size of the name can be scaled by entering a value or using the arrows to increase
or decrease the value in the filed beside the checkbox.

When not enabled, no name is displayed. This can be useful if you are using a map style
that includes names.

Use the drop-down to select a text drawing style to apply to the names.

When you select a Name Style, you can preview it in the Output Window, but it is
not saved into the Shape Style until you select OK.

When enabled, abbreviations will be used for the names of the top level shapes.
Children shapes need to be separately configured

When enabled, the height shading in the scene will be displayed. In order for this to
work, the Height Shading parameter in the Edit Map Style editor must also be
enabled.

See Height Shading| 0 for more information.
When enabled, all parts of a shape that extend into the ocean will be hidden. In order

for this to work, the Ocean Mask overlay parameter in the Edit Map Style editor must
also be enabled.

See Overlay for more information.

Enter or use the arrows to select the camera Zoom Level value at which the shape will
be visible.

If the camera Zoom Level value is smaller than the Zoom In value, the shape will not
be visible.

Enter or use the arrows to select a camera Zoom Level value at which the shape will no
longer be visible.

If the camera Zoom Level value is larger than the Zoom Out value, the shape will not
be visible.

220 « Editors

XPression Maps User Guide (v3.4)



Properties Description

Effect These two parameters define how a shape appears and disappears during its visible
animation. This effect can be seen when the animation is played or when the zoom level
is changed.

In - When set to Dissolve, the shape will blend in for the humber of seconds selected in
the corresponding field, starting at the key frame at which the shape is set to appear.

When set to None, the shape appears at the frame to which the key frame is set.

Out - When set to Dissolve, the shape will blend out for the number of seconds
selected in the corrersponding field, starting at the key frame at which the shape is set
to disappear.

When set to None, the shape disappears at the frame to which the key frame is set.

Blend Mode Use the drop-down to select how the Fill Area color of the shape is combined with the
underlying map. The options are:

Regular — the area color is combined with the underlying map color.
This is the most common blend method.

Multiply — the area color is multiplied with the underlying map color.
Add — the area color is added to the underlying map color.

Hue From Map — the hue (dominant color) of the shape style is discarded and the hue
of the underlying map is used instead.

Saturation From Map — the saturation (intensity) of the shape style is discarded and
the saturation of the underlying map is used instead.

Value From Map — the value (lightness or darkness) of the shape style is discarded
and the value of the underlying map is used instead.

Saturation and Value From Map — the hue (dominant color) of the shape style is
combined with the saturation (intensity) and value (lightness or darkness) from the
underlying map.

Multiply Add Hue From Map Saturation Value From Map Saturation and
From Map Value From Map

Regular

The Height Shading and 3D of the scene style is also applied to the shapes.

Children Description

Shape

Properties

Borders When enabled, state or region borders will be visible in the output.

Enter or use the arrows to select a width for the child borders.

Click the Color button to open the Color Selection editor and set a color for the child
borders.
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Properties Description

Names When enabled, the names of the states or regions will be visible in the output. Enter or
use the arrows to select a size for the name of the children.

Click the Color button to open the Color Selection editor and set a color for the child
names.

The name style is determined by the Name Style selected in the Properties section.

Database
Automation

Border When Database Automation is enabled and Border Color is selected, the border
Color color queried from the SQL database that is defined in the file selected in the File field
is applied to the shape.

Fill Area When Database Automation is enabled and Fill Area Color is selected, the fill area
Color color queried from the SQL database that is defined in the file selected in the File field
is applied to the shape.

File Click the Browse button (/) beside the File field to navigate to the .xml configuration
file which contains the pointer to the Shape Color Database in which the Border and
Fill Area colors are defined.
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Drawing Editor

Use the Drawing Editor, shown below, to modify the parameters of a selected drawing that has been
added to the map. If a parameter is greyed out, it doesn’t apply to the selected drawing.
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Drawing Editor Location

The following topics are discussed in this section:
Common Parameters/224)

Specific Parameters[ 220

Line Drawing Parameters[z8)

Text and OSM Replacement Drawing Parameters| 229
Area Drawing Parameters|[ 230

Magnifier Drawing Parameters(2sfl

Locator Drawing Parameters(232)

Dynamic Data Drawing Parameters( 23

Inset Drawing Parameters| 2
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Common Parameters

The upper part of the Drawing Editor contains the parameters that are common to most drawings.
Select the drawing in the scene before adjusting the parameters.

Parameter Description

Location The Longitude and Latitude parameters, in degrees, determine the location of the
selected drawing.

Click the radio buttons beside the Longitude and Latitude fields to add a key frame
for that location.

Right-click the radio buttons to select an Easing method for the animation to and
from that key frame.

Rotation The Angle parameter, in degrees, determines the rotation of the selected drawing.

This parameter does not apply to Line and Area drawings.

Size The Scale and Zoom parameters are used to resize a drawing. New drawings are
always created in the same size in pixels. When a drawing is created in the Drawing
Management Editor, the default Scale value is 1.

Scale - Enter a value or use the arrows to increase or decrease the scale of the
drawing in the Output Window.

For Line drawings, the Scale parameter adjusts the width of the line.

Zoom - Enter a value or use the arrows to increase or decrease the zoom level of the
drawing.

Adjust the camera Zoom Level of the map to the level at which you want the
drawing to appear before adding it.

Auto - when checked, the drawing remains the same size in pixels, while the camera
animates through the different zoom levels.

When unchecked, the drawing increases or decreases in size as the camera animates
through the different zoom levels.

Aspect The Value parameter increases or decreases the width of the drawing, relative to
the height.

e If the value is less than 1, the width (X) decreases relative to the height (Y).
e If the value is greater than 1, the width increases relative to the height.

When you make the drawing larger or smaller by clicking and dragging a corner of
the bounding box, the set Aspect ratio is maintained.

The default is 1.

Opacity Enter or select a value between 0 and 1 to define the transparency of the drawing.

A value of 1 is opaque and a value of 0 is transparent.

Visible Select the Visible checkbox to make the drawing visible.

It has the same effect as clicking the Eye icon (&) in the output window.
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Parameter Description

Frontface Frontface - Select to have the front side of the drawing face the camera.
You can also toggle this parameter in the output window by clicking the Frontface
icon ( 4!) at the bottom of the drawing’s bounding box.
This parameter does not apply to Line and Area drawings.
The View Camera button in the camera control area changes to indicate that this
camera is locked ().
Only one drawing at a time can lock the playout camera.
For a Line drawing, the playout camera looks at the head of the line when locked.
Keep Keep Orientation - Select to align a text drawing to the screen. Clear to align a text
Orientation drawing to the camera. Applies to Text drawings only.
Lock Camera Lock Camera - Select to force the playout camera to look at the drawing.

The play out camera can no longer be moved in its normal fashion.

Use Spline Use Spline Rotation - Select to have the rotation angle of the drawing change
Rotation according to the direction of the line.

This parameter is only applicable for drawings that are connected to the head of a
line.

In order to connect a drawing to a line, it must be dragged and dropped to the head
of the line in the output window. A yellow rectangle indicates that the drawing will be
connected to the line when the drawing is dropped.

To disconnect a drawing, drag it away from the head of the line until the yellow
rectangle disappears.
Animation Animation Slowdown - Enter or select the number of frames in which an image is
Slowdown repeated in an image sequence before the next image is shown.
The default value is 0.
This parameter is only applicable to Icon, Area and Line Drawings.
Image sequences loop independently of the timeline animation.
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Parameter Description

Effect These parameters define how a drawing appears (In) and disappears (Out) during

(In and Out) animation.
Options are:

None - the drawing appears instantly at the frame to which the key frame is set.

Dissolve - the drawing blends in over the number of seconds selected in the Time
field, starting at the key frame at which the drawing is set to appear.

Typewriter - the drawing appears one character at a time over the number of
seconds selected in the Time field.

*Applies to Text drawings only.

Alpha - the drawing blends in one character at a time over the number of seconds
selected in the Time field.

*Applies to Text drawings only.

Wipe - the drawing animates in and out at the level set in the corresponding Zoom
fields. The drawing appears from the right over the number of seconds selected in
the Time field. Use the Delay field to input the number of seconds that the drawing
will delay its animation.

*Applies to Text drawings only.

Wipe Reverse - the drawing appears in and out at the level set in the corresponding
Zoom fields. The drawing appears from the left over the number of seconds selected
in the Time field. Use the Delay field to input the number of seconds that the
drawing will delay its animation.

*Applies to Text drawings only.

Wipe Left - the drawing appears/disappears from the left over the number of
seconds selected in the Time field. The drawing animates in and out at the level set
in the corresponding Zoom fields.

Wipe Right - the drawing appears/disappears from the right over the humber of
seconds selecting in the Time field. The drawing animates in and out at the level set
in the corresponding Zoom levels.

Wipe Bottom - the drawing appears/disappears from the bottom over the number
of seconds selected in the Time field. The drawing animates in and out at the level
set in the corresponding Zoom levels.

Wipe Top - the drawing appears/disappears from the top over the number of
seconds selected in the Time field. The drawing animates in and out at the level set
in the corresponding Zoom fields.

DatalLing The Dataling section links Drawings to Dataling Sources configured in the DatalLing
Setup window. See DatalLing Setup|8d for information.

Select a Dataling source from the drop-down menu or select the Browse button (|
) to open the DatalLinq Setup window.

Once you have selected a Dataling source, select the Source checkbox to view the
configured Dataling Drawing data in the output window.

226 - Editors XPression Maps User Guide (v3.4)



Specific Parameters

The lower part of the editor will display parameters that are specific to the selected drawing. See the
following sections for details:

Line Drawing Parameters| 23

Text and OSM Replacement Drawing Parameters| 22
Area Drawing Parameters| 20

Magnifier Drawing Parameters/zs1

Locator Drawing Parameters|23)

Dynamic Data Drawing Parameters/2s

Inset Drawing Parameters| 24
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Line Drawing Parameters

The Line section contains the parameters that are specific to line drawings. Select the line drawing in the
scene before adjusting the parameters.

Line Drawing Parameters

Parameter Description

Texture Aspect — enter or select an aspect value to define how the image is mapped
on the line.
Scale — enter or select a scale value to define how the image is mapped on
the line.
Angle — enter or select an angle value to define how the image is mapped
on the line.

Progress Value - enter or use the slider to select a percentage between 0 and 100 to
define how much of the line is visible.

Point Index — enter or select a value for the active point of the line. A value of 0
means no active point. The active point is red in the output. All other points
are green.

Longitude — enter or select a longitudinal value for the active point of the
line.

Latitude — enter or select a latitudinal value for the active point of the line.

Close Select the Close checbox to close the Line drawing from the starting point to
the ending point.
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Text and OSM Replacement Drawing Parameters

The Text section contains the parameters for modifying the alignment of text and OSM Replacement
drawings. Select the drawing in the scene before adjusting the parameters.

Text Drawing Parameters

Parameter

Alignment

Kerning

Line Spacing

Text Box

Description

Left - align the text to the left.
Center - center the text.
=/ Right - align the text to the right.

Justified - align the text to the left and right margins.
Enter a value or use the arrows to set the amount of space between letters.

Enter a value or use the arrows to set the amount of space between multiple
lines of text.

Use the text box to edit the text on one or more lines.

Press the Enter key to move text to the next line.
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Area Drawing Parameters

The Area section contains the parameters that are specific to area drawings. Select the area drawing in
the scene before adjusting the parameters.

—Area

— Texture

Aspect: 1.0000 =
Scale: 1.0000 =
Angle: 0.0000 =
Sendtrce:
—Point

e
Longitude: 75,6822 |=
Latitude: 45,6104 |=

Area Drawing Parameters

Parameter

Texture

Point

Description

Aspect — Enter or select a value to define the appearance of the pattern in the area.
Scale — Enter or select a value to define the size of the pattern in the area.

Angle — Enter or select a value to define the angle of the pattern in the area.

Blend Mode — Use the drop-down to select how the area texture is mixed with the
underlying map.

The options are:
Regular — the area is blended with the map.
Multiply — the area color is multiplied with the map color.

Add — the area color is added to the map color.

Add

Regular Multiply

Index - enter or select a value for the active point of the line.

A value of 0 means no active point.

The active point is red in the output. All other points are green.

The active point can also be set by left-clicking the mouse on the point.
Longitude - enter or select a longitudinal value for the active point of the area.

Latitude - enter or select a latitudinal value for the active point of the area.
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Magnifier Drawing Parameters

The Magnifier section contains the parameters that are specific to magnifier drawings. Select the
magnifier drawing in the scene before adjusting the parameters.

— Magnifier

Zoom Level: |1E] =

Map Style: Bing Aerial -
MapZoom: | L0000 |2 Q
Map OffsstX: |0.0000 |=| O
Map Offset¥: |0.0000 |=| O

Map Location:  -72.8161, 53.4779

Reload Map

Magnifier Drawing Parameters

Parameter Description

Zoom Level Enter or select a zoom level between 1 and 21 to define how much detail is
displayed in the highlighted area.

A higher zoom level value means more detail is shown.
Map Style Use the drop-down to select a map style.

The options are:

Bing Aerial

Bing Aerial Label

Bing Road

Bing Road Dark

Bing Road Gray

Bing Road Light
Map Zoom Enter or select a zoom value for the highlighted area of a map.

0 - 1: The area is magnified.

>1: The area is made smaller.

The resolution of the map is not changed, so it does not show more or fewer
details when zoomed in or out.

Map Offset X Enter or select a value to move the highlighted area within the drawing along
the X coordinate.

Map Offset Y Enter or select a value to move the highlighted area within the drawing along
the Y coordinate.

Map Location Displays the longitude and latitude coordinates of the highlighted area.
This is defined by the position of the drawing at creation.

Reload Map If you move the magnifier drawing within the scene, click Reload Map to set
the Map Location coordinates to the actual location of the drawing. This
updates the map in the highlighted area.
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Locator Drawing Parameters

The Locator section contains the parameters that are specific to locator drawings. Select the locator
drawing in the scene before adjusting the parameters.

R
P E——
1000 |2 C

0.0000 |2/ C
0.0000 |2 C

Locator Drawing Parameters

Parameter Description

Zoom Level Enter or select a zoom level between 1 and 21 to define how much detail is
displayed in the highlighted area.

A higher zoom level value means more detail is shown.
Map Style Use the drop-down to select a map style.

The options are:

Bing Aerial

Bing Aerial Label

Bing Road

Bing Road Dark

Bing Road Gray

Bing Road Light
Map Zoom Enter or select a zoom value for the highlighted area of a map.

0 - 1: The area is magnified.

>1: The area is made smaller.

The resolution of the map is not changed, so it does not show more or fewer
details when zoomed in or out.

Map Offset X Enter or select a value to move the highlighted area within the drawing along
the X coordinate.

Map Offset Y Enter or select a value to move the highlighted area within the drawing along
the Y coordinate.
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Dynamic Data Drawing Parameters

The Dynamic Data section contains the Data Filter parameter which is specific to dynamic data
drawings. Select the dynamic data drawing in the scene before adjusting the parameters.

Dynamic Data is an optional feature for XPression Maps and the XPression Maps Server.

Dynamic Data Drawing Parameter

Parameter Description
Data Filter Defines a filter parameter for the dynamic data query.

For example, if you place a Dynamic Data Drawing on the map which
draws information about a city from an SQL database, and you want to move
this drawing away from the location of the city on the map, enter the name
of the city in the Data Filter parameter and use an SQL statement in the
Dynamic Data Query such that the SQL statement is using the ${Filter}
parameter for the selection of the data.

The data will be updated to be specific to that city.

Updating requires that you move the drawing slightly in the output window.

XPression Maps User Guide (v3.4) Editors « 233



Inset Drawing Parameters

The Inset section contains the parameters that are specific to the Inset drawings. Select the Inset
drawing in the scene before adjusting the parameters.

Inset
(EditFulsceen | Edit |
e | [
Inset Drawing Parameters
Parameter Description
Edit Fullscreen Select the Edit Fullscreen button to edit the Inset drawing in fullscreen
mode. See Editing Inset Drawings[+s7! for information on editing in fullscreen
mode.
Edit Select the Edit button to edit the view of the Inset drawing as it is presented

in the output window.

File Select the Browse button (.- ) to open the File Explorer window to import
an external file for the Inset drawing

234 - Editors XPression Maps User Guide (v3.4)



Search Editor

Use the integrated Microsoft© search editor to find maps of locations throughout the world by searching
for addresses, cities, countries and even prominent buildings. You can also add default names, icons or
dynamic data drawings to the scene and edit shape label properties from this editor.

Use the Search Editor, shown below to specify a location.

Fle £t Sole Cutom Ouput Animaion Intersctive Vew Help

N -

Ejrttit Geog

oo | aa oot | [ im0t | | et
A

210 tengase 75 503) O Tl0oo0 12O

H> o[BI [ @nla] [ol<] of"

Search Editor Location

The following topics are discussed in this section:
Searching for a Location| 23!

Shape Database Viewer[2

Shape Label Properties|2:

Shape Label Translation[2:)
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Searching for a Location

You can search for a location using the Search field or by using the Geo Location button beside the
Search button. Both methods are described below:

To search for a location using the Search field:

1.

In the Search Editor, in the Search (Location/Address, City, Country) field, enter the location
for which you want to find a map.

e Separate the different parts of the location with a comma, for example, Ottawa, Ontario,
Canada.

e Enter more parameters, such as a street address, to narrow the search results.

¢ In the Filter section, select the appropriate checkbox if you want to search for a country, state,
region or any combination of the three.

If you want the map to go directly to the location you are searching, select the Go to Result
checkbox.

Then select the Search button.
The search results show all locations found that match the entered information.

Where multiple results are returned, the first result is shown in the output window and lower quality
results will be highlighted in yellow in the Result pane in the editor.

In the Search Related Shapes section, a list of the available shapes for the searched location
appears. This list is dependent on the search filters selected (Country, States and/or Region).

In the Result pane, click the arrow beside the location to see details such as the country and latitude
and longitude of the location.

—Result
Information Value
* Location Cornwall, ON
Type PopulatedPlace

Address Cornwall, ON
Admin Distr...  OMN

Country Canada

Result Quality High

Pasition Lon=-74.7, Lat=45.02
P Location Cornwall, United Ki..
b Location Cornwall, NY
b Location Cornwall Island, ON
b Location Cornwall, CT

Search Results

If you haven't selected the Go to Result checkbox, double-click on any result to switch to that
location in the output window.

To search for a location using Geo Location:

Select the Geo Location button () located next to the Search button.

The Geo Location dialog box opens.

B Geo Location ? X

Longitude: H ‘

Latitude: | \

Zoom Level: ICounhy - J
| GoTo | Cancel

Geo Location Dialog
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2. Enter the Longitude and Latitude coordinates of the location you want to find.
3. Then from the Zoom Level drop-down, select how broad a view you want.
Options are:
e Country
o State
o City
e Street
e Address
4. Select Go To.

Geo Location moves the map to the specified longitude and latitude.
To add a name, an icon or drawing data to the map:

1. Right-click on a search result.

2. From the context menu that opens, select one of the following options.

e Add Name to Map: If you have identified a text drawing as the default, the name of the location
will be added to the map using the style of the default text drawing.

e Add Icon to Map: If you have identified an icon drawing as the default, the default icon will be
added to the map at the corresponding location.

e Add Dynamic Data Drawing to Map: If you have identified a dynamic data drawing as the
default, the default dynamic data drawing for the corresponding location is added to the map.

To add a shape layer to a location:

1. After searching for a location in the Search Editor, in the Search Related Shapes list, double-click
on the country, state or region shape you want to add to the scene.

—Search Related Shapes
MName In

1|kl Canada | Canada

2/ \§ Ontario | Canada

3| =/ Ottawa | Ontario->Canada

Fiter:  fled Country £\ States
Mu'a’ Region
Label:  [JAuto Create

fAdjust Map to new Shape
I Shape Database Viewer I

Search Related Shapes List
OR

Select the Shape Database Viewer button and select a shape from the database.
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To add a label to a shape:

1. In the Label area, select Auto Create to enable labeling.

2. Then, in the Search Related Shapes list, double-click a shape to automatically add a label, if there
isn't already one for that shape.

The shape keeps a reference to its label so that the label is visible for as long as the shape exists and
is visible.

This label is created with the default text style and can be moved and scaled like a regular drawing.
You can drag a different text style onto the label to change it.
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Shape Database Viewer

The Shape Database Viewer provides direct access to the shapes of all countries and their states (and
regions, where available). When using the Shape Database Viewer, it is not necessary to first search a
location.

i Shape Database Viewer ? X

The Gambia
Togo

Tonga

Trinidad and Tobago
Tunisia

Turkey

Turkmenistan

Turks and Caicos Islands

Vv vV VvV VYTYYY

»
»
»
»
»
»
»
»
»
»
»
»
»

Shape Database Viewer

The countries are arranged in alphabetical order.
To add a shape:

1. In the Search Editor, select or clear the Adjust Map to New Shape checkbox.

e When selected, the map in the output window moves to the location of the shape you're adding and
adds the shape at its default zoom level, which is different for each shape.

e When cleared, you need to manually adjust the map to the area of interest but then each shape is
added to the map at the same zoom level.

2. Then select Shape Database Viewer.
3. Do one of the following:
e Select a country from the list.
e Click the arrow beside a country to select a state from the list.

e Click the arrow beside a country and then the arrow beside a state to select a region from the list
(if regions are available for the selected state).

4. Select Add State Shape or double-click the selected country, state or region to create a shape for
the country.

The shape appears on the map in the output window and in the Shape list in the Shape Editor.
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5. If you want to make changes to the label of a shape, select the shape in the list and select Edit Label
Properties. See Shape Label Properties|a1) for details.

6. When you have finished adding shapes and editing shape labels, select Done to close the Shape
Database Viewer.

The same shape can be created multiple times. This can be useful if you want to swap different views
of a single shape. In an election map, for example, you might want a state to change color to show
which party controlled the state before and after the election.
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Shape Label Properties
The Shape Label Properties editor provides access to the label details of a shape and is accessed from

the Shape Database Viewer. You can change the name of the shape label, the position, the size and
the zoom level at which it appears and you can add search terms to the search info.

To edit the shape label properties:

1. In the Search Editor, select Shape Database Viewer at the bottom of the editor.

The Shape Database Viewer opens.

[ shape Database Viewer ? X

The Gambia
Togo

Tonga

Trinidad and Tobago
Tunisia

Turkey

Turkmenistan

Turks and Caicos Islands

»
13
»
13
»
3
»
»
»
»

LA A A A A

Shape Database Viewer
2. From the list, select the shape whose label you want to edit.
3. Select Edit Label Properties.

The Shape Label Properties editor opens.

B Shape Label Properties ? *

Shape Label Properties Editor
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4. Edit the parameters in the Shape Label Properties editor, as described in the table below, to
configure the shape label.

Parameter Description

Name The name of the label.

You might want to change the name that’s displayed if you are translating it
into a language that isn’t configurable in the Preferences, i.e. English (en-
US), Canadian French (fr-CA) or German (de-de).

See Shape Label Translation[ 243 for more information.

Longitude Enter or use the arrows to select a longitudinal coordinate for the label to
reposition it within the shape boundaries.

In the Output Window, the labels for all the shapes associated with your
selection appear, so that you can judge how far and in what direction to
move the label. Only the label you've selected will be changed.

Latitude Enter or use the arrows to select a latitudinal coordinate for the label to
reposition it within the shape boundaries.

In the Output Window, the labels for all the shapes associated with your
selection appear, so that you can judge how far and in what direction to
move the label. Only the label you've selected will be changed.

Size Enter or use the arrows to select a size for the label.

The value of the size parameter is equal to the zoom parameter of a
drawing.

A value of 20 will make the label readable at a zoom level of 20.

A larger value will make the label smaller, so that it is readable at a larger
zoom value.

Valid range is 0.00 to 100.

Zoom Level Enter or select the zoom level of the map on which the shape will be
created.

The shape will become visible at this zoom level.

Search Info Enter a group of search terms which can be used to find the shape in the
database when searching for a location.
5. Select Update to save your changes.
6. Select Done to close the Shape Database Viewer.
The new labels will not yet be updated in the scene.
7. Select Save.

8. Then select File and select the scene from the Recent Scenes list to re-open the same scene and
apply the label changes.
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Shape Label Translation

The shape labels are stored by language (Country code) in the shape database. The default language is
English (en-US) and an initial translation for Canadian French (fr-CA) and German (de-de) exists. The
labels for other languages need to be changed manually in the Shape Label Properties editor.

See Shape Label Properties[ 241 for more information.

The language can be changed in File > Preferences in the Map tab.
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Bookmark Editor

The Bookmark Editor allows you to save map positions and organize them in folders for later use.

Use the Bookmark Editor shown below, to add and delete folders and bookmarks. These functions are
useful for creating presets of commonly used locations. Using folders allows you to categorize bookmarks
for different map types, styles, or other use cases. The application saves the bookmarks you’ve created
on exit and reloads the bookmarks upon the next start.

The Bookmark Editor only saves the map position, not drawings that have been added to the scene. All
bookmarks are shown in the currently selected map style, regardless of the map style selected when the
bookmark was added.

Bookmarks can also be used to add a pause to a flight.

LR L ——
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Bookmark Editor Location

The following topics are discussed in this section:
Adding and Deleting Bookmark Folders/[2s)
Adding and Deleting Bookmarks!2s)

Recalling and Editing Bookmarks|z47)

Saving and Loading Bookmarks| 247

Adding a Pause to a Flight/24)
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Adding and Deleting Bookmark Folders

Keep your bookmarks organized to make them easier to locate by sorting them into folders.
To add a bookmark folder:

1. In the Bookmark Editor, click the arrow beside the Add Bookmark button, to open the Bookmark
menu shown below.

Add Bockmark

Add Folder
Delete Folder

Save Bookmarks
Load Bookmarks

Bookmark Menu
2. Select Add Folder.

3. In the New Folder dialog, shown below, enter a name for the folder and select OK.

H MNew Folder ? X

Add New Bookmark Folder

The new folder is added at the bottom of the Bookmark tab.

T T

MBROOrNERRE

New Bookmark Folder
To delete a folder:

1. In the Bookmark Editor, select the folder you want to delete, to make it the active folder.
2. Then click the arrow beside the Add Bookmark button to open the Bookmark menu.
3. From the Bookmark menu, select Delete Folder.

The Delete Bookmark Folder confirmation dialog opens.

B Delete Bookmark Folder X

Delete Bookmark Folder

4. Select Yes to delete the folder.

The folder is deleted from the current view, but remains.
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Adding and Deleting Bookmarks

Adding a bookmark allows you to quickly get back to a specific location with the same camera
parameters that were used when the bookmark was created.

To add a bookmark:

1. With the map location selected and displayed in the output window, select Add Bookmark.

The New Bookmark dialog opens.

4 New Bookmark  ? >

Name:

|Parliament Hill Centre Block |

=

Add New Bookmark
2. In the Name field, add an identifying name for the bookmark and seelct OK.

A thumbnail of the map is added to the Bookmark folder.

To delete a bookmark:

1. In the Bookmark Editor, select the folder containing the bookmark you want to delete.

2. Select the red X in the corner of the bookmark.

Bookmark

The Delete Bookmark confirmation dialog opens.

B4 Delete Bookmark it

\q]) Do you want to delete this bockmark?
4

| Yes | o |

Delete Bookmark Confirmation Dialog

3. Select Yes to delete the bookmark.
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Recalling and Editing Bookmarks

You can recall a saved bookmark to include it in your production or to edit the bookmark name.

To recall a bookmark:

1. In the Bookmark Editor, select the folder containing the bookmark you want, to open it.

2. Then click on the bookmark thumbnail.

To change a bookmark name:

1. In the Bookmark Editor, select the folder containing the bookmark whose name you want to
change.

2. Double-click on the name of the bookmark.

3. In the Change Bookmark Name dialog that opens, type in the new name and select OK.

Saving and Loading Bookmarks

Your bookmarks are automatically saved into a default folder when you exit the XPression Maps
application and reloaded when you launch the application. You can also save them into a folder of your
choice.

To save your bookmarks:

1. In the Bookmark Editor, select the arrow beside the Add Bookmark button, to open the
Bookmark menu.

2. From the Bookmark menu, select Save Bookmarks.

3. In the Save File dialog, navigate to the folder where you want to save your bookmarks and select
Save.

The bookmarks are saved in an xml file, which can then be loaded as needed.

To load your saved bookmarks:

1. In the Bookmark Editor, select the arrow beside the Add Bookmark button, to open the
Bookmark menu.

2. From the Bookmark menu, select Load Bookmarks.

3. In the Load File dialog, navigate to the folder containing the bookmark file with your saved
bookmarks.

4. Select the bookmark file and select Open.
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Adding a Pause to a Flight

You can use a bookmark to add a pause during a flight animation, for example if you wanted to provide
further information at that point in the flight.

To add a pause to a flight:

1. Select File > Open to open a flight animation scene in which the flight goes from point A to B to C
without stopping.
Alternatively, you can create a new flight animation.
For information on creating a flight animation, see Flight Points.[1e3)

2. If necessary, move the key frames following flight point B towards the end of the timeline to leave
space for the pause.

3. Move the timeline handle to point B and in the Bookmark Editor, click Add Bookmark.

4. Now move the timeline handle to a position after flight point B, where you want the pause to end and
click on the bookmark you created in the previous step.

5. Add a camera key frame at that position.

6. Select the green Play button in the animation toolbar to play the animation.
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OSM (OpenStreetMap) Style Editor

The OSM Style Editor allows you to customize scenes that use OpenStreetMaps as the map style.

Use the OSM Style Editor shown below, to change the background color of an OSM map, as well as the
visibility, colors, parameters and labels of the layers of the selected map or its overlay. The elements
are grouped into categories to make them easier to find.

You can convert the language used for the labels in real time by selecting a language from the drop-
down.

S secondary-tertiary

N secondary-tettiary-casing
[ name-major

5 tunnel-major

T bridge-major

X bridge-major-casing

T minor

'Qm

el
v
v
]
O
]
]

Gl EEREEO

[ name-minor

Show Information Layers

OSM Style Editor

All street name suffixes in OSM maps are styled the same in XPression Maps. By default, an abbreviated
suffix with no punctuation is used (ST, AVE, RD, DR, etc.). It is possible to change the suffix style. If this
is something you would like to do, contact techsupport@rossvideo.com.

Editing Overview|zso!

Real-Time Language Support|zsil

Editing OpenStreet Mapsl 23!

OSM Replacement Drawings|ze3)

Show Information Layers| 2!

Editing Individual Layer Elements| 25!
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Editing Overview

This is an overview of the procedure for editing OpenStreet maps. For detailed instructions on using the
OSM Style Editor, see Editing OpenStreet Maps. [2s)

To edit and save a new OpenStreet map:

1. In the Map Styles section below the OSM Style Editor, from the Style drop-down, select an
OpenStreet Map Style.
It is preferable to add a new map style copied from an existing style and edit the new one.

For instructions on adding a map style see To add a new map stylel 4.

Map Styles - OpenStreet Maps
2. Edit the style according to the instructions in Editing OpenStreet Maps|2s\.
3. Select Style > Map Styles to open the Map Style Manager.

B Map Style Manager e

0SM-Basic Aerial

0SM-Basic Aerial Mercator

0SM-Basic Shadow

0SM-Custom

0SM-Custom Example

OSM-Style-A

Map Style Manager
4. Select the map style you have modified.

5. Select the Save icon @ to save your changes into the default database or select the Reset icon @
to discard your changes and revert to the last saved version of the style.

An exclamation mark & at the left of the map style indicates that the style is saved in the scene but
not in the database. That style will not be available to be used in other scenes.

The Save All button W at the bottom of the dialog box saves all changes made to all styles in
the database.

The Reset All button @ at the bottom of the dialog box resets all styles in the database to
their last saved version.

6. Select Done to close the Map Style Manager.
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Real-Time Language Support

In the OSM Style Editor, you can convert the language of OSM Maps in real-time. This is useful in
multilingual workplaces where map templates can get saved in one language and exported in others.

Language translations are supplied from the OpenStreet Maps Global Community.

Configure language codes in the Country Code Text Document in the XPression Maps installation files.
See Configuring Languages|2s3) for information.

To convert the language of an OSM Map:

e In the OSM Style Editor, select a Language from the drop-down.
The default options are:
» Arabic
» English
» French
» German

» Spanish

N secondary-tertiary
X secondary-tertiary-casing
name-major

L tunnel-major

S bridge-major

S bridge-major-casing
X minor

T service

name-minor

. tunnel-minor

S bridge-minor

S\ bridge-minor-casing

i}
o
i}
o
i}
o
i}
o
i}
o
i}
]
i}
]
i}

Show Information Layers

OSM Style Editor - Language
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The map will display labels in the selected language.

LIBYA

ERIT
(L) SUDAN
BURKINA FASO

LEONE _ NIGERIA = EDHORIA
)

CENTRAL AFRICAN , w sl Uil 2340
\ p 59320
/ «  KENYA 5o il Lot

DEMOCRATIC,
REPUBLIC OF THE Indian
. Ocean

English (United States) o Arabic (Saudi Arabia)
OSM Style Labels With Language Change

Once a language has been selected, XPression Maps will continue to populate maps with that language
until it has been changed.

To edit the translation and/or spelling of languages (optional):

1. Select the text label or drawing you want to edit from the output window.
2. Press Shift + right-click and select whether you want to edit or remove the text label or drawing.

3. Select edit to open Edit OpenStreetMap Data window.

¥ Edit OpenStreetMap Data X
Layer Name: I > I
Longitude: | 92.554321 |% |Latitude:  [65.037379 |%
Rank: B >
IDefalt . ||Nunavut |
I&\ﬁsh v ||Nunavut |
| Chinese ~ | BaRERE |
IFrmch = ||Nunavut |
| arabic ~| ceduyi |
| Russian > | ynasyr |
| Concdl | Do |

Edit OpenStreetMap Data Window

3. Edit the necessary fields and select Update.

* Updates made to the labels will be in effect for everyone using that map.
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To remove translation from map:

1. Select the text label you want to remove in the output window

2. Press Shift + right-click shift and select Remove.

X Labels removed from the map template will be in effect for all users that have access to the map.

Configuring Languages
Language translations are supplied from the OpenStreet Maps global community.

Configure language codes from the Country Code Text Document in the XPression Maps installation
files.

*Country Code Text Document is a master list for all users, do not edit this list.

To configure translation codes for XPression Maps:

1. Navigate to C:\XPressionMaps_3.0/DB folder and open the two Text Documents:
CountryCodeText
WorkCountryCodeText

WNM Styles
WNMDBInfo
WNMDBInfo3.0

30items ==

XPression Maps Country Code Text File Location
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e CountryCodeText - this master list is supplied by the OpenStreetMaps global community and
contains the translation codes for each language provided. Use this list to copy language codes into
the WorkCountryCodeText document.

X Do not make changes in this document.

| CountryCodeText - Notepad

File Edit Format View Help
laf;Afrikaans

am;Amharic

ar-sa;Arabic (Saudi Arabia)
as;Assamese
az-Latn;Azerbaijani (Latin)
be;Belarusian

bg;Bulgarian

bn-BD;Bangla (Bangladesh)
bn-IN;Bangla (India)
bs;Bosnian (Latin)

ca;Catalan Spanish
ca-ES-valencia;Valencian
cs;Czech

cy;Welsh

da;Danish

de-de;German (Germany)
el;Greek

en-GB;English (United Kingdom)
en-US;English (United States)
es-ES;Spanish (Spain)
es-US;Spanish (United States)
es-MX;Spanish (Mexico)
et;Estonian

eu;Basque

fa;Persian

fi;Finnish

fil-Latn;Filipino

Ln 1, Col 1

100%

Windows (CRLF)

UTF-8

CountryCodeText File

¢ WorkCountryCodeText - this is the local working list of language codes that can be modified as
needed. Paste codes from the CountryCodeText file into the location you'd like to see them

appear.

_| WorkCountryCodeText - Notepad

File Edit Format View Help
fen-Us;English (United States)
de-de;German (Germany)
es-ES;Spanish (Spain)
fr-FR;French (France)
ar-sa;Arabic (Saudi Arabia)

Ln 1, Col 1

WorkCountryCodeText File

100%

Windows (CRLF)

UTF-8

1. Select File > Save to save configurations in the WorkCountryCodeText file and close both

windows.
2. Restart XPression Maps.

The new languages will appear.

X When changing languages, it's important to note that fonts for text drawings and labels need to be
supported for the selected languages.
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Editing OpenStreet Maps

This section provides instructions for changing the background color, visibility, layer color, and layer
highlight color of an OpenStreet map. It also describes how to edit the layer parameters and individual

layer elements.

* Right-click on the layer in the output window to highlight that layer in the OSM Style Editor.

To change the background color of an OSM map:

1. In the OSM Style Editor, from the layer list, select the Background layer.

2. Then select Color.

The Color Selector opens.

B select Color

[

||

||

||

L

L]

[ —

o |2
o |2
o |2
1255 2|

=000000

| ok || cancel |

OSM Style Editor Color Selector - Background

3. Select a color swatch from the Basic colors or use the slider or RGB values to create a custom color.

If you create a custom color, select Add to Custom Colors so that it’s available for subsequent use.

4. Select OK.

The background color changes to the new color.

- » o]
Background Color Change
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To change the visibility of a layer:

¢ In the OSM Style Editor, in the Visible column, clear the checkbox beside a layer to hide it or select
the checkbox to show the layer.

E water E
OSM Style Editor Visibility Checkbox

To change the color of a layer:

1. In the OSM Style Editor, in the Color column, select the color swatch beside the layer.

Ewdﬂ' E

OSM Style Editor Color Swatch

The Color Selector for that layer opens.

[ Select Color for: water

OSM Style Editor Color Selector
2. Select a color swatch from the Basic colors or use the slider or RGB values to create a custom color.

If you create a custom color, select Add to Custom Colors so that it's available for subsequent use.

3. Then select OK.
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To change the highlight color of a layer:

1. In the OSM Style Editor, in the High column, select the highlight color swatch beside the layer.

E water E
OSM Style Editor Highlight Swatch

The Highlight Selector for that layer opens.

[ Select Highlight for : water X

:

OSM Style Editor Highlight Selector
2. Select a color swatch from the Basic colors or use the slider or RGB values to create a custom color.
If you create a custom color, select Add to Custom Colors so that it's available for subsequent use.

3. Then select OK.
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To switch a layer from color to highlight:

1. Do one of the following:

e Double-click on the layer in the output window to toggle between using the configured Color or
Highlight.

Double-clicking selects all the parts of a layer that have the same ID.
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Double-click to Change Color
OR

e Right-click on the layer in the output window and from the context menu, select Set color > Color
or select Set color > Highlight.

Right-clicking selects the part of the layer on which you are clicking.

? o
ﬁ S X 9 .

Right-click to Change Color
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To edit the parameters of a layer:

1. In the OSM Style Editor, in the Edit column, select Edit for the layer you want to edit.

Name Visble Color High Edit
W v [ CH

OSM Style Editor Edit Button

The OSM Layer Parameters dialog opens. There are at least 4 editable parameters for each layer,
Use As Information, Zoom In, Zoom Out and Opacity. The other parameters depend on the type
of layer that is selected.

k4 0SM Layer Parameters ? >

Layer Mame: building

Use As Information: [ ] ( hidden in final output )
R .
Zoom Out: 250 2[00 [3]
Opaity: 100 |2

OSM Layer Parameters

2. Select the Use As Information checkbox if you don’t want the layer to appear in the final output but
want it showing while you edit the map.

You can also deselect the Visible checkbox for a category of layers if you don’t want any of them to
appear in the final output. For example, if you don’t want any buildings in the final output, deselect
the building layer checkbox.

3. Enter a value or use the arrows to adjust the Zoom In level at which the layer will appear.
The adjacent field determines the amount of time, in seconds, it will take for the layer to dissolve in.
0.00 = The layer is fully visible as soon as the Zoom In level is reached.
9.00 = The layer dissolves in gradually over 9 seconds once the Zoom In level is reached.

4. Enter a value or use the arrows to adjust the Zoom Out level at which the layer will disappear.

The adjacent field determines the amount of time, in seconds, it will take for the layer to dissolve
out.

0.00 = The layer disappears immediately after the Zoom Out level has been reached.
9.00 = The layer dissolves gradually over 9 seconds, after the Zoom Out level has been reached.

5. Enter a value or use the arrows to adjust the Opacity of a layer, making it more or less transparent.
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6. Adjust any additional parameters as described in the following table:

Parameter Description
Background  Select the Color button to open the Color Selector and select the color for the
Color Text Background.
Background | Enter a value or use the arrows to adjust the opacity of the background color for
Opacity the text.
Background Opacity - 1.00 Background Opacity - 0.60
Font Use the drop-down to select a font for the text.
Icon Color Select the Color button to open the Color Selector and select a color for the icon.

Icon Opacity Enter a value or use the arrows to adjust the opacity of the icon.
Icon Size Enter a value or use the arrows to adjust the size of the icon.
Icon Text Fit  Select to link the size of the icon to the text or the size of the text to the icon.

Some examples are shown below.

= , -~
Grenfell / i ( !g
Capital Grenfell / !

Capital
Unlinked lconFitsText TextFizlcon
Keephspect Keepispect
Ignore When checked, all OSM Layers will be displayed, even if they overlap at the
Collision current zoom level.

When cleared, higher level layers will be displayed until a zoom level is reached
that allows room for other level layers to be displayed.

Applies to text layers only.
Line Stipple Select if you want to give a road a dotted line effect.

Line Stipple Enter a value or use the arrows to adjust the width of the dot (1st field) and the

Pattern width of the space between the dots (2nd field).
» - s -~
T i - ..
. » .

1.00, 1.00 2.00, 1.00 1.00, 2.00
Line Width Enter a value or use the arrows to adjust the width of the line.
Line Enter a value or use the arrows to adjust the gap between the 2 lines of a casing,
GapWidth such as the bridge_major_casing.
Opacity Enter a value or use the arrows to adjust the opacity of text.
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Parameter

Outline Color

Shadow

Shadow Color

Shadow
Offset

Text
Background

Text Halo Blur

Text Halo
Color

Text Halo
Width

Text Letter
Spacing

Text Line
Height

Description

Select the Color button to open the Color Selector and select a new color for the
outline of buildings (applies to building layer only).

Select the checkbox to add a shadow to the layer.

-~ o o' O
- .‘;,;\ . 3
s * L"\}:-! | \\\\
Wore o |

If you've chosen to add a shadow, select the Color button to open the Color
Selector and select a color for the shadow.

Use the arrows or enter a value in the Offset fields to change the position of the
shadow. The first field changes the horizontal position. The second field changes
the vertical position. See illustration below:

Select the checkbox to insert a rectangle as a background to the text. Click the
Color button to open the Color Selector and select a color for the background.
See illustration below:

\. Ottawa A Ottawa

-0 /’ N /
Enter a value or use the arrows to adjust the amount of blur in the text halo.

Select the Color button to open the Color Selector and select a color that will
surround the text characters.

This parameter only works if the value in Text Halo Width is greater than 0.

Enter a value or use the arrows to adjust the thickness of the text halo.

Austria

Halo - 3.00

Austria  Austria

No Halo Halo - 1.00

Enter a value or use the arrows to adjust the amount of space between the
characters of the text.

Enter a value or use the arrows to increase or decrease the space between lines of

text.
\ % A

s
gt 2 % e %

Westminster \ Westminster
Cathedral Cathedral
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Parameter Description

Text Max Enter a value or use the arrows to increase or decrease the maximum number of
Width characters allowed in one line of text.

Exceeding the Text Max Width will cause a line break, where possible.

Text Size Enter a value or use the arrows to adjust the size of the existing label text.
Text Use the drop-down to select whether the text should be UPPERCASE, lower case
Transform or None (mixed case).

User Defined Check to add a user-defined replacement drawing for the layer.
Replacement

Drawing Then select the Browse button ( ) to select a replacement drawing from one of
the following groups in the Drawing Toolbox:
o Text

e Web Examples
¢ OSM Replacement
e Your custom group

When unchecked, a replacement drawing that is the same as the OSM text will be
added. This could be used to add a label at a location where there isn't one or to
change the size or the orientation of the text.

7. Select Done if you are satisfied with your changes.
OR
Select Reset to restore the OSM Layer Parameters to their original settings.
OR

Select Cancel to discard your changes.
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OSM Replacement Drawings

Replacement drawings are text drawings that can be used to replace existing labels on a map. The
replacement drawings are placed in roughly the same location as the existing label and when the scene is
used in production, all layers that have been configured as Use As Information will be hidden and only
the replacement labels and items that are not configured to be hidden, will be displayed. This allows for a
less cluttered map that shows only those items that are necessary for the production.

Parliament Hill

iy e e s
o

OSM Replacement Drawings (Original and Production)
To add a replacement drawing to a scene:

1. Right-click on a label on the map.
2. From the context menu, select Add Replacement Drawing.

The replacement drawing that has been defined for the selected layer is added to the scene.

stage -

N

|
B = /
fall Nmonqem—a
CentPd bulding

Set color »
Hide

building-3d
Set color 3
Hide

’.ﬁ level-3
Add Replacement Drawing
A

Set color 13

Hide

Add Replacement Drawing Context Menus

Alternatively, you can double-click on a place label on the map to automatically add the replacement
drawing for that layer.

For information about defining a replacement drawing, see User Defined Replacement Drawing. [2s5)

The replacement drawing is placed on top of the existing place label and is selected by default. You
can reposition the replacement drawing as needed.
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Replacement Drawing Added
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To edit user-defined replacement drawings:
1. In the Drawing Toolbox, from the Group drop-down, select the Group that contains the
replacement drawing you want to edit.

Typically, replacement drawings are found in the Text, OSM Replacement, or Web Examples
groups or in a custom group.

The available drawings are displayed. The example below shows OSM Replacement drawings.

Drawing Toalbox: (=15
Group: | OSM Replacement ~|

NEW @ i

NewDrawing  Interstate Highway
Country,
Road State Basic Country

stATe || City || irport

Basic State Basic City Airport

Location STREET

Basiclocaton  Basic Street Water

POI || country || STATE

Basic POL A-Country AState

CITY
A-City A-Street AOI
CITY COUNTRY

Adiocation  A-State Aerial  B-Country

STATE

B-State B-City. B-Location

Drawing Toolbox - OSM Replacement Drawings
2. Right-click the drawing you want to edit and select Edit Drawing.
3. Make the changes you want to the drawing and then click Done.

4. If you want to make your edited drawing the default drawing for that layer, right-click the drawing
again and select Set as Default Text.

The drawing will still have to be designated as the replacement drawing in the OSM Layer
Parameters in the User Defined Replacement Drawing section. See User Defined Replacement
Drawing. [2s2!

To delete a replacement drawing from the scene:

1. In the output window, select the drawing you want to delete.
2. Press the Delete key.

3. To delete a replacement drawing from a Group in the Drawing Toolbox, see To delete a
drawing.[ss
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Show Information Layers
You may not want all the layers of a map to be displayed in your final output. Selected layers can be
hidden in the OSM Style Editor. The exception is that if you've highlighted a particular road, area,

building, etc., then that element will remain visible in the final output, while all other elements in the
selected layer will be hidden.

To hide a layer:

1. In the OSM Style Editor, click the Edit button beside the layer you want to hide.

The OSM Layer Parameters dialog opens.

B 05M Layer Parameters ? X

OSM Layer Parameter
2. In the OSM Layer Parameters dialog, select the Use As Information checkbox and select Done.

3. In the OSM Style Editor, click the Show Information Layers button to view the scene with the
selected layers hidden.

By default, the Show Information Layers button is red, indicating that all layers are visible. When
clicked, the button turns grey, indicating that the layers which have been chosen to be hidden, will
not be visible.
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N secondary-tertiary

X secondary-tertiary-casing
@ name-major

S tunnel-major

S bridge-major

s brdge-maor-casing

'{ minor

'(suviee
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name-minor

Show Information Layers

OSM Style Editor
4. Select Show Information Layers again to view your scene with the layers displayed.

When the scene is recorded, those layers will not be visible.

XPression Maps User Guide (v3.4) Editors « 265



Editing Individual Layer Elements

For each element of a layer, you can switch between the main color and the highlight color or hide the
element. You can also add a replacement drawing on top of a place label.

To edit individual elements:

1. Right-click on the element in the map.

A menu opens, listing each layer that appears in that location.
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Hide
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OSM Editing Menu

2. To change the color of an element, click Set color and from the context menu, select either Color or
Highlight.

Alternatively, you can double-click the layer to switch between the Color and Highlight colors.

The layer changes to the color or highlight that has been selected for that layer in the OSM Style
Editor.

3. To hide the element, select Hide.
e To make the element visible again, press Alt + Right-click.
4. To add a replacement drawing on top of a text label, select Add Replacement Drawing.

If a user-defined replacement drawing has been set for that layer in the OSM Style Editor the text
label will be replaced by that replacement drawing. If no user-defined replacement drawing has been
set, a drawing that is identical to the text label will be added.

For information on defining a replacement drawing, see User Defined Replacement Drawing.[22)
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Creating Animations

You can create interesting animations to illustrate your story using the timeline and the key frame
controls.

The following topics are discussed in this section:
Adding and Deleting Key Frames| 2!

Animation Control Menulz1

Location and View Animation[272)

Drawing Animation| 273

Line Animation| 272

Zoom Animation[zzs)

Shape Animation[2r7\

RossTalk Animation/zz8)
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Adding and Deleting Key Frames
You can add and delete key frames using the Key Frame toolbar beside the timeline or the Edit menu.
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Key Frame Toolbar - Location

There are three options:

o Add Camera Key Frame - creates key frames for the camera parameters, Zoom Level, Longitude,
Latitude, Tilt and Roll all at once, to record the location and view of the map. Additionally, it creates
a key frame for the map style if it has changed and for the lock camera parameter if it has changed.

Zoomlevel:| 196 |%| O Longitude:| 57.6325%| Q Tit:|45.0000 |2| @  PauseDuw: [0 [2] Q
Latitude:| 41.8851 |+ @ Rol:|0.0000 |=| Q

Camera Parameters with Key Frames
Camera, map style, and camera lock key frames are shown in the upper scale of the timeline slider.

e Add Drawing Key Frame - creates key frames for drawings. The Location, Rotation, and Size
parameters are recorded when adding a key frame for a drawing. If a drawing is selected, only the
parameters for this drawing are recorded, otherwise the above mentioned parameters of all drawings
are recorded.

Drawing key frames are shown in the lower part of the timeline scale.

¢ Delete Selected Key Frames - deletes all selected key frames.
To add a camera key frame:

1. With the timeline slider at the position where you want to start your animation, rotate the globe to
the location where you want the animation to begin.

2. In the menu bar, select Edit > Add Camera Key Frame or select the Add Camera Key Frame
button.

i,
Add Camera Key Frame

The timeline will display a blue camera key frame icon above the groove of the timeline slider.
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| Y |

1|ﬁ|||1||i nTl |||||||?|

Camera Key Frame Icon
3. Move the slider in the timeline to a different position and change the location of the globe.

4. Select Edit > Add Camera Key Frame or select the Add Camera Key Frame button again to
record the new location.

5. Repeat steps 3 and 4 until you have added all the key frames you want.

The animation can be viewed by playing it or by moving the timeline slider.
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To add a drawing key frame:

1. With the timeline slider at the position where you want to start your animation, place a drawing on
the map.

2. With the drawing selected, select Edit > Add Drawing Key Frame in the menu bar or select the
Add Drawing Key Frame button.

Add Drawing Key Frame

The new Location, Rotation and Size parameters are recorded.

The timeline will display a blue drawing key frame icon below the groove of the timeline slider.

L B L
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Drawing Key Frame Icon

3. Move the timeline slider to a different position and change the location or parameters of the drawing.
4. Select the Add Drawing Key Frame button to record the new location and/or parameters.

The drawing will animate all recorded parameters between the two positions of the timeline.
To delete key frames:

1. From the timeline slider, select the key frame you want to delete.

Press Ctrl and click to select multiple key frames or left-click in the timeline and drag a selection box
around multiple key frames.

The selected key frames change from blue to green (drawing key frames) or red (camera and
interactive event key frames).

2. Select Edit > Delete Selected Key Frames in the menu bar or select the Delete Selected Key
Frames button.

B P

Delete Selected Key Frames
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Moving Between Key Frames

There are several ways to move from one key frame to another.

To move between key frames:

e Select Edit > Jump to Next Key Frame or Jump to Previous Key Frame, as required.

OR

e Press Ctrl+Right Arrow to move to the next key frame or Ctrl+Left Arrow to move to the previous
key frame.

OR

e In the timeline, select on the key frame to which you want to move.
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Animation Control Menu

The Animation menu contains the animation playback controls. These controls are also provided in the
toolbar shown below, located at the bottom-left side of the application.

> ] 0

Animation Playback Toolbar
To use the animation playback controls:

e Select Animation in the menu bar and then select one of the following controls:
» Rewind - rewind the animation to the beginning; you can also press Ctrl+B
> Play - play the animation from the beginning; you can also press Ctrl+Space

» Continue - continue playing the animation from the position on the timeline; you can also press
Ctrl+G

> Stop - stop playing the animation; you can also press Ctri+H

> Forward - fast-forward the animation to the end; you can also press Ctrl+M
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Location and View Animation

You can use a location and view animation to draw attention to multiple locations and different map
views.

To animate multiple locations:

1. In the Search Editor, enter the location at which you want to begin your animation.
The location you enter will be displayed in the center of the map.
Alternatively, you can left-click on the map and move it to the location you want.
2. Adjust the Zoom Level, Tilt and Roll values to change the viewpoint of the map, if desired.

3. Select the Add Camera Key Frame button.

[ 5

Add Camera Key Frame
4. Drag the slider in the timeline to a different position.

Alternatively, you can select any point in the timeline to move the slider to that point or enter the
position in the frame counter to the left of the timeline.
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Frame Counter

5. Repeat steps 1 to 3 for each location you want to show.

6. Select the green Play Animation button in the Animation Control toolbar to view your animation.

Play Animation

7. When you are satisfied with the animation, save it.
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Drawing Animation

You can make drawings appear and/or disappear at specific points in an animation.

To create a drawing animation:

1. With the map positioned where you want to start your animation and the timeline slider at 0, select
the Add Camera Key Frame button in the Key Frames toolbar.

2. Drag the timeline slider to the point in the timeline where you want a drawing to appear.

Alternatively, you can select any point in the timeline to move the slider to that point or enter the
position in the frame counter to the left of the timeline.
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Frame Counter

3. Add a drawing to your scene and keep it selected.

4. In the Drawing Editor, in the General section, select the Visible checkbox (or clear the checkbox if
you want the drawing to disappear) and select the Radio button beside the checkbox to key frame
the visibility.

5. Then select the Add Drawing Key Frame button in the Key Frames toolbar.
6. Repeat steps 2 to 5 for each additional drawing you want to include in your scene.

7. Select the green Play Animation button in the Animation Control toolbar to view your animation.

LBLILIC]

Play Animation

8. When you are satisfied with the animation, save it.
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Line Animation

You can use a line animation to show the progression of a route across a map, for example the route to
take to get from point A to point B, or the route that will be followed for a race.

To animate a line:
1. Add a line drawing to your scene to mark a route. See Adding and Editing Line Drawingsl s for
instructions on adding a line drawing.

2. In the output window, select the line drawing you want to animate.

3. In the frame counter to the right of the timeline slider enter the number of frames you want to have
in your animation.

The timeline will display up to 9999 frames. The speed of the animation playback depends on the
screen resolution selected in File > Preferences > Output. For example, HD 1080 50i will play 25
frames per second and HD 1080 60p will play 60 frames per second.

4. Then move the timeline slider to the last frame.

Alternatively, you can select any point in the timeline to move the slider to that point or enter the
position in the frame counter to the left of the timeline.
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Frame Counter

5. In the Drawing Editor, in the Progress section, select the Radio button beside the Value field.
This creates a key frame on the timeline at the slider position.
6. Select the Close checkbox to connect and close both ends of the Line animation.

Leave unchecked if you want to have an open ended Line animation.

~ Line
Aspect: [10000 |2]
Scale: [10000 |2]
Angle: [0.0000 [2]
Value: | 100.0000 ;|
‘ L
Longitude: | -61.6017 |/
Latitude: |7+.8070 |2
dﬂng

Drawing Editor - Progress Section
7. Move the timeline slider to the left to the 0 position.
This marks the point on the timeline as the ending key frame (100.0000) of the animation.

8. In the Drawing Editor, in the Progress section, move the Value slider all the way to the left to the
0 position and select the Radio button beside the Value field.

This creates the starting key frame of the animation.

If your animation covers a large area of the map and you want the map to move with the line, in the
Drawing Editor, in the Misc section, select the Lock Camera checkbox.

274 - Creating Animations XPression Maps User Guide (v3.4)



9. Select the green Play Animation button in the Animation Control toolbar to view your animation.

Play Animation

10.When you are satisfied with the animation, save it.
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Zoom Animation

You can use a zoom animation to draw the viewer’s attention to a specific location, beginning from a
distant camera view and zooming in to a close-up view or starting close-up and zooming out.

To animate a zoom into a location:
1. In the frame counter to the right of the timeline slider enter the number of frames you want to have

in your animation.

The timeline will display up to 9999 frames. The speed of the animation playback depends on the
video format and on the screen resolution selected in File > Preferences > Output. For example,
HD 1080 50i will play 25 frames per second and HD 1080 60p will play 60 frames per second.

2. In the Search Editor, in the Location field, enter the name of the city, the area of the city or the
landmark that you want to zoom into and select Search.

The map in the output window will move to the specified location.

3. In the camera parameters beneath the output window, adjust the Zoom Level parameter to a level
that gives you the desired starting view of the country or area of your location.

Alternatively, you can scroll with your mouse to the desired zoom level.

4. With the timeline slider at the beginning of the timeline, select the Add Camera Key Frame button
in the Key Frame toolbar.

Add Camera Key Frame

5. Drag the timeline slider to the right as many frames as you want the animation to take to zoom into
or out of the location.

Alternatively, you can click on any point in the timeline to move the slider to that point or enter the
position in the frame counter to the left of the timeline.
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6. Adjust the Zoom Level parameter to a level that gives you the desired final view of the target
location and add another camera key frame at this position.

The animation will automatically move through the levels to the final zoom level.
7. Select the green Play Animation button in the Animation Control toolbar to view your animation.
TR DI
Play Animation

8. When you are satisfied with the animation, save it.
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Shape Animation

You can use a shape animation to draw the viewer’s attention to specific related locations, by having
each location appear in the scene individually. An example would be a map showing election results.
Each location is represented by a shape that appears at a specific point in the animation.

To animate a shape:

1. In the frame counter to the right of the timeline slider enter the number of frames you want to have
in your animation.

The timeline will display up to 9999 frames. The speed of the animation playback depends on the
screen resolution selected in File > Preferences > Output. For example, HD 1080 50i will play 25
frames per second and HD 1080 60p will play 60 frames per second.

2. With the map positioned where you want to create your animation and the timeline slider at the
beginning of the timeline, click the Add Camera Key Frame button in the Key Frames toolbar.

3. Drag the timeline slider to the point on the timeline where you want to display the shape.

Alternatively, you can select any point on the timeline to move the slider to that point or enter the
position in the frame counter to the left of the timeline.
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Frame Counter

Incrementing the frame count by the same amount each time helps to create a smooth animation.

4. In the Search Editor, at the bottom, make sure the Adjust Map to New Shape checkbox is
cleared.

When cleared, shapes added using the Shape Database Viewer will appear at the current zoom
level, rather than the zoom level set in the Shape Database Viewer.

5. Select the Shape Database Viewer button and select the shape you want to add.
6. Select Add Shape (or double-click the shape name) and then select Done.
The shape appears on the map, using the default shape style defined in the Shape Editor.

7. In the Shape Editor, select the new shape you just added from the list and in the Properties
section, make sure the Visible checkbox is selected and click the Radio button beside the Visible
checkbox to add a key frame.

This will make the shape become visible at this point in the timeline.

8. Select the Add Camera Key Frame button.
To add additional shapes to the scene:
e Repeat steps 3 to 7 to add additional shapes to the scene.
To view animation playback and save:
1. Select the green Play Animation button in the Animation Control toolbar to view your animation.
T ROLCIC]
Play Animation

2. When you are satisfied with the animation, save it.
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RossTalk Animation

You can use RossTalk animation to draw the viewer's attention to a specific RossTalk Event.

To animate a RossTalk event:

1. In the frame counter to the right of the timeline slider enter the number of frames you want to have
in your animation.

The timeline will display up to 9999 frames. The speed of the animation playback depends on the
screen resolution selected in File > Preferences > Output. For example, HD 1080 50i will play 25
frames per second and HD 1080 60p will play 60 frames per second.

2. With the map positioned where you want to create your animation and the timeline slider at the
beginning of the timeline, click the Add Camera Key Frame button in the Key Frames toolbar.

3. Drag the timeline slider to the point on the timeline where you want to display the RossTalk event.

Alternatively, you can select any point on the timeline to move the slider to that point or enter the
position in the frame counter to the left of the timeline.

4. From the RossTalk section select the radio button next to the Event you want to add to the
Animation Control toolbar.
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Frame Counter

Incrementing the frame count by the same amount each time helps to create a smooth animation.
To view animation playback and save:
1. Select the green Play Animation button in the Animation Control toolbar to view your animation.
TROLIC]
Play Animation

2. When you are satisfied with the animation, save it.
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Recording Animations

Maps provides the ability to render the full animation of a scene using the Record Animation function.
The following topics are discussed in this section:
Record Animation as an AVI File[2s0)

Record Animation as ffmpeglzs2)
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Record Animation as an AVI File

Record the animation of your scene as an AVI (Audio Video Interleaved) file using the Record
Animation function.

To record an animation as an AVI file:

1. Select Output > Record Animation in the menu bar or select Record Animation in the toolbar.

XPression Maps Toolbar - Record Animation

The Animation Recording dialog opens.

Animation Recording - AVI

2. Select the AVI tab if it is not already selected.

3. In the Output section, select Browse (iIJ) beside the File field, to navigate to the location where
you want to save the video file.

The Save Video dialog opens.

B Save Video X

A [ ThisPC > Local Disk (C) » XPressionMaps 3.X > Output v|®] | search Output

o

New folder =~ @

@ OneDrive

0 ThisPC
8 3D Objects

s
D Music

=] Pictures

1 videos

L Local Disk (C)

Saveastype: Video (avi) ~|

Save Video in AVI Format
4. Inthe Save Video dialog, in the File name field, enter a name for the video file and select Save.

In the Animation Recording dialog, in the Output section, the File field is populated with the path
to the video file.

5. Select the Overwrite File checkbox if you want to overwrite an existing copy of the animation or
clear the checkbox if you want to keep existing copies and create a new video file.

If you choose not to overwrite an existing copy, you need to change the file name.
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6. In the Configuration section, select AVI Setup to open the Video Compression dialog.

Video Compression

Compressar: OK

Full Frames (Uncompressed) [ Cancel
(5l ~1

e,

AVI Video Compression
a. Select a video compressor from the drop-down and select OK.

Some options will activate the Compression Quality slider and/or the Configure button and
require further configuration.

K Video compression options depend on system capabilities.
b. Select OK when you have finished configuring the video compression.
7. In the Save Format File, select a video format file and select Save.
8. When you have finished configuring the output, select Record to record your animation.

The Animation Recording progress dialog opens. When the recording is complete, the dialog

closes.
A Animation Recording to AV ? *
\Writing to video.
D |

| Cancel |

Animation Recording Progress Dialog - AVI
To stop recording an animation:

e In the Animation Recording dialog, select Cancel or select the Stop Animation Recording button
in the toolbar.

S 28 @ gz BERrE

XPression Maps Toolbar - Stop Animation Recording
To play a recorded animation:

1. Navigate to the folder in which you’ve saved your recorded animations.

2. Double-click the recording you want to play.
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Record Animation in ffmpeg Format

Record the animation of your scene into one of several ffmpeg file formats using the Record Animation

function.

To record an animation in an ffmpeg file format:

1. Select Output > Record Animation in the menu bar or click the Record Animation button in the

toolbar.

Maps Toolbar Record Animation

The Animation Recording dialog opens.

B 2Animation Recording ? X

Annimation Recording - ffmpeg

2. Select the ffmpeg tab if it is not already selected.

3. In the Output section, select Browse (E) beside the File field, to navigate to the location where

you want to save the video file.

The Save Video dialog opens.

B SaveVideo

4[> ThisPC > 0S(C) > XPressionMaps3X > Output

Organize v

= This PC

New folder

A Name

Date modified

Type

0 3D Objects

No items match your search.

~ & | Search Output

©

A Hide Folders

Save Video in ffmpeg Format

4. Inthe Save Video dialog, in the File name field, enter a name for the video file and select Save.

Include the appropriate file extension in your file name.

In the Animation Recording dialog, in the Output section, the File field is populated with the path

to the video file.
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5. Select the Overwrite File checkbox if you want to overwrite an existing copy of the animation or
clear the checkbox if you want to keep existing copies and create a new video file.

If you choose not to overwrite an existing copy, you need to change the file name.
6. When you have finished configuring the output, select Record to record your animation.

The Animation Recording to ffmpeg progress dialog opens. When the recording is complete, the
dialog closes.

B Animation Recording to fimpeg ? d
Writing to video.
| T |
| Cancel |

Animation Recording Progress Dialog - ffmpeg
To stop recording an animation:

« In the Animation Recording dialog, select Cancel or click the Stop Animation Recording button in
the toolbar.

Sl 20 4 - oEis BRsx

XPression Maps Toolbar - Stop Animation Recording
To play a recorded animation:

1. Navigate to the folder in which you’ve saved your recorded animations.

2. Double-click the recording you want to play.
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Custom Data

Custom data can be imported through the Custom menu in the menu bar. It allows the user to import
custom shapes and maps.

The following topics are discussed in this section:
Custom Shapes| 285

Custom Maps| 207
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Custom Shapes

Custom shapes can be area or line shapes. Most common projection formats can be used.

Country or state borders are examples of area shapes. This kind of shape can be filled with a color and
the border can be colored as well.

Streets, rivers and train lines are examples of line shapes. The lines can be colored.

It's a good idea to create a folder outside of the XPression Maps folder to store your custom shapes, to
avoid inadvertently losing them when you upgrade your version of XPression Maps.

Once you've imported a custom shape, you'll want to create a custom shape style for that shape. See
Shape Styles[2i5) for more information.

Managing Custom Groups

Custom shapes can be organized into groups, for easier retrieval. You can add, edit or delete custom
groups, as described in the following sections.

To add a custom group:

1. From the menu bar select Custom > Shapes to open the Custom Shapes editor.

[ Custom Shapes ? b

Custom Shapes Editor
2. In the Custom Shapes editor, select the Browse button beside the Group drop-down.

The Custom Groups dialog opens.

B Custorn Groups ? X

Custom Groups Dialog

3. Selet the Add button to open the Add Custom Group dialog.

B Add Custom Group ? X

Add Custom Group

4. Inthe Group Name field, enter a name for the new custom group and select OK.
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5. In the Custom Groups dialog, select Done to close the dialog.
6. Then select Done to close the Custom Shapes editor.

The new group will appear in the Group drop-down.
To edit a custom group:

1. From the menu bar select Custom > Shapes to open the Custom Shapes editor.

N

From the Group drop-down, select the Group you want to edit.

The table in the center of the Custom Shapes editor displays the data for the selected group.
Select a data row in the table.

Select the Edit tab.

Edit the Name, Layer Name or Search Info parameters and select Update.

o u s, W

Then select Done to close the Custom Shapes editor.
To delete a custom group:

1. From the menu bar select Custom > Shapes to open the Custom Shapes editor.
OR

In the Shape Editor, select the Add Custom Shapes button at the top of the editor to open the
Custom Shapes editor.

2. Select the Browse button beside the Group drop-down to open the Custom Groups dialog.

3. In the Custom Groups dialog, from the Group Name drop-down, select the Group you want to
delete.

4. Select Delete.

5. In the Delete Custom Group confirmation dialog that opens, select Yes to delete the group and all
its contents.

6. In the Custom Groups dialog, select Done to close the dialog.

7. Then select Done to close the Custom Shapes editor.
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Managing Custom Shapes

You can add custom shapes which you’ve created or acquired and stored locally on disk and use those
shapes when creating new scenes.

Once you've added a custom shape to a scene, you’ll want to create a shape style that will make it stand
out. See Shape Styles[28) for more information.

To import a custom shape:

1. From the menu bar select Custom > Shapes to open the Custom Shapes editor.

The Custom Shapes editor opens.

B Custom Shapes

Custom Shapes Editor - Blank
2. From the Group drop-down, select the Group to which you want to add the imported custom shape.

If the Group already contains shapes, the table in the center of the Custom Shapes editor displays
the data for the shapes in the Group.

i Custom Shapes

Milwaukee District North

Milve-N, Milw-4, NCS <html xmins:fo="http: /fwww.w3.0rg/1999/%5L fFormat™>

Union Pacific Northwest

UP-N, UP-NW, UP- <html xmins:fo="http: {jwww.w3.0rg/1999/XSL fFormat™>

Custom Shapes Editor - Populated
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3. Select Import.

The Shape Import editor opens.

[ shape Import ? X
Shape Folder: |C:/ROSS/XPression Maps SourcesTrain LinesMetra Train Lines. k] [
Name Type Object Count Bounding Attrbutes ]
1 |Metra (Lines) | Unknown (any) |0 -88.6171,41.418... |11
2 |UnionPacficN... | Unknown (any) |28 -87.8468,41.683,... 12
3 |Miweukee Dist.. |Unknown (any) |22 -88.1821,41.875... [12 i
4 |NorthcCentralS... |Unknown (any) |29 -88.0922,41.879... 12
5 |UnionPacificN.. | Unknown (any) |24 -88.6171,41,883,... 12
6 |Miwoukee Dist.. |Unknown (any) |25 -88.3284,41.679... |12
B 1 =
-
fbeselect Al [JCombine Parts  Name Column -
Import to Custom Group: MyCustomshapes | Impert | Done

Shape Import Editor

If you've previously imported custom shapes, the Shape Folder field will display the last shape
folder that was opened.

4. To open a different folder, select the Browse button (/) beside the Shape Folder field, navigate to
the folder containing the custom shape you want to import and select Open.

All shape archives in the selected folder are listed in the upper table of the editor. Information for

each archive is displayed as follows:

Name: The name of the shape archive.

Type: The type can be 2D or 3D for Polygon (a closed shape where the beginning of each line is
connected to its end), Line String (which is simply a line), or Point (a location reference).

Object Count: The number of shape objects in the archive.

Bounding: The area in which the shapes are contained, expressed in longitude and latitude
coordinates.

Attributes: The number of attribute columns with additional data for the shape, that are stored in
the archive.

5. Select the archive containing the shape you want to import.

The layers of the selected archive appear in the bottom-half of the Shape Import editor.

6. Select the layer(s) you want to import.

e Check the Select All checkbox to select all the layers.

e Check the Combine Parts checkbox to combine multiple layers into one shape.
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7. Select Import.

The Shape Import Report dialog opens indicating if there were any errors during the import.

B Shape Import Report 7 x

Following shapes produced errors during the import!
Please check the result.

OK

Shape Import Report Dialog
8. If there were no errors, select OK to close the dialog and then select Done.
The shapes from the selected archive appear in the table in the Custom Shapes editor.

9. Select Done to close the Custom Shapes editor or continue to add the custom shape to a scene.
To add a custom shape to a scene:

1. Open the scene to which you want to add a custom shape.

2. From the menu bar select Custom > Shapes to open the Custom Shapes editor, if it is not
already open.

3. In the Custom Shapes editor, double-click the shape you want to add to your scene and select
Done.

The shape is added to the Shape Editor on the left.

4. Double-click the shape in the Shape Editor to display it in the output window.

5. If the map in the output window isn’t displaying the selected shape, in the Shape Editor, right-click
on the shape and select Go to Shape on Map.

To search for custom shapes:

1. From the menu bar select Custom > Shapes to open the Custom Shapes editor.

2. In the Custom Shapes editor, in the Filter tab, enter one or more of the Name, Layer Name or
Search Information parameters to narrow down the number of custom shapes displayed in the
table.

3. Select Refresh to display the new search results.
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To delete custom shapes:

1. From the menu bar select Custom > Shapes to open the Custom Shapes editor.

OR

In the Shape Editor, select the Add Custom Shapes button at the top of the editor to open the
Custom Shapes editor.

2. In the Custom Shapes editor, from the Group drop-down, select the group containing the custom
shape(s) you want to delete.

3. Select the shape you want to delete or press Ctrl and click several shapes if you want to delete
multiple shapes.

4. Go to the Manage tab and select Delete.
5. In the Delete Shapes confirmation dialog, select Yes to delete the selected shape(s).

6. Select Done to close the Custom Shapes editor.
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Custom Maps

Custom maps can be high quality satellite images which have a geo-reference to the world. A geo-
reference means this image has an exact mapping location, so that it can be mapped onto the globe in its
exact position in the world. One of the most used formats is Geo-Tiff.

Each image, mostly large in resolution and size, is calculated and its position in between the 21 map
levels is found. It is also cut into small images and stored in the database with exact location reference
information. This allows for taking only the visible parts of the image.

For information on map setup, see Map Styles, [47

The Custom Maps editor displays all map data sources that contain imported map data or are ready to
import map data.

Creating a Map Data Source

Before importing maps, you will need to create a data source. The data source will use either an Sqlite or
MariaDB database.

The Sqlite database requires no additional program and can be used immediately with XPression Maps.
However, the amount of data that can be stored in such a database is limited. A performance drop in
reading and writing data into the one Sqlite file is the result.

If you plan to import more than 4 GB total of image data, the setup of a MariaDB (MySQL) server is
recommended.

To create a map data source:

1. From the menu bar select Custom > Maps to open the Custom Maps editor.

[ Custom Maps ? X
Satelite Maps | Elevation Maps.
Name Connection
1 Test Map available
2| New Data Source available
New || Edt || Delete | | Import || Create Levels
Done

Custom Maps Editor
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2. In the Custom Maps editor, select New.

The Data Sources editor opens.

B Data Sources ? s

Datasources Editor
3. In the Data Source Name field, enter a unique name.

4. From the Type drop-down, select whether the data source will use an Sqlite file or the mysql
(MariaDB) connection to the server.

o If you select Sqlite, in the Database Details section, select the Browse button (E]) beside the
Data Source File field to navigate to the SQLite file you want to use and click Save. The file will
be created if it does not exist.

Then select OK and continue with Step 5.

B Data Sources 7 X

Datasources Editor - SQLite
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o If you select mysql, in the Database Details section, enter the Server Name, Database Name,
User Name and User Password for the database you want to use, to establish a connection with

the server.

» On this server, a separate database needs to be created and the name of the database entered
into the Database Name field. Creation of the database on the server can be done using the

HeidiSQL program.

» Consult the database manual for how to create an empty database.

Then continue with Step 5.

H Data Sources

Datasources Editor - MySQL (MariaDB)
The default Details for the XPression Maps Database are:
Server Name: localhost
Database Name: name of the database
User Name: your user hame

User Password: your password

5. Select the Test Connection button to open a connection to the database and check if read and write
access exists.

6. If the connection is successful, select OK.
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Importing Map Data

Import and level creation is a process which takes a lot of time depending on how much data is
imported. Ensure that this procedure is performed ahead of time, if possible, and be aware that the
XPression Maps system is busy importing during this time.

To import map data:

1. From the menu bar select Custom > Maps to open the Custom Maps editor.

2. In the Satellite Maps tab, select the data source for the custom map you want to import.

3. Then select Import.

The Map File explorer opens.

=] TC_NG_Baghdad_|Q_Geo.tif
£.2 Dropbox
&« 5] TC_NG_Baghdad_IQ_Geo.tt
@ OneDrive - Ross Video

& ThisPC
[ Desktop
[ Documents
4 Downloads
B Music
=] Pictures
B Videos

PV_Maps

s OS5 (C:)
v

Date modified

¥ Map File
1 > ThisPC » OS(C:) » KPressionMaps » Custom Maps > tc_ng_baghdad_iq_geotiff
Organize *  New folder
Builds A [0 Mame .
& Creative Cloud Files [] TC_NG_Baghdad_|Q_Geo.tfw

v 0 Search te_ng_baghdad_ig_ge.. 0

=~ ™ @

Type Size

TFW File TKE
TIF File 547713 KB
Text Document TKB

File name: ‘ 'C_NG_Baghdad |0 Geo.ti

v‘ Map Files (%)

X

Cancel

Map File Explorer
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4. Select all geo-referenced image files (.tif) needed for the import and select Open.

The Map Import editor opens and the selected image files are listed in the Maps list.

B4 Map Import ? *

Maps:
C:/¥PressionMaps/Custom Maps/tc_ng_baghdad_iq_geotiff/TC_NG_Baghdad_IQ_

q] I [r

Type: | GTiffiGeoTIFF \

Size: |4322v4323 |

Level: | 13 ‘

Tie Progress | 0% \

Totdl Progress | 0% \

[|Create Levels after import Strt || cancel |

Map Import Editor

Below the list, you’'ll see information displayed about the selected image, as follows:
e Type: the data type of the image

e Size: the image size

e Level: the calculated level where the maximal image resolution is reached

o Tile Progress: displays the progress of the imported file.

e If you want the level creation to be started automatically at the end of the import, select the
Create Levels after Import checkbox. See Creating Levels|z6 for details about level creation.

e Total Progress: displays the overall progress of the import

o Create Levels after Import: select this checkbox to automatically start the level creation at the
end of the import.

5. Select Start to begin the import process.

The Map Import confirmation dialog appears when the import is successfully completed.
To display a custom map:

1. From the menu bar select Style > Map Styles and in the Map Style Manager, select Edit to open
the Edit Map Style editor.
2. In the Custom Data section, select the Map checkbox.

3. From the drop-down, select your custom map.
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Creating Levels

In the map data importing procedure, the maps are cut into parts and stored in the database with
information about where in the world each map part is located and the resolution (level) of this map
part.

4 Map Import ? X

Maps:
C:/¥PressionMaps/Custom Maps/tc_ng_baghdad_iq_geotiff/TC_NG_Baghdad_IQ

4] I D

Type: | criffiGeoTIFF |

Size: | a322v4323 |

Level: | 13 |

Tle Progress | 0% \

Total Progress | 0% \

[C)Create Levels after import Start | Cancel

Map Import Editor

In the Map Import editor image above, we can see that the example data will be imported into level
13. This means that we will see the map once we zoom into the location of the imported map in a height
somewhere above street level. Without any level creation, we will only see our imported maps in this
level. The level creation process, started by clicking the Create Levels button in the Custom Maps
editor or by selecting the Create Levels after Import checkbox in the Map Import editor, calculates
map tiles for lower levels out of the imported map tiles.

The next level with higher quality provides four tiles with the same resolution for one tile. This makes the
resolution two times higher in X and Y. For the creation of a tile in the lower levels, we combine four map
tiles to one tile, scale this new tile down to the needed tile size, and write it back into the database for
the lower level.

Once the next lower level (in our example, level 12) is created the process continues with the next lower
level based on the newly generated level, until the top level is generated. This process reads and writes
heavily from and into the database, and the process usually takes longer than the import of the images.
If you plan to import several map regions, wait until all maps are imported before creating the levels.

* If you import more groups of maps, do not select the automatic Create Levels after Import checkbox
before you start the last import.
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Using Custom Maps

Imported custom maps can be activated in an existing Blue Marble Colored or Blue Marble Satellite style.
This means that when the style is used, the custom map is drawn on top.

To use a custom map:

1. From the menu bar select Style > Map Styles and in the Map Style Manager, add a new map
style to assign to your custom map. See To add a new map stylel+" for more information.
Custom maps can only be assigned to map types using the Sphere projection.

2. Select the new map style and select Edit.

3. In the Edit Map Style editor, in the Custom Data section, select the Map checkbox.

4. From the Map drop-down, select which data source to use.

Custom Data
M Map Test Map =

Imported Map Style
5. At the bottom of the Edit Map Style editor, select OK.

The Edit Map Style editor closes and the Map Style Manager reopens. The edited style is
highlighted and the Save icon E= is displayed beside it. If you are editing an existing map style, the
Reset icon 5!' will also be displayed.

6. Select the Save icon = to save your changes into the default database or select the Reset icon EL
to discard your changes and revert to the last saved version of the style.

The Save All button \MJ at the bottom of the dialog box saves all changes made to all styles in
the database.

The Reset All button L #8==t4 | ot the bottom of the dialog box resets all styles in the database to
their last saved version.

7. In the Save Map Style confirmation dialog that opens, select Yes.

8. Select Done to close the Map Style Manager.
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Map Data Configurator

The Map Data Configurator defines which data will be taken from local files (QSQLITE) and which will
be shared through a database server (QMYSQL). The sharing of data is required to combine an instance
of XPression Maps in the graphics department with the XPression Maps server in the machine room
where scenes, drawings, and styles can be created and shared.

The main window of the application provides a list of data sources. It shows the data source type and
indicates if the connection to the data source is available. You can also edit the parameters of each data
source.

SQLite is a database setup where there is a file on the disk and the application can open and browse the
data inside the file in a direct way. But SQLite is limited in parallel user access. Most files inside of the DB
sub-folder are SQLite files.

To get around the limitation of the parallel user access, you can use the MariaDBdatabase server
software. MariaDB can host several databases and can be accessed through the network by multiple
users at the same time in parallel.

XPression Maps users using the Data option must also install the DataLing Server Software so that the
data can be imported.

The following topics are discussed in this section:
Configuring Data Sources| 209

Data Source Sharing[s02

Data Source Description| o3

Dataling Server Software[sd
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Configuring Data Sources

The following sections provide instructions for launching the Map Data Configurator and defining which
data sources will be used by XPression Maps.

If you have upgraded from a previous version of XPression Maps, you will have loaded a new Shape
database. This could mean that some scenes in your projects may have to be modified to accommodate
the new database. If you want to continue using the old Shape database, you can do so by selecting it in
the Data Sources editor in the Map Data Configurator. See To edit a data source[2e9) for more
information.

To launch the Map Data Configurator:

1. Go to C:\XPressionMaps\MapDataConfigurator.
2. Double-click on the MapDataConfigurator.exe file.

The Map Data Configurator opens.

[@] Map Data Configurator [C:\XPressionMaps_3.0/DB/WNMDBInfo3.0.db] - | ®
Name Type Connection Imported Edit &
1 BingMaps QSQLITE available Yes -
2 DrawingFeatures QSQLITE available Yes -
3 CustomShapes QSQLITE available Yes -
4 SceneStyles QSQLITE available Yes -
5 ShapeStyles QSQLITE available Yes -
6 SafeTitle QSQLITE available Yes -
7 OSMLocalData QSQLITE available Yes -
8 HeightMap QSQLITE available Yes -
9 OceanMap QSQLITE available Yes -
10 CustomMaps QSQLITE available Yes -
11 WorldCityNames QSQLITE available Yes -
12 VideoCenfiguration QSQLITE available Yes -
13 BlueMarbleMap QSQLITE available Yes -
14 Shapes QSQLITE available Yes -
15 DisputedBorders QSQLITE available Yes -
16 UserPredefinedObjects QSQLITE available Yes l

Map Data Configurator
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To edit a data source:
1. Open the Map Data Configurator.
2. Select a data source from the list (eg. Select Shapes to change the Shapes Database).

3. In the Edit column, select the corresponding ... button.

The Data Sources editor opens.

[@] Data Sources

Data Source Name: |Shapes

Type: Sqlite
Database Details

Data SourceFile  [PressionMaps_3.0/DE MarldNewsMapperShapeDB_3.0. 1.db | | ...

Test Connection oK Cancel

Data Sources Editor

4. From the Type drop-down, select whether the data source will use the Sqlite file or the MariaDB
connection to the server.
5. Some databases, like the Shape database can only use the SQLite data file.
Alternatively, if you just want to change the Type, you can right-click in the Type column of a
database and select either Set SQlite or Set MariaDB from the context menu.
[@] Map Data Configurator [CA\XPressionMaps_3.0/DB/WNMDEInfo3.0.db] - O x

Main

Mame aan Imported Edit

1 BingMaps O Set MariaDB Yes
& Set SOLite

2 DrawingFeatures Q Yes

3 CustomShapes QSOLITE available Ves

Set Database Type

If you select Sqlite, in the Database Details section, click the Browse button (.- ) beside the

a.
Data Source File field to navigate to the SQLite file you want to use and select Save.

For example, if you are changing to the 3.0 version of the Shape database, you would select the
WorldNewsMapperShapeDB_3.0.1.db SQLite file.

Then select OK and continue with Step 5.
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b. If you select MariaDB, in the Database Details section, enter the Server Name, Database
Name, User Name and User Password for the database you want to use and then continue
with Step 5.

If the XPression Maps Database is installed, the default Database Details are:
Server Name: hostname of the XPression Maps server where the MariaDB database is installed
Database Name: same as the data source
User Name: mapsuser
User Password: wnmdb
The following data types need to be changed to QMYSQL in a configuration with a server:
e DrawingFeatures
e CustomShapes
e SceneStyles
e ShapeStyles
o SafeTitle
e OSMLocalData
e CustomMaps
e UserPredefinedObjects
6. Select the Test Connection button.
a. If the database exists, a confirmation dialog opens indicating that it exists.
Select OK to close the dialog.

b. If the database does not exist, a confirmation dialog will open asking if you want to create the
database and tables in the server.

Select Yes to create the database or No to cancel.

If you select Yes, the Map Data Configurator will create the database and tables, but they will be
empty.

7. Select Import Data.

This step only needs to be done for the first XPression Maps system. Other systems will automatically
use the same data. See Data Source Sharing[s2) for more information.

8. In the SQLite file window, select the database you want to use and select Open.

This step only needs to be done for the first XPression Maps system. Other systems will automatically
use the same data. See Data Source Sharingls2! for more information.

The data from the selected database is copied to the MariaDB database.
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Data Source Sharing

The first XPression Maps system joins the shared data on the server used to import the data. The second
system only needs to connect to the server and use the data.

Data Source Description

The following data sources can be configured in the Map Data Configurator. Only some of the data
sources can be shared, as indicated in the table.

Data Source Description Sharing
BingMaps The map tiles download from Bing N/A
DrawingFeatures All drawing objects Yes
CustomShapes Shapes imported by the user Yes
SceneStyles The map styles Yes
ShapeStyles The styles for the shapes Yes
SafeTitle All Safe Titles generated in the Safe Titles Yes
editor.
OSMLocalData All local changes to the OSM data Yes
HeightMap The Blue Marble height model N/A
OceanMap The ocean overlay data N/A
CustomMaps Maps imported by the user Yes
WorldCityNames Name database for the offline mode N/A
VideoConfiguration Deprecated N/A
BlueMarbleMap The Blue Marble satellite images N/A
Shapes The internal shape database N/A
DisputedBorders All map styles Yes
UserPredefinedObjects Objects imported by the user Yes

Dataling Server Software

XPression Maps users using the Data option will also need to install the DatalLing Server Software
installer from the USB drive in the package shipped with the software.

For information on installing the Datalinqg Server Software see the XPression User Guide.
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HTML5 Client

The XPression Maps HTML5 Client is a web-based control interface that allows you to access, edit,
preview and play scenes that have been created from templates in the XPression Maps database.

The following topics are discussed in this section:
Launching the HTML5 Client/ 302

Using the HTML5 Client/s0)

Playing Saved Scenes in the HTML5 Client[ 3231

Playing Saved Scenes in a Host Application[an
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Launching the HTML5 Client

The XPression Maps main application needs to be running in Server mode in order to use the HTML5
Client. Refer to the instructions below.

To select Server mode:

1. Launch XPression Maps.

2. From the menu bar select File > Preferences > Output, in the Misc section, select the Start in
Server Mode checkbox.

B Preferences

Preferences - Output - Server Mode

3. Select Save and OK.

4. Close and relaunch XPression Maps.

XPression Maps is launched and immediately minimized to the Windows system tray.

5. Continue with the next section to launch the HTML5 Client.
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To launch the HTML5 Client:
1. With the XPression Maps main application running in Server mode, open your browser and in the
address field, enter "computername/maps/” (without the quotation marks).

Instead of “computername” you can also enter the IP address of the computer on which you want to
run the HTML5 Client.

2. Press Enter.

The XPressionMaps HTML5 Client opens.

x +

¢ @

XPression XD

XPression Maps HTML5 Client Application - Login

3. Enter your Username and Password and click Log in.

The HTMLS5 Client Home page is displayed.
# XPression[@3 -

XPression Maps HTML5 Client - Home Page
To return to the main XPression Maps application:

e In the Windows system tray, right-click on the XPression Maps icon and from the context menu,
select Return.
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Using the HTML5 Client

You can use the XPression Maps HTML5 Client to modify a template to create a new scene. You can also
access a scene that has been saved in the HTML5 Client and drag it into a host application to play it
there.

Templates that have been created in the XPression Maps main application are automatically available in
the HTML5 client in the New tab.

Templates that have been modified in the HTML5 Client and saved as scenes, are found in the Saved
tab.

The following topics are discussed in this section:
Selecting a Template or Scenelso

Modifying Templates in the HTML5 Client[ )
Deleting and Duplicating Saved Scenes(zz4

Managing Saved Scene Folders/z3)
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Selecting a Template or Scene
After launching the HTMLS5 client and logging in, you can either select a template and create a new scene

or select a saved scene and edit it.

To select a template or scene:

e In the New tab, select the folder containing the type of map from which you want to create a scene
and in the output window, click on the template you want to use.
OR

¢ In the Saved tab, select the folder containing the scene you want to edit and in the output window,
click on the scene you want to edit.
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Modifying Templates in the HTML5 Client

In the XPression Maps HTML5 Client, you can modify templates that were created in the main
application, to create a new scene. You can change the camera view, convert languages, modify the safe
title area, add, edit or delete labels shapes and drawings and add a flight point.

If the template has an animation, the scene you create from that template will also contain the
animation, but the only animation you can add within the HTMLS5 client is a simple flight from Point A to
Point B.

You can change the language for the text labels and drawings from a list of configured country codes. See
Real-Time Language Support[zsi for information.

The ability to delete a saved scene is one of the privileges that is assigned to a user group. If your group
doesn’t have that privilege, you will not be able to delete a scene.

To modify a template:

1. Select the template you want to edit.
A XPression@™ Salect Scene from: New

New Saved

E ...

o

105 @ 071

. Still Map
[ ]

|05 &

HTMLS5 Client - Select a Template

The template opens on the Search tab.

HTML5 Client Template
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2. Modify the template, as described in the following sections:
Changing the Camera View/[310)
Changing the Languagem
Modifying the Safe Title Arealsifl
Adding, Editing and Deleting Shapes(s:2)
Adding, Editing and Deleting Labels[s1)
Adding, Editing, Deleting and Ordering Drawings| s
Adding a Flight Point/s20)
Downloading a Still Imagel[s2)

3. Save your new scene. See To save a scene 3] for more information.
4. To return to the Home page, click the Home icon m
To save a scene:

1. In the Save tab, in the Name field, enter a name for your scene.

A XPression@@ °

Edit Search Scene Save

Information

Name Austria

/Satelite Maps/Europe

HTML5 Client - Save Scene
2. In the Description field, enter a description of the scene (optional).

3. In the Folder field, click the folder icon at the right of the field and select the folder to which you
want to save the scene.

You can only save into an existing folder. Creating new folders is an Administrator privilege.

Once you've saved a scene the first time, the folder will be selected automatically if you edit the
scene and save it again.

4. Then select the Save - icon.

Once a scene has been saved, the Media ID icon becomes active and you can drag it into a host
project such as XPression, to play.

For more information, see Playing Saved Scenes in a Host Application[ sz,
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Changing the Camera View

In the XPression Maps HTML5 Client you can change the camera view of the scene in the template.
To change the camera view:

1. Select the template or scene you want to edit.

2. In the Scene tab, in the Camera section, adjust the Longitude, Latitude, Tilt, Roll and Zoom
Level as desired.

Changing the Language of a Scene

In the XPression Maps HTML5 Client you can change the language of a scene from a predefined list of
translation country codes.

To change the language of a scene:

1. Select the scene you want to edit.

2. Click on the hamburger stack and select Duplicate Scene.
A duplicate of the scene opens.

3. In the Scene tab, in the Language section, select a language from the drop-down.
The language in the output window will update.

4. Languages are populated from a predefined list of translation codes in the XPression Maps installation
files. See Configuring Languages/(2s1 for information on translation codes.

5. In the Save tab, in the Information section, update the name of the map to reflect the language
change. For ex. Europe English.

6. Click the folder button to select a location to save the updated template.
7. Press the Save button.
8. The scene with the updated language will be displayed from the Saved Templates window.

The scene with the new language change will be displayed from the Saved Templates window
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Modifying the Safe Title Area

The Safe Title Area is the area inside the output window defined by the white rectangles. Content inside
this area will be fully visible on air. The Safe Title Area is defined in the main application but you can
decide whether or not to use it in the HTMLS5 Client. You can also select the style of the safe title area.

To modify the Safe Title Area:

1. Select the template or scene you want to edit.
2. In the Scene tab, in the Safe Title area, do one of the following:
a. Select the checkbox to use the configured safe title area.
OR
b. Deselect the checkbox to use the entire Output Window.
3. From the Style drop-down, select how the safe title area should be displayed.
The options are:

e Fullscreen — the map credits appear in the bottom corners of the scene

e OTS (Over the shoulder) — the map credits appear centered in the scene
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Adding, Editing and Deleting Shapes

In the XPression Maps HTML5 Client, you can add a shape for any location that exists in the shape
database. You can also change the shape that has been applied to the location, to any shape that has
been added to the Shapes tab for the original template in the main application.

To add a shape:

1. Select the template or scene to which you want to add a shape.

2. In the Search tab, enter the location for which you want to add a shape and select the Search icon
or press Enter.

3. In the Shapes section, click on the location for which you want to add a shape and then click the +
sign to the right of the location to add the default shape to the scene.

The new shape appears on the map. The shape appears at the Zoom level set in the shape style, so
you may have to zoom in or out (using the scroll wheel on your mouse) in order to see the new
shape.

A XPressionl@® °

Search Edit Predefined Scene Save

Location
Canada Q

Result v

> 8 Canada
Locality:
District:
Country: Canada
Type: CountryRegion

> Canada, Mexico

o
8 Canada, Hampshire, United Kingdom

>
> 8 Canada, Durham, United Kingdom
>

#. Canada Morelos Municipality

HTML5 Client - Select Shape

4. Save your new scene. See To save a scene s8] for more information.
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To edit a shape:

1. Select the template or scene you want to edit.
2. In the output window, click on the shape.
3. In the Edit tab, from the Style drop-down, select a different shape style.

A XPression[I@® °

Search Edit Predefined Scene Save

Shape

Name Canada
Action 'ﬁ
Opacity 1.00000

Style Highlight Abbv

HTML5 Client - Edit Shape

4. In the Opacity field, enter a value or use the up and down arrows to change the transparency of the
shape.

5. Save your new scene. See To save a scenelaw! for more information.
To delete a shape:

1. Select the template or scene you want to edit.
2. In the output window, select the shape you want to delete.

3. In the Edit tab, select the Delete Shape button.

A XPression@d °

Search Edit Predefined Scene Save

Shape
Name Canada

Action [11]

Opacity 1.00000

Style Highlight Abbv

HTML5 Client - Delete Shape Button

Alternatively, with the shape selected, press the Delete key.
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Adding, Editing and Deleting Labels

In the XPression Maps HTML5 Client, you can add a label anywhere in the scene. The labels that can be
added are those that have been added to the Location Labels tab for the original template in the main
application.

You can also set a default label which will be added automatically by clicking the + sign beside the
location in the Result section and override a default label in the current scene only.

To add a label:

1. Select the template or scene to which you want to add a label.
2. In the Search tab, in the Location field, enter the location to which you want to add a label.
3. Click on the arrow beside the XPression Maps title to open the Label and Drawing menus.
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HTMLS5 Client - Labels and Drawings Menus

4. From the Labels list, click on the label style you want to use and drag it to the desired location.

The label appears at the Zoom level set in the label style, so you may have to zoom in or out (using
the scroll wheel on your mouse) in order to see the new label.

Alternatively, you can set a default label style to use in any scene in the current folder. See To add a
default labell sl for more information.

To add a default label:

=

Select the template or scene to which you want to add a label.

2. In the Search tab, in the Location field, enter the location to which you want to add a label.
3. Click on the arrow beside the XPression Maps title to open the Label and Drawing menus.
4

. Then click on the three dots in the top-right corner of the label you want to use and click Set
Default.

Label Drawing

Set Default

B: City Name

HTMLS5 Client - Set Default Drawing

314 « HTMLS5 Client XPression Maps User Guide (v3.4)



5. In the Result section, click the + sign beside the location for which you want to add a label.

The label is inserted in the correct location on the map, with the Locality name. This label style will
be used by default for all scenes in the current folder.

To override a default label:

e Click on a different label style and drag it on top of the default label, to change only that instance of
the label.

In other scenes in the same folder, the default label will remain the same.
To edit a label:

1. Select the template or scene you want to edit.
2. In the Output Window, select the label you want to edit.

3. In the Edit tab, in the Drawing section, adjust the following properties as necessary.

Property Description

Action Place the label on top of or behind other text in the scene or
delete the label

Zoom Enter a value or use the arrows to adjust the size of the label
in relation to the map.

Longitude, Latitude Enter a value or use the arrows to adjust the position of the

and Rotation label.

GPS The GPS coordinates of the label.

Size Enter a value or use the arrows to adjust the absolute size of
the label.

Frontface Select to have the front side of the label face the camera.

You can also toggle this parameter in the output window by

2
clicking the Frontface icon ( ¥s ) at the bottom of the label’s
bounding box.

Auto Zoom Select to have the label stay the same size, regardless of the
Zoom Level.

Visible Select if you want the label to be visible or deselect to hide the
label.

4. In the Text section, you can change the text of the label if you want.

5. When you've finished modifying the label, save your new scene. See To save a scene[3d) for more
information.
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To delete a label:

1. Select the template you want to edit.

2. In the output window, select the label you want to delete.

3. In the Edit tab, select the Delete Drawing button.

HTML5 Client - Delete Drawing Button

Alternatively, with the label selected, press the Delete key.
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Adding, Editing, Deleting and Ordering Drawings

You can add drawings to your scenes, providing the drawings have been added to the Drawings tab of
the template group that contains your template. You can also delete and edit drawings and change their
order, putting one in front of another. For more information, see Adding Drawings.[ 711

B4 Scene Templates ? x
Group IDJsbom Maps 'J E]
Scenes | Locationlabek | Drawnos | Shape Styles |
Name Type || ~Details
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Nevr Text Region Text Text |
Mew Text pegion Text with Callout | Text
New Line Line
A
= Airplane Icon
;l ¥ Checkered Flag Icon
F Green Flag Icon
White Labels Text Order Priority |0 |~
[ tpate |

Scene Templates - Drawings Tab
To add a drawing:

1. Select the template or scene to which you want to add a drawing.

2. Select the arrow beside the XPression Maps logo to open the Label and Drawing lists and select the
Drawing tab.

# XPressionEED < "

Search Edit Predefined Scene Save .
¥
Language Q/
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: Convertible
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Download | 4
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Style Full Screen

HTMLS5 Client - Drawing List

3. In the Drawing list, select the drawing that you want to add to the scene and then click on the map
where you want to place the drawing.

For Line and Area drawings, click and drag the mouse on the map until the line or area is complete.
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To edit a drawing:

1. Select the scene you want to edit.
2. Select the drawing you want to edit.

3. In the Edit tab, in the Drawing section, adjust the following properties as required.

Property Description

Action Place the drawing on top of or behind other drawings in the scene or delete
the drawing.

Zoom Enter a value or use the arrows to adjust the size of the drawing in relation to
the map.

Longitude, Enter a value or use the arrows to adjust the position of the drawing.

Latitude and

Rotation

GPS The GPS coordinates of the drawing.

Size Enter a value or use the arrows to adjust the absolute size of the drawing.

Frontface Select to have the front side of the drawing face the camera.

You can also toggle this parameter in the output window by clicking the
2]
Frontface icon ( ¥s ) at the bottom of the drawing’s bounding box.

Auto Zoom When checked, the drawing remains the same size in pixels, while the
camera animates through the different zoom levels.

When unchecked, the drawing increases or decreases in size as the camera
animates through the different zoom levels.

Visible Select if you want the drawing to be visible.
Texture Applies to line drawings and area drawings that have an image or pattern.

Scale — Multiplies the scale of the drawing. For example, a line drawing of a
road with a scale of 1, will be a single 2-lane road, while a road with a scale
of 2 will be a 4-lane road.

Rotation — Increases the rotation of the drawing, making it appear spiraled.

Aspect — Increases or decreases the width of the drawing, relative to the
height.

o If the value is less than 1, the width (X) decreases relative to the height
(Y).
o If the value is greater than 1, the width increases relative to the height.
Point Applies to area drawings only.

Index — identifies each point in the drawing based on the order in which it
was added. The selected point turns red.

Longitude — Enter a value or use the arrow to adjust the longitudinal
position of the selected Index point.

Latitude — Enter a value or use the arrow to adjust the latitudinal position of
the selected Index point.

Progress Applies to line drawings only.

Visualizes the progression of the line being drawn on the map. Use the up and
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Property Description

down arrows to view the placement of the drawing at different intervals.

4. When you've finished modifying the drawing, save your new scene. See To save a scene a0 for more
information.

To replace a drawing:

1. Select the scene you want to edit.
2. From the Drawings list, click on a different drawing of the same type (line, area, text, etc.) and
drag it on top of the drawing you want to replace.

To set a default text drawing:

1. Select the scene you want to edit.

2. From the Drawings list, click on the text drawing you want to set as a default for all scenes in the
current folder.

3. Then click on the three dots in the top-right corner of the text drawing you want to use and select Set
Default.

To delete a drawing:

1. Open the scene from which you want to delete a drawing.
2. Click on the drawing you want to delete to select it

3. In the Edit tab, select the Delete Drawing button.

HTML5 Cient - Delete Drawing Button

Alternatively, you can click on the drawing you want to delete and then press the Delete key.
To order drawings:

1. Open the scene in which you want to reorder the drawings.
2. Select the drawing you want to move.

3. In the Edit tab, click the Move Drawing to Front button to move the drawing to the front.

HTML5 Client - Move Drawing to Front Button
OR

Click the Move Drawing to Back button to move the drawing to the back.

HTML5 Client - Move Drawing to Back Button
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Adding a Flight Point

Start and Stop flight points are automatically added to each template if none exist. You can add one
additional flight point in the XPression Maps HTMLS5 client to create a flight animation. If you add more
than one additional flight point, only the last one added will be kept. The flight is calculated automatically
between the initial flight point, stored inside of the template, and the ending location selected by the user
in the client application.

To add a flight point:

1. In the Home screen, from the New tab, select the group that contains the template you want to use
for your scene.

2. In the Select Scene from: pane, select the template to modify.

HTML5 Client - Select a Template
The template opens on the Search tab.
3. In the Search field, enter the location where you want to add the flight point.

4. In the Scene tab, use the Zoom Level parameter to adjust the zoom level of the map at that
location.

Alternatively, you can scroll the mouse wheel to adjust the zoom level.

5. Then, in the Control section, select the Add Flight Point button.

A XPression®@D ¢
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HTML5 Client - Add Flight Point
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6. Select the Preview icon to play the animation.

A XPression[E@y ¢
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HTMLS5 Client - Preview

7. If no further edits are required, in the Save tab, save your new scene. See To save a scenelzos! for
more information.
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Downloading a Still Image

You can download a still image of any scene if desired.

To download a still:

1. Select the scene you want to save as a still image.

2. In the Scene tab, from the Type drop-down, select Still.

A XPression®@ ¢
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HTMLS5 Client - Select Still

3. Then select the Preview button.

4. In the bottom-right corner of the scene, click the Download button.

st

e 3 "
5’

s

> bir

HTML5 Client - Download Still
The Opening PNG dialog appears.
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5. Select Save File in the Opening PNG dialog and navigate to the location where you want to save
the still image.

6. Give the still image a name and select Save.

Playing Saved Scenes in the HTML5 Client

Any template that has been added to the Scene Templates feature in the XPression Maps main
application is automatically available in the HTMLS5 client.

To play a saved scene:

1. Launch the XPression Maps HTML5 Client.
See Launching the HTMLS5 Client[s0d) for more information.

2. Select the Saved tab and open the folder containing the scene you want to play.

# XPression@D

Saved

HTMLS5 Client - Select Saved Scene
3. In the Scenes pane, click on the scene you want to play.

4. In the Scene tab, select Preview.

XPression Maps User Guide (v3.4) HTMLS5 Client « 323



Deleting and Duplicating Saved Scenes

Only users with the Delete Saved Scenes privilege can delete a scene, but anyone can duplicate a
scene.

To delete a scene:
1. In the Home screen, from the Saved tab, select the group that contains the scene you want to
delete.

The group expands to display subgroups, if there are any.

2. In the Select Scene from: Saved panel, in the top-right corner of the scene, move the cursor over
the 3 dots and select Delete Scene.

T B: San Fran
ﬂ o .. Duplicate Scene

Delete Scene
John

B:10s @03/

HTMLS5 Client - Delete Scene

3. In the confirmation dialog that opens, select Yes to delete the scene.

To duplicate a scene:

1. In the Home screen, from the Saved tab, select the folder that contains the scene you want to
duplicate.

The group expands to display subfolders, if there are any.

2. In the Select Scene from: Saved panel, in the top-right corner of the scene, move the cursor over
the 3 dots and select Duplicate Scene.

Duplicate Scene

Delete Scene

The scene is opened for editing.
Make any needed changes to the scene.
Then, in the Save tab, enter a new name for the scene.

Select the Folder icon to select a folder to which to save the scene.

o u s W

Select the Save icon.
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Managing Saved Scene Folders

User who have been assigned the privilege of Managing Saved Scene Folders can add, delete and
rename folders and sub-folders.

To add a folder:

1. In the Saved tab, select the Add New Folder icon.

+ B o f

HTML5 Client - Add New Folder Icon

2. In the New Folder dialog, enter a name for the folder and then select OK.

New Folder

Name | Folder Name

Cancel 0K

HTMLS5 Client - Add New Folder
To add a sub-folder:

1. In the Saved tab, select the folder to which you want to add a sub-folder.

2. Then select the Add New Sub-Folder icon.

+ B o f

HTMLS5 Client - Add New Sub-Folder Icon

3. In the New Sub-Folder dialog, enter a name for the sub-folder and then select OK.

New Folder

Name | Folder Name

Cancel 0K

HTMLS5 Client - Add New Sub-Folder
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To delete a folder:

1. In the Saved tab, select the folder or sub-folder you want to delete and select the Delete Folder
icon.

HTMLS5 Client - Delete Folder Icon

2. In the Delete Folder dialog, select the checkbox to confirm that you want to delete the folder and all
its contents and then select Delete.

Delete Folder ®

Do you want to delete the actual folder [Folder Namel], all its sub folders and all saved scenes?

Confirm the delete with this checkbox!

Cancel Delete

HTMLS5 Client - Delete Folder
To rename a folder:

1. In the Saved tab, select the folder you want to rename and select the Rename Folder icon.

HTMLS5 Client - Rename Folder icon

2. In the Change Folder Name dialog, enter a new name for the folder and then select OK.

Change Folder Name

Name | Custom Maps

Cancel oK

HTML5 Client - Change Folder Name
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Playing Saved Scenes in a Host Application

Saved scenes created in the XPression Maps HTML5 Client application can be dragged into projects in
host applications such as XPression Studio.

You'll also need to configure the host application, as described below. The instructions provided are for
configuring an XPression rendering engine, but the same process (or something similar) will need to be
done for any rendering or preview engine on which you want to run your XPression Maps HTML5 Client
scene.

To configure a host application:

1. In XPression, select Edit > OpenMAM Setup.

The OpenMAM Setup dialog opens.

OpenMAM Setup X

Configurs.., Dalt=,,

XPression OpenMAM Setup Dialog
2. Select Add.
The Add OpenMAM Server dialog opens.

Add OpenMAM Server *

Add OpenMAM Server Dialog
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3. Select the XPression Maps option and select OK.

The XPression Maps Server dialog opens.

XPression Maps Server *

~ Server ID

D: [192.168.0.11

Description: [XPression Maps Server

~ Connection Settings

Server URL: [192.168.0.11|

Plugin App: [c:‘l,!PressionMapsWebCIient\,!PressionMapswebdier]

XPression Maps Server Dialog

4. In the Server ID section, in the ID field, enter the name of the server that is running XPression
Maps.

You can find this address in the XPression Maps main application in File > Preferences > Web
Interface, in the Web Template Database section, in the Hostname field. Do not include http://
or anything after .rossvideo.com.

5. In the Description field, enter a user-readable name, for example, XPression Maps Server to
identify the server.

6. In the Connection Settings section, in the Server URL field, enter the same information as in the
Server ID field.

7. In the Plugin App field, enter the path to the XPression Maps HTML5 Client application
executable file.

Typically this path is C:\XPressionMapsWebClient\XPressionMapswebclient.exe.
8. Then select OK and in the OpenMAM Setup dialog, click OK again.

To drag a scene into a host application:

1. Open a project in the host application (XPression Studio, for example) and add a new blank scene.
2. Launch the XPression Maps HTML5 Client application.

3. In the HTML5 Client application, from the Saved tab, navigate to the scene you want to bring into
the host application.

The scene must be saved before you drag it into the host application.
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4. Select the scene and in the Save tab, click and hold the mouse button down on the Media ID icon
and drag the cursor into the XPression scene.

A XPressionl@d ¢

Search Edit Predefined Scene Save

Information

United States White House

/Political (Grey Design)

Flesliexll

Drag scene here

[ seoong s | sps oo | Sow | aapaues s | wormuy atoms| Adems e

St Scre G

Menu Bar of Viewport in XPression Studio

The Asset Transfer progress dialog appears and closes when the transfer is complete.

XPression Asset Transfer...

Asset Transfer Progress Dialog
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Alternatively, with the HTML5 Plugin open in your news room system, you can just drag a saved
map straight from the HTML5 Client into the Object/Field Content section in the plugin, as shown
below:

Dragging into the HTML5 Plugin

The map appears in the Preview pane of the HTML5 Plugin and the video can be viewed.

XPression ®rowse Graphics Lucid Clins  View Edit OpenMAM:  Maps - PVXPN-rossvideo.com

two maps with label

G CHANNELT  ~ Layer: 0 (middic) -1 Two Maps

Content

B EN seect

>+

Spelicheck

Map Added to the HTML5 Plugin
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User Management

XPression Maps supports the management of user accounts and privileges for the XPression Maps
HTMLS5 Client and XPression Maps Touch Client. A drop-down menu in the top-right corner of both
clients allows an administrator or superuser to add or delete users, assign them to user groups and edit
their account information.

This menu is also used to log out of the client.

Any user can use this feature to change their account password.

Administrator

Account

Mew User

Manage Users
Web User Groups
Touch User Groups

Log Out

User Management Menu (Administrator and Superuser)

¥

Ross Smith

« Account

« LogOut

User Management Menu (All Other Users)

The following topics are discussed in this section:
Managing Users| a3

Managing Groups| )

Changing your Password| s
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Managing Users

There are a number of operations that the administrator can perform, as follows:
Adding users and assigning them to groupslas)

Deleting users|as

Editing user details[as2

To add a user:

1. From the User Management Menu, select New User.

The New User form opens.

New User

Please fillin all the required fields to create a new user account.

Username Talent

ssssssss

First Name

Last Name

Is Administrator Wl

Web Client Group: Journalist

Touch Group: Journalist

E-Mail isv2000@gmail.com

Phone Number 555-555-5555

Submit Cancel

User Management - New User Form
Enter the Username, Password, First Name and Last Name of the new user.
If the user will be an administrator, select the Is Administrator checkbox.

From the Web Client Group drop-down, assign the user to a user group.

u oA LN

For more information on user privileges, see Managing Groups| ).
The user groups and default privileges are:
e Artist — Delete Saved Scenes

Journalist — None

Producer — Manage Saved Folders / Delete Saved Scenes

Production — None

Superuser — Manage Saved Folders / Delete Saved Scenes
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6. Similarly, from the Touch Group drop-down, assign the user to a user group.
The user groups and default privileges are:
o Artist — All Users Scenes / Change Home / Load Scene
¢ Journalist — Change Home / Load Scene
e Producer — All Users Scenes / Change Home / Load Scene / Use Controls
e Production — All Users Scenes / Change Home / Load Scene
e Superuser — All Users Scenes / Change Home / Load Scene / Use Controls
7. In the E-Mail field, enter an e-mail address for the user (required).
8. In the Phone Number field, enter a phone number for the user (optional).

9. Select Submit to add the user.
To delete a user:

1. From the User Management Menu, select Manage Users.

The Manage Users screen is displayed.

User Management - Manage Users
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2. In the Users list, select the user you want to delete.

The Details panel is populated with the user’s information.

Manage U

Details

Update Delate User

User Management - User Details
3. In the Details panel, select Delete User.

A confirmation dialog opens.

Are you sure you wish to delete this user?

Cancel

Web and Touch Client - Delete User Confirmation
4. Select OK.

5. Select Exit to close the Manage Users screen.
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To edit user details:
1. From the User Management Menu, select Manage Users.

The Manage Users screen is displayed.

User Management - Manage Users
2. From the Users list, select the user whose information you want to edit.

The Details panel is populated with the user’s information.

Manage Us

User Management - User Details

3. Edit the user details as necessary and select Update.
A message appears above the Update button, indicating that the update was successful.

4. Select Exit to close the Manage Users screen.
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Managing Groups

Users can be assigned to Web User Groups or Touch User Groups or both. Within those groups, they
can be further assigned to one of a number of sub-groups:

A sub-group of users can have the right to manage scene folders and/or delete saved scenes, as
determined by the administrator.

To edit user groups:

1. From the User Management Menu, select Web User Groups or Touch User Groups.

The Manage User Groups screen for that group is displayed.

Manage Touch User Groups

Group

User Management - Manage User Groups
2. Select the sub-group you want to edit.

The Details panel is populated with the group’s details.

User Management - User Group Details
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3. In the Details panel, select or deselect the check boxes to assign privileges to the group.
In the Web User Groups, the options are:

¢ Manage Saved Folders — the user will be able to add and delete Group folders and Sub-folders
and edit the folder names.

o Delete Saved Scenes — the user will be able to delete scenes from the Saved tab.
In the Touch User Groups, the options are:

e All Users Scenes — The user can load scenes created by anyone. If this option is unchecked, the
user will only be able to load scenes they’ve created themselves.

e Change Home — The user can change the location of the Home Position scene by manipulating
the globe.

e Load Scene — The user can load a saved scene.

e Use Controls — The user can use the playout controls to manage the scene animation. If this
option is unchecked, the Control tab is removed.

4. Select Update to save your changes.

5. Select Exit to close the Manage Web User Groups or Manage Touch User Groups screen.
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Changing your Password

Any user can change their own password.

To change your password:

1. From the User Management Menu, select Account.

The User Details screen opens.

User Details

Username John

First Name John

Last Name Smith

Is Administrator [l
Web Client Group: Production
Touch Group: Production
E-Mail J.Smith@company.com

Phone Number 555-555-5555

Change Password

Old Password

New Password

Repeat vord

Save

HTML5 and Touch Client - Change Password

2. In the Change Password section, enter your current password and then enter your new password

twice.

3. Select Save and then click Exit to close the User Details screen.
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Appendix A: Keyboard Shortcuts

Shortcuts for the following menus and windows are included in this section:

File Menu Shortcuts/ a3

Edit Menu Shortcuts| )

Output Window Shortcuts|zd)
Animation Menu Shortcuts| a1

Output Window Shortcuts|ad)

File Menu Shortcuts

Command

New

Open

Save

Save As

Export

Open Recent Used

Exit

Shortcut
CTRL+N
CTRL+O
CTRL+S
CTRL+SHIFT+S
CTRL+E
CTRL+0...4

CTRL+Q
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Edit Menu Shortcuts

Command Shortcut

Undo CTRL+Z

Redo CTRL+Y

Copy Drawing CTRL+C

Cut Drawing CTRL+X

Paste Drawing CTRL+V

Move Drawing to Top CTRL+Page Up
Move Drawing Up CTRL+Up

Move Drawing Down CTRL+Down
Move Drawing to Bottom CTRL+Page Down

Next Animation Key Frame CTRL+Right Arrow

Previous Animation Key CTRL+Left Arrow
Frame

Add Camera Key Frame CTRL+,

Add Drawing Key Frame CTRL+.

Delete Selected Key Frames  CTRL+D

Output Window Shortcuts

Command Shortcut
Snapshot CTRL+P
Record Animation CTRL+R
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Animation Menu Shortcuts

Command

Rewind Animation
Play Animation
Continue Animation
Stop Animation

Forward Animation

Shortcut
CTRL+B
CTRL+Space Bar
CTRL+G
CTRL+H

CTRL+M
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Output Window Shortcuts

Command
Toggle Framerate Display

Select Previous Point (shape,
area object, or line object)

Select Next Point (shape,
area object, or line object)

Delete drawing or point
(shape, area drawing, line
drawing)

To enter Full Screen Mode

Shortcut
F

Left Arrow

Right Arrow

Delete

F1
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Appendix B: Managing Network
Security

Secure Sockets Layer (SSL) protocol protects sensitive information as it travels across computer
networks. It provides privacy, critical security and data integrity.

This section describes how to enable the SSL protocol in XPression Maps.
An SSL certificate must be purchased and installed on the XPression Maps Gateway and in the

XPression Maps application. Purchase an SSL certificate from a trusted root authority (our certificates
are purchased from DigiCert, so these instructions will use the steps for DigiCert as an example).

Buying an SSL Certificate

To purchase an SSL certificate, a CSR file must be generated and sent to the certificate authority. The
CSR file describes the server machine that will hold the certificate as well as your Company and
Organization details.

The CSR can usually be generated using a tool provided by the certificate authority (or they will provide
documentation on how to generate the CSR).

Installing the SSL Certificate

The certificate authority will provide you with the SSL certificate files.

Once the certificates have been installed, they must be configured and bound to the ports used by the
XPression Maps Gateway and the XPression Maps application.

To install the certificates:

e Copy the Security Certificate (.crt) and the KEY file (.key) into the following locations:
» C:\XPressionMaps_3.x\bin64\certs

» C:\XPressionMapsGateway\certs
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To configure the Maps Gateway:

1. Navigate to C:\XPressionMapsGateway\bin64\ and double-click the
MapsGatewayConfig.xml file.

| *MapsGatewayConfig.xml - Notepad - a x

File Edit Format View Help
<configs>
l<l-- To enable SSL set SSL to "1" and the <HttpServer Port="80" to Port="443" __> |
<Main ApplicationFolder="C:\XpressionMapsGateway"” LogFileName="/log/Main.log” Loglevel="Error"|55L=
HostName="L-O0TTIHUGHESL. rossvideo.com” DocumentFolder="/htdocs"
ResourcePrefix="/clips” PreviewClipShare="Z:/preview” DebugCommunication="false" >
<MapController DBHostMName="L-OTTIHUGHES1.rossvideo.com” DBPort="3386" DEUser="mapuser”
DBPassword="wnmdb" AppWSPort="9977" FullResClipShare="C:\XpressionMapsGateway/clips" »
<Interactive DBHostName="L-OTTIHUGHES1.rossvideo.com” DBPort="3386" DBUser="mapuser™
DBPassword="wnmdb"” />
</MapController>/>
<!-- set AutologoutMin to the minutes when auto logout will happen or te "8" to disable auto logout -->
<UserController DBHostName="L-OTTIHUGHES1.rossvideo.com” DBPort="3386" DBUser="mapuser”
DBPassword="wnmdb” AutologoutMin="9" />
</HttpServer>
</config> I

Ln 11, Col 11 100%  Windows (CRLF) UTF-8

MapsGatewayConfig.xm/
2. In the editor, change the SSL value to 1 and the HttpServer Port to 443.
3. Select File > Save.

4. Open the Windows Computer Management application and from Services and Applications,
select Services > Maps Gateway Service.

&Y Computer Management — [m] x
File Action View Help
e pm EDE= HE » a0
5 gomputerManagement (Local) <\ Semvices Actions
v [f} System Tools ~ .
(@) Task Scheduler Maps Gateway Service Name Description  Status ~ | Services =
@ Event Viewer LhLanguage Experience Service  Provides inf... More... ¥
Shared Fold Stap the service &k Link-Layer Topology Discov... Createsa N,
] Shared Folders Pauce the service o Maps Gate.. «
#% Local Users and Groups ‘& Local Profile Assistant Service  This service ...
(&) Performance cal Session Manager Core Windo... Running Mere... F
& Device Manager o aps Gateway Service The Maps G... Running
p escription:

v 3 Storage G MessagingService 118606 Service sup...

= Disk Management

The Maps Gateway Service is
providing the web client application 4 Microsoft (R) Diagnostics H... Diagnostics ...
Services and Applications and controlls the access to themaps G} Microsoft Account Sign-in .. Enables use..,
server 16 Microsaft App-V Client Manages A...
WMI Control {8 Micrasoft iSCSl Initiator Ser...  Manages In...
L Microsoft Office Click-to-R.. Manages re..  Running
{6} Microsoft Passport Provides pr...

v

£ Microsoft Passport Container Manages lo...
ChMicrosoft Search in Bing Aserviceto.. Running
1 Microsoft Software Shadow... Manages so...

1) Microsoft Storage Spaces S...  Host service...
<

~
v

" Bxtended 4 Standard

Maps Gateway Service

5. In the Services pane, click Restart the service.
To configure XPression Maps:

1. Launch the XPression Maps application.
Go to File > Preferences > Web Interface.

In the Web Server Details section, select the SSL checkbox.

In the Web Gateway section, change the UI Port from 80 to 443.

v A W N

Select OK and relaunch the application.
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Appendix C: Third Party Licenses

XPression Maps uses software covered by one or more of the licenses described below:

As required by the GNU General Public License, and the Lesser GNU Public License (LGPL), source code

can be obtained from Ross Video for at least 3 years. Contact Ross Video Technical Support for more

information.

Name
Earcut
ffmpeg
FreeImage

FreeType

GDAL/OGR
GStreamer
GTS
ImageMagick
Libav
Noto-emoji
ProtoZero

Vector Tile

Version
0.12.4
3.3.3
1.0

1.0

1.5.2
1.0.1

License

ISC Licensels#)

ffmpeg License /s

FreeImage Public License /3501
FreeType Project License

FreeType Font Engine License/ss3)
GDAL/OGR License/[3s)

GNU Library General Public License/ss2)
GNU Library General Public License/zss)
GNU Library General Public License/s74)
GNU Lesser General Public License[s78)
Apache License 2.0z

Apache License 2.0[3s3)

Copyright[ss
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Earcut License

Copyright (c) 2015, Mapbox

Permission to use, copy, modify, and/or distribute this software for any purpose with or without fee is
hereby granted, provided that the above copyright notice and this permission notice appear in all copies.

THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES WITH REGARD
TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO
EVENT SHALL THE AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL
DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS,
WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
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ffmpeg License

Most files in FFmpeg are under the GNU Lesser General Public License version 2.1 or later (LGPL v2.1+).
Read the file "COPYING.LGPLv2.1" for details. Some other files have MIT/X11/BSD-style licenses. In

combination the LGPL v2.1+ applies to FFmpeg.

Some optional parts of FFmpeg are licensed under the GNU General Public License version 2 or later (GPL
v2+). See the file "COPYING.GPLv2" for details. None of these parts are used by default, you have to
explicitly pass "--enable-gpl” to configure to activate them. In this case, FFmpeg's license changes to

GPL v2+.

Specifically, the GPL parts of FFmpeg are:

- libpostproc
- optional x86 optimization in the files
- "libavcodec/x86/flac_dsp_gpl.asm"

- 'libavcodec/x86/idct_mmx.c’

- "libavfilter/x86/vf_removegrain.asm’

- the following building and testing tools
- "compat/solaris/make_sunver.pl’
- “doc/t2h.pm’
- “doc/texi2pod.pl”
- "libswresample/swresample-test.c’
- “tests/checkasm/*’
- “tests/tiny_ssim.c’
- the following filters in libavfilter:
- “vf_blackframe.c’
- “vf_boxblur.c’
- "vf_colormatrix.c’
- “vf_cover_rect.c’
- “vf_cropdetect.c’
- “vf_delogo.c’
- "vf_eq.c’
- “vf_find_rect.c’
- “vf_fspp.c’
- "vf_geq.c’
- “vf_histeq.c’

- “vf_hqgdn3d.c’
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- “vf_interlace.c”

- “vf_kerndeint.c’

- "vf_mcdeint.c’

- "vf_mpdecimate.c’

- "vf_owdenoise.c’

- “vf_perspective.c’

- "vf_phase.c’

- "vf_pp.c’

- “vf_pp7.c’

- “vf_pullup.c’

- "vf_repeatfields.c’

- "vf_sab.c’

- “vf_smartblur.c’

- “vf_spp.c’

- "vf_stereo3d.c’

- “vf_super2xsai.c’

- “vf_tinterlace.c’

- “vf_uspp.c’

- “vsrc_mptestsrc.c’
Should you, for whatever reason, prefer to use version 3 of the (L)GPL, then the configure parameter " --
enable-version3" will activate this licensing option for you. Read the file *COPYING.LGPLv3" or, if you
have enabled GPL parts, COPYING.GPLv3" to learn the exact legal terms that apply in this case.
There are a handful of files under other licensing terms, namely:
e The files "libavcodec/jfdctfst.c”, "libavcodec/jfdctint_template.c’ and "libavcodec/jrevdct.c’ are taken

from libjpeg, see the top of the files for licensing details. Specifically note that you must credit the 1JG
in the documentation accompanying your program if you only distribute executables.

You must also indicate any changes including additions and deletions to those three files in the
documentation.

e tests/reference.pnm’ is under the expat license.

External libraries

FFmpeg can be combined with a number of external libraries, which sometimes affect the licensing of
binaries resulting from the combination.

Compatible libraries
The following libraries are under GPL:

- freiOr
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- libcdio

- librubberband
- libvidstab

- libx264

- libx265

- libxavs

- libxvid

When combining them with FFmpeg, FFmpeg needs to be licensed as GPL as well by passing " --enable-
gpl® to configure.

The OpenCORE and VisualOn libraries are under the Apache License 2.0. That license is incompatible with
the LGPL v2.1 and the GPL v2, but not with version 3 of those licenses. So to combine these libraries with
FFmpeg, the license version needs to be upgraded by passing "--enable-version3" to configure.

Incompatible libraries

There are certain libraries you can combine with FFmpeg whose licenses are not compatible with the GPL
and/or the LGPL. If you wish to enable these libraries, even in circumstances that their license may be
incompatible, pass *--enable-nonfree” to configure. But note that if you enable any of these libraries the
resulting binary will be under a complex license mix that is more restrictive than the LGPL and that may
result in additional obligations.

It is possible that these restrictions cause the resulting binary to be unredistributable.

The Fraunhofer FDK AAC and OpenSSL libraries are under licenses which are incompatible with the GPLv2
and v3. To the best of our knowledge, they are compatible with the LGPL.

The NVENC library, while its header file is licensed under the compatible MIT license, requires a
proprietary binary blob at run time, and is deemed to be incompatible with the GPL. We are not certain if
it is compatible with the LGPL, but we require ' --enable-nonfree’ even with LGPL configurations in case
it is not.
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Freelmage License

FreeImage Public License - Version 1.0
1. Definitions.

1.1 "Contributor" means each entity that creates or contributes to the creation of Modifications.

1.2 "Contributor Version" means the combination of the Original Code, prior Modifications used by a
Contributor, and the Modifications made by that particular Contributor.

1.3 "Covered Code" means the Original Code or Modifications or the combination of the Original Code
and Maodifications, in each case including portions thereof.

1.4 "Electronic Distribution Mechanism" means a mechanism generally accepted in the software
development community for the electronic transfer of data.

1.5 "Executable" means Covered Code in any form other than Source Code.

1.6 "Initial Developer" means the individual or entity identified as the Initial Developer in the Source
Code notice required by Exhibit A.

1.7 "Larger Work" means a work which combines Covered Code or portions thereof with code not
governed by the terms of this License.

1.8 "License" means this document.

1.9 "Modifications” means any addition to or deletion from the substance or structure of either the
Original Code or any previous Modifications.

When Covered Code is released as a series of files, a modification is:

A. Any addition to or deletion from the contents of a file containing Original Code or previous
Modifications.

B. Any new file that contains any part of the Original Code or previous Modifications.

1.10 "Original Code"™ means Source Code of computer software code which is described in the Source
Code notice required by Exhibit A as Original Code, and which, at the time of its release under this
License is not already Covered Code governed by this License.

1.11 "Source Code" means the preferred form of the Covered Code for making modifications to it,
including all modules it contains, plus any associated interface definition files, scripts used to control
compilation and installation of an Executable, or a list of source code differential comparisons against
either the Original Code or another well known, available Covered Code of the Contributor's choice. The
Source Code can be in a compressed or archival form, provided the appropriate decompression or de-
archiving software is widely available for no charge.

1.12 "You" means an individual or a legal entity exercising rights under, and complying with all of the
terms of, this License or a future version of this License issued under Section 6.1. For legal entities, "You"
includes any entity which controls, is controlled by, or is under common control with You. For purposes of
this definition, "control" means (a) the power, direct or indirect, to cause the direction or management of
such entity, whether by contract or otherwise, or (b) ownership of fifty percent (50%) or more of the
outstanding shares or beneficial ownership of such entity.

2. Source Code License.
2.1. The Initial Developer Grant.

The Initial Developer hereby grants You a world-wide, royalty-free, non-exclusive license, subject to
third party intellectual property claims:

(a) to use, reproduce, modify, display, perform, sublicense and distribute the Original Code (or portions
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thereof) with or without Modifications, or as part of a Larger Work; and

(b) under patents now or hereafter owned or controlled by Initial Developer, to make, have made, use
and sell ("Utilize") the Original Code (or portions thereof), but solely to the extent that any such patent is
reasonably necessary to enable You to Utilize the Original Code (or portions thereof) and not to any
greater extent that may be necessary to Utilize further Modifications or combinations.

2.2. Contributor Grant.

Each Contributor hereby grants You a world-wide, royalty-free, non-exclusive license, subject to third
party intellectual property claims:

(a) to use, reproduce, modify, display, perform, sublicense and distribute the Modifications created by
such Contributor (or portions thereof) either on an unmodified basis, with other Modifications, as Covered
Code or as part of a Larger Work; and

(b) under patents now or hereafter owned or controlled by Contributor, to Utilize the Contributor Version
(or portions thereof), but solely to the extent that any such patent is reasonably necessary to enable You
to Utilize the Contributor Version (or portions thereof), and not to any greater extent that may be
necessary to Utilize further Modifications or combinations.

3. Distribution Obligations.
3.1. Application of License.

The Modifications which You create or to which You contribute are governed by the terms of this License,
including without limitation Section 2.2. The Source Code version of Covered Code may be distributed
only under the terms of this License or a future version of this License released under Section 6.1, and
You must include a copy of this License with every copy of the Source Code You distribute. You may not
offer or impose any terms on any Source Code version that alters or restricts the applicable version of
this License or the recipients' rights hereunder. However, You may include an additional document
offering the additional rights described in Section 3.5.

3.2. Availability of Source Code.

Any Modification which You create or to which You contribute must be made available in Source Code
form under the terms of this License either on the same media as an Executable version or via an
accepted Electronic Distribution Mechanism to anyone to whom you made an Executable version
available; and if made available via Electronic Distribution Mechanism, must remain available for at least
twelve (12) months after the date it initially became available, or at least six (6) months after a
subsequent version of that particular Modification has been made available to such recipients. You are
responsible for ensuring that the Source Code version remains available even if the Electronic
Distribution Mechanism is maintained by a third party.

3.3. Description of Modifications.

You must cause all Covered Code to which you contribute to contain a file documenting the changes You
made to create that Covered Code and the date of any change. You must include a prominent statement
that the Modification is derived, directly or indirectly, from Original Code provided by the Initial
Developer and including the name of the Initial Developer in (a) the Source Code, and (b) in any notice
in an Executable version or related documentation in which You describe the origin or ownership of the
Covered Code.

3.4. Intellectual Property Matters.
(a) Third Party Claims.

If You have knowledge that a party claims an intellectual property right in particular functionality or code
(or its utilization under this License), you must include a text file with the source code distribution titled
"LEGAL" which describes the claim and the party making the claim in sufficient detail that a recipient will
know whom to contact. If you obtain such knowledge after You make Your Modification available as
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described in Section 3.2, You shall promptly modify the LEGAL file in all copies You make available
thereafter and shall take other steps (such as notifying appropriate mailing lists or newsgroups)
reasonably calculated to inform those who received the Covered Code that new knowledge has been
obtained.

(b) Contributor APIs.

If Your Modification is an application programming interface and You own or control patents which are
reasonably necessary to implement that API, you must also include this information in the LEGAL file.

3.5. Required Notices.

You must duplicate the notice in Exhibit A in each file of the Source Code, and this License in any
documentation for the Source Code, where You describe recipients' rights relating to Covered Code. If
You created one or more Modification(s), You may add your name as a Contributor to the notice
described in Exhibit A. If it is not possible to put such notice in a particular Source Code file due to its
structure, then you must include such notice in a location (such as a relevant directory file) where a user
would be likely to look for such a notice. You may choose to offer, and to charge a fee for, warranty,
support, indemnity or liability obligations to one or more recipients of Covered Code. However, You may
do so only on Your own behalf, and not on behalf of the Initial Developer or any Contributor. You must
make it absolutely clear than any such warranty, support, indemnity or liability obligation is offered by
You alone, and You hereby agree to indemnify the Initial Developer and every Contributor for any
liability incurred by the Initial Developer or such Contributor as a result of warranty, support, indemnity
or liability terms You offer.

3.6. Distribution of Executable Versions.

You may distribute Covered Code in Executable form only if the requirements of Section 3.1-3.5 have
been met for that Covered Code, and if You include a notice stating that the Source Code version of the
Covered Code is available under the terms of this License, including a description of how and where You
have fulfilled the obligations of Section 3.2. The notice must be conspicuously included in any notice in an
Executable version, related documentation or collateral in which You describe recipients' rights relating to
the Covered Code. You may distribute the Executable version of Covered Code under a license of Your
choice, which may contain terms different from this License, provided that You are in compliance with the
terms of this License and that the license for the Executable version does not attempt to limit or alter the
recipient's rights in the Source Code version from the rights set forth in this License. If You distribute the
Executable version under a different license You must make it absolutely clear that any terms which
differ from this License are offered by You alone, not by the Initial Developer or any Contributor. You
hereby agree to indemnify the Initial Developer and every Contributor for any liability incurred by the
Initial Developer or such Contributor as a result of any such terms You offer.

3.7. Larger Works.

You may create a Larger Work by combining Covered Code with other code not governed by the terms
of this License and distribute the Larger Work as a single product. In such a case, You must make sure
the requirements of this License are fulfilled for the Covered Code.

4. Inability to Comply Due to Statute or Regulation.

If it is impossible for You to comply with any of the terms of this License with respect to some or all of
the Covered Code due to statute or regulation then You must: (a) comply with the terms of this License
to the maximum extent possible; and (b) describe the limitations and the code they affect. Such
description must be included in the LEGAL file described in Section 3.4 and must be included with all
distributions of the Source Code. Except to the extent prohibited by statute or regulation, such
description must be sufficiently detailed for a recipient of ordinary skill to be able to understand it.

5. Application of this License.

This License applies to code to which the Initial Developer has attached the notice in Exhibit A, and to
related Covered Code.
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6. Versions of the License.
6.1. New Versions.

Floris van den Berg may publish revised and/or new versions of the License from time to time. Each
version will be given a distinguishing version number.

6.2. Effect of New Versions.

Once Covered Code has been published under a particular version of the License, You may always
continue to use it under the terms of that version. You may also choose to use such Covered Code under
the terms of any subsequent version of the License published by Floris van den Berg

No one other than Floris van den Berg has the right to modify the terms applicable to Covered Code
created under this License.

6.3. Derivative Works.

If you create or use a modified version of this License (which you may only do in order to apply it to code
which is not already Covered Code governed by this License), you must (a) rename Your license so that
the phrases "FreeImage", *FreeImage Public License", "FIPL", or any confusingly similar phrase do not
appear anywhere in your license and (b) otherwise make it clear that your version of the license contains
terms which differ from the FreeImage Public License. (Filling in the name of the Initial Developer,
Original Code or Contributor in the notice described in Exhibit A shall not of themselves be deemed to be
modifications of this License.)

7. DISCLAIMER OF WARRANTY.

COVERED CODE IS PROVIDED UNDER THIS LICENSE ON AN "AS IS" BASIS, WITHOUT WARRANTY OF
ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, WARRANTIES THAT
THE COVERED CODE IS FREE OF DEFECTS, MERCHANTABLE, FIT FOR A PARTICULAR PURPOSE OR NON-
INFRINGING. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE COVERED CODE IS
WITH YOU. SHOULD ANY COVERED CODE PROVE DEFECTIVE IN ANY RESPECT, YOU (NOT THE INITIAL
DEVELOPER OR ANY OTHER CONTRIBUTOR) ASSUME THE COST OF ANY NECESSARY SERVICING,
REPAIR OR CORRECTION. THIS DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF
THIS LICENSE. NO USE OF ANY COVERED CODE IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS
DISCLAIMER.

8. TERMINATION.

This License and the rights granted hereunder will terminate automatically if You fail to comply with
terms herein and fail to cure such breach within 30 days of becoming aware of the breach. All sublicenses
to the Covered Code which are properly granted shall survive any termination of this License. Provisions
which, by their nature, must remain in effect beyond the termination of this License shall survive.

9. LIMITATION OF LIABILITY.

UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER TORT (INCLUDING
NEGLIGENCE), CONTRACT, OR OTHERWISE, SHALL THE INITIAL DEVELOPER, ANY OTHER
CONTRIBUTOR, OR ANY DISTRIBUTOR OF COVERED CODE, OR ANY SUPPLIER OF ANY OF SUCH
PARTIES, BE LIABLE TO YOU OR ANY OTHER PERSON FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR
CONSEQUENTIAL DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR
LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL
OTHER COMMERCIAL DAMAGES OR LOSSES, EVEN IF SUCH PARTY SHALL HAVE BEEN INFORMED OF THE
POSSIBILITY OF SUCH DAMAGES. THIS LIMITATION OF LIABILITY SHALL NOT APPLY TO LIABILITY FOR
DEATH OR PERSONAL INJURY RESULTING FROM SUCH PARTY'S NEGLIGENCE TO THE EXTENT
APPLICABLE LAW PROHIBITS SUCH LIMITATION. SOME JURISDICTIONS DO NOT ALLOW THE

EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THAT EXCLUSION AND
LIMITATION MAY NOT APPLY TO YOU.

XPression Maps User Guide (v3.4) Appendix C: Third Party Licenses « 353



10. U.S. GOVERNMENT END USERS.

The Covered Code is a "commercial item," as that term is defined in 48 C.F.R. 2.101 (Oct. 1995),
consisting of "commercial computer software" and "commercial computer software documentation," as
such terms are used in 48 C.F.R. 12.212 (Sept. 1995). Consistent with 48 C.F.R. 12.212 and 48 C.F.R.
227.7202-1 through 227.7202-4 (June 1995), all U.S. Government End Users acquire Covered Code with
only those rights set forth herein.

11. MISCELLANEOUS.

This License represents the complete agreement concerning subject matter hereof. If any provision of
this License is held to be unenforceable, such provision shall be reformed only to the extent necessary to
make it enforceable. This License shall be governed by Dutch law provisions (except to the extent
applicable law, if any, provides otherwise), excluding its conflict-of-law provisions. With respect to
disputes in which at least one party is a citizen of, or an entity chartered or registered to do business in,
the The Netherlands: (a) unless otherwise agreed in writing, all disputes relating to this License
(excepting any dispute relating to intellectual property rights) shall be subject to final and binding
arbitration, with the losing party paying all costs of arbitration; (b) any arbitration relating to this
Agreement shall be held in Aimelo, The Netherlands; and (c) any litigation relating to this Agreement
shall be subject to the jurisdiction of the court of Almelo, The Netherlands with the losing party
responsible for costs, including without limitation, court costs and reasonable attorneys fees and
expenses. Any law or regulation which provides that the language of a contract shall be construed against
the drafter shall not apply to this License.

12. RESPONSIBILITY FOR CLAIMS.

Except in cases where another Contributor has failed to comply with Section 3.4, You are responsible for
damages arising, directly or indirectly, out of Your utilization of rights under this License, based on the
number of copies of Covered Code you made available, the revenues you received from utilizing such
rights, and other relevant factors. You agree to work with affected parties to distribute responsibility on
an equitable basis.

EXHIBIT A.

"The contents of this file are subject to the FreeImage Public License Version 1.0 (the "License"); you
may not use this file except in compliance with the License. You may obtain a copy of the License at
http://home.wxs.nl/~flvdberg/freeimage-license.txt

Software distributed under the License is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY
KIND, either express or implied. See the License for the specific language governing rights and
limitations under the License.
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FreeType License

XPression Maps uses software covered by one or both of the licenses described below:
FreeType Project Licenselass!

FreeType Font Engine License[ss

FreeType Project License

2006-Jan-27 Copyright 1996-2002, 2006 by David Turner, Robert Wilhelm, and Werner Lemberg
Introduction

The FreeType Project is distributed in several archive packages; some of them may contain, in addition
to the FreeType font engine, various tools and contributions which rely on, or relate to, the FreeType
Project.

This license applies to all files found in such packages, and which do not fall under their own explicit
license. The license affects thus the FreeType font engine, the test programs, documentation and
makefiles, at the very least.

This license was inspired by the BSD, Artistic, and IJG (Independent JPEG Group) licenses, which all
encourage inclusion and use of free software in commercial and freeware products alike. As a
consequence, its main points are that:

e We don't promise that this software works. However, we will be interested in any kind of bug reports.
(Tas is' distribution)

e You can use this software for whatever you want, in parts or full form, without having to pay us.
(" royalty-free' usage)

e You may not pretend that you wrote this software. If you use it, or only parts of it, in a program, you
must acknowledge somewhere in your documentation that you have used the FreeType code (" credits').

We specifically permit and encourage the inclusion of this software, with or without modifications, in
commercial products.

We disclaim all warranties covering The FreeType Project and assume no liability related to The
FreeType Project.

Finally, many people asked us for a preferred form for a credit/disclaimer to use in compliance with this
license. We thus encourage you to use the following text:

"Portions of this software are copyright © <year> The FreeType Project (www.freetype.org). All rights
reserved."

Please replace <year> with the value from the FreeType version you actually use.
Legal Terms
0. Definitions
Throughout this license, the terms "package', *FreeType Project', and "FreeType archive' refer to the set
of files originally distributed by the authors (David Turner, Robert Wilhelm, and Werner Lemberg) as the

*FreeType Project', be they named as alpha, beta or final release.

“You' refers to the licensee, or person using the project, where “using' is a generic term including
compiling the project's source code as well as linking it to form a " program' or “executable'. This
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program is referred to as “a program using the FreeType engine'.

This license applies to all files distributed in the original FreeType Project, including all source code,
binaries and documentation, unless otherwise stated in the file in its original, unmodified form as
distributed in the original archive. If you are unsure whether or not a particular file is covered by this
license, you must contact us to verify this.

The FreeType Project is copyright (C) 1996-2000 by David Turner, Robert Wilhelm, and Werner
Lemberg. All rights reserved except as specified below.

1. No Warranty

THE FREETYPE PROJECT IS PROVIDED "AS IS' WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE. IN NO EVENT WILL ANY OF THE AUTHORS OR COPYRIGHT HOLDERS
BE LIABLE FOR ANY DAMAGES CAUSED BY THE USE OR THE INABILITY TO USE, OF THE FREETYPE
PROJECT.

2. Redistribution

This license grants a worldwide, royalty-free, perpetual and irrevocable right and license to use,
execute, perform, compile, display, copy, create derivative works of, distribute and sublicense the
FreeType Project (in both source and object code forms) and derivative works thereof for any
purpose; and to authorize others to exercise some or all of the rights granted herein, subject to the
following conditions:

¢ Redistribution of source code must retain this license file (* FTL.TXT') unaltered; any additions,
deletions or changes to the original files must be clearly indicated in accompanying documentation.
The copyright notices of the unaltered, original files must be preserved in all copies of source files.

e Redistribution in binary form must provide a disclaimer that states that the software is based in
part of the work of the FreeType Team, in the distribution documentation. We also encourage you to
put an URL to the FreeType web page in your documentation, though this isn't mandatory.

These conditions apply to any software derived from or based on the FreeType Project, not just the
unmodified files. If you use our work, you must acknowledge us. However, no fee need be paid to us.

3. Advertising

Neither the FreeType authors and contributors nor you shall use the name of the other for
commercial, advertising, or promotional purposes without specific prior written permission.

We suggest, but do not require, that you use one or more of the following phrases to refer to this
software in your documentation or advertising materials: *FreeType Project', " FreeType Engine’',
"FreeType library', or *FreeType Distribution'.

As you have not signed this license, you are not required to accept it. However, as the FreeType
Project is copyrighted material, only this license, or another one contracted with the authors, grants
you the right to use, distribute, and modify it. Therefore, by using, distributing, or modifying the
FreeType Project, you indicate that you understand and accept all the terms of this license.

4. Contacts
There are two mailing lists related to FreeType:
o freetype@nongnu.org

Discusses general use and applications of FreeType, as well as future and wanted additions to the
library and distribution. If you are looking for support, start in this list if you haven't found anything
to help you in the documentation.

o freetype-devel@nongnu.org

Discusses bugs, as well as engine internals, design issues, specific licenses, porting, etc.
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Our home page can be found at http://www.freetype.org.

FreeType Font Engine License

This means that *you* must choose *one* of the two licenses described below, then obey all its terms
and conditions when using FreeType 2 in any of your projects or products.

e The FreeType License, found in the file *FTL.TXT', which is similar to the original BSD license *with* an
advertising clause that forces you to explicitly cite the FreeType project in your product's
documentation. All details are in the license file. This license is suited to products which don't use the
GNU General Public License.

Note that this license is compatible to the GNU General Public License version 3, but not version 2.

e The GNU General Public License version 2, found in “GPLv2.TXT' (any later version can be used also),
for programs which already use the GPL. Note that the FTL is incompatible with GPLv2 due to its
advertisement clause.

The contributed BDF and PCF drivers come with a license similar to that of the X Window System. It is
compatible to the above two licenses (see file src/bdf/README and src/pcf/README).

The gzip module uses the zlib license (see src/gzip/zlib.h) which too is compatible to the above two
licenses.
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GDAL/OGR License

This file attempts to include all licenses that apply within the GDAL/OGR source tree, in particular any
that are supposed to be exposed to the end user for credit requirements for instance. The contents of this
file can be displayed from GDAL commandline utilities using the --license commandline switch.

GDAL/OGR General
In general GDAL/OGR is licensed under an MIT/X style license with the following terms:

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and
associated documentation files (the "Software"), to deal in the Software without restriction, including
without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the
following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial
portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF
CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE
OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

gdal/frmts/gtiff/tif_float.c
Copyright (c) 2002, Industrial Light & Magic, a division of Lucas Digital Ltd. LLC All rights reserved.

e Redistribution and use in source and binary forms, with or without modification, are permitted provided
that the following conditions are met:

e Redistributions of source code must retain the above copyright notice, this list of conditions and the
following disclaimer.

¢ Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other materials provided with the distribution.

e Neither the name of Industrial Light & Magic nor the names of its contributors may be used to endorse
or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

gdal/frmts/hdf4 /hdf-eos/*

Copyright (C) 1996 Hughes and Applied Research Corporation

Permission to use, modify, and distribute this software and its documentation for any purpose without fee
is hereby granted, provided that the above copyright notice appear in all copies and that both that

copyright notice and this permission notice appear in supporting documentation.

gdal/frmts/pcraster/libcsf
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Copyright (c) 1997-2003, Utrecht University All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided
that the following conditions are met:

e Redistributions of source code must retain the above copyright notice, this list of conditions and the
following disclaimer.

e Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other materials provided with the distribution.

¢ Neither the name of Utrecht University nor the names of its contributors may be used to endorse or
promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

gdal/frmts/grib/degrib/*

The degrib and g2clib source code are modified versions of code produced by NOAA NWS and are in the
public domain subject to the following restrictions:

http://www.weather.gov/im/softa.htm

DISCLAIMER The United States Government makes no warranty, expressed or implied, as to the
usefulness of the software and documentation for any purpose. The U.S. Government, its
instrumentalities, officers, employees, and agents assumes no responsibility (1) for the use of the
software and documentation listed below, or (2) to provide technical support to users.

http://www.weather.gov/disclaimer.php

The information on government servers are in the public domain, unless specifically annotated otherwise,
and may be used freely by the public so long as you do not 1) claim it is your own (e.g. by claiming
copyright for NWS information -- see below), 2) use it in a manner that implies an endorsement or
affiliation with NOAA/NWS, or 3) modify it in content and then present it as official government material.
You also cannot present information of your own in a way that makes it appear to be official government
information.

The user assumes the entire risk related to its use of this data. NWS is providing this data "as is," and
NWS disclaims any and all warranties, whether express or implied, including (without limitation) any
implied warranties of merchantability or fitness for a particular purpose. In no event will NWS be liable to
you or to any third party for any direct, indirect, incidental, consequential, special or exemplary
damages or lost profit resulting from any use or misuse of this data.

As required by 17 U.S.C. 403, third parties producing copyrighted works consisting predominantly of the
material appearing in NWS Web pages must provide notice with such work(s) identifying the NWS
material incorporated and stating that such material is not subject to copyright protection.
port/cpl_minizip*

This is version 2005-Feb-10 of the Info-ZIP copyright and license. The definitive version of this document
should be available at ftp://ftp.info-zip.org/pub/infozip/license.html indefinitely.

Copyright (c) 1990-2005 Info-ZIP. All rights reserved.
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For the purposes of this copyright and license, "Info-ZIP" is defined as the following set of individuals:

Mark Adler, John Bush, Karl Davis, Harald Denker, Jean-Michel Dubois, Jean-loup Gailly, Hunter Goatley,
Ed Gordon, Ian Gorman, Chris Herborth, Dirk Haase, Greg Hartwig, Robert Heath, Jonathan Hudson,
Paul Kienitz, David Kirschbaum, Johnny Lee, Onno van der Linden, Igor Mandrichenko, Steve P. Miller,
Sergio Monesi, Keith Owens, George Petrov, Greg Roelofs, Kai Uwe Rommel, Steve Salisbury, Dave
Smith, Steven M. Schweda, Christian Spieler, Cosmin Truta, Antoine Verheijen, Paul von Behren, Rich
Wales, Mike White

This software is provided "as is," without warranty of any kind, express or implied. In no event shall
Info-ZIP or its contributors be held liable for any direct, indirect, incidental, special or consequential
damages arising out of the use of or inability to use this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications,
and to alter it and redistribute it freely, subject to the following restrictions:

1. Redistributions of source code must retain the above copyright notice, definition, disclaimer, and this
list of conditions.

2. Redistributions in binary form (compiled executables) must reproduce the above copyright notice,
definition, disclaimer, and this list of conditions in documentation and/or other materials provided
with the distribution. The sole exception to this condition is redistribution of a standard UnZipSFX
binary (including SFXWiz) as part of a self-extracting archive; that is permitted without inclusion of
this license, as long as the normal SFX banner has not been removed from the binary or disabled.

3. Altered versions--including, but not limited to, ports to new operating systems, existing ports with
new graphical interfaces, and dynamic, shared, or static library versions--must be plainly marked as
such and must not be misrepresented as being the original source. Such altered versions also must
not be misrepresented as being Info-ZIP releases--including, but not limited to, labeling of the
altered versions with the names "Info-ZIP" (or any variation thereof, including but not limited to,
different capitalizations), "Pocket UnZip," "WiZ" or "MacZip" without the explicit permission of Info-
ZIP. Such altered versions are further prohibited from misrepresentative use of the Zip-Bugs or Info-
ZIP e-mail addresses or of the Info-ZIP URL(s).

4. Info-ZIP retains the right to use the names "Info-ZIP," "Zip," "UnZip," "UnZipSFX," "WiZ," "Pocket
UnZip," "Pocket Zip," and "MacZip" for its own source and binary releases.

gdal/ogr/ogrsf_frmts/dxf/intronurbs.cpp

This code is derived from the code associated with the book "An Introduction to NURBS" by David F.
Rogers. More information on the book and the code is available at:

http://www.nar-associates.com/nurbs/
Copyright (c) 2009, David F. Rogers. All rights reserved.

e Redistribution and use in source and binary forms, with or without modification, are permitted
provided that the following conditions are met:

e Redistributions of source code must retain the above copyright notice, this list of conditions and the
following disclaimer.

e Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other materials provided with the distribution.

¢ Neither the name of the David F. Rogers nor the names of its contributors may be used to endorse or
promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
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PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN ARISING IN ANY
WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
gdal/alg/thinplatespline.cpp

IEEE754 log() code derived from: @(#)e_log.c 1.3 95/01/18

Copyright (C) 1993 by Sun Microsystems, Inc. All rights reserved.

Developed at SunSoft, a Sun Microsystems, Inc. business.

Permission to use, copy, modify, and distribute this software is freely granted, provided that this notice is
preserved.
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GStreamer License

GNU LIBRARY GENERAL PUBLIC LICENSE
Version 2, June 1991

Copyright (C) 1991 Free Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301,
USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is
not allowed.

[This is the first released version of the library GPL. It is numbered 2 because it goes with version 2 of
the ordinary GPL.]

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By
contrast, the GNU General Public Licenses are intended to guarantee your freedom to share and change
free software--to make sure the software is free for all its users.

This license, the Library General Public License, applies to some specially designated Free Software
Foundation software, and to any other libraries whose authors decide to use it. You can use it for your
libraries, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are
designed to make sure that you have the freedom to distribute copies of free software (and charge for
this service if you wish), that you receive source code or can get it if you want it, that you can change the
software or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to
ask you to surrender the rights. These restrictions translate to certain responsibilities for you if you
distribute copies of the library, or if you modify it.

For example, if you distribute copies of the library, whether gratis or for a fee, you must give the
recipients all the rights that we gave you. You must make sure that they, too, receive or can get the
source code. If you link a program with the library, you must provide complete object files to the
recipients so that they can relink them with the library, after making changes to the library and
recompiling it. And you must show them these terms so they know their rights.

Our method of protecting your rights has two steps: (1) copyright the library, and (2) offer you this
license which gives you legal permission to copy, distribute and/or modify the library.

Also, for each distributor's protection, we want to make certain that everyone understands that there is
no warranty for this free library. If the library is modified by someone else and passed on, we want its
recipients to know that what they have is not the original version, so that any problems introduced by
others will not reflect on the original authors' reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger
that companies distributing free software will individually obtain patent licenses, thus in effect
transforming the program into proprietary software. To prevent this, we have made it clear that any
patent must be licensed for everyone's free use or not licensed at all.

Most GNU software, including some libraries, is covered by the ordinary GNU General Public License,
which was designed for utility programs. This license, the GNU Library General Public License, applies to
certain designated libraries. This license is quite different from the ordinary one; be sure to read it in
full, and don't assume that anything in it is the same as in the ordinary license.

The reason we have a separate public license for some libraries is that they blur the distinction we
usually make between modifying or adding to a program and simply using it. Linking a program with a
library, without changing the library, is in some sense simply using the library, and is analogous to
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running a utility program or application program. However, in a textual and legal sense, the linked
executable is a combined work, a derivative of the original library, and the ordinary General Public
License treats it as such.

Because of this blurred distinction, using the ordinary General Public License for libraries did not
effectively promote software sharing, because most developers did not use the libraries. We concluded
that weaker conditions might promote sharing better.

However, unrestricted linking of non-free programs would deprive the users of those programs of all
benefit from the free status of the libraries themselves. This Library General Public License is intended to
permit developers of non-free programs to use free libraries, while preserving your freedom as a user of
such programs to change the free libraries that are incorporated in them. (We have not seen how to
achieve this as regards changes in header files, but we have achieved it as regards changes in the actual
functions of the Library.) The hope is that this will lead to faster development of free libraries.

The precise terms and conditions for copying, distribution and modification follow. Pay close attention to
the difference between a "work based on the library" and a "work that uses the library". The former
contains code derived from the library, while the latter only works together with the library.

Note that it is possible for a library to be covered by the ordinary General Public License rather than by
this special one.

GNU LIBRARY GENERAL PUBLIC LICENSE
TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License Agreement applies to any software library which contains a notice placed by the
copyright holder or other authorized party saying it may be distributed under the terms of this
Library General Public License (also called "this License"). Each licensee is addressed as "you".

A "library" means a collection of software functions and/or data prepared so as to be conveniently
linked with application programs (which use some of those functions and data) to form executables.

The "Library", below, refers to any such software library or work which has been distributed under
these terms. A "work based on the Library" means either the Library or any derivative work under
copyright law: that is to say, a work containing the Library or a portion of it, either verbatim or with
modifications and/or translated straightforwardly into another language. (Hereinafter, translation is
included without limitation in the term "modification".)

"Source code" for a work means the preferred form of the work for making modifications to it. For a
library, complete source code means all the source code for all modules it contains, plus any
associated interface definition files, plus the scripts used to control compilation and installation of the
library.

Activities other than copying, distribution and modification are not covered by this License; they are
outside its scope. The act of running a program using the Library is not restricted, and output from
such a program is covered only if its contents constitute a work based on the Library (independent of
the use of the Library in a tool for writing it). Whether that is true depends on what the Library does
and what the program that uses the Library does.

1. You may copy and distribute verbatim copies of the Library's complete source code as you receive it,
in any medium, provided that you conspicuously and appropriately publish on each copy an
appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this
License and to the absence of any warranty; and distribute a copy of this License along with the
Library.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer
warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Library or any portion of it, thus forming a work based on
the Library, and copy and distribute such modifications or work under the terms of Section 1 above,
provided that you also meet all of these conditions:
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a) The modified work must itself be a software library.

b) You must cause the files modified to carry prominent notices stating that you changed the files and
the date of any change.

¢) You must cause the whole of the work to be licensed at no charge to all third parties under the
terms of this License.

d) If a facility in the modified Library refers to a function or a table of data to be supplied by an
application program that uses the facility, other than as an argument passed when the facility is
invoked, then you must make a good faith effort to ensure that in the event an application does not
supply such function or table, the facility still operates, and performs whatever part of its purpose
remains meaningful.

(For example, a function in a library to compute square roots has a purpose that is entirely well-
defined independent of the application. herefore, Subsection 2d requires that any application-supplied
function or table used by this function must be optional: if the application does not supply it, the
square root function must still compute square roots.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are
not derived from the Library, and can be reasonably considered independent and separate works in
themselves, then this License, and its terms, do not apply to those sections when you distribute them
as separate works. But when you distribute the same sections as part of a whole which is a work
based on the Library, the distribution of the whole must be on the terms of this License, whose
permissions for other licensees extend to the entire whole, and thus to each and every part
regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely
by you; rather, the intent is to exercise the right to control the distribution of derivative or collective
works based on the Library.

In addition, mere aggregation of another work not based on the Library with the Library (or with a
work based on the Library) on a volume of a storage or distribution medium does not bring the other
work under the scope of this License.

3. You may opt to apply the terms of the ordinary GNU General Public License instead of this License to
a given copy of the Library. To do this, you must alter all the notices that refer to this License, so that
they refer to the ordinary GNU General Public License, version 2, nstead of to this License. (If a
newer version than version 2 of the ordinary GNU General Public License has appeared, then you can
specify that version instead if you wish.) Do not make any other change in these notices.

Once this change is made in a given copy, it is irreversible for that copy, so the ordinary GNU General
Public License applies to all subsequent copies and derivative works made from that copy.

This option is useful when you wish to copy part of the code of the Library into a program that is not a
library.

4. You may copy and distribute the Library (or a portion or derivative of it, under Section 2) in object
code or executable form under the terms of Sections 1 and 2 above provided that you accompany it
with the complete corresponding machine-readable source code, which must be distributed under the
terms of Sections 1 and 2 above on a medium customarily used for software interchange.

If distribution of object code is made by offering access to copy from a designated place, then offering
equivalent access to copy the source code from the same place satisfies the requirement to distribute
the source code, even though third parties are not compelled to copy the source along with the object
code.

5. A program that contains no derivative of any portion of the Library, but is designed to work with the
Library by being compiled or linked with it, is called a "work that uses the Library". Such a work, in
isolation, is not a derivative work of the Library, and therefore falls outside the scope of this License.

However, linking a "work that uses the Library" with the Library creates an executable that is a
derivative of the Library (because it contains portions of the Library), rather than a "work that uses
the library". The executable is therefore covered by this License. Section 6 states terms for
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distribution of such executables.

When a "work that uses the Library" uses material from a header file that is part of the Library, the
object code for the work may be a derivative work of the Library even though the source code is not.
Whether this is true is especially significant if the work can be linked without the Library, or if the
work is itself a library. The threshold for this to be true is not precisely defined by law.

If such an object file uses only numerical parameters, data structure layouts and accessors, and small
macros and small inline functions (ten lines or less in length), then the use of the object file is
unrestricted, regardless of whether it is legally a derivative work. (Executables containing this object
code plus portions of the Library will still fall under Section 6.)

Otherwise, if the work is a derivative of the Library, you may distribute the object code for the work
under the terms of Section 6. Any executables containing that work also fall under Section 6, whether
or not they are linked directly with the Library itself.

6. As an exception to the Sections above, you may also compile or link a "work that uses the Library"
with the Library to produce a work containing portions of the Library, and distribute that work under
terms of your choice, provided that the terms permit modification of the work for the customer's own
use and reverse engineering for debugging such modifications.

You must give prominent notice with each copy of the work that the Library is used in it and that the
Library and its use are covered by this License. You must supply a copy of this License. If the work
during execution displays copyright notices, you must include the copyright notice for the Library
among them, as well as a reference directing the user to the copy of this License. Also, you must do
one of these things:

a) Accompany the work with the complete corresponding machine-readable source code for the
Library including whatever changes were used in the work (which must be distributed under Sections
1 and 2 above); and, if the work is an executable linked with the Library, with the complete machine-
readable "work that uses the Library", as object code and/or source code, so that the user can modify
the Library and then relink to produce a modified executable containing the modified Library. (Itis
understood that the user who changes the contents of definitions files in the Library will not
necessarily be able to recompile the application to use the modified definitions.)

b) Accompany the work with a written offer, valid for at least three years, to give the same user the
materials specified in Subsection 6a, above, for a charge no more than the cost of performing this
distribution.

c) If distribution of the work is made by offering access to copy from a designated place, offer
equivalent access to copy the above specified materials from the same place.

d) Verify that the user has already received a copy of these materials or that you have already sent
this user a copy.

For an executable, the required form of the "work that uses the Library" must include any data and
utility programs needed for reproducing the executable from it. However, as a special exception, the
source code distributed need not include anything that is normally distributed (in either source or
binary form) with the major components (compiler, kernel, and so on) of the operating system on
which the executable runs, unless that component itself accompanies the executable.

It may happen that this requirement contradicts the license restrictions of other proprietary libraries
that do not normally accompany the operating system. Such a contradiction means you cannot use
both them and the Library together in an executable that you distribute.

7. You may place library facilities that are a work based on the Library side-by-side in a single library
together with other library facilities not covered by this License, and distribute such a combined
library, provided that the separate distribution of the work based on the Library and of the other
library facilities is otherwise permitted, and provided that you do these two things:

a) Accompany the combined library with a copy of the same work based on the Library, uncombined
with any other library facilities. This must be distributed under the terms of the Sections above.

b) Give prominent notice with the combined library of the fact that part of it is a work based on the
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Library, and explaining where to find the accompanying uncombined form of the same work.

8. You may not copy, modify, sublicense, link with, or distribute the Library except as expressly
provided under this License. Any attempt otherwise to copy, modify, sublicense, link with, or
distribute the Library is void, and will automatically terminate your rights under this License.
However, parties who have received copies, or rights, from you under this License will not have their
licensesterminated so long as such parties remain in full compliance.

9. You are not required to accept this License, since you have not signed it. However, nothing else
grants you permission to modify or distribute the Library or its derivative works. These actions are
prohibited by law if you do not accept this License. Therefore, by modifying or distributing the
Library (or any work based on the Library), you indicate your acceptance of this License to do so, and
all its terms and conditions for copying, distributing or modifying the Library or works based on it.

10.Each time you redistribute the Library (or any work based on the Library), the recipient automatically
receives a license from the original licensor to copy, distribute, link with or modify the Library subject
to these terms and conditions. You may not impose any further restrictions on the recipients'
exercise of the rights granted herein. You are not responsible for enforcing compliance by third
parties to this License.

11.1If, as a consequence of a court judgment or allegation of patent infringement or for any other reason
(not limited to patent issues), conditions are imposed on you (whether by court order, agreement or
otherwise) that contradict the conditions of this License, they do not excuse you from the conditions
of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this
License and any other pertinent obligations, then as a consequence you may not distribute the
Library at all. For example, if a patent license would not permit royalty-free redistribution of the
Library by all those who receive copies directly or indirectly through you, then the only way you could
satisfy both it and this License would be to refrain entirely from distribution of the Library.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the
balance of the section is intended to apply, and the section as a whole is intended to apply in other
circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right
claims or to contest validity of any such claims; this section has the sole purpose of protecting the
integrity of the free software distribution system which is implemented by public license practices.
Many people have made generous contributions to the wide range of software distributed through
that system in reliance on consistent application of that system; it is up to the author/donor to decide
if he or she is willing to distribute software through any other system and a licensee cannot impose
that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of
this License.

12.1If the distribution and/or use of the Library is restricted in certain countries either by patents or by
copyrighted interfaces, the original copyright holder who places the Library under this License may
add an explicit geographical distribution limitation excluding those countries, so that distribution is
permitted only in or among countries not thus excluded. In such case, this License incorporates the
limitation as if written in the body of this License.

13.The Free Software Foundation may publish revised and/or new versions of the Library General Public
License from time to time. Such new versions will be similar in spirit to the present version, but may
differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Library specifies a version humber of
this License which applies to it and "any later version", you have the option of following the terms and
conditions either of that version or of any later version published by the Free Software Foundation. If
the Library does not specify a license version number, you may choose any version ever published by
the Free Software Foundation.

14.If you wish to incorporate parts of the Library into other free programs whose distribution conditions
are incompatible with these, write to the author to ask for permission. For software which is
copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes
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make exceptions for this. Our decision will be guided by the two goals of preserving the free status
of all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

15.BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE LIBRARY,
TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING
THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE LIBRARY "AS IS" WITHOUT
WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE
ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE LIBRARY IS WITH YOU. SHOULD THE
LIBRARY PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR
CORRECTION.

16.IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY
COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE
LIBRARY AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL,
SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO
USE THE LIBRARY (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED
INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE LIBRARY TO
OPERATE WITH ANY OTHER SOFTWARE), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS
Appendix: How to Apply These Terms to Your New Libraries

If you develop a new library, and you want it to be of the greatest possible use to the public, we
recommend making it free software that everyone can redistribute and change. You can do so by
permitting redistribution under these terms (or, alternatively, under the terms of the ordinary General
Public License).

To apply these terms, attach the following notices to the library. It is safest to attach them to the start
of each source file to most effectively convey the exclusion of warranty; and each file should have at
least the "copyright" line and a pointer to where the full notice is found.

<one line to give the library's name and a brief idea of what it does.> Copyright (C) <year> <name of
author>

This library is free software; you can redistribute it and/or modify it under the terms of the GNU Library
General Public License as published by the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even
the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Library General Public License for more details.

You should have received a copy of the GNU Library General Public License along with this library; if not,
write to the Free Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.

Also add information on how to contact you by electronic and paper mail.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a
"copyright disclaimer" for the library, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the library “Frob' (a library for tweaking knobs)
written by James Random Hacker.

<signature of Ty Coon>, 1 April 1990
Ty Coon, President of Vice

That's all there is to it!
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GTS License

GNU LIBRARY GENERAL PUBLIC LICENSE
Version 2, June 1991

Copyright (C) 1991 Free Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301,
USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is
not allowed.

[This is the first released version of the library GPL. It is numbered 2 because it goes with version 2 of
the ordinary GPL.]

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By
contrast, the GNU General Public Licenses are intended to guarantee your freedom to share and change
free software--to make sure the software is free for all its users.

This license, the Library General Public License, applies to some specially designated Free Software
Foundation software, and to any other libraries whose authors decide to use it. You can use it for your
libraries, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are
designed to make sure that you have the freedom to distribute copies of free software (and charge for
this service if you wish), that you receive source code or can get it if you want it, that you can change the
software or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to
ask you to surrender the rights. These restrictions translate to certain responsibilities for you if you
distribute copies of the library, or if you modify it.

For example, if you distribute copies of the library, whether gratis or for a fee, you must give the
recipients all the rights that we gave you. You must make sure that they, too, receive or can get the
source code. If you link a program with the library, you must provide complete object files to the
recipients so that they can relink them with the library, after making changes to the library and
recompiling it. And you must show them these terms so they know their rights.

Our method of protecting your rights has two steps: (1) copyright the library, and (2) offer you this
license which gives you legal permission to copy, distribute and/or modify the library.

Also, for each distributor's protection, we want to make certain that everyone understands that there is
no warranty for this free library. If the library is modified by someone else and passed on, we want its
recipients to know that what they have is not the original version, so that any problems introduced by
others will not reflect on the original authors' reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger
that companies distributing free software will individually obtain patent licenses, thus in effect
transforming the program into proprietary software. To prevent this, we have made it clear that any
patent must be licensed for everyone's free use or not licensed at all.

Most GNU software, including some libraries, is covered by the ordinary GNU General Public License,
which was designed for utility programs. This license, the GNU Library General Public License, applies to
certain designated libraries. This license is quite different from the ordinary one; be sure to read it in
full, and don't assume that anything in it is the same as in the ordinary license.

The reason we have a separate public license for some libraries is that they blur the distinction we
usually make between modifying or adding to a program and simply using it. Linking a program with a
library, without changing the library, is in some sense simply using the library, and is analogous to
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running a utility program or application program. However, in a textual and legal sense, the linked
executable is a combined work, a derivative of the original library, and the ordinary General Public
License treats it as such.

Because of this blurred distinction, using the ordinary General Public License for libraries did not
effectively promote software sharing, because most developers did not use the libraries. We concluded
that weaker conditions might promote sharing better.

However, unrestricted linking of non-free programs would deprive the users of those programs of all
benefit from the free status of the libraries themselves. This Library General Public License is intended to
permit developers of non-free programs to use free libraries, while preserving your freedom as a user of
such programs to change the free libraries that are incorporated in them. (We have not seen how to
achieve this as regards changes in header files, but we have achieved it as regards changes in the actual
functions of the Library.) The hope is that this will lead to faster development of free libraries.

The precise terms and conditions for copying, distribution and modification follow. Pay close attention to
the difference between a "work based on the library" and a "work that uses the library". The former
contains code derived from the library, while the latter only works together with the library.

Note that it is possible for a library to be covered by the ordinary General Public License rather than by
this special one.

GNU LIBRARY GENERAL PUBLIC LICENSE
TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License Agreement applies to any software library which contains a notice placed by the
copyright holder or other authorized party saying it may be distributed under the terms of this
Library General Public License (also called "this License"). Each licensee is addressed as "you".

A "library" means a collection of software functions and/or data prepared so as to be conveniently
linked with application programs (which use some of those functions and data) to form executables.

The "Library", below, refers to any such software library or work which has been distributed under
these terms. A "work based on the Library" means either the Library or any derivative work under
copyright law: that is to say, a work containing the Library or a portion of it, either verbatim or with
modifications and/or translated straightforwardly into another language. (Hereinafter, translation is
included without limitation in the term "modification".)

"Source code" for a work means the preferred form of the work for making modifications to it. For a
library, complete source code means all the source code for all modules it contains, plus any
associated interface definition files, plus the scripts used to control compilation and installation of the
library.

Activities other than copying, distribution and modification are not covered by this License; they are
outside its scope. The act of running a program using the Library is not restricted, and output from
such a program is covered only if its contents constitute a work based on the Library (independent of
the use of the Library in a tool for writing it). Whether that is true depends on what the Library does
and what the program that uses the Library does.

1. You may copy and distribute verbatim copies of the Library's complete source code as you receive it,
in any medium, provided that you conspicuously and appropriately publish on each copy an
appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this
License and to the absence of any warranty; and distribute a copy of this License along with the
Library.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer
warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Library or any portion of it, thus forming a work based on
the Library, and copy and distribute such modifications or work under the terms of Section 1 above,
provided that you also meet all of these conditions:
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a) The modified work must itself be a software library.

b) You must cause the files modified to carry prominent notices stating that you changed the files and
the date of any change.

¢) You must cause the whole of the work to be licensed at no charge to all third parties under the
terms of this License.

d) If a facility in the modified Library refers to a function or a table of data to be supplied by an
application program that uses the facility, other than as an argument passed when the facility is
invoked, then you must make a good faith effort to ensure that in the event an application does not
supply such function or table, the facility still operates, and performs whatever part of its purpose
remains meaningful.

(For example, a function in a library to compute square roots has a purpose that is entirely well-
defined independent of the application. herefore, Subsection 2d requires that any application-supplied
function or table used by this function must be optional: if the application does not supply it, the
square root function must still compute square roots.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are
not derived from the Library, and can be reasonably considered independent and separate works in
themselves, then this License, and its terms, do not apply to those sections when you distribute them
as separate works. But when you distribute the same sections as part of a whole which is a work
based on the Library, the distribution of the whole must be on the terms of this License, whose
permissions for other licensees extend to the entire whole, and thus to each and every part
regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely
by you; rather, the intent is to exercise the right to control the distribution of derivative or collective
works based on the Library.

In addition, mere aggregation of another work not based on the Library with the Library (or with a
work based on the Library) on a volume of a storage or distribution medium does not bring the other
work under the scope of this License.

3. You may opt to apply the terms of the ordinary GNU General Public License instead of this License to
a given copy of the Library. To do this, you must alter all the notices that refer to this License, so that
they refer to the ordinary GNU General Public License, version 2, nstead of to this License. (If a
newer version than version 2 of the ordinary GNU General Public License has appeared, then you can
specify that version instead if you wish.) Do not make any other change in these notices.

Once this change is made in a given copy, it is irreversible for that copy, so the ordinary GNU General
Public License applies to all subsequent copies and derivative works made from that copy.

This option is useful when you wish to copy part of the code of the Library into a program that is not a
library.

4. You may copy and distribute the Library (or a portion or derivative of it, under Section 2) in object
code or executable form under the terms of Sections 1 and 2 above provided that you accompany it
with the complete corresponding machine-readable source code, which must be distributed under the
terms of Sections 1 and 2 above on a medium customarily used for software interchange.

If distribution of object code is made by offering access to copy from a designated place, then offering
equivalent access to copy the source code from the same place satisfies the requirement to distribute
the source code, even though third parties are not compelled to copy the source along with the object
code.

5. A program that contains no derivative of any portion of the Library, but is designed to work with the
Library by being compiled or linked with it, is called a "work that uses the Library". Such a work, in
isolation, is not a derivative work of the Library, and therefore falls outside the scope of this License.

However, linking a "work that uses the Library" with the Library creates an executable that is a
derivative of the Library (because it contains portions of the Library), rather than a "work that uses
the library". The executable is therefore covered by this License. Section 6 states terms for
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distribution of such executables.

When a "work that uses the Library" uses material from a header file that is part of the Library, the
object code for the work may be a derivative work of the Library even though the source code is not.
Whether this is true is especially significant if the work can be linked without the Library, or if the
work is itself a library. The threshold for this to be true is not precisely defined by law.

If such an object file uses only numerical parameters, data structure layouts and accessors, and small
macros and small inline functions (ten lines or less in length), then the use of the object file is
unrestricted, regardless of whether it is legally a derivative work. (Executables containing this object
code plus portions of the Library will still fall under Section 6.)

Otherwise, if the work is a derivative of the Library, you may distribute the object code for the work
under the terms of Section 6. Any executables containing that work also fall under Section 6, whether
or not they are linked directly with the Library itself.

6. As an exception to the Sections above, you may also compile or link a "work that uses the Library"
with the Library to produce a work containing portions of the Library, and distribute that work under
terms of your choice, provided that the terms permit modification of the work for the customer's own
use and reverse engineering for debugging such modifications.

You must give prominent notice with each copy of the work that the Library is used in it and that the
Library and its use are covered by this License. You must supply a copy of this License. If the work
during execution displays copyright notices, you must include the copyright notice for the Library
among them, as well as a reference directing the user to the copy of this License. Also, you must do
one of these things:

a) Accompany the work with the complete corresponding machine-readable source code for the
Library including whatever changes were used in the work (which must be distributed under Sections
1 and 2 above); and, if the work is an executable linked with the Library, with the complete machine-
readable "work that uses the Library", as object code and/or source code, so that the user can modify
the Library and then relink to produce a modified executable containing the modified Library. (Itis
understood that the user who changes the contents of definitions files in the Library will not
necessarily be able to recompile the application to use the modified definitions.)

b) Accompany the work with a written offer, valid for at least three years, to give the same user the
materials specified in Subsection 6a, above, for a charge no more than the cost of performing this
distribution.

c) If distribution of the work is made by offering access to copy from a designated place, offer
equivalent access to copy the above specified materials from the same place.

d) Verify that the user has already received a copy of these materials or that you have already sent
this user a copy.

For an executable, the required form of the "work that uses the Library" must include any data and
utility programs needed for reproducing the executable from it. However, as a special exception, the
source code distributed need not include anything that is normally distributed (in either source or
binary form) with the major components (compiler, kernel, and so on) of the operating system on
which the executable runs, unless that component itself accompanies the executable.

It may happen that this requirement contradicts the license restrictions of other proprietary libraries
that do not normally accompany the operating system. Such a contradiction means you cannot use
both them and the Library together in an executable that you distribute.

7. You may place library facilities that are a work based on the Library side-by-side in a single library
together with other library facilities not covered by this License, and distribute such a combined
library, provided that the separate distribution of the work based on the Library and of the other
library facilities is otherwise permitted, and provided that you do these two things:

a) Accompany the combined library with a copy of the same work based on the Library, uncombined
with any other library facilities. This must be distributed under the terms of the Sections above.

b) Give prominent notice with the combined library of the fact that part of it is a work based on the
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Library, and explaining where to find the accompanying uncombined form of the same work.

8. You may not copy, modify, sublicense, link with, or distribute the Library except as expressly
provided under this License. Any attempt otherwise to copy, modify, sublicense, link with, or
distribute the Library is void, and will automatically terminate your rights under this License.
However, parties who have received copies, or rights, from you under this License will not have their
licensesterminated so long as such parties remain in full compliance.

9. You are not required to accept this License, since you have not signed it. However, nothing else
grants you permission to modify or distribute the Library or its derivative works. These actions are
prohibited by law if you do not accept this License. Therefore, by modifying or distributing the
Library (or any work based on the Library), you indicate your acceptance of this License to do so, and
all its terms and conditions for copying, distributing or modifying the Library or works based on it.

10.Each time you redistribute the Library (or any work based on the Library), the recipient automatically
receives a license from the original licensor to copy, distribute, link with or modify the Library subject
to these terms and conditions. You may not impose any further restrictions on the recipients'
exercise of the rights granted herein. You are not responsible for enforcing compliance by third
parties to this License.

11.1If, as a consequence of a court judgment or allegation of patent infringement or for any other reason
(not limited to patent issues), conditions are imposed on you (whether by court order, agreement or
otherwise) that contradict the conditions of this License, they do not excuse you from the conditions
of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this
License and any other pertinent obligations, then as a consequence you may not distribute the
Library at all. For example, if a patent license would not permit royalty-free redistribution of the
Library by all those who receive copies directly or indirectly through you, then the only way you could
satisfy both it and this License would be to refrain entirely from distribution of the Library.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the
balance of the section is intended to apply, and the section as a whole is intended to apply in other
circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right
claims or to contest validity of any such claims; this section has the sole purpose of protecting the
integrity of the free software distribution system which is implemented by public license practices.
Many people have made generous contributions to the wide range of software distributed through
that system in reliance on consistent application of that system; it is up to the author/donor to decide
if he or she is willing to distribute software through any other system and a licensee cannot impose
that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of
this License.

12.1If the distribution and/or use of the Library is restricted in certain countries either by patents or by
copyrighted interfaces, the original copyright holder who places the Library under this License may
add an explicit geographical distribution limitation excluding those countries, so that distribution is
permitted only in or among countries not thus excluded. In such case, this License incorporates the
limitation as if written in the body of this License.

13.The Free Software Foundation may publish revised and/or new versions of the Library General Public
License from time to time. Such new versions will be similar in spirit to the present version, but may
differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Library specifies a version humber of
this License which applies to it and "any later version", you have the option of following the terms and
conditions either of that version or of any later version published by the Free Software Foundation. If
the Library does not specify a license version number, you may choose any version ever published by
the Free Software Foundation.

14.If you wish to incorporate parts of the Library into other free programs whose distribution conditions
are incompatible with these, write to the author to ask for permission. For software which is
copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes
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make exceptions for this. Our decision will be guided by the two goals of preserving the free status
of all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

15.BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE LIBRARY,
TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING
THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE LIBRARY "AS IS" WITHOUT
WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE
ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE LIBRARY IS WITH YOU. SHOULD THE
LIBRARY PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR
CORRECTION.

16.IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY
COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE
LIBRARY AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL,
SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO
USE THE LIBRARY (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED
INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE LIBRARY TO
OPERATE WITH ANY OTHER SOFTWARE), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS
Appendix: How to Apply These Terms to Your New Libraries

If you develop a new library, and you want it to be of the greatest possible use to the public, we
recommend making it free software that everyone can redistribute and change. You can do so by
permitting redistribution under these terms (or, alternatively, under the terms of the ordinary General
Public License).

To apply these terms, attach the following notices to the library. It is safest to attach them to the start
of each source file to most effectively convey the exclusion of warranty; and each file should have at
least the "copyright" line and a pointer to where the full notice is found.

<one line to give the library's name and a brief idea of what it does.> Copyright (C) <year> <name of
author>

This library is free software; you can redistribute it and/or modify it under the terms of the GNU Library
General Public License as published by the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even
the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Library General Public License for more details.

You should have received a copy of the GNU Library General Public License along with this library; if not,
write to the Free Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.

Also add information on how to contact you by electronic and paper mail.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a
"copyright disclaimer" for the library, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the library “Frob' (a library for tweaking knobs)
written by James Random Hacker.

<signature of Ty Coon>, 1 April 1990
Ty Coon, President of Vice

That's all there is to it!
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ImageMagick License

Before we get to the text of the license, lets just review what the license says in simple terms:

It allows you to:

e freely download and use ImageMagick software, in whole or in part, for personal, company internal, or
commercial purposes;

e use ImageMagick software in packages or distributions that you create;

¢ link against a library under a different license;

¢ link code under a different license against a library under this license;

e merge code into a work under a different license;

e extend patent grants to any code using code under this license;

e and extend patent protection.
It forbids you to:

¢ redistribute any piece of ImageMagick-originated software without proper attribution;

e use any marks owned by ImageMagick Studio LLC in any way that might state or imply that
ImageMagick Studio LLC endorses your distribution;

e use any marks owned by ImageMagick Studio LLC in any way that might state or imply that you
created the ImageMagick software in question.

It requires you to:

e include a copy of the license in any redistribution you may make that includes ImageMagick software;

e provide clear attribution to ImageMagick Studio LLC for any distributions that include ImageMagick
software.

It does not require you to:

e include the source of the ImageMagick software itself, or of any modifications you may have made to
it, in any redistribution you may assemble that includes it;

e submit changes that you make to the software back to the ImageMagick Studio LLC (though such
feedback is encouraged).

A few other clarifications include:

e ImageMagick is freely available without charge;
e you may include ImageMagick on a DVD as long as you comply with the terms of the license;

e you can give modified code away for free or sell it under the terms of the ImageMagick license or
distribute the result under a different license, but you need to acknowledge the use of the
ImageMagick software;

e the license is compatible with the GPL V3.

e when exporting the ImageMagick software, review its export classification.
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Terms and Conditions for Use, Reproduction, and Distribution

The legally binding and authoritative terms and conditions for use, reproduction, and distribution of
ImageMagick follow:

Copyright 1999-2015 ImageMagick Studio LLC, a non-profit organization dedicated to making software
imaging solutions freely available.

1. Definitions.

License shall mean the terms and conditions for use, reproduction, and distribution as defined by
Sections 1 through 9 of this document.

Licensor shall mean the copyright owner or entity authorized by the copyright owner that is granting
the License.

Legal Entity shall mean the union of the acting entity and all other entities that control, are controlled
by, or are under common control with that entity. For the purposes of this definition, control means
(i) the power, direct or indirect, to cause the direction or management of such entity, whether by
contract or otherwise, or (ii) ownership of fifty percent (50%) or more of the outstanding shares, or
(iii) beneficial ownership of such entity.

You (or Your) shall mean an individual or Legal Entity exercising permissions granted by this License.

Source form shall mean the preferred form for making modifications, including but not limited to
software source code, documentation source, and configuration files.

Object form shall mean any form resulting from mechanical transformation or translation of a Source
form, including but not limited to compiled object code, generated documentation, and conversions to
other media types.

Work shall mean the work of authorship, whether in Source or Object form, made available under the
License, as indicated by a copyright notice that is included in or attached to the work (an example is
provided in the Appendix below).

Derivative Works shall mean any work, whether in Source or Object form, that is based on (or
derived from) the Work and for which the editorial revisions, annotations, elaborations, or other
modifications represent, as a whole, an original work of authorship. For the purposes of this License,
Derivative Works shall not include works that remain separable from, or merely link (or bind by
name) to the interfaces of, the Work and Derivative Works thereof.

Contribution shall mean any work of authorship, including the original version of the Work and any
modifications or additions to that Work or Derivative Works thereof, that is intentionally submitted to
Licensor for inclusion in the Work by the copyright owner or by an individual or Legal Entity
authorized to submit on behalf of the copyright owner. For the purposes of this definition, "submitted"
means any form of electronic, verbal, or written communication sent to the Licensor or its
representatives, including but not limited to communication on electronic mailing lists, source code
control systems, and issue tracking systems that are managed by, or on behalf of, the Licensor for
the purpose of discussing and improving the Work, but excluding communication that is conspicuously
marked or otherwise designated in writing by the copyright owner as Not a Contribution.

Contributor shall mean Licensor and any individual or Legal Entity on behalf of whom a Contribution
has been received by Licensor and subsequently incorporated within the Work.

2. Grant of Copyright License. Subject to the terms and conditions of this License, each Contributor
hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable
copyright license to reproduce, prepare Derivative Works of, publicly display, publicly perform,
sublicense, and distribute the Work and such Derivative Works in Source or Object form.

3. Grant of Patent License. Subject to the terms and conditions of this License, each Contributor
hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable
patent license to make, have made, use, offer to sell, sell, import, and otherwise transfer the Work,
where such license applies only to those patent claims licensable by such Contributor that are
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necessarily infringed by their Contribution(s) alone or by combination of their Contribution(s) with the
Work to which such Contribution(s) was submitted. If You institute patent litigation against any entity
(including a cross-claim or counterclaim in a lawsuit) alleging that the Work or a Contribution
incorporated within the Work constitutes direct or contributory patent infringement, then any patent
licenses granted to You under this License for that Work shall terminate as of the date such litigation
is filed.

4. Redistribution. You may reproduce and distribute copies of the Work or Derivative Works thereof in
any medium, with or without modifications, and in Source or Object form, provided that You meet
the following conditions:

e You must give any other recipients of the Work or Derivative Works a copy of this License; and

e You must cause any modified files to carry prominent notices stating that You changed the files;
and

e You must retain, in the Source form of any Derivative Works that You distribute, all copyright,
patent, trademark, and attribution notices from the Source form of the Work, excluding those
notices that do not pertain to any part of the Derivative Works; and

o If the Work includes a "NOTICE" text file as part of its distribution, then any Derivative Works that
You distribute must include a readable copy of the attribution notices contained within such NOTICE
file, excluding those notices that do not pertain to any part of the Derivative Works, in at least one
of the following places: within a NOTICE text file distributed as part of the Derivative Works; within
the Source form or documentation, if provided along with the Derivative Works; or, within a
display generated by the Derivative Works, if and wherever such third-party notices normally
appear. The contents of the NOTICE file are for informational purposes only and do not modify the
License. You may add Your own attribution notices within Derivative Works that You distribute,
alongside or as an addendum to the NOTICE text from the Work, provided that such additional
attribution notices cannot be construed as modifying the License. You may add Your own copyright
statement to Your modifications and may provide additional or different license terms and
conditions for use, reproduction, or distribution of Your modifications, or for any such Derivative
Works as a whole, provided Your use, reproduction, and distribution of the Work otherwise
complies with the conditions stated in this License.

5. Submission of Contributions. Unless You explicitly state otherwise, any Contribution intentionally
submitted for inclusion in the Work by You to the Licensor shall be under the terms and conditions of
this License, without any additional terms or conditions. Notwithstanding the above, nothing herein
shall supersede or modify the terms of any separate license agreement you may have executed with
Licensor regarding such Contributions.

6. Trademarks. This License does not grant permission to use the trade names, trademarks, service
marks, or product names of the Licensor, except as required for reasonable and customary use in
describing the origin of the Work and reproducing the content of the NOTICE file.

7. Disclaimer of Warranty. Unless required by applicable law or agreed to in writing, Licensor
provides the Work (and each Contributor provides its Contributions) on an AS IS BASIS, WITHOUT
WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied, including, without limitation,
any warranties or conditions of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
PARTICULAR PURPOSE. You are solely responsible for determining the appropriateness of using or
redistributing the Work and assume any risks associated with Your exercise of permissions under this
License.

8. Limitation of Liability. In no event and under no legal theory, whether in tort (including
negligence), contract, or otherwise, unless required by applicable law (such as deliberate and grossly
negligent acts) or agreed to in writing, shall any Contributor be liable to You for damages, including
any direct, indirect, special, incidental, or consequential damages of any character arising as a result
of this License or out of the use or inability to use the Work (including but not limited to damages for
loss of goodwill, work stoppage, computer failure or malfunction, or any and all other commercial
damages or losses), even if such Contributor has been advised of the possibility of such damages.

9. Accepting Warranty or Additional Liability. While redistributing the Work or Derivative Works
thereof, You may choose to offer, and charge a fee for, acceptance of support, warranty, indemnity,
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or other liability obligations and/or rights consistent with this License. However, in accepting such
obligations, You may act only on Your own behalf and on Your sole responsibility, not on behalf of any
other Contributor, and only if You agree to indemnify, defend, and hold each Contributor harmless for
any liability incurred by, or claims asserted against, such Contributor by reason of your accepting any
such warranty or additional liability.

How to Apply the License to your Work

To apply the ImageMagick License to your work, attach the following boilerplate notice, with the fields
enclosed by brackets "[]1" replaced with your own identifying information (don't include the brackets). The
text should be enclosed in the appropriate comment syntax for the file format. We also recommend that
a file or class name and description of purpose be included on the same "printed page" as the copyright
notice for easier identification within third-party archives.

Copyright [yyyy] [name of copyright owner]

Licensed under the ImageMagick License (the "License"); you may not use this file except in compliance
with the License. You may obtain a copy of the License at:

http://www.imagemagick.org/script/license.php

Unless required by applicable law or agreed to in writing, software distributed under the License is
distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express
or implied. See the License for the specific language governing permissions and limitations under the
License.
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Libav License

Most files in Libav are under the GNU Lesser General Public License version 2.1 or later (LGPL v2.1+).
Read the file COPYING.LGPLv2.1 for details. Some other files have MIT/X11/BSD-style licenses. In
combination the LGPL v2.1+ applies to Libav.

Some optional parts of Libav are licensed under the GNU General Public License version 2 or later (GPL
v2+). See the file COPYING.GPLv2 for details. None of these parts are used by default, you have to
explicitly pass --enable-gpl to configure to activate them. In this case, Libav's license changes to GPL
v2+.

Specifically, the GPL parts of Libav are

e the X11 grabber in libavdevice/x11grab.c
e the texi2pod.pl tool

o the following filters in libavfilter:

» vf_blackframe.c
> vf_boxblur.c

» vf_cropdetect.c
» vf_delogo.c

» vf_hqgdn3d.c

> vf_interlace.c

Should you, for whatever reason, prefer to use version 3 of the (L)GPL, then the configure parameter --
enable-version3 will activate this licensing option for you. Read the file COPYING.LGPLv3 or, if you have
enabled GPL parts, COPYING.GPLv3 to learn the exact legal terms that apply in this case.

There are a handful of files under other licensing terms, namely:
e The files libavcodec/jfdctfst.c, libavcodec/jfdctint_template.c and libavcodec/jrevdct.c are taken from
libjpeg, see the top of the files for licensing details. Specifically note that you must credit the IJG in the

documentation accompanying your program if you only distribute executables. You must also indicate
any changes including additions and deletions to those three files in the documentation.

external libraries

Libav can be combined with a number of external libraries, which sometimes affect the licensing of
binaries resulting from the combination.

compatible libraries

The libcdio, libx264, libx265, libxavs and libxvid libraries are under GPL. When combining them with
Libav, Libav needs to be licensed as GPL as well by passing --enable-gpl to configure.

The OpenCORE and VisualOn libraries are under the Apache License 2.0. That license is incompatible with

the LGPL v2.1 and the GPL v2, but not with version 3 of those licenses. So to combine these libraries with
Libav, the license version needs to be upgraded by passing --enable-version3 to configure.

incompatible libraries

The Fraunhofer AAC library, FAAC and OpenSSL are under licenses incompatible with all (L)GPL versions.
Thus, unfortunately, since both licenses cannot be satisfied simultaneously, binaries resulting from the
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combination of Libav with these libraries are nonfree und unredistributable. If you wish to enable any of
these libraries nonetheless, pass --enable-nonfree to configure.

GNU LESSER GENERAL PUBLIC LICENSE

Version 2.1, February 1999

Copyright (C) 1991, 1999 Free Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-
1301, USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is
not allowed.

[This is the first released version of the Lesser GPL. It also counts as the successor of the GNU Library
Public License, version 2, hence the version humber 2.1.]

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By
contrast, the GNU General Public Licenses are intended to guarantee your freedom to share and change
free software--to make sure the software is free for all its users.

This license, the Lesser General Public License, applies to some specially software packages--typically
libraries--of the Free Software Foundation and other authors who decide to use it. You can use it too, but
we suggest you first think carefully about whether this license or the ordinary General Public License is
the better strategy to use in any particular case, based on the explanations below.

When we speak of free software, we are referring to freedom of use, not price. Our General Public
Licenses are designed to make sure that you have the freedom to distribute copies of free software (and
charge for this service if you wish), that you receive source code or can get it if you want it, that you can
change the software or use pieces of it in new free programs; and that you are informed that you can do
these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to
ask you to surrender the rights. These restrictions translate to certain responsibilities for you if you
distribute copies of the library or if you modify it.

For example, if you distribute copies of the library, whether gratis or for a fee, you must give the
recipients all the rights that we gave you. You must make sure that they, too, receive or can get the
source code. If you link other code with the library, you must provide complete object files to the
recipients so that they can relink them with the library after making changes to the library and
recompiling it. And you must show them these terms so they know their rights.

We protect your rights with a two-step method: (1) we copyright the library, and (2) we offer you this
license, which gives you legal permission to copy, distribute and/or modify the library.

To protect each distributor, we want to make it very clear that there is no warranty for the free library.
Also, if the library is modified by someone else and passed on, recipients should know that what they
have is not the original version, so that the original author's reputation will not be affected by problems
that might be introduced by others.

Finally, software patents pose a constant threat to the existence of any free program. We wish to make
sure that a company cannot effectively restrict the users of a free program by obtaining restrictive
licenses from a patent holder. Therefore, we insist that any patent license obtained for a version of the
library must be consistent with the full freedom of use specified in this license.

Most GNU software, including some libraries, is covered by the ordinary GNU General Public License. This
license, the GNU Lesser General Public License, applies to certain designated libraries, and is quite
different from the ordinary General Public License. We use this license for certain libraries in order to
permit linking those libraries into non-free programs.
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When a program is linked with a library, whether statically or using a shared library, the combination of
the two is legally speaking a combined work, a derivative of the original library. The ordinary General
Public License therefore permits such linking only if the entire combination fits its criteria of freedom.
The Lesser General Public License permits more lax criteria for linking other code with the library.

We call this license the "Lesser" General Public License because it does Less to protect the user's freedom
than the ordinary General Public License. It also provides other free software developers Less of an
advantage over competing non-free programs. These disadvantages are the reason we use the ordinary
General Public License for many libraries. However, the Lesser license provides advantages in certain
special circumstances.

For example, on rare occasions, there may be a special need to encourage the widest possible use of a
certain library, so that it becomes a de-facto standard. To achieve this, non-free programs must be
allowed to use the library. A more frequent case is that a free library does the same job as widely used
non-free libraries. In this case, there is little to gain by limiting the free library to free software only, so
we use the Lesser General Public License.

In other cases, permission to use a particular library in non-free programs enables a greater number of
people to use a large body of free software. For example, permission to use the GNU C Library in non-
free programs enables many more people to use the whole GNU operating system, as well as its variant,
the GNU/Linux operating system.

Although the Lesser General Public License is Less protective of the users' freedom, it does ensure that
the user of a program that is linked with the Library has the freedom and the wherewithal to run that
program using a modified version of the Library.

The precise terms and conditions for copying, distribution and modification follow. Pay close attention to
the difference between a "work based on the library" and a "work that uses the library". The former
contains code derived from the library, while the latter must be combined with the library in order to
run.

GNU LESSER GENERAL PUBLIC LICENSE
TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License Agreement applies to any software library or other program which contains a notice
placed by the copyright holder or other authorized party saying it may be distributed under the terms
of this Lesser General Public License (also called "this License"). Each licensee is addressed as "you".

A "library" means a collection of software functions and/or data prepared so as to be conveniently
linked with application programs (which use some of those functions and data) to form executables.

The "Library", below, refers to any such software library or work which has been distributed under
these terms. A "work based on the Library" means either the Library or any derivative work under
copyright law: that is to say, a work containing the Library or a portion of it, either verbatim or with
modifications and/or translated straightforwardly into another language. (Hereinafter, translation is
included without limitation in the term "modification".)

"Source code" for a work means the preferred form of the work for making modifications to it. For a
library, complete source code means all the source code for all modules it contains, plus any
associated interface definition files, plus the scripts used to control compilation and installation of the
library.

Activities other than copying, distribution and modification are not covered by this License; they are
outside its scope. The act of running a program using the Library is not restricted, and output from
such a program is covered only if its contents constitute a work based on the Library (independent of
the use of the Library in a tool for writing it). Whether that is true depends on what the Library does
and what the program that uses the Library does.

1. You may copy and distribute verbatim copies of the Library's complete source code as you receive it,
in any medium, provided that you conspicuously and appropriately publish on each copy an
appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this
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License and to the absence of any warranty; and distribute a copy of this License along with the
Library.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer
warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Library or any portion of it, thus forming a work based on
the Library, and copy and distribute such modifications or work under the terms of Section 1 above,
provided that you also meet all of these conditions:

a) The modified work must itself be a software library.

b) You must cause the files modified to carry prominent notices stating that you changed the files and
the date of any change.

¢) You must cause the whole of the work to be licensed at no charge to all third parties under the
terms of this License.

d) If a facility in the modified Library refers to a function or a table of data to be supplied by an
application program that uses the facility, other than as an argument passed when the facility is
invoked, then you must make a good faith effort to ensure that in the event an application does not
supply such function or table, the facility still operates, and performs whatever part of its purpose
remains meaningful.

(For example, a function in a library to compute square roots has a purpose that is entirely well-
defined independent of the application. Therefore, Subsection 2d requires that any application-
supplied function or table used by this function must be optional: if the application does not supply it,
the square root function must still compute square roots.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are
not derived from the Library, and can be reasonably considered independent and separate works in
themselves, then this License, and its terms, do not apply to those sections when you distribute them
as separate works. But when you distribute the same sections as part of a whole which is a work
based on the Library, the distribution of the whole must be on the terms of this License, whose
permissions for other licensees extend to the entire whole, and thus to each and every part
regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely
by you; rather, the intent is to exercise the right to control the distribution of derivative or collective
works based on the Library.

In addition, mere aggregation of another work not based on the Library with the Library (or with a
work based on the Library) on a volume of a storage or distribution medium does not bring the other
work under the scope of this License.

3. You may opt to apply the terms of the ordinary GNU General Public License instead of this License to
a given copy of the Library. To do this, you must alter all the notices that refer to this License, so that
they refer to the ordinary GNU General Public License, version 2, instead of to this License. (If a
newer version than version 2 of the ordinary GNU General Public License has appeared, then you can
specify that version instead if you wish.) Do not make any other change in these notices.

Once this change is made in a given copy, it is irreversible for that copy, so the ordinary GNU General
Public License applies to all subsequent copies and derivative works made from that copy.

This option is useful when you wish to copy part of the code of the Library into a program that is not a
library.

4. You may copy and distribute the Library (or a portion or derivative of it, under Section 2) in object
code or executable form under the terms of Sections 1 and 2 above provided that you accompany it
with the complete corresponding machine-readable source code, which must be distributed under the
terms of Sections 1 and 2 above on a medium customarily used for software interchange.

If distribution of object code is made by offering access to copy from a designated place, then offering
equivalent access to copy the source code from the same place satisfies the requirement to distribute
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the source code, even though third parties are not compelled to copy the source along with the object
code.

5. A program that contains no derivative of any portion of the Library, but is designed to work with the
Library by being compiled or linked with it, is called a "work that uses the Library". Such a work, in
isolation, is not a derivative work of the Library, and therefore falls outside the scope of this License.

However, linking a "work that uses the Library" with the Library creates an executable that is a
derivative of the Library (because it contains portions of the Library), rather than a "work that uses
the library". The executable is therefore covered by this License. Section 6 states terms for
distribution of such executables.

When a "work that uses the Library" uses material from a header file that is part of the Library, the
object code for the work may be a derivative work of the Library even though the source code is not.
Whether this is true is especially significant if the work can be linked without the Library, or if the
work is itself a library. The threshold for this to be true is not precisely defined by law.

If such an object file uses only numerical parameters, data structure layouts and accessors, and small
macros and small inline functions (ten lines or less in length), then the use of the object file is
unrestricted, regardless of whether it is legally a derivative work. (Executables containing this object
code plus portions of the Library will still fall under Section 6.)

Otherwise, if the work is a derivative of the Library, you may distribute the object code for the work
under the terms of Section 6. Any executables containing that work also fall under Section 6, whether
or not they are linked directly with the Library itself.

6. As an exception to the Sections above, you may also combine or link a "work that uses the Library"
with the Library to produce a work containing portions of the Library, and distribute that work under
terms of your choice, provided that the terms permit modification of the work for the customer's own
use and reverse engineering for debugging such modifications.

You must give prominent notice with each copy of the work that the Library is used in it and that the
Library and its use are covered by this License. You must supply a copy of this License. If the work
during execution displays copyright notices, you must include the copyright notice for the Library
among them, as well as a reference directing the user to the copy of this License. Also, you must do
one of these things:

a) Accompany the work with the complete corresponding machine-readable source code for the
Library including whatever changes were used in the work (which must be distributed under
Sections 1 and 2 above); and, if the work is an executable linked with the Library, with the
complete machine-readable "work that uses the Library", as object code and/or source code, so
that the user can modify the Library and then relink to produce a modified executable containing
the modified Library. (It is understood that the user who changes the contents of definitions files
in the Library will not necessarily be able to recompile the application to use the modified
definitions.)

b) Use a suitable shared library mechanism for linking with the Library. A suitable mechanism is one
that (1) uses at run time a copy of the library already present on the user's computer system,
rather than copying library functions into the executable, and (2) will operate properly with a
modified version of the library, if the user installs one, as long as the modified version is interface-
compatible with the version that the work was made with.

c) Accompany the work with a written offer, valid for at least three years, to give the same user the
materials specified in Subsection 6a, above, for a charge no more than the cost of performing this
distribution.

d) If distribution of the work is made by offering access to copy from a designated place, offer
equivalent access to copy the above specified materials from the same place.

e) Verify that the user has already received a copy of these materials or that you have already sent
this user a copy.

For an executable, the required form of the "work that uses the Library" must include any data and
utility programs needed for reproducing the executable from it. However, as a special exception, the
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materials to be distributed need not include anything that is normally distributed (in either source or
binary form) with the major components (compiler, kernel, and so on) of the operating system on
which the executable runs, unless that component itself accompanies the executable.

It may happen that this requirement contradicts the license restrictions of other proprietary libraries
that do not normally accompany the operating system. Such a contradiction means you cannot use
both them and the Library together in an executable that you distribute.

7. You may place library facilities that are a work based on the Library side-by-side in a single library
together with other library facilities not covered by this License, and distribute such a combined
library, provided that the separate distribution of the work based on the Library and of the other
library facilities is otherwise permitted, and provided that you do these two things:

a) Accompany the combined library with a copy of the same work based on the Library, uncombined
with any other library facilities. This must be distributed under the terms of the Sections above.

b) Give prominent notice with the combined library of the fact that part of it is a work based on the
Library, and explaining where to find the accompanying uncombined form of the same work.

8. You may not copy, modify, sublicense, link with, or distribute the Library except as expressly
provided under this License. Any attempt otherwise to copy, modify, sublicense, link with, or
distribute the Library is void, and will automatically terminate your rights under this License.
However, parties who have received copies, or rights, from you under this License will not have their
licenses terminated so long as such parties remain in full compliance.

9. You are not required to accept this License, since you have not signed it. However, nothing else
grants you permission to modify or distribute the Library or its derivative works. These actions are
prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Library
(or any work based on the Library), you indicate your acceptance of this License to do so, and all its
terms and conditions for copying, distributing or modifying the Library or works based on it.

10.Each time you redistribute the Library (or any work based on the Library), the recipient automatically
receives a license from the original licensor to copy, distribute, link with or modify the Library subject
to these terms and conditions. You may not impose any further restrictions on the recipients' exercise
of the rights granted herein. You are not responsible for enforcing compliance by third parties to this
License.

11.1If, as a consequence of a court judgment or allegation of patent infringement of for any other reason
(not limited to patent issues),conditions are imposed on you (whether by court order, agreement or
otherwise) that contradict the conditions of this License, they do not excuse you from the conditions
of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this
License and any other pertinent obligations, then as a consequence you may not distribute the
Library at all. For example, if a patent license would not permit royalty-free redistribution of the
Library by all those who receive copies directly or indirectly through you, then the only way you could
satisfy both it and this License would be to refrain entirely from distribution of the Library.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the
balance of the section is intended to apply, and the section as a whole is intended to apply in other
circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right
claims or to contest validity of any such claims; this section has the sole purpose of protecting the
integrity of the free software distribution system which is implemented by public license practices.
Many people have made generous contributions to the wide range of software distributed through
that system in reliance on consistent application of that system; it is up to the author/donor to decide
if he or she is willing to distribute software through any other system and a licensee cannot impose
that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of
this License.

12.1f the distribution and/or use of the Library is restricted in certain countries either by patents or by
copyrighted interfaces, the original copyright holder who places the Library under this License may
add an explicit geographical distribution limitation excluding those countries, so that distribution is
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permitted only in or among countries not thus excluded. In such case, this License incorporates the
limitation as if written in the body of this License.

13.The Free Software Foundation may publish revised and/or new versions of the Lesser General Public
License from time to time. Such new versions will be similar in spirit to the present version, but may
differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Library specifies a version number of
this License which applies to it and "any later version", you have the option of following the terms and
conditions either of that version or of any later version published by the Free Software Foundation. If
the Library does not specify a license version number, you may choose any version ever published by
the Free Software Foundation.

14.1f you wish to incorporate parts of the Library into other free programs whose distribution conditions
are incompatible with these, write to the author to ask for permission. For software which is
copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes
make exceptions for this. Our decision will be guided by the two goals of preserving the free status of
all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

15.BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE LIBRARY,
TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING
THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE LIBRARY "AS IS" WITHOUT
WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE
ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE LIBRARY IS WITH YOU. SHOULD THE
LIBRARY PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR
CORRECTION.

16.IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY
COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE
LIBRARY AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL,
SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO
USE THE LIBRARY (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED
INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE LIBRARY TO
OPERATE WITH ANY OTHER SOFTWARE), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS
Appendix: How to Apply These Terms to Your New Libraries

If you develop a new library, and you want it to be of the greatest possible use to the public, we
recommend making it free software that everyone can redistribute and change. You can do so by
permitting redistribution under these terms (or, alternatively, under the terms of the ordinary General
Public License).

To apply these terms, attach the following notices to the library. It is safest to attach them to the start of
each source file to most effectively convey the exclusion of warranty; and each file should have at least
the "copyright" line and a pointer to where the full notice is found.

<one line to give the library's name and a brief idea of what it does.> Copyright (C) <year> <name of
author>

This library is free software; you can redistribute it and/or modify it under the terms of the GNU Lesser
General Public License as published by the Free Software Foundation; either version 2.1 of the License,
or (at your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even
the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details.
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You should have received a copy of the GNU Lesser General Public License along with this library; if not,
write to the Free Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.

Also add information on how to contact you by electronic and paper mail.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a
"copyright disclaimer" for the library, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the library *Frob' (a library for tweaking knobs)
written by James Random Hacker.

<signature of Ty Coon>, 1 April 1990
Ty Coon, President of Vice

That's all there is to it!
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Noto-emoji License

Apache License
Version 2.0, January 2004

http://www.apache.org/licenses/
TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION

1. Definitions.

"License" shall mean the terms and conditions for use, reproduction, and distribution as defined by
Sections 1 through 9 of this document.

"Licensor" shall mean the copyright owner or entity authorized by the copyright owner that is
granting the License.

"Legal Entity" shall mean the union of the acting entity and all other entities that control, are
controlled by, or are under common control with that entity. For the purposes of this definition,
"control" means (i) the power, direct or indirect, to cause the direction or management of such
entity, whether by contract or otherwise, or (ii) ownership of fifty percent (50%) or more of the
outstanding shares, or (iii) beneficial ownership of such entity.

"You" (or "Your") shall mean an individual or Legal Entity exercising permissions granted by this
License.

"Source" form shall mean the preferred form for making modifications, including but not limited to
software source code, documentation source, and configuration files.

"Object" form shall mean any form resulting from mechanical transformation or translation of a
Source form, including but not limited to compiled object code, generated documentation, and
conversions to other media types.

"Work" shall mean the work of authorship, whether in Source or Object form, made available under
the License, as indicated by a copyright notice that is included in or attached to the work (an example
is provided in the Appendix below).

"Derivative Works" shall mean any work, whether in Source or Object form, that is based on (or
derived from) the Work and for which the editorial revisions, annotations, elaborations, or other
modifications represent, as a whole, an original work of authorship. For the purposes of this License,
Derivative Works shall not include works that remain separable from, or merely link (or bind by
name) to the interfaces of, the Work and Derivative Works thereof.

"Contribution” shall mean any work of authorship, including the original version of the Work and any
modifications or additions to that Work or Derivative Works thereof, that is intentionally submitted to
Licensor for inclusion in the Work by the copyright owner or by an individual or Legal Entity
authorized to submit on behalf of the copyright owner. For the purposes of this definition,
"submitted"means any form of electronic, verbal, or written communication sent to the Licensor or its
representatives, including but not limited to communication on electronic mailing lists, source code
control systems, and issue tracking systems that are managed by, or on behalf of, the Licensor for
the purpose of discussing and improving the Work, but excluding communication that is conspicuously
marked or otherwise designated in writing by the copyright owner as "Not a Contribution."

"Contributor"” shall mean Licensor and any individual or Legal Entity on behalf of whom a Contribution
has been received by Licensor and subsequently incorporated within the Work.

2. Grant of Copyright License. Subject to the terms and conditions of this License, each Contributor
hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable
copyright license to reproduce, prepare Derivative Works of, publicly display, publicly perform,
sublicense, and distribute the Work and such Derivative Works in Source or Object form.
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3. Grant of Patent License. Subject to the terms and conditions of this License, each Contributor
hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable
(except as stated in this section) patent license to make, have made, use, offer to sell, sell, import,
and otherwise transfer the Work where such license applies only to those patent claims licensable by
such Contributor that are necessarily infringed by their Contribution(s) alone or by combination of
their Contribution(s) with the Work to which such Contribution(s) was submitted. If You institute
patent litigation against any entity (including a cross-claim or counterclaim in a lawsuit) alleging that
the Work or a Contribution incorporated within the Work constitutes direct or contributory patent
infringement, then any patent licenses granted to You under this License for that Work shall
terminate as of the date such litigation is filed.

4. Redistribution. You may reproduce and distribute copies of the Work or Derivative Works thereof in
any medium, with or without modifications, and in Source or Object form, provided that You meet
the following conditions:

a) You must give any other recipients of the Work or Derivative Works a copy of this License; and

b) You must cause any modified files to carry prominent notices stating that You changed the files;
and

c) You must retain, in the Source form of any Derivative Works that You distribute, all copyright,
patent, trademark, and attribution notices from the Source form of the Work, excluding those
notices that do not pertain to any part of the Derivative Works; and

d) If the Work includes a "NOTICE" text file as part of its distribution, then any Derivative Works that
You distribute must include a readable copy of the attribution notices contained within such
NOTICE file, excluding those notices that do not pertain to any part of the Derivative Works, in at
least one of the following places: within a NOTICE text file distributed as part of the Derivative
Works; within the Source form or documentation, if provided along with the Derivative Works; or
within a display generated by the Derivative Works, if and wherever such third-party notices
normally appear. The contents of the NOTICE file are for informational purposes only and do not
modify the License. You may add Your own attribution notices within Derivative Works that You
distribute, alongside or as an addendum to the NOTICE text from the Work, provided that such
additional attribution notices cannot be construed as modifying the License.

You may add Your own copyright statement to Your modifications and may provide additional or
different license terms and conditions for use, reproduction, or distribution of Your modifications, or
for any such Derivative Works as a whole, provided Your use, reproduction, and distribution of the
Work otherwise complies with the conditions stated in this License.

5. Submission of Contributions. Unless You explicitly state otherwise, any Contribution intentionally
submitted for inclusion in the Work by You to the Licensor shall be under the terms and conditions of
this License, without any additional terms or conditions. Notwithstanding the above, nothing herein
shall supersede or modify the terms of any separate license agreement you may have executed with
Licensor regarding such Contributions.

6. Trademarks. This License does not grant permission to use the tradenames, trademarks, service
marks, or product names of the Licensor, except as required for reasonable and customary use in
describing the origin of the Work and reproducing the content of the NOTICE file.

7. Disclaimer of Warranty. Unless required by applicable law or agreed to in writing, Licensor
provides the Work (and each Contributor provides its Contributions) on an "AS IS" BASIS, WITHOUT
WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied, including, without limitation,
any warranties or conditions of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
PARTICULAR PURPOSE. You are solely responsible for determining the appropriateness of using or
redistributing the Work and assume any risks associated with Your exercise of permissions under this
License.

8. Limitation of Liability. In no event and under no legal theory, whether in tort (including
negligence), contract, or otherwise, unless required by applicable law (such as deliberate and grossly
negligent acts) or agreed to in writing, shall any Contributor be liable to You for damages, including
any direct, indirect, special, incidental, or consequential damages of any character arising as a result
of this License or out of the use or inability to use the Work (including but not limited to damages for

XPression Maps User Guide (v3.4) Appendix C: Third Party Licenses « 387



loss of goodwill, work stoppage, computer failure or malfunction, or any and all other commercial
damages or losses), even if such Contributor has been advised of the possibility of such damages.

9. Accepting Warranty or Additional Liability. While redistributing the Work or Derivative Works
thereof, You may choose to offer and charge a fee for, acceptance of support, warranty, indemnity,or
other liability obligations and/or rights consistent with this License. However, in accepting such
obligations, You may act only on Your own behalf and on Your sole responsibility, not on behalf of any
other Contributor, and only if You agree to indemnify, defend, and hold each Contributor harmless for
any liability incurred by, or claims asserted against, such Contributor by reason of your accepting any
such warranty or additional liability

END OF TERMS AND CONDITIONS

APPENDIX: How to apply the Apache License to your work.

To apply the Apache License to your work, attach the following boilerplate notice, with the fields enclosed
by brackets "[]" replaced with your own identifying information. (Don't include the brackets!) The text
should be enclosed in the appropriate comment syntax for the file format. We also recommend that a file
or class name and description of purpose be included on the same "printed page" as the copyright notice
for easier identification within third-party archives.

Copyright [yyyy] [name of copyright owner]

Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in
compliance with the License.

You may obtain a copy of the License at:
http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the License is
distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express
or implied. See the License for the specific language governing permissions and limitations under the
License.
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ProtoZero License

ProtoZero Copyright/aon
Apache License
Version 2.0, January 2004

http://www.apache.org/licenses/
TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION

1. Definitions.

"License" shall mean the terms and conditions for use, reproduction, and distribution as defined by
Sections 1 through 9 of this document.

"Licensor" shall mean the copyright owner or entity authorized by the copyright owner that is
granting the License.

"Legal Entity" shall mean the union of the acting entity and all other entities that control, are
controlled by, or are under common control with that entity. For the purposes of this definition,
"control" means (i) the power, direct or indirect, to cause the direction or management of such
entity, whether by contract or otherwise, or (ii) ownership of fifty percent (50%) or more of the
outstanding shares, or (iii) beneficial ownership of such entity.

"You" (or "Your") shall mean an individual or Legal Entity exercising permissions granted by this
License.

"Source" form shall mean the preferred form for making modifications, including but not limited to
software source code, documentation source, and configuration files.

"Object" form shall mean any form resulting from mechanical transformation or translation of a
Source form, including but not limited to compiled object code, generated documentation, and
conversions to other media types.

"Work" shall mean the work of authorship, whether in Source or Object form, made available under
the License, as indicated by a copyright notice that is included in or attached to the work (an example
is provided in the Appendix below).

"Derivative Works" shall mean any work, whether in Source or Object form, that is based on (or
derived from) the Work and for which the editorial revisions, annotations, elaborations, or other
modifications represent, as a whole, an original work of authorship. For the purposes of this License,
Derivative Works shall not include works that remain separable from, or merely link (or bind by
name) to the interfaces of, the Work and Derivative Works thereof.

"Contribution" shall mean any work of authorship, including the original version of the Work and any
modifications or additions to that Work or Derivative Works thereof, that is intentionally submitted to
Licensor for inclusion in the Work by the copyright owner or by an individual or Legal Entity
authorized to submit on behalf of the copyright owner. For the purposes of this definition,
"submitted"means any form of electronic, verbal, or written communication sent to the Licensor or its
representatives, including but not limited to communication on electronic mailing lists, source code
control systems, and issue tracking systems that are managed by, or on behalf of, the Licensor for
the purpose of discussing and improving the Work, but excluding communication that is conspicuously
marked or otherwise designated in writing by the copyright owner as "Not a Contribution."

"Contributor" shall mean Licensor and any individual or Legal Entity on behalf of whom a Contribution
has been received by Licensor and subsequently incorporated within the Work.

2. Grant of Copyright License. Subject to the terms and conditions of this License, each Contributor
hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable
copyright license to reproduce, prepare Derivative Works of, publicly display, publicly perform,
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sublicense, and distribute the Work and such Derivative Works in Source or Object form.

3. Grant of Patent License. Subject to the terms and conditions of this License, each Contributor
hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable
(except as stated in this section) patent license to make, have made, use, offer to sell, sell, import,
and otherwise transfer the Work where such license applies only to those patent claims licensable by
such Contributor that are necessarily infringed by their Contribution(s) alone or by combination of
their Contribution(s) with the Work to which such Contribution(s) was submitted. If You institute
patent litigation against any entity (including a cross-claim or counterclaim in a lawsuit) alleging that
the Work or a Contribution incorporated within the Work constitutes direct or contributory patent
infringement, then any patent licenses granted to You under this License for that Work shall
terminate as of the date such litigation is filed.

4. Redistribution. You may reproduce and distribute copies of the Work or Derivative Works thereof in
any medium, with or without modifications, and in Source or Object form, provided that You meet
the following conditions:

a) You must give any other recipients of the Work or Derivative Works a copy of this License; and

b) You must cause any modified files to carry prominent notices stating that You changed the files;
and

c) You must retain, in the Source form of any Derivative Works that You distribute, all copyright,
patent, trademark, and attribution notices from the Source form of the Work, excluding those
notices that do not pertain to any part of the Derivative Works; and

d) If the Work includes a "NOTICE" text file as part of its distribution, then any Derivative Works that
You distribute must include a readable copy of the attribution notices contained within such
NOTICE file, excluding those notices that do not pertain to any part of the Derivative Works, in at
least one of the following places: within a NOTICE text file distributed as part of the Derivative
Works; within the Source form or documentation, if provided along with the Derivative Works; or
within a display generated by the Derivative Works, if and wherever such third-party notices
normally appear. The contents of the NOTICE file are for informational purposes only and do not
modify the License. You may add Your own attribution notices within Derivative Works that You
distribute, alongside or as an addendum to the NOTICE text from the Work, provided that such
additional attribution notices cannot be construed as modifying the License.

You may add Your own copyright statement to Your modifications and may provide additional or
different license terms and conditions for use, reproduction, or distribution of Your modifications, or
for any such Derivative Works as a whole, provided Your use, reproduction, and distribution of the
Work otherwise complies with the conditions stated in this License.

5. Submission of Contributions. Unless You explicitly state otherwise, any Contribution intentionally
submitted for inclusion in the Work by You to the Licensor shall be under the terms and conditions of
this License, without any additional terms or conditions. Notwithstanding the above, nothing herein
shall supersede or modify the terms of any separate license agreement you may have executed with
Licensor regarding such Contributions.

6. Trademarks. This License does not grant permission to use the tradenames, trademarks, service
marks, or product names of the Licensor, except as required for reasonable and customary use in
describing the origin of the Work and reproducing the content of the NOTICE file.

7. Disclaimer of Warranty. Unless required by applicable law or agreed to in writing, Licensor
provides the Work (and each Contributor provides its Contributions) on an "AS IS" BASIS, WITHOUT
WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied, including, without limitation,
any warranties or conditions of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
PARTICULAR PURPOSE. You are solely responsible for determining the appropriateness of using or
redistributing the Work and assume any risks associated with Your exercise of permissions under this
License.

8. Limitation of Liability. In no event and under no legal theory, whether in tort (including
negligence), contract, or otherwise, unless required by applicable law (such as deliberate and grossly
negligent acts) or agreed to in writing, shall any Contributor be liable to You for damages, including
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any direct, indirect, special, incidental, or consequential damages of any character arising as a result
of this License or out of the use or inability to use the Work (including but not limited to damages for
loss of goodwill, work stoppage, computer failure or malfunction, or any and all other commercial
damages or losses), even if such Contributor has been advised of the possibility of such damages.

9. Accepting Warranty or Additional Liability. While redistributing the Work or Derivative Works
thereof, You may choose to offer and charge a fee for, acceptance of support, warranty, indemnity,or
other liability obligations and/or rights consistent with this License. However, in accepting such
obligations, You may act only on Your own behalf and on Your sole responsibility, not on behalf of any
other Contributor, and only if You agree to indemnify, defend, and hold each Contributor harmless for
any liability incurred by, or claims asserted against, such Contributor by reason of your accepting any
such warranty or additional liability

END OF TERMS AND CONDITIONS

APPENDIX: How to apply the Apache License to your work.

To apply the Apache License to your work, attach the following boilerplate notice, with the fields enclosed
by brackets "[]" replaced with your own identifying information. (Don't include the brackets!) The text
should be enclosed in the appropriate comment syntax for the file format. We also recommend that a file
or class name and description of purpose be included on the same "printed page" as the copyright notice
for easier identification within third-party archives.

Copyright [yyyy] [name of copyright owner]

Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in
compliance with the License.

You may obtain a copy of the License at:
http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the License is
distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express
or implied. See the License for the specific language governing permissions and limitations under the
License.

ProtoZero Copyright

protozero copyright (c) Mapbox.

Redistribution and use in source and binary forms, with or without modification, are permitted provided
that the following conditions are met:

e Redistributions of source code must retain the above copyright notice, this list of conditions and the
following disclaimer.

e Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
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THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
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Vector Tile License

Copyright (c) 2016, Mapbox

Permission to use, copy, modify, and/or distribute this software for any purpose with or without fee is
hereby granted, provided that the above copyright notice and this permission notice appear in all copies.

THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES WITH REGARD
TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO
EVENT SHALL THE AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL
DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS,
WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
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XPression

Contact Us

Contact our friendly and professional support representatives for the following:
¢ Name and address of your local dealer

e Product information and pricing

e Technical support

e Upcoming trade show information

Telephone: +1-844-652-0645 (North America)
Technical +800 1005 0100 (International)
Support After Hours Emergency: +1 613 e 349 « 0006
Email: techsupport@rossvideo.com
Telephone: +1 613 « 652 « 4886
General Fax: +1 613 e 652 ¢ 4425
Information Email: solutions@rossvideo.com
Website: http://www.rossvideo.com

Visit Us

Visit our website for:
e Company information and news
e Related products and full product lines

¢ Online catalog

e Testimonials
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