
XPression Distributed Workflow
User Guide

VERSION 12.0



Thank You for Choosing Ross

You've made a great choice. We expect you will be very happy with your purchase of Ross
Technology.

Our mission is to:

1. Provide a Superior Customer Experience

· offer the best product quality and support

2. Make Cool Practical Technology

· develop great products that customers love

Ross has become well known for the Ross Video Code of Ethics. It guides our interactions and
empowers our employees. I hope you enjoy reading it below.

If anything at all with your Ross experience does not live up to your expectations be sure to reach
out to us at solutions@rossvideo.com.

David Ross

CEO, Ross Video

dross@rossvideo.com

Ross Video Code of Ethics

Any company is the sum total of the people that make things happen. At Ross, our employees are
a special group. Our employees truly care about doing a great job and delivering a high quality
customer experience every day. This code of ethics hangs on the wall of all Ross Video locations
to guide our behavior:

1. We will always act in our customers’ best interest.

2. We will do our best to understand our customers’ requirements.

3. We will not ship crap.

4. We will be great to work with.

5. We will do something extra for our customers, as an apology, when something big goes wrong
and it's our fault.

6. We will keep our promises.

7. We will treat the competition with respect.

8. We will cooperate with and help other friendly companies.

9. We will go above and beyond in times of crisis. If there's no one to authorize the required
action in times of company or customer crisis - do what you know in your heart is right. (You
may rent helicopters if necessary.)

mailto:solutions@rossvideo.com
mailto:dross@rossvideo.com
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Important Regulatory and Safety Notices
to Service Personnel

Before using this product and any associated equipment, refer to the "Important Safety Instructions"
listed below so as to avoid personal injury and to prevent product damage.

Products may require specific equipment, and /or installation procedures be carried out to satisfy certain
regulatory compliance requirements. Notices have been included in this publication to call attention to
these specific requirements.

Symbol Meanings

Protective Earth — This symbol identifies a Protective Earth (PE) terminal, which is
provided for connection of the supply system’s protective earth (green or green/yellow)
conductor.

The exclamation point within an equilateral triangle is intended to alert the user to the
presence of important operating and maintenance (servicing) instructions in the literature
accompanying the product. Failure to heed this information may present a risk of damage
or injury to persons or equipment.

Warning — The symbol with the word "Warning" within the equipment manual indicates
a potentially hazardous situation, which if not avoided, could result in death or serious
injury

Caution — The symbol with the word "Caution" within the equipment manual indicates a
potentially hazardous situation, which if not avoided, may result in minor or moderate
injury. It may also be used to alert against unsafe practices.

Notice — The symbol with the word "Notice" within the equipment manual indicates a
situation, which if not avoided, may result in major or minor equipment damage or a
situation, which could place the equipment in a non-compliant operating state. 

Warning Hazardous Voltage — The lightning flash with arrowhead symbol within an
equilateral triangle is intended to alert the user to the presence of uninsulated "dangerous
voltage" within the product's enclosure that may be of sufficient magnitude to constitute a
risk of shock to persons

ESD Susceptibility — This symbol is used to alert the user that an electrical or electronic
device or assembly is susceptible to damage from an ESD event.



Important Safety Instructions

1) Read these instructions.

2) Follow all instructions and heed all warnings.

3) Refer all servicing to qualified service personnel.

4) The equipment's AC appliance inlets are the means to disconnect the
product from the AC Mains and must remain readily operable for this
purpose.

5) Parts of the equipment's power supplies can still present a safety hazard
even when the product is in the "OFF" state. To avoid the risk of electrical
shock and to completely disconnect the apparatus from the AC Mains,
remove all power supply cords from the product's AC appliance inlets prior
to servicing.

6) If the product nameplate indicates that the chassis is “Rack Mounted”, it
is to be rack mounted only. To ensure safe operation and maintain long-
term system reliability, proper installation requires that the front and back
area of the chassis remain clear of obstructions so as not to restrict airflow.

7) The Optical Disk Drive within this product is a “Laser - Class 1 product”.

Warning 8) No operator access to internal parts in this product. The power supply
outputs are considered an Energy Hazard (>240VA). To avoid the risk of
contact with the Energy Hazard and to completely de-energize the
apparatus, remove all power supply cords from the product’s AC appliance
inlet(s) prior to servicing.

Warning 9) Indoor Use: To reduce the risk of fire or electric shock, do not expose
this apparatus to rain or moisture.

Warning 10) This product includes an “Ethernet Port” which allows this product to be
connected to a local area network (LAN). Only connect to networks that
remain inside the building. Do not connect to networks that go outside the
building.

Caution 11) This apparatus contains a Lithium battery, which if replaced incorrectly,
or with an incorrect type, may cause an explosion. Replace only with the
same type recommended by the manufacturer. Dispose of used batteries
according to the manufacturer's instruction by qualified service personnel.

Caution /

Attention

12) This unit may have more than one power supply cord. Disconnect all
power supply cords before servicing to avoid electric shock / Cet appareil
peut comporter plus d’un cordon d’alimentation. Afin de prévenir les chocs
électriques, debrancher tous les cordons d’alimentation avant de faire le
dépannage.



Use of Hazardous Substances in Electrical and Electronic Products (China RoHS)

Ross Video Limited has reviewed all components and processes for compliance to:

“Management Methods for the Restriction of the Use of Hazardous Substances in Electrical and Electronic
Products” also known as China RoHS.

The “Environmentally Friendly Use Period” (EFUP) and Hazardous Substance Tables have been
established for all products.

The Hazardous substances tables are available on our website at:

http://www.rossvideo.com/about-ross/company-profile/green-practices/china-rohs.html 

              

Ross Video Limited                      

“                  ”      RoHS 

       “      ”(EFUP                           

            

http://www.rossvideo.com/about-ross/company-profile/green-practices/china-rohs.html 

http://www.rossvideo.com/about-ross/company-profile/green-practices/china-rohs.html
http://www.rossvideo.com/about-ross/company-profile/green-practices/china-rohs.html


EMC Notices

US
FCC Part 15

This equipment has been tested and found to comply with the limits for a class A Digital device, pursuant
to part 15 of the FCC Rules. These limits are designed to provide reasonable protection against harmful
interference when the equipment is operated in a Commercial environment. This equipment generates,
uses, and can radiate radio frequency energy and, if not installed and used in accordance with the
instruction manual, may cause harmful interference to radio communications. Operation of this
equipment in a residential area is likely to cause harmful interference in which case the user will be
required to correct the interference at his own expense.

Notice Changes or modifications to this equipment not expressly approved by
Ross Video Ltd. could void the user’s authority to operate this equipment.

CANADA

This Class “A” digital apparatus complies with Canadian ICES-003. 

Cet appareil numerique de la classe “A” est conforme a la norme NMB-003 du Canada.

EUROPE

This equipment is in compliance with the essential requirements and other relevant provisions of CE
Directive 93/68/EEC.

AUSTRALIA

This equipment has been tested to AS/NZS CISPR32:2015 AMD1:2020 and found to comply with the
limits for a Class A Digital device.

INTERNATIONAL

This equipment has been tested to CISPR 32:2015 AMD1:2019 and found to comply with the limits for
a Class A Digital device.

Notice This is a Class A product. In domestic environments, this product may
cause radio interference, in which case the user may have to take
adequate measures.

KOREA



Warranty and Repair Policy

Ross Video Limited (Ross) warrants its XPression Distributed Workflow systems to be free from defects
under normal use and service for the following time periods from the date of shipment:

· XPression Distributed Workflow Server — 12 months

· XPression Distributed Workflow Software Upgrades — 12 months free of charge

· System and Media hard drives — 12 months

If an item becomes defective within the warranty period Ross will repair or replace the defective item, as
determined solely by Ross.

Warranty repairs will be conducted at Ross, with all shipping FOB Ross dock. If repairs are conducted at
the customer site, reasonable out-of-pocket charges will apply. At the discretion of Ross, and on a
temporary loan basis, plug in circuit boards or other replacement parts may be supplied free of charge
while defective items undergo repair. Return packing, shipping, and special handling costs are the
responsibility of the customer.

This warranty is void if products are subjected to misuse, neglect, accident, improper installation or
application, or unauthorized modification.

In no event shall Ross Video Limited be liable for direct, indirect, special, incidental, or consequential
damages (including loss of profit). Implied warranties, including that of merchantability and fitness for a
particular purpose, are expressly limited to the duration of this warranty.

This warranty is TRANSFERABLE to subsequent owners, subject to Ross’ notification of change of
ownership.

Extended Warranty

For customers that require a longer warranty period, Ross offers an extended warranty plan to extend
the standard warranty period by one year increments. For more information about an extended
warranty for your XPression Distributed Workflow system, contact your regional sales manager.



Environmental Information

The equipment that you purchased required the extraction and use of natural resources for its
production. It may contain hazardous substances that could impact health and the environment.

To avoid the potential release of those substances into the environment and to diminish the need for
the extraction of natural resources, Ross Video encourages you to use the appropriate take-back
systems. These systems will reuse or recycle most of the materials from your end-of-life equipment in an
environmentally friendly and health conscious manner.

The crossed-out wheeled bin symbol invites you to use these systems.

If you need more information on the collection, reuse, and recycling systems, please contact your local or
regional waste administration.

You can also contact Ross Video for more information on the environmental performances of our
products.



Company Address

Ross Video Limited 

8 John Street
Iroquois, Ontario
Canada, K0E 1K0

Ross Video Incorporated 

P.O. Box 880
Ogdensburg, New York
USA 13669-0880

General Business Office:

Fax:

(+1) 613 · 652 · 4886

(+1) 613 · 652 · 4425

Toll Free Technical Support: 1-844-652-0645 (North America)

+800 3540 3545 (International)

Alternately, you can contact:

Technical Support: (+1) 613 · 652 · 4886

After Hours Emergency: (+1) 613 · 349 · 0006

E-mail for Technical Support: techsupport@rossvideo.com

E-mail for General Information: solutions@rossvideo.com

Website: http://www.rossvideo.com

mailto:techsupport@rossvideo.com?Subject=Information Request&Body=Hi,%0D%0D
mailto:solutions@rossvideo.com?Subject=Information Request&Body=Hi,%0D%0D
http://www.rossvideo.com
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Introduction
In today's fast-paced news, sports, branding, and entertainment environments, the best graphics
engines are only as good as the workflow tools that take those graphics to air. XPression offers a
complete line of hardware and software products for efficient collaboration and media moving.

About This Guide

This user guide describes the XPression MOS, NLE, and Template Builder workflows, their configuration,
and functions.

If, at any time, you have a question pertaining to the installation, configuration, or operation of the
XPression workflow tools, please contact us at the numbers listed in the section Contacting Technical
Support. Our technical staff are always available for consultation, training, or service.

Documentation Conventions

Special text formats are used in this guide to identify parts of the user interface, text that a user must
enter, or a sequence of menus and sub-menus that must be followed to reach a particular command.

Bold text Bold text identifies a user interface element such as a dialog box, menu item,
or button.

For example:

In the Slug column, type a slug name for the story.

Italic text Italic text is used to identify the titles of referenced guides, manuals, or
documents.

For example:

For more information, refer to the DashBoard User Guide.

Courier text Courier text identifies text that a user must type.

For example:

In the Username box, type postgres.

Menu Sequences Menu arrows are used in procedures to identify a sequence of menu items that
you must follow.

For example:

If a step reads Server > Save As, you would select the Server menu and
then select Save As.

Hypertext Identifies a hyperlink to a related topic.



XPression Distributed Workflow User Guide (v12.0) Introduction • 2

Getting Help

XPression Distributed Workflow documentation is available online at Product Documentation and is also
accessible on the product USB key and by selecting the Help icon in the user interface.

Contacting Technical Support

At Ross Video, we take pride in the quality of our products, but if problems occur, help is as close as the
nearest telephone.

Our 24-hour Hot Line service ensures you have access to technical expertise around the clock. After-
sales service and technical support is provided directly by Ross Video personnel. During business hours
(Eastern Time), technical support personnel are available by telephone. After hours and on weekends, a
direct emergency technical support phone line is available. If the technical support person who is on call
does not answer this line immediately, a voice message can be left and the call will be returned shortly.
This team of highly trained staff is available to react to any problem and to do whatever is necessary to
ensure customer satisfaction.

Technical Support:

· 1-844-652-0645 (North America)

· +800 3540 3545 (International)

· After Hours Emergency: (+1) 613-349-0006

· E-mail: techsupport@rossvideo.com

· Website: http://www.rossvideo.com

https://www.rossvideo.com/support/product-documentation
mailto:techsupport@rossvideo.com
http://www.rossvideo.com
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User Interface Overviews
This section provides user interface overviews for the various components used in the XPression
distributed workflow. For information on the XPression Project Server, refer to the XPression Project
Server User Guide.

The following user interfaces are discussed in this section:

The XPression Gateway User Interface

The XPression ActiveX MOS Plugin User Interface - Browse

The XPression ActiveX MOS Plugin User Interface - Graphics

The XPression ActiveX MOS Plugin User Interface - Clips

The XPression ActiveX MOS Plugin User Interface - Edit Graphics

The XPression ActiveX MOS Plugin User Interface - Edit Clips

The XPression ActiveX MOS Plugin User Interface - Lucid

The XPression HTML5 MOS Plugin User Interface Overview - Browse

The XPression HTML5 MOS Plugin User Interface Overview - Graphics

The XPression HTML5 MOS Plugin User Interface Overview - Lucid

The XPression HTML5 MOS Plugin User Interface Overview - Edit

The XPression NLE Plugin and Edius Plugin User Interface - Templates

The XPression NLE Plugin and Edius Plugin User Interface - Edit Mode

The XPression Template Builder User Interface - Templates

The XPression Template Builder User Interface - Edit Mode

The XPression Rundown Controller User Interface

The XPression Remote Sequencer User Interface

The XPression Remote Sequencer User Interface (Legacy)
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XPression Gateway User Interface

The following screen capture displays the main elements of the XPression Gateway user interface.
Descriptions of individual elements are contained below the diagram.

1. Menu Bar — access the Gateway menu.

2. Output Engines List — lists the output engines
that have been configured for each XPression
system being used for playout.

3. Preview and Offline Render Engines, and
Lucid Studio Daeons List — lists the preview
engines that have been configured for each
XPression Bluebox OFL system being used for
motion and still preview in the XPression MOS
Plugin, NLE Plugin, Template Builder, Lucid
Studio, and Remote Sequencer.

4. MOS Object Monitor — displays the currently
monitored and MOS active rundowns on the
Gateway. Stories that contain graphics can be
expanded to view the associated MOS objects.

5. Log Area — displays the activities of the
Gateway. Select a tab to view the activity log
for the Gateway, the information sent or
received by the Gateway, or the connected
plugin clients, user, last activity, and
connection time.



5 • User Interface Overviews XPression Distributed Workflow User Guide (v12.0)

XPression ActiveX MOS Plugin User Interface - Browse

The following screen capture displays the main elements of the XPression ActiveX Plugin user interface
Browse tab. Descriptions of individual elements are contained below the diagram.

1. Saved Items Folders — view and select
graphics, clips, or rundowns from the folders
list.

2. Options Menu — open the Configuration
dialog or select the primary or secondary MOS
Gateway.

3. Thumbnails / List — view and select graphics
or clips from the Browse tab display results.
Use the filter at the top to locate specific
graphics or clips.

4. Display — select the viewing method (Tile,
Thumbnail, or List), resize thumbnails, and
refresh the display results.

5. Button Controls — connect to an OpenMAM
server or close the plugin. The other buttons
will only become active if there is a graphic or
clip open for editing in the Edit tab.



XPression Distributed Workflow User Guide (v12.0) User Interface Overviews • 6

XPression ActiveX MOS Plugin User Interface - Graphics

The following screen capture displays the main elements of the XPression ActiveX Plugin user interface
Graphics tab. Descriptions of individual elements are contained below the diagram.

1. Show / Filter — displays the selected show.
Use the filter to display specific saved graphic
templates.

2. Thumbnails / List — view and select graphics
in either thumbnail or list views.

3. Options Menu — open the Configuration
dialog or select the primary or secondary MOS
Gateway.

4. Button Controls — connect to an OpenMAM
server or close the plugin. The Add to Story
and OK buttons will only become active if there
is a graphic open in the Edit tab. The Update
Story and Cancel Edit buttons become active
only when editing a graphic directly from the
newsroom system.
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XPression ActiveX MOS Plugin User Interface - Clips

The following screen capture displays the main elements of the XPression ActiveX Plugin user interface
Clips tab. Descriptions of individual elements are contained below the diagram.

XPression Clips is optional for XPression and the XPression MOS workflow. If you do not have XPression
Clips. If you do not have XPression Clips and you are interested in adding it to your workflow, please
contact your Ross Video sales representative.

1. Search Area — use the Quick Find search field
to display specific saved clips, or click the
Show/Hide advanced search button to enter
detailed search criteria. Use the Reset search
filter button to clear all search fields.

2. Clips — view and select clips from the list.

3. Options Menu — open the Configuration
dialog or select the primary or secondary MOS
Gateway.

4. Create Placeholder — create a placeholder for
a clip that will be added to the story at a later
time.

5. Button Controls — connect to an OpenMAM
server or close the plugin. The Add to Story
and OK buttons will only become active if there
is a clip open in the Edit tab. The Update Story
and Cancel Edit buttons become active only
when editing a clip directly from the newsroom
system.
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XPression ActiveX MOS Plugin User Interface - Edit
Graphics

The following screen capture displays the main elements of the XPression ActiveX Plugin user interface
in Edit tab for graphics. Descriptions of individual elements are contained below the diagram.

1. Show / Filter — displays the selected show.
Use the filter to display specific saved graphic
templates.

2. Thumbnails / List — view and select graphics
in either thumbnail or list views.

3. Editor — edit the Object/Field contents and
template playout information and to run a Spell
Check on text. Select the Save button to save
any changes.

4. Preview Area — view the graphic template
and any changes made in the Editor. Use the
playback controls to play animations.

5. Options Menu — open the Configuration
dialog or select the primary or secondary MOS
Gateway.

6. Button Controls — connect to an openMAM
server, add the graphic to a story, add the
graphic to a story and close the plugin in one
operation (OK), or close the plugin without
adding the graphic to a story (Cancel). The
Update Story and Cancel Edit buttons become
active only when editing a graphic directly from
the newsroom system.
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XPression ActiveX MOS Plugin User Interface - Edit Clips

The following screen capture displays the main elements of the XPression ActiveX Plugin user interface
in Edit tab for clips. Descriptions of individual elements are contained below the diagram.

«XPression Clips is optional for XPression and the XPression MOS workflow. If you do not have

XPression Clips. If you do not have XPression Clips and you are interested in adding it to your workflow,
please contact your Ross Video sales representative.

1. Search Area — use the Quick Find search field
to display specific saved clips, or select the
Show/Hide advanced search button to enter
detailed search criteria. Use the Reset search
filter button to clear all search fields.

2. Clips — view and select clips from the list.

3. Editable Settings — edit the Channel, Layer
and Description of the clip.

4. Preview Area — preview the clips and use the
playback controls to control preview playback.

5. Options Menu — open the Configuration
dialog or select the primary or secondary MOS
Gateway.

6. Button Controls — connect to an openMAM
server, add the clip to a story, add the clip to a
story and close the plugin in one operation
(OK), or close the plugin without adding the
clip to a story (Cancel). The Update Story and
Cancel Edit buttons become active only when
editing a graphic directly from the newsroom
system.
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XPression ActiveX MOS Plugin User Interface - Lucid

The following screen capture displays the main elements of the XPression ActiveX MOS Plugin user
interface Lucid tab. Descriptions of individual elements are contained below the diagram.

1. Filter — locate specific Lucid events. 

2. Project — select a Lucid project from the drop-
down.

3. Thumbnails — view and select Lucid events.
Double-clicking a thumbnail opens the selected
event in the Edit tab.

4. Button Controls — connect to an OpenMAM
server or close the plugin. The Add to Story
and OK buttons will only become active if there
is an event open in the Edit tab. The Update
Story and Cancel Edit buttons become active
only when editing an event directly from the
newsroom system.
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XPression HTML5 MOS Plugin User Interface - Browse

The following screen capture displays the main elements of the XPression HTML5 Plugin user interface
Browse tab. Descriptions of individual elements are contained below the diagram.

1. Saved Items Folders — view and select
graphics, clips, or rundowns from the folders
list.

2. Search — locate specific graphics or clips and
then select the Refresh icon to update the
thumbnail results.

3. Settings - access the MOS ID, Spell Check
dictionary and Miscellaneous settings.

4. Display — select the viewing method (Grid,
Details, or Table), and re-size thumbnails,.

5. Thumbnails — view and select graphics or clips
in the Browse tab display results. 
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XPression HTML5 MOS Plugin User Interface - Graphics

The following screen capture displays the main elements of the XPression HTML5 Plugin user interface
Graphics tab. Descriptions of individual elements are contained below the diagram.

1. Search — locate specific graphics or clips and
then select the Refresh icon to update the
thumbnail results.

2. Show / Filter — displays the selected show.
Use the filter to display specific saved graphic
templates.

3. Settings - access the MOS ID, Spell Check
dictionary and Miscellaneous settings.

4. Expand / Collapse / Thumbnails / List —
expand or collapse the categories and then
view and select graphics in either thumbnail or
list views.

5. Thumbnails — view and select graphics or
clips. Double-clicking a thumbnail opens the
selected graphic in Edit mode.
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XPression HTML5 MOS Plugin User Interface - Lucid

The following screen capture displays the main elements of the XPression HTML5 Plugin user interface
Lucid tab. Descriptions of individual elements are contained below the diagram.

1. Search — locate specific Lucid events and then
select the Reload List icon to update the
thumbnail results.

2. Project — select a Lucid project from the drop-
down.

3. Settings - access the MOS ID, Spell Check
dictionary and Miscellaneous settings.

4. Thumbnails — view and select Lucid events.
Double-clicking a thumbnail opens the selected
event in the Edit tab.
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XPression HTML5 MOS Plugin User Interface - Clips

The following screen capture displays the main elements of the XPression HTML5 Plugin user interface
Clips tab. Descriptions of individual elements are contained below the diagram.

XPression Clips is optional for XPression and the XPression MOS workflow. If you do not have XPression
Clips. If you do not have XPression Clips and you are interested in adding it to your workflow, please
contact your Ross Video sales representative.

1. Search Area — use the Quick Find search field
to display specific saved clips, or select the
Show/Hide advanced search options button
to enter detailed search criteria. Select the
Reload List icon to update the thumbnail
results.

2. Clips — view and select clips from the list.

3. OpenMAM - select an OpenMAM server.

4. Settings - access the MOS ID, Spell Check
dictionary and Miscellaneous settings.

5. View Menu — select how the clips will be
displayed, either in a Table or Grid.

6. Create Placeholder — create a placeholder for
a clip that will be added to the story at a later
time.
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XPression HTML5 MOS Plugin User Interface - View

The following screen capture displays the main elements of the XPression HTML5 Plugin user interface
View tab. Double-clicking a clip in the Clips tab opens the clip in the View tab. Descriptions of individual
elements are contained below the diagram.

XPression Clips is optional for XPression and the XPression MOS workflow. If you do not have XPression
Clips and you are interested in adding it to your workflow, please contact your Ross Video sales
representative.

1. Editable Settings — edit the Channel, Layer
and Description of the clip in this section.

2. Preview Area — preview the clip. Use the
playback controls to control preview playback.

3. Settings - access the MOS ID, Spell Check
dictionary and Miscellaneous settings.

4. Button Controls — connect to an openMAM
server, add the clip to a story, add the clip to a
story and close the plugin in one operation
(OK), or close the plugin without adding the
clip to a story (Cancel). The Update Story and
Cancel Edit buttons become active only when
editing a graphic directly from the newsroom
system.
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XPression HTML5 MOS Plugin User Interface - Edit

The following screen capture displays the main elements of the XPression HTML5 Plugin user interface
Edit tab for graphics. Descriptions of individual elements are contained below the diagram.

1. Editor — edit the object/field contents and
template playout information. 

2. Preview Area — view the graphic template
and any changes made in the Editor. Use the
playback controls to play animations.

3. Settings - access the MOS ID, Spell Check
dictionary and Miscellaneous settings.

4. Button Controls — check the spelling of your
edits, add a graphic to a story, add a graphic
to a story and close the plugin in one operation
(OK) or close the plugin without adding the
graphic to a story (Cancel). The Update Story
and Cancel Edit buttons become active only
when editing a graphic directly from the
newsroom system.
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XPression NLE Plugin and Edius Plugin User Interface -
Browse

The following screen capture displays the main elements of the XPression NLE Plugin user interface
Browse tab. Descriptions of individual elements are contained below the diagram.

1. Saved Items Folders — view and select
graphics, clips, or rundowns from the folders
list.

2. Options Menu — open the Configuration
dialog or select the primary or secondary MOS
Gateway.

3. Thumbnails / List — view and select graphics
or clips from the Browse tab display results.
Use the filter at the top to locate specific
graphics or clips.

4. Display — select the viewing method (Tile,
Thumbnail, or List), resize thumbnails, and
refresh the display results.
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XPression NLE Plugin and Edius Plugin User Interface -
Graphics

The following screen capture displays the main elements of the XPression NLE Plugin user interface
Graphics tab. Descriptions of individual elements are contained below the diagram.

1. Show / Filter — displays the selected show.
Use the filter to display specific saved graphic
templates.

2. Thumbnails / List — view and select graphics
in either thumbnail or list views.

3. Options and Button Controls — open the
Configuration dialog or select the primary or
secondary MOS Gateway. Use the button
controls to apply or cancel changes.
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XPression NLE Plugin and Edius Plugin User Interface -
Edit

The following screen capture displays the main elements of the XPression NLE Plugin user interface in
Edit Mode. Descriptions of individual elements are contained below the diagram.

1. Show / Filter — displays the selected show.
Use the filter to display specific saved graphic
templates.

2. Thumbnails / List — view and select graphics
in either thumbnail or list views.

3. Options and Button Controls — open the
Configuration dialog or select the primary or
secondary MOS Gateway.

4. Editor — view and edit the objects and fields
of the template and to save graphics.

5. Preview Area — view the template and any
changes made in the Editor. Use the playback
controls to play animations.
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XPression Template Builder User Interface - Templates

The following screen capture displays the main elements of the XPression Template Builder user
interface in Templates mode. Descriptions of individual elements are contained below the diagram.

1. Thumbnails / List — view and select templates
in thumbnail or list views. Use the filter at the
top to locate specific templates.

2. Saved Graphics — view and select saved
graphics. Use the filter at the top to locate
specific saved graphics.

3. Options and Button Controls — open the
Configuration dialog or select the primary or
secondary MOS Gateway. Use the button
controls to apply or cancel changes.



21 • User Interface Overviews XPression Distributed Workflow User Guide (v12.0)

XPression Template Builder User Interface - Edit Mode

The following screen capture displays the main elements of the XPression Template Builder user
interface in Edit Mode. Descriptions of individual elements are contained below the diagram.

1. Editor — view and edit the objects and fields
of the template and to save graphics.

2. Preview Area — view the template and any
changes made in the Editor. Use the playback
controls to play animations.

3. Options Menu — open the Configuration
dialog or select the primary or secondary MOS
Gateway.
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XPression Rundown Controller User Interface

The following screen capture displays the main elements of the XPression Rundown Controller user
interface. Descriptions of individual elements are contained in the legend below the diagram.

1. Menu Bar — access the File menu.

2. Toolbar — select the Gateway Connection and
the Channel Group.

3. Rundown List — view and select rundowns
and show styles.

4. Selection Area — filter through rundowns and
apply the selected rundown settings.
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XPression Remote Sequencer User Interface

The following screen capture displays the main elements of the XPression Remote Sequencer user
interface. Descriptions of individual elements are contained below the diagram.

1. Menu Bar — access the File, Docking, and
Display menus.

2. Toolbar — select rundowns, Connection
Points, and Channel Groups, select saved
docking layouts, and view the status of
connections to the Gateway, Project Server,
ClipStore, and DataLinq Server.

3. Channels — view, select, and modify the items
on a particular channel in the Linear Rundown.

4. Scene Manager — view and manage the
scenes and scene groups contained in a
project.

5. Linear Rundown — view and control a list of
scenes or scene groups.

6. Next Up Preview — displays the upcoming
take items in the queue.

7. Take Item Inspector / Clip Browser — toggle
between the Take Item Inspector and the
Clip Browser. Use the Take Item Inspector to
edit the properties of a selected group or take
item. Use the Clip Browser to browse for clips
to drop into the Linear Rundown for preview
and playout.

8. Up Next Preview — preview the upcoming
scene.
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XPression Remote Sequencer User Interface (Legacy)
The following screen capture displays the main elements of the XPression Remote Sequencer (Legacy)
user interface. Descriptions of individual elements are contained below the diagram.

1. Menu Bar — access the File, Docking, and
Help menus.

2. Toolbar — select rundowns, access and edit
Connection Points and Channel Groups, and
use the Fast Recall feature.

3. Sequencer — view and control a list of scenes
or scene groups.

4. Preview Area — displays the upcoming take
items in the queue.

5. Status Area — displays the current status of
the Remote Sequencer.



25 • MOS Workflow Setup XPression Distributed Workflow User Guide (v12.0)

MOS Workflow Setup
The XPression Gateway serves as a communication hub between the customer supplied newsroom
control system and the various XPression components required to complete the XPression MOS
workflow. The XPression MOS Plugin, XPression Remote Sequencer, XPression Rundown Controller,
XPression preview engine, and Clip Store Server all connect to the XPression Gateway. MOS messages
created using the MOS plugin are added to stories in the customer supplied newsroom control system.
These MOS messages are then parsed from active rundowns by the XPression Gateway and used to
create take items in the necessary XPression playout device.

Before you start using the XPression MOS workflow, the various components and settings need to be
configured for operability.

The following topics are described in this section:

Required Components

Optional Components

Setting Up the XPression Gateway

Setting Up and Using Multiple XPression Gateways

Setting Up the XPression ActiveX MOS Plugin

Setting Up the XPression HTML5 MOS Plugin

Installing an SSL Certificate for the XPression HTML5 MOS Plugin
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Required Components

The following is a list of the required components for the XPression MOS workflow:

· XPression Gateway

· XPression Studio, Prime, or BlueBox OFL (preview engine)

· XPression MOS Plugin or HTML5 MOS Plugin

· XPression Studio/Prime/BlueBox (playout engine)

If you are using Lucid Studio in your MOS workflow, you will also need the following:

· Lucid Studio

· Lucid Driver for XPression

· Lucid MOS Service

Optional Components

The following items are optional for the XPression MOS workflow:

· XPression Project Server

· XPression Remote Sequencer

· XPression Rundown Controller

· XPression Desktop Preview Server

· Supported MAM system

· XPression Clips

· XPression Tessera (requires project-based region mapping and XPression Project Server)

For More Information on...

· The XPression Gateway user interface, refer to The XPression Gateway User Interface.

· The XPression MOS Plugin user interface, refer to The XPression ActiveX MOS Plugin User Interface -
Graphics and The XPression ActiveX MOS Plugin User Interface - Clips.
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Setting Up the XPression Gateway

The following steps explain the XPression Gateway configuration for the MOS workflow.

«If you have any Citrix programs installed, such as GoToMeeting, ensure that the DNE LightWeight

Filter is disabled in the Local Area Connection Properties window of any machine that is connected to
the XPression Gateway, including the XPression Gateway itself.

To configure the XPression Gateway:

1. Open the XPression Gateway application.

2. Select Gateway > Settings.

By default, the XPression Gateway - Settings window opens in the Gateway configuration area.

Gateway Settings

3. Configure each section of the XPression Gateway Settings (as needed) as described in the
following procedures.

Gateway Channel Groups DataLinq

Rundowns Preview & Offline Engines OverDrive

Client Plugins Project Server Running Order Export

MOS Objects Clip Store HTTP Server

Remote Sequencer Persistent Templates Lucid Studio Integration

Output Engines Saved Items Reserved Client Slots

Virtual Channel Mapping OpenMAM Miscellaneous
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Gateway

Use the Gateway section to configure the Media Object and Running Order ports and MOS IDs as well
as the MOS Objects and message behavior and MOS Message encoding.

For information on using a secondary gateway, see Using Multiple XPression Gateways.

To configure the Gateway settings:

1. In the MOS Server section, in the Media Object Port field enter or select a port number on which
the newsroom control system will accept connections from MOS devices. 

The default port is 10540.

«Only change the Media Object Port number if there is a port conflict.

Gateway Settings

2. In the Running Order Port field, enter or select a port number on which the MOS server will accept
connections from the newsroom control system. 

The default port is 10541.

«Only change the Running Order Port number if there is a port conflict.

3. In the Primary MOS ID field, enter the MOS ID that you are using in your newsroom control system.

An optional secondary ID can be entered in the Secondary MOS ID field.

4. In the NRCS ID field, enter your newsroom control system ID.

5. In the MOS Objects & Messages section, configure the following options as necessary:

· Parse roStorySend Messages — select this checkbox to parse all incoming MOS objects, including
those for unrelated devices. It is recommended that this option be left unselected if not using multiple
gateways.

«Some newsroom systems require this feature to be selected for basic functionality (for example,

Dalet).
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· Select the Accept Items With Incorrect MOS ID checkbox to allow the XPression Gateway to
accept items with incorrect MOS IDs. 

This requires parsing the roStorySend MOS messages to see the other MOS ID objects.

· Don’t Send Status Messages — select this checkbox to disable reporting the MOS status of
graphics and clips to the NRCS.

6. In the MOS Message Encoding section, configure the following options as necessary:

· Use UTF8 — select this checkbox for 8-bit character encoding.

· Encode MOS Payload — select this checkbox to encode the MOS payload of MOS items to avoid
issues with Unicode and older versions of some newsroom systems.

· Strip Unicode Chars from MOS Abstracts — select this checkbox to remove Unicode characters in
the MOS abstracts or slugs if the newsroom system does not support Unicode text.

7. Select OK to save and then close the XPression Gateway Settings window or continue with
configuring other settings.
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Rundowns

Use the Rundowns section to configure settings for handling rundown behavior.

To configure the Rundowns settings:

1. Select Rundowns to configure the rundown settings.

The Rundowns configuration section opens.

Rundowns Settings

2. In the Settings section, select the Auto Activate New Rundowns checkbox to automatically trigger
new rundowns.

3. Select the Don’t Delete Active Rundowns checkbox to prevent rundowns from being removed while
they are still activated for playout.

4. Select the Deactivate rundown checkbox to hold a rundown active for a specified number of minutes
after the NRCS stops monitoring it.

5. Use the Minutes field to enter or select the amount of time to wait before deactivating the rundown. 

6. Select OK to save and then close the XPression Gateway Settings window or continue with
configuring other settings.
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Client Plugins

Use the Client Plugins section to configure global plugin settings and to configure the custom layers
available in the layer drop-down menu in the MOS plugin

To configure the Client Plugins settings:

1. Select Client Plugins to configure the plugin settings.

The Client Plugins configuration section opens.

Client Plugins Settings

2. In the Global Settings section, in the Plugin Server Port field, enter or select a port number on
which the XPression MOS Plugin will communicate with the XPression Gateway. 

The default is 10550.

«Only change the Plugin Server Port number if there is a port conflict.

3. Configure the following options as necessary:

· Enforce the Gateway’s MOS ID — select this checkbox to set the MOS ID in any connected
ActiveX or HTML5 plugin to the MOS ID entered in the XPression Gateway.

It is recommended that this option be selected.

· Enable MOS Timing Fields — select this checkbox to allow in and out information to be inserted
into the MOS message for autonomous triggering of graphics.

· Default Inpoint — enter or select a default in point time for the MOS message.

· Default Duration — enter or select a default duration time for the MOS message.

«Check with your newsroom and production automation provider to see if this functionality is

supported.

· Enable Remote Plugin Updates — select this checkbox to prompt users of the XPression ActiveX
Plugin to update the plugin if the version does not match the version of the XPression Gateway.
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· Show Template List on Edit Mode tab — select this checkbox to allow users of the XPression
ActiveX Plugin to browse templates while the plugin is in edit mode.

· Empty Material Fields Show as <none> — select this checkbox to remove the display of <none>
from empty material fields.

· Disable Channel and Layer — select this checkbox to disable the channel and layer settings for
the MOS objects.

· Hide frames in timing fields — select this checkbox to hide frames in the ActiveX and HTML5 Plugin
timing fields.

· Enable OverDrive Fields — select this checkbox to enable the use of fields for the OverDrive
automation system.

· Enable Mosart Fields — select this checkbox to enable the use of fields for the Mosart automated
news system.

· Enable Ignite Fields — select this checkbox to enable the use of fields for the Ignite automated
news system.

· Hide hours in timing fields — select this checkbox to hide the hours in timing fields in the ActiveX
Plugin.

· Collapse multiple spaces in text — select this checkbox to remove extra spaces between words.

4. In the Layer Options section, select the Edit Custom Layers button.

The Custom Layer List window opens.

Custom Layer List

5. Perform the following to edit and add layers as necessary:

· Select a layer in the list and edit the Name and Layer assignments as necessary.

· Select Add to add a new layer to the list and edit the Name and Layer assignments as necessary.

· Select a layer in the list and select Delete to remove the selected layer.

· Use the Move Up and Move Down buttons to move a selected layer up or down within the list.

6. Select Close to exit the Custom Layer List window.
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7. From the Default Layer dropdown, select a layer as the default layer assignment for a MOS
generated take item. 

The options are:

· Default for Channel — assign take items to the default layer for the framebuffer.

· Default for Template — assign take items to the layer assignment of the scene object.

Use the following default layer options to have scenes play on the selected layer:

· Layer -3 (background) 

· Layer -2 

· Layer -1 

· Layer 0 (middle) 

· Layer 1 

· Layer 2 

· Layer 3 (foreground) 

8. In the Render Options section, select the Clients connect directly to offline and preview engines
checkbox to direct ActiveX clients to render directly to the offline and preview engines.

9. Select OK to save and then close the XPression Gateway Settings window or continue with
configuring other settings.
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MOS Objects

Use the MOS Objects section to configure MOS abstracts for the MOS items.

A MOS abstract is a human-readable description of a MOS item. Most newsroom systems will display the
MOS abstract to the user in the MOS story. The MOS abstract can be configured to contain a number of
different descriptive fields that will automatically be populated based on the contents of the MOS item.

To configure the MOS Objects settings:

1. Select MOS Objects to configure the MOS object settings.

The MOS Objects configuration section opens.

MOS Objects Settings

2. In the MOS Abstract section, in the Maximum MOS Abstract Length field, enter or select a maximum
number of characters for the MOS abstracts.

3. In the Format field, use tags to build a descriptive text string that will be used to format the MOS
abstract field. 

Any characters outside of a given tag will be carried over to the MOS abstract. For example:
@TEMPLATE@:@CONTENT@ may become ‘Lower Third:First Name’.

The format can also be entered by right-clicking inside the box and selecting Insert Format and
selecting the necessary tag from the shortcut menu.

The available tags are:

· @TEMPLATE@ · @INPOINT@ · @GWID@ 

· @CLIP@ · @OUTPOINT@ · @TYPE@ 

· @CONTENT@ · @DURATION@ · @TAKEID@ 

· @DESCRIPTION@ · @CHANNEL@ · @OUTMETHOD@ 

· @TIMING@ · @VCNAME@ 
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Some newsrooms (for example, Autocue) display the ObjSlug field to the user instead of the MOS
abstract. Select the Apply MOS Abstract format to objSlug field checkbox to use the MOS abstract
format definition to build up the objSlug field.

4. In the Options section, select the Include Item Timing in MOS Editorial Fields checkbox to include
the item timing in the editorial time fields of the MOS object.

5. In the Tessera section, use the Value for <itemChannel> field field to enter the item abstract value
for the itemChannel tags of MOS objects when using Tessera with MOS workflow. 

The default value is TESSERA.

6. Select OK to save and then close the XPression Gateway Settings window or continue with
configuring other settings.
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Remote Sequencer

Use the Remote Sequencer section to configure the Remote Sequencer server port.

To configure the Remote Sequencer settings:

1. Select Remote Sequencer.

The Remote Sequencer configuration section opens.

Remote Sequencer Settings

2. In the Server section, in the Sequencer Server Port field, enter or select the port number for the
Remote Sequencer.

3. In the Settings section, in the Purge locally modified MOS Items older than field, enter a time in
days or hours to purge modified MOS items on a local folder. 

4. Select the Days or Hours radio button to set the respective unit of time until the purge.

5. Select the Disable Channel and Layer Fields to...

6. Select OK to save and then close the XPression Gateway Settings window or continue with
configuring other settings.
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Output Engines

In the Output Engines section you can configure XPression output engines and also XPression Tessera
master/single engines for use in a MOS workflow.

To configure XPression Output Engines:

1. Select Output Engines to configure the output engine settings.

The Output Engines configuration section opens.

XPression Output Engines Settings

2. Use the Output Engines section to add and configure XPression output engines or XPression Tessera
masters/single engines for use in a MOS workflow, as described below:

«Add an output engine for each XPression system being used for on air playout.

3. In the Output Engines section, select Add.

The XPression Output Engine window opens.

Add Output Engine

4. In the Engine ID section, in the Name field, enter an ID for the output engine.

5. In the Description field, enter a brief description for the output engine.
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6. In the Remote XPression Engine section, in the Host field, enter the IP address of the XPression
system for the output engine.

7. In the Port field, enter or select the port number for the XPression system.

8. Select OK.

The XPression Output Engine window closes and the output engine is added to the Output Engines
list.

To configure XPression Tessera Masters/Solo engines:

1. In the Tessera Masters / Solo Engines section, select Add.

The XPression Tessera Master window opens.

Configure XPression Tessera Details and Network Settings

2. In the Tessera Details section: 

· In the Name field, enter the name of the Tessera master or solo engine.

· In the Description field, enter a brief description for the Tessera master or solo engine.

3. In the Network Settings section:

In the Host field, enter the IP address of the Tessera master or solo engine.

In the Port field, enter or select the port number for the Tessera master or solo engine.
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4. If using a Tessera master (and not a solo engine), select Add in the Tessera Output Nodes section
to add output engines for the Tessera master.

The XPression Output Engine window opens.

Add XPression Tessera Master Output Engine

5. In the Engine ID section:

· In the Name field, enter the name of the Tessera output node.

· In the Description field, enter a brief description for the Tessera output node.

6. In the Remote XPression Engine section:

In the Host field, enter the IP address of the Tessera output node.

In the Port field, enter or select the port number for the Tessera output node.

7. Select OK.

The XPression Output Engine window closes and the output node is added to the Tessera Output
Nodes list.

8. Repeat steps 4 to 7 for any other output nodes.

9. Select OK.

The XPression Tessera Master window closes and the Tessera master or solo engine is added to
the Tessera Masters / Solo Engines list.

Repeat steps 1 to 7 for any other Tessera masters or solo engines.

10.Select OK to save and then close the XPression Gateway Settings window or continue with
configuring other settings.
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Virtual Channel Mapping

Virtual channels represent an individual layer on a specific output. This makes it possible to configure
more virtual channels than there are physical outputs because a virtual channel can be configured for
one of potentially many layers used on the output.

To add a Virtual Channel:

1. Select Virtual Channel Mapping to configure individual outputs on separate devices into a single
pool of output channels for operation.

The Virtual Channel Mapping configuration section opens.

Virtual Channel Mapping Settings

2. In the Channels section, select Add.

The Virtual Channel Routing window opens.

Virtual Channel Routing

3. In the Channel ID section, in the Name field, enter an ID for the channel.
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4. In the Description field, enter a brief description for the channel.

To configure the virtual channel mapping:

1. From the Engine Routing list, select the checkbox of the engine you want to use.

2. Right-click inside the Output column of the selected engine and enter or select the output to use for
the engine.

Virtual Channel - Select Output

3. Right-click inside the Layer column of the selected engine and enter or select the layer to use for the
engine.

4. If you are using XPression Clips with the MOS workflow, right-click inside the Server Channel
column of the selected engine and enter or select the virtual server channel for previewing and
playing out clips.

5. In the Desktop Preview Server Channel field, enter or select a preview output channel from the
Desktop Preview Server.

6. Select OK.

The Virtual Channel Routing window closes and the channel and engine are added to the Channels
list.

7. Select OK to save and then close the XPression Gateway Settings window or continue with
configuring other settings.
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Channel Groups

Channel groups need to be configured before the MOS workflow is functional.

Channel groups are a way of organizing virtual channels and activating them on multiple output engines
in different locations.

«If you have configured a Lucid Studio Engine in Lucid Studio Integration and added it to a channel

group, a custom Lucid channel window will appear in the Remote Sequencer, after the other channel
windows. Lucid items in the project will only appear in this custom channel window.

The diagram below illustrates just one example of how you might use channel groups to facilitate your
workflow.
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To configure channel groups:

1. Select Channel Groups.

The Channel Groups configuration section opens.

Channel Group Settings

2. In the Channel Groups section, select Add.

The Channel Group Settings window opens.

Add Channel Group

3. In the Channel Group section, in the Name field, enter a name for the channel group.

4. In the Description field, enter a brief description for the channel group.
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5. Under the Allowed IPs field, select Add to enter the IP addresses of the Remote Sequencers that
can use the new channel group.

 Leaving the field blank allows all Remote Sequencers to use that channel group.

6. In the Running Order Filter field, select Add to enter a list of running order slugs to limit the running
orders that can be loaded to the channel group.

Wildcards are allowed, such as *6PM*, to further filter the running orders. Leaving the field blank
allows all running orders to use that channel group.

7. In the Active Engines section, for each channel, select the check box for the engine(s) that will be
active on that channel.

8. Select OK.

The Channel Group Settings window closes and the channel group is added to the Channel Groups
list.

9. Select OK to save and then close the XPression Gateway Settings window or continue with
configuring other settings.
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Preview & Offline Engines

A preview engine needs to be added for motion and still preview in the XPression MOS Plugin and
XPression Remote Sequencer.

To configure Preview & Offline Engines:

1. Select Preview & Offline Engines.

The Preview & Offline Engines configuration section opens.

Preview & Offline Engines Settings

2. In the Preview & Offline Render Engines section, select Add.

The XPression Preview Engine window opens.

Add Preview Engine

3. In the Engine ID section, in the Name field, enter an ID for the engine.

4. In the Description field, enter a brief description for the engine.
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5. In the Remote XPression Engine section, in the Host field, enter the IP address of the XPression
system for the preview engine.

6. In the Port field, enter or select the port number for the XPression system.

7. In the Options section, select the Reserve engine for NLE client rendering checkbox to send
preview requests from the NLE to any OFL engine(s) reserved for NLE use.

Any MOS plugin requests will be sent to the non-reserved OFL engines. If all OFL engines in the
Gateway have this checkbox enabled, MOS plugin requests will go to any of the OFL engines. If none
of the OFL engines have this checkbox enabled, previews from NLE clients will be assigned to any
one of the OFL engines.

8. Select OK.

The XPression Preview Engine window closes and the preview engine is added to the Preview &
Offline Render Engines list.

9. If you are using an XPression Desktop Preview Server, continue with the next section.

Otherwise, select OK to save and close the XPression Gateway Settings window or continue with
configuring other settings.

To configure the Desktop Preview Server:

1. Select the Enabled checkbox in the Desktop Preview Server section.

2. Configure the Host and Port settings. 

3. In the Up Next Channel field, select the preview channel for the preview that is going to air next.

4. Select OK to save and then close the XPression Gateway Settings window or continue with
configuring other settings.
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Project Server

The XPression Project Server is optional for the XPression MOS workflow. If you do not have the Project
Server, proceed to the next section. If you are interested in adding the XPression Project Server to your
workflow, please contact your Ross Video sales representative.

The Project Server offers centralized storage and creative collaboration within a facility or across an
enterprise. Designers and operators can access any XPression project from any XPression workstation,
share projects while working locally, then re-publish to the server.

The login and password must be configured in the Project Server before you can connect to the
XPression Gateway. For more information, refer to the Project Server User Guide.

To configure the Project Server settings:

1. Select Project Server.

The Project Server configuration section opens.

Project Server Settings

2. In the Project Server section, select the Enabled checkbox to use the Project Server.

3. In the Host field, enter the IP address of the Project Server.

4. In the Port field, enter or select the port number for the Project Server.

5. In the Login field, enter your username for the Project Server.

6. In the Password field, enter the password for your Project Server login.

7. Select the Allow all plugin users to access any project checkbox to allow all plugin users to access
any project from the Project Server.

8. Select the Legacy Project Server checkbox if you have updated your XPression software, but are
still using an older version of the Project Server.

9. Select OK to save and then close the XPression Gateway Settings window or continue with
configuring other settings.
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Clip Store

XPression Clips is optional for XPression and the XPression MOS workflow. If you do not have XPression
Clips, proceed to the next section. If you are interested in adding the XPression Clips to your workflow,
please contact your Ross Video sales representative. 

With a Clip Store configured on the XPression Gateway, the XPression MOS Plugin offers the ability to
browse, preview, and select clips as MOS items to include in an NRCS running order. It integrates with
the XPression output and preview engines and the Remote Sequencer.

To configure the Clip Store:

1. Select Clip Store.

The Clip Store configuration section opens.

Clip Store Settings

2. In the Clip Store Server section, select the Enabled checkbox to use the Clip Store Server in the
MOS workflow.

3. In the Host field, enter the IP address of the Clip Store Server.

4. In the Port field, enter or select the port number for the Clip Store Server.

5. Select the Use HTTPS / SSL checkbox to enable the use of HTTPS/SSL in the HTTP Server
configuration. 

When selected, the HTTP Port field automatically populates with the port number found in the HTTP
Server settings section of the XPression Gateway - Settings.

Selecting this option requires a pre-installed SSL certificate. See Installing an SSL Certificate for
further information.

6. Select the Resolve hostname before sending to plugins checkbox to resolve the ClipStore hostname
to an IP before it is provided to the client plugins.

7. In the Clips Settings section, from the Default Channel dropdown, select the default engine and
channel to which the clips will be assigned.
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8. Select the Clips added to running order should be recalled via their Recall ID checkbox to retrieve
clips added to a rundown using their recall IDs. 

When this feature is selected, if newer versions of clips are incoded, the new version will be recalled.

Configure the following options as necessary:

· Default the placeholder Recall ID to reflect the clip name (overwrite enabled) — select this
checkbox to make the recall ID match the clip name.

Ø Force the placeholder Recall ID to reflect the clip name (overwrite disabled) — select this
checkbox to force the recall ID to match the clip name if Default the placeholder Recall ID to
reflect the clip name is enabled.

· Hide 'Remove Recall ID' button in plug in — select this checkbox to hide the Remove Recall ID
button in the plugin when creating a placeholder.

9. Select OK to save and then close the XPression Gateway Settings window or continue with
configuring other settings.
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Persistent Templates

Use the Persistent Templates section to save persistent graphics in the XPression MOS Plugin to a
folder in the XPression Gateway engine.

To configure Persistent Templates settings:

1. Select Persistent Templates.

The Persistent Templates configuration section opens.

Persistent Templates Settings

2. In the Path field, enter a file path or click Browse (...) to open a file browser to select a folder to
which graphics will be saved from the XPression MOS Plugin and XPression Template builder.

3. Select the Delete source file after parsing checkbox to delete the source file once it has been saved
to the watch folder.

4. Select OK to save and then close the XPression Gateway Settings window or continue with
configuring other settings.
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Saved Items

Saved Items are templates that are saved to the XPression Gateway and edited via the XPression MOS
ActiveX or HTML5 Plugins. These pre-populated templates can be saved in user-configured folders that
can be stored permanently, or in the daily graphics folder that can be automatically purged after a user-
defined duration. 

You can add top-level folders through Windows Explorer. See To add a new top-level folder To add sub-
folders, see Adding and Deleting Folders (ActiveX) and Adding and Deleting Folders (HTML5).

To configure the Saved Items settings:

1. Select Saved Items.

The Saved Items configuration section opens.

Saved Items Settings

2. In the Database section, in the Path field, enter a file path or click Browse (...) to open a file
browser to select a permanent or daily graphics folder.

3. From the Date format drop-down, select a date format for the date that the graphic was saved. 

The options are:

· dd-mm-yyyy — Day-Month-Year (for example, 15-07-2015)

· mm-dd-yyyy — Month-Day-Year (for example, 07-15-2015)

· yyyy-mm-dd — Year-Month-Day (for example, 2015-07-15)

4. In the Purge daily templates after X days field, enter or select the number of days after which the
daily graphics folder will be purged. 

Set to 0 for no purging.

5. Select OK to save and then close the XPression Gateway Settings window or continue with
configuring other settings.
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To add a new top-level folder:

1. In Windows File Explorer, browse to C:\SavedGraphics.

2. Right-click in a blank area and select New > Folder.

3. Give the folder a name.

4. Close File Explorer.

5. Close and re-open the XPression MOS Editor.

You will now see your new folder in the Saved Items structure.

Add New Folder

To delete a top-level folder:

1. In Windows File Explorer, browse to C:\SavedGraphics.

2. Right-click the folder you want to delete and from the menu, select Delete.
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OpenMAM

«OpenMAM is optional for XPression MOS workflow. If you are not using Dali, MediaBeacon 3.0,

MediaBeacon 5.0, Streamline, or XPression Maps asset management systems, proceed to the next
section.

If you are configuring an OpenMAM driver, refer to the section Adding and Configuring an OpenMAM
Server.

XPression Gateway Settings - OpenMAM
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DataLinq

Use the DataLinq section to connect to the XPression DataLinq Server, enabling you to import data from
multiple sources for use in your graphics.

To configure DataLinq settings:

1. Select DataLinq.

The DataLinq configuration section opens.

XPression Gateway Settings - DataLinq Settings

2. In the Datalinq Options section, select the Enable Datalinq Server checkbox to enable the
connection to the DataLinq Server in the DataLinq Connection Settings section below.

3. Select the MOS/NLE Plugins connect to Datalinq Server directly checkbox to directly connect the
plugins to the DataLinq Server.

Selecting this checkbox results in DataLinq messaging bypassing the XPression Gateway. Clearing
this checkbox results in the DataLinq messaging traveling through the XPression Gateway and the
XPression Gateway managing the connections. This path through the XPression Gateway is required
for the HTML5 plugin.

4. In the DataLinq Server section, in the Host field, enter the IP address of the XPression DataLinq
Server.

5. In the Port field, enter or select the port number for the XPression DataLinq Server.

6. Select OK to save and then close the XPression Gateway Settings window or continue with
configuring other settings.
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OverDrive

OverDrive is a production control system that enables control over all the devices used in a production
environment.

To configure Overdrive settings:

1. Select OverDrive.

The OverDrive configuration section opens.

OverDrive Settings

2. In the OverDrive Settings section, select the Accept Incoming Connections checkbox to enable the
XPression Gateway to accept incoming connections from OverDrive for automatic rundown activation.

3. In the Port field, enter or select the port number for the incoming OverDrive connections.

4. From the Channel Group drop-down, select a pre-configured channel group for the OverDrive
connection. 

Channel groups need to be configured in the Channel Groups configuration section of the XPression
Gateway settings before they are available for selection for the OverDrive connection.

5. Select OK to save and then close the XPression Gateway Settings window or continue with
configuring other settings.
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Running Order Export

Use the Running Order Export section to configure the settings for exporting running orders to an XML
file.

To configure the Running Order Export settings:

1. Select Running Order Export.

The Running Order Export configuration section opens.

Running Order Export Settings

2. In the Export Options section, select the Enable Running Order Export checkbox to export running
orders to an XML file.

The XML file can be used by DataLinq to provide running order information in XPression graphics.

3. Select the Start at Current Active Story checkbox to place the current on-air story at the top of the
XML file.

4. Select the Exclude Stories with Empty Headline Field checkbox to ensure that graphics without
headlines do not make it to air.

5. In the Headline Field field, enter the path to the customizable headline field in the MOS object to be
written to the exported rundown.

6. In the Headline Qualifier field, enter the path to the customizable headline qualifier in the MOS
object to be written to the exported rundown.

7. In the Destination Folder field, enter a folder path or click Browse (...) to open a file browser and
navigate to the folder to use for the exported running order XML file.

8. Select OK to save and then close the XPression Gateway Settings window or continue with
configuring other settings.
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HTTP Server

Use the HTTP Server settings to enable and configure a web server.

To configure HTTP Server settings:

1. Select HTTP Server.

The HTTP Server configuration section opens.

HTTP Server Settings

2. In the Web Server Settings section, select the Enable Web Server checkbox to use the HTML5 MOS
Plugin.

3. In the Port field, enter or select the port number of the HTML5 MOS Plugin.

4. In the Client Timeout field, enter or select the number of minutes after which the plugin will timeout.

5. Select the Use HTTPS / SSL checkbox to establish an encrypted link between the web server and
the browser.

A pre-installed SSL (Secure Sockets Layer) certificate is required. See Installing an SSL Certificate.

6. In the Server Settings section:

·  In the Plugin Asset Root Folder field, enter a folder path or click Browse (...) to open a file
browser and navigate to a folder to store the assets used in the plugin. 

 This folder will be seen in the plugin as the root location when the user chooses Select in a
material field to browse for an image or video to insert.

· Select the Show Add to Story Button checkbox to display the Add to Story button in the HTML5
MOS Plugin interface.

· Select the Show OK Button checkbox to display the OK button in the HTML5 MOS Plugin interface.

· Select the Show Cancel Button checkbox to display the Cancel button in the HTML5 MOS Plugin
interface.
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· Select the Show Update Story Button checkbox to display the Update Story button in the HTML5
MOS Plugin interface.

· Select the Edit mode cleared by drag checkbox to enable Edit mode to be canceled automatically
when a drag motion is detected within the window.

· Select the Block non NRCS user checkbox to block users without an NRCS.

7. Select OK to save and then close the XPression Gateway Settings window or continue with
configuring other settings.
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Lucid Studio Integration

Lucid Studio is an application that provides operational control of renderers, with server and logic
capabilities. 

You need to make sure you are using the correct version of Lucid Studio with your XPression system.
Lucid Studio 7.0 is compatible with XPression 11.5.5821.

To use Lucid Studio with XPression, you'll need to configure the Lucid Studio Integration settings in the
XPression Gateway and enable the Lucid Studio engine in a channel group. 

«When you have configured a Lucid Studio Engine and added it to a channel group, a custom Lucid

channel window will appear in the Remote Sequencer, after the other channel windows. Lucid items in
the project will only appear in this custom channel window.

To configure Lucid Studio Integration settings:

1. Select Lucid Studio Integration.

The Lucid Studio Integration configuration section opens.

Lucid Studio Integration

2. In the Lucid Studio Integration section, select the Enabled checkbox to enable Lucid Studio
integration with MOS.

3. In the Lucid MOS Service Host field, enter the IP address of the machine running Lucid MOS Service.

The Port is automatically detected.
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4. In the Lucid Studio Engines section, select Add.

The Lucid Studio Engine window opens.

Add Lucid Studio Engine

5. In the Lucid Studio ID section, in the Name field, enter a name for the engine.

6. In the Description field, enter a description, such as the location of the engine (optional).

7. Ensure the Synchronize Running Orders on Project Load checkbox is selected.

8. In the Connection Settings section, in the Host field, enter the IP address of the machine running
Lucid Studio.

The Port number 7791 is entered by default. If this port is in use, enter a different port number.

9. Select OK to save and close the XPression Gateway Settings window or continue with configuring
other settings.

To enable the Lucid Studio Engine in a Channel Group:

1. From the Gateway Settings list on the left side, select Channel Groups.

The Channel Groups configuration window opens.

XPression Gateway Settings - Channel Groups
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2. In the Channel Groups section, select Add.

The Channel Group Settings window opens.

XPression Gateway Settings - Channel Group Settings

3. Configure the Channel Group Settings as follows:

· In the Channel Group section, in the Name field, enter a name for the channel group you want to
use to play your MOS stories.

·  In the Description field, enter a description for the channel group.

· In the Allowed IPs panel, if you want to limit the Remote Sequencers that can use the new
channel group, click Add and enter the IP addresses of permitted Remote Sequencers.

 Leaving the field blank allows all Remote Sequencers to use that channel group.

· In the Active Engines section, select the Lucid Studio Engine 1 (or whatever you have named the
engine) checkbox to send Lucid Studio scenes to the engine and then click OK. 
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4. Select OK to save the settings and then close the XPression Gateway Settings window or continue
with configuring other sections.

Communication is now established and can be confirmed by looking at the MOS section of the Lucid
MOS Service application. There will be a notification saying “Receiving from XPression Gateway”
with the version and build number as shown in the image below.

XPression Gateway and Lucid MOS Communication Established

For More Information on...

Lucid Studio integration with MOS, refer to the Lucid Studio User Guide.
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Reserved Client Slots

This section is reserved for future development.
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Miscellaneous

The Miscellaneous section contains a few general settings.

 To configure the Miscellaneous settings:

1. Select Miscellaneous.

The Miscellaneous configuration section opens.

Miscellaneous Settings

2. In the Misc section, select the Start With Windows checkbox to launch the XPression Gateway upon
Windows startup.

3. Select the Show Gateway Online / Offline controls checkbox to display the online and offline radio
button options in the XPression Gateway interface.

 This will allow you to take the gateway offline so that it will not communicate with the engines when
multiple gateways are connecting to shared engines.

4. Select the Enable TCP Keep Alive For ActiveX Plugins checkbox to prevent the ActiveX TCP
connection from breaking during periods of inactivity.

5. In the Project Settings section, in the Frames Per Second field, enter or select a frame rate for
projects.

6. In the Running Orders Thumbnails section, select the Only render on plugin requests checkbox to
only render the thumbnails from a running order when selected in the Browse tab in the XPression
MOS Plugin, as opposed to having them render as soon as the running order is monitored.

7. In the Graphics / Clips section:

· Select the Enable Graphics tab in plugin checkbox to display the Graphics tab in the MOS Plugin
interface to use graphics in the MOS workflow.

· Select the Enable Clips tab in plugin checkbox to display the Clips tab in the MOS Plugin interface
to use clips in the MOS workflow.

8. Select OK to save and then close the XPression Gateway Settings window.
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Using Multiple XPression Gateways

In the event that the primary XPression Gateway fails, having multiple gateways allows for redundancy.
The secondary XPression Gateway must be connected to manually, as the fail-over is not automatic. The
following procedures explain the configuration and use of multiple XPression Gateways within a MOS
workflow:

Setting Up Multiple XPression Gateways

Verifying the Connections

Switching Over to Another XPression Gateway
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Setting Up Multiple XPression Gateways

This section describes how to configure a primary and secondary XPression Gateway in your newsroom
control system. 

Once configured, ensure that the Online setting for the Engine Connections in the XPression Gateway
is selected for only one gateway and disabled for the other. You will also need to configure the
XPression ActiveX Plugin to connect to the primary and secondary XPression Gateways.

«The virtual channel mapping configuration should be identical in both XPression Gateways.

To configure the primary XPression Gateway:

1. Open an XPression Gateway to use as the primary gateway.

2. Select Gateway > Settings.

The XPression Gateway - Settings window opens.

3. Select Gateway.

The Gateway configuration section opens.

Gateway Settings

4. Configure the Gateway settings as follows:

· In the MOS Server section, in the Primary MOS ID field, enter the MOS ID for the primary
gateway you are using in your newsroom control system. 

The primary MOS ID is the local MOS ID.

· In the Secondary MOS ID field, enter the MOS ID for the secondary gateway you are using in your
newsroom control system.

· In the NRCS ID field, enter your newsroom control system ID.

· In the MOS Objects & Messages section, select the Parse roStorySend Messages checkbox.
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5. Select Rundowns.

The Rundowns configuration section opens.

Rundowns Settings

6. In the Settings section, ensure that the Auto activate new rundowns checkbox is cleared.

7. Select Miscellaneous.

The Miscellaneous configuration section opens.

Miscellaneous Settings - Multiple Gateways
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8. In the Misc section, select the Show Gateway Online / Offline controls checkbox to display the
Online/Offline radio button options for the Engine Connections in the XPression Gateway interface.

9. Select OK.

The XPression Gateway - Settings window closes.

To configure the Secondary XPression gateway:

1. On another machine, open the XPression Gateway to use as the secondary gateway.

2. Select Gateway > Settings.

The XPression Gateway - Settings window opens.

3. Select Gateway.

The Gateway configuration section opens.

Gateway Settings

4. Configure the Gateway settings as follows:

· In the MOS Server section, because the primary MOS ID is the local MOS ID, use the Primary MOS
ID field to enter the MOS ID for the secondary gateway you are using in your newsroom control
system. 

This should be the same ID entered for the Secondary MOS ID in the steps for configuring the
primary XPression Gateway.

· In the Secondary MOS ID field, enter the MOS ID for the primary gateway you are using in your
newsroom control system. 

This should be the same ID entered for the primary MOS ID in the steps for the primary XPression
Gateway.

· In the NRCS ID field, enter your newsroom control system ID.

· In the MOS Objects & Messages section, select the Parse roStorySend Messages checkbox.
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5. Select Rundowns.

The Rundowns configuration section opens.

Rundowns Settings

6. In the Settings section, ensure that the Auto activate new rundowns checkbox is disabled.

7. Select Miscellaneous.

The Miscellaneous configuration section opens.

Miscellaneous Settings - Multiple Gateways

8. In the Misc section, select the Show Gateway Online / Offline controls checkbox to display the
Online/Offline radio button options for the Engine Connections in the XPression Gateway interface.
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9. Select OK.

The XPression Gateway - Settings window closes.

To select which Gateway is online:

· In the top-right corner of the Gateway UI, select either Offline or Online for each gateway.

Gateway Online

To configure the XPression ActiveX MOS Plugin:

1. In the XPression ActiveX MOS Plugin, select Options > Configuration.

The XPression ActiveX MOS Plugin Configuration window opens.

XPression MOS ActiveX Plugin Configuration
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2. In the XPression MOS Gateways section, select Add.

The XPression Gateway Config window opens.

Add Primary and Secondary Gateways

3. In the XPression Gateway Settings section, in the Name field, enter a name for the XPression
Gateway.

4. In the Primary section, in the Host Address field, enter the IP address of the primary XPression
Gateway.

5. In the Server Port field, enter or select the port number of the XPression Gateway.

6. In the Secondary section, in the Host Address field, enter the IP address of the secondary
XPression Gateway.

7. In the Server Port field, enter or select the server port number of the secondary XPression Gateway.

8. Select OK.

The XPression Gateway Config window closes and the primary gateway with secondary host is
added to the XPression MOS Gateways list.

XPression MOS ActiveX Plugin - Configured
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9. Repeat steps 2 to 8 for any additional gateways.

Existing gateways in the list can be edited by selecting a gateway and clicking Edit, or removed by
selecting a gateway and clicking Delete.

To configure the XPression Remote Sequencer:

· configure a connection point for the primary XPression Gateway and a connection point for the
secondary XPression Gateway.

· configure a connection group for the primary XPression Gateway connection and a connection group
for the secondary XPression Gateway connection.

For More Information on...

· configuring the XPression Gateway, refer to Setting Up the XPression Gateway.

· configuring the XPression MOS Plugin, refer to Setting Up the XPression ActiveX MOS Plugin.

· configuring the connection points and groups in the XPression Remote Sequencer, refer to XPression
Remote Sequencer.
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Verifying the Connections

You can ensure the multiple XPression Gateway setup is functional by following the procedure below.

To verify the connections:

1. In the XPression MOS Plugin, click Options > Use Gateway and select:

· Secondary (if currently using the primary gateway)

· Primary (if currently using the secondary gateway)

2. Select Options > Configuration.

The XPression MOS Plugin Configuration window opens.

3. In the NRCS section, ensure the MOS ID of the gateway you selected in step 1 of this procedure is
displayed in the MOS ID box.

Switching to Another XPression Gateway

This procedure assumes that the primary gateway is used as the main gateway and that the secondary
is used as the fail-over gateway.

To switch to another XPression Gateway:

1. If the primary XPression Gateway fails or is taken offline for maintenance, in the Engine Connections
options in the top-right corner of the Primary XPression Gateway UI, select Offline.

Take Gateway Offline

2. In the secondary XPression Gateway, select Online for the Engine Connections.

3. In the XPression ActiveX Plugin, select Options > Use Gateway > Secondary.

OR

Open the HTML5 Plugin that is configured for the active XPression Gateway within the NRCS.

The MOS device is configured in the NRCS to connect to a single gateway. 

4. If you are using the XPression Remote Sequencer, from the Gateiway drop-down, select the
connection point assigned to the secondary XPression Gateway.
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Setting Up the XPression ActiveX MOS Plugin

The XPression ActiveX MOS plugin is accessed from within the customer supplied newsroom control
system. The plugin allows users to edit the contents of templates by manipulating published fields
defined during the template creation process. These edited templates can then be added to rundowns
as MOS messages in the newsroom control system.

«If you have any Citrix programs installed, such as GoToMeeting, ensure that the DNE LightWeight

Filter is disabled in the Local Area Connection Properties of any machine that is connected to the
XPression Gateway, including the XPression Gateway itself.

To set up the XPression ActiveX MOS Plugin:

1. Open the XPression ActiveX Plugin in the newsroom client.

ActiveX MOS Plugin
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2. In the bottom-left corner of the plugin, select Options > Configuration.

The XPression MOS ActiveX Plugin Configuration window opens.

ActiveX Plugin Configuration

3. In the XPression MOS Gateways section, select Add.

The XPression Gateway Configuration window opens.

XPression Gateway Configuration

4. In the XPression Gateway Settings section:

· In the Name field, enter a name for the XPression Gateway.

· In the Primary section, in the Host Address field, enter the IP address of the XPression Gateway.

· In the Server Port field, enter or select the port number of the XPression Gateway.

You can optionally configure a connection to a second XPression MOS Gateway using the Secondary
section.
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5. Select OK.

The gateway is added to the XPression MOS Gateways list.

XPression MOS Gateways

6. In the NRCS section, in the MOS ID field, enter the Primary MOS ID that has been entered in the
XPression MOS Gateway settings.

If you have selected Enforce the Gateway’s MOS ID in the Client Plugins section of the settings for
the XPression Gateway, the MOS ID will automatically appear in the MOS ID field.

7. In the Spell Check section, from the Dictionary drop-down, select a language for the spell check. 

Words can be added to a local dictionary per user.

8. In the XPression Local Preview Engine section:

· Select the Active checkbox if you are using a preview engine other than the one configured on the
XPression Gateway.

· In the Host Address field, enter the IP address of the preview engine.

· In the Server Port field, enter or select the port number of the preview engine.
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9. In the Misc section, configure the following:

· Floating Preview — select to display the preview in a scalable window detached from the plugin.

· Show Timing Fields — select to enable the In Point and Duration fields to be used by production
automation for automatically inserting and removing graphics.

· Show Hours set in Gateway — this setting is not editable in the plugin. If Hide hours in timing
fields is selected in the XPression Gateway > Client Plugins settings, this checkbox will be cleared.
If Hide hours in timing fields is not selected in the Client Plugins settings, this checkbox will be
selected.

· Show Hours in Timing Fields — select to enable hour counts in the In Point and Duration timing
fields.

· Show template list on Edit Mode tab — select to display the template list in the plugin while in edit
mode.

· Use Windows Explorer instead of Texture Browser — select to use Windows Internet Explorer to
browse for images and videos instead of the built-in texture browser.

10.Select OK.

The XPression ActiveX Plugin Configuration window closes.

For More Information on...

· setting up multiple gateways, refer to Setting Up Multiple XPression Gateways.

· using Spell Check, refer to Using Spell Check.
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Setting Up the XPression HTML5 MOS Plugin

The XPression HTML5 Plugin is accessed from within the customer supplied newsroom client system. The
plugin allows users to edit the contents of templates by manipulating published fields defined during the
template creation process. These edited templates can then be added to rundowns as MOS messages
in the newsroom system.

1. Open the XPression HTML5 Plugin in the newsroom client.

XPression HTML5 Plugin

2. Select the Configuration button ( ) in the top-right corner of the plugin interface.

3. The XPression HTML5 Plugin Configuration window opens.

XPression HTML5 Plugin - Configuration

4. In the NRCS section, in the MOS ID field, enter the MOS ID that has been entered in the XPression
Gateway.

If Enforce the Gateway’s MOS ID is selected in the Client Plugins section of the XPression
Gateway > Settings, the MOS ID will automatically appear in the MOS ID field and editing is
disabled.
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5. In the Spell Check section, from the Dictionary drop-down, select a language for the spell check. 

Words can be added to a custom dictionary that is saved on the XPression Gateway and shared by
all users.

6. In the Misc section, configure the following:

· Show Timing Fields — select this checkbox to add the In Point, Duration and Manual Timing
fields to the graphics editor to allow automation of the graphic.

· Show Console Logging — select this checkbox to enable viewing of the console logs within the
HTML5 interface for NRCS troubleshooting that does not facilitate a Chrome browser.

· MOS Object includes ncsitem/item depth — if using iNEWS, select this checkbox to enable MOS
objects to include the NRCS item/item depth. 

It is selected by default.

· Close OpenMAM window on drop — select to have the OpenMAM window close automatically after
dragging and dropping an asset into the plugin.

· Open floating preview on start — select to have the floating Preview window open when the
plugin is launched. 

«If you are running the HTML5 plugin in a Chrome browser, you'll need to enable popups in the

Chrome settings. Go to chrome://settings/content/popups.

· In the Number of clips to load per request field, enter or select the number of clips that will be
allowed to be loaded per request (optional).

7. Select Save.

The XPression HTML5 Plugin Configuration panel closes.
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Installing an SSL Certificate

In order for the XPression HTML5 plugin to operate over SSL/HTTPS connections, an SSL certificate must
be purchased and installed on the XPression Gateway server. This section outlines the steps.

Prerequisites

A purchased SSL certificate from a trusted root authority (our certificates are purchased from DigiCert,
so these instructions will use the steps for DigiCert as an example).

Buying an SSL Certificate

To purchase an SSL certificate, a CSR file must be generated and sent to the certificate authority. The
CSR file describes the server machine that will hold the certificate as well as the Company and
Organization details for the purchaser. This must be generated on the Gateway machine and must be
registered against the server/domain that the HTML5 plugins will use to connect to the gateway.

The CSR can usually be generated using a tool provided by the Certificate Authority (or they should
provide documentation on how to generate the CSR).

When purchasing from DigiCert, the platform can be specified as “Other”. This will provide you with .CRT
files containing the certificates.

Installing the Certificate

DigiCert provides a DigiCert Key Utility that can be used to install the three certificate files (Root,
Intermediate, and the actual gateway certificate).

Once the certificates have been installed, they must be configured and bound to the port that the
XPression Gateway will use.
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To add the Snap-in:

1. Open Windows MMC by pressing Win+R, typing MMC and pressing Enter.

2. In the Console1 window, from the File menu, select Add/Remove Snap-in.

SSL - Add/Remove Snap-ins

3. In the Available snap-ins list, double-click Certificates.

SSL - Certificates Snap-in
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4. In the Certificates snap-in dialog, select Computer Account and click Next.

SSL - Select Computer

5. In the Select Computer dialog, select Local Computer and select Finish.

6. In the Add or Remove Snap-ins dialog, select OK.

To select the certificate:

1. Select Personal > Certificates and find the certificate. 

In this example, it is *.rossvideo.com.

SSL - Select Certificate
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2. Double-click the certificate and go to Details->Thumbprint.

SSL - Certificate Details

3. Copy and paste the thumbprint text to a clipboard or notepad.

4. Open the Windows Command Prompt console as administrator and run the following command:

netsh http add sslcert ipport=0.0.0.0:9443 certhash=%thumbprint% appid= {3CF6A009-07A4-
4A80-BB43-F3A6E147B00A} 

where %thumbprint% will be the thumbprint you copied from MMC.

A message should be received indicating successful installation of the certificate.

To remove a certificate from a port:

· Open the Windows Command Prompt console as administrator and run the following command: 

netsh http delete sslcert ipport=0.0.0.0:9443 

Existing bindings must be deleted before a certificate can be reassigned to an existing port.
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To see a list of bound SSL certificates to ports:

· Open the Windows command prompt console as administrator and run the following command: 

netsh http show sslcert 

If the certificate is correctly bound, it will appear as follows:

SSL - Certificate Successfuly Bound

To configure the XPression Gateway:

· In the XPression Gateway in Settings > HTTP Server > Web Server Settings, select Use HTTPS /
SSL.

When HTTPS is enabled, the port will be forced to 9443.

SSL - HTTP Server - Use HTTPS / SSL



85 • MOS Workflow Setup XPression Distributed Workflow User Guide (v12.0)

Troubleshooting

If there are issues with the webserver starting on XPression Gateway, this command can be run from
the Windows Command Prompt console to view which URLs have been registered with the Web
Server:

netsh http show urlacl 

There should be three URLs registered against 9500 (if not using HTTPS), and 9443 (if using HTTPS):

SSL - Registered URLs

These URLs can be deleted if necessary, and the gateway will recreate them as needed, with the
following command (repeated 3 times for each of client, static, and plugin):

netsh http delete urlacl url=https://+:9443/CLIENT 

Certificate Not Attached to Private Key

If the certificate is manually imported into the personal certificate store (by right-clicking import in the
MMC certificate plugin); the certificate may not be linked with the private key.

This is visible by the certificate missing the “key” icon in its thumbnail:
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SSL - Missing Key Icon

If this is the case, open up the certificate and find its serial number:

SSL - Open Certificate

Then open the Windows Command Prompt console as administrator and run the following command:

certutil -repairstore my %serialnumber% 

where %serialnumber% is replaced with the serial number of the certificate.



87 • MOS Workflow Operation - XPression ActiveX MOS Plugin XPression Distributed Workflow User Guide (v12.0)

MOS Workflow Operation - XPression
ActiveX MOS Plugin
This section describes how to use the templates and saved graphics in the XPression MOS Plugin.

The following topics are discussed in this section:

Using Graphics in the XPression ActiveX MOS Plugin

Using Clips in the XPression ActiveX MOS Plugin

Assigning Take IDs to MOS Objects

Using Spell Check

Copying MOS Content from other Projects

Adding Resources from Streamline

Adding and Deleting Folders

For More Information on...

The XPression ActiveX MOS Plugin user interface, refer to:

XPression ActiveX MOS Plugin User Interface - Browse

XPression ActiveX MOS Plugin User Interface - Graphics

XPression ActiveX MOS Plugin User Interface - Clips

XPression ActiveX MOS Plugin User Interface - Edit Graphics

XPression ActiveX MOS Plugin User Interface - Edit Clips

XPression ActiveX MOS Plugin User Interface - Lucid
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Using Graphics in the XPression ActiveX MOS Plugin

In the Graphics tab you can select a graphic to be edited, edit a graphic from the plugin or from the
NRCS, and add graphics to a story in the NRCS. You can also browse the metadata of a graphic or
template. 

«When a scene is modified locally in XPression, the local modifications take precedence over changes

made in the XPression ActiveX Plugin.

ActiveX MOS Plugin - Graphics Tab

Selecting Graphics

Editing Graphics

Saving Graphics

Exporting Graphics to PNG

Adding and Editing a Graphic in the NRCS

Browsing Graphic Metadata

Formatting Text
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Selecting and Deleting Graphics

There are several ways to locate the graphic you want to edit: 

Browsing Graphics from the Project Server

Browsing Graphics Without Project Server

Selecting Saved Graphics

Selecting Graphics from the NRCS

Selecting Graphics from an OpenMAM Server

See the following section for how to delete graphics:

Deleting Graphics
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Browsing Graphics From the Project Server

«If a revision of a project is published in XPression, the XPression ActiveX Plugin will receive a

notification of the revision.

To browse graphics from the Project Server:

1. In the XPression ActiveX MOS plugin, select the Graphics tab.

2. In the top-left corner, select the Story Browse (...) button.

ActiveX MOS Plugin - Browse

The Show, Category and Style Selection window opens.

ActiveX MOS Plugin - Show, Category and Style Selection

3. From the Show and Category list, select a show and category.

4. From the Style list, select a style.

5. Select OK.

The Show, Category and Style Selection window closes and the graphics associated with the
selected style are available for selection in the Thumbnails / List.

6. Double-click a graphic from the Thumbnails or List.

OR

In the Filter field, enter a graphic name or keyword to search for specific graphics. 

The filter also searches the metadata of graphics when available.
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Browsing Graphics Without a Project Server

The available graphics are dictated by what has been loaded on the preview engine. This must be done
manually.

To browse graphics without a project server:

1. In the XPression ActiveX MOS plugin, select the Graphics tab.

2. Select a graphic from the Thumbnails or List tab. 

OR

In the Filter field, enter the name of a graphic or a keyword to search for specific graphics. 

The filter also searches the metadata of graphics when available.

Selecting Saved Graphics

· In the Browse tab, select a graphic from the Saved Items folder structure. 

These graphics need to have been pre-populated with information and saved to a user specified
folder.

Selecting Graphics from the NRCS

You can select graphics used in MOS rundowns that are being monitored by the XPression Gateway. The
graphics can be copied to other rundowns or modified from their current state using the Edit tab and
then added to a rundown.

To select a graphic from the NRCS:

· In the NRCS, in the Rundowns area, double-click a graphic to open it in the ActiveX MOS editor.

Deleting Graphics

You can delete saved graphics in the Browse tab.

To delete a graphic:

1. In the XPression ActiveX MOS plugin, select the Browse tab.

2. In the Browse tab, in the folder structure, browse to the graphic to be deleted. 

3. Right-click the graphic and from the context menu, select Delete Item.

ActiveX MOS Plugin - Delete Item

4. In the Delete Item confirmation dialog, select Yes.
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Editing Graphics

The content of the graphic depends on settings chosen in XPression. 

«Modifying the text template data fields of MOS items in XPression prevents the changes from being

overwritten by new updates in the XPression ActiveX Plugin.

If Enable User Input Controls is selected in the Data Source tab of the Object Inspector in XPression,
the Content cell will contain a list of available static text, global list, and DataLinq values. 

If radio button user input controls have been configured, they can be selected using the Up and Down
arrows on the keyboard.

«For information on creating user input controls for static text, global list, and DataLinq objects, refer

to the XPression Help File in XPression.

«Fixed Take ID numbers can be assigned to MOS objects. For more information, refer to Assigning

Take IDs to MOS Objects.

To edit a graphic:

1. In the XPression ActiveX MOS Plugin, select a graphic to edit.

Refer to Selecting Graphics for instructions.

The graphic opens in Edit mode.

ActiveX MOS Plugin - Edit Mode

The graphic is visible in the preview window and the published fields will be displayed in the Object /
Field and Content lists.

2. Edit clip information such as Channel, Layer, Description, In Point, and Duration as necessary.

«If using XPression Tessera, from the Channel drop-down, select a source rather than a channel

(for example, Source 1, Source 2, etc.).

«The In Point, Duration, and Manual Timing fields only appear if they have been enabled in the

XPression Gateway Settings. See Client Plugins for more information.

3. Select the Manual Timing checkbox to use a manual time instead of the In Point/Duration timing
fields of the graphic when under automation control.
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4. Edit the Object / Field information in the Content column. 

You can also select a field by clicking on the object in the preview window.

The changes appear in the preview.

5. Clear a field by right-clicking it and selecting Clear Field from the shortcut menu.

OR

Revert to the original template values by selecting Revert all fields to template values.

6. Select Add to Story.
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Saving Graphics

You can save your graphics to a daily folder or to a specific folder in the Saved Items folder structure.

To save a graphic:

1. When you have finished editing your graphic, select Save.

The Save Item to Folder dialog box opens.

Save Item to Folder

2. Select one of the following save options:

Save as Daily Item — select this radio button to save the graphic to a daily items folder. This will
create an items folder for the current date that is subject to the Saved Items settings in the
XPression Gateway.

Save to Specific Folder — select this radio button to save the graphic to a specific folder selected
from the Saved Items folder structure.

«For information on adding or deleting a folder, refer to Adding and Deleting Folders.

3. Enter a Name for the graphic and select OK.

The Save Item to Folder window closes and the graphic is saved.

Exporting Graphics to PNG

The preview image for a graphic can be saved as a .png file.

To export a graphic to a png file:

1. In the preview section, right-click on the preview image and select Export Image from the shortcut
menu.

A Save As file browser opens.

2. Navigate to the folder where you want to save the .png file.

3. Select Save.
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Adding and Editing Graphics in the NRCS

This section describes the procedures for adding and editing graphics in the NRCS.

Adding a Graphic to the NRCS

Once you have a graphic ready to be put on air, you can add it to the NRCS from the ActiveX MOS Plugin.

To add a graphic to the NRCS:

· In the XPression ActiveX MOS Editor, from the Graphics browser or Edit tab, select a graphic and
then select Add To Story.

In the Edit tab, you can also select and drag a graphic from the Preview window to the newsroom
client interface.

Editing a Graphic from the NRCS

You can open a graphic from the story in the NRCS to edit it in the XPression MOS Editor.

To edit a graphic from the NRCS:

1. Double-click the graphic you want to edit.

The graphic will open in the XPression ActiveX MOS Editor and a colored bar at the top of the Edit
tab indicates that the graphic was opened from the NRCS. 

ActiveX MOS Plugin - Edit a Graphic from the NRCS

2. Edit the graphic as needed.

3. Then select Update Story to apply the changes.
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Browsing Graphic Metadata

Metadata is an option that can be designed into a scene. You can view the metadata of any graphic or
template using the following procedure.

To browse metadata:

1. In the Graphics or Edit tab, right-click on a graphic or template from the Thumbnails, List or Saved
Graphics.

2. Select Browse Metadata.

The Browse Metadata window opens.

Browse Metadata
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Formatting Text

Underline, superscript, and subscript font formats can be applied to the text of graphics opened for
editing in the plugin.

The following commands are used to apply or end underlines, superscripts, and subscripts:

· {U} — apply underline attribute

· {/U} — end underline attribute

· {SUP} — apply superscript attribute

· {/SUP} — end superscript attribute

· {SUB} — apply subscript attribute

· {/SUB} — end subscript attribute

· { } — end all text attributes

«Font tags are not case-sensitive.

To apply underline, superscript, or subscript:

1. In the Graphics tab, double-click a graphic that contains text from the Thumbnails, List, or Saved
Graphics.

The template opens in the Edit tab.

ActiveX MOS Plugin - Edit Graphic to Format Text

2. Select the Content field with the text you want to format and place the cursor in front of the text.
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3. Type the appropriate tag for the formatting you want to apply.

The formatting is applied to all text after the tag.

ActiveX MOS Plugin - Format Graphic Text

4. To end the formatting at a specific location within the text, place the cursor at the end of the text
intended to be formatted and enter {/followed by the tag}, e.g., {/U}.

The formatting is applied to the text within the tags.

5. To apply more than one type of formatting, insert the tags for each format type at the beginning of
the text to be formatted.

To end the underline after a certain point in the text but keep the superscript (or subscript) for the
rest of the text, enter {/U} at the location to end the underline.

6. When you have finished formatting the text, select Save.
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Using Clips in the XPression ActiveX MOS Plugin

XPression Clips is optional for XPression and the XPression MOS workflow. If you do not have XPression
Clips and are interested in adding it to your workflow, please contact your Ross Video sales
representative.

If you are using a Project Server and a revision of a project is published in XPression, the XPression
ActiveX Plugin will receive a notification of the revision.

The Clips tab in the XPression ActiveX Plugin is used for adding clips to the story in the NRCS.

ActiveX MOS Plugin - Clips

Refer to the following topics for using clips in the XPression ActiveX MOS Plugin:

Selecting Clips

Editing Clips

Saving Clips

Exporting Clips

Creating a Clip Placeholder

Adding a Clip to a MOS Graphic
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Selecting Clips

You can select clips from the Clips tab in the ActiveX MOS plugin or from an OpenMAM Server.

To select a clip from the Clips tab:

1. Open the XPression ActiveX MOS Plugin in the newsroom client.

2. In the plugin, select the Clips tab.

The Clips tab opens.

ActiveX MOS Plugin - Clips Tab

3. Select a clip.

OR

Select the Advanced Search Options icon ( ) to locate a specific clip.
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The Advanced Search Options section opens.

ActiveX MOS Plugin - Advanced Search Options

4. Enter or select search criteria as follows:

· Name — enter the name of a clip to search.

· Recall ID — enter a recall ID to search.

· Source — enter a location to search for a clip.

· Duration Min — enter a minimum duration time to search for a clip that is at least as long as the
value.

· Duration Max — enter a maximum duration time to search for a clip that is no longer than the
value.

· Project — from the drop-down, select a project in which to search for a clip.

· Added Min — use the calendar to select the date after which the clip was added.

· Added Max — use the calendar to select the date before which the clip was added.

· Expires Min — use the calendar to select the date after which the clip will expire.

· Expires Max — use the calendar to select the date before which the clip will expire.

· Never Expires — select this checkbox to search for a clip with no expiry date set.

· Audio Ch Min — enter or select the minimum number of embedded audio channels in the clip to
find.

· Audio Ch Max — enter or select the maximum number of embedded audio channels in the clip to
find.

· No Audio — select this checkbox to search for a clip with no embedded audio.

5. Select Reset Filter  to clear all the fields in the Advanced Search Options.

6. Select the Show all sub clips checkbox to display any sub clips of a clip in the Clip Browser list when
performing an advanced search.

7. Click Save default search criteria ( ) to save the search criteria as a default if necessary.



XPression Distributed Workflow User Guide (v12.0) MOS Workflow Operation - XPression ActiveX MOS Plugin • 102

Editing Clips

You can edit any clip that appears in the Clips tab and then add the edited clip to the NRCS.

To edit a clip:

1. In the Clips tab, double-click a clip to open it for editing.

The clip opens in the Edit tab.

The graphic is visible in the preview window and the clip info will be displayed in the Timing and
Source Information sections.

ActiveX MOS Plugin - Edit Clip

You can play the clip using the playback controls below the preview window.

«Fixed Take ID numbers can be assigned to MOS objects. For more information, refer to Assigning

Take IDs to MOS Objects.

2. Edit clip information such as Channel, Layer, and Description as necessary.

3. Select Update Story.

You can also click and drag from the thumbnail list to the newsroom client interface.

4. Save the edited clip. 

See Saving Clips for further information.
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Saving Clips

You can save your clips to a daily folder or to a specific folder in the Saved Items folder structure.

To save a clip:

1. When you have finished editing your clip, select Save.

The Save Item to Folder dialog opens.

2. Select one of the following save options:

Save as Daily Item — select this radio button to save the clip to a daily items folder. This will create
a folder for the current date that is subject to the Saved Items settings in the XPression Gateway.

Save to Specific Folder — select this radio button to save the clip to a specific items folder selected
from the Saved Items folder structure.

3. In the Name field, enter a name for the saved clip.

4. Select OK.

The Save Item to Folder dialog closes and the clip is saved.

«For information on adding or deleting a folder, refer to Adding and Deleting Folders.
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Exporting Clips

This section describes how to export a clip to a .png file format.

To export a clip to a .png file:

1. In the Browse tab, select a clip from the Saved Items folder structure. 

These clips need to have been pre-populated with information and saved to a user specified folder.

OR

Select a clip from the Rundowns area in the NRCS. 

This enables users to select clips used in MOS rundowns that are being monitored by the XPression
Gateway. 

2. Right-click on the preview image and select Export Image from the shortcut menu.

A Save As file browser opens.

3. Use the file browser to locate a folder in which to save the .png file.

4. Select Save.
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Creating a Clip Placeholder

A placeholder based on Recall ID can be created for a clip to be placed into a rundown. The Recall ID is
what will link the new MOS object with a current or future clip from the Clip Store.

«Placeholder Recall IDs can only be created if the Clips added to a running order should be recalled

via their Recall ID checkbox is enabled in the Clip Store settings in the XPression Gateway. Also, the
Create Placeholder button will not appear unless all Clip Stores in the workflow have the Recall ID
option Allow same Recall ID to be used in different projects disabled in their Clip Store Managers.

«Clip placeholders can also be created in the Edit tab by selecting the Create Placeholder button.

ActiveX MOS Plugin - Create Placeholder Button in Edit Tab

To create a Clip Placeholder:

1. Open the XPression ActiveX MOS Plugin in the newsroom client.

2. Select the Clips tab.

ActiveX MOS Plugin - Clips Tab

3. In the top-right corner of the plugin, select Create Placeholder.

The Create a Clip Placeholder dialog opens.

ActiveX MOS Plugin - Create Placeholder
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4. In the Clip Name field, enter a name for the clip placeholder.

The name does not have to match the clip name in the Clip Store. It will populate the field in the MOS
object so that the object in the running order displays a meaningful name.

5. In the Recall ID field, enter a placeholder recall ID for the MOS object.

6. In the Description field, enter a brief description for the clip placeholder.

This is not applied to the clip in the Clip Store. It will populate the field in the MOS object so that the
object in the running order displays a meaningful description.

7. Select OK.

A clip placeholder recall ID is created that can be dragged and dropped into the rundown. However, a
clip with the newly created recall ID will need to be ingested for it to function properly.

ActiveX MOS Plugin - Clip Placeholder

8. If a clip exists in the rundown that already uses the Recall ID entered, a notice is displayed in the
Create a clip placeholder dialog.

ActiveX MOS Plugin - Recall ID Already Exists

9. If necessary, the existing Recall ID can be removed from the original clip by selecting Remove Recall
ID.
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Adding a Clip to a MOS Graphic

Clips can be added to a MOS graphic by copying and pasting the clip into a graphic or by dragging and
dropping a clip into a graphic.

To copy and paste a clip into a MOS graphic:

1. In the Clips tab, select the clip you want to add to the MOS graphic.

2. Press Ctrl+C to copy the clip.

3. In the Graphics tab, double-click the graphic to which you want to add a clip, to open it in the Edit
tab.

4. Select the Content field of an Image or Video object.

5. Press Ctrl+V to paste the clip into the field.

To drag and drop a clip into a MOS graphic:

1. In the Graphics tab, double-click a graphic that contains a video object.

The graphic opens in the Edit tab.

ActiveX MOS Plugin - Edit Graphic
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2. Select the Clips tab.

ActiveX MOS Plugin - Clips Tab

3. Select a clip and drag it over the Edit tab.

4. Drop the clip into the content field of the video object.

The clip is added to the video object selected in the graphic and the clip is displayed in the preview
for the graphic.

ActiveX MOS Plugin - Clip Added to MOS Graphic

For More Information on...

· XPression Clips, refer to the XPression Clips User Guide.



109 • MOS Workflow Operation - XPression ActiveX MOS Plugin XPression Distributed Workflow User Guide (v12.0)

Using Lucid MOS Events in the XPression ActiveX MOS
Plugin

When Lucid Studio has been configured to communicate with a Newsroom Control System (NRCS)
through the XPression Gateway, you can play out a MOS story sequence from the Sequencer panel in
Lucid Studio or through the XPression Remote Sequencer.

MOS story sequences are generated by the NRCS and appear in the MOS tab of the Sequencer panel in
Lucid Studio automatically.

The following topics are described in this section:

Selecting Lucid MOS Events

Editing Lucid MOS Events

For information about..

· setting up communication between the NRCS and the XPression Gateway, see the XPression Gateway
Settings.

· setting up the XPression ActiveX MOS plugin, see Setting up the XPression ActiveX MOS Plugin.

· configuring the XPression Gateway for Lucid Integration, see Lucid Studio Integration.

Selecting Lucid MOS Events

You can select a Lucid MOS event from the Lucid tab or from a story in the NRCS.

To select a Lucid MOS event from the Lucid tab:

1. Open the XPression ActiveX MOS Plugin in the newsroom client.

2. Select the Lucid tab. 

The MOS-enabled Lucid events that have been created in Lucid Studio will appear in the Lucid tab.

ActiveX MOS Plugin - Lucid Tab

«For information about enabling MOS in Lucid Studio, see the Lucid Studio User Guide.
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3. From the Project drop-down, select the project containing the event you want to use.

The MOS enabled Lucid events in that project are displayed.

4. Double-click the event you want.

The event opens in the Edit tab.

To select a Lucid MOS event from the NRCS:

1. Open the XPression ActiveX MOS Plugin in the newsroom client.

2. In the NRCS, select the story containing the Lucid MOS event you want. 

3. In the story, double-click the Lucid MOS event you want.

The event opens in the Edit tab and Edit Mode is displayed beside the name of the event.
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Editing Lucid MOS Events

In the Edit tab, you can change the image or video contained in an event, selecting assets from a local
folder or from an OpenMAM server. 

To edit a Lucid MOS event:

1. Open the XPression ActiveX MOS Plugin in the newsroom client.

2. In the plugin, select the Lucid tab. 

The MOS-enabled Lucid events for the project that was last opened will appear in the Lucid tab.

ActiveX MOS Plugin - Lucid Tab

«For information about enabling MOS in Lucid Studio, see the Lucid Studio User Guide.

3. From the Project drop-down, select the project containing the event you want to edit.

4. Double-click the event you want to edit.

Alternatively, you can double-click a Lucid MOS event in an NRCS story to open it for editing.

The selected event opens in the Edit tab.
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ActiveX MOS Plugin - Edit a Lucid MOS Event

5. On the left side of the plugin, select an Out Method and add a Description (optional).

6. In the Source Content field, do one of the following:

Select an OpenMAM icon to access media resources on an OpenMAM server.

«For information about accessing resources from an OpenMAM server, see Adding Assets from an

OpenMAM Server.

OR

Press Select and in the Select Texture panel, navigate to the folder containing the image or video
you want use and press Select.

7. If you are adding a video, in the Duration field, enter or use the arrows to select a duration for the
video.

8. Then select Add to Story if editing an event from the Lucid tab, or Update Story if editing an event
from a story.
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Assigning Take IDs to MOS Objects

Take ID numbers can be assigned to graphics and clips in the XPression ActiveX MOS Plugin.

«Take IDs on the Remote Sequencer will not match the Take IDs assigned to the XPression

Sequencer items.

To assign a Take ID to a MOS object:

1. In the Graphics or Clips tab, double-click a graphic or clip to open it in Edit mode.

2. In Edit mode, right-click inside the top section of the XPression ActiveX MOS Plugin editor (between
the Channel and Description fields, for example) and select Assigned Fixed ID.

The Set Take ID window opens.

ActiveX MOS Plugin - Set Take ID

3. Select one of the following:

Automatically Generate Take ID — select this radio button to automatically assign a Take ID based
on the next available Take ID number. This is the default setting.

Fixed Take ID — select this radio button to manually assign a static Take ID. Enter or select a Take
ID number in the Take ID field..

«When a fixed Take ID is assigned, no checks or safeguards are performed to prevent duplicate

IDs from being used in the rundown. When two rundowns are loaded in the XPression Sequencer
with duplicates, one of the Take IDs will automatically be renumbered. It is recommended that when
two rundowns use duplicate Take ID numbers that only one rundown be activated at a time.

It is also recommended that all static Take IDs be assigned numbers over 2000 to avoid conflicts
between automatically generated Take ID numbers and the static Take ID numbers.

4. Select OK.

The Set Take ID window closes.

«When the Take ID is set, you recall and edit the graphic or clip from the rundown and the fixed ID

is retained in the rundown only.
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Using Spell Check

The XPression ActiveX Plugin offers spell check with a local dictionary to which words can be added on a
per user basis.

To use Spell Check:

1. In the XPression ActiveX Plugin, select Options > Configuration.

The XPression ActiveX MOS Plugin Configuration window opens.

ActiveX MOS Plugin - Select Spell Check Dictionary

2. In the Spell Check section, use the Dictionary drop-down to select a language for the spell check.

3. Select OK.

The XPression ActiveX MOS Plugin Configuration window closes.
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4. Open a graphic in the Edit tab of the XPression ActiveX MOS Plugin.

ActiveX MOS Plugin - Spell Check Graphic Text

5. Click inside the Content cell of a text object.

Any existing text content is highlighted.

6. Highlight a specific word or enter and highlight a new word to use for the spell check.

7. Select Spell Check.

If the word is spelled correctly, or it has already been added to the dictionary, a message appears
saying "Spell Check Complete".

If the word is spelled incorrectly, or has not been added to the dictionary, the Spell Check dialog
opens.

ActiveX MOS Plugin - Spell Check

8. Do one of the following:

· Click Ignore to return to the graphic without making any changes.

· Select a word from the Suggestions list and click Change to correct the spelling.

· Click Add to add the word to the dictionary.

An information window opens indicating the spell check is complete.

9. Click OK to return to the graphic.

Depending on the action taken in Step 8, the text content is either the same or corrected/changed.
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Copying MOS Content from other Projects

If you are using a project server, the content of MOS objects and fields can be copied from a template in
one project to a template in a different project, providing the Object / Field names are the same in
both templates. This enables quick and easy transfer of MOS content between multiple projects.

To transfer a MOS object to another project:

1. Open a project in the ActiveX MOS Plugin.

2. In the Graphics tab, double-click the template containing the content you want to copy to a template
in another project.

The selected template opens in the Edit tab.

ActiveX MOS Plugin - Edit Graphic

3. In the top-left corner, select the Show selector Browse button.

ActiveX MOS Plugin - Browse

The Show, Category and Style Selection window opens.

ActiveX MOS Plugin - Show, Category and Style Selection
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4. From the Style list, select a style. 

The new style can come from the show and category already selected, or from a different show and
category in the Show and Category list.

OR

Select a show to access all the graphics for that show.

5. Then select OK.

The Show, Category and Style Selection window closes and the graphics associated with the
selected style or show are available for selection in the Thumbnails / List.

The Object / Field and Content lists in the graphic are grayed out, indicating that the previous
project’s MOS items have been copied to the clipboard.

6. From the Graphics tab, select the template to which you want to copy the content from the initial
project.

7. Press and hold the Shift key and double-click the graphic.

The item opens in the editor and any corresponding Object / Field items and their Content are
populated from the initial project.
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Adding Resources from an OpenMAM Server

An integrated openMAM browser can be used in the XPression ActiveX MOS plugin to add images and
video to templates in the plugin. For information about configuring OpenMAM servers, see Adding and
Configuring an OpenMAM Server.

The following topics are covered in this section:

Adding an Integrated OpenMAM Browser

Adding Assets from an OpenMAM Server to a Template

Adding an Integrated OpenMAM Browser

If you want to use an OpenMAM server to add media assets into the XPression ActiveX MOS Plugin, you
will need to select this option when installing the plugin.

To add an integrated OpenMAM browser to the XPression ActiveX MOS Plugin:

· When installing the plugin, select the Integrated OpenMAM Browser checkbox.

ActiveX MOS Plugin - Installation - Select Components

OpenMAM servers can then be accessed within the plugin.
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Adding Assets from an OpenMAM Server

Images and video can be dragged and dropped directly from an OpenMAM server into the XPression
ActiveX MOS plugin.

To add an asset from an OpenMAM server to a template:

1. Open the XPression ActiveX MOS plugin in the newsroom client.

2. In the Graphics tab, double-click a template to open it in the Edit tab.

OR

In the Running Order of the NRCS, double-click a template to open it in the Edit tab.

ActiveX MOS Plugin - Select Template

3. From the OpenMAM drop-down in the bottom-right corner of the plugin, select an OpenMAM server.

Alternatively, you can click in the Content field of the image or video object in the template and select
the icon for the OpenMAM server you want to access.
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ActiveX MOS Plugin - Select OpenMAM Server

The selected OpenMAM server login window opens in the XPression Asset Browser.

4. Log in to the OpenMAM server.

The OpenMAM browser opens.

5. Select a media asset and then drag and drop the asset onto the Content field of an image or video
in the selected template.

The media asset is added to the template.

ActiveX MOS Plugin - Add Asset from OpenMAM Server

For more information on the Streamline MAM system, refer to the Streamline Online Help file, available
on the Ross website.

Adding and Deleting Folders

You can add folders in which to save your graphics and clips and delete folders that are no longer
needed.

To add a folder:

1. In the XPression ActiveX MOS Plugin, select the Browse tab.

2. Select a folder in the folder structure.

Folders can be added to the Daily and Persistent folders and to the sub-folders of the User
Favorites folder, but not to the top-level User Favorites or Rundowns folders.

3. Right-click and select New Folder.

The New Folder dialog opens.
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ActiveX MOS Plugin - Add New Folder

4. In the Name field, enter a name for the folder.

5. Select OK.

The new folder appears as a sub-folder in the folder structure.

To delete a folder:

1. In the ActiveX MOS Plugin, select the Browse tab.

2. Select a folder in the folder structure.

Folders can be deleted from the Daily and Persistent folders and from the sub-folders of the User
Favorites folder, but not from the top-level User Favorites or Rundowns folders.

3. Right-click and select Delete Folder.

The Delete Folder confirmation dialog opens.

4. Select Yes.

The folder and its contents are deleted from the folder structure.
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MOS Workflow Operation - HTML5
Plugin
This section describes how to use the templates and saved graphics in the XPression MOS Plugin.

The following topics are discussed in this section:

Using Graphics in the XPression HTML5 MOS Plugin

Using Clips in the XPression HTML5 MOS Plugin

Assigning Take IDs to MOS Objects

Using Spell Check

Copying MOS Content from Other Projects

Adding Resources from Streamline OpenMAM

Adding and Deleting Folders

For More Information on...

The XPression HTML5 MOS Plugin user interfaces, refer to:

XPression HTML5 MOS Plugin User Interface Overview - Browse

XPression HTML5 MOS Plugin User Interface Overview - Graphics

XPression HTML5 MOS Plugin User Interface Overview - Lucid

XPression HTML5 MOS Plugin User Interface Overview - Edit
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Using Graphics in the XPression HTML5 MOS Plugin

The Graphics tab in the XPression HTML5 Plugin is used for adding graphics to the story in the
Newsroom Computer System (NRCS). 

The Add to Story, Update Story, OK, and Cancel buttons in the XPression HTML5 Plugin can be
conditionally rendered using the HTTP Server settings in the XPression Gateway > Settings window.

If you are using a Project Server and a revision of a project is published in XPression, the XPression
HTML5 Plugin will receive a notification of the revision.

The following topics are covered in this section:

Selecting Graphics

Editing Graphics

Saving Graphics

Exporting Graphics to PNG

Replacing and Converting Graphics

Browsing Graphic Metadata

Adding and Editing Graphics in the NRCS

Formatting Text

To change the view type and scale of the Graphics tab:

1. Click the Change view type and scale button ( ) in the top-right corner of the Graphics tab.

HTML5 Plugin - Change View and Scale

2. Select one of the following viewing methods for the graphics browser:

· Grid — select this method to view the graphics in a grid layout.

· List — select this method to view the graphics in a name list.

· Size bar — select the bar and drag it left or right to adjust the thumbnail or name size in the
Graphics tab.
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Selecting and Deleting Graphics

There are several ways to locate the graphic you want to edit:

Browsing Graphics from the Project Server (recommended)

Selecting Saved Graphics

Selecting Graphics from the NRCS

See the following section for how to delete graphics:

Deleting Graphics
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Browsing Graphics from the Project Server

To select a graphic :

1. Open the XPression HTML5 Plugin in the newsroom client.

2. In the XPression HTML5 Plugin, select the Graphics tab.

The Graphics tab opens. By default, it will show graphics from the last show that was opened.

HTML5 Plugin - Graphics Tab

3. To select graphics from a different show, select Show. 

The Show button is not available if you are not using the Project Server.

The Show, Category, and Style window opens.

HTML5 Plugin - Show, Category and Style Window
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4. In the Search field, enter a show name to quickly retrieve a show.

OR

Scroll through the list of shows and double-click to select the show you want.

5. Select the Collapse all button ( ) in the top-right corner to view the category headings of the
graphics and then select a heading to expand the category containing the graphic to add to the
story.

6. Select the Expand all button ( ) to expand all the category headings of the graphics.

7. Double-click a graphic to select it and in the Edit tab, select Add To Story.

Alternatively, you can drag the graphic from the plugin into the story.

The graphic is added to the story that is currently open in the Story Editor Panel of the NRCS. It
appears as a MOS object placeholder in the NRCS and reflects the MOS abstract as configured in the
Gateway. It displays the channel, layer, graphic name, etc. 

HTML5 Plugin - Add Graphic to Story

8. Select Save in the Story Editor Panel to save the graphic in the story. 
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Selecting Saved Graphics

The Browse tab in the XPression HTML5 Plugin is used for selecting graphics that have been pre-
populated with information and saved to a user-specified folder. You can also delete graphics, add or
delete folders, browse the metadata of a graphic and copy a MOS object to a text editor, for
troubleshooting purposes.

Graphics can also be browsed from the Rundowns area. This enables users to select graphics used in
MOS rundowns that are being monitored by the XPression Gateway. The graphics can be copied to
other rundowns or modified from their current state using the Edit tab and then added to a rundown.

To select a graphic:

1. In the XPression HTML5 Plugin, select the Browse tab.

The Browse tab opens.

HTML5 Plugin - Browse Tab

2. In the Browse tab, select a folder in the Saved Items folder structure or in the Rundowns.

The graphics contained in the selected folder are shown in the Preview area.

3. Double-click on a graphic in the Preview area to select it. 

The graphic opens in the Edit tab.

Selecting Graphics from an NRCS

You can select graphics used in MOS rundowns that are being monitored by the XPression Gateway. The
graphics can be copied to other rundowns or modified from their current state using the Edit tab and
then added to a rundown.

To select a graphic from the NRCS:

· In the NRCS, in the Rundowns area, double-click a graphic to open it in the XPression HTML5 MOS
editor.



XPression Distributed Workflow User Guide (v12.0) MOS Workflow Operation - HTML5 Plugin • 128

Deleting Graphics

You can delete graphics in the Browse tab.

To delete a graphic:

1. In the XPression HTML5 plugin, select the Browse tab.

2. In the Browse tab, in the folder structure, browse to the graphic to be deleted. 

3. Select the graphic and select the options button in the bottom-right corner of the graphic.

HTML5 Plugin - Delete Item

4. From the Options menu, select Delete Item.

The Delete Item confirmation dialog opens.

5. Select Delete.
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Editing Graphics

The Edit tab in the XPression HTML5 Plugin is used for editing and saving graphics. A preview image of
the graphic can also be exported to a file.

The graphic is visible in the preview window and the published fields will be displayed in the Object /
Field Content section. 

When using static text, if Enable User Input Controls is selected in the Data Source tab of the Object
Inspector in XPression, the Content cell will contain a list of available static text values. The text fields
will reflect the design of the scene. This could be a simple text field or drop down lists, radio buttons,
combo boxes, or check boxes supplied by static lists, global lists, or DataLinq lists.

To edit a graphic:

1. Select a graphic.

The graphic opens in the Edit tab.

HTML5 Plugin - Edit Graphic

2. Edit graphic information such as Channel, Layer, Description, In Point, and Duration as necessary.

These settings are only available if they have been set up in the Configuration panel. See Setting Up
the XPression HTML5 MOS Plugin.

If using XPression Tessera and a Net ID has been assigned to a channel for a destination region in
the Region Mapper, selecting that channel in the HTML5 plugin will include the assigned Net ID.

3. Select the Manual Timing checkbox to use a manual time instead of the In Point /Duration timing
fields of the graphic when under automation control.

The Manual Timing checkbox is only available if it has been set up in the Configuration panel. See
Setting Up the XPression HTML5 MOS Plugin.

If using an XPression Tessera project, use the Channel list to select a source rather than a channel
(e.g., Source 1, Source 2, etc.).
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4. To assign a Take ID to the graphic, select the Options button ( ) in the top-right corner of the
Graphic Editor and select Enable take ID input from the sub-menu.

HTML5 Plugin - Enable Take ID Input

Take ID input can be disabled after enabling by selecting Disable take ID input.

By default, Automatic is selected in the Take ID field, which assigns a Take ID based on the next
available Take ID number. For more information, refer to Assigning Take IDs to MOS Objects.

5. Select a field in the Content column to edit it. 

Alternatively, the object can be selected by clicking it in the preview window.

The changes appear in the preview window. 

6. Use the playback controls below the preview window to play animations from the graphic.

The preview window can be opened in a floating window by clicking the icon in the bottom-right
corner. It can also be re-sized and moved to another screen. 

7. To revert to the default values for each field, click the options button ( ) in the top-right corner of
the Graphics Editor and select Revert all fields to template values.

HTML5 Plugin - Revert all Fields

8. Select Add To Story.

Saving Graphics

You can save your graphics to a daily folder or to a specific folder in the Saved Items folder structure.

To save a graphic to a folder:

1. Click the options button ( ) in the top-right corner of the graphics editor and select Save to folder
from the menu.
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HTML5 Plugin - Save to Folder

The Save Item to Folder dialog opens.

HTML5 Plugin - Save Item to Folder

2. Select one of the following save options:

· Save as daily item — select this radio button to save the graphic to a daily items folder. This will
create a folder for the current date. The path, date format, and purge frequency are set in the
XPression Gateway > Saved Items settings.

· Save to specific folder — select this radio button to save the graphic to a specific folder selected
from the Saved Items folder structure.
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3. In the Name field, enter a name for the graphic.

4. Select Save.

The Save Item to Folder dialog closes and the graphic is saved.

The folder might have to be refreshed to see the added graphic.
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Exporting Graphics to PNG

The preview image for a graphic can be saved as a .png file.

To export the current frame of the graphic:

1. With the graphic open in the Graphic Editor, click the options button ( ) in the top-right corner of
the editor and from the sub-menu, select Export current frame to file.

HTML5 Plugin - Export Current Frame to File

2. In the Save As window, navigate to a folder to store the image and click Save.

If the Save As window does not open, it is because this option has not been selected in the web
browser settings. To enable the Save As window, edit the web browser settings to allow the file
browser to open to select a specific folder. Otherwise, the image will be saved in Downloads.
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Replacing and Converting Graphics

You can replace the graphics and field content of a template selected from the NRCS rundown. You can
also convert a template selected from the Graphics tab, while maintaining any field content that
corresponds to the new template.

To replace graphic templates:

1. Double-click a graphic in the NRCS to open it for editing.

2. From the Graphics tab, select the graphic template to use instead.

3. Select the options button in the bottom-right corner of the graphic and select Replace Template from
the sub-menu.

HTML5 Plugin - Replace Template

4. In the Replace Template confirmation dialog, select OK.

The original graphic is replaced with the new graphic and all field content is reset.

5. Select Add to Story to save the new graphic.

To convert graphic templates:

1. From the Graphics tab, double-click a graphic to open it.

2. Edit the graphic.

3. To change the template of the graphic, before adding it to the story, click the Graphics tab again and
select the graphic to use instead.

4. Click the options button in the bottom-right corner of the graphic and select Convert Template from
the sub-menu.

HTML5 Plugin - Convert Template

5. In the Convert Template confirmation dialog, click OK.

The template is replaced, but field content in the original template that corresponds with the new
template is maintained.
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Adding and Editing Graphics in the NRCS

This section describes the procedures for adding and editing graphics in the NRCS.

Adding a Graphic to the NRCS

Once you have a graphic ready to be put on air, you can add it to the NRCS from the HTML5 Plugin.

To add a graphic to the NRCS:

· In the XPression HTML5 MOS Editor, from the Graphics browser or Edit tab, select a graphic and
then select Add To Story.

In the Edit tab, you can also select and drag a graphic from the Preview window to the newsroom
client interface.

Editing Graphics from the NRCS

You can open a graphic from the story in the NRCS to edit it in the XPression HTML5 MOS Editor.

To edit a graphic from the NRCS:

1. Select a graphic.

The graphic opens in the Edit tab and you will see Edit Mode beside the graphic name.

HTML5 Plugin - Edit a Graphic from the NRCS

2. Edit the graphic as needed.

3. Then select Update Story to apply the changes.
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Browsing Graphic Metadata

Metadata is an option that can be designed into a scene. You can view the metadata of any graphic or
template using the following procedure.

To browse the metadata of a graphic:

1. In the Graphics or Browse tab, select a graphic and click on the options button ( ) in the bottom-
right corner of the graphic.

2. Select Browse Metadata.

HTML5 Plugin - Browse Metadata

3. The Metadata window opens.

HTML5 Plugin - Metadata Window
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To copy MOS metadata:

1. In the Graphics or Browse tab, select a graphic.

2. Select the Options button (the 3 vertical dots) in the bottom-right corner of the graphic.

3. Select Copy MOS.

4. Open a text editor.

5. Right-click and select Paste.

The MOS data for the graphic is copied into the text editor.
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Formatting Text

Underline, superscript, and subscript font formats can be applied to the text of graphics opened for
editing in the plugin.

The following font tag commands are used to apply or end underlines, superscripts, and subscripts:

· {U} — apply underline attribute

· {/U} — end underline attribute

· {SUP} — apply superscript attribute

· {/SUP} — end superscript attribute

· {SUB} — apply subscript attribute

· {/SUB} — end subscript attribute

· { } — end all text attributes

«Font tags are not case-sensitive.

To apply underline, superscript, or subscript:

1. In the Graphics tab, double-click a graphic from the Thumbnails, List, or Saved Graphics.

The template opens in the Edit tab.

HTML5 Plugin - Edit Graphic

2. Select the Content field with the text you want to format and place the cursor in front of the text.
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3. Type the appropriate tag for the formatting you want to apply.

The formatting is applied to all text after the tag. In the image below, the apply underline attribute
tag was used.

HTML5 Plugin - Format Graphic Text

4. To end the formatting at a specific location within the text, place the cursor at the end of the text
intended to be formatted and enter {/followed by the tag}, e.g., {/U}.

The formatting is applied to the text within the tags.

5. To apply more than one type of formatting, insert the tags for each format type at the beginning of
the text to be formatted.

To end the underline after a certain point in the text but keep the superscript (or subscript) for the
rest of the text, enter {/U} at the location to end the underline.

6. When you have finished formatting the text, select Save.
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Using Clips in the XPression HTML5 MOS Plugin

The Clips tab in the XPression HTML5 Plugin is used for adding clips to the story in the Newsroom
Computer System (NRCS) or for adding a clip to a material in a graphic.

XPression Clips is optional for XPression and the XPression MOS workflow. If you do not have XPression
Clips and are interested in adding it to your workflow, please contact your Ross Video sales
representative.

Selecting Clips

Editing Clips

Saving Clips

Adding a Clip to a Graphic

Previewing Clips
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Selecting Clips

Use the Clips tab to locate a clip to add to a story.

To select a clip:

1. Open the XPression HTML5 Plugin in the newsroom client.

2. In the XPression HTML5 Plugin, select the Clips tab.

The Clips tab opens.

HTML5 Plugin - Clips Tab

3. Select a clip using one of the following methods:

In the Search field, enter the name of a specific clip to find it quickly.

OR

Hover your mouse over a clip thumbnail to see a preview of the clip.

OR

Select the Show/Hide advanced search options ( ) button to use the advanced search options.

Name enter the name of a clip to search.

Recall ID enter a recall ID to search.

Duration Min enter the minimum clip duration to search for a clip that is at least as long as
the value.

Duration Max enter a maximum clip duration to search for a clip that is no longer than the
value.

Project select a project in which to search for a clip.

Added Min select the date on or after which the clip was added.

Added Max select the date on or before which the clip was added.

4. After setting your search options, select Search.
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The clips matching your search options will appear and the number of matching clips found will be
indicated.

HTML5 Plugin - Advanced Search Options

5. Select Load More to see more clips. 

6. When you have found the clips you want, select Reset Filters to reset the Advanced Search options
and return to the default Clips view.
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To view clip information:

· In the Clips tab, double-click a clip to view it.

The clip opens in the View tab.

HTML5 Plugin - View Tab

The clip is visible in the preview window and the clip info will be displayed in the Timing and Source
Information sections.
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Editing Clips

You can edit any clip that appears in the Clips tab and then add the edited clip to the NRCS.

To edit a clip:

1. In the Clips tab, select a clip to edit.

2. Edit clip information such as Channel, Layer, and Description as necessary.

If using XPression Tessera and a Net ID has been assigned to a channel for a destination region in
the Region Mapper, selecting that channel in the HTML5 plugin will include the assigned Net ID.

3. Change the Take ID if necessary:

In the graphic details, right-click the vertical ellipsis and select Enable take ID input.

HTML5 - Enable Take ID Input

In the Take ID field, type or use the arrows to enter a take ID for the clip.

4. Select Add To Story.
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Saving Clips

You can save your clips to a daily folder or to a specific folder in the Saved Items folder structure.

To save a clip:

1. When you have finished editing your clip, select Save.

The Save Item to Folder dialog opens.

2. Select one of the following save options:

Save as Daily Item — select this radio button to save the clip to a daily items folder. This will create
a folder for the current date that is subject to the Saved Items settings in the XPression Gateway.

Save to Specific Folder — select this radio button to save the clip to a specific items folder selected
from the Saved Items folder structure.

3. In the Name field, enter a name for the saved clip.

4. Select OK.

The Save Item to Folder dialog closes and the clip is saved.
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Adding a Clip to a MOS Graphic

You can add a clip to any graphic that contains a video object.

To add a clip to a graphic:

1. In the Graphics tab, double-click a graphic that contains a video object.

The graphic opens in the Edit tab.

HTML5 Plugin - Edit Tab

2. Select the Clips tab.

The Clips tab opens.

HTML5 Plugin - Clips Tab
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3. Select a clip and drag it over the Edit tab.

The Edit tab opens.

4. Drop the clip onto the video object field.

The clip is added to the video object field selected in the graphic and the clip is displayed in the
preview for the graphic.

HTML5 Plugin - Add Clip

For more information on XPression Clips, refer to the XPression Clips User Guide.
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Previewing Clips

Use the Preview window to preview the clip that is open in the Edit tab.

To preview the clip:

1. Click in the preview window.

The clip begins playing immediately and the Speaker, Full-screen and Settings buttons appear.

If instead you see a message saying "Please run the proxy generation tool on your XPression Clip
Store to enable playing this clip", as shown in the image below, it means that the clip cannot
currently be played or even previewed, because it is lacking the required proxies. See Running the
Proxy Generation Tool for instructions on fixing this issue.

HTML5 Plugin - Run Proxy Generation Tool Message

2. Select the Speaker button to hear the audio.

3. Select the Full-screen button to play the clip in full-screen.
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4. In the bottom-right corner of the preview window, use the icons to add captions, view picture-in-
picture or view full-screen. 

HTML5 Plugin - Preview Clips
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Running the Proxy Generation Tool

When you select a clip to be previewed, you might see a message saying "Please run the proxy
generation tool on your XPression Clip Store to enable playing this clip". This means that the clip cannot
currently be played or even previewed, because it is lacking the required proxies. In order to use this
clip in the HTML5 Plugin, you need to generate proxies for the clip using the XPression ClipStore Proxy
Generator tool.

HTML5 Plugin - Proxy Warning

To generate proxies for clips:

1. Go to C:\Program Files (x86)\XPression Clip Store\bin and double-click the xpCSProxyTool.exe
file.

The XPression ClipStore Proxy Generator tool opens.

Clipstore Proxy Tool
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2. Select Start Proxy Generation to generate proxies for any clips in the clip store that do not already
have proxies.

In the Active Transcodes section, you will see the clip(s) being transcoded and the progress is
indicated in the Overall Progress bar. If there is more than one clip in the clip store that doesn't
have proxies, they will all be transcoded in this step.

Clipstore Proxy Tool - Generating Proxies

3. When the Overall Progress bar indicates 100%, select the X in the top-right corner to close the
Proxy Generator.

The clip(s) is now ready to be used in the HTML5 plugin.
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Using Lucid MOS Events in the XPression HTML5 Plugin

When Lucid Studio has been configured to communicate with a Newsroom Control System (NRCS)
through the XPression Gateway, you can play out a MOS story sequence from the Sequencer panel in
Lucid Studio or through the XPression Remote Sequencer.

MOS story sequences are generated by the NRCS and appear in the MOS tab of the Sequencer panel in
Lucid Studio automatically.

The following topics are described in this section:

Selecting Lucid MOS Events

Editing Lucid MOS Events

For information about..

· setting up communication between the NRCS and the XPression Gateway, see the XPression Gateway
Settings.

· setting up the HTML5 MOS plugin, see Setting up the HTML5 MOS Plugin.

· configuring the XPression Gateway for Lucid Integration, see Lucid Studio Integration.
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Selecting Lucid MOS Events

You can select a Lucid MOS event from the Lucid tab or from a story in the NRCS.

To select a Lucid MOS event from the Lucid tab:

1. Open the XPression HTML5 MOS Plugin in the newsroom client.

2. Select the Lucid tab. 

The MOS-enabled Lucid events that have been created in Lucid Studio will appear in the Lucid tab.

HTML5 Plugin - Lucid Tab

«For information about enabling MOS in Lucid Studio, see the Lucid Studio User Guide.

3. From the Project drop-down, select the project containing the event you want to use.

The MOS enabled Lucid events in that project are displayed.

4. Double-click the event you want.

The event opens in the Edit tab.

To select a Lucid MOS event from the NRCS:

1. Open the XPression HTML5 MOS Plugin in the newsroom client.

2. In the NRCS, select the story containing the Lucid MOS event you want. 

3. In the story, double-click the Lucid MOS event you want.

The event opens in the Edit tab and Edit Mode is displayed beside the name of the event.



XPression Distributed Workflow User Guide (v12.0) MOS Workflow Operation - HTML5 Plugin • 154

Editing Lucid MOS Events

In the Edit tab, you can change the image or video contained in an event, selecting assets from a local
folder or from an OpenMAM server. 

To edit a Lucid MOS event:

1. Open the XPression HTML5 Plugin in the newsroom client.

2. In the plugin, select the Lucid tab. 

The MOS-enabled Lucid events for the project that was last opened will appear in the Lucid tab.

HTML5 Plugin - Lucid Tab

«For information about enabling MOS in Lucid Studio, see the Lucid Studio User Guide.

3. From the Project drop-down, select the project containing the event you want to edit.

4. Double-click the event you want to edit.

Alternatively, you can double-click a Lucid MOS event in an NRCS story to open it for editing.

The selected event opens in the Edit tab.
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HTML5 Plugin - Edit a Lucid MOS Event

5. On the left side of the plugin, select an Out Method and add a Description (optional).

6. In the Source Content field, do one of the following:

Select an OpenMAM icon to access media resources on an OpenMAM server.

«For information about accessing resources from an OpenMAM server, see Adding Assets from an

OpenMAM Server.

OR

Press Select and in the Select Texture panel, navigate to the folder containing the image or video
you want use and press Select.

7. If you are adding a video, in the Duration field, enter or use the arrows to select a duration for the
video.

8. Then select Add to Story if editing an event from the Lucid tab, or Update Story if editing an event
from an NRCS story.
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Assigning Take IDs to MOS Objects

Take ID numbers can be assigned to graphics and clips in the HTML5 Plugin.

«Take IDs on the Remote Sequencer will not match the Take IDs assigned to the XPression

Sequencer items.

To assign a Take ID to a MOS object:

1. In the Graphics or Clips tab, double-click a graphic or clip to open it in Edit mode.

2. In Edit mode, in the graphic details, right-click the vertical ellipsis and select Enable take ID input.

HTML5 Plugin - Enable Take ID Input

3. In the Take ID field, type or use the up and down arrows to enter a Take ID number.

HTML5 Plugin - Set Take ID
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Using Spell Check

The HTML5 Plugin offers spell check with a local dictionary to which words can be added on a per user
basis.

To use Spell Check:

1. In the HTML5 Plugin, select the gear icon in the top-right corner to open the Configuration panel.

2. In the Spell Check section, use the Dictionary drop-down to select a language for the spell check.

HTML5 Plugin - Select Spell Check Dictionary

3. Then select Save.

The Configuration panel closes.

4. Open a graphic that contains text in the Edit tab of the HTML5 Plugin.

HTML5 Plugin - Spell Check Graphic Text



XPression Distributed Workflow User Guide (v12.0) MOS Workflow Operation - HTML5 Plugin • 158

5. Click inside the Content cell of a text Object / Field.

Any existing text content is highlighted.

6. Highlight a specific word or enter and highlight a new word to use for the spell check.

7. Select Spell Check.

If the word is spelled correctly, or it has already been added to the dictionary, a message appears
saying "Complete".

If the word is spelled incorrectly, or has not been added to the dictionary, the Spell Check window
opens.

HTML5 Plugin - Spell Check Window

8. Do one of the following:

· Click Ignore to return to the graphic without making any changes.

· Select a word from the Suggestions list and click Change to correct the spelling.

· Click Add to Dictionary to add the word to the dictionary.

An information window opens indicating the spell check is complete.

9. Click OK to return to the graphic.

Depending on the action taken in Step 8, the text content is either the same or corrected/changed.
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Copying MOS Content from other Projects

If you are using a project server, the content of MOS objects and fields can be copied from a template in
one project to a template in a different project, providing the Object / Field names are the same in
both templates. This enables quick and easy transfer of MOS content between multiple projects.

To transfer a MOS object to another project:

1. Open a project in the HTML5 Plugin.

2. In the Graphics tab, double-click the template containing the content you want to copy to a template
in another project.

The selected template opens in the Edit tab.

HTML5 Plugin - Select Template to Copy

3. Select the Graphics tab.

4. In the Graphics tab, select the Show drop-down and then select the show that contains the
template you want to edit and select OK.

5. In the Graphics tab of the selected show, select the template you want to edit.
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HTML5 Plugin - Select Template to Edit

6. In the bottom-right corner of the template, select the vertical ellipsis and select Convert template.
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7. In the Confirmation dialog, select OK.

In the edited template, the objects that are common to both templates (in this case Text1, Text2,
Text3 and Text4) will be updated with the copied content. The heading object was not copied, as the
selected template to edit did not contain a heading object.

HTML5 Plugin - Content Copied from another Project
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Adding Assets from an OpenMAM Server

An integrated openMAM browser can be used in the XPression HTML5 Plugin for adding images and
video to graphics in the XPression HTML5 plugin. For information about configuring Streamline, see
Adding and Configuring an OpenMAM Server - Streamline Driver.

«The Streamline server must be on the same domain as the HTML5 plugin.

Images and video can be dragged and dropped directly from a Streamline server into the XPression

«Launching an OpenMAM server while in iNews opens the iNews web browser as it supports drag-and-

drop functionality.

To add an asset from an OpenMAM server into the XPression HTML5 Plugin:

1. Open the XPression HTML5 Plugin in the newsroom client.

2. In the Graphics tab, double-click a template to open it in the Edit tab.

OR

In the Running Order of the NRCS, double-click a template to open it in the Edit tab.

HTML5 Plugin - Select Template

3. From the OpenMAM drop-down at the top of plugin, select an OpenMAM server.

Alternatively, you can click in the Content field of the image object in the template and select the icon
for the OpenMAM server you want to access.
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HTML5 Plugin - Select OpenMAM Server

«If using iNEWS, open the server manually.

4. Log in to the OpenMAM server.

The OpenMAM browser opens.

5. Select a media asset and then drag and drop the asset onto the Content field of an image or video
in the selected template.

The media asset is added to the template.

HTML5 Plugin - Add Asset from OpenMAM Server
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Adding and Deleting Folders

You can add folders in which to save your graphics and clips and delete folders that are no longer
needed.

To add a folder:

1. In the HTML5 Plugin, select the Browse tab.

2. Select a folder in the folder structure.

Folders can be added to the Daily and Persistent folders and to the sub-folders of the User
Favorites folder, but not to the top-level User Favorites or Rundowns folders.

3. Select the New Folder icon.

HTML5 Plugin - Add New Folder

The New Folder dialog opens.

HTML5 Plugin - Add New Folder

4. In the Name field, enter a name for the folder.

5. Select OK.

The new folder appears as a sub-folder in the folder structure.

To delete a folder:

1. In the HTML5 Plugin, select the Browse tab.

2. Select a folder in the folder structure.
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Folders can be deleted from the Daily and Persistent folders and from the sub-folders of the User
Favorites folder, but not from the top-level User Favorites or Rundowns folders.

3. Select the Delete Folder icon.

The Delete Folder confirmation dialog opens.

4. Select Yes.

The folder and its contents are deleted from the folder structure.
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NLE Workflow Setup
The XPression Gateway serves as a communication hub between the XPression NLE plugins, XPression
Template Builder, or Edius plugins installed on NLE workstations running supported NLE software and
the Bluebox Offline Engines rendering XPression templates. These renderings are transported over
TCP/IP to be applied to the users editing timeline.

Before you start using the XPression NLE workflow, the various components and settings need to be
configured for operability.

The XPression NLE Plugin is supported in Adobe Premier Pro 2019.

The following topics are discussed in this section:

Required Components

Optional Components

Setting Up the XPression Gateway for the XPression NLE Plugin and Edius Plugin

Setting Up the XPression Gateway for the XPression Template Builder
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Required Components

The following is a list of the required components for the XPression NLE workflow:

· XPression Gateway

· Studio, Prime, or BlueBox OFL (preview engine)

· XPression NLE Plugin, XPression Template Builder, or Edius Plugin

«The XPression Edius Plugin requires the Microsoft Visual Studio 2013 redistributable in order to install.

This is automatically done during installation, however, an internet connection is required to connect to
the Microsoft website during the install.

Optional Components

The following items are optional for the XPression NLE workflow:

· XPression Project Server

· Supported MAM system

For more information on...

The XPression Gateway user interface, refer to the section The XPression Gateway User Interface.

The XPression NLE Plugi and XPression Edius Plugin user interface, refer to the section The XPression
NLE Plugin and Edius Plugin User Interface - Templates and The XPression NLE Plugin and Edius Plugin
User Interface - Edit Mode.

The XPression Template Builder user interface, refer to the section The XPression Template Builder User
Interface - Templates and The XPression Template Builder User Interface - Edit Mode.
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Setting Up the XPression Gateway for the NLE and Edius
Plugins

The following steps explain the XPression Gateway configuration for the NLE workflow when using the
NLE Plugin or Edius Plugin.

«If you have any Citrix programs installed, such as GoToMeeting, ensure that the DNE LightWeight

Filter is disabled in the Local Area Connection Properties window of any machine that is connected to
the XPression Gateway, including the XPression Gateway itself.

To set up the XPression Gateway for the NLE and Edius plugins:

1. Open the XPression Gateway.

2. Select Gateway > Settings.

The XPression Gateway - Settings window opens.

3. Configure the following sections:

Client Plugins

Preview & Offline Engines

Project Server

Saved Items

OpenMAM

Reserved Client Slots
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Client Plugins

1. Select Client Plugins to configure the client plugin settings.

The Client Plugins configuration section opens.

2. In the Global Settings section, select the Enable Remote Plugin Updates checkbox to prompt users
of the XPression NLE Plugin or Edius Plugin to update the plugin if the version does not match the
version of the XPression Gateway.

3. Select the Show Template List on Edit Mode tab checkbox to allow users of the XPression NLE
Plugin or Edius Plugin to browse templates while the plugin is in edit mode.

4. Continue with configuring Preview & Offline Engines.
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Preview & Offline Engines

1. Select Preview & Offline Engines to configure the preview engines.

The Preview & Offline Engines configuration section opens.

«A preview engine needs to be added for every XPression Bluebox OFL system being used for

motion and still preview in the XPression NLE Plugin and Edius Plugin.

2. In the Preview & Offline Render Engines section, select Add.

The XPression Preview Engine dialog opens.

3. In the Engine ID section, in the Name field, enter an ID for the engine.

4. In the Description field, enter a brief description for the engine.

5. In the Remote XPression Engine section, in the Host field, enter the IP address of the XPression
system for the preview engine.

6. In the Port field, enter or select the port number for the XPression system.
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7. In the Options section, select the Reserve engine for NLE client rendering checkbox to send
preview requests from the NLE to any OFL engine(s) reserved for NLE use.

Any MOS plugin requests will be sent to the non-reserved OFL engine(s). If all OFL engines in the
Gateway have this check box enabled, MOS plugin requests will go to any of the OFL engines. If none
of the OFL engines have this check box enabled, previews from NLE clients will be assigned to any
one of the OFL engines.

8. Select OK.

The XPression Preview Engine dialog closes and the preview engine is added to the Preview &
Offline Render Engines list.

9. Continue with configuring the Project Server or if you do not have a project server, proceed to Saved
Items.
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Project Server

If you do not have the Project Server, proceed to Saved Items. If you are interested in adding the
XPression Project Server to your workflow, please contact your Ross Video sales representative.

The XPression Project Server offers centralized storage and creative collaboration within a facility or
across an enterprise. Designers and operators can access any XPression project from any XPression
workstation, share projects while working locally, then re-publish to the server.

The login username and password must be configured in the Project Server before you can connect to
the XPression Gateway.

«The XPression Project Server is optional for XPression NLE workflow.

1. Select Project Server to configure the XPression Project Server settings.

The Project Server configuration section opens.

2. In the Project Server section, select the Enabled checkbox to use the Project Server.

3. In the Host field, enter the IP address of the Project Server.

4. In the Port field, enter or select the port number for the Project Server.

5. In the Login field, enter your username for the Project Server.

6. In the Password field, enter the password for your Project Server login.

7. Continue with configuring Saved Items.

For more information on the XPression Project Server, refer to the XPression Project Server User Guide.
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Saved Items

Saved Items are templates that are saved to the gateway and edited via the XPression NLE Plugin and
Edius Plugin. These pre-populated templates can be saved in user configured folders that can be stored
permanently, or in the daily graphics folder that can be automatically purged after a user defined
duration.

1. Select Saved Items to select and configure a graphics folder for the XPression Gateway.

The Saved Items configuration section opens.

2. In the Database section, in the Path field, enter a file path or select the Browse (...) button to open
a file browser to select a permanent or daily graphics folder.

3. From the Date format drop-down, select an order for the date that the graphic was saved. The
options are:

· dd-mm-yyyy — Day-Month-Year (for example, 15-07-2015)

· mm-dd-yyyy — Month-Day-Year (for example, 07-15-2015)

· yyyy-mm-dd — Year-Month-Day (for example, 2015-07-15)

4. In the Purge daily templates after X days field, enter or select the number of days after which the
daily graphics folder will be automatically purged. Set to 0 for no purging.

5. Continue with configuring OpenMAM servers and Reserved Client Slots, both optional.
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OpenMAM

«OpenMAM is optional for XPression NLE workflow. If you are not using MediaBeacon 3.0, MediaBeacon

5.0, Streamline, or XPression Maps asset management systems, proceed to Reserved Client Slots.

If you are configuring an OpenMAM driver, refer to the section Adding and Configuring an OpenMAM
Server for information on configuring the MediaBeacon 3.0, MediaBeacon 5.0, Streamline, or XPression
Maps connections.
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Reserved Client Slots

Reserved Client Slots are a list of NLE client IP addresses that can always connect. If the reserved client
list is less than the maximum number of allowed clients, then the extra slots can be connected by
anyone but only as many as are remaining, even if no reserved IPs are being used. Reserved IPs will
always connect.

1. Select Reserved Client Slots to reserve IP slots for NLE clients.

The Reserved Client Slots configuration section opens.

2. In the NLE section, select Add.

The Reserved Slot dialog opens.

3. In the Slot section, in the IP Address field, enter an IP address to reserve for the floating NLE client.

4. In the Description field, enter a brief description for the IP address reservation.

5. Select OK.

The Reserved Slot dialog closes and the IP address is added to the NLE reserved client list.

6. Select OK.

The XPression Gateway - Settings dialog closes and the settings are applied to the XPression
Gateway.

If access to a reserved IP address is attempted, or if the maximum amount of licenses are in use, the
following warning message is sent by the XPression Gateway:
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Setting Up the XPression Gateway for the Template
Builder

The following steps explain the XPression Gateway configuration for the XPression Template Builder in
an NLE workflow.

To set up the XPression Gateway for the Template Builder:

1. Open the XPression Gateway.

2. Select Gateway > Settings.

The XPression Gateway - Settings window opens.

3. Configure the following sections:

Preview & Offline Engines

Project Server

Saved Items

OpenMAM
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Preview & Offline Engines

1. Select Preview & Offline Engines to configure the preview engines.

The Preview & Offline Engines configuration section opens.

«A preview engine needs to be added for every XPression Bluebox OFL system being used for

motion and still preview in the XPression NLE Plugin and Edius Plugin.

2. In the Preview & Offline Render Engines section, select Add.

The XPression Preview Engine dialog opens.

3. In the Engine ID section, in the Name field, enter an ID for the engine.

4. In the Description field, enter a brief description for the engine.

5. In the Remote XPression Engine section, in the Host field, enter the IP address of the XPression
system for the preview engine.

6. In the Port field, enter or select the port number for the XPression system.

7. In the Options section, select the Reserve engine for NLE client rendering checkbox to send
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preview requests from the NLE to any OFL engine(s) reserved for NLE use.

Any MOS plugin requests will be sent to the non-reserved OFL engine(s). If all OFL engines in the
Gateway have this check box enabled, MOS plugin requests will go to any of the OFL engines. If none
of the OFL engines have this check box enabled, previews from NLE clients will be assigned to any
one of the OFL engines.

8. Select OK.

The XPression Preview Engine dialog closes and the preview engine is added to the Preview &
Offline Render Engines list.

9. Continue with configuring the Project Server or if you do not have a project server, proceed to Saved
Items.
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Project Server

If you do not have the Project Server, proceed to Saved Items. If you are interested in adding the
XPression Project Server to your workflow, please contact your Ross Video sales representative.

The XPression Project Server offers centralized storage and creative collaboration within a facility or
across an enterprise. Designers and operators can access any XPression project from any XPression
workstation, share projects while working locally, then re-publish to the server.

The login username and password must be configured in the Project Server before you can connect to
the XPression Gateway.

«The XPression Project Server is optional for XPression NLE workflow.

1. Select Project Server to configure the XPression Project Server settings.

The Project Server configuration section opens.

2. In the Project Server section, select the Enabled checkbox to use the Project Server.

3. In the Host field, enter the IP address of the Project Server.

4. In the Port field, enter or select the port number for the Project Server.

5. In the Login field, enter your username for the Project Server.

6. In the Password field, enter the password for your Project Server login.

7. Continue with configuring Saved Items.

For more information on the XPression Project Server, refer to the XPression Project Server User Guide.
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Saved Items

Saved Items are templates that are saved to the gateway and edited via the XPression NLE Plugin and
Edius Plugin. These pre-populated templates can be saved in user configured folders that can be stored
permanently, or in the daily graphics folder that can be automatically purged after a user defined
duration.

1. Select Saved Items to select and configure a graphics folder for the XPression Gateway.

The Saved Items configuration section opens.

2. In the Database section, in the Path field, enter a file path or select the Browse (...) button to open
a file browser to select a permanent or daily graphics folder.

3. From the Date format drop-down, select an order for the date that the graphic was saved. The
options are:

· dd-mm-yyyy — Day-Month-Year (for example, 15-07-2015)

· mm-dd-yyyy — Month-Day-Year (for example, 07-15-2015)

· yyyy-mm-dd — Year-Month-Day (for example, 2015-07-15)

4. In the Purge daily templates after X days field, enter or select the number of days after which the
daily graphics folder will be automatically purged. Set to 0 for no purging.

5. Continue with configuring OpenMAM servers (optional).
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OpenMAM

«OpenMAM is optional for XPression NLE workflow. If you are not using MediaBeacon 3.0, MediaBeacon

5.0, Streamline, or XPression Maps asset management systems, select OK to close the XPression
Gateway - Settings window.

The XPression Gateway - Settings window closes and the settings are applied to the XPression
Gateway.

If you are configuring an OpenMAM driver, refer to the section Adding and Configuring an OpenMAM
Server for information on configuring the MediaBeacon 3.0, MediaBeacon 5.0, Streamline, or XPression
Maps connections.
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NLE Workflow Operation
This section describes how to use the templates and saved graphics in the XPression NLE Plugin and
Edius Plugin.

The following topics are discussed in this section:

Using Graphics in an NLE Workflow

Using Clips in an NLE Workflow

Assigning Take IDs to Objects

Using Spell Check

For more information on...

The XPression NLE Plugin and Edius Plugin user interface, refer The XPression NLE Plugin and Edius
Plugin User Interface - Templates and The XPression NLE Plugin and Edius Plugin User Interface - Edit
Mode.

The XPression Template Builder user interface, refer to the section The XPression Template Builder User
Interface - Templates and The XPression Template Builder User Interface - Edit Mode.
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Using Graphics in an NLE Workflow

The Graphics tab is used for selecting graphics that have been pre-populated with information and
saved to a user-specified folder and for adding graphics to a story in the NRCS. You can also delete
graphics, add or delete folders, and browse the metadata of a graphic.

1. Open the XPression NLE Plugin, XPression Template Builder, or Edius Plugin in the newsroom client.

2. Select Graphics.

The Graphics tab opens.

NLE Workflow - Graphics Tab

3. Select one of the following viewing methods for the graphics browser:

Thumbnails — select this tab to view the graphics in a thumbnail layout.

List — select this tab to view the graphics in a name list.

4. Select and edit your graphics:

For information on selecting graphics, refer to the section Selecting Graphics.

To edit graphics, refer to the section Editing Graphics.

5. To browse the metadata of a graphic or template, refer to the section Browsing Graphic Metadata.
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Selecting Graphics

There are several ways to locate the graphic you want to edit. You can browse graphics in the Project
Server or from the Preview Engine or select from graphics you've saved. You can also browse the
metadata of a graphic or template.

Browsing Graphics from a Project Server

Browsing Graphics without a Project Server

Selecting Saved Graphics

Browsing Graphics From a Project Server

If a revision of a project is published in the NLE Plugin, the Template Builder, and Edius Plugin will
receive a notification of the revision.

To browse graphics from a Project Server:

1. In the Browse tab, 

2. Select Browse (...).

The Show, Category and Style Selection dialog opens.

3. Select a show and category from the Show and Category tree.

4. In the Style list, select a style.

5. Select OK.

The Show, Category and Style Selection dialog closes and the graphics associated with the
selected style are available for selection in the Thumbnails / List.

6. In the Filter field, enter a graphic name or keyword to search for specific graphics.

The filter also searches the metadata of graphics when available.

7. Double-click a graphic from the Thumbnails or List.

«For information about XPression Project Server, refer to the XPression Project Server User Guide.

Browsing Graphics Without Project Server
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The available graphics are dictated by what has been loaded on the preview engine. This must be done
manually.

1. Open the NLE Plugin in the newsroom client.

2. In the NLE Plugin, select the Graphics tab.

The Graphics tab opens. By default, it will show graphics from the last show that was opened.

NLE Workflow - Graphics Tab

Alternatively, you can enter the name of a graphic in the Filter field to search for a specific graphic.

The filter also searches the metadata of graphics when available.

Selecting Saved Graphics

You can select graphics from any of the folders in the Browse tab.

To select a saved graphic:

· In the Browse tab, select a graphic from the Saved Items folder structure. 

These graphics need to have been pre-populated with information and saved to a user-specified
folder.

OR

Select a graphic from the Rundowns area.

This enables users to select graphics used in rundowns that are being monitored by the XPression
Gateway. The graphics can be copied to other rundowns or modified from their current state using the
Edit tab and then added to a rundown.
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Editing Graphics

«Modifying the text template data fields of MOS items in XPression prevents the changes from being

overwritten by new updates in the MOS Plugin.

To edit graphics:

1. In the Graphics tab, double-click a graphic from the Thumbnails, List, or Saved Graphics.

The template opens in the Edit tab.

NLE Workflow - Edit Tab

The graphic is visible in the preview window and the published fields will be displayed in the Object /
Field and Content lists. When using static text, if Enable User Input Controls is selected in the Data
Source tab of the Object Inspector in XPression, the Content cell will contain a list of available static
text values.

Users can play animations from the graphic using the playback controls below the preview window.

2. Assign Fixed Take ID numbers if desired.

For more information, refer to Assigning Take IDs to Objects.

3. Edit the Object / Field information in the Content column. 

The changes appear in the preview.

The specific object or field can also be selected by clicking on it in the preview window.

Clear a field by right-clicking it and selecting Clear Field from the shortcut menu; or revert to the
template values by selecting Revert all fields to template values.

4. Select Save.

You can also drag and drop a graphic from the preview window to the newsroom client interface.
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«When using the NLE Plugin or Edius Plugin, you can open a graphic from the story in the NRCS to edit

or update by double-clicking it. The graphic will open in the Edit tab. Once edited/updated, select Save
to apply the changes.

«For more information about creating user input controls for static text objects, refer to the XPression

Help File in XPression.
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Saving Graphics

You can save your graphics to a daily folder or to a specific folder in the Saved Items folder structure or
you can create a new folder. 

Daily folders are auto-generated with the current date and can be set to purge after a specified period
of time.

To save a graphic:

1. When you have finished editing your graphic, select Save.

2. The Save Item to Folder dialog opens.

3. Select one of the following save options:

Save as Daily Item — select this radio button to save the graphic to a daily items folder. This will
create an items folder for the current date that is subject to the Saved Items settings in the
XPression Gateway.

Save to Specific Folder — select this radio button to save the graphic to a specific folder selected
from the Saved Items folder structure.

4. Click OK.

The Save Item to Folder dialog closes and the graphic is saved.
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Exporting Graphics to PNG

The preview image for a graphic can be saved as a PNG file.

To export a graphic to a PNG file:

1. In the Preview section, right-click on the preview image and select Export Image from the shortcut
menu.

A Save As file browser opens.

2. Use the file browser to locate a folder in which to save the .png file.

3. Select Save.
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Using Saved Graphics in Template Builder for Playout

Saved graphics and clips can be dragged and dropped into the Sequencer in XPression to generate
take items for playback.

If you are using a Project Server, this drag and drop will initiate deployment of the required project to
the playout engine. If you are not using a Project Server, take items created by drag and drop must be
manually synchronized with the correct project.

Copying and pasting graphics only works from Template Builder to a newsroom system. It does not
function like the Template Builder drag and drop feature.

Browsing Graphic Metadata

Metadata is an option that can be designed into a scene. You can view the metadata of any graphic or
template using the following procedure.

To browse the metadata of a graphic:

1. In the Graphics or Edit tab, right-click on a graphic or template from the Thumbnails, List, or Saved
Graphics.

2. Select Browse Metadata.

The Browse Metadata window opens.

Browse Metadata
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Using Clips in an NLE Workflow

«XPression Clips is optional for XPression and the XPression NLE workflow. If you do not have

XPression Clips and are interested in adding it to your workflow, please contact your Ross Video sales
representative.

«If you're using a Project Server and a revision of a project is published in the NLE Plugin, Template

Builder, and Edius Plugin will receive a notification of the revision.

The Clips tab is used for adding clips to a template. The Clips tab in the NLE Plugin and Edius Plugin can
also be used for adding clips to the story in the NRCS.

Selecting Clips

To select a clip:

1. Open the XPression NLE Plugin, XPression Template Builder, or Edius Plugin.

2. Select Clips.

The Clips tab opens.

3. Click on a clip to select it or use the Advanced Search Options to locate a specific clip.

To locate a specific clip:

1. Select the Show/Hide advanced search options ( )button beside the Quick Find field, to open
the advanced search options.

2. Enter or select search criteria as follows:

· Name — enter the name of a clip to search.

· Recall ID — enter a recall ID to search.

· Source — enter a location to search for a clip.

· ID Min — enter the first clip ID number in a range.
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· ID Max — enter the last clip ID number in a range.

· Duration Min — enter a minimum duration time to search for a clip that is at least as long as the
value.

· Duration Max — enter a maximum duration time to search for a clip that is no longer than the
value.

· Project — from the drop-down, select a project in which to search for a clip.

· Added Min — use the calendar to select clips that were added on or after the selected date.

· Added Max — use the calendar to select clips that were added on or before the selected date.

· Expires Min — use the calendar to select clips that expire on or after the selected date.

· Expires Max — use the calendar to select clips which expire on or before the selected date.

· Never Expires — select this checkbox to search for a clip with no expiry date set.

· Audio Ch Min — enter or select the minimum number of embedded audio channels in the clip to
find.

· Audio Ch Max — enter or select the maximum number of embedded audio channels in the clip to
find.

· No Audio — select this checkbox to search for a clip with no embedded audio.

· Show all sub clips — select this checkbox to display all sub clips of a clip in the Clip Browser list
when performing an advanced search.

Selecting Saved Clips

«Users can create new folders in the Saved Items folder on the XPression Gateway. These folders will

appear in the Saved Items folder structure in the NLE Plugin, Template Builder, and Edius Plugin. 

Clips can be saved to the daily folders. These folders are auto-generated with the current date and can
be set to purge after a specified period of time.

For information on Saved Items folders, refer to Saved Items.

To select a saved clip:

· In the Browse tab, select a clip from the Saved Items folder structure. 

These clips need to have been pre-populated with information and saved to a user-specified folder.

OR

Select a clip from the Rundowns area.

This enables users to select clips used in rundowns that are being monitored by the XPression
Gateway. The clips can be copied to other rundowns or modified from their current state using the
Edit tab and then added to a rundown.

Editing Clips

You can edit any clip that appears in the Clips tab and then add the edited clip to the NRCS.

1. In the Clips tab, double-click a clip from the list of clips.

The clip opens in the Edit tab.

The graphic is visible in the preview window and the clip info will be displayed in the Timing and
Source Information sections.
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You can play the clip using the playback controls below the preview window.

2. Assign Fixed Take ID numbers if desired. 

For more information, refer to Assigning Take IDs to Objects.

3. In the Description field, enter a brief descriptor as necessary.

4. Select Save.

You can also select and drag from the thumbnail list to the newsroom client interface, if using the NLE
Plugin or Edius Plugin.

Saving Clips

You can save your clips to a daily folder or to a specific folder in the Saved Items folder structure.

To save a clip:

1. When you have finished editing your clip, select Save.

The Save Item to Folder dialog opens.
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2. Select one of the following save options:

Save as Daily Item — select this radio button to save the clip to a daily items folder. This will create
a folder for the current date that is subject to the Saved Items settings in the XPression Gateway.

Save to Specific Folder — select this radio button to save the clip to a specific items folder selected
from the Saved Items folder structure.

3. In the Name field, enter a name for the saved clip.

4. Select OK.

The Save Item to Folder dialog closes and the clip is saved.

Exporting Clips to PNG

The preview image for a clip can be saved as a PNG file.

To export a clip to a .png file:

1. In the preview section, right-click on the preview image and select Export Image from the shortcut
menu.

A Save As file browser opens.

2. In the file browser, navigate to a folder in which to save the .png file.

3. Select Save.

Adding a Clip to a Graphic

To add a clip to a graphic:

1. Open a graphic in the Edit tab that contains a video or image Object / Field.

NLE Workflow - Edit Tab

2. Select the Clips tab.

The Clips tab opens.
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NLE Workflow - Clips Tab

3. Select and drag a clip over the Edit tab.

The Edit tab opens.

NLE Workflow - Edit Tab

4. Drop the clip onto the video or image field.

The clip is added to the video or image field selected in the graphic and the clip is displayed in the
preview for the graphic.
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NLE Workflow - Add Clip

For more information on XPression Clips, refer to the XPression Clips User Guide.

Assigning Take IDs to Objects

Take ID numbers can be assigned to graphics and clips in the XPression NLE Plugin, XPression Template
Builder, and Edius Plugin.

«Take IDs on the Remote Sequencer will not match the Take IDs assigned to the XPression Sequencer

items.

To assign a Take ID to an object:

1. In Edit, right-click inside the top section of the editor and select Assigned Fixed ID.

The Set Take ID dialog opens.

NLE Workflow - Set Take ID

2. Select one of the following:

· Automatically Generate Take ID — select this radio button to automatically assign a Take ID
based on the next available Take ID number. This is the default setting.

· Fixed Take ID — select this radio button to manually assign a static Take ID.

In the Fixed Take ID field, enter or select a Take ID number.

«When a fixed Take ID is assigned, no checks or safeguards are performed to prevent duplicate

IDs from being used in the rundown. When two rundowns are loaded in the XPression Sequencer
with duplicates, one of the Take IDs will automatically be renumbered. It is recommended that when
two rundowns use duplicate Take ID numbers that only one rundown be activated at a time.
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«It is also recommended that all static Take IDs be assigned numbers over 2000 to avoid conflicts

between automatically generated Take ID numbers and the static Take ID numbers.

3. Select OK.

The Set Take ID dialog closes.

«When the Take ID is set, you recall and edit the graphic or clip from the rundown and the fixed ID

is retained in the rundown only.



199 • NLE Workflow Operation XPression Distributed Workflow User Guide (v12.0)

Using Spell Check

The NLE Plugin, Template Builder, and Edius Plugin offer spell check with a local dictionary to which
words can be added on a per user basis.

To use Spell Check:

1. Select Options > Configuration.

The respective Configuration dialog opens for the NLE Plugin, Template Builder, or Edius Plugin.

NLE Workflow - Spell Check Configuration

2. In the Spell Check section, from the Dictionary drop-down, select a language for the spell check.

3. Select OK.

The Configuration dialog closes.

4. Open a graphic in the Edit tab of the plugin.
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NLE Workflow - Edit Tab

5. Left-click inside the Content cell of a text Object / Field.

Any existing text content is highlighted.

6. Highlight a specific word or enter and highlight a new word to use for the spell check.

7. Select Spellcheck.

· If the word is spelled correctly, or it has already been added to the dictionary, an information
window opens that indicates that the spell check is complete.

· If the word is spelled incorrectly, or has not been added to the dictionary, the Spell Check dialog
opens.

8. Do one of the following:

· Select Ignore to return to the Edit tab without making any changes.

· Select a word from the Suggestions list and then select Change to correct the spelling.

· Select Add to add the word to the dictionary.

An information window opens indicating that the spell check is complete.

9. Select OK to exit the information window.

Depending on the action taken in Step 8, the text content is either the same or corrected/changed.
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Adding and Deleting Folders

You can save your graphics to a daily folder or to a specific folder in the Saved Items folder structure or
you can create a new folder. 

You can add folders in which to save your graphics and clips and delete folders that are no longer
needed.

To add a folder:

1. In the HTML5 Plugin, select the Browse tab.

Folders can be added to the Daily and Persistent folders and to the sub-folders of the User
Favorites folder, but not to the top-level User Favorites or Rundowns folders.

2. Right-click on a folder and select New Folder.

NLE Workflow - Add New Folder

The New Folder Name dialog opens.

HTML5 Plugin - Add New Folder

3. In the Name field, enter a name for the folder.

4. Select OK.

The new folder appears as a sub-folder in the folder structure.

To delete a folder:

1. In the NLE Plugin, select the Browse tab.

Folders can be deleted from the Daily and Persistent folders and from the sub-folders of the User
Favorites folder, but not from the top-level User Favorites or Rundowns folders.

2. Right-click on the folder you want to delete and select Delete Folder.
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NLE Workflow - Delete Folder

The Delete Folder confirmation dialog opens.

NLE Workflow - Delete Folder Confirmation

3. Select Yes.

The folder and its contents are deleted from the folder structure.
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OpenMAM
«OpenMAM is optional for XPression MOS and NLE workflows.

This section describes how to set up an OpenMAM server for the XPression MOS and NLE workflows.

The following topics are discussed in this section:

Adding and Configuring an OpenMAM Server

Using OpenMAM Filter Strings With Streamline
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Adding and Configuring an OpenMAM Server

OpenMAM is optional for XPression MOS and NLE workflows.

This section explains the procedure for adding an OpenMAM server for the XPression MOS and NLE
workflows and provides instructions for configuring each driver.

To add an OpenMAM server:

1. In the XPression Gateway, select Gateway > Settings.

The XPression Gateway - Settings window opens.

2. Select OpenMAM.

The OpenMAM panel opens.

3. In the OpenMAM Servers section, select Add.
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The Add OpenMAM Server window opens.

4. In the Select OpenMAM Driver section, select an OpenMAM driver.

5. Select OK.

The driver configuration window of the selected asset management system opens.

6. Continue with the instructions for the selected driver as described in the following links:

Dali Driver 

XPression Maps 

MediaBeacon (v3.0) Driver

MediaBeacon (v5.0+) Driver

Streamline Driver 

7. When you have finished configuring the selected driver, select OK to close the XPression Gateway
Settings window.
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Dali Driver

Use the instructions below to configure a Dali Driver.

To configure a Dali Driver:

1. In the Server ID section, in the ID field, assign the Dali Driver server ID. 

Make a note of this ID because it will be the same for any other XPression device connecting to the
Dali Driver server.

2. In the Description field, enter a brief description for the server (optional).

3. In the Connection Settings section, in the Server URL field, enter the URL of the Dali Driver server.

4. In the Path to Dali Plugin field, enter the file path for the Dali Driver Web Client executable.

5. Select the Local Cache tab.

The Local Cache tab opens.

6. In the Local Asset Cache Settings section, select the Retrieve assets from a local Asset Cache
Server checkbox to retrieve assets from a cache server.

7. In the Path field, enter the location of the local server or select Browse (...) to select a location.

8. Select OK.

The Dali Server Configuration window closes and the server is added to the OpenMAM Servers list.
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XPression Maps

Use the instructions below to configure an XPression Maps server.

To configure the XPression Maps server:

1. In the Server ID section, in the ID field, assign the XPression Maps server ID.

Make a note of this ID because it will be the same for any other XPression device connecting to the
XPression Maps server.

2. In the Description field, enter a brief description for the server (optional).

3. In the Connection Settings section, in the Server URL field, enter the URL of the XPression Maps
server.

4. In the Plugin App field, enter the file path for the XPression Maps Web Client executable.

5. Select OK.

The XPression Maps Server Configuration window closes and the server is added to the OpenMAM
Servers list.
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MediaBeacon (v3.0) Driver

Use the instructions below to configure a MediaBeacon (v3.0) driver.

To configure the MediaBeacon (v3.0) Driver:

1. In the Server Info section, in the ID field, assign the MediaBeacon server ID.

Make a note of this ID because it will be the same for any other XPression device connecting to the
MediaBeacon server.

2. In the Description field, enter a brief description for the server (optional).

3. In the Connection Settings section, in the Host field, enter the IP address of the MediaBeacon
server.

4. In the Port field, enter or select the port number for the MediaBeacon server.

5. In the Login field, enter the username configured on the MediaBeacon server.

6. In the Password field, enter the password for the MediaBeacon username.

7. Select OK.

The MediaBeacon Driver Configuration window closes and the server is added to the OpenMAM
Servers list.
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MediaBeacon (v5.0+) Driver

«To connect the XPression Gateway to a MediaBeacon 5.0+ server, you must first register the

MediaBeacon plugin on the MediaBeacon server.

Use the instructions below to configure a MediaBeacon (v5.0+) driver.

To configure the MediaBeacon (v5.0+) Driver:

1. In the Connection Settings section of the Configuration tab, in the Plugin ID field, enter or select
the plugin identification number.

2. In the Server Settings section, in the ID field, assign the MediaBeacon server ID. 

Make a note of this ID because it will be the same for any other XPression device connecting to the
MediaBeacon server.

3. If this is the first device you are connecting to the server, select Register Plugin to be redirected to
the MediaBeacon login screen in Google Chrome and enter the login information.

Once the login information has been entered, you should see a message indicating the plugin has
been successfully registered.

The plugin only has to be registered once. When configuring other engines, use the same plugin ID.

4. In the Description field, enter a brief description for the server (optional).

5. In the IP Address field, enter the IP address of the MediaBeacon server.

«The Port field is set to 80 by default and must remain set to 80.

6. Select the Local Cache tab.

The Local Cache tab opens.

7. In the Local Asset Cache Settings section, select the Retrieve assets from a local Asset Cache
Server to retrieve assets from a cache server.
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8. In the Path field, enter the location of the local server or select Browse (...) to select a location.

9. Select OK.

The MediaBeacon Driver Configuration window closes and the server is added to the OpenMAM
Servers list.
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Streamline Driver

Use the instructions below to configure a Streamline driver.

To configure a Streamline Driver:

1. In the Server ID section, in the MOS ID field, enter the MOS ID of the Streamline server.

2. In the Description field, enter a brief description for the server (optional).

3. In the Connection Settings section, in the Server URL field, enter the URL of the Streamline server.

«The Streamline server must be on the same domain as the HTML5 plugin.

4. In the API Key field, enter the API key of the Streamline user.

5. In the Miscellaneous Settings section, from the Streamline Version drop-down, select the version
of Streamline software being used in the workflow.

6. Select the Allow use of unapproved assets checkbox if allowing the use of unapproved assets.

7. Select the Download only transcoded XPression videos, if allowing only transcoded videos to be
used.

8. Continue with configuring the Local Cache.
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To configure the Local Cache:

1. Select the Local Cache tab.

The Local Cache tab opens.

2. In the Local Asset Cache Settings section, select the Retrieve assets from a local Asset Cache
Server to retrieve assets from a cache server.

3. In the Path field, enter the location of the local server or select Browse (...) to select a location.

4. Continue with configuring MOS Integration.

To configure MOS Integration:

1. Select the MOS Integration tab.stre

The MOS Integration tab opens.

2. In the MOS Settings section, select the Add Streamline Clips to MOS Rundown checkbox, if you
intend to use a MOS workflow.
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3. Select OK.

The Streamline Server window closes and the server is added to the OpenMAM Servers list.

4. In the Gateway panel, in the MOS Objects & Messages section, select the Parse
roStorySendMessage checkbox, which is required when adding Streamline clips to a MOS rundown.
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Using OpenMAM Filter Strings with Streamline

«OpenMAM is optional for XPression MOS and NLE workflows.

«The steps below apply to Streamline 4.1 or higher.

The following steps explain how to use user input controls to dynamically adjust OpenMAM filters for the
faces of background, quad, sphere, cube, cylinder, torus, and slab objects in XPression when using
Streamline.

To enable the OpenMAM properties tab in the Object Inspector:

1. In XPression select Edit > Preferences.

The Preferences window opens.

2. Select Remote Server.

The Remote Server panel opens.
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3. In the Automation section, select the Show Automation / OpenMAM Properties Tab in Object
Inspector checkbox to enable the OpenMAM tab in the Object Inspector of an object.

4. Select OK.

The Preferences window closes.

To select a user control type:

1. In the Scene Manager, select a scene that contains an object and text to use for the OpenMAM
filter.

Scene Manager

2. In the Object Manager, select the text object and enter a meaningful name in relation to the filter to
be created (e.g., VideoDescription).
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Object Manager - Text

3. In the Object Inspector, click the Data Source tab.

Object Inspector - Data Source

4. In the Select Data Source section:

· Select the Static Text radio button.

· Select the Enable User Input Controls checkbox.

  The User Control panel opens.

· From the Type dropdown, select the user input control you want to use for the filter. 

The options are:

Ø List Box

Ø Combo Box (Drop Down)

Ø Radio Buttons

Ø Checkboxes

5. Clear the Allow custom values checkbox.

To configure a filter for the text:

1. In the User Control section, select Static List as the input source.

2. Select Add to add the user input control you selected to the list and enter a description. 

3. Repeat this step to add the text options for the selected user control (e.g., Today's Headlines, Up
Next, Market Update).
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Object Inspector - User Control

4. Right-click inside the list and select Add Column from the shortcut menu.

The Add New Column dialog opens.

Object Inspector - Add New Column

5. In the Add New Column dialog, enter the column name Filter and select OK.

The new column is added to the list.

Object Inspector - User Control - Add Column

6. For each user control, click in the Filter column of a user control and enter the file path to the
Streamline folder containing the content that will be used with the selected text,
(e.g., /videos/Today's Headlines) on the Streamline server. 

Object Inspector - Streamline Paths

«Entering a ‘*’ variable for a generic filter will create a file path to the root folder in Streamline.

To configure a filter for an object: 
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1. In the Object Manager, select an object to use for the OpenMAM filter (e.g., a quad).

Object Manager - Object

2. In the Object Inspector, select the Template Links tab.

The Template Links tab opens.

Object Inspector - Template Links

3. In the Template Links section, select the Publish Object checkbox to publish the selected object.

4. In the Object Inspector, select the OpenMAM tab.

The OpenMAM tab is displayed.

Object Inspector - OpenMAM

5. In the list of object faces in the OpenMAM tab, select the face of the object to which a filter string is
to be applied.

6. In the OpenMAM Options section, in the Filter String field, enter a filter string to link the object face
and the text, in Streamline (e.g., @VideoDescription@).
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Object Inspector - OpenMAM Options

7. Select Save Project and Publish To Project Server ( ).

To use the filters in the XPression plugin:

1. Open the project in the XPression Plugin.

2. Open the scene with the OpenMAM filters in the Edit tab of the plugin.

OpenMAM - Edit Graphic

3. In the Object / Field list, click on the Content row for the text object (e.g., VideoDescription).

The user input controls created in XPression for the scene are displayed. In this example, radio
buttons for Today's Headlines, Up Next, Market Update and Weather.
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OpenMAM - User Input Controls in Plugin

4. Select one of the radio buttons, e.g., Weather.

The text in the graphic is replaced by the text assigned to that radio button.

OpenMAM - Select Radio Button

5. From the Object / Field list, select the object face to which the text refers and then select the

Streamline button ( ).

6. Log in to Streamline, if prompted.

The Streamline XPression Asset Browser opens on the folder of the selected user input control, in
this example, Weather.



221 • OpenMAM XPression Distributed Workflow User Guide (v12.0)

OpenMAM - Streamline Filter

7. To access a different folder in the Streamline XPression Asset Browser, in the plugin, select a

different user input control for the object face (e.g., Up Next) and click the Streamline button ( ).

The Streamline XPression Asset Browser opens on the folder of the newly selected user input
control.
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OpenMAM - Different Streamline Filter 
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XPression Rundown Controller
«The XPression Rundown Controller is optional when using an XPression workflow and must be

installed separately. If you are interested in this free component, you can find the installer on the USB
media stick shipped with XPression.

The XPression Rundown Controller is used to activate rundowns from the XPression Gateway for playout
in the XPression Sequencer.

Before you start using the XPression Rundown Controller, the remote connection points need to be
configured. A connection point is a link between the XPression Rundown Controller and an XPression
Gateway.

The following topics are discussed in this section:

Adding a Remote Connection Point

Editing a Remote Connection Point

Deleting a Remote Connection Point

Selecting Rundowns
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Adding a Remote Connection Point

A connection point is a link between the XPression Rundown Controller and the XPression Gateway. Use
the following procedure to add a connection point between the XPression Rundown Controller and an
XPression Gateway.

To add a remote connection point:

1. In the Windows Search field, enter xpression rundown controller and double-click the application
or select Open to launch the Rundown Controller.  

2. In the XPression Rundown Controller, select File > Connection Points. 

The Remote Connection Points window opens. 

Rundown Controller - Remote Connection Points

3. Select the Add button.

The Remote Connection Point window opens. 

Rundown Controller - Add Connection Point

4. In the Connection ID section, in the Name field, enter a name for the connection. 

5. From the Category drop-down, select a category to identify the connection point.

6. In the Description field, enter a description for the connection. 
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7. In the Remote Address section, from the Connection Type drop-down, select a connection type for
the remote address.

8. In the Host field, enter the remote host IP address. 

9. In the Port field, enter or select the host port number of the remote address and then select OK.

The Remote Connection Point window closes and the new connection point appears in the Remote
Connections list in the Remote Connection Points window. 

10.Select OK to close the Remote Connection Points window.
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Editing a Remote Connection Point

Use the following procedure to edit a connection point between the XPression Rundown Controller and
an XPression Gateway.

To edit a connection point:

1. In the XPression Rundown Controller, select File > Connection Points. 

The Remote Connections window opens. 

Rundown Controller - Remote Connection Points

2. In the Remote Connections window, select a remote connection point from the Remote Connections
list. 

3. Select the Edit button. 

The Remote Connection Point window opens. 

Rundown Controller - Edit Connection Point

4. In the Remote Connection Point window, edit the details as necessary and then select OK.

The Remote Connection Point window closes and the edited connection point appears in the
Remote Connections list in the Remote Connections window. 

5. Select OK to close the Remote Connections window.
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Deleting a Remote Connection Point

Use the following procedure to delete a connection point between the XPression Rundown Controller
and an XPression Gateway.

To delete a remote connection point:

1. In the XPression Rundown Controller, select File > Connection Points. 

The Remote Connections window opens. 

Rundown Controller - Remote Connections

2. From the Remote Connections list, select a remote connection point. 

3. Then select the Delete button. 

A Confirmation dialog opens. 

Rundown Controller - Delete Remote Connection Confirmation

4. Select Yes. 

The Confirmation dialog closes and the connection point is deleted from the Remote Connections list
in the Remote Connections window. 

5. Select OK to close the Remote Connections window.
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Selecting Rundowns

Select rundowns to update the XPression Gateway for the playout engine.

1. In the Rundown list, select the checkbox of the rundown(s) to use in the playout engine.

2. Use the Sort Filter field to enter a rundown or keyword to move the rundown to the top of the
rundown list.

Rundown Controller - Select Rundown

3. If applicable, select the radio button of the style(s) template to use.

4. Select Apply Settings.

The rundown selections are sent to the XPression Gateway and are available for playout in the
playout engine.
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XPression Remote Sequencer
The XPression Remote Sequencer is used to control remote XPression engines and playout graphics and
clips from a MOS rundown.

This section describes how to configure the remote sequencer preferences, reset the layout, configure
connection points and groups, select rundowns, and control sequence playout.

Remote Sequencer

The following topics are discussed in this section:

Configuring Smart GPI / RossTalk

Setting Preferences

Changing and Saving the Layout

Adding a Remote Connection Point

Editing a Remote Connection Point

Deleting a Remote Connection Point

Selecting a Channel Group

Selecting Active Rundowns
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Creating a Manual Rundown

Keyboard / GPI Mapping

Channels

Scene Manager

Previews

Linear Rundown

Take Item Inspector

Clip Browser

Control Sequence Playout
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Configuring Smart GPI / RossTalk

Use the following procedure to configure the Smart GPI / RossTalk Settings for the XPression Remote
Sequencer.

To configure Smart GPI / Rosstalk:

1. In the XPression Remote Sequencer, select File > Hardware Setup. 

The Hardware Setup window opens. 

Remote Sequencer - Hardware Setup

2. In the GPI Boards tab, select Add.

The Add New GPI Board dialog opens.

Remote Sequencer - Add New GPI Board

3. From the Brand drop-down, select the Smart GPI / RossTalk board.

4. Select OK.

The Smart GPI / RossTalk Setup window opens.

Remote Sequencer - Smart GPI / Ross Talk Settings
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5. In the Settings section, from the State drop-down, select Enabled. 

Select Disabled to turn off Smart GPI/RossTalk.

6. Select a Mode for Smart GPI/RossTalk:

Serial RS232 — select to use RS232 to send Smart GPI/RossTalk signals to XPression Remote
Sequencer. 

TCP — select to use TCP/IP to send Smart GPI/RossTalk signals to XPression Remote Sequencer. 

UDP — select to use UDP sockets to send Smart GPI/RossTalk signals to XPression Remote
Sequencer. 

7. Configure the selected GPI mode.

8. Select OK.

9. Select Close.

Serial RS232

1. In the RS232 GPI Settings panel, from the Port drop-down, select the Communication port that
receives GPI signals.

Remote Sequencer - RS232 GPI Settings

2. From the Baudrate drop-down, select the communication speed for GPI signals.

3. From the Data Bits drop-down, select the number of bits used to represent one character of data for
GPI signals.

4. From the Parity drop-down, select the method used to check for lost data in a GPI signal.

5. From the Stop Bits drop-down, select the number of bits used to indicate the end of a byte in a GPI
signal.

6. From the Flow Control drop-down, select the data transmission rate controller for a GPI signal.

«When using Smart GPI/RossTalk, the flow control can be set to Hardware or None, but it must be

set the same in both XPression and the transmitting device.
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TCP

1. In the Incoming Network Settings section, in the TCP Port field, enter or select the communication
port that receives GPI signals from an external source.

Remote Sequencer - TCP Settings

2. In the Outgoing Network Settings section, in the Hostname field, enter the host name of a remote
device that is to receive RossTalk messages from the local XPression engine.

3. In the TCP Port field, enter or select the communication port that receives the signals. 

UDP

1. In the Incoming Network Settings box, in the UDP Port field, enter or select the communication port
that receives GPI signals from an external source. 

Remote Sequencer - UDP Settings

2. In the Outgoing Network Settings section, in the Hostname field, enter the host name of a remote
device that is to receive RossTalk messages from the local XPression engine.

3. In the TCP Port field, enter or select the communication port that receives the signals. 
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Setting Preferences

Use the following procedure to configure the General settings and Channel Colors for the XPression
Remote Sequencer.

To access the Preference settings:

· In the XPression Remote Sequencer, select File > Preferences.

The Preferences window opens on the General panel.

Remote Sequencer - Preferences - General Panel

To configure the General settings for the XPression Remote Sequencer:

1. In the Sequencer section, make the following selections as needed:

· Select the Loop On End checkbox to loop the cursor to the start of a rundown when it has reached
the end. 

· Select the Center online item in view checkbox to center the online take item in the view of the
rundown. 

· Select the Center focused item in view checkbox to position a focused scene in a sequence list in
the middle of the view, provided the sequence list extends the size of the view. 

· Select the Advance focus after taking item offline (with minus key) checkbox to advance to the
focus to the next take item after taking a take item offline using the minus (-) key.

· Select the Disable ESC-ESC from clearing channels checkbox to disable the ESC-ESC keyboard
command from clearing all channels.

2. In the Display Preferences section, make the following selections as needed:

· Select the Highlight online and cued items checkbox to distinguish online and cued items in the
Linear Rundown and Channel lists by highlighting them.

· Select the Channel Sequencers should follow linear sequencer checkbox to have the channel
sequencers items follow the up next items in the linear sequencer (all channel items highlight/focus
to the next/upcoming item in the list).

· Select the Only the channel assigned to the selected item should follow checkbox to have only
the item focused in the Linear Rundown follow in the channel list. 
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· Select the Show empty stories in MOS rundowns checkbox to display stories in the rundown that
don’t contain items.

· Select the Show preview image / layer list for individual channels checkbox to display the

preview image and layers for a selected item in individual channels.

· Select the Prioritize channel column previews checkbox to only send individual channel previews
to the Desktop Preview Server when the Linear Sequence is undocked. 

To configure the Channel Colors for the XPression Remote Sequencer:

1. Select the Channel Colors panel to configure channel colors for the XPression Remote Sequencer.

Remote Sequencer - Preferences - Channel Colors

2. In the Channel Colors section, select the Use Channel Colors checkbox to colorize Next Up Preview
thumbnails, Linear Rundown Take IDs, Virtual Channel columns, and Channel Take Item lists. 

OR

Click inside the Color column of a Ch # to open the Color Editor to configure a color for the channel:

Remote Sequencer - Preferences - Color Editor
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· Use the Basic Colors section to select a preexisting color from the list and select OK.

· Use the Custom Colors section to select a color from the list of custom-created colors.

· Select Define Custom Colors to open a color spectrum to configure a specific color:

Remote Sequencer - Preferences - Custom Colors

· Configure the color mode for the custom color as HSL, RGB, or using the Hex Color field.

· Once a custom color has been created, select Add to Custom Colors to add the color to the
Custom Colors list and select OK.

3. Select Default to use the default channel colors. 

4. Select OK. 

The Preferences window closes.
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Changing and Saving the Layout

You can rearrange the various sections of the XPression Remote Sequencer to suit how you work and
then save it, so it always looks the same. 

To change the layout:

1. Select the header of the section you want to move.

2. Left-click and move the section.

When you move the section, you'll see a set of directional controls.

Remote Sequencer - Change Layout

3. Move the section to the control that matches where you want to dock that section and release the
left mouse button.

4. To pin the section as a pull-down tab, select the pin button.

To unpin the section, left-click the tab and select the pin button.

To save a layout:

1. When you have a layout you like, click the Save Docking Layout button ( ) to save a layout.

The Save Docking Layout window opens.
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Remote Sequencer - Save Docking Layout

2. Use the Name field to enter a name for the layout.

3. Select OK.

The layout is saved and is now available to select in the layouts list as well as the default layout.

To reset the layout:

1. In the XPression Remote Sequencer, select Docking > Reset Layout (or press Ctrl+Alt+R).

A Confirmation dialog opens. 

Remote Sequencer - Reset Docking Layout Confirmation

2. Select Yes. 

The Confirmation dialog closes and the XPression Remote Sequencer layout is reset.
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Adding a Remote Connection Point

A connection point is a link between the XPression Remote Sequencer and the XPression Gateway. Use
the following procedure to add a connection point between the XPression Remote Sequencer and an
XPression Gateway.

To add a remote connection point:

1. In the XPression Remote Sequencer, select File > Connection Points. 

The Remote Connection Points window opens. 

Remote Sequencer - Remote Connection Points

2. Select Add.

The Remote Connection Point window opens. 

Remote Sequencer - Add Remote Connection Point

3. In the Connection ID section, in the Name field, enter a name for the connection. 

4. From the Category drop-down, select or enter a category or location to identify the connection point,
e.g., Site 1, Site 2, etc.

5. In the Description field, enter a descriptor for the connection. 

In the Remote Address section, the Connection Type drop-down is automatically populated with the
XPression Gateway.

6. In the Host field, enter the remote host IP address. 

7. In the Port field, enter or select the port number set in the Remote Sequencer configuration area of
the XPression Gateway settings.
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8. Select OK. 

The Remote Connection Point window closes and the new connection point appears in the Remote
Connections list in the Remote Connection Points window. 

9. Select OK. 

The Remote Connection Points window closes. 
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Editing a Remote Connection Point

Use the following procedure to edit a connection point between the XPression Remote Sequencer and
an XPression Gateway.

1. In the XPression Remote Sequencer, select File > Connection Points. 

The Remote Connection Points window opens. 

Remote Sequencer - Remote Connection Points Populated

2. In the Remote Connections Points window, from the Remote Connections list, select a remote
connection point.

3. Select the Edit button. 

The Remote Connection Point window opens. 

Remote Sequencer - Edit Remote Connection Point

4. In the Remote Connection Point window, edit the details as necessary and then select OK.

The Remote Connection Point window closes and the edited connection point appears in the
Remote Connections list in the Remote Connections window. 

5. Select OK to close the Remote Connections window.
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Deleting a Remote Connection Point

Use the following procedure to delete a connection point between the XPression Remote Sequencer and
an XPression Gateway.

To delete a remote connection point:

1. In the XPression Remote Sequencer, select File > Connection Points. 

The Remote Connection Points window opens. 

Remote Sequencer - Remote Connection Points - Populated

2. From the Remote Connections list, select a remote connection point. 

3. Then select the Delete button. 

A Confirmation dialog opens. 

Remote Sequencer - Delete Remote Connection Point Confirmation

4. Select Yes. 

The Confirmation dialog closes and the connection point is deleted from the Remote Connections list
in the Remote Connections window. 

5. Select OK to close the Remote Connections window.
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Selecting a Channel Group

Channel groups are created in the XPression Gateway settings, in the Channel Groups configuration
area. A channel group can be selected once a connection point has been established to an XPression
Gateway with channel groups configured.

This procedure describes how to select a channel group in the XPression Remote Sequencer.

For information on creating channel groups, see Configuring Channel Groups.

1. In the XPression Remote Sequencer toolbar, from the Gateway drop-down, select a connection
point.

2. From the Channel Group drop-down, select a channel group.

The selected channel group opens.

Remote Sequencer - Channel Group

«If you have configured a Lucid Studio Engine in Lucid Studio Integration and added it to a channel

group, a custom Lucid channel window will appear in the Remote Sequencer, after the other channel
windows. Lucid items in the project will only appear in this custom channel window.
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Selecting Active Rundowns

Active rundowns can be opened for playout in the XPression Remote Sequencer.

To select Active Rundowns:

1. In the XPression Remote Sequencer toolbar, select the Browse (...) button beside Activate
Rundowns.

Alternatively, you can press Ctrl + R.

The Select Active Rundowns window opens.

Remote Sequencer - Select Active Rundowns

2. In the Rundown List, select the checkbox of the rundown to open in the remote sequencer.

You can select multiple rundowns.

3. Use the Sort Filter field to enter a rundown or keyword to move the rundown to the top of the
rundown list.
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4. Select OK.

The selected rundown(s) and associated style open in the remote sequencer.

Remote Sequencer - Rundown
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Creating a Manual Rundown

Manual rundowns can be created in the XPression Remote Sequencer that are not linked to a MOS
NRCS.

To create a manual rundown:

1. In the Linear Rundown window of the XPression Remote Sequencer, select Rundowns > Open /
Manage Rundowns.

The Manage Rundowns window opens.

Remote Sequencer - Manage Rundowns

2. Select New Rundown.

The Create Rundown dialog opens.

Remote Sequencer - Create Rundown

Other options include:

· Delete — select to delete a selected rundown.

· Import — select to import a rundown from any selected location.

· Export — select to export a selected rundown to a desired location as a .xprundown or .csv file.

3. In the Rundown Name field, enter a name for the rundown.
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4. Select OK.

The Create Rundown dialog closes and the rundown is added to the list.

Remote Sequencer - New Rundown

5. Select the new rundown and then select Open Rundown.

The rundown opens in the Linear Rundown window and in the Channel columns.

Remote Sequencer - Linear Rundown
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6. Select an item from the Scene Manager or Clip Browser and drag and drop the item into the linear
rundown list or a channel. 

Repeat for as many items as necessary.

The items are added to the rundown or channel.

Remote Sequencer - Linear Rundown - Items Added

7. Right-click on the rundown and select Activate Rundown.

The Select Active Rundowns dialog opens.

Remote Sequencer - Linear Rundown - Activate Rundown
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8. Select the checkbox for the rundown to activate and select OK.

The rundown is activated.

Remote Sequencer - Linear Rundown - Rundown Activated

9. Select Rundowns > Close Inactive Rundowns to close inactive rundowns. 

Only active rundowns will remain visible in the list.
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Channels

The Remote Sequencer can have up to eight channels configured in the XPression Gateway. Channels
are distinguished by number and color. Each channel lists all items that have been assigned to the
respective channel.

«If you have configured a Lucid Studio Engine in Lucid Studio Integration and added it to a channel

group, a custom Lucid channel window will appear in the Remote Sequencer, after the other channel
windows. Lucid items in the project will only appear in this custom channel window.

Remote Sequencer - Channels

The following topics are discussed in this section:

Channel User Interface

Shortcut Menu
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Channel User Interface

Take items in the Channel windows are displayed in black and blue text:

· Black items are from the NRCS and can not be deleted in a Channel list.

· Blue items are added locally and can be deleted in a Channel list. 

Local items can be dragged and dropped into rundowns, including MOS rundowns. However, MOS items
can not be dragged and dropped into other places in rundowns because their order is determined by
the MOS rundown. Items within the Channel list can be rearranged by dragging and dropping within the
Channel list.

«When editing existing items, no further MOS updates for that item will be applied unless the local

changes are reverted by right-clicking on the item and selecting Revert changes to MOS item from the
shortcut menu.

Local modifications can be purged by configuring the purge settings in the Settings section of the
Remote Sequencer panel in the Gateway Settings.

«If you have configured a Lucid Studio Engine in Lucid Studio Integration and added it to a channel

group, a custom Lucid channel window will appear in the Remote Sequencer, after the other channel
windows. Lucid items in the project will only appear in this custom channel window.

The Channel window contains a preview thumbnail of the selected scene in the top-left corner as well
as the following:

Channel displays the channel number and lists the layers, take ID, scene name,
and the text object content for the selected scene.

Take ID use this column to select or enter an identification number for a take
item.

State (read-only) displays the current playout state of a take item.

Scene (read-only) displays the scene or scene group name of a take item. When using
clips, it will list whether the item is a clip or a still. When a clip is played,
it displays a progress bar and a timer that counts down the time
remaining in the clip (XPression Clips Option only).

Thumbnail (read-only) displays a thumbnail of the scene.

Story Num (read-only) displays the MOS story number column from the NRCS.

Name (read-only) displays the name for a take item.

Content (read-only) displays text object content provided to a take item. Content values for
a take item are set in the Template Data tab of the Take Item Inspector
window.

Virtual Channel displays the channel number assigned to the take item. Click inside the
column to open a list of the virtual channels and select a channel to
assign the take item to that channel.

Layer use this column to select or enter the output framebuffer layer to place
a take item.

In Point (read-only) lists the drop frame timecode starting point for the clip.

Out Point (read-only) lists the drop frame timecode ending point for the clip.

Duration (read-only) displays the time duration of a take item.

Description (read-only) displays the number of entries in a particular scene group.
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Right-clicking on the column headers and selecting Columns allows the selection of specific columns for
the list to be hidden or displayed. The columns can also be reordered by dragging individual columns to
another location. 

Selecting Reset To Default will reset the list to the default layout.

Shortcut Menu

Right-click on a take item to access the following shortcut menu:

Cue cues the selected take item.

Take Offline takes the selected take item off-line.

Focus in Linear Sequence sets the focus in the linear rundown on the selected item in the
channel window.

Revert changes to MOS Item reverts a MOS take item to its original settings if changes have
been made.

Layer > Default For Channel uses the take item on the default layer for the channel.

Layer > Default For Template uses the take item on the default layer of the template for the
item.

Copy copies the selected take item.

Paste pastes a copied take item into another channel or the sequence
list in the Linear Rundown window. Pasting a copied take item
from one channel to another will place the take item on the
channel in which it is pasted.

Delete Item removes the selected take item from the channel. The associated
scene or scene group is not deleted. Only manually edited take
items can be deleted; NRCS take items can not be deleted.
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Keyboard / GPI Mapping

Use keyboard and GPI mapping to assign many of the Remote Sequencer functions to keyboard
shortcuts or GPI input triggers. Many of the existing default keyboard shortcuts can also be customized. 

The following topics are discussed in this section:

Creating a Custom Keyboard Map

Assigning a Global Shortcut

Assigning a Local Shortcut

Creating a Custom Smart GPI / RossTalk Map
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Creating a Custom Keyboard Map

To create a custom keyboard map:

1. In the XPression Remote Sequencer, select File > Keyboard / GPI Mapping.

The Keyboard / GPI Mapping window opens. 

Remote Sequencer - Keyboard / GPI Mapping

2. Select the Save Keyboard Mapping ( ) button to create a new custom keyboard mapping. 

The default keyboard map cannot be edited.

The Save Keyboard Mapping dialog opens. 

Remote Sequencer - Keyboard /GPI Mapping - Save Keyboard Mapping

3. In the Save Keyboard Mapping dialog, enter a name for the new custom keyboard mapping and
select OK. 

The added custom keyboard mapping appears in the Current Keyboard Map list and is saved as a
.kbd file.



255 • XPression Remote Sequencer XPression Distributed Workflow User Guide (v12.0)

Assigning a Global Shortcut

Global Shortcuts represent functions that can be assigned to keyboard hotkeys that are active at any
time while the XPression Remote Sequencer is running. 

To assign a global shortcut:

1. In the XPression Remote Sequencer, select File > Keyboard / GPI Mapping.

The Keyboard / GPI Mapping window opens.

Remote Sequencer - Keyboard / GPI Mapping

2. From the Current Keyboard Map drop-down, select a keyboard map or create a custom keyboard
map.

3. From the Available Global Functions list, drag and drop a Group function or click the Add Group (
) button in the toolbar to create a group branch in the Global Shortcuts table. 
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4. From the Available Global Functions list, select a function and drag and drop it into the desired spot
in the Global Shortcuts table to add the function.

OR

Enter a function in the Filter field to search the Available Global Functions list for a specific function. 

Remote Sequencer - Keyboard / GPI Mapping - Drag and Drop
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5. In the Global Shortcuts table, right-click on the function you added and select Assign Shortcut to
assign a custom keyboard control to the selected function. 

Remote Sequencer - Keyboard / GPI Mapping - Assign Shortcut

6. In the Shortcut Details section, do the following: 

· In the Name field, edit the name of the selected item if necessary. 

· Select the Set button beside the Shortcut field and enter a keyboard shortcut to assign to the
selected item by entering the command on the keyboard. 

The assigned keyboard shortcut appears in the Shortcut field and in the row for the selected item
in the Direct Access Shortcut column in the Global Shortcuts table. 

If the assigned keyboard shortcut is already in use by another item, a warning icon ( ) will appear
next to the command in the Direct Access Shortcut column and also next to the command which is
already using the shortcut. 

· Select the Include In Quick Menu checkbox to include the keyboard shortcut in a Quick Menu.

Quick Menus are shortcut menus that appear when a Quick Key for a global shortcut is entered.
The keyboard shortcuts available for the selected global shortcut are listed in the Quick Menu
that appears. This feature only applies to Global Shortcut branches that contain child nodes. 

· In the Quick Key field, enter a letter or number as the Quick Menu command. 
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7. In the Channel Options section located to the right of the Shortcut Details section, configure the
shortcut options (if options are available) of various functions: 

Clear Single Channel Options Framebuffer — use the list to select a framebuffer for
clearing the channel. 

Cue Item Options Select Current Sequence Item to apply the shortcut to the
current focused item in a sequencer, or select Take ID and
enter or select a Take ID number in the field to apply the
shortcut to a specific Take ID. 
Channel — use the list to assign a channel if using current
sequence item.
Move Sequencer Focus to Item — check this box to the set
sequencer focus to the selected Take ID. 

Focus Channel Options Channel — use the list to assign the linear sequence or a
channel to set the focus. 

Next Item Options Channel — use the list to assign the linear sequence or a
channel to the next item. 

Next Story Options Channel — use the list to assign a channel to the next
story. 

Previous Item Options Channel — use the list to assign the linear sequence or a
channel to the previous item. 

Previous Story Options Channel — use the list to assign a channel to the previous
story. 

Swap Channel Options Channel — use the list to assign a channel to swap. 

Take Offline Options Select Current Sequence Item to apply the shortcut to the
current item in a sequence, or select Take ID and enter or
select a Take ID number in the field to apply the shortcut
to a specific Take ID, or select Entire Framebuffer to take
all layers off of a framebuffer and use the list to select the
framebuffer.

Take Options Select Current Sequence Item to apply the shortcut to the
current item in a sequence, or select Take ID and enter or
select a Take ID number in the field to apply the shortcut
to a specific Take ID. 
Channel — use the list to assign a channel if using current
sequence item. 
Move Sequencer Focus to Item — select this box to the set
sequencer focus to the selected Take ID.
Advance Sequence After Take — check this box to advance
to the next Take Item in the sequence after the current or
selected Take Item has finished playing. 

8. Select OK. 
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Assigning a Local Shortcut

Local shortcuts represent keyboard hotkeys that apply to one particular component of XPression
Remote Sequencer, such as the File menu, and are only active when the particular component of
XPression Remote Sequencer has keyboard/mouse focus. 

To assign a local shortcut:

1. In the XPression Remote Sequencer, select File > Keyboard / GPI Mapping.

The Keyboard / GPI Mapping window opens.

Remote Sequencer - Keyboard / GPI Mapping

2. From the Current Keyboard Map drop-down, select a keyboard map or create a custom keyboard
map. 

3. In the Local Shortcuts table, expand the function tree, right-click a function that doesn't have a
shortcut assigned and select Assign Shortcut. 

4. In the Shortcut Details section, do the following: 

· In the Name field, edit the name of the selected item if necessary. 

· Select the Set button beside the Shortcut field and enter a keyboard shortcut to assign to the
selected item by entering the command on the keyboard. 

The assigned keyboard shortcut appears in the Shortcut field and in the row for the selected
function under the Direct Access Shortcut column in the Local Shortcuts table. 

If the assigned keyboard shortcut is already in use by another item, a warning icon ( ) will appear
next to the command in the Direct Access Shortcut column and also next to the command which is
already using the shortcut.

5. Select OK.
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Creating a Custom Smart GPI / RossTalk Map

Use the Hardware Setup dialog box to configure a GPI board for XPression Remote Sequencer. 

To create a custom Smart GPI / RossTalk map:

1. In the XPression Remote Sequencer, select File > Keyboard / GPI Mapping.

The Keyboard / GPI Mapping window opens.

Remote Sequencer - Keyboard / GPI Mapping

2. Create a custom keyboard mapping that includes global shortcuts. 

See Creating a Custom Keyboard Map. 
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3. In the Global Shortcuts tree, right-click on a global shortcut and select Edit GPI Assignment. 

A GPI assignment pairing is added in the GPI column.

The same GPI trigger can be assigned to multiple global functions to execute them in order. 

Remote Sequencer - Keyboard / GPI Mapping - Edit GPI Assignment
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4. From the Unassigned drop-down, select a GPI board. 

Remote Sequencer - Keyboard / GPI Mapping - Select GPI Board

5. In the GPI field, enter or select a GPI input to assign to the selected global shortcut. 

6. If the assigned GPI input is already in use by another item, a warning icon ( ) will appear next to
the GPI details in the GPI column and also next to the command which is already using the shortcut.

7. Select OK. 

«For more information on adding a Smart GPI/RossTalk board, refer to Configuring Smart GPI /

RossTalk.
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Scene Manager

Use the Scene Manager window to view all of the scenes and scene groups contained in a rundown.

If the Scene Manager window is not showing, select Display > Scene Manager.

Show — displays the show that is open in the Scene Manager.

Filter — use this field to search for scenes using words to filter for specific scene names.

Thumbnails — select this tab to view the scenes as a list of thumbnails that display an image of the
scenes.

List — select this tab to view the scenes as a list of scene names.

Use the toolbar to adjust the display of the Scene Manager:

 Expand Categories 
expands all categories in the Scene Manager.

 Collapse Categories 
collapses all categories in the Scene Manager.

 Resize Thumbnails / Resize Items 
resizes the thumbnails or items (depending on the which
display is selected). Use the scroll bar that opens to slide
the bar right to increase the size or left to decrease the
size.

 Refresh Project refreshes the items in the Scene Manager when the
Remote Sequencer provides notification that the project
has been updated in the Project Server.

Show, Category, and Style Selection

Adding Scenes to the Linear Rundown
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Show, Category, and Style Selection

Use the Show, Category, and Style Selection dialog to select a new show, category, or style to open in
the Scene Manager.

To select a new show, category or style:

1. In the Scene Manager, select Browse (...).

The Show, Category, and Style Selection dialog opens.

Remote Sequencer - Scene Manager - Show Category Style Selection

2. Select a show and category from the Show and Category tree.

3. In the Style list, select a style, if one exists.

4. Select OK.

The Show, Category and Style Selection dialog closes and the graphics associated with the
selected style are available for selection in the Thumbnails / List.

Adding Scenes to the Linear Rundown

Scenes can be added to the Linear Rundown from the Scene Manager.

To add a scene to the Linear Rundown:

1. Select a scene in the Scene Manager.

2. Drag and drop the scene onto the sequence in the Linear Rundown window.

The scene is added to the Linear Rundown where it was dropped within the sequence.
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Previews

There are 2 preview windows in the Remote Sequencer, the Next Up Preview window and the Up Next
Preview window. 

This section describes the purpose of these 2 previews.

Next Up Preview

Use the Next Up Preview to view the next scene in each channel in the rundown.

Up Next Preview

Use the Up Next Preview window to view the scene you're editing in the Take Item Inspector.

Remote Sequencer - Up Next Preview

 Play Animation 
plays a preview of the scene.

 Pause Animation 
pauses the preview of the scene when playing.

 Stop Animation 
stops the preview of the scene when playing.

 Move to Preview Frame 
moves the scroll bar to the preview frame of the scene.

 Scroll Bar 
 select and hold the scroll bar and move it forward or backward
along the timeline to view specific parts of the scene.
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Linear Rundown

Use the Linear Rundown window to view and manage the scenes and scene groups to playout from a
sequence, in the order from top to bottom. The sequence is populated by opening rundowns and by
dragging scenes or scene groups from the Scene Manager or clips from the Clip Browser into the
sequence list.

Remote Sequencer - Linear Rundown

Linear Rundown User Interface

Take items in the Linear Rundown window are displayed in black and blue text:

· Black items are from the NRCS and con not be deleted in the Remote Sequencer Linear Rundown.

· Blue items are added locally and can be deleted in the Remote Sequencer Linear Rundown.

Local items can be dragged and dropped into rundowns, including MOS rundowns. However, MOS items
can not be dragged and dropped into other places in rundowns because their order is determined by
the MOS rundown.

«When editing existing items, no further MOS updates for that item will be applied unless the local

changes are reverted by right-clicking on the item and selecting Revert changes to MOS item from the
shortcut menu.

Local modifications can be purged by configuring the purge settings in the Settings section of the
Remote Sequencer panel in the Gateway Settings.
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The Linear Rundown window contains the following interface items:

Take ID use this column to select or enter an identification number for a take
item.

State (read-only) displays the current playout state of a take item.

Scene (read-only) displays the scene or scene group name of a take item. When using
clips, it will list whether the item is a clip or a still. When a clip is played,
it displays a progress bar and a timer that counts down the time
remaining in the clip (XPression Clips Option only).

Thumbnail (read-only) displays a thumbnail of the scene.

Story Num (read-only) displays the MOS story number column from the NRCS.

Name (read-only) displays the name for a take item.

Content (read-only) displays text object content provided to a take item. Content values for
a take item are set in the Template Data tab of the Take Item Inspector
window.

Virtual Channel displays the channel number assigned to the take item. Click inside the
column to open a list of the virtual channels and select a channel to
assign the take item to that channel.

Layer use this column to select or enter the output framebuffer layer to place a
take item.

In Point (read-only) lists the drop frame timecode starting point for the clip.

Out Point (read-only) lists the drop frame timecode ending point for the clip.

Duration (read-only) displays the time duration of a take item.

Description (read-only) displays the number of entries in a particular scene group.

Right-clicking on the column headers and selecting Columns allows the selection of specific columns for
the list to be hidden or displayed. The columns can also be reordered by dragging individual columns to
another location. Selecting Reset To Default will reset the list to the default layout.

«When the Enable Edit button  in the toolbar at the top of the Remote Sequencer interface is

enabled, it will enable framebuffer/layer changes in the linear rundown and template data modifications.
The button is green when enabled and gray when disabled.

Next Up Preview (read-only) — displays a preview list of the upcoming scenes in the sequence list.
Channel and take item info is displayed, as well as a preview thumbnail.
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Shortcut Menu

Right-click on a take item to access the following shortcut menu:

Cue  cues the selected take item(s).

Take Offline  takes the selected take item off-line.

Revert changes to MOS Item  reverts a MOS take item to its original settings if changes have
been made.

Layer > Default For Channel  uses the take item on the default layer for the channel.

Layer > Default For Template  uses the take item on the default layer of the template for the
item.

Copy  copies the selected take item.

Paste  pastes a copied take item into another area of the sequence or
into a Channel window list. Pasting a copied take item into a
different channel than to which it is set will place the take item
on the channel in which it is pasted.

Delete Item  removes the selected take item from the sequence list. The
associated scene or scene group is not deleted.
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Take Item Inspector

Use the Take Inspector Item tab to view and set properties for the take item selected in the Linear
Rundown window. Click the Take Item Inspector tab to open the Take Item Inspector. 

Take Item Tab User Interface

Use this tab to set the properties for a take item. Edits to take items are live/dynamic.

Remote Sequencer - Take Item Inspector - Take Item Tab

Entry

Use this section to enter or change the name of the take item.

Name (read-only) — displays the name of the selected take item.

Target

Use this section to configure the playout settings for the take item.

Framebuffer — use the Framebuffer list to select the default channel used to playout the take item.

Layer — use this list to select the layer of the output framebuffer on which to playout the take item.

MOS

This section lists the MOS details of the take item.

ObjID (read-only) — displays the Object ID.

ItemID (read-only) — displays the Item ID.

StoryID (read-only) — displays the Story ID.



XPression Distributed Workflow User Guide (v12.0) XPression Remote Sequencer • 270

Template Data Tab User Interface

Use this tab to edit published fields.

Remote Sequencer - Take Item Inspector - Template Data Tab

«Selecting a published object in the Up Next Preview window will highlight/select that published

object in the Template Data tab list.

Object List

This table lists the template objects and attributes, and their values.

 Select Previous Object
selects the previous object.

 Select Next Object
selects the next object.

 Expand All Object Nodes
expands all objects.

 Collapse All Object Nodes
collapses all objects.

 Refresh 
refreshes the template data fields using the values from the
XPression Gateway.

Objects lists the template objects. Expand the template objects to view
the attributes.

Values lists the value of the template data associated with the attribute.

Static appears when the selected template contains text or user input
controls. Use this tab to edit text or to select static text items
from previously configured user input controls.
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Image Files

This tab appears when the selected template contains an image.

To select a new image:

1. In the template, select the image object.

2. Then select the Image Files tab opens.

3. Double-click a folder to open it and select an image.

OR

4. Use the File Drop-Down to navigate to the location of an image.

 Browse — select this button to move up a location/folder level.

OpenMAM — select an OpenMAM server from the drop-down to browse images on that server.

Icon Size — use this list to select a display size for the image thumbnails in the list of image files.

Video Files

This tab appears when the selected template contains a video. 

To select a new video:

1. In the template, select the video object.

2. Then select the Video Files tab.

3. Double-click a folder to open it and select a video file to apply as the value of the object attribute. 

If the object had originally been assigned a video file, the properties of that video will be applied to
the newly assigned video.

OR

4. Use the File Drop-Down to select a location/folder of a video.

 Browse — select this button to move up a location/folder level.

OpenMAM — select an OpenMAM server from the drop-down to browse videos on that server.
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Object Properties

When an object is expanded in the Object List, specific properties applicable to the selected object are
available for editing, such as position, scale, etc.

Position Configure the following settings to adjust the position of the object:

X — enter or select the X coordinate for the object location.

Y — enter or select the Y coordinate for the object location.

Z — enter or select the Z coordinate for the object location.

Rotation Configure the following settings to adjust the rotation of the object:

X — enter or select the degrees to rotate an object around the X axis.

Y — enter or select the degrees to rotate an object around the Y axis.

Z —  enter or select the degrees to rotate an object around the Z axis.

Scale Configure the following settings to adjust the rotation of the object:

X — enter or select the scale factor to apply to an object along the X (horizontal)
axis.

Y — enter or select the scale factor to apply to an object along the Y (vertical)
axis.

Z — enter or select the scale factor to apply to an object along the Z (depth)
axis.

XYZ Select this option to equally adjust the Y and Z scale factors when changing the
X scale factor. Changing the Y or Z scale factor does not adjust the X scale
factor.

XY Select this option to equally adjust the Y scale factor when changing the X scale
factor. Changing the Y scale factor does not adjust the X scale factor.

XZ Select this option to equally adjust the Z scale factor when changing the X scale
factor. Changing the Z scale factor does not adjust the X scale factor.

None Select this option to independently change scale factors.

Pivot Configure the following settings to adjust the pivot point of the object:

X — enter or select the X coordinate for the object pivot point.

Y — enter or select the Y coordinate for the object pivot point.

Z — enter or select the Z coordinate for the object pivot point.

Visibility Select this check box to make the object visible in the scene. It is selected by
default.

Texture Position Configure the following settings to adjust the position of the texture applied to
the object:

X — enter or select the X coordinate for the texture location.

Y — enter or select the Y coordinate for the texture location.

Texture Scale Configure the following settings to adjust the scale of the texture applied to the
object:

X — enter or select the scale factor to apply to the texture along the X
(horizontal) axis.

Y — enter or select the scale factor to apply to the texture along the Y (vertical)
axis.
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Clip Browser

Select the Clip Browser tab to open the Clip Browser if it is not already open. Use the Clip Browser to
drag and drop clips into sequences in the Linear Rundown window or onto channels as take items.

Remote Sequencer - Clip Browser

Clip Browser User Interface

The Clip Browser contains a toolbar for searching clips and a list of clips available to use as take items.

Clip Browser Toolbar

Use the toolbar for searching clips.

Quick Find — enter keywords to search for clips listed in the Clip Browser.

 Show/Hide advanced search options — select to show or hide the Advanced Search Options in the
Clip Browser.

 Reset search filter — select to clear the Quick Find field and any entries in the fields of the
Advanced Search Options.
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Advanced Search Options

Use the Advanced Search Options to enter specific criteria for locating a clip.

Name enter the name of a clip to search.

Recall ID enter a recall ID to search.

Source enter a location to search for a clip.

ID Min enter the first clip ID number in a range.

ID Max enter the last clip ID number in a range.

Duration Min enter a minimum duration time to search for a clip that is at least as long as
the value.

Duration Max enter a maximum duration time to search for a clip that is no longer than
the value.

Project from the drop-down, select a project in which to search for a clip.

Added Min use the calendar to select clips that were added on or after the selected
date.

Added Max use the calendar to select clips that were added on or before the selected
date.

Expires Min use the calendar to select clips that expire on or after the selected date.

Expires Max use the calendar to select clips which expire on or before the selected date.

Never Expires select this checkbox to search for a clip with no expiry date set.

Audio Ch Min enter or select the minimum number of embedded audio channels in the clip
to find.

Audio Ch Max enter or select the maximum number of embedded audio channels in the
clip to find.

No Audio select this checkbox to search for a clip with no embedded audio.

Show all sub clips select this checkbox to display all sub clips of a clip in the Clip Browser list
when performing an advanced search.
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Clip List

Drag clips from the list and drop them into the sequence in the Linear Rundown section or to a specific
channel for playout. Multiple clips can be selected and added to the Linear Rundown.

The Clip Browser contains mostly read-only information as follows:

# (read-only) the list number in the Clip Browser list. A "+" indicates that the clip
listing can be expanded to show associated sub clips.

Thumbnail the thumbnail image of the clip or still. Thumbnails can be enlarged
by clicking and dragging the right border of the thumbnail column
title. Review a flip book playout of the clip by hovering the cursor
over the thumbnail. The flip book is rendered over a checkerboard
pattern so that the alpha channel is visible unless the clip is full

frame. Still image thumbnails display an icon  indicating that they
are still images and not clips.

Name (read-only) the name of the clip.

In Point (read-only) the drop frame timecode starting point for the clip.

Out Point (read-only) the drop frame timecode ending point for the clip.

Length (read-only) the drop frame timecode duration of the clip.

Format (read-only) the formatting used for the clip.

Flags (read-only) if using clips that have been transcoded by the XPression INcoder
that include tags in the filename, this column lists the tags that
have been parsed from the filename of the clip. The possible flags
include:

· LE — indicates that looping has been enabled.

· HF — indicates that the clip will hold the last frame.

Audio Ch (read-only) the number of audio channels embedded in the clip.

Bit Depth (read-only) the quality of the signal quantization for the clip.

Recall ID (read-only) the ID number for the clip when it is recalled.

Project (read-only) the name of the project to which the clip has been added.

Added (read-only) the date the clip was added to the project.

Expires (read-only) the expiry date for the clip, if applicable.

Codec (read-only) the codec format of the clip.

File Ext (read-only) the file type of the clip.

File Size (read-only) the file size of the clip.

Alpha a thumbnail image of the clip with the alpha channel visible.

First Frame TC the timecode for the first frame of the clip.
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Controlling Sequence Playout

Multiple take item groups can be played out using the XPression Remote Sequencer. Items can be
played out using the Linear Rundown or the Channel windows.

«The take items of the take item groups opened in the Remote Sequencer are numbered according to

their order in the Remote Sequencer and not the Sequencer tab in XPression.

To control sequence playout using the linear rundown:

1. Open a Connection Group.

«The take items of the take item groups opened in the Remote Sequencer are numbered according

to their order in the Remote Sequencer and not the Sequencer in XPression.

2. In the Linear Rundown window, select the take item group that contains the take items to playout.

3. Double-click a take item to play out the selected take item.

The selected take item plays out through the default output, and the State changes to online for
take items or Active for take item groups.

 In the Scene column, clip take items will also display a playback progress bar with a counter
showing the time remaining.

4. On the keyboard, press Number Pad - to stop the playout of an online take item or Active take item
group.

To control sequence playout using channel windows:

1. Open a Connection Group.

«The take items of the take item groups opened in the Remote Sequencer are numbered according

to their order in the Remote Sequencer and not the Sequencer in XPression.

2. In a Channel window, select the take item group that contains the take items to play out.

3. Double-click a take item to play out the selected take item.

The selected take item plays out through the default output, and the State changes to online for
take items or Active for take item groups. In the Scene column, clip take items will also display a
playback progress bar with a counter showing the time remaining.

4. On the keyboard, press Number Pad - to stop the playout of an online take item or Active take item
group.
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Keyboard Control

The keyboard number pad can also be used to control the playout of a sequence in the Linear
Rundown window. 

The following keyboard shortcuts are available in the Remote Sequencer:

Cursor Up Arrow selects the previous take item in the sequence.

Cursor Down Arrow selects the next take item in the sequence.

Ctrl-Home selects the first take item in the sequence.

Ctrl-End selects the last take item in the sequence.

Number Pad + plays out the selected take item and select the next take item in the
sequence.

Number Pad - takes a take item or Active take item group offline.

Number Pad Enter plays out the selected take item. This shortcut requires the Fast Recall
feature to be enabled.

Number Pad +/- increases (+) or decreases (-) the speed of a roll/crawl while it is online.

Number Pad . cues a take item in the sequence.
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XPression Remote Sequencer (Legacy)
The XPression Remote Sequencer is used to control remote XPression engines and playout graphics and
clips from a MOS rundown.

Before you start using the XPression Remote Sequencer, the remote sequencer needs to be setup. This
section describes how to configure the remote sequencer preferences, reset the layout, configure
connection points and groups, select rundowns, and control sequence playout.

The following topics are discussed in this section:

Configuring Smart GPI / RossTalk

Setting Preferences

Resetting the Layout

Adding a Remote Connection Point

Editing a Remote Connection Point

Deleting a Remote Connection Point

Selecting a Channel Group

Selecting Active Rundowns

Controlling Sequence Playout
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Configuring Smart GPI / RossTalk

Use the following procedure to configure the Smart GPI / RossTalk Settings for the XPression Remote
Sequencer.

To configure Smart GPI / RossTalk:

1. In the XPression Remote Sequencer, select File > Hardware Setup. 

The Hardware Setup window opens. 

Remote Sequencer (Legacy) - Hardware Setup

2. In the GPI Boards tab, select Add.

The Add New GPI Board dialog opens.

Remote Sequencer (Legacy) - Add New GPI Board

3. From the Brand drop-down, select the Smart GPI / RossTalk board.

4. Select OK.

The Smart GPI / RossTalk Setup window opens.

Remote Sequencer (Legacy) - Smart GPI / Ross Setup
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5. In the Settings section, from the State drop-down, select Enabled. 

Select Disabled to turn off Smart GPI/RossTalk.

6. Select a Mode for Smart GPI/RossTalk:

Serial RS232 — select to use RS232 to send Smart GPI/RossTalk signals to XPression Remote
Sequencer. 

TCP — select to use TCP/IP to send Smart GPI/RossTalk signals to XPression Remote Sequencer. 

UDP — select to use UDP sockets to send Smart GPI/RossTalk signals to XPression Remote
Sequencer. 

7. Configure the selected GPI mode.

8. Select OK.

9. Select Close.

Serial RS232

1. In the RS232 GPI Settings panel, from the Port drop-down, select the Communication port that
receives GPI signals.

2. From the Baudrate drop-down, select the communication speed for GPI signals.

3. From the Data Bits drop-down, select the number of bits used to represent one character of data for
GPI signals.

4. From the Parity drop-down, select the method used to check for lost data in a GPI signal.

5. From the Stop Bits drop-down, select the number of bits used to indicate the end of a byte in a GPI
signal.

6. From the Flow Control drop-down, select the data transmission rate controller for a GPI signal.

«When using Smart GPI/RossTalk, the flow control can be set to Hardware or None, but it must be

set the same in both XPression and the transmitting device.

TCP

1. In the Incoming Network Settings section, in the TCP Port field, enter or select the communication
port that receives GPI signals from an external source.

2. In the Outgoing Network Settings section, in the Hostname field, enter the host name of a remote
device that is to receive RossTalk messages from the local XPression engine.

3. In the TCP Port field, enter or select the communication port that receives the signals. 

UDP

· In the Incoming Network Settings box, in the UDP Port field, enter or select the communication port
that receives GPI signals from an external source. 

For more information on configuring and working with GPIs, refer to the GPI White Paper available from
Ross Video.
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Setting Preferences

Use the following procedure to configure the General settings and Channel Colors for the XPression
Remote Sequencer.

To access the Preference settings:

· In the XPression Remote Sequencer, select File > Preferences.

The Preferences window opens on the General panel.

Remote Sequencer (Legacy) - Preferences - General Panel

To configure the General settings for the XPression Remote Sequencer:

1. In the Sequencer section, select the Loop On End checkbox to loop the cursor to the start of a
rundown when it has reached the end. 

2. Select the Show Story Number Column (ENPS) checkbox to add a column with the story number of
the rundown (ENPS only). 

3. Select the Center online item in view checkbox to center the online take item in the view of the
rundown. 

4. Select the Group items into stories checkbox to group items in the rundown into their individual
stories.

5. Select the Advance focus after taking item offline (with minus key) to advance the focus to the
next take item after taking a take item offline using the minus (-) key. 
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To configure the Channel Colors for the XPression Remote Sequencer:

1. Click the Channel Colors panel to configure channel colors for the XPression Remote Sequencer.

Remote Sequencer (Legacy) - Preferences - Channel Colors

2. In the Channel Colors section, select the Use Channel Colors checkbox to colorize Next Up Preview
thumbnails, Linear Rundown Take IDs, Virtual Channel columns, and Channel Take Item lists. 

OR

Click inside the Color column of a Ch # to open the Color Editor to configure a color for the channel:

Remote Sequencer (Legacy) - Preferences - Color Editor

· Use the Basic Colors section to select a preexisting color from the list and select OK.

· Use the Custom Colors section to select a color from the list of custom-created colors.



283 • XPression Remote Sequencer (Legacy) XPression Distributed Workflow User Guide (v12.0)

· Select Define Custom Colors to open a color spectrum to configure a specific color:

Remote Sequencer (Legacy) - Preferences - Custom Colors

· Configure the color mode for the custom color as HSL, RGB, or using the Hex Color field.

· Once a custom color has been created, select Add to Custom Colors to add the color to the
Custom Colors list and select OK.

3. Select Default to use the default channel colors. 

4. Select OK. 

The Preferences window closes.
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Resetting the Layout

In the XPression Remote Sequencer, you can reset the layout to the default layout if necessary. 

To reset the layout:

1. From the Docking menu, select Reset Layout.

A Confirmation dialog opens.

Remote Sequencer (Legacy) - Resetting Docking Layout Confirmation

2. Select Yes.

The Confirmation dialog closes and the XPression Remote Sequencer layout is reset.
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Adding a Remote Connection Point

A connection point is a link between the XPression Remote Sequencer and the XPression Gateway. Use
the following procedure to add a connection point between the XPression Remote Sequencer and an
XPression Gateway.

To add a remote connection point:

1. In the XPression Remote Sequencer, select File > Connection Points. 

The Remote Connection Points window opens. 

Remote Sequencer (Legacy) - Remote Connection Points

2. Select the Add button to add a remote connection point. 

The Remote Connection Point window opens. 

Remote Sequencer (Legacy) - Add Remote Connection Point

3. In the Connection ID section, in the Name field enter a name for the connection. 

4. From the Category drop-down, select or enter a category or location to identify the connection point.
For example Site 1, Site 2, etc.

5. In the Description field, enter a descriptor for the connection. 

In the Remote Address section, the Connection Type field is automatically populated with the
XPression Gateway.

6. In the Host field, enter the remote host IP address. 

7. In the Port field, enter or select the port number set in the Remote Sequencer configuration area of
the XPression Gateway settings.
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8. Select OK. 

The Remote Connection Point window closes and the new connection point appears in the Remote
Connections list in the Remote Connection Points window. 

9. Select OK. 

The Remote Connection Points window closes. 
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Editing a Remote Connection Point

Use the following procedure to edit a connection point between the XPression Remote Sequencer and
an XPression Gateway.

1. In the XPression Remote Sequencer, select File > Connection Points. 

The Remote Connection Points window opens. 

Remote Sequencer (Legacy) - Remote Connection Points Populated

2. In the Remote Connections Points window, from the Remote Connections list, select a remote
connection point.

3. Select the Edit button. 

The Remote Connection Point window opens. 

Remote Sequencer - Edit Remote Connection Point

4. In the Remote Connection Point window, edit the details as necessary and then select OK.

The Remote Connection Point window closes and the edited connection point appears in the
Remote Connections list in the Remote Connections window. 

5. Select OK to close the Remote Connections window.
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Deleting a Remote Connection Point

Use the following procedure to delete a connection point between the XPression Remote Sequencer and
an XPression Gateway.

To delete a remote connection point:

1. In the XPression Remote Sequencer, select File > Connection Points. 

The Remote Connection Points window opens. 

Remote Sequencer (Legacy) - Remote Connection Points - Populated

2. From the Remote Connections list, select a remote connection point. 

3. Then select the Delete button. 

A Confirmation dialog opens. 

Remote Sequencer - Delete Remote Connection Point Confirmation

4. Select Yes. 

The Confirmation dialog closes and the connection point is deleted from the Remote Connections list
in the Remote Connections window. 

5. Select OK to close the Remote Connections window.
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Selecting a Channel Group

Channel groups are created in the XPression Gateway settings, in the Channel Groups configuration
area. A channel group can be selected once a connection point has been established to an XPression
Gateway with channel groups configured.

This procedure describes how to select a channel group in the XPression Remote Sequencer.

For information on creating channel groups, see Configuring Channel Groups.

1. In the XPression Remote Sequencer toolbar, from the Gateway drop-down, select a connection
point.

2. From the Channel Group drop-down, select a channel group.

The selected channel group opens.

Remote Sequencer - Channel Group
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Selecting Active Rundowns

Active rundowns can be selected for playout in the XPression Remote Sequencer.

1. In the XPression Remote Sequencer toolbar, select the Browse (...) button beside Activate
Rundowns.

The Select Active Rundowns window opens.

Remote Sequencer (Legacy) - Select Active Rundowns

2. In the Rundown List, select the checkbox of the rundown to open in the remote sequencer.

You can select multiple rundowns.

3. Use the Sort Filter field to enter a rundown or keyword to move the rundown to the top of the
rundown list.

4. Select OK.

The selected rundown(s) and associated style open in the remote sequencer.

Remote Sequencer (Legacy) - Rundown
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Controlling Sequence Playout

Multiple take item groups can be played out using the XPression Remote Sequencer.

To play a sequence:

1. Open a Connection Group.

«The take items of the take item groups opened in the Remote Sequencer are numbered according

to their order in the Remote Sequencer and not the Sequencer in XPression.

2. Select the take item group that contains the take items to play out.

3. In the Sequencer, double-click a take item to play out the selected take item.

The selected take item plays out through the default output and the State changes to online for take
items or Active for take item groups. In the Scene column, clip take items will also display a playback
progress bar with a counter showing the time remaining.

4. On the keyboard, press Number Pad - to stop the playout of an online take item or Active take item
group.

Keyboard Control

The keyboard number pad can also be used to control the playout of a sequence in the Linear
Rundown window. 

The following keyboard shortcuts are available in the Remote Sequencer:

Cursor Up Arrow selects the previous take item in the sequence.

Cursor Down Arrow selects the next take item in the sequence.

Ctrl-Home selects the first take item in the sequence.

Ctrl-End selects the last take item in the sequence.

Number Pad + plays out the selected take item and select the next take item in the
sequence.

Number Pad - takes a take item or Active take item group offline.

Number Pad Enter plays out the selected take item. This shortcut requires the Fast Recall
feature to be enabled.

Number Pad +/- increases (+) or decreases (-) the speed of a roll/crawl while it is online.

Number Pad . cues a take item in the sequence.



Contact Us

Contact our friendly and professional support representatives for the following:

· Name and address of your local dealer

· Product information and pricing

· Technical support

· Upcoming trade show information

Technical
Support

Telephone: +1-844-652-0645 (North America)

+800 3540 3545 (International)

After Hours Emergency: +1 613 • 349 • 0006

Email: techsupport@rossvideo.com

General
Information

Telephone: +1 613 • 652 • 4886

Fax: +1 613 • 652 • 4425

Email: solutions@rossvideo.com

Website: http://www.rossvideo.com

Visit Us

Visit our website for:

· Company information and news

· Related products and full product lines

· Online catalog

· Testimonials
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