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Thank You for Choosing Ross

You've made a great choice. We expect you will be very happy with your purchase of Ross
Technology.

Our mission is to:
1. Provide a Superior Customer Experience

o offer the best product quality and support
2. Make Cool Practical Technology

e develop great products that customers love

Ross has become well known for the Ross Video Code of Ethics. It guides our interactions and
empowers our employees. I hope you enjoy reading it below.

If anything at all with your Ross experience does not live up to your expectations be sure to reach
out to us at solutions@rossvideo.com.

'DJ\ 2\!5

David Ross
CEO, Ross Video

dross@rossvideo.com

Ross Video Code of Ethics

Any company is the sum total of the people that make things happen. At Ross, our employees are
a special group. Our employees truly care about doing a great job and delivering a high quality
customer experience every day. This code of ethics hangs on the wall of all Ross Video locations
to guide our behavior:

1. We will always act in our customers’ best interest.

2. We will do our best to understand our customers’ requirements.

3. We will not ship crap.

4. We will be great to work with.

5. We will do something extra for our customers, as an apology, when something big goes wrong
and it's our fault.

6. We will keep our promises.

7. We will treat the competition with respect.

8. We will cooperate with and help other friendly companies.

9. We will go above and beyond in times of crisis. If there's no one to authorize the required

action in times of company or customer crisis - do what you know in your heart is right. (You
may rent helicopters if necessary.)
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Copyright

©2024 Ross Video Limited, Ross®, and any related marks are trademarks or registered trademarks of
Ross Video Limited. All other trademarks are the property of their respective companies. PATENTS
ISSUED and PENDING. All rights reserved. No part of this publication may be reproduced, stored in a
retrieval system, or transmitted in any form or by any means, mechanical, photocopying, recording or
otherwise, without the prior written permission of Ross Video. While every precaution has been taken in
the preparation of this document, Ross Video assumes no responsibility for errors or omissions. Neither
is any liability assumed for damages resulting from the use of the information contained herein.

Patents

Patent numbers US 7,034,886; US 7,508,455; US 7,602,446; US 7,802,802 B2; US 7,834,886; US
7,914,332; US 8,307,284; US 8,407,374 B2; US 8,499,019 B2; US 8,519,949 B2; US 8,743,292 B2; GB
2,419,119 B; GB 2,447,380 B; and other patents pending.

Notice

The material in this manual is furnished for informational use only. It is subject to change without notice
and should not be construed as commitment by Ross Video Limited. Ross Video Limited assumes no
responsibility or liability for errors or inaccuracies that may appear in this manual.



End User Software License Agreement

This End User Software License Agreement is a legal agreement between you (the “Licensee”) and
Ross Video Limited ("Ross Video"”) specifying the terms and conditions of your installation and use of the
Software and all Documentation (as those terms are defined herein).

IMPORTANT:

BY DOWNLOADING, ACCESSING, INSTALLING OR USING THE SOFTWARE AND/OR
DOCUMENTATION AND/OR BY AUTHORIZING ANY THIRD PARTY, INCLUDING WITHOUT
LIMITATION AN INSTALLER OR COMMISSIONER ACTING ON YOUR BEHALF TO DO SO, LICENSEE
AGREES TO THE TERMS OF THIS AGREEMENT AND THE LICENSE GRANTED HEREUNDER SHALL BE
EFFECTIVE AS OF AND FROM SUCH DATE. IF YOU DO NOT WISH TO ACCEPT THE TERMS AND
CONDITIONS OF THIS AGREEMENT, DO NOT DOWNLOAD, ACCESS, INSTALL, REFER TO OR
OTHERWISE USE THE SOFTWARE AND/OR DOCUMENTATION.

1. INTERPRETATION. In this Agreement, (a) words signifying the singular number include the plural
and vice versa, and words signifying gender include all genders; (b) every use of the words
"herein", "hereof", “hereto” "hereunder" and similar words shall be construed to refer to this
Agreement in its entirety and not to any particular provision hereof; (c) reference to any agreement
or other document herein will be construed as referring to such agreement or other document as
from time to time amended, modified or supplemented (subject to any restrictions on such
amendment, modification or supplement set forth therein); (d) every use of the words “including” or
“includes” is to be construed as meaning “including, without limitation” or “includes, without
limitation”, respectively; and (e) references to an Article or a Section are to be construed as
references to an Article or Section of or to this Agreement unless otherwise specified.

2. DEFINITIONS. In this Agreement, in addition to the terms defined elsewhere in this Agreement,
the following terms have the meanings set out below:

“Affiliate” means, with respect to any Person, any other Person who directly or indirectly controls,
is controlled by, or is under direct or indirect common control with, such Person. A Person shall be
deemed to control a Person if such Person possesses, directly or indirectly, the power to direct or
cause the direction of the management and policies of such Person, whether through the
ownership of voting securities, by contract or otherwise; and the term “controlled” and “controlling”
shall have a similar meaning.

“Agreement” means this End User Software License Agreement including the recitals hereto, as the
same may be amended from time to time in accordance with the provisions hereof.

“"Backup System” means the secondary piece of Designated Equipment upon which the Software is
installed and mirrored for the sole purpose of replacing a Primary System in the event such Primary
System is not available or functioning properly for any reason.

“Change of Control” means (a) the direct or indirect sale, transfer or exchange by the shareholders
of a Party of more than fifty percent (50%) of the voting securities of such Party, (b) a merger or
amalgamation or reorganization or other transaction to which a Party is party after which the
shareholders of such Party immediately prior to such transaction hold less than fifty percent (50%)
of the voting securities of the surviving entity, (c) the sale, exchange, or transfer of all or
substantially all of the assets of a Party.



“Confidential Information” means all data and information relating to the business and
management of either Party, including the Software, trade secrets and other technology to which
access is obtained or granted hereunder by the other Party, and any materials provided by Ross
Video to Licensee; provided, however, that Confidential Information shall not include any data or
information which:

(i) is or becomes publicly available through no fault of the other Party;
(ii) is already in the rightful possession of the other Party prior to its receipt from the other Party;

(iii) is already known to the receiving Party at the time of its disclosure to the receiving Party by the
disclosing Party and is not the subject of an obligation of confidence of any kind;

(iv) is independently developed by the other Party;
(v) is rightfully obtained by the other Party from a third party; or
(vi) is disclosed with the written consent of the Party whose information it is.

“Designated Equipment” shall mean (a) the hardware products sold by Ross Video to Licensee on
which the Software is installed and licensed for use, as the same may be replaced from time to time
by Ross Video; or (b) in the case of Software licensed on a stand-alone basis, the equipment of
Licensee on which the Software is to be installed and meets the minimum specifications set out in
the Documentation.

“Documentation” shall mean manuals, instruction guides, user documentation and other related
materials of any kind pertaining to the Software (whether in electronic, hard-copy or other media
format) that are furnished to Licensee by or on behalf of Ross Video in relation to the Software.

“Freeware” means Software that is available free of charge from Ross Video, and includes, without
limitation the master control system software known as "DashBoard".

"Governmental Authority” means (a) any federal, provincial, state, local, municipal, regional,
territorial, aboriginal, or other government, governmental or public department, branch, ministry, or
court, domestic or foreign, including any district, agency, commission, board, arbitration panel or
authority and any subdivision of any of them exercising or entitled to exercise any administrative,
executive, judicial, ministerial, prerogative, legislative, regulatory, or taxing authority or power of
any nature; and (b) any quasi-governmental or private body exercising any regulatory,
expropriation or taxing authority under or for the account of any of them, and any subdivision of
any of them.

“Improvements” means all inventions, works, discoveries, improvements and innovations of or in
connection with the Software, including error corrections, bug fixes, patches and other updates in
Object Code form to the extent made available to Licensee in accordance with Ross Video’s release
schedule.

"License Fee" means the fee(s), if any, payable in respect of the Software in accordance with the
relevant invoice(s) or other purchase documents delivered in connection with this Agreement.

“License Period” means the period of time that Licensee will have the rights granted under this
Agreement, as may be specified in an Order.

“Madifications” means any enhancements, changes, corrections, translations, adaptations,
revisions, developments, upgrades or updates thereto; and “Modify” shall mean the creation of any
of the foregoing.

“Object Code” means the machine readable executable form of a computer software program.



"Open Source Components" means third party Open Source software, libraries or other
components.

"Open Source License" means the license that governs each Open Source Component.

"Order" means the documents provided by Ross Video to Licensee detailing the Ross Video
products contemplated for purchase, the corresponding fees and License Period that may apply to
the Software, including any and all quotations, purchase orders, acknowledgments, pro formas,
invoices and other purchase documentation.

“Parties” means both Ross Video and Licensee and “Party” means either one of them as the
context requires.

“Person” will be broadly interpreted and includes (a) a natural person, whether acting in his or her
own capacity, or in his or her capacity as executor, administrator, estate trustee, trustee or
personal or legal representative; (b) a corporation or a company of any kind, a partnership of any
kind, a sole proprietorship, a trust, a joint venture, an association, an unincorporated association,
an unincorporated syndicate, an unincorporated organization or any other association, organization
or entity of any kind; and (c) a Governmental Authority.

“Primary System” means the Designated Equipment upon which the Software is installed and
executed to deliver its intended functionality.

“Released Claims” has the meaning ascribed to it in Section 9(b).
“Released Parties” has the meaning ascribed to it in Section 9(b).
“Ross Video” means Ross Video Limited and its Affiliates.

“Software” means the version of the Object Code licensed and delivered to Licensee by Ross Video
concurrently with delivery of this Agreement, including without limitation the Freeware, and any
subsequent error corrections, updates, Modifications or Improvements provided to Licensee by Ross
Video pursuant to this Agreement, but specifically excluding any features or plug-ins that may be
purchased by you directly from third parties as upgrades or enhancements to the Software.

“Source Code” means the human readable form of a computer software program, and all tools and
documentation necessary for a reasonably competent computer programmer to understand,
maintain and Modify the Software.

“Third Party Software” means those portions of the Software, if any, which are owned or
controlled by third parties and licensed to Ross Video pursuant to certain license agreements or
arrangements with such third parties, including the Open Source Components and NDI®! software
(http://NDl.video); and

“Use” means to execute, run, display, store, merge, network, Modify, translate, host or integrate
with Licensee’s products or other third party software.

L NDI® is a registered trademark of Vizrt NDI AB.


http://NDI.video

LICENSE. Subject to the terms and conditions of this Agreement, upon payment of the applicable
License Fee by Licensee, or, in the case of Freeware only, upon download of the Software by
Licensee onto its Designated Equipment, Ross Video hereby grants to Licensee a non-transferable
and non-exclusive right to Use the Software and Documentation solely for the internal use of
Licensee (the “License”), during the License Period. In the event that a License Period is not
identified on the Order, such License Period shall be deemed to be perpetual, subject to paragraph
10 (c) of this Agreement. The Software shall only be used in connection with or installed on the
Designated Equipment and, where applicable, shall only be used on the Primary System, provided
such Primary System is operating properly."

If the Primary System is not operating properly for any reason, the Software may be used on the
designated Backup System for that Primary System until such time that the Primary System begins
operating properly. The Software and Documentation are provided to Licensee for the exclusive use
by Licensee’s organization for its ordinary business purposes and shall not be used by any third
party for any purposes. Licensee may make copies of the Software as required for internal backup
and archival purposes. To the extent permitted hereunder, Licensee may distribute copies of the
Software and/or Documentation to members of its organization, provided (a) this Agreement is
included with each copy, (b) any member of its organization who uses the Software and/or
Documentation accepts and agrees to be bound by the terms of this Agreement and by any other
license agreements or other agreement incorporated by reference into this Agreement, and (c)
Licensee has paid any applicable additional License Fees in respect of copying and redistributing of
the Software. To the extent Licensee is permitted to make copies of the Software under this
Agreement, Licensee agrees to reproduce and include on any copy made or portion merged into
another work, all Ross Video proprietary notices, including any notices with respect to copyrights,
trademarks and this License. With the exception of copying the Software for backup or archival
purposes, Licensee agrees to keep a record of the number and location of all such copies and will
make such record available at Ross Video’s request. The Software may include mechanisms to limit
or inhibit copying.

LICENSE RESTRICTIONS. Except as otherwise provided in section 3 above, Licensee shall not: (1)
copy any Software or Documentation, or part thereof, which is provided to Licensee by Ross Video
pursuant to this Agreement, in Object Code form, Source Code form or other human or machine
readable form, including written or printed documents, without the prior written consent of Ross
Video; (2) in any way market, distribute, export, translate, transmit, merge, Modify, transfer, adapt,
loan, rent, lease, assign, share, sub-license, sell, make available for download on any website or
make available to another Person, the Software and/or Documentation, in whole or in part,
provided that Licensee shall not be prohibited from renting or leasing the Software if Ross Video
has consented, in writing, to Licensee engaging in such activities in respect of the Software; (3)
reverse engineer, decompile or disassemble the Software or electronically transfer it into another
computer language; or (4) use the Software or Documentation in a manner that is inconsistent with
the License granted hereunder or that will result in a breach of this Agreement. Licensee agrees to
take all reasonable precautions to prevent third parties from using the Software and/or
Documentation in any way that would constitute a breach of this Agreement, including such
precautions Licensee would ordinarily take to protect its own proprietary software, hardware or
information.

DELIVERY. Ross Video shall deliver to Licensee one (1) master copy of the Software in compiled
binary (executable) form suitable for reproduction in electronic files only and Ross Video shall deliver
to Licensee a minimum of one copy of the Documentation.

IMPROVEMENTS. Licensee may from time to time request Ross Video to incorporate certain
Improvements into the Software. Ross Video may, in its sole discretion, undertake to incorporate
and provide such Improvements to Licensee with or without payment of a fee to be negotiated at
the time of such request. All Improvements, whether recommended and developed by Ross Video
or Licensee, shall be considered the sole property of Ross Video and shall be used by Licensee
pursuant to the terms of the License granted under this Agreement.



FREEWARE. Other than the obligation to pay a License Fee, which does not apply to the Freeware,
all other provisions of this End User Software License Agreement apply to the Freeware in the same
way as they apply to all other Software that is the subject of this Agreement. In addition, in
connection with the Freeware, the following provisions apply:

a. Licensee will not Use the Freeware to engage in or allow others to engage in any illegal activity.

b. Licensee will not Use the Freeware in any way that will interfere with or damage the operation
of the services of any third parties by overburdening/disabling network resources through
automated queries, excessive usage or similar conduct.

c. Licensee will not Use the Freeware to engage in any activity that will violate the rights of others,
including, without limitation, by using it for operations that involve child labour, suppressing the
right of freedom of expression or endangering the security of person.

OWNERSHIP. The Parties acknowledge and agree that, as between the Parties, Ross Video shall
be the owner of all intellectual property rights in the Software, Documentation and all related
Modifications and Improvements, written materials, logos, trademarks, trade names, copyright,
patents, trade secrets and moral rights, registered or unregistered. No proprietary interest or title
in or to the intellectual property in the Software, Documentation or any Improvements or
Modifications is transferred to Licensee by this Agreement. Ross Video reserves all rights not
expressly licensed to Licensee under section 3.

OPEN SOURCE SOFTWARE.

a. Software may use and/or be provided with Open Source Components, including those detailed in
the Third Party section below. To the extent stipulated by its Open Source License, each such
Open Source Component is licensed directly to Licensee from its respective licensors and not
sub-licensed to Licensee by Ross Video, and such Open Source Component is subject to its
respective Open Source License, and not to this Agreement. If, and to the extent, an Open
Source Component requires that this Agreement effectively impose, or incorporate by reference,
certain disclaimers, permissions, provisions, prohibitions or restrictions, then such disclaimers,
permissions, provisions, prohibitions or restrictions shall be deemed to be imposed, or
incorporated by reference into this Agreement, as required, and shall supersede any conflicting
provision of this Agreement, solely with respect to the corresponding Open Source Component
which is governed by such Open Source License.

b. If Licensee, or another party on Licensee’s behalf, modifies, replaces or substitutes any Open
Source Component used in or provided with this Software, Licensee hereby fully, forever,
irrevocably and unconditionally releases and discharges Ross Video, its Affiliates and its and
their employees, officers, directors, resellers, distributors and representatives (collectively,
“Released Parties”) from any and all claims, charges, complaints, demands, actions, causes of
action, suits, rights, debts, covenants, liabilities, warranties, performance and maintenance and
support obligations (collectively, "Released Claims”), of every kind and nature, with respect to
such Software, including without limitation any such Released Claims that arise as a matter of
applicable Law.

c. Ifan Open Source License requires that the source code of its corresponding Open Source
Component be made available to Licensee, and such source code was not delivered to Licensee
with the Software, then Ross Video hereby extends a written offer, valid for the period
prescribed in such Open Source License, to obtain a copy of the source code of the
corresponding Open Source Component, from Ross Video from
https://www.rossvideo.com/open-source-information/.


https://www.rossvideo.com/open-source-information/

10. THIRD PARTY SOFTWARE.

a. Licensee acknowledges that the Third Party Software is not owned by Ross Video.
Notwithstanding any other provision of this Agreement, Ross Video, to the extent permitted by
applicable law, offers no warranties (whether express, implied, statutory or by course of
communication or dealing with Licensee, or otherwise) with respect to the Third Party Software.
Ross Video may pass through to Licensee, if and to the extent permitted by applicable law, any
warranties expressly provided by such third parties to Ross Video for such Third Party Software.

b. FFmpeg Notice. The Software may utilize FFmpeg video components and their included libraries.
FFmpeg is a trademark of Fabrice Bellard (originator of the FFmpeg project). Ross Video disclaims
any ownership claim to FFmpeg. Please refer to http://ffmpeg.org (copyright is in the FFmpeg
developers). FFmpeg is licensed under the GNU Lesser General Public License v2.1 or Lesser
General Public License v3.0. GNU Lesser General Public License contact information: Free
Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA. Licensee
can distribute it and/or modify it under the terms of such licenses.

11. INTELLECTUAL PROPERTY INDEMNITY.

a. Ross Video agrees to defend, indemnify and hold harmless Licensee from final damages
awarded by a court of competent jurisdiction (hereinafter referred to as the “"Losses”), which
Licensee, or any of its officers or directors, may incur, suffer or become liable for as a result of, or
in connection with, any third party claim asserted against Licensee to the extent such claim is
based on a contention that the Software, Documentation or any portion thereof, infringes any
valid, registered, enforceable patents, copyrights, trade secrets, trademarks or other intellectual
property rights of any third party, provided that (a) the allegedly infringing Software or
Documentation has been used within the scope of and in accordance with the terms of this
Agreement, and (b) Licensee notifies Ross Video in writing of such claim within ten (10) days of a
responsible officer of Licensee becoming aware of such claim. If the Software, Documentation or
any portion thereof is held to constitute an infringement of a third party’s intellectual property
rights, and use thereof is enjoined, Ross Video shall, at its election and expense, either (i)
procure the right to use the infringing element of the Software or Documentation; or (ii) replace
or modify the element of the Software or Documentation so that the infringing portion is no
longer infringing and still performs the same function without any material loss of functionality.
Ross Video shall make every reasonable effort to correct the situation with minimal effect upon
the operations of Licensee.

b. Notwithstanding the above, Ross Video reserves the right to terminate this Agreement and the
License granted hereunder on immediate notice to Licensee, and without liability to Licensee, in
the event that the Software or Documentation constitutes or may, in Ross Video’s determination,
constitute, an infringement of the rights of a third party that Ross Video, in its sole discretion,
does not consider to be affordably remediable.

c. Either party may terminate this Agreement immediately should any Software become, or in either
party's opinion be likely to become, the subject of a claim of infringement of any intellectual
property right and, in such event, there shall be no claim by either Licensee or Ross Video
against the other arising out of such termination, provided that the foregoing shall not apply to
a claim for infringement by Ross Video against Licensee in the event that Licensee is alleged to
have infringed Ross Video's intellectual property rights, in which case Licensee shall remain liable
for all outstanding License Fees and other amounts owing to Ross Video.

d. Notwithstanding the foregoing, Ross Video shall have no liability for any claim of infringement
based on use of other than a current, unaltered release of the Software and/or Documentation
available from Ross Video if such infringement would have been avoided by the use of a current,
unaltered release of the Software and/or Documentation provided that such current, unaltered
release performs substantially in conformity with the specifications set out in the Documentation
and was provided, at no additional cost by Ross Video, to those subscribing for maintenance
services for the Software or Documentation.



12. CONFIDENTIALITY. Each Party shall maintain in confidence all Confidential Information of the
other Party, shall use such Confidential Information only for the purpose of exercising its rights and
fulfilling its obligations under this Agreement, and shall not disclose any Confidential Information of
the disclosing Party to any third party except as expressly permitted hereunder or make any
unauthorized use thereof. Each Party shall disclose the Confidential Information only to those of its
employees, consultants, advisors, and/or subcontractors who have a need to know the Confidential
Information. Each Party shall, prior to disclosing the Confidential Information to such employees,
consultants, advisors and/or subcontractors, obtain their agreement to receive and use the
Confidential Information on a confidential basis on the same terms and conditions contained in this
Agreement. The receiving Party shall treat the Confidential Information of the disclosing Party with
the same degree of care against disclosure and/or unauthorized use as it affords to its own
information of a similar nature, or a reasonable degree of care, whichever is greater. The receiving
Party further agrees not to remove or destroy any proprietary or confidential legends or markings
placed upon any documents or other materials of the disclosing Party. The obligations of confidence
set forth in this Agreement shall extend to any Affiliates that have received Confidential Information
of the disclosing Party and shall also cover Confidential Information disclosed by any Affiliate. The
receiving Party shall be responsible for any actions or omissions of its Affiliates as if such actions or
omissions were its own.

Either party may disclose certain Confidential Information if it is expressly required to do so
pursuant to legal, judicial, or administrative proceedings, or otherwise required by law, provided
that (i) such Party provides the other Party with reasonable written notice prior to such disclosure;
(ii) such Party seeks confidential treatment for such Confidential Information; (iii) the extent of such
disclosure is only to the extent expressly required by law or under the applicable court order; and
(iv) such Party complies with any applicable protective or equivalent order.

Each of Ross Video and Licensee (the “Indemnifying Party”, as applicable) agree to indemnify the
other (the “Indemnified Party”, as applicable) for all Losses incurred by the Indemnified Party as a
result of a failure of the Indemnifying Party to comply with its obligations under this Section 12
provided that the Indemnified Party has given prompt notice of any such claim and, to the extent
that a claim may lie against a third party for the unauthorized disclosure of such Confidential
Information, the right to control and direct the investigation, preparation, action and settlement of
each such claim and, further, provided that the Indemnified Party reasonably co-operates with the
Indemnifying Party in connection with the foregoing and provides the Indemnifying Party with all
information in the Indemnified Party’s possession related to such claim and such further assistance
as reasonably requested by the Indemnifying Party.

The Parties acknowledge and agree that any breach of the confidentiality provisions of this
Agreement by one Party may cause significant and irreparable injury to the other Party that is not
compensable monetarily, as well as damages that may be difficult to ascertain, and agrees that, in
addition to such other remedies that may be available at law or in equity, the other Party shall be
entitled to seek injunctive relief (including temporary restraining orders, interim injunctions and
permanent injunctions) in a court of competent jurisdiction in the event of the breach or threatened
breach by such party of any of the confidentiality provisions of this Agreement. The relief
contemplated in this Section shall be available to each Party without the necessity of having to
prove actual damages and without the necessity of having to post any bond or other security. Each
Party further agrees to notify the other Party in the event that it learns of or has reason to believe
that any Person has breached the confidentiality provisions of this Agreement.
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LIMITATION OF LIABILITY. The limitation of liability provisions of this Agreement reflect an
informed voluntary allocation of the risks (known and unknown) that may exist in connection with
the licensing of the Software or Documentation hereunder by Ross Video, and that voluntary risk
allocation represents a material part of the Agreement reached between Ross Video and Licensee.
Should Ross Video be in breach of any obligation, Licensee agrees that Licensee’s remedies will be
limited to those set forth in this Agreement. No action, regardless of form, arising out of this
Agreement may be brought by Licensee more than twelve (12) months after the facts giving rise to
the cause of action have occurred, regardless of whether those facts by that time are known to, or
reasonably ought to have been discovered by, Licensee.

(A) EXCEPT AS EXPRESSLY PROVIDED IN THIS AGREEMENT, THE SOFTWARE AND DOCUMENTATION
ARE PROVIDED “AS IS” AND ROSS VIDEO (I) MAKES NO OTHER REPRESENTATIONS, AND PROVIDES
NO WARRANTIES OR CONDITIONS OF ANY KIND, EXPRESS OR IMPLIED, STATUTORY, BY USAGE OF
TRADE CUSTOM OF DEALING, OR OTHERWISE, AND (II) SPECIFICALLY DISCLAIMS ALL IMPLIED
WARRANTIES INCLUDING ANY IMPLIED WARRANTY OF UNINTERRUPTED OR ERROR FREE OPERATION,
MERCHANTABILITY, QUALITY OR FITNESS FOR A PARTICULAR PURPOSE. ROSS VIDEO DOES NOT
REPRESENT OR WARRANT THAT THE SOFTWARE WILL MEET ANY OR ALL OF LICENSEE'S PARTICULAR
REQUIREMENTS, THAT THE USE AND OPERATION OF THE SOFTWARE WILL OPERATE ERROR-FREE OR
UNINTERRUPTED, THAT ALL PROGRAMMING ERRORS IN THE SOFTWARE CAN BE FOUND IN ORDER TO
BE CORRECTED, OR THAT THE SOFTWARE WILL BE COMPATIBLE WITH OTHER PROGRAMS, SYSTEMS,
AND HARDW ARE.

(B) IN NO EVENT SHALL ROSS VIDEO, ITS AFFILIATES AND LICENSORS, AND THEIR RESPECTIVE
DIRECTORS, OFFICERS, EMPLOYEES AND AGENTS, BE LIABLE FOR ANY CLAIM FOR INDIRECT,
CONSEQUENTIAL, SPECIAL, INCIDENTAL, PUNITIVE, EXEMPLARY, AGGRAVATED DAMAGES; LOST
PROFITS, OR LOST REVENUE ARISING FROM OR IN CONNECTION WITH THIS AGREEMENT,
REGARDLESS OF THE FORM OF ACTION, WHETHER IN CONTRACT, OR IN TORT, EVEN IF THE PARTY
HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

(C) IN ANY EVENT THE AGGREGATE LIABILITY OF ROSS VIDEO, ITS AFFILIATES AND LICENSORS, AND
THEIR RESPECTIVE DIRECTORS, OFFICERS, EMPLOYEES AND AGENTS, FOR ANY CLAIM FOR DIRECT
DAMAGES WITH RESPECT TO THE SUBJECT MATTER OF THIS AGREEMENT SHALL NOT EXCEED THE
AMOUNT OF THE PURCHASE PRICE PAID TO ROSS VIDEO UNDER THIS AGREEMENT.

TERM AND TERMINATION.

(1) Unless terminated earlier in accordance with the terms of this Agreement, the term of this
Agreement shall commence upon Licensee’s first download, access, installation, or other use of
the Software or Documentation and continues until, in the case of Software licensed with
Designated Equipment provided by Ross Video, the earliest of (a) the end of the License
Period, or (b) if the Designated Equipment is assigned or transferred in accordance with this
Agreement, the date on which the Designated Equipment is no longer owned by Licensee;

(2) Either Party shall have the right to terminate this Agreement on notice to the other Party if:

(@) the other Party fails to pay any fees or other amounts when due hereunder or under any
other agreement between the Parties (or any Affiliates of the Parties, as applicable) in
connection with the Software and/or Designated Equipment and such breach is not cured
within thirty (30) days after written notice of such failure to pay is given to the defaulting
Party by the non-defaulting Party;

(b) the other Party shall file a voluntary petition in bankruptcy or insolvency or shall petition
for reorganization under any bankruptcy law, consent to an involuntary petition in
bankruptcy, or if a receiving order is given against it under the Bankruptcy and Insolvency
Act (Canada) or the comparable law of any other jurisdiction (and such is not dismissed
within ten (10) days);
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(c) there shall be entered an order, judgment or decree by a court of competent jurisdiction,
upon the application of a creditor, approving a petition seeking reorganization or
appointing a receiver, trustee or liquidator of all or a substantial part of the other Party’s
assets and such order, judgment or decree continues in effect for a period of thirty (30)
consecutive days; or

(d) the other Party shall fail to perform any of the other material obligations set forth in this
Agreement and such default, in the case of a default which is remediable, continues for a
period of thirty (30) days after written notice of such failure has been given by the non-
defaulting Party or, in the case of a non-remediable default, immediately upon notice.

(3) Notwithstanding anything to the contrary contained in this Agreement:

(@) Ross Video may forthwith terminate this Agreement if Licensee is in breach of any of
sections 3, 4 or 12 of this Agreement. For greater certainty, in such instances Ross Video
shall provide written notice of such termination as soon as practicable but written notice
shall not be a necessary prerequisite to such termination; and

(b) in the event of a Change of Control of Licensee, Ross Video shall have the right to
terminate this Agreement and the License granted hereunder upon thirty (30) days’ prior
written notice to Licensee. For greater certainty, Ross Video’s right to terminate in the
event of a Change of Control of Licensee shall continue for a period of six (6) months from
the date Licensee delivers notice of such Change of Control to Ross Video.

(c) Ross Video may terminate the License immediately on the date on which it provides notice
to Licensee, if its agreements for Third Party Software are terminated.

(4) Upon the termination or expiry of this Agreement:
(@) Licensee shall immediately cease and desist all use of the Software and Documentation;

(b) Licensee shall immediately deliver to Ross Video any of Ross Video’s Confidential
Information provided hereunder (including the Software and Documentation) then in its
possession or control, if any, and shall deliver a certificate of an officer of Licensee
certifying the completeness of same;

(c) Licensee shall refrain from further use of such Confidential Information; and

(d) Licensee shall forthwith pay all amounts owing to Ross Video or any of its Affiliates
hereunder.

SURVIVAL. The provisions of sections 1, 2,6, 8,9, 10,11, 12,13, 14, 18, 22, 23, and 24 herein
shall survive the expiry or termination of this Agreement.

FORCE MAJEURE. Dates and times by which Ross Video is required to render performance under
this Agreement shall be automatically postponed to the extent and for the period that Ross Video is
prevented from meeting them by reason of events of force majeure or any cause beyond its
reasonable control provided Ross Video notifies Licensee of the commencement and nature of such
cause and uses its reasonable efforts to render performance in a timely manner.

ASSIGNMENT. Ross Video may assign this Agreement, or any of its rights or obligations hereunder,
in whole or in part, upon notice to Licensee. Licensee shall not assign this Agreement, or any of its
rights or obligations hereunder, in whole or in part, without the prior written consent of Ross Video,
which consent may not be unreasonably withheld. This Agreement enures to the benefit of and is
binding upon each of the Parties and their respective successors and permitted assigns.



18.

19.

20.

21.

22.

23.

24.

GOVERNING LAW. If Licensee acquired the Ross Product(s) in the United States or Canada, the
laws of the state or province where Licensee’s principal place of business is located govern the
interpretation of this Agreement, claims for its breach, and all other claims regardless of conflict of
laws principles. If Licensee acquired the Ross Product(s) in the European Union or the United
Kingdom, then the laws of England and Wales apply. If Licensee acquired the Ross Product(s) in any
other country, then the laws of the Province of Ontario, Canada shall apply.

LANGUAGE. The Parties have expressly required that this Agreement and all documents relating
thereto be prepared in English. Les parties ont expressément exigé que cette convention ainsi que
tous les documents qui s’y rattachent soient rédigés en anglais.

GOVERNMENT CONTRACTS. If the Software and/or Documentation to be furnished to Licensee
hereunder are to be used in the performance of a government contract or subcontract, the Software
and/or Documentation shall be provided on a "restricted rights" basis only and Licensee shall place
a legend, in addition to applicable copyright notices, in the form provided under the applicable
governmental regulations. For greater certainty, Ross Video shall not be subject to any flow-down
provisions required by any customer of Licensee that is a Governmental Authority unless Ross Video
expressly agrees to be bound by such flow-down provisions in writing.

EXPORT AND IMPORT LAWS. Licensee acknowledges and agrees that the Software (including any
technical data and related technology) may be subject to the export control laws, rules, regulations,
restrictions and national security controls of the United States and other applicable countries (the
“Export Controls”) and agrees not to export, re-export, import or allow the export, re-export or
import of such export-controlled Software (including any technical data and related technology) or
any copy, portion or direct product of the foregoing in violation of the Export Controls. Licensee
hereby represents that it is not an entity or person to whom provision of the Software (including
any technical data and related technology) is restricted or prohibited by the Export Controls.
Licensee agrees that it has the sole responsibility to obtain any authorization to export, re-export,
or import the Software (including any technical data and related technology), as may be required.
Licensee will defend, indemnify and hold Ross Video harmless from any and all claims, losses,
liabilities, damages, fines, penalties, costs and expenses (including attorney’s fees) arising from or
relating to any breach by Licensee of its obligations under this Section.

AMENDMENT AND WAIVER. No amendment, discharge, modification, restatement, supplement,
termination or waiver of this Agreement or any Section of this Agreement is binding unless it is in
writing and executed by the Party to be bound. No waiver of, failure to exercise or delay in
exercising, any Section of this Agreement constitutes a waiver of any other Section (whether or not
similar) nor does any waiver constitute a continuing waiver unless otherwise expressly provided.

SEVERABILITY. Each Section of this Agreement is distinct and severable. If any Section of this
Agreement, in whole orin part, is or becomes illegal, invalid, void, voidable or unenforceable in any
jurisdiction by any court of competent jurisdiction, the illegality, invalidity or unenforceability of that
Section, in whole or in part, will not affect (a) the legality, validity or enforceability of the remaining
Sections of this Agreement, in whole or in part; or (b) the legality, validity or enforceability of that
Section, in whole or in part, in any other jurisdiction.

ENTIRE AGREEMENT. This Agreement, and any other documents referred to herein, constitutes the
entire agreement between the Parties relating to the subject matter of this Agreement and
supersedes all prior written or oral agreements, representations and other communications
between the Parties.

Updated: November 1, 2023



Warranty and Repair Policy

Ross Video Limited (Ross) warrants its Voyager systems to be free from defects under normal use and
service for the following time periods from the date of shipment:

e Voyager Server — 12 months
e Voyager Software Upgrades — 12 months free of charge
e System and Media hard drives — 12 months

If an item becomes defective within the warranty period Ross will repair or replace the defective item, as
determined solely by Ross.

Warranty repairs will be conducted at Ross, with all shipping FOB Ross dock. If repairs are conducted at
the customer site, reasonable out-of-pocket charges will apply. At the discretion of Ross, and on a
temporary loan basis, plug in circuit boards or other replacement parts may be supplied free of charge
while defective items undergo repair. Return packing, shipping, and special handling costs are the
responsibility of the customer.

This warranty is void if products are subjected to misuse, neglect, accident, improper installation or
application, or unauthorized modification.

In no event shall Ross Video Limited be liable for direct, indirect, special, incidental, or consequential
damages (including loss of profit). Implied warranties, including that of merchantability and fitness for a
particular purpose, are expressly limited to the duration of this warranty.

This warranty is TRANSFERABLE to subsequent owners, subject to Ross’ notification of change of
ownership.

Extended Warranty

For customers that require a longer warranty period, Ross offers an extended warranty plan to extend
the standard warranty period by one year increments. For more information about an extended
warranty for your Voyager system, contact your regional sales manager.



Environmental Information

The equipment that you purchased required the extraction and use of natural resources for its
production. It may contain hazardous substances that could impact health and the environment.

To avoid the potential release of those substances into the environment and to diminish the need for
the extraction of natural resources, Ross Video encourages you to use the appropriate take-back
systems. These systems will reuse or recycle most of the materials from your end-of-life equipment in an
environmentally friendly and health conscious manner.

The crossed-out wheeled bin symbol invites you to use these systems.

If you need more information on the collection, reuse, and recycling systems, please contact your local or
regional waste administration.

You can also contact Ross Video for more information on the environmental performances of our
products.



Company Address

Ross Video Limited

8 John Street
Iroquois, Ontario
Canada, KOE 1KO

Ross Video Incorporated

P.O. Box 880
Ogdensburg, New York
USA 13669-0880

General Business Office:

Fax:

Toll Free Technical Support:

Alternately, you can contact:
Technical Support:

After Hours Emergency:

E-mail for Technical Support:
E-mail for General Information:

Website:

(+1) 613 - 652 - 4886
(+1) 613 - 652 - 4425

1-844-652-0645 (North America)
+800 3540 3545 (International)

(+1) 613 - 652 - 4886
(+1) 613 - 349 - 0006

techsupport@rossvideo.com
solutions@rossvideo.com

http://www.rossvideo.com
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What's New?

e Voyager Node License/Shortcut
» Voyager Node
e Timecode-based event scheduling and execution
» Timecode
¢ Timecode for Adrienne LTC card
» Timecode > Configuring the Timecode Provider
e Timecode-based event scheduling using RossTalk
» Timecode > Scheduling Timecode Events Using a RossTalk Command
¢ RVS Engine Service updated
» Launching a Voyager Project Locally
¢ VS Trackless template updated

The VS Trackless Template has been updated, removing unnecessary Trackless Camera initialization
on Begin Play and setting the default Voyager Operator prepare delay property to 10.

e nDisplay cluster support
Added nDisplay cluster support when executing the following nodes from Lucid:
e Lucid String Async Blueprint nodes
e Lucid Rotator Async Blueprint nodes
e Lucid Vector Async Blueprint nodes
e Lucid Float Async Blueprint nodes
e Unreal Functions execution
¢ Send RossTalk Commands
Added Blueprint nodes to send RossTalk Commands (GPI, CC, SEQI, NEXT, and Custom).
» Using RossTalk
e NDI® Media Plugin
» Enabling the NDI Media I/O Plugin
» Using NDI Media I/O
e Internal compositing mode

Added the ability to select an internal compositing mode (Auto-detect, Linear, or Non-Linear) in the
Voyager Operator.

» Configuring the Voyager Operator
» Creating and Configuring the Voyager Operator
¢ Manage Media Targets Panel
Added a new editor to allow selection of specific material textures as media targets.

» Targeting Selected Material Textures
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Introduction

Voyager is Ross Video's latest graphics platform, powered by Epic Games’ Unreal Engine. Voyager
leverages the world’s most powerful and realistic renderer, enabling it's use for Augmented Reality (AR)

and Virtual Studio (VS) and helping the user to create stunning, complex virtual environments designed
for use in broadcast television.

Voyager uses the Lucid Studio control platform as an operator-friendly front end, so operators are not
required to have in-depth knowledge of the Unreal engine to use the system. Voyager supports
customization, flexibility, and scalability in terms of number of cameras and graphics engines through the
integration of Lucid Studio and Lucid Track applications.

Voyager 7.1 uses Unreal Engine 5.3.2 and supports Lucid 7.1 and Voyager Trackless 7.1.
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About This Guide

If, at any time, you have a question pertaining to the operation of the Voyager system, please contact
Ross Video at the numbers listed in the section Getting Help. Our technical staff are always available for
consultation, training, or service.

Documentation Conventions

Special text formats are used in this guide to identify parts of the user interface, text that a user must
enter, or a sequence of menus and sub-menus that must be followed to reach a particular command.

Bold text Bold text identifies a user interface element such as a dialog box, menu item,
or button.

For example:

In the Slug column, type a slug name for the story.

Italic text Italic text is used to identify the titles of referenced guides, manuals, or
documents.

For example:

For more information, refer to the DashBoard User Guide.

Courier text Courier text identifies text that a user must type.

For example:

In the Username box, type postgres.

Menu Sequences Menu arrows are used in procedures to identify a sequence of menu items that
you must follow.

For example:

If a step reads Server > Save As, you would select the Server menu and
then select Save As.

Hypertext Identifies a hyperlink to a related topic.
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Getting Help

Voyager documentation is available online at Product Documentation and is also accessible on the
product USB key and by selecting the Help icon in the user interface.

Contacting Technical Support

At Ross Video, we take pride in the quality of our products, but if problems occur, help is as close as the
nearest telephone.

Our 24-hour Hot Line service ensures you have access to technical expertise around the clock. After-
sales service and technical support is provided directly by Ross Video personnel. During business hours
(Eastern Time), technical support personnel are available by telephone. After hours and on weekends, a
direct emergency technical support phone line is available. If the technical support person who is on call
does not answer this line immediately, a voice message can be left and the call will be returned shortly.
This team of highly trained staff is available to react to any problem and to do whatever is necessary to
ensure customer satisfaction.

Technical Support:

e 1-844-652-0645 (North America)

e +800 3540 3545 (International)

e After Hours Emergency: (+1) 613-349-0006
e E-mail: techsupport@rossvideo.com

e Website: http://www.rossvideo.com
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Installation Notes

Voyager 7.1 is compatible with Windows 10, build 1809 and forward and Lucid 7.1.
It's best not to install Voyager and the Unreal Engine on the same computer, as you will have to re-
install Voyager to launch projects properly. If you do want both on the same computer, install the Unreal

Engine first and then Voyager. It's also recommended not to run both applications at the same time, to
avoid compatibility issues.

Dependencies

Voyager engine requires the following:

e .NET Framework 3.5. If .NET Framework 3.5 is not installed, Voyager will prompt the user to download
and install this feature. This requires an internet connection.

e Microsoft® Visual C++ 2015-2022 Redistributable 14.40.33810 (or higher)

Switchboard Launcher requires some dependencies that are automatically downloaded and installed
when executed the first time. This requires an internet connection.

NDI® Plugin
The NDI plugin included in Voyager 7.1 requires that NDI 6 or newer be installed.
NDI® is a registered trademark of Vizrt ND AB.

Voyager NDI® Streams License

To use the NDI plugin for NDI inputs and outputs in Voyager 7.1, you will need the Voyager NDI Streams
license on your Voyager system.

The Voyager NDI Streams license includes a specified number of input/output streams (the Count).

Voyager NDI Streams License

For example, if your Voyager system has a Voyager NDI Streams license with a Count of "2", it can use a
maximum of 2 NDI Streams, in any combination:

e 1 NDI Input and 1 NDI Output
e 2 NDI Inputs
e 2 NDI Outputs
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Driver Recommendations

It is recommended that the following drivers be installed:
e nVidia Driver 552.74

e Matrox Driver v10.2.103.26148

nVidia Power Management Settings

If your Voyager engine contains the nVidia Quadro Sync II card, you will need to adjust the nVidia power

management settings.
To adjust nVidia power management settings:

1. In the nVidia Control Panel, select Manage 3D Settings.

B nvIDIA Control Panel
File Edit Desktop 3D Settings Help

Change resolution

Adjust desktop color settings
Rotate display

View HDCP status Global Settings  Program Settings
Setup digital audio

Adjust desktop size and position

1 would like to use the following 3D settings:

Preferred graphics processor:

Qu - O |G
Select a Task... e . ~
= D setings ... Manage 3D Settings
i L.Adjust image settings with preview oz Restore Defaults
You can change the global 3D settings and create ovenmides for specific programs. The ovemides will be used automatically each time the specfied
~Configure Surround, PhysX programs are launched
E! Display

System Information

| L-Setup multiple displays High-performance NVIDIA processor
- Video
Adjust video color settings Settings:
Adjust video image settings
Feature Setting 2
CUDA - GPUs All
DSR - Factors Off
DSR. - Smoothness Off
Low Latency Mode off
Max Frame Rate Off
Multi-Frame Sampled AA (MFA&) Off
st CEL EIIEE
Power management mode Prefer maximum performance
Shader Cache on
Toschien Slbowinn el ot ez hd
@ Restore

Apply Cancel

nVidia Power Management Settings

2. In the Global Settings tab, in the Settings section, scroll down to Power management mode and

from the drop-down, select Prefer maximum performance.

3. Select Apply and close the control panel.

Multi-Engine Systems

When working in a multi-engine configuration, some rules need to be followed:

e Each engine runs its own exact copy of the projects. Those projects needs to be copied in the exact

same local path on every engine. Example: D:\Voyager_Projects\

e The Voyager software itself also needs to be installed in the same exact local path on every engine.
By default, Voyager software is installed to C:\Program Files\Voyager.

Voyager User Guide (v7.1)

Introduction * 27



Getting Started

When creating a Voyager project, you’'ll need to consider whether your project will use internal or
external compositing and whether it will be a Virtual Set (VS) or Augmented Reality (AR) project. The
difference in settings between VS and AR will be explained within the instructions for internal and
external compositing.

The instructions in this guide reference a system that has a Matrox video card. If your Voyager system
uses an AJA video card, anywhere in the instructions where it says to select "Ross Matrox...”, select the
AJA version of that component instead.

You can choose one of the following methods to set up your project:

Creating a Project from a Template

Making an Existing Project Compatible with Voyager

K When you are working in Voyager and haven't yet saved your work, an asterisk appears beside the
title of the window in which you are working. When you save your work, the asterisk disappears.

AV | FETIET ' Ay | PEUTEE

File Edit Window Help File Edit Window Help

%fr Place Actors R Place Actors

Before and After Saving

Logging in to Voyager
If you haven't already done so, log onto your Voyager system.

To log onto the Voyager system:

1. Press the Power button on the front of the Voyager system.
2. Select the Voyager user account icon on the desktop.
3. Log onto the system using the following credentials:
Username - Voyager
Password - beyondinfinity

4. Launch Voyager from the Start menu.
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Selecting a Ul Layout

Voyager has been updated with the latest version of the Unreal Engine, which resulted in many
changes to the UL If you would like to continue using the classic UE4 layout, you can elect to do so.
Otherwise, the same functionality remains, but you may have to look in different locations to find a
particular setting. In this document, the screenshots and instructions are for the classic layout.

To use the classic UE4 layout:

1. Launch Voyager and select the project or template you want to use.

2. Then select Window > Load Layout > UE4 Classic Layout.
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Creating a Project from a Template

Voyager provides several templates to make setting up your project easier. This is the recommended
method for creating projects as many of the required assets and settings are included in the templates.
You can still import files from an existing project, if you have one prepared that you want to use.
There are a number of steps that are the same for all types of projects, except the Virtual LED project.
The Virtual LED project requires no media proxies, media profile or media bundle.

The rest of the project types require all of the following steps to create:

Setting up a Project

Creating a Media Source Proxy (not necessary for a Virtual LED project)

Select or creating a Media Profile (not necessary for a Virtual LED project)

Configuring the Voyager Operator

Selecting the Startup Media Profile

Creating a Media Bundle (not necessary for a Virtual LED project)

Adding the Composite Actor(s) to the Set

Multiple Composites

If you want more composite inputs in your project than the one that is included with the template, see:

Using Multiple Composite Inputs in Your Project

Live Source Materials

For instructions on creating a material for a live source, see Creating a Live Source Material

Template-Specific Instructions

The following templates require some additional setup. Once you've completed the above steps, go to
the section corresponding to your selected template for further template-specific instructions.

Augmented Reality + Virtual Set Template with Set Extension
Virtual LED Template

Virtual LED + Set Extension Template
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Setting up a Project

The first step is to create an empty project from the template. Then you can migrate files from an
existing project to the template and add the migrated level(s) to the new project.

To create an empty project:

1. Launch Voyager from the desktop icon.

2. In the New Project Catagories section, select the Film, Television and Live Events option and
select Next.

Unreal Projec

b AR Template

& B
AR vs

RECENT PROJECTS

AR Template

FILM, TEL

EVENTS
n

VLED VLED EXT

VLED Template VLED+Ext
te

Template

Cancel

Select Film, Television and Live Events

3. In the Select Template window, select the template you want to use and select Next.

Unreal Projec

s

RECENT PROJECTS AR

AR Template

10N, AND LIVE

&3l

FILM, TEL

EVENTS
el

AR+VS

Template

Select Template

VS Template
= B2 -
Vs Vs

VS Template

VLED

%

VLED EXT

VLED Template

Create
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4. In the Project Settings window, from the Raytracing drop-down, select whether or not to use real-
time raytracing in your project.

If you don't know which option to choose, select Raytracing Disabled. You can change this setting
later in the project settings. Raytracing can be very GPU-intensive, so only use it if necessary.

5. Select Browse beside the Project Location field to navigate to a folder in which to save your new
project (e.g., D:\Voyager_Projects) and select Select Folder.

6. In the Project Name field, enter a name for your project.

Your project name cannot have any spaces in it. Use underscores rather than spaces.

7. Then select Create.

Your new project opens.
File Edit Window Tools Build Actor  Help
A Build_Vs
n &, Selection Mode : Bpiatioms v H ve
€, Place Actors = erspective. @ Lit  Show o ® % @ &w (Flozs 4

Q

v 8

BASIC

Actor

Character

s
&

-
ES Content Bi
+ Add V) Import Al mm Al > Content »

v MyVSProject Q)

B Al
w & Content

=5 Derived Data

New Project from Template

8. Select the Save Current icon and minimize your empty project to the task bar.
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Migrating Files into a Project

Next you’ll need to migrate the levels you want to use from an existing project into the template.

To migrate files into a project:
1. Launch the source project containing the level(s) you want to use, by double-clicking the .uproject
file.

2. In the Select Unreal Engine Version dialog, select the latest version of the Unreal Engine and select
OK.

3. In the Multiple Instances Running dialog, select Yes.
Wait a few minutes for the project to launch and the shaders to compile.

4. In the Content Browser, select the Add Filter arrow and select Level from the Filter menu to view
the project levels.

-+ Add Yy Import  |= Sa

BroadcastStudio Q,  Filters

All ' Level

Content

Collections ® Q

tent Drawer B output Log Cmd v

Select Level Filter
5. Double-click the level you want to use to load it in the viewport, if it is not already displayed.
6. In the Content Browser, right-click the level and select Asset Actions > Migrate.

You can migrate more than one level at a time, by using Ctrl + Click or Shift + Click to select
multiple levels.

X You can only migrate to the same version of the Unreal Engine or forwards. You cannot migrate
backwards from a newer version.

# Edit...

[ Rename
Duplicate
Save CTRL+S
Delete DELETE
Asset Actions >
Asset Localization > Capture Thumbnail

O 1 i . -
% Show in Folder View Select Actors Using This Asset

© Show in Explorer

Export...

F: Copy Reference
I": Copy File Path

= Migrate...

Migrate Level

7. In the Asset Report screen, select OK.
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8. In the Choose a destination Content folder screen, navigate to the Content folder of your new
project and select Select Folder.

The level files are copied to the new project and you'll see a "Content migration completed
successfully!” message when it is complete.

9. Close the source project and restore your new project.

You'll see that in addition to the default folder, the Content Browser now displays the migrated
folder(s).

Adding the Migrated Level(s) to the Project

Now you’ll add the migrated level to your new project.

To add migrated levels to the project:

1. In the new project, select Window > Levels to open the Levels panel if it is not already present.
File Edit | Window | T Build

A Build_vs

Cinematics
Content Browser
Details
Imghedia

Outliner

Pl @ N

Viewports

Virtual Production

WOW W W W W WY

[2]
- ]

World Partition
>onsole Variables
@ Env. Light Mixer
Hierarchical LOD Outliner
Layers
Levels
22~ Light Mixer
Multi-User Browser
Place Actors
11 Variant Manager

World Settings

Add Levels Panel
2. Select and drag the Levels panel tab to position it where you want in the UI.
3. In the Content Drawer, select Filters > Level to display the levels in your project.
You will see the default Voyager level (Build_"Template Type”) and the migrated level(s).

4. Drag the migrated project level into the Levels panel, where it will be nested under the Persistent
Level folder.

Notice that in the Levels panel, the migrated level name is blue and there is a dot beside it. This
indicates that a blueprint is required to launch the level.
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5.

If you only have one level in your project, right-click the level in the Levels panel and select Change
Streaming Method > Always Loaded instead of creating a blueprint.

The level will be selected and played when the project is launched. Notice that the level name is no
longer blue and there is no dot beside it.

If you have more than one level in your project, see Creating a Blueprint to Launch Multiple Levels.

Showcas

Make Current ENTER
Visibility >
Lock >
Remove Selected

Change Streaming Method

+  Blueprint

Lighting Scenario i et

Find in Content Browser

Change Streaming Method

6. Select the Save button to save your project.

7. Continue with Creating a Media Source Proxy.
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Creating a Media Source Proxy

With your basic project created, you now need to create media source proxies for any additional
composite input in your project. Voyager templates have 1 Media Source Proxy and 1 Media Output
Proxy already configured.

To create a media source proxy:

. Select Edit > Project Settings and scroll down to the Plugins section.
. From the Plugins section, select Media Profile.

1
2
3.
4

Expand the Advanced options.

. In the Media Source Proxy section, select the + icon to add an array element for each additional

composite plane in your project.

Proxy Media Source

F: Copy

o Clear

Create a Media Source Proxy

In the Save Asset As window, navigate to the Voyager > Proxies folder and in the Name field,
enter a name for the media source proxy (e.g. ProxyMediaSource_Composite2).

Select Save.

Repeat steps 5 to 7 so that you have a media source proxy for each composite plane in your project.

. When you have finished, close the Project Settings window and continue with Selecting or Creating

a Media Profile.
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Selecting or Creating a Media Profile

If you do not have a media profile on your engine, you'll need to create one. The media profile defines
the number of inputs being used and configures the inputs and output for your project.

X You will not need a media profile for a Virtual LED project.

Selecting an Existing Media Profile

If you have previously created a media profile on your engine, it will be saved in Engine Content and is
available for use with any project.

To select an existing media profile:

e Select the arrow beside the Media Profile icon, and select the media profile that matches your
requirements.

Accessing the Media Profiles Folder

If you need to create a media profile, you'll need to access a folder in the Engine Content. It is best not
to have the core engine files visible all the time, as inadvertently changing something in these files could
interfere with your Voyager installation. Make them visible only while it is necessary, then hide them
again.

To view engine content:
1. In the bottom-right corner of the Content space, select View Options and select the Show Engine
Content checkbox.

2. Proceed with the instructions for creating a media profile.

3. When you have finished creating your media profile, go back to View Options and deselect the
Show Engine Content checkbox.

4. If you want to reuse the media profile you create here in another project, you'll need to again go to
View Options, select the Show Engine Content checkbox and in the Content Browser navigate to
the profile in the MediaProfile folder.
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Creating a Media Profile

The steps for creating a media profile are described in the following sections:
Creating an Empty Media Profile

Configuring Inputs and an Output

Configuring the Genlock Settings

Updating Voyager Project Settings

Selecting the Startup Media Profile

Creating an Empty Media Profile

This step creates the container that stores the input and output configurations.

You will not need a media profile for a Virtual LED project.
To create an empty media profile:

1. In the main toolbar, select the 3 vertical dots beside the Media Profile icon.

Media Profile Icon
2. From the drop-down menu, select New Empty Media Profile.
3. In the Pick Media Profile Class section, select the MediaProfile item and select Select.
W Pick Media Pro
COMMON

ALL CLASSES

Q

81 MediaProfile

1item

Cancel

Pick Media Profile Class

4. In the Save Asset As window, select the settings icon to the right of the Search Assets field and
select Show Engine Content.
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5. Then in the Search Folders list, select Content > Engine > Content, scroll down and select the

MediaProfiles folder.
o If the MediaProfiles folder does not exist, right-click Engine > Content and select New Folder to

create a folder named MediaProfiles.

e or right click to creat

0items

Cancel

Save Asset As
In the Name field at the bottom of the Save Asset As window, enter a name for the media profile

you will create and select Save.

e.g., Matrox_1080p_5994_VS.
The new empty media profile is saved in the MediaProfile folder and the Details tab opens.

6.

7. Continue with Configuring Inputs.
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Configuring Inputs

Now you’ll configure your input(s). The instructions in this section describe how to configure a composite
input. If you want to create a live source input, see Creating Live Sources. You'll also need to create a
live source material; see Creating a Live Source Material.

Select your hardware version for the appropriate instructions.

Voyager SDI and 12G

Voyager IP

Voyager SDI and 12G

The configuration instructions in this section are for configuring a composite input for the Voyager SDI
and 12G versions.

If you want to configure an input for a live source, see Creating Live Sources. You will also need to
create a live source material for each live source; see Creating a Live Source Material.

To configure a composite input:

1. Double-click the Media Profile icon in the main tool bar to open the media profile you created, if it is
not already open.

2. Expand the Inputs > Media Sources section, then select the ProxyMediaSource_Compositel drop-
down and select Ross Matrox Media Source.

Genlock

Media Source Input
3. Expand the ProxyMediaSource_Compositel input and then expand RossMatrox to access
Configuration.
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4. Select the Configuration drop-down and in the configuration panel that opens, select the options
described below and select Apply.

The Resolution and Frame Rate options will differ depending on your hardware configuration.

o Input Type: Fill and Key (for a VS with an external keyer) or Fill (for VS with an internal keyer or
AR)

e Device: DSXLE4/8/100F
e Source: Single Link 1 (first composite), Single Link 3 (2nd composite), etc.
¢ Resolution/Standard/Frame Rate: The video format that corresponds to your workflow.

e Key Source: The appropriate key source will be automatically selected, based on your selection of
Source, if using a Matrox card. If using an AJA card, select the appropriate key source manually.

o Keying Mode: Select Shaped (pre-multiplied) or Unshaped (straight alpha).

Fill ® DSXLE4/8/100F ® Single Link 1 HD 720 ® Progressive

® Filland Key SingleLink3 e HD1080 Interlaced Unshaped

Single Link 9

Input Configuration - Composite Input

5. If you intend to use the Timecode Provider, from the Timecode Format drop-down, select VITC.
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6. Expand Video and configure the settings as follows:

Select the Capture Video checkbox.
From the Color Format drop-down, select the color format that works best for your project.
10bit YUV 422 is recommended when using HDR and Wide Color Gamut.

With multiple inputs, there may be a performance cost when using 10bit YUV 422. In this case,
try using 8bit YUV 422,

10bit YUV 422 is not supported in a Fill and Key configuration with an AJA card. In this case you
could use RGBA.

If you have an AJA card with the Interlaced Standard, and you notice field inversion, select the
Invert Interlaced Fields checkbox.

From the Max Num Video Frame Buffer drop-down, select 8 if you are using a Progressive format
or if you are using an Interlaced format, select 16.

From the Input Frame Delay drop-down, select the frame delay that works best for your project.
Video
Capture Video
C Format
Invert Interlaced Fields

Max Mum Video Frame Buffer

Input Frame Delay

Video Configuration - Composite Input
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7. Expand Colorspace and configure the settings as follows:
e From the Colorimetry drop-down, select one of the following options:

> Rec. 709 (HD SDR) for High Dynamic Range (increased levels in the range between bright and
dark) and Standard Dynamic Range

OR
» Rec. 2020 (WCG) for Wide Color Gamut (increased selection of color values)
¢ From the Transfer Function drop-down, select one of the following options:
> SDR (Rec. 1886) — Standard Dynamic Range

» HLG (Rec. 2100) — increases the dynamic range of the video and is compatible with both SDR
and HDR displays

> HDR10 (PQ 1000 nits) — supports a significantly larger range of brightness as SDR, with a
corresponding increase in contrast and a color palette of one billion shades.

LUT Qutput Colorimetry

LUT Output Transfer Function

Colorspace Settings

e Select the Linear Alpha checkbox if the incoming alpha is already linear; the Transfer Function will
not be applied.

Refer to the documentation for your chroma keyer or key source to determine whether or not the
alpha is linear.

e If you selected an 8bit color format in the Video settings, these are the only Colorspace settings
available. Select Save and continue with the output configuration.

e If you selected a 10bit color format in the Video settings, the HDR settings will also be available.
Continue with the next steps to edit HDR settings.

» From the Conversion LUT drop-down, browse to and select the Look Up Table you want to
apply to your color grading.

» From the LUT Output Colorimetry drop-down, select either Rec. 709 (HD SDR) or Rec. 2020
(WCG).

» From the LUT Output Transfer Function drop-down, select either SDR (Rec. 1886), HLG (Rec.
2100) or HDR10 (PQ 1000 nits).

8. Select Save.

Continue with Configuring an Output.

Voyager User Guide (v7.1) Creating a Project from a Template « 43



Voyager IP

The configuration instructions in this section are for the Voyager IP version.

If you want to configure an input for a live source, see Creating Live Sources. You will also need to
create a live source material for each live source; see Creating a Live Source Material.

To configure a composite input:

1. Double-click the Media Profile icon in the main toolbar to open the media profile you created.

2. Expand the Inputs > Media Sources section, then select the ProxyMediaSource_Compositel drop-
down and select Ross Matrox Media Source.

Genlock
Media Source Input
3. Expand the ProxyMediaSource_Compositel input and then expand RossMatrox to access
Configuration.
4. From the Timecode Format drop-down, select VITC.

5. Select the Configuration drop-down and in the configuration panel that opens, select the options
described below and select Apply.

The Resolution and Frame Rate options will differ depending on your hardware configuration.

o Input Type: Fill and Key (for a VS with an external keyer) or Fill (for VS with an internal keyer or
AR)

e Device: Matrox
e Source: IP Flow 1
¢ Resolution/Standard/Frame Rate: The video format that corresponds to your workflow.

Fill - XMIOSQ25/100 [dev
VITC v [l

Fill and Key

2

239.106.1.1 o

1234 W e

IGMP Jain IGMP w2 -

Input Configuration - Composite Input (IP)
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6. Expand the IP section and then expand Primary and configure the settings as follows:
e Select the Enabled checkbox.
¢ In the Remote IP field, enter the IP address of the remote machine.
e Enter the Port number on which the machines will be communicating.
e Expand Secondary and from the IGMP Join drop-down, select IGMP v2.
7. Expand Video and configure the settings as follows:
e Select the Capture Video checkbox.
e From the Color Format drop-down, select the color format that works best for your project.
10bit YUV 422 is recommended when using HDR and Wide Color Gamut.

With multiple inputs, there may be a performance cost when using 10bit YUV 422. In this case,
try using 8bit YUV 422,

10bit YUV 422 is not supported in a Fill and Key configuration with an AJA card. In this case you
could use RGBA.

Leave the remaining settings as they are.

e If you have an AJA card with the Interlaced Standard, and you notice field inversion, select the
Invert Interlaced Fields checkbox.

e From the Max Num Video Frame Buffer drop-down, select 8 if you are using a Progressive format
or if you are using an Interlaced format, select 16.

e From the Input Frame Delay drop-down, select the frame delay that works best for your project.
Video
Capture Vi
Color Format
Invert Interlaced Fields

Max Mum Video Frame Buffer

Input Frame Delay

Video Configuration - Composite Input
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8. Expand Colorspace and configure the settings as follows:
e From the Colorimetry drop-down, select one of the following options:

> Rec. 709 (HD SDR) for High Dynamic Range (increased levels in the range between bright and
dark) and Standard Dynamic Range

OR
» Rec. 2020 (WCG) for Wide Color Gamut (increased selection of color values)
¢ From the Transfer Function drop-down, select one of the following options:
> SDR (Rec. 1886) — Standard Dynamic Range

» HLG (Rec. 2100) — increases the dynamic range of the video and is compatible with both SDR
and HDR displays

> HDR10 (PQ 1000 nits) — supports a significantly larger range of brightness as SDR, with a
corresponding increase in contrast and a color palette of one billion shades.

LUT Qutput Colorimetry

LUT Output Transfer Function

Colorspace Settings

e Select the Linear Alpha checkbox if the incoming alpha is already linear; the Transfer Function will
not be applied.

Refer to the documentation for your chroma keyer or key source to determine whether or not the
alpha is linear.

e If you selected an 8bit color format in the Video settings, these are the only Colorspace settings
available. Select Save and continue with the output configuration.

e If you selected a 10bit color format in the Video settings, the HDR settings will also be available.
Continue with the next steps to edit HDR settings.

» From the Conversion LUT drop-down, browse to and select the Look Up Table you want to
apply to your color grading.

» From the LUT Output Colorimetry drop-down, select either Rec. 709 (HD SDR) or Rec. 2020
(WCG).

» From the LUT Output Transfer Function drop-down, select either SDR (Rec. 1886), HLG (Rec.
2100) or HDR10 (PQ 1000 nits).

9. Select Save.

Continue with Configuring an Output.
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Configuring an Output

There is only one output available in Voyager. You only need to decide whether you want to configure
that output for internal compositing or external compositing. Instructions for both are provided in this
section.

Internal Compositing

To configure an output for internal compositing:

1. In the Outputs section, expand Media Outputs.

2. Then select the ProxyMediaOutputl drop-down and select Ross Matrox Media Output.

Outputs

Timecode Provider

Media Profile - Output Config

3. Expand ProxyMediaOutputl and then expand RossMatrox to access Configuration.

4. Select the Configuration drop-down and in the configuration panel that opens, select the options
described below and select Apply.

The Source, Resolution and Frame Rate options will differ depending on your hardware
configuration.

Output Type: Fill
Device: DSXLE4/8/100F

Destination: The physical pin you are using for your output (different cards will display different
options here)

Resolution/Standard/Frame Rate: The video format that corresponds to your workflow.

Reference: External

Outputs

e Fill ® DSXLE4/8/100F HD 720 ® Progre 24 fps Free Run

Fill and Key Single Link6 & HD 1080 Interlaced 25 fps e External

2097 fps Input
30 fps

50 fps

50,94 fps

Output Configuration
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5. Expand Output, select the arrow in the Pixel Format field and select the format that works best for
your project.

10bit YUV 422 is recommended when using HDR and Wide Color Gamut.

With multiple inputs, there may be a performance cost when using 10bit YUV 422, In this case, try
using 8bit YUV 422,

10bit YUV 422 is not supported in a Fill and Key configuration with an AJA card. In this case you
could use RGBA.

6. Select the Parallelize Transfers checkbox to improve performance.
Output frames are transferred faster, which can make a noticeable difference in 4K projects.
7. Leave the remaining settings as they are and select Save.

Continue with Configuring the Genlock Settings.
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External Compositing

To configure an output for external compositing:

1. In the Outputs section, expand Media Outputs.

2. Then select the ProxyMediaOutputl drop-down and select Ross Matrox Media Output.

3. Expand ProxyMediaOutputl and then expand RossMatrox to access Configuration.

4. Select the Configuration drop-down and in the configuration panel that opens, select the options
described below and select Apply.

The Resolution and Frame Rate options will differ depending on your hardware configuration.

Output Type: Fill and Key
Device: DSXLE4/8/100F

Destination: The physical pin you are using for your output (different cards will display different
options here)

KX For AJA cards, the Destination and Key Destination pins need to be adjacent (e.g., Destination
= Out 1 and Key Destination = Out 2).

Resolution/Standard/Frame Rate: The video format that corresponds to your workflow.

Key Destination: The appropriate key destination will be automatically selected, based on your
selection of Destination, if using a Matrox card. If using an AJA card, select the appropriate key
destination manually.

X For AJA cards, the Destination and Key Destination pins need to be adjacent (e.g., Destination
= Out 1 and Key Destination = Out 2).

Reference: External

Standard

& DSXLE4/8/100F ® Single Link 2 HD 720 ® Progressive 5 Free Run

® Fill and Key & HD1080 Interlaced ® External

9.97 fps
ey Input

30fps

59.94fps
60 fps

Output Configuration - External Compositing

5. Expand Output, select the arrow in the Pixel Format field and select the format that works best for
your project.

10bit YUV 422 is recommended when using HDR and Wide Color Gamut.

With multiple inputs, there may be a performance cost when using 10bit YUV 422. In this case, try
using 8bit YUV 422,

10bit YUV 422 is not supported in a Fill and Key configuration with an AJA card. In this case you
could use RGBA.

6. Select the Parallelize Transfers checkbox to improve performance.

Output frames are transferred faster, which can make a noticeable difference in 4K projects.
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7. Leave the remaining settings as they are and select Save.

Continue with Configuring the Genlock Settings.
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Configuring the Genlock Settings

Once you have your input(s) and output configured, the last step is to configure the Genlock settings.
The settings will depend on the type of graphics card you have in your engine. Select the appropriate
instructions below:

To configure the Genlock Settings for a Matrox card:

1. In the Genlock section, select the Override Project Settings checkbox.

Genlock Configuration - Matrox
2. Select the Custom Time Step arrow and from the drop-down select Ross Matrox SDI Input.

3. Expand Custom Time Step and then expand Genlock and select the Use Media Output Settings
checkbox.

4. Select Save and close the Media Profile window.
To configure the Genlock Settings for an AJA card:

1. In the Genlock section, select the Override Project Settings checkbox.

Genlock Configuration - AJA

2. Select the Custom Time Step arrow and from the drop-down select AJA SDI Input.

3. Expand Custom Time Step and then expand Genlock and select the Use Media Output Settings
checkbox.

This forces the AJA Custom Time Step to use the Genlock settings configured on the first AJA Media
Output of the Media Profile.

4., Select Save and close the Media Profile window.

Continue with Updating Voyager Project Settings.

Voyager User Guide (v7.1) Creating a Project from a Template « 51



Updating Voyager Project Settings

Once you've set up your project, it's time to update the Voyager project settings.
To update the project settings:

1. Select the 3 vertical dots beside the Voyager icon and select Select a Voyager Operator >
VoyagerOperator.

2. Then select Update Project Settings.

Lucid

New Voyager Operator

VoyagerOperator >

Update Project Settings

About Voyager

Updating Voyager Project Settings
3. In the Voyager Project Defaults dialog, select Yes to proceed.

4. Continue with Selecting the Startup Media Profile.
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Selecting the Startup Media Profile

If you want to run your project in Game mode (Voyager Node or nDisplay), you will need to select the
Startup Media Profile.

To select the Startup Media Profile:

1. Select Edit > Project Settings > Plugins > Media Profile.

2. In the Media Profile plugin, from the Startup Media Profile drop-down, select the media profile you
created for your project and then close the Project Settings editor.

oS SV FIO[ECUSERingE

4 Media Profile

Apply in Commandiet

Plugins

Matrox_1080p_ARVS

« 0

Startup Media Profile

-

cLeapARPIn Plugin

Select Startup Media Profile
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Configuring the Voyager Operator

The next step in the process is to configure the Voyager Operator.

To configure the Voyager Operator:

1. At the top-right corner of the UI, select the Edit VoyagerOperator button.

Lucid

Edit VoyagerEditor Button

The VoyagerOperator editor opens.
File Edit

F

| VoyagerOperator

- Details
Voyager

Internal

Virtual LED

VoyagerOperator Editor
2. From the Internal Compositing Mode drop-down, select from the following options:

Auto-detect — uses Linear compositing (engine default) unless the Voyager Media Bundle on the first
compositing layer is set to External Keying and Tonemapping is set to Hybrid.

Linear — recommended for multiple compositing layers, as it supports the most features and layering
combinations.

Non-Linear — recommended for a single layer using external keying, as it supports fewer layering
and post-processing combinations but replicates the external compositing typical of broadcast
devices.

X In Non-Linear mode, pixels in the virtual graphics that are hidden by composite objects will still
generate bloom, as if they were visible. This mode is intended for use with external keyers. It could
have undesired effects on the edges of internal chroma keyers.

* Additional live sources that are fill-only without using chroma keying can be used in either mode,
based on the nature of the main composite's keying method.

3. Select Save and close the VoyagerOperator editor.
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Creating a Media Bundle

You need to create a media bundle asset for each input in your project. This will allow the asset to be
controlled by other applications.

To create a media bundle:

1. Navigate to the Voyager > LiveSources folder.

2. Right-click in an empty section of the Content pane and select Media > Voyager Composite Media
Bundle (for a composite input) or Media > Media Bundle (for a live source input).

Live Link
Materials
Media

- A Proxy Media Output
Lf

Proxy Media Source
Miscellaneous
nDisplay Ross Matrox Media Output
Paper2D
Physics Ross Matrox Media Source
Sounds

Textures Stream Media Source

WOWOW W N W W N W

User Interface
Iﬁ Voyager Color Calibration

Tl = : :
¢¥. Voyager Composite Media Bundle

Create VoyagerComposite Media Bundle

3. In the Content pane, rename the Media Bundle asset to associate it with a composite input (e.g.,
VoyagerComposite_1) or a live source input (e.g., LiveInput_1).

The InnerAssets folder is created automatically.
4. Double-click the media bundle you created to open the Details tab.
5. From the Mode drop-down, select the chroma keyer mode you need for your project.

6. From the Media Source drop-down, select Proxy Media Source.
& Details
Q

Media Bundle

Select Media Source

7. Expand Media Source and Media Proxy and from the drop-down, select the proxy media source to
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be used with that media bundle.

Media Bundle

Select Proxy Media Source

Aja Media Source

'z File Media Source

) Img Media Source

% Platform Media Source

Proxy Media Source

Ross Matrox Media Source

“% Stream Media Source

Copy

] Clear

8. Repeat steps 2 to 7 for each input in your project.

9. Select Save and close the Details tab.
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Augmented Reality + Virtual Set
Template with Set Extension

When creating a project that uses both AR and a virtual set with set extension, you may find that you
are seeing some reflection from the green screen in parts of the physical set.

You can use the VoyagerARDespillMask actor to gray out the green.

By default, the VoyagerARDespillMask actor is a plane, but it is a 3D object that can be replaced by a
static mesh, if that would be more suitable for masking a particular area.

The VoyagerARDespillMask is used in conjunction with the despill_matte actor. The despill_matte
actor determines how the despill will be applied, either to an area in the AR background outside of the
VoyagerARDespillMask object (Garbage Matte) or only to the area defined by the
VoyagerARDespillMask object (Holdout).

You can also feather the edges of the mask in order to provide a more seamless blending of the masked
area and the unmasked area.

Using the VoyagerARDespill Mask

If you are seeing some reflection from the green screen in parts of the physical set, you can mask out
the reflection with the VoyagerARDespill Mask.

To use the VoyagerARDespillMask:

1. Determine to which part of the set you want to apply the mask.
2. In the Outliner, select the despill_matte actor.

3. In the Details tab, scroll down to Composure > Input > Matte Type and select the appropriate
option:

¢ Garbage Matte - to remove any green reflection from the camera feed on the AR background
outside of the region defined by the VoyagerARDespill Mask. This is the default setting.

¢ Holdout - to remove any green reflection in the region defined by the VoyagerARDespill Mask.
4. Then, in the Outliner, select the VoyagerARDespillMask actor.

5. In the Output window, move the VoyagerARDespillMask from its default location so that the green
reflection is removed.

6. With the VoyagerARDespillMask still selected, in the Details tab, in the Materials section, double-
click the ARComposureFeather_Inst material to open the editor.

7. In the editor, in the Details tab, in the Feather section, select an edge of the mask and adjust the
value to blur the edge.

8. Adjust each edge as necessary to soften any hard lines.

9. Then select Save and close the material editor.
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Virtual LED Template

With the Virtual LED template you can render content on multiple displays simultaneously. This type of
project typically requires several Voyager engines. One engine is identified as the “master node” and
additional engines are identified as “cluster nodes”.

A Virtual LED setup outputs directly to the video wall from an HDMI or DisplayPort connection.

The following tools will help you make the most of your Virtual LED project:

e The nDisplay plugin inside Voyager communicates and synchronizes information amongst all the
Voyger engines that make up the cluster, to make sure all engines render correctly at the same time
(enabled by default).

e The Voyager Switchboard Launcher application (located on the master node only) is used to
automatically launch and quit your Voyager project on all the engines in your setup.

e The Voyager Switchboard Listener application (running on the master node and each cluster node)
listens for incoming requests from Voyager Switchboard Launcher, and processes those requests on
the local engine.

e In the Voyager level blueprint, you can set up camera switching amongst multiple cameras from a
number of input sources. See Adding Camera-Switching to the Level Blueprint for more information.

Virtual LED Rendering Content on Three Screens Simultaneously

Begin by creating a project from the Virtual LED template as described in Creating a Project from a Template.
Then review the following topics, which are specific to a Virtual LED project:

Configuring Your Screen Setup
Using Voyager Switchboard Launcher

Using Voyager Switchboard Listener
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Configuring Your Screen Setup

In your new project, you'll need to match the screens in the project to your physical screen layout. You
define most aspects of the VLED system in the VLED_Stage Editor. Here you will define the engines
that make up your network, the size and location of the screens and the viewports to render on each
engine.

The default configuration is the VLED_Stage. This configuration can be altered to match your physical
layout.

Depending on your screen setup and content, you may need more engines. In that case, you'll have to
add engines to the template and assign viewports to each engine.

X When running nDisplay projects, the engine runs in Game mode.

X When running in Game mode, the project's Media Profile needs to be set as the Startup Media
Profile. See Selecting the Startup Media Profile for instructions.

To set up the template screens:

1. In the Content Drawer > Content > Voyager > VLEDContent, double-click the VLED_Stage
configuration icon to open the editor.

~+ Add Yy Import = m Al > Content > \

MyVLEDProject

W_TargetText | WLED_St \ VLEDPlane
s 3 (1 | 1%Tem_TL

Em VLEDContent

VLED_Stage Configuration Blueprint
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The Configuration Editor opens.
File  Edit ew Debug W v  Tools  Help

VLED_Stage X

31 Import Export } , #. Class Defaults

y Blueprint = Previe
+add  Q =

#N VLED Stage (Self)

EJcmd v

VLED_Stage Configuration Editor

In the Editor, you'll see the example configuration components in the upper-left section (called STEP
1)

2. Define the screen parameters and add engines or screens as described in Screen Setup.
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Screen Setup

This section describes the steps for defining the screen parameters, adding new engines and screens to
the project and deleting screens.

To define the screen parameters:

1. In the VLED_Stage Configuration Editor, in the Preview window or in the Components panel (STEP
1), select a screen and then move and rotate (if necessary) the screen to position it approximately
where it is located in the physical screen setup.

2. In the Details panel, in the Transform section, set the Y and Z Scale values for each screen to
match the size of the corresponding physical screen in your studio.

3. Measure from the zero point (0,0) of your studio to the bottom-left corner of each upright screen and
to the front-left corner of each floor screen (if applicable) and enter these values into the appropriate
Location fields.

4. When you have finished configuring your screens, in the main tool bar click Save.
To add new engines:

1. In the Cluster tab (STEP 2), select Add New > Add New Cluster Node.
Y4
Mame
Parent Cluster
Preset Full HD (1,920

Adjust Cluster Node Position to Prevent Overlap

Add Viewport to New Cluster Node

Configu

Media

Cancel

Add New Cluster Node

2. In the Add New Cluster Node editor, give the second engine a name (e.g., Voy2) and deselect the
Add Viewport to New Cluster Node option.

3. In the Configuration section of the editor, enter the IP Address of the second engine.
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4. Then select Add.

The new engine is added as a child of the cluster.

8 Cluster

E| node_main (Prir
= vp_left

Add New Engine

5. To assign one or more of the viewports from the first engine to the second engine, select and drag
the viewport from Host_1 - node_main (Primary) to the second engine.

6. Repeat the above steps to add additional engines, giving each one a unique name.
To add new screens to the blueprint:
1. In the Components panel (STEP 1), right-click any of the default screens and select Duplicate to

make a copy.

2. With the new screen selected, in the Details tab on the right, rename it to correspond with one of
the screens in your physical layout.

3. Move the new screen to its approximate location in the blueprint.

4. In the Details tab, in the Transform section, define the size and location of the screen as you did in
the previous section for the default screens.

5. In the main tool bar select Save.
To delete screens:

1. In the Components panel (STEP 1), right-click any of the default screens and select Delete to
remove it.

2. In the main tool bar select Save.
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To export the configuration file:

1. When you have finished configuring your screens, in the main toolbar of the VLED_Stage
Configuration Editor, select Export to save your new configuration file (.ndisplay) in the Content
folder of the project.

The file will replace the existing .ndisplay file and set the export path.

2. Then select the arrow beside the Export icon and select Export on Save.

~  Exporton Save

Export on Save

3. Thereafter, any time a change is saved, it will automatically update the asset and the configuration
file.
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Using Voyager Switchboard Launcher

Voyager Switchboard Launcher is used to automatically launch and quit your Voyager project on all the
engines in your setup simultaneously. The Voyager Switchboard Launcher is located on the master
node. You will need to launch the Voyager Switchboard Listener manually on each cluster node.

To launch Voyager Switchboard Launcher:

1. Select the Voyager Switchboard Launcher desktop icon.

Alternatively, in the menu bar, double-click on the Switchboard icon.

Launch Switchboard

2. When you launch Switchboard for the first time, it will set up a new Python virtual environment.

tras\ThirdPartyNotUE\SwitchboardThirdPar

Python Virtual Environment Setup

Then the Add new Switchboard Configuration window opens.

n Add new Switchbeard Cenfiguration x

Config Path Browse
uProject o ger_Projects\VLED_Set\WLED_Set.uproject Browse
Engine Dir gram File ) \ Browse

Il Perforce

OK Detect Cancel

Add New Switchboard Configuration

3. The Config Path (the name of the configuration file), the uProject path and the Engine Dir field are
automatically populated with the details of the currently open project.

4. Select OK to accept the automatically populated settings or edit the settings as described in the next
section.

To edit the Voyager Switchboard Configuration file:

1. In the Config Path field, enter a new name for the Voyager Switchboard configuration file or select
the Browse button and navigate to the folder containing the configuration file you want to use.

2. Beside the uProject field, select the Browse button and navigate to the project you want to control
with Switchboard.
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3. Beside the Engine Dir field, select the Browse button and navigate to the location of the Voyager
engine on your computer.

4. Select the Detect button to return to the default configuration for the project that is currently open.
5. When you have finished editing the Switchboard configuration file, select OK.

6. The Voyager Switchboard editor opens.

Bl switchboard - IHC_News

Configs Settings Tools

Sequence Defa ult

- Default Map —

{:} Add De: Level:
5

B Line Wrap

Virtual Prc

Session: MU_Session

Voyager Switchboard Editor
To configure Voyager Switchboard Launcher:

1. In the Voyager Switchboard editor, select Add Device and from the drop-down menu, select
nDisplay.

2. In the Add nDisplay Device window, select Browse and navigate to the Content folder of your
Voyager project.

W7 Add nDisplay Device

ConfipFile Ci%oyamer_Projects/ My VLEDPro) ect/CGont entVLED Stage ndisplay * Erowse Populate

o Cancel

Add nDisplay Config File
3. Select the VLEDStage.ndisplay (or VLED_Stage.ndisplay) config file and select Open.
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4. Then, in the Add nDisplay Device window, select OK.

Now you’ll see the virtual LED node displayed in the Switchboard editor along with any Voyager
Switchboard Listeners that are part of your system. Each engine in your system needs to have an
instance of the Voyager Switchboard Listener installed.

Bl switchboard - MyWLEDProject - u X

sequence Default sae Scene

{F Add Device = Level: -~ Default Map --

& N

Hede Con 8| Displa

'I nja Frea Unsyn:

nDispiay Devices Address Changelist & 0o o

. * npode_main 127001 ~ oo

2,3 starting listening ¢

Voyager Switchboard with nDisplay Device Added

5. Select the Connection icon beside each component that you want to connect or select the top-level
icon to connect all the components.

To start a project from Voyager Switchboard Launcher:

¢ In the list of nDisplay Devices, select the arrow for the device you want to start or select the top level arrow to
start all connected devices.

niisplay Devices Address ."% n a

® r. * npode_main 127.0.0.1 : o«

Voyager Switchboard Launcher - Start Connected Device
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To stop a project from Switchboard:

1. Press the Windows key on your keyboard to access the task bar.
2. Select the Voyager Switchboard Launcher icon to open the launcher.
3. In the list of nDisplay Devices, select the X to stop the connected device.

nDisplay Devices Address Changelist e-c-‘. X i

o * node_main 127.000 X -

Voyager Switchboard Launcher - Stop Connected Device
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Using Voyager Switchboard Listener

While only the master node requires an instance of Voyager Switchboard Launcher to be running,
each cluster node in your multi-display network will need to be running an instance of the Voyager
Switchboard Listener in order to receive messages from the Launcher.

When Voyager is installed, a Voyager Switchboard Listener icon is automatically added to the desktop.

To launch the Voyager Switchboard Listener application:

1. Select the 3 vertical dots beside the Launch Switchboard icon on the desktop and select Launch
Switchboard Listener.

Launch Switchboard Listener

Launch Switchboard Listener on Login

Create Config

Launch Switchboard Listener
2. If you get a Windows Security Alert message, select Allow Access to continue.

The Voyager Switchboard Listener opens and is immediately minimized to the taskbar.
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Virtual LED + Set Extension Template

With the Virtual LED template you can render content on multiple displays simultaneously and enhance
your virtual set with set extension. This type of project typically requires several Voyager engines. One
engine is identified as the “"master node” and handles the AR or VS set extension. The additional
engines are identified as “cluster nodes” and feed the LED screens.

There are three components in a Virtual LED + Set Extension setup, as follows:

The nDisplay plugin inside Voyager communicates and synchronizes information amongst all the Voyager
engines that make up the cluster, to make sure all engines render correctly at the same time (enabled
by default).

The Voyager Switchboard Launcher application (located on the master node only) is used to automatically
launch and quit your Voyager project on all the engines in your setup.

The Voyager Switchboard Listener application (running on the master node and each cluster node) listens
for incoming requests from Voyager Switchboard Launcher, and processes those requests on the local
engine.

Virtual LED Rendering Content on Three Screens Simultaneously

Begin by creating a project from the Virtual LED + Set Extension template as described in Creating a
Project from a Template. Then continue with the following steps, which are specific to a Virtual LED +
Set Extension project:

Configuring Your Screen Setup

Capturing Shadows and Reflections

Using Voyager Switchboard Launcher

Using Voyager Switchboard Listener

Using Voyager Color Calibration
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Configuring Your Screen Setup

In your new project, you'll need to match the screens in the project to your physical screen layout. You
define most aspects of the system in the VLEDStage Editor. Here you will define the engines that make
up your network, the size and location of the screens and the viewports to render on each engine.

The VLED+Ext template default configuration is the VLEDStage. This configuration can be altered to
match your physical layout.

If you modify the VLEDStage screen setup, you'll have to also modify the BP_VoyagerGreenScreen
actor so that it matches the screen setup in size and position.

For more information about configuring a green screen, see Using the Voyager Green Screen Model.
The VLEDStage blueprint is configured for two engines. Depending on your screen setup and content,

you may need more engines. In that case, you'll have to add engines to the template and assign
viewports to each engine.

* When running nDisplay projects, the engine runs in Game mode.

K When running in Game mode, the project's Media Profile needs to be set as the Startup Media
Profile. See Selecting the Startup Media Profile for instructions.

To add engines:

1. In the Content Drawer > Content > Voyager > VLEDContent, double-click the VLEDStage
configuration icon to open the editor.

W5 Content Browser

+ Add V3 Import

R

VLEDStage
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The Configuration Editor opens.

Defaulis

= n@ InfoBaro@YAgA® 12

VLEDStage - Configuration Editor

In the Editor, you'll see the example configuration components in the upper-left section (called STEP
1).

2. Define the screen parameters and add engines or screens as described in Screen Setup.
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Screen Setup

This section describes the steps for defining the screen parameters, adding new engines and screens to
the project and deleting screens.

To define the screen parameters:

1. In the VLEDStage Editor, in the Preview window or in the Components panel (STEP 1), select a
screen and then move and rotate (if necessary) the screen to position it approximately where it is
located in the physical screen setup.

2. In the Details panel, in the Transform section, set the Y and Z Scale values for each screen to
match the size of the corresponding physical screen in your studio.

3. Measure from the zero point (0,0) of your studio to the bottom-left corner of each upright screen and
to the front-left corner of each floor screen (if applicable) and enter these values into the appropriate
Location fields.

4. When you have finished configuring your screens, in the main tool bar select Save.
To add new engines:

1. In the Cluster tab (STEP 2), select Add New > Add New Cluster Node.

Add New Cluste|

Full HD (1

Adjust Cluster Mode Position to Prevent Overlap

Add Viewport to New Cluster Node

Configuration

0 Map elements

0 Map elements

Add New Cluster Node

2. In the Add New Cluster Node editor, give the third engine a name (e.g., Voy3) and deselect the Add
Viewport to New Cluster Node option.

3. In the Configuration section of the editor, enter the IP Address of the third engine.
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4. Then select Add.

B outputLog B Cmd v

Add New Engine

5. To assign one or more of the viewports from the second engine to the third engine, select and drag
the viewport from Host_0 - node_virtual_led to the third engine.

6. Repeat the above steps to add additional engines, giving each one a unique name.
To add new screens to the blueprint:

1. In the Components panel (STEP 1), right-click any of the default screens and select Duplicate to
make a copy.

2. With the new screen selected, in the Details tab on the right, rename it to correspond with one of
the screens in your physical layout.

w

Move the new screen to its approximate location in the blueprint.

N

. In the Details tab, in the Transform section, define the size and location of the screen as you did in
the previous section for the default screens.

5. In the main tool bar select Save.
To delete screens:

1. In the Components panel (STEP 1), right-click any of the default screens and select Delete to
remove it.

2. In the main tool bar select Save.

Voyager User Guide (v7.1) Virtual LED + Set Extension Template « 73



To export the configuration file:

1. When you have finished configuring your screens, in the main toolbar of the VLEDStage
Configuration Editor, select Export to save your new configuration file (.ndisplay) in the Content
folder of the project.

The file will replace the existing .ndisplay file and set the export path.

2. Then select the arrow beside the Export icon and select Export on Save.

# ClassD

v Exporton Save
Export on Save

3. Thereafter, any time a change is saved, it will automatically update the asset and the configuration
file.
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Capturing Shadows and Reflections

When there is a floor in your Virtual LED + Set Extension project that is part of the live feed, you will
want to capture the shadows and reflections of some of the AR elements and apply them to the floor.
You won't necessarily want all the virtual elements to cast shadows because part of the extension (the
virtual set) is behind the talent and shouldn't cast unrealistic shadows or reflections on the talent. The
rest of the virtual set does need to cast shadows and reflections on the floor.

You can use an AR Shadow Catcher actor for this, but you'll want to pick which AR objects will cast
shadows and reflections on the Shadow Catcher.

Shadows

For shadows you can use Lighting Channels. The Shadow Catcher actor can use any lighting channel
except channel 1 and the chosen directional lights and AR objects will use the same channel. Lighting
from other lights and objects in the set that are using channel 1 won't affect the Shadow Catcher.

Reflections

For reflections, we can use a native Planar Reflections actor, place it over the Shadow Catcher (to get
the same perspective), and use the Planar Reflections actor options to select which objects to capture
the reflections from. However, the engine still combines the plane reflections with the global reflections
(these could be Screen Space Reflections, Ray Tracing or Lumen), so that using a Planar Reflections
actor is not enough to fully exclude the other actors from affecting the Shadow Catcher. In addition,
there are other forms of reflection captures that could be present in the set, as well as sky reflections,
fog, etc. that the user may not want to have showing on the Shadow Catcher.

In the Planar Reflections actor, use the Use Show Only List option, combined with a list of Show Only
Actors.

In the Voyager Operator, the following Shadow Catcher options are available:

¢ Allow Only Planar Reflections On Shadow Catcher — Only the reflections from Planar Reflections
actors will show on the Shadow Catchers (applies to all Shadow Catchers). All other types of
reflections, sky reflections, sky light, fog, etc. will be prevented from showing on the Shadow Catcher.
This is the recommended option to achieve reflections only for certain objects and nothing else. When
this option is enabled, the next options are not available.

e Disable SSR On Shadow Catcher — Screen space reflections will not affect the Shadow Catchers,
but other reflections beyond the Planar Reflections might, if applicable.

o Disable Reflections Captures and Sky Reflections On Shadow Catcher — Reflection captures and
most of the reflection environment will not affect the Shadow Catchers. Other types of reflections, like
screen space reflections, might if applicable.

Voyager Operator - Shadow Catcher Options
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Using Voyager Switchboard Launcher

Voyager Switchboard Launcher is used to automatically launch and quit your Voyager project on all the
engines in your setup simultaneously. The Voyager Switchboard Launcher is located on the master
node. You will need to launch the Voyager Switchboard Listener manually on each cluster node.

To launch Voyager Switchboard Launcher:

1. Select the Voyager Switchboard Launcher desktop icon.

Alternatively, in the menu bar, double-click on the Switchboard icon.

Launch Switchboard

2. When you launch Switchboard for the first time, it will set up a new Python virtual environment.

tras\ThirdPartyNotUE\SwitchboardThirdPar

Python Virtual Environment Setup

Then the Add new Switchboard Configuration window opens.

n Add new Switchbeard Cenfiguration x

Config Path Browse
uProject o ger_Projects\VLED_Set\WLED_Set.uproject Browse
Engine Dir gram File ) \ Browse

Il Perforce

OK Detect Cancel

Add New Switchboard Configuration

3. The Config Path (the name of the configuration file), the uProject path and the Engine Dir field are
automatically populated with the details of the currently open project.

4. Select OK to accept the automatically populated settings or edit the settings as described in the next
section.

To edit the Voyager Switchboard Configuration file:

1. In the Config Path field, enter a new name for the Voyager Switchboard configuration file or select
the Browse button and navigate to the folder containing the configuration file you want to use.

2. Beside the uProject field, select the Browse button and navigate to the project you want to control
with Switchboard.
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3. Beside the Engine Dir field, select the Browse button and navigate to the location of the Voyager
engine on your computer.

4. Select the Detect button to return to the default configuration for the project that is currently open.
5. When you have finished editing the Switchboard configuration file, select OK.

6. The Voyager Switchboard editor opens.

Bl switchboard - IHC_News

Sequence Defa ult

{+  AddDevice = Level: -- Default Map --

&5

0 Session

Voyager Switchboard Editor
To configure Voyager Switchboard Launcher:

1. In the Voyager Switchboard editor, select Add Device and from the drop-down menu, select
nDisplay.

2. In the Add nDisplay Device window, select Browse and navigate to the Content folder of your
Voyager project.

W7 Add nDisplay Device

ConfipFile Ci%oyamer_Projects/ My VLEDPro) ect/CGont entVLED Stage ndisplay * Erowse Populate

o Cancel

Add nDisplay Config File
3. Select the VLEDStage.ndisplay (or VLED_Stage.ndisplay) config file and select Open.
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4. Then, in the Add nDisplay Device window, select OK.

Now you’ll see the virtual LED node displayed in the Switchboard editor along with any Voyager
Switchboard Listeners that are part of your system. Each engine in your system needs to have an
instance of the Voyager Switchboard Listener installed.

Bl switchboard - MyWLEDProject - u X

sequence Default sae Scene

{F Add Device = Level: -~ Default Map --
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Voyager Switchboard with nDisplay Device Added

5. Select the Connection icon beside each component that you want to connect or select the top-level
icon to connect all the components.

To start a project from Voyager Switchboard Launcher:

¢ In the list of nDisplay Devices, select the arrow for the device you want to start or select the top level arrow to
start all connected devices.

niisplay Devices Address ."% n a

® r. * npode_main 127.0.0.1 : o«

Voyager Switchboard Launcher - Start Connected Device
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To stop a project from Switchboard:

1. Press the Windows key on your keyboard to access the task bar.
2. Select the Voyager Switchboard Launcher icon to open the launcher.
3. In the list of nDisplay Devices, select the X to stop the connected device.

nDisplay Devices Address Changelist e-c-‘. X i

o * node_main 127.000 X -

Voyager Switchboard Launcher - Stop Connected Device
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Using Voyager Switchboard Listener

While only the master node requires an instance of Voyager Switchboard Launcher to be running,
each cluster node in your multi-display network will need to be running an instance of the Voyager
Switchboard Listener in order to receive messages from the Launcher.

When Voyager is installed, a Voyager Switchboard Listener icon is automatically added to the desktop.

To launch the Voyager Switchboard Listener application:

1. Select the 3 vertical dots beside the Launch Switchboard icon on the desktop and select Launch
Switchboard Listener.

Launch Switchboard Listener

Launch Switchboard Listener on Login

Create Config

Launch Switchboard Listener
2. If you get a Windows Security Alert message, select Allow Access to continue.

The Voyager Switchboard Listener opens and is immediately minimized to the taskbar.
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Using Voyager Color Calibration

In Voyager 5.1.1. and newer, you can apply color calibration in VLED+Set Extension workflows.

This process will sample multiple points in every dimension, comparing the colors in the AR part of the
set with the colors in the video wall. A visual representation of the results is shown in the Output
window.

Changes in lighting in the studio can affect the calibration, as can the LED calibration and camera
settings, so if any of these things changes, the calibration would need to be redone. Once done, the
calibration can be reused in other projects, as long as these factors remain the same.

The process takes about 15 minutes.

In a good calibration, most of the mesh will be blue.
e Blue mesh represents colors that were able to be reproduced.
e Green mesh represents colors that were mapped to the closest color possible.

e Orange mesh represents colors that are outside the sampling area.

To add the Voyager Color Calibration asset:

1. In the Outliner, select the VoyagerOperator actor and in Details > Voyager, double-click the
VoyagerOperator icon to open the editor.

2. In the VoyagerOperator editor, in the Virtual LED section, from the Color Correction drop-down,
select Voyager Color Calibration.

@ Voyager Color Calibration

I; Copy

Internal Compositing

Add Voyager Color Calibration
3. Select Save and close the VoyagerOperator editor.

4. In the main Voyager screen, select Save again and close the project.
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To run the Voyager Color Calibration:

1. Launch your project using Voyager Switchboard Launcher.

2. In the Preview window, select the Show Calibration checkbox.

The Voyager Color Calibration asset will begin sampling colors. During the calibration, the RGB
sliders will show the color being calibrated, giving you an idea of the progress.

Debug WEGRNTTE

# Show IEEErElISEE

Color Sampling

3. Deselect the Show Color Calibration checkbox once calibration has started to save on engine
performance while the system is calibrating.

4. When the calibration is finished, select the Save button.
A good color calibration will show a mesh similar to the one in the image below:

'_7'3
VOVYAGER

Vession 5.1 R1 0511 Beta

= Show Teikenlato

Good Color Calibration
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Testing the Calibration

When the calibration is completed and saved, you can use the RGB sliders to test the calibration.
To test the calibration:

1. Touch any of the RGB sliders to enter testing mode.

2. Move the slider to select a color to check the match between the AR extension and the LED wall.
3. Select the Stop button to exit testing mode.

Tips

If during the calibration process, a new color shows up on the AR side (the bar on the right) before the
previous color has appeared in the sampling area (the box outline), increase the Sampling Delay value
to give the calibration more time to sample each point and rerun the calibration.

Increasing the Sampling Steps value will increase the precision of the calibration but will also increase
the time it takes to calibrate.

To run the calibration again:

1. Select the Reset button to reset and initialize the calibration and then select the Start button to
start a new calibration.

Calibration Reset and Start

2. When the calibration is finished, select the Save button.
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Making an Existing Project Compatible

with Voyager

With this method, you'll open an existing non-Voyager project and add the necessary Voyager

components.

The steps for this method are:

Setting up an Existing Project

Creating and Configuring Media Proxies
Selecting or Creating a Media Profile

Creating a Media Bundle

Creating and Configuring the Voyager Operator
Creating and Configuring the Voyager Tracker
Setting Up Compatibility With Voyager
Updating Voyager Project Settings

Organizing Voyager Assets
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Setting up an Existing Project
Any Unreal Engine (UE) project can be made to work with Voyager.

To open an existing project:

1. Navigate to the folder containing the UE project you want to use in Voyager and double-click the
project file (.uproject).

2. In the Select Unreal Engine Version dialog, select the latest version and select OK.

3. In the Content Browser, if the levels aren’t already displayed, select the Filters drop-down and from
the Filters list, select Level.

4. If there is more than one level, double-click the level you want to use in your project to open it in the
viewport.

To set up a Voyager folder structure for your project:

1. In the Content Browser, select the Show or hide the sources panel icon (if necessary), to display
the Content tree.

2. Then select the Content folder and select the Add New button and from the context menu, select
New Folder.

Alternatively, you can right-click the Content folder and from the context menu, select New Folder.
3. Name the folder “Voyager”.
4. With the Voyager folder selected, add the following sub-folders as shown in the image below:

e LiveSources

e Operator

e Proxies

e Tracker

N5 Content Browser

+ ﬁ-dd vl Import

w NewsBroadcast

Content Folder Tree
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Creating and Configuring Media Proxies

You'll need to configure media proxies to provide a connection between your media profile and the
places in your project where the input(s) and output are actually used or generated.

Voyager templates include the media proxies. If you're not using a template, you need to configure
media proxies for your inputs and outputs. Instructions for configuring a media proxy for a composite
input and for an output are provided in this section. For instructions on configuring a media proxy for a
live source, see Creating Live Sources.

To configure a media proxy for a composite input:

1. Select Edit > Project Settings, scroll down to Plugins and select Media Profile.

The Plugins - Media Profile pane opens.

# Project Setiings

Plugins - Media Profile

Export... Import...
o T ved in DefaultGame ini, which is currently writable

Media Profile

have the media prox onfigured. Configure Now

Media Profile Plugin

2. Expand the Advanced section and select the + icon on the Media Source Proxy > Array elements
line, to add a proxy input that will correspond to the input you will create later.

Add Media Input Proxy
3. Select the arrow in the input drop-down and select Create New Asset > Proxy Media Source.
4 Media Profile

Apply in Commandlet

Startup Media Profile

=3
®° ¢°

1 Array elements + @

' ProxyMediaSource_Composite] =
~ KK

Media Output Proxy 0 Array elements + @

-

Add Proxy Media Source
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4. In the Save Asset As window, navigate to the Voyager > Proxies folder and give the asset a name
that will correspond to the composite input (e. g. ProxyMediaSource_Compositel) you will create
later.

5. Select Save.
To configure a media proxy for an output:

1. In the Plugins - Media Profile pane, in the Media Output Proxy section, select the + icon to add an
output proxy that will correspond to the output you will create later.

4 Media Output Proxy 1 Array elements 4= @

E ProxyMediaOutput]

D €D

Add Media Output Proxy
2. Select the arrow in the drop-down and select Create New Asset > Proxy Media Output.

3. In the Save Asset As window, navigate to the Voyager > Proxies folder and give the asset a name
to match the output you will create later (e. g. ProxyMediaOutputl).

4. Select Save and close the Project Settings editor.
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Selecting or Creating a Media Profile

If you do not have a media profile on your engine, you'll need to create one. The media profile defines
the number of inputs being used and configures the inputs and output for your project.

X You will not need a media profile for a Virtual LED project.

Selecting an Existing Media Profile

If you have previously created a media profile on your engine, it will be saved in Engine Content and is
available for use with any project.

To select an existing media profile:

e Select the arrow beside the Media Profile icon, and select the media profile that matches your
requirements.

Accessing the Media Profiles Folder

If you need to create a media profile, you'll need to access a folder in the Engine Content. It is best not
to have the core engine files visible all the time, as inadvertently changing something in these files could
interfere with your Voyager installation. Make them visible only while it is necessary, then hide them
again.

To view engine content:
1. In the bottom-right corner of the Content space, select View Options and select the Show Engine
Content checkbox.

2. Proceed with the instructions for creating a media profile.

3. When you have finished creating your media profile, go back to View Options and deselect the
Show Engine Content checkbox.

4. If you want to reuse the media profile you create here in another project, you'll need to again go to
View Options, select the Show Engine Content checkbox and in the Content Browser navigate to
the profile in the MediaProfile folder.
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Creating a Media Profile

The steps for creating a media profile are described in the following sections:
Creating an Empty Media Profile

Configuring Inputs and Outputs

Configuring the Genlock Settings

Creating an Empty Media Profile

This step creates the container that stores the input and output configurations.

You will not need a media profile for a Virtual LED project.
To create an empty media profile:

1. In the main toolbar, select the 3 vertical dots beside the Media Profile icon.

J;:T‘.-' Platforms H VP Roles w

Media Profile Icon
2. From the drop-down menu, select New Empty Media Profile.
3. In the Pick Media Profile Class section, select the MediaProfile item and select Select.
W Pick Media Pro
COMMON

ALL CLASSES

Q

81 MediaProfile

1item

Cancel

Pick Media Profile Class

4. In the Save Asset As window, select the settings icon to the right of the Search Assets field and
select Show Engine Content.
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5. Then in the Search Folders list, select Content > Engine > Content, scroll down and select the

MediaProfiles folder.
o If the MediaProfiles folder does not exist, right-click Engine > Content and select New Folder to

create a folder named MediaProfiles.

e or right click to creat

0items

Cancel

Save Asset As
In the Name field at the bottom of the Save Asset As window, enter a name for the media profile

you will create and select Save.

e.g., Matrox_1080p_5994_VS.
The new empty media profile is saved in the MediaProfile folder and the Details tab opens.

6.

7. Continue with Configuring Inputs.
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Configuring Inputs

Now you’ll configure your input(s). The instructions in this section describe how to configure a composite
input. If you want to create a live source input, see Creating Live Sources. You'll also need to create a
live source material; see Creating a Live Source Material.

Select your hardware version for the appropriate instructions.

Voyager SDI and 12G

Voyager IP

Voyager SDI and 12G

The configuration instructions in this section are for configuring a composite input for the Voyager SDI
and 12G versions.

If you want to configure an input for a live source, see Creating Live Sources. You will also need to
create a live source material for each live source; see Creating a Live Source Material.

To configure a composite input:

1. Double-click the Media Profile icon in the main tool bar to open the media profile you created, if it is
not already open.

2. Expand the Inputs > Media Sources section, then select the ProxyMediaSource_Compositel drop-
down and select Ross Matrox Media Source.

Genlock

Media Source Input
3. Expand the ProxyMediaSource_Compositel input and then expand RossMatrox to access
Configuration.
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4. Select the Configuration drop-down and in the configuration panel that opens, select the options
described below and select Apply.

The Resolution and Frame Rate options will differ depending on your hardware configuration.

o Input Type: Fill and Key (for a VS with an external keyer) or Fill (for VS with an internal keyer or
AR)

e Device: DSXLE4/8/100F
e Source: Single Link 1 (first composite), Single Link 3 (2nd composite), etc.
¢ Resolution/Standard/Frame Rate: The video format that corresponds to your workflow.

e Key Source: The appropriate key source will be automatically selected, based on your selection of
Source, if using a Matrox card. If using an AJA card, select the appropriate key source manually.

o Keying Mode: Select Shaped (pre-multiplied) or Unshaped (straight alpha).

Fill ® DSXLE4/8/100F ® Single Link 1 HD 720 ® Progressive

® Filland Key SingleLink3 e HD1080 Interlaced Unshaped

Single Link 9

Input Configuration - Composite Input

5. If you intend to use the Timecode Provider, from the Timecode Format drop-down, select VITC.
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6. Expand Video and configure the settings as follows:

Select the Capture Video checkbox.
From the Color Format drop-down, select the color format that works best for your project.
10bit YUV 422 is recommended when using HDR and Wide Color Gamut.

With multiple inputs, there may be a performance cost when using 10bit YUV 422. In this case,
try using 8bit YUV 422,

10bit YUV 422 is not supported in a Fill and Key configuration with an AJA card. In this case you
could use RGBA.

If you have an AJA card with the Interlaced Standard, and you notice field inversion, select the
Invert Interlaced Fields checkbox.

From the Max Num Video Frame Buffer drop-down, select 8 if you are using a Progressive format
or if you are using an Interlaced format, select 16.

From the Input Frame Delay drop-down, select the frame delay that works best for your project.
Video
Capture Video
C Format
Invert Interlaced Fields

Max Mum Video Frame Buffer

Input Frame Delay

Video Configuration - Composite Input
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7. Expand Colorspace and configure the settings as follows:
e From the Colorimetry drop-down, select one of the following options:

> Rec. 709 (HD SDR) for High Dynamic Range (increased levels in the range between bright and
dark) and Standard Dynamic Range

OR
» Rec. 2020 (WCG) for Wide Color Gamut (increased selection of color values)
¢ From the Transfer Function drop-down, select one of the following options:
> SDR (Rec. 1886) — Standard Dynamic Range

» HLG (Rec. 2100) — increases the dynamic range of the video and is compatible with both SDR
and HDR displays

> HDR10 (PQ 1000 nits) — supports a significantly larger range of brightness as SDR, with a
corresponding increase in contrast and a color palette of one billion shades.

LUT Qutput Colorimetry

LUT Output Transfer Function

Colorspace Settings

e Select the Linear Alpha checkbox if the incoming alpha is already linear; the Transfer Function will
not be applied.

Refer to the documentation for your chroma keyer or key source to determine whether or not the
alpha is linear.

e If you selected an 8bit color format in the Video settings, these are the only Colorspace settings
available. Select Save and continue with the output configuration.

e If you selected a 10bit color format in the Video settings, the HDR settings will also be available.
Continue with the next steps to edit HDR settings.

» From the Conversion LUT drop-down, browse to and select the Look Up Table you want to
apply to your color grading.

» From the LUT Output Colorimetry drop-down, select either Rec. 709 (HD SDR) or Rec. 2020
(WCG).

» From the LUT Output Transfer Function drop-down, select either SDR (Rec. 1886), HLG (Rec.
2100) or HDR10 (PQ 1000 nits).

8. Select Save.

Continue with Configuring an Output.
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Voyager IP

The configuration instructions in this section are for the Voyager IP version.

If you want to configure an input for a live source, see Creating Live Sources. You will also need to
create a live source material for each live source; see Creating a Live Source Material.

To configure a composite input:

1. Double-click the Media Profile icon in the main toolbar to open the media profile you created.

2. Expand the Inputs > Media Sources section, then select the ProxyMediaSource_Compositel drop-
down and select Ross Matrox Media Source.

Genlock
Media Source Input
3. Expand the ProxyMediaSource_Compositel input and then expand RossMatrox to access
Configuration.
4. From the Timecode Format drop-down, select VITC.

5. Select the Configuration drop-down and in the configuration panel that opens, select the options
described below and select Apply.

The Resolution and Frame Rate options will differ depending on your hardware configuration.

o Input Type: Fill and Key (for a VS with an external keyer) or Fill (for VS with an internal keyer or
AR)

e Device: Matrox
e Source: IP Flow 1
¢ Resolution/Standard/Frame Rate: The video format that corresponds to your workflow.

Fill - XMIOSQ25/100 [dev
VITC v [l

Fill and Key

2

239.106.1.1 o

1234 W e

IGMP Jain IGMP w2 -

Input Configuration - Composite Input (IP)
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6. Expand the IP section and then expand Primary and configure the settings as follows:
e Select the Enabled checkbox.
¢ In the Remote IP field, enter the IP address of the remote machine.
e Enter the Port number on which the machines will be communicating.
e Expand Secondary and from the IGMP Join drop-down, select IGMP v2.
7. Expand Video and configure the settings as follows:
e Select the Capture Video checkbox.
e From the Color Format drop-down, select the color format that works best for your project.
10bit YUV 422 is recommended when using HDR and Wide Color Gamut.

With multiple inputs, there may be a performance cost when using 10bit YUV 422. In this case,
try using 8bit YUV 422,

10bit YUV 422 is not supported in a Fill and Key configuration with an AJA card. In this case you
could use RGBA.

Leave the remaining settings as they are.

e If you have an AJA card with the Interlaced Standard, and you notice field inversion, select the
Invert Interlaced Fields checkbox.

e From the Max Num Video Frame Buffer drop-down, select 8 if you are using a Progressive format
or if you are using an Interlaced format, select 16.

e From the Input Frame Delay drop-down, select the frame delay that works best for your project.
Video
Capture Vi
Color Format
Invert Interlaced Fields

Max Mum Video Frame Buffer

Input Frame Delay

Video Configuration - Composite Input
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8. Expand Colorspace and configure the settings as follows:
e From the Colorimetry drop-down, select one of the following options:

> Rec. 709 (HD SDR) for High Dynamic Range (increased levels in the range between bright and
dark) and Standard Dynamic Range

OR
» Rec. 2020 (WCG) for Wide Color Gamut (increased selection of color values)
¢ From the Transfer Function drop-down, select one of the following options:
> SDR (Rec. 1886) — Standard Dynamic Range

» HLG (Rec. 2100) — increases the dynamic range of the video and is compatible with both SDR
and HDR displays

> HDR10 (PQ 1000 nits) — supports a significantly larger range of brightness as SDR, with a
corresponding increase in contrast and a color palette of one billion shades.

LUT Qutput Colorimetry

LUT Output Transfer Function

Colorspace Settings

e Select the Linear Alpha checkbox if the incoming alpha is already linear; the Transfer Function will
not be applied.

Refer to the documentation for your chroma keyer or key source to determine whether or not the
alpha is linear.

e If you selected an 8bit color format in the Video settings, these are the only Colorspace settings
available. Select Save and continue with the output configuration.

e If you selected a 10bit color format in the Video settings, the HDR settings will also be available.
Continue with the next steps to edit HDR settings.

» From the Conversion LUT drop-down, browse to and select the Look Up Table you want to
apply to your color grading.

» From the LUT Output Colorimetry drop-down, select either Rec. 709 (HD SDR) or Rec. 2020
(WCG).

» From the LUT Output Transfer Function drop-down, select either SDR (Rec. 1886), HLG (Rec.
2100) or HDR10 (PQ 1000 nits).

9. Select Save.

Continue with Configuring an Output.
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Configuring an Output

There is only one output available in Voyager. You only need to decide whether you want to configure
that output for internal compositing or external compositing. Instructions for both are provided in this
section.

Internal Compositing

To configure an output for internal compositing:

1. In the Outputs section, expand Media Outputs.

2. Then select the ProxyMediaOutputl drop-down and select Ross Matrox Media Output.

Outputs

Timecode Provider

Media Profile - Output Config

3. Expand ProxyMediaOutputl and then expand RossMatrox to access Configuration.

4. Select the Configuration drop-down and in the configuration panel that opens, select the options
described below and select Apply.

The Source, Resolution and Frame Rate options will differ depending on your hardware
configuration.

Output Type: Fill
Device: DSXLE4/8/100F

Destination: The physical pin you are using for your output (different cards will display different
options here)

Resolution/Standard/Frame Rate: The video format that corresponds to your workflow.

Reference: External

Outputs

e Fill ® DSXLE4/8/100F ink 2 HD 720 ® Progre 24 fps Free Run
Fill and Key Single Link6 & HD 1080 Interlaced 25 fps e External

2097 fps Input
30 fps

50 fps

50,94 fps

Output Configuration
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5. Expand Output, select the arrow in the Pixel Format field and select the format that works best for
your project.

10bit YUV 422 is recommended when using HDR and Wide Color Gamut.

With multiple inputs, there may be a performance cost when using 10bit YUV 422, In this case, try
using 8bit YUV 422,

10bit YUV 422 is not supported in a Fill and Key configuration with an AJA card. In this case you
could use RGBA.

6. Select the Parallelize Transfers checkbox to improve performance.
Output frames are transferred faster, which can make a noticeable difference in 4K projects.
7. Leave the remaining settings as they are and select Save.

Continue with Configuring the Genlock Settings.
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External Compositing

To configure an output for external compositing:

1. In the Outputs section, expand Media Outputs.

2. Then select the ProxyMediaOutputl drop-down and select Ross Matrox Media Output.

3. Expand ProxyMediaOutputl and then expand RossMatrox to access Configuration.

4. Select the Configuration drop-down and in the configuration panel that opens, select the options
described below and select Apply.

The Resolution and Frame Rate options will differ depending on your hardware configuration.

Output Type: Fill and Key
Device: DSXLE4/8/100F

Destination: The physical pin you are using for your output (different cards will display different
options here)

KX For AJA cards, the Destination and Key Destination pins need to be adjacent (e.g., Destination
= Out 1 and Key Destination = Out 2).

Resolution/Standard/Frame Rate: The video format that corresponds to your workflow.

Key Destination: The appropriate key destination will be automatically selected, based on your
selection of Destination, if using a Matrox card. If using an AJA card, select the appropriate key
destination manually.

X For AJA cards, the Destination and Key Destination pins need to be adjacent (e.g., Destination
= Out 1 and Key Destination = Out 2).

Reference: External

Standard

& DSXLE4/8/100F ® Single Link 2 HD 720 ® Progressive 5 Free Run

® Fill and Key & HD1080 Interlaced ® External

9.97 fps
ey Input

30fps

59.94fps
60 fps

Output Configuration - External Compositing

5. Expand Output, select the arrow in the Pixel Format field and select the format that works best for
your project.

10bit YUV 422 is recommended when using HDR and Wide Color Gamut.

With multiple inputs, there may be a performance cost when using 10bit YUV 422. In this case, try
using 8bit YUV 422,

10bit YUV 422 is not supported in a Fill and Key configuration with an AJA card. In this case you
could use RGBA.

6. Select the Parallelize Transfers checkbox to improve performance.

Output frames are transferred faster, which can make a noticeable difference in 4K projects.
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7. Leave the remaining settings as they are and select Save.

Continue with Configuring the Genlock Settings.
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Configuring the Genlock Settings

Once you have your input(s) and output configured, the last step is to configure the Genlock settings.
The settings will depend on the type of graphics card you have in your engine. Select the appropriate
instructions below:

To configure the Genlock Settings for a Matrox card:

1. In the Genlock section, select the Override Project Settings checkbox.

Genlock Configuration - Matrox
2. Select the Custom Time Step arrow and from the drop-down select Ross Matrox SDI Input.

3. Expand Custom Time Step and then expand Genlock and select the Use Media Output Settings
checkbox.

4. Select Save and close the Media Profile window.
To configure the Genlock Settings for an AJA card:

1. In the Genlock section, select the Override Project Settings checkbox.

Genlock Configuration - AJA

2. Select the Custom Time Step arrow and from the drop-down select AJA SDI Input.

3. Expand Custom Time Step and then expand Genlock and select the Use Media Output Settings
checkbox.

This forces the AJA Custom Time Step to use the Genlock settings configured on the first AJA Media
Output of the Media Profile.

4., Select Save and close the Media Profile window.

Continue with Updating Voyager Project Settings.
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Updating Voyager Project Settings

Once you've set up your project, it's time to update the Voyager project settings.
To update the project settings:

1. Select the 3 vertical dots beside the Voyager icon and select Select a Voyager Operator >
VoyagerOperator.

2. Then select Update Project Settings.

Lucid

New Voyager Operator

VoyagerOperator >

Update Project Settings

About Voyager

Updating Voyager Project Settings
3. In the Voyager Project Defaults dialog, select Yes to proceed.

Continue with Selecting the Startup Media Profile.
Selecting the Startup Media Profile

If you want to run your project in Game mode (Voyager Node or nDisplay), you will need to select the
Startup Media Profile.

To select the Startup Media Profile:

1. Select Edit > Project Settings > Plugins > Media Profile.

2. In the Media Profile plugin, from the Startup Media Profile drop-down, select the media profile you
created for your project and then close the Project Settings editor.

[Bearch Details
4Plugins - Media Profile

T These settings are

4 Media Profile

Matrox_1080p_ARVS

+* 0

-

Select Startup Media Profile
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Creating a Media Bundle

You need to create a media bundle asset for each input in your project. This will allow the asset to be
controlled by other applications.

To create a media bundle:

1. Navigate to the Voyager > LiveSources folder.

2. Right-click in an empty section of the Content pane and select Media > Voyager Composite Media
Bundle (for a composite input) or Media > Media Bundle (for a live source input).

Live Link
Materials
Media

- A Proxy Media Output
Lf

Proxy Media Source
Miscellaneocus
ay

Paper2D

Ross Matrox Media Output
Physics Ross Matrox Media Source
Sounds

Textures Stream Media Source

WOWOW W N W W N W

User Interface
Iﬁ Voyager Color Calibration

Tl = : :
¢¥. Voyager Composite Media Bundle

Create VoyagerComposite Media Bundle

3. In the Content pane, rename the Media Bundle asset to associate it with a composite input (e.g.,
VoyagerComposite_1) or a live source input (e.g., LiveInput_1).

The InnerAssets folder is created automatically.
4. Double-click the media bundle you created to open the Details tab.
5. From the Mode drop-down, select the chroma keyer mode you need for your project.

6. From the Media Source drop-down, select Proxy Media Source.
& Details
Q

Media Bundle

Select Media Source

7. Expand Media Source and Media Proxy and from the drop-down, select the proxy media source to
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be used with that media bundle.

Media Bundle

Aja Media Source

'z File Media Source

) Img Media Source

‘s Platform Media Source
Proxy Media Source
Ross Matrox Media Source

“% Stream Media Source

Copy

] Clear

Select Proxy Media Source
8. Repeat steps 2 to 7 for each input in your project.

9. Select Save and close the Details tab.
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Creating and Configuring the Voyager Operator

The next step in the process is to create and configure the Voyager Operator.

To create and configure the Voyager Operator:

1. In the main toolbar, from the Voyager drop-down, select New Voyager Operator.

2. In the Save Asset As window, navigate to the Voyager > Operator folder and enter a name for the
operator (e.g., VoyagerOperator) and select Save.

The VoyagerOperator editor opens and the VoyagerOperator_InnerAssets folder is automatically
created.

" VoyagerOperator

B

Ca

. Details

Internal

ntent Drawer ﬂ Qutput Log Cmd ~
VoyagerOperator Editor

3. In the VoyagerOperator editor, in the Voyager section, from the Compositing Mode drop-down,
select the appropriate option.

The options are:
e Internal

o External

e Portal

e nDisplay
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4. From the Tonemapping drop-down, select the Tonemapper you want to use.
The options are:

Native (broadcast tonemapper off) — The Unreal Engine native tonemapping and post-processing
will be applied to everything in the level, including the incoming camera feeds. This setting is not
recommended in internal compositing as the look of the camera feeds will be affected.

Broadcast — A broadcast tonemapping (designed to preserve the look of the incoming camera feed)
will be applied to everything in the level. Post-processing will affect everything in the level, including
the incoming camera feeds

Hybrid (composited layers only) — A broadcast tonemapping (designed to preserve the look of the
incoming camera feed) will be applied only to the incoming camera feeds. Native tonemapping and
post-processing will only affect the graphics, not the incoming camera feeds used for the composite
layers. This is the recommended option.

Hybrid ( no color grading) — Similar to the Hybrid (composited layers only) option, but also
disables the color grading post-processing options on the rest of the set, so that the broadcasting
tonemapper is used everywhere. Unlike the Broadcast option, the other post-processing effects can
still be applied to the rest of the set, while not affecting the composited layers.

5. From the Internal Compositing Mode drop-down, select from the following:

Auto-detect — uses Linear compositing (engine default) unless the Voyager Media Bundle on the first
compositing layer is set to External Keying and Tonemapping is set to Hybrid.

Linear — recommended for multiple compositing layers, as it supports the most features and layering
combinations.

Non-Linear — recommended for a single layer using external keying, as it supports fewer layering
and post-processing combinations but replicates the external compositing typical of broadcast
devices.

X In Non-Linear mode, pixels in the virtual graphics that are hidden by composite objects will still

generate bloom, as if they were visible. This mode is intended for use with external keyers. It could
have undesired effects on the edges of internal chroma keyers.

* Additional live sources that are fill-only without using chroma keying can be used in either mode,
based on the nature of the main composite's keying method.

6. In the Outputs section, select the + icon to add one Array element.
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7. Select the Output drop-down and scroll down to select the proxy output (ProxyMediaOutput) you
created earlier.

Hybrid (composited layers only) » [l

1 Array elements == @ 2

1 Virtual LED
I Internal Compositing
- External Compositing

Project Settings

Select Proxy Media Output

8. If you selected External in Step 3, in the External Compositing section, from the drop-down select
whether you are using a Virtual Set or Augmented Reality. Then select Save and close the
VoyagerOperator editor.

OR

If you selected Internal in Step 3, you'll need to add a Voyager Composite Media Bundle.

To add a Voyager Composite Media Bundle:

1. In the Voyager Operator editor, expand the Internal Compositing section.

2. Select the + icon in the section Compositing Layers to add an array element.
3. Expand Index [0] and add an array element to the Layer Inputs section.
4

. From the Layer Inputs drop-down, select Create New Asset > Voyager Composite Media Bundile.

Internal Compositing

Layer Inputs

Add Voyager Composite Media Bundle

5. In the Save Asset As window, navigate to the Voyager > Live Sources folder and enter a name for
the media bundle (e. g. VoyagerComposite) and select Save.

The VoyagerComposite_InnerAssets folder is automatically created.
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6. If you will not have a live background in your project, select Save and close the VoyagerOperator
editor.

If you do want a live background in your project, continue with To configure a live background.

To configure a live background:

1. Select the Live Background element drop-down and select Create New Asset > Voyager
Composite Media Bundle.

Internal Compositing

Layer Inputs

Voyager Composite Live Background

2. In the Save Asset As window, navigate to the Voyager > Live Sources folder and enter a name for
the media bundle (e.g., VoyagerComposite_Live) and select Save.

The VoyagerComposite_Live_InnerAssets folder is automatically created.

3. Then double-click on the Live Background icon and in the Details tab, from the Mode drop-down,
select AR+VS Set Extension.

This mode will work for either an augmented reality project or a virtual set project.

& Details

Voyager Composite - Live Source Details

4. From the Keyer Mode drop-down, select the chroma keyer mode you want to use, typically the
Internal Chroma Keyer.

5. From the Background Mode drop-down, select Live Background.
6. Select Save and close the VoyagerComposite_Live Details tab.
7. In the VoyagerOperator editor Details tab, select Save and close the editor.

Continue with Creating and Configuring the Voyager Tracker.
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Creating and Configuring the Voyager Tracker

The next step is to add a Voyager Tracker actor to the project and configure it as needed.

Service Location Protocol

Voyager supports the Service Location Protocol (SLP) which allows auto-discovery of the existence,
location, and configuration of networked services. This feature is enabled by default, but if you want to
use it, you need to ensure that Port 427 is enabled.

The following services can be found when SLP is enabled:
e Voyager (engine): service:voyager.rossvideo

e Voyager API: service:api.voyager.rossvideo

e Voyager Trackless: service:trackless.voyager.rossvideo
e Lucid: service:lucid.voyager.rossvideo

e Voyager Tracker: service:tracker.voyager.rossvideo

If you find that the networked services are not being discovered you can test the SLP using OpenSLP.
See Appendix B: Testing SLP.

To create the Voyager Tracker:

1. In the Content Drawer, navigate to the Voyager > Tracker folder.

2. Right-click in the empty space and select Media and then Voyager Tracker at the very bottom of the
menu and give it a name (e.g., VoyagerTracker).

Animation

&7 Platform Media Source

Artificial Intelligence

-3 Proxy Media Output
les Editor =
Editor Utilities 1 Proxy Media Source
Foliage
FX Ross Matrox Media Qutput
Gameplay
Input ! Ross Matrox Media Source
Live Link
Materials
Media

Miscellaneous

78 Stream Media Source
Voyager Composite Media Bundle

l_/ﬁ\_l Voyager Media Frame Output

| Voyager Operator

Sounds

Textures

WOW W W W WY YW R YW Y Y Y Y W W Y W Y Y

@u Voyager Tracker

User Interface

Add Voyager Tracker

The VoyagerTracker_InnerAssets folder is automatically created.
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To configure the Voyager Tracker:

1. In the Content pane, double-click VoyagerTracker to open the VoyagerTracker Details tab.

File Edit t Window Tools

\V4

@ wvoyagerTracker x

& Details

VoyagerTracker - Details
In the Details tab, the UDP Portis by default, the same as the default port in Lucid Track.
If you need to change the port in either Voyager or Lucid Track, it needs to be changed in both.

2. The Enable SLP (Service Location Protocol) checkbox is selected by default. Clear the checkbox if you
do not want to use it.

3. The Queue Size setting needs to be larger than the Target Buffer Depth to allow more tracking
packets to be held in the queue and released when appropriate.

The Target Buffer Depth setting is used to create a delay in the application of the tracking data, to
align with the incoming video feed.

Increasing the value increases the delay of the tracking data.

4. In the Scene Units field, leave the units at the default setting of cm.

5. In the Tracker Units field, ensure that the units selected match the units set in your renderer.
The default Sensor Size values should work for most broadcast situations.

The default Rotation Order values do not need to be changed.
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6. From the Lens Distortion Method drop-down, select a lens distortion type as follows:
e Select Lucid Track if you are using a lens distortion type from the list in Lucid Track.
e Select Spherical if you are using a lens with spherical distortion curves.
e Select Overscan Only if you are using the Portal effect.
e Select None if you are not using lens distortion.

7. Leave the Lens Distortion Overscan setting at 0.15.
Increasing this value may cause performance issues.

The Lens Distortion Displacement Map is automatically created when the Tracker is created and
needs no change.

8. In the Log Anomalies section, enter or use the arrows to select a value for each of the following
options. A value of "0” indicates that it is disabled.

Variation Threshold Position — log variations in position between two tracking packets if beyond
this threshold.

Variation Threshold Rotation — log variations in rotation between two tracking packets if beyond
this threshold

Variation Threshold FOV — log variations in FOV between two tracking packets if beyond this
threshold.

9. Select Save and close the VoyagerTracker Details window.

Continue with Setting Up Compatibility With Voyager.
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Setting Up Compatibility With Voyager

To make your project compatible with Voyager, you'll need to add a Voyager Camera Actor to the level.
Then you will add the assets you created in the previous sections and configure them to connect with
each other.

Which assets you add depends on whether you're doing internal compositing or external compositing.
You will need to add a Voyager Camera Actor for either method.

e Internal Compositing: VoyagerOperator, VoyagerTracker and VoyagerComposite

e External Compositing: VoyagerOperator and VoyagerTracker

If you have more than one level in your project you need to add these assets to each level.

To add a Voyager Camera Actor to the scene:

1. If you haven't already opened the project level, open the project Maps folder and select on the level

now to open it.

2. In the Place Actors tab, select the Voyager category and drag the Voyager Camera Actor into the
level.

By default the Voyager Camera Actor will be named VoyagerCameraActor1.
.+ Place Actors

Q

L] e
O f ®g@
O e
VOYAGER

Voyager Camera Actor

. .\. Voyager Operator Actor
} Yag

. /\ Voyager AR Composite (Background)

Place VVoyager Camera Actor
3. For External Compositing - AR only:

In the Outliner, delete any actors that aren’t necessary (e.g., Atmospheric Fog, Floor, Player Start,
Sky Sphere, SkyLight, SphereReflectionCapture).

Voyager User Guide (v7.1) Making an Existing Project Compatible with Voyager + 113



4. In the Outliner, with VoyagerCameraActorl selected, in the Details tab, in the Transform section,
make sure that the Location Z position value is set to 0.0 (or at the same level as the virtual floor if
it is not at 0.0).

<) VoyagerCameraActorl

<. VoyagerCameraActor] (Instance)

Q
General

Transform

1800 *
1.0

Movable

Position the VoyagerCameraActor at Floor Level

5. Maneuver the Voyager Camera Actor in the scene using the X and Y arrows (one at a time) to the
position needed for the view you want to show.

The Location and Rotation values in the Transform section will adjust accordingly.

6. Press Play to verify the final location of the camera in the virtual world.

7. If you're not seeing what you expect to see, your camera actor may be turned the wrong way. Try
changing the Z Rotation value (e.g., change it to 180.0, if it is currently 0.0).

To add assets:

e In the Content Browser:

» Open the Voyager > Operator folder and then select and drag VoyagerOperator into the level.

The location of the VoyagerOperator actor in the scene is not important. It can be placed
anywhere.

» Open the Tracker folder and then select and drag VoyagerTracker into the level.
The location of the VoyagerTracker actor in the scene is not important. It can be placed anywhere.

» Open the LiveSources folder and then select and drag your VoyagerComposite(s) and live

background (if using) into the level (for internal compositing only, these assets are not required for
external compositing).

If you are creating an AR or VS project with set extension, in the Place Actors list, select Voyager
and then select either the Voyager AR Composite (Background) Blueprint or the Voyager VS
Tracked Composite (Keyer) Blueprint and drag it into the scene. The selected actor will
automatically be populated with the settings that were configured in the VoyagerO perator asset.

» Scroll down to the Voyager Content > Blueprints folder and then select and drag the
FreeRoamingCamera into the level, if you are using one.
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To configure VoyagerOperator:

1. In the Outliner tab, select VoyagerOperator.

2. In the Details tab, in the Tracking tab, select the + icon to add one Tracker Actor Array element
and from the drop-down for the new element, select VoyagerTracker.

w Tracking

Multi Cam Prepare.

Add Voyager Tracker Actor
To configure VoyagerTracker:

1. In the Outliner tab, select VoyagerTracker.

2. In the Details tab, in the Tracking tab, from the Camera Actor drop-down, select
VoyagerCameraActorl.

3. From the Tracking Origin drop-down, select one of the following tracking origin positions:
e Relative to Camera Actor
e Relative to Tracker Actor
e Absolute (Relative to World Origin)
4. Select the Track In Editor checkbox to enable camera tracking.
LD
£ VoyagerTracker
7 WoyagerTracker (Instance)
Genera

Tracking

Configure VoyagerTracker
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5. Select the Show Visual Helpers checkbox if you want to check that the units of distance between
VoyagerTracker and the VoyagerCameraActor are correct.

e If you are using external compositing, your project setup is now complete.

e If you are using internal compositing, continue with the next section, To configure the Voyager
Composite actor.

To configure the Voyager Composite actor:

1. In the Outliner tab, select VoyagerCompositel.

2. In the Media Bundle section, from the Media Bundle drop-down, select the VoyagerCompositel
media bundle.

3. Make sure the front side of the VoyagerCompositel actor is facing you.
4. If you don't see a white face on the VoyagerCompositel actor:

a. In the Details tab, in the Plane Visualization tab, select the Visualize Plane checkbox and select
a color that will make it easy to see the plane in the viewport.

Plane Visualization

Visualizati

Plane Visualization

b. In the Transformation section, use the Y Rotation value to rotate the VoyagerCompositel actor
until you see the white face. For example, if the Y Rotation value is 0.0, change it to 180.0.

c. Deselect the Visualize Plane checkbox.

5. In the Media Bundle section, select the Request Play Media button.
Media Bundle

Request Play Media

Configure VoyagerCompositel

6. In the Tracking section, from the Tracker Actor drop-down, select VoyagerTracker.

Your project setup is now complete.

116 « Making an Existing Project Compatible with Voyager Voyager User Guide (v7.1)



Updating Voyager Project Settings

Once you've set up your project, it's time to update the Voyager project settings.

To update the project settings:

1. Select the 3 vertical dots beside the Voyager icon and select Select a Voyager Operator >

VoyagerOperator.

2. Then select Update Project Settings.

1 =i TE
Lucid Voyager

New Voyager Operator
VoyagerOperator >

Update Project Settings

About Voyager

Updating Voyager Project Settings

3. In the Voyager Project Defaults dialog, select Yes to proceed.
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Adding Voyager Color Calibration

If you are making an nDisplay with set extension project compatible with Voyager and want to ensure
consistent colors across your displays, you can add and run the Voyager Color Calibration asset to
your project. This is available in Voyager 5.1.1 and newer versions.

This process will sample multiple points in every dimension, comparing the colors in the AR part of the
set with the colors in the video wall. A visual representation of the results is shown in the Output
window.

Changes in lighting in the studio can affect the calibration, as can the LED calibration and camera
settings, so if any of these things changes, the calibration would need to be redone. Once done, the
calibration can be reused in other projects, as long as these factors remain the same.

The process takes about 15 minutes.

In a good calibration, most of the mesh will be blue.

e Blue mesh represents colors that were able to be reproduced.

e Green mesh represents colors that were mapped to the closest color possible.
e Orange mesh represents colors that are outside the sampling area.

If after calibration, the mesh is not mostly blue, you can make some adjustments and run the calibration
again. See Adjusting the Voyager Color Calibration.

To add the Voyager Color Calibration asset:

1. In the Outliner, select the VoyagerOperator actor and in Details > Voyager, double-click the
VoyagerOperator icon to open the editor.
2. In the VoyagerOperator editor, in the Voyager section, from the Compositing Mode drop-down, select nDisplay.

3. In the Virtual LED section, select the Use Main Cluster for Set Extension checkbox.

4. Also in the Virtual LED section, from the Color Correction drop-down, select Voyager Color
Calibration.

@ Voyager Color Calibration

' Copy

Add Voyager Color Calibration

5. Select Save and in the Apply Voyager Operator to Project confirmation dialog, select Yes.
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6. Close the Voyager Operator editor and in the main Voyager screen, select Save again and close the
project.

To run the Voyager Color Calibration:

1. Launch your project using Voyager Switchboard Launcher.
2. In the Preview window, select the Show Calibration checkbox.

The Voyager Color Calibration asset will begin sampling colors. During the calibration, the RGB
sliders will show the color being calibrated, giving you an idea of the progress.

ok 1L 165667 0. 1.0 00890
N7 e 1R
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Color Sampling

3. Deselect the Show Color Calibration checkbox once calibration has started to save on engine
performance while the system is calibrating.

4. When the calibration is finished, select the Save button.
A good color calibration will show a mesh similar to the one in the image below:

m Show TEEkelnto

Good Color Calibration
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Testing the Calibration

When the calibration is completed and saved, you can use the RGB sliders to test the calibration.
To test the calibration:

1. Touch any of the RGB sliders to enter testing mode.

2. Move the slider to select a color to check the match between the AR extension and the LED wall.
3. Select the Stop button to exit testing mode.

Tips

If during the calibration process, a new color shows up on the AR side (the bar on the right) before the
previous color has appeared in the sampling area (the box outline), increase the Sampling Delay value
to give the calibration more time to sample each point and rerun the calibration.

Increasing the Sampling Steps value will increase the precision of the calibration but will also increase
the time it takes to calibrate.

To run the calibration again:

1. Select the Reset button to reset and initialize the calibration and then select the Start button to
start a new calibration.

Calibration Reset and Start

2. When the calibration is finished, select the Save button.
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Organizing Voyager Assets

It's helpful from an organizational standpoint to create a Voyager folder in the Outliner to contain the
Voyager assets.

To create a Voyager folder in the Outliner:

1. In the Outliner, select one of the Voyager assets you created.
2. Select the + symbol to the right of the Search field.
A new folder is created and the selected asset is placed inside the folder.
3. Name the new folder Voyager.
4. Right-click on each Voyager asset and at the bottom of the context menu, select Move To.
Alternatively, you can press Shift and select to select multiple assets and move them all at once.
5. From the folder list, select the Voyager folder you just created.
If you have a long list of folders, start typing “voyager” in the Search field to find the Voyager folder
quickly.
= World Outliner

Y
Label

-
W

-
W

-
M S
m T T

-
W

omponents

= (7 Voyager

5 b X |
5 b ase C ]
- P 3P_Fre

-
W

aming_Cam

im

-
|
L

Voyager Folder in Outliner

Voyager User Guide (v7.1) Making an Existing Project Compatible with Voyager * 121



Using Multiple Composite Inputs in
Your Project

You can have multiple media sources playing in your virtual set at the same time.The composite planes
on which the media sources will be displayed can be on a single layer or on up to 3 separate layers. You
can display the same media source on multiple composite planes or have a different media source on
each plane. The total number of composite planes you can have will depend on the size and complexity
of your project.

There are some considerations to keep in mind when using multiple composites and multiple layers:

e Having only one composite on a layer is less costly in terms of performance, than having several
composites on a layer; so if you have more than one composite, it's best to put them on separate
layers.

e Each additional layer adds to the performance cost.

e Using a custom mesh for a composite is more costly than using the default mesh; so if you do want to
use a custom mesh, it's best to put it on the same layer as another composite.

e Although in most situations, the compositing layers can be in any order, it is recommended that you
place the compositing layers in the same order as they appear in the scene (starting from the back),
whenever possible, particularly if there are some objects with translucent materials in between the
compositing layers.

e If more than 2 compositing layers are overlapping in regions where they are all semi-translucent, the
results may not be accurate.

e Voyager supports having a clean live source composite with up to two keyed talent trackless
composite planes side by side on top of it. Performance may vary, depending on the configuration.
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Adding Composite Inputs

If you are using one of the Voyager project templates, there will be one composite array element with
one layer and one input already set up.

You will need to add a VoyagerCompositeMediaProxy for each composite plane you intend to have in
your project. See Creating a Media Source Proxy for instructions.

If you don't already have a media profile set up, you will need to create one. See Creating a Media
Profile for instructions.

Prior to adding composite inputs, you will need to add a VoyagerCompositeMediaBundle for each
composite plane you intend to have in your project. See Creating a Media Bundle for instructions.

To add composite inputs:

1. In the Outliner, select the VoyagerOperator actor.

2. In the VoyagerOperator Details tab, scroll down to the Voyager section and double-click the
VoyagerOperator icon to open the Details editor.

3. In the VoyagerOperator Details editor, in the Internal Compositing section, expand the
Compositing Layers section.

If you are adding composite inputs to a Voyager template, Layer 1 (Index 0) will already have 1
composite configured.

4. If you want to have composites on more than one layer, select the + icon beside the Compositing
Layers Array elements to add another layer (called Index [1]).

5. In any layer, in the Layer Inputs line, select the + icon to add a composite input.

VoyagerOperator - Add Composite Inputs
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6. Then from the Layer Input drop-down, select the Media Bundle for the input source you want to
use.

Voyager Composite Media Bundle

# Edit
I Copy

" Clear
External Compositing

Select Media Bundle

Repeat steps 5 and 6 to add as many composite inputs on each layer as you need.

Now you can add a Composite Actor for each composite you added in the above steps
See Adding the Composite Actor(s) to the Set.
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Adding the Composite Actor(s) to the Set

Now that the composite inputs have been added and configured, you need to add a composite actor to
your set for any additional composite inputs you've configured and assign a media bundle to each
composite.

*If you only require one composite input, and you are using a template, that is already set up in the
template and has a media bundle assigned to it and you can skip these instructions.

You may want to exclude one or more composite planes from the view of other cameras, perhaps when
showing only a portion of the camera feed on one plane. In this case, you'll need to add a camera actor
for the composite plane you want to exclude and assign the camera to that composite. See To exclude a
composite plane from the view of other cameras.

To add composite inputs to the set:
1. In the Place Actors tab, from the Voyager category, select one of the following actors for each
composite in your project:
e Voyager AR Composite (Background) Blueprint
e Voyager VS Tracked Composite (Keyer) Blueprint
e Voyager Source Composite Blueprint (for use on a video wall)

e Voyager Trackless Composite Blueprint (for use on a composite plane; available only in the
Trackless template)

®; Place Actors

VOYAGER

Voyager Camera Actaor

Voyager Operator Actor

Voyager AR Col e (Background) Blueprint

Voyager VS Tracked Composite (Keyer) Blueprint

Voyager Source Composite Blueprint

Voyager Track mposite Blueprint

Voyager Green Screen Model

Select Composite Actor

2. Drag the blueprint into the level and position it where you want it.
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3. In the Outliner, right-click the first BP_MediaBundleActor you brought in and rename it to
something meaningful.

4. In the Details tab, select the All button and in the Media Bundle section, from the Media Bundle
drop-down, select the media bundle you want to assign to the composite.

The composite actor you drag into the level will automatically pick up the first media source that has
been set up in the VoyagerOperator, but you may want to change this.

5. Repeat steps 3 and 4 for each composite you brought into the level.

6. Select Save Current.
To exclude a composite plane from the view of other cameras:
1. In the Place Actors tab, from the Voyager category, select and drag a Voyager Camera Actor into

the level.

2. Position the Voyager Camera Actor to point towards the composite you want to exclude from other
views.

3. In the Outliner, select the composite you want to exclude.

4. In the Details tab, in the Tracking section, select the Exclude from Other Views checkbox.

r Tracking

Voyager Composite - Exclude from Other Views

5. Then, from the Trackless Camera drop-down, select the camera actor you added to assign it to this
composite.

126 « Using Multiple Composite Inputs in Your Project Voyager User Guide (v7.1)



Creating Live Sources

This section describes the procedure for creating a live video source that can be displayed on a surface
in the scene. The procedure is the same whether you're using Internal or External compositing.

If you want to create multiple live sources that are "clean" (they have no TAA, post-processing,
broadcast tonemapper, etc.), refer to Using Multiple Composite Inputs in Your Project.

The steps for this process are:

Configuring a Proxy Media Source for a Live Input
Configuring a Live Input

Creating a Media Bundle for a Live Source

Creating a Live Source Material

Configuring a Proxy Media Source for a Live Input

To be able to add one or more live inputs to your project, you'll first need to add an equal number of
media source proxies.

To add a proxy media source for a live input:

1. In the main menu, select Edit > Project Settings and scroll down to the Plugins section.
2. Select Media Profile.
3. Expand Advanced and then expand the Media Source Proxy section.

4. Select the + icon to add an Array element (Index [#]).

Proxy Media Source

Proxy Media Source for a Live input
5. From the new element drop-down, select Create New Asset > Proxy Media Source.

6. In the Save Asset As window, navigate to the Voyager > Proxies folder and in the Name field,
enter a name for the proxy (e.g., ProxyMediaSource_Livel).

7. Select Save and close the Project Settings window.
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Configuring a Live Input
You can have several live inputs displayed on various surfaces in the project scene.
To configure a live input:

1. In the main toolbar, double-click the Media Profile icon to open the media profile you created in an
earlier step.

2. In the Details editor that opens, expand the Inputs > Media Sources section, then select the
ProxyMediaSource_Livel drop-down and select Ross Matrox Media Source.

Live Media Source Input
3. Expand the ProxyMediaSource_Livel input and then expand RossMatrox to access Configuration.

4. Select the Configuration drop-down and in the configuration panel that opens, select the options
described below and select Apply.

The Resolution and Frame Rate options will differ depending on your hardware configuration.
Input Type: Fill

Device: DSXLE4/8/100F

Source: Single Link 3 (or any pin not being used by another media source)

Resolution/Standard/Frame Rate: The video formats that correspond to your workflow.

DSXLE4/8/100F Single Link 1 HD 720
Fill and Key Single Link 3 & HD 1080 Interlaced

Single Link 5
i 2997 fps

Single Link 7

30fps
501ps
59.94 fps

Single Link 9

single Link 11

Apply

Input Configuration - Live Input
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5. Expand Video and configure the settings as follows:
e Select the Capture Video checkbox.
e From the Color Format drop-down, select the color format that works best for your project.
10bit YUV 422 is recommended when using HDR and Wide Color Gamut.

With multiple inputs, there may be a performance cost when using 10bit YUV 422, In this case,
try using 8bit YUV 422,

10bit YUV 422 is not supported in a Fill and Key configuration with an AJA card. In this case you
could use RGBA.

e From the Max Num Video Frame Buffer drop-down, select 8 if you are using a Progressive format
or if you are using an Interlaced format, select 1 or 16.

e From the Input Frame Delay drop-down, select the frame delay that works best for your project.

Video Configuration - Composite Input
6. Expand Colorspace and configure the settings as follows:
e From the Colorimetry drop-down, select one of the following options:

> Rec. 709 (HD SDR) for High Dynamic Range (increased levels in the range between bright and
dark) and Standard Dynamic Range

OR
» Rec. 2020 (WCG) for Wide Color Gamut (increased selection of color values)
e From the Transfer Function drop-down, select one of the following options:
> SDR (Rec. 1886) — Standard Dynamic Range

» HLG (Rec. 2100) — increases the dynamic range of the video and is compatible with both SDR
and HDR displays

> HDR10 (PQ 1000 nits) — supports a significantly larger range of brightness as SDR, with a
corresponding increase in contrast and a color palette of one billion shades.

LUT Output Colorimetry

LUT Output Transfer Function

Colorspace Settings
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e Select the Linear Alpha checkbox if the incoming alpha is already linear; the Transfer Function will
not be applied.

Refer to the documentation for your chroma keyer or key source to determine whether or not the
alpha is linear.

e If you selected an 8bit color format in the Video settings, these are the only Colorspace settings
available. Select Save and continue with the output configuration.

e If you selected a 10bit color format in the Video settings, the HDR settings will also be available.
Continue with the next steps to edit HDR settings.

» From the Conversion LUT drop-down, browse to and select the Look Up Table you want to
apply to your color grading.

» From the LUT Output Colorimetry drop-down, select either Rec. 709 (HD SDR) or Rec. 2020
(WCG).

» From the LUT Output Transfer Function drop-down, select either SDR (Rec. 1886), HLG (Rec.
2100) or HDR10 (PQ 1000 nits).

7. If you are configuring a live input for a Virtual LED + Set Extension project, expand VLED and select
the Activate on Set Extension Node Only checkbox.

For all other project types, leave this checkbox clear.
8. Repeat steps 1 to 7 for each Live Inputin your project.

9. Select Save and close the Media Profile editor.

Creating a Media Bundle for a Live Source

You need to create a media bundle asset to play the video that you want to see on a surface in your
scene. This will allow the asset to be controlled by other applications.

To create a media bundle:

1. Navigate to the Voyager > LiveSources folder.
2. Right-click in an empty section of the Content pane and select Media > Media Bundle.

* Do not select the VoyagerCompositeMediaBundle in this step.

] Img Media Source

Animation

Artificial Intelligence

i
._*,_l Media Bundle

: B Media Player
Console Variables Editor
Editor Utilities ,ﬁ, Media Playlist

®=% Media Profile
-

Foliage
FX
Gameplay
Input

Live Link

ﬁ’ Media Texture

&7 Platform Media Source

Materials

Media

Create Media Bundle

WOW W W W W W W W W Y WY Y

3. In the Content browser, rename the Media Bundle asset to LiveInput_1.

The LiveInput_1_InnerAssets folder is created automatically.
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4. Double-click the LiveInput_1 media bundle to open the Details editor.

5. In the Details editor, from the Media Source drop-down, select Proxy Media Source.
Media Bundle

Medla So

ocop Media Source

Param

Select Proxy Media Source

6. Expand Media Source and Media Proxy and from the Proxy drop-down, select
ProxyMediaSource_Livel.

Media Source

Media Proxy

Aja Media Source
w: File Media Source
Img Media Source
== Platform Media Source
Proxy Media Source
Ross Matrox Media Source

% Stream Media Source

i Copy

Clear

Select ProxyMediaSource_Livel

7. Select Save and close the Details editor.
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Creating a Live Source Material

This procedure creates a material for the media bundle you created previously, using a texture present
in the Inner Assets folder. It then hides the media bundle from the camera view.

To create a live source material:

1. Drag the LiveInput_1 media bundle into the level and position this actor so that it is out of sight of
the camera (beneath the floor or elsewhere in the scene).

2. Double-click the LiveInput_1_Inner Assets folder to open it.

W5 Content Brows:

-+ Add 3V Import

w MyVSProject

Open Livelnput_1_InnerAssets Folder

3. Then right-click on the T_LiveInput_1_BC media texture and from the context menu, select Create
Material.

= Create Material

Edit...
Rename
Duplicate
Save

Delete

Asset Actions

Asset Localization

= Show in Folder View

& Show in Explorer

T Copy Reference
i Copy Fi th

=% Reference Viewer.

*% ConnectTo Source Confrol...

Select Create Material

4. In the content browser, name the material LiveInput_1.
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5. Double-click the LiveInput_1 material and in the Details tab, in the Material section, set the
Shading Model to Unlit.

& Livelnput_1

& Apply rch % Home

X
-

Texture Sample

Livelnput_1

@ Emissive Color

L L1l

B i RGEA O

Physical Material

Material

O World Position Offset

O Pixel Depth Offset

Material Mask

Livelnput_1 Material Details

In the blueprint, drag the RGB pin of the Texture Sample node to the Emissive Color pin of the
LiveInput_1 node.

. Select Save and close the editor
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Converting a Tracked Project to a
Trackless Project

You can convert an existing Voyager tracked-camera project to a Voyager Trackless Studio project.
This requires a few changes to the VoyagerOperator actor (if there is one in your project) and the
composite(s), as described in this section. To keep your project clean, you will also be able to remove a
few actors that will no longer be needed.

K This option is available starting in Voyager version 4.27 R3.

* Before starting this process, ensure the Voyager Trackless Plugin is installed and enabled in Voyager.
See Enabling the Voyager Plugins.

Perform the following steps to convert your tracked project to a trackless project:
Modifying the VoyagerOperator

Configuring the VoyagerComposite(s)
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Modifying the VoyagerOperator

In a tracked Voyager project, the VoyagerOperator is associated with the VoyagerTracker. In a trackless
project, there is no VoyagerTracker. Instead, the default trackless camera is associated with the
VoyagerCameraActor, as described in the following procedure.

To modify the VoyagerOperator:

1. Launch your tracked Voyager project.

2. In the Outliner, select the VoyagerOperator.

3. In VoyagerOperator > Details > Tracking, do the following:
e Select the Trackless Mode checkbox.

e Set the Default Trackless Camera to the corresponding VoyagerCameraActor.

Tracking

Default Trackle.
Select Trackless Mode
4. In the Voyager section, double-click the VoyagerOperator icon to open the Details editor.

5. In the Details editor, in the Internal Compositing section, check that your Composite Media
Bundle(s) are listed in the Composite Layers Array.

If there are no media bundles present, you will need to add one for each composite plane in your
project. See Creating a Media Bundle for instructions.

You will also need to add a Media Source Proxy for each composite. See Creating a Media Source
Proxy.

For information on using multiple composites on one or more layers, see Configuring Multiple
Composite Inputs.

4 Internal Compositing

None

* 0

nositing Layers 2 Array elements + @ 2

1 members

4 Layer Inputs 2 Array elements

Add Composite Media Bundles

6. Select Save and close the editor.

Voyager User Guide (v7.1) Converting a Tracked Project to a Trackless Project+ 135



Configuring the VoyagerComposite(s)

When converting a tracked project to a trackless project, you'll need to modify some settings in the
VoyagerCompositeActor(s) and add a new component called Always Face Camera. There are 2
methods for doing this:

Method 1 — Make changes in the existing composite actor(s).
Method 2 — Replace each existing composite actor with a Voyager Trackless Composite.

Both methods are described in this section.

Method 1

In the first method, you will modify existing composite actors.

To modify a composite actor:

1. In the Outliner, select a composite actor.

= Outliner

Select a Voyager Composite Actor
2. In Details > Media Bundle, double-click the Media Bundle icon to open the composite editor.

3. In the composite editor, set the Media Bundle Mode to VS Internal Chroma Keyer, VS External
Keyer or VS Composure Input, as appropriate for your chroma keyer setup.

Window  Tools Help

Media Bundle

Media Bundle Details - Select Mode

4., Select Save and close the editor.

5. In VoyagerComposite > Details > Tracking, make the following changes:
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a) Clear the Tracked checkbox.
b) Select the Trackless Compositing checkbox.

6. If you have more than one composite and want to make sure that the camera for this composite
doesn’t see the other composite(s), do the following:

a) Select the Exclude from Other Views checkbox.

b) From the Trackless Camera drop-down, select the camera actor associated with the composite.

Trackless Mode - Exclude from Other Views

7. With the VoyagerCompositeActor still selected, select the Add button and start entering “always...”
to add an Always Face Camera component.

# Details X
“| VoyagerCompositel +add e=v o
“1 VoyagerCompos X awa

by m'f: Face Camera

Voyager Composite - Always Face Camera

8. The Always Face Camera details are added to the VoyagerComposite Details tab immediately
following the Transform section.

If you don't see the Always Face Camera details, select the All tab.

9. In the Always Face Camera section, set the Target Camera to the corresponding
VoyagerCameraActor.

Voyager Composite Details - Always Face Camera
10.Repeat this procedure to configure each VoyagerCompositeActor, if there are more than one.

11.Select Save.

Voyager User Guide (v7.1) Converting a Tracked Project to a Trackless Project+ 137



Method 2

In the second method, you will replace each composite actor with a Voyager Trackless Composite
actor.

To replace a VoyagerCompositeActor:

1. In the Place Actors tab, from the Voyager category, select the Voyager Trackless Composite
Blueprint and drag it into the level.

Recently Placed

Basic

Lights

Cinematic
round) Blueprint
Virtual Production
Visual Effects
Media
Geometry
Volumes
Voyager

All Classes

Place Voyager Trackless Composite Blueprint

2. In the Outliner, select a composite.

"1 Copy Selected Actor(s) File Path

Place Actor
* Replace Selected Actors with
v
%, Snap View to Object
5 Snap Object to View
Pilot "VoyagerCompositel’

Group
*. Directional Light ) AttachTo

. SpotLight
Level

® Point Light

Replace Voyager Composite Actor

4. In Details > Media Bundle, double-click the Media Bundle icon to open the Media Bundle editor.

138 « Converting a Tracked Project to a Trackless Project Voyager User Guide (v7.1)



5. In the editor, set the Media Bundle Mode to VS Internal Chroma Keyer, VS External Keyer or VS
Composure Input — depending on your chroma keyer setup.

Media Bundle Details - Select Mode
6. Select Save and close the editor.

7. If you have more than one composite and want to make sure that the camera for this composite
doesn't see the other composite, in Details > Tracking, do the following:

a) Select the Exclude from Other Views checkbox.
b) From the Trackless Camera drop-down, select the camera actor associated with the composite.

Tracking

Tracked

Trackless Mode - Exclude from Other Views
8. In the Outliner, delete the BP_VoyagerMediaBundleActor_Trackless actor.

9. Select Save.
To remove unused components:

1. In the Outliner, right-click the VoyagerTracker actor and select Edit > Delete to remove it from the
project.
2. Similarly, remove the BP_FreeRoaming_Cam Blueprint from the Outliner, if one exists.

3. Select Save.
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Launching and Playing a Voyager
Project

Now that you've created your Voyager project, you can launch and play it to ensure it's behaving as you
expect.

You can launch a Voyager project in several ways, as follows:
Locally, using Lucid Studio Renderer Service

Remotely, using Lucid Studio

From the desktop icon

Directly from a Voyager project file

From Voyager Switchboard (Virtual LED and Virtual LED with Set Extension projects), see Using Voyager
Switchboard Launcher.

For information on playing your Voyager project, see Playing a Voyager Project.

140 « Launching and Playing a Voyager Project Voyager User Guide (v7.1)



Launching a Voyager Project Locally

To launch your Voyager project locally:

1. Select the RVS Engine Service icon in the Windows tray to launch RVS Renderer Service if it is not
already running.

RVS Engine Service

Settings
[ Stay on Top

B Show DOS console
Using TCF Port 8911

Settings

RVS Engine Service
2. Then select Settings.

Service IP Address: TCP Port: 8911

XXX XXX XXX
® ShowDOSconsole g Minimize to system tray

B Start with Windows B Start minimized
Il Auto Relaunch # Launch PIE on startup

Unreal Engine Path
...am Files\VoyageriEngine\Binaries\Win64\UnrealEditor.exe

Extra Command Line Parameters

Switchboard Listener Path
...€\Binaries\Win64\SwitchboardListener.exe Stop

Voyager Projects Paths (uproject files from paths will be recursively found)
C:\ROSS\Voyager Projects View All

Add Path

Delete Path

RVS Engine Service Settings

2. In Settings, from the Renderer drop-down, select Voyager.
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3. From the Launch Mode drop-down, select whether to launch your project in Editor or Game mode. If
Game is selected, this setting will over-ride the Launch PIE on startup setting (if it is selected).

4. Select the Browse button beside the Unreal Engine Path field and navigate to the location of your
Unreal Engine executable file (UnrealEditor.exe), select the file and select Open.

Typically, this file is located in C:\Program Files\Voyager\Engine\Binaries\Win64.

5. To launch Voyager in the editor window before going on air, in the Extra Command Line Parameters
field, enter -piewin.

OR

Leave the Extra Command Line Parameters field blank if you want to launch Voyager while on air.
In the Voyager Projects Paths window, select the path to your Voyager projects.

Select View All to display the list of projects in that location.

Select the project (name.uproject file) you want to open and select Run.

© 0 N O

Then select Close.
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Launching a Voyager Project Remotely from Lucid Studio

To launch your Voyager project remotely (from Lucid Studio):

1. Configure RVS Engine Service as described in Steps 1 to 6 in To launch your Voyager project locally.
2. In Lucid Studio, in the Server panel, select the Renderer Service tab.

3. Select the + sign in the bottom-right corner of the Renderer Services pane to add the RVS Engine
Service that resides on your Voyager engine to the list, if it is not already there.

New Lucid Service

Name: RWS Engine Servic

Cancel

Add RVS Engine Service
4. In the Name field, enter a unique name for the Service, for example, RVS Engine Service.

5. In the IP field, enter the IP address of the Voyager machine on which the RVS Engine Service is
running.

6. In the Port field, enter the TCP Port number found in the Settings window of the RVS Engine
Service on the Voyager engine.

The default port is 8911.
7. Then select OK.

8. From the Renderer Services list, double-click the Lucid Service instance you just created for
Voyager, to load a list of available projects on that engine.

9. From the Available Projects list, double-click the project you want to open.
Server
Server Renderer Groups Remote Renderer Service

Renderer Services:

RVS Engine Service

Actions:
Stop Renderer

Select Voyager Project
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Launching a Voyager Project from the Desktop Icon

To launch your Voyager project from the desktop icon:

1. Select the Voyager icon on your desktop.
2. From the Recent Projects section, select the project you want to launch and select Open Project.

3. If the project you want isn't displayed, select the More button.
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Launching a Voyager Project From a Project File

To launch your project directly from a project file:

1. Navigate to the location on your PC where your project file is located.

2. Double-click the project file (name.uproject).

If this is the first time you are launching this project, the Select Unreal Engine Version dialog opens.
3. From the drop-down, select the latest build from the drop-down and select OK.

Subsequently, your project will launch immediately upon double-clicking the project file.
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Playing a Voyager Project
With your project launched, you can now play the project in the editor and check your results.

For Virtual LED projects with multiple screens, you can play your project from the Voyager Switchboard
Launcher. See Using Voyager Switchboard Launcher.

To play your project:

1. Launch your Voyager project.

2. In the main toolbar of Voyager, select the 3 vertical dots beside the Play controls, and from the
context menu, select Advanced Settings.

H veR

Selected Viewport
%, Moabile Preview ES3.1 (PIE)
% New Editor Window (FIE)

Standalone Game

. Simulate

N\ L-OTTIHUGHES1

Current Camera Location

Number of Players 1
Net Mode
Advanced Settings...

Advanced Settings
The Editor Preferences window opens with Level Editor - Play displayed.

3. In the Game Viewport Settings section, check that the New Viewport Resolution is set to 1920 x
1080 and close the Editor Preferences window.

|f_j_._
Level Editor - Play
Set as Default Export... Import... Reset to Defaults
Play in Editor

ort Settings

New Window Size Setting
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4. Now, select the arrow beside the Play icon and select New Editor Window (PIE).

e
VC)YA\)GER

Version 5.1 R1 0506 Beta
License: Demo

® Enable Output
Performanees=ss76:9%
Reference:NNGTSE

Debug Viewéw

m Show Delay-Infa™

= Show CompositeSource Info

m Show Trackerinfo —_

Project Playout

The white text you see is informational and is not visible on air.

The following information is provided if selected:

e Enable Output: Puts the signal out for broadcast (selected by default).

e Performance: Indicates the level of performance.

o Reference: Indicates whether the reference signal is locked or unlocked.

e Debug View: Provides a selection of different views for information or troubleshooting.

e None: Selected by default.

* Do not select other views while on air, as this could interfere with the output.

e Show Delay Info: Shows the breakdown of frame delays for tracking, composite input and set
extension (if applicable). The set extension delay can be changed in this screen, if necessary.

e Show Composite Source Info: Shows information about the incoming VoyagerComposite video
feed (the talent feed inside the set).

e Show Tracker Info: Displays camera tracking data and incoming camera position data. Red X's
indicate a problem.
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Chroma Keying

Once you've created a project from a template or made an existing project compatible with Voyager, you
may need to make some adjustments in the chroma keying.

There are a couple of ways to do this.
Composure Chroma Keying
Color Difference Chroma Keying

You might find it helpful to first open the Voyager Editor Preview Output window. This allows you to
see how the set and talent will look in Play mode without actually playing it.

To open the Voyager Editor Preview Output window:

1. In the Outliner, select the VoyagerOperator actor.
2. In the Details tab, scroll down to and expand the Editor Preview Output section.

3. Select the Enable Editor Output Capture checkbox.
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Composure Chroma Keying

This method uses the VS Composure Input mode and Multi Pass Chroma Keying. You will also need to
create a composure shot and add a media plate, as described below.

To select the chroma keying mode:

1. In the Outliner, select VoyagerCompositel.

2. In the Details panel, scroll down to the Media Bundle section and double-click the
VoyagerCompositel Media Bundle icon to open the Details editor.

3. In the Details tab, in the Media Bundle section, from the Mode drop-down, select VS Composure
Input.

File  Edit Window Tools  Help

VoyagerCompositels - * %

rial Editor

Media Bundle

Select VS Composure Input

4. Select Save and close the editor.
To create a composure shot:

1. Select Window > Virtual Production > Composure Compositing and dock the panel that opens to
the right of the Content Browser.

Build

1 Cinematics

5 Content Browser
Details
ImgMedia
Outliner

Pl @ VO

Viewports

Virtual Production

VW VOV WY Y W v

=B

World Partition ? Media Capture
v Console Variables Media Playback

Env. Light Mixer | Composure Compositing

Hierarchical LOD Outliner a' Genlock
 In-Camera VFX

Live Link
5 Timecode Provider

Layers

Levels

Composure Compositing
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2. In the Composure Compositing panel, right-click and select Create New Comp.

&l composure Com... %

Create New Comp

[jg Paste

Create New Comp
3. In the Pick an Comp Class window, select Empty Comp Shot.

4. In the Composure Compositing panel, name the comp shot (e.g., ColorDifferenceKeyer).

To add a media plate element:

1. In the Composure Compositing panel, right-click on the new comp shot and select Add Layer
Element.

&)l Composure Com...

cekeyer
Create New Comp

Add Layer Element
] Cut
_i Copy
Paste
Duplicate CTAL+D
Delete DELETE

[l Rename F2

Preview P

Add Layer Element
2. In the Pick an Element Type window, select Media Plate.

The Media Plate element is nested inside the ColorDifferenceKeyer comp shot and by default is
named media_platel.

3. In the Outliner, move the ColorDifferenceKeyer and media_platel element into the Voyager folder
to be able to find them easily.

»

In the Outliner, select VoyagerCompositel.

5. In the Details panel, in the Composure section, from the Composure Input Pass drop-down, select
media_platel.

150 « Chroma Keying Voyager User Guide (v7.1)



6. In the Outliner, select media_platel and in the Details panel, scroll down to the Input section.
You'll see that the appropriate selections have been made by default, as shown in the image below:

. Details

& media_platel +add v o

& media_platel (Self)
BH &«

Streaming

Material

Required Material

Intermediate

Media_platel Details

7. Continue with Multi Pass Chroma Keying.

Multi Pass Chroma Keying

The settings and parameters for Multi Pass chroma keying are found in the media_platel actor. You
will need to select the Multi Pass chroma keyer, then select two colors to be keyed out and make some
adjustments in the material parameters to get a sharp keyed image.

You may find it helpful to zoom your camera in on the talent while adjusting the Chroma Keyer
parameters. This will make it easier to see the changes.

To select the Multi Pass Chroma Keyer:

1. In the Outliner, select media_platel, if it is not already selected.

2. In the Details panel, in the Transform/Compositing Passes section, expand Transform Passes and
make sure that Multi Pass Chroma Keyer is selected in the Chroma Keying drop-down.

To select colors to be keyed out:

1. In the Content Browser, open the Voyager > LiveSources > VoyagerComposite_InnerAssets
folder and double-click the T_VoyagerComposite_BC media texture to open its editor.

You may need to re-size the editor, so that you can see the editor and the Outliner and Details
panels.

2. With media_platel selected in the Outliner, expand Chroma Keying and from the Material drop-
down, select M_SinglePassChromaKeyer.

3. Select the + icon beside Key Colors to add an Array element.
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4. Select the checkered bar to open the Color Picker and select the eye-dropper.

5. Use the eye-dropper to select the main color in the background of the T_VoyagerComposite_BC
media texture.

6. Drag and drop the selected color to the color bar at the top of the Color Picker.

- Details

B media_platel

E media_platel (Self)

Streaming

Composure

Input

Tr

Array elements @

Material

Select Main Key Color (Multi Pass)
7. Select the + icon beside Key Colors to add a second Array element.
8. Select the second checkered bar to open the Color Picker and select on the eye-dropper.

9. Use the eye-dropper to select the second most prominent color in the background of the
T_VoyagerComposite_BC media texture.

10.Close the T_VoyagerComposite_BC media texture.
To select the Despill color:

1. In the Details tab, scroll down to Despill and expand that section.
2. Select the + icon beside Key Colors to add an Array element.

3. Select the checkered bar in the Despill Key Colors and select the color saved to the color bar at the
top of the Color Picker.

This helps to remove any reflection spilling onto the talent from the background.

4. Select OK to close the color picker.
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To adjust the material parameters:

1. Zoomin on the talent to be able to see details like the hair better.

2. Still in the media_platel Details panel, in the Chroma Keying section, expand the Material
Parameters section.

Material

Material Parameters - Composure Chroma Keying
3. Adjust the Material Parameters as necessary to achieve a good image.

4. If further adjustment is necessary, increase or decrease the other parameter values one at a time
and check the result to see if the image is improved.

You can return to the default values at any time by selecting the yellow reset arrow that appears
beside the parameter field when it's changed.
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Color Difference Chroma Keying

This method uses the VS Internal Chroma Keyer mode and Single Pass Chroma Keying.
To select the chroma keying mode:
1. Navigate to the Voyager > LiveSources folder and double-click the VoyagerCompositel Media

Bundle to open the Details tab.

2. In the Details tab, in the Media Bundle section, from the Mode drop-down, select VS Internal
Chroma Keyer.

Window
VoyagerCompositels - =

B % Open Material Editor

# Details X

Q

Select VS Internal Chroma Keyer
3. Select Save and close the editor.

4. Continue with Single Pass Chroma Keying.

Single Pass Chroma Keying

The settings and parameters for Single Pass chroma keying are found in the VoyagerCompositel
Media Bundle. You'll need to select the color to be keyed out and make some adjustments in the
material parameters to get a sharp keyed image.

You may find it helpful to zoom your camera in on the talent while adjusting the Chroma Keyer
parameters. This will make it easier to see the changes.

To select the color to be keyed out:

1. In the Content Browser, open the Voyager > LiveSources > VoyagerComposite_InnerAssets
folder and double-click the T_VoyagerComposite_BC media texture to open its editor.

2. In the Outliner, select the VoyagerCompositel actor.

3. In the Details tab, scroll down and expand the Chroma Keyer section.

4. Select the Key Color bar to open the Color Picker and select on the eye-dropper.
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5. Use the eye-dropper to select the main color in the background of the T_VoyagerComposite_BC

media texture.

,/ Pintaile "

B nerCompositel

Transform

Internal Compositing

Input Pass
Chroma Keyer

Select Key Color (Single Pass)

6. Close the T_VoyagerComposite_BC media texture.

To adjust the material parameters:

1. Zoomin on the talent to be able to see details like the hair better.

2. Still in the VoyagerComposite 1 Details tab, in the Chroma Keyer section, adjust the Key Color
parameters as necessary to achieve a good image.

Parameter
Alpha Threshold
Alpha Offset

Red Weight
Blue Weight
Clip Black
Clip White
Despill

Description
Removes most of the core green signal while keeping detail (ie hair).

Adding a positive value brings back the core fill if the talent or object starts
to become transparent.

Turning on SHOW ALPHA in the Debug tab will help you make better
adjustments.

Helps add or remove red tint from the green spill.
Helps add or remove blue tint from the green spill.
Adds or removes blacks from the signal.
Adds or removes whites from the signal.
+ Despill Hue Range
Desaturates or saturates the signal to neutralize the hue.
e Despill Amount

Replaces the despill with a color range depending on the value input.

3. Begin by adjusting the Alpha Threshold and Alpha Offset parameters slightly to remove any
transparent areas and sharpen the image.
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Make the minimum amount of adjustment possible to get a good image.

4. If further adjustment is necessary, increase or decrease the other parameter values one at a time
and check the result to see if the image is improved.

You can return to the default values at any time by selecting the yellow reset arrow that appears
beside the parameter field when it's changed.
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Switching Cameras in a Multi-Camera
Setup

You can switch between multiple cameras in a set to show the same scene from a different perspective.
This requires defining a number of virtual cameras to be associated with the physical cameras in your
set and adding nodes to the level blueprint that will set the active tracker actor.

Follow the steps below to set up camera switching:

Adding a Voyager Operator to your Project (if there isn't one already)

Adding Voyager Trackers

Adding Voyager Tracker Actors

Adding Camera-Switching to the Level Blueprint
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Adding a Voyager Operator to your Project

If you have used the Virtual LED template to create your project, you will need to add a Voyager
Operator to your project in order to do camera-switching. All other templates already have a Voyager
Operator.

If you already have a Voyager Operator in your project you can skip these instructions and continue
with Adding Voyager Trackers.

To add a Voyager Operator to your project:

1. In the main toolbar, from the Voyager drop-down, select New Voyager Operator.

2. In the Save Asset As window, navigate to the Voyager folder and add a new folder named
Operator.

3. Then save the new Voyager Operator in the Operator folder, with a name like VoyagerO perator.

The VoyagerOperator editor opens and the VoyagerOperator_InnerAssets folder is automatically
created.

4. In the VoyagerOperator editor, in the Voyager section, from the Compositing Mode drop-down,
select nDisplay.
File Edit t Window To

F

| VWoyagerOperator %

] = o
- [ %] Apply

-

& Details *®

mpling Delay

Voyager Operator Editor - nDisplay
5. From the Tonemapping drop-down, select either the Native or Hybrid option.

¢ Native - The Unreal Engine native tonemapping and post-processing will be applied to everything
in the level, including the incoming camera feeds. This setting is not recommended in internal
compositing as the look of the camera feeds will be affected.

e Hybrid - A broadcast tonemapping (designed to preserve the look of the incoming camera feed)
will be applied only to the incoming camera feeds. Native tonemapping and post-processing will
only affect the graphics and not the incoming camera feeds used for the composite layers.
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6. From the Internal Compositing Mode drop-down, select from the following options:

Auto-detect — uses Linear compositing (engine default) unless the Voyager Media Bundle on the first
compositing layer is set to External Keying and Tonemapping is set to Hybrid.

Linear — recommended for multiple compositing layers, as it supports the most features and layering
combinations.

Non-Linear — recommended for a single layer using external keying, as it supports fewer layering
and post-processing combinations but replicates the external compositing typical of broadcast
devices.

X In Non-Linear mode, pixels in the virtual graphics that are hidden by composite objects will still

generate bloom, as if they were visible. This mode is intended for use with external keyers. It could
have undesired effects on the edges of internal chroma keyers.

X Additional live sources that are fill-only without using chroma keying can be used in either mode,
based on the nature of the main composite's keying method.

7. Select Save and close the editor.

8. In the Content Browser, open the Voyager > Operator folder and then select and drag the
VoyagerOperator into the level.

The location of the VoyagerOperator actor in the scene is not important. It can be placed anywhere.
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Adding Voyager Trackers

Typically, your project will have at least one Voyager Tracker (except for Voyager Trackless projects).
For multi-camera switching, you’'ll need to add an additional Voyager Tracker for each physical camera
in your set to which you want to be able to switch.

To add Voyager Trackers:

1. In the Content Drawer, in the Voyager > Tracker folder, right-click in the empty space and select
Media > Voyager Tracker.

Animation

bl LA P Platform Media Source

L, g Proxy Media Output
Console Variables Editor

Editor Utilities 1 Proxy Media Source

Foliage =
FX

Gameplay
! Ross Matrox Media Source

Input
Live Link
Materials
Media

llaneous

"B Ross Matrox Media Outpurt

{i-)® Stream Media Source

¥, Voyager Composite Media Bundle

lﬁl Voyager Media Frame Output

| Voyager Operator

Sounds
Textures
@ Voyager Tracker
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User Interface

Add Voyager Tracker
Rename the Voyager Tracker to identify the physical camera it represents (Caml1, Camz2, etc.).
Double-click the new Voyager Tracker to open the editor.

In the UDP Port field, enter a different port number from any other tracker in the scene.

aua ~» W N

By default, the UDP Port is 8456, so you can enter 8457 for the second tracker, 8458 for the third
tracker, etc.

6. Select Save and close the editor.
7. Drag the new Voyager Tracker into the scene.

8. Repeat the steps 1 to 7 for each camera view you want to display.
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Adding Voyager Tracker Actors

Once you've added the required number of Voyager Trackers to your project, you’'ll need to connect
them to the Voyager Operator by adding Voyager Tracker Actors..

To connect Voyager Tracker Actors:

1. In the Outliner tab, select VoyagerOperator.

2. In the Details tab, in the Tracking section, select the + icon to add a Tracker Actor Array element
for each tracker you added to the scene.

3. From the drop-down for the first new element (Tracker Actor Index [0]), select your first
VoyagerTracker (e.g., Caml).

Tracking

Add Tracker Actors

4. From the drop-down for the second new element (Tracker Actor Index [1]), select your second
VoyagerTracker (e.g., Cam2).

5. Repeat steps 3 and 4 for each additional tracker.
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Adding Virtual Camera-Switching to the Level Blueprint

Now you’ll need to add some nodes to the level blueprint to switch cameras. The trigger to switch
cameras can come from a number of inputs, such as a switcher node, a Lucid_Exec node, a RossTalk
node, or a Voyager Timecode Event node, depending on your workflow.

To open the level blueprint:

1. In the Outliner, select the VoyagerOperator.

2. Then select the arrow beside the Blueprints icon and select Open Level Blueprint.

=3 New Empty Blueprint Class...
Convert Selection to Blueprint Class

B5 Open Blueprint Class... >
iF Open Level Blueprint

® GameMode: GameModeBase

Open Level Blueprint
To create the first camera switch graph:

1. In the Event Graph tab, right-click in an empty section of the graph and select Create a Reference
to VoyagerOperator.

All Actions for this Blueprint Context Sensitive
Q

Add Event for Voyager Operator 2

23 Create a Referenci

Create a Reference to VoyagerOperator

2. Right-click again and in the All Actions for this Blueprint list, in the Search field, start typing the first
part of the input node name and then select the node from the list:

For example:

Type RossTalk to add an On RossTalk GPI Event node.
OR

Type Lucid to add a Lucid Exec node.

OR

Type Timecode to add a Voyager Timecode Event node. For further information see how to execute a
camera switch using the On Voyager Event node

3. Select the On GPI pin (or Exec 1 on a Lucid input node, or the Exec output pin on a Voyager
Timecode Event node) and drag out a connection to place a new node.
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4. In the Executable actions list, in the Search field, start typing Set Active Tracker Index and add a
Set Active Tracker Index node to the input node.

If your search doesn't come up with the Set Active Tracker Index node, clear the Context Sensitive
checkbox and try again.

5. In the input node, set the applicable parameters as described below:
¢ In a Lucid Exec node, in the Var Name field, enter a name (e.g., Camera_Switch_1).
e In a RossTalk node,
> set the Condition to Match Number only.

» Set the GPI As Number field to the Index number of the tracker actor to which it refers (e.g., “0”
for Cami1, “"1” for Cam2, etc.) as defined in the VoyagerO perator.

¢ In a Voyager Timecode Event node, set the Timecode Event Action value to the number of the
tracker actor to which it refers (e.g., "0" for Caml, "1" for Cam2, etc.) as defined in the
VoyagerOperator.

6. In the Set Active Tracker Index node:
e Connect the Output pin of the VoyagerOperator reference node to the Target pin.

e Set the An Index field to the Index number of the tracker actor to which it refers (*0” for Cam1, “1”
for Cam2, etc.) as defined in the VoyagerO perator.

7. Add the Event Begin Play node to the input node.

8. Select Save and then Compile.
To add additional camera switches:

1. Left-click and drag around the input node and the Set Active Tracker Index node created above to
select them, and then right-click and select Duplicate to create another set of identical nodes.

"B Lucid Exec
JF Set Active Tracker Index

© Event BeginPlay / » > Larget is Voyag Tt
| 2 - | ] (]

Target Return Value

> AnIndex [0]

"B Lucid Exec
[
C

Duplicate Camera Switching Graph
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2. In the second input node, change the applicable parameter as follows:

¢ In a second RossTalk node, set the GPI As Number value in the new node to correspond to the
Index number of the second tracker actor defined in the VoyagerOperator.

e In a second Lucid Exec node, change the Var Name to correspond to the Index number of the
second tracker actor defined in the VoyagerOperator, which would be called in a Renderer Logic
function in Lucid Studio (Method 1).

Alternatively, you can have one Lucid Exec node that switches up to 5 cameras and connect the
Exec 2 pin to the second camera, the Exec 3 pin to the third camera, etc. (Method 2).

If you need more than 5 camera switches, you'll need to use Method 1.

¢ In a second Voyager Timecode Event node, set the Timecode Event Action value to correspond
to the number of the 2nd tracker actor defined in the VoyagerO perator.

3. In the second Set Active Tracker Index node, set the An Index value to the Index number of the
second tracker actor.

4. Repeat steps 1 to 3 for any additional physical cameras to which you want to be able to switch.

5. Connect the Exec output pin of the first input node to the Exec input pin of the second input node
and connect the Exec output pin of the second input node to the Exec input pin of the third input
node, as is necessary for the number of input nodes.

6. Select Save and then Compile.

A blueprint for two cameras with a RossTalk trigger would look like the blueprint below:

‘B On RossTalk GPI Event
T Set Active Tracker Index

»
(..::- Event BeginPlay / Condition OnGPI P # »
»

Mat only
GPI Struct Target Return Value

v GPI As Number |I| Source © An Index [0]

GPIAs Text ||
f g. VoyagerOperator

‘BB On RossTalk GPI Event

»
Condition On GPI B
Match Number cnly

GPI Struct Target Return Value

O GP1AS Number |:| Source » An Index |1_|

GPIAs Text [_]

Camera Switching via RossTalk GPI
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A blueprint for 2 cameras with a Lucid trigger could look like either of the blueprints below:

"B Lucid Exec

&> Event BeginPlay / »
»

"B Lucid Exec

> Event BeginPlay
»

" &) VoyagerOperator

F Set Active Tracker Index

Target Return Value

» An Index | [l|

£ o ) VoyagerOperator

F Set Active Tracker Index

Target

» An Index | 1 |

Return Value

» An Index |

f Set Active Tracker Index

Target Return Value

» An Index | 1 |

Camera Switching via Lucid Exec (Method 2)
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Embedded Audio Output

Embedded audio output is a feature that is available on Voyager engines that have a Matrox video
card.

It is not currently supported by AJA.
To use embedded audio output:

1. In the main tool bar, double-click the Media Profile icon to open the editor.

2. In the Outputs > Media Outputs section, expand ProxyMediaOutputl and then expand Audio.

Inputs

Outputs

Embedded Audio Settings

3. Select the Capture Audio checkbox to capture audio from the media port.

4. In the Buffered Audio Frames field, enter the maximum number of frames of audio data to be stored
in memory at any given time.

The default value is 4. If you notice jumps or hitches in the input video, you can try raising this value.
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Creating a Blueprint to Launch Multiple
Levels

If your project contains more than one level, you'll need to create a blueprint that will launch the level
you want.

Multi-level projects present some challenges, beyond just launching the desired level. See the Unreal
Engine documentation for more information.

The following procedures describe a simple blueprint that can be used to launch any of three levels. For
the purpose of these instructions, the levels are named Studio_A, Studio_B, and Studio_C.

To create a new blueprint:

To create a variable to launch levels:
To load a specific level:

To unload a level:

To connect the nodes:

To create a new blueprint:

1. In the main toolbar, select the arrow beside the Blueprints icon and select New Empty Blueprint
Class.

= New Empty Blueprint Class...
* Convert Selection to Blueprint C

5 Open Blueprint Class...

Select New Empty Blueprint Class
2. From the Pick Parent Class list, select any class.

3. In the Create Blank Blueprint Class, in the Name field, enter a name for your new blueprint and
select OK.

By default, the blueprint is saved in the Blueprints folder.

The blueprint editor opens.
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To create a variable to launch levels:

1. In the blueprint editor, select the Event Graph tab.
Right-click in the graph and in the Search field, type Lucid.

f Lugid Float

J Lucid

S Lucid

Search Results for Lucid Nodes

3. Select the Lucid Exec node.

4. In the Lucid Exec node, in the Var Name field, enter a name for the variable (e.g., Load_Levels).

To load a specific level:

1. Right-click in the graph and in the Search field, type Load Stream.
All Possible Actions B

[ Load Stream
f Load Stream Leve ject Reference
Jf unload Stream Leve

J unload Stream Level
4| evel Streaming

5 eq gU d and Removal
Search Results for Load Stream Level
2. Select Load Stream Level (by Name).

3. In the Level Name field, enter the name of the first level you want to load.
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To unload a level:

1. Right-click in the graph and in the Search field, type Unload Stream.

All Actions for this Blueprint Conte tive
4 Asset Manager

f unload

_f Unlead Prima

4Game

Search Results for Unload Stream Level

2. Select Unload Stream Level (by Name).

3. In the Level Name field, enter the name of the level that should not be launched.

4. Rep_ea;c Steps 2 and 3 to create additional Unload Stream Level nodes for the other levels in your
project.

To connect the nodes:

1. Connect the Output pin of the Event Begin Play node to the Input pin of the Lucid Exec node.

2. Connect Output pin Exec 1 of the Lucid Exec node to the Input pin of the first Unload Stream Level
node (e.g., Studio_B).

3. Connect the Output pin of the Unload Stream Level node to the Input pin of the second Unload
Stream Level node (e.g., Studio_C).

4. Connect the Output pin of the second Unload Stream Level node to the Input pin of the Load
Stream Level node (e.g., Studio_A).

> Event BeginPlay

/
"B Lucid Exec °
~

=P B [ Unload Stream Level (by Name) a | Unload Stream Level (by Name) a " Load stream Level (by Name) c

Var Name [Loa 3 Completed b —— B Completed [ » Completed [
» Level Name [ Studio_C]

should Block on Unload Make Visible After Load

0

should Block on Load [

Blueprint to Launch Studio_A

5. Create additional Unload Stream Level and Load Stream Level nodes to launch Studio_B and
Studio_C.
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6. Connect the Output and Input pins in the same way as previously, starting with Output pin Exec 2
in the Lucid Node and changing the names so that the Load Stream Level node will launch a

different level.

Unload Stream Level Load Stream Level
Studio_B, Studio_C Studio_A
Studio_A, Studio_C Studio_B
Studio_A, Studio_B Studio_C

The blueprint for launching all three levels would look like this:

< Event BeginPlay
| Load Stream Level (by Name) o

= [ [ competed
| Unload Stream Level (by Name) | Unload Stream Level (by Name) Completed [>
Completed b — P Complete O Level Name | Studi

& Lucid Exec O Level Name
» Unlo Should
O
Var Name |
Name) ° f Unload Stream Level (by Name) ° f Load Stream Level (by Name) °
G cted p —— B Com Completed [
O» Level Name O» Level Nam O» Level Name

ock on Unload Should 5 Ma

(m) (m)
Should BI vad ()

[ Unload Stream Level (by Name) ° [ Unload Stream Level (by Name) ° L °
N = | Load Stream Level (by Name)
Completed [p —— P Completed B ~
2 ]

Completed [

Blueprint to Launch Multiple Levels

7. Select Save and close the blueprint editor.
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Using Remote Assets

In the Voyager level blueprint, you can add nodes to apply remote assets (images or videos) to an actor
or object in your scene or to multiple actors or objects. You only need to identify the URL of the remote
location of the asset and specify to which actor(s)/object(s) you want to apply the asset.

The asset can then be applied using a key press, Lucid Exec, RossTalk GPI or other input node.

To be able to use remote assets, you first need to configure a few general settings.

To configure remote asset settings:

1. From the main menu, select Window > Voyager > General Settings.

Voyager

General Settings

Lucid > Template Links
RossTalk Settings
Device Output Log Web API Settings

Configure General Settings

2. In the General Settings tab, select the Remote Asset Storage Location Browse button and
navigate to the folder to which you want to download your remote assets.

3. In the Remote Asset Cache Expiration Interval field, set the amount of time in minutes for which
the locally cached assets will be used.

After the interval, the next time the asset is requested, the system will check the remote source for
updates to the asset and download any that have changed. If the remote asset can’t be found or
there haven't been any changes, the cached asset will be used.

Remote A
E ge Location: Browse

Remot Cache tion interval (minutes):

Apply Changes

General Settings - Remote Assets
4. Select Apply changes and save settings.

5. Close the General Settings tab.
To apply a remote asset to an actor or object:

1. In the main toolbar, select Blueprints > Open Level Blueprint.

2. Right-click in an empty part of the Event graph and start typing Apply Remote Asset to Actor.

Voyager User Guide (v7.1) Using Remote Assets + 171



3. From the results, select the Apply Remote Asset to Actor node.

From the Outliner, drag the actor or object to which you want to apply the asset into the blueprint
and connect the Output pin on the node that is created to the Actor pin on the Apply Remote Asset
to Actor node.

Then drag the Input pin of the Apply Remote Asset to Actor node out and start typing Input 1 to
place an input event node.

Alternatively, you can add a Lucid Exec node or a RossTalk GPI node or other input node.

f I Apply Remote Asset to Actor

.__'_____...—--D

Unlit

Apply a Remote Asset to Actor
From the Keyboard Events list, select 1.

In the Apply Remote Asset to Actor node, in the URL field, enter the full URL of the asset you want
to apply.

Select the Unlit checkbox if you don’t want lighting applied to the asset or leave it unchecked if you
do want lighting applied.

Select Save and close the blueprint.

To apply a remote asset to multiple actors or objects:

1
2
3.
4

ui

. In the main toolbar, select Blueprints > Open Level Blueprint.

. Right-click in an empty part of the Event graph and start typing Apply Remote Asset to Actors.

From the results, select the Apply Remote Asset to Actors node.

. From the Outliner, drag the actors or objects to which you want to apply the asset into the

blueprint.
Right-click in the graph and add a Make Array node.

6. In the Make Array node, do the following:

e Select the Add pin icon to add a pin for each actor or object node.
e Connect the Output pin of each actor/object node to an Input pin on the Make Array node.

e Connect the Array pin of the Make Array node to the Actors pin of the Apply Remote Asset to
Actors node.
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7. Then drag the Input pin of the Apply Remote Asset to Actor node out and start typing Input 1 to
place an input event node.

Alternatively, you can add a Lucid Exec node or a RossTalk GPI node or other input node.

X1 | Apply Remote Asset to Actors
Pressed [P
Released [
o Key
¥ Cubel
Actors

__
_ i Make Array unlit
¥ Cube2 (ol Array

0l Add pin +

" {} Cube3 [2

Apply Remote Asset to Multiple Actors

8. In the Apply Remote Asset to Actors node, in the URL field, enter the full URL of the asset you want
to apply.

9. Select the Unlit checkbox if you don‘t want lighting applied to the asset or leave it unchecked if you
do want lighting applied.

10.Select Save and close the blueprint.

Voyager User Guide (v7.1) Using Remote Assets < 173



Creating a Portal Effect

Voyager uses tracked off-axis projection to create a portal effect that gives the impression that you are
looking through a window into another space.

The portal effect can also be used to extend the set to give it depth without using a green screen.

Follow the steps outlined in this guide for creating a project from a template or making an existing
project compatible with Voyager. Then follow the instructions below to add a portal effect.

To set up a portal effect:

1. In the Place Actors tab, from the Voyager category, drag the VoyagerPortalWindow actor into the
level.

®; Place Actors

Q,
Of*Aa"HadO0Ne
VOYAGER
voyager Garmera Actor
Voyager Operator Actor
Voyager AR Compos ackground) Blueprint
Voyager VS Tracked Composite (Keyer) Blueprint
Voyager Source Composite Blueprint
Voyager Green Screen Model
Voyager Green Screen Static Mesh
Voyager C siting Garbage Matte

Voyager Portal Window

Voyager Portal Window Actor

2. In the Content Drawer, navigate to the VoyagerOperator actor and double-click on it to open the
Details editor.

3. Change the Compositing Mode to Portal, select Apply and close the editor.

/- Details

External
Portal

Virtual LED nDisplay

Internal Compositing

Select Portal Mode
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4. In the Outliner, select the VoyagerOperator and in the Portal section of the Details tab, from the
Portal Window drop-down, select the BP_VoyagerPortalWindow actor.

/. Details

;sf': VoyagerOperator

r;ﬁ VoyagerOperator (Instance)

Select BP_VoyagerPortalWindow

5. In the Outliner, select the VoyagerCameraActorl and in the Transform section of the Details tab,
set the Location to 0, 0, O.

6. Take the following measurements from the 0, 0, O reference point of the room:
a. Horizontally to the center of the screen.
b. Vertically from the floor to the center of the screen.
c. Forwards to the front face of the screen.

d. The width of the screen.

Reference Point
0,00

Measuring to Center of Screen
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8. In the Outliner, select the BP_VoyagerPortalWindow and in the Transform section of the Details
tab:

a. Enter the measurements for a, b, and c into the appropriate Location fields.
b. Select the lock to the right of the Scale field to lock the axis.
c. Enter the measurement for d into the appropriate Scale field.

The height of the screen will automatically be calculated to maintain a 16/9 ratio and be entered
into the appropriate field.

d. Enter a value of 1 into the third Scale field.

To position the portal window:

1. In the viewport, select both the VoyagerCameraActorl and the BP_VoyagerPortalWindow actor.
2. Move both actors together to the position that gives you the desired view.
3. Press Play to check the viewpoint.

Tip:

In the VoyagerTracker, set the Target Buffer Depth setting to the lowest value that works for your
project.

176 « Creating a Portal Effect Voyager User Guide (v7.1)



Using the Voyager Green Screen Model

When you're project uses internal compositing, you have the option to add a virtual green screen to
define the area on which a video or static image will be displayed.

If you have created your project from a template, the BP_VoyagerGreenScreen model is included. If you
have not used a template, you’ll have to add the model as described below.

You can also use a custom green screen model that you've created in another program. In this case,
you’ll have to ensure that the mapping of the UV coordinates in the model applies to the static mesh as
a whole, rather than to individual sections. This will ensure that any feathering is applied correctly.

In the two examples of the green screen model shown below, the UV coordinates are correctly mapped
on the model on the left, but incorrectly mapped on the model on the right. Incorrect mapping results in
the feathering being applied to each section of the model instead of to the model as a whole.

e

UV Mapping Example

To further refine the green screen area, you can add garbage mattes to the scene to hide parts of the
physical set that you don't want to see in the output.

You might find it helpful to first open the Voyager Editor Preview Output window. This allows you to see
how the set will look in Play mode without actually playing it.

To open the Voyager Editor Preview Output window:

1. In the Outliner, select the VoyagerOperator.

2. In the Details panel, expand the Editor Preview Output section and select the Enable Editor
Output Capture.

Alternatively, you can select Start Capture.

3. To keep the Preview window on top, select the Keep Preview Window on Top checkbox.
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To add the Voyager Green Screen model:

1. In the Place Actors tab, select on the Voyager group icon.
2. Drag the Voyager Green Screen Model into your project scene.
By default, the model is given the name BP_VoyagerGreenScreen.

3. In the Outliner, move the BP_VoyagerGreenScreen actor into the Voyager folder, to be able to find
it quickly.

4. In the Outliner, select VoyagerCompositel.
5. In the Details tab, scroll down to the Internal Compositing section and select the Use Physical Set
Model checkbox.

To configure the Voyager Green Screen:

1. In the Outliner, select the BP_VoyagerGreenScreen actor.

2. Using the Move tool, position the BP_VoyagerGreenScreen approximately where you want it in the
scene.

3. In the Details tab, in the Transform section, adjust the Rotation of the BP_VoyagerGreenScreen
actor, if necessary.

Alternatively, you can use the Rotate tool in the Viewport to adjust the rotation.
- Details X

& BP_VoyagerGreenScreen

© BP_voyagerGreenScreen (Self)

ProceduralMesh

Dimension

Voyager Green Screen Details

4. In the Dimension section, increase or decrease the values of each parameter to make the size of the
BP_VoyagerGreenScreen actor roughly the same size as the physical green screen.
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5. In the Feather section, increase or decrease the values of each parameter to adjust the blending of
each edge of the green screen model.

e The Left feathering is applied from u=0, going towards 1.
e The Right feathering is applied from u=1, going towards 0.
e The Top feathering is applied from v = 0, going towards 1.

e The Bottom feathering is applied from v =1, going towards O.

To use a custom shape for the Voyager Green Screen model:

1. From the Place Actors tab, select and drag a Voyager Green Screen Static Mesh actor into the
project scene.

2. In the Outliner, select the Voyager Green Screen Static Mesh actor.

3. In the Details tab, scroll down to the Static Mesh section and from the drop-down, select your
custom green screen model.

4. Then delete the BP_VoyagerGreenScreen actor (if using a template).
To add a Voyager Compositing Garbage Matte:

1. In the Place Actors tab, select on the Voyager group.
2. Drag the Voyager Compositing Garbage Matte into your project scene.

3. By default, the matte is given the name BP_VoyagerCompositingGarbageMatte and is red.
To configure a Voyager garbage matte:

1. In the Outliner, select the BP_VoyagerCompositingGarbageMatte.

If you don't see a red rectangle when the garbage matte is selected, try changing the Z Rotation
value.

2. With the BP_VoyagerCompositingGarbageMatte selected, use the Move tool to place the actor on
top of the part of the set you want hidden.

Wherever the garbage matte intersects with the VoyagerCompositel plane, you won't see that part
of the plane.

3. Use the Scale tool to adjust the size of the garbage matte, so that it just covers the area to be
hidden.

4. In the Outliner, move the BP_VoyagerCompositingGarbageMatte actor into the Voyager folder, to
be able to find it quickly.
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Voyager Plugins

Voyager contains a number of plugins to make the connections between Voyager and other video
production components, including other Voyager plugins. Some are enabled by default, while others
need to be enabled.

Enabled by Default:

Lucid Plugin - Allows Lucid Studio to operate Voyager remotely. See Configuring the Lucid Studio
Plugin.

Matrox Media Player for Voyager - Implements input and ouput using Matrox DSX cards.

Ross RossTalk™ Plugin - Receives and processes RossTalk™ Commands. See Configuring the RossTalk
Plugin.

Ross Voyager Core Plugin - Provides the shared functionality and common dependencies for other
Voyager plugins.

Ross Voyager Media I/O Framework - Core interfaces and utilities for the Media I/O plugins inside
Voyager.

Ross Voyager Plugin - Handles AR and VS solutions, as well as Virtual LED set extensions.

Ross Voyager Tracker Plugin - Handles camera tracking.

Disabled by Default:

PIERO Plugin - Communicates with the PIERO sports graphics analysis tool.
Ross Adrienne GPIO Plugin - Communicates with a switcher. See Enabling the Adrienne GPIO Plugin.
Ross D3 Plugin - Sends commands to D3 TrueControl API.

Ross DatalLing™ Plugin - The client for the XPression Dataling server. See Configuring the DatalLing
Plugin.

Ross Tally TSL UMD Plugin - Provides visual cues (in PIE mode) to indicate the status of the Voyager
machine, whether it is on air or only in preview mode. It now supports the TSL 5 protocol which is
required for Acuity workflows.

Ross Voyager API Plugin - Enables Voyager’'s RESTful API server for third-party integration. See
Enabling and Using the Voyager Web API.

Ross Voyager Charts Plugin - Enables the creation of 3D charts using a Dataling source. Requires the
Dataling Plugin and a valid DatalLinqg license. See Using Voyager Charts.

Ross Voyager Trackless Plugin - Required to use Voyager Trackless for projects with no tracked
cameras Voyager Trackless requires an additional license (optional.)

NDI® IO Plugin - Enables NDI I/O for Voyager. See Enabling the NDI® Media Plugin.
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Enabling the Voyager Plugins

The process is the same to access any of the Ross Virtual Solutions plugins.

To access the Voyager plugins:

1. From the Edit menu, select Plugins.
Alternatively, select Settings > Plugins from the main toolbar.

2. Scroll down in the list on the left side and select Ross Virtual Solutions.

File [=ill oW To Help

Built-In >

ager from Lucid

Piero Plugin (Bes
Bluepri i

# Edit & Package
Ross DataLing™ Plugin
Cli A n Data

# Edit &P

Ross RossTalk™ Plugi

Virtua

Enz

Ross Voyager A e
g ST h

# Edit & Package

Ross Voy

er plugir

Voyager Plugins
The list will move to the Voyager plugins.
3. Select the plugin you want to enable or edit.
4. Select the checkbox to the left of the plugin to enable it.

5. Select Restart Now when prompted.
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Configuring the Lucid Studio Plugin

The Lucid Studio Plugin is the interface between Lucid Studio and Voyager. When running Lucid Studio
with the Voyager renderer, you need to set up communication between Lucid Studio and Voyager.

Once communication is established, you'll also be able to use the Lucid Studio logic function to query
Voyager and have Voyager return the values that can be set from the Renderer Logic function block in

Lucid Studio.
To configure the Lucid Plugin Settings:

1. In Voyager, in the main toolbar, select the Lucid icon.

Lucid

Alternatively, you can select Window > Lucid > Lucid Plugin Settings.
The Lucid plugin opens.

Lucid

Send to Lucid ToFile MNormal

ile in PIE A
hile in PIE Mode

hile in PIE Mode

Lucid Plugin Settings

2. In the Create Server section, from the IP drop-down, select the IP address that will be used by the
Lucid Plugin to listen to Lucid commands.

You can also select the option Any IP (0.0.0.0) which will allow communication from any address.

3. In the Port field, enter the port on which the Lucid Studio plugin will listen for Lucid Studio
commands.

This is the same port as is defined when adding a renderer in Lucid Studio > Server Panel > Server
> Add New Element, in the Operate Port field.

The default port is 8458.
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4. Select the Use MipMaps checkbox, to generate mipmaps for image sequences.
Using mipmaps increases rendering speed and reduces stress on the CPU.
Default is unchecked.

5. Select the Force power of two textures checkbox to convert textures that are not sized to “power
of two” dimensions to “power of two” dimensions, so mipmaps can be used.

This setting is only applicable if Use MipMaps is enabled.
6. Select the Garbage Mattes checkbox to create garbage mattes in the renderer.

Garbage mattes are only enabled by this setting. They need to be configured in Lucid Studio >
Track Operate Panel > Garbage Mattes, to take effect.

Default is unchecked.
7. In the Log section, make the following optional selections:

e Select the On screen checkbox if you want to show the Lucid Studio log on the Unreal Editor
screen.

e Select Send to Lucid if you want to send a log to Lucid Studio.
AND/OR
Select To File to save the log in a file.
The log will be saved in the project Saved > Logs folder.
¢ From the Verbosity drop-down, select the amount of detail you want to get in the log.

e Select the Notify media (re)load checkbox to notify Lucid Studio when all media have been loaded
after reloading sources and every loaded source is logged.

8. In the Lucid Studio Materials Properties section, make the following optional selections:

e Select the Render After DOF checkbox to enable Render After DOF on Lucid Studio materials.

X This requires a restart.

e Select the Cast Dynamic Shadows as Masked checkbox to have Lucid Studio materials cast
dynamic shadows as masked.

e Select the Automatically stop unused movies checkbox to stop and reset to the beginning, any
movie that is not being used in any actor.

e Select the Automatically play movies from start when assigned checkbox to play movies from the
beginning when assigned in Lucid Studio (unless they are already visible in another object).

e Select the Loop movie based on file name suffix checkbox to override Lucid’s “Loop” command,
setting it to true of a movie file ends with *_LOOP"” or false if a movie file ends with *_ NOLOOP".

¢ In the Movies cache (seconds) field, use the arrows to set a time (in seconds) for which movies
should be played in the background, on load. This improves the first run in certain (usually high
resolution) movies, but it takes longer for the project to fully load.
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9. In the Miscellaneous Properties section, make the following optional selections:

e Select the Position Quadrant Animation Override checkbox to allow an active animation to be
overridden in Lucid Studio with an event that controls the same item.

¢ Select the Allow Multiple Actor Cinematics to allow running Sequences and Matinees with actors that are already
animated in another cinematic of the same type.

e Select the Copy Track camera parameters to Trackless, if you want any virtual camera in the set
to have the same camera properties as the broadcast camera.

OR

Clear the checkbox if you want to ensure that the virtual camera(s) you set up in the editor retain
their own properties.

10.From the Units drop-down, select the unit of length to be used by the Lucid Plugin and close the
Lucid plugin.
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Configuring the RossTalk Plugin

The RossTalk Plugin is enabled by default and can be configured in the Voyager UI. It is not necessary to
restart Voyager when making changes to the plugin.

For information on using RossTalk in your projects, see Using RossTalk.
To configure the RossTalk plugin:

1. Select Window > Voyager > RossTalk Settings.
The RossTalk Settings tab opens.

Any 1P ((

Listening Port: 7799

Apply changes and restart RossTalk Server

RossTalk Settings

2. From the Listening IP/Network drop-down, select the local IP address to be used by the plugin to
listen to RossTalk commands.

3. In the Listening Port field, enter the number of the TCP port to be used by the plugin to listen to
RossTalk commands.

The default port is 7799.
4. Select Apply changes and restart RossTalk Server.
5. Close the RossTalk Settings tab.
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Configuring the Voyager Web API Plugin

The Voyager Web API is a beta feature that allows an authorized user to access OpenAPI
documentation to retrieve detailed information on the processes and to understand and interact with
remote engines (for example, for testing purposes) without needing to log into each engine. The
machine from which you are accessing the Web API must be on the same network or VPN as the
Voyager engines.

The OpenAPI documentation can be accessed at a URL defined by the IP address of the Voyager engine
followed by the port number and “openAPI”.

(eg. http://xx.xx.xxx.xx:8087/openAPI).

You can also access Swagger, the more user-friendly version of the API using a URL defined by the IP
address of the Voyager engine followed by the port number and “swagger”.

(eg. http://xx.xx.xxx.xx:8087/swagger).
See Using the Voyager Web API for more information.

The Voyager Web API is disabled by default. You will need to enable it if you want to use it. See
Enabling the Voyager Plugins for instructions. You will need to restart Voyager after enabling the plugin.

To configure the Voyager Web API:

1. Select Window > Voyager > Web API Settings.
In the Web API editor the Web API Key is automatically entered when the API plugin is enabled.

The Web API Key is a unique identifier that is randomly generated on every new Voyager machine
and can be changed manually if necessary.

Web API
Generate Web API Key

Apply Changes and Restart VoyagerAPI

Web API Settings
2. Then enter the Port number on which the API will communicate with the Voyager engines.

The default Port number is 8087, but if this port is being used by something else in your network,
you can change it to a free port.
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3. Make sure that the Portis enabled in the firewall.
See Appendix A: Enabling a Port Number in the Firewall for instructions.

4. Select the CORS Enabled checkbox, to restrict access to the WebAPI to machines running on the
domain specified in the Origin field (replace the asterisk in the field with the domain name).

Disabled by default.

* If you select the CORS Enabled checkbox and just leave the asterisk in the Origin field, you are
allowing anyone to access the Web API.

5. Then select Apply Changes and Restart VoyagerAPI.
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Configuring the DataLing Plugin

The Dataling plugin is disabled by default and allows you to connect to a DatalLing server and make
Datalinqg data available to Voyager. See Enabling the Voyager Plugins for instructions on enabling the
DatalLing Plugin. You will need to restart Voyager after enabling the plugin.

To configure the DataLinq plugin:

1. In the Main menu, select Window > Voyager > DatalLinq Settings.

The DatalLinq Settings tab opens.

Vv Dataling

DataLing Settings:

DataLing Server IF:  127.0.0.1
DataLing Server Port: 8888

Apply changes and restart DataLing Client

DatalLingq Client Settings
2. Select the AutoUpdate checkbox to allow automatic update of the plugin.

3. In the DataLinq Server IP field, enter the IP address to be used by the plugin to connect to the
Dataling server.

4. In the DatalLinq Server Port field, enter the port to be used by the plugin to connect to the Dataling
server.

The default port is 8888.
5. Select Apply changes and restart DataLinq Client.
6. Close the DatalLinq Settings tab.
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Enabling the NDI® Media I/O Plugin

The NDI® Media I/O plugin allows you to create NDI inputs and outputs for Voyager. The plugin is
disabled by default.

To enable the NDI I/0 Plugin:

1. Select Edit > Plugins.

2. In the Search field, type NDI.

3. Select the NDI IO Plugin.

4. When prompted, restart Voyager.

For information about using NDI in your Voyager project, see Using NDI Media I/O.
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Voyager Node

The Voyager Node allows users to run Voyager projects in Game mode only (no Editor user interface).
Upon installation, a new desktop shortcut is created, which enables the user to launch Voyager Node
and select a project to run in game mode.

A full Voyager license or a Voyager Node license is required to run Voyager Node.
Additionally, users can run XR/nDisplay nodes if they have a Voyager Node License. As XR nodes

operate in GAME mode when running an XR/nDisplay project, you do not require a full Voyager license.
However, you will need the following licenses to run the XR nodes:

e nDisplay Controller — use for the main XR node.

e nDisplay Node — use for any secondary XR node.
To run Voyager Node:

1. On the desktop, double-click the Voyager Node shortcut.

Voyager Node Desktop Shortcut

A project explorer window opens.
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2. Navigate to the project you want and select Open.

Voyager starts in Game mode and runs the selected project.

K When running in Game mode, the project's Media Profile needs to be set as the Startup Media
Profile. See Selecting the Startup Media Profile for instructions.

ZA
VOY/%GER’

Version 7.1
License: Voyager

e My State Name

Reference: Not Set

Debug View: [[EE

u Show Delay Info

m Show Composite Source Info

® Show Tracker Info

Project Running in Game Mode
To close Voyager Node:

e On the keyboard, press SHIFT+ESC.

The Voyager Node closes.
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Using RossTalk

You can use RossTalk commands from a switcher or control application to trigger events in Voyager.

To use RossTalk in Voyager, you need to have the RossTalk Plugin enabled. The plugin is enabled by
default.

You'll also need to configure the RossTalk settings. Once the settings are configured, you can use the
following RossTalk nodes in your blueprints:

On RossTalk CC Event — triggered when an incoming RossTalk CC command is received.

On RossTalk NEXT Event — triggered when an incoming RossTalk NEXT command is received.

On RossTalk GPI Event — triggered when an incoming RossTalk GPI command is received.

Send RossTalk CC — to send a RossTalk Custom Control Command to other Ross equipment.

Send RossTalk Next — to send a RossTalk Next command to other Ross equipment.

Send RossTalk GPI — to send a RossTalk GPI command to other Ross equipment.

Send RossTalk SEQI — to send a RossTalk SEQI command to other Ross equipment.

Send RossTalk Custom Command — to send a Custom RossTalk Command to other Ross equipment.
To print the values and states of any of the GPI settings, see To display the GPI values and states.

To initialize multiple RossTalk events, see To initialize multiple RossTalk events.
To configure the RossTalk Settings:

1. From the Window menu, select Voyager > RossTalk Settings.

2. From the Listening IP/Network drop-down, select the network device on which to listen to RossTalk
commands.

You can select a specific device or select Any IP to allow multiple devices to listen to RossTalk
commands.

3. In the Listening Port field, enter the number of the port on which the device(s) will listen for
RossTalk commands.

The default port is 7799.

4. Then select Apply changes and restart RossTalk Server.
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To use an On RossTalk CC Event node:

1. Select the arrow beside the Blueprints icon and select Open Level Blueprint.

2. Right-click in the blueprint and in the Search field, begin typing Event Begin Play and then select the
Event Begin Play node.

3. Right-click in the blueprint and in the Search field, begin typing RossTalk.
4. From the search results, select the On RossTalk CC Event node.

5. Connect the Output pin of the Event BeginPlay node to the Exec input pin of the On RossTalk CC
Event node.

6. In the On RossTalk CC Event node, do the following:

e From the Condition drop-down, select whether to match Any Custom Control Command, Match
Bank and CC, Match CC Only, or Match Bank Only.

e If you selected Match Bank and CC, in the Bank field enter the number of the bank (a row on a
switcher) and in the CC field, enter the number of the custom control.

e If you selected Match CC Only, in the CC field, enter the number of the custom control command
that must be matched.

e If you selected Match Bank Only, in the Bank field, enter the number of the bank that must be
matched.

7. Then connect the Exec output pin of the On RossTalk CC Event node to the Exec input pin of the
event you want to trigger.

8. Save and compile the blueprint.
To use an On RossTalk NEXT Event node:

1. Select the arrow beside the Blueprints icon and select Open Level Blueprint.

2. Right-click in the blueprint and in the Search field, begin typing Event BeginPlay and then select the
Event BeginPlay node.

3. Right-click in the blueprint and in the Search field, begin typing RossTalk.
4. From the search results, select the On RossTalk NEXT Event node.

5. Connect the Output pin of the Event BeginPlay node to the Exec input pin of the On RossTalk Next
Event node.

6. Connect the On Next pin of the On RossTalk Next Event node to the Exec input pin of the event
you want to trigger.

7. Save and compile the blueprint.
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To use an On RossTalk GPI Event node:

9.

Select the arrow beside the Blueprints icon and select Open Level Blueprint.

Right-click in the blueprint and in the Search field, begin typing Event BeginPlay and then select the
Event BeginPlay node.

Right-click in the blueprint and in the Search field, begin typing RossTalk.
From the search results, select the On RossTalk GPI Event node.

Connect the Output pin of the Event BeginPlay node to the Exec input pin of the RossTalk GPI
Event node.

In the On RossTalk GPI Event node, do the following:

e From the Condition drop-down, select whether to match Any GPI Command, Match Number only,
Match Text only or Match Number or Text.

e If you selected Match Number only or Match Number or Text, in the GPI as Number field, enter
the number of the GPI command that must be matched.

e If you selected Match Text only or Match Number or Text, in the GPI as Text field, enter the text
of the GPI command that must be matched.

Then connect the Exec output pin of the On RossTalk GPI Event node to the Exec input pin of the
event you want to trigger.

In the example below, the On RossTalk GPI Event is triggering the printing of a headline to the
screen.

"I On RossTalk GPI Event 0 i
< Event BeginPlay = J Print String

>
~ == o - [

-_’__..-"'"" .
On GPI ¢
In String [Headline 1]
GPI Struct
) . Development Only
O» GPIAs Number [11] Source w5

GPIAs Text [ ]

On RossTalk GPI Event

Save and compile the blueprint.

To use a Send RossTalk CC node:

1.
2
3.
4

6.

Select the arrow beside the Blueprints icon and select Open Level Blueprint.

. Right-click in the blueprint and in the Search field, begin typing RossTalk.

From the search results, select the Send RossTalk CC node.

. Add an input node (e.g., Lucid Exec, Voyager Event Execution, Key Press, etc.) and connect the

Output pin of the input node to the Exec input pin of the Send RossTalk CC node.

In the Send RossTalk CC node, do the following:

e In the IP field, enter the IP address of the Ross equipment.

e In the Port field, enter the Port number on which Voyager will communicate with the equipment.
e In the Value field, enter the number of the custom control command to send.

Save and compile the blueprint.
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To use a Send RossTalk Next node:

1. Select the arrow beside the Blueprints icon and select Open Level Blueprint.
2. Right-click in the blueprint and in the Search field, begin typing RossTalk.

3. From the search results, select the Send RossTalk Next node.
4

. Add an input node (e.g., Lucid Exec, Voyager Event Execution, Key Press, etc.) and connect the
Output pin of the input node to the Exec input pin of the Send RossTalk Next node.

5. In the Send RossTalk Next node, do the following:
e In the IP field, enter the IP address of the Ross equipment.
e In the Port field, enter the Port number on which Voyager will communicate with the equipment.

6. Save and compile the blueprint.
To use a Send RossTalk GPI node:

1. Select the arrow beside the Blueprints icon and select Open Level Blueprint.
2. Right-click in the blueprint and in the Search field, begin typing RossTalk.

3. From the search results, select the Send RossTalk GPI node.
4

. Add an input node (e.g., Lucid Exec, Voyager Event Execution, Key Press, etc.) and connect the
Output pin of the input node to the Exec input pin of the Send RossTalk GPI node.

5. In the Send RossTalk GPI node, do the following:
e In the IP field, enter the IP address of the Ross equipment.
e In the Port field, enter the Port number on which Voyager will communicate with the equipment.
e In the Value field, enter the number of the GPI command to send.

6. Save and compile the blueprint.
To use a Send RossTalk SEQI node:

1. Select the arrow beside the Blueprints icon and select Open Level Blueprint.
2. Right-click in the blueprint and in the Search field, begin typing RossTalk.

3. From the search results, select the Send RossTalk SEQI node.
4

. Add an input node (e.g., Lucid Exec, Voyager Event Execution, Key Press, etc.) and connect the
Output pin of the input node to the Exec input pin of the Send RossTalk SEQI node.

5. In the Send RossTalk SEQI node, do the following:
e In the IP field, enter the IP address of the Ross equipment.
e In the Port field, enter the Port number on which Voyager will communicate with the equipment.
¢ In the Value field, enter the Take ID of the scene to send to air.

6. Save and compile the blueprint.
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To use a Send RossTalk Custom Command node:

1. Select the arrow beside the Blueprints icon and select Open Level Blueprint.
2. Right-click in the blueprint and in the Search field, begin typing RossTalk.
3. From the search results, select the Send RossTalk Custom Command node.

4. Add an input node (e.g., Lucid Exec, Voyager Event Execution, Key Press, etc.) and connect the
Output pin of the input node to the Exec input pin of the Send RossTalk Custom Command node.

5. In the Send RossTalk Custom Command node, do the following:
e In the IP field, enter the IP address of the Ross equipment.
e In the Port field, enter the Port number on which Voyager will communicate with the equipment.
e In the Command field, enter the command you want to send.

6. Save and compile the blueprint.
To display the GPI values and states:

1. Right-click the GPI Struct pin and select Split Struct Pin.

2. For each setting you want to get the value or state of, right-click in an empty part of the blueprint,
begin typing string append and select the Append node.

3. For pins that are integers, insert a To String (Integer) and for pins that are Booleans, insert a To
String (Boolean) node between the pin and the Append node.

4. Connect the pin or the Output pin of the To String (Integer) or To String (Boolean) node to the B
Input pin of the Append node.

ui

In the Append node, in the A Input field, enter the name of the pin.

6. Left-click and drag off the Return Value pin of the Append node, begin typing print string and
select the Print String node.

7. Connect the Output pin of the node that is being triggered to the Input pin of the Print String node.

8. If you are getting more than one value, connect the Output pin of the first Print String node to the
Input pin of the next Print String node, until all the nodes are connected.

"I on RossTalk GPI Event °

F Print String

» D
_— »
> Event BeginPlay / pog on GPI |p =l

In String
f Print String

In String
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Development Only.
v
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Retum Value

Add pin ®

On RossTalk GPI Event with Struct
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To initialize multiple RossTalk events:

1. In any of the blueprints created in the above procedures, right-click in the blueprint and in the
Search field, begin typing sequence and select the Sequence node.

2. Break the link between the Event BeginPlay node and the RossTalk node and instead, connect the
Event BeginPlay node Output pin to the Input pin of the Sequence node.

3. Then connect the Output pin of the Sequence node to the Input pin of the RossTalk node.

4. Add as many RossTalk nodes as you require and connect them to the Sequence node as described in
the previous step.

5. If you require more than 2 RossTalk nodes, select Add pin on the Sequence node to add a pin for
each RossTalk node.

In the example below, all of the events will be executed when any GPI command is received.

B On RossTalk GPI Event

f Print String

> GPI As Number [11]
Development Only
GPl As Text | | w
£z Sequence

» Then 0 B B On RossTalk GPI Event

<> Event BeginPlay .
Then 1 [ re— > J Print String

Then2

Add pin ®

O GPI As Number |E| Source 1
Deyelopment Only
GPI As Text [ Text| v

B On RossTalk GPI Event

f Print String

w

Initializing Multiple RossTalk Events
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Using the Voyager Web API

The Voyager Web API allows an authorized user to access OpenAPI documentation to retrieve detailed
information on the processes and to understand and interact with remote engines without needing to
log into each engine. The documentation provides a complete list of endpoints that can be used for third
party integration and testing. For a more user-friendly UI, you can use the Swagger version.

The machine from which you are accessing the Web API must be on the same network or VPN as the
Voyager engines.

For instruction on enabling the Voyager Web API Plugin, see Enabling the Voyager Plugins.

You can increase the security of your Voyager network by whitelisting the machines that can access the
Web API. See Whitelisting IP Addresses for instructions.

OpenAPI

The OpenAPI documentation can be accessed at a URL defined by the IP address of the Voyager engine
followed by the port number and “openAPI” (eg. http://xx.xx.xxx.xx:8087/openAPI).

It provides a complete list of endpoints that can be used for third party integration.

@ In @ =

¥ [3 Other Bookmarks

Voyager Web API - OpenAPI Documentation
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Swagger

Swagger is the more user-friendly version of the API. It can be accessed using a URL defined by the IP
address of the Voyager engine followed by the port number and “swagger” (eg.
http://xx.xx.xxx.xx:8087/swagger).

Voyager Web AP| &2 &=

Voyager Web AP1

Sarvers

[ ttpiion o x 8067 - voyager v

api ~
] fasset/copy Copy ssset v B
fblueprint/event Execule aVoyager Event v B
/blueprint/execute Execule 3 pinon a specibed Busprint v o

fblueprint/list Got the list of Blueprnt exccution pns )

Sehroma/get Gatthe propenties of the chroma keyer -

Voyager Web API - Swagger Documentation
To use Swagger:

1. Select the Authorize button.

The Available authorizations window opens.

Available authorizations X

ApiKeyHeader (apiKey)

X-API-Key
MName: X-API-Key
In: header

Value:

ApiKeyQuery (apiKey)
api-key

Mame: api-key

In: query

Value:

Voyager Web API - Swagger Authorization

2. In the ApiKeyHeader (apiKey) section, enter your Web API key in the Value field and select
Authorize.
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Whitelisting IP Addresses

You can restrict access to the Voyager Web API to a select group of machines by whitelisting their IP
addresses.This provides greater control and security.

To whitelist IP addresses:

1. Navigate to the Voyager configuration file, typically located at the address below:
C:\Program Files\Voyager\Engine\Plugins\VoyagerAPI\Config.
2. Open the Config file with a text editor.

3. Add the list of IP addresses, separated by a comma, as shown in the image below:

File Edit Search View Encoding Language Settings Tools Macro Run  Plugins  Window 7 ®
o']a@ eehg” ‘c_;’) |mb‘&|% 3|‘—'.“.‘1_!.|_=_~'-=.-—Lj'ﬂj@‘—'“@ B
[=] BaseVoyagerWebServerini E3 I
1 [Network]
2 Port=8087
4 [Authentication]
5 Key=5ZIn0TGH0a4 9RtESNC]xsFIolkRTB
7 [Whitelist]
IP=M¥X NXX.X.XX, XXX . X.X.X, XXX.XXX.X.XX
1 [CORS]
11 Enabled=false
12 origin=*
14
MS ini file length : 171 lines: 14 Ln:14 Col:1 Pos:172 Windows (CR LF) UTF-8 INS

Voyager Web API - Add Whitelist
4, Select the Save button.
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Using Dataling in Your Project

With the DatalLing Plugin enabled and configured (see Configuring the Dataling Plugin) you can apply
data from a referenced source, such as a text file, a lighting control or a static mesh object to actors in
your project. In the case of a static mesh object, the DataLing component for static meshes will apply
the downloaded texture only to Texture Parameter 2D elements of the corresponding static mesh
object material, and only to the ones that have the “tg_" prefix in their name.

For instructions on enabling the DatalLinqg Plugin, see Enabling the Voyager Plugins.
You will need to install the XPression DatalLing Server on your network. The server is available free but

requires a license to connect to it. Contact Ross Video at the numbers listed in the section Contacting
Technical Support for assistance.

If you attempt to add a Dataling source to your project but don’t have a valid DatalLing license, you will
see a message in the bottom-right corner of the screen, as shown in the image below:

DatalLing License Not Found

You will also need to add your data source to the DatalLing server in order to make it available to
Voyager. See Adding a DataLing Source to the XPression DataLing Server.

To add Dataling sources from DashBoard, see Using DashBoard DataLing Sources.
There are two methods for adding a Dataling source to your project:
Adding a DataLing Component

Adding the DatalLing Multi-Value Actor
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Adding a DataLing Source to the XPression DatalLing
Server

Once you have your DatalLing source configured, you'll need to add it to the XPression DatalLing Server.
To add a DatalLinq source to the XPression DatalLinq Server:

1. Launch the XPression Dataling Server.
ﬂ XPression Dataling Server [port: 8888] - w10,19 build 5504 beta = O x

File ‘Windous

COrifgUrE, Broiias...

XPression Dataling Server

2. Select Add New.

b Add Datsling Saurce x

Add Dataling Source

3. Select your Dataling source from the list.
4. Configure your Dataling source.

The configuration dialog differs depending on the source selected. Once you've configured your data
source, it will appear in the list.
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5. Select your data source and select Browse to verify that the parameter value is being received.

ﬂ Browsse Dataling - ] X

Verify DatalLing Value

6. Select OK and then close the XPression DatalLing Server window.

The XPression Dataling Server will be minimized to the taskbar.
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Adding a DatalLing Component

With the DatalLing plugin enabled and a DatalLinqg source added to the XPression DatalLinqg server, you
can manually add an additional component to your project to retrieve the data from the DatalLing
source.

If you only need one target in your project for the data, add a DataLing Single-Value Component.

If you need several targets in your project for the data, add a DataLing Multi-Value Component.

KX Versions of XPression DatalLing preceding v11.1 Build 5762, require that there be 2 or more values
drawn from the DatalLing source when using the DataLinq Multi-Value Component.

DatalLing Single-Value Component
Use this component for a single target.
To add a DatalLinq source using the DataLinq Single-Value component:

1. In the Outliner, select the 3D text, light or object actor to which you want to apply the data.
2. In the Details tab, select the Add Component button.

,/ Details

30 Text3DActor

3D Text3DActor (Instance)

Add Component
3. In the Search field, start typing DatalLing and select DATALINQ Single-Value.

X datg

[ EEFLING Multi- Value
[ A LING Single- Value

L. BETE smith Selector

DataLinqg - Add Single-Value Component

4. In the Voyager - DataLinq section, select the Browse button to open the DataLinq window.

Voyager - Data Ling

Browse

DatalLing - Browse

5. From the Source drop-down, select the Dataling source you want to apply to your actor.
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Make sure the Dataling source you select is running.

Dataling

1/18/2023 10:37:07

Set Data

DatalLing - Select Single-Value Source

The data from the selected source is displayed in the DatalLing window.
6. If your source has more than one table, from the Table drop-down, select the table you want to use.
7. Then double-click a cell in the table to select the row and column you want to display in your project.

The DatalLing window closes and the Voyager - DatalLinq section of the Details tab is populated
with the Source Name and Table (if applicable) from the selected source, along with the default
properties.

X When using a DashBoard data source, the Row field is populated with the OID (Object Identifier)
of the selected cell rather than the actual value.

Datalinq - Summary

8. Set the Update properties as follows:

e Select the Auto Update checkbox to update the data for the selected actor automatically, whether
it changes or not.

e For optimal performance, select the On Change Only checkbox, in addition to the Auto Update
checkbox, to update the data for the selected actor only when it changes.

e From the Update in Editor drop-down, select one of the following options to define when the
DatalLing component will be updated.

> Never: The object will not be updated while running in the editor.
> Only if not playing: The object will be updated only if it is not in PIE mode.
> Always: The object will always be updated, whether it is in editor or PIE mode.

9. Select Save and then Play to check that the data is updating correctly.

DataLing Multi-Value Component

Use this component for multiple targets.
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To add a DatalLinq source using the DataLinq Multi-Value component:

1. In the Outliner, select the 3D text, light or object actor to which you want to apply the data.
2. In the Details tab, select the Add Component button.

# Details

30 Text3DActor

3D Text3DActor (Instance)

b

Add Component
3. In the Search field, start typing Dataling and select DATALINQ Multi-Value.

A Details

3D Text3DActor
3D Text3DActor (Instance) X daty
b, Text3DC 3nc [# GIEFILING Multi- Value
[& EIEFELING Single- Value

m

Q Ly smith Selector

DataLing - Add Multi-Value Component

4. In the Voyager - DatalLinq section, select the Browse button to open the DataLinq window.

Voyager - Data Ling

Browse

Datalinqg - Browse
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5. From the Source drop-down, select the Datalinqg source you want to apply to your actor.

Dataling

ck v

Remave

63813696988735

Set Data

DatalLingq - Select Multi-Value Source
The data from the selected source is displayed in the DatalLing window.
6. If your source has more than one table, from the Table drop-down, select the table you want to use.

7. Then double-click cells in the table to select the rows and columns you want to display in your
project.

8. Select Set Data to close the window and apply the selected values.

The Dataling window closes and the Voyager - DatalLinq section of the Details tab is populated
with the Source Name and Table (if applicable) from the selected source, along with the default
properties.

Datalinqg - Summary

9. Set the Update properties as follows:

e Select the Auto Update checkbox to update the data for the selected actor automatically, whether
it changes or not.

e For optimal performance, select the On Change Only checkbox, in addition to the Auto Update
checkbox, to update the data for the selected actor only when it changes.

e From the Update in Editor drop-down, select one of the following options to define when the
DatalLing component will be updated.

> Never: The object will not be updated while running in the editor.
» Only if not playing: The object will be updated only if it is not in PIE mode.

» Always: The object will always be updated, whether it is in editor or PIE mode.
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To assign values to scene components:

1. Expand the Update Properties section and in each Array Element, from the Scene Component
drop-down, select the actor to which the DatalLing value should be applied.

K When using a DashBoard data source, the Row field is populated with the OID (Object Identifier)
of the selected cell rather than the actual value.

The first value you selected from the Dataling table will be in the Index [0] array element, the
second will be in the Index [2] array element, etc.

By default, the first value will be displayed on the 3D Text, light or object actor you selected when
you added the DataLinq Multi-Value component.

A Details

30 Text3DActor

DataLinqg - Update Properties
2. Select Save and then Play to check that the data is updating correctly.

Play Button
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Adding the Dataling Multi-Value Actor

In Voyager 4.27 R3 and newer versions, a DataLing Multi-Value actor has been added to the Place
Actors tab to make adding a Dataling source easier. You must have a Dataling license and have
enabled the DatalLing plugin, to access the actor.

You can also use the Dataling Multi-Value actor directly in the blueprint to retrieve the source data.

See Using the DataLing Multi-Value Actor in a Blueprint.

To add a DataLinq source using the DataLinq MultiValue actor:

1. In the Place Actors tab, from the DataLinqg category, drag the DataLinq MultiValue Actor into the
level.
@ Place Ac

LJ

CH ®*mE D% &
SO Ce

DATALING

g Dataling MultiValue Actor
)

Add Dataling Multi-Value Actor
The DatalLinq window opens.

Dataling

Add

Remo

63813698309893

Set Data

Datalinq - Select DatalLing Source
2. From the Source drop-down, select the Dataling source you want to use.

3. If you have more than one table in your DatalLing source, from the Table drop-down, select the table
you want to use.

4. Then double-click cells in the table to select the rows and columns you want to display in your
project.

5. Select Set Data.
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6. In the Details tab, select the DataLinqMultiValueComponent.

The Dataling window closes and the Voyager - DatalLinq section of the Details tab is populated
with the Source Name and Table (if applicable) from the selected source, along with the default
properties.

Datalinqg - Summary
7. Expand the Voyager - Datalinq section and set the Update properties as follows:
e Select the Auto Update checkbox to update the data automatically, whether it changes or not.

e For optimal performance, select the On Change Only checkbox, in addition to the Auto Update
checkbox, to update the data for the selected actor only when it changes.

e From the Update in Editor drop-down, select the update behavior.
» Never: The object will not be updated while running in the editor.
> Only if not playing: The object will be updated only if it is not in PIE mode.

> Always: The object will always be updated, whether it is in editor or PIE mode.
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8. Expand the Update Properties section and in each Array Element, from the Scene Component
drop-down, select the actor to which the Dataling value should be applied.

If you are using a blueprint to update the properties from your data source, you can skip this step.
See Using the Dataling Multi-Value Actor in a Blueprint for further information.

X When using a DashBoard data source, the Row field is populated with the OID (Object Identifier)
of the selected cell rather than the actual value.

The first value you selected from the Dataling table will be in the 0 Array Element, the second will
be in the 1 Array Element, etc.

By default, the first value will be displayed on the 3D Text, light or object actor you selected when
you added the DatalLing Multi-Value component.

# Details

30 Text3DActor

Q

DatalLing - Update Properties
9. Select Save and then Play to check that the data is updating correctly.

Play Button
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Using the Dataling Multi-Value Actor in a Blueprint

When dealing with large amounts of data, you will probably want to set up the functionality in a
blueprint. The DatalLing Multi-Value Actor makes it easy to do this. You'll need to select your DatalLing
source and then configure the DataLing Multi-Value actor in the blueprint.

To select the DatalLinq source:

1. In the Place Actors tab, from the DataLinq category, drag the DataLinq MultiValue Actor into the
level.

The Dataling source window opens.

Datalinq

Remo

Set Data

Datalinq - Select Dataling Source
2. From the Source drop-down, select the Dataling source you want to use.
3. If you have more than one table, from the Table drop-down, select the table you want to use.

4. Then double-click cells in the table to select the rows and columns you want to display in your
project.

5. Select Set Data.
To configure the DataLing Multi-Value actor in the blueprint:

1. In the Outliner select the DataLinq Multi-Value Actor you added.

2. Then select Blueprints > Open Level Blueprint and right-click in an empty area of the blueprint.

=2 New Empty Blueprint Cle
# Convert Selection to Blueprint Class

B Open Blueprint Class... >

i Open Level Blueprint

® GameMode: GameModeBase

DataLing - Open Level Blueprint
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3. Expand Add Event for DataLinq MultiValue Actor and then expand Voyager - DataLinq and select
Add On Data Update.

All Actions for this Blueprint

Q
Add Event for Data Ling Multi Value Actor 1
Collision
Game
Input
S e

< OnD

DatalLing Blueprint - Add On Data Update
4. In the On Data Update node, right-click the Data pin and select Split Struct Pin.

On Data Update (Election_Data)

Promote to Variable
Split Struct Pin

DataLing Blueprint - Split Struct Pin
5. Then connect as many pins as needed to the desired output node.

Example:

> On Data Update (DataLingMultiValueActor1) J Print String
B » >
In String

Development Only.
W

Data Values

Data Value 1
Data Value 2 I Print String
ata Value 2
, C: D
Data Value 3 -
In Strin
Data Value 4 9
Development @nly

=t Walue
Data Value 5 -

Data Value 6 |
int String
Data Value 7 5
Data Value 8
In String

Development Only
v

DataLinqg Blueprint - Connect Output Nodes
6. Select Compile and Save and close the blueprint.

7. Select Play to check that the data is being successfully retrieved.

Play Button
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Using a DataLing Key

Starting with Voyager 7.0, you can use the DataLinq Key feature to replace data in your Dataling
source. The DataLinqg Key can then be used in a blueprint to update that data from Lucid Studio,
Voyager Trackless, DashBoard or other applications.

To use this feature, you will need to add your Dataling source to the XPression DatalLing Server (see
instructions here). Then follow the instructions in the next sections to add and configure a DataLinq
Multi-Value actor, use a DataLinq Key in the DataLinqgMultiValueComponent and create event graphs
in the level blueprint to update the data.

A DatalLinq Key can be used in an event graph to update the data in a column or row of your DatalLing
source or it can be used to update an entire table. The DataLinq Key can be any text you want to use
to describe the data it is replacing, e.g., State, State_Code, Data_Set. It needs to use the syntax <%
DataLinq Key%> or <Attribute=%DatalLinq_Key%>.

K It is recommended that you use XPression Dataling Server v11.5 build 5816 or later.

The following steps take you through this process for using the DatalLing Key in a blueprint to update
the value of a column, row or table:

Add and configure a Dataling Multi-Value Actor

Enter a DatalLing Key in the DatalLingMultiValueComponent

Create an Event Graph to Update a Dataling Key Value

Update Data in a Text3D Actor

To add and configure a DataLinq Multi-Value Actor:

1. In the Place Actors tab, from the DataLinqg category, drag the DataLinq MultiValue Actor into the
level.
@ Place Ac

LJ

CH ®*mE D% &
SO Ce

DATALING

g Dataling MultiValue Actor
)

Add Dataling Multi-Value Actor
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The DataLinq window opens with the most recently selected source displayed.

MNothing active

Add

SetData

Datalinq - Select Dataling Source
2. From the Source drop-down, select the Dataling source you want to use.

3. Then select the cell(s) in the table containing the data you want to display and select Add to add the
data to the list on the right.

Alternatively, you can double-click a cell to add the data to the list.

4. Continue adding data from the table to the list until you have everything you want and then select
Set Data.

In the image below, the selected data is the Republican last name, Democrat last name and the
state.

Note that the first set of data does not indicate <1>. The number 1 is assumed.

DataLing
US_Elec

Remaove

Dataling Key - Select Data
The Datalinqg tab closes.

5. In the Outliner, right-click the DataLinq Multi-Value Actor you just created, select Edit > Rename
and give it a meaningful name.
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To enter a DataLinq Key in the DataLinqMultiValueComponent:

1. In the Outliner, select the DataLinq Multi-Value Actor you just created.
2. In the Details tab, select the DataLingMultiValueComponent.
3. In the Voyager - DatalLinq section of the Details tab, do the following:

e If you're using the DataLinq Key to replace row or column data, expand Update Properties and
expand each of the Indexes.

e In the Column (or row) field of each Index, replace the number of the array or data set with a
DatalLinq Key, using either the syntax <%DatalLinq Key%> or <Attribute=%DataLinq_Key%>.

For the Indexes for the first set of data, the number 1 is assumed, so you just add the DatalLinq
Key.

& members

Apply On Empty

DatalLinqg Key - Enter DataLinq Key
In the image above, the data set is \Data, and the DatalLinq Key is %Data_Set%.
This will return the data contained in that data set.

Alternatively, you can use \Data<Attribute=%DatalLinq_Key%> where the Attribute is a column
or row Name and %DataLinq_Key%o is the text you use to replace the data in that column or
row.

OR

e If you're using the DataLinqg Key to replace the name of a table, scroll down to the Table field
(after all the Indexes).

e In the Table field, replace the table name with the DataLinq Key you want to use to represent the
table (in this example, %STATE_CODE%).

This will return all the data in the table for each State code.

Voyager - Data Ling

DatalLing Key - Enter DatalLinq Key (Table)
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To create an event graph to update a DataLinq Key value:

1. Select the Blueprint icon and select Open Level Blueprint.

= New Empty Blueprint Class...
/% Convert Selection to Blueprint Class

B5 Open Blueprint Class... >

1* Open Level Blueprint

® GameMode: GameModeBase

Open Level Blueprint

2. From the Outliner, drag the DataLinqMultiValueActor you created in Using the Dataling Key into
the blueprint.

For this example, the DataLinqMultiValueActor is called Election_Data.
3. Using the Left Mouse Button, drag off from the Output pin of the DataLinqMultiValueActor and in
the Search field, begin typing set dataling key and then select the Set DataLinq Key node.
W F Set DataLing Key
)

Target

MName |:|

value [ ]

Request Data

Datalinq Blueprint - Add Set Datalinqg Key Node

4. In the Name field of the Set DataLinq Key node, enter the DataLinq Key (without the percent
symbols) you created in the previous procedure.

. &) Election_Data . JF SetDataling Key

>
Target

Name | it |

Value | |

Request Data

DataLing Blueprint - Enter Dataling Key
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5. Right-click in an empty area of the blueprint and add a blueprint node to execute the Set DataLinq
Key method (e.g., a Keyboard Event node, RossTalk command, Lucid String Async, etc.).

"B Lucid String Async

Variable Name [ | Lucid String A

DatalLing Blueprint - Add Lucid String Async Node

6. If using a Lucid String Async node, in the Variable Name field, enter the name you will use in Lucid
Studio to identify the node (e.g., Set_Data).

7. Connect the Lucid String Async Output pin of the Lucid String Async node to the Exec Input pin of
the Set DatalLinq Key node.

8. Then connect the Value pin of the Lucid String Async node to the Value pin of the Set DataLinq
Key node.

g Election_Data
F Set DataLing Key

Target
Value

Name |Da

Value

Request Data

Datalinqg Blueprint - Connect Lucid String Async Node
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Updating Data in a Text3D Actor

Once you have an event graph to update the column or row data from your data source, you can output
the updated data (to a Text3D actors in this example).

First you'll need to add the Text3D actor to the project and then create an event graph to update the
data in the Text3D actor.

To add a Text3D actor to your project:

1. In the Place Actors tab to the left of the Viewport, in the Search field, start typing text3d and select
and drag a Text3D actor into the Viewport.

2. In the Outliner, right-click the Text3D actor and select Edit > Rename to give the actor a meaningful
name (in this example, Data).

3. With the Text3D actor selected, in the Details tab, select All and in the Text 3D section, in the Text
field, enter the name of the data to be displayed in this actor (typically the same name as the
Text3D actor itself).

Z Details

3D Data

General
All
Transform

Text 3D

DatalLinq Blueprint - Configure Text3D Actor
4. Use the other options in the Text 3D section to modify the appearance of the text.

5. Position the Text3D actor where you want it in the Viewport.
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To create an event graph to update data in the Text3D actor:

1. With the DataLinqMultiValueActor you created selected in the Outliner, right-click in an empty area
of the blueprint and in the Search field, begin typing voyager - on Data Update and then select the
Add On Data Update node.

All Actions for this Blueprint Context Sensitive

. Voyager - on|
Add Event for Data Ling Multi Value Actor 3
Voyager - Data Ling
&> Add On Data Update
Call Function on Data Ling Multi Value Actor 3
Voyager - Data Ling - Data Ling Key

JatalLing Key

DatalLinq Blueprint - Add Add On Data Update Node
2. Right-click the Data pin of the Add On Data Update node and select Split Struct Pin.

.. <> On Data Update (Election_Data) ,

Promote to Variable
Split Struct Pin

DatalLing Blueprint - Split Struct Pin
This expands the node with multiple Data pins.

> On Data Update (Election_Data)

Data Values
PEIEREN
Data Value 2
Data Value 3
Data Value 4
Data Value 5
Data Value 6
Data Value 7
Data Value 8

Data Value 9

Data Value 10

DatalLinq Blueprint - Expanded On Data Update Node

3. In the Outliner, select and drag the Text3D actor you created into the blueprint.
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4. Left-click and drag off the Output pin of the Text3D actor node, type Get Text 3D, scroll down to the
bottom of the menu and select the Get Text 3D Component node.

DatalLinqg Blueprint - Add Get Text 3D Component Node

5. Left-click and drag off the Text 3D Component node, type set Text, and select the Set Text node.

Datalinq Blueprint - Add Set Text Node

6. Left-click and drag off the first Data Value pin of the On Data Update node and in the Search field,
begin typing To Text and select the To Text (String) node.

<> On Data Update (Election_Data)

Datalinqg Blueprint - Add To Text (String) Node
7. Connect the Return Value pin of the To Text (String) node to the Text pin of the Set Text node.

8. Connect the Exec Output pin of the On Data Update node to the Exec Input pin of the Set Text
node.

Target Text3

Data Value 9

Data Value 10

DataLing Blueprint - Update Text3D Actor Event Graph

9. Save and compile your blueprint.
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Using DashBoard DatalLing Sources

To use Dataling sources from DashBoard, you'll need to create a custom DashBoard panel for Voyager.
In this panel, you'll add the data source to be applied to the Voyager actor. This could be a number

control, an image, or text. Once you have the source configured, you'll add your DashBoard Datalinqg
source to the XPression DatalLing Server.

To create a custom DashBoard panel:

1. Launch DashBoard.
2. Select the + icon at the top of the Basic Tree View.

In the Select Equipment or Service Type to Add window, select General > New CustomPanel File
and select Next.

o

Select Equipment or Service Type to Add

Wizards:

type filter text

= Cameras
v [ General
Il Bookmark
<+ Manual Connection
[ New CustomPanel File
= Input Devices
== MK Router Series
= Robots
== XPression
w [= openGear/ DashBoard Connect
|= Frame Demo (from file)
B Import openGear Help Files

< Back Finish Cancel
DashBoard Dataling - Select New CustomPanel File

4. Keep the Folder as is or select the Browse button to navigate to a new folder.
e |

New CustomPanel File

DashBoard's PanelBuilder feature allows you to create completely customized user interfaces.
Select afile and a template to get started.

Folder: | Ch\DashBoard | Browse...

File name: | Voyager.grid |

[] Add to file navigator

Template:
Empty Canvas
External XML Data Source Panel
MK Data Source Canvas
Self-Contained Production and Config Template
Ultritouch 2 Panel
Ultritouch 4 Panel

< Back Mext = Cancel
DashBoard Dataling - Create CustomPanel File

222 + Using DatalLing in Your Project Voyager User Guide (v7.1)



5. In the File Name field, enter a name for your custom panel (e.g., Voyager.grid).
6. From the Template list, select Blank Self-Contained Data Source Panel (XPression) and select
Finish.

To add a light control component to the panel:

1. Select PanelBuilder Edit Mode and double-click the panel.

2. In the Abs Attributes tab, set the XPression DashBoard Linq Port and select the Enable Streaming
checkbox.

3. Select Apply and Close.

4. Select Params > Number and drag a rectangle in the panel to add a number parameter.

Edit Mode

Split &
Drawer.

-ll:l:{ﬂ; Label Button

&
NDI

Func
Button

& | o

Browser SFarams Widget

© T
Default Label Text
i =

Choice | Number| Toggle

DashBoard DatalLing - Add a Number Parameter
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The Insert into ABS Component window opens.

5. In the Insert into ABS Component window, select the Create New Parameter radio button.

[ insertinta ABS Component X

Ingert Number

Existing Parameter

®) Create MNew Parameter
MName:

Canstraint

Minirmum: o]
Maximum 1,000

10

Display Type

O]

Default

—
Label “‘

Cancel
DashBoard DatalLing - Configure Number Parameter
Enter a Name (e.g., FaderBar) for the parameter.
Set the Minimum and Maximum values and the Step Size.

Select the Display Type (e.g., Fader Bar).

O 00 N O

. Then select Ok and exit from PanelBuilder Edit Mode.

Continue with Adding a Dataling Source to the XPression DatalLing Server.
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To add an image component to the panel:

1. Select PanelBuilder Edit Mode and double-click the panel.

The Edit Component window opens.

Abs Attributes Style Source

Override Default

Override Default

uters:

n DataLing:

oard Ling Port:

DashBoard Datalinqg - Edit Component

In the Abs Attributes tab, set the XPression DashBoard Linq Port and select the Enable Streaming
checkbox.

3. Select Apply and Close.

Select Params > Label and drag a rectangle in the panel to define the label area.
Edit Mode

|

Resize

= 0 2]

Tab Basic
SpitE  Canvas Help
Drawer.

im T (m]
£l Label

NDI
T
Params

Defautt Label

Text

-T

B ==
Choice

Number Toggle

DashBoard Dataling - Add an Image Source Parameter
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The Insert into Abs Component window opens.

5. In the Insert into ABS Component window, select the Create New Parameter radio button.

Insert Label

Existing Parameter

® ) Create New Parameter

Im

Display Type

Cancel

DashBoard Dataling - Configure Image Source Parameter
Enter a Name (e.g., ImageSource) for the parameter.
In the Initial Value field, enter a URL to the image you want to apply to your static mesh object.

In the Display Type section, select Label.

O 0 N O

Then select Ok and exit from PanelBuilder Edit Mode.

Continue with Adding a DatalLing Source to the XPression DatalLing Server.
To add a text component to the panel:

1. Select PanelBuilder Edit Mode and double-click the panel.

The Edit Component window opens.

Abs Attributes Style Source
General Attributes
Name:

1D:

x
x
x
X

k GPI Listener:

er Port:

DashBoard Dataling - Edit Component

2. In the Abs Attributes tab, set the XPression DashBoard Linq Port and select the Enable Streaming
checkbox.

3. Select Apply and Close.
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4. Select Params > Text and drag a rectangle in the panel to define the text area.

Edit Mode

Resize

Tab Basic
Split & Canvas
Drawer.

i iy (]

H‘ﬁe Label Button

<
NDI Func
Button
|

Line

- o
Bm\\ ser  (Paramsy  Widget
i =]

Default Label

0) ‘ m

B o o

Choice Number Toggle

DashBoard DatalLinqg - Add a Text Parameter
The Insert into ABS Component window opens.

5. In the Insert into ABS Component window, select the Create a New Parameter radio button.

Insert String

Constraint (optional)

(insert valug]

Display Type

Cancel

DashBoard DatalLing - Configure Text Parameter Insert into ABS Component
Enter a name for the parameter.
In the Initial Value field, enter the text that you want to appear first.

In the Display Type section, select the format in which you want your text to appear.

© 00 N O

Then select Ok and exit from PanelBuilder Edit Mode.

The text you entered in the Initial Value field appears in the text box and can now be edited.
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Using the Adrienne GPIO Plugin

Voyager contains blueprint nodes that read and write the GPI state to the Adrienne card. Selecting a
virtual camera relays a message to a switcher (such as Ross Carbonite) which triggers the physical
camera switch.

You will need to update the Adrienne Driver 1.0.1.1 to version 5/29/12 and then enable the Adrienne
Plugin. For instructions on enabling the Adrienne Plugin, see Enabling the Voyager Plugins.

You can use the Adrienne GPIO Plugin to trigger Voyager project events from a physical signal or to
trigger physical events from Voyager.

To use the Adrienne GPI nodes:

1. In Voyager, in the main toolbar, select the arrow beside the Blueprints icon and select Open Level
Blueprint.

= New Empty Blueprint Class...
/% Convert Selection to Blueprint Class

B5 Open Blueprint Class...
1* Open Level Blueprint

® GameMode: GameModeBase

Open Level Blueprint

2. Right-click in the blueprint, and in the All Actions for this Blueprint search field, begin typing
Adrienne.

Context Sensitive

Adrienne GPI Nodes
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3. Select the node you need.
The options are:
Adrienne Get Input Pin - On a key press, retrieves the current state of the selected input pin.

Enter the pin number in the Index field and connect the node to a Print String node to generate a
True or False indicator.

Example:

" f Print String

2o | Adrienne Get Input Pin »

Pressed p =—— P In String
Development.Only

> O Index |Z| Return Value -

Adrienne Get Input Pin Node
Adrienne Get Output Pin - On a key press, retrieves the current state of the selected output pin.

Enter the pin number in the Index field and connect the node to a Print String node to generate a
True or False indicator.

Example:

“fPrint string

»
\ | Adrienne Get Output Pin / -
> » » )

evelopment. Only
v

O Index [1]  Return Value

Adrienne Get Output Pin Node

Adrienne GPI Input Event - Triggers an event when an input state changes and the conditions are

met.
Condition Description Additional Parameters
Number Any Pin None
Condition Match Pin Number only Enter pin number in Pin field
State Condition  Any State None
True Only "
False Only "
Time Condition | As soon as possible None
After Delay in milliseconds Add milliseconds in Delay field
After Delay in frames Add frames in Delay field
Cluster When selected, the triggered event will occur in | None

all Voyager engines in an nDisplay setup.
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Example:

‘BB Adrienne GPI Input Event ‘BB Voyager Event Execution °

/ .
Number Condition on GPI Event Name | P
M Pin k =

Input Struct | Event

Event Description [ |
State Condition

O Delay |

Adrienne GPI Input Event Node

Adrienne Output Pin - When triggered by an event, triggers a physical reaction (e.g., a set
component moves).

Example:

" F Adrienne Output Fin
B 1
Pressed [

Release

» Delay Amount |I|

Adrienne Output Pin
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Using NDI®Media I/0

NDI inputs and output are configured in the Media Profile. If you require additional outputs, you can
use NDI Broadcast Actors.

X The number of inputs and outputs available depends on your Voyager NDI Streams License.

* NDI Receive Actor and NDI Broadcast Actor rendering are not the same as the Media I/0s configured

in the Media Profile. The NDI Broadcast Actor is useful for getting preview outputs from different
perspectives, but should not be used in place of the Media Output.

Before getting started, from the official NDI website, download either of the following:
e NDI Tools version 6.0.1

e NDI SDK 6.0.1

For information on how to set up and use NDI Tools, see the NDI Tools documentation on the official
NDI website.

To configure an NDI input in the Media Profile:

1. In Voyager, in the main toolbar, select the Media Profile icon.

_',:‘.J Platforms ~ H VP Rales v

Media Profile Icon
2. In the Media Profile editor, expand Media Sources for the input source.

3. Expand ProxyMediaSource and from the drop-down, select NDI Media Receiver.

Inputs

Med =t} 1 Array element
P te None

Outputs

Timm Provider

Genlock

O

11 items

Select NDI Media Receiver
4. Expand the Settings section and from the Connection drop-down, select the NDI source you want.

All NDI sources in the network are automatically detected and displayed in the Connection drop-
down.

5. Select Save and close the Media Profile editor.

The changes have been saved and the project now displays the NDI source in the composite plane.

Voyager User Guide (v7.1) Using NDI®Media /O « 231



To configure the NDI output in the Media Profile:

1. In Voyager, in the main toolbar, select the Media Profile icon.

Media Profile Icon
2. In the Media Profile editor, expand Outputs and Media Outputs.
3. From the ProxyMediaOutputl drop-down, select NDIMedia Output.

Outputs

ntDrawer [ Output Log Ctmd v

Select NDI Media Output

4. Expand Broadcast Settings and configure the output settings as follows:
Source Name - enter a name for the source (e.g., Voyager Output)
Frame Size - enter the pixel values of the frame (e.g., x=1920 and y=1080)
Frame Rate - from the drop-down, select the frame rate.
Output Alpha - select to enable viewing the Alpha channel.

Output Audio - select if your video includes audio and you want it included in the output.

Broadcast Settings

KX The Voyager Operator Compositing Mode needs to be set to External to view the Alpha channel.

5. Select Save and close the Media Profile editor.
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To configure an NDI Receive Actor:

From the Place Actors panel, select the NDI category.

. Select the NDI Receive Actor to add an input and drag it into the Viewport.

1.

2

3. Position the actor in the Viewport.

4. In the Outliner, select the NDIReceiveActor and rename it to something meaningful.
5

. With the NDIReceiverActor selected in the Outliner, in the Details panel, scroll down to the NDI IO
section, and from the NDI Media Source drop-down, select Create New Asset > NDI Media
Receiver.

NDI Media Receiver
I Copy

7 Clear

Q|

P Name -

Create New NDI Media Receiver

6. In the Save Asset As window, navigate to the folder where you want to save the asset and in the
Name field, enter a name for the asset and select Save.

7. With the NDIReceiveActor selected in the Outliner, in the Details tab, in the NDI IO section,
double-click the NDI Media Receiver icon to open the editor.

NDI 10

Frame Width

Open NDI Media Receiver Editor
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8. In the editor, in the Details panel, expand Connection and from the NDI Sources drop-down, select
your media source.

Frame

& Details

ings
NDI

Source Name :
Remaote Connection 1

NATTTE
NI Test Pattern

NDI Media Receiver Editor - Select NDI Source
The Source Name, Machine Name, and Stream Name are automatically populated.

9. Select Save and close the editor.
To configure an NDI Broadcast Actor:

1. From the Place Actors panel, select the NDI category.

2. Select the NDI Broadcast Actor to add an output and drag it into the Viewport.

3. Position the NDI Broadcast Actor so that it is projecting onto the NDI Receive Actor.
4. In the Outliner, select the NDIBroadcastActor and rename it to something meaningful.
5

. With the NDIBroadcastActor selected in the Outliner, in the Details panel, scroll down to the NDI
IO section, and from the NDI Media Sender drop-down, select Create New Asset > NDI Media
Sender.

NDI Media Sender
I' Copy
T Clear

Q|

I Name -

Create New NDI Media Sender

6. In the Save Asset As window, navigate to the folder where you want to save the asset and in the
Name field, enter a name for the asset and select Save.
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7. With the NDI Media Sender selected in the Outliner, in the Details tab, double-click the NDI Media
Sender icon to open the editor.

NDI 10

Open NDI Media Sender Editor

The NDI Media Sender is populated automatically, but you can change the settings if necessary.

Enable PTZ

NDI Media Sender Editor - Details

8. When configured as desired, select Save and close the editor.

* Remove any unused NDI Sender assets from the project, as they are counted as NDI Streams
licenses and will prevent you from adding new streams, if you have reached your license maximum.
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Using the D3 Plugin

The D3 plugin allows you to send commands to the D3 TrueControl API. For instructions on enabling the
D3 Plugin, see Enabling the Voyager Plugins.

To access the Voyager D3 nodes:

1. Select the arrow beside the Blueprints icon and select Open Level Blueprint.
2. Right-click in the blueprint and in the Search field, begin typing voyager D3.

All Actions for this Blueprint Context Sensitive
X

w Voyager - D3

Voyager D3 Blueprints
3. Select the node you want to use.
For information on creating blueprints for each node, see the following sections:
Controller Settings — controls the settings of the LED panel
Face Settings — controls individual screens (faces) that make up a large LED display

Playlist Commands — controls the playout of a video playlist
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Controller Settings

Use the Controller settings to make changes in the device that controls the entire LED panel.
To begin creating a blueprint for any D3 Controller Settings action:

1. Select the arrow beside the Blueprints icon and select Open Level Blueprint.

2. Right-click in the blueprint and in the Search field, begin typing D3 and from the results, select the D3
node you want.

3. In any D3 node, left-click and drag off from the D3Server Configuration pin and from the Actions
providing a(n) D3Server Configuration Structure menu, select Make 3DServerConfiguration.

. GetD3 Controller Settings

‘oviding a(n) D3Server

Centext Sensitive

Make D3ServerConfiguration

4. In the Make D3ServerConfiguration node, do the following:
e In the Ip field, enter the IP address of the D3 server.
e In the Port field, enter the port number for the D3 server.

e In the Auth Token field, enter your token number.

»= Make D3ServerConfiguration “F Get D3 Controller Settings

D3Server Configuration ]

3Server Configuration

On Controller Settings Request Completed

D3 Server Configuration

5. Right-click in the blueprint and select a trigger node (e.g., a button press node, or a RossTalk GPI
Event node).
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6. Connect the Output pin of the trigger node to the Input pin of the D3 node.

EF1
Pressed [
Releas:
J Get D3 Face Settings

rverConfiguration rver Configuration
D3Server Configuration Face Id |7|

On Face Settings Request Completed

Auth Token |:|

Add Trigger

7. Add Feedback nodes as follows:

a.

In the D3 node, left-click and drag off from the Request Completed pin, begin typing add custom
event and select the Add Custom Event node.

The Custom Event node will differ depending on the D3 node to which it is connected.

. Give the Custom Event node a unique name that corresponds to the D3 node.

In the Custom Event node, left-click and drag off from the Success pin, begin typing branch and
select the Branch node.

The Output pin of the Custom Event node is automatically connected to the Input pin of the
Branch node.

In the Branch node, left-click and drag off from the True pin, begin typing print string and select
the Print String node.

In the Print String node, in the In String field, enter some text to indicate success (e.g., Request
Succeeded).

In the Branch node, left-click and drag off from the False pin, begin typing print string and
select the Print String node.

. In the Print String node, in the In String field, enter some text to indicate failure (e.g., Request

Failed).

J Print String

»
InString
< D3 Controller Settings Development Only
z Branch v
— True

f Print String

Condition False [ -.______-“-_
»

DevelopmentOnly

w

D3 Feedback Nodes

When the command is executed, the success or failure of the command is indicated.
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8. Continue with the procedure for the specific D3 blueprint you want.
Get D3 API Version
Get D3 Controller Settings
Get D3 Controllers Id List
Set D3 Controller Brightness
Get D3 Health Status
Set D3 Selected Scene
Get D3 UI Refresh Rate

To create a Get D3 API Version blueprint:

1. In an empty area of the blueprint, right-click and begin typing string append and select the Append
node.

2. Connect the D3APIVersion pin of the Custom Event node to the B Input pin of the Append node.

3. In the Append node, in the A Input field, enter name of the custom event (e.g., API Version).

4. In the Append node, left-click and drag off the Return Value pin, begin typing print string and
select the Print String node.

5. Connect the Output pin of the Print String node connected to the True pin of the Branch node to
the Input pin of the new Print String node.

Your blueprint will be similar to the blueprint below:

T Get D3 API Version

f Print String

Configuration /.— 1
ol

ion Reque

Development Only

nfiguration :'ll Branch l
> True [ F Print String

Condition False B

&> AP Version Development Only;

w

7 Append C J Print String
AlA N Return Value »

Add pin ® In String
Development Only

W

Get D3 API Version Blueprint
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To create a Get D3 Controller Settings blueprint:

1. In the Custom Event node, left-click and drag off from the D3Controller Settings pin and select the
Break D3 Controller Settings node.

2. Select the arrow at the bottom of the Break D3 ControllerSettings node to expand it.

3. In the Break D3Controller Settings node, decide which settings you want to get and do the
following:

e For each setting that is a string, right-click in an empty part of the blueprint, begin typing string
append and select the Append node.

Connect the setting pin to the B Input pin In the Append node.

In the Append node, in the A Input field, enter the name of the setting to which it is connected.

f JF Append

Add Append Node - String

e For each setting that is an integer, left-click and drag off from the pin, begin typing string append
and select the Append node.

The To String (Integer) node is automatically inserted between the setting pin and the Append
node.

Disconnect the Output pin of the To String (Integer) node from the A Input pin of the Append
node and connect it instead to the B Input pin.

In the Append node, in the A Input field, enter the name of the setting to which it is connected.

Add To String (Integer) Node and Append Node

e For each setting that is a Boolean, left-click and drag off from the pin, begin typing string append
and select the Append node.

The To String (Boolean) node is automatically inserted between the setting pin and the Append
node.

Disconnect the Output pin of the To String (Boolean) node from the A Input pin of the Append
node and connect it instead to the B Input pin.

In the Append node, in the A Input field, enter the name of the setting to which it is connected.

Add To String (Boolean) Node and Append Node
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e For each setting that is an enum, left-click and drag off from the pin, begin typing string append
and select the Append node.

The Enum to String node is automatically inserted between the setting pin and the Append node.

Disconnect the Return Value pin of the Enum to String node from the A Input pin of the Append
node and connect it instead to the B Input pin.

In the Append node, in the A Input field, enter the name of the setting to which it is connected.

f J Append

Add To String (Enum) Node and Append Node

e For each setting that is an array, begin typing join string array and select the Join String Array
node.

Right-click in an empty part of the blueprint, begin typing string append and select the Append
node.

Connect the Return Value pin of the Join String Array node to the B Input pin of the Append
node.

In the Join String Array node, in the Separator field, enter a character (e.g., comma) to separate
the items in the resulting list.

In the Append node, in the A Input field, enter the name of the setting to which it is connected.

*F Join String Amray

Add Join String Array Node and Append Node
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4. Now, left-click and drag off the Return Value pin of each Append node, begin typing print string
and select the Print String node.

I Print String

n Strang

Development Onhy
T

Add Print String Node

Connect the Output pin of the Print String node that is connected to the True pin of the Branch
node, to the Input pin of the first setting Print String node.

. Connect the Output pin of the first setting Print String node to the Input pin of the second setting
Print String node.

. Continue connecting the Print String nodes until they are all connected.

Your blueprint will be similar to the blueprint below:

*F Get D3 Controller Settngs ¥ Print String

> D3 Controller Settings

' Print String

_ 7 Print String
7 Append C
» »
a8 P Nty e

n string )

DéVelopmantOniy
v

o~

C F Prnt String
1

Gy

C F Print Stng
» »

7

“F Append

Get D3 Controller Settings Blueprint
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To create a Get D3 Controllers Id List blueprint:
1. In the Custom Event node, left-click and drag off the D3Id List pin, begin typing join string array
and select the Join String Array node.

2. In the Join String Array node, in the Separator field, enter a character (e.g., comma) to separate
the items in the resulting list.

3. Then left-click and drag off the Return Value pin, begin typing print string and select the Print
String node.

4. Connect the Output pin of the Print String node that is connected to the True pin of the Branch
node, to the Input pin of the new Print String node.

Your blueprint will be similar to the blueprint below:

T Get D3 Controllers Id List

D3Server Configuration

F Print String

On Id List Request Completed

Development Only
er Configuration v

F Print String

:|: Branch b »

» True B In String [R ailed |

Condition False B Development Only
A

J Print String

In String

©F Join String Array

D3Id List Source Array Return Value

separator [, |
I Development Only,

~

Get D3 Controllers Id List Blueprint
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To create a Set D3 Controller Brightness blueprint:

e In the Set D3 Controller Brightness node, in the Brightness field, enter a value between 0 - 100.

E=E 1
Pressed [

Released [ J Set D3 Controller Brigﬁtness

D35Server Configuration
»= Make D3ServerConfiguration

o O Bright JF Print String
ver Configuration

On Reguest Completed

Auth Token [ssssasssases |

Development Only
:I ! Branch
<> D3 Controller Brightness -

W

» True
/ F Print String
» Condition

False
"-u““‘-‘- .

In String | Reque

Development Only

W

Set D3 Controller Brightness Blueprint
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To create a Get D3 Health Status blueprint:

1. In the Custom Event node, left-click and drag off the D3Health Status pin, begin typing switch and
select the Switch on ED3HealthStatus node.

The Output pin of the Custom Event node is automatically connected to the Input pin of the Switch
on ED3HealthStatus node.

2. Then connect each of the Status pins to nodes that will initiate the desired response to the status.

Your blueprint will be similar to the blueprint below:

1 F Get D3 Health Status
Pressed p ——— P
Releas > D3server Configuration
Key On Health Status Request Completed

I Print String

L __ »
>= Make D3ServerConfiguration -|: Branch /
C True B

D3Server Configuration ()]

Condition False p Development Only
v

I Print String

In String [ Re led]

&> D3 Health Status

(T ——————————
£* Switch on ED3HealthStatus
_ Unhealthy >
Development Only
Selection Healthy > v

Advisory >

Unkno

Get D3 Health Status Blueprint
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To create a Set D3 Selected Scene blueprint:

e In the Set D3 Selected Scene node, in the Selected Scene Id field, enter the number of the selected

scene.

Your blueprint will be similar to the blueprint below:

»= Make D3ServerConfiguration

er Configuration

3 Selected Scene

Set D3 Selected Scene Blueprint

T Set D3 Selected Scene

D ser Configuration
Selected

On Request Completed

:I : Branch ;
» i 2

Condition

False \

I Print String

»
In String
Development Only
W

I Print String

In string [ Re 1]

pment Only
v
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To create a Get D3 UI Refresh Rate blueprint:

1. In the Custom Event node, left-click and drag off the D3UIRefresh Rate in Seconds pin, begin typing
print string and select the Print String node.
If you don't get any results, deselect the Context Sensitive checkbox and retry.

The connecting node, To String (Integer) will be inserted automatically between the Custom Event
node and the Print String node.

2. Connect the Output pin of the Print String node that is connected to the True pin of the Branch
node, to the Input pin of the new Print String node.

Your blueprint will be similar to the blueprint below:

ER1

Pressed [ \ F Get D3 Ul Refresh Rate .
Released [ »

Key D3Server Configuration

»
On UIRefresh Rate Request Completed
~= Make D3ServerConfiguration L
) D3Server Configuration
Auth Toker L :I: Branch -
» True B T »
nds @ C

F Print String

& D3 Ul Refresh Rate Condition False [

F Print String

D3UIRefresh Rate in S

]
In String

Development Only
v

Get D3 UI Refresh Rate Blueprint
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Face Settings

Use the D3 Face Settings nodes to get and set data for an individual display screen in an LED panel.
The first procedure described below applies to all of the nodes. The procedures following the first one
pertain to specific nodes.

To begin creating a blueprint for any D3 Face Settings action:

1. Select the arrow beside the Blueprints icon and select Open Level Blueprint.

2. Right-click in the blueprint and in the Search field, begin typing D3 and from the results, select the D3
node you want.

3. In any D3 node, left-click and drag off from the D3Server Configuration pin and from the Actions
providing a(n) D3Server Configuration Structure menu, select Make 3DServerConfiguration.

I Get D3 Face Settings

D3Server Configuration

viding a(n) D3Server
Configuration Structure

Context Sensitive

Utilities

Make D3ServerConfiguration

4. In the Make D3ServerConfiguration node, do the following:
e In the Ip field, enter the IP address of the D3 server.
e In the Port field, enter the port number for the D3 server.

e In the Auth Token field, enter your token number.

" F Get D3 Face Settings
»= Make D3ServerConfiguration

Ip | D3Server Configuration
rer Configuration

Port |

Face Id |:|

FDTTE | On Face Settings Request Completed

D3 Server Configuration

5. Right-click in the blueprint and select a trigger (e.g., a button press, or a RossTalk GPI Event node).
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6. Connect the Output pin of the trigger node to the Input pin of the D3 node.

J Get D3 Face Settings

Auth Token |:|

Add Trigger

7. In the D3 node, in the Face Id field, enter the identification number of the display screen for which to
get or set data.

There is no Face Id field in the Get D3 Faces Id List node.

8. Add Feedback nodes as follows:

a.

In the D3 node, left-click and drag off from the Request Completed pin, begin typing add custom
event and select the Add Custom Event node.

The Custom Event node will differ depending on the D3 node to which it is connected.

. Give the Custom Event node a unique name that corresponds to the D3 node.

In the Custom Event node, left-click and drag off from the Success pin, begin typing branch and
select the Branch node.

The Output pin of the Custom Event node is automatically connected to the Input pin of the
Branch node.

. In the Branch node, left-click and drag off from the True pin, begin typing print string and select

the Print String node.

In the Print String node, in the In String field, enter some text to indicate success (e.g., Request
Succeeded).

In the Branch node, left-click and drag off from the False pin, begin typing print string and
select the Print String node.

. In the Print String node, in the In String field, enter some text to indicate failure (e.g., Request

Failed).

J Print String

<> D3 Face Brightness d ]

r Branch

= Development Only

» True [ ~

False [p
\ J Print String
»

Condition

Development Only

D3 Feedback Nodes

When the command is executed, the success or failure of the command is indicated.
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9. Continue with the procedure for the specific D3 blueprint you want.
Get D3 Face Settings
Set D3 Face Settings
Get D3 Faces Id List
Set D3 Face Brightness
Set D3 Face Offsets
Set D3 Face Color Adjustments

To create a Get D3 Face Settings blueprint:
1. In the Custom Event node, right-click the D3 Face Settings pin and from the menu, select Split
Struct Pin.

The D3 Face Settings pin is expanded to show all the settings.

2. Left-click and drag off the D3 Face Settings Id pin, begin typing string append and select the
Append node.

3. Disconnect the D3 Face Settings Id pin from the A Input pin of the Append node and connect it
instead to the B Input pin.

4. Then in the A Input field of the Append node, enter the name of the setting (e.g., Face Settings ID).

5. For any of the remaining D3 Face Settings, left-click and drag off from the pin, begin typing string
append and select the Append node.

The To String (Integer) node is automatically inserted between the setting pin and the Append
node.

6. Disconnect the setting pin from the A Input pin of the Append node and connect it instead to the B
Input pin.

7. In each Append node, in the A Input field, enter the name of the setting from which it originates
(e.g., Brightness, Red Color Adjustment, etc.)

8. For each Append node, left-click and drag off from the Return Value pin, begin typing print string
and then select the Print String node.
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9. Connect the Output pin of one Print String node to the Input pin of the next Print String node.

Your blueprint will be similar to the blueprint below:

[ Print String

J Print

n String

Developm
v

P

C S _Print String
»

C I Print String
] »

7

Get D3 Face Settings Blueprint
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To create a Set D3 Face Settings blueprint:

1. In the Set D3 Face Settings node, left-click and drag off from the D3Face Settings pin and select
the Make D3FaceSettings node.

2. In the Make D3FaceSettings node, set the required parameters as described below:

In the Id field, enter the identification number of the display you want to configure.
In the Brightness field, enter a value from 0 - 100 for the level of brightness for the display.

In the Red, Green and Blue Color Adjustment fields, enter values from 0 - 100 to modify those
colors in the display.

In the Offset X field, enter the pixel value from the top left of the screen to offset the input in the
display, on the X axis.

In the Offset Y field, enter the pixel value from the top left of the screen to offset the input in the
display, on the Y axis.

Your blueprint will be similar to the blueprint below:

f Set D3 Face Settings

ServerConfiguration . L
f Print String
Configuration

On Request Completed !
d]

Development Only

W

Auth Toke

E Branch

= Make D3FaceSettings -
» True B

C ol False [
f Print Strin
N g Settinas 02 g
<> Set Face Settings 02
»

In

Development Only

w

Set D3 Face Settings Blueprint
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To create a Get D3 Faces Id List blueprint:
1. In the Custom Event node, left-click and drag off the D3Id List pin, begin typing 1oop and select the
For Each Loop with Break node.

2. In the For Each Loop with Break node, left-click and drag off the Array Element pin, begin typing
print string and select the Print String node.

3. Connect the Loop Body pin to the Print String Input pin.

4. Connect the Output pin of the Print String node that is connected to the True pin of the Branch
node to the Input pin of the new Print String node.

Your blueprint will be similar to the blueprint below:

J Get D3 Faces Id List
» o f Print String

Cenfiguration

ser Configuration

E Branch

» True [p
. ) ]
Auth Tok Condition False [p —T

f Print String

Development Only,
<> Get D3 Id List

€5 For Each Loop with Break ! F Print String
Su [ Exec Loop Body [ » (]

D3ld List Array Element In String

Array Index C Development Only

w

Get D3 Faces Id List Blueprint
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To create a Set D3 Face Brightness blueprint:
e In the Set D3 Face Brightness node, in the Brightness field, enter a value from 0 - 100 for the level
of brightness of the selected face.

Your blueprint will be similar to the blueprint below:

F Set D3 Face Brightness

»= Make D3ServerConfiguration
ver Configuraticn > Bri C T Print E‘-tr‘ing
On Request Completed
Auth Token
Development Only

w

3 Face Brightness

E Branch

F Print String

Condition

Development Only,

W

Set D3 Face Brightness Blueprint
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To create a Set D3 Face Offsets blueprint:
1. In the Set D3 Face Offsets node, in the Offset X field, enter a pixel value from the top-left of the
screen for the amount of offset required for the selected face, on the X axis.

2. In the Offset Y field, enter a pixel value from the top-left of the screen for the amount of offset
required for the selected face, on the Y axis.

Your blueprint will be similar to the blueprint below:

I Set D3 Face Offsets

Configuration

Face Id |04 |

D3Server Configuration
On Request Completed
F Print String

Auth Token | ** »

<> D3 Face Offsets - 04

T Branch Development Only

(¥

» True [
Condition False [ \ F Print String
»

t Failed |

DevelopmentOnly,

L]

Set D3 Face Offsets Blueprint
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To create a Set D3 Face Color Adjustments blueprint:

e In the Set D3 Face Color Adjustments node, enter values from 0 - 100 in the Red Adjustment,
Green Adjustment and Blue Adjustment fields to modify those colors in the selected face.

Your blueprint will be similar to the blueprint below:

f Set D3 Face Color Adjustments

»
xnfiguraticn
Face Id [05 |
- - - Red Adjustment I_I|
>= Make D3ServerConfiguration =

T ) ~» Green Adjustment |0
ver Configuration reen Adjustment [0 ]

Blue Adjustment |0 |

h S Print String

On Request Completed

Auth Token

<> D3 Face Color Adj

E Branch Development Only

—_— True [p

Condition False [p \ J Print String
»

W

DevelopmentOnly.

W

Set D3 Face Color Adjustments Blueprint
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Playlist Commands

Use the Playlist Commands to control the playout of videos and to select the playlist you want to use.
There are 2 playlist commands:

Execute D3 Playlist Button Command — switches between playlists

Execute D3 Playlist Command — controls the playout of a video playlist (Play, Pause, Next, Previous and
Stop)

To use the Execute D3 Playlist Button Command:

1. Select the arrow beside the Blueprints icon and select Open Level Blueprint.

2. Right-click in the blueprint and in the Search field, begin typing D3 and from the results, select the
Execute D3 Playlist Button Command node.

3. Left-click and drag off from the D3Server Configuration pin and from the Actions providing a(n)
D3Server Configuration Structure menu, select Make 3DServerConfiguration.

J Execute D3 Playlist Button Command

D3Server Configuration
]
Enabled

On Request Completed

ding a(n) D3Server

Context Sensitive

Utilities
D Ad

- Ma

Make D3ServerConfiguration - Playlist Button

4. In the Make D3ServerConfiguration node, do the following:
e In the Ip field, enter the IP address of the D3 server.
e In the Port field, enter the port number for the D3 server.

e In the Auth Token field, enter your token number.

"7 Execute D3 Playlist Button Command

»= Make D3ServerConfiguration D3server Configuration

D3Server Configuration

Enabled

On Reguest Completed

D3 Server Configuration - Playlist Button
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5. Right-click in the blueprint and select a trigger (e.g., a button press, or a RossTalk GPI Event node).

6. Connect the Output pin of the trigger node to the Input pin of the Execute D3 Playlist Button

Command node.

7. In the Execute D3 Playlist Button Command node, enter the number of the Playlist Button.

Your blueprint will be similar to the blueprint below:

B2
Pressed [
Released [

Key

= Make D3ServerConfiguration

D3Server Configuration

Execute D3 Playlist Button Command Blueprint

To use the Execute D3 Playlist Command node:

1. Select the arrow beside the Blueprints icon and select Open Level Blueprint.

" f Execute D3 Playlist Button Command

D3Server Configuration

Enabled

On Request Completed

2. Right-click in the blueprint and in the Search field, begin typing D3 and from the results, select the

Execute D3 Playlist Command node.

3. Left-click and drag off from the D3Server Configuration pin and from the Actions providing a(n)
D3Server Configuration Structure menu, select Make 3DServerConfiguration.

" F Execute D3 Playlist Command

D3server Configuration
Playlist Id [01]
Command

(n) D3Server »
. Context Sensitive

Configuration Structure

Q

Promaof iable

utilities

Make D3ServerConfiguration - Playlist
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4,

In the Make D3ServerConfiguration node, do the following:
e In the Ip field, enter the IP address of the D3 server.
e In the Port field, enter the port number for the D3 server.

e In the Auth Token field, enter your token number.

f T Execute D3 Playlist Command

= Make D3ServerConfiguration D3Server Configuration

| D3Server Configuration Playlist Id |_|

Command

On Request Completed

D3 Server Configuration - Playlist

Right-click in the blueprint and select a trigger (e.g., a button press, or a RossTalk GPI Event node).

. Connect the Output pin of the trigger node to the Input pin of the Execute D3 Playlist Command

node.

“F Execute D3 Playlist Command

Pressed [ -—-—--._.________________
~ »
Released [
ser Configuration
Key ol
Playlist 1d [01]

»= Make D3ServerConfiguration Command
= = Pause
D3Server Configuration

On Request Completed

Auth Token |]

Add Trigger

. Add Feedback nodes as follows:

a. In the Execute D3 Playlist Command node, left-click and drag off from the On Request
Completed pin, begin typing add custom event and then select the Add Custom Event node.

b. Give the Custom Event node a unique name that corresponds to the Execute D3 Playlist
Command node.

c. In the Custom Event node, left-click and drag off from the Success pin, begin typing branch and
then select the Branch node.

The Output pin of the Custom Event node is automatically connected to the Input pin of the
Branch node.

d. In the Branch node, left-click and drag off from the True pin, begin typing print string and then
select the Print String node.

e. In the Print String node, in the In String field, enter some text to indicate success (e.g., Request
Succeeded).

f. In the Branch node, left-click and drag off from the False pin, begin typing print string and then
select the Print String node.
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g. In the Print String node, in the In String field, enter some text to indicate failure (e.g., Request
Failed).

F Print String

© D3 Playlist

:|: Branch y
. Development Only
» — True [ v

Condition False |p
\ F Print String

D3 Feedback Nodes
When the command is executed, the success or failure of the command is indicated.
8. In the Execute D3 Playlist Command node, do the following:
e In the Playlist Id field, enter the number of the playlist you want to control.

e From the Command drop-down, select the action you want to initiate when the trigger is received,
either Stop, Previous, Pause, Play, or Next.

Your blueprint will be similar to the blueprint below:

J Execute D3 Playlist Command
»
D ver Configuration
Playlist Id [10]

Command
»= Make D3ServerConfiguration

ver Configuration
est Completed

—
Auth Token |+ f Print 5tring

<> D3 Playlist

: Branch

5 Development Only

e J True P v
Condition False |p \ f Print String

DevelopmentOnly,

W

Execute D3 Playlist Command Blueprint
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Using Voyager Charts

Use Voyager charts to add a graphic representation of data from your DatalLing source. You can choose
from pie charts, column/bar charts, and line charts, including multi-line charts.

This feature requires that the Voyager Charts Plugin and the DatalLing Plugin be enabled and that you
have a valid DatalLing Plugin License.

For instructions on enabling the Voyager Charts Plugin and Dataling Plugin, see Enabling the Voyager
Plugins.

You will need to have a Dataling source configured to populate your chart. For more information, see
Adding a DatalLing Source to the XPression Datalinqg Server.

Pie Charts
Column/Bar Charts
Line Charts

Multi-Line Charts
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Creating a Pie Chart

When you create a pie chart, the values, labels and colors come from the source data.
To create a Pie chart:

1. Add a DataLinq Multi-Value Actor to the level and configure it as described in Adding a Datalinqg
Multi Value Actor.

2. In the Place Actors tab, from the Voyager Charts category, select a Pie Chart and drag it into the
level.

e Ve

VOYAGER CHARTS

Column Chart

Pie Chart

Line Chart

Select a Voyager Chart

3. Select the Blueprint icon and select Open Level Blueprint.

G Open Blueprint Class. .
it Open Level Blueprint

# GameMode: GameModeBase

Open Level Blueprint

4. Select your DataLinq Multi-Value Actor in the Outliner and then right-click in an empty area of the
blueprint, expand Add Event for DataLing MultiValue Actor, expand Voyager - DatalLinqg and select
Add On Data Update.

All Actions for this Blueprint Context Sensitive

Add Event for Data Ling Multi Value Actor 1
Col on
Game
Input

on Data Ling Multi \

Datalinqg Blueprint - Add On Data Update
The On Data Update node is added to the blueprint.
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5. In the On Data Update node, right-click the Data pin and select Split Struct Pin.

pdate (Election_Data)

Promote to Variable
Split Struct Pin

DatalLing Blueprint - Split Struct Pin

6. With your chart selected in the Outliner, right-click in an empty area of the blueprint and in the All
Actions for this Blueprint list, expand Call Function on..., expand Voyager Charts, and then select
Animate to State from String Array.

All Actions for this Blueprint Context Sensitive
Add Event for IX Pie Chart 1
Call Function on IX Pie Chart 1
Al
Game
Idonix
Level

Accessibility

Voyager Charts - Call Function

The reference object for the chart and the Animate to State from String Array node are added to
the blueprint.

" @ 1X_PieChart

F Animate to State from String Array

IX Base ACLO

Target

Is Immediate

Voyager Charts - Animate to State from String Array
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7. In the Animate to State from String Array node, from the Data Type drop-down, select the data
you want to display in the chart.

The options are:

e Value Only

e Value and Label (in your data source, make sure that the data is added in the same order)

e Value, Label and Color (in your data source, make sure that the data is added in the same order)

For example, in the image below, the data corresponds to Value, Label and Color.

DataLing

Add

Remi

Voyager Charts - Pie Chart Data
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8. Connect the On Data Update node as follows:

e Connect the Exec pin of the On Data Update node to the Exec pin of the Animate to State from
String Array node.

e Connect the Data Values pin of the On Data Update node to the Data pin of the Animate to State
from String Array node.

" @ 1%_PieChart

<> On Data Update (DL_Elections) J m String Array

Data Size Or
Target
Data Values
Data
Data Value 1
Data
Data Value 2

Data Value 3
Is Immediate
Data Value 4
Data Value 5
Data Value 6
Data Value 7
Data Value 8
Data Value 9

Data Value 10

Voyager Charts - Pie Chart Blueprint
9. Save and compile your blueprint.

10.Press the Play (PIE) button to see your chart automatically generated with an IN animation
displaying your Datalinq data.

Play Button

Other
40,000,000

Democrats
71,200,000

=

Voyager Charts - Pie Chart Example
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Creating a Column/Bar Chart

When you create a column/bar chart, the values, labels and colors are retrieved from the source data.

To create a Column/Bar chart:
1. Add a DataLinq Multi-Value Actor to the level and configure it as described in Adding a Datalinqg
Multi Value Actor.

2. In the Place Actors tab, from the Voyager Charts category, select a Column Chart and drag it into
the level.

e Ve

VOYAGER CHARTS

Column Chart

Pie Chart

Line Chart

Select a Voyager Chart

3. Select the Blueprint icon and select Open Level Blueprint.

G Open Blueprint Class. .
it Open Level Blueprint

# GameMode: GameModeBase

Open Level Blueprint

4. Select your DataLinq Multi-Value Actor in the Outliner and then right-click in an empty area of the
blueprint, expand Add Event for DataLing MultiValue Actor, expand Voyager - DatalLinqg and select
Add On Data Update.

All Actions for this Blueprint Context Sensitive

Add Event for Data Ling Multi Value Actor 1
Col on
Game
Input

on Data Ling Multi \

Datalinqg Blueprint - Add On Data Update
The On Data Update node is added to the blueprint.
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5. In the On Data Update node, right-click the Data pin and select Split Struct Pin.

pdate (Election_Data)

Promote to Variable
Split Struct Pin

DatalLing Blueprint - Split Struct Pin

6. With your chart selected in the Outliner, right-click in an empty area of the blueprint and in the All
Actions for this Blueprint list, expand Call Function on..., expand Voyager Charts, and then select
Animate to State from String Array.

All Actions for this Blueprint Context Sensitive
Add Event for IX Pie Chart 1
Call Function on IX Pie Chart 1
Al
Game
Idonix
Level

Accessibility

Voyager Charts - Call Function

The reference object for the chart and the Animate to State from String Array node are added to
the blueprint.

JF Animate to State from String Array
" @ 1X_ColumnChart e Actor

Target

Data

Data Type

Value, Label r (alternate) s

Is Immediate

Voyager Charts - Animate to State from String Array

Voyager User Guide (v7.1) Using Voyager Charts « 267



7. In the Animate to State from String Array node, from the Data Type drop-down, select the data

you want to display in the chart.
The options are:

e Value Only

e Value and Label (in your data source, make sure that the data is added in the same order)

e Value, Label and Color (in your data source, make sure that the data is added in the same order)

For example, in the image below, the data corresponds to Value, and Label.

DataLing ]

ColumnChartData ~

Set Data

Voyager Charts - Column Chart Data

Add

Remt

8. Connect the On Data Update node as follows:

e Connect the Exec pin of the On Data Update node to the Exec pin of the Animate to State from

String Array node.

e Connect the Data Values pin of the On Data Update node to the Data pin of the Animate to State

from String Array node.

e B F —_—
&> On Data Update (US_Elections) @ 1x_ColumnChart

Data Values
Data Value 1
Data Value 2
Data Value 3
Data Value 4
Data Value 5
Data Value 6
Data Value 7
Data Value 8

Data Value

Data Value 10

Voyager Charts - Column Chart Blueprint

9. Save and compile your blueprint.

Target
Data

Data Ty

Is Immediate
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10.Press the Play (PIE) button.

Play Button

Your column chart is automatically generated with an IN animation displaying your DatalLinqg data.

Voyager Charts - Column Chart Example
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Creating a Line Chart

When you create a line chart, the values and labels are retrieved from the source data.

To create a Voyager chart:

1. Add a DataLinq Multi-Value Actor to the level and configure it as described in Adding a Datalinqg
Multi Value Actor.

2. In the Place Actors tab, from the Voyager Charts category, select a Line Chart and drag it into the
level.

e Ve

VOYAGER CHARTS

Column Chart

Pie Chart

Line Chart

Select a Voyager Chart

3. Select the Blueprint icon and select Open Level Blueprint.

G Open Blueprint Class. .
it Open Level Blueprint

# GameMode: GameModeBase

Open Level Blueprint

4. Select your DataLinq Multi-Value Actor in the Outliner and then right-click in an empty area of the
blueprint, expand Add Event for DataLing MultiValue Actor, expand Voyager - DatalLinqg and select
Add On Data Update.

All Actions for this Blueprint Context Sensitive

Add Event for Data Ling Multi Value Actor 1
Col on
Game
Input

on Data Ling Multi \

Datalinqg Blueprint - Add On Data Update
The On Data Update node is added to the blueprint.
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5. In the On Data Update node, right-click the Data pin and select Split Struct Pin.

pdate (Election_Data)

Promote to Variable
Split Struct Pin

DatalLing Blueprint - Split Struct Pin

6. With your line chart selected in the Outliner, right-click in an empty area of the blueprint and in the
All Actions for this Blueprint list, expand Call Function on..., expand Voyager Charts, and then
select Animate to State from String Array.

All Actions for this Blueprint Context Sensitive
Add Event for IX Pie Chart 1
Call Function on IX Pie Chart 1
Al
Game
Idonix
Level

Accessibility

Voyager Charts - Call Function

The reference object for the chart and the Animate to State from String Array node are added to
the blueprint.

* @ IX_LineChart -—_
F Animate to State from String Array

base ACIK

Target

Data

Data Type

nd Label (alternate)

Is Immediate

Voyager Charts - Animate to State from String Array
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7. In the Animate to State from String Array node, from the Data Type drop-down, select the data
you want to display in the chart.

The options are:

e Value Only

e Value and Label (in your data source, make sure that the data is added in the same order)

e Value, Label and Color (in your data source, make sure that the data is added in the same order)

For example, in the image below, the data corresponds to Value (Votes) and Label (Year).

DataLing

LineChartData ~

Add

Remt

Set Data

Voyager Charts - Line Chart Data

272 + Using Voyager Charts Voyager User Guide (v7.1)



8. Connect the On Data Update node as follows:

e Connect the Exec pin of the On Data Update node to the Exec pin of the Animate to State from
String Array node.

e Connect the Data Values pin of the On Data Update node to the Data pin of the Animate to State
from String Array node.

& On Data Update (US_Election) " @ 1X_LineChart

Data Size Or

Data Values J Animate to State from String Array

Data Value 1

Target

Data Value 2
Data Value 3
Data Value 4
Data Value 5
bel (alternate)
Data Value 6
Data Val Is Immediate
ata Value 7
Data Value 8

Data Value 9

Data Value 10

Voyager Charts - Line Chart Blueprint
9. Save and compile your blueprint.

10.Press the Play (PIE) button.

Play Button

Your line chart is automatically generated with an IN animation displaying your Datalinqg data.

0.0

Voyager Charts - Line Chart Example

(AR R R R RNARANRNRRAREN
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Creating a Multi-Line Chart

When you create a multi-line line chart, you'll configure the line legends, line colors, and the X Axis labels
in the blueprint. You'll also need 2 DataLinq Multi Value Actors, one to retrieve the data values for your
chart and one to provide the X Axis labels.

Ensure that the number of data values in your DatalLing source is a multiple of the number of lines in
your chart. For example, if you have 3 lines then you need to have 3, 6, 9, etc. data values so that each
line will have the same number of points.

To create a multi-line chart:
1. Add a DatalLinq Multi Value Actor to the level and configure it as described in Adding the Dataling

Multi Value Actor.

This DataLinq Multi Value Actor will draw only the values from the data source. All the values for the
first line should be selected first, followed by all the values for the second line, etc.

2. Add a second DatalLinq Multi Value Actor to the level and configure it as described in Adding the
Dataling Multi Value Actor.

This DataLinq Multi Value Actor will draw only the X Axis labels from the data source.

3. In the Place Actors tab, from the Voyager Charts category, select the Line Chart and drag it into
the level.

e Ve

VOYAGER CHARTS

Column Chart

Pie Chart

Line Chart

Select a Voyager Chart

4. Select the Blueprint icon and select Open Level Blueprint.

=2 New Empty Blueprint Class...
#* Convert Selection to Blueprint Class
G Open Blueprint Class. .

it Open Level Blueprint

# GameMode: GameModeBase

Open Level Blueprint
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5.

6.

In the Outliner, select your DataLinq Multi-Value Actor and then right-click in an empty area of the
blueprint, expand Add Event for DataLinqg MultiValue Actor, expand Voyager - DataLinq and select
Add On Data Update.

All Actions for this Blueprint

Q

Add Event for Data Ling Multi Value Actor 1
Colhision
Game

Input

DatalLinq Blueprint - Add On Data Update
The On Data Update node is added to the blueprint.
In the On Data Update node, right-click the Data pin and select Split Struct Pin.

On Data Update (Election_Data

Promote to Variable
Split Struct Pin

DatalLing Blueprint - Split Struct Pin

. With your line chart selected in the Outliner, right-click in an empty area of the blueprint and in the

All Actions for this Blueprint list, expand Call Function on... , expand Voyager Charts, and select
Animate to State from String Array Multi Line.

All Actions for this Blueprint Context Sensitive
Q

Add Event for IX Line Chart 1

Call Function on 1X Line Chart 1

Al

Game
Idonix
Level
Networking

Voyager Charts - Add Call Function - Multi Line
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The reference object for the chart and the Animate to State from String Array Multi Line node are
added to the blueprint.

- - _—
@ IX_LineChart F Animate to State from String Array Multi Line

Target
Line Legend
Line Color
Label XAxis
Data Values

Is Immediate

Voyager Charts - Animate to State from String Array Multi Line

To configure the line legends:

1. In the Animate to State from String Array Multi Line node, right-click the Line Legend pin and
select Promote to Variable.
A Line Legend variable node is added to the blueprint.

2. Select Save and Compile.

3. In the Variables list on the left side of the blueprint, select the Line Legend variable.

In the Details tab on the right side of the blueprint, under Default Value, you'll now see the Line
Legend variable.

& Details

Default

Voyager Charts - Details Tab

4. In the Details tab, in the Line Legend variable, select the + icon beside Array Elements to add as
many elements as you want lines in your graph.

5. Give each array element a name that corresponds to the data for the line.
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To configure the line color:

1.

2.
3.

4.

5.

In the Animate to State from String Array Multi Line node, right-click the Line Color pin and select
Promote to Variable.

A Line Color variable node is added to the blueprint.
Select Save and Compile.
In the Variables list on the left side of the blueprint, select the Line Color variable.

In the Details tab on the right side of the blueprint, under Default Value, you'll now see the Line
Color variable.

In the Details tab, in the Line Color variable, select the + icon beside Array Elements to add a color
for each line in your graph.

Double-click the bar for each Array Element and use the Color Picker to select a color for the line.
The color for the first line corresponds to the first value in your data source.

The color for the second line corresponds to the second value in your data source, etc.

/- Details

2 Array elements

Voyager Charts - Details Tab - Line Color
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To configure the X Axis labels:

1. In the Animate to State from String Array Multi Line node, right-click the Label X Axis pin and
select Promote to Variable.

2. Select Save and Compile.

3. In the Variables list on the left side of the blueprint, select the Label X Axis variable.

In the Details tab on the right side of the blueprint, under Default Value, you'll now see the Label X
Axis variable.

4. In the Details tab, in the Label X Axis variable, select the + icon beside Array Elements to add an
array element for each label on the horizontal axis (X axis) of your chart.

5. In each array element, enter the label name, in the order in which you want them to appear on the
chart (which should match the order in which they appear in the data source).

To get values from your data source:

1. In the Variables list on the left side of the blueprint, select the + icon beside Variables to add a new
variable to represent the data from your data source and give the variable a name (e.g., My Data).

2. With the new variable selected, in the Details tab, from the Variable Type drop-downs, select String
and Array.

3. Drag the variable into the blueprint and from the menu, select Set My Data.
The Set variable node is added to the blueprint.
4. Connect the On Data Update node as follows:
e Connect the Exec pin of the On Data Update node to the Exec pin of the Set variable node.

e Connect the Data Values pin of the On Data Update node to the Data Values pin of the Set
variable node (the Data Values pin will have the name you entered for the Set variable).

<> On Data Update (US_Elections_By_Year)

\-o =L

Data Values My Data

Data Size O»

Data Value 1

Data Value 10

Voyager Charts - Set Data

5. In the Animate to State from String Array Multi Line node, left-click and drag off the Data Values
node and in the Search field, begin typing the name of the Set variable you created.

6. Then select the Get variable node for your Set data variable.
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7. Connect the Output pin of the Set Data node to the Input pin of the Animate to State from String
Array Multi Line node.

Vistalizelyatal
<> On Data Update (US_Elections_By_Year)

@ 1X_LineChart

My Data

f Animate to State from String Array Multi Line

»

Line Legend

Is Immediate

My Data

8. Save and compile your blueprint.

9. Press the Play (PIE) button.

Play Button

(RNARNRRNRRRRRUNRRARARE

Voyager Charts - Multi-Line Chart Example
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Timecode

Use the Timecode feature to schedule and execute events through Blueprints or using RossTalk. Events
can be scheduled to occur at a specific hour, minute, second, and frame.

You will first need to configure the Timecode Provider. Then set up Timecode events using blueprint
nodes in the level blueprint or schedule Timecode events using a RossTalk command.

You can also configure frame delays to fine tune the timing of the events.
Configuring the Timecode Provider

Configuring Frame Delays

Setting up Timecode Events in the Level Blueprints

Scheduling Timecode Events Using a RossTalk Command
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Configuring the Timecode Provider

The Timecode Provider allows the timecode to be read every frame and enables you to schedule and
trigger events on certain timecodes. To use the Timecode Provider, you will need to configure it inside
the media profile.

Once you have configured the Timecode Provider, you can then use the Timecode for setting up events
in the level blueprint or scheduling them with a RossTalk command.

The following procedures are covered in this section:
To configure the Timecode Provider - Matrox
To configure the Timecode Provider - Adrienne LTC

To view the Timecode Provider

To configure the Timecode Provider - Matrox:

1. Double-click the Media Profile icon in the main tool bar to open the editor.

",,T.-‘ Platforms E VP Roles v

Media Profile Icon

2. In the Media Profile editor, expand the proxy media source for the input whose timecode you want
to read.

3. Expand Ross Matrox and from the Timecode Format field drop-down, select VITC.

Select Timecode Format
4. Expand the Timecode Provider section and select the Override Project Settings checkbox.

5. From the Timecode Provider drop-down, select RossMatrox SDI Input.

Format
@ DSXLE4/8/100F Single Link 1 HD 720 Progressive
Single Link 3 HD 1080 Interlaced

Single Link 7

Timecode Provider Configuration
6. Expand Timecode and select the arrow beside the Video Configuration field.

7. Configure the settings to match the input (composite/live source/AR Background) you want to read,
selecting VITC in the Format column, and then select Apply.
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8. Select Save and close the Media Profile editor.
To configure the Timecode Provider - Adrienne LTC:

1. Ensure the Ross Adrienne GPIO Plugin is enabled.
See Enabling the Voyager Plugins for instructions.

2. Double-click the Media Profile icon in the main tool bar to open the editor.

l’.;.—‘ Platforms » H VP Roles v

Media Profile Icon
3. Expand the Timecode Provider section and select the Override Project Settings checkbox.
4. From the Timecode Provider drop-down, select Adrienne LTC.

v Timecode Provider

Media Profile - Timecode Provider Settings

5. Expand Framerate and from the Framerate drop-down, select the framerate that corresponds to
your input signal.

6. Select Save and close the Media Profile editor.
The changes have been saved and the project now supports the Timecode.
For information on using the Timecode for event scheduling, see the Timecode - Scheduling Events
section.

To view the Timecode Provider:

e In the main toolbar, select Window > Virtual Production > Timecode Provider.

v (® Timecode Provid... = O

135001 :31'

Timecode Provider
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Configuring Frame Delays

You can configure a frame delay for timecode events triggered through RossTalk or through a blueprint.

To configure a frame delay:

1. Select Window > Voyager > General Settings.
General Settings X
General Setting guration
Remote A
Remot 5 ge Location: Browse

Remot Cache tion interval (minutes): 60

Apply Changes

General Settings

2. In the Timecode Settings section, enter the number of frames to delay, depending on your event
scheduling method and framerate:

¢ Global RossTalk Timecode Event Frame Delay Count — the delay is added to all scheduled
RossTalk Timecode events.

¢ Global Blueprint Timecode Event Frame Delay Count — the delay is added to all scheduled
blueprint Timecode events.

K This setting can be overwritten if No Delay is selected when scheduling a Timecode eventin a
blueprint node or if a Custom Frame Delay has been set in the node.

¢ Use Drop Frame for Timecode Event Delays — the delay is added when a fractional framerate
(e.g., 29.97 fps) is used, to preserve the overall time accuracy.

3. Then select Apply Changes and close the General Settings window.
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Setting up Timecode Events in the Level Blueprint

Once you have configured the Timecode Provider, you can then use the Timecode to schedule and
execute events in the level blueprint. You can schedule the execution of events based on a specified
hour, minute, second, and frame.

To access Voyager Timecode Blueprint nodes:

1. In Voyager, in the main toolbar, select the arrow beside the Blueprints icon and select Open Level
Blueprint.

= New Empty Blueprint Class...
/% Convert Selection to Blueprint Class

B5 Open Blueprint Class... >
1* Open Level Blueprint

® GameMode: GameModeBase

Open Level Blueprint

2. Inside the level blueprint, right-click and in the All Actions for this Blueprint field, begin typing
Voyager - Timecode to search for the Voyager - Timecode category.

All Actions for this Blueprint Context Sensitive

Voyager - Timecode Category

3. From the list, select one of the following blueprint nodes and continue with the instructions for that
node:

e Enqueue Voyager Timecode Event

Enqueue Voyager Timecode Array

Enqueue Voyager Timecode Key and Action

On Voyager Timecode Events

Clear Voyager Timecode Events

Get Voyager Timecode

Get Voyager Timecode Events Count
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Enqueue Voyager Timecode Event

Use the Enqueue Voyager Timecode Event node to schedule a Voyager timecode-based event. The
event will be triggered when the configured Timecode is reached.

To enqueue a Voyager Timecode event:

1. In the Enqueue Voyager Timecode Event node, right-click the Timecode Event pin and from the
menu, select Promote to Variable.

The Timecode Event variable node is added to the Enqueue Voyager Timecode Event node.

T Enqueue Voyager Timecode Event

Timecode Event Return Value

e ——— Frame Delay Type
Timecode Event 0

Or Custom Frame Delay | 0 |

Enqueue Voyager Timecode Event - Promote to Variable

2. Compile the blueprint and then select the Timecode Event variable node to access the Details
panel.

Enqgueue Voyager Timecode Event - Details
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3. Expand Timecode Event and then expand Key and Action.

Engueue Voyager Timecode Event - Timecode Event Details

4. In the Key section, in the Hours, Minutes, Seconds, and Frames (optional) fields, enter the time that
the event should occur.

5. In the Action section, enter the Id that represents the event and the Value of the actor associated
with the event.

For example, if the event is a camera switch, then the Id can be any number you want and the Value
would be the number representing the specific camera that will be impacted by the event.

6. From the Frame Delay Type drop-down, select one of the following options:
e No Delay — the event will occur immediately when the signal is received from the event node.

e General Settings Delay — the event will occur following the frame delay set in the General
Settings dialog, when the signal is received from the event node.

e Custom Delay — the event will occur following the frame delay set in the Custom Frame Delay
field in this node, when the signal is received from the event node.

7. Add an input node (e.g., RossTalk GPI or Lucid Exec) and connect the execution pin to the Input pin
of the Enqueue Voyager Timecode Event node.

When Voyager receives the signal from the input node, it will enqueue the event.

"I Lucid Exec o 7 Enqueue Voyager Timecode Event .

B / » C
Timecode Event Return Value

Frame Delay Type
No

Timecode Event 1

O Custom Frame Delay [ 0]

Enqueue Voyager Timecode Event - From Lucid Exec Node
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8. Add the Event BeginPlay node to the input node.

"I Lucid Exec o T Enqueue Voyager Timecode Event

™ Event BeginPla » »
_— / /
» Var Name Exec1 [P Timecode Event Return Value

| En
Frame Delay Type

©» Custom Frame Delay [0]

Enqueue Voyager Timecode Event - Add Event Begin Play Node
9. Select Save and then Compile.

The event is put into the queue of scheduled events.
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Enqueue Voyager Timecode Event Array

Use the Enqueue Voyager Timecode Array node to add multiple new Voyager timecode-based events
to the queue of scheduled events. The events will be triggered when the configured Timecodes are
reached.

To enqueue a Voyager Timecode Event Array:

1. In the Enqueue Voyager Timecode Event Array node, right-click the Timecode Event pin and from
the menu, select Promote to Variable.

The Timecode Event variable node is added to the Enqueue Voyager Timecode Event node.

T Engueue Voyager Timecode Event Arrair

Timecode Event 1

Clear Queue Return Value O»
Timecode Event

Frame Delay Type

O» Custom Frame Delay | 0 |

Enqueue Voyager Timecode Event Array - Promote to Variable

2. Select the Clear Queue checkbox to ensure that the current queue is completely clear before
scheduling further timecode events.

3. Compile the blueprint.

4. Select the Timecode Event variable node to access the Details panel.

- Details

Default

Mone

0 Array element ® T

Enqgueue Voyager Timecode Event Array - Details
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5. Expand the Default Value section and select the + icon beside Array element to add as many Array
elements as you have Timecode events.

Default Value

Tim: Event 0

Enqgueue Voyager Timecode Event Array - Add Array Elements
6. Expand each Index and then expand each Key and Action section and do the following:

e In the Key section, in the Hours, Minutes, Seconds, and Frames (optional) fields, enter the time
that the event should occur.

e In the Action section, enter the Id that represents the event and the Value of the actor associated
with the event.
Default Value
Tim ent 0 3 Array elements @ ﬁ

2 members

2 members

2 members

Enqueue Voyager Timecode Event Array - Event 1 Details

For example, if the event is a camera switch, then the Id can be any number you want and the Value
would be the number representing the specific camera that will be impacted by the event.

7. From the Frame Delay Type drop-down, select one of the following options:
¢ No Delay — the event will occur immediately when the signal is received from the event node.

¢ General Settings Delay — the event will occur following the frame delay set in the General
Settings dialog, when the signal is received from the event node.

e Custom Delay — the event will occur following the frame delay set in the Custom Frame Delay
field in this node, when the signal is received from the event node.
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8. Add an input node (e.g., RossTalk GPI or Lucid Exec) and connect the execution pin to the Input pin
of the Enqueue Voyager Timecode Event Array node.

When Voyager receives the signal from the input node, it will enqueue the events.

"I Lucid Exec 7 Enqueue Voyager Timecode Event Array .

/— .
Var Name )

Clear Queue Return Value Or

Timecode Event

T ———

- Frame Delay Type
Timecode Event 0 y P

Or Custom Frame Delay |

Enqgueue Voyager Timecode Event Array - From Lucid Exec Node

9. Add the Event BeginPlay to the input node.

"B Lucid Exec L Enqueue Voyager Timecode Event Array .

> Event BeginPlay /
Var Name xEC

Clear Queue Return Value O»

Timecode Event

Timecode Event 0

v Custom Frame Delay | 0 |

EEnqueue Voyager Timecode Event Array - Add Event Begin Play Node
10.Select Save and then Compile.

The events are put into the queue of scheduled events.
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Enqueue Voyager Timecode Key and Action

Use the Enqueue Voyager Timecode Key and Action node to add a new Voyager timecode-based
event to the queue that includes a separate Timecode Event Key and Action.

Specify the timecode and Action separately from each other.

To enqueue Voyager Timecode Key and Action:

1. In the Enqueue Voyager Timecode Key and Action node, right-click the Timecode pin and from the
menu, select Promote to Variable.

The Timecode variable node is added to the Enqueue Voyager Timecode Key and Action node.

J Enqueue Voyager Timecode Key and Action

Timecode 0
Timecode Return Value
Action

Frame Delay Type
Nov D

O Custom Frame Delay [0

Enqueue Voyager Timecode Key and Action - Promote Timecode to Variable
2. Select Compile.
The Details panel opens
. Details
Q,

Variable

Default Value

Tim

Enqueue Voyager Timecode Key and Action - Details
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3. Select the Timecode node and in the Details panel, expand Timecode, and in the Hours, Minutes,
Seconds, and Frames (optional) fields, enter the time that the event should occur.

Default Value

Frames

Enqueue Voyager Timecode Key and Action - Timecode Details

4. Right-click the Action pin, and from the menu, select Promote to Variable.

e Enqueue Voyager Timecode Key and Action
Timecode 0

Timecode Return Value
S S——

Action 0 Action

Frame Delay Type
No

O» Custom Frame Delay | 0

Enqueue Voyager Timecode Key and Action - Promote Action to Variable
5. Select Compile.

6. Select the Action node and in the Details panel, expand the Action section and enter the Id that
represents the event and the Value of the actor associated with the event.

For example, if the event is a camera switch, then the Id can be any number you want and the Value
would be the humber representing the specific camera that will be impacted by the event.

Default Value

Enqueue Voyager Timecode Key and Action - Action Details
7. From the Frame Delay Type drop-down, select one of the following options:
e No Delay — the event will occur immediately when the signal is received from the event node.

¢ General Settings Delay — the event will occur following the frame delay set in the General
Settings dialog, when the signal is received from the event node.

e Custom Delay — the event will occur following the frame delay set in the Custom Frame Delay
field in this node, when the signal is received from the event node.
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8. Add an input node (e.g., RossTalk GPI or Lucid Exec) and connect the execution pin to the Exec input
pin of the Enqueue Voyager Timecode Key and Action node.

When Voyager receives the signal from the input node, it will enqueue the event.

"I Lucid Exec

T Enqueue Voyager Timecode Key and Action

Var Name

Timecode Return Value
Eni

Action

Frame Delay Type
= Mo

Action 0

¢ Custom Frame Delay

Enqueue Voyager Timecode Key and Action - From Lucid Exec Node

9. Add the Event BeginPlay node to the input node.

"B Lucid Exec °

I Engueue Voyager Timecode Key and Action

» Event BeginPla
< 3 d / Var Name xe Timecode
»

[Enqueue nt . " Timecode 0

Return Value

Action

Frame Delay Type
!

—_——

Action 0

O» Custom Frame Delay

Enqueue Voyager Timecode Key and Action - Add Event Begin Play Node

10.Select Save and then Compile.
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On Voyager Timecode Event

Use the On Voyager Timecode Event node to execute an event that has been scheduled using one of
the Voyager Timecode Event nodes or through RossTalk.

See Setting up Timecode Events in the Level Blueprint for instructions on accessing Voyager - Timecode
nodes.

To execute an event with the On Voyager Timecode Event node:

1. Add the On Voyager Timecode Event node to the blueprint and then add the Event BeginPlay node
to initialize it.

<> Event BeginPlay “BB on Voyager Timecode Event o

»p — P
On Timecode [
Source
Timecode
First Action

All Actions

On Voyager Timecode Event

2. Left-click and drag off the On Timecode pin and from the Executable Actions list, select the event
that you want to execute.

3. In the On Voyager Timecode Event node, right-click on the First Action pin and from the menu,
select Split Struct Pin.

4. Drag out from the First Action Id pin and in the Actions taking a(n) Integer list, in the Search field,
enter equal and select the Equal operator node.

& Event BeginPlay . On Voyager Timecode Event o
Context Sensitive

On Timecode Utilities
i Operators
source
Timecode

First Action Id O»

First Action Value

All Actions

On Voyager Timecode Event - Select Equal Operator
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5. In the Equal operator node, in the pin field, enter the Action Id number of the event you want to
trigger.

& Event BeginPlay "Bl on Voyager Timecode Event e

P — b
On Timecode
Source
Timecode
First Action Id @
First Action Value O»

All Actions

On Voyager Timecode Event - Enter Action Id

6. Drag out from the On Timecode pin and in the Executable Actions list, in the Search field, enter
branch and select the Branch node.

€ Event BeginPlay "Il on Voyager Timecode Event o

i d / Executable actions Context Sensitive
On Timecod

Timecode
First Action id

First Action Value

All Actions

On Voyager Timecode Event - Add Branch Node
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The Branch Node is added to the blueprint.

¢> Event BeginPlay "I On Voyager Timecode Event e E Branch .

»—» LT »
On Timecode [P Condition

Source

Timecode
First Action Id @
First Action Value O

All Actions

On Voyager Timecode Event - Branch Node Added

7. Continue with the next section to execute a camera switch.
To execute a camera switch using the On Voyager Timecode Event node:

1. After completing the above instructions for executing an event, from the Outliner, left-click and drag
the Voyager Operator actor into the blueprint.

2. Drag out from the Voyager Operator node and in the Actions taking a(n) Voyager Operator Actor
Object Reference list, enter set active tracker index and select the Set Active Tracker Index
node.

) Voyager

) B Context Sensitive
ct Reference

= otiv S T
gq-. VoyagerOperator EE RIS
Voyager
Tracking

Vi |Set Active Tracker|[ile53

On Voyager Timecode Event - Add Set Tracker Index Node
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3. The Set Active Tracker Index node is added to the blueprint.

! g‘. VoyagerOperator

"B On Voyager Timecode Event o

€ Event BeginPlay

» G

» -'/ :II Branch T Set Active Tracker Index

On Timecode [ -...,.____“ A

» True [ :
Source
Condition
Timecode Target Return Value
First Action Id @ v An Index ||_|

First Action Value O»

All Actions

On Voyager Timecode Event - Set Active Tracker Index Node Added
4. Make the following connections:

e Connect the First Action Value pin on the On Voyager Timecode Event to the An Index pin on the
Set Active Tracker Index node.

e Connect the Output pin on the Equal Operator node to the Condition pin on the Branch node.

e Connect the True output pin on the Branch node to the Exec pin.

B On Voyager Timecode Event o [ Branch
€ Event BeginPlay

/-- » (D) »
» /
on Tim » L Conditio e T Set Active Tracker Index

B Target Return Value

@ An Index
ue @

All Actions

On Voyager Timecode Event - Connect Set Active Tracker Index Node
5. Select Save and then Compile.

The On Voyager Timecode Event node will now set the active tracker index (the number of the
camera) when the Action Id used to schedule the event matches the value in the Equal operator
node.
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Clear Voyager Timecode Events
Use this option to clear the list of pending timecode-based events that are scheduled.

To clear Voyager Timecode Events:

1. Add the Clear Voyager Timecode Events node to the blueprint.

2. Add an input node (e.g., RossTalk GPI or Lucid Exec) and connect the execution pin to the Exec input
pin of the Clear Voyager Timecode Events node.

3. Add the Event BeginPlay node to the input node.

"B Lucid Exec o

JF Clear Voyager Timecode Events

» G
< Event BeginPlay = »
Var Name |_| xec 1 B ==
»

Clear Voyager Timecode Events
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Get Voyager Timecode

Use the Get Voyager Timecode node to return the current Timecode value of the system.
To use the Get Voyager Timecode node:

1. In the Get Voyager Timecode node, right-click Return Value and select Split Struct Pin.

"7 Get Voyager Timecode .

Return Value Hours O
Return Value Minutes O
Return Value Seconds O
Return Value Frames (O»

Return Value Drop Frame Format

Get Voyager Timecode - Split Struct Pin

2. Add an input node (e.g., RossTalk GPI or Lucid Exec) to trigger the Get Voyager Timecode node and
connect the execution pin to the Input pin of the Get Voyager Timecode node.

"Il On RossTalk GPI Event

D p “F Get Voyager Timecode
Condition OnGPI p =— P
Mateh Number o Return Value Hours Or
O GPI As Number [ 2] Source Return Value Minutes O
GPI As Text |:| Return Value Seconds O

Return Value Frames O

Return Value Drop Frame Format

Get Voyager Timecode - Add Input Node
3. Add the Event BeginPlay node to the input node.

"I On RossTalk GPI Event " F Get Voyager Timecode

&> Event BeginPlay / » b / B
» Condition OonGPI Return Value Hours O»

GPI Struct Return Value Minutes O»

O GPIAS Number [ 2| Source Return Value Seconds O»

GPI As Text | | Return Value Frames Or

Return Value Drop Frame Format

Get Voyager Timecode - Add Event Begin Play

4. Drag out from any of the Return Value pins of the Get Voyager Timecode node and from the
Actions taking a(n) Integer list, select what you want to do with the returned value.

5. Connect the Exec output pin of the Get Voyager Timecode node to the Exec input pin of the action
node selected in Step 4.
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6. Select Save.

When the event is executed, the selected return value is retrieved.

300 - Timecode Voyager User Guide (v7.1)



Get Voyager Timecode Events Count

Use the Get Voyager Timecode Events Count node to return the total number of pending events that
are currently scheduled in queue.

To use the Get Voyager Timecode Events Count node:

1. Add an input node (e.g., On RossTalk GPI Event, or Lucid Exec) to the Get Voyager Timecode Events
Count node.

"B Lucid Exec

» =) J Get Voyager Timecode Events Count
<> Event BeginPlay ) i
Y . .
» 3 .

Return Value

Get Voyager Timecode Events Count Node
2. Add the Event BeginPlay node to the input node.

3. Connect the execution pin of the event node to the Exec input pin of the Get Voyager Timecode
Events Count node.

4. Drag out from the Return Value pin of the Get Voyager Timecode Events Count node, and from the
Actions taking a(n) Integer list, select an action node.

5. Connect the Exec Output pin of the Get Voyager Timecode Events Count node to the Exec Input
pin of the action node selected in Step 3.

6. Select Compile and Save.
If the action event is activated before the events are enqueued, the return value will be zero.

If the action event is activated after events are enqueued, the number of available events is
returned.
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Scheduling Timecode Events Using a RossTalk Command

Timecode events can be scheduled using a custom RossTalk command.

To receive this command, the RossTalk Plugin needs to be enabled. In Voyager, the RossTalk Plugin is
enabled by default.

The syntax for the command is as follows:

TC hh:mm:ss:ff aa:vv

Parameter Description

hh Hours

mm Minutes

ss Seconds

ff Frame Number
aa Custom Action ID
bb Custom Action VA

You can configure a frame delay for timecode events triggered through RossTalk. See Configuring Frame
Delays for further information.
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Voyager and Lucid Studio

Lucid Studio is a studio operator control software developed by Ross Video. Studio operators should
never need to go into the Unreal Editor to adjust elements in the virtual set. Instead, Lucid Studio
communicates with an Unreal Engine plugin that parses all the objects in the scene, and interfaces the
objects to its user interface.

The Lucid Studio Plugin is the interface between Lucid Studio and Voyager. When running Lucid Studio
with the Voyager renderer, you need to set up communication between Lucid Studio and Voyager.

See Configuring the Lucid Studio Plugin for configuration instructions.

Lucid Studio Interface

What is Interfaced?

Currently Lucid Studio interfaces the following actors:
e Static Mesh Actors
e Lights

» Point Lights

> Spot Lights

» Directional Lights
e Skeletal Mesh Actors
e Cameras

» Camera Actors

» Cinema Camera Actors
e Sequences and Matinees

e Floating Text
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What can be controlled through Lucid Studio?

These are the basic properties that can be controlled through Lucid Studio:
e Position

e Scale

e Rotation

e Visibility

Foreground/Background (in external compositing only)
e Material
» Lucid Studio can add video/textures from the UI to any static mesh object.

» Lucid Studio can also change materials to other materials found in the scene.

Light color and intensity

e Text

Can Lucid Studio Interface Blueprints?

Lucid Studio can select and interact with (move, rotate, scale, show/hide, etc.) blueprint actors through
its Position panel, but not with the blueprint coding. If a mesh is a component of a blueprint, Lucid
Studio will not interface it. However, if you make the mesh a child of a Static Mesh Actor, Lucid Studio will
be able to control it.

Lucid Studio can also interface with blueprints through the Logic panel. This requires that you select a
Lucid Studio node in the blueprint and make it part of the Exec flow. In Lucid Studio, you will use the
Renderer Logic function block to access the Voyager blueprint.

Naming convention

When you create an actor blueprint in Voyager that you want to control with Lucid Studio, you need to
preface the name of the blueprint with "BP_", e.g., BP_Lucid StudioActor. This will ensure that Lucid
Studio will see the blueprint. Once you place the actor in the scene, you can change the name in the
Details tab, if you like. Lucid Studio will continue to see it as long as the source blueprint uses the
correct naming convention.

For further information on using a Voyager blueprint with Lucid Studio, see the Lucid Studio User Guide
( Lucid Studio > Logic > Renderer.)
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BP_FreeRoaming_Camera

This actor is used to switch from the tracked Voyager Camera to another camera that will not use
tracking data. This allows you to use Lucid Studio to trigger a trackless move like flying away from the
talent in front of the green screen. If you created your project using either the VS Template or the
AR+VS Template, there will already be a BP_FreeRoaming_Camera actor.

To switch from a tracked camera to a trackless camera:

1. In the Outliner, select the BP_FreeRoaming_Cam and double-click Edit BP_FreeRoamingCam to
open the blueprint.

2. In the Event Graph, right-click in the blueprint and in the Search field, type Trackless.

If you don't get any results, deselect the Context Sensitive checkbox.

3. From the results, select the Set Trackless Camera node.

4. In the Set Trackless Camera node:

Connect the Target pin to the Operator node.
Connect the Trackless Camera pin to the Free Roaming Voyager Camera.

In the Blend Time field, enter a value to set the transition time from the tracked camera to the
untracked camera.

From the Blend Func drop-down, select the easing/smoothing method for the transition.

Use the Blend Exp field to enter a value to modify the Blend Function.

For more information about the Blend Time and Blend Func settings, see the Unreal Engine
documentation.

Select the Lock Outgoing checkbox to ensure that the transition goes to the targeted Trackless
camera without resetting.

OR

Leave the Lock Outgoing checkbox unchecked to have the focus returned to the tracked camera
before switching to the targeted Trackless camera.
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Template Links

Template links allow you to manage which Voyager actors, materials, sequences and levels can be
accessed and modified in Lucid Studio or Voyager Trackless Studio. Only those items which are

published will be available to the other applications. You can also designate whether or not actors are
moveable, can be used as media targets, or can have their functions published and specify to which part
of an actor you can apply media.

If there are items in your project that already have tags assigned to them from a previous version, you
can add the items along with their tags.

The items are ordered alphabetically and grouped by level and identified by their ID Name and Type.

You can check that all the items in the list still exist in the project using the Validate Items button.
To open the Template Links window:

e In Voyager, select Window > Voyager > Template Links.

The Template Links manager opens.

Template Links ® m|

Add Remove Add All Add Legacy Items Validate Items
e Media Target

Edit

Edit

Edit racker tudio Com

Edit ' Pl

Edit rac Pl

Edit I Re

Edit I Re

Template Links Manager
See the following topics for more information:
Adding and Removing Items
Validating Items
Tagging Items

Targeting Selected Material Textures
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Adding and Removing Items

Use the buttons along the top of the Template Links Manager to add and remove items.
To add items to the Template Links manager:

1. From the Filter drop-down, select the type of item to add.
The options are:
e Actors
¢ Materials
¢ Sequences
e Levels
2. Then select Add.
Alternatively, you can right-click anywhere in the list and from the context menu, select Add Item.

The Add Actor (or Add Material or Add Sequences or Add Levels) window opens, depending on
which item type you selected in the first step.

Add Actor

Use Selected
Copy

o}

Iterm Label «

Selected Actor:

Cancel

Template Links - Add Item
3. Scroll through the list to find the item you want to add.

Alternatively, in the Search field, enter the name of the item you want to add.
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4. Select the itemin the list and then select Add.
The selected item is added to the list (in alphabetical order) and automatically tagged to be
published.

To remove an item(s):

1. From the Filter drop-down, select the type of item to remove.
2. Then select an item in the list and select Remove.

Alternatively, you can right-click an item in the list and from the context menu, select Remove Item or
right-click in the list and select Remove All.

If you select Remove All, a confirmation dialog opens.

Warning

Template Links - Remove All Confirmation Dialog
3. Select Yes to continue or No if you change your mind.

The selected item or items are removed from the list.
To add Legacy items:

1. From the Filter drop-down, select Actors.
2. Then select Add Legacy Items.
The project will be scanned and any items that have valid Voyager metadata will be found.

A confirmation dialog opens, warning that this approach may add a large number of items.

Warning

Template Links - Add Legacy Items Confirmation Dialog
3. Select Yes to continue or No if you change your mind.

The legacy items are added to the list with the existing tags selected.
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To add all items of the Actor or Sequence type:

1. From the Filter drop-down, select Actors or Sequences.
2. Then select Add All.
Alternatively, you can right-click anywhere in the list and from the context menu, select Add All.

A confirmation dialog opens which tells you how many items of that type were found. This could be a
very large number of items, depending on the project. Be sure you want to add all of them before
confirming.

Warning

Template Links - Add All Confirmation Dialog
3. Then select Yes to add all the items or No if you change your mind.

Items in the project of that type are added to the list (in alphabetical order) and automatically
tagged to be published.
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Validating Items

You can check that all the items in the Template Links Manager still exist in the project and remove any
that don't.

To validate items:

1. Select the Validate Items tab.

A confirmation dialog opens indicating that only those items in the currently loaded level will be
validated.

Warning

Template Links - Validation Limitation Dialog
2. Select Yes to continue.

A confirmation dialog opens indicating how many items are no longer valid (they do not exist in the
project), or indicating that all the items are valid (they still exist in the project).

Warning

d loaded levels.

led levels are valid.

OK

Template Links - All Items Valid Dialog

3. Select Yes to remove any invalid items from the list.
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Tagging Items

You can tag individual items in the Template Links Manager to control which items are used by other
applications and how they can be used.

To tag items:

1. From the Publish Type Filter drop-down, select the type of item to tag.

2. In the list, do any of the following:

Select the checkbox in the Publish column to make it available to Lucid Studio and Voyager
Trackless Studio or clear the checkbox to just keep a list of items in the project, but not have them
available to Lucid Studio.

Select the checkbox in the Moveable column to make it possible to change the item's position from
Lucid Studio (applies to the Actor type item only).

Select the checkbox in the Media Target column to make it possible to add movies or stills to the
item from Lucid Studio or Voyager Trackless (applies to the Actor type item only).

Select the Edit button in the Media Target column to open the Manage Media Targets window,
where you can select to which texture materials you want to allow media to be applied.

Select the checkbox in the Functions column to make it possible to call the functions associated
with that item from Lucid Studio (applies to the Actor type item only).

X You can select multiple items at once and select a tag to tag them all.
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Targeting Selected Material Textures

Each actor can have multiple material textures, for example a video monitor could have material textures
for the frame and for the screen itself. You can select only those material textures that you want to be
able to apply media to, in the Manage Media Targets window.

It is helpful to give meaningful names to material slots in the actor mesh. See Naming Material Slots for
more information.

To specify to which material texture(s) media can be applied:

1. In the Media Target column, select the Edit button for the target you want to edit.

The Manage Media Targets window opens.

ge Media Targets

Target £ ted Material Textures

Apply Cancel

Manage Media Targets

2. In the Manage Media Targets window, select the Target Selected Material Textures Only
checkbox.

3. Then select the Publish checkbox for the Texture Parameters to which media can be applied and
deselect the Publish checkbox for the Texture Parameters to which you don't want media applied.

4. Select Apply save your selection and close the window.
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Naming Material Slots

Depending on how an actor is configured, it can have one or more material slots and any of those slots
can be selected as a media target. The name assigned to each slot when the actor was designed may
not identify each part of the mesh. It is good practice to rename the material slots so that you can easily
identify the part of the mesh you want to use as a media target.

To change a material slot name:

1. In the Outliner, select the actor you want to use as a media target.

2. In the Details tab, scroll down to the Static Mesh section and double-click the Static Mesh icon to
open the editor.

3. In the editor, in the Material Slots section, in the Slot Name fields, enter names that will make it
evident which part of the actor is being referenced.

 Details

F v Slot Name

Static Mesh Editor - Rename Material Slots
4. Select Save and close the editor.
5. In the Template Links Manager, add the actor you've just edited, if it is not already listed.
6. In the Media Target column, select the actor and then select the Edit button.

The new material slot names will appear in the Material Slot list.

X If there is a material slot that does not contain a texture parameter, it will not appear in the list,
as it cannot be used as a media target.

7. In the Manage Media Targets window, select the Target Selected Material Textures Only
checkbox.

8. Then select the material slot/texture parameter that you want to use as a media target.

9. Select Apply to save your selection and close the Manage Media Targets window.
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Adding a Free-Roaming Camera

You can add an additional Voyager camera (called the BP_FreeRoaming_Cam) that will not use tracking
data. This allows you to switch between cameras, to get different viewpoints while you’re working on
your project. This is not something you can use while you're on air.

To add a Free Roaming Camera (optional):

e In the Place Actors tab, begin typing "op" and from the results, drag the BP_FreeRoaming_Cam
actor into the level.
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Adding a Texture to Part of an Object
(Legacy Method)

When you assign a video or texture to a static mesh object in your Voyager project, it's important to
understand how to name the material slots, so that the texture is displayed correctly.

X This section applies to the legacy method previously used to make material slots visible in Lucid

Studio. To learn about renaming material slots and accessing them through the Template Links
Manager, see Targeting Selected Material Textures.

e If the selected Voyager object does not have any material slots with the “TG_" prefix, the video or
texture will be applied to the entire mesh (all the material slots).

e If the selected Voyager object has one or more material slots with the “"TG_" prefix on its name, the
video or texture will be applied only to the material slot(s) that have that prefix.
To name the material slots of an object:
1. In your Voyager project, in the Outliner, select the object to which you want to add a video or
texture.

2. In the Details tab, in the Static Mesh section, double-click on the Static Mesh icon to open the
object for editing.

Static Mesh Material Editor

3. In the Details tab, in the Material Slots section, check the names of the material slots.

By default, the material names do not have the TG_ prefix.
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If you applied an image to the static mesh object now, it would be applied to the entire mesh, as
shown below:

Image Applied to Entire Static Mesh

4. Edit the name of the material slot to which you want to apply the source video or texture, to include
the prefix TG

Static Mesh Material Editor - With Prefix Added
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5. In the example, the video or texture should only be applied to the screen area, not the frame, so you
would change the Element 1 Slot Name to TG_Screen_Image_Material.

Subsequently, when a video or texture is applied to the target static mesh, it will appear only on the
part of the mesh called TG_Screen_Image_Material, as shown below:

UNREAL

ENGINE

Image Applied to Selected Part of Mesh
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Virtual Set Considerations

e Many visual issues only show up when looking through a tracked camera.

There are ways to simulate a tracked camera through Lucid Studio, but mostly issues of flickering
occur when the tracked camera is slightly defocused. This can be tested by running the level with
camera tracking from Lucid Track applied.

e MipMaps are important.

When using big textures for detailed background, use mipmaps. Backgrounds in virtual sets are
typically a bit out of focus. If mipmaps are not used, details start to flicker.

An example of textures that should be mipmapped are the images on the screens in the background:
- . - . _

Using MipMaps

e Avoid thin lines.

When the camera is slightly out of focus, thin lines can start to flicker because the temporal AA will
blur the pixels completely with neighboring colors. Ensure that lines are not too thin from the
expected camera positions.

e Avoid high emissive values.
High emissive values cause flickering when zoomed out.

The best way to test for flickering is to run the level in the studio. Alternatively, you can test it by
running it through Lucid Studio.

When running with a tracked camera, we will run a defocus filter as a post-process effect. In practice,
cameras will send data slightly defocused. This defocus may cause flickering on screen if there are thin
lines or high emissive values. If you cannot run it through a real TV studio test, run it through Lucid
Studio.

e Screens must be seperate meshes from the TV. Screens should also be children of the TV.

This is because Lucid Studio can only apply textures and materials on whole meshes.
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Screen UVs must match the mesh so that an arbitrary video in 16:9 format can be shown without
being zoomed in or cut.

When creating screen meshes make sure that the UVs do not crop out arbitrary textures. Do not
create screen objects so that they only work with a single texture or video.

Screens prefer emissive values and should probably be nonlit.

Video on lit screens can be pretty performance intensive, and if the screen is already emissive, it does
not need lights on it.

In external composite virtual sets, do not set a translucent material on a foreground object, as this
will allow the background to be seen through the object.

In external compositing, you can configure an object or objects in your scene to always appear in the
foreground or always appear in the background. If you have objects configured to always appear in
the foreground, you need to also configure the background objects.

To enable an object to appear in the foreground:

N oo o b~ W

In the Outliner, select the object you want to appear in the foreground.
In the Search Details field, type custom to get to the Rendering tab.
- Details

& Cube

&5 Cube (Instance)

CustomDepth Settings - External Compositing

In the Rendering tab, select the Render Custom Depth checkbox.

In the CustomDepth Stencil Value field, enter 2.

Then select the object(s) you want to remain in the background.

This time, in the CustomDepth Stencil Value field for each object, enter 1.
Save your project.

A custom depth value of 1 will automatically be applied to all objects without a custom depth value
set, when you select Update Project Settings.
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Retaining Existing Material Properties

Lucid Studio can change textures on materials and retain their properties, provided the material is built
with special parameters.

When Lucid Studio sets a texture or video to a mesh, it typically applies a basic surface material with
base color, nothing more, so you need to ensure that the existing material properties are retained.

To retain existing material properties:
1. In the Content Browser > Materials, double-click the material whose properties you want to retain,
to open the Material Editor.
You'll see the blueprint with all of the material parameters in the Material Editor.
2. In the Material Editor, add two TextureSampleParameter2D textures with the following names:
e UX Texture A
e UX_Texture_B
3. In the Parameter Defaults tab, make sure both parameters are set to the default texture.
4. Add a ScalarParameter with the name:
UX_Interpolation_A

5. Add a LinearInterpolate (Lerp) node so that Lucid Studio can transition smoothly between two
textures over time.

It will look like this:

" UX_Texture_A

O Nomal
O Tangent
O World Position Offset

Or Ambient Occlusion

" UXInterpolation_A

O Pixel Depth Offset
P P

Setting up Lucid Studio Materials
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Augmented Reality Set Considerations

This section provides some design recommendations to consider when creating an augmented reality
set as they apply to either internal or external compositing.

Internal Compositing

e You can use the VoyagerComposite_ShadowCatcher to display the reflections of virtual objects in
the scene (for example, if they are sitting on a shiny surface), by setting the Specular Intensity to a
value greater than 0 up to a maximum of 1. However, if you are also using the
VoyagerComposite_Reflection actor to reflect a part of the live background feed, you need to
position the Reflection actor so that it is not reflecting on the ShadowCatcher.

Otherwise, both the reflections of the virtual objects and the reflection of the live background feed
could be displayed on the real world floor.

You can adjust the Ambient Lighting Intensity to make the ShadowCatcher shadow better match
the other shadows in the scene. A value of 0 disregards all the ambient lighting when generating
shadows, while anything above 0 factors in ambient lighting, with 1 using all the ambient lighting.

For more information on Ambient Lighting and Ambient Occlusion, see the Unreal Engine
documentation.

# Details x

7 VoyagerComposite_ShadowCatcher_1

“ VoyagerComposite_ShadowCatcher_1 (Self)

VoyagerComposite _ShadowCatcher
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e In internal compositing, when you add a new object to the scene, you need to configure the
CustomDepth Stencil Value to differentiate the new object from the rest of the scene.

To configure the CustomDepth Stencil Value:

1. In the Outliner, select the new object you've added.

2. In the Search Details field, type custom to get to the Rendering tab.

Default

CustomDepth Settings - Internal Compositing
3. In the Rendering tab, select the Render CustomDepth Pass checkbox.
4. In the CustomDepth Stencil Value field, enter 1.

This allows the object to be rendered on top of the composite plane and considered in the screen
space reflection.

A custom depth value of 1 will automatically be applied to all objects without a custom depth value
set, when you select Update Project Settings.

5. Save your project.

* If you have a complex AR set with many virtual objects, many of which are hidden behind other
objects, it is recommended that you turn on the Allow Occlusion with Custom Depth option.

To turn on the Allow Occlusion with Custom Depth option:

1. In the main toolbar, double-click the Voyager icon to open the Voyager Operator editor.
2. In the Project Settings section, select the Allow Occlusion with Custom Depth checkbox.
Project Settings

Ignore Mi om Dept

sion with Custom Depth

Voyager Operator - Allow Occlusion with Custom Depth

3. Select Save and close the editor.
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Appendix A: Enabling a Port Number in
the Firewall

When using Voyager, you need to make sure that any port you are using to listen to connections has
been enabled in the Windows Defender Firewall.

To enable a port number:

1. In the Control Panel, select Windows Defender Firewall.

4 EB : Control Panel > All Control Panel ltems

Adjust your computer’s settings View by:  Smallicons =
&1 Administrative Tools @ AutoPlay E} Backup and Restore (Windows 7) %e‘ BitLocker Drive Encryption
K& Color Management [E Credential Manager ) Date and Time Fﬂ Default Programs
.‘.; Device Manager Ma Devices and Printers I.@.' Ease of Access Center = File Explorer Options
£ File History A Fonts &= Indexing Options Internet Options
E Keyboard B Mail (Microsoft Outlook) @ Mouse :‘: Metwork and Sharing Center
|5 Phone and Modem E Power Options 2 Programs and Features & Recovery
0 ] Region ™5 RemoteApp and Desktop Connections \od Security and Maintenance iy Sound
@ Speech Recognition & Storage Spaces SupportAssist 05 Recovery @ Sync Center
4 S\-‘:tsm ﬂ Taskbar and Mavigation [ Troubleshocting H2, User Accounts
I @ Windows Defender Firewall I @ Windows Mehbility Center [ Work Folders

Control Panel

2. Select Advanced settings > Inbound Rules.

® < All Control Panel ltems > Windows Defender Firewall

+

Help protect your PC with Windows Defender Firewall

Control Panel Home

Windows Defender Firewall can help prevent hackers or malicicus software from gaining access to your PC
Allow an app or feature through the Internet or a network.
through Windows Defender

Firewsall o For your security, some settings are managed by your system administrator.
) Change notification settings

E; Turn Windows Defender
Firewall on or off

) Restore defaults
IE; Advanced settings I

Troubleshoot my network

Update your Firewall settings

Windows Defender Firewall is not using the

. & Use recommended settings
recommended settings to protect your computer,

What are the recommended settings?

Advanced Settings
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3. In the Actions pane, select New Rule.

Io..": Defender Firewa h Adva m} has
File Action View Help
|| 2E =]
er Firewall wit]) JETRTTS N AT Actions
i nbound Rules Name Gre* || Inbound Rules -
Outbound Rules .
¥4 Connection Security Rules CommVault_Process_1_cvd
“__"l Menitoring CommVault_Process_1_cviwd T Filter by Profile »
dashboard .
dashboard ST Filter by State »
EpicGameslauncher ST Filter by Group »
EpicGamesLauncher View »
EpicGamesLauncher
= | Refresh
EpicGamesLauncher = res
() EpicWebHelper = Export List.
® EpicWebHelper Help
Lucid
® Lucid
) Lucid
Lucid
Lucid
Lucid
Lucid
Lucid
Lucid MOS Service
Lucid MOS Service v
< 3|« >
Actions - New Rule
4. In the Rule Type window, select Port and select Next.
Rule Type
Select the type of firewall ule to create.
Steps:
I“ Rule Type I What type of rule would you like to create?
@ Protocol and Ports
@ Action ) Program
@ Profile Rule that controls connections for a program.
@ Name ® Port
Rule that controls connections for a TCP or UDP port.
) Predefined:
@Firewall AP1.dIl.-80200
Rule that controls connections for a Windows experience.
() Custom
Custom rule.
| < Back Next > Cancel

Rule Type - Port
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5. In the Protocol and Ports window, select TCP.
|
Protocol and Ports
Specify the protocols and ports ta which this rule applies.

Steps:
» Rule Type Does this rule apply to TCP or UDP7
I.‘ Protocol and Ports I I @ TCP I
@ Action ) UDP
@ Profile
@ MName

Dioes this rule apply to all local ports or specific local ports?

() Al local ports
(® Specific local ports:

.

Example: 80, 443, 5000-5010

Protocol and Ports

< Back

Next = Cancel

6. Then select Specific local ports, enter the port number you will be using and select Next.

7. In the Action window, select Allow the connection and select Next again.

Action

Specify the action to be taken when a connection matches the conditions specified in the rule.
Steps:

» Rule Type

What action should be taken when a connection matches the specified conditions?

» Protocol and Ports
(@ Allow the connection

J B3I This includes connections that are protected with [Psec as well as those are not.
o Profile

N (O Allow the connection if it is secure
§ Name

This includes only connections that have been authenticated by using IPsec. Connections
will be secured using the settings in IPsec properties and rules in the Connection Security

Rule node.

(O) Block the connection

< Back

Allow the Connection

Next > Cancel

8. In the Name window, enter a name for the new rule (e. g. Voyager Web API, Lucid Studio, RossTalk,

etc.) and select Finish.

9. Close all the windows.
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Appendix B: Testing SLP

If SLP is enabled in the Voyager Tracker and port 427 is also enabled, but services on your network
aren't being discovered, you can test it using the following procedure.

To test SLP:

1. In the Windows Search field, start typing "command prompt".
2. In the results, select the Command Prompt application.

The Command Prompt window opens.

SLP - Command Prompt Window

3. Type "cd c:\program files\openslp".

4. Then type "slptool findsrvs service:myserv.x
and company name..

replacing "myserv.x" with the computer host name

A list of connected services is returned.

5. Then type "slptool findattrs service:myserv.x://myhost.com", replacing "myserv.x://myhost.com"
with one of the services that was returned in the previous step.

A list of attributes for the service is returned. Attributes include IP addresses, port number, version
number and engine number of the service.

6. If you don't get any results, contact Technical Support for assistance.
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Appendix C: Troubleshooting

System

The following system setting changes are recommended for optimal performance.

CPU

Hyper threading should be disabled in the BIOS setup,

nVidia

Use the recommended nVidia Driver version: Studio WHQL Quadro Certified 552.74.

Make sure you don’t have nVidia Geforce Experience installed. Uninstall it if installed.

Power management mode should be set to Prefer maximum performance.

To set power management mode:

1. Right-click on the desktop and select nVidia Control Panel.
2. In 3D Settings > Manage 3D Settings, select the Global Settings tab.

3. In the Settings box, scroll down to Power management mode and select Prefer maximum
performance.

Microsoft Windows

The Windows 10 March 2023 Update (KB5023696) for version 22H2 may affect the performance of the
engine.

Virtualization Based Security may affect the performance of the engine.

Disable Virtualization Based Security if it is enabled.

To disable Virtualization Based Security:
1. In the Windows Security application, go to Device Security > Core Isolation > Core Isolation
Details and set Memory integrity to Off.

2. In the Registry Editor, go to
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\DeviceGuard and set
EnableVirtualizationBasedSecurity to 0.

If this setting doesn't exist, then Virtualized Based Security is not enabled.
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Unreal Engine

In Voyager, change the following settings:

Anti-Aliasing Method
Temporal Anti-Aliasing (TAA) should be used.

X Do not use Temporal Super-Resolution (TSR).

To select Temporal Anti-Aliasing (TAA):

e In the Edit menu, go to Project Settings > Engine > Rendering > Default Settings and from the
Anti-Aliasing Method drop-down, select Temporal Anti-Aliasing (TAA).

Lumen

Lumen (Unreal 5) has an important performance impact. Disable Lumen if it is not strictly required.

When Lumen is enabled, Generate Mesh Distance Fields is also enabled. If you disable Lumen, you

should also disable Generate Mesh Distance Fields.

To disable Lumen:

e In the Edit menu, go to Project Settings > Engine > Rendering > Global Illumination and from the
Dynamic Global Illumination Method drop-down, select None.

e In the Edit menu, go to Project Settings > Engine > Rendering > Reflections and from the
Reflection Method drop-down, select None if you don't need reflections at all, or select Screen Space
if Unreal Engine's 4 screen space reflections are good enough.

Nanite

Nanite (Unreal Engine 5) should generally be enabled wherever possible. Any static mesh that has it
enabled will typically render faster and take up less memory and disk space..

To enable Nanite:

e Go to Edit > Project Settings > Engine > Rendering and select the Nanite checkbox.

e When importing new meshes, select Build > Build Nanite (it might be disabled by default for some
meshes).

e For previously imported meshes, enable Nanite (right-click > Nanite > Nanite).
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Ray Tracing
Ray Tracing is expensive; enable it only if strictly necessary.
To disable Ray Tracing:

e Go to Edit > Project Settings > Engine > Rendering > Hardware Ray Tracing and deselect the
following checkboxes:

* Support Hardware Ray Tracing
= Ray Traced Shadows
= Ray Traced Skylight

Virtual Shadow Maps
Virtual Shadow Maps is Beta and may have some performance impact. Use Shadow Maps instead.
To use Shadow Maps:

¢ Go to Edit > Project Settings > Engine > Rendering > Shadows > Shadow Map Method and from
the drop-down, select Shadow Maps.

DirectX 12
Enable DirectX 12 only if you need Ray Tracing or another Unreal Engine 5 feature that requires it.
To disable DirectX 12:

e Go to Edit > Project Settings > Platforms > Windows > Targeted RHIs and from the Default RHI
drop-down, select DirectX 11.
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VLED Checklist

nVidia
For best performance, change the Global Presets and Vertical Sync settings as follows:

To change the Global Presets setting:

1. Right-click on the desktop and select nVidia Control Panel.
2. In 3D Settings > Manage 3D Settings, select the Global Settings tab.

3. In the Settings box, scroll down to Global Presets and from the drop-down, select Workstation App
Dynamic Streaming.

To change the Vertical Sync setting:

1. Right-click on the desktop and select nVidia Control Panel.
2. In 3D Settings > Manage 3D Settings, select the Global Settings tab.

3. In the Settings box, scroll down to Vertical Sync and from the drop-down, select Use the 3D
Application setting.

Network

Check that the network adapter and hardware meet the following requirements:

e Verify the Windows network adapter is running at 10 Gbps.

e Verify you have the proper 10 GB network hardware:
— 10 GB Ethernet Adapter (Voyager’s Intel x550 network adapters support 10 GB.)
— Factory 10 GB Ethernet cable, ideally not DIY cables.
— Use a good 10 GB Ethernet switch.

Disable Power Management for the Network Adapter.
To disable Power Management:

1. In Network and Internet settings > Advanced network settings > Change adapter options,
double-click your connection to open the Wi-Fi Status window.

2. Select Properties and in the Networking tab, select Configure.

3. Select the Power Management tab and clear the Allow the computer to turn off this device to save
power checkbox.

Switchboard

Fullscreen Optimization

Disable Fullscreen Optimization on every Unreal Engine node executable.
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To disable fullscreen optimization:

1. Go to C:\Program Files\Voyager\Engine\Binaries\.
2. Right-click on the UnrealEditor.exe file and select Properties.

3. In the Compatibility tab, in the Settings section, select the Disable fullscreen optimizations
checkbox.

OR

Launch Voyager Switchboard and in the Voyager Switchboard editor, select the Fix ExeFlags button.

Internet Connection

An Internet connection may be required for first execution.
The first time you run Voyager Switchboard on a system, it may download some dependencies. Make
sure the machine is connected to the Internet before running Voyager Switchboard the first time.

Project Path and Name

Verify the project path and file name.
e Project name should not include spaces or special characters.
e Project name should have a maximum of 20 characters long.

e Project path should not have spaces or special characters.

Switchboard Listener

Voyager Switchboard Listener needs to be running on all the nodes.

Licenses

Verify your machines have the required licenses. Voyager Switchboard may open and close abruptly with
no prompt if no valid licenses are found. Check the log files to verify that you have the appropriate
licenses.

e The nDisplay Master node requires the Voyager nDisplay Controller License.

e The nDisplay nodes require the Voyager nDisplay Node License.

Projects

Run your projects on all machines - to check for any problems running.

With nDisplay if any Node times out (popup waiting for answer) then the whole nDisplay cluster will quit.
You will just see a Black Screen
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nVidia Sync

Use CAT-5 (or higher) factory manufactured Ethernet cables for connecting the nVidia Quadro Sync
cards.

Do not use Ethernet hubs or switches to branch or extend the signal, as it is not TCP/IP.

nDisplay Synchronization Policy should be set to nVidia Sync.

To set nDisplay Synchronization Policy to nVidia Sync:

1. In your Voyager project, in the Outliner, select the VLEDStage actor to open the editor.
2. In the editor, in Details > Configuration > Cluster, expand Render Sync Policy.
3. From the Type drop-down, select Nvidia.

OR

In Voyager Switchboard Launcher, select Settings > Settings > nDisplay and from the Render Sync
Policy drop-down, select Nvidia.

KX The setting chosen in Voyager Switchboard Launcher over-rides the setting chosen in the Voyager

project.

VLED + Set Extension

Make sure the Primary Device Used as Set Extension checkbox is selected in Voyager Switchboard.

In the Voyager Switchboard Launcher, in Settings > nDisplay Settings, select the Primary Device
Used As Set Extension checkbox.

Set Extension AR Voyager machine will be black if this checkbox is not selected.
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Contact Us

Contact our friendly and professional support representatives for the following:
e Name and address of your local dealer

e Product information and pricing

e Technical support

e Upcoming trade show information

Telephone: +1-844-652-0645 (North America)
Technical +800 3540 3545 (International)
Support After Hours Emergency: +1 613 ¢ 349 « 0006
Email: techsupport@rossvideo.com
Telephone: +1 613 ¢ 652 ¢ 4886
General Fax: +1 613 ¢ 652 ¢ 4425
Information Email: solutions@rossvideo.com
Website: http://www.rossvideo.com

Visit Us

Visit our website for:

e Company information and news

e Related products and full product lines

e Online catalog

e Testimonials

Ross Video®
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